Release Notes for Modo15.2v2

Copyright © 2022 The Foundry Visionmongers Ltd.

Release Date

20 January 2022

System Requirements

* macOS 10.15.x, 11.x, and 12.x

Note: Testing on Apple Silicon (M1) processors is in progress and this statement will be
updated when completed.

* Windows 10 and Windows 11 (64-bit only)
* Linux 64-bit operating system (CentOS/RHEL 7.6+ and Ubuntu 20.04)

* Intel processor(s), Core i3 or higher

* 10 GB available hard disk space (for a full Modo and content installation)
* At least 2 GB RAM

+ Display with 1920 x 1080 pixel resolution

* Internet connection for product activation and online videos access

* The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU
memory and drivers that support OpenGL 4.4 or higher.

* AMD Al Denoiser requires a minimum of 4 GB of GPU memory.
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Note: This information is our best recommendation for the average user. Requirements
vary by usage, and individual users may have different requirements from those listed here.

+ 2.5+ GHz quad-core processor

+ 250+ GB disk space available for caching and temporary files, SSD is preferable
* 16 GB RAM with additional virtual memory*

+ Display with 1920 x 1080 pixel resolution

* An NVIDIA or AMD graphics card with the latest drivers

+ 2+ GB of graphics memory

* OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

* NVIDIA: 461.09 or later
* AMD: 8.982.8.1 or later

Note: We recommend downloading the latest driver version from the NVIDIA or AMD
websites

The configurations listed below are those that Foundry have tested with Modo 15.2. Due to the
constantly changing nature and wide variety of computer hardware available in the market, Foundry
is unable to officially certify hardware. The list below can be used as a recommendation and does not
guarantee that it meets your particular needs.

Note: Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.2
because of office access limitations due to COVID-19, but has been used to test previous
releases.
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If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

Tested Workstation Hardware

Apple * Macbook Pro (Retina, 16-inch, 2019)
* Macbook Pro (Retina, 15-inch, 2018)
« Macbook Pro (Retina, 15-inch, 2017)

CPU « AMD Ryzen Threadripper*
* Intel i7-7700k*
* Intel i7-8700
* Intel i9-9900k
* Intel Core i7 10750H

Tested GPU Hardware
AMD Prosumer Graphics Cards * Radeon Vega RX*

AMD Enterprise Graphics Cards * Radeon Pro 5300M
* Radeon Pro WX 8200
* Radeon Pro WX 7100
« Radeon Pro 560X
* Radeon Pro W6600

NVIDIA Prosumer Graphics Cards * GeForce GTX 1070 Ti (Linux)
* GeForce 1080*
* GeForce 2070 Super

NVIDIA Enterprise Graphics Cards * Quadro T1000
* Quadro M4000*

New Features

There are no new features in this maintenance release.
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Feature Enhancements
* ID 491597 - Windows only: Modo's Solidworks import plug-in now supports the 2022 version.

Bug Fixes
+ ID 439952 - Image antialiasing caused incorrect directional blurriness in renders.
* ID 449580 - UV Rotation of a Normal Map altered normal information at render time.
* ID 453866 - Modo occasionally hung on exit.
* ID 463695 - Calling emd_dumpapi did not work as expected.
+ ID 469215 - MeshFusion: Using Dynamic Separation mode in certain scenes caused Modo to crash.
* ID 474401 - Edge Chamfer did not always work as expected.

* ID 474618 - Executing Pack UV with Orient Mode set to Horizontal or Vertical tilted some UV
islands incorrectly.

* ID 479713 - The Pen Tool occasionally dragged stacked vertices on polylines incorrectly.

+ ID 480288 - The tooltip for the Dimensions Tool > Orient to Selection option contained a typo.
+ ID 482110 - MeshFusion: Enabling Sharp Bezier Corners affected MatCap unexpectedly.

* ID 484252 - Curve Falloff had the Radius channel listed twice.

* ID 484478 - Procedural assembly selection was not retained.

* ID 484648 - Channel hauling for channel relationships did not work as expected.

* ID 484891 - Changing distance channels using the Shift key modifier did not work as expected when
the distance value was near zero.

* ID 486851 - Saving Omnihaul defaults for MeshFusion source meshes caused Modo to crash.

+ ID 487449 - Windows only: Material Full and Basic modes in certain scenes did not work as
expected in the Advanced viewport.

* ID 487769 - Certain scripts calling Ix.objectColorMapping.ToLinear caused a memory leak.
* ID 488337 - Expanding and collapsing an assembly multiple times caused Modo to crash.

+ ID 489303 - Changing assembly type between Material and Mesh randomly positioned the Mesh
node.

+ ID 490647 - Using deformers in certain scenes caused Modo to crash on exit.

+ ID 490650 - Markup was not saved as expected in presets.

* ID 490759 - The thumbnails for standalone legacy presets appeared washed out.
* ID 490965 - The inputs for assembly presets were reordered incorrectly on load.

* ID 490969 - Dialog pop-ups in scripts attached to assembly presets were not suppressed as
expected.
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* ID 491776 - Certain Presets did not contain Assembly in the option name as expected.

* ID 492246 - UV Boundary selection did not work as expected after smooth subdivision.

* ID 492260 - Omnihaul defaults were missing for the Primitive Slice and Primitive Generator tools.
+ ID 492261 - Primitive shapes were not update as expected when their sides property was edited.

* ID 492265 - The label names for the Depth settings on the Primitive Slice and Primitive Generator
tools were too long.

* ID 492271 - Bevels took a long time to process on meshes created from frozen curves.
* ID 492274 - Opening certain scenes containing Edge Chamfer mesh ops caused Modo to crash.

* ID 492324 - Adding a Lattice Effector through the Mesh Ops stack tied the effector to the wrong
mesh.

+ ID 492376 - Windows only: modo_cl didn't recognize the registry set Content path, preventing some
kits loading correctly.

* ID 492464 - Saving an empty assembly preset caused Modo to crash.

+ ID 492501 - The Slice Effector flipped polygons when the profile curve start/end point was on the
concave part of a curve.

* ID 492529 - Primitive Slice Boolean modes did not always work in symmetry mode.

* ID 492541 - macOS only: Curve Booleans did not always work as expected.

* ID 492609 - The Python 2 and Python 3 unittest modules were missing in Modo 15 builds.
+ ID 492759 - Standalone presets were saved alongside preset packages.

* ID 492761 - Primitive Slice: Editing the Bank Angle with a Boolean operation did not always work as
expected.

* ID 492826 - Executing Vertex > Join Averaged in certain scenes caused Modo to crash.
+ ID 493103 - Light Materials were not saved with Light Presets.
+ ID 493108 - Direction constraints were not saved correctly when saving an assembly preset.

+ ID 493112 - Certain relationships and constraints were not saved correctly to General Assembly
Presets.

+ ID 493117 - Rigging and dynamics items were not filtered out when changing to mesh and material
assemblies.

* ID 493245 - Dictionary ordering in Python 3 caused Ix.command to fail if an item argument was
passed anywhere except at the start of the argument list.

* ID 493369 - Attempting to load an existing mesh op into a new scene caused Modo to crash.

+ ID 493409 - Saving assembly preset with Create Assembly with Preset disabled did not work as
expected.

+ ID 493504 - The Selection Set Array node displayed an incorrect normal array when using per
element polygon selection sets.

* ID 493560 - Lights and Camera presets were saved with an unnecessary item mask.

+ ID 493581 - Material presets were saved with an extra shader tree group layer.
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+ ID 493635 - The Legacy Package Setup preference for Presets did not have a tooltip.
* ID 493683 - Edge Chamfer: Mitre did not work as expected in certain scenes.
* ID 493908 - Modo used CPU resources unexpectedly while idle.

* ID 494259 - Executing a Vertex Join in certain Pen Slice Boolean modes caused the end of the
polyline to break.

* ID 494284 - Edge Chamfer mesh ops occasionally caused runtime errors.
* ID 494371 - Applying an Edge Chamfer to a dense cylinder mesh caused Modo to crash.

* ID 494539 - Enabling the Averaged Polygon Normal setting when smoothing occasionally caused
Modo to crash.

+ ID 494607 - Array operators did not always work as expected with procedural curves.

* ID 494654 - Windows 11 only: Modo did not perform consistently between Windows 10 and
Windows 11.

* ID 494710 - Pen Slice: Subtract mode did not work with a custom work plane.

* ID 494801 - Transforming normal maps with a matrix caused normals to render incorrectly.

+ ID 494872 - Executing Pack UVs in certain scenes caused Modo to crash.

+ ID 495018 - Using the Curve Slice tool in certain scenes caused Modo to crash.

* ID 495098 - Custom mesh ops created using an older SDK didn't load as expected.

* ID 495331 - Loading certain scenes caused Modo to crash on exit.

* ID 495453 - Certain schematic items could not be deleted from within the Schematic viewport.
+ ID 495455 - The Save Preset dialog file type field could not be changed once set.

* ID 495458 - Drop scripts did not run as expected when assembly presets were loaded using the .IxI
and .Ipkg formats.

* ID 495579 - Applying linear falloff to multiple meshes with polygon selections caused Modo to crash.
* ID 495604 - Scrubbing the timeline in the Advanced viewport caused Modo to crash.

* ID 496102 - Mesh ops could not access polygon tags in the MeshOp stack.

* ID 496778 - Selecting the thumbnail grid in the Preset Browser occasionally caused Modo to crash.
+ ID 496791 - Saving Material Presets from the workspace did not include all nodes as expected.

+ ID 496802 - Saving and importing a preset also created additional Render and Camera items.

* ID 496884 - Certain existing presets did not work as expected.

+ ID 497073 - Preset Browser: Dragging a preset over its parent folder caused Modo to crash.

+ ID 485642 - Connecting a Fusion item into a Merge Meshes node caused Modo to crash on exit.

* ID 486378 - Chamfer Edit did not always update end polygons correctly.

* ID 492180 - Adjusting the Segment property on Edge Chamfer mesh op caused Modo to crash.

* ID 498025 - Creating a Topological Transfer Morph caused Modo to crash.

* ID 498048 - Saving an assembly containing a mesh always selected the mesh on import.

+ ID 498187 - Saving mesh presets with Octane overrides did not work as expected.
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Release Notes for Modo15.2v2 |

* ID 498356 - Editing shared markup for profile presets caused Modo to crash.
+ ID 498358 - Adding a script and then moving a tool handle caused Modo to crash.

* ID 498443 - Presets: Disabling Create Assembly with Preset did not save Octane nodes as
expected.

* ID 498445 - Moving nodes to other sub-assemblies in new presets using the right-click menu did not
work as expected.

* ID 498465 - Selection Aliases did not work as expected.

Known Issues

This section covers known issues and gives workarounds for them, where appropriate.

+ ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.
* ID 395357 - Deformer Caching doesn't work.

* ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by
copying actions.

Note: As a workaround, manually edit the tags on the broken actions by selecting them in
the Groups tab, then save and reload the scene.

+ ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual
layout of nodes on import.

Note: As a workaround, you can save assemblies from the Schematic viewport.

+ ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked
displacement map to show quilting effects and other render artifacts.

+ ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.
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* ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

+ ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot
pixels) in some cases.

Note: As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

+ ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than
expected.

Note: As a workaround, any machine that has more than 32 cores, performance will be
better if you limit rendering to half the number of cores you have.

* ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1
or earlier now show on the render item instead.

+ ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the
mesh has transform channels.

Note: As a workaround, freeze the transforms in the mesh properties.

* ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a
scene with a mesh that has a position channel crashes Modo at launch.

Note: As a workaround, use System > Reset Preferences to reset to defaults or
move/remove the default scene.

* ID 289290 (49514) - macOS only: Running modo_cl before running the Ul Modo application breaks
code signing.

RELEASE NOTES



Release Notes for Modo15.2v2 |

Note: As a workaround, start the Ul version of Modo once, before running modo_cl on any
system where you later intend to use the Ul version.

* ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

Note: As a workaround, use File > Import.

+ ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks
file twice in one Modo session. This only affects import using the kit, not direct imports (File >
Import).

Note: As a workaround, before importing a SolidWorks file for the second time, exit and
restart Modo.

+ ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and
procedural shatter items.

+ ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't
export instances, unless the original mesh is also exported.

Note: To resolve this, set the .fbx preference to Export Selection and use the Export As...
option.

+ ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect
of a fix where the largest allowable image size (64k x 64k) was always used when color correction
was enabled.

+ ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer
masking can be very slow.

+ ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

Note: Use different fur length drivers, such as hair guides or vector vertex maps.
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+ ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause
undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

Note: To avoid this, plug in the tablet before application start up or restart.

+ ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the
combination of a click-drag in a tree view (for example, when toggling the visibility of two successive
items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices,
including laptop trackpads and the Magic Mouse.

Note: As a workaround, change to a 3-button mouse (recommended to fully access all of
Modo's features).

+ ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped
onto a Primary, the drop menu does not contain the Trim Boolean options.

Note: As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role &
Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding
Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied
with either of those methods, all subsequent Drag & Drop options will be supported.

+ ID 408278 (60027) - Linear Falloff snaps to object size.

Note: As a workaround, use the right mouse button for an interactive initial linear handle.

* ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

RELEASE NOTES
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+ ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image
sequence number on worker machines.

Note: As a workaround, use File > Consolidate Scene, then render the scene using a
shared network folder (Preferences option under Rendering > Network Rendering).

* |ID 226337 (36986) - Workers render hidden meshes. Since mesh hide state is not stored in the scene,

when that scene is transferred to the workers, the state is lost. The master respects the hidden state,
however.

Note: As a workaround, if the intent is to avoid rendering, toggle the visibility for the item

or render or open System > Preferences > Rendering and disable Use Network Render
Nodes.

* ID 226336 (25636) - Frame passes are not supported.
+ ID 220955 (30318) - Network Rendering doesn’'t support Realflow particles.

+ Several bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not
implemented to support baking. Changes to Modo in the 10-series apparently broke what was
working for some artists, so the functionality has been disabled.

Note: As a workaround, Modo 10 implemented the ability to Network Bake using Bake
Items and an external render controller. For more information, please see the SDK Wiki.

+ ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.
+ ID 221393 (50642) - Nodal shading does not support UDIMs.

+ ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image
map.

RELEASE NOTES .
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Note: You can save and reload the image to force the update.

+ ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

Note: To avosuch issues, delete the cache before closing Modo, or export the particles to
.csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the
Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

* If a high poly mesh is not visible, the Preview baking output will be incorrect.

Note: As a workaround, reset Preview to fix the baking.

* ID 242621 - Assembly Preset Aliases will crash when certain connections are made to them. If any of
these are inside of an assembly alias that is collapsed, then you can potentially hit a crash:
Replicator Item, Array Operator modifier, Falloff Operator, Selection Operator, Particle Operator,
Any kind of texture (images, procedural textures, etc)

Note: As a workaround, expand the assembly alias, as evaluating those types of items for a
non-aliased assembly should still work fine.

* ID 484639 - Select by Material Tag doesn't work with Mesh Op stack.
+ ID 388978 - Paving does not work when a Guide curve runs through a paving hole

+ ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops
list.
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+ ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation
tool.

Note: As a workaround, manually edit the duplicate's Select By Previous Operation Mesh
Ops.

* ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh
Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge
Meshes Ops List as a source.

Note: As a workaround, remove the unwanted additional Merge Mesh Sources (regardless
of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge
Meshes source.

+ ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal
option doesn't work when using a Bezier with zero-length tangents.

Note: As a workaround, rotate the polygons to point toward the +Z before extruding or
make sure there are no zero-length tangents.

+ ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL.
This is a limitation of the feature and will not be fixed.

Note: You can use Preview or RayGL to visualize the variations from rigging.

* ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after
attempting to revert a reference override.

Note: As a workaround, first close and reopen the scene before attempting to revert the
reference.

* ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the
original references may not persist.
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Note: As a workaround, limit scenes with shading to one level of reference.

+ ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to
crash.

+ ID 483457 - Disabling or hiding connections using the H keyboard shortcut causes the stack order to
behave erratically.

+ ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

* ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint
chain.

* ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

Note: As a workaround, click in the top window of the Script Editor, use the main menus, or
change to another application, then switch back to Modo.

* ID 385991 (57874) - Custom Materials that define their own smoothing properties (such as the Skin
material), no longer smooth the mesh correctly.

+ ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip
browser) fails.

Note: To work around this issue, in the Clip Browser, choose a single image instead of the
group, and then change to the image group using the Texture Layer's Properties tab.

* ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the
masking layer onto the displacement layer.

* ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
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* ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

+ ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced
viewport when used with bump maps and shadows.

* ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn't resize back
the popover correctly.

+ ID 388937 - macOS only: Ul form field highlights can appear gray.
* ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

Note: As a workaround, click the alt key.

+ ID 288714 (43162) (Windows only) -Setting a custom text size affects Modo's text drawing.

Note: As a workaround, go to the compatibility settings by right-clicking the Modo shortcut
or executable, and turn off font-scaling for the application.

+ ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.
* ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

* ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some
macOS/AMD configurations.

Note: As a workaround, upgrade Mac OS to 10.13.

* ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering >
Color Management, and using the system color picker caused colors to darken with each use of the
color picker.

Note: This is due to an OS X issue, which requires the color profile in both the monitor
settings and color picker to be set to sSRGB IEC61966-2.1.

* ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.
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Note: If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it
above or below other images in the list.

* ID 478549 - Saving Alpha with Playblast is just completely white.
* ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

+ ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

Note: As a workaround, use Preview.

+ ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the
Advanced viewport.

Note: As a workaround, enable and then disable the visibility of the Shader Tree textures.

+ ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

Note: As a workaround, avoid transparency when modeling or doing work where
wireframes are needed. Alternatively, use the Default viewport.

+ ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view
(palette or separate window).

Note: As a workaround, use Game Navigation mode only in docked 3D views (views that are
part of a Layout).

* ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-
series graphics card. This is due to a driver and should be fixed by a AMD in a future driver release.

+ ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode
and the width is less than the height.

* ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.
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Note: To avoid this, make sure that the projection camera has a film width-to-height ratio
that matches the main render camera.

* RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any
unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in
the Shader Tree.

* Windows only: Using Raptr can cause GL driver crashes in Modo.

+ ID 218386 - VR is now supported on Linux, but has only been tested and verified working using
SteamVR on Ubuntu 18.04.

RELEASE NOTES .
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Copyright © 2022 The Foundry Visionmongers Ltd.

Release Date

09 November 2021

System Requirements

* macOS 10.14.x, 10.15.x, and 11.x

Note: Testing on Apple Silicon (M1) processors, macOS 12 (Monterey), and Windows 11 is in
progress and this statement will be updated when completed.

* Windows 10 (64-bit only)
* Linux 64-bit operating system (CentOS/RHEL 7.6+)

* Intel processor(s), Core i3 or higher

* 10 GB available hard disk space (for a full Modo and content installation)
* At least 2 GB RAM

+ Display with 1920 x 1080 pixel resolution

* Internet connection for product activation and online videos access

* The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of GPU
memory and drivers that support OpenGL 4.4 or higher.

* AMD Al Denoiser requires a minimum of 4 GB of GPU memory.
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Note: This information is our best recommendation for the average user. Requirements
vary by usage, and individual users may have different requirements from those listed here.

+ 2.5+ GHz quad-core processor

+ 250+ GB disk space available for caching and temporary files, SSD is preferable
* 16 GB RAM with additional virtual memory*

+ Display with 1920 x 1080 pixel resolution

* An NVIDIA or AMD graphics card with the latest drivers

+ 2+ GB of graphics memory

* OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

* NVIDIA: 461.09 or later
* AMD: 8.982.8.1 or later

Note: We recommend downloading the latest driver version from the NVIDIA or AMD
websites

The configurations listed below are those that Foundry have tested with Modo 15.2. Due to the
constantly changing nature and wide variety of computer hardware available in the market, Foundry
is unable to officially certify hardware. The list below can be used as a recommendation and does not
guarantee that it meets your particular needs.

Note: Hardware marked with * (asterisk) was unavailable for QA testing for Modo 15.2
because of office access limitations due to COVID-19, but has been used to test previous
releases.
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If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

Tested Workstation Hardware

Apple * Macbook Pro (Retina, 16-inch, 2019)
« Macbook Pro (Retina, 15-inch, 2018)
« Macbook Pro (Retina, 15-inch, 2017)

CPU « AMD Ryzen Threadripper*
* Intel i7-7700k*
* Intel i7-8700
* Intel i9-9900k
* Intel Core i7 10750H

Tested GPU Hardware
AMD Prosumer Graphics Cards * Radeon Vega RX*

AMD Enterprise Graphics Cards * Radeon Pro 5300M
* Radeon Pro WX 8200
* Radeon Pro WX 7100
« Radeon Pro 560X
* Radeon Pro W6600

NVIDIA Prosumer Graphics Cards * GeForce GTX 1070 Ti (Linux)
* GeForce 1080*
* GeForce 2070 Super

NVIDIA Enterprise Graphics Cards * Quadro T1000
* Quadro M4000*
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New Features

Modo's Preset system and Assemblies have long been a valuable workflow component. The new
Assembly Preset Workflow refines this further by simplifying the creation process and making presets
easier to share. Presets are now packaged, containing associated content like images within a Preset
Package. When you pass a preset to another artist, you can now be sure they have the supporting
content that they need.

The new Preset system automatically creates an assembly in your scene, more closely linking the
relationship between presets and assemblies. Assemblies no longer need to have every element
exposed in a schematic assembly. The Stack Nodes and Schematic now contain the elements needed
to do more of your work without leaving Schematic.

See Easily Share Presets with Assembly Presets for more information.

Curves are an essential component of modeling today. Primitive slice further elevates Modo’s curve
modeling capabilities by allowing users to slice primitive shapes into geometry and even produce
boolean effects with depth control when leveraging the procedural variant of the tool with the slice
effector.

See Creating Geometry on a Mesh Using Preset Shapes for more information.

Simple features can have a big impact on workflow. Edge Subdivide simply divides each selected edge
into multiple edges, making it easier to add vertices along an edge. This is tremendously useful for
quickly modifying and refining topology.

See Adding Additional Vertices to an Edge for more information.

In 15.0, Mesh Fusion workflow was completely reenvisioned. With 15.2 we've taken this further by
removing Fusion Selection Modes. Now you simply select the element you want to modify and we
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give you the info you need.

See MeshFusionfor more information.

Procedurally generating 2D designs on 3D surfaces is extremely valuable for designers. The geodesic
distance modifier can be leveraged to find the distance between two points and trace a path between
them on the surface. This enables generation of complex patterns that can drive exciting, procedural
modeling results.

See Create Intricate Patterns using Geodesic Distance Modifier for more information.

Control over vertex normals and vertex maps in general is a very important part of 3D in general and
specifically for real time renderers. The largest normals option is now a part of material smoothing
properties. The color tool and Set RGB node now have an option for Discontinuous values,
eliminating color blending across the boundary of a selection. Finally, a Set Vertex Normals MeshOp
has been added, further expanding what's possible in our procedural toolset.

See Using The Set Vertex Normals MeshOp to Adjust the Appearance of Your Mesh for more
information.

Modo's Order Of Operations system is extremely powerful. However, it can be difficult to understand
the order of MeshOps and SelectionOps in the schematic viewport. The MeshOp Stack node was
added in 15.1. In 15.2 we have added this ability for Selection Ops, better informing artists of how a
stack relates to a node graph.

See Organize Your Schematic Viewport using the Selection Stack for more information.

mPath is Foundry's powerful new hybrid pathtrace renderer. In 15.2 we've added Render booleans.
This makes it incredibly easy to create cross section cutaways for product and graphical
visualizations.

See Create Boolean Effects at Render Time using mPath for more information.
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With every release, we try to touch on existing features and workflows with meaningful refinements.
The Script Editor and Schematic viewports have received many improvements to make scripting and
navigation a more comfortable experience. Convert Instances to Replicas makes it easier to switch
between instancing and replicators.

Playblast Advanced Viewport Progressive node lets artists take advantage of progressive antialiasing
when creating viewport playblasts.

The PBR loader now automatically adds imported PBR textures into groups that already have the
correct polygon tags.

Feature Enhancements

+ ID 446539 - Importing or exporting an .obj file now replaces spaces in the file name with
underscores.

+ ID 487461 - PBR Loader now includes an option to match existing material groups.

* ID 486856 - Fusion Strip attributes now support OmniHaul.

+ ID 380301 - An option to forcibly set discontinuous values has been added to the Vertex Color tool.
* ID 469082 - Unsubdivide performance has been improved.

* ID 482192 - The Mirror tool now sets Invert Polygons by default.

+ ID 485609 - Weight Map Transfer performance has been improved.

+ ID 488500 - Boolean performance with co-planar faces has been improved.
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* ID 490991 - Edges to Curves now generates more stable indices for the curves.

+ ID 471177 - You can now drag presets to the parent folder in the Preset browser.

* ID 424839 - Set Vertex Map now includes a Largest option for material weighting and Largest
Normals option.

+ ID 477305 - The Set RGB mesh operation now supports discontinuous values.

* ID 454434 - mPath now supports render Booleans.

* ID 480320 - The way Command Regions / Rig Clay were using reference transforms has been
rewritten to improve stability and flipping of the rigs.

Bug Fixes

* ID 485940 - Launching Modo with no channel list in the Graph Editor caused the application to
crash.

* ID 486113 - Changing subdivision level during animation playback caused Modo to crash.

+ ID 481662 - Editing certain meshes driven by deformers caused Modo to crash.
* ID 486874 - Enabling Deferred Evaluation > Smoothing occasionally caused Modo to crash.

+ ID 484300 - macOS only: Opening a scene from Finder containing missing images caused Modo to
crash.

* ID 485867 - FBX meshes incorrectly exported Actors and Actions.
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+ ID 486073 - Undoing a mesh drag and drop to another scene occasionally caused Modo to crash.

* ID 487446 - The Normal option was missing from the PBR Loader preferences.
+ ID 487984 - Animated .usd files did not export the skin correctly unless exported in setup mode.
+ ID 490841 - Camera attributes were scaled incorrectly when exporting to the .usd format.

* ID 492782 - Animated .fbx files did not export the skin correctly unless exported in setup mode.

+ ID 485879 - MeshFusion occasionally crashed with preview running.
+ ID 485953 - MeshFusion was slower than expected with Deferred Updates enabled.

* ID 486906 - MeshFusion channels were not displayed in the same order in the Properties and
channel haul windows.

* ID 461646 - The Set Weight tool did not include tooltips.

* ID 463342 - Booleans were not creating a solmesh in some instances.

* ID 467026 - Edge Chamfer created undesirable UVs in some instances.

* ID 472943 - Undoing Linear Falloff occasionally caused Modo to crash.

* ID 478423 - Edge Chamfer produced uneven edges across edge loops.

* ID 479330 - Edge Chamfer occasionally produced invalpositions when moving geometry to the
origin.

+ ID 480154 - Edge Chamfer occasionally stopped working when Shape was set to Square.

* ID 480646 - Edge Chamfer occasionally produced asymmetrical results.

* ID 480942 - Edge Chamfer was performing slower than expected.

* ID 481419 - Boolean > Union All failed with some co-planar polygons.

* ID 482246 - Dimensions set to Orient To Selection would fail on triangulated meshes.

+ ID 482301 - Edge Chamfer gave undesirable results when Offset in Parallel was enabled, and
multiple loops were selected.

* ID 482909 - Edge Chamfer mitering removed polygons unexpectedly.

+ ID 483112 - Using push on symmetrical geometry occasionally pushed in the opposite direction.
* ID 483264 - Windows only: Curve Booleans occasionally caused Modo to become unresponsive.
* ID 483802 - Edge Chamfer concave patches occasionally produced undesirable results.

* ID 484592 - Element Move did not respect the rig option when components were selected.

+ ID 484789 - Edge Chamfer created the wrong end shape if a co-planar edge was connected.

* ID 485019 - Edge Chamfer creating incorrect rounding on some corners.

+ ID 485597 - Editing edge weights on irregular topology occasionally caused Modo to crash.
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* ID 485615 - Sync Index Order did not automatically attempt to match islands on the same mesh with
the same topology.

+ ID 485685 - Polygon Bevel Square Corner did not work as expected on scaled meshes.
* ID 485771 - Large chamfers occasionally caused polygons to disappear.

* ID 485939 - Using the direct modelling merge meshes command on a transformed procedural mesh
caused Modo to crash.

* ID 486785 - Canceling options in the Static Analysis viewport displayed an error.

+ ID 487013 - Loop Slice on a high number of segments occasionally caused Modo to crash.
* ID 487567 - Static Analysis Unused Deformers listed tool pipes incorrectly.

* ID 487961 - Deleting segments of a bezier curve occasionally caused Modo to crash.

* ID 468216 - Exporting a mesh from the Item List after creating or selecting its material item created
an empty .Ixp file.

+ ID 468221 - Canceling Replace Icon with Image File on a preset displayed an error message.

+ ID 471169 - Comments on presets were displayed against the incorrect preset.

* ID 483650 - Clicking Replace Icon with Image File for presets opened the scene unexpectedly.
+ ID 485937 - Adding certain presets occasionally caused Modo to crash.

+ ID 483711 - Changing layout after locking a preview could cause the Ul to become unresponsive.
* ID 490760 - macOS only: Preview did not update when changing material properties.
+ ID 492107 - Moving the camera when preview was locked caused Modo to crash.

* ID 226508 - Weights were not always updated as expected on procedural meshes.

* ID 456434 - Scene Cleanup > Unused Deformers did not remove unused mesh operations.
+ ID 480105 - The Vertex Bevel meshop did not support negative inset as expected.

* ID 485227 - Edges to Curves occasionally flipped the curve when re-evaluated.

* ID 485932 - Using bezier curves in Curve Offset By Mesh caused Modo to crash.

+ ID 486081 - Using Procedural Loop Slice on a curve caused Modo to crash.

* ID 486859 - Fixing a procedural using the Static Analysis floating vertices / one point polygons test
caused Modo to crash.

RELEASE NOTES
26



Release Notes for Modo15.2v1 |

* ID 412084 - Foreground image masks resulted in aliased edges.
* ID 473682 - mPath: Shadow catchers produced a noisy alpha channel.

* ID 481079 - mPath: Alpha was not considered for adaptive sampling when the beauty pass passed
the requirements.

* ID 482666 - mPath: Antialias settings were not respected for render outputs.

* ID 295273 - Schematic nodes could not be connected if they contained more than 256 channels.

* ID 448914 - The IK solver occasionally flipped when going in and out of setup mode.

Note: Any rigs hitting this issue need to recreate the solver for the fix to take effect.

* ID 484119 - Command Regions occasionally did not draw as expected.

* ID 487304 - MeshOp Stack nodes occasionally caused ghosted views on other layers to display
incorrectly.

* ID 471077 - Dragging an assembly into the schematic overview did not creates a new workspace as
expected.

+ ID 481318 - Lasso select in the Schematic viewport incorrectly selected nodes inside closed
Backdrop nodes.

* ID 484221 - Dragging an item to the Schematic viewport failed when an assembly was selected.
* ID 484362 - Items in sub-assemblies were not hidden when converting to an alias.

* ID 478911 - Pressing Shift+Enter in the Script Editor displayed an error.
+ ID 480108 - The alt gr modified keyboard shortcut did not work as expected in the Script Editor.
* ID 481626 - Certain non-unicode characters in item names caused failures running Python scripts.

* ID 483649 - TD SDK: Removing items in a loop occasionally caused Modo to crash.
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* ID 485949 - Python Ixifc.LogListener stopped Modo shutting down correctly.

* ID 473444 - Normal Maps propogated farther up the shader tree than expected.

* ID 483997 - Creating an Image Layer, such as Gradient Fill, did not place the layer correctly in the
shader tree.

+ ID 486005 - Scenes containing an Iridescence shader caused Modo to crash on exit.

+ ID 366868 - The Cylinder tool's controls contained incorrect tooltips.
+ ID 399079 - Mini gradients did not size correctly.

* ID 463770 - Undoing a mini-slider change with Allow Modifier Chording enabled caused Modo to
crash.

* ID 477408 - Right-click context menus occasionally showed incorrect options.

* ID 479155 - The Alt+Space pie menus Topology option did not work as expected.
* ID 479786 - The State column in the Graph Editor was missing.

+ ID 481008 - The cursor occasionally got stuck on the pan icon.

* ID 482407 - Form Command filters were incorrect when using the != operator.

* ID 482493 - The Channel Sets window had misaligned icons.

+ ID 482616 - Incorrect characters were displayed in the Split and Sew tooltip.

+ ID 486028 - Right-clicking in a different viewport after Lasso selecting occasionally displayed an
error.

+ ID 487026 - The Form Editor saved the form proficiency incorrectly.
+ ID 487165 - Choosing Group By Package in the Channels viewport caused Modo to crash.

+ ID 487447 - A divider set to proficiency Advanced in the form editor set multiple sub-sheets to Last
Instance.

* ID 404381 - UV Split occasionally failed to split all selected edges.

+ ID 460304 - Zero area triangles occasionally caused Pack UVs to fail.

* ID 462362 - Activating Channel Haul with multiple items selected occasionally caused Modo to crash.
* ID 474904 - Pack UVs did not align correctly when using vertical or horizontal modes.

* ID 483121 - Element move snapped incorrectly in the UV viewport.
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Known Issues

This section covers known issues and gives workarounds for them, where appropriate.

* ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.
* ID 395357 - Deformer Caching doesn't work.

+ ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by
copying actions.

Note: As a workaround, manually edit the tags on the broken actions by selecting them in
the Groups tab, then save and reload the scene.

+ ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual
layout of nodes on import.

Note: As a workaround, you can save assemblies from the Schematic viewport.

+ ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked
displacement map to show quilting effects and other render artifacts.

+ ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.

* ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

+ ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot
pixels) in some cases.

Note: As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.
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* ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than
expected.

Note: As a workaround, any machine that has more than 32 cores, performance will be
better if you limit rendering to half the number of cores you have.

+ ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1
or earlier now show on the render item instead.

+ ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the
mesh has transform channels.

Note: As a workaround, freeze the transforms in the mesh properties.

* ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a
scene with a mesh that has a position channel crashes Modo at launch.

Note: As a workaround, use System > Reset Preferences to reset to defaults or
move/remove the default scene.

+ ID 289290 (49514) - macOS only: Running modo_cl before running the Ul Modo application breaks
code signing.

Note: As a workaround, start the Ul version of Modo once, before running modo_cl on any
system where you later intend to use the Ul version.

+ ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.
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Note: As a workaround, use File > Import.

+ ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks
file twice in one Modo session. This only affects import using the kit, not direct imports (File >
Import).

Note: As a workaround, before importing a SolidWorks file for the second time, exit and
restart Modo.

+ ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and
procedural shatter items.

* ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't
export instances, unless the original mesh is also exported.

Note: To resolve this, set the .fbx preference to Export Selection and use the Export As...
option.

+ ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect
of a fix where the largest allowable image size (64k x 64k) was always used when color correction
was enabled.

* ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer
masking can be very slow.

+ ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

Note: Use different fur length drivers, such as hair guides or vector vertex maps.

+ ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause
undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

Note: To avoid this, plug in the tablet before application start up or restart.
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* ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the
combination of a click-drag in a tree view (for example, when toggling the visibility of two successive
items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices,
including laptop trackpads and the Magic Mouse.

Note: As a workaround, change to a 3-button mouse (recommended to fully access all of

Modo's features).

+ ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped
onto a Primary, the drop menu does not contain the Trim Boolean options.

Note: As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role &
Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding
Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied
with either of those methods, all subsequent Drag & Drop options will be supported.

+ ID 408278 (60027) - Linear Falloff snaps to object size.
Note: As a workaround, use the right mouse button for an interactive initial linear handle.

* ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

+ ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image
sequence number on worker machines.

Note: As a workaround, use File > Consolidate Scene, then render the scene using a
shared network folder (Preferences option under Rendering > Network Rendering).
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* ID 226337 (36986) - Workers render hidden meshes. Since mesh hide state is not stored in the scene,

when that scene is transferred to the workers, the state is lost. The master respects the hidden state,
however.

Note: As a workaround, if the intent is to avoid rendering, toggle the visibility for the item
or render or open System > Preferences > Rendering and disable Use Network Render
Nodes.

* ID 226336 (25636) - Frame passes are not supported.
* ID 220955 (30318) - Network Rendering doesn't support Realflow particles.

* Several bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not
implemented to support baking. Changes to Modo in the 10-series apparently broke what was
working for some artists, so the functionality has been disabled.

Note: As a workaround, Modo 10 implemented the ability to Network Bake using Bake
Items and an external render controller. For more information, please see the SDK Wiki.

+ ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.
+ ID 221393 (50642) - Nodal shading does not support UDIMs.

+ ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image
map.

Note: You can save and reload the image to force the update.

* ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.
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Note: To avosuch issues, delete the cache before closing Modo, or export the particles to
.csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the
Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

* If a high poly mesh is not visible, the Preview baking output will be incorrect.

Note: As a workaround, reset Preview to fix the baking.

* ID 242621 - Assembly Preset Aliases will crash when certain connections are made to them. If any of
these are inside of an assembly alias that is collapsed, then you can potentially hit a crash:
Replicator Item, Array Operator modifier, Falloff Operator, Selection Operator, Particle Operator,
Any kind of texture (images, procedural textures, etc)

Note: As a workaround, expand the assembly alias, as evaluating those types of items for a
non-aliased assembly should still work fine.

* ID 484639 - Select by Material Tag doesn't work with Mesh Op stack.
+ ID 388978 - Paving does not work when a Guide curve runs through a paving hole

+ ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops
list.

+ ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation
tool.

Note: As a workaround, manually edit the duplicate's Select By Previous Operation Mesh
Ops.
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* ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh
Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge
Meshes Ops List as a source.

Note: As a workaround, remove the unwanted additional Merge Mesh Sources (regardless
of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge
Meshes source.

* ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal
option doesn't work when using a Bezier with zero-length tangents.

Note: As a workaround, rotate the polygons to point toward the +Z before extruding or
make sure there are no zero-length tangents.

+ ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL.
This is a limitation of the feature and will not be fixed.

Note: You can use Preview or RayGL to visualize the variations from rigging.

+ ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after
attempting to revert a reference override.

Note: As a workaround, first close and reopen the scene before attempting to revert the
reference.

* ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the
original references may not persist.

Note: As a workaround, limit scenes with shading to one level of reference.

+ ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to
crash.
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+ ID 483457 - Disabling or hiding connections using the H keyboard shortcut causes the stack order to
behave erratically.

+ ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

+ ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint
chain.

* ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

Note: As a workaround, click in the top window of the Script Editor, use the main menus, or
change to another application, then switch back to Modo.

+ ID 385991 (57874) - Custom Materials that define their own smoothing properties (such as the Skin
material), no longer smooth the mesh correctly.

* ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip
browser) fails.

Note: To work around this issue, in the Clip Browser, choose a single image instead of the
group, and then change to the image group using the Texture Layer's Properties tab.

* ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the
masking layer onto the displacement layer.

* ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.
+ ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

+ ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced
viewport when used with bump maps and shadows.
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+ ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn't resize back
the popover correctly.

+ ID 388937 - macOS only: Ul form field highlights can appear gray.
+ ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

Note: As a workaround, click the alt key.

* ID 288714 (43162) (Windows only) -Setting a custom text size affects Modo's text drawing.

Note: As a workaround, go to the compatibility settings by right-clicking the Modo shortcut
or executable, and turn off font-scaling for the application.

+ ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

* ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

+ ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some
macOS/AMD configurations.

Note: As a workaround, upgrade Mac OS to 10.13.

+ ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering >
Color Management, and using the system color picker caused colors to darken with each use of the
color picker.

Note: This is due to an OS X issue, which requires the color profile in both the monitor
settings and color picker to be set to sSRGB IEC61966-2.1.

* ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

Note: If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it
above or below other images in the list.
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* ID 478549 - Saving Alpha with Playblast is just completely white.
* ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.
+ ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

Note: As a workaround, use Preview.

+ ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the
Advanced viewport.

Note: As a workaround, enable and then disable the visibility of the Shader Tree textures.

+ ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

Note: As a workaround, avoid transparency when modeling or doing work where
wireframes are needed. Alternatively, use the Default viewport.

+ ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view
(palette or separate window).

Note: As a workaround, use Game Navigation mode only in docked 3D views (views that are
part of a Layout).

+ ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-
series graphics card. This is due to a driver and should be fixed by a AMD in a future driver release.

+ ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode
and the width is less than the height.

+ ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.

Note: To avoid this, make sure that the projection camera has a film width-to-height ratio
that matches the main render camera.
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* RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any
unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in
the Shader Tree.

* Windows only: Using Raptr can cause GL driver crashes in Modo.

+ ID 218386 - VR is now supported on Linux, but has only been tested and verified working using
SteamVR on Ubuntu 18.04.
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