Release Notes for Modo14.1v2

Copyright © 2020 The Foundry Visionmongers Ltd.

Release Date
03 September 2020

System Requirements

Officially Supported Operating Systems
• macOS 10.13.x, 10.14.x, and 10.15.x (64-bit only)
• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7.6+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher
• 1 GB available hard disk space (for Modo installation).
• 6 GB available hard disk space (for full content).
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of graphics memory and drivers that support OpenGL 3.2 or higher.
Recommended System Requirements

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 2+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 435 or later*
- AMD: 8.982.8.1 or later*

*We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 13.0v1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

<table>
<thead>
<tr>
<th>Tested Workstation Hardware</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple</td>
<td>MacBook Pro (Retina, 15-inch, Mid-2015)</td>
</tr>
<tr>
<td></td>
<td>iMac (Late 2012)</td>
</tr>
<tr>
<td></td>
<td>Mac Pro (Late 2013)</td>
</tr>
</tbody>
</table>
### Tested Workstation Hardware

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dell</strong></td>
<td>• MacBook Pro (Mid-2015)</td>
</tr>
<tr>
<td></td>
<td>• XPS 15 9560</td>
</tr>
<tr>
<td></td>
<td>• Precision 3520</td>
</tr>
<tr>
<td><strong>HP</strong></td>
<td>• HP Z800</td>
</tr>
<tr>
<td></td>
<td>• HP Z640</td>
</tr>
<tr>
<td></td>
<td>• HP Z600</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td>• AMD Ryzen Threadripper</td>
</tr>
<tr>
<td></td>
<td>• Intel i7-4770k</td>
</tr>
<tr>
<td></td>
<td>• Intel i7-7700k</td>
</tr>
<tr>
<td></td>
<td>• Intel i7-8700</td>
</tr>
<tr>
<td></td>
<td>• Xeon E3-1505M v6</td>
</tr>
<tr>
<td></td>
<td>• Xeon E5504</td>
</tr>
<tr>
<td></td>
<td>• Xeon 5620</td>
</tr>
</tbody>
</table>

### Tested GPU Hardware

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AMD Prosumer</strong></td>
<td>• Radeon™ Vega RX</td>
</tr>
<tr>
<td>Graphics Cards</td>
<td>• Radeon™ R9 M370X</td>
</tr>
<tr>
<td></td>
<td>• Radeon™ Pro WX8200</td>
</tr>
<tr>
<td></td>
<td>• Radeon™ Pro WX7100</td>
</tr>
<tr>
<td><strong>AMD Enterprise</strong></td>
<td>• FirePro™ D700</td>
</tr>
<tr>
<td>Graphics Cards</td>
<td></td>
</tr>
<tr>
<td><strong>NVIDIA Prosumer</strong></td>
<td>• GeForce 675MX</td>
</tr>
<tr>
<td>Graphics Cards</td>
<td>• GeForce 970</td>
</tr>
<tr>
<td></td>
<td>• GeForce 1050 (laptop)</td>
</tr>
<tr>
<td></td>
<td>• GeForce GTX 1070 Ti (Linux)</td>
</tr>
<tr>
<td></td>
<td>• GeForce 1080</td>
</tr>
<tr>
<td><strong>NVIDIA Enterprise</strong></td>
<td>• Quadro® K620</td>
</tr>
<tr>
<td>Graphics Cards</td>
<td>• Quadro® M620</td>
</tr>
<tr>
<td></td>
<td>• Quadro® M4000</td>
</tr>
</tbody>
</table>
New Features

Advanced Real-time Viewport

Advanced Viewport Ghost & Xray Support

Whether you’re modeling or animating, coherent and customizable visualization of geometry is essential. **Ghost** and **X-Ray** viewport modes help you see what you need, when you need it, letting you stay in the creative flow. Now if you want to visualize your scenes with **Ghost** & **X-Ray** you can enjoy the quality that the Advanced Viewport provides too. For more information, see Viewport Toggle Buttons.

Advanced Viewport Vertex Map Texture Support

Visualization of your Vertex Maps allows you to make fast decisions and edits without having to fiddle with parameters. Now you can visualize Weight Maps, UV Distortion, and Vertex Colors in the Advanced Viewport. For more information, see Viewport Toggle Buttons.

Advanced Viewport Improved Processing

Complex scenes can be a challenge to visualize at high quality. In Modo 14.1 the Advanced Viewport has been optimized for faster Shader Tree and Shader Group processing for better performance when working in complex models and environments.

Performance

Performance Improvements

Always striving to improve performance, Modo 14.1 brings a handful of performance improvements to speed up your daily work. The UV Relax Mesh Operation has been multi-threaded in **Adaptive** mode offering up to 5X speed increase when relaxing UVs. The **Edge Remove** operation has also been significantly improved for speed increases between 5 and 20 times.
Direct Modeling

Bevel Auto Weld

Worrying about overlapping geometry when beveling is a thing of the past with the new Bevel Auto Weld feature in Modo 14.1. A new option for the Polygon Bevel tool, Auto Weld computes the border loop of selected polygons and then stops the inset vertices at a point of contact. Whether direct or procedural modeling, Bevel Auto Weld is a really powerful tool many Modo modelers will appreciate. For more information, see Using Auto Weld to Manage Overlap.

Edge Chamfer Extend Boundary

Sometimes you want to push past the boundary when Chamfering and the new Extended Boundary option in Edge Chamfer lets you do just that. The outgoing direction is computed by the outer face normal and edge vectors. This new enhancement is available both for procedural and direct modeling versions of Edge Chamfer. For more information, see Extend Boundary.

Polygon Make Enhancement

Making simple operations smarter adds speed and agility to the modeling process. Polygon Make can now create a new quad polygon when only two edges are selected. For more information, see Polygon Make.

Polygon Bevel Falloff Controls

Falloffs are a powerful and flexible part of Modo’s workflow and you can now use them to control Polygon Bevel. Use all your favorite falloffs with Polygon BevelShift and Inset.

Curve Sweep Point Mode

Curve Sweep has a new mode, allowing vertices of a mesh to be swept along a curve using Curve Sweep. Point mode brings exciting new versatility to Curve Sweep for making vertices into curves. For more information, see Point Mode.
Procedural Modeling

Unwrap and Relax Mesh Operation

**Unwrap and Relax** is a powerful tool that makes quick work of complex UV tasks and is now available as a procedural Mesh Operation. For more information, see Procedural Unwrap & Relax.

UV Relax Mesh Operation

Get procedural with UVs using the **UV Relax** mesh op. It can be used to refine an existing UV map in much the same way as the smooth tool is used to soften and regularize a model's surface. For more information, see Procedural UV Relax.

Rendering & Shading

Denoising Improvements

Denoising is an important part of a modern rendering workflow and mPath in Modo now offers two new options for denoising as well as improvements to the current **Nvidia OptiX** denoising.

- **Intel’s Open Image Denoise** - A new high quality denoiser that uses AI to improve image quality on the host CPU, with no user parameters. For more information, see Intel Open Image Denoise.
- **AMD AI** - A new high quality denoiser that uses AI to improve image quality on the GPU. It is most efficient on AMD hardware. For more information, see AMD AI.

When looking for quick updates, Per Iteration Denoising can speed up your workflow by denoising the image between mPath iterations. It is currently available when using the Intel or OptiX denoisers.

mPath Embree CPU path tracing

mPath takes full advantage of the latest multi core CPU systems hitting the market with the addition of Intel's Embree high performance ray tracing library. Embree enables faster ray tracing calculation for CPU platforms including MAC. For more information, see Ray Tracing Engine.
mPath Optix 7 Update

GPU Ray Tracing on qualified NVIDIA hardware has been upgraded to use OptiX 7. mPath is now significantly faster to render your ray traced scenes with NVIDIA OptiX 7.

This update to mPath also adds support for ray tracing two-point polygons in OptiX, useful for rendering hair and fur. For more information, see Ray Tracing Engine.

mPath Automatic EIS

Simplicity can remove barriers and allow focus on the artwork at hand. Environment Importance Sampling (EIS) is now automated when rendering with mPath, based on whether any image maps are affecting the environment. For more information, see Rendering with mPath.

PBR Loader / Set Effects

PBR Loader allows you to rapidly load PBR textures created in other applications like Substance Designer into the shader tree. Quickly load in all related images, and then set their effect based on the effect in the name of the file. For more information, see PBR Textures.

Gaps by Pixel Enhancements

The UV Pack and UV Fit mesh ops now have new attributes to set the gaps size by pixel for 14.1. For more information on the Set Gaps Size by Pixel option for UV Pack, see Pack UVs Properties - Set Gaps by Pixel. For UV Fit, see Fit UVs / UV Fit Properties - Gaps by Pixel.

Animation & Rigging

IK/FK Switching

Switching between IK and FK can be cumbersome. The new IK/FK Switching with Planar IK lets you quickly match IK to FK and FK back to IK. When animating you can easily visualize your state with fading IK lines and a custom IK Goal for IK or FK. For more information, see IK/FK Switch.
Disable IK & Update Rest Pose

Sometimes you need to adjust your joints after Inverse Kinematics has been applied. Disable IK enables you to do just that by tweaking joint placement even after IK is setup. Both Full Body and Planar IK can now be disabled in Setup mode and commands have been added to update the Rest Pose of both types of IK chains. For more information, see Full Body IK Utility Options or Planar IK Utility Options.

USD Importer

The UsdModo plugin, enables you to import assets authored with Pixar’s Universal Scene Description into Modo. Types of Geometry, Curves, Lights, Cameras, Material, and Animation are supported. For more information, see USD I/O.

Miscellaneous

• Licensing - Modo now includes a Japanese translation for the licensing interface.
• Rendering - The Intel Embree libraries have been updated from version 3.9.0 to 3.11.0
• Rendering - The Intel denoiser now uses the surface normal buffer correctly.
• SDK - A `UVBoundingBox()` function has been added to the SDK.

Bug Fixes

• BUG ID 408916 - Aborting a render using NVIDIA OptiX as the ray tracing engine occasionally caused Modo to crash.
• BUG ID 423545 - Completing an animation render did not release memory as expected.
• BUG ID 436370 - Rendering a scene to .png produced a darker image in 14.1 compared to earlier versions of Modo.
• BUG ID 439946 - Rendering: Backface culling did not work as expected.
• BUG ID 441550 - Rendering: Setting Indirect Bounces to 1 caused AMD AI denoise to fail.
• BUG ID 442598 - The Modo Intro offline image was not consistent across all operating systems.
• BUG ID 442667 - USD: The scaling of a certain mesh was not consistent between macOS and Windows.
• BUG ID 442944 - Rendering: Selecting the mPath renderer with an environment image and preview running caused Modo to crash.
• BUG ID 442946 - Opening a preview with the Viewport Properties open caused Modo to crash.
• BUG ID 443276 - Rendering: Changing texture attributes with preview running caused Modo to crash.
• BUG ID 443575 - Rendering: Selecting the mPath renderer caused Modo to crash under certain conditions.
• BUG ID 443715 - macOS only: Modo occasionally reported errors on start-up with PowerTranslators installed.
• BUG ID 444426 - UVing: Selecting Show Outside Labels inside the UV editor caused Modo to crash.
• BUG ID 444876 (60661) - Rigging: 3Bar IK chains occasionally flipped the second and third joints during evaluation.
• BUG ID 444879 (60662) - Rigging: FK to IK matching on 3bar IK chains did not work as expected.
• BUG ID 444895 (60663) - Rigging: 3Bar IK chain solving was too inflexible, which occasionally caused flipped poses during evaluation.
• BUG ID 444900 (60664) - Rigging: Matching IK to FK using the 2D IK solver ignored IK chain up vectors.
• BUG ID 445368 - Licensing: Design Collective licenses did not work as expected with Modo 14.1 builds.
• BUG ID 445477 - Licensing: Permanent node-locked license messaging was not consistent with earlier versions of Modo.
• BUG ID 445500 - Rendering fur in a certain project displayed a Can't create Embree scene error.
• BUG ID 445638 (60698) - Rigging: FK to IK matching on certain 3bar IK chains did not work as expected.

• BUG ID 446071 - UVing: UVs with non-default names did not always return the correct bounding box.

Known Issues

This section covers some known issues and gives workarounds for them, where appropriate.

Animation

• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  Note: As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

• ID 395357 - Deformer Caching doesn't work.

• ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.

Assemblies

• ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

  Note: As a workaround, you can save assemblies from the Schematic viewport.

Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.

• ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.
Bucket Render

• ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.

  Note: As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

• ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

  Note: As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

• ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.

• ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

  Note: As a workaround, freeze the transforms in the mesh properties.

Color Management

• ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

  Note: As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.
Command Line

- ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

**Note:** As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.

File and Image I/O

- ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct imports (File > Import).

**Note:** As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

- ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and procedural shatter items.

- ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances, unless the original mesh is also exported.

**Note:** To resolve this, set the .fbx preference to Export Selection and use Export As....

- ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

- ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.

- ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

**Note:** As a workaround, use File > Import.
Fur

• ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

**Note:** Use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices

• ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

**Note:** As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).

• ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

**Note:** To avoid this, plug in the tablet before application startup or restart.

MeshFusion

• ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

**Note:** As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.
Modeling

- ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.
- ID 408278 (60027) - Linear Falloff snaps to object size.

**Note:** As a workaround, use the right mouse button for an interactive initial linear handle.

Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

**Note:** As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).

- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

**Note:** As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.

- ID 220955 (30318) - Network Rendering doesn't support Realflow particles.
- ID 226336 (25636) - Frame passes are not supported.

- Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

**Note:** As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.
**Nodal Shading**

- ID 221393 (50642) - Nodal shading does not support UDIMs.
- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

**Painting/Sculpting**

- ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.

> **Note:** You can save and reload the image to force the update.

**Particles**

- ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

> **Note:** To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

**Preview Render**

- If a high poly mesh is not visible, the Preview baking output will be incorrect.

> **Note:** As a workaround, reset Preview to fix the baking.

**Procedurals**

- ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.
• ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

  **Note:** As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

• ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.

  **Note:** As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

• ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

  **Note:** As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

• ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

  **Note:** You can use Preview or RayGL to visualize the variations from rigging.

• ID 388978 - Paving does not work when a Guide curve runs through a paving hole

**References**

• ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

  **Note:** As a workaround, limit scenes with shading to one level of reference.
• ID 220957 (41119) - reloading a reference after replacing it with the same file can cause Modo to crash.

• ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.

  Note: As a workaround, first close and reopen the scene before attempting to revert the reference.

Rigging

• ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.

• ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

Scripting

• ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

  Note: As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

• ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

  Note: To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer’s Properties tab.

• ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.

• ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.
Unreal and Unity Materials

• ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.

UI

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

Note: As a workaround, upgrade Mac OS to 10.13.

• ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

Note: This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

Note: If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

• ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo’s text drawing.
Note: As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

- ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

Note: As a workaround, click the alt key.

- ID 388937 - macOS only: UI form field highlights can appear grey.
- ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn't resize back the popover correctly

UVing

- ID 440824 (60620) - Modo crashes when I click "Apply Overall" in the Texel Density Palette...

Note: As a workaround, deselect any Mesh item that does not have the specified (or currently selected) UV map.

Viewports

- ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

Note: As a workaround, enable and then disable the visibility of the Shader Tree textures.

- RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.
- ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

Note: As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.
• Windows only: Using Raptr can cause GL driver crashes in Modo.

• ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

**Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

• ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver bug and should be fixed by AMD in a future driver release.

• ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.

• ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.

**Note:** To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

• ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

**Note:** As a workaround, use Preview.

• ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

**VR**

• ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.
Release Notes for Modo14.1v1

Release Date
23 July 2020

System Requirements

Officially Supported Operating Systems
• macOS 10.13.x, 10.14.x, and 10.15.x (64-bit only)
• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7.6+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher
• 1 GB available hard disk space (for Modo installation).
• 6 GB available hard disk space (for full content).
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of graphics memory and drivers that support OpenGL 3.2 or higher.
Recommended System Requirements

Note: This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 2+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 435 or later*
- AMD: 8.982.8.1 or later*

*We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 13.0v1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

<table>
<thead>
<tr>
<th>Tested Workstation Hardware</th>
<th>Apple</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• MacBook Pro (Retina, 15-inch, Mid-2015)</td>
</tr>
<tr>
<td></td>
<td>• iMac (Late 2012)</td>
</tr>
<tr>
<td></td>
<td>• Mac Pro (Late 2013)</td>
</tr>
<tr>
<td>Tested Workstation Hardware</td>
<td>MacBook Pro (Mid-2015)</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Dell</td>
<td>XPS 15 9560</td>
</tr>
<tr>
<td></td>
<td>Precision 3520</td>
</tr>
<tr>
<td>HP</td>
<td>HP Z800</td>
</tr>
<tr>
<td></td>
<td>HP Z640</td>
</tr>
<tr>
<td></td>
<td>HP Z600</td>
</tr>
<tr>
<td>CPU</td>
<td>AMD Ryzen Threadripper</td>
</tr>
<tr>
<td></td>
<td>Intel i7-4770k</td>
</tr>
<tr>
<td></td>
<td>Intel i7-7700k</td>
</tr>
<tr>
<td></td>
<td>Intel i7-8700</td>
</tr>
<tr>
<td></td>
<td>Xeon E3-1505M v6</td>
</tr>
<tr>
<td></td>
<td>Xeon E5504</td>
</tr>
<tr>
<td></td>
<td>Xeon 5620</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tested GPU Hardware</th>
<th>AMD Prosumer Graphics Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Radeon™ Vega RX</td>
</tr>
<tr>
<td></td>
<td>Radeon™ R9 M370X</td>
</tr>
<tr>
<td></td>
<td>Radeon™ Pro WX8200</td>
</tr>
<tr>
<td></td>
<td>Radeon™ Pro WX7100</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>AMD Enterprise Graphics Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FirePro™ D700</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NVIDIA Prosumer Graphics Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeForce 675MX</td>
</tr>
<tr>
<td>GeForce 970</td>
</tr>
<tr>
<td>GeForce 1050 (laptop)</td>
</tr>
<tr>
<td>GeForce GTX 1070 Ti (Linux)</td>
</tr>
<tr>
<td>GeForce 1080</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NVIDIA Enterprise Graphics Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quadro® K620</td>
</tr>
<tr>
<td>Quadro® M620</td>
</tr>
<tr>
<td>Quadro® M4000</td>
</tr>
</tbody>
</table>
New Features

Advanced Real-time Viewport

Advanced Viewport Ghost & Xray Support

Whether you’re modeling or animating, coherent and customizable visualization of geometry is essential. Ghost and X-Ray viewport modes help you see what you need, when you need it, letting you stay in the creative flow. Now if you want to visualize your scenes with Ghost & X-Ray you can enjoy the quality that the Advanced Viewport provides too. For more information, see Viewport Toggle Buttons.

Advanced Viewport Vertex Map Texture Support

Visualization of your Vertex Maps allows you to make fast decisions and edits without having to fiddle with parameters. Now you can visualize Weight Maps, UV Distortion, and Vertex Colors in the Advanced Viewport. For more information, see Viewport Toggle Buttons.

Advanced Viewport Improved Processing

Complex scenes can be a challenge to visualize at high quality. In Modo 14.1 the Advanced Viewport has been optimized for faster Shader Tree and Shader Group processing for better performance when working in complex models and environments.

Performance

Performance Improvements

Always striving to improve performance, Modo 14.1 brings a handful of performance improvements to speed up your daily work. The UV Relax Mesh Operation has been multi-threaded in Adaptive mode offering up to 5X speed increase when relaxing UVs. The Edge Remove operation has also been significantly improved for speed increases between 5 and 20 times.
Release Notes for Modo14.1v1 | New Features

Direct Modeling

Bevel Auto Weld

Worrying about overlapping geometry when beveling is a thing of the past with the new **Bevel Auto Weld** feature in Modo 14.1. A new option for the **Polygon Bevel** tool, **Auto Weld** computes the border loop of selected polygons and then stops the inset vertices at a point of contact. Whether direct or procedural modeling, **Bevel Auto Weld** is a really powerful tool many Modo modelers will appreciate. For more information, see Using Auto Weld to Manage Overlap.

Edge Chamfer Extend Boundary

Sometimes you want to push past the boundary when Chamfering and the new **Extended Boundary** option in **Edge Chamfer** lets you do just that. The outgoing direction is computed by the outer face normal and edge vectors. This new enhancement is available both for procedural and direct modeling versions of **Edge Chamfer**. For more information, see **Extend Boundary**.

Polygon Make Enhancement

Making simple operations smarter adds speed and agility to the modeling process. **Polygon Make** can now create a new quad polygon when only two edges are selected. For more information, see **Polygon Make**.

Polygon Bevel Falloff Controls

Falloffs are a powerful and flexible part of Modo’s workflow and you can now use them to control **Polygon Bevel**. Use all your favorite falloffs with **Polygon BevelShift** and **Inset**.

Curve Sweep Point Mode

**Curve Sweep** has a new mode, allowing vertices of a mesh to be swept along a curve using **Curve Sweep**. **Point** mode brings exciting new versatility to **Curve Sweep** for making vertices into curves. For more information, see **Point Mode**.
Procedural Modeling

Unwrap and Relax Mesh Operation

Unwrap and Relax is a powerful tool that makes quick work of complex UV tasks and is now available as a procedural Mesh Operation. For more information, see Procedural Unwrap & Relax.

UV Relax Mesh Operation

Get procedural with UVs using the UV Relax mesh op. It can be used to refine an existing UV map in much the same way as the smooth tool is used to soften and regularize a model's surface. For more information, see Procedural UV Relax.

Rendering & Shading

Denoising Improvements

Denoising is an important part of a modern rendering workflow and mPath in Modo now offers two new options for denoising as well as improvements to the current Nvidia OptiX denoising.

- Intel's Open Image Denoise - A new high quality denoiser that uses AI to improve image quality on the host CPU, with no user parameters. For more information, see Intel Open Image Denoise.
- AMD AI - A new high quality denoiser that uses AI to improve image quality on the GPU. It is most efficient on AMD hardware. For more information, see AMD AI.

When looking for quick updates, Per Iteration Denoising can speed up your workflow by denoising the image between mPath iterations. It is currently available when using the Intel or OptiX denoisers.

mPath Embree CPU path tracing

mPath takes full advantage of the latest multi core CPU systems hitting the market with the addition of Intel's Embree high performance ray tracing library. Embree enables faster ray tracing calculation for CPU platforms including MAC. For more information, see Ray Tracing Engine.
mPath Optix 7 Update

GPU Ray Tracing on qualified NVIDIA hardware has been upgraded to use OptiX 7. mPath is now significantly faster to render your ray traced scenes with NVIDIA OptiX 7.

This update to mPath also adds support for ray tracing two-point polygons in OptiX, useful for rendering hair and fur. For more information, see Ray Tracing Engine.

mPath Automatic EIS

Simplicity can remove barriers and allow focus on the artwork at hand. Environment Importance Sampling (EIS) is now automated when rendering with mPath, based on whether any image maps are affecting the environment. For more information, see Rendering with mPath.

PBR Loader / Set Effects

**PBR Loader** allows you to rapidly load PBR textures created in other applications like Substance Designer into the shader tree. Quickly load in all related images, and then set their effect based on the effect in the name of the file. For more information, see PBR Textures.

Gaps by Pixel Enhancements

The **UV Pack** and **UV Fit** mesh ops now have new attributes to set the gaps size by pixel for 14.1. For more information on the **Set Gaps Size by Pixel** option for **UV Pack**, see Pack UVs Properties - Set Gaps by Pixel. For **UV Fit**, see Fit UVs / UV Fit Properties - Gaps by Pixel.

Animation & Rigging

IK/FK Switching

Switching between IK and FK can be cumbersome. The new IK/FK Switching with Planar IK lets you quickly match IK to FK and FK back to IK. When animating you can easily visualize your state with fading IK lines and a custom IK Goal for IK or FK. For more information, see IK/FK Switch.
Disable IK & Update Rest Pose

Sometimes you need to adjust your joints after Inverse Kinematics has been applied. Disable IK enables you to do just that by tweaking joint placement even after IK is setup. Both Full Body and Planar IK can now be disabled in Setup mode and commands have been added to update the Rest Pose of both types of IK chains. For more information, see Full Body IK Utility Options or Planar IK Utility Options.

USD Importer

The **UsdModo** plugin, enables you to import assets authored with Pixar’s Universal Scene Description into Modo. Types of Geometry, Curves, Lights, Cameras, Material, and Animation are supported. For more information, see USD I/O.

Bug Fixes

- BUG ID 264492 (54188) - Deleting filtered items in the item list using the Delete key did not display a warning.
• BUG ID 273066 (55076) - Exiting Slave Mode caused Modo to crash.
• BUG ID 294373 - Iridescence Materials did not work with Group Masks in the Shader Tree.
• BUG ID 320289 (57087) - Viewport interaction was slow compared to previous versions of Modo.
• BUG ID 331702 (57628) - UV handle positions ignored the aspect ratio of the image.
• BUG ID 344037 (58326) - Expanding the Modo interface immediately after scene load with the pointer over the Shader Tree caused Modo to crash.
• BUG ID 345130 (57803) - Enabling Use Image Ratio in the UV view places snapping and element action centers incorrectly.
• BUG ID 345188 (57507) - The Modo introduction screen was occasionally blank on start-up.
• BUG ID 347180 (58403) - Calling sel.hide() or sel.unhide() in a Python script caused Modo to crash.
• BUG ID 347876 (58437) - AVP: Multiple shader groups made viewport interaction sluggish.
• BUG ID 353279 - Certain test scripts failed due to strict references to file types rather than Int codes.
• BUG ID 371449 - Logging into Modo on more than two machines at the same time displayed the wrong error message.
• BUG ID 378762 (59357) - Adding a vertex map texture automatically created a weight map.
• BUG ID 380043 - Using Replace Icon With Image File in the Preset Browser did not apply image files as thumbnails for .lxo presets.
• BUG ID 380737 - Adjusting the thumbnail size in the Preset Browser caused Modo to crash.
• BUG ID 384909 - Applying a Vert Merge and Poly Subdivide positioned geometry incorrectly.
• BUG ID 389309 (59642) - Schematic: Dragging a channel output to another node's title bar created a green link incorrectly.
• BUG ID 389679 (59651) - Using the Quick Align tool with snapping enabled did not display a gizmo as expected.
• BUG ID 391894 - Duplicate layered materials referenced from the Library folder did not render correctly.
• BUG ID 393564 - Child items in the viewport were not updated as expected when the parent was deselected.
• BUG ID 393601 - The Coplanar Polygons tool did not select all coplanar polygons.
• BUG ID 396485 - Sliding an edge selection in a certain scene caused Modo to crash.
• BUG ID 397231 - Importing a mesh containing hidden polygons using layer.import() revealed hidden polygons on the target layer.
• BUG ID 398020 - Adding a Freeze mesh operation to a certain scene caused Modo to crash.
• BUG ID 399100 - Zooming out and zooming back in on an object using the Shift+A keyboard shortcut caused the Move tool handles to freeze.
• BUG ID 400917 - Moving UVs was less responsive than in Modo 13.0 builds.
• BUG ID 403484 - The Space Navigator rotation override could not be set per viewport.
• BUG ID 403970 - The option to use the legacy FBX plug-in for import was still accessible in the FBX I/O preferences.
• BUG ID 404240 (59915) - Camera background/foreground images did not work as expected in the path tracer.
• BUG ID 404627 (59929) - Schematic: New nodes could not be connected to existing floating elbows.
• BUG ID 404786 - Rendering certain scenes in the Preview renderer caused Modo to crash.
• BUG ID 405278 (59954) - Rendering certain scenes using the RTX path tracer caused Modo to become unresponsive.
• BUG ID 405752/405759 (59975/59976) - Mesh Ops: Edge Selection Sets were not preserved on both the source and driver meshes when processed by a Boolean.
• BUG ID 406704 - Certain legacy scenes did not load as expected in later releases.
• BUG ID 407380 - Pressing Delete while editing text occasionally deleted the wrong characters or caused Modo to crash.
• BUG ID 407946 - Curve Fill Holes did not work as expected for curves on the X or Y axes.
• BUG ID 408323 - Add Layer was occasionally replaced by ... (ellipsis) in the UI.
• BUG ID 408324 - Assigning a Light Path Expression (LPE) to a selected light displayed an error.
• BUG ID 409248 - Path Tracer: Diffuse coefficient renders produced incorrect output.
• BUG ID 410900 - Right-clicking on a tool property while editing it occasionally caused Modo to crash.
• BUG ID 411309 - Mouse scroll did not work as expected in embedded viewports.
• BUG ID 411786 - Using the Tack tool with Copy Geometry and Make Bridge enabled caused Modo to crash.
• BUG ID 414046 - Switching from interactive to value sliders did not update the tool handles as expected.
• BUG ID 414236 (60079) - Playblasts did not match the output from the AVP.
• BUG ID 414525 (60087) - Schematic: Links between nodes in the Schematic viewport were occasionally disconnected on load.
• BUG ID 414579 - Solid Drill slowed down the AVP when a Default material was assigned.
• BUG ID 414953 (60095) - Performing a Merge operation on polygons removed and associated materials.
• BUG ID 415034 - Performing an undo after using the Mirror tool caused Modo to crash.
• BUG ID 415158 - Using an Edge Chamfer with profiles did not handle corners well in certain scenarios.
• BUG ID 416584 - Viewport selection was slower in Modo 13.2 compared to previous versions.
• BUG ID 417104 (60113) - Performing a Jitter mesh operation followed by a Subdivide operation caused the mesh UVs to distort.
• BUG ID 417469 - When used with area falloffs, the **Bevel** mesh operation used the `BevelVertexWeight()` command instead of `BevelPolygonWeight()` to compute falloffs, which resulted in incorrect weights.

• BUG ID 417725 - The **Transform** tool **Use World Transform** property did not work correctly when using secondary falloffs.

• BUG ID 417744 - **Mix Mode** in the **Transform** tool properties did not work as **Use World Transforms** did not work correctly when a secondary falloff was added.

• BUG ID 418017 (60133) - Modo did not perform well when removing many edges from a mesh.

• BUG ID 418402 (60140) - Texture Locator transform properties did not update with the correct value at a given frame when scrubbing the timeline.

• BUG ID 418412 (60143) - OCIO settings were not saved between sessions.

• BUG ID 418858 (60144) - Fur could not be rendered in certain scenes.

• BUG ID 419050 (60148) - **Axis Slice** and other slice mesh operations caused mesh UVs to distort.

• BUG ID 419083 - macOS only: Modo crashed when disconnecting links in the **Schematic** view.

• BUG ID 419133 (60150) - The wrong tooltip displayed when the cursor hovered over gang edit icons.

• BUG ID 419225 (60158) - The Modo layout **Discard** button in the render passes form did not fit on the screen.

• BUG ID 419276 (60162) - Working with command regions in the **Advanced** viewport became difficult due to the way the regions obscured meshes.

• BUG ID 419331 (60166) - Item shape drawings had additional gamma correction applied in the **Advanced** viewport.

• BUG ID 419390 (60172) - There was no option to switch automatically from IK to FK on a given frame.

• BUG ID 419413 (60174) - Animation layers did not work with channel based actors.

• BUG ID 419508 (60178) - Mouse and stylus actions could often be interpreted as drag and drop instead of single-click, which resulted in failure of selection redirection or adding commands to items.

• BUG ID 419514 (60179) - **Edge Bevel** operations caused one polygon to be assigned an incorrect **ptag**.

• BUG ID 420529 (60193) - Selecting a bezier curve in **Polygons** selection mode sometimes changed the curve’s shape.

• BUG ID 420771 (60195) - Input fields lost focus if the cursor moved to the top of the screen.

• BUG ID 421190 (60201) - When a non-square image with **Use Image Aspect** was enabled in the background of the **UV** viewport, tool handles were drawn incorrectly.

• BUG ID 421191 (60202) - Modo crashed when importing a sub-scene and then performing an undo.

• BUG ID 421215 - **Ignore Scale Groups** had no tooltip.

• BUG ID 421516 - **Grease Pencil** did not support images with the same aspect ratio as the camera, causing distorted brush shapes.
• BUG ID 421569 (60210) - The Advanced viewport became slow when material display was set to Full.
• BUG ID 421651 - Rename commands on procedural vertex maps did not work.
• BUG ID 422358 (60212) - The IK solver could not be reset from FK correctly when the IK was using a locator with an up vector.
• BUG ID 422615 - Edge Chamfer performed poorly in certain scenes.
• BUG ID 422947 - Bezier effector bends became stepped at extreme values.
• BUG ID 422974 (60231) - Strange refraction behavior occurred in certain scenes using the mPath Renderer.
• BUG ID 423270 - Loaded image sequences used color management when they should not be color managed.
• BUG ID 424157 - Textures were re-read on each frame in an animation render causing decreased render performance and increased network traffic.
• BUG ID 424420 (60270) - Bridge with profile set to Reverse Direction used an incorrect Profile.
• BUG ID 424422 (60272) - Vertex Slide did not slide correctly when Merge Vertices was enabled and Stop at Edges was disabled.
• BUG ID 424853 - In UV view with Inactive disabled and Snapping enabled, you could still see the highlight for inactive meshes.
• BUG ID 424921 (60284) - The UV viewport Backdrop Image property reset between Modo sessions.
• BUG ID 424924 (60287) - Rotating the gizmo in the 3D viewport for the Create UV Map operation caused a drop in performance.
• BUG ID 425119 (60299) - Modo crashed when connecting a mesh to a Weight Map falloff.
• BUG ID 425197 - Changing texture locator values while previewing in certain scenes caused Modo to crash.
• BUG ID 425198 - The uv.relax command did not support mode and boundary settings.
• BUG ID 426137 - AVP did not work with component Selections Transparency settings from the Preferences.
• BUG ID 426696 - Modo was unstable when using certain internal scene files.
• BUG ID 426744 - When a weight map was selected, it overrode Ghost and X-Ray view modes in the Vertex Map viewport.
• BUG ID 426893 - The Multi-cut option of the Edge Slice tool did not work when Work Plane > Lock Plane to Origin was enabled.
• BUG ID 426898 - AVP: Scenes with a normal map and a metallic constant appear black in the AVP.
• BUG ID 427099 - The Topology Pen snapped to the background mesh.
• BUG ID 427131 - AVP: Modo renders handle negative values incorrectly in layer masks.
• BUG ID 427155 (60337) - New features including Unbevel and Partial Element Selection are not accessible from outside the Modo layout.
• BUG ID 427260 - Modo crashed when setting the Sides property of Lace Geometry to two or below.
• BUG ID 427284 - Modo locked up when launched for the first time with both plug-ins available and no config.cfg file.

• BUG ID 427484 (60342) - Activating the UV Relax tool with Angle Based mode enabled caused Modo to crash.

• BUG ID 427699 - The frame rate dropped when playing animations with the Mesh properties visible on the screen.

• BUG ID 427721 - The Slide tool had inconsistent handles when used in different states.

• BUG ID 427956 (60354) - Rendering an animation auto-saved images when using a Denoiser, which used up a lot of disk space.

• BUG ID 427957 (60355) - Markup had no basic text tool similar to the Modo paint tools.

• BUG ID 427964 (60357) - Markup had no autosave feature.

• BUG ID 427978 - The render items values did not match the saved values of the imported .lxp presets.

• BUG ID 427983 (60359) - Light linking for mPath renders did not work as expected.

• BUG ID 428072 - Modo crashed when drawing with the Pen tool in the AVP.

• BUG ID 428178 - The large icons for Quick Align and Ground Align were incorrect.

• BUG ID 428199 - Enabling Stacked from the Select Error UVs in the UV layout did not work.

• BUG ID 428419 (60361) - Modo crashed when adding a Merge mesh operation to meshes in certain scenes.

• BUG ID 428447 (60362) - Modo crashed when grouping MeshFusion items together in the Shader Tree.

• BUG ID 428529 (60363) - The Align Center or Align Middle Island commands could not align multiple UV islands in Polygon mode.

• BUG ID 428634 (60365) - Bezier curve based MeshFusion Surface Strips did not create clean strips when underlying primary surfaces had planar changes.

• BUG ID 429097 (60370) - Modo crashed when toggling Enable Embossing in Fusion items for MeshFusion.

• BUG ID 429110 (60372) - Polygon Bevel using Thicken mode failed to output the Front / Back polygon tags.

• BUG ID 429157 - Modo crashed on first launch when setting Usage Stats to Never.

• BUG ID 429611 (60382) - Modo crashed when enabling Sharp Bezier Corners on bezier curves.

• BUG ID 429640 - Certain scenes did not release RAM after rendering the scene, causing increased memory usage even after the render had completed.

• BUG ID 429790 - Editing files on disk did not update the images in the viewport or render windows until Modo was restarted.

• BUG ID 429823 - In some situations Edge Chamfer produced uneven edges.

• BUG ID 429839 - Modo crashed after performing an Edge Chamfer in certain scenes.
- BUG ID 429928 - Modo crashed after performing a cube Boolean operation on a mesh.
- BUG ID 429984 (60390) - Modo crashed when the **Fusion Polygon Set** was changed from **Fusion! To Fusion+**.
- BUG ID 430018 - Modo crashed when quickly selecting different **Bridge** tool profiles.
- BUG ID 430144 - **Surface Strip** creation occasionally failed on MeshFusion items.
- BUG ID 430189 (60393) - Scenes with disabled elbow links reloaded schematic links incorrectly.
- BUG ID 430195 - Modo crashed when clicking **Simulate** in certain scenes.
- BUG ID 430292 (60397) - Modo crashed in certain scenes when moving certain polygons.
- BUG ID 430404 - Enabling **Render Curves** and triggering a render resulted in a crash.
- BUG ID 430539 - The Modo introduction screen occasionally failed to load content.
- BUG ID 430652 - Modo crashed when importing certain .dxf files.
- BUG ID 430781 - Modo crashed when using the **UV Unwrap** tool on scenes with degenerated polygons.
- BUG ID 430967 - The endpoint on closed loops was incorrectly facing the wrong direction.
- BUG ID 431472 - Modo crashed randomly upon instancing an Assembly.
- BUG ID 431505 - Solidworks loader DLLs required an update to SW2020.
- BUG ID 431615 (60421) - The **Merge** command merged bezier control points when it should not.
- BUG ID 431720 - CloudPreset load: A corrupted .json file caused Modo to crash.
- BUG ID 431804 - Modo crashed when adding a mesh containing curves as a **Surface Strip**.
- BUG ID 431889 - The **Recolor To** effect in the Shader Tree did not handle oversaturated values consistently between Preview renders, and the **Default** and **Advanced** viewports.
- BUG ID 432197 - Exporting .fbx files did not retain material information.
- BUG ID 432417 (60436) - The mesh had to be selected and deselected in order for command regions to work properly.
- BUG ID 432437 - **Edge Chamfer** offset edges asymmetrically.
- BUG ID 432443 - Enabling **Show Selection Normals** in the 3D viewport **Visibility** options, when you had an operation and a face of the base mesh selected, resulted in a crash.
- BUG ID 432883 - The `item.delete item:[name]` command did not delete an item unless the item was selected.
- BUG ID 432920 (60445) - Modo crashed when changing the **Depth** value in the assembly.
- BUG ID 433010 - Some scenes were too slow to transfer items using the `layer.import` command.
- BUG ID 433011 - Image clip previews in the **Preset Browser** did not update after they were modified on disk.
- BUG ID 433262 (60451) - **Radial Sweep** did not work as expected with **Square** enabled on arcs that were less than 360 degrees.
- BUG ID 433810 - Calling **MM_Destroy** from a thread caused a crash during ray evaluation.
• BUG ID 433824 - **Edge Align** did not always preserve the UV island position in UV space.
• BUG ID 433981 - Adding mesh operations occasionally caused Modo to crash.
• BUG ID 434105 - **Motion Vector Output** rendered curves incorrectly.
• BUG ID 43431 (60471) - Transforming selected UVs dropped the selection.
• BUG ID 434723 - MeshFusion: Embossing did not work as expected for the letter E.
• BUG ID 434865 - Importing .fbx files and rearranging the scene caused Modo to crash on exit.
• BUG ID 435647 - Selecting **Render > Render Animation** occasionally caused Modo to crash.
• BUG ID 436309 (60529) - Setting a UV space control to a value less than 0.1 did not update the UI correctly.
• BUG ID 436423 - cloudPB temporary files occasionally caused Modo to crash on restart.
• BUG ID 437478 (60549) - Clicking the spans that close a curve did not select closed B-Spline correctly.
• BUG ID 437646 (60557) - **Replica Radial Array** did not use `item.refSystem()` correctly.
• BUG ID 437648 (60558) - Single-sided polygons were displayed as double-sided in the AVP.
• BUG ID 437689 (60559) - Combinations of internal and boundary edges caused **Edge Slide** to behave erratically.
• BUG ID 438437 - The **Bridge** tool did not work as expected with 1D **Profiles**.
• BUG ID 438469 (60586) - The **Pen** tool in **Polyline** and **Wall Mode > Both Sides** mode only drew on one side.
• BUG ID 438474 - MeshFusion did not work well with surface strip intersections.
• BUG ID 440370 - Overlapping area lights in mPath occasionally caused shading artifacts.

**Known Issues**

This section covers some known issues and gives workarounds for them, where appropriate.

**Animation**

• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

  **Note:** As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab, then save and reload the scene.

• ID 395357 - Deformer Caching doesn't work.

• ID 423909 - Grease Pencil - Setting image type to JPG results in a black fill over the screen.
Assemblies

• ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual layout of nodes on import.

Note: As a workaround, you can save assemblies from the Schematic viewport.

Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.

• ID 221481 (49437) - The Bake Channel Swizzling option can’t bake to texture alpha.

Bucket Render

• ID 279848 (55663) - Motion Blur applied on a curve in a Mesh Operation no longer works.

• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.

Note: As a workaround, use a Maximum Radiance higher than 1 W/srm2 to reduce the bias.

• ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

Note: As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

• ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.

• ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.
Note: As a workaround, freeze the transforms in the mesh properties.

Color Management

• ID 221439 (49244) - Windows only: With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

Note: As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

Command Line

• ID 289290 (49514) - macOS only: Running modo_cl before running the UI Modo application breaks code signing.

Note: As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.

File and Image I/O

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct imports (File > Import).

Note: As a workaround, before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don’t export some surface items, including static meshes and procedural shatter items.

• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances, unless the original mesh is also exported.
Note: To resolve this, set the .fbx preference to Export Selection and use Export As....

- ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

- ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.

- ID 346842 - Alembic import - Drag/drop doesn't import animation correctly.

Note: As a workaround, use File > Import.

Fur

- ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

Note: Use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices

- ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

Note: As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).

- ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

Note: To avoid this, plug in the tablet before application startup or restart.
MeshFusion

- ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

  Note: As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options will be supported.

Modeling

- ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.
- ID 408278 (60027) - Linear Falloff snaps to object size.

  Note: As a workaround, use the right mouse button for an interactive initial linear handle.

Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

  Note: As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).

- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.
**Note:** As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.

- ID 220955 (30318) - Network Rendering doesn't support Realflow particles.
- ID 226336 (25636) - Frame passes are not supported.
- Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

**Note:** As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.

### Nodal Shading

- ID 221393 (50642) - Nodal shading does not support UDIMs.
- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

### Painting/Sculpting

- ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.

**Note:** You can save and reload the image to force the update.

### Particles

- ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.
**Note:** To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

**Preview Render**

- If a high poly mesh is not visible, the Preview baking output will be incorrect.

**Note:** As a workaround, reset Preview to fix the baking.

**Procedurals**

- ID 305303 (56318) - Procedural duplication of Mesh Ops in a Deform folder creates errant Mesh Ops list.

- ID 305302 (56317) - Duplication of Procedurals does not work with the Select By Previous Operation tool.

**Note:** As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

- ID 266469 (54738) - A duplication of any item that is a Merge Meshes Source (For example, a Mesh Item, Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.

**Note:** As a workaround, remove the unwanted additional Merge Mesh Sources (regardless of the type of source) in the Mesh Ops List using the X icon in that list next to each Merge Meshes source.

- ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.
Note: As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

• ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

Note: You can use Preview or RayGL to visualize the variations from rigging.

• ID 388978 - Paving does not work when a Guide curve runs through a paving hole

References

• ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

Note: As a workaround, limit scenes with shading to one level of reference.

• ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.

• ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.

Note: As a workaround, first close and reopen the scene before attempting to revert the reference.

Rigging

• ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.

• ID 404238 - Bezier Curves don’t work correctly with the Curve Falloff.
Scripting

• ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

   Note: As a workarounds, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

• ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

   Note: To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer's Properties tab.

• ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.

• ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

Unreal and Unity Materials

• ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the Advanced viewport when used with bump maps and shadows.

UI

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.
• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some Mac OS/AMD configurations.

  **Note:** As a workaround, upgrade Mac OS to 10.13.

• ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

  **Note:** This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

  **Note:** If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

• ID 288714 (43162) (Windows only) - Setting a custom text size affects Modo’s text drawing.

  **Note:** As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

• ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

  **Note:** As a workaround, click the alt key.

• ID 388937 - macOS only: UI form field highlights can appear grey.

• ID 395884 - Mac only - Double-clicking bottom right corner or edge of popover doesn't resize back the popover correctly

**UVing**

• ID 440824 (60620) - Modo crashes when I click "Apply Overall" in the Texel Density Palette...
**Note:** As a workaround, deselect any Mesh item that does not have the specified (or currently selected) UV map.

### Viewports

- ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

**Note:** As a workaround, enable and then disable the visibility of the Shader Tree textures.

- RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.
- ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

**Note:** As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

- Windows only: Using Raptr can cause GL driver crashes in Modo.
- ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

**Note:** As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

- ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver bug and should be fixed by AMD in a future driver release.
- ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.
- ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.
**Note:** To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

- ID 408416 - Gradient (texture layer) renders incorrectly in the Advanced Viewport.

**Note:** As a workaround, use Preview.

- ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

**VR**

- ID 218386 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.