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Preface

Hiero, in conjunction with HieroPlayer, is designed to provide shot management, conform, and
playback capabilities for people creating visual effects, especially those using Foundry's Nuke
Compositor. Hiero combines well with Nuke to deliver visual effects sequences without resorting to
other third party applications.

Key Features

The following are key features supported by Hiero and HieroPlayer:

» Conform multi-track timelines from CMX 3600 Edit Decision Lists (EDLs), OTIO, Final Cut Pro XML,
and AAFs including cuts, transitions and retimes.

+ Soft import any image sequence type supported by Nuke, meaning the media is not copied multiple
times saving disk space. In addition, Hiero and HieroPlayer can also ingest audio and multi-channel
images.

* Playback clips and sequences in real-time (dependent on hardware) on 2-up source/record Viewers,
including multi-view or stereo footage.

* Version and snapshot clips and sequences to record progress and manage your creative options.
+ Add real-time GPU soft effects directly on the timeline before export.

* Round-trip through Nuke or export general purpose shots using soft exports in most cases - no
bakes are required.

+ Accomplish most tasks through Python scripting that you can with the Hiero and HieroPlayer user
interfaces.

About this Guide

Throughout this User Guide, we assume you have a basic knowledge of video and audio theory, as
well as proficiency with the operating system on which the application is installed.

For the most up-to-date information, please see the relevant product page and the latest User Guide
on our website at www.foundry.com.

Getting Help

If you can't find what you need in this document, there are other sources of help available to you for
all aspects of Hiero and its operation.

USER GUIDE
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Should questions arise that this help fails to address, you can contact Customer Support by visiting
support.foundry.com.

Most controls offer concise instructions in the form of tooltips. To display the tooltips, hover your
mouse pointer over an interface control or parameter.

Export Queue

colour 4 f/8 b SsSRGEB _ ¥l

N

Set the layer to display.

Hiero's Help menu includes links to the latest Release Notes and www.nukepedia.com, the online
knowledge base maintained by experienced Nuke users, containing downloads, tutorials, interviews

and more.

There is also a user forum at community.foundry.com/discuss/hiero, set up as a hub for users to ask
questions and share information.


https://support.foundry.com/
http://www.nukepedia.com/
https://community.foundry.com/discuss/hiero

Installation and Licensing

Installing and licensing new applications can be a boring task that you just want to be done with as
soon as possible. To help you with that, this chapter guides you to the point where you have a default
workspace in front of you and are ready to start viewing and editing your media with the minimum of
effort.

System Requirements

Before you do anything else, ensure that whichever platform you intend to run Hiero or HieroPlayer
on meets the minimum requirements listed in the release notes for your version of the application.
See the Hiero Release Notes page for more information.

Installing Hiero or HieroPlayer

Hiero and HieroPlayer are included in the Hiero application bundle, so you'll need to download the
required Hiero version from www.foundry.com/products/ by choosing the correct platform from the
list. For example, if you intend to install Hiero on Mac, download the Hiero .dmg file.

Follow the on-screen instructions to download the correct installer.

Mac

1. Double-click on the .dmg archive to extract the installation package.
Double-click on the .pkg file.

Follow the on-screen instructions to install the application. By default, Hiero (contained within the
Hiero bundle) is installed to:

/Applications/Nuke<version>

Linux

1. Extract the application from the .run archive with the following terminal command:
sudo ./Nuke<version>-linux-x86-release-64.run
The installer displays the End User Licensing Agreement (EULA) and prompts you to accept it.

2. If you agree with the EULA, enter y and press Enter to accept the EULA. (If you don't agree with the
EULA and press n instead, the installation is canceled.)

USER GUIDE
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The selected application is installed in an appropriately named folder in the current working
directory.

If you leave out sudo from the terminal command, you need to ensure that you have sufficient
permissions to install the application under your current working directory.

Note: After the application files have been installed, the installer also runs a post-installation
script that creates the following directory:

/usr/local/foundry/RLM

If you don't have sufficient permissions on the /usr/local folder for this directory to be
created, the post-installation script prompts you for your sudo password as necessary.

Windows

1. Download the .zip file from our website at https://www.foundry.com/products/nuke/download
and extract the contents.
In the extracted directory, you'll find an .msi executable and several .cab files, which are required
for installation on Windows.

2. Double-click on the .msi file to start the installation. Follow the on-screen instructions. By default,
the application is installed to:

C:\Program Files\Nuke<version>

Launching Hiero or HieroPlayer

Launch Hiero or HieroPlayer using one of the following methods, depending on which platform you're
using.

Mac

* Click the required dock icon.

+ Using the Finder, open the Hiero application directory (by default, /Applications/Nuke16.0v5/ and
double-click the required .app icon (or list item).

* Open a terminal and enter the following command:
/Applications/Nukel6.0v5/Nukel6.0v5.app/Contents/MacOS/Nukel6.0v5 —--hiero
OR

/BApplications/Nukel6.0v5/Nukel6.0v5.app/Contents/MacOS/Nukel6.0v5 —-player

USER GUIDE
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Linux

* Double-click the required icon on the Desktop.
* Open a terminal, navigate to the ~/Nuke16.0v5 directory and enter:

./Nukel6.0 —--hiero

OR

./Nukel6.0 --player

Note: The ~/ in the file path indicates the directory from which the installer was executed.

Windows

* Double-click the required icon on the Desktop.

+ Using a command prompt, navigate to the application directory (by default, \Program
Files\Nuke16.0v5 or \Program Files (x86)\Nuke16.0v5), and enter:

Nukel6.0.exe —--hiero

OR

Nukel6.0.exe --player

Hiero Analytics

In an effort to further improve quality and reliability, we ask you to allow us to collect usage statistics
from the machines on which you license Hiero and HieroPlayer. This usage information also assists
our Support team to resolve issues more quickly.

Note: The port number used to communicate with Foundry is 443, the same one used for
uploading crash reports.

The first time you start an application, and on every major release, a dialog displays asking for
permission for us to collect this information. You can enable or disable collection at any time in the
Preferences under Behaviors > Startup.

USER GUIDE
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Note: This information is only collected for interactive sessions. Running applications in
terminal mode or under render licenses does not upload data to Foundry.

The following list shows the information we'll collect, if you give us permission to do so:

* Unique session ID
* Application name

« If the session exited cleanly

* Operating system
* CPU Name

« Amount of GPU RAM

« Amount of RAM

Startup Options

* Anonymous user key * Application version string

* Session start time (GMT) * Session duration (in seconds)
* Peak memory usage * Model

* System OS version * MAC address

* CPU Cores * GPU model name

* OpenGL driver version * GPU driver version

* Memory speed

If you choose to launch the application from a command line, you can append arguments to the

command as follows:

Argument
--help (-h)
--version

--script

--player (Hiero only)

--log-file

--log-level

USER GUIDE

Result
Displays the available arguments with examples.
Displays version and copyright information.

Opens the specified script. For example:
./Hierol6.0v5 --hiero --script myscript.py

If the script resides in a different directory to the application,
specify the file path as well.

Launches Hiero in HieroPlayer mode.

Sets the location of any logfiles created. For example:
./Hierol6.0v5 --hiero --log-file /Desktop/log.txt

See to specify the logfile using an environment variable.

Sets the level of logging produced during operation. For example:

./Hierol6.0v5 --hiero --log-level warning

Log messages are output to screen unless you specify a

21



Argument

--quiet (-q)

--safe (-s)

--single-threaded-playback

Installation and Licensing |

Result

--log-file. There are four levels of detail, on a sliding scale from
minimal to verbose:

. error

« warning (default)
* message

* verbose

Note: Setting the logging level to verbose can produce
large log files when --log-file is specified.

See to set the log level using an environment variable.

Launch the application without displaying the splash screen or
startup dialog.

Launch the application without loading any plug-ins, Export presets,
and so on.

Launch the application in single-thread mode. This option can solve
playback issues on various Linux Fedora flavors.

On Windows, you can also use the same arguments on executables (or their shortcuts) by adding
them to the program’s Properties. To use a startup argument:

1. Right-click the C:\Program Files\Hiero16.0v5 icon or the equivalent icon on the Desktop.

2. Click Properties.

3. Append the required argument to the Target or .exe field.

USER GUIDE
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Licensing Foundry Applications

Foundry applications support two types of license, cloud-based login licensing and local RLM licensing.
Login licenses require an internet connection, but local RLM licenses are locked to a single machine or
license server and don't require an internet connection.

Login Licensing

Cloud-based login licensing provides quick and easy access to all your licenses regardless of which
machine you happen to be using. You can use your login license on any machine with internet access,
giving you the freedom to work anywhere.

Note: Local RLM licensing is available alongside login licensing. You are not obliged to switch
to the login-based model unless you're using an Indie or Non-Commercial license.

As well as Individual licenses, login licensing also supports Team licenses that give administrators
greater control over who uses the licenses available in the team pool. You can quickly invite a team of
artists to collaborate on a project with nothing more than their name and email address.

Individual Login licenses allow you to run Foundry applications on any machine using your Foundry
account email and password. There's no need to manually install a license, the application takes care
of all your license administration. If you don't have a Foundry account, you can create one by clicking
Sign up on this page: https://www.foundry.com/user/register

Once you have a Foundry account, you can request an Individual license for Foundry products:
« from Foundry's Sales Department at sales@foundry.com
« from the product pages on our website, such as https://www.foundry.com/products/nuke

* by launching a Foundry application without a license, selecting Try or Buy a License, and then
selecting:
* Try - opens a web browser directly to our website's 30-day trial license screen.
Enter your Foundry account details or create a new account and follow the on-screen
instructions to receive a trial license.

* Buy - opens a web browser directly to our website to purchase a license.

USER GUIDE
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After purchasing a license, download your Foundry application from
https://www.foundry.com/product-downloads

Note: If you were given an Activation Key, navigate to
https://www.foundry.com/licensing/activate-product, enter the key, and follow in the
onscreen instructions.

1. Launch your Foundry application as described in the Install Guide for your Foundry application
by operating system.

The Licensing dialog displays.

2. Select Login License to continue.

No License found for Nuke 14.0

Login License Local License Try or Buy a
Activate a Login License from Install an RLM Nodelocked Llcense
your Foundry account License, connect to a License

Server or use an Activation Key Request a Trial or purchase a

License for Nuke

Click here ta log-in to your
Foundry account.

CLOSE

3. If this is the first time you've logged in to a Foundry application on this machine, enter your
email address and Foundry account password, and then click Sign in.

You don't need to enter your Foundry account information again unless you log out of an
application.

4. Select the license you want to install from the list and click Install.


https://www.foundry.com/product-downloads
https://www.foundry.com/licensing/activate-product
https://learn.foundry.com/hiero/docs
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Select Individual Licenses to Install

I}) nukestudio_bundle 0.0-2023.0223 February 24 2023

View Account

< BACK

5. Click Done to close the Licensing dialog.

You can now use your Foundry application.

Note: A license is activated for a period of 37 days. Make sure that you connect to the
internet at least once during the activation period to extend your access. You can check the
activation period of your license in your Foundry application's Help menu.

An Individual license is active until you deactivate it or sign out of the Foundry Licensing application.
Deactivation means you can activate the license again without needing to enter your email address
and password.

Note: Individual licenses can be active on up to two machines concurrently. If you want to
activate a license on a third machine, you must return an active license first.
To deactivate a license:
1. Go to your application's Help menu and click Licenses.

2. The License Status dialog displays.
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License Status

PRODUCT LICENSE DAYS MAINTENANCE
TYPE REMAINING JAYS REMAININC
nuke_i Team Login * 10

*Individual Login Licenses are issued on & 30 day basis and will auto-renew when connected to the internat.

For more detziled licensing information about this machine please download the

CLOSE

3. Click Manage Login Licenses.

The Return Login Licenses dialog displays.

Return Login Licenses

nuke_i 2021.0811

MOTE: Logging cut of your account will return all licenses for Foundry products on this machine.

< BACK RETURN

4. Select the license you want to deactivate and then click Return,
OR

Click Logout to return all of the activated licenses on this machine and clear your login details.
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Tip: Returning a license allows you to activate it again without entering your Foundry
login details.

Team licenses also allow you to run Foundry applications using your Foundry account email and
password, but the license is tied to team entitlements within the cloud-based login licensing system,
rather than an individual's Foundry account. A license is taken from the pool of available licenses
when you launch your Foundry application and the license is returned automatically when you close
the application. Members of a team don't need to log-in and log-out to take and return licenses.

Team administrators can add and remove users from the team and control license access. See the
Foundry Licensing website for more information on Team license administration.

1. Launch your Foundry application as described in the Install Guide for your Foundry application
by operating system.

The Licensing dialog displays.

2. Select Login License to continue.

No License found for Nuke 14.0

re Information

Login License Local License Try or Buy a
Activate a Login License from Install an RLM Nodelocked License
your Foundry account License, connect to a License

Server or use an Activation Key Request a Trial or purchase a

License for Nuke

Click here to log-in to your
Foundry account.

CLOSE

3. Enter your Foundry account information and click Sign in.

You'll be asked to verify an activation code in a web browser.


https://learn.foundry.com/licensing/Content/cloud-licensing.html
https://learn.foundry.com/hiero/docs
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Activate device

You're activating Foundry Desktop Apps. Please
make sure the code below is the same as displayed
in the Foundry application's licensing window. Do
not accept the sign in request unless you initiated it

yourself.
Code
RCVJ-MPQX

Reject

4. Check that the code in the browser matches the code in the Licensing dialog and then click
Activate.

5. Select Team to access your team entitlements.

6. Click the entitlement from which you want to take a license and click Select.

——  Note: You can use any of the licenses in the selected entitlement, except those
reserved by your administrator. See Foundry Licensing for more information on
reserving licenses.
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Select the Team Entitlement to Use

Nuke Team (Company)

< BACK

Organisation: Nuke Team (Company)

PRODUCT ENTITLEMENT POOL SEATS

nukestudio_i Studio_Pool 25
hiero_i Common_Pool 25
hieroplayer i Common_Pool 25

nuke_ i Common_Pool 25
nuke_i Common_Pool 20
nuke_i Common_Pool 10

Common_Pool 25
aCc

VERSIC

2023
2023
2023
2023
2023
2023
2023

o T a'te Be 10
L4

7. Click Done to close the Licensing dialog.

You can now use your Foundry application.

Using a Different Team License or Logging Out

A Team license is active until you close your Foundry application, you don't need to return the license
manually. You can use a license from a different Team on the same machine or you can logout to stop

any licenses running on your machine.

To use a different Team license:

1. Go to your application's Help menu and click Licenses.

2. The License Status dialog displays.
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License Status

PRODUCT LICENSE DAYS MAINTENANCE
TYPE REMAINING JAYS REMAININ{
nuke_i Team Login * 10

*Individual Login Licenses are issued on & 30 day basis and will auto-renew when connected to the internet.

For more detailed licensing informatien about this machine please download the

X CLOSE

3. Click Add License and select Login License.

The Select the Team Entitlement to Use dialog displays.

Select the Team Entitlement to Use

Organisation: Nuke Team (Company)

Nuke T C
BREISS  (Cenesay) PRODUCT ENTITLEMENT FOOL

nukestudio_i Studio_Pool
hiero_i Common_Pool
hieroplayer i Common_Pool

nuke_ i Common_Pool
nuke_i Common_Pool
nuke_ i Common_Pool

Common_Pool

< BACK

4. Click the entitlement from which you want to take a license and click Select.
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Note: You can use any of the licenses in the selected entitlement, except those
reserved by your administrator. See Foundry Licensing for more information on
reserving licenses.

5. Click Done to close the Licensing dialog.
You can now use your Foundry application with the new Team license.

When you're finished working, close the application to automatically return the license to the
pool.

To logout, return all of the activated licenses on this machine and clear your login details:
1. Go to your application's Help menu and click License.

The License Status dialog displays.

License Status

PRODUCT LICENSE DAYS MAINTENANCE
TYPE REMAINING JAYS REMATNTNI

nuke_i Team Login * 10

*Individual Login Licenses are issued on & 30 day basis and will auto-renew when connected to the internet.

For more detziled licensing infermation about this machine please download the

CLOSE

2. Click Add License and then click Login License.

3. Click Team and then click Logout to return all of the activated licenses on this machine and clear
your login details.

Local RLM Licensing

Local licensing using RLM software does not required internet access and so it is well suited to
individuals that move around a lot and to site licensing where security considerations mean that there
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is no access to the internet.

Note: Local RLM licensing is available alongside login licensing. You are under no obligation
to switch to the login-based model unless you're using an Indie or Non-Commercial license.

The following local licensing methods are available:

* Activation Keys - activation keys allow you to generate your actual product license key, at a later
point after purchase, on the machine for which you require the license.

They are provided for both node locked and floating licenses, and generate the appropriate license
type once installed using the application's Licensing dialog. Go to the Activate a Product page to use
your Activation Key: https://www.foundry.com/licensing/activate-product

* Node Locked Licenses - these can be used to license an application on a single machine. They do
not work on different machines and if you need them to, you'll have to transfer your license.

Node locked licenses, sometimes called uncounted licenses, do not require additional licensing
software to be installed.

* Floating Licenses - also known as counted licenses, enable applications to work on any networked
client machine. The floating license is put on the server and is locked to a unique number on that
server.

Floating licenses on a server requires additional software to be installed on the server to manage the
licenses and give them out to the client stations that want them. This software is supplied as part of
the Foundry Licensing Utility can be downloaded at no extra cost from
https://www.foundry.com/licensing/tools

To obtain a local license, you'll need your machine's System ID (sometimes called the MAC address,
Host ID, or rimhostid). Just so you know what a System ID looks like, here’s an example:
000ea641d7al.

Note: For local floating licenses, you'll need the System ID of the license server, not the
machines on which you intend to run the application.

There are a number of ways you can find out your machine's System ID:

* Launch the application without a license, click Status, and then scroll down the error report until you
see your System ID.
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* Download the Foundry License Utility (FLU) from https://www.foundry.com/licensing/tools and run it.
Click System ID to display your computer's unique identifier.

When you know your System ID, you can request a local license for Foundry products:

« from Foundry's Sales Department at sales@foundry.com

« from the product pages on our website, such as https://www.foundry.com/products/nuke

* by launching the application without a license and selecting Try or Buy a License and then selecting:

* Try - opens a web browser directly to our website's 30-day trial license screen.
Enter your Foundry account details or create a new account and follow the on-screen
instructions to receive a trial license.

* Buy - opens a web browser directly to our website to purchase a license.

Note: By default, if you have installed a temporary license, the application displays a dialog
at start-up alerting you to the number of days remaining. If you want to disable this behavior,
you can set the FN_DISABLE_LICENSE_DIALOG environment variable to 1 to suppress the
warning message about imminent license expiration. See Environment Variables for more
information.

To use local license roaming you require a Roaming License. Licenses issued Before July 10th 2020 do
not support roaming. New roaming licenses will be issued to customers at Maintenance Renewal time.
If you are in Current Maintenance and would like to upgrade your licenses to take advantage of this
new feature, please submit a request using this form: https://www.foundry.com/nuke-roaming-license

See Local License Roaming for more information on roaming.

We recommend using the Foundry Licensing Utility to install local licenses, available from
https://www.foundry.com/licensing/tools free of charge. See
https://learn.foundry.com/licensing/Content/install.ntml for more information on installing licenses.

However, you can also install local licenses after starting a Foundry application.

When you start the application before installing a license, a Licensing dialog displays an error
informing you that no license was available. The installation process is dependent on what type of
license you requested:

* License file - if you requested a license file, typically foundry.lic, this option allows you to browse to
the file location and install it automatically. See To Install a Local License from Disk or Local License
Text for more information.
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* Activation Key or license text - if you requested an Activation Key or license by email, this option
allows you to paste the key or license text into the Licensing dialog, which then installs the license in
the correct directory. See To Install an Activation Key for more information.

* A floating license - also known as a server license. if you requested a server license to supply
licenses to multiple client machines, this option allows you to enter the server address that supplies
the client licenses.

Note: You must install a floating license and additional software on the license server to use
this option.

See To Use a Floating Server License for more information.

To Install a Local License from Disk or Local License Text

1. Save the license file to a known location on disk.
2. Launch your Foundry application.

The Licensing dialog displays.

w

Click Local License to display the available license installation options and then click License File.
4. Click Open File, browse to the location of the license file, and then click Open to install the
license automatically in the correct directory,

OR

Copy the license text, paste it over the Drag & Drop or paste license texta License here string,
and then click Install License.

License text typically looks something like this:

LICENSE foundry nuke i 2015.0929 29-sep-2015 uncounted hostid=000a957bfdeb
share=h min timeout=30 start=29-sep-2015 issued=29-sep-2015 disable=VM
ck=da32d7372f sig="60P0450MIJRPI7E3DP
B42C99Y5UAPRMEMGNQ39PG22HAWGH3WFK2KPTXFWITYROGYASIBXCOPUS"

The license is automatically installed on your machine in the correct directory.

To Install an Activation Key
1. Launch your Foundry application.

The Licensing dialog displays.

2. Click Local License to display the available license installation options.
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3. Click Activation Key and then enter the Activation Key string into the key field.

A license key typically looks something like this:
nuke-0101-77d3-990d-a977-93e9-8035

4. Click Activate Key.

The license is automatically installed on your machine in the correct directory.

Note: Activation Keys require an internet connection. If you access the internet
through a proxy server and cannot connect to the activation server, you may get an
error dialog prompting you to either:

Click Use Proxy to enter the proxy server name, port number, username, and
password. This enables the application to connect to the activation server and obtain a
license. The license is then installed automatically, or

Click on the web link in the dialog and use the System ID (also known as hostid)
provided to manually activate and install a license.

To Use a Floating Server License

If you requested a server license from Foundry, you receive your license key (foundry.lic) in an email

or download. You should also receive a link to the Foundry License Utility (FLU) application to help you

install the license key on the license server machine. The server manages licenses for the client
machines on your network.

To install a connection to your local license server:

1. Launch your Foundry application.

The Licensing dialog displays.

2. Click Local License to display the available license installation options.
3. Click Server and then enter the port and server name or IP address of the license server.

The format for the server name is: <port>@<servername>, for example, 30001@red.
4. Click Connect.

Note: You must perform these steps on each client machine that requires a license
from the server. The client machines do not need the server tools installed.
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License roaming allows you to temporarily check out a server license so you can work offline. Licenses
are checked out and returned through the Help > License menu or by setting environment variables.

Note: License Roaming is not currently supported by Katana and Mari or with Production
Collective and EDU Collective licenses.

There are a few important things to take into consideration with license roaming:

* Roaming is only available to Maintenance customers and requires a new license from Foundry.
* Roaming and returning licenses requires a connection to the license server.

* Roamed licenses are valid for a maximum of 30 days.

* Roamed licenses are only valid on the machine that took the license from the server.

* The number of roaming licenses available on the server decreases by one until you return the
license.

Installing the Local Roaming License

To activate roaming licenses you need to request a new roaming license and install the license on
your license server.

See Licensing Foundry Applications and To Use a Floating Server License for more details on
requesting and installing a server license.

How to Roam a Local License

1. Launch the application you want to roam, making sure it has a connection to your license
server.
2. Goto Help > License.

The Licensing dialog displays.
3. Click Manage Roaming.

The Roam Licenses panel displays.
4. Enter the number of days you want the roamed license to last, from 1 to 30 days.
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Note: The maximum number of roam days may be less than 30 depending on your
license.

Roam Licenses

License Roaming allows you to check out a Floating License from the Server for a number of days.
‘You can then take the machine off the network and keep running Nuke.

If you want to return the Roamed License early you will need to reconnect to the License Server's
network first.

Please see roaming for More Information.

Enter the Number of Days to Roam for: lIEM Days

< BACK HOAN LICERSES

5. Click Roam Licenses.

The panel displays the number of roaming days remaining.
6. Click Close.

How to Return a Roamed Local License

1. Launch the application using the roamed license, making sure it has a connection to your license

server.
2. Goto Help > License.

The Licensing dialog displays the license type and number of roam days remaining.
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License Status

PRODUCT

LICENSE DAYS MAINTENANCE
TYPE REMAINING MAYS REMAININt
nuke_i Roaming 5 141

For more detziled licensing infermation about this machine please download the

Manage Roaming

X CLOSE ADD LICENEE

3. Click Manage Roaming.
4. Click Return Roam.
5. Exit the application to return the roaming license to the server.

You can automate some of the aspects of roaming licensing using the RLM_ROAM environment
variable supplied by Reprise Software, the third-party vendor of our licensing administration software.

For more information see How to use Roaming Licenses in the RLM Administration Guide:
https://www.reprisesoftware.com/RLM_License_Administration.pdf

Further Reading on Licensing

There is a lot to learn about licenses, much of which is beyond the scope of this manual. For more
information on cloud-based login licensing and local RLM licensing, go to our Licensing website:
https://learn.foundry.com/licensing/

Uninstalling Hiero or HieroPlayer

To uninstall Hiero or HieroPlayer, following the instructions below, depending on what platform
you're running.

1. Navigate to Applications and delete the Hiero 16.0v5 folder.
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2. Delete, rename, or move your .nuke folder, if it exists.
The .nuke folder is found in your home directory, by default:

/Users/<login name>/.nuke

Note: The .nuke folder may be a hidden folder on your machine. To allow your Mac to
display hidden files and folders, type the following command in the Terminal application,

press Return, and then relaunch the Finder application:
defaults write com.apple.finder AppleShowAllFiles YES

3. Delete, rename, or move your cached files, which reside in the following directory by default:
/var/tmp/nuke

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location. See Hiero Environment Variables
for more information.

Linux

1. Navigate to /usr/local/ and delete the Hiero 16.0v5 folder.
2. Delete, rename, or move your .nuke folder, if it exists.
The .nuke folder is found in your home directory, by default:
/home/<login name>/.nuke

3. Delete, rename, or move your cached files, which reside in the following directory by default:
/var/tmp/nuke

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location. See Hiero Environment Variables
for more information.

Windows

1. Navigate to the install directory for the required version. By default, the application is installed
to:
C:\Program Files\Nukel6.0v5

2. Double-click uninstall.bat.
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The Uninstall dialog displays.
. Click Yes to uninstall.

Tip: You can also uninstall silently, with no prompts or popups, by running the

Command Prompt as an Administrator and entering:
"C:\Program Files\Hierol6.0v5\uninstall.bat" /passive

. Delete, rename, or move your .nuke directory, if it exists.

The .nuke directory is usually found under the directory pointed to by the HOME environment
variable. If this variable is not set (which is common), the directory is under the directory
specified by the USERPROFILE environment variable, which is generally one of the following:
C:\Documents and Settings\login name)\

C:\Users\login name\

To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer. If the
environment variable is set, the folder it's pointing at is opened. If it's not set, you get an error.

. Delete, rename, or move your cached files, which reside in the following directory by default:
~\AppData\Local\Temp\nuke\

Where ~ is equal to %HOME% or %USERPROFILE% as detailed above.

Note: If you specified an alternate directory using the NUKE_TEMP_DIR environment
variable, purge those files as well as the default location.

. Remove any application-related environment variables. See Environment Variables for more
information.
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Hiero and HieroPlayer Workflow

This section describes the main differences between Hiero and HieroPlayer, and an example
collaborative workflow using Nuke.

Hiero

In a typical collaborative project environment, Hiero sits in between edit and grading, and finishing
and delivery, acting as a hub for visual effects. It is used to locate, preview, and then farm media out
to shot-based effects applications (such as Nuke), and take their results and re-integrate them into the
sequences for review and comment.

HieroPlayer

HieroPlayer sits next to your compositing and other shot creation software, allowing artists to view
their work in the context of a timeline. This collaborative workflow allows multiple artists to work on
the same timeline, viewing colleague’s work as well as their own. See Collaborative Project Case Study
for more information.

HieroPlayer is a free annual subscription with your Nuke or NukeX license. Simply renew your existing
Nuke or NukeX license to receive your HieroPlayer entitlement or fill in the on-demand form.

See HieroPlayer Free with Nuke for more information.
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Feature Comparison

Designed to work hand-in-hand in different scenarios, Hiero and HieroPlayer share a number of
features, but as the hub, Hiero has a richer feature set than HieroPlayer.
Feature Hiero HieroPlayer
Review and Playback - Robust playback & review engine for post production

Multi-track timeline viewing and editorial workspace, including
industry standard tools

Nuke equivalent format support including OpenColorlO
management

Multi-channel audio import and playback

Extensive review toolset including A/B compare, masks, and
color picker

Realtime image scopes including histogram, waveform, and
vector

Media localization and caching
Standard jog and shuttle controls
Track Blending for merging of tracks on the timeline

Annotations in the Viewer and exports for reviewing work in
collaborative projects

Broadcast Monitor support

Editing - Standard tools and layouts for editorial.

Modal editorial tools including equivalent keyboard hotkey
interface

Source/record 2-up Viewer workspace and 3-point editing
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Feature Hiero HieroPlayer
Conform - Simple and flexible ingest of cuts from editorial.

Conform multi-track timelines from CMX 3600 Edit Decision
Lists (EDLs), OTIO, Final Cut Pro XML, and AAFs including cuts,
transitions and retimes

Session-wide spreadsheet containing all sequence events

Shot Management and Export - Manage, distribute and ingest media with ease

Export sequences, timeline shot structures, clip hierarchies,
and EDL/OTIO/XMLs

Soft Effects directly on the timeline, such as Crop, LUT, and
Transform.

Transcode, copy, and soft link media

Create template Nuke scripts for easy distribution of work
Automatically update VFX shots in context

Version shots and snapshot timelines for review and editing
Hierarchical project and element library management

Tag shots, frames, and sequences for easy filtering of content
including custom metadata

Open and Scriptable Playback Framework - Flexible enough to fit any pipeline

Extensive Python API to accomplish most tasks through Python
scripting that you can with the Hiero and HieroPlayer user
interfaces

Integrated Pyside enabling fine-grained customization of
interface tasks
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Collaborative Project Case Study

Hiero can work effectively as the hub for managing content in a post pipeline. The diagram below
shows a typical workgroup scenario, with Hiero and Nuke at the top as the hub managing a number of

Nuke workstations employing HieroPlayer as a review tool.

@G)

A
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Preparing a Project in Hiero

The first step in Hiero is to conform the EDL, OTIO, or XML from the editor. The conform process pulls
together the required source clips and matches them to events in the EDL, OTIO, or XML. Hiero
displays these events in a spreadsheet which is linked to a timeline showing the corresponding shots.
See Conforming Using Hiero for more information.

Once the conform is complete, you can view your timeline to confirm that the correct clips are
present, check the content using Hiero's scopes, add reference tracks, and pass on any pertinent
information to the next step in production using tags and notes. See Ingesting Media for more
information.

The next step is to make any minor edits to the timeline, including transitions and retimes, swap or
rename shots, or examine different versions of clips on the timeline. See Managing Timelines and
Versions and Snapshots for more information.

The final step before HieroPlayer steps in is to export and save your project. Exporting from Hiero and
saving the project creates placemarker shots for VFEX work in a read-only Hiero project (.hrox file),
preserving the conform work from Hiero. Multiple artists can then work on shots, creating versions
which are then automatically updated in HieroPlayer. See Round-Tripping Using the Export Dialog for
more information.
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Loading a Hiero Project in
HieroPlayer

HieroPlayer is most commonly used to open Hiero projects as read-only copies to preserve conform
work from Hiero. This way, multiple artists can work on a project without worrying about overwriting a
colleagues work.

To open a Hiero project in read-only form:
1. Launch HieroPlayer and navigate to File > Open.

Tip: You may find that the project you require is displayed in the startup dialog under
Recent Projects.
Select the project and click Open to quickly access the project.

2. Locate the required Hiero project using the browser and click Open.
A warning displays informing you that the project is read-only, as it was created in Hiero.

This project was created by MukeStudio. Some existing items on the timeline are locked.

oK Don't show this dialog again

3. Click OK to dismiss the prompt.

Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to
indicate that the project is read-only.

You can't delete bins, clips, or shots, or make edits on the timeline when the highlight is light blue.
You can, however, drag source clips on to new tracks on the timeline.
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5. To save your work, navigate to File > Save as Player Project. HieroPlayer cannot overwrite Hiero
projects.

Opening a Writable Hiero Project

If you want to open a writable version of a Hiero project, you can open the project and save it as a
HieroPlayer project. HieroPlayer projects are always readable in Hiero, so don't worry about backward
compatibility.

To open a Hiero project in writable form:
1. Launch HieroPlayer and navigate to File > Open.

Tip: You may find that the project you require is displayed in the startup dialog under
Recent Projects.
Select the project and click Open to quickly access the project.

2. Locate the required Hiero project using the browser and click Open.

A warning displays informing you that the project is read-only, as it was created in Hiero.

This project was created by MukeStudio. Some existing items on the timeline are locked.

iz dialog again

3. Click OK to dismiss the prompt.

Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to
indicate that the project is read-only.

You can't delete bins, source clips, or shots or make edits on the timeline when the highlight is
light blue.

Navigate to File > Save as Player Project and select a save location.

The highlight color changes to orange to indicate that the project is now writable.
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Customizing Your Workspace

The application interfaces are customizable using floating panes and show/hide functionality, but
several default workspaces are supplied for your convenience.

Workspace Overview

Hiero and HieroPlayer ship with a number of different workspaces. These are specific layouts that can
be loaded as the current tasks change.

Hiero ships with the following workspaces:

* Hiero’s Conforming workspace is where the bulk of the work you undertake with Hiero is done. The
linked spreadsheet and timeline panes are where you'll really see the power of Hiero.

* The Editing workspace provides the tools you'll need to fine-tune your media in Hiero, including 2-up
source/record Viewers.

* The Reviewing workspace is shared by both applications and is used to confirm your media intent is
fully realized. You can add tags and notes, mark In and Out points on clips and timelines, and
organize your ingested media into bins as required.

* The Timeline workspace is similar to the Conforming workspace, but doesn't include the
spreadsheet pane.

HieroPlayer ships with the following workspaces:

* The Editing workspace provides the tools you'll need to fine-tune your media, including 2-up
source/record Viewers.

* The Reviewing workspace is shared by both applications and is used to confirm your media intent is
fully realized. You can add tags and notes, mark In and Out points on clips and timelines, and
organize your ingested media into bins as required.

* The Timeline workspace is similar to the Editing workspace, but only include a single source Viewer.

Note: HieroPlayer doesn't include any Conform functionality and projects loaded from Hiero
can't be edited unless they're resaved using File > Save as Player Project.

When you launch either application, you're presented with a startup dialog.
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Recent Projects

Start @ mew Project...

Open a Project. ..

Read the User Guide

Visit the Hiero Web Site

Dion't show this dialog again

The startup dialog allows you to create a new project, open an existing project, or view the User Guide
and website dedicated to Hiero.

Tip: You can disable this dialog by checking Don’t show this dialog again or by toggling it
off in the dialog.

Select the required option or click Close to access the application. Take a moment to familiarize
yourself with the default workspaces.

Hiero's default Conforming workspace: HieroPlayer's default Timeline workspace:

Menu Bar Menu Bar

Project 3 ’ ‘ Project
Tab Tab
Timeline . — Timeline '
Editing Editing
Tools Tools
Feature Description Hiero HieroPlayer
Project Tab You can manage all aspects of your projects and bins

in the Project tab.
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Feature Description Hiero HieroPlayer

Menu Bar Use the Menu bar to access Hiero's dropdown ] o
menus.

Bin View The Bin displays the contents of any selected Project o o
tab.

Viewer You can display and review your media in the Viewer. o ®

Timeline Info  The timeline info displays the current timeline’s L ] L ]

sequence, media, and metadata information.

Editing Tools  There is a comprehensive set of editing tools o o
provided in Hiero and HieroPlayer. See Timeline
Editing Tools for more information.

Spreadsheet  Use the Spreadsheet tab to display the contents of o
Tab the timeline in spreadsheet form. Note that the

spreadsheet and timeline are linked, mirroring any

selections made.

Timeline The timeline displays the current track including all o o
shots and any effects that have been added.

Menu Bar Components

The Menu Bar contains various controls, many of which are available through right-click menus,
keyboard shortcuts, and toolbars.

For a full list of keyboard shortcuts, buttons, and menu functions, seeAppendix B: Keyboard Shortcuts.

You can switch between workspaces by navigating to Workspace and selecting Conforming, Editing,
Reviewing, or Timeline. Alternatively, you can toggle between the default workspaces using Shift+F1,
Shift+F2, Shift+F3, and so on.

Any custom workspaces you create are added to the end of the list. You can access the first custom
workspace using Shift+F5, and so on.
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Creating Your Own Workspace

Hiero's interface is comprised of any number of panels. Panels act like containers with different tabs;
you can configure panels to contain specific tools, such as the timeline or a Viewer, depending on the
task you are presently performing. The default panel configurations are saved as Workspaces
(referred to as Layouts in Nuke) and include: Conforming, Editing, Reviewing, and Timeline. You can
easily create your own custom workspace that suits your needs, and then save it as a custom
Workspace for easy recall.

During the customization process, you can:

* Resize your entire workspace or panes independently.

* Split panes to create new work areas, for example two Viewers side-by-side.
* Add and remove panes and tabs as required.

* Float and nest tabs to group similar functions together, for example Histogram, Vector, and
Waveform in the same pane.

* Maximize the pane under the mouse cursor by pressing ~ (back tick). Press ~ again to return to the
regular interface.

You can create as many workspaces as you require, one for each project you undertake if necessary.
In practice though, you may find that two or three custom workspaces are sufficient.

Tip: You can return to the saved version of a workspace by navigating to Workspace >
Reset Workspace.

Resizing Your Workspace

Resizing the interface, panes, and tabs works in much the same way as other software applications:

* To resize the entire interface, drag the resize handle at the bottom right of the application to the
required width and height.

* To resize individual panes, hover the mouse over the edges of the required area until the cursor
changes to the resize icon. Click and drag the cursor to resize the pane or tab.

Ui
Splitting Panes

Splitting panes allows you to organize your workspace into distinct areas delineated by well-defined
borders.

* To split panes, right-click the required pane and select Split Vertical or Split Horizontal.
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O Viewer

- Split Vertical
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Float Pane

!

Close Pane

Float Tab

Close Tab
X Show Tabs

Windows

Adding and removing tabs gives you the freedom to personalize your workspace depending on your
current project.

* Add new tabs by:

+ Navigating to Window and selecting the required tab. The tab is embedded in its default position
or added to the interface as a floating window,

OR

* Right-clicking the pane in which you want the tab to appear and selecting it from the Windows
dropdown.

* Close any tab that is not required by:
* Clicking the x on the tab’s right-hand side,
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f}‘ B Tags

8] Untitled 1(0)]

OR
* Right-clicking the tab name and selecting Close Pane or Close Tab.

B Project B Tea-
mm Split Vertical
I Split Horizontal
| &) untit Float Pane
Close Pane

Float Tab

f Tabs

Windows

Floating and Nesting

You can move existing panes and tabs to new locations in the interface (to help you organize your
project).
* Float a pane or tab by:

* Right-clicking the tab name and selecting Float Pane or Float Tab.

a .

Split Vertical
5plit Horizontal
Float Pane

Close Pane

Show Tabs

Windows

OR
* Dragging the required tab from its current location.
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Tip: Use the orange highlight Bl around the destination pane to help you determine
where the tab nests.
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Saving Workspaces

Once you're happy with the changes you've made to the workspace, navigate to Workspace > Save
Workspace....

Enter a name for the workspace, then click OK to preserve your workspace as a workspace file
(extension .xml).

@ Save Workspace: ¥

Workspace name: Shortcut key:

New Workspace Name) _J Shift+F5 [ Free |

Workspaces are saved in your .nuke file under Workspaces > Hiero or HieroPlayer, depending on
which application you are using.

Tip: If you save a workspace called Conforming, Editing, Reviewing, Sync Session,
Timeline, or Viewer Monitor Out, you can override the defaults supplied with either
application by clicking Save in the dialog box.

Delete the workspace you created to restore the default layout. Go to Workspaces > Delete
Workspace... and select the workspace to delete from the dropdown.

USER GUIDE

56



Loading Workspaces |

Loading Workspaces

To use a previously saved workspace, navigate to Workspace and select the custom workspace name
you require.

Tip: Alternatively, you can use the workspace keyboard shortcut Ctrl/Cmd+n (where n is
equal to the number of the custom workspace).

Your pre-saved workspace is loaded.

Deleting Workspaces

You may find that after using Hiero or HieroPlayer on a number of projects, some of the workspaces
you created earlier have been superceded by more useful entries. Delete Workspace allows you to
clear up your saved files, although you can remove the files manually from the save location.

To delete custom workspaces:
1. Navigate to Workspace > Delete Workspace.
2. Select the required workspace from the dropdown menu.

‘ann Delete Workspace:

ace o delete

3. Click OK to delete the selected entry.

Workspace Preferences

The Preferences dialog allows you to make global changes to the way the interface behaves every
time you start Hiero or HieroPlayer. Changes you make in the Preferences override any local changes
when you restart the application. See Appendix A: Preferences

Note: Workspace Preferences are saved in the ~/.nuke/uistate.ini file.

To access the Preferences dialog, either:
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* Navigate to Hiero (HieroPlayer) > Preferences (OS X) or Edit > Preferences (Linux and Windows),
or

* Use the Preferences hotkeys Shift+S.

Once you've made your selections in the Preference dialog, click OK to save your changes. Bear in
mind that changing some preferences, for example Scopes, require you to restart Hiero before they're
applied.

Note: Click Restore Defaults to return to the default Preference settings.

Optimizing Read and Decode Performance

The Performance preferences enable you to get the best the results from the hardware you're using
by specifying the number of “threads” used for reading and decoding media.

A thread is, at its most basic level, a series of operations (in this case reading and decoding frames)
that operates concurrently with other sets of operations. Most media is read intensive, but highly
compressed formats like .jpg are decode intensive. Increasing the number of threads can decrease
the time it takes to perform an instruction. For example, decoding a .dpx file using 2 threads, instead
of 1, decodes 2 frames in parallel.

Hiero defaults to 4 threads per reader, but as a general rule of thumb, you shouldn't increase the
number of threads above the number of cores in your machine.

You can override the Default number of threads per reader on a format-by-format basis using the
override table in the Preferences.

1. Click the icon to add an entry to the table.
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2. Inthe Extension column, click the dropdown to select the file extension to override.

3. Enter the Number of threads to use for the selected format.

For example, .jpg files rely heavily on decoding so an override setting between 6 and 8 is
recommended. Setting the default threads per helper to 6 is not advisable, except on high
specification hardware.

4. Click OK to close the Preferences and apply the setting immediately, there is no need to restart
the application, so feel free to experiment to achieve the best combination for your setup.

Hiero and HieroPlayer also include two additional helper thread settings dedicated to OpenEXR and
ARRI files. These helper threads assist the reader threads to improve performance for .exr and .ari
files.

You can change the number of available helpers using the up and down arrows, or by simply entering
the number of required helpers in the fields provided under Preferences > Performance >
Threads/Processes.

In general, the default setting 0 should automatically assign helper threads correctly. If, however, your
project is .exr/.ari heavy you might consider increasing the number of helper threads.

Note: The application must be restarted to apply changes to the ARRI helper setting.

The Viewer Image Quality dropdown affects the decode rate and resolution of clips displayed in the
Viewer. Lower resolutions decode faster and vice versa.

You can customize this behavior by bit-depth using the Preferences > Performance >
Threads/Processes > Downsize filtering controls.
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Ingesting Media

Hiero handles many file formats, including embedded audio and .wav files. For a full list of supported
file formats, see Appendix C: Supported File and Camera Formats.

About Clips and Shots

The interface sorts your clips into three broad categories: Audio and Video, Audio Only, and Video
Only. Clips are displayed differently depending on their content, location, and in the case of the
Viewer, the current mode.

Note: The timeline Viewer currently treats all alpha channels as premultiplied, which can
result in the Viewer background being "added" to the image. If you're working with un-
premultiplied images, set the Viewer background to Black.

Note: There is currently no QuickTime audio support on Linux. Support for audio is
scheduled for a later release.

Source clips are representations of files on disk. Shots on the timeline refer to source clips, so making
changes to a clip in a bin affects all shots that refer to that source clip.
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Audio and video Video only Audio only

Note: The colored bars under the thumbnail represent the layers available in the clip, in this
case color. Other layers include alpha, depth, and motion, similar to Nuke.

Shots are representations of source clips, they are not saved on disk. Making changes to a shot only
affects that instance. See Managing Timelines for more information.

Audio and Video Audio Only Video Only

Opening a source clip in the timeline view allows you to control its output and add soft effects to the
source clip. Clips opened as timelines always contain all available frames, but you can adjust their
output using the original range controls in the clip's properties or in and out points. See Using In and
Out Markers and Adding Effects on the Timeline for more information.
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AD16C006_101031_L

2:01

AD16C006_ 101031 L1023
s |

Purple Background
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Clip and Shot Properties

The Properties contain standard controls similar to Hiero's Read node Properties and format-specific
controls, depending on the selected source clip or shot. You can also control localization for individual
clips and shots using the Localization Policy dropdown.

See Localizing Media for more information on localization.

If the clip Properties are not displayed in your workspace, double-click a source clip or shot or
navigate to Window > Properties to open them in a floating window.

Note: The Properties panel allows you to override the Preferences and Project Settings
on a per file basis. See Appendix A: Preferences and Project Settings for more information.

As an example, some .mov files allow you to control the YCbCr matrix and Data Range for clips, as
well as the standard controls available for all clips. R3D and ARRIRAW media use their own software
development kits (SDKs) to control the extensive settings usually seen on RED and ARRIRAW Cameras.

Note: The RED Decode Resolution and ARRIRAW Resolution and Proxy dropdowns control
the maximum allowed Viewer resolution, overriding the Viewer Image Quality setting.

MOV Options
rix  default (R

Diata Range default (Full Range) =

Do not attach prefic ¥ Match key format

264

In addition, source clip properties are accessible through the same Python API as Hiero, improving
scripting capabilities and integration into existing pipelines.

Setting Clip Frame Rates

You can change a clip's frame rate, or frames per second (FPS), from the Project bin. This allows you to
set or change the FPS of clips before adding them to a sequence in case the clip's FPS is set incorrectly
or badly defined in the file's metadata. You can set a single clip's FPS or multiple selections
simultaneously.
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To set a clip's frame rate:
1. Select the target clip or clips in the Project bin.
2. Right-click a selected clip and navigate to Clip > Set Frame Rate.

3. Select the required frame rate from the menu.

The selected clip or clips are updated to playback at the chosen FPS.

Note: Changing a clip's frame rate does not change the FPS of related shots in a
sequence. This is because a shot's FPS is set by the sequence Frame Rate control and
does not rely on the source clip's frame rate.

Setting Source Clip Ranges

The original range controls in the source clip/shot Properties panel allows you to set the output
range for source clips when you add them to a sequence as shots. The entire frame range of the clip is
read on import, but altering the original range changes the output of the shot on the timeline.
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Note: You can reset source clip to its original frame range at any time by clicking rescan.
Rescanning also appends new frames as they become available.

Changing the original range affects source clips and shots differently. Opening a source clip in the
Viewer, or in the right-click Timeline View, and adjusting the original range limits or extends the clip

to that range of frames.

Extending the range past the original range adds handles, shown in red.

3001 \ f'.}.'.............................................|.....................

3001 3051

drone.cami

Video 1

Adjusting the original range changes the output of any existing shots, but still allows you to trim and
slip the shot range using the available handles. New shots pick up the new original range specified in

the Properties.

-
Il 00:=00:00 01:00:02:00 01:00:04:00 01:00:06:00

C005_001_2110_05 (C005_001_3110_05)

Existing Shot

—_
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Using Relative Paths to Media

Nuke Studio's timeline Read nodes support relative paths in the file control, allowing you to import
media relative to a specific project directory. The Project Settings control this behavior for the
current project.

Tip: If you want to set the project path for all new projects, navigate to the Preferences
under Project Defaults > General and set the project directory there.

To set a Read file path to a relative location:
1. Open the Project Settings by clicking Project > Edit Settings.

2. Enter the required file path in the Project Directory field.

Tip: Click Hrox Directory to automatically enter an expression that evaluates to the
.hrox location.

3. Double-click the required source clip or shot to display its Properties.

4. In the file field, adjust the path to the relative location of the .hrox project file. For example, if
the project directory and absolute path to the source clip are:
C:/projects/timeline read/scripts/
C:/projects/timeline read/footage/renders/shot110/A009C005 101029
L103.%04d.dpx

Then the relative path to the clip is:
./../footage/renders/shot110/A009C005 101029 L103.%04d.dpx
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Ingesting Media

Adding media is as simple as drag-and-drop from a file browser or selecting File > Import File(s) or
Import Folder(s). The application imports your media into the bin view providing you with a
thumbnail of all of your clips and preserving the original folder and file hierarchy.

The media is soft imported, creating symbolic links to locations on disk. See Using the Copy Exporter
for information on how to quickly consolidate your media and projects, or Localizing Media to help
stabilize playback.

Note: Projects containing large amounts of movie files (for example .r3d and .mov) may
exceed the number of available file handles per process, causing problems opening new files
or projects and exporting.

You can increase the default limit of 1024 by entering the following command from the

terminal, then running the application from the same session:
ulimit -Sn 2048

Clips with no inherent frame rate information are assigned a frame rate at ingest as specified in the
Preferences.

1. Open the Preferences dialog by pressing Shift+S.

2. Select Behaviors > Timecode from the sub-menu on the left.

R30 file timecode Default From File =

Management

other media timecode File Header -
valid timebase 10000 - fps
EDL style spreadsheet tim

- Panels

3. Use the RED file timecode dropdown to determine R3D clip behavior:
* Default from File - use the default set by the R3D file in question.
+ Absolute Timecode - force the use of the Absolute Timecode as specified in the clip metadata.
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- Edge Timecode - force the use of the Edge Timecode as specified in the clip metadata.
Use the other media timecode dropdown to determine clip behavior for all other clips:

* File Header - the file metadata header is used to derive the timecode, if it exists. This option
defaults to Frame Number if the header is missing.

* Frame Number - ignores the metadata header, even when present, and derives the timecode
from the frames in the clip.

Set the max valid timebase allowed from the image header, above which the value is clamped.

Image files are often created with application specific timebase values in the header description.
This can lead to reading in spuriously high frame rates, and the clamp aims to prevent this from
happening.

If your clips do have extremely high frame rates, increase this value as necessary to avoid
clamping.

Enable or disable EDL style spreadsheet timecodes:

* When disabled, the srcOut and dstOut values use the film convention, representing the last
frame of the cut.

* When enabled, the srcOut and dstOut values use the video convention, representing the frame
directly after the cut.

Click OK to save your settings.
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Using Drag-and-Drop

Locate your media in a file browser and drag the frame range, clip, folder, or folders into the Project
tab.

Ingest behavior depends on the target:

* Dragging a folder into the Project tab automatically ingests all the contents of the folder, including
other folders and their contents.

+ Dragging a movie file, such as a .mov or .r3d, automatically ingests the entire clip.

* Dragging a single file or file range, that is part of an image sequence, is controlled by the
Preferences > Behaviors > File Handling > Scan for file sequence range checkbox:

 Enabled - the default setting, dragging a single file or file range, that is part of an image
sequence, creates a clip in the bin view containing all available frames.

For example, dragging frames 1-5 and 11-20 ingests the entire frame range.
* Disabled - only the dragged frame or range is imported into the bin.

For example, dragging frames 1-5 and 11-20 ingests two distinct clips, one containing 5 frames
and one containing 10 frames.
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Using the File Browser

If you prefer to work with menus, you can also import clips using the file browser. You can import
individual clip files, ranges, or entire folders, depending on the amount of media you intend to use.

Whenever you load or save files, a browser similar to the one shown below is displayed. The directory
navigation buttons let you create or access the directory from which you wish to read or write data.

navigation
controls

The navigation controls let you move through the directory structure, bookmark favorite directories,
and create new directory folders.

Note: If you import folders, use the Import Options dialog to filter your ingest using
inclusion and exclusion parameters, separated by spaces. The dialog's Include patterns
field defaults to {supportedfiles}, which resolves to a list of all known supported file
extensions. To add your own custom extensions to this, you can use {supportedfiles} *.ext
(replacing .ext with your custom file extension).

Windows only: You can show/hide the drives that Windows auto creates by right-clicking the required
drive, selecting ShowDefaults, and checking or unchecking the drive.
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To Use the Navigation Controls

* Click the Create New Directory button m to create a new directory at your current position in the
file hierarchy.

* Click Up one directoryn to go up one directory closer to the root.
* Click Previous directoryn to go back one directory.

* Click Next directoryu to go forward one directory.

* Click the + button to add a directory bookmark.

* Click the edit button to edit the name or path name to a bookmark.
* Click the - button to remove a directory bookmark.

Path Name Field

The path name field displays the current directory path, lets you navigate to a new path, and also
enter a file name for scripts and rendered images.

C:fFootage/

X =equences zplit seq Filter:

* To navigate to a directory, type the path name in the field.
* To enter a script name, browse to a directory path and enter the file name after the displayed path.
* To limit the file list to specific file types, use the filter dropdown menu and Sequences checkbox.

USER GUIDE
72



Using the File Browser |

To Use the Filter Dropdown Menu and Sequences
Checkbox

* Select *.nk to display only Nuke script files.

* Select * to display all files (except hidden files), regardless of what they're associated with.
* Select .* * to display all files, including hidden files.

* Select */ to display directory names, but not their contents.

* Check sequences to display image sequences as single titles, as in fgelement.####.cin 1-50 rather
than fgelement.0001.cin, fgelement.0002.cin, fgelement. 0003.cin, and so on.

Note: File sequences with no file extension (for example, fgelement.0001, fgelement.0002,
fgelement.0003, and so on) are not displayed as single titles the first time you view the
directory in the File Browser. However, they are displayed as single titles once you have
navigated to another directory and back again.

* You can also split incomplete sequences into separate Read nodes using the split seq checkbox.

To Preview Files in the File Browser

1. Click the black arrow in the top-right corner of the file browser.

# * &« &

Home MName
DPX/f
ent EXR/
Mulke FBX/
fisheye/
PG/

The file browser expands to include a small viewer.

2. Select the file you want to preview in the file browser to view it.
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C:/Footage/DPX/nissan/Shot0100/Nuke/Renders/
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920x1080 Frame 0 of 0 to 31

To Select Multiple Files with the File Browser

Browse to the folder where the files are located.
Ctrl+click on all the files you want to open to select them (Mac users Cmd-+click).

You can open files from multiple directories by clicking Next and browsing to the next file location.

A w N -

Click Open.
All the selected files open.
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Sorting and Searching Media

Nuke Studio's Project panel includes several sorting and searching methods so you can organize,
manage, and navigate through media more easily. You can sort items alphabetically, by type, or
manually and select the appearance of media within bins. The search functionality allows you to enter
strings and apply searches on all or partial matches. You can control the poster frame displayed by
items in the project, selecting either an absolute or relative frame.

You can also color-code items in the Project panel and timeline to quickly sort and locate media. See
Color-coding Source Clips and Shots for more information.

Sorting the Project Panel

The Project panel can be sorted in the left-hand directory side and right-hand file side independently,
though files have more sorting and display options.

In the left-hand directory pane, items are sorted alphabetically in ascending order by default. To sort
project items manually:
1. Click and hold, or right-click, the sorting dropdown and select Manual.

2. Drag-and-drop items into your preferred order.
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The right-hand bin pane is also sorted alphabetically in ascending order by default, and there are
more options available in the sorting dropdown. Click and hold the dropdown to display the various
options, including Duration, Resolution, and Type.

-

=0 n * Color
E’ baseproject_11.1 o
+

© Duration

m FPS

Start Timecode

B Type

You can also change the layout and size of items in the right-hand bin pane. Choose a layout from
thumbnails, list, and details and use the slider to determine the size of the items. The slider is disabled
in details mode.
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Searching for Media

Nuke Studio's search functionality allows you to enter strings and apply searches on all or partial
matches with the option to include metadata searches. Nuke Studio searches for items that match
any of the input string and displays only those items by default.

Tip: Nuke Studio also examines file metadata for the search string by default, but you can
disable this behavior by disabling Include Metadata in the search dropdown.

® Filter
Flag
Match All Criteria

1
' X Include Metadata k : L
el S

+ Match All Criteria - media that matches all the entries in the search string are matched. For
example, entering AO1 DPX only matches media containing both AO1 and DPX.
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* Match Any Criteria - media that matches any of the entries in the search string are matched. Using
the same example, AO1 DPX matches any media containing AO1 or DPX.

Tip: This functionality extends to the media spreadsheet if you prefer to search for items
there. See About the Media Spreadsheet for more information.

Filtering and flagging produce the same search results, but they are presented differently. Filtering
only displays files that match some or all of the search string, whereas flagging displays all content
and flags files that don't match some or all of the search string.

Filtering ... ... and Flagging

You can also filter and flag media by tag. See Filtering and Flagging Media Using Tags for more
information.

Setting Poster Frames

You can assign poster frames to image items in the Project panel so that they represent the frames
you intend to use if your sequences. This is particularly useful if your source clips contain handles of
blank frames at the beginning of the footage.

To set a poster frame for source clips:
1. Select the clip or clips in the Project panel.
2. Right-click the selection, and select Set Poster Frame.
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Import
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Custom...
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Select a preset frame or click Custom to select an absolute or relative frame as the poster frame
for the source clip:

* Absolute - the poster frame number is derived from the file(s) on disk. For example, a .dpx

sequence myClip.####.dpx 1001-1500 can have an absolute poster frame between 1001 and
1500.

* Relative - the poster frame number is derived from the number of frames in the clip starting at

0. For example, a .dpx sequence myClip.####.dpx 1001-1500 can have a relative poster frame
between 0 and 499.

Note: If you select more than one source clip, you can't set an Absolute frame as the poster
frame.
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Color-coding Source Clips and
Shots

In large projects, the Project bin and timeline can quickly become busy and difficult to manage.
Adding colors to items or file types can help you find what you're looking for in bins and sequences.
You can quickly enable and disable colors in the Project panel and timeline in the Preferences under
Panels > Project Items. See the Appendix A: Preferences page under Panels for more information.

You can set general defaults for items such as bins, sequences, and source clips as well as for specific
file types such as .exr or .mov files. You can also set custom colors for individual selections or groups
using the right-click menu or color picker button at the top left of the Project panel.

Setting Default Colors

Project items have a default color assigned to them by type, such as orange for sequences and gray
for source clips. You can change these assignments using the Preferences > Panels > Project Items
dialog.

Note: You can disable the color scheme in the Project panel, timeline, and spreadsheet at
any time using the display in controls in the Preferences.
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chade project items
Item Labels
ject bin timeline
X auto-adjust contrast
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offline

freeze
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project bin sequence SOUFCE audio comp

color

To change a default color, click a button in the Project Items preferences and use the color wheel to
change the color.

Item Labels

Item States

Item Colors

comp

file types 0 color

You can also set the label color for the Project panel and timeline or change the color used to indicate
the state of a shot on the timeline, such as offline.

Setting Colors by Selection

You can keep track of particular clips and shots by manually assigning them a color of their own. This
custom color overrides any color you set by type. You can set colors on items individually or by
selecting multiple instances in the Project panel or timeline.

USER GUIDE
81



1.

Color-coding Source Clips and Shots |

In the Project panel or timeline, select the items you want to color.

Tip: The selection tools can help you make multiple selections quickly in the timeline. See
Using the Selection Tools for more information.

2. Right-click the selection and choose Color > Color Picker or click a color under Recent.

Properties Background Renders

Import

Edit

COpen In

Clip

Set Media Color Transform
Set Poster Frame

tion Palicy

Ctri+Shift+E Clear Color

o' Recent

3. Click Clear Color to remove any custom colors applied to the selection. The selection reverts to

the default item color set in the Preferences.

Setting Colors by File Type

Another way to organize your project is to assign colors to items by file extension. This custom color
overrides any color you set by item type.

1.
2.
3.

Open the Preferences by pressing Shift+S.

Navigate to the Panels > Project Items sub-menu.

Under file types, click the B button.

A new entry is added to the file types table.

Click the extension dropdown and select the required file type.

Double-click the color swatch and select the new color using the color wheel.
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6. Click OK to apply your changes.
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Reconnecting and Refreshing
Clips

During the post process, media inevitably changes location or form. You can reload or replace your
media using the reconnect, refresh, and rescan functions.

New

Import

Edit =
Open In ‘j

: Reconnect Media...
Set Media Color Transform
can Clip Range Alt+Fs
ization Policy Clear In/Cut Points

ion

Ctri+Shift+E

Though all three options deal with reloading source clips, each has a particular use dependent on

context:

* Reconnect Media - allows you to redirect the filepath when the source file location changes.

* Refresh Clips (F8) - allows you to reload the clip when the source file location has not changed, such
as when work has been done on the clip offline. Selecting refresh only refreshes the clip’s current
frame range.

* Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional
frames that may have been added to the source file and adds them to the source clip's frame range.
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Localizing Media

Hiero has the facility to cache source clips locally, either individually or by setting an automatically
localized folder (NUKE_TEMP_DIR/localize, by default), to help guarantee playback stability. Local
caching is controlled initially in the Preferences dialog, then on a clip-by-clip basis.

Setting Localization Preferences

The Preferences control how Hiero deals with new source clips as they are ingested, but does not
affect existing source clips in the project. If you plan to localize source clips in your project, it's a good
idea to set the Preferences before ingesting your source clips.

1. Press Shift+S to open the Preferences dialog and navigate to Performance > Localization.

System

mode on -

Inputs
localization policy from auto-localize path

Paths

auto-localize from

localize to [getenv NUKE_TEMP_DIR
Storage

currently in uze 0.0 GB
currently free 10.0 GB
Metwork
check for updated files every 30 mins

Appearance

progress bar up to date W in progress out of date

2. Setthe required localization mode:

* on - checks for updates to source clips for all localization policies, and localizes those files set to
On or From auto-localize path automatically. On demand source clips must always be
localized manually.

* manual - checks for updates to source clips and prompts you to update them manually. Only
those with the policy set to off are not updated.

« off - no source clips are localized, regardless of the their localization policy.
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Note: The current localization mode is displayed in the status bar at the bottom-right of the

interface.
I Localization Mode: On|Memory: 3.6 GB (11.4%) CPU: 4.7% Disk: 0.0 MB/s Network: 0.3 MB/s

3. Setthe default localization policy for new source clips using the dropdown:

Note: The localization policy for existing source clips in the project must be set
individually. See Managing Localization for more information.

* on - always localize source clips with this policy.
« from auto-localize path - localize these source clips automatically if they reside in the auto-
localize from directory.
+ on demand - only localize these source clips when you manually update them. See Updating On
Demand Clips for more information.
« off - never localize these source clips.
4. Enter a file path for auto-localize from, if required.
Any files that reside in this directory are automatically cached when ingested into Hiero, providing
that the Localization Policy is set to From auto-localize path.
5. Enter afile path for localize to. Leaving this field as the default creates a sub-directory in the
Temp Directory as the local cache.

Note: On Windows, files saved to the localize to directory replace \\ (double back slashes)
and : (colon drive signifiers) with underscores so that the file path works as expected
between operating systems. For example:

\\windowspath\to\my\network\file.dpx is saved as __
windowspath\to\my\network\file.dpx
t:\my\network\path\file.dpx is saved as t_\my\network\path\file.dpx

6. Enter avalue for limit to (GB) to control how much disk space is available in the cache directory.

Note: Negative values in this field reserve the specified amount of space at all times. For
example, -2 stops 2 GB of memory being used for caching.

7. You can specify the time interval (in minutes) before localized files are checked for updates using
the check for updated files every ## mins control.
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The default setting checks for new versions of files every 30 minutes, but you can set this control
to any value. Any files that have changed since the last update check are flagged red in the Project
bin.

Tip: You can change the default localization indicators using the Appearance controls.

If read source files when localized files are out of date is enabled, source clips referencing cached
files that have changed since they were localized revert to reading the source files. Source clips that
are reading from the source files are marked with a striped red bar on the clip.
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Enabling hide out of date progress bar hides the localization state of out of date files so that the
source clip appears the same as regular clips.

Note: The out of date localized files are not discarded, disabling read source files when
localized files are out of date picks up the out of date files instead of reading the source

files.

Managing Localization

As well as the overall Preferences for when new source clips should be localized, you can set
localization on a file-by-file basis. The localization policy for any existing source clips in your project
must be managed individually.

Tip: If you find that localization is slow to copy files, you can increase the number of threads
that Hiero uses to process jobs. Set the NUKE_LOCALIZATION_NUMWATCHERS environment
variable to the number of threads you want to use. See the Nuke Online Help for more
information.

To set the localization policy for source clips:
1. Select the clip(s) in the bin view.
2. Right-click and select Localization Policy to display the available options:
* On - the files are localized, regardless of location, as long as the limit to (GB) limit is not
breached.
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* From auto-localize path - the files are localized if they reside in the auto-localize from
directory, as long as the limit to (GB) limit is not breached.

+ On Demand - the files are only localized when you update them manually. See Updating On
Demand Clips for more information.

+ Off - the files are never localized, regardless of location.

As clips are localized, an amber progress bar displays in the thumbnail. Fully cached clips are
marked with a green bar at the top of the thumbnail and out-of-date clips are marked in red.

Note: Container formats, such as.mov and .r3d, do not display progress bars during
localization. The source clip only shows the green indicator once the entire file is localized

successfully.

Note: Hiero also features a playback cache and timeline disk cache, allowing frames to be
cached in RAM or disk. See Caching Frames in the Playback Cache and Caching Frames in the
Disk Cache for more information.

If you need to pause localization temporarily, navigate to Cache > Localization and select Pause.
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File Edit Workspace WViewer Render Cache Window Project Clip Timeline Help

4. If you find that your cache is filling up regularly, you can:

* Increase the amount of available space for localization by raising the limit to (GB) preference,
* Navigate to Cache > Localization > Clear Unused Local Files (see Clearing Localized Files), or

* Manually clear files from the cache directory in NUKE_TEMP_DIR/localize, by default.

5. You can force Hiero to check for updated source files, rather than waiting for the check for
updated files every interval to expire, by selecting Force Update for All files, just Selected

source clips, or On Demand only.

Note: Each file has its own update time, which is reset whenever the source files are

checked.

The following table is a quick reference guide to when and how source clips are localized, where:

* green - clips are localized automatically.
« amber - clips are localized when updated manually.
* red - clips are not localized.

Source Clip Preference

System Preference auto-path on demand

off

o [ I
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Updating On Demand Clips

Source clips with their localization policy set to on demand are polled to check for updates at the
interval set in the Preferences. If the file has changed, the source clip is marked with a red bar to
show it is out of date.

To update a single on demand source clip:
1. Double-click the source clip in the Project bin to display its Properties.
2. Click Update.

AD11C001_101029 103

file /Renders/A011C001_101029_L10

localization |::|::|il:';.-' an demand u

original range 150 275 rescan
missing frames  error

colorspace  default (Cineon) =~

Note: If a Read node's localization policy is set to on demand and it hasn't been localized
previously, clicking the Update button localizes the file.
The local copy of the source clip is updated from the remote source clip.

To update all on demand source clips:
1. Navigate to Localization > Force Update.
2. Click On demand only.

USER GUIDE



Localizing Media |

Render Cache Window Project Clip Timeline Help

Cache *

X Pause

Mode

The local copy of all on demand source clips is updated from the remote source clip.

Clearing Localized Files

Localizing a large amount of files can fill up the localization cache quite quickly if you leave the limit
to (GB) preference at the default 10 GB. When the cache runs out of space, a Failed to Localize File
dialog displays and localization pauses.

ization).

Delete Unused Localized Files

You can delete localized files by clicking Delete Unused Local Files (or by navigating to Cache >
Localization > Clear Unused Local Files). Hiero displays a dialog containing all the files that are
marked for delete.

Tip: You can also open the Preferences from this dialog to adjust the localization behavior,
such as increasing the limit to (GB) preference.
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%d.dpx 100-180

Continue

Click Continue to delete the localized files or Cancel to keep the cached files.
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Using the Viewer

Hiero supports two distinct Viewer types: clip and sequence. This chapter describes the difference
between the two and how to use them.

Clip Viewers, sometimes referred to as source Viewers, are marked with the a2 icon and deal

exclusively with source clips. You can set In and Out points and apply tags to the Viewer, but the
source clips are unaffected.

Sequence Viewers, also known as record Viewers, are marked with the icon and deal with
sequences and shots on the timeline. You can set In and Out points and apply tags here too, but you
can also edit the shots on the timeline by trimming, retiming, and so on. See Timeline Editing Tools for
more information.

The Editing workspace combines both clip and sequence Viewers by default, enabling you to add
source clips to the timeline using insert and overwrite functions. See Insert, Overwrite, and 3-Point
Editing for more information.

To view your media in a Viewer, simply drag-and-drop a clip or sequence from the Project tab onto a
Viewer input, or double-click the item to send it to the appropriate Viewer.
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Note: The Viewer currently treats all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image. If you're working with un-premultiplied
images, set the Viewer background to Black.

See Appendix A: Preferences for more information.

Deleting Media
To remove media from the bin view, select the clip(s) or bin and press Backspace or Delete.
If any of the media is in use in a sequence, the following warning displays:

® The clip "C 10" is currently being used in one or more seguences.

Deleting it will delete it from all of these

Are you Sure you W

Click Yes to delete the media from the bin view, but bear in mind that all instances of the deleted
media are removed from your current sequences.
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Timeline Playback Tools

There are many useful tools at the top of the Viewer, some of which allow you to select channels,
adjust gain and gamma, and zoom and scale down the image in the Viewer.

clipping annotations Pause

channel apply frame Viewer scale down

warnin
dropdown safe zone masking 9 menu update input
g |a)c/je" input input overlay Enable zoom
ropdown process buffers ROI menu

rgba v RGB v SRGB v . - o Oo%Js I 100% 11 -~
<8 P ”
gain gamma audio
display overflow
color info menu
bar

For more information about the tools above the Viewer, see Viewer Tools.

The tools at the bottom of the Viewer allow you to adjust the playback settings, including setting the

frame range, selecting the playback mode, and locking the Viewer playback range.

Drag the orange marker along the timeline to quickly cue to a specific frame or timecode. The number

of the current frame or timecode appears below the center of the timeline. You can also cue to a
frame or timecode by typing its number directly into this field.

Tip: The current frame and in an out point fields accept simple mathematical functions, such

as +/-20 to jump forward or backward 20 frames or +/-00002000 to jump forward or
backward 20 seconds.

in point current frame frame increment out point

00:57:39:14
00:57:36:23 1T e e e S e oo i 0:57:41:23
00:57:36:00 00:57:38:00 00:57:40:00 00:57:42:00 00:57:42:19

25° v TCv Global v 3 < |« <« <« 0057:39:14 > > | Db « 12 » 00:00:05:01

timecode layback controls
display playback Py lock this
playback frame range mode Viewer sequence overflow
rate source playback duration menu
range

By default, Hiero automatically adjusts the timeline of every Viewer window to show the frame range

defined in your Project Settings. If no frame range is defined, the frame range of the first image you

read in is used as the global frame range.

USER GUIDE

96



Timeline Playback Tools |

Viewer timeline controls also have a frame range source dropdown menu that you can use to define
where the timeline gets its frame range from. You can set this menu to Global, Input, or Custom.
Global is the default setting described above.

The playback rate field (frames-per-second) initially displays the project’s playback speed. Hiero
attempts to maintain this speed throughout playback, although this adjusts depending on the
resolution of the imagery and your hardware configuration.

Note: The asterisk (*) denotes the Sequence playback speed selected using the Frame Rate
dropdown or, for new projects, the Project Settings > Sequence > Frame Rate dropdown.

Playback Controls

The playback rate field (frames-per-second) initially displays the project's playback speed. The Viewer
attempts to maintain this speed throughout playback, although this adjusts depending on the
resolution of the imagery and your hardware configuration.

The following table lists the functions of the playback buttons:

Buttons Functions

The Play backward and Play forward buttons play the sequence
backward or forward at the script's frame rate. When you press a play
buttons, it toggles to a stop a button.

— The Back 1 Frame and Forward 1 Frame buttons cue the sequence to
the previous or next frame.

= The Previous keyframe and Next keyframe buttons cue the sequence
to the script’s previous or next keyframe.

o The First frame and Last frame buttons cue the sequence to the first
and last frame.

The Frame Increment field allow you to specify the number of frames by
which the Previous increment/Next increment buttons cue the sequence.
This is set to 10 frames by default.

The J, K, and L keyboard shortcuts also control playback. The K keyboard shortcut is mapped to
Pause/Play. J and L are mapped to backward and forward. Combinations are also supported:
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* K+J - frame backward.
* K+L - frame forward.

« K+drag in the top third of the Viewer - standard jog controls. Dragging the cursor left and right
moves the playhead backward and forward, frame-by-frame.

* The jog controls also detect rotary motion to jog through frames. Clockwise motion in the top third
of the Viewer, while holding K, advances the playhead and anti-clockwise reverses the playhead.

+ K+drag in the middle third of the Viewer - standard shuttle controls. Dragging the cursor left and
right plays backward and forward, with increased frame rate toward the edges of the Viewer.

+ K+drag in the bottom third of the Viewer - skips the playhead to absolute timeline position.

rgba ¥ RGB ~ v - ol - v - 28 %< I 100% 11

A\bsolute
Timeline

00:57:39:14
00:57:36:23 |11 1L U U EE B D O 00:57:41:23
00:57:36:00 00:57:38:00 00:57:40:00 00:57:42:00 00:57:42:19

25° v TCv Global v I« |4 <« <« 00573914 » 1> > Dl 00:00:05:01

The Playback Mode button lets you control how many times and in what direction the Viewer plays
back the sequence. Click the button to toggle between the following modes:

Button Function

Repeat Repeatedly plays the sequence in a loop.
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Button Function

Repeatedly plays the image back and forth from head to tail.

Plays once through the section between in and out point and stops at the
out point. If these are not marked, then it plays from the beginning to the
end of the sequence.

— Plays once from the beginning to the end of the sequence, ignoring any in
=% L0 e
and out points.

Viewer Tools

The Viewer has two sets of tools for manipulating your media: the Viewer tools and the playback tools.

The Viewer tools, located at the top of the Viewer, are used to affect the mouse pointer as you move
over the Viewer, and to select Viewer preferences:

Icon Function Description
Layers Select the layer to output to the Viewer, for example forward

motion vectors or disparityL. Only layers available in the clip
are displayed - check the clip's thumbnail to see at a glance
which layers are present:

I - red color layer.

I - green color layer.
I - blue color layer.
[—1- alpha layer.

I - depth layer.

E - forward motion vector layers.
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RGE

Channels

4

Viewer color

A/B

transform

Viewer
Output

. Guides
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Description

E - backward motion vector layers.

I - oll other custom layers, such as disparity.

Note: You can scroll through available layers using
PgUp or PgDn.

Select the channel(s) to output to the Viewer, for example
RGB, single channel, Alpha, or Luma.

Set the view transform used to display images in the Viewer,
for example sRGB and rec709.

Note: If you have specified an OpenColorlO
configuration file in the Preferences, you may have
more colorspace choices available.

Click the A or B dropdown and select what you want to view.
This can be selected tracks or tracks with selected tags.

When both Viewer buffers contain an image, enable wipe to
compare the two images. You can also use the center drop
down to set the blend mode between images in the Viewer,
for example Onion Skin or Difference, and the A/B buffer
configuration.

Enable or disable Viewer overlays:

+ title safe - any text intended for the audience should reside

within this zone.

+ action safe - any visual elements intended for the audience

should reside within this zone.

» format center - adds a crosshair in the center of the format

currently in the Viewer.

* Format - adds a red, format-dependent box for the clip or
sequence in the Viewer. Sequences support multi-format
clips, see Viewing Multi-Format Timelines for more
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Function

Mask

Clipping

Annotations

ROI

Pause
playback caching

Scale

Image Quality
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Description
information.

Enable or disable a range of Viewer masks, for example 16:9
or 1.85:1.

Enable or disable Viewer warnings:
* No Warnings - all clipping warnings are disabled.

* Exposure - alerts you when the image is under (blue) or over
(red) exposed.

Click to enable the Annotations tool bar. Annotations allow
you draw and add text to clips in the Viewer. See Annotations
for more information.

Note: The Annotations button also controls existing
annotation visibility.

Click and drag to define a Region of Interest (ROI) in the
Viewer. The scopes only display information within the RO,
when active.

Pause or release Viewer playback caching, indicated by the
green bar under the Viewer.

Set the scale applied to the clip in the Viewer, for example
25%, 75%, or Fit.

Set the Viewer image quality, for example 1:1, 1:4, or 1:16. The
default setting, Auto, resizes the image dependent on the
Viewer zoom level, which may re-cache the image at a higher
resolution.

Note: Image quality, or proxy, for RED clips is
dependent on the clip’s Decode Resolution in the
Media panel.

For example, if you're viewing a 4K file and the
Decode Resolution is set to Half Premium, a 1:1
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Function

Non RT Playback

See through missing
media

View

Obey Alpha

Audio latency

Gain
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Description

proxy value is equal to 2K, 1:2 is equal to 1K, and so
on.

Sets the Viewer playback mode:

* Play All Frames - the default setting, plays all frames in real-
time (dependent on hardware).

+ Skip Frames - plays frames in real-time skipping where
necessary to maintain the frame rate.

* Play All Frames, Buffering - plays all frames by buffering
and playing frames back as they become available.

When disabled, any offline media on a timeline is treated as a
blank clip so the Viewer cannot display the track underneath.
This setting also applies to missing frames within a clip.

Note: This control only affects the current Viewer.

Select the Viewer display mode, for example Audio and Video
or Video Only.

Allows you to control the alpha channel independent of the

Viewer Blend Mode.

* Enabled - any alpha channel present in the image is treated
as premultiplied transparency.

* Disabled - the alpha channel is ignored.

Sets the audio latency, in milliseconds, for the current Viewer
only. Audio latency allows you to correct audio and video
synchronization by changing the point at which audio
playback starts.

Positive values cause the audio track to start earlier in relation
to the video track, and vice versa.

Adjusts the gain applied to the linear input image before
viewing, but doesn't affect your exported image.
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Gamma

Saturation

Mute / Audio

Color
Sample
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Description

Adjusts the gamma applied to the image after the viewing
transform, but doesn't affect your exported image.

Adjusts the saturation applied to the linear input image before
viewing, but doesn't affect your exported image.

Click to mute audio output for the current Viewer or use the
slider to control the audio output level.

Tip: You can also control volume on a per track and
per shot basis. See Audio and the Timeline for more
information.

Enable or disable the RGBA color information bar in the
Viewer.

Note: The Color Sample tool displays color
information from the source file, not the colorspace
selected in the Viewer color transform dropdown.

See Working with Colorspaces for more information.

Using In and Out Markers

In and Out markers enable you to alter the duration of a shot to just the portions of the source or
sequence that you require.

Tip: You can use the source clip/shot properties original range controls in similar way to In
and Out points. See Setting Source Clip Ranges for more information.

When a clip containing In and Out points is added to a timeline, you can slip the clip around the
markers to adjust the clip’s output. See Timeline Editing Tools for more information. You can also use
In and Out points to export certain portions of a clip or sequence. See Transcoding for more
information.

To se

t In and Out markers:
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1. Right-click on the required clip or sequence and select Open In > Timeline View.

Tip: Source clips opened in the timeline view have a purple background in the
timeline.

2. Move the playhead to the location of the In point and press | on your keyboard.
The In point is marked by the In tab and the time is recorded in the playback controls.
3. Move the playhead to the location of the Out point and press O on your keyboard.

The Out point is marked by the Out tab and the time is recorded in the playback controls.

Note: You can also set markers by navigating to View > Mark In or Mark Out, by using the
Timeline menu to Mark Selection or Mark Clip dependent on clip selections on the
timeline, or by right-clicking a shots and selecting Open In > Viewer.

Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once,
retaining their relative positions. A Viewer preview shows the current frame for the selected marker(s)
and a timecode/frame popup helps to set the new position.

Drag the in point, out point,
or both by holding Ctrl.
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Clear the markers from your clip by navigating to View > ClearIn Point (Alt+]) and Clear OutPoint
(Alt+0). The markers are removed completely, but you can reapply them by repositioning the
playhead and pressing I or O.

Tip: You can also press Alt+U to remove both markers at once.

When the playhead is positioned near In and Out markers, the top half of the timecode scale controls
the playhead and bottom half controls the markers.

Flayhead
Control Area

01:00:04:00

Marker Control
Area

Ref _nce "=--‘

Ref__nce

Audio 2

Playhead A/B Indicators

The timeline playhead indicates what is currently displayed in the Viewer using a number of different
display markers. Swapping tracks between buffers automatically updates the playhead so that you
always know which tracks you are looking at in the Viewer.

» Selecting all tracks in the current Viewer buffer displays an ‘AB’ at the top of the playhead to
indicate that you're viewing all tracks in the sequence from top to bottom.
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Channel Count: 379 Localization Mode: Off Memory: 1.1 GB (6.7%) CPU: 102.1%)

» Selecting a track for the current compare Viewer buffer displays your A or B tab at the playhead
in the selected track.
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x*=1011 y=1055 1.00000 B H:100 S:0.44 V:0.54 L: 0.4
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01:01:02:12 01:01:23:08 01:01:44:04 01:02:05:00 01:02:27:10
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01:00:47:22 01:00: 50: 00

Channel Count: 379 Localization Mode: Off Memory: 1.7 G

 Selecting different tracks to the Viewer's A/B buffers draws A and B tabs on the playhead in the
selected tracks.
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Tip: Use A or B hotkeys whilst selecting shots to quickly assign Compare viewers.

01 01:0 S:00

LI T T T T O T T T T T T . T T O T T T I T O T T T R A A A O AR
1:00:45:15 01:00:47:22

01:04

Channel Count: 379 Lot

Using In and Out Markers

In and Out markers enable you to alter the duration of a clip to just the portions of the source or
sequence that you require.

Tip: You can use the source clip/shot properties original range controls in similar way to In
and Out points. See Setting Source Clip Ranges for more information.

When a clip containing In and Out points is added to a timeline, you can slip the clip around the
markers to adjust the clip’s output. See Timeline Editing Tools for more information. You can also use

In and Out points to export certain portions of a clip or sequence. See Transcoding for more
information.
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To set In and Out markers:
1. Right-click on the required clip or sequence and select Open In > Timeline View.

Tip: Source clips opened in the timeline view have a purple background in the timeline.

2. Move the playhead to the location of the In point and press | on your keyboard.
The In point is marked by the In tab and the time is recorded in the playback controls.
3. Move the playhead to the location of the Out point and press O on your keyboard.
The Out point is marked by the Out tab and the time is recorded in the playback controls.

Note: You can also set markers by navigating to View > Mark In or Mark Out, by using the
Timeline menu to Mark Selection or Mark Clip dependent on clip selections on the
timeline, or by right-clicking a shots and selecting Open In > Viewer.

Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once,
retaining their relative positions. A Viewer preview shows the current frame for the selected marker(s)
and a timecode/frame popup helps to set the new position.

Clear the markers from your clip by navigating to View > Clear In Point (Alt+l) and Clear Out Point
(Alt+O). The markers are removed completely, but you can reapply them by repositioning the
playhead and pressing | or O.

Tip: You can also press Alt+U to remove both markers at once.
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When the playhead is positioned near In and Out markers, the top half of the timecode scale controls

the playhead and bottom half controls the markers.
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Working with Colorspaces

Colorspace changes are applicable to clips in bins and shots, as well as in the Viewer using the Media
tab.

To apply colorspace changes to clips in bins:
1. Select the clip or clips in the bin view.
2. Right-click a selected clip and navigate to Set Media Color Transform.

Import
Edit = |

Open In

linear

Ctri+Shift+E

Panalog

The current colorspace is highlighted with a tick mark.

3. Select the colorspace to apply to the clip selection.

Note: Only colorspaces applicable to the selection are displayed. For example, REDspace
and LogC - CameraNative are only available for R3D and ARRIRAW clips, respectively.

4. Selecting multiple formats supporting different colorspaces, for example R3Ds and ARRIRAW,
breaks the available LUTs into sub-menus:
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Import
Edit

Open In

Clip
A0 T

=1a]

ter Frame

Ctrl+5Shift+E
L —

To apply colorspace changes to shots:

1. Select the item(s) on the timeline.

Half Float Linear
REDlogFilm

2. Right-click a selected item and navigate to Set Media Color Transform.

3. Select the colorspace to apply to the selection.
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Monitor Output in Hiero
(SDI/HDMI)

The Monitor Out feature allows you to preview a timeline Viewer image in a floating window, NDI
session, or on an external projector/video monitor to check the final result, including the correct
output transform and aspect ratio.

A dedicated Viewer Monitor Out workspace provides easy access to the monitor out strip and its
controls, but you can also access the controls through the ViewerMonitorOut in the node Properties
panel.

Properties Background Renders

=

X Enable Monitor Out

a, Gain and Saturation

X s

Output Transform

Hiero supports internal monitor out using a Floating Window, NDI sessions, and dedicated AJA or

Blackmagic cards, selected from the Device dropdown in the ViewerMonitorOut's Properties:

* Floating Window - Hiero's native monitor out uses a floating monitor and does not require additional
hardware. Mac users can also take advantage of additional HDR technology including an extended
SRGBf LUT. See Working with HDR Images for more information.

* NDI - A network protocol that enables video and metadata signals to be sent over standard IP
networks in real-time. This option allows you to easily share a stream of the Viewer output to anyone
else on the same network.
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Note: To view the NDI stream, you need the NDI Studio Monitor or NDI Video Monitor
application installed. See Streaming Viewer Output Over the Internet with NDI® for more
information.

* Dedicated AJA or Blackmagic Design cards - Hiero supports various AJA and Blackmagic devices that
can be selected from the Device dropdown after installation. See AJA and Blackmagic Design Monitor
Out Devices for more information on supported hardware and drivers.

Note: Audio scrubbing is not currently available through monitor out cards. Audio scrubbing
is only supported through internal audio output devices.

Enabling Hiero Monitor Out

Hiero's monitor out uses a floating monitor, NDI session, or additional hardware from AJA or
Blackmagic to display monitor out. The floating monitor allows Mac users to take advantage of
additional HDR technology including an extended sRGBf LUT. See Working with HDR Images for more
information.

1. Navigate to Workspace > Viewer Monitor Out.

The Viewer Monitor Out workspace is displayed with the Monitor Out toolbar under the Viewer
by default.

PRI BRI L PR N IR A B
00:00 01:00:04:04 0 01:00:14:16

24* ( o 01:00:00:00 o a1 12 e

Timeline er Acti Sequence 1) From Source 8 bit n = k

If you're working with multi-view footage in Interactive Bl bufrer mode, the monitor shows the
output from the selected Viewer including the A/B player mode currently in use, such as wipe or
difference. In Active, Buffer A, or Buffer B mode, additional controls display to determine the
stereo mode and view to output. See Stereoscopic and Multi-View Projects for more information.

Timeline Vie i:i' Active Viewe L FLd 0 From Source 8 bit s 0 = # recy09

2. Click the cogﬂ icon in the Viewer Monitor Out panel to display the Properties panel.
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IO T T S B S A SR R B B B
01:00:14:16

1 L] 4 01: ) | A4 12 BE

Timeline Viewer L} Active Viewer (Sequence 1) * B From Source 8 bit = &k 7 recii9

Viewer Monitor Out Properties

Select the device you want to use from the output Device dropdown. All available devices are
automatically detected and listed in this menu, along with the default options:

* Floating Window - opens a floating monitor window, without the need for a monitor device and
card. This is intended for full-screen use without displaying any of the interface.

Tip: Disable Minimize with Application to allow the floating window to remain visible when
Hiero is minimized.

* NDI - A network protocol that enables video and metadata signals to be sent over standard IP

networks in real-time. This option allows you to easily share a stream of the Viewer output to
anyone else on the network.

Note: To view the NDI stream, you need the NDI Studio Monitor or NDI Video Monitor

application installed. See Streaming Viewer Output Over the Internet with NDI® for more
information.

* Installed Cards - transfers the Viewer contents to the selected card and displays SDK and driver
information associated with the card.

The Viewer Monitor Out and Properties panel duplicate some controls for convenience.
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| Properties

x &
TimelineMonitorOut
Enable Monitor Out

e  Floating W

X Minimize with Application

Input Setup

2;: Timeline Vi i i (Seguence 1)

Output Transform
vl 1
01:00:14:16

eguence 1) S From Source

SRHLT 10

Select the Viewer to feed to the output monitor using the source viewer
dropdown. Selecting Active Viewer always displays the Viewer that is
currently selected in the workspace.

Select the view mode using the AB Mode dropdown:

* Active Buffer - the monitor always shows the output from the buffer
currently in use by the selected Viewer.

* Buffer A - the monitor always shows the output from the selected
Viewer buffer A.

* Buffer B - the monitor always shows the output from the selected
Viewer buffer B.

* Interactive - the monitor shows the output from the selected Viewer
including the A/B player mode currently in use, such as wipe or
difference.
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3 Display Select the resolution output from the monitor card currently in use. The
Mode resolutions available depend on the card manufacturer.

Note: Floating monitor out always uses the resolution of the
Viewer in use.

4 Pixel Select the pixel format output from the monitor card currently in use. The
Format formats available depend on the card manufacturer.

5 - Click the button or enable Use Viewer Gamma, Gain and Saturation to
apply the active Viewer's filtering, gamma, gain and saturation to the
monitor out.

£ 11 Click the button or enable Vertical Flip to flip the output vertically. This
control is handy if you're using a ceiling mounted projector.

7 B8 Click the button or enable Horizontal Flip to flop the output horizontally.

8 x| Click to enable the mouse pointer position on the monitor. You can

control the size of the cursor on the monitor in the Preferences under
Panels > Viewer (Monitor Out) > Mouse Pointer Scale.

9 [~ Click to display annotations active in the selected timeline Viewer on the
monitor for review purposes.

See Annotations for more information.

10 Output Select the color transform to apply to the image. If you've specified an
Transform  OCIO configuration file in the preferences, these custom LUTs are also
applicable.

AJA and Blackmagic Design Monitor Out Devices

Our monitor out architecture interfaces directly with the AJA and BlackMagic Design device drivers,
which are unified across their respective hardware lines, meaning all current supported cards for the
versions detailed in Third-Party Libraries and Fonts should work.

You can select installed cards from the MonitorOut's Properties panel using the Device control. The
SDK and driver versions for the selected card are displayed for convenience.
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ViewerMonitorQut

Viewer Monitor Out

%X Enable Monitor Cut

rasStudio 4K Mini

We've tested the following AJA and Blackmagic Design hardware:

AJA Card:

KONA 4 KONA 5 KONA iO4k+ T-Tap Pro

See https://www.aja.com/family/desktop-io and https://www.aja.com/products/t-tap-pro#techspecs
for more details on supported formats.

Connection

BNC

HDMI

Stereoscopic Support

Platforms

Drivers

USER GUIDE

@ @ @
& @ @ @
Yes Yes No No
Win, Mac, Linux Win, Mac, Linux Win, Mac, Linux Win, Mac

Driver 16.2.5 or later, available here:
* Windows:

https://www.aja.com/assets/support/files/9149/en/AJA-
Software-Installer_Windows_v16.2.5_Release.zip

* macOS:

https://www.aja.com/assets/support/files/9146/en/AJA-
Software-Installer_macOS_v16.2.5_Release.zip

* Linux: https://www.aja.com/assets/support/files/9140/en/AJA-
Software-Installer_Linux_RedHat_CentOS_v16.2.5_Release.zip
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Blackma UltraStudio 4K 4K Extreme 4K Extreme 12G 8K Pro
gic Card: Mini

See https://www.blackmagicdesign.com/uk/products/ for more details on supported formats per
card.

Connection
BNC [ ] ® o
HDMI ® o

Stereoscopic Support

No No Yes No
Platforms

Win, Mac, Linux Win, Mac, Linux Win, Mac, Linux Win, Mac, Linux
Drivers

Driver 12.4.2.0 or later, available here:

* Windows:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Windows

* macOS:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Mac%2005%20X

* Linux:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Linux

Blackma DeckLink Studio 4K DeckLink 4K Extreme DeckLink 4K Extreme 12G
gic Card:

See https://www.blackmagicdesign.com/uk/products/ for more details on supported formats per
card.

Interface

BNC o [ ] o
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Blackma DeckLink Studio 4K DeckLink 4K Extreme DeckLink 4K Extreme 12G
gic Card:
HDMI ® o ®

Stereoscopic Support
Yes Yes Yes

(Both views through one
output, so the Full
Resolution option is not
available.)

Platforms
Win, Mac, Linux Win, Mac, Linux Win, Mac, Linux
Drivers

Driver 12.4.2.0 or later, available here:

* Windows:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Windows

* macOS:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Mac%2005%20X

* Linux:
https://www.blackmagicdesign.com/support/download/2438c76b9f734f69b4a914505e
50a5ab/Linux

Some monitor out cards allow you to extend or mirror your desktop so that the user interface is
visible on the monitor. Please refer to your card’s documentation for more information.
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Working with HDR Images

Hiero handles HDR (high dynamic range) images in the same way as any other image, and so
manipulating HDR footage in Hiero does not compromise the range of data available. The only

difference is that you can't view HDR output in Hiero's native Viewer because most regular monitors

don't support HDR.

Nuke, Nuke Studio, and Hiero support viewing HDR output through approved monitors and Monitor
Output devices such as AJA, Blackmagic Design, and Bluefish SDI/HDMI cards. See AJA and Blackmagic
Design Monitor Out Devices for more details on supported cards. The following table contains details

of the output devices we've tested and approved.

Device Operating System
Dell UP3221Q Linux and Windows

macOS (Catalina 10.15.x, or later)
LG EP950 Linux and Windows

macOS (Catalina 10.15.x, or later)

Apple XDR macOS (Catalina 10.15.x, or later)

EDR Displays - Mac Only (Beta)

If you're running Hiero on macOS Catalina or Big Sur and have a compatible screen capable of

Connection
HDMI
Thunderbolt
HDMI
Thunderbolt

Thunderbolt

displaying values above 1, you can view your projects with HDR luminance ranges using sRGBf in OCIO
Color Management. You can also display images in the P3 gamut, giving more accurate color on wide

gamut displays.

Note: This feature requires a 2019 Mac Pro running macOS 10.15, or later, and a suitable

display or a current generation iMac Pro, iMac or MacBook Pro with an HDR screen.

1. On an Apple XDR, set the profile of your display to one of the HDR options in the OS System

Display Preferences:
* Pro Display XDR (P3-1600 nits)
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* Apple Display (P3-500 nits)
* HDR Video (P3-5T2084) - 1000 nits

On other monitors, enable the High Dynamic Range checkbox.

2. Inthe Preferences, open the Color Management > HDR section and check Enable macOS HDR
Color Profile (Display P3) (Beta).

Note: Enabling this control requires you to restart the application.

This control sets the Viewer colorspace to Display P3, so that the screen can display values
above 1. This setting also applies the P3 colorspace to the following;

* All Viewers
* Node Graph
* Dope Sheet
* Curve editors
* Scopes
3. Inthe Viewer Properties, set the gl buffer depth to half-float or float to allow HDR values to
display.
4. Set the Viewer Process to sRGBf using OCIO Color Management or provide your own extended
color space. This ensures that the frame buffer is not clamped at 1.

sRGB (default) Display P3
¢ sRGB (default)

@ sRGBf (default)

rec709 (default)
rec1886 (default)
None (default)

show panel

5. To use the HDR Video (P3-ST2084) setting on the monitor, select an appropriate ST2084 Output
Transform in the MonitorOut Properties or in the Viewer.
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MonitorOut

MonitorOut

® Enable Monitor Out
Device Floating Window «
¥ Minimize with Application
Video Setup
Display Mode 'From Source

Pixel Format | half

Viewer
Viewer 'Active Viewer (View..UKE))
AB Mode Active Buffer =

Use Viewer Gamma and Gain
Vertical Flip

¥ Use Input Process

Qutput Transform Rec.2020 ST2084 1000 nits (ACES) ¥

A further color space conversion is required to allow HDR images to display correctly. An
example of how this can be achieved in Nuke can be seen using a gizmo created by a customer,
Nick Shaw - the gizmo is available for download here: PQ-EDR_v101.gizmo

For more information on gizmos and how to use them, see Accessing Gizmos in Nuke.

Using this gizmo as an Input Process and setting the input process order to after viewer process
renders the correct image in the Viewer.
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gl buffer depth

viewer process
input process
input process order

viewer selector mode

The gizmo also contains a slider called Normalization (nits). This allows you to set the PQ nit
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half-float =

use GPU for viewer when possible

use GPU for inputs when possible

disable GPU viewer dithering

Rec.2020 ST2084 1000 nits (ACES) ~
HDR_IP
after viewer process

rectangle selection =

value which is normalized to 1.0. This is useful, for example, to prevent clipping of a 1000 nit PQ
signal on the 16" MacBook Pro's 500 nit display.

USER GUIDE

124



Streaming Viewer Output Over the Internet with NDI® |

Streaming Viewer Output Over
the Internet with NDI®

Network Device Interface, or NDI, is a network protocol from NewTek that enables you to send video,
audio, and metadata signals over standard IP networks in real-time. NDI allows you to easily share a
Nuke Viewer's output with anyone else on the same network.

Nuke's monitor out functionality is controlled by Viewer nodes, so you can compare or combine
multiple streams from as many Viewers as you like. Each Viewer can be enabled separately to output
your shots to multiple output devices, whether they're dedicated monitor out devices, NDI streams, or
Nuke's native Floating Window. The example shows five Nuke Viewers in total. The first Viewer at the
top of the image is feeding an HDR SDI monitor using a dedicated AJA or Blackmagic Design card and
the other four are combined over NDI connections to a remote multi-projector display.

See Comparing and Combining Multi-Viewer Output with NDI for more details.

Multi Monitor Out in Nuke Nodegraph

Lo -
i g fﬁ-’f.
&0l O ® k?
HDR 501 Out ' .
- ¥
L e - iy

FOUNDRY.

Nuke Studio's monitor out is controlled by the ViewerMonitorOut node, which only allows you to
stream one timeline Viewer to a dedicated monitor out device, NDI stream, or Nuke's native Floating
Window. Sharing your Viewer over an NDI connection is a great way to collaborate in a review session
with your creative team on the same local network or over VPN to remote customers.
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NDI in Nuke Studio Timeline

&)NUKESTUDIO

Timeline

FOUNDRY,

Installing the NDI Tools

To view an NDI stream, you need the NDI Studio Monitor (Windows) or NDI Video Monitor (macOS)
application installed on your machine. The monitor searches your network for NDI signals from Nuke
or Nuke Studio and allows you to select the stream you'd like to view.

NDI Studio Monitor and NDI Video Monitor are available for download as part of the NDI Tools on
Windows and macOS here:

* NDI Tools for Windows
* NDI Tools for macOS

Note: NDI streams require you to bypass the operating system's firewall software on the
remote machine to work correctly. Installing the NDI Tools on the remote machine should set
exceptions in the firewall automatically, but you can add exceptions manually as described
under Setting Up an NDI Stream from Nuke and Nuke Studio and Adding Firewall Exceptions
on macOS.


https://www.ndi.tv/form-windows-tools-ndi5
https://www.ndi.tv/form-mac-tools-ndi5/
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Setting Up an NDI Stream from Nuke and Nuke Studio

1. On the local machine in Nuke or Nuke Studio, go to Edit > Preferences, or press Shift+S, and
navigate to Panels > Viewer Monitor Out.

2. Ensure that Enable NDI is checked.

3. In the monitor out Properties, set the monitor out Device to NDI to start broadcasting the
stream over the network.

MukeStudio - Cat_ard_moth_Timeline - SQ030_5H0190_comp_v04

To display the Properties panel:

* Nuke - click the cogE icon in the bottom-left of the Viewer Monitor Out panel or double-click
the Viewer node.

00:00:02:12 00:00:02:23

0 a4 10 e ﬂ i

=RGEB

Monitor Out Properties

* Nuke Studio - click the cogE icon in the bottom-left of the Viewer Monitor Out panel.

T T ST U TN NN S N MU SO O N AR AU I A P T T B O R B B B IR B B B
01:00:04:04 } 01:00:14:16

4 4 0 00 O 4 12 e

(Sequence 1) -

Viewer Monitor Out Properties

4. Set the Display Mode for the receiver device of the NDI stream. If you don't change this, Nuke
broadcasts the source resolution of the project over NDI. However, this format may not be
supported on the receiving device, so you can set the NDI stream to scale to a specific resolution
and frame rate here.
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Note: If the Display Mode is set from a timeline sequence, the NDI resolution is auto-
scaled. Whereas the node graph viewer outputs an absolute pixel-for-pixel view, center
cropping or padding, based on the resolution of the NDI signal. For example, a 3K
(2880x1620) resolution comp set to output from the node graph viewer to UHD
(3840x2160) would appear padded on a UHD device because the image is smaller than
the frame size being broadcast, whereas the same 3K (2880x1620) comp set to output
to HD (1920x1080) would appear cropped on the receiver side.

6. On the remote machine, download and install the NDI Tools for your operating system from the
links under Installing the NDI Tools.

7. Launch the NDI Studio Monitor (Windows) or NDI Video Monitor (macOS), depending on your
operating system:

* Windows - In the NDI Studio Monitor, click the options icon at the top-left and then select
the required stream.

* macOS - In the NDI Video Monitor, click the NDI menu at the top of the screen and then select
the required stream.

The stream name is shown in the Viewer Properties and on the NDI stream for identification and
is constructed as follows: [Application] - [Project or Script] - [Viewer]

For example: Nuke - cat_and_moth - Viewer2

The Viewer is output through the NDI Studio Monitor or NDI Video Monitor.

USER GUIDE
128



Streaming Viewer Output Over the Internet with NDI® |

Background Renders

Output Transform

&

Audio scrubbing outg 4K d through external meonitar o

Comparing and Combining Multi-Viewer Output with NDI

Nuke's monitor out functionality is controlled by Viewer nodes, so you can compare or combine
multiple streams from as many Viewers as you like. Each Viewer can be enabled separately to output
your shots to multiple NDI streams. For example, using four Viewers and four NDI streams, you could
compare the format of multiple shots.
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i0 210

You can switch the Output Transform on each Viewer independently to check color consistency
between the shots.
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ot

Viewer1 - sRGB Viewer2 - P3-DCI D65

)
- -

Viewer4 - Rec709 D60 +

Vi 3-L
lewer og ColorCorrect

Using a similar four-Viewer setup, you could send four quadrants over NDI to four projectors to
produce a larger image somewhere else on the same network.
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Each quadrant is a Crop node that defines which part of the overall image is handled by each Viewer.
For example, Quadrant3 is set up as shown here, with simple expressions to handle different formats.
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Quadrant3

Crop Node

r[osol ] |tlaos | wh

box
=height/2

Viewer1 - Quad1 Viewer2 - Quad?2

Viewer3 - Quad3 Viewer4 - Quad4

Adding Firewall Exceptions on Windows

Installing the NDI Tools on the remote machine should set exceptions in the firewall automatically, but
you can add exceptions manually as follows:

1. Click the show hidden icons button on the right-hand side of the taskbar and then click Windows
Security,

D e 13:52
J U k|
16/03/2022

OR
Click the Windows Start button and type Windows Security and then click Windows Security.
The Windows Security dialog is displayed.

2. Click Firewall & network protection.
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Windows Security - O *

<

= Security at a glance

| a See what's happening with the security and health of your device
and take any actions needed.

@

0P O % ( |8

= Virus & threat protection Account protection Firewall & network
Status unavailable, open No action needed. protection

= CylancePROTECT for information. Mo action needed.
Open CylancePROTECT

@

4. Click Allow an app through the firewall.
The Allowed applications dialog is displayed.

5. Click Change settings to enable editing.

‘ Allowed applications — O X
T ﬂ « Windows De.. > Allowed applications v | O p
~
Allow apps to communicate through Windows Defender Firewall
To add, change or remove allowed apps and ports, click Change settings.
What are the risks of allowing an app to communicate? GChange settings
Allowed apps and features:
Name Private Public ~
@FirewallAPIdII,-80201
@FirewallAPLdII,-80206
O@netlogon.dll,-1003
O@netlogon.dll,-1008
& AllJoyn Router O
application.ndi.remote.xb4 O
OBranchCache - Content Retrieval (Uses HTTP) O O
O BranchiCarcha - Hoctad Cacha Cliant £ leac HTTDEY (| (| &
oK Cancel

7. Scroll to the bottom of the window and click Allow another app.
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8. Enter the file path to the NDI Studio Monitor executable or click Browse to locate the .exe using
the explorer. NDI Studio Monitor is installed here by default:

C:\Program Files\NDI\NDI 5 Tools\Studio
Monitor\Application.Network.StudioMonitor.x64.exe

9. Click Add and then click OK to complete the firewall exception.

Refer to your operating system's documentation or speak to your network administrator for more
details. For more information on the NDI Tools and network configuration best practice, see:
https://ndi.tv/tools/education/networking/best-practices/networking-best-practice/

Adding Firewall Exceptions on macOS

Installing the NDI Tools on the remote machine should set exceptions in the firewall automatically, but
you can add exceptions manually as follows:

1. Launch System Preferences.
2. Click Security & Privacy and go to the Firewall tab.

3. Click the Firewall Options button.

Note: You may need to click the lock icon at the bottom-left to enable changes.

| General FileVault Privacy |

@ Firewall: On Turn Off Firewall

The firewall is turned on and set up to prevent unauthorized applications, programs,
and services from accepting incoming connections.

Firewall Options

@ Click the lock to make changes. Advanced.. 7

4. Under the list of incoming connections, click on the + button.
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__ Block all incoming connections
Blocks all incoming connections except those reguired for basic Internet services,
such as DHCP, Bonjour, and IPSec.

Printer Sharing © Allow incoming connections
Remote Login (S5H) © Allow incoming connections
4+ Dropbox @ Allow incoming connections =
M rim.foundry @ Allow incoming connections =
M sophosManagementAgent @ Block incoming connections *
@ SophosMessageRouter @ Block incoming connections  :

[+[J]

4 Automatically allow signed software to receive incoming connections

Allows software signed by a valid certificate authority to provide services accessed
from the network.

_| Enable stealth mode
Don't respond to or acknowledge attempts to access this computer from the network
by test applications using ICMP, such as Ping.

© (Cancel ) ( OK )

5. Enter the file path to the NDI Video Monitor application or click Browse to locate the .app using
the Finder. NDI Video Monitor is installed here by default:
/Applications/NDI Video Monitor.app

6. Select NDI Video Monitor.app and click Add and then OK to complete the firewall exception.

Refer to your operating system's documentation or speak to your network administrator for more
details. For more information on the NDI Tools and network configuration best practice, see:
https://ndi.tv/tools/education/networking/best-practices/networking-best-practice/
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Using Scopes

Hiero provides scopes to help you evaluate your media. There are a number of global controls
(Preferences > Panels > Scopes) that affect how the Scopes display information:

* black point - sets the black out of range warning level.
+ white point - sets the white out of range warning level.

* luma/chroma encoding - sets the video standard to use when converting RGB to luma or chroma
values in the scope displays, either REC601 or REC709.

* Include viewer color transforms - when enabled, scope data includes the applied Viewer color
transforms (gain, gamma, and LUT). When disabled, scope data does not include the applied Viewer
color transforms. This may slow down rendering, as it may require image calculation.

* Force full frame - When enabled, scopes display data for the full frame, regardless of what portion
of that frame is displayed in the Viewer. When disabled, scopes only display data for the current area
requested by the Viewer rather than the full frame.

To open a scope, navigate to Window > New Scope and select the required scope from the list.

Histogram

The Histogram provides three color channel and luma channel information that describes the
distribution of red, green, blue, and luma pixels throughout the current frame.

The Histogram graphs the number of pixels at each brightness level, and from left to right, the areas
of the Histogram represent shadow, mid tones, and highlights.

[ Histogram

Active Viewer (Danc..roup) - RGB (rg,br

Viewer Channel Mode
Selection Selection B Selection

Buffer A : main
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Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.

There are also Viewer and Channel selection controls on the Histogram tab:

* Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Histogram output to the required clip.

The default value, Active Viewer, automatically displays details on the last Viewer you selected.

* Channel selection - select the channels to output. The default setting displays RGB, but you can also
view channels separately.

* Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.

* Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.

Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.

For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

B Histogram

Viewerl (NUKE) RGB (rag,bY¥

Buffer & : left Buffer & : right Buffer B : left Buffer B : right

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Waveform display.

The guides at the edges of the Histogram turn red to warn you when the distribution is out of range:
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Histogram

Active Viewer (Seguence 1) - RGB (rg,bY

Shadow Guide Highlight Guide

Buffer A : main

Waveform

The Waveform scope provides information on clip luminance, or brightness, which you can use to
decide whether the clip is over or under exposed. The white traces represent luminance values from 0
- 100% (black through the spectrum to white). The higher the waveform, the brighter the image in the
Viewer.

Wawveform

Active Viewer (cityscape) RGE (rg,br

Viewer Channel Mode
Selection Selection B Selection

Current
View

Buffer A : main

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.

The upper white marker is used to measure when over exposure could be a problem. If your
waveform has a lot of traces over the white marker, you should consider reducing the brightness of
the clip. The opposite is true of the lower black marker.

There are also Viewer and Mode selection controls on the Waveform tab:

* Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Waveform output to the required clip.
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The default value, Active Viewer, automatically displays details on the last Viewer you selected.

* Channel selection - select the channels to output. The default setting displays RGB, but you can also
view channels separately.

* Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.

* Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.

Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.

For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

Wawveform

Active Viewer (Seguence 1) RGB (rg,bY

Buffer A : left Buffer A : right Buffer B: left Buffer B : right

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Histogram display.

The guides at the top and bottom of the Waveform turn red to warn you when the distribution is out
of range:

Wawveform

Active Viewer (cityscape) RGB (rg,bY
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Vector

The Vector scope displays color, saturation, and hue information for the current frame. Similar to
color wheels, Vector scopes display information radially, from the center outward. The farther from
the center the data spans, the more saturation is represented.

In the image on the left, you can see that the frame represented contains mostly yellows and reds, but
the values are not oversaturated. The image on the right represents a badly saturated frame. Notice
the spill of red traces distributed toward the edge of the scope pass the target (the highlighted
square).

Buffer A : main Buffer A : main

Normal saturation. High Saturation.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.

There is also a Viewer selection control and Current View label on the Vectorscope tab:

* Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Vector
scope output to the required clip.

The default value, Active Viewer, automatically displays details on the last Viewer you selected.

* Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.

Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.
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For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

ectorscope

Active Viewer (Sequence 1) -

Buffer & : left Buffer A : right Buffer B : left Buffer B : right

The Waveform scope provides information on clip luminance, or brightness, which you can use to
decide whether the clip is over or under exposed. The white traces represent luminance values from 0
- 100% (black through the spectrum to white). The higher the waveform, the brighter the image in the
Viewer.

B Wawveform
Active Viewer (cityscape) RGB (r,g,br

Viewer Channel Mode
Selection Selection B Selection

Current
View

Buffer A : main

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.

The upper white marker is used to measure when over exposure could be a problem. If your
waveform has a lot of traces over the white marker, you should consider reducing the brightness of
the clip. The opposite is true of the lower black marker.

There are also Viewer and Mode selection controls on the Waveform tab:
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* Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate
Waveform output to the required clip.

The default value, Active Viewer, automatically displays details on the last Viewer you selected.

« Channel selection - select the channels to output. The default setting displays RGB, but you can also
view channels separately.

* Mode selection - select the mode to output. The default setting displays ganged RGB, but you can
also view the channels separately.

* Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.

Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.

For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:
eform

Active Viewer (Seguence 1) RGB (ra,byr

Buffer A : left Buffer A : right Buffer B: left Buffer B : right

The scopes feature global customizable guides to help you view your clips. Navigate to Preferences >
Panels > Scopes and enter values between 0 and 1 for the Black and White points. Note that this
also sets the values for the Histogram display.

The guides at the top and bottom of the Waveform turn red to warn you when the distribution is out
of range:
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|
¥

Active Viewer (cityscape) RGE (rg,bY

Buffer A : main

The Vector scope displays color, saturation, and hue information for the current frame. Similar to
color wheels, Vector scopes display information radially, from the center outward. The farther from
the center the data spans, the more saturation is represented.

In the image on the left, you can see that the frame represented contains mostly yellows and reds, but
the values are not oversaturated. The image on the right represents a badly saturated frame. Notice
the spill of red traces distributed toward the edge of the scope pass the target (the highlighted

square).
]

Vectorscope L] Vectorscope

cityscape cityscape

Buffer A : main Buffer A : main

Normal saturation. High Saturation.

Tip: You can pan the view area by holding Alt, or the middle mouse button, and dragging in
the panel.

There is also a Viewer selection control and Current View label on the Vectorscope tab:
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* Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Vector
scope output to the required clip.

The default value, Active Viewer, automatically displays details on the last Viewer you selected.

* Current View - describes the view currently displayed in the scope, whether it's the A or B buffer
and the view. The view defaults to main, unless main has been replaced in multi-view scripts or
projects.

Depending on which Viewer tools and views you have active, you can have up to four scopes
displayed at once.

For example, with two stereo Read nodes, one in each input buffer, and wipe and Side by Side
active, the scopes display something like this:

fectorscope

Active Viewer (Sequence 1) -

Buffer & : left Buffer A : right Buffer B : left Buffer B : right
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About Anamorphic Media

The Viewer automatically recognizes anamorphic clips and displays them with the correct aspect ratio.

If for any reason you want to display an anamorphic clip with a 1:1 aspect ratio, right-click in the

Viewer displaying the clip and enable the Ignore Pixel Aspect checkbox, or use the Ctrl/Cmd+Shift+P
keyboard shortcut.

Mark: b
Frame Control * to Size Ctrl+Shift+1

Ctrl+Shift+2
Ctrl+F
Ctrl+5hift+F
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About QuickTime Media

Working with .mov files can be unpredictable when compared to other formats, so Hiero gives you a
few QuickTime options when reading and writing .mov files.

Hiero attempts to select the 'best fit' combination by reading an extended list of metadata key/value
pairs from the QuickTime header, including nclc atom, gama atom, and ProRes codec headers.

If you place a clip in the Viewer, or open a shot in the Viewer, and open the Media tab, you'll see that
Hiero has a number of media-specific controls that you can manually override if the 'best fit' is not
what you're looking for:

MOV Options

¥ ChCr matrix  default (Rec 709) =

Data Range default (Full Range) =

Metadata Do not attach prefix % Match key format

vVideo Codec: h264

* YCbCr Matrix - sets the way Y'CbCr is converted to RGB. You can choose to use the new Rec 601 and
Rec 709 or the Legacy encoding methods, which are the methods used previously in Hiero.

+ Codec - sets the codec used to read (write already had a similar control) the QuickTime file.

The codec dropdown defaults to a codec appropriate for the QuickTime in question, where available,
and only lists those that declare themselves able to read the file.

* Pixel Format - sets the read and write pixel format, which includes bit depth, colorspace, pixel
packing, and ranges.

This setting defaults to the best format accepted by the codec, allowing Nuke to perform the
conversion to RGB without the use of an unknown QuickTime transform, where possible. RGB pixel
types rely on QuickTime to do the conversion from Y'CbCr when dealing with a non-RGB codec.

In addition to the nclc, gama, and ProRes data Hiero, and by extension Nuke, also write additional
metadata into the file headers during export, retaining your QuickTime preferences. This combined
metadata represents myriad potential QuickTimes preferences, so Hiero reads the available metadata
in the following order, reverting down each level as the level above is unavailable or set to a reserved
or unknown value:

* Foundry-specific metadata
* ProRes header data
* nclc atom data

* gama atom data
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* The defaults associated with the chosen codec

In this way, the worst case scenario is that you end up with the chosen codec class' default values.

Synching to VBlank on Linux

Hiero automatically accounts for tearing that can occur due to NVIDIA and OpenGL issues on Linux,
but with dual screen setups, you need to specify which screen to synchronize. The __GL_SYNC_
DISPLAY_DEVICE environment variable enables you to specify the sync device by appending the
screen device name to the variable.

To determine your screen names:
1. From a command line, enter:
nvidia-settings

The NVIDIA X Server Settings dialog box displays.

= BATLA E Tarves Nelliegs =lalx

e |

LakFilel .

2. Open up the GPU dropdown to display the screen device names.

= GPU 0 - (Quadro FX 580)
Thiermal Settings
Powerkizer
DFP-0 - (Samsung SMB2440)
DFPZ - (Samsung SMB2440)

fividia-settings Configuration

3. Make a note of the device names, for example, DFP-0 or CRT-1.

Set the __ GL_SYNC_DISPLAY_DEVICE environment variable value to the device name as describe
in Setting Environment Variables.
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Using Tags

Tags are used by Hiero to quickly sort or filter clips and shots for better visibility, organization, and
export. Tags are used to mark shots of a particular type or content as you organize your project. The
default tags supplied include Approved, Note, Reference, and other general purpose tags. You can
also create custom tags by right-clicking in the Tags tab or by pressing Ctrl/Cmd+Y in the Tags tab.
You can apply tags to clips, shots and Comp shots, individual frames, sequences, and tracks.

Clip and shot tags and notes can be added to exports using the burn-in feature. See Adding Burn-in
Text to Exports for more information.

Tags can also be converted to Final Cut Pro or Premiere markers during export to XML. See Exporting
Sequences as EDL, OTIO, and XML for more information.

Using Quick Tags

Quick tags allow you to add tags, depending on context, by right-clicking a selection and then choosing
the type of tag to apply. If you're tagging a large amount of media, you might find it more convenient
to use the drag-and-drop methods described later on.

Quick tags are accessible from bins, spreadsheets, Viewers, and timelines for single or multiple
selections.

1. Select the target clips or sequences.

2. Right-click a highlighted selection, go to Tags, and choose the required action, dependent on
context.

For example, bin items only allow you to Tag Selection, whereas shots allow you to Tag Shot
Selection, Tag Tracks, or Tag this Sequence

Once you've selected the tag type, the Add Tag dialog displays.

3. Select the icon to represent the tag using the lcon dropdown.
Enter a Name and Note as required.

5. Click Add to mark your selections with the chosen tag.
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See Creating Custom Tags and Removing Tags for more information.
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Tagging Using the Viewer

To apply a tag using the Viewer:
1. Click the Tags tab, or navigate to Window > Tags.
The Tags panel displays.
2. Drag-and-drop the required tag from the Tags panel to the Viewer.

Depending on whether you're looking at a clip or sequence, drop the tag on Tag this frame, Tag
whole clip, or Tag whole sequence as required.

Tags applied to frames appear above the playback tools in the Viewer frame slider.

Tags Playhead

||||||||||||||||||||I||||||||-|-||-|?|||-|-|||||
0g:00 01:00:12:00 01:00:16

4 " | | e aTatE 9 = [ (™ e

Tip: You can use Alt+Shift+left and right arrows to skip to the previous or next tag on the
current clip. You can also reposition tags by dragging them along the Viewer timeline.

Tags applied to clips are displayed above the Viewer.

Clip Tags
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Tagging Shots

To apply a tag to a shot on the timeline:
1. Click the Tags tab, or navigate to Window > Tags.
The Tags panel displays.
2. Drag-and-drop the required tag from the Tags panel to the timeline.

Depending on where the tag is dropped, you'll mark a shot (or items if you make multiple
selections) or a track.

1
4
1
e 2 e I

+ + + +[J

| G-C
+
+
+

Tags applied to tracks appear in the track header on the left of the timeline.
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Adding Notes to Tags

In some cases, a simple tag on a frame or clip may not contain all the information that you wish to
pass on to the next stage of production. Adding notes to a tag can provide that extra detail.

Warning: To delete a note, don't click the - button because this refers to the tag. Instead,
simply delete the notes in the window and click outside the note dialog.

1. Add notes to tags by clicking on the required tag and entering text or editing the metadata keys
and values.

The example shows a note and metadata key “Artist” added to a clip tag, but you can add notes to
frame and timeline tags in the same way.

2. Click outside the dialog to save the note.

Hiero allows you to “hide” tags using the Python API. Hidden tags are not displayed in the interface,
unless you enable Show Hidden in the Tags popup, but the notes and metadata are still accessible.

Navigate to Help > Documentation > Hiero Python Developer's Guide for more information on
creating hidden tags.
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Filtering and Flagging Media Using Tags

You can search for clips containing certain tags, for example, if you wanted to find all clips that you
tagged as Approved.

There are two types of tag search you can perform: Filter and Flag. Select the desired search type by
clicking the magpnifier icon in the Project tab.

* Filter - displays all objects that contain the specified tag. This is the default search method.

* Flag - displays all objects and marks the items that don't match the search tag.

Drag the required tag from the Tags panel into the search box and select the bin or bins you want to
Filter or Flag.

Tip: If you have more than one search criteria, click the icons in the search box to display a
brief description of the icons.

Filters and flags persist until you change the search criteria or click the x icon in the search
box.

The following examples show Filtering a bin to display only clips with the Notes tag applied and
Flagging all clips that don't have the Notes tag applied.

[0 [8) bassproject 11.1]

B

Filtering ... ... Flagging.
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Creating Custom Tags

You may find that you require a specific tag or suite of tags that are not provided by default. Creating
custom tags allows you to really control the organization of your media, and you can even create your
own tagicons.

Note: Custom tags can only be created in the Tags panel.

To create a custom tag:

1.
2.

Click the Tags tab, or navigate to Window > Tags.

Select your project and navigate to Project > New Tag, or press Ctrl/Cmd+Y.
The new tag is placed in the selected project.

Double-click the tag to open the Edit Tag dialog box.

Click the Icon dropdown menu to select an icon for the custom tag.

Tip: You can import your own image for the tag by selecting Custom to open the browser.

Enter a description for the tag in the Name field.
Click OK to save your changes.
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Removing Tags

To remove a tag from a frame or shot, click the tag and then click -

You can remove all tags from a source clip or selection of clips by right-clicking your selections in the
bin and choosing Tags > Clear Tags.

Import
Edit

Open In

Ctrl+Shift+E

To remove a tag from a track or shot, click on a tag icon and select the required tag to remove.

Click - to remove your selection.
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Viewing Metadata

Metadata is information that describes media content, separate from the clip itself, in the form of a
table on the Metadata tab. Types of metadata include Duration, File Size, and the Path to the
location of the source media.

Source Clip and Shot Metadata

To view metadata for a source clip, right-click the clip and select Open In > Metadata View, or press
Alt+D.

To view metadata for a shot, select the Metadata tab in the timeline panel and click on the item to
examine.

Tip: You may have to add the Metadata tab manually by clicking the oMl icon and selecting
Window > Metadata.

[ =l Sequence 1 letadata Curve Editor

Viewer (Sequence 1)

Timeline

Curation
User
+ Tags
Timeline
Curation
Media
User

Timeline
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Conforming Using Hiero

Conforming describes the process of matching up the footage from a shoot with the required edit
decisions to create a meaningful timeline. Hiero accepts sequences either from EDLs (edit decision
lists), OTIO (OpenTimelinelO), AAFs (advanced authoring format), or Final Cut Pro XML files from a
specified directory structure containing the source media files. Hiero attempts to conform the media,
warning you if there are missing media.

Hiero conforms EDLs into single tracks, and OTIOs, AAFs and XMLs into multi-track timelines. You can
either conform into a brand new timeline, or into an existing timeline by adding new tracks. For
example, when conforming multiple EDLs into the same timeline, you would add new tracks for each
EDL sequence conformed.

See Project Settings, Importing Sequences, and Conforming Sequences for more information.
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Project Settings

A good place to start work is by defining default Project Settings before importing sequences,
particularly in the case of EDLs as they may not contain frame rate information. Project Settings only
apply to the current project and override Preferences settings.

Note: You can modify Project Settings later on, for example, when you're ingesting media.

Tip: You can create templates for Hiero or Nuke Studio by creating .hrox files in the
.nuke/Templates folder. This helps if you have particular Project Settings, such as
Colorspaces, footage, and folder structures, that you wish to reuse across multiple projects.
See Creating and Using Project Templates.

To define Project Settings:

1.

Navigate to Project > Edit Settings.
The Project Settings dialog displays.
Click the General sub-menu to set the project Name.

Enter a Project Directory if required. This is the location of the .hrox project file and can be used
as the root of the project if you want to use relative paths to source clips. See About Clips and
Shots for more information.

If you want this setting to apply to all new projects, use the Preferences > Project Defaults >
General panel settings.

Tip: Click Hrox Directory to automatically enter an expression that evaluates to the .hrox
location.

Set the Poster Frame used by Project bin clips or use the default First frame. See Setting Poster
Frames for more information.

Click the Sequence sub-menu to set the default Output Resolution, Frame Rate, and Start
Timecode for new timelines in the current project, and set clip formatting when new clips are
added to the timeline.

Click the Views sub-menu to set up multi-view or stereo projects. See Stereoscopic and Multi-View
Projects for more information.

Click the Color Management sub-menu to manage the display and file colorspaces for this
project.
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See Color Management Settings for more information.

Tip: Use the options in Preferences > Project Defaults > Color Management to apply
them to all new projects.

Click the RED Settings sub-menu to define the Default Video Decode Mode for new R3D files in
the current project. This setting overrides the Preferences > Behaviors > File Handling > default
red clip video decode mode control for existing projects. See Appendix A: Preferences for more
information.

Note: Changing this setting does not change the decode setting for R3D media that has
already been imported.

The dropdown contains a sliding resolution scale from FullPremium to SixteenthGood, but bear
in mind that higher resolutions are slower to decode.

Lastly, click the Export/Roundtrip sub-menu to select:

 External Media Track Name - sets the default name of the track created when exported media
is brought back into Hiero.

« Export Directory - sets whether the Project Directory, if specified, or a custom directory is
used for exports. If no Project Directory is specified, the project root in the Export dialog is
used.

If you want this setting to apply to all new projects, use the Preferences > Project Defaults >
General panel settings.

+ Custom Export Directory - when Export Directory is set to custom, enter the required custom
export directory.

* Shot Preset - sets the default preset to use when exporting.

Color Management Settings

Hiero uses OpenColorlO for color management. All of the colorspaces in Hiero, whether those
shipped with the application or custom colorspaces are defined in OCIO config files.

Depending on the OCIO config file that you are working with, there are a number of colorspace
options and roles (aliases to colorspaces) that you can set in Hiero. There are also default options,
which change depending on what file type you are working with. When the default option is selected,
the colorspace that Hiero has set for it is listed in brackets.
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Tip: Use the options in Preferences > Project Defaults > Color Management to apply
them to all new projects.

General

Sequence

Color Management

RED Settings

Export

OpenColorld Config

nuke-default =

Default Color Transforms
Warking Space: scene_linear (linear)
Thumbnails:
Monitor
8 Bit Files: matte_paint (sRG
16 Bit Files: texture_paint (sRGEB)
compositing_log (Cineon)

Log Files:

Floating Point Files: scene_linear (linear)

Set the OpenColorlO Config you want to use for this project.

Hiero ships with a number of default configurations, but you can:

* use a custom OCIO config file by selecting custom from the OpenColorlO Config dropdown and
then entering the file path, or

+ add your own config to your .nuke file. See Adding OCIO Configurations for more information.
Changing the configuration updates the Default Color Transforms accordingly. If the selected

configuration is invalid for certain transforms, a warning displays. For example, if you choose the
shipped iff configuration, the 8-bit and 16-bit transforms are not compatible.

Could no
their chos

colorspaces for the following transforms. Please check

Hide Details...

In this case, the non-compatible transforms are set to the raw colorspace.

The Working Space transform determines what colorspace files should be converted to, on

import, and from, during export - it's the colorspace used by Hiero under the hood.
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Note: In earlier releases of Hiero, this colorspace was hidden because linear was always
chosen as the Working Space. You may find that some operations work better in
colorspaces other than linear. For example, some transforms work better in the CLog
colorspace.

3. You can use Default Color Transforms dropdown menus to override how clips in the Viewer,
thumbnails, and so on are converted to and from the Working Space.

4. The Nuke Script Project Settings dropdown determines whether Hiero uses the LUTs read from
the configuration specified or the Nuke native LUTs during export. Selecting OCIO makes the
relevant OCIO LUTs available to the Read and Write nodes in scripts on a per project basis.

All configurations except nuke-default automatically switch this control to OCIO.

When the Nuke is selected, Reads and Writes work the same as in previous versions of Hiero, with no
integrated OCIO transforms. When OCIO is selected:

* Reads and Writes use OCIO transforms, with no Hiero built-in LUTs applied to the image.

* Read and Write colorspace controls are populated with the list of colorspaces defined in your
currently selected OCIO config.

* The default LUT settings dropdowns are also populated with the list of colorspaces or display
transforms defined in your OCIO config. The default value for each menu match the defaults in a

Hiero project with the same config. These defaults can be overridden using Python callbacks. See the
following path for the default implementation that ships with Hiero:

<install dir>/plugins/nuke/colorspaces.py

* The working space dropdown allows you to change the colorspace that Nuke uses internally for its
image processing. This automatically sets the in colorspace of Write nodes and Viewer Processes,
and the out colorspace for Read nodes. This defaults to the scene linear role defined in your OCIO
config.

* Hiero-created comps no longer contain automatically injected OCIOColorspace nodes. Instead, OCIO
Color Management is automatically set in the comp’s Project Settings, and the correct OCIO
colorspace is set directly into the Read and Write nodes.

Adding OCIO Configurations

You can add your own OCIO configurations to Hiero as they become available, such as new versions
of ACES. You can also add legacy configs for backward compatibility.

1. Navigate to the location of your .nuke file as shown by platform. You may have to create a .nuke
folder if it doesn't exist.

* Linux: /users/login name/.nuke

* Mac: /Users/login name/.nuke
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* Windows: ~\.nuke

Note: On Windows, the .nuke folder can be found under the directory pointed to by the
HOME environment variable. If this variable is not set (which is common), the .nuke directory
is under the folder specified by the USERPROFILE environment variable - which is generally of
the form drive letter:\Documents and Settings\login name\ or drive letter:\Users\login name\

To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer.
If the environment variable is set, the folder it's pointing at is opened.

2. Recreate the following structure within your .nuke folder:
~/plugins/0OCIOConfigs/configs/<config name>

3. Copy the contents of the config into the config name named folder. There should be a luts folder
and .ocio file at the bare minimum.

4. If Hiero is already running, relaunch the application to apply the change.

5. You can now select your configuration from the Project Settings > Color Management >
OpenColorlO Config dropdown.

Adding OCIO Roles

OCIO roles allow you to set custom role names for different colorspaces to make it easier for artists to
instinctively know which LUT to use for any shot. For instance, if an element is coming from your
matte painting department and should always be brought into Nuke as sRGB, you can create a matte
painting role, which is associated with the sRGB colorspace for your artist to select.

OCIO roles are the primary method for selecting colorspaces. All of the colorspaces in the OCIO config
file are still accessible, but they have been grouped together into a Colorspaces menu under the
roles.
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OCIO roles are stored in config files, some of which ship with Nuke in the following directory:
<install dir>/plugins/OCIOConfigs/configs/

For example, the aces_1.1 config file includes the following roles:

roles:

color picking: Output - Rec.709

matte paint: Utility - sRGB - Texture
scene linear: ACES - ACEScg

texture paint: ACES - ACEScc

The first part of the role defines the name of the role displayed in Nuke and second part describes
colorspace family and name. The family and name define which colorspace is associated with the
role. For example:

!<ColorSpace>
name: ACES - ACEScg
family: ACES
equalitygroup: ""
bitdepth: 32f
description: |

The ACEScg color space

ACES Transform ID
isdata:
allocation: 1lg2
allocationvars:
to reference:

ACEScsc.ACEScg _to ACES
false

[-8, 5, 0.00390625]
I<MatrixTransform> {matrix:
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0.0447946, 0.859671, 0.0955343, O,
-0.00552588, 0.00402521, 1.0015, O, O, O, O, 11}

Note: The LUT specified must exist in the luts directory in the same location as config file
for the role to pick up the required colorspace.

You can edit these files to add roles or create your own custom config and then point Nuke to the file
using the Project Settings > Color Management > OpenColorlO Config field.

To add a role to a config file:
1. Open the required config file or create a custom config.

2. Enter the role, family, and name of the role under the roles: line. For example:
compositing linear: ACES - ACEScg

3. Save the file and open Nuke.
Open the Project Settings and click the Color Management tab.

5. You can now pick your role from the default LUT settings. For example, you can set the working
space to compositing_linear if you want to work in the ACEScg colorspace.

General
Sequence
Views

RED Settings

Export

8 Bit Files:
16 Bit Files:

Log Files:

Floating Point Files:
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Define Color Space Mappings Using OCIO Aliases

Hiero supports the use of aliases in an OCIO config and checks these when attempting to set the input
transform for a given image or sequence. The aliases feature in OCIO allows config authors to define a
set of alternate names for a color space, which can then be used in place of the primary color space
name. For example, it may be useful to define a more suitable name for file paths, or a color space
name might have changed between versions of a config, so it may be necessary to add an alias for the
older version of the name for backwards compatibility. Additionally if an application tries to set
defaults based on a specific name then aliases can be used to ensure a suitable color space is found.

Below is part of a ColorSpace definition from an ACES 1.3 OCIO config.
- !<ColorSpace>

name: ARRI LogC3 (EI800)

aliases: [arri logc3 ei800, Input - ARRI - V3 LogC (EI800) - Wide Gamut,
logc3ei800 alexawide]

family: Input/ARRI

equalitygroup: ""

bitdepth: 32f

description: |

Convert ARRI LogC3 (EI800) to ACES2065-1

Here you can see the name: attribute is defined as ARRI LogC3 (EI800). This is the primary name for
the color space.

Directly below is the aliases: attribute. This is where the alternate names are defined, in this case:

e arri logc3 ei800
e Input - ARRI - V3 LogC (EI800) - Wide Gamut

e Logc3ei800 alexawide

The first and third aliases (arri_logc3_ei800 and logc3ei800_alexawide) could be an example of a
suitable name for including in a file path.

The second alias (Input - ARRI - V3 LogC (EI800) - Wide Gamut) is the name that was used for this
color space in ACES 1.2. This is useful when switching from an ACES 1.2 config to ACES 1.3. The Hiero
script will likely reference the older name but the alias means the input transform should be set
correctly without any user intervention required.

Adding an alias to a color space in an OCIO config can be as simple as appending it to the end of the
comma separated list. For example:
- !<ColorSpace>

name: ARRI LogC3 (EI800)
aliases: [arri logc3 ei1800, Input - ARRI - V3 LogC (EI800) - Wide Gamut,
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logc3ei800 alexawide, AlexaV3LogC]

Here we've added the alias AlexaV3LogC. This is the color space name that Hiero looks for in the first
instance when it detects an ARRI V3 LogC file.

Note: In versions of Hiero prior to 14.1 the example above would typically result in an error,
because there isn't a matching color space name in the ACES config.

From Hiero 14.1, the following aliases are included in our ACES 1.3 configs:
- Aliases (Nuke > ACES):

AlexaV3LogC > ARRI LogC3 (EI800)

ARRILogC4 > ARRI LogC4

Blackmagic Film Generation 5 > BMDFilm WideGamut Genb
Log3Gl0 > Log3Gl0 REDWideGamutRGB

SLog3 > S-Log3 S-Gamut3

Gammal.8 > Gamma 1.8 Rec.709 - Texture

GammaZ2.2 > Gamma 2.2 Rec.709 - Texture

GammaZ2.4 > Gamma 2.4 Rec.709 - Texture

The color space names that Hiero currently looks for can be seen in the nuke-default OCIO config.

For more information on aliases and authoring configs please see the official OCIO documentation.
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Creating and Using Project
Templates

You can create templates for Hiero or Nuke Studio by creating .hrox files in the .nuke/Templates
folder. This helps if you have particular Project Settings, such as Colorspaces, footage, and folder
structures, that you wish to reuse across multiple projects.

1. Set up a Hiero or Nuke Studio project with your desired Project Settings, footage, and folder

structures.

Create a folder named Templates under your .nuke directory, if you don't already have one.

Save your Hiero or Nuke Studio project into the .nuke/Templates folder, with a name for the
template. E.g. Advertising ACES.hrox.

Templates

<

@ MNew ~

% Home
_"] Gallery

> @ OneDrive

B NMacltan
2 items

1. When you start Hiero or Nuke Studio, close the opening dialogue window via the Close button.

X als

J > = nuke

@

Name

@ Advertising_ACES.hrox

¥ examplehrox

>

Templates

T sort ~ = View ~

Date modified
19,/08/2025 16:28

21/08/2025 12:.04

Search Templ Q

aee [:E] Details
Type Size
Nuke Studio Project

Nuke Studio Project

2. A New Project dialogue box will open allowing you to select a template from the dropdown.
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& New Project X

example

3. A new project will open with your saved setup to reuse.

Video: See this in practice - Creating Project Templates.
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Importing Sequences

Hiero allows you to import your EDL, OTIO, XML, or AAF sequences in one of two ways, depending on
your preferences. Either:

* Navigate to File > Import EDL/XML/AAF or Import OTIO and then use the browser to locate the EDL,
OTIO, XML, or AAF, and then select the file and click Open to import the sequence,

OR
* Drag-and-drop the EDL, OTIO, XML, or AAF files directly from a file browser into the interface.

If you're importing an EDL, bear in mind that there is no guaranteed frame rate information included
in the file, so an Import Options dialog displays.

o D) Impedt Options

1. Select the correct frame rate and use the following check boxes, if required:
* Drop Frame - when enabled, the EDL is assumed to contain drop file information. SeeTimeline
Playback Tools for more information.
* Assume differences in source/destination durations indicate a retime - when enabled, any
disparity between the source clip (Src) and shot (Dst) duration is treated as a retime.

2. Click OK to import.

OTIO, XML and AAF files imported into Hiero support transform, crop, and retime edit decisions
implemented in third-party applications, such as Adobe Premiere, Apple Final Cut Pro, and Avid
Media Composer. The information in the .otio, .xml, or .aaf is interpreted using soft effects, such
as Transform and Crop. Non-linear retimes are represented by TimeWarp effects. Constant linear
retimes are handled in the same way as in previous versions of Hiero. See Notes on AAF
Sequences for more information.
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Note: Non-linear animation curves from .otio or .xml may not appear as expected when
imported. As a result, you may need to adjust the handles on curves to match footage
between keyframes in the Curve Editor or Dope Sheet.

See the Nuke User Guide, Getting Started, Using the Compositing Environment, Animating
Parameter section or the Nuke Online Help for more information.

Additionally, Premiere Pro .xml exports only support constant, linear retimes. As a result,
retimed shots on the Nuke Studio timeline may not match those on the Premier Pro timeline,
because certain non-linear retime data is not written into the exported .xml file.

After importing the EDL, OTIO, AAF, or XML the Conforming workspace displays and the spreadsheet
and timeline are populated with offline clips - media with an unknown location.

Note: The Event column represents the clip’s position on the timeline, not its event number
from the edit.

Notice that clicking entries in the spreadsheet highlights the corresponding shots on the timeline?
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The spreadsheet, timeline, and Viewer are linked together when viewing sequences. If suitable screen
real estate exists within the current workspace, double-clicking a sequence forces the associated
panel to open automatically. If you want to close a single panel in a linked group, hold the Alt modifier
while closing the linked panel, otherwise all panels in the group are closed.

Note: If you imported an XML sequence, you may find that Hiero has automatically matched
media for you.

Any transform, crop, or retime edit decisions from third-party software .otio, .xml or .aaf files are

represented using soft effects. These effects are imported along with the shot to which they're
associated.
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Notes on AAF Sequences

Avid Media Composer supports retimes using curves that map frame to frame or frame to speed.

Hiero handles the import differently depending on the retime method.

+ frame to frame - describes the retiming in relative terms, such as 'at frame 100 in the output clip,
display frame 50 of the source clip'.

+ frame to speed - describes the retiming in terms of overall output duration. For example, half speed
doubles the duration of the clip.

Hiero's TimeWarp effect only supports frame to frame mapping, which means that frame to speed
retimes from .aaf files requires some curve-fitting to describe the required retime. As a result, the
keyframes generated in Hiero don't match those in Avid, but the resulting curve should match the

original very closely.

Note: Hiero currently only supports Fixed Keyframes from Avid Media Composer.

Tip: If you need to adjust the handles on curves, see
https://learn.foundry.com/nuke/content/getting_started/using_interface/animating_

parameters.html for more information.

Hiero's TimeWarp effect supports the following Spline types when importing .aaf files:

* Shelf
* Linear
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* Spline
* Bezier
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Conforming Sequences

Once your EDL, OTIO, AAF, or XML sequences are imported, it's time to begin the conform process to
match the offline shots in your spreadsheet with the source clips on disk. You can conform sequences
by searching on disk or by pre-ingesting the required clips into Hiero.

Note: Projects containing large amounts of movie files (for example .r3d and .mov) may
exceed the number of available file handles per process, causing problems opening new files
or projects and exporting.

You can increase the default limit of 1024 by entering the following command from the

terminal, then running the application from the same session:
ulimit -Sn 2048
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Conforming Using a Browser

To conform a sequence using a browser:

1. After importing a sequence, click Match Media on the spreadsheet and use the browser to locate
the source folder containing the correct media.

Note: Match Media can also be used on selected events in the Spreadsheet view.

2. Click Open to display the Conform Options dialog.

Mative Rules:

X Umid X RedTapeName X RedMame
X ReelMame X FullPath X FileMame
X FileHead X PartialName ¥ FolderName

Select All Unselect All

Patterns:

Include patterns: {supportedfiles}

Hiero uses a set of conform Rules and file name Patterns to match candidate media files on disk to
the events, or shots, in a sequence:

* Rules - sets the offline media properties to match to the corresponding spreadsheet entry
during conform.

Rules that rely on information that doesn't exist in the event or candidate clip are ignored, and
some rules compound others to identify a better match.

Rule Description

Umid Match a file’s unique material ID (UMID) - that is written into the file's
metadata on creation - to the candidate media’s UMID. If either, or both,
lack a UMID this rule is ignored.

RedTapeName Match a RED-style camera reel name from the event to the candidate media
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Description
name.

Look for a RED-style camera file name in the event that matches the
candidate media name.

Look for the event's reel name in the candidate's media name.
Match the event's entire filepath to the candidate media’s entire filepath.

The Event is the first field in the Spreadsheet view, the order in which shots
appear on the timeline. Candidate media is the media that Hiero is testing
the conform rules against.

Match only the event's file name (no path) to the candidate media’s file
name.

Match the event's file name head (no path, file extension, or padding) to the
candidate media’s file name.

Look for the event's name in the candidate media’s name and vice versa.

Look for the event's name in the filepath of the candidate media.

All rules are enabled by default, but you may occasionally need to disable rules if they cause
incorrect matches between a particular edit and set of source clips.

Tip: Use the Select/Deselect All buttons to quickly enable or disable rules.

* Patterns - sets the inclusion and exclusion parameters during the conform, separated by spaces.
For example, *mov *dpx would only include or exclude .mov and .dpx files.

You could also conform by name, such as BR_Shot*, which would only include or exclude source
clip names starting with that string.

Tip: It's always a good idea to be as specific as possible with search locations during
conforms, but if the need arises, conform Rules and Patterns can save time.

Enable Accept best timecode match... to use the nearest source timecode match to conform the

event, if no rules are matched.

USER GUIDE

178



Conforming Using a Browser |

When Ignore clips with non-overlapping timecodes is enabled, any potentially matching source
clip whose timecode doesn't overlap the shot in question at all is ignored.

Disabling Ignore clips with non-overlapping timecodes causes Hiero to fall back to the other
selected conform rules, even if the timecodes don't overlap.

Check Conform shots that already have media if you want to update all timeline shots. By
default, the application doesn't try to conform events that are not offline.

When Split sequences is enabled, any non-contiguous file sequences found by the conform are
split into separate clips, in the same way as when the split seq option is enabled in the file
browser.

Click OK to begin the conform process.
Hiero attempts to conform the edits with the selected media.
A dialog box informs you of the success rate once the conform is complete.

A
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Note: You can display the conform Rules matched for each spreadsheet object by hovering
the cursor over the required entry.

Import Track Match Me

E Status

FE::Fer'Ern:E Media
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Conforming with Pre-ingested
Media

To conform with pre-ingested media:

1. If your source media has been ingested, you can drag-and-drop media from the bin view onto the
Match Media button.

See Ingesting Media for information on getting media into Hiero.

2. Follow the Conform Options instructions described previously to complete the conform process.

If you want to conform a single entry in the spreadsheet, drag-and-drop the media from the bin
view onto the required entry in the spreadsheet.
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ound Renders

Import Track Match Media

E Status

Conforming individual, pre-ingested media doesn’t require Conform Options because Hiero
already knows the exact location of the media and trusts your decision to replace a shot.
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About the Media Spreadsheet

All events in a sequence are displayed in an easy to read format in the spreadsheet including status,
the track it resides on, length, and the source file location.

After conforming, you can use the spreadsheet to locate source clips or replace shots in the timeline,
as well as massage timecodes if they are invalid.

The media spreadsheet displays each entry’s current media state:

« I - the media was successfully conformed and its timecode is correct.

« 351 - the media was successfully conformed, but the timecode is currently incorrect.
« [l - the media could not be conformed.

Note: Any source or destination field highlighted in yellow indicates that the entry has been
rounded down for display purposes.

See Managing Timelines for more information on importing tracks and reference media.

Sorting and Custom Columns

The spreadsheet can be organized in much the same way as accounting spreadsheets:

* Right-click the column headers to display the list of default columns available. Enable or disable each
column using the checkboxes.

* Click the required column to sort the spreadsheet in ascending or descending order, as indicated by
the arrow in the column header.

* Drag-and-drop column headers to reorder the spreadsheet as required.

* Add custom columns, such as Tags, using the Python API. See Help > Documentation for more
information on the Python API.

Tip: Hiero's Project panel search functionality extends to the spreadsheet, allowing you to
enter strings and apply searches on all or partial matches with the option to include
metadata searches. Hiero searches for items that match any of the input string and displays
only those items by default. See Sorting and Searching Media for more information.
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Spreadsheet Controls

There are also a number of controls, accessed by clicking the cog icon, that determine the
spreadsheet’s appearance and behavior.

Missan_¥_Trail_w2
Import Track  Match Media

Status

Retime method: Keep timeline duration

Time Edit Behawviours: Choose Settings

+ Select Matching Name - when enabled, selecting an item in the spreadsheet highlights all items
with the same name.

* Select Linked - when enabled, selecting an item in the spreadsheet highlights other items linked to
it, such as audio tracks ingested with video tracks.

* Display Speed As - sets the unit used in the Speed column of the spreadsheet. Select either fps
(frames per second) or % (the percentage of the media frame rate).

* Retime method - sets the type of Speed retime applied on the timeline.
* Time Edit Behaviors - sets how source and destination In, Out, and Duration are calculated.

See Retiming Shots for more information on retime methods and Timeline Editing Tools for
source/destination calculations.

You can locate, display, reconnect, or rename shots directly from the spreadsheet.
+ Hold Alt and click an entry to move the playhead to the shot's In point on the timeline.

* Hold Alt and double-click an entry to move the playhead to the shot’s In point on the timeline and
zoom to fit the timeline view.

* Right-click a spreadsheet entry and select the required option:
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5

Import Track Match Media Set Reference Media

Ewvent Status ame lee rack Action
45 40 Cut

* Open In - the associated source clip opens in the selected location, such as a Viewer.
* Project View - the associated source clip is highlighted in the bin view.

* Reconnect Media - attempt to reconnect the media from a specified location on disk, such as
when the source was originally on a drive that is no longer connected.

* Replace Clip - replaces the selected entry with a specified source clip. Nuke Studio assumes that
any source clip you choose is acceptable, regardless of timecode.

* Delete - deletes the selected entries from the spreadsheet and timeline.

« Version - access the powerful versioning system to control which version of the selected shot is
visible in the sequence. See Using Versions for more information.

* Tags - add tags to your selection directly from the spreadsheet view. See Using Quick Tags for
more information.

* Localize - control the localization of clips, tracks, and sequences from the spreadsheet. See
Localizing Media for more information.

* Soft Effects - add soft effects to shots directly from the spreadsheet, see steps below.

Using the Spreadsheet View

You can add soft effects using the spreadsheet view in any workspace by doing the following:

1.
2.

To open the spreadsheet view in any workspace, select Window > New Spreadsheet View.
Right-click a sequence in the bin view.
This opens a context menu.

If the spreadsheet view is not already populated in the context menu, select Open In >
Spreadsheet View.
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Ctrl+Return
wer Ctri+Alt+Return
rinput A 1
Snapshot Viewer Input B 2

Tags Timeline View
- e bt o

3

Ctel+Shift+E Versions Bin

This loads the sequence in the spreadsheet view that you previously opened.

Right-click an event from the list in the spreadsheet view and select Soft Effects to open a list of
all available soft effects. See Adding Effects on the Timeline for more information.

Select the required soft effect from the Soft Effects list.

The sequence-level soft effect is then displayed above the shot and is color coordinated. For
example, if the effect appears in green on the timeline, the corresponding effect properties are
highlighted in the same color in the Properties pane.

When you insert a soft effect, its Properties open automatically. If you have it open, the effect
properties panel displays in the Properties pane. If the Properties pane is not open, the effect's
properties panel appears as a floating dialog.
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Adjusting Timecodes

You can easily adjust single or multiple event timecodes:

1. Select the invalid entry or entries in the spreadsheet.

2. Double-click in the Src In column.

3. Adjust the timecode as required. You can enter absolute or relative timecode values:

* Absolute - absolute timecodes contain eight digits and specify the new timecode for the event,
regardless of the current timecode.

Example Result
01:05:43:21 Sets the timecode at 1 hour, 05 minutes, 43 seconds, and 21 frames
01054321

* Relative - uses + and - values to alter the timecode relative to its current value. You can also use
h, m, and s to denote hours, minutes, and seconds.

Current Position Example Result

01:05:43:21 +1h 02:05:43:21
-110 01:05:42:11
+10000 01:06:43:21
-6m 00:59:43:21

The media changes state to .

Note: Timelines start at 01:00:00:00 by default, but you can change this to any value using
the Sequence panel.
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[ | =t niceq

Sequence Metadata Properties

Output Resolution: |1920x1080 HD_1080

Frame Rate:
Start Timeco

Time Ch

If you're not sure what the timecode should be, you can:

* Hover the mouse over the target entry in the spreadsheet to view a timecode tooltip.

Import Track Match Media Set Reference Media

Status Caolor

‘ - :
Media Timecode: 00:35:24:03 - 00:35:23:08

Conform Rules Matched: FileMame FileHead PartialName

10

OR
* Examine the source clip’'s metadata and calculate the correct Src In:
1. Right-click the required entry and select Project View.
2. Right-click the clip in the bin and select Open In > Metadata View, or press Alt+D.

The selected clip metadata is displayed in a floating pane.
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ct Ratio

USER GUIDE
189



Renaming Shots on the Timeline |

Renaming Shots on the Timeline

Once you've conformed your edit, you may want to rename shots on the timeline sequentially for
clarity.

To rename shots:
1. Select the shots to rename using the timeline or spreadsheet view.
2. Right-click on the timeline and select Editorial > Rename Shots.

Tip: You can also navigate to Timeline > Rename Shots or use the Alt+Shift+/ keyboard
shortcut.

The Rename Shots dialog displays.

Seguential Rename =

Increment: 10

Include Clips From Audio Tracks

Restore Defaults Rename

3. Select the rename type from the dropdown:
* Simple Rename - all shots are replaced by the New Name specified.

* Find and Replace - a simple find and replace shot name. All selected shots containing the
specified Find pattern are substituted with the Replace pattern.

* Sequential Rename - rename shots sequentially using the Pattern, Start #, and Increment
fields.

« Match Sequence - allows you to select a sequence to copy shot names from, providing that they
use the same shots. For example, renaming shots on a 30 second timeline to mirror the shot
names from a 60 second timeline.

Note: You can only use sequences that reside in the same project and shots that have
overlapping frame ranges.

* Clip Name - all shot names are replaced by the name of the source clip they reference. This
option can be used to revert previous rename operations.
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« Change Case - the case of all shot names is changed, as specified by the Case dropdown. For
example, selecting Title Case capitalizes the first character of each word.

4. Rename operations also accept token substitutions. The following tokens are recognized:

Token Resolves to

{clip} The name of the source clip referenced by the target shot.
{event} The EDL event number associated with the target shot.
{filename} The file name of the shot's source.

{fps} The frame rate of the sequence containing the rename target.
{sequence} The name of the sequence containing the rename target.
{shot} The name of the shot.

{track} The name of the track containing the rename target.

5. Enable Include Clips From Audio Tracks to rename audio shots as well as video shots.
6. Click Rename.

The selected shots are renamed as specified.
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Saving and Loading Projects

You can save your work in a project using the .hrox file extension. Projects can contain .nk scripts in
the form of shots added by using Create Comp Clips during round-tripping. See Building VFX Tracks
and Comp Clips for more information.

If you quit the application without saving, you'll be prompted to save or discard your changes:

Save changes to "Untitled 2° before closing?

Don't Save Cancel Save

Click the required button or press D for Don’t Save or S to Save.

Note: If you have a .nk script open in the same session, a second prompt is displayed so you
can save your script as well.

To save a project:
1. Navigate to File > Save Project or Save Project As...
OR
Use the Ctrl/Cmd+S or Shift+Ctrl/Cmd+S keyboard shortcuts respectively.
The Save Project dialog box displays.
Browse to the save location and enter a name for the project.
Click Save.
Your project is saved to the location specified and appends the .hrox file extension automatically.

To load a project:
1. Navigate to File > Open Project.

Tip: If you need to open a project that you worked on recently, you can select Open Recent
Project to quickly locate your work.

OR
Use the Ctrl/Cmd+0 keyboard shortcut.
The Open Project dialog box displays.

2. Browse to the file location and click Open.

USER GUIDE
192



Saving and Loading Projects | Using the Spreadsheet View

Your project opens and populates the necessary panel automatically.
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Autosaved Projects

The autosave function creates a temporary project save file at 5 minute intervals, but you can adjust
force project autosave after in the Preferences > General dialog. See Appendix A: Preferences for
more information.

At startup, the application scans for autosaved projects and displays a prompt if autosaves exist.

1 autosaved project.
like to load it?

o will delete it

Click Yes to load the autosave or No to ignore and delete it.

Opening a project also uses the autosave functionality. If the autosave is more recent than the saved
project file, a prompt displays:

The autosave file for
ject.hrox is newer.

Click Yes to load the autosave file or No to load the original project file.

Note: Clicking No does not delete the autosaved project in this case.
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Timelines contain video and audio shots that reference the source clips in your project. Once the
conform process is complete, the timeline displays your clips in context and enables you make finer
edits. Timelines can contain any number of video sequences and audio tracks with each track
containing shots that reference the source clips in your project - making changes to shots in the
timeline does not affect the original source clip.

Hiero also features real-time soft effects on the timeline and the ability to add shots containing .nk
scripts. See Adding Effects on the Timeline and Building VFX Tracks and Comp Clips for more
information.

Note: Conformed EDLs only support one video sequence. If you've created multiple EDLs
from the same edit, you can add each one into the timeline using the right-click New Track >
New Track(s) from EDL/XML option or the Import Track button in the spreadsheet tab.
See Adding Tracks to the Timeline.

Video Disk Cache . Playhead
Timecode i
Toggles Controls Position

01:00:08:00

Track Lock Audio Audio Vidt“_

Toggles Tracks Tracks

* Video Toggles - quickly turn off and on video tracks during playback. Hold Alt and click to solo the
selected track. You can also enable and disable track blending and masking. See Blending Tracks on
the Timeline for more information.
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* Disk Caching Controls - click and hold to display the disk caching options for the current timeline.
See Caching Frames in the Disk Cache for more information.

* Timecode - displays the timecode or frame number depending on the Time Display mode selected.
You can adjust the scale using the Scale Slider or by using the mouse wheel.

* Playhead Position - displays the playhead location synchronized with the contents of the Viewer.
* Video Tracks - contain all video sequences for the current timeline.

* Audio Tracks - contain all the audio clips for the current timeline.

+ Audio Toggles - quickly mute audio or set the track output during playback to left, right, or mono.
* Track Lock - secure the selected track to disable all editing tools.

Tip: Selecting tracks while holding Ctrl/Cmd allows tools to affect multiple tracks at once,
such as locking, disabling, and resizing tracks.

Video tracks in multi-track timelines are read from the highest number track downward, for example
Video 3, Video 2, Video 1. As a result, if video is present on track 3, video on track 2 in the same time
slice is obscured.

In this example, although the playhead crosses clips on two video tracks, only the clip in Video 3 is
displayed in the Viewer.

01:00:06:13 |...................|.........'.'.'T:.];....|..............
01:00:00:00 01:00:04:00 01:00:08:00

Ref_nce

RIAS bbb e A Hihn et

Audio 2

Audio tracks, on the other hand, play back simultaneously - all the audio tracks crossed by the
playhead in the example play back together, creating a complete audio backing for the video.
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Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.
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Adding Tracks to the Timeline

You can add empty tracks to existing timelines or import other EDL, OTIO, AAF, or XML edits -
effectively another sequence within the timeline.
To import EDL, OTIO, AAF, or XML edits:

1. Select the required sequence in the project bin, right-click, and select Import > New Track(s) from
EDL/XML or New Track(s) from OTIO (Beta),

OR
Click Import Track in the spreadsheet tab.

Match Media | Set Reference Media £}

Status

2. Use the browser to locate the EDL, OTIO, AAF, or XML files, select the file(s) and click Open to
import the sequence.

Note: If you're importing EDLs, bear in mind that there is no guaranteed frame rate

information included in the file. Select the correct frame rate then click OK in the dialog
supplied.

3. Conform the new track as described in Conforming Sequences.

To add new tracks:

+ Hold Shift and drag a shot to insert a new track above or between existing tracks,
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01:00:04:00 01:00:0

Ref..nce

Audio 2

Tip: This is the default behavior. If you disable Preferences > Panels > Timeline > Hotkey
required to insert new track, the new track is created automatically.

OR
* Right-click in the timeline and select New Track > New Video Track or New Audio Track.

1 I T T T T T T T T S O S (T S N T TN N T S (N Y SN SN T SO T B S O SO
01 :00:00:00 01:00:04:00 O1:00:0

(e
Frame Control

Audio _ r-'____,.. —

Clip

Disk Cache

Version

Editorial
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Note: You can also collapse and expand existing tracks using the right-click Editorial menu,
and resize the track header to accommodate longer track names.
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Adding Clips to the Timeline

The timeline allows you to add clips by simple drag-and-drop from either the Viewer or bins. Using the

Viewer restricts you to a single clip, the current clip, but you can drag as many clips as you like from
bins.

Tip: You can create a new sequence by dragging a clip to an empty timeline pane.

New timelines pick up their frame rate from the Project > Edit Settings > Sequence sub-menu by
default. Dropping a clip with a different frame rate on a new timeline displays a warning:

The clips and sequence have different frame rates. You may:

® Change the sequence frame rate (48 fps) to match the clips (25 fps)
Maintain the duration of the clips

Maintain the frame count of the clips

Cancel

However, if the timeline is already populated and the clip you're adding doesn't have the same frame
rate as the timeline, you're prompted to choose whether the clip’s duration or frame count is retained.
The clips and sequence have different frame rates. You may:

® Change the sequence frame rate (24 fps) to match the clips (25 fps)
Maintain the duration of the clips

Maintain the frame count of the clips

Take care not to overwrite existing shots - the most recent clip overlays any existing shot. To avoid
this, do one of the following:

* Move the playhead to the target area of the timeline in the record Viewer , load the required clip

in a source Viewer , and then use Insert (N) or Overwrite (M) to place the clip into the timeline
at the playhead position on the lowest, unlocked track available.

Note: You can only Insert or Overwrite using clips from the current project.
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See Insert, Overwrite, and 3-Point Editing for more information on source/record editing.

* Use the Multi or Move/Trim tools to make space for the new clip and then drag-and-drop it in to
the space (see Using the Move/Trim Tool for more information).

TR B [ B
01 :00:00:00 01:00:04:00 01:00:08:00

Ref..nce

Audio 2

* Drag-and-drop the new clip at the end of the sequence, then using the Multi or Move/Trim tools,
drag the new clip to an existing transition, hold down the Alt modifier, and drop the clip to Ripple all
other shots down the timeline.

R ]
01:00:00:00 01:00:04:00 01:00:08:00 01:00

Ref..nce

Audio 2
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Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.
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Audio and the Timeline

Audio tracks on the timeline are handled in much the same way as video tracks. By default, linked
audio and video tracks are edited at the same time, but you can lock either track and move them
independently or hold Alt to select a single track, if required.

Hiero supports integrated audio from container files, such as .mov, and audio specific files, such as
.wav, on the timeline. Hiero assigns the channels in the audio file to separate tracks and matches the
channels in the file to the available channels on the timeline.

When both Viewer inputs contain clips, the audio output is set by the orange marker in the color

picker information bar, displayed by clicking . In the following example, input A is providing the
audio output:

W [A] C003_006_3010_04 - 01:00:01:08 (00:05:37:20) - 1920 x 1080 - 25 FPS

[B] A016C006_101031_L103 - 01:00:01:08 (08:12:03:09) - 1920 x 1080 - 25 FPS

A

01:00:01:08
| L} L} L] L L L} L] L} 1] I ] L} L] Ll 1) L} ' L L] I ' L} L} L} ] L] L} L} L l L} IYI ' L L L] L l L} L] Ll
01:00:00:00 01:00:00:20 01:00:01:05 01:00:01:15

¥ TC~ Global ~ - I 14 <t | <

v

The volume slider in the upper-right corner of the Viewer controls the output level for that Viewer
only.

Audio output for shots can be toggled between eight channels, depending on the requirements of the
clip or shot: left, center, right, left surround, right surround, low-frequency effects, back surround left,
and back surround right. Click on the dropdown to cycle between outputs:
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1:00:00:00 01:00:02:02

3

right

left surround

right surround
low-frequency effects
back surround left

back surround right

You can also control audio on a per track and per shot basis. Audio track headers and shots have
independent volume controls in the timeline and Properties tab.

* Track headers - click and hold the mute icon on the header to display the volume slider.

Tl 20 0000 0 \ \ \ [ N T I T
01:00:00:00 01:00:04:00

i

k‘ = Ref_.nce

Audio 2

* Shots - select an audio shot and click on the Properties tab to display the Volume control.

Tip: You can control the volume on multiple shots simultaneously by holding Ctrl/Cmd and
selecting the required items before adjusting the volume slider.
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The Preferences > Panels > Viewer (Sequence) sub-menu contains audio controls allowing you to
control the volume level for all new Viewers. See Appendix A: Preferences for more information.

Note: If the frame rate drops too low, audio is automatically muted and the speaker
changes to the no audio playback icon.
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WAV Shots

Audio can be recorded at the same time as shooting the video or it can be unrelated to the shoot, for
example sound effects or music. You can add .wav clips to the timeline in two ways:

* Drag-and-drop - drag your .wav clip to a timeline audio track and drop it in to place.
+ Navigate to File > Import File(s) or Import Folder(s).

Tip: You can also use the Ctrl/Cmd+I and Ctrl/Cmd+Shift+l keyboard shortcuts.

Hiero assigns the channels in the audio file to separate tracks and matches the channels in the file to
the available channels on the timeline. If a channel is not matched correctly, you can select the
channel manually using the dropdown in the track header. For example, LFE (low frequency effects)
may be assigned to C (center) incorrectly.

01:00:00:00
Audio 1
Audio 2

Audio 3

centre

right

Use theTimeline Editing Tools to move the clip into place and set its output.
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Displaying Audio Waveforms

Visualizing an audio waveform helps synchronization with video events, and Hiero displays waveforms
in the timeline by default.

Audio shots are manipulated in the same way as video shots, so using waveforms in conjunction with
the Timeline Editing Tools enables you to quickly synchronize audio and video events. Audio shots
also support Fade In, Fade Out, and Dissolve transitions in the same way as video. See Adding
Transitions Between Shots and Audio Clips for more information.

You can toggle the waveform display on and off by right-clicking in the timeline and selecting View >
Audio Waveforms. You can also control how the waveform appears, when enabled. Open the
Preferences and navigate to Panels > Timeline to toggle between full and half waveforms.

.': 00:00 :,:
New Track 00 01:00:04:00

Edit

Open In

Mark
Frame Control *

Audio

Displaying waveforms in audio-heavy projects can cause significant slow down on the timeline, so
Hiero includes a preference to limit how much system memory is available for waveform display. In
the Preferences, navigate to Performance > Caching > Audio Waveforms and set the waveform
memory control to the required amount.
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Audio Scrubbing

Hiero's timeline supports audio scrubbing, allowing you synchronize audio and video more easily
while scrubbing the playhead. Audio scrubbing is disabled by default, but you can enable it by right-
clicking in the timeline tab and clicking Audio > Audio Scrubbing or by pressing Ctrl/Cmd+Alt+S.

Mark:

Frame Control

Editorial

Tags

Localize

Effects

Ref_.nce

Audio 2

Audio shots cache temporarily to increase responsiveness during scrubbing. If you need to clear the
audio cache, navigate to Cache > RAM Cache > Clear Audio Cache.

Note: Audio scrubbing is not currently available through monitor output cards. Audio
scrubbing is only supported through internal audio output devices.
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Synchronizing Audio and Video

Hiero allows you to massage the synchronization between audio and video tracks using audio latency
adjustment during playback in the Viewer, or by a default amount in the Preferences > Panels >
Viewer (Sequence) sub-menu.

Note: Latency adjustments can take a few seconds to affect the audio track.

1. Mark a portion of the timeline containing the target audio and video shots using In and Out
markers.

2. Press = or use the L keyboard shortcut to begin playback.
3. Click the Viewer settings icon and increment the latency using the controls in the popup.

Non RT playback (Play All Frames) *
See Through Missing Media

View (Video Only)

Obey Alpha

7 7 {3 M 525% v 1:1* ~

Audio latency adjustment:

“
|5 ms

4. Adjust the latency until the tracks are in sync.
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PulseAudio on Linux

PulseAudio on Linux distributions has been linked with fluctuating frame rates due to the latency
when retrieving audio samples. If Hiero detects that your setup is running PulseAudio alongside the
application, a warning message displays.

Detected PulseAudio running. This may significantly affect playback
performance. To disable PulseAudio please refer to the Nuke Documentation

Don't show again

Stopping PulseAudio

You can disable PulseAudio for the current user or all users on a machine. To stop the daemon, do the
following:

Note: PulseAudio restarts automatically when you restart you machine, but you can prevent
this by navigating to System > Preferences > Startup Applications and disabling the
PulseAudio Sound System.

1. Open the ~/.pulse/client.conf file to disable PulseAudio for the current user,
OR
Open the /etc/pulse/client.conf file to disable PulseAudio for all users.

2. Set the following attribute and ensure the line is not commented out:
autospawn = no

3. Call pulseaudio --kill to end the PulseAudio process.
Call ps -e | grep pulse to check the process stopped correctly.

Note: Ending PulseAudio while other applications are running may disable audio output.
Stop and start the application to re-enable audio output. Additionally, the desktop audio
slider may be removed.
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Restarting PulseAudio

To start the PulseAudio daemon, do the following:

1.

Open the ~/.pulse/client.conf file to enable PulseAudio for the current user,
OR

Open the /etc/pulse/client.conf file to enable PulseAudio for all users.

Set the following attribute and ensure the line is not commented out:

autospawn = yes
Call pulseaudio --start to start the PulseAudio daemon.
Call ps -e | grep pulse to check the process started correctly.
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Using Reference Media

Importing a reference version of your timeline enables you to compare your current timeline against
the reference media to avoid issues with continuity, missed frames, and so on.

To import reference media, click Set Reference Media and use the browser to locate the required
file.

B nNissan X Trail v2

I=>20Q0 ) < P

Import Track Match Media

Event Status Shot Name

04 C003_006_30...
05 C004_001_30...
06 C003_007_30...
07 C004_001_30...
08 A007C005_10...
09 A010C003_10...

The reference media is automatically imported into Reference tracks, pushing existing tracks
outward, and marked with the Reference Media tag.

After importing the reference media, use the show/hide icon or A/B input tools to compare the
current timeline against the reference clip. SeeComparing Media for more information.

A Nissa..v2_¥ B Nissa..v2_¥

st
horizontal
vertical
under
over
minus
difference
onion skin

invert & add

® gang
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Comparing Media

The Viewer A/B tools allow you to quickly compare media using the two Viewer input buffers. Select a
clip, sequence, shot or track and press A or B to place your selection in the Viewer input buffers. You
can also drag-and-drop items into the input buffers using the Viewer hotspots.

Note: The Viewer currently treats all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image. If you're working with un-premultiplied
images, set the Viewer background to Black. See Appendix A: Preferences for more
information.

When the Viewer input buffers contain sequences, the A and B dropdowns control what is displayed in
the Viewer using track names and tags. Selecting a track or tag from the dropdown displays the
selected media in the Viewer.

Export Queue

under v B Nissa..v2_¥ O 7 J/

all tracks
Nissan_X_Trail_v2_1 V1
® Reference

/
al

Use the wipe, stack, horizontal, and vertical modes to control how the buffers are displayed in the
Viewer.

Note: If you're working in a multi-view project, using stereo footage for example, you can set
which view is output in the A and B buffers using the Views buttons over the Viewer. See
Displaying Views in the Viewer for more information.
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The wipe and stack modes also allow you to blend the two buffers together, and in the case of wipe
mode, provides a handle in the Viewer to quickly wipe between the two inputs.

A Nissa..v2_ ¥
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difference
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o
The color picker overlay displays a description of the contents of the A and B inputs, or No Clip
when there is no clip at the playhead, for instance, when there is a gap in a timeline or if a track is
disabled.

No Clip

W [B] NissanXTrail_Offline - 01:00:02:04 (00:00:02:04) - 1920 x 1080 x=7

A PO ™ A

00 04

||-|-|-t-|y A A N O O O N O T O O e

A
01:00:00:00 01:00:04:00 01:00:08:00 01:00:12:00

TC v | Global ~ D O

v

The orange triangle in the overlay denotes the clip currently supplying audio and timecode
information in the Viewer.

Playhead A/B Indicators

The timeline playhead indicates what is currently displayed in the Viewer using a number of different
display markers. Swapping tracks between buffers automatically updates the playhead so that you
always know which tracks you are looking at in the Viewer.
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» Selecting all tracks in the current Viewer buffer displays an ‘AB’ at the top of the playhead to
indicate that you're viewing all tracks in the sequence from top to bottom.

|||||||||I|||||||||||||||||||||||||||||||||||||||||||||||||I|||||||||||||||||||||||||||||||||||||||||||||||||I|||||||||||||||||||||||||||||||||||||||||||||||||I|||||||||||||||||||||||||||||||||||||||||||||||||I||||
01:01:02:12 01:01:23:08 01:01:44:04 01:02:05:00 01

11:02:27:10

B B 00:02:27:11
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Channel Count: 379 L ation Mode: Off Memaory:

» Selecting a track for the current compare Viewer buffer displays your A or B tab at the playhead
in the selected track.
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Channel Count: 379 Localization Mode: Off Memory: 1.7 G

 Selecting different tracks to the Viewer's A/B buffers draws A and B tabs on the playhead in the
selected tracks.
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Tip: Use A or B hotkeys whilst selecting shots to quickly assign Compare viewers.

01:00 120 01:00:41:16

I

1:00:45:15 01:00:47:22 01:04

Channel Cou
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Caching Frames in the Playback
Cache

The playback cache places frames in RAM for rapid retrieval during playback, rather than creating files
locally as with Caching Frames in the Disk Cache orLocalizing Media.

The white bar under the Viewer represents the contents of the playback cache, a full bar indicating
that the entire clip or timeline is currently accessible from RAM, optimizing playback. You can:

* Temporarily disable caching using the pause button above the Viewer, or use the P keyboard
shortcut.

Clicking pause again, resumes caching from the playhead position.

* Flush the cache completely by navigating to Cache > Clear Playback Cache. Caching is
automatically paused after flushing, but clicking the pause button resumes caching from the
playhead position.

There are also a number of Preferences that affect how much RAM is available and when caching
should occur. To set the caching behavior:
1. Navigate to Hiero > Preferences (OS X) or Edit > Preferences (Linux and Windows),

OR

Use the Preferences keyboard shortcut Shift+S.

2. Select Performance > Caching and set the total RAM cache available using the playback cache
size field.

Note: You can't set this to a value higher than 80% of the memory available (rounded down
to the nearest half-GB). For example, if you have 6 GB of memory available, the maximum
cache size available 4.5 GB.

3. You can enable free timeline playback RAM to discard any frames cached to RAM (the white bar
in the timeline Viewer) when you switch to the Node Graph within Nuke Studio, freeing the RAM
for use in Nuke.

Note: When you switch back to the timeline, the cached files are re-cached, which can be
time consuming.
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4. Enable pause caching when the application goes to the background to pause playback
caching when the application loses focus.
When you click back into Hiero, caching picks up from where it stopped.

5. Enable clear cache when the application goes to the background to flush the playback cache
when the application loses focus.
When you click back into Hiero, caching starts again from the position of the playhead.
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Caching Frames in the Disk Cache

Timeline Disk Caching provides reliable playback for more complex timelines by rendering frames to
disk using the GPU. The cache provides persistent frames per edit in the timeline that only needs
updating for full changes on the edit, such as adding a soft effect. For editorial changes, only the new
frames need to be cached.

Note: Frames are always cached at the sequence resolution, regardless of source clip
format and Viewer proxy settings.

You can cache whole sequences, selections of clip ranges, and frame ranges specified using In and
Out points. Files in the disk cache are frames identical to what you see rendered in the timeline
Viewer, written into .exr sequences, and saved in NUKE_TEMP_DIR/TimelineCache by default.

Tip: You can find the location of Hiero's general cache directory from within Hiero by hitting
X on your keyboard, when the focus is on the Node Graph, and then running the following

Tcl command:
value preferences.TimelineDiskCachePath

Cached frames are represented in the timeline by the state of the timeline cache icon:

=n Automatic cachingis active. See Update Changes to Cached Frames Automatically for more
= details.

. None of the frames in the current timeline are cached.
The current timeline is partially cached.

The current timeline is fully cached.

Cached frames are represented in the Viewer with an orange bar, under the RAM cache bar, which is
white by default.

See Caching Sequence Ranges, Caching Selected Shot Ranges, and Caching In/Out Ranges for more
information.

You can set the cache directory location, size of the timeline cache, and type of EXR compression used:

¢ Click the timeline cache icon and select Cache Settings, or
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* Open the Preferences and navigating to Performance > Caching.

Note: You can override the caching mode in the Preferences using the Sequence panel's
Disk Caching Mode dropdown.

Update Changes to Cached Frames Automatically

Timeline disk caching has two modes, Automatic and Manual, providing greater flexibility when used
in conjunction with soft effects to ensure the best possible performance when playing back on the
timeline.

* Manual - the default mode. When frames are cached, any changes made to soft effects on the
cached frames are not automatically re-cached.

* Automatic - when frames are cached, any changes to soft effects made after the initial cache
operation automatically triggers a re-cache of the affected region of your cached timeline. This
means that your timeline is always cached and up to date in the selected regions, regardless of
changes made.

To set the caching mode for all new sequences:
1. Navigate to Nuke > Preferences (macOS) or Edit > Preferences (Linux and Windows),
OR

Use the Preferences keyboard shortcut Shift+S.

2. Select Performance > Caching.
3. Click the default disk caching mode dropdown and select Manual or Automatic.

Any new sequences you create default to the option selected in the Preferences.

4. You can override this preference in the Sequence panel using the Disk Caching Mode dropdown.

a =} Sequence 1 Mode Graph Curve Editor Dope Sheet

Sequence Properties 14 F
&

RENDER
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Caching Sequence Ranges

Caching a sequence caches exactly what you see when play through the entire timeline. As the

playhead walks the timeline, all tracks are read from the highest track downwards, so what you see in

the Viewer is what you cache to disk.

You can only cache one sequence at a time, either from the timeline itself, the Cache menu, or the

Project bin:

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the

menu bar.

* Select the required sequence in the Sequence tab, click the . icon, and then select Cache
Sequence Range.

(:\' |IIII|IIII|IIIIIIIII|IIIIIIIII|IIII-I.-II-I-.? I.-I:IIII|IIIIIIIII|I
- i 01:00:02:02

*) Cache

* Select the required sequence in the Sequence tab and then select Cache > Disk Cache > Cache
Sequence Range from the menu bar.

Window Project Clip Timeline Help

O Cache Settings

* In the Project bin, right-click the sequence you want to cache, and then select Cache > Cache
Sequence Range.
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See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Caching Selected Shot Ranges

Caching shot ranges allows you to be more selective than caching an entire sequence, though it works
in the same way. All tracks are read from the highest track downwards, so what you see in the Viewer
for the shot selection is what Hiero caches to disk.

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the
menu bar.

As a result of this, you may not get the frames you expect. For example, caching the shot in the image
produces frames from the three shots on the highest track, including the soft effect, not the selected
shot on the COMP track.
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COMPS

You can cache clip ranges from the timeline itself or from the Cache menu:

* Select the required clip range in the Sequence tab, click the. icon, and then select Cache Selected
Shot Ranges.
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COMPS

Select the required clip range in the Sequence tab and then select Cache > Disk Cache > Cache
Selected Shot Ranges from the menu bar.

Render Cache Window Project Clip Timeline Help

Sequence Range

See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Caching In/Out Ranges

Caching ranges uses In and Out points set on the timeline to determine what you cache to disk. All
tracks are read from the highest track downwards, so what you see in the Viewer between the In and
Out markers is what you cache to disk. See Using In and Out Markers for more information.

Tip: You can pause caching at any time by navigating to Cache > Disk Cache > Pause in the
menu bar.

After setting In and Out points, you can cache that range from the timeline itself or from the Cache
menu:

* In the Sequence tab, click the . icon, and then select Cache In/Out Range.
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O Cache Settings

COMPS

Project Clip Timeline Help

O Cache Settings

See Clearing Cached Frames for information on how to clear frames from the disk cache.
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Clearing Cached Frames

Frames in the timeline cache can be cleared in a number of ways, including Clear All frames across all
projects and the more selective Clear Range option.

Clearing All Cached Frames

The Clear All option is only available from the Preferences dialog under Performance > Caching,
because it clears all frames from all projects and should be used with care. Clicking Clear All displays
a warning dialog containing all the projects that are affected.

ring all will rem everything in the disk cache root dir for all projects.
is a list of pro s that hawve data in the disk cache. D want to clear

prev

Mizsan_previs

Click OK to proceed or Cancel to retain all the frames in the cache.

Clearing Sequences

Instead of using the Clear All option, you can clear certain sequences within a project. You can clear a
sequence from the timeline itself, the Cache menu, or the Project bin:

* Select the required sequence in the Sequence tab, click the icon, and then select Clear Sequence
Range.
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* Select the required sequence in the Sequence tab and then select Cache > Disk Cache > Clear
Sequence Range from the menu bar.

Viewer Render Cache Window Project Clip Timeline Help

quence Range

* In the Project bin, right-click the sequence you want to clear, and then select Cache > Clear
Sequence Range.

=
e
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Import
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Clearing Selected Shot Ranges

You can also clear selected ranges of shots from a sequence, rather than the entire sequence, from
the timeline itself or from the Cache menu:

. . . . o1
* Select the required clip range in the Sequence tab, click the. icon, and then select Clear Selected

Shot Ranges.
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& Cache Settings

COMPS

* Select the required clip range in the timeline tab and then select Cache > Disk Cache > Clear
Selected Shot Ranges from the menu bar.

Viewer Render Cache Window Project Clip Timeline Help

O Cache Settings

Clearing In/Out Ranges

Clearing frames using In and Out markers is the most fine-grained method for removing frames from
the timeline cache. Only the frames bracketed by the markers are removed, regardless of how the
frames were cached originally. See Using In and Out Markers for more information.

After setting In and Out points, you can clear that range from the timeline itself or from the Cache

menu:
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. Il .
* In the Sequence tab, click the . icon, and then select Clear In/Out Range.

Viewer Render Cache W w  Project Clip Timeline Help

O Cache Settings
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Viewing Multi-Format Timelines

All sequences and shots added to them adopt the output resolution and clip reformat settings
from the Preferences dialog under Project Defaults > General. You can override these settings on a
per Project or per Sequence basis.

General
- Project Defaults
Color Management output resolution

Sequence

- Performance frame rate
Caching
it start timecode

time display

- Behaviors Clip
Documentation
File Handling
Nodes resize type
OFX Plug-ins
Positions
Scripting
Startup
Timecode

clip reformat

General Sequence

Output Resolution:
Sequence
Frame Rate

Views Start Tim
Time Display:
Clip

Clip Reformat:

Color Management

1920x1080 HD_1080
24 -
01:00:00:00

Timecode ¥

None

1920x1080 HD_1080
01:00:00:00

Timecode ¥

None

Node Graph Curve Editor Dope She

Media Metadata Properties
t Resolution: ' 1920x1080 HD_1080
Frame Rate: 24 7
Start Timecode: 01:00:00:00

Time Display: Timecode ¥

N
=>|

Node Graph Curve Editor Dope She

Sequence Media Metadata Properties

Clip Reformat: None <

Resize Type:

N

The Preferences dialog controls the default settings for
new projects. Existing projects are unaffected by changes
to the preferences.

The Project Settings control the default settings for new
sequences and shots in the current project. Existing
sequences and shots are unaffected.

Project Settings override Preference settings.

The Sequence settings control the current sequence.

Sequence settings override Project Settings and
Preference settings for the current timeline.

The Properties settings control shots in the current
sequence.

Properties settings override Sequence settings, Project
Settings, and Preference settings for shots on the current
timeline.

Reformatting applied to shots on a timeline carry over into any export, including Create CompClips.
The reformat options in the Export dialog are applied after the transforms applied here. See
Exporting from Hiero for more information.
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Setting the Sequence Format

The current sequence format is controlled by the Output Resolution dropdown in the timeline
Sequence tab. The selected resolution is applied to all shots on the timeline, but by default, shots
retain their native resolution. For example, setting the Output Resolution to 2k_DCP on a timeline
containing HD_1080 shots results in the output resolution being larger than the shot.

Tip: Enabling the Custom Sequence Format guide at the top of the Viewer makes it easier
to see differences between output resolution and shot format.

A 1920x1080 shot at native The same shot with Output
resolution. Resolution set to 2048x1080.

Similarly, setting the Output Resolution to a format smaller than the shot's native resolution results
in the clip resolution being larger than the sequence resolution.

A 1920x1080 shot at native The same shot with Output
resolution. Resolution set to 720x486.

Shots with a higher resolution than the sequence format enable you to apply soft effects, such as
Transform, more easily. See Adding Effects on the Timeline for more information.
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Reformatting Shots

Shots on the timeline retain the source clip's resolution by default. You can force shots to the
sequence format using the timeline's Properties tab:

1. Select the target shots on the timeline.
2. Click the Properties tab to display the shot options.

Properties

Mone

Volume:

Note: The Volume control is only available when you have an audio shot selected.

3. Click the Clip Reformat dropdown and selected To Sequence Resolution.
The shot is reformatted to the Output Resolution specified on the Sequence tab.
5. Depending on the source clip, you may need to change the Resize Type:

* Width - scales the original until its width matches the format's width. Height is then scaled to
preserve the original aspect ratio.

* Height - scales the original until its height matches the format’s height. Width is then scaled to
preserve the original aspect ratio.

* Fit - scales the original until its smallest side matches the format’s smallest side. The original’s
longer side is then scaled to preserve original aspect ratio.

* Fill - scales the original until its longest side matches the format's longest side. The input’s
shorter side is then scaled to preserve original aspect ratio.
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* Distort - scales the original until all its sides match the lengths specified by the format. This
option does not preserve the original aspect ratio, so distortions may occur.

Tip: When Clip Reformat is To Sequence Resolution, disabling center places the clip at
the bottom-left of the Output Resolution, rather than the center.

Transforming Shots

If you right-click on a shot in the timeline Viewer, a contextual menu will appear with various options.

By selecting Transform from the menu, you can then choose to either Flop Horizontal or Flip
Vertical.

When you select the checkbox next to each option, the current shot will be transformed.

It is possible to perform both of these transformations at once. To revert back, you can simply select
the checkbox again to disable the transformation.

MOV Options
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Refreshing and Replacing Shots

During the post process, media inevitably changes location or form. Hiero can reload or replace your
media using the refresh, rescan, reconnect, and replace functions.

Mew Track:
Edit 01:00:0

Open In

Mark:

Frame Control

Editorial

Ref_nce

Audio 2

Though all four options deal with reloading shots, each has a particular use dependent on context:
* Reconnect Media - allows you to redirect the file path when the source file location changes.

* Replace Clip - replaces the selected shot with a specified source clip. Hiero assumes that any source
clip you choose is acceptable, regardless of timecode.

* Refresh Clips (F8) - allows you to reload the shot when the source file location has not changed,
such as when work has been done on the clip offline. Selecting refresh only refreshes the clip’s
current frame range.

* Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional
frames that may have been added to the source file and adds them to the shot's frame range.

* Set Soft Trims - sets the files handles on the selected clip(s). SeeSetting Soft Trims for more
information.
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Setting Soft Trims

Soft Trims limit the handles on shots to a pre-defined amount, simulating In and Out points on the
source clips, allowing you to use other timeline tools on the shots such as Slip Clip and Slide Clip.

To set Soft Trims on a shot(s):
1. Select the shot(s) on the timeline.
2. Right-click and select Clip > Set Soft Trims.
The Set Soft Trims dialog displays.
3. Setthe number of frames to add to the head and tail of each shot:

In Cut
Source
Clip
— I 5hot

I (I
Head Tail

+ Use full available range - sets the handles to the full extent of the source clip frame range.
* Use Frames - adds the specified number of frames to the head and tail of the shot(s).

4. Click OK to add the specified number of handles.

If the handles requested are not within the available frame range, a warning dialog displays with a

suitable correction for each selected shot.

- Yo"

Camnst aat trim for ahot "01_ER_ShatDO1"™ (clip

Click Yes to accept, or No to abort the operation.
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— Note: With shots used in multiple sequences, click Yes to All to accept the correction in all
instances.

(E)HIERO USER GUIDE
238



Enabling and Disabling Shots |

Enabling and Disabling Shots

You can temporarily enable or disable tracks and shots on the timeline to selectively view your media

without removing shot(s), for example if you wanted to view to lower level video tracks within a
timeline.

To enable or disable a track or shot(s):
1. Select the item(s) you want to enable or disable.

2. Right-click on a highlighted item and select Editorial > Disable Track or Disable Items to disable
the selection.

Tip: You can also use the D keyboard shortcut to disable or enable your selection.

Disabled items appear gray, and are effectively removed from the timeline.

Ref_.nce

Audio 2

3. Right-click the item and select Enable Clip, or press D again, to re-enable the clip.
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Adding Transitions Between
Shots and Audio Clips

Hiero supports video and audio fade transitions as well as dissolves between shots on the same track.
Transitions come in three flavors:

* Fade in - fades in from black on a single shot or fades in audio.
* Fade out - fades out to black on a single shot or fades out audio.

* Dissolve / Audio Crossfade - fades out from one shot or audio clip and into the next, by merging
frames or audio.

Tip: Once a transition is in place, it can be nudged in the same way as an edit using the,
(comma) and . (period) keyboard shortcuts, providing the required handles exist.
To add a fade transition:

1. Right-click the target shot or audio clip and select Editorial > Add Transition > Fade In, Fade
Out, Audio Fade In or Audio Fade Out to add the fade icon.

2. Adjust the fade by dragging the fade icon using the Multi Tool or Move/Trim tool.

T[...].].u’. AT 0 010 000 0100 00000000000 0 1001
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To add a dissolve transition:

1.

3.

4.

Note: You can only add dissolves between shots when they're on the same track and have
sufficient handles available on both sides of the transition.

Select the Multi Tool or Roll Edit tool and hover the mouse pointer over an edit between two
shots or audio clips.

Tip: Clicking and holding the edit point displays available handles as a red overlay.

Right-click and select Editorial > Add Transition > Dissolve or Audio Crossfade, or use the
Ctrl/Cmd+T keyboard shortcuts, to add the dissolve icon to the edit.

Adjust either side of the dissolve by dragging the icon, in a similar way to using the Multi Tool or
Move/Trim tool.

Non-Linear Transitions

Transitions in Hiero are linear by default, meaning that the fade or dissolve happens at the same rate
throughout the transition. For example, a linear fade out on the last five frames of a shot would
appear as follows:

USER GUIDE
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Non-linear transitions allow you to vary the speed at which the transition happens, giving you more
creative control. For example, you might want a fade out to be slow and then speed up towards the

end of the shot.

@l (ol el e

When you add a transition, keyframes are added to the timeline as blue chips, so you can see where
the transition begins and ends.

Keyframes

RENDER

COMPS

You can adjust the keyframes in the Curve Editor to achieve the required transition speed. You can
adjust the keyframes manually by dragging them to different frames and adjusting the curve handles
to change the speed of transition. You can also add keyframes to edit the curve with even more
precision by pressing Ctrl/Cmd+Alt and clicking on the curve.
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ransition?.which curve
The Curve Editor also has some preset curves that you can apply to keyframes:

1. Select all the keyframes by pressing Ctrl/Cmd+A.

2. Right-click in the Curve Editor and select Interpolation to display the available presets.
|| Curve Editor Constant

File

Interpolation Catmull-Rom
View Cubic

Predefined Horizontal

4 b

ransition6.which curve

See Using the Curve Editor for more information on the Curve Editor and keyframes.


https://learn.foundry.com/nuke/content/getting_started/using_interface/animating_parameters.html#UsingtheCurveEditor
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Invalid Transitions

Transitions are controlled in a similar way to shots, in that you can drag-and-drop them, but with the
following restrictions:

+ Afade can not be dragged past the ends of the shot it's attached to, and if the item is deleted, the
fade is deleted with it.

* Dissolve ends can not be dragged past the ends of the shots they are attached to, and if both items
are deleted, then the dissolve is also deleted.

If only one of the shots linked by the dissolve is deleted, the transition remains so that another item
can be placed on the other side.

Invalid transitions are colored red on the timeline. In most cases, adjusting the length of the transition
should be enough to correct the error.

00:00:00 01:00:02:00 01:00:04:00 01:00:06:00 0
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Retiming Shots

In addition to transitions, Hiero supports constant retimes on shots. Decreasing the speed of a shot
causes frames to play more than once, whereas increasing the speed skips frames.

Note: Audio is not currently supported for retimes and is automatically muted to avoid
playback problems.

To retime shots using the Speed column in the spreadsheet:
1. Select the required event(s) in the spreadsheet view.
2. Click the cogicon and select the required Retime method:

* Keep source duration - the shot length is altered on the timeline depending on the retime
applied.
For example, retiming a shot to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer,
and as a result, the item'’s length is doubled on the timeline.

Retiming a shot to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length
is halved on the timeline.

Keep timeline duration - the shot length on the timeline is maintained regardless of the retime
applied.

For example, retiming a shot to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer,
but the item'’s length on the timeline remains the same, effectively removing the second half of
the item.

Retiming a shot to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length
on the timeline remains the same. If no extra frames are available from the source, the item is
filled with black frames.

3. Double-click the Speed column and enter the retime value.

The following example shows a shot and the results of 50% and 200% retimes with the Keep source
duration and Keep timeline duration methods selected.

Notice that the Keep timeline duration method doesn’'t change the length of the shot on the
timeline and inserts blank filler frames on the 200% retime?

Original clip
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50% Source retime 200% Source retime

50% Destination retime 200% Destination retime

You can also retime shots using the Src, Dst, and Duration columns of the spreadsheet, though the
calculation method depends on the Time Edit Behaviors applied.

1. Select the event(s) in the spreadsheet view.

2. Click the cogicon and select the required Time Edit Behaviors:

Modify Using

Src In Retime

Src Out Retime

Src Dur Retime
USER GUIDE

Result

Adjusts the event's Src In and retimes the remaining frames to maintain

Dst Duration.

Before and after a 2 second Src In increase:

Adjusts the event’s Src Out and applies a retime to maintain Dst
Duration.

Before and after a 2 second Src Out increase:

Sre Dur Dst In

Adjusts the event's Src Dur and Src Out, and applies a retime to
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Modify Using Result
maintain Dst Duration.

Before and after a 50 frame Src Dur increase:

DstIn Retime Adjusts the event's Dst In and retimes the remaining frames to maintain

the relationship between Dst In and Out.

Before and after a 2 second Dst In increase:

Sre Dur Dt In Dsr Out Dst Dur

200.0% 00:00c00:01  OD:00:03:24 100 01:00:02:00 01:00:03:24 50

Dst Out Retime Adjusts the event's Dst Out and retimes the remaining frames to
maintain the relationship between Dst Out and In.

Before and after a 2 second Dst Out increase:

Sre Dur Dst In

Dst Dur Retime Adjusts the event’s Dst Dur and Dst Out, and applies a retime to
accommodate the new Dst Duration.

Before and after a 50 frame Dst Dur increase:

0:01  00:00:04:00 100

w

Adjust the values as required to retime the shot(s) by the specified amount.
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Note: Any source or destination field highlighted in yellow indicates that the entry has been
rounded down for display purposes.

To retime a shot using the Timeline menu:

1.
2.

Select the required shot(s) on the timeline.

Navigate to Timeline > Retime.

The Clip Speed dialog displays.

Enter the required retime value as a percentage.

Select the required retime method using the dropdown:

* Keep timeline duration - the shot length on the timeline is maintained regardless of the retime
applied. When increasing speed, if no extra frames are available from the source, the shot is
filled with black frames.

 Keep source duration - the shot length is altered on the timeline depending on the retime
applied. For example, a 200% retime halves the length of the item.

* Anchor current frame - the shot length on the timeline and the current frame’s position are
maintained after the retime. When increasing speed, if no extra frames are available from the
source, the shot is filled with black frames.

Click OK to retime the shot(s).
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Using Freeze Frames

The freeze frame feature enables you to create shots of any length using a single frame. To achieve
this, the application takes the first frame of the shot and applies a 0% retime, which is reversible by
applying a 100% retime.
To freeze frame shots:
1. Select the target item(s) on the timeline.
2. Right-click the item and select Editorial > Make Freeze Frame,

OR

Navigate to Timeline > Make Freeze Frame.

Note: Freeze Frames can also be created using the spreadsheet retime modes to modify Src
Dur to 0, or make Src In and Src Out equal.

3. The selection is retimed to 0% and colored blue on the timeline for easy identification.

O T E T b i o e e e e e
01:00:00:00 01:00:02:00 01:00:04:00

AD12C006 101030_L10O3 0.0%

4. Use the Multi Tool or Slip Clip to set the freeze frame from the available range.

5. Drag the item'’s edit points, using the Multi Tool or Move/Trim as required, to set the length of
the shot. There's no upper limit for the length of a freeze frame shot.
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Blending Tracks on the Timeline

Hiero allows you to perform merges between tracks in the timeline, for example overlaying a logo on
a shot without heading into Nuke. Tracks that are designated as blend tracks have a blue header in
the timeline for convenience and are blended using a sub-set of Nuke's Merge node operations.

See the Nuke Online Help for a full description of the available blend modes.

Note: The Viewer currently treats all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image.

You can add soft effects to blended tracks as normal (see Adding Effects on the Timeline for more
information) and blended tracks are included along with the shot in Export operations. See Exporting
from Hiero and using Create Comp Clips during round-tripping Building VFX Tracks and Comp Clips
for more information.

Adding New Blend Tracks

1. Right-click in the timeline, select New Track > New Video Track Blend, and then choose the
blend mode to apply.

T-I-l--l-l-l-l- | | | [ T T T R R I
01 :00:00:00 01:00:04:00

1
[ MewTrack 0+ [T

Edit

Open In

Mark:
Frame Control

Audio

Difference
Minus
Miri

Max

Editorial
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A new track is added at the top of the track stack, colored blue to indicate that it's going to be
blended over the track below.

Add the required shot to the blend track as you would any other shot. See Adding Clips to the
Timeline for more information.

3. Click and hold the Blend B icon to select the blend mode.

01:00:04:00 01:00:0

Color Dodge

Color Burn
Hard Light
Difference
Minus

Min

4. Click the Blend [ icon to toggle blending on and off.

Converting Tracks to Blend Tracks

1.

Click the Blend B icon to toggle blending on,
OR

Right-click in the header of the target track and select Editorial > Blend Mode > Enable Track
Blend.
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1 1 1 1 1 1 I 1 1
01:00:00:00 01:00:04:00 01:00:0
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MNew Track

Edit
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Mark:

Frame Control

Audio &

Owver
Plus

Disable Track D ® Multiply

Copy Cuts...
Tags Collapse Tracks
Localize Add Transition 0 urn

Effcct= Hard Light

The selected track is converted into a blend track, colored blue to indicate that it's going to be
blended over the track below.

2. You can add shots to the blend track as you would any other shot. See Adding Clips to the Timeline
for more information.

The Viewer displays the higher track blended with the track below.
3. Click and hold the Blend B icon to select the blend mode.

Masking Blended Tracks

Masking limits the effect of the blend track to just those areas covered by the alpha channel in the
blend image. For example, using the Multiply blend mode with masking disabled multiplies the
background plate in non-alpha areas, which may not be the result you require.
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Background track B. Blend track A.
A multiplied by B with Masking A multiplied by B with Masking
disabled. enabled.

See the Nuke Online Help for a full description of the available blend modes.

Click the Mask [l icon to toggle alpha masking on and off. The mask option also carries over into the
Node Graph when you Create Comp for a masked blend operation:

Comp of A over B using the multiply merge The same comp using the multiply merge
operation with masking disabled. operation, but with masking enabled.


https://learn.foundry.com/nuke/content/comp_environment/merging/merge_operations.html
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Stereoscopic and Multi-View
Projects

Hiero provides multi-view support for as many views as you need. The views do not have to be stereo
pairs, but since that is the most obvious application, these pages mainly deal with stereoscopic
projects. See Creating Views in a Project and Importing Source Clips for more information.

Existing views inside a project are managed in the Viewer, timeline, and in the Properties panel of
most soft effects. In the Viewer, all views in the current project are represented by buttons that allow
you to switch between views with a single click. See Displaying Views in the Viewer for more
information.

- I-l

The timeline employs a views button B that allows you to switch between views per track. See
Displaying Views in the Timeline for more information.

| f T ' ' [ ' ' |
01:00:00:10 01:00:00:20

ubstitch (pubstitch)

Video 1_right

The Properties panel includes a split button B for controls that support multiple views. Split controls
only affect individual views. See Applying Changes to Selected Views for more information.
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channels 'rgb u

¥ red ™ green X blue none

blackpoint g

white po int

gain

multiply

gamma

X black clamp white clamp

You can export multi-view shots and effects in a similar way to regular shots. See Exporting Multi-View
Source Clips for more information.
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Creating Views in a Project

Views in Hiero are managed in the Project Settings. Views can be processed separately or together
and you can see the effect of your changes on each view. If you're working with multi-view source
clips, such as .exr and .sxr, Hiero offers to create views for you on import. See Importing Multi-View
Clips for more information.

Creating and Managing Views

If you're working with single-view clips, it's a good idea to create the project views before you import
your footage so that the views are assigned correctly. If you're working with multi-view clips, the views
are set up automatically on import.

1. Select Project > Edit Settings.

2. Go to the Views sub-menu. The available views are listed in the Views panel.

Sequence

Color Management
RED Settings

Export

hero main -

Set up views for stereo

Use colors in UI?

3. If you want to remove the view called main and add views called left and right, click the Set up
views for stereo button. The two views are assigned colors. To change the colors, double-click on
the color field and select another color from the color picker that opens.

4. Enable Use colors in Ul to apply the selected color for each view to the associated button above
the Viewer.

You can add and remove views using the + and - buttons or move views using the up and down
arrows above the views panel.

USER GUIDE
256



Creating Views in a Project |

Each view has its own button above the Viewer controls.

Tip: If you decide that you only need the main view in the project, click Set up Views for
Mono in the Project Settings.

See Importing Multi-View Clips for information on reading source clips in to Hiero.
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Importing Source Clips

Hiero supports multi-view clips in two formats:
* single-view - formats such as .dpx and .jpg, with file names that Hiero can interpret as multi-view
using specific naming conventions. For example:

myStereo compl left.####.dpx and myStereo compl right.####.dpx

See Importing Single-View Clips for more information.
* multi-view - formats such as .exr, .sxr, and .mov, that support multiple views per file. For example:

myStereo compl.####.exr containing two layers called left and right.

Note: Hiero can assign any shot on the timeline to any view in the project, but stereo is the
most common use case.

See Importing Multi-View Clips for more information.

Importing Single-View Clips

After setting up views in the Project Settings, Hiero can interpret single-view clips as multi-view using
specific naming conventions. These conventions can be applied to the file names themselves or to the
directories in which they reside.

If the images you want to read in contain a view name or the initial letter of one (for example, left,
right, | or r) in their file names, replace this with the variable %V or %v in the file name. Use %V to
replace an entire view name (for example, left or right), and %v to replace an initial letter (for
example, I or r). When a variable is used, Hiero reads in the missing inputs and combines all inputs
into a single output.

Note: You can enable detect views in the file browser to automatically substitute the %V or
%v variable where possible.

To use the %V and %v variables manually:
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1. Click File > Import File(s) or press Ctrl/Cmd+I to display the file browser.
2. Locate a single-view file, for example pubstitch.left.####.dpx
3. Replace the view name with the %V variable, continuing the example pubstitch.%V . ####.dpx

#®* & 5

' *  Name s

pubstitch left.##£22.dpx 831-850 ]
39 4

pubstitch_right. ###£.dp 0

Home

LEE]

-
-
e
-
-
-
-
+

edit - 1
¥/pub_stitch/stereo/pubstitch_ g2

X sequences split seq

4. Click Open.
Hiero reads in both pubstitch.left.####.dpx and pubstitch.right.####.dpx with the same Read
node, provided that views called left and right exist in the Project Settings.

Note: Mac and Linux operating systems can be case-sensitive or case-insensitive. If your OS
is case-sensitive, you'll need to make sure you use the correct case when naming your left
and right views, as the %v variable can only retrieve the case used in the view name.

Both input images are combined into a single source clip, marked with a O icon, which can
display any of the combined views.
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n Project

=

-

[ - [@] untitled 1 (1)
Bl pubstitch

See Displaying Views in the Viewer and Displaying Views in the Timeline for more information.

You can also use the %V and %v variables at a directory level. For example, if you have set up views
called cam3, left, and right, and you have the following directories and files:
stereo/pubstitchcam3/pubstitch cam3. ####.dpx
stereo/pubstitchleft/pubstitch left.####.dpx
stereo/pubstitchright/pubstitch right.####.dpx

If you read in pubstitch_cam3.####.dpx and change the file path to
stereo/pubstitch%V/pubstitch_%V.####.dpx, all three inputs are read in with the same Read node,
providing that the cam3, left, and right views exist in the Project Settings.
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MName

1

All three input images are combined into a single source clip, marked with a O icon, which can
display any of the combined views.

n Project

=1

-

[ - [@] untitled 1 (1)
Bl pubstitch

See Displaying Views in the Viewer and Displaying Views in the Timeline for more information.

Importing Multi-View Clips

Nuke offers to automatically create views when you import single files containing multiple views, such
as .exr and .sxr, unless they already exist. For multiple files, views must be created manually. See
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Importing Source Clips for more information.
1. Click File > Import File(s) or press Ctrl/Cmd+I to display the file browser.
2. Locate a multi-view file, for example pubstitch_stereo.####.exr
3. Click Open.
The Create missing views? dialog displays.

exist in the project "Untitled 1, want to create them?

® The imported « contain the v ft" and "right". These views don't

Add Views

4. Click Add Views, Replace Views, or No:
* Add Views - add the views in the incoming clip to those that exist in the project.
* Replace Views - replace all existing project views with those in the incoming clip.

* No - import the clip and display only the first view in the file, retaining any existing views in the
project.

You can now access the views in your project. See Displaying Views in the Viewer and Displaying
Views in the Timeline for more information.

Multi-view .mov files only display one view by default. To enable all views in a multi-view .mov file:
1. Double-click the .mov to display its Properties panel.
2. Disable First track only.

You'll notice that the .mov in the bin is now marked with @ to denote multiple views.

You can now access the views in your project. See Displaying Views in the Viewer and Displaying
Views in the Timeline for more information.
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Displaying Views in the Viewer

You can only display the views that exist in your Project Settings. To see a list of these views, or to
add or delete views, select Project > Edit Settings and go to the Views tab. For more information, see
Creating Views in a Project.

Displaying a Particular View
1. Double-click the clip or sequence to load it in the timeline Viewer.

2. On top of the Viewer controls, click the view to display. In the example, main, left or right.

Tip: You can also press the ; (semicolon) and ' (forward single quote) keys to move between
different views in the Viewer.

-

Note: Hiero lists the views in .exr files in the order they appear in the clip's header, so a view
named 'left' may not always be the first view displayed above the Viewer.

If your views do not appear in the correct order, you can rearrange them in the Project >
Edit Settings > Views tab. See Creating Views in a Project for more information.

Displaying Two Views Next to Each Other

1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select one of the following options:
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+ Side by Side - displays the views side by side at the correct aspect ratio, and adds selection
controls above the Viewer.

* Squeezed Side by Side - displays the views side by side and squeezed to fit the format
horizontally, and adds selection controls above the Viewer.

* Squeezed Above by Below - displays the views above and below each other and squeezed to fit
the format vertically, and adds selection controls above the Viewer.

Displaying a Blend Between Two Views

1. Right-click in the Viewer and select the Stereo Modes menu.
2. Select one of the following options:

* Interlace H - displays the views interlaced horizontally, and adds selection controls above the
Viewer.

* Interlace V - displays the views interlaced vertically, and adds selection controls above the
Viewer.

* Checkerboard - displays the views using an alternating checkerboard pattern (one pixel from
left and one pixel from right), and adds selection controls above the Viewer.

« Anaglyph - displays the views simultaneously using a red hue for left and green hue for right,
and adds selection controls above the Viewer.

* Flicker - displays both views alternately, and adds selection controls above the Viewer.

Displaying OpenGL Stereo in Timeline Viewers

The Viewer OpenGL Stereo mode allows you to see both views at once on a 3D monitor for review
purposes. OpenGL Stereo is only supported on NVIDIA Quadro series GPUs and AMD Radeon Pro
series GPUs on Windows and Linux OS.

Note: OpenGL Stereo mode is not supported on Mac due to limitations in macOS and not
supported with AMD GPUs on Linux.

Windows

To enable NVIDIA GPU stereo output:
1. Right-click on the desktop and select NVIDIA Control Panel.
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2. Navigate to 3D Settings > Manage 3D Settings > Stereo - Enable.

NVIDIA Contral Panel
File Edit Desktop 3D Settings

QO - Q| B

Select a Task...

Help

=) 30 Settings

-Adjust image settings with previ
{.5et PhysX Configuration

=1 Display

+-Change resolution

i Adjust desktop colour settings
Rotate display

# HDCP status

i-Set Up Digital Audio

-Adjust desktop size and position
i.5et up multiple displays

[=) Stereoscopic 3D

Set up stereoscopic 30

~.View rating for games

video

+-Adjust video colour settings
~.Adjust video image settings
[= Workstation

+.View system topology

Set up Mosaic

i.Manage GPU Utilisation

~ Manage 3D Settings

e w Restore Defaults

“fou can change the global 3D settings and create overides for specffic programs. The overides will be
automatically each time the specified programs are launched.

Iwould like to use the following 3D settings:

Global Settings  Program Settings

Global presets:

Base profile ~| |@d Restore
Settings:
Feature Setting ~
OpenGL rendering GPU Quadro P4000

Power management mode MVIDIA driver-controlled
Shader Cache Oon
Stereo - Display mode On-board DIMN connector

meo-we 5

Stereo - Swap eyes A0
Threaded optimisation

Triple buffering off

3. Proceed to Switching to OpenGL Stereo Output.

To enable AMD GPU stereo output:
1. Double-click the AMD taskbar icon and select Advanced Settings.

2. Navigate to the AMD Pro Sett

RADEON

ings and check Enable Quad Buffer Stereo.

Radeon Pro and AMD FirePro Advanced Settings

> Presels @

AMD Radeon Pro
~ and AMD
FirePro™ e

AMD Radeon Pro and
AMD FirePro™ Settings

v
Panels i

Properties (Digital Flat-
Panely

Preferences

AMD Radeon Pro and AMD FirePro™ Settings ?

Configure settings for your AMD Radeon Pro and AMD FirePro™ graphics card.

Quad Buffer Sterec

[[] Enable Quad Buffer Stereo rea L @

Active Sync (Sync signal enabled)

This option is used in conjuncticn with active stereo
display devices like sterec shutter glass eyewear.

[[] Enable 10-bit pixel format support

3. Select either Auto-Stereo (Horizontal Interleaved) or Auto-Stereo (Vertical Interleaved) and

click Apply.

4. Proceed to Switching to OpenGL Stereo Output.
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Linux

To enable NVIDIA GPU stereo output:
1. Open a command prompt and enter:

nvidia-xconfig --stereo=3

Tip: For more information on the nvidia-xconfig utility, please see the man page: man
nvidia-xconfig

2. Proceed to Switching to OpenGL Stereo Output.

Note: OpenGL Stereo mode is not supported with AMD GPUs on Linux.

1. Right-click in the Viewer to display the context-sensitive menu.
2. Navigate to Stereo Modes and select OpenGL Stereo.
If you select OpenGL Stereo mode before enabling your GPU settings, a warning is displayed.

& MNuke >

n OpenGL Stereo Mode is not supported or disabled on your system

Ok

The first time you select OpenGL Stereo, a warning message is displayed.

&' OpeniL Stereo et

You are about to ch to [ o Mode. You might
A some disruptic 7 onment w this h

Don't show again

Tip: You can disable the warning by enabling Don't show again and clicking OK.
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OpenGL Stereo is displayed in the Timeline Viewer.

Note: Switching to and from OpenGL Stereo mode causes playback to pause. Press play to
resume playback.
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Displaying Views in the Timeline

You can only display the views that exist in your Project Settings. To see a list of these views, or to

add or delete views, select Project > Edit Settings and go to the Views tab. For more information, see

Creating Views in a Project.

Adding a multi-view clip to the timeline groups all views into a single track. All the views in the clip are
assigned a Viewer button. Click the assigned view icon S I display the views available in the shot. All

Views are visible by default.

right

cama3

Audio 1

Selecting a particular view for a track in the timeline, such as left, means that only the left view is
visible in the Viewer for that track.

Note: You can also import single-view files manually and then assign them views in the
timeline individually, providing that the views exist in the Project Settings.

Splitting Views to Separate Tracks

Working with all views in a single track is not always convenient, such as when you need to apply
different color corrections to stereo cameras. Hiero includes a Split Views to Tracks option that

quickly separates views into individual tracks. You can use Split Views to Tracks with grouped single-

and multi-view shots.

1. Right-click a multi-view shot on the timeline and select Editorial > Split Views to Tracks.
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Audio ]

Blend Mode

Tags

Localize

b Add Transition 4

Audio 1

ubstitch {pubstitch)

Video 1_cam3

ubstitch {pubstitch)
I'.I"i d 20 1_r|g ht

) pubstitch {pubstitch)
Video 1_left |-

Audio 1

The new track names are suffixed with the view name, for example Video1_left, and the views are
assigned appropriately.

Note: If a view exists in the Project Settings, but there's no corresponding view in the source
files, empty placeholder tracks are added.

You can change the view assigned to a track by clicking the & icon and selecting from the list of
available views.
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ubstitch {pubstitch)

right ubstitch (pubstitch)

cam3 1ht

) pubstitch {pubstitch)
Video 1_left |-

Audio 1

See Applying Changes to Selected Views for information on adding soft effects to different views.

Right-click in the Viewer and select the Stereo Modes menu.
Select on of the following options:

+ Side by Side - displays the views side by side at the correct aspect ratio, and adds selection
controls above the Viewer.

* Squeezed Side by Side - displays the views side by side and squeezed to fit the format
horizontally, and adds selection controls above the Viewer.

* Squeezed Above by Below - displays the views above and below each other and squeezed to fit
the format vertically, and adds selection controls above the Viewer.

Right-click in the Viewer and select the Stereo Modes menu.
Select on of the following options:

* Interlace H - displays the views interlaced horizontally, and adds selection controls above the
Viewer.

* Interlace V - displays the views interlaced vertically, and adds selection controls above the
Viewer.

* Checkerboard - displays the views using an alternating checkerboard pattern (one pixel from
left and one pixel from right), and adds selection controls above the Viewer.
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« Anaglyph - displays the views simultaneously using a red hue for left and green hue for right,
and adds selection controls above the Viewer.

* Flicker - displays both views alternately, and adds selection controls above the Viewer.
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Applying Changes to Selected
Views

By default, Hiero applies any changes you make to all views. To apply changes to a particular view only
(for example, the left view but not the right), you can:

* Split the views into separate tracks. Separating views allows you to apply effects, such as a
Transform or Timewarp, to individual views without affecting the other views. See Splitting Views to
Tracks for more information.

* Split the view off in the soft effect’'s Properties. Splitting properties allows you to perform the same
operation on multiple views, but with different values for each, such as a Grade or ColorCorrect. See
Splitting Views in the Properties Panel for more information.

Splitting Views to Tracks

1. Right-click a multi-view shot on the timeline and select Editorial > Split Views to Tracks.

Audio L
| Editorial 0000+ TSRV

D e Trac

Effects Add Transition

Audio 1

2. Right-click the track to which you want to add the soft effect, select Effects and then the required
soft effect. For example, adding a Transform to the left view applies the effect to only the left view
track. See Adding Effects on the Timeline for more details on adding effects to shots.
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ubstitch (pubstitch)
Video 1_cam3

ubstitch {pubstitch)

Video 1_right

Il.ll.i d 20 1_| -Eﬂ: :.

Audio 1

You can export multi-view shots and effects in a similar way to regular shots. See Exporting Multi-View
Source Clips for more information.

Splitting Views in the Properties Panel

1. Right-click the track to which you want to add the soft effect, select Effects and then the required
soft effect. For example, adding a ColorCorrect a multi-view shot.

See Adding Effects on the Timeline for more details on adding effects to shots.

Video 1 B

Audio 1

2. Select the view you want to make changes to using the buttons above the timeline Viewer.
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3. Open the effect’s Properties and click the view button lil on the right, next to the control you
want to adjust.
4. Select Split off [view name]. For example, to apply changes to a view called left, select Split off

left. You can also split all the effect's controls by selecting Split all knobs from the right-click
menu.

ColorCorrectl

ColorCorrectl

ColorCorrect Ranges ColorCorrect Ranges

channels ray ® re B gr ¥ bl channels ray ® re B gr ¥ bl nom =

master master Set kev on all knobs

saturation saturation Set o default

contrast contrast

gamma fanmiE
Mo animation on*all knobs
e

gain gain

An eye appears on the split view button E Any changes you make using the control in question
are only applied to the view you chose to split off. Changes to controls that have not been split off
are still applied to all views.

You can export multi-view shots and effects in a similar way to regular shots. See Exporting Multi-View
Source Clips for more information.

Showing Separate Values for Each View

Once you have split off a view, you can apply changes to the existing views separately. Click on the
arrow on the left side of a split control to divide the control into values for each view.

ColorCorrectl
ColorCorrect
channels rgb X red W green *X blue none

master

sgturation He®

contrast e :
me
e :

gamma 1 He

In the example, the left view is split for the saturation control and left and cam3 views are split for
the contrast control.
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Note: The * (asterisk) denotes there is more than one unsplit view remaining for the
saturation control and () denotes that the right view is the only unsplit view for the
contrast control.

Unsplitting Views
1. In the effect's controls, click the view button .

2. Select Unsplit [view]. For example, to unsplit a view called left, you'd select Unsplit left.
The view is unsplit, and all changes you made to individual views are lost.
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A soft effect is a real-time effect, such as Transform or TimeWarp, processed on GPU instead of CPU.
You can add soft effects to your timeline in any of the workspaces.

You can add custom plug-in or gizmo soft effects to the Add Effect menu using Python. Valid custom
soft effects must have a GPUEngine implementation using DD::Image::lop::gpuEngine type functions.
For more information see Hiero's NDK Reference Guide.

Soft Effects must also be registered after creation. An example of how to register a plug-in or gizmo as
a custom soft effect is located in:

<install directory>/pythonextensions/site-packages/hiero/examples/custom soft
effect.py

Available Soft Effects

Below is a brief summary of the available soft effects.

Soft Effect Color Code Summary

ColorCorrect Make quick adjustments to saturation, contrast,
gamma, gain, and offset. You can apply these to a
clip’s entire tonal range, shadows, midtones, or

highlights.

You can control the range of the image that is
considered to be in the shadows, midtones, and
highlights using the lookup curves on the Ranges tab.
However, do not adjust the midtone curve - midtones
are always equal to 1 minus the other two curves.

Alt+C inserts a ColorCorrect soft effect on any shot
selections or at the playhead

Grade Gradet Define white and black points by sampling pixels from
- the Viewer. For example, you can use this for matching
foreground plates to background plates.
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Soft Effect Color Code

Transform

Text Textl

TimeWarp

Adding Effects on the Timeline |

Summary

Alt+G inserts a Grade soft effect on any shot selections
or at the playhead

Translate, rotate, scale, and skew shots from a single
control panel.

Alt+T inserts a Transform soft effect on any shot
selections or at the playhead

Add text overlays on your images. You can simply type
in the text you want to have displayed or use Tcl
expressions (such as [metadata values]) or Tcl
variables to create a text overlay. Text overlays can
also be animated using animation layers in the Groups
tab, so that their properties (such as position, size, and
color) change over time.

Slow down, speed up, or even reverse selected frames
in a clip without necessarily altering its overall length.
Sequences imported from .xml and .aff files also
support non-linear retimes.

Note: TimeWarp effects are only allowed on
tracks with clips as they are linked to the
clips.

Color Submenu (OCIO soft effects are also available in HieroPlayer)

ColorLookup

HueCorrect

USER GUIDE

Make color adjustments using lookup tables (LUTSs).
LUTs refer to line graphs of a given color channel’'s
brightness. The horizontal axis represents the original,
or input, values and the vertical axis represents the
new, or output values.

Adjusts the hue of the images.
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Soft Effect Color Code Summary

Grade Define white and black points by sampling pixels from
the Viewer. For example, you can use this for matching

foreground plates to background plates.

Alt+G inserts a Grade soft effect on any shot selections
or at the playhead

OCIO Submenu

OCIO CDL
Transform

Applies an ASC CDL (American Society of
Cinematographers Color Decision List) grade based on
the OpenColorlO Library.

See OCIOCDLTransform in the Nuke Online Help for
more information on the Properties panel for this
effect.

OCIO ColorSpace Converts images from the input colorspace of the shot
on the timeline to an output colorspace more
appropriate to a given process or intended display

device.

OCIO Display Applies a colorspace conversion to an image sequence
so that it can be accurately represented on a specific

display device.

See OCIODisplay in the Nuke Online Help for more
information on the Properties panel for this effect.

0ocClo
FileTransform
(LUT)

Loads a colorspace conversion from a file (usually a 1D
or 3D LUT) and applies it. You can also load other file-
based transformations, for example an ASC
ColorCorrection XML. File transforms are applied
without any input or output colorspace handling. If the
file expects log-encoded pixels, but you apply the
node to a linear image, you will get incorrect results.

See OCIOFileTransform in the Nuke Online Help for
more information on the Properties panel for this
effect.
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Soft Effect Color Code Summary

OCIO LogConvert Converts from compositing_log to scene_linear, or the
reverse. Sometimes log data is required for certain
processing operations, like plate resizing or pulling
keys. Usually a colorspace is provided specifically for
these operations.

OcCIo Applies a creative colorspace transform using a

LookTransform predefined look in the OCIO config file. Alook is a
named color transform intended to modify the 'look’
of an image in a creative way, rather than a technically
or mathematically defined colorspace conversion.

See OCIOLookTransform in the Nuke Online Help for
more information on the Properties panel for this
effect.

OCIONamedTransform uses NamedTransforms in the
OCIO configs shipped with Nuke to emulate older
methods of color management that ignored the RGB
primaries and simply applied one-dimensional
transformations. These NamedTransforms have been
added to the config as sometimes it is helpful to
include one or more transforms in a config that are
essentially stand-alone transforms that do not have a
fixed relationship to a reference space or a process
space. An example would be a utility curve transform
where the intent is to simply apply a LUT1D without
any conversion to a reference space.

OCIO
NamedTransform

See OCIONamedTransform in the Nuke Online Help
for more information on the Properties panel for this
effect.

Tip: For more information on the OpenColorlO (OCIO) library, see https://opencolorio.org/

Pull a quick chroma key from green or bluescreen
areas of your footage.

ChromakKeyer
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Soft Effect Color Code

Merge Submenu

Premult

Unpremult

Transform Submenu

Transform

Crop

LensDistortion

USER GUIDE

Premultl

Unpremultl
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Summary

Use the screen color selector to choose a color from
the Source input to use as the blue/green screen
color. To remove blue/green spill from the foreground
object, use the despill controls to pick skin tones from
the source. Use the matte parameters to improve the
matte.

Just like the Premult and Unpremult node in Nuke,
these effects multiply or divide the shot's rgb channels
by its alpha channel.

If the alpha channel doesn't exist or covers the whole
frame equally, premultiply and unpremultiply have no
effect.

See Premult and Unpremult in the Nuke Online Help
for more information on the Properties panel for this
effect.

Translate, rotate, scale, and skew shots from a single
control panel.

Alt+T inserts a Transform soft effect on any shot
selections or at the playhead

Cut out the unwanted portions of the image area. You
can fill the cropped portion with black or adjust the
image output format to match the cropped image.

The LensDistortion effect estimates the lens distortion
in a given image, either through Grid Detection or
manual Line Detection. The warp can then be used to
add or remove distortion or produce an STMap in the
motion channel for use elsewhere.

See Correct Shots Using LensDistortion for more
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Soft Effect

Mirror

CornerPin

Filter Submenu

FilterErode

Denoise

Blur

(Continued)
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Color Code

Dencisel
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Summary
information.

Flip the input image around the center of the format
area. A flip on the x axis mirrors the image vertically. A
flop on the y axis mirrors the image horizontally.

The CornerPin2D effect is designed to map the four
corners of an image sequence to or from positions
derived from tracking data. In practice, this effect lets
you replace any four-cornered feature with another
image sequence. You can use it to place an image in
an on-screen television, for example.

See Using the CornerPin2D Node for more
information.

Filters input pixel’s relation to the size control.
Negative values cause brighter areas to expand into
darker areas and positive values cause darker areas to
expand into lighter areas.

The Denoise effect is an efficient tool for removing
noise or grain from your footage. It uses spatial or
temporal filtering to remove noise without losing
image quality.

See Removing Noise with Denoise for more
information.

Adds blur to the images.
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ModifyMetaData

Burn-In

Inference (Machine
Learning)
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Summary

Inject metadata key pairs into the shot during export
in a similar way to the ModifyMetaData node in Nuke.

Quickly add standard burn-in elements on the
timeline. You can control the color, opacity, font, scale,
and so on, as well as use the dropdowns to determine
what element is added from the file or sequence
metadata.

You can also reference custom metadata from shots.
For example:
hiero/shot/tags/Approved

Extracts the Approved tag from the shot. You can also
append note to include any notes associated with the
tag:

hiero/shot/tags/Approved/note

Note: You must precede spaces and slashes
in the tag name with \\ (backslashes) to
enable Hiero to process the tag name

correctly. For example:
hiero/shot/tags/Blue\\ Screen/note

You can also add burn-in through the Export dialog,
see Adding Burn-in Text to Exports for more
information.

The Inference effect applies a pre-trained .cat file to
create the effect modeled by a neural network across
the input image. You can use pre-trained .cat files
from Nuke's CopyCat node, models from the Cattery,
or third-party converted files from CatFileCreator can
be used in the Inference effect.

See Apply Pre-Trained Models to Shots Using
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BlinkScript
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Summary
Inference for more information.

Run Foundry's Blink framework on the timeline,
enabling you to write code once and run it on any
supported device.

Warning: BlinkScript is very flexible, as there
are no restrictions on the code you can write
within a kernel. As a result, code complied
from the Kernel Source can cause Nuke to
crash, so please use caution!

The BlinkScript soft effect supports a subset of the
functionality available in the full BlinkScript node:

* You can't publish your kernels to Groups or Gizmos.

+ Due to the way stacks of soft effects are processed in
Hiero, the BlinkScript soft effect only contains one
input source and produces only one output.

* The following functions are not supported by the
BlinkScript effect if all the images have eAccessPoint
data access:

*log10

* round

* rsqrt

* abs for integer types

* modf(a, *b)

* sign

s rep

* max, min, and clamp for integer types
* median, atomiclnc and atomicAdd.

* The only data types supported by the BlinkScript
effect are int, float, and bool.
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Soft Effect Color Code Summary

Warning: Soft effects using RIP will not work
if there is a mismatch between your OpenCL
GPU (blink device) and the OpenGL GPU.

Note: The BlinkScript soft effect supports
both pixel-wise and component-wise kernels,
but the former is preferred for performance
reasons. For more information about this
and a more detailed description of the
language, see
https://learn.foundry.com/nuke/developers/
16.0/BlinkKernels/

Note: Soft effects have equivalent Nuke nodes with the same name. Only these nodes can
be used in gizmos to create custom soft effects.

Adding Sequence-Level Soft Effects

Warning: Please keep in mind the following:

* Sequence-level soft effects are only permitted on the same track as clips if they're trimmed
to exactly match the in and out points of individual clips. In this case, each effect is linked to a
specific clip.

+ Soft effects can be trimmed arbitrarily if they're on tracks with no clips.

The timeline provides some additional ways to add soft effects. You can either:

* Right-click a shot on the timeline, select Soft Effects and then select the soft effect you want to
apply, or

* Select a shot on the timeline, click the Add Effect button to the left of the timeline, and then select
the soft effect you want to apply.
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< ColorCorrect

b Transform

Ted

%) Timewarp

Color

b Transform

Y Filter
ModifyMetaData
Burn-In

- Inference

= BlinkScript

Note: You can add a soft effect to multiple shots by selecting the required shots first and
then right-clicking on one of them and selecting the soft effect you want to add. A soft effect
is added to each of the selected shots. You can also add a single soft effect for the whole
track by right-clicking on the track header and then selecting the soft effect you want to add.

Note: TimeWarp effects are only allowed on tracks with clips (and therefore linked to clips).

You can add soft effects using the spreadsheet view in any workspace - see Using the Spreadsheet
View.

You can add Transform, Grade, and ColorCorrect effects using the keyboard shortcuts Alt+T, Alt+G,
and Alt+C. You can add effects to multiple shot selections or at the playhead if no shots are selected.

Note: If no shots are selected, the effect is added to the top-most shot under the playhead.
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Audio 1 Audio 1

Adding effects to multiple selections. Adding effects at the playhead.

Adding Shot-Level Soft Effects

Warning: Soft effects added at shot-level, must match the length of the shot on the locked
track. Any soft effect that is trimmed beyond the end of a shot, or a different length from the
shot is marked with red hashing to show that it is invalid.

You can add shot-level soft effects on the timeline, by doing the following:

1.
2.
3.

Right-click the shot that you want to add a soft effect to.
Select Open In > Timeline View.

Click the Soft Effects menu icon and select the soft effect you want to apply. For example, you can
select Grade.

The soft effect is then displayed above the shot as a colored box.

D5:52:54:01
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When you close the timeline view of the shot - as it is a shot-level soft effect - the soft effect is
displayed as a colored line within the top of the shot. The color of the line displayed reflects the
highest soft effect added to the shot.

05_101029_L

Soft Effect Controls

Adding an effect displays the associated controls in the Properties panel, similar to Hiero nodes.
Adjusting the controls affects the shots underneath the effect in real-time. For example, adding a
Grade effect at sequence level displays the Grade controls in the Properties panel.

Gradel

channels ~ X red * green R blue =
blackpoint g -
whitepoint 1
lift o
gain 1
multiply 0.97
offset 0.405
gamma 1.63
reverse ¥ black clamp white clamp
mask ¥ VRayDiffuseFilter.red

(un)premult by ¥ rgba.alpha

mix 1

See the Hiero User Guide > Using the Compositing Environment > Properties Panels section, the Hiero
Reference Guide, or the Online Help for more information on node controls.

If you intend to animate soft effect controls using keyframes, you can use the Curve Editor and Dope

Sheet to fine-tune the output. To add the Curve Editor or Dope Sheet to the interface, navigate to
Window and select the required panel.
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File Edit Warkspac Viewer Render Cache Window Project Clip Timeline Help

roperties

Script Editor

See the Hiero User Guide Getting Started > Using the Compositing Environment > Animating Parameters
section or the Online Help for more information.

Editing Sequence-Level Soft Effects

You can copy, move, and cut soft effects just like you can with shots in the timeline. You can perform
these actions by either accessing them from Edit in the right-click menu, or by using the keyboard
shortcuts. You can copy soft effects to different tracks, different sequences, and different projects.

You can move a sequence-level soft effect by simply clicking and dragging the soft effect to a different
shot, or even onto a different video track.

Nuke Studio and Hiero allow you to copy a sequence-level soft effect above the original to create a
stack, to a different track, or to a different sequence. You can also copy a sequence-level soft effect to
a shot open in the timeline view, therefore pasting it as a shot-level soft effect. There are several copy
operations available for soft effects, standard copy/paste, replace paste, sequential paste, and
sequential replace paste.
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Standard Copy and Paste

Standard copy and paste adds the copied effect(s) to the stack on the target shot(s). Effects are read

from the top down, so pay attention to the order of the stack.
1. Select the soft effect you want to copy by clicking it.
2. Press Ctrl/Cmd+C or right-click and select Edit > Copy.
3. Select the target shot or move the playhead to where you want to paste the copy.

4. Press Ctrl/Cmd+V or right-click and select Edit > Paste.

-II_II _I|_II-II_IIIII||IIIIIII|||II|I|||||IIIIIIIII|||IIIIIII||IIII|||||IIIII|||||IIIII||||||IIIIIIII|IIIIIIIII|
01:00:00:00 01:00:02:02 01:00:04:04

R

Graded

RN R RN TR RN RN TR A RN I R R RN TRAR AR TR AN Y
01:00:00:00 0z 01:00:04:04

Standard pasting multiple effects adds all the effects to each
target effect stack

USER GUIDE

289



Adding Effects on the Timeline |

Replace Paste

Replace paste copies the source effect(s) to the target shot and removes any existing effects on the
shot.

Press Shift+V or right-click and select Edit > Replace Paste.

II_II I-II_IIIII|||IIIIII|||IIIIIII||IIIIIIIII|||IIIIIII||IIII|||||IIIIIII|||IIIII||||||IIIIIIII|IIIIIIIII|
01:00:00:00 01:00:02:02 01:00:04:04

Transform<

Replace pasting an effect removes exsiting effects from the
stack

Sequential Paste

Unlike standard paste, sequential paste only pastes each effect once, in the order that they appear on
the source shots.

Press Ctrl/Cmd+Alt+V or right-click and select Edit > Sequential Paste.

01:00:02:03 ||||||||||.|||||||||.|||||||||.|||||||||.||||-|-|||- --I|.|||||||||.|||||||||.|||||||||.|||||||||I|||||||||.
01:00:00:00 01:00 01:00:04:04

Sequential pasting only pastes each effect once, in the order
they appear on the source shot
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01:00:02:03 : ||||||||||.|||||||||.|||||||||.|||||||||.||||_.|_||nilurl:;l.l||||||||.|||||||||.|||||||||.|||||||||I|||||||||.
01:00:00:00 01:00:02:02 01:00:04:04

OCIOCDLTran

Sequential pasting retains the order of effects from the source
stack

Sequential replace paste only pastes each effect once, in the order that they appear on the source
shots, removing any existing effects from the target shots.

Press Alt+Shift+V or right-click and select Edit > Sequential Replace Paste.

01:00:02:03 d ||||||||||.|||||||||.|||||||||.|||||||||.||||-|-|| % T A K AT L KRR AT
01:00:00:00 01:00:02:02 01:00:04:04

Sequential replace paste only pastes each effect once, in the
order that they appear, removing any existing effects

[n] 3
01:00:02:03 N R TR TN IR TR RN TR R AR AR AR IR EN NI VRN Y IR RN AR E R RN IR TN AR TRI RN AR TR RN RN RARRTRNARY
01:00:00:00 01:0 01:00:04:04

Sequential replace pasting retains the order of effects from

the source stack
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You can clone a sequence-level soft effect. This copies the soft effect and links it to the original, which
means when one of these is edited, the changes are reflected in the other one. You can clone a soft
effect to a different track or even a different sequence. You cannot clone a soft effect in different
projects.

To clone a soft effect:

1.

2
3.
4

Select the soft effect you want to clone by clicking on it.

Select Edit > Copy (or press Ctrl/Cmd+C).

Move the playhead on the timeline to where you want to place the new clone.
Select Edit > Clone (or press Alt+K).

The new clone is placed at the current playhead position on the timeline. You can repeat steps 3
and 4 to create multiple clones that are all linked, at different places on the timeline.

Clones are indicated by a C highlighted in red in the left of the soft effect.

Note: Cloning animation in soft effects is not supported.

You can also copy a sequence-level soft effect as a clone. This means, when you paste a new copy of
the soft effect above a selected shot, it is automatically linked to the original soft effect as a clone.
Therefore, any changes made to either of the cloned soft effects, are reflected in the other.

To copy a soft effect as a clone, do the following:

1.

2
3.
4

Select the soft effect you want to copy as a clone by clicking on it.
Select Edit > Copy as Clones (or press Ctrl/Cmd+K).

Click on the shot that you want to clone the soft effect to.

Select Edit > Paste (or press Ctrl/Cmd+V).

The soft effect is copied as a clone on your selected shot. You can repeat steps 3 and 4 to create
multiple clones that are all linked above different selected shots.

Clones are indicated by a C highlighted in red in the left of the soft effect.

Note: Cloning animation in soft effects is not supported.
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To declone a soft effect, simply click on the clone you want to declone and select Edit > Declone (or
press Alt+Shift+K).

Note: For more information about copying, moving, and cutting soft effects, see Timeline
Editing Tools .

To delete a soft effect, simply right-click on it and select Edit > Delete (or press Backspace).

Editing Shot-Level Soft Effects

To edit a shot-level soft effect, you first need to open the shot with the applied soft effect, in the
timeline view. You can do this by right-clicking the shot and selecting Open In > Timeline View. You
can then copy, delete or move the shot-level soft effect in exactly the same way as sequence-level soft
effects.

You can copy and paste the shot-level soft effect on top of the original, creating a stack in the timeline
view. When you close the timeline view, stacked shot-level soft effects are displayed as a single line
within the top of the shot. Hiero allows you to copy a shot-level soft effect, return to the full sequence,
and then paste it as a sequence-level soft effect. You can also paste a shot-level soft effect to another
shot open in the timeline view.

Note: You cannot clone shot-level soft effects.

You can choose to disable and re-enable soft effects from the output. To enable or disable a
sequence-level soft effect, select the soft effect by clicking on the colored box and then pressing D. To
enable or disable a shot-level soft effect, you first need to open the shot - that includes the soft effect
- in the timeline view. Then you can select the soft effect and press D.
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Using Soft Effects across multiple channels

You can edit Multichannel EXRs directly in the timeline. This allows you to use effects and make
precise adjustments to specific layers, and combine them to get fast shot tweaks, which you can copy
and paste across shots in the timeline.

See Using Multichannel Soft Effects to learn more.
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Using Multichannel Soft Effects

You can utilize Multichannel EXRs directly in the timeline. This allows you to use effects and make
precise adjustments choosing specific layers, and combine them to get fast shot tweaks, which you
can copy and paste across shots in the timeline.

Import EXR into the timeline

Import your EXR files into the timeline using File > Import Files(s), and selecting your .exr file.

Your file will now be visible in the project panel.

The layers available in the current frame are visible on the first level of the Layer dropdown at the top

of the Viewer. Ik

Add new channels

You can create new channels from any Soft Effect.

To do this, go into a soft effect’s properties, select the output > channels dropdown, and select new.
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Background Renders

BlinkScript4

BlinkScript Kernel Parameters Library Files

inputs

src

Rotation

Safety Rails

i :E] - ® red M green *® blue

Width 2

Height
Centre

Step

x 1233.76391ty 736.520690¢

BO

output

channels

rgba ¥ red M green % blue M alpha
rgb

® rgba
alpha
other layers

W

This opens a window where you can choose what type of channel to create using the buttons in the

auto menu.

radial_mask

Channels: red r Auto:
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Apply soft effects to specific layers and mask through any
available channel

You can select, filter, and isolate specific layers for detailed editing. For example:

* Use soft effects such as HueCorrect, Grade, and Blur, and apply them to specific channels.
To do this, open each effect's Properties, and use the channel dropdown.

* Mask a color soft effect via a non-rgba layer such as depth or mattes.
To do this, you can open each effect's Properties, and use the mask dropdown.

* Premult and unpremult using any layer.
To do this, you can open each effect’'s node Properties, and use the (un)premult by dropdown.

* Use BlinkScript with multiple layers as inputs.
To do this, you can open the BlinkScript effect's Properties, and use the src dropdown.

For example, you can see specific layers have been selected for a Grade effect here:

Grade

channels rgb X red M green X blue

blackpoint p

whitepoint 1

lift o

gain 1
multiply p.97
offset 0.405
gamma 1.63

reverse ¥ black clamp white clam

mask % VRayDiffuseFilter.red

(un)premult by % rgba.alpha z invert

Tip: See Adding Effects on the Timeline to learn more about each soft effect.
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Channel indicator chips

You'll be able to see which channels are being used by a soft effect, when a soft effect is using a mask,
and which channels are being used by a track item.

Colored indicator chips will appear on track items and soft effects when they are selected.

00C00020_styraco_rimright (00CO0020_styraco_rimright)

1:00:00:00

I - red color layer.
I - green color layer.
I - blue color layer.
- alpha layer.

I - depth layer.
E - forward motion vector layers.

E - backward motion vector layers.
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I - oll other custom layers, such as disparity.

When a layer is being used as a mask it will show the icon - &

Note: Multi-part EXRs are required for optimal performance. If you haven't already, we
recommend you switch to this type of files in order to get the best of this feature.

Note: While the multi-channel aware timeline is a powerful tool, it's important to note that
extremely large or complex EXR files may still impact performance. We recommend
optimizing your files where possible for the best experience.

Tip: The BlinkScript soft effect allows multiple layers as an input, which means a great
expansion of the potential of this versatile tool. For example, using secondary inputs to
process, such as DepthBlur Kernel, Shuffle(BlinkScript) and others.

Tip: You can use .cat files requiring multiple inputs with the Inference soft effect. See Apply
Pre-Trained Models to Shots Using Inference.
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Correct Shots Using
LensDistortion

Nuke Studio and Hiero's soft effect collection also includes a LensDistortion effect in the timeline.
Using LensDistortion in the timeline enables new workflows for shot prep and distribution and you
don't have to go back and forth between the timeline and comp environments. The results can be
applied to multiple shots that use the same lens metadata or at sequence-level across an entire show.

Just like Nuke's LensDistortion node, the timeline effect estimates the lens distortion in a given shot,
either through Grid Detection or manual Line Detection. The warp can then be used to add or remove
distortion or produce an STMap in the motion channel for use elsewhere.

See Working with LensDistortion for more information.

Remove Lens Distortion from a Shot

Here's how to remove distortion from a shot using the LensDistortion effect on the timeline.

1. Either select the shot on the timeline manually or use the handy auto-select feature to choose a
shot for you depending on the current playhead's position.
2. Click the soft effect menu icon i on the left-hand side of the timeline.

Select Transformations > LensDistortion to add the effect to the shot.
4. If you have a lens distortion grid shot with the same camera used for filming, you can use that to

estimate the lens distortion applied to your shots,

w

R

The original distorted shot Associated grid shot

OR
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If no estimation grid is available, you can use the LensDistortion effect's manual line drawing
workflow to estimate lens distortion.

The original distorted shot Example lines in the alpha channel

See Estimating Lens Distortion Using a Grid or Estimating and Removing Lens Distortion Using
Lines for more information.

5. When you've calculated the required lens distortion, make sure that the LensDistortion effect's
Mode is set to Undistort in the Properties panel.

This step removes the calculated distortion from the shot so that you can send the undistorted
plate to your comp department using Create Comp. Nuke Studio or Hiero automatically adds a
LensDistortion node to the comp, as you can see in the example.

' - P — J e ‘

S

Your comp department can now add their work to the undistorted plate.
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Add Lens Distortion to a Shot

You can quickly add lens distortion to shots or whole sequences on the timeline by copying a
LensDistortion effect set to Undistort and changing the Mode to Redistort. You might need to do this if
your comp department didn't redistort the comp for you before sending it back from Nuke. In this

example, we'll assume that our comp has come back from Nuke, but the CG elements are
undistorted.

The shot on the Elements track is merged down onto the Video 1 track, but because the
LensDistortion effect is disabled, the original plate is no longer undistorted.

01:00:00:00 01:00:04:00 01:00:08:00

AD11C014_120824_
=
Elements

To make the CG elements match the original plate's lens distortion:

1. Copy the LensDistortion effect from the Video 1 track and paste it on to the CG shot on the
Elements track.

01:00:00:00 01:00:04:00 01:00:08:00

Elements

Audio 1
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Note: The copy of the LensDistortion effect is not a clone, so the effect name is
incremented as normal. In this case, to LensDistortion5.

2. Double-click the pasted LensDistortion effect to display its Properties panel.
3. Click the Mode dropdown and select Redistort to invert the distortion applied by the original
effect.

The Original Undistorted CG Redistorting CG elements corrects
elements placement

Remove Lens Distortion from Multiple Shots

If you intend to undistort multiple shots, it's a good idea to apply LensDistortion to one shot first and
then clone the effect to the other shots in case you update the lens solve later on.

1. Either select the shot on the timeline manually or use the handy auto-select feature to choose a
shot for you depending on the current playhead's position.

2. Click the soft effect menu icon . on the left-hand side of the timeline.

Select Transformations > LensDistortion to add the effect to the shot.

4. If you have a lens distortion grid shot with the same camera used for filming, you can use that to
estimate the lens distortion applied to your shots,

w
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The original distorted shot Associated grid shot

OR

If no estimation grid is available, you can use the LensDistortion effect's manual line drawing
workflow to estimate lens distortion.

- —

The original distorted shot Example lines in the alpha channel

See Estimating Lens Distortion Using a Grid or Estimating and Removing Lens Distortion Using
Lines for more information.

5. When you've calculated the required lens distortion, make sure that the LensDistortion effect's
Mode is set to Undistort in the Properties panel.

6. Select the LensDistortion effect, right-click and choose Edit > Copy As Clones or press the
Ctrl/Cmd+K keyboard shortcut.

7. Select the other shots in the timeline to which you want to add the cloned effect.

8. Right-click the selection and choose Edit > Paste or press the Ctrl/Cmd+V keyboard shortcut.

The effect is cloned to the selected shots and the LensDistortion effect is applied. Cloned effects
are clearly marked with a C and retain the same effect name, in this case LensDistortion2, so
you can quickly locate them.


https://learn.foundry.com/nuke/content/comp_environment/lens_distortion/analyzing_distortion_grid.html
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01:00:00:00 01:00:04:00 01:00:08:00

Audio 1

If you update the lens solve further to improve the results, simply update the clone source
LensDistortion effect to apply it to all the clones on the timeline.

9. You can now use Create Comp to send all the affected shots to your comp department.
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Apply Pre-Trained Models to
Shots Using Inference

Nuke Studio and Hiero's soft effect collection also includes an Inference effect in the timeline. The
Inference effect applies a pre-trained .cat file to create the effect modeled by a neural network across
shots on the timeline. The Inference effect is designed to maximize artist efficiency by eliminating the
need for round-tripping between the timeline and comp environments in order to see the results of
CopyCat training on multiple shots. You can also convert your own models to .cat files using the
CatFileCreator, or download open-source models from Cattery for use on the timeline.

See Train Neural Networks to Replicate Effects Using Machine Learning and Import Pre-Trained
PyTorch Models for more information on creating and sourcing .cat files for use in the Inference
effect.

Note: You can use .cat files requiring multiple inputs with the Inference soft effect, using
the Channels In and Channels Out options.

Add an Inference Effect to a Shot

So you've trained your model and it's ready to go. In this example, we've trained a model to remove a
bruise from an actor's face. Here's how to apply the model to a shot on the timeline.

1. Either select the shot on the timeline manually or use the handy auto-select feature to choose a
shot for you depending on the current playhead's position.

2. Click the soft effect menu icon . on the left-hand side of the timeline.
3. Select Inference to add the effect to the shot.

An error is displayed in the Viewer because no .cat file is selected by default.
4. Inthe Properties panel, enter a Model File path to the .cat file you want to apply to the shot.

The model is applied to the shot and you'll see the result in the Viewer.
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Before Inference - ' After Inference

01:00:00:00

Video 1 n

Audio 1

Note: Depending on the model's size and complexity, there may be a delay while the
effect is applied to the shot.

5. You can enable Optimize for Speed and Memory if you want a faster preview of the results. The
Properties panel also displays the Channels In and Channels Out for reference.

Tip: You can also apply Inference soft effects to an entire sequence by creating a new
track and adding the effect to the track, instead of individual shots. See Adding
Sequence-Level Soft Effects for more information.

Apply an Inference Effect to Multiple Shots

You can easily test how well the Inference effect works on other shots by simply copying and pasting
the effect onto those shots. However, once you intend to use an Inference effect on multiple shots, it's
a good idea to apply it to one shot first and then clone the effect to the other shots in case you update
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the .cat file later on with further training. Another useful method is to apply the soft effect to a track
above the clip, then extend it to cover as many clips on the tracks below as needed. You can also cut
the soft effect into pieces for more control over which clips it applies to.

1. Follow the steps above to add an Inference effect.
2. Clone the Inference effect onto other shots in the timelines. See Cloning to learn how to clone a

soft effect.

Cloned effects are clearly marked with a C and retain the same effect name, in this case
Inference2, so you can quickly locate them.

01:00:00:0001:00:04:04 01:00:08:08 01:00:12:12

HInfErEnce?_
HInFErEm:E?_ HInfErEnce?_

Video 1

& O Bie

If you train the model further to improve the results, simply update the clone source Model File
control with the new .cat file to apply it to all the clones on the timeline.
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Annotations can be used as quick instructions for a compositor to implement in Nuke's Compositing
environment. You can add annotations to a clip, a section marked with in and out points, or a whole
sequence.

Annotations can be exported with a Nuke Comp and can then be viewed and/or deleted in the
Compositing environment. When all the suggested changes have been made to the script in the
Compositing environment, this can be saved as a new comp version and then rendered back to the
Timeline environment. If you want to add new annotations to the rendered Nuke Comp, you can
choose to re-export annotations only.

Workflow

The following steps show an example of Hiero's workflow for annotations:

1. Inthe Viewer, open the Annotations menu.
See The Annotations Menu for more information for more information about it.

2. Add an annotation to a shot(s) at sequence or shot-level, by using the Annotation menu tools.
See Adding Annotations for more information.

3. You can choose to edit a sequence or shot-level annotation after it has been created. See Editing
Sequence-Level Annotations or Editing Shot-Level Annotations for more information.

4. Create a Nuke Comp of the shot with the annotations, ensuring annotations are enabled in the
export settings.

5. Open the Nuke Comp in an external Nuke application.
See Viewing Annotations in Nuke for more information.

6. After the suggested changes are made in the in the external Hiero, select File > Save New Comp
Version.

7. Return to the timeline, and version up the Nuke Comp by right-clicking it and selecting Versions >
Version Up.
The Nuke Comp is versioned up. Depending on your Preferences > Performance >
Threads/Processes > Rendering > background renders setting, the comp may need rendering
manually.

8. You can add new annotations to the rendered Nuke Comp by ensuring you select the Clip radio
button and then using the Annotations menu tools.
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9. After adding the new annotations, right-click the rendered Nuke Comp and select Export > Re-
Export Annotations.

10. Open the rendered Nuke Comp in an external Nuke application.

11. Double-click the Precomp node to open its properties and version it up. For example, if the file
path has v01.nk at the end, change it to v02.nk. See Re-Exporting Annotations from the Timeline
for more information.

12. Display the Precomp in the Viewer.

Your new annotations are displayed.

The Annotations Menu

You can open the Annotations menu by selecting the paint brush icon . at the top-right of the
Viewer.

The Annotations menu displays down the left side of the Viewer.

] Annotations Menu

Note: Annotations on sequences and shots are only visible when you have the Annotations
menu open.

Adding Annotations

To add an annotation, do the following:

1. After you have opened the Annotations menu, move the playhead on the timeline to where you
want to add your annotation.

2. Click the + (addition) icon.
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A dialog is displayed containing annotation options.

colour Add to:

4 T8 Range:

3. You can choose which level you want to add your annotation to, sequence or shot-level, by
selecting either the Sequence or Clip radio buttons.

When you add an annotation to the clip level, a turquoise line is displayed within the top of the

shot. When you apply an annotation to the sequence level, a turquoise box appears above the
selected section on a separate Annotations track.

4. From the Range dropdown select one of the following:
* Current Item - Applies the annotation to the shot at the current playhead position.
* Current Frame - Applies the annotation to the frame at the current playhead position.

* In/Out Points - Applies the annotation to in and out points that have already been marked on
the timeline.

* All - Applies the annotation to the whole track.

+ Custom - When you select this from the Range dropdown, the in and out point fields within the

dialog, become active. You can then use these to set the section that you want your annotation
to appear on.

Note: The timecode displayed in the In and Out fields is derived from the clip's metadata,
not its position in the sequence.

5. When you have set where you want your annotation to appear, click New.
A label is added to the location of your annotations, detailing the clip timecode and name.

You can click and drag this label to place it anywhere in the Viewer.
6. Todraw in your annotation, select the paint brush tool from the Annotation menu.
This is highlighted orange when selected.

7. Before drawing in the Viewer, you can set the brush and paint settings:

* Select the brush and/or background color by clicking the paint colors icon .
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This opens a color wheel that allows you to select the color and brightness, and an opacity slider
underneath that you can use to set the opacity of the paint.

* Select the paint brush size icon n to set the required brush size. You can either use the slider
to drag to your required brush size, or enter it into the brush size field.

Note: You can also edit these settings after drawing by clicking the selection tool in the
Annotations menu, selecting the lines that you've drawn in the Viewer, and then adjusting
the paint brush settings.

8. Click and drag in the Viewer to draw with your selected brush settings.

9. To add text to your annotation, click the text icon in the Annotations menu and then click
anywhere in Viewer to enter your required text.

A text dialog appears allowing you to type your required text, align it horizontally and vertically,
and adjust the text size. You can then click and drag the text box to anywhere in the Viewer.
[[inseit car
S AeTe
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Enabling and Disabling Annotations

You can choose to disable and re-enable annotations from the output. To enable or disable a
sequence-level annotation, simply select the annotation by clicking on the turquoise box and then
pressing D. To enable or disable a shot-level annotation, you first need to open the shot - that
includes the annotation - in the timeline view. Then you can select the annotation and press D.

Editing Sequence-Level Annotations

You can choose to edit, copy, move, and delete any annotations that were added on the sequence-
level.

To remove an annotation from the sequence-level, simply select the turquoise box representing the
annotation you want to move from the Annotation track, right-click and select Edit > Delete (or press
Backspace or Delete on the keyboard).

To copy an annotation that was added at sequence level:

1. Select the annotation and then click Edit > Copy (or press Ctrl/Cmd+C). You can also access these
tools in the right-click menu.

2. Move the timeline playhead to the position where you want to paste the annotation.
3. Select Edit > Paste (or press Ctrl/Cmd+V).

Note: You can also copy and paste annotations, that were added at sequence-level, between
different sequences.

To move an annotation that was added at sequence level, you can simply click and drag it to the
required location. You can also drag annotations to different track levels.

You can trim an annotation at either end by hovering the cursor over one end of the annotation until

it changes into the trim icon:

Then click and drag to where you want to trim the annotation to.

To edit the actual annotation, you can use the selection tool in the Annotations menu to select the
annotation in the Viewer and move it, delete it, or replace it.
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Editing Shot-Level Annotations

You can choose to move, trim, and simply delete shot-level annotations.

To edit a shot-level annotation, you first need to open the annotated shot as a timeline. To do this:
1. Right-click the shot with the annotation you want edit.
2. Select Open In > Timeline View.

The shot opens in the Timeline View, and the annotation now appears as on a separate level from
the video. To view the annotation in the Viewer, ensure the Annotation menu is open.

To move a shot-level annotation from the Timeline view, hover the cursor over the annotation until it

changes into a move icon:

Then simply click and drag it to where you want to move it to.

You can trim an annotation at either end by hovering the cursor over one end of the annotation until
it changes into the trim icon:

Then click and drag to where you want to trim the annotation to.

To delete the annotation, click the turquoise box and select Edit > Delete (or press Backspace or
Delete on the keyboard).

To edit the actual annotation, you can use the selection tool in the Annotations menu to select the
annotation in the Viewer and move it, delete it, or replace it.
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Viewing Annotations in Nuke

If you want to view annotations in an external Hiero application, you need to ensure annotations are
enabled when creating a Nuke Comp. You can do this by either opening the Export dialog or the
Project Settings dialog and checking the option Basic Nuke Shot With Annotations is selected. See
using Create Comp Clips during round-tripping under Building VFX Tracks and Comp Clips for more
information.

To create a Nuke Comp with annotations, do the following:

1.

Create a Nuke Comp by right-clicking on the shot that you want use to create a Nuke Comp, and
selecting Export.

The Export dialog opens.

In the Using Local export preset setting in the middle-top of the dialog, ensure Basic Nuke Shot
With Annotations is selected. Also, in the Tracks For This Export section in the bottom-left of
the dialog, ensure either all tracks is selected, or that the Annotations checkbox is selected with
certain tracks.

Click Export.

A message warns that you've changed the export templates and asks whether you want to keep
them.

Click Yes or No.

See Building VFX Tracks and Comp Clipsfor more information on bringing Nuke Comps back into
Hiero.

If you wish, you can view the annotations in an external Hiero by doing the following:

1.

Double-click the Precomp node to open its properties panel, and the click Open.
This opens the contents of the Precomp node as a node tree in a new instance of Hiero.
Ensure you have the Node Graph tab selected.

The node tree displays in two parts. The top part represents the shot-level settings and the bottom
part represents the sequence-level settings. Depending on where you set your annotation to be,
an Annotations node group is displayed in the node tree.
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Sequence Level

3. Double-click the Annotations node group to open its properties panel.

4. Inthe top-right of the node properties, click the node structure icon - to display the contents of
the node group.
This displays the contents of the Annotations node group in a new Node Graph tab.

Re-Exporting Annotations from the Timeline

You may want to add new annotations after the Nuke Comp has been edited and rendered. In this
case, you can re-export the annotations only.

To re-export annotations, do the following:
1. Move the playhead to the rendered Nuke Comp.
2. Pressthe +in the Annotations menu at the side of the Viewer, and select the Clip radio button.

Tip: You cannot add sequence-level annotations to a Nuke Comp.

3. Add an annotation using the brush or text tools in the Annotation menu.
4. Right-click the Nuke Comp, and select Export > Re-Export Annotations.
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5. Return to the Hiero script and double-click the Precomp node to open its properties, and version it

up.

For example, if the file path has v01.nk at the end, change it to v02.nk. You can also version up

the Precomp node by doing one of the following:

* Select the Precomp node and press Alt+Up Arrow.

* Select the Precomp node and click Edit > Node > Filename > Version Up.

6. Ensure the Precomp node is connected to a Viewer node.

Your new annotation is now visible in the Viewer.
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Sync Review

Sync Review allows multiple participants to collaborate on a single project in Nuke Studio, Hiero, or
HieroPlayer. The host allows multiple clients to join the review session and all participants have access
to the playback controls, annotations, and versioning system.

Warning: All participants must use the same version of the application to run a sync
session. For example, if the host is using 16.0v5, clients can only connect to the session if
they are using 16.0v5 as well.

Sync Review works by connecting clients to the host using the host's IP address or hostname and an
open port number. The project .hrox file only needs to exist on the host machine, but the source clips
referenced by the shots on the timeline must be available for all participants either locally or from a

central server.

N N

Client

All sessions must have
access to the source files

Source
Files

Client

. )

Host Client

Only the host needs the
.hrox project file
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Hosting a Sync Review Session

Nuke Studio, Hiero, and HieroPlayer can all act as host in Sync Review sessions, though you only need
one host to connect multiple clients.

To start a host session:
1. Goto File > Open Project to load the project you want to review.

Note: Only the host loads the project, client sessions don't require the .hrox file.

2. Go to Workspace > Sync Session to load a dedicated review workspace,

OR
Go to Window > Sync Session to open the Sync Session panel.

3. Click Host.
The Session Setup dialog is displayed.

Session Setup
Your Name: biff
Connection Setup

Hostname To Share: FWZSTU011 =

Port: 45124 §

Connection Info FWZ5TU011:45124

4. Enter the name you want to display on participant sessions and pick a cursor color by clicking on
the color swatch.

Tip: You can set your name and cursor color for new sessions in the Preferences under
Project Defaults > Sync Review.

5. Select the host name and port to which you want the client sessions to connect.
Your selection is displayed in the Connection Info field.

Tip: Click the copy to clipboard button to automatically copy the connection details so that
you can pass them on to participants.

6. Click Start to begin hosting.
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The Sync Session panel is populated with your details automatically.
7. Send the connection details to the participants that intend to join the review session.

Tip: If you didn't copy them to the clipboard earlier, click Sync Panel > Copy Info.

Connecting to a Sync Review Session

Nuke Studio, Hiero, and HieroPlayer can all connect as clients in Sync Review sessions, all you need is
the connection information from the host.

Warning: All participants must use the same version of the application to run a sync
session. For example, if the host is using 16.0v5, clients can only connect to the session if
they are using 16.0v5 as well.

To connect a client session to a host:
1. Ensure that you have access to the source files used in the host project.

The files can be on a server on the same network as the host machine or accessed over the
internet using suitable security, such as VPN.

Note: Only the host loads the project, client sessions don't require the .hrox file.

2. Go to Workspace > Sync Session to load a dedicated review workspace,

OR
Go to Window > Sync Session to open the Sync Session panel.

3. Click Connect.
The Session Setup dialog is displayed.

Session Setup

Your Name: george
Connection Information
Host FWZSTUO11
Port 45124 S

Status

Connect
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4. Enter the name you want to display on client sessions and pick a cursor color by clicking on the

color swatch.

Tip: You can set your name and cursor color for new sessions in the Preferences under
Project Defaults > Sync Review.

5. Enter the Host name and Port supplied by the Sync Review session host.

6. Click Connect to join the review.
A list of participants is displayed in the Sync Session panel.

End Session

Status

- Participants (3)
B bif Host

george Connected

doc Connected

Client sessions can connect or disconnect at any time and the Status updates as required.

Host

Offline

Connected

If the Host ends the session, all client sessions are also ended.

Collaborative Review

Participants in a Sync Review session can all contribute equally to the review. Each participant has a
named and color-coded cursor that other participants can see in the Viewer. In the example, biff's

cursor is shown as normal because it's their session.
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Most participant actions available in the Viewer, Project panel, and timeline are synced automatically

during the session, including:

* Viewer - Layer and channel selection, TC/Frames option, guides and Viewer selection options, Zoom
in/out.

* Project panel - Importing files, creating new sequences, tags, and bins and creating, renaming,
moving or deleting project items.

* Timeline - Creating new tracks, renaming shots, adding or deleting soft effects, changes in soft
effects parameters, retimes and transitions, Sync Lock Status of tracks, trimming and moving clips in
the timeline.

If participant sessions are out of sync, you can push actions to other participants manually. Click the
update button in the Sync Session panel or use the Ctrl/Cmd+P keyboard shortcut to force an
update across all participant sessions.
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Timeline Editing Tools

The timeline editing tools allow you to manipulate your shots directly in the timeline, in single- or
multi-view projects, using a series of modal editorial tools that complement the Multi Tool. Select the
tool you need for the job and then select a new tool and continue editing.

The timeline editing tools are grouped for convenience - each tool group contains several tools and
you can cycle between them by clicking the tool or using keyboard shortcuts. The editing tools work
the same way in single- and multi-view timelines.

Icon

Tools

Multi Tool

Move/Trim

Select

Selection by
Track

Slip Clip

Slide Clip

Roll Edit

Ripple Edit

Description

The Multi Tool's functionality is equivalent to most of the other tools
combined, but doesn't require modal tool selection.

The Move/Trim tool allows you to manipulate the position of a shot
or its output by adding or removing handles.

The marquee Select tool allows you to make multiple selections
quickly by lassoing shots. Hold Shift to add to the selection and Alt to
subtract from the selection.

The track selection tools allow you to quickly select multiple items
depending on the initial selection. For example, the Select Track to
Right tool selects all shots to the right of the target shot, within a
single track.

The Slip Clip tool allows you to shift a shot's In and Out points by the
same amount and in the same direction, retaining the original
duration but altering the timeline output.

The Slide Clip tool allows you to move a shot in relation to the item
before and/or after the target item, without changing its length or
timeline output.

The Roll Edit tool enables you to roll a single edit within the available
handles, shortening one shot while lengthening the other, but keeping
the overall duration the same.

The Ripple Edit tool operates similarly to the trim function of the
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Icon Tools Description

Move/Trim tool, except that downstream shots are rippled to
automatically close any resulting gaps in the timeline.

Retime Clip The Retime Clip tool allows you to trim a shot's In or Out point and
automatically retime the clip to fill the new shot duration.

Razor The Razor and Razor All tools allow you to cut shots in to separate
parts so you can remove sections or rearrange items on the timeline.

ﬁ Join The Join tool can only be used on edit points between two razored
shots, denoted by the yellow arrows at the edit.

Tip: Enabling Preferences > Panels > Timeline > show frame end marker draws an extra
line on the timeline to the right of the playhead, indicating the end of the current frame.

The modal editorial tools are mapped to the Q, W, E, R, and T keyboard shortcuts when the timeline is
the active tab.

Note: For a full list of keyboard shortcuts, please see Appendix B: Keyboard Shortcuts.

Playhead
Editorial Toocls Manipulaticn
and Marking

Selection, Mudging,
and Timecode Entry

Pressing a keyboard shortcut multiple times selects the tools within each mode. For example, pressing
E twice, rapidly in succession activates Slide Clip. Pressing them slowly in succession does not achieve
the same result, but instead, remains on the first item in the menu. This allows you to activate a tool
without knowing the current state of tool selection.

* mapped to Q, cycles through Multi Tool, Move/Trim, and Select.
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* mapped to W, cycles through Track Selection tools.

* mapped to E, cycles through Slip Clip and Slide Clip.

* mapped to R, cycles through Roll Edit, Ripple Edit, and Retime Clip.
* mapped to T, cycles through Razor, Razor All, and Join.

USER GUIDE
326



Using the Multi Tool |

Using the Multi Tool

Unlike the other editing tools available, the Multi Tool changes function depending on the position of
your pointer in relation to the shot(s) selected.

Slide Tool Maowve Tool

Trim Tool Slip Teol Roll Tool

The Multi Tool's functionality is equivalent to most of the other tools combined, but doesn’t require
modal tool selection:

* Move - placing the mouse in the center of a shot activates the tool. Drag the selected shot to the
required position on the timeline.

* Trim - placing the mouse at the left or right of the shot activates the tool. Drag the edit point to the
new position and release the mouse to complete the trim.

See Using the Move/Trim Tool for more information.
* Select - click-and-drag to marquee select clips. Hold Shift to add to your selection or Alt to subtract.

See Using the Selection Tools for more information.

+ Slip - placing the mouse at the bottom of the shot activates the tool and displays the slip handles.
Drag the shot to the new position and release the mouse to complete the slip.

See Using the Slip Clip Tool for more information.

+ Slide - placing the mouse at the top of the shot activates the tool and displays the slide handles.
Drag the shot to the new position and release the mouse to complete the slide.

See Using the Slide Clip Tool for more information.

* Roll - placing the mouse on the edit between shots activates the tool and displays the handles. Drag
the edit to the new position and release the mouse to complete the roll.

See Using the Roll Edit Tool for more information.

* Razor - when using the Multi Tool, Razor cuts are menu driven. Navigate to Timeline > Razor
Selected or Razor All to make cuts at the current playhead position.
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See Using the Razor and Join Tools for more information.
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Using the Move/Trim Tool

The Move/Trim tool allows you to manipulate the position of a shot or its output by adding or
removing handles. Activate the Move/Trim tool by clicking the tool or pressing Q twice.

Moving Shots

Click and drag the selected shot(s) to the required position on the timeline. A time count popup, in
conjunction with the snap to edit function, helps you to reposition the shot(s) accurately.

01:00:00:00 I T T e R T T I A S R T |
01:00:00:00 01:00:02:00 01:00:04:00 01:00:06:00

Ref..nce

Ref..nce

You can also move shots up and down the track hierarchy using drag-and-drop or the Alt+, (comma)
and Alt+. (period) keyboard shortcuts.

01:00:00:00 'i )
El 00:00:00

Ref_nce

Ref_nce
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The following table describes the Move/Trim tool's modifiers and actions:

Mode Method Description

Overwrite drag-and-drop The default move mode. The dragged shot overwrites
any items that are present in the move location.

Ripple drag then hold Altand  Drag-and-drop shots on top of other items without
drop overwriting content - items are pushed down the
timeline to accommodate the move.

Duplicate hold Alt and drag then ~ Copy the shot, then drag-and-drop on top of other
release Alt and drop items overwriting existing content - items are not
pushed down the timeline to accommodate the move.

Ripple and hold Alt then drag and  Copy the shot, then drag-and-drop items on top of
Duplicate drop while holding Alt  others without overwriting content - items are pushed
down the timeline to accommodate the move.

Note: On Linux, hold Ctrl+Alt for Duplicate and RippleDuplicate modifiers.

Action Keyboard Shortcut Description

Delete Backspace Delete the selected shot(s) or gap(s).

Ripple Shift + Backspace Remove the selected shot(s) and ripple items down stream to
Delete close gaps in the timeline.

Note: The ripple effect may not close gaps entirely,
because Hiero does not allow linked tracks to
become desynchronized during rippling.

If you need to nudge shots horizontally by just a frame or two, you can select the items on the
timeline and press, (comma) to nudge it left or . (period) to nudge it right. Press Shift+, (comma) or.
(period) to nudge the shot horizontally by the Framelncrement set under the Viewer.

Note: You cannot overwrite other shots on the timeline horizontally using the nudge keys.
However, vertical nudging (Alt+, and Alt+.) overwrites other tracks.
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To Move Shots Using the Spreadsheet View:

1. Select the required events in the spreadsheet view.

2. Click the cogicon and select the required Time Edit Behaviors:

Modify Using

Dst In Move
Destination

Dst Out Move
Destination

Result

Adjusts the event’s Dst In and Out by the same amount, moving the
shot's position on the timeline by the specified amount, while
maintaining Speed.

Before and after a 2 second Dst In increase:

Sre Dur Dat In

Adjusts the event's Dst Out and In by the same amount, moving the
shot's position on the timeline by the specified amount, while
maintaining Speed.

Before and after a 2 second Dst Out increase:

3. Adjust the Dst In or DstOut to move the shot(s) by the specified amount.

Trimming Shots

Click-and-drag the edit point to the new position and release the mouse to complete the trim.
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Tip: Use the Ripple Edit tool, activated by pressing R twice, to ripple downstream shots
automatically.

The Viewer displays the new In or Out point (depending on whether you're adjusting the beginning or
end of the shot), allowing you to accurately gauge the new output.

Note: Trimming multiple shots simultaneously trims each item by the same amount and in
the same direction.

Alternatively, click an edit point and nudge the edit using the Ctrl/Cmd+€&-> (numeric pad) keys or
hold Shift to nudge by the Frame Increment set under the Viewer.
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By holding Ctrl/Cmd and dragging an edit, you can add blank frames past the end of the shot's
handles. Blank frames are colored red on the timeline for clarity:

1. Select the required events in the spreadsheet view.

2. Click the cogicon and select the required Time Edit Behaviors depending on whether you're
using the In or Out points or duration:
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Modify Using Result
Srcin Trim In Trims the event's Src In, Dst In, and durations while maintaining speed.

Before and after a 2 second Src In increase:

Src Out Trim Out Trims the event’s Src Out, Dst Out, and durations while maintaining
speed.

Before and after a 2 second Src Out increase:

Dt Ot Dt Dur

0000 01:00:03:24 100

ur Dt In D=t Out

O1:00:00:00 01:00:0%5:24 150

Src Dur Trim Out Trims the event's Src Dur, Dst Dur, and Src/Dst Out while maintaining
speed.

Before and after a 50 frame Src Dur increase:

Sre ln Sre Owuit Sre Daar  Dx

00:00:00:01  0:-00:04:00 100 01:00:00:00 01:00:03:24

Dst In Trim In Trims the event’s Dst In, Src In, and durations while maintaining speed.

Before and after a 2 second Dst In increase:

Sre lm Sre Owt Sre Dur Dat In Dsr Out Dsr Dar

00:00:00:01  0:-00:04:00 100 01:00:00:00 01:00-:03:24 100

Sre Owt Sre Dur Dt In Dt Ot

201 O0D-O0:04:00 50 01:00:02:00 01:00-03:24 50

Dst Out Trim Out Trims the event's Dst Out, Src Out, and durations while maintaining
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Modify Using Result
speed.

Before and after a 2 second Dst Out increase:

Dst Dur Trim Out Trims the event’s Dst Dur, Src Dur, and Dst/Src Out while maintaining
speed.

Before and after a 50 frame Dst Dur increase:

Dt Ot Dt Dur

00500 01:00003:24 100

100.0%  D0:00:00:01 000006 (0

3. Adjust the values as required to trim the shot(s) by the specified amount.
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Using the Selection Tools

The timeline editing tools include a marquee selection tool and several context dependent track
selection tools.

The marquee Select tool, activated by clicking the tool or pressing Q three times, allows you to make
multiple selections quickly by lassoing shots.

Hold Shift to add to the selection:

I|-I|I|I-|-I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I
01:00:00:00 01:00:0<4:00 01:00:08:00

Video 3

Mis... V

Ref_.nce

Audio 2

The track selection tools, activated by clicking the tool or by pressing W, selects multiple items
depending on the initial selection:

* Select Track to Right or Left - all shots right or left of the target shot are selected, within a single
track.
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Il 00:00:00 01:00:04:00 01:00:08:00

Video 3

Mis... V

Ref_.nce

Ref_.nce

Audio 2

01:00:08:00

Ref_.nce

Audio 2

+ Select All Tracks Right or Left - all shots right or left of the target item are selected, regardless of

which track they occupy.
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01:00:00:00 1 T|.|.|.|.|.|.|.|.|.|||||||||||||||||||||||||||||||||||

01:00:00:00 01:00:04:00 01:00:08:00

Video 3

Mis...

Ref_.nce

Audio 2
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Using the Slip Clip Tool

The Slip Clip tool allows you to shift a shot's In and Out points by the same amount and in the same
direction, retaining the original duration but altering the timeline output. Activate the Slip Clip tool by

clicking the tool or pressing E.

Note: The target shot must have handles to use the Slip tool.

The Slip Clip tool displays different Viewer previews depending on whether the playhead is on the

target shot or not, but the basic principles are the same.

Click the target clip to display the available handles and then drag the shot to the new position.
Release the mouse to complete the slip.

01:00:00:00

Note: Using the Slip Clip tool does not move the shot on the timeline, only the output is
changed.

Alternatively, nudge the slip using the , (comma) or . (period) keys or hold Shift to nudge by the
Frame Increment set under the Viewer.

Tip: If you're using the Multi Tool, you can nudge using the “slip bar” by clicking at the
bottom the shot.

The following Viewer previews are displayed, depending on the playhead position:

Note: The Viewer background always displays the playhead'’s current position.
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* When the playhead is not currently on the target shot, the Viewer displays the In frame (1) and Out
frame (2), allowing you to accurately gauge the new output.

* When the playhead is on the target shot, the Viewer displays the In frame (1), the current frame (2),
and Out frame (3), allowing you to accurately gauge the output of the shot against the current
frame.

* When the playhead is on the target shot and A/B compare is active, the Viewer displays the target
shot (1) and the reference shot (2), allowing you to synchronize your working track against the
reference track.

Slipping Using the Spreadsheet View

You can slip shots using the Src In and Src Out columns of the spreadsheet:

1. Select the required event in the spreadsheet view.
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2. Click the cogicon and select the required Time Edit Behaviors depending on whether you're

using the In or Out point:

Modify Using
SrcIn Slip Source
Src Out Slip Source

Result

Adjusts the Src In and Src Out by the same amount, slipping the event
while maintaining speed.

Before and after a 2 second Src In increase:

Adjusts the Src Out and Src In by the same amount, slipping the event
while maintaining speed.

Before and after a 2 second Src Out increase:

3. Adjust the Src In or Src Out to slip the shot(s) by the specified amount.
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Using the Slide Clip Tool

The Slide Clip tool allows you to move a shot in relation to the item before and/or after the target
item, without changing its length or timeline output. Activate the Slide Clip tool by clicking the tool or
pressing E twice.

The shot either side of the target are shortened or lengthened within the limits of their handles to
accommodate the slide.

Note: The surrounding shots must have handles to use the Slide tool.

Click the target shot and then drag it to the new position and release the mouse to complete the slide.

For example, if you slide the target shot (2) five frames to the right, the preceding item (1) ends five
frames later and the next item (3) starts five frames later.

The first image shows a timeline containing three shot, and the second shows the same shots with the
target (2) sliding to the right.

1 1 1 1 1 1 1
-
Il 00:00:00 01:00:02:00

Ref _.nce

Audio 1

Audio 2
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1

Audio

Audio 2

The Viewer displays the new end point of the previous shot on the left and the new start point of the
next shot on the right, allowing you to accurately gauge the slide.

The two center images (2) represent the start and end frames of the target shot, which don't change.
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Using the Roll Edit Tool

The Roll Edit tool enables you to roll a single edit within the available handles, shortening one shot

while lengthening the other, but keeping the overall duration the same. Activate the Roll Edit tool by
clicking the tool or pressing R.

Note: Atleast one of the target items must have handles to use the Roll tool.

1. Click an edit point between two shots to display the available handles as a red overlay.
2. Drag the edit to the new position and release the mouse to complete the roll.
For example, if you roll a number of frames at the end of one shot (1), the next item (2) starts that

number of frames later. The first image shows a timeline containing two shots, and the second
shows the same items with the edit point “rolled” to the right.

1 12/

Audio

Audio 2
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Audio 1

Audio 2

The Viewer displays the pre-edit shot on the left and the post-edit item on the right, allowing you to
accurately gauge the new position of the edit.

Alternatively, click the edit point between the shot and nudge the edit using the , (comma) or . (period)
keys or hold Shift to nudge by the Frame Increment set under the Viewer.
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Using the Retime Clip Tool

The Retime Clip tool allows you to trim a shot's In or Out point and automatically retime the clip to fill
the new shot duration. Activate the Retime Clip tool by clicking the tool or pressing R three times.

Click-and-drag the edit point to the new position and release to complete the trim and retime. For
example, trimming a 50 frame shot to 25 frames retimes the clip to 200%.

Ref _nce

Audio 2

Ref _nce

Audio 2

Alternatively, click an edit point and nudge the edit using the , (comma) or . (period) keys or hold Shift
to nudge by the Frame Increment set under the Viewer.
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Using the Retime Clip Tool | Slipping Using the Spreadsheet View

. Tip: By holding Ctrl/Cmd and dragging an edit, you can retime past the end of the shot's
~ handles.

(E)HIERO USER GUIDE
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Using the Razor and Join Tools

The Razor tools allow you to cut shots in to separate parts so you can remove sections or rearrange
items on the timeline. Activate Razor and Razor All by clicking the tool or pressing R.

Place the cursor on the target shot, and if the cut is permissible, click to razor the shot or all shots
depending on which tool you have selected.

Tip: The Razor cursor indicates whether a cut is permissible or not, such as on existing edits.

You can also apply cuts at the playhead position from the menu bar using Timeline > Razor Selected,
or all tracks using Timeline > Razor All.

Tip: Use the C (with the shot under the playhead selected) and Shift+C keyboard shortcut,
or the right-click context menu, to perform the respective cuts.

The Join tool can only be used on edit points between razored shots, denoted by the yellow arrows at
the edit.

Tl-llu-l-l||-.|-||-||-||||.|||||||||.|||||||||.|||||||||I|||||||||.|||||||||.|||||||||.|||||||||.||||||||

0 I i 01:00:02:00

Copying Cuts Between Tracks

The Copy Cuts function allows you to quickly apply cuts from one track to other tracks on the
timeline. For example, in the timeline shown, you could copy the cuts from the second video track to
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the Reference audio tracks.

Ref_.nce

Audio 2

To copy cuts:

1. Select the shots containing the cuts to copy, or if you intend to copy all the cuts from a track you
don't need to make a selection.

2. Right-click in the timeline and select Editorial > Copy Cuts.

The Copy Cuts dialog displays.

From: ™= Nissan_X_Trail_wZ V1
To:

Reference
Audio 2

Select/Deselect All Tracks

Rename: Using 'From' Shot Names

3. If you made a selection on the timeline, use the dropdown to select Copy All Cuts or Copy
Selected Cuts as required.
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This dropdown is not displayed if no shots were selected.
Click the From dropdown to select the source track.

Check all the destination tracks in the To field to which you want to copy the cuts.

Choose whether or not the resulting shots are named identically to the source track.

Selecting None retains the destination clip name.

Click OK to copy the cuts to the destination track(s).
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Insert, Overwrite, and 3-Point
Editing

Insert and Overwrite edits are applied at the current playhead position by default, but the use of In
and Out points in the clip Viewer and/or sequence Viewer can give you greater control over the result.
3-point editing, makes use of In and Out points in the clip Viewer and an In or Out in the sequence
Viewer to control where the clip is placed on the timeline.

Inserting Clips

By default, Insert places the entire contents of the clip Viewer into the timeline at the current
playhead position, on the lowest available track. All shots downstream of the playhead are rippled to
make room for the clip. No items are overwritten or removed.

Pre-insert timeline Post-insert timeline

Note: If the playhead is not positioned at an edit point, or there are shots on other tracks,
the Insert action cuts the shot(s) at the playhead and ripples the cut downstream.

For example, the Post-insert image shows the audio shot being cut and rippled, even though
it doesn't reside on the same track.

You can select a track before inserting if you don't want to target the lowest available track. Even if the
target track is empty, shots on all other unlocked tracks are rippled by the same amount.

You can also use In and Out points to control where the clip is inserted and how many frames are
included. See 3-Point Editing for more information.

To insert a clip at the playhead:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
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Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

Double-click the source clip to load it into the left-hand clip Viewer .
Place the playhead at the required edit point or timecode and select the target track, if necessary.
Navigate to Clip > Insert, or press N, to insert the clip into the timeline.

vk wenN

All shots downstream of the clip are rippled to make room for the duration of the edit.

To insert a clip at an In or Out point:

1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .
4. Place an In or Out point on the timeline to determine the clip’s position:

* In point - the source clip is inserted so that the first frame is at the In point specified.

« Out point - the source clip is inserted so that the last frame is at the Out point specified.
5. Navigate to Clip > Insert, or press N, to insert the clip into the timeline.

All shots downstream of the In or Out point are rippled to make room for the duration of the edit.

Overwrite Edits

Unlike inserting, Overwrite does not incorporate downstream ripple and doesn't alter the length of
your sequence. Any shots you overwrite are destroyed, though they can easily be recovered from the
source clips in the bin view.

Pre-overwrite timeline Post-overwrite timeline

You can select a track before overwriting if you don't want to target the lowest available track.

You can also use In and Out points to control what the clip overwrites and how many frames are
included. See 3-Point Editing for more information.

To overwrite at the playhead:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .
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3. Double-click the source clip to load it into the left-hand clip Viewer .
Place the playhead at the required edit point or timecode and select the target track, if necessary.

5. Navigate to Clip > Overwrite, or press M, to overwrite from the playhead for the duration of the
source clip.

All shots under the source clip are overwritten.

To overwrite from an In or Out point:
1. Navigate to Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .
Place an In or Out point on the timeline to determine the clip’s behavior:

* In point - the source clip begins overwriting from its first frame at the In point specified
downstream for the duration of the clip.

* Out point - the source clip begins overwriting from its last frame at the Out point specified
upstream for the duration of the clip.
5. Navigate to Clip > Overwrite, or press M, to overwrite from the In or Out point for the duration of
the source clip.

All shots under the source clip are overwritten.

3-Point Editing

Setting the output of a source clip and then editing the clip into a timeline at a specific point is
sometimes referred to as 3-point editing. Using this method, you can insert and overwrite edits in an
existing timeline or quickly construct scratch timelines from your source clips.

Firstly, set the output of your source clip using In and Out points in a clip Viewer, then set the
reference In or Out point on your timeline to determine the clip’s position. Finally, add the clip to the
timeline using Insert or Overwrite.

Tip: You can set both In and Out points on the timeline, but bear in mind that there may be
insufficient source frames for the range specified. If this is the case, blank frames are added
and highlighted in red.

You can select a track before editing if you don’t want to target the lowest available track. When
inserting, even if the target track is empty, shots on all other unlocked tracks are rippled by the same
amount.

1. Navigate to Workspace > Editing to display the 2-up Viewer layout.
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Double-click the required source clip to load it into the left-hand clip Viewer .

Set the required frame range using In and Out points.

Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

Set In and/or Out points on the timeline to specify where the clip should be added and use Insert
(N) or Overwrite (M) as required.

As an example, assuming your clip Viewer and timeline are represented by the following image,
and the Overwrite function is used:

* No In or Out points - insert or overwrite at the current playhead position, for the range
currently set in the clip Viewer.
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ef .nce

Reference Madia

3...Mmce

Reference Madia

T...nce

* In point but no Out point - insert or overwrite from the In point position downstream, for the
range currently set in the clip Viewer.

Reference Media

Reference Media

+ Out point but no In point - insert or overwrite from the Out point position upstream, for the
range currently set in the clip Viewer.
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ef .nce

Reference Media

3...Mmce

Reference Media

T...nce

* In and Out points - insert or overwrite at the current In point position, for the duration set by
the timeline's In and Out points. If there are insufficient source frames for the range specified,
blank frames are added highlighted in red.

AD12C006 101020 L1002 (A012C006_1

Reference Media

Refarance Meadia
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Versions and Snapshots

In addition to the regular project save and restore options, Hiero can record the different states of
your workflow as you progress using versions and snapshots.

* Versions are children of clips. You can have any number of versions per clip as long as they follow
the correct naming conventions, as shown in Using Versions. Versions can only be applied to source

clips and shots and can be swapped in and out without overwriting existing work. Source clips have
three states: Linked (default), Unlinked and Mixed, and you can define if a shot is linked to its source
clip or not. See Version Linking for more information.

* Snapshots are time-stamped copies of a sequence, allowing you to save its current state without the
inconvenience of saving the entire project. When you restore a snapshot, a warning displays prior to

the restore reminding you that edits since the snapshot was taken are lost. See Using Snapshots for
more information.
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Using Versions

Versions can be added to source clips and shots to allow greater flexibility in your workflow. You can
have as many versions as required and cycle through them quickly using keyboard shortcuts.

Using Versions |

Note: You cannot use versions when a clip is opened as a timeline, that is, by using the right-
click Open In > Timeline View option.

The application relies on specific file naming or directory structure conventions to discover versions:

Convention
File name constants

Clip name

Version prefix

File name variables

Version

padding

Frame padding

Extension

USER GUIDE

Description

The file name base must remain the
same.

The delineation between the file name
and version information must be either _
(underscore) or . (period) and remain the
same for all versions.

The version number padding in the clip
name can be increased or decreased.

The frame padding in the clip name can
be increased or decreased.

The file format is interchangeable. See
Appendix C: Supported File and Camera

Example

myClip_v1.0001.dpx
myClip_v2.0001.dpx
myClip_v3.0001.dpx
myClip_v1.0001.dpx
myClip_v2.0001.dpx

myClip_v3.0001.dpx

myClip_v1.0001.dpx
myClip_v002.0001.dpx
myClip_v03.0001.dpx
myClip_v1.01.dpx
myClip_v1.1.dpx
myClip_v1.0001.dpx
myClip_v1.01.png

myClip_v1.0001.dpx
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Convention Description Example

Formats for more information. myClip_v1.mov

Note: If the file extension is a movie format, such as .r3d or .mov, the Frame padding can
be omitted.
Directory name constants

Root directory The root directory name must remain the  ~/version/v1/myClip_v1.0001.dpx
same for all directories containing

verlars. ~/version/v2/myClip_v2.0001.dpx

~/version/v3/myClip_v3.0001.dpx

Directory name variables

Version The version number padding in the 09_WF_Shot004 v1
padding directory name can be increased or
deereeEEd 09_WF_Shot004_v002

09_WF_Shot004_v03

Version Linking

Control linking between source clip versions and shot versions.
Versions in Bins

Apply versioning to Project bin source clips.

Versions in Sequences

Apply versioning to shots in a sequence.
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Version Linking

Version Linking allows linking and unlinking of source clip versions between source clips and shots.
You can define if a shot version is linked to its source clip version or not, and there are three clip
states:

* Linked - the source clip and all instances of shots referencing the clip are linked. Versioning up or
down on any linked item affects all items.

Note: Linked is the default state for all clips and shots, but you can set the default in the
Preferences under Project Defaults > General > Link bin and track item version.

* Unlinked - the source clip and all instances of shots referencing the clip are unlinked. Versioning up
or down on any clip or shot only affects that item.

* Mixed - the source clip is linked to some instances of shots referencing the clip, but not all of them.
Versioning up or down on any clip or shot only affects linked items. Unlinked items are unchanged.

Linked Unlinked Mixed

Two states govern shots in sequences:

* Linked - The shot is linked to the version used by the source clip it references. Versioning up the
shot or the source clip affects both.

* Unlinked - The shot is not linked to the version used by the source clip it references. Versioning up
the shot or the source clip only affects the versioned item.
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Reference Media (Offline Master [(Clean])
Ref_nce

You can order the Project bin by Link Status to keep track of clip status and the spreadsheet view
includes columns for Version and Link Status to keep track of shot status.

Missan_X_Trail_wvz2

Import Track Match Media Set Reference Media 43
Bvent ™ Status  WVersion Link Status | Sh
~ol 20 -
-7 " - = Color = _
- wversion_linking (20) |8 ]_4
- © Duration 18 V3
—

17
FPS 16

-
h.‘

Az Name

t Timecode

I Type

B EERERELERRTOE

Source clip link status. Shot version and link status.

Linking and Unlinking Clips and Shots

Clip and shot versions are linked by default so that versioning up or down on any linked item affects
all other items. You can unlink all clips and shots in new projects by disabling Project Defaults >
General > Link bin and track item version in the Preferences. If you want more control over
linking, you can right-click a source clip or shot and set the link state individually.

Source clips allow you to link or unlink all instances of shots in one action. Link All and Unlink All
affect the version of all shots that reference the selected source clip.

USER GUIDE
361



Version Linking |

Import

Edit

Open In

Clip

Set Media ¢ r Transform

Set Poster Frame

Ctrl+Shift+E

Shots can be linked or unlinked to their source clip's version individually. If you choose to link a shot,
you can choose to use the shot's current version or the clip's current version as the linked version.

P
Tags i

Editorial Scan For Wersions
Version Up
Pttt aa b rora o

wport... Ctrl+Shift+E Version Down 01:00:12:00

Build Track Max Wersion

Effects

USER GUIDE
362



Versions in Bins |

Versions in Bins

Versions behave similarly in both bins and sequences, and in both cases, you first have to ingest an
existing version.

Ingest and locate the versioned clip, then:

1.

Right-click and select Version > Scan for Versions to search for available versions.
A dialog box lets you know how many versions were discovered.

Use the right-click Version menu to:

* Go to the next Version Up or Version Down.

* Go to the Minimum or Maximum Versions.

Tip: You can also use the Alt+Up/Down Arrow keyboard shortcuts to increment versions or
Alt+Shift+Up/Down Arrow to go to the maximum or minimum.

When you reach the end of the discovered versions, incrementing the version automatically scans
for new versions that may have become available.

For source clips only, you can right-click the clip and select Open In > Versions Bin to display all
discovered versions of the target clip.

The versioning conventions may allows clips into the Version Bin that you weren't expecting. You
can disable versions by selecting them and pressing D or by selecting the Set Active Version of a
clip using the right-click Version menu.

The Active Version is the version displayed when you drag the source clip to the timeline,
denoted by the orange V in the top left-hand corner of the thumbnail.
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Project sourceClip

=T

-

(™= courceClip = v1

Active Version Disabled Version

Once you've sorted all the available versions, select a clip in the bin view and press V to display all
versions for that clip in a convenient window. Disabled versions are not displayed.

n Project

(™= sourceClip > v1

Select the required clip to set the Active Version and apply it to the clip.
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Versions in Sequences

As mentioned previously, versions behave similarly in both bins and sequences, but swapping
versions in sequences allows you to compare results more easily.

Note: You cannot use versions when a clip is opened as a sequence, that is, using the right-
click Open In > Timeline View option.

Locate the ingested version clip and drag it to the timeline, right-click and select the Version menu:
* Scan For Versions to locate new versions of the clip.
* Version Up or Version Down to increment the version by one.

* Go to the Minimum or Maximum Version.

Tip: You can also use the Alt +Up/Down Arrow keyboard shortcuts to increment versions or
Alt+Shift+Up/Down Arrow to go to the maximum or minimum.

Once you've scanned for versions, select a shot on the timeline and press V to display all available
versions for that item in a convenient window.

Select the required shot version to set the Active Version.
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Using Snapshots

Within a project you can save the current state of a sequence as a snapshot, including a comment or
tag to describe that snapshot. You can see what snapshots exist for a sequence in the bin view and
flip it back to any previously saved state.

An example workflow might appear as follows:

Y
SQ SQ -l-. 5Q -I-.

-‘..l'"

Time

1. Two snapshots of the sequence (SQ) are recorded after edits. See Creating Snapshots.
2. Snapshot 1 is then restored. See Restoring Snapshots.
3. Further edits are made, then the sequence is recorded as snapshot 3.
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Creating Snapshots

To create a snapshot for a sequence:
1. Locate the sequence in the bin view.
2. Right-click the sequence and select Snapshot > Add Snapshot.

Import

Edit

- Open In
o

|- =" Nissan_X_Trail_v2_ Clip

Ctrl+Shift+E

The Add new snapshot dialog box displays.

Initial Conform and Edit.l

Comment:

Name: 1 - 29/

3. Enter a comment, or use the default date and time supplied.

Click Add to create the snapshot.
Snapshots are indicated in the bin view with a camera icon containing the number of snapshots
available.

USER GUIDE

367



Creating Snapshots |

Project
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Restoring Snapshots

To restore a snapshot:
1. Locate the sequence in the bin view.
2. Right-click the sequence and select Snapshot > Restore Snapshot.
3. Select the required snapshot from the list.
A warning displays reminding you that edits since the snapshot was taken are lost.

Restoring a snapshot will overwrite any subsequent changes that were made to
the sequence.

4. Click OK to restore the sequence to the point at which the snap was recorded.
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Exporting from Hiero

This section deals primarily with shot management and export functionality when you're farming out
shots or sequences to other artists. It also deals with the presets, which dictate how Create Comp
Clips passes data between Hiero and Nuke.

The export suite can transcode, export clip selections from a timeline or bin, write out EDL, OTIO, and
XML files, or bake out an entire timeline as a single clip in your required delivery format. The Export
presets are also used to manage how Create Comp Clips sends clips back and forth between Hiero
and Nuke using Local and Project Presets.

Export Dialog

There are two tabs on the Export Dialog - Quick and Custom. The Quick tab allows you to export
your timeline to video format, without additional steps. The Custom tab allows you to change more
settings such as export presets, files, tracks, and handles. See more at Introduction to the Export
Dialog.

Export Options
* Exporting Sequences with Quick Export - an accelerated renderer that allows for fast exporting of
sequences to .MOV formats.

* Exporting Sequences and Shots - the process of preparing a sequence or individual shots for export
and paving the way for VFX work to come back into Hiero.

* Transcoding - converts one file format to another. You can transcode sequences, timeline selections,
and clips from the bin view.

* Ad Hoc Exports - an umbrella covering exports that you might not perform on a per project basis,
such as EDL, OTIO, or XML exports.

With the addition of Python bindings to perform the same functions, this infrastructure provides a
massive amount of flexibility, whether your pipeline is GUI or command line orientated.

Note: Hiero is non-destructive and can slot into your pipeline if you setup your shot
template to mirror the existing file structure.
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Round-Tripping Using the Export Dialog

A round-trip describes the process of exporting clips to another application, in this case Nuke, and
then paving the way back into Hiero to conform the new VFX clips.
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Introduction to the Export Dialog

Hiero uses presets and shot templates to perform export operations, including round-tripping and
EDL/OTIO/XML creation. The Export dialog controls what is exported and where, and whether or not
to expect versioned clips as part of a round-trip from Nuke.

The Export dialog is accessed from the File menu, from the right-click bin and timeline menus, or by
using the keyboard shortcut Ctrl/Cmd+Shift+E.

There are two tabs on the Export dialog - Quick and Custom. The Quick tab allows you to export your
timeline to video format, without additional steps. The Custom tab allows you to change more
settings such as export presets, files, tracks, and handles.

The Quick tab:

Quick Export

File Path

Export Controls

The Custom tab:
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Exporters Export Controls

Content

Local Presets

Export To: {pro

Structure:
1 10 bit -

CONTENT

(auto detect)

Big Endian: %
Fill:

Reformat

Reformat: None

Burn-in

Burn-in Gizmo

Render with:

Trackand Tag Handle and
Filters Range Controls

By default you will be taken to the Quick tab if the item you are exporting is compatible, otherwise
you'll be taken to the Custom tab and the Quick tab will be grayed out.

If the source to be exported is compatible with both the Quick and Custom export options then you
can switch freely between both. Remember that only the Quick export option leverages the
accelerated rendering mechanism.

Note: See more about Quick Export at Exporting Sequences with Quick Export.

For Custom export, the Shot Template is also used to create the presets used during Create Comp
Clips, passing shots from Hiero and sending rendered Write nodes from the Node Graph back to
Hiero.
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Hiero uses Content Presets in all shot templates, enabling you to create commonly used export
conditions, which are then available across all projects. Some presets are only available with certain
exporters, for example, the EDL Exporter preset cannot be used with Process as Shots exports.

You can filter your exports using the Tracks for this Export and Filter by Tag lists, exporting only
certain tracks or shots marked with a particular tag. See Using Tags for more information.

For your convenience, Hiero ships with a number of ready-made Content Presets, but you can edit
these as required:

* Audio Export - copies any audio tracks to .wav files in a specified location.
* EDL Exporter - used to export a sequence to the EDL format.

* External Render - inserts a placeholder in the template so that other tasks can find the location of
external renders.

* Nuke Annotations File - defines the script name and paths used by Nuke Write nodes and Precomp
group during a round-trip or Create Comp Clips.

* Nuke Project File - defines the script name and paths used by Nuke Read and Write nodes during a
round-trip or Create Comp Clips.

* Nuke Write Node - defines the render format for Nuke Write nodes. Add multiple Nuke Write Node
presets to create multiple Write nodes in the resulting Nuke script.

+ OTIO Exporter - used to export a sequence to OTIO format.
* SymLink Generator - creates symlinks to the location of the source files, rather than making copies.

* Transcode Images - defines transcode parameters allowing you to save your most-used file type
conversions.

* XML Exporter - used to export a sequence to XML format.

Note: See more about export options at Exporting from Hiero.
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Exporting Sequences with Quick
Export

To export your sequence quickly to a compressed video file, for example to show to reviewers, you
can use Quick Export. This exports a sequence from Nuke Studio or Hiero to a variety of video
formats at a fast speed.

You can output your sequence to .MOV formats in the following codecs:

Apple ProRes * 4:4:4:4 XQ 12-bit
« 4:4:4:4 12-bit
« 4:2:2 HQ 10-bit
* 4:2:2 10-bit
*« 4:2:2 LT 10-bit
* 4:2:2 Proxy 10-bit

Avid DNxHD * DNxHD 444 10-bit 440Mbit
* DNxHD 422 10-bit 220Mbit
* DNxHD 422 8-bit 220Mbit
* DNxHD 422 10-bit 145Mbit
* DNxHD 422 10-bit 36Mbit

Avid DNxHR * 4:4:4 12-bit
* HQX 4:2:2 12-bit
* HQ 4:2:2 8-bit
* SQ 4:2:2 8-bit
* LB 4:2:2 8-bit

H.264 * High 4:2:0 8-bit
* Main 4:2:0 8-bit

By default you will be taken to the Quick tab if the item you are exporting is compatible, otherwise
you'll be taken to the Custom tab and the Quick tab will be grayed out.
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If the source to be exported is compatible with both the Quick and Custom export options then you
can switch freely between both. Remember that only the Quick export option leverages the
accelerated rendering mechanism.

Quick Export unavailable for the
source to be exported

Process as Clips

pcal export [‘,I""’.-"'

s Apple Pro

- Avid DNx
Clips DNxHR MXF ¢
e Clips DNxHR MXF co

Transcode Clips Photo - JPEG MOV
4 4

Export To: {projectroot)}
Export Structure

PATH

™ {binpath}
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Source compatible with both Quick
and Custom export

Faster exports with

Open the sequence that you wish to export in the sequence Viewer. Ensure that the layers you
wish to be included in the export are enabled.

Any video or audio tracks that are disabled will not be included in the final exported video file.
Likewise any clips in the sequence that are disabled will also be ignored.*

(*On Mac and Linus disabled Audio tracks or disabled audio clips will be ignored. On Windows all
audio will be exported regardless of track or clip status.)

Select File > Export, or right click the sequence in the project view and choose Export. This can
also be done by using the Ctrl + Shift + E hotkey combination.

This will open up the Export dialog.
In the Quick tab there will be a subset of options that are applicable to formats supported.

Choose a destination for your file path, and configure the codec and format options. You can then
select the Export button.

USER GUIDE
377



Exporting Sequences with Quick Export |

1.set file path and name 2.set codec and
format settings

Faster exports the Quick Export

Hie

Export

6. A progress popup will appear and update based on the percentage of the export process that is
complete.

7. When the export is complete, you can choose to either open the file folder location or to close the
window and return to the Studio Ul.

Note: During export, the studio interface will be locked to prevent any changes to the
sequence being outputted. It will be possible to cancel the export but a warning will appear
notifying that any partially exported files will be deleted if it is canceled.
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Limitations
* Currently only Whole Sequence in the Range options is available.

* Annotations are not available.

* Only on Windows; disabled audio tracks or audio clips are not ignored and will be exported.

« Currently there is no provision to save custom presets.

Behavior
* Currently only the {sequence} token is available in the file path name.

* The last used file path is persistent within the current session.
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Using Local and Project Presets

Presets are containers for export preferences, such as file structure and format, and filters for tracks,
tags, and frame range. Two types of Presets are available to construct commonly used export tasks:

* Local Presets - these presets are used to set up round-trips between artists on different platforms
and also to manage passing files between the Timeline and Nuke. Local Presets are saved in a Task
Presets folder using the XML file format.

* Project Presets - you can drag-and-drop Local Presets into this panel to save the preset within a
project .hrox file. This option is designed for collaborative work, allowing you to quickly share your
export presets.

You can edit these options in the Custom tab of the Export dialog. See Introduction to the Export
Dialog.

Using the Shot Template

The shot template sets up the folder hierarchy and naming conventions for export presets such as
Basic Nuke Shot with Annotations and Transcode Clip DPX, and how Create Comp Clips sends
clips back and forth between Hiero and Nuke. Any folders added to the template are created during
export unless they already exist, in which case the export writes to the existing structure.

Nuke Studio ships with default templates for your convenience, but you can quickly create custom
templates using folders and “tokens”, which are replaced with the relevant information during export.

Tip: Clicking an entry in the shot template displays a preview file path with the tokens
resolved under the Version token number field.

Exports can resolve the following tokens:

Token Resolves to

_nameindex The index of the shot name in the sequence, preceded by _
(underscore), to avoid clashes with shots of the same name.

{ampm} The local equivalent of either AM or PM.

{binpath} The bin structure to preserve. Including this token recreates your bin
structure up to the nearest parent bin.
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Token
{clip}
{day}
{DD}
{event}
{ext}

{filebase}

{fileext}

{filehead}

{filename}

{filepadding}

{filepath}

{fullbinpath}

{fullday}
{fullmonth}
{hierotemp}
{hour12}
{hour24}
{MM}
{minute}

{month}
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Using Local and Project Presets |

Resolves to

The name of the clip used in the shot processed.

The local weekday name, abbreviated to Mon, Tue, and so on.
The day of the month as a decimal, 01, 02, and so on.

The timeline event number associated with the shot to process.
The extension of the file to output, such as .dpx or .mov

The base of the clip name to process. For example, the filebase of
ShotO1_####.dpx is ShotO1_####.

The format of the clip to process, such as .dpx or .mov

The source clip filename not including frame padding or extension. For

example, the filehead of ShotO1_####.dpx is Shot01.
The source clip name of the media to process.

The source filename padding, which you might use for formatting
frame indices.

The full file path to the source media referenced in the export.

The full bin structure to preserve. Including this token recreates the bin

structure up to the project level.

The local full weekday name.

The local full month name.

The temp directory as specified in the Preferences.
The export start time hour component (12-hour clock).
The export start time hour component (24-hour clock).
The month of the year as a decimal, 01, 02, and so on.
The export start time minute component.

The local month name, abbreviated to Jan, Feb, and so on.
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Token
{project}
{projectroot}
{second}
{sequence}
{shot}
{timestamp}

{track}

{user}

{version}

{YY}

{YYYY}
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Resolves to

The name of the parent project of the export item.

The root export file path as specified in the Project Settings.
The export start time second component.

The sequence name to process.

The name of the shot to process.

The export start time in the 24-hour clock format (HHMM).

The name of the track to process. Exporting EDLs using this token
generates a separate EDL for each track.

The current username.

The string v#, defined by the number (#) set in the Version section of
the export dialog

The year of the century as a decimal, 01, 02, and so on.

The year, including century.

Tip: Double-click the path column, right-click, and then choose Select Keyword to display a
list of available export tokens, though only valid tokens for the current selection are listed.

Export Structure:

- [ nuke

- s
|

— r-r'u

Cut

i Copy

Delete

Version token number: 01 =

Token substrings are valid if you need to extract a certain part of an evaluated string. For example, if
{shot} resolves to JB100, then:

* {shot [0:2] } - resolves to |B
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s {shot [-3:] } - resolves to 100

Similarly, anything within the outer brackets is evaluated as a Python string. For example, if {shot}
resolves to JB_10_20, then:

* {shot.split(_") [0] } - resolves to JB
* {shot.split(_") [2] } - resolves to 20

Custom Shot Templates

The shot template enables you to create as many Nuke Read and Write nodes as required for a
project. A typical use case might be creating .jpg clips for review and .dpx resolution clips for finishing.

The following example describes how to build a shot template to export a sequence of .mov clips,
create .dpx and .jpg Write nodes in Nuke, and bring the .dpx clips back into the timeline.

1. Inthe Export dialog, in the Custom tab, select Basic Nuke Shot in the Local Presets panel to
auto-complete the shot template with the preset values.

Click Duplicate selected preset and give the new preset a name.
Rename the renders folder renders_dpx.

Select the nuke folder and click the folder icon to add a new folder. Name the new folder
renders_jpg.

Select the renders_jpg folder and click to add a new entry.

6. Replace the {filename} token with {shot}_comp{_nameindex} {version}.####.{ext}, the same as
the existing entry under renders_dpx.

Note: The #### marks represent frame numbers for image sequences. If you were creating
.mov clips, they'd be omitted.

The shot template should look something like this:
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Export Structure:

PATH

= [ {shot}
- [ nuke
[ script
[ ] {shot}_comp{_nameindex}_{version}.{ext}

[ renders_dpx

[ ] {shot}_comp{_nameindex}_{version}
@ renders_jpg

B {shot} comp{ nameindex}_ {version}

7. Click the Content column and select Nuke Write Node.

8.

Export Structure:

PATH
= [ {shot}
- [@ nuke
- [ script
N {shot}_comp{_nameindex}_{version}.{ext}
- [ renders_dpx

B {shot}_comp{ nameindex}_{version}.Z###.{ex
- [ renders_jpg
B {shot}_comp{_nameindex}_{version}

3

Version token number: 01 -

Preview: {projectroot}/{shot}/nuke/renders_jpg/{shot}_comp{_nameindex

t)

CONTENT

Nuke Project File

Nuke Write Node (dpx - 10 bit)

CONTENT

Nuke Project File

Nuke Write Node (dpx - 10 bit)

M

Transcode Images
Nuke Project File
@ Nuke Write Node

External Render

Note: When using a third party application to produce the VFX work, select ExternalRender

instead of Nuke Write Node.

In the Content settings tab, use the File Type dropdown to select jpeg.
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Content

Nuke Write Node

Channels: rgb

Write Node Name Write_{ext}
Colourspace: @ default
File Type: jpeg ~

jpeg Options

quality: 0.0

Notice that the settings available change depending on the File Type selected.
9. Click Nuke Project File in the shot template and check that both Write nodes are enabled.

Content

Nuke Project File
Write Nodes

10. Set up the rest of the export as described in Exporting Sequences and Shots and click Export.
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Adding Burn-in Text to Exports

Hiero can burn-in text during the export process using a simple Nuke gizmo. The gizmo is accessed
from the Export’s dialog's Custom tab. Here you can find the Write Node preset's Content panel and
edit the Burn-in section.

The gizmo contains controls for the font style and fields denoting the position of the text. You can also
add burn-in directly on timeline using the Burn-In soft effect. See Adding Effects on the Timeline for
more information.

Note: The Font field only accepts the full file path and name of the font file to use. For
example, on Mac ~/Library/Fonts/Verdana.ttf

Click Edit to display the available controls.

Text Size |43.5

Padding 40
Font C:\Windows\Fonts\times.tff
Top Left [metadata hiero/tags/Approved]
Top Middle
Top Right {shot}_comp
Bottomn Left

Bottom Middle

Bottom Right {timecode}

Restore Defaults Cancel

You can mix-and-match the following methods to create burn-in text:
* Enter text manually, what you see is what you get in the burn-in.

+ Use any of the tokens valid in the shot template as burn-in tokens. For example:

{shot} comp
Extracts the shot nam from the timeline and appends _comp.

See Using Local and Project Presets for more information.
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+ Use metadata from tags applied to clips and shots. For example:
[metadata hiero/shot/tags/Approved]

Extracts the Approved tag from the clip or shot. You can also append note to include any notes
associated with the tag:

[metadata hiero/shot/tags/Approved/note]

Note: You must precede spaces and slashes in the tag name with \\ (backslashes) to enable
Hiero to process the tag name correctly. For example: [metadata hiero/shot/tags/Blue\\

Screen/note]

Tip: If you're not sure what metadata keys and values are available on a shot, you can add a
Text soft effect containing the Tcl expression [metadata values] to display all metadata in
the Viewer. See Adding Effects on the Timeline for more information.
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Adding Additional Nodes During
Export

Hiero can include additional nodes, in any Nuke Project File or Transcode export in the Shot
Template, by simply copying and pasting scripts from the Node Graph.

You can add nodes to shots, tracks, or sequences, or include them as unconnected ad hoc nodes in
the script, filtered by tags if necessary.

1.

In the Export dialog's Custom tab, find the Content tab, scroll down to the Additional Nodes
control and click Edit.
The Additional Nodes Setup dialog displays.

Click to add an entry.

Click the Apply To field and select what the current entry applies to:

* Shot - the additional nodes are added to the script for each shot in the export.

* Track - the additional nodes are added to the script for each track in the export.

« Sequence - the additional nodes are added to the script for the entire sequence.

* Unconnected - the additional nodes are added to the script, but are not connected to the export
node tree.

* None - temporarily disables the current entry.

Select the Tags that you intend to use to filter which items receive the additional nodes.

If you want to affect only the Reference track, for example, select the Reference tag. All items

without that tag are ignored.

Copy and paste a node from the Node Graph into the Script panel.
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Note: If you need more than one node, you might consider creating a Group in the Node
Graph and pasting that into the Script panel.

6. Click OK to accept the additional nodes.

7. Select the Additional Nodes checkbox and complete the export process as described Exporting
Sequences and Shots.
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Using the Frame Server on
Render Machines

Although Hiero is capable of rendering frames internally, running the Frame Server on a render
machine can accelerate the process considerably by sharing work across a network of machines.

Note: The Frame Server requires a Hiero license (hiero_i) on the main workstation, but only
a Nuke render license (nuke_r) on the render machines. Local Frame Server processes use
ports 5558-5662.

If you want to use an interactive license (nuke_i) on the render machines, add the --
uselnteractiveLicense argument to the runframeserver.py command described below.

Configuring the Frame Server on Render Machines

Hiero's Frame Server can be set up on a render machine (or a number of machines) to render from
your Hiero session. To do this, you need to run the runframeserver.py script on the render
machines, found inside the Python site-packages, with specific command line arguments.

Warning: In order for everything to work smoothly, you need to ensure that both your
external render machines and main Hiero session can read and write files to a shared
location, such as an NFS share.

Depending on platform this can be done by manipulating your default umask setting, but be
aware that this alters the permissions of the created files.

Additionally, Mac and certain Linux distributions, such as RHEL, can not function as the main
workstation if the firewall is blocking the communication port 5560. You can configure the
firewall to allow certain ports through the firewall using the iptables command, but use
caution when doing so. For example:

sudo iptables -I INPUT -p tcp --dport 5560 --syn -j ACCEPT
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Please refer. to the documentation on firewalls for your particular platform for more
information.

The Frame Server uses a number of worker processes on the render machine, each of which requires
allocated resources, such as threads, memory, and so on. There are a number of arguments that you
must pass to runframeserver.py for the server to work correctly:

« --numworkers - this is the number of concurrent processes that are launched when you run this
server render node.

« --nukeworkerthreads - the number of threads that each worker is allocated. This is similar to
setting the -m argument when running Hiero from the command line.

* --nukeworkermemory - the amount of memory, in MB, allocated to each frame server worker.

+ --workerconnecturl - the TCP port address of the main workstation you want to serve. For example:

tcp://bob:5560

where bob is the resolved hostname of a machine you wish to serve. You can also use an IP address.

Tip: To ensure that you're entering a valid URL, try using the ping command to see if you get
a response.

* --nukepath - the path to the application on the render machine.

Tip: On Windows, if there are spaces in the file path, remember to place the path in quotes.
For example, --nukepath="C:\Program Files\Nuke16.0v5\Nuke16.0.exe"

On a Linux render machine, an example command prompt entry running from the application
directory might look like this:

./python ./pythonextensions/site-
packages/foundry/frameserver/nuke/runframeserver.py —--numworkers=2 -—-

nukeworkerthreads=4 --nukeworkermemory=8096 --workerconnecturl=tcp://bob:5560 -
-nukepath=./Nukel6.0

On a Windows render machine, an example command prompt entry running from the application
directory might look like this:

python.exe pythonextensions\site-
packages\foundry\frameserver\nuke\runframeserver.py --numworkers=2 --
nukeworkerthreads=4 --nukeworkermemory=8096 --workerconnecturl=tcp://bob:5560 -
-nukepath=Nukel6.0.exe
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On a macOS render machine, an example command prompt entry running from the application
directory might look like this:

./python ../Resources/pythonextensions/site-
packages/foundry/frameserver/nuke/runframeserver.py --numworkers=2 --
nukeworkerthreads=4 --nukeworkermemory=8096 --workerconnecturl=tcp://bob:5560 --

nukepath=/Applications/Nukel2.1v1l/Nukel2.1lvl.app/Contents/MacOS/Nukel2.1

In the examples, we specify that the render machine uses two workers, with four threads and 8 GB
RAM each, and are linked to the main Hiero workstation running on bob.

Tip: If your render machines run a different OS than your main Hiero machine, you can use
the --remap command line argument to convert file paths between them. The host file path
is read first followed by the render machine file path. Hiero expects all file paths to use /

(forward slash) between directories. For example:
--remap "P:/,/mnt/renders/"

converts host paths beginning with P:/ (Windows style) to render machine paths beginning
with /mnt/renders/ (Linux style).

You can check that the Frame Server and workers are connected by running the following lines in the
Script Editor on the main workstation:
from hiero.ui.nuke bridge.FnNsFrameServer import frameServer

print ([worker.address for worker in frameServer.getStatus(l) .workerStatus])

Successful connections should report something similar to the following in the output panel:

['Worker 0 - henry.local - 192.168.1.11', 'Worker 0 - bob.local -
192.168.1.111"', 'Worker 1 - henry.local - 192.168.1.11"]

Where henry.local is the name of the render machine, and bob.local is the name of the main Hiero
session.

Note: If the workers cannot contact the Frame Server, an exception is printed in the Script
Editor's output panel.

Frame Server Logs

Broker and Worker logging can to help diagnose Frame Server issues. The logs are written to NUKE_
TEMP_DIR/logs by default, and take the form:

broker.log

worker-0.log
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worker-1.1log

worker-2.log

Note: Running the Frame Server using Python, as described above, always writes log files to
the specific OS temporary directory. For example, on Windows C:\temp is used.

Tip: You can use the FRAMESERVER_LOG_DIR environment variable to force Frame Server
logs into a different location. See for more information.
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Exporting Sequences and Shots

1.

Select an entire sequence in the bin view, or shots in the timeline, and navigate to File > Export...
The Export dialog displays.

If you simply want to export your current sequence to a compressed video file, you can export

using the default settings on the Quick tab. If you wish to amend more settings, go to the Custom
tab.

Select Process as Shots from the Export dropdown.
Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

Select the Basic Nuke Shot preset under Local Presets to auto-complete the shot template or
build a custom shot template by copying an existing template and editing as required using Path
tokens, the Contents field, and the folder and +/- buttons.

Basic Nuke Shot creates a folder for each clip, or shot, containing nuke, script, and renders
folders.

PATH
- [ {shot}
- [ nuke
- [ script
B {shot} comp{ nameindex} {version}.
- [@ renders

B {shot} comp{ nameindex} {version}.

The tokens in the Basic Nuke Shot template break down as follows:
* {shot} simply extracts the shot names as they appear in the timeline.

* {shot}_comp{_nameindex}_{version}.nk extracts the shot name for each clip and the version
selected in the Tracks and Handles controls. For example, Shot01_comp_v03.nk

* {shot}_comp{_nameindex}_{version}.####.{ext} appends padding and the specified file
extension. For example, Shot01_comp_v03.0001.dpx

Note: The {_ nameindex} token is included to avoid conflicts with non-unique shot names.
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Tip: Select a file entry in the shot template to display a preview of the file path with all the
tokens resolved.

6. Proceed to Nuke Project File Settings to determine the Nuke script's behavior.
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Nuke Project File Settings

Note: Custom shot presets can only be selected from the Project Settings if they contain a
Nuke Project File and Nuke Write Node Content preset.

Open the Export Dialog’'s Custom tab. In the Export Structure section, click the Nuke Project
File Content preset to display the script settings.

In the Content pane, select Write Nodes from the dropdown and check which path from the shot
template should be used for the Nuke Write node. For example:

{shot}/nuke/renders/{shot} comp{_nameindex}_{version}.####.{ext} to resolve the render
path where Hiero expects to find the files when they're rendered.

Note: If you included a Nuke Annotations File Content preset, enable the Annotations
Precomp creator. See Annotations for more information.

If you're exporting retimed media, set how you want the Nuke script to handle the retime:
* None - no retime is applied.

* Motion - vector interpolation is used to calculate the in between frames. This is the most
accurate retime method, but takes longer to render.

* Frame - the nearest original frame is displayed.

* Blend - a mix between two frames is used for the in between frames. This is quick to render and
is useful when tweaking the timing in the Curve Editor before setting the method to Motion.

Soft Effects added to shots in your export are included in the resulting Hiero script by default. If

you don't need the soft effects, disable Include Effects to omit them from the script. See Adding

Effects on the Timeline for more information.

Select the required Reformatting options:

* Plate Resolution - exports at the clip's original resolution, regardless of what is set in the
timeline.

* To Sequence Resolution - exports at the resolution set in the timeline Sequence panel Output
Resolution dropdown.

+ Custom - activates the Reformat controls allowing you to customize the export resolution.

Enable Collate Shot Timings or Collate Shot Name to create additional Nuke Read nodes in the

same script for clips that would normally be hidden by clips higher up the track hierarchy or clips
on the same track with the same shot name.
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Note: If you have a Read node selected, you can't enable the Collate functions.

For example:

+ Collate Shot Timings - Items on track 1 that would otherwise be hidden by track 2.

Timeline environment Compositing environment

Note: Shots on different tracks are not connected by default. If you want all the exported
clips to be connected to the Nuke script Write node, enable Connect Tracks.

This applies to stereo and multi-view sequences as well when you use separate files for the
tracks per view. See Stereoscopic and Multi-View Projects for more information.

* Collate Shot Name - Two items on the same track with the same shot name.

Timeline environment Compositing environment

If you want to add additional nodes to the script on export, enable Additional Nodes and click
Edit. See Adding Additional Nodes During Export for more information.

Proceed to Nuke Write Node Settings to determine the Write node's behavior.
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Nuke Write Node Settings

Note: Custom shot presets can only be selected from the Project Settings if they contain a
Hiero Project File and Hiero Write Node Content preset.

1. Inthe Export dialog’'s Custom tab, find the Content presets. Click the Nuke Write Node Content
preset to display the write settings.

2. Set the following controls common to all file types:

* Channels - set the channels to export using the dropdown. If you want to export a non-standard
channel, type the name of the channel into the field manually.

* Write Node Name - if you intend to create more than one Hiero Write node, define the name
here. The default, Write_{ext}, appends the individual Write nodes with the file extension being
written. You can, however, use any of the tokens Hiero recognizes.

* Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.

3. Select the file type to render using the dropdown and complete the relevant fields, dependent on
the file type selected.

Note: Selecting mov from the dropdown provides additional controls, allowing you to
choose a Codec, Codec Profile or Pixel Format, and in some cases, YCbCrMatrix. The
matrix control enables you to use the Rec 601 and Rec 709 encoding methods.

Similarly, selecting exr provides an additional metadata dropdown allowing you to export or
round-trip selected metadata along with your .exr output.

4. Create Directories is enabled by default, which enables the corresponding control in the .nk
script's Write node. This control allows Hiero to create the required directories when you render
out a new version from the Write node.

Disabling this control causes versioned renders to fail because the target directories don't exist.
You can manually create the correct directories or enable Create Directories in the script's Write
node if this happens.

Use the Reformat controls to determine how the Write node is set up in the Hiero script:
* None - the clip or sequence resolution is used, no additional formatting is applied during export.

* To Sequence Resolution - exports at the resolution set in the timeline Sequence panel Output
Resolution dropdown. This option also allows you to set the Filter used to resize the output.
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Note: The filters available are generally listed in order of quality and processing time. Cubic
can be faster to render, but Lanczos4 may be produce better results. See the Nuke Online

Help for more information.

* To Scale - activates all the Reformat controls, except Format, allowing you to customize the

export resolution.

+ Custom - activates all the Reformat controls, except Scale, allowing you to customize the export

resolution.

Reformat Control

Format - sets the format to render out in Hiero, such as
1920x1080 HD 1080.

Scale - sets the proportion by which to scale the output format.

Resize - sets the method by which you want to preserve or
override the original aspect ratio:

* width - scales the original until its width matches the format's
width. Height is then scaled in such a manner as to preserve
the original aspect ratio.

* height - scales the original until its height matches the
format's height. Width is then scaled in such a manner as to
preserve the original aspect ratio.

« fit - scales the original until its smallest side matches the
format’s smallest side. The original’'s longer side is then scaled
in such a manner as to preserve original aspect ratio.

« fill - scales the original until its longest side matches the
format’s longest side. The input’s shorter side is then scaled in
such a manner as to preserve original aspect ratio.

+ distort - scales the original until all its sides match the lengths
specified by the format. This option does not preserve the
original aspect ratio, so distortion may occur.

Center - when enabled, transform image to the center of the
output. When disabled, the image is aligned with the bottom-
left corner of the output.
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Reformat Control To To Custom
Sequence Scale
Resolution

Filter - sets the filtering algorithm used to transform pixels. See o ] o

the Nuke Online Help for more information.

6. You can apply text burn-in to the media using a Hiero gizmo. Enable Burn-in Gizmo and click Edit
to define the information applied. See Adding Burn-in Text to Exports for more information.

7. Proceed to Tracks, Range, and Handles Settings to select which items are processed during export.
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Tracks, Range, and Handles
Settings

The tracks, tags, and handles controls in the Export dialog’'s Custom panel allow you to select the
frame range or shots to export.

1. Setthe Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

2. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.

3. Enable or disable tags using the Filter by tag panel. Click the checkbox to cycle through the
available tag states.

4. If you're exporting a sequence, set the Range controls as required:
* Select Whole Sequence or In/Out Points to export only the selected frames.
* Set how clip Start Frames are derived using the dropdown menu:
* Sequence - use the sequence’s start frame.
* Custom - specify a start frame for all clips using the field to the right.
5. Ifyou're exporting shots, set the Handles controls as required:
* Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.
* Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.

* Check Apply Retimes to export any retimes present on the timeline.

Note: When Apply Retimes is disabled, which is the default state for Create Comp Clips,
any TimeWarp soft effects are not included in the resulting Nuke script. When the new shot is
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created through Build Track from Export Tag, TimeWarp soft effects are copied from the
original shot to the new one.

* Set how clip Start Frames are derived using the dropdown menu:
* Source - use the source clip’s start frame.
* Custom - specify a start frame for all clips using the field to the right.
6. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource

management.
See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

« Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

7. Click Export.

The Export Queue window displays an estimate of how long each component of the export is

expected to take.

Once the export is complete, the file structure specified in the shot template is created. You can

then import the Nuke clips on a separate track when they're ready.

Tip: Click the magnifying glass icon to reveal the file structure in a browser window.

When clips are exported from Hiero, they are marked with a Nuke tag flagging which clips have an
export history. Clips tagged in this way can be used to build VFX tracks quickly as described in
Building VFX Tracks and Comp Clips.
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Building VFX Tracks and Comp
Clips

When the compositing work is complete, the clips are ready to re-ingest. The shot template defines
where the Nuke files reside, so all you need to do is instruct Hiero to build tracks from previous
exports. See Building Tracks From Export Structure for more information.

Alternatively, if you have a history of rendered VFX clips, different versions and so on, you can also
build tracks from export tags to select from a list of available clips. This method allows you to add
Comp Clips to the timeline, which act as containers for Hiero .nk scripts, or placeholders for Hiero

renders. See Building Comp Clips From Export Tags or Building Render Placeholders From Export Tags
for more information.

Building Tracks From Export Structure

1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.

2. Click Build Track > From Export Structure.
The Build Track From Export Structure dialog displays.

3. Enter a Track Name or use the default VFX.
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Select an Export Preset using the dropdown menu. In this case, select the same preset used
during the export.

Enter the file path of the Export Root directory or click Choose and browse to the location.

Note: The root directory is the location entered in Export To when exporting the project.

Select the Content preset you intend to ingest from the shot template. In this case, the Nuke
Write Node.

Click Build to create the VFX track.

Note: Hiero warns you if no selection is made in the Content column.

Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place
holders if the clips are a work in progress.

If a shot already exists in any of the target tracks, a new track is created to hold the new shots.

oo EI_I:I n} E_EI o1 I:I_I:I-'-‘I- co I:I-'-‘I-_I:I 0 ]__EI o1 I:I_I:I-'-‘I- AQOFCO00 5_ 10102 EI_L 10

C003 006 3010 04 Y Coo4 001 32010 04

Audio 1

Audio 2

The clips are automatically updated when work is complete as long as they are saved with the
expected name and location, as specified in the shot template.
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Building Comp Clips From Export Tags

When you build a track from an export tag, Hiero imports Comp Clips containing the Hiero script, by
default. Comp Clips are shots that reference Hiero scripts, rather than being placeholders for offline
clips as in the Building Render Placeholders From Export Tags workflow.

1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.

2. Click Build Track > From Export Tag.
The Build Track From Export Tag dialog displays.
3. Enter a Track Name or use the default VFX.

Select the required export tag in the left-hand panel to display tag information in the right-hand
panel.

Hiero imports the .nk Comp Clip by default.

Track Name:

=

xport Tag:
MNuke Project File 2015/07/23 12:05:39

Yinuke/script/{shot}_

th this Tag:

® Create Comp Clips

Ewuild

If you just want to import the offline renders when they're finished, disable the Create Comp
Clips checkbox. See Building Render Placeholders From Export Tags for more information.
5. Click Build to create the VFX track.

Hiero automatically creates a new track containing the Comp Clips. If a shot already exists in any
of the target tracks, a new track is created to hold the new shots.
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6. You can Ctrl/Cmd+double-click Comp Clips to open them an external Hiero to make edits as
required.

Building Render Placeholders From Export Tags

When you build a track from an export tag, you can choose to import the renders from the .nk script,
rather than Comp Clips which contain the Hiero script.

1. Select the required clips on the timeline and right-click to display the context sensitive menu.

Tip: You may find it easier to select clips in the spreadsheet and then right-click on the
timeline.

2. Click Build Track > From Export Tag.
The Build Track From Export Tag dialog displays.
3. Enter a Track Name or use the default VFX.

Select the required export tag in the left-hand panel to display tag information in the right-hand
panel.

5. Disable the Create Comp Clips checkbox to import the offline renders when they're finished.
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Select Export Tag:

" Nuke Project File 2015/07/23 12:05:39

Yinuke/script/{shot}_

ith this Tag:

eate Comp Clips

Ewuild

If you want to import the .nk Comp Clips, enable the Create Comp Clips checkbox. See Building
Comp Clips From Export Tags for more information.

Click Build to create the VFX track.

Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place
holders if the clips are a work in progress.

If a shot already exists in any of the target tracks, a new track is created to hold the new shots.
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Exporting Multi-View Source Clips

Multi-view exports are similar to regular exports, but the DPX Multi-View or Multi-View Nuke Shot
templates are used to created the required export tree using %v functionality, just like Nuke's Node
Graph. The DPX Multi-View example preset is designed for exporting sequences and the Multi-View
Nuke Shot preset is designed for shots.

See Stereoscopic and Multi-View Projects for more information on working with multi-view footage.
1. Right-click on the sequence or shot that you want to export.

Sequences are exported from the bin view.

[ - [®] untitled 1 (2)

=1

Shots can be a multi-view or single views split into separate tracks. See Displaying Views in the
Timeline for more information.

Video 1_cam3
pubstitch {pubstitch)
r -

Video 1 =53
Video 1_right

pubstitch {pubstitch)
. _ - -
Video 1_left |F5.3-

Audio 1

For separate tracks, you can right-click a single track to export all views or select all the per-track
views and right-click.

2. Select Export.
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The Export dialog is displayed. Go to the Custom tab.
Select Process as Sequence or Process as Shots from the Export dropdown.

If you're exporting a sequence, select the Log10 Cineon DPX Multi-View example preset. If you're
exporting shots, select the Multi-View Nuke Shot (%v) example preset.

Set the Nuke Project File and Nuke Write Node presets as described in Nuke Project File
Settings and Nuke Write Node Settings.

If you're using independent files per track, that is without importing multi-view files or using %V
functionality, the separate tracks in the export script are not connected by default. If you want the
tracks to be connected in the script, enable Connect Tracks in the Nuke Project File preset.
Effects
Include Effects:
Reformat

Reformat: Plate Resolution

Caollate & Connect

ot Timings:

Caollate Shot Name:
Connect Tracks:

AdditionalNodes

Additional Nodes:

Set the track and handle preferences as described in Tracks, Range, and Handles Settings and then
click Export.

Once the export is complete, the file structure specified in the shot template is created. You can
then import the Nuke clips on a separate track when they're ready.

Tip: Click the magnifying glass icon in the Export Queue to reveal the file structure in a
browser window.

When clips are exported from Hiero, they are marked with a Nuke tag flagging which clips have an
export history. Clips tagged in this way can be used to build VFX tracks quickly as described in
Building VFX Tracks and Comp Clips.
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Transcoding

Transcoding in Hiero uses a background render process to convert one file format to another. You can
transcode sequences, timeline selections, and clips from the bin view.

Transcoding a Sequence

1.

vk N

Select a sequence in the bin view and navigate to File > Export...

The Export dialog displays. Open the Custom tab.

Select Process as Sequence and the preset you intend to use, or use the default dpx preset.
Enter the Export To directory or click Choose... and browse to the location.

Click the Content column in the shot template to display the transcode options.

Set the following controls common to all file types:

* Channels - set the channels to export using the dropdown. If you want to export a non-standard
channel, type the name of the channel into the field manually.

* Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.

Select the File Type to render using the dropdown and complete the relevant fields, dependent on
the File Type selected.

For a full description of the file type options available, see the Write node topic in the Nuke
Reference Guide.

Note: Selecting mov from the dropdown provides additional controls, allowing you to
choose a Codec, Codec Profile or Pixel Format, and in some cases, YCbCrMatrix. The
matrix control enables you to use the Rec 601 and Rec 709 encoding methods.

Similarly, selecting exr provides an additional metadata dropdown allowing you to export or
round-trip selected metadata along with your .exr output.

Use the Reformat controls to determine how the Write node is set up in the Hiero script:
* None - the clip or sequence resolution is used, no additional formatting is applied during export.

* To Scale - activates all the Reformat controls, except Format, allowing you to customize the
export resolution.

« Custom - activates all the Reformat controls, except Scale, allowing you to customize the export
resolution.
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Reformat Control To Custom
Scale

Format - sets the format to render out in Hiero, such as 1920x1080 HD 1080.
Scale - sets the proportion by which to scale the output format.

Resize - sets the method by which you want to preserve or override the

original aspect ratio:

» width - scales the original until its width matches the format’s width. Height is
then scaled in such a manner as to preserve the original aspect ratio.

* height - scales the original until its height matches the format's height. Width
is then scaled in such a manner as to preserve the original aspect ratio.

« fit - scales the original until its smallest side matches the format’s smallest
side. The original’s longer side is then scaled in such a manner as to preserve
original aspect ratio.

« fill - scales the original until its longest side matches the format's longest
side. The input's shorter side is then scaled in such a manner as to preserve
original aspect ratio.

« distort - scales the original until all its sides match the lengths specified by
the format. This option does not preserve the original aspect ratio, so
distortion may occur.

Center - when enabled, transform image to the center of the output. When
disabled, the image is aligned with the bottom-left corner of the output.

Filter - sets the filtering algorithm used to transform pixels. See the Nuke
Online Help for more information on filters.

8. Complete the general controls common to all file types:
* Select the Retime Method to apply, if applicable.

« Soft Effects added to shots in your export are included in the resulting Hiero script by default. If
you don't need the soft effects, disable Include Effects to omit them from the script. See Adding
Effects on the Timeline for more information.

* Include Audio - when enabled, any audio tracks are exported alongside the video.
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Audio
Include Audio: =
linear PCM (waw]
Sample Rate: 44100 Hz

Bit Depth: 24 bit

Output Channels: 7.1 (L R C LFE Ls R= Bzl Bsr)

* Delete Audio File - when disabled, delete the .wav file used to create the export. This control
only applies to formats that support audio, such as .mov files.

9. Enable the Burn-in Gizmo to burn-in text using a Nuke gizmo. Click Edit to define the information
applied during burn-in. See Adding Burn-in Text to Exports for more information.

10. Specify any Additional Nodes required during export by clicking Edit. See Adding Additional
Nodes During Export for more information.

11. Check Keep Nuke Script if you require the .nk files after the transcode operation.

Note: The following controls may improve render times for certain exports:

For .dpx exports, you can enable Read All Lines, which can speed up transcode times for I/0
heavy scripts.

For machines with multiple CPU sockets using a Single Render Process, you may find that
limiting the render with Use Single Socket may improve render times.

Tracks and Range Settings

1. Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

2. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.

3. Ifyou setin and out point on the sequence, enable In/Out Points to export only the selected
frames.

4. Set how clip Start Frames are derived using the dropdown menu:

* Sequence - use the sequence’s start frame.

USER GUIDE
412



Transcoding |

* Custom - specify a start frame for all clips using the field to the right.

Set how Hiero renders your export using the Render with dropdown. The following options are

available:

* Frame Server - uses multiple Hiero processes to speed up render times, improving resource
management.

* Single Render Process - uses a single Hiero process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

« Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

Click Export.

The Export Queue window displays an estimate of how long each component of the export is

expected to take.

Once the export is complete, the file structure specified in the shot template is created containing

the transcoded files.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Transcoding a Sequence as Shots

1.

Select the required sequence in the bin view and navigate to File > Export...
The Export dialog displays. Open the Custom tab.

Select Process as Shots and use the default, Transcode Shots DPX, or build a shot template
using the Path and Contents fields and the folder and +/- buttons.

The default:
Export Structure:

PATH CONTENT

- [ {shot}

Creates a folder for each shot, containing a clip with the {shot} name and the required file padding
(##4#4#) and extension {ext}.

Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

In the Content tab, complete the File Type specific and general controls common to all file types
as described in Transcoding a Sequence.

Click the Tracks and Handles tab, select the Tracks For This Export by enabling or disabling the
tracks in the list. Nuke Studio exports all tracks by default.

Enable or disable tags using the Filter by Tag panel. Click the checkbox to cycle through the
available tag states.

Set the Range and Handles, as required:
* Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.

* Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.

Check Apply Retimes to export any retimes present on the timeline.

Note: When Apply Retimes is disabled, which is the default state for Create Comp, any
TimeWarp soft effects are not included in the resulting Nuke script. When the new shot is
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created through Create Comp or Build Track from Export Tag, TimeWarp soft effects are
copied from the original shot to the new one.

10.

11.

12.

Set how clip Start Frames are derived using the dropdown menu:
* Source - use the source clip’s start frame.
* Custom - specify a start frame for all clips using the field to the right.

Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: SeeUsing Versions for more information on how versioning works in Hiero.

Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering

QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

+ Custom Render Process - uses a custom render process. Hiero requires a Python script to pass

exports to your render farm of choice. Scripts must be located in specific directories, depende

nt

on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the

default render processes.
Click Export.

The Export Queue window displays an estimate of how long each component of the export is
expected to take.

Once the export is complete, the file structure specified in the shot template is created. You can
then import the Nuke clips on a separate track when they're ready.

Tip: Click the magnifying glass icon to reveal the file structure in a browser window.
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Transcoding from the Bin View

To transcode directly from the bin view:
1. Select the bin(s) to export from the bin view.
2. Right-click a highlighted bin and select Export...

baseproject_11.1 (

-y
Import
Edit

Open In

Clip

Set Media Color Transform

Version

Tags

The Export dialog displays. Open the Custom tab.
3. Select Process as Clips and modify the shot template, if required.

4. Follow the steps under Transcoding a Sequence to complete the export.
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Transcoding Timeline Selections

Transcoding an entire timeline can be time consuming, or even unnecessary, if all you're looking for is
a new version of a selection of shots.

To transcode a selection of clips from a timeline:
1. Select the required shots on the timeline.
2. Right-click a highlighted item and select Export...
0 Editorial

Loy

 Erer. . raChiELE

Build Track k 3
Effects ¥

Audio 1

Audio 2

The Export dialog displays.

3. Referto Transcoding a Sequence to complete the export.
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Ad Hoc Exports

This section covers exports that you might not perform on a per project basis, such the EDL, OTIO, or
XML Exporters and Copy Exporter. Exporters are available for sequences, shots, and clips as described
in the following table.

Exporter Source
Sequences Shots Source Clips

EDL Exporter
OTIO Exporter
XML Exporter
Audio Exporter
Copy Exporter

SymLink Exporter
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Exporting Sequences as EDL,
OTIO, and XML

Hiero supports export to EDL, OTIO, and XML using very similar methods, the main difference being
that EDL doesn’'t support multiple video tracks in a single file whereas OTIO and XML does.

Note: Hiero can read AAF files, but not write them out.

To export to EDL, OTIO, or XML:

1.

Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays. Open the Custom tab.
Select Process as Sequence from the Export dropdown.

Select the CMX 3600 EDL, OTIO, or Final Cut Pro XML preset, or duplicate one and create your own
preset.

Note: EDLs only support one video track per file. If you have more than one track, include
the {track} token in the shot template to write out an EDL for each track preset.

For example, {filename}_{track}.{ext} might produce a separate EDL for each track on your
timeline called myTimeline_Video1.edl, myTimeline_Video2.edl, and so on.

Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

If you're exporting to EDL, set the additional EDL Exporter controls in the Content tab, if required:
* Reel Name - define the reel name written into the EDL, independent of the clip's reel name.

Enter text or standard shot-level tokens in this field. See Using the Shot Template for more
information.

If the field is left blank, the reel name from the clip is used or the name of the shot, if no reel
name exists.

* Truncate Reel Name - restricts the Reel name to eight characters.
+ Use Absolute Path - adds the full file path for each clip to the EDL comments field.



10.

11.
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* From Clip Name - define the text appended to “from” comment fields in EDLs, such as *FROM
CLIP NAME. Text and/or standard shot-level tokens are valid in this field: {shot}, {clip}, {track},
{sequence}, {event}, {fps}, and the default {filename}.

OR

If you're exporting to XML, you can enable Include Markers to convert any frame tags present in
the sequence to markers in Final Cut Pro or Premiere. See Tagging Using the Viewer for more
information on adding tags to frames.

Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

Click the Tracks and Range tab and select the Tracks For This Export by enabling or disabling
the tracks in the list. Hiero exports all tracks by default.

If you set in and out point on the sequence, enable In/Out Points to export only the selected
frames.

Set how clip Start Frames are derived using the dropdown menu:
* Sequence - use the sequence’s start frame.
* Custom - specify a start frame for all clips using the field to the right.

Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

+ Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke User Guide, Loading Gizmos, NDK Plug-ins, and Python and Tcl
Scripts section. If no scripts exist, the dropdown only contains the default render processes.

Click Export.

The Export Queue window displays an estimate of how long each component of the export is
expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Use the following custom options when you export an OTIO file from Nuke Studio.

Replace comp with rendered media

e On by default. This option is for sending the OTIO file to a generic OTIO reader/editor. The
setting replaces the .nk path with a literal path to the file location of the rendered media.

e Turn this option off when sending an OTIO to another Nuke Studio. This setting keeps the
Create Comp workflows .nk path to automatically pick up comps and versions of renders.

Include Effects

« On by default. Includes all Nuke Studio effects - soft effects, track blend, tags, locked/disabled
clip states - in custom OTIO metadata. Another Nuke Studio/Hiero reads and makes the effects
editable, whereas a 3rd party OTIO reader/editor ignore s Nuke Studio custom effects.
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« Turn off this option to make a simplified standard OTIO without any custom metadata. It won't
include any soft effects, tags etc. This option allows for compatibility in cases where your
exported OTIO with effects won't open in a 3rd party app.
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Using the Audio Exporter

The Audio Exporter allows you write audio to separate .wav files. You can extract audio from whole
sequences, shots, and source clips.

Exporting Audio from Sequences

1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays. Open the Custom tab.

2. Select Process as Sequence from the Export dropdown and select a preset, duplicate it, and give
ita name.

3. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

4. Build a custom shot template using Path tokens and the folder and +/- buttons and then click the
Content field and select Audio Export from the list.

An example shot template is shown below:

Export To: {projectroot}

Export Structure:

PATH CONTENT
- [ {sequence}
B {sequence}_{version} Audio Export

5. Click the Audio Export field and select the required export options, including the Output
Channels for multi-channel audio.

Audio Export
Codec: linear PCM (wawv)
Sample Rate: 44100 Hz

Bit Depth: -
mono

Output Channels: % stereo

5.1 (L R C LFE Is Rs)

7.1 (L R C LFE Ls Rs Bsl Bsr h
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6. Setthe Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

7. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.

8. Setthe Range controls as required:
* Select Whole Sequence or In/Out Points to export only the selected frames.
* Set how clip Start Frames are derived using the dropdown menu:
* Sequence - use the sequence’s start frame.
* Custom - specify a start frame for all clips using the field to the right.

9. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.

See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

* Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

10. Click Export.

The Export Queue window displays an estimate of how long each component of the export is
expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.

Exporting Audio from Shots

1. Select the required shots in the timeline and navigate to File > Export...

The Export dialog displays.
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2. Select Process as Shots from the Export dropdown and select a preset, duplicate it, and give it a
name.

3. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

4. Build a custom shot template using Path tokens, the Contents field, and the folder and +/-
buttons.

An example shot template is shown below:

Export To: {projectroot}

Export Structure:

PATH CONTENT
- [ {shot}
) {shot} Audio Export

5. Click the Audio Export field and select the required export options, including the Output
Channels for multi-channel audio.
Audio Export
Codec: linear PCM (wav)
Sample Rate: 44100 Hz
Bit Depth: mano

Output Channels: % stereo

5.1 (L R C LFE Is Rs)

7.1 (L R C LFE Ls Rs Bsl Bsr h

6. Setthe Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: SeeUsing Versions for more information on how versioning works in Hiero.

7. Select Tracks for this export by enabling or disabling the tracks in the list. Hiero exports all
tracks by default.

8. Enable or disable tags using the Filter by tag panel. Click the checkbox to cycle through the
available tag states.

9. Ifyou're exporting a sequence, set the Range controls as required:
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* Select Whole Sequence or In/Out Points to export only the selected frames.
* Set how clip Start Frames are derived using the dropdown menu:
* Sequence - use the sequence’s start frame.
* Custom - specify a start frame for all clips using the field to the right.
If you're exporting shots, set the Handles controls as required:
* Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.
* Cut Length - exports only the cuts included on the timeline.

Note: Selecting Cut Length allows you to add handles to each clip, up to the maximum
available source clip length.

Set how clip Start Frames are derived using the dropdown menu:

* Source - use the source clip’s start frame.

* Custom - specify a start frame for all clips using the field to the right.

Set how Hiero should render your export using the Render with dropdown. Hiero provides the

following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

« Custom Render Process - uses a custom render process. Hiero requires a Python script to pass

exports to your render farm of choice. Scripts must be located in specific directories, depende

nt

on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the

default render processes.
Click Export.

The Export Queue window displays an estimate of how long each component of the export is
expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Exporting Audio from Source Clips

1.

Select the required source clips and navigate to File > Export...
The Export dialog displays.

Process as Clips is selected automatically from the Export list, so select a preset, duplicate it, and

give it a name.
Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

Build a custom shot template using Path tokens, the Contents field, and the folder and +/-
buttons.

An example shot template is shown below:

Export To: {projectroot}

Export Structure:

PATH CONTENT
- [ {binpath}
B {clip} Audio Export

5. Click the Audio Export field and select the required export options, including the Output

Channels for multi-channel audio.
Audio Export
Codec: linear PCM (waw)
Sample Rate: 44100 Hz

Bit Depth: D
mono

Output Channels: % stereo

5.1 (L R C LFE Is Rs)

7.1 (L R C LFE Ls Rs Bsl Bsr, h

Set the Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

Set how clip Start Frames are derived using the dropdown menu:
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* Source - use the source clip’s start frame.

« Custom - specify a start frame for all clips using the field to the right.

Set how Hiero should render your export using the Render with dropdown. Hiero provides the

following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.

See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

+ Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

Click Export.

The Export Queue window displays an estimate of how long each component of the export is

expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the Copy Exporter

Copying media from various locations is very time consuming and can waste disk space. The Copy
Exporter allows you to consolidate sequences containing only your project media in a named file
structure using the shot template.

To copy media to a named location:
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays. Open the Custom tab.
Select Process as Shots from the Export dropdown.
Select the Transcode Shots DPX preset, duplicate it, and give it a name.
Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/-
buttons.

An example shot template is shown below:

Export To: {projectroot}

Export Structure:

PATH CONTENT
- [@® Copy Export
{shot}.z##Z.{fileext} Copy Exporter

6. Setthe Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

7. Set how clip Start Frames are derived using the dropdown menu:
* Source - use the source start frame.
* Custom - specify a start frame for all clips using the field to the right.

8. Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:
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* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.
See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

+ Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

Click Export.

The Export Queue window displays an estimate of how long each component of the export is

expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the SymLink Generator

The SymLink Generator allows you to create symbolic links to your project media in a named file
structure using the shot template.

Note: Windows - you may also need administrator privileges to create symbolic links on
Windows.

To create symbolic links to a named location:
1. Select a sequence in the bin view and navigate to File > Export...
The Export dialog displays. Open the Custom tab.
Select Process as Shots from the Export dropdown.
Select the Transcode Shots DPX preset, duplicate it, and give it a name.
Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot
hierarchy.

5. Build a custom shot template using Path tokens, the Contents field, and the folder and +/-
buttons.

An example shot template is shown below:

: 1projectroot}

rt Structure:

CONTENT

SymLink Generator

6. Setthe Version number for the export, if applicable. Use the arrows to increment the version
number and the +/- buttons to increase or decrease the padding. You can also type directly into
the numeric field.

Note: See Using Versions for more information on how versioning works in Hiero.

7. Set how clip Start Frames are derived using the dropdown menu:
* Source - use the source start frame.

* Custom - specify a start frame for all clips using the field to the right.
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Set how Hiero should render your export using the Render with dropdown. Hiero provides the
following options:

* Frame Server - uses multiple Nuke processes to speed up render times, improving resource
management.

See Using the Frame Server on Render Machines for more information.

* Single Render Process - uses a single Nuke process to render your export. Rendering
QuickTimes falls back to this setting, but it's also used when a problem is detected with the
Frame Server.

* Custom Render Process - uses a custom render process. Hiero requires a Python script to pass
exports to your render farm of choice. Scripts must be located in specific directories, dependent
on platform, as listed in the Nuke Online Help. If no scripts exist, the dropdown only contains the
default render processes.

Click Export.

The Export Queue window displays an estimate of how long each component of the export is
expected to take.

Once the export is complete, the file structure specified in the shot template is created.

Tip: Click the magnifying glass icon to reveal the exported file in a browser window.
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Contact Sheet in Hiero

This section covers how Contact Sheet works in Nuke Studio, Hiero, and HieroPlayer.

Contact Sheet enables you to quickly load multiple shots from a sequence, for artistic, comparison,
and review purposes.

Contact Sheet is designed to offer a fluid and dynamic user experience, with the ability to add and
filter shots to the Contact Sheet Viewer.

Contact Sheet Overview

In the example below we have a sequence open and some shots have been selected to be displayed

in the Contact Sheet. The Timeline viewer and the Contact Sheet Viewer can be seen side by side.

The Contact Sheet buttons and menu items are shown below:

> 1

Tag Filter Drop Down ‘ ; Soft FX Bypass =20 | | _
i || A
? Lty i
Tag Filter / Pick
Selection Toggle

# Contact Sheet Viewer

Send To Contact Sheet jl Pick Mode

* Send To Contact Sheet - The Send To Contact Sheet button is used to make the current
sequence eligible to populate the Contact Sheet.

The button has two states:

* Inactive (gray) - The sequence is not populating the Contact Sheet
* Active (highlighted) - The sequence is being used by the Contact Sheet
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Note: Once the button is active, you cannot disable it unless another sequence is loaded
and sent to the Contact Sheet or the Contact Sheet Viewer is closed. More on this in the
Using Contact Sheet section.

* Pick Mode I8 - The Pick Mode button lets you manually choose shots in the sequence to be
displayed in the Contact Sheer Viewer. The Pick Mode button will only be available once the Send To
Contact Sheet button is active for the sequence.

The button has two states:

* Inactive (gray) - Normal hard selection and editorial tools are active in the Edit Tool bar.
Any shots selected will obey the usual hard selection methodology and will not be
displayed in the Contact Sheet Viewer

* Active (highlighted) - This state is used to explicitly select shots in the sequence that
you want displayed in the Contact Sheet viewer. Any selections made in Pick Mode are
only for Contact Sheet use and will not interfere or affect any current hard selections
made in the sequence before entering Pick Mode

* Tag Filter/Pick Toggle & Tag Filter Drop Down m - This button enables you to switch between
displaying either manually selected shots from the sequence in the Contact Sheet Viewer, or toggling
to display shots that are using tag filtering. This functionality is provided by the left hand Tag icon.
The right hand side drop down icon, when pressed, will show a list of all tags currently being used in
the sequence and check boxes to allow for boolean operations.

The left hand Tag button has two states:

* Inactive (gray) - This state will display any shots that have been selected via the Pick
Mode button

* Active (highlighted) - This state will toggle the Contact Sheet Viewer to display shots
that match the criteria set in the Tag Filter Drop Down menu

Note: Tag Filtering is available in Nuke Studio and Hiero, but not in HieroPlayer.

* Pages - This button works in conjunction with the Max Row Count and Max Column
Count options found in the Contact Sheet Settings. This is set by default to a 5x5 grid able to
accommodate 25 shots per page. If a selection of more than 25 shots are selected to be displayed in
the Contact Sheet in this particular example, then any shot count above 25 will be automatically
added to a second page until this is populated. The page count will then increment to display how
many pages the selected are contained in and up and down arrows to be able to navigate between
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the pages. You can also use the scroll functionality found in other number fields in Nuke, to also
navigate the additional pages.

* Soft FX Bypass! - The Soft FX Bypass button will bypass only any track based Soft effects to
enable the user to quickly disable these effects without having to modify the sequence. This will only

affect the Contact Sheet Viewer. Viewing the sequence in the Timeline Viewer will still show any track
based Soft effects.

The button has two states:

* Inactive (gray) - This state will display any track based Soft effects in the sequence being
used to populate the Contact Sheet

* Active (highlighted) - This state will bypass any track based Soft effects in the sequence
being used to populate the Contact Sheet

Note: Soft Effects are available in Nuke Studio and Hiero, but not in HieroPlayer.

. Reset - The Reset button will quickly clear the Contact Sheet of all clips and reset to its initial

state. Pushing this button will clear all active clips in the Pick Mode and as well as all tag filter states.
The function is not undoable.

* Contact Sheet SettingsE - The Contact Sheet Settings drop down displays options that affect the
way the Contact Sheet functions.

Currently this includes:

+ Contact Sheet Output Resolution - This gives the user the ability to customize the
Contact Sheet resolution. Modifying this can affect the quality of the images currently
being displayed. You can also set custom resolutions that can be useful when used in
conjunction with the Max Row and Column count options.

* Max Row & Column Count - These two values allow you to customize the layout of the
Contact Sheet. Together the two values will effectively set a maximum amount of shots
that can be displayed per page, i.e the default of 5 rows and 5 columns allows for a
Contact Sheet of 25 shots per page.

Tip: By adjusting the Max Row & Columns Count in combination with Contact Sheet Output
Resolution, you can optimize the amount of shots and their scale displayed and create
bespoke layouts for review.
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Using Contact Sheet

To learn how to use the Contact Sheet, see the following pages:
*» Using Contact Sheet: Manual Pick Mode

+ Using Contact Sheet: Playback

* Using Contact Sheet: Tag Filtering

* Using Contact Sheet: Workflows & Soft Effects

* Using Contact Sheet: Preferences

Additional Considerations

Performance

The performance of the Contact Sheet feature in Hiero 16.0v5 will depend on the specification of the
host computer that Hiero is being run on, storage and network performance as well as the format of
media sources being used.

Currently, there is no specific Contact Sheet Disk Caching so real time playback will depend on the
amount of shots being displayed in conjunction with the available RAM cache allocated in preferences.

Integration with Existing Features

Contact Sheet is compatible with existing timeline Soft Effects, although multiple stacked Soft Effects
and BlinkScript effects may impact responsiveness.

Annotations are not currently displayed and it is not possible to annotate directly onto a Contact
Sheet view.

A/B compare modes are not supported in the Contact Sheet Viewer.
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Using Contact Sheet: Manual Pick
Mode

To get started with Contact Sheet, you first have to open a sequence in the Timeline View. Only shots
that are residing in a sequence can be used to populate the Contact Sheet view.

Here is an example of a project to use with Contact Sheet.
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The first step is to create a new Contact Sheet Viewer which can be populated with the shots you'd
like to review.

To do this, click the Send To Contact Sheet button in the Timeline View. Doing this will create a
new Contact Sheet Viewer named after the sequence.
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Contact Sheet Viewer
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You can also use the Window drop down menu to create a new Contact Sheet Viewer as well.
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Tile Window to Right of Screen
Replace Tiled Window

Remove Window from Set

Move to Built-in Retina Display
+ Properties
+' Curve Editor
~ Dope Sheet

Progress

Toolbar

Error Console

Pixel Analyzer

Profile

Scene Graph

Variables

Metadata '
+' Export Queue

Tags

~ Project

+' Background Renders
Viewer Monitor Out I
Script Editor

Sync Session

Viewer1
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If you have a second monitor you can drag the Contact Sheet Viewer to be displayed on the second
screen or move it to a new pane alongside the standard Viewer.

2. You can now start to populate the Contact Sheet Viewer with clips from the sequence. You can do
this by directly selecting the clips from the sequence. First go into the Pick Mode by using the
button next to the Send To Contact Sheet button.
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Global

Curve Editor Dope Sheet
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A4

Pick Mode
-

3. Onceyou are in Pick Mode you can select shots directly from the sequence view and they will
dynamically populate the Contact Sheet Viewer.

MEELET

You can use all the standard selection methods like Ctrl+Left Click to select non contiguous clips,
Left Click+Drag Marquee to select a range or Left Click on a clip and Shift+Left Click on a different
clip to select all clips in between.

The Pick Mode works in the same fashion as Hard Selections; so if, for instance, you want to deselect
all your currently selected clips being displayed in Contact Sheet simply make sure that you are in Pick
Mode and tap down in an empty area in the sequence and your selection will be cleared.

It's worth noting that when you are selecting non-contiguous clips using the Ctrl+Left Click method,
the order you select the clips defines the order that they appear in the Contact Sheet Viewer, as
shown in the example below.

USER GUIDE
440



Using Contact Sheet: Manual Pick Mode |

Selected 3rd # Selected 1st

When selecting via either the Left Click+Drag Marquee or Shift+Left Click methods, the direction of
the selection is ignored and clips are displayed in the Contact Sheet in the order they appear in the
sequence.

Shots displayed in
sequence order
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Shots displayed in
sequence order

4. Once you've finished adding the shots you want displayed in the Contact Sheet deactivate the Pick
Mode button to return to normal editing and selection mode. You'll note that when you do this
that your chosen shots are highlighted with a dashed border so that you can visually keep track
of what shots are being used in the Contact Sheet. In the normal editing mode you cannot affect
the Contact Sheet selection and will need to go back into the Pick Mode if you want to add or
remove shots.

De-select Pick mode

<<<<<<

5. At this point, depending on how many clips you have selected, additional pages may be shown
available in the Contact Sheet menu bar Pages area. The default Max Rows & Max Columns
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Count is set to 5 by default, meaning that up to 25 shots can be displayed per page before the
remaining are automatically spilled over to additional pages.

In the screenshot below with these default settings 15 shots are selected to be displayed.

e i | . 15 Shots using
All shots LN ‘y default Max
displayed on a S8 N o = Loy Row & Column
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15 Shots
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If you now select a further 20 shots, making a total of 35, then a second page is created as you've
exceeded the maximum allowed determined by the Row & Column Count, and 10 shots are placed on
page 2. The page navigation box is updated accordingly.

25 Shots using
S default Max
1] Row & Column
2 pages are now

available and 10 ‘ LA Th ] Countat 5

shots spilled over
to page 2
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So now using the up and down arrows you can navigate between the pages; this is what is seen on
page 2.

10 Shots

T TR R

Using the Max Rows & Columns count you can optimize the amount of shots and their scale when
working with large amounts of content in the Contact Sheet, which will also help playback
performance, but in combination with the Contact Sheet Output Resolution create bespoke layouts a
few examples of which can be seen below.

Contact Sheet Output Resolution 9600 x 540
Max Row Count =1
Max Column Count = 10

90000




Using Contact Sheet: Manual Pick Mode |

Contact Sheet Output Resolution 9600 x 2160
Max Row Count = 2
Max Column Count =5

Contact Sheet Output Resolution 3840 x 6480
Max Row Count = 6
Max Column Count =2
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B Contact Sheet Output Resolution 5760 x 10800 —
Max Row Count =10 ‘
Max Column Count = 3
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Using Contact Sheet: Playback

Once you have populated the Contact Sheet Viewer with some clips, there are several things to note in
regard to playback, navigation and quality in the Contact Sheet Viewer.

Time

Looking at the timebar under the Contact Sheet Viewer, you'll notice that the clips in the Contact Sheet
do not have a temporal relationship to the where they exist in the sequence. In fact the Contact Sheet
and Timeline Viewers act independently of each other when it comes to playback. Playing, scrubbing
and stepping through frames in the sequence or timeline viewer does not affect the Contact Sheet
Viewer and vice versa.

Contact Sheet
viewer acts
independently

8 Timeline viewer &
# Sequence viewer 8
play / scrub
synced together

Cache

The playback cache is automatically split in half when a Contact Sheet Viewer is opened. For example,
if you have assigned 20GB of RAM in your playback cache preferences 10GB will be allocated to the
Contact Sheet Viewer and 10GB to the Timeline Viewer when using Contact Sheet.

On closing a Contact Sheet Viewer, this RAW allocation will be returned to the active Viewer.
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Playback range

If you look at the duration of the Timeline Viewer showing the sequence and the Contact Sheet Viewer
duration you'll notice that they are considerably different.

This is because clips displayed in the Contact Sheet Viewer are all synced to frame 1 and the Contact
Sheet Viewer playback range is dynamically determined by the longest clip in the current selection.

This also means that you will see shorter clips freeze on the last frame when you playback or scrub,
and held to the duration of the longest clip.
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Framés 365

As mentioned above, this means that the Contact Sheet playback range will constantly change
according to the clips loaded.

Navigation

Navigation around the Contact Sheet Viewer is exactly the same as the standard Viewer so you can
use the normal zooming and panning gestures and home and fit hotkeys. You will also have a lot of
the same Viewer controls as in the standard Viewer but with some exceptions.

Quality

Most notably is the lack of a proxy or quality setting drop down. To enhance performance, the Contact
Sheet will automatically set this for you.
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By default the initial Contact Sheet Viewer resolution is set to HD 1920x1080 regardless of the
sequence resolution. Depending on your display device this may be perfectly fine for general viewing
and comparison tasks. But if you are using the Contact Sheet Viewer for more critical decisions then

you will most likely require a higher fidelity.

Take the example here where we have loaded four clips into the Contact Sheet Viewer and zoomed
into a similar area in both the timeline viewer on the left and the same clip in the Contact Sheet
Viewer on the right. You can clearly see some pixelation happening in the Contact Sheet Viewer.
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Improving quality

We can easily improve the quality of the Contact Sheet image by increasing the resolution of the
Contact Sheet Viewer.

To do this we can access the Output Resolution option found in the Contact Sheet Settings cog

This provides a familiar interface similar to the Sequence Output resolution setting, but again like the

Viewer player timebar, this setting is particular to just the Contact Sheet Viewer.

If we change the Contact Sheet output resolution to UHD 3140x2160 4K we can now see a huge
improvement of the zoomed in area compared to the Timeline Viewer.

3840x2160 UHD
Contact Sheet
Output
Resolution

1920x1080 HD
Contact Sheet
Output
Resolution

Note: Like the Viewer's playback behavior, the sequence resolution and the Contact Sheet'’s

resolution are not directly linked which allows you a lot of flexibility.
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Using Contact Sheet: Tag Filtering

In addition to manually choosing the shots with Pick Mode, you can also populate the Contact Sheet
Viewer by using tags on shots in the Timeline.

Note: Tag Filtering is available in Nuke Studio and Hiero, but not in HieroPlayer.

The example below shows a simplified sequence that has three tags applied in various ways to
different clips. The beginning and end clip are also populating the Contact Sheet Viewer via manual
Pick Mode selection.

v
»
-|

DI T

To start filtering the Contact Sheet by tags, you can simply select which tags and boolean operation
you'd like to use.

Clicking the Tag Filter drop down in the Contact Sheet menu bar will display all the tags currently
present on the sequence being sent to the Contact Sheet. Here you can also see check boxes
indicating the boolean operation.
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B properties Background Renders
rgb RGB SsRGB ~ = Page: 1/1

Blue
LS UL L # Green

Magenta

Page: 1 /1
Blue
B Green

Magenta

The two check boxes next to each tag entry have three states:
* Inactive (gray) - this tag is not be used to display a shot in Contact Sheet

* Active (highlighted) ‘+' PLUS - This tag is being used to include shots in the Contact Sheet and is
performing an “AND"” boolean

* Active (highlighted) " MINUS - This tag is being used to include shots in the Contact Sheet and is
performing an “MINUS"” boolean

Blue
8 Green

Magenta

The check boxes make it quick to toggle between the different states and see your changes
dynamically update the Contact Sheet Viewer. Note that you can only have one state for a particular
tag enabled at a time. For instance if you had a '+’ PLUS check box enabled for a tag then clicked the *-

MINUS check box the '+ PLUS state would automatically be disabled and the - MINUS checkbox
enabled.

Clicking an active checkbox again will disable it, effectively removing that tag from the filtering.

USER GUIDE
453



Using Contact Sheet: Tag Filtering |

In this simple sequence we're first going to enable the Tag Filter Pick Toggle button on the left so we
can see changes in the Contact Sheet Viewer as we change the tag filtering options. As we have no
pre-chosen tags this will effectively show an empty Contact Sheet.

Now opening the tag filter drop down, check the ‘+' PLUS button next to the Blue tag. You'll see that
three shots are added to the Contact Sheet because they contain a Blue tag.

Contact Sheet
Page: 1/1
+ Blue

f Green
Magenta

Now if you check the '+’ PLUS button next to the Green tag only two shots are displayed because we
are asking the Contact Sheet to ONLY filter and display shots that meet that “AND” boolean. In other
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words the clips MUST contain both a Blue AND a Green tag. You'll notice that there is a clip that
contains just a Blue tag and just a Green tag that are not displayed.

Contact Sheet

Page: 1/1

+ Blue

Now if you click the - MINUS button next to the Magenta tag you will only see the one shot which has
a Blue AND Green tag but NOT a Magenta one.

Contact Sheet
Page: 1/1
Blue

e
Y “1F RS O

W [@ 909 se0 BIIGIHIGE W12 W

Using this simple mechanism it should be possible to filter and display a lot of combinations. For
instance if you wanted to see all shots that contained no tags then you could just switch to - MINUS
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on all the tags and you would then see what is left; in this case the two un-tagged shots at the
beginning and end of the sequence.

Contact Sheet - W
Page: 1/ 1
Blue
f Green

Magenta

v
X
-

DI & T

The manual Pick Mode selection and Tag filter selections are persistent, meaning that you can use the
Tag Filter/Pick Toggle button to quickly switch between the two modes and see what was last used.

Tag Filter mode
selecting Blue
Tags

Pick mode
selecting 2 clips

USER GUIDE
456



Using Contact Sheet: Workflows & Soft Effects |

Using Contact Sheet: Workflows &
Soft Effects

Display other sequences alongside Contact Sheet

Although in this release Contact Sheet only supports loading clips from a single sequence it is still
possible to have multiple sequences loaded and displayed whilst using a Contact Sheet Viewer from

another sequence.

To do this, simply open a sequence and create a Contact Sheet Viewer populated with some clips. In
this example note there is a sequence loaded called “WHG_edit_nuke_feature_video_full".

WHG_edit_nuke_feature_video_full WHG edlt nuke_feature_video_full
BN - . SN

= WHG_edit nuke feature video full

Once you've done that, you can now either double click a different sequence to open this into the
existing Timeline Viewer, or open a sequence into a new Timeline Viewer. In this example the opened

sequence is called WHG_edit_WIP.

Either way the end result is the same, the new sequence is displayed in a Timeline Viewer and the
original sequence that was the source for the Contact Sheet is still displayed.
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WHG_edit_nuke_feature_video_full
RN - . 3B

WHG_edit WIP

If you now want to have this NEW sequence populate the Contact Sheet you just need to click the
Send To Contact Sheet button and this sequence will now replace the previously loaded one.

WHG_edit WIP

This functionality allows you to view one sequence’s shots in a Contact Sheet against another
sequence.
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Display multiple shots with Soft Effects

Another really useful workflow in Contact Sheet is the ability to display multiple shots that have clip-
based and layer-based Soft Effects.

The example below demonstrates using a Grade Soft effect which is being used to balance out shots.
This effect then can be viewed dynamically over multiple shots in a Contact Sheet Viewer.

You could also use Contact Sheet to have a “show look” over everything and see the culmination of all
these effects.

N

omp 'I" {'ﬁ}ff&’u Yk & cre

Contact Sheet grade in
context L

Track based Soft FX §
“Look”

Shot based Soft FX
Grades

When the sequence has track based Soft Effects applied you can quickly bypass these for the Contact
Sheer Viewer by clicking on the Soft FX Bypass button in the Contact Sheet menu bar. This will then
hide these track based Soft Effects but only for the Contact Sheet Viewer; the Timeline Viewer will still
display the track Soft Effects.

USER GUIDE
459



Using Contact Sheet: Workflows & Soft Effects |

Track based Soft Effect Grade visible in
both Contact Sheet and Timeline Viewers

Track Based Soft Effect Grade ONLY visible in
Timeline Viewer
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Using Contact Sheet: Preferences

There is a new Contact Sheet section in the Preferences panel.

The options are:
* show border - Allows you to toggle the Contact Sheet shot outline on and off. The default is enabled
* border color - Allows you to customize the Contact Sheet shot outline color. The default is white.

+ selection fill color - Allows you to customize the fill color of shots in the sequence being used in the
Contact Sheet Viewer. Visible only in Pick mode. The default is green.

* selection border color - Allows you to customize the border color of shots in the sequence being
used in the Contact Sheet Viewer. Visible in both Pick and Edit mode. The default is white.

+ default resolution - Allows you to set a default Contact Sheet Output resolution that will affect the
quality of the shots displayed when either zooming in close or when the Contact Sheet is displayed
on a large monitor device. The default is 1920x1090 HD.

+ default max row count - Sets the maximum number of rows on a Contact Sheet Page. The default
is 5.

+ default max column count - Sets the maximum number of columns on a Contact Sheet Page. The
default is 5.
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These pages provide a basic overview and some simple examples to get you started, but more
information is available in the dedicated Python API document included in the Hiero package. See
Help > Python Dev Guide for more information.

Environment Variables

Environment variables are used to store values that influence the behavior of Hiero and HieroPlayer,
such as adding additional file paths to check at startup for plug-in scripts.

The process of setting environment variables differs depending on the operating system you're using:

On Mac and Linux

1. Thefirst step is to determine the type of the shell you're using. Launch a terminal and enter:
echo $SHELL

Your shell type is printed to the screen. For example, /bin/bash indicates that your shell is “bash”.
2. Depending on the output of the $SHELL command, do one of the following:

* csh or tesh - add the following command to the .cshre or .teshrc file in your home directory:
setenv VARIABLE value

Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:

setenv HIERO PLUGIN PATH /SharedDisk/Hiero

setenv TIMELINE DISABLE PBO UPLOADS 1

* bash or ksh - add the following command to the .bashrc or .kshrc file in your home directory:
export VARIABLE=value

Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:

export HIERO PLUGIN PATH=/SharedDisk/Hiero

export TIMELINE DISABLE PBO UPLOADS=1
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Note: These steps set the environment variable until you manually remove it from the file in
your home directory. If you want to set a variable for a single session, you can simply type
the variable in the terminal then run Hiero from the same session.

On Windows

1. Right-click on My Computer and select Properties.
Click the Advanced tab.
Click the Environment Variables button.
The Environment Variables dialog opens.

4. Click the New button under either User variables or System variables, depending on whether
you want to set the variable for the current user or all users.

Note: You must have administrator privileges to set system-wide variables.

In the Variable name field, enter the name of the environment variable you want to set.

In the Value field, enter the value for the variable. The value can be a directory path, for example.
You can also disable and enable variables by adding the value 0 or 1, respectively.

7. Click OK to save the variable.

Environment Variables

Environment variables are used to store values that influence the behavior of Hiero and HieroPlayer,
such as adding additional file paths to check at startup for plug-in scripts.

The process of setting environment variables differs depending on the operating system you're using:

On Mac and Linux
1. The first step is to determine the type of the shell you're using. Launch a terminal and enter:

echo $SHELL

Your shell type is printed to the screen. For example, /bin/bash indicates that your shell is “bash”.
2. Depending on the output of the $SHELL command, do one of the following:

* csh or tesh - add the following command to the .cshrc or .teshre file in your home directory:
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setenv VARIABLE value

Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:

setenv HIERO PLUGIN PATH /SharedDisk/Hiero

setenv TIMELINE DISABLE PBO UPLOADS 1

bash or ksh - add the following command to the .bashrc or .kshrc file in your home directory:
export VARIABLE=value

Replace VARIABLE with the name of the environment variable and value with the value you want
to give it, for example:

export HIERO PLUGIN PATH=/SharedDisk/Hiero

export TIMELINE DISABLE PBO UPLOADS=1

Note: These steps set the environment variable until you manually remove it from the file in
your home directory. If you want to set a variable for a single session, you can simply type
the variable in the terminal then run Hiero from the same session.

On Windows

1. Right-click on My Computer and select Properties.
Click the Advanced tab.
Click the Environment Variables button.
The Environment Variables dialog opens.

4. C(lick the New button under either User variables or System variables, depending on whether
you want to set the variable for the current user or all users.

Note: You must have administrator privileges to set system-wide variables.

In the Variable name field, enter the name of the environment variable you want to set.

In the Value field, enter the value for the variable. The value can be a directory path, for example.
You can also disable and enable variables by adding the value 0 or 1, respectively.

7. Click OK to save the variable.

Article: How to set environment variables
How to delete or unset environment variables
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get environment variable values
o list environment variables
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Hiero Environment Variables

The following table lists the environment variables Hiero recognizes.

Environment Variable

__GL_SYNC_DISPLAY_
DEVICE

FN_CRASH_DUMP_PATH

FN_DISABLE_LICENSE_
DIALOG

or

FN_NUKE_DISABLE_
TMPLIC_NOTIFY_DIALOG

FN_LICENSE_DIALOG_
DAYS_LEFT_BEFORE_
PROMPT

FN_SUBSCRIPTION_
LICENSE_DIR

Description

On Linux, set this variable to the name of screen device to synchronize
in dual screen setups. See Synching to VBlank on Linux for more
information.

Allows you to specify where Issue Reporter dumps are saved by default.

By default, if you have installed a temporary license, Hiero displays a
dialog at start-up alerting you to the number of days remaining. If you
want to disable this behavior, you can set either of these environment
variables to 1 to suppress the warning message about imminent license
expiration.

Note: You still get a warning if no license is found, for
example if you only have a HieroPlayer license but you try to
run Hiero.

By default, if you have installed a temporary license, Hiero displays a
dialog at start-up alerting you to the number of days remaining. If you
want to disable this behavior until a set number of days before expiry,
you can set this environment variables to the required number of days.

Note: You still get a warning if no license is found, for
example if you only have a HieroPlayer license but you try to
run Hiero.

On Windows, user names containing non-ASCII characters can cause
subscription licensing to fail. If a licensing error similar to the following
displays:

Unable to create subscription license directory: C:\Users\Zoé
Hernandez\FoundryLicensing\



Environment Variable

foundry_LICENSE

FOUNDRY_LICENSE_
DEBUG

FOUNDRY_LICENSE_FILE

FOUNDRY_LOG_FILE

FOUNDRY_LOG_LEVEL
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Description

Try changing the license directory to an alternate location using this
environment variable.

The location of the Hiero RLM license file, if the following
recommended location is not used:

On Mac and Linux:
/usr/local/foundry/RLM

On Windows:
drive letter:\Program Files\The Foundry\RLM

Note: If you still use FLEXIm licenses and you're interested in
making a move to RLM licensing, please contact
sales@foundry.com to obtain a replacement license.

This variable prints additional licensing information to the command
line or Terminal.

The location of the Hiero FLEXIm license file, if the following
recommended location is not used:

On Mac and Linux:
/usr/local/foundry/FLEX1m

On Windows:
drive letter:\Program Files\The Foundry\FLEXIm

Note: If you still use FLEXIm licenses and you're interested in
making a move to RLM licensing, please contact
sales@foundry.com to obtain a replacement license.

This variable specifies the location of Hiero's logfile. If you don't specify

a logfile, all output is to screen.

This variable sets the level of logging Hiero produces during operation.

There are four levels of detail, on a sliding scale from minimal to
verbose:
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Environment Variable Description

* error
* warning
* message
* verbose

Note: Setting the logging level to verbose can produce large
log files when FOUNDRY_LOG_FILE is specified.

FRAMESERVER_LOG_DIR This variable is used to specify a different location for the Frame Server
to write log files to, if you'd like to keep them separate from the default
NUKE_TEMP_DIR.

See Using the Frame Server on Render Machines for more information.

HIERO_DISABLE_ Set this variable to stop Hiero loading thumbnails.

THUMBNAILS

HIERO_DISABLE_ Set this variable to stop Hiero caching thumbnails for improved access
THUMBNAILS_CACHE once loaded.

Note: This variable does not clear the cache, you must
remove cached files manually.

HIERO_PLUGIN_PATH Set this variable to the location of additional scripts to run at startup.
You can use .<folder> to point to hidden folders, for example
.myPlugins.

For example, you could create a facility-wide location to share presets
and use this variable to point multiple Hiero’s to it. See Sharing Presets
for more information.

Use the following method to display set paths:

print hiero.core.pluginPath ()

HIERO_SINGLE_ This variable launches Hiero in single-thread mode, which can solve
THREADED_PLAYBACK playback issues on various Linux Fedora distributions.
USER GUIDE
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Environment Variable Description

NUKE_AJA_CHANNEL AJA cards take 3G level signal (mostly for 12-bit 444 RGB) and combine

it into a single 3G-B (B denotes B level, hence the 3G-B) stream through

SDI1 by default. Use these environment variables to customize this

output behavior:

* NUKE_AJA_CHANNEL - set this variable to 2, 3, or 4 to output a single
stream through SDI2, SDI3, or SDI4.

* NUKE_AJA_DUALOUTPUT - set this environment variable to 1 to force
the card to separate the single 3G stream into two 1.5G streams
through SDI1 and SDI2.

Combining these two environment variables can force the stream to
NUKE_AJA_ DUALOUTPUT  split and output through alternate SDI outputs. For example:
* DUALOUTPUT + CHANNEL=1 OR CHANNEL=2 results in two 1.5G
streams coming from SDI1 and SDI2.

* DUALOUTPUT + CHANNEL=3 OR CHANNEL=4 results in two 1.5G
streams coming from SDI3 and SDI4.

Note: Certain modes, such as 12-bit 444, require a 3G stream.
Otherwise, the card uses the single stream on the channel
number specified.

NUKE_ALLOW_GIZMO_ Nuke does not allow you to Overwrite and Save as gizmos by default,

SAVING without copying the gizmo to a Group. Setting this environment
variable to 1 enables this behavior, so artists don't need to copy a
gizmo before editing it.

NUKE_CRASH_HANDLING Breakpad crash reporting allows you to submit crash dumps to Foundry
in the unlikely event of a crash. By default, crash reporting is enabled in
GUI mode and disabled in terminal mode.

When NUKE_CRASH_HANDLING is set to 1, crash reporting is enabled in
both GUI and terminal mode.

When NUKE_CRASH_HANDLING is set to 0, crash reporting is disabled
in both GUI and terminal mode.

NUKE_DISK_CACHE The location where Hiero saves all recent images displayed in the
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NUKE_DISK_CACHE_GB

NUKE_EXR_TEMP_DIR

NUKE_EXR_TEMP_NAME

NUKE_FONT_PATH

NUKE_LEGACY_CHANNEL_
SORTING

NUKE_LOCALIZATION_
NUMWATCHERS

NUKE_MOV64READER_

ENABLE

NUKE_NO_CRASH_
PROMPT

NUKE_TEMP_DIR
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Description

Viewer. Ideally, this should be a local disk with the fastest access time
available.

The maximum size the disk cache can reach (in gigabytes).

On Linux, this is the location Hiero uses for temporary files while
reading PlZ-compressed .exr files. This environment variable is only
relevant on Linux.

If this variable is not set, the location is determined by NUKE_TEMP_DIR.

Changes the naming convention of .exr temporary files during
rendering.

Setting the variable to 1 writes temporary .exr files as
<filename>.exr.tmp, rather than <filehash>.tmp as in previous
releases.

The location that Hiero checks for available font files when the Text
node properties panel is opened.

This variable disables the new channel sorting behavior, where the
RGBA layer is sorted first. Enabling this variable causes Hiero to sort
channels alphabetically.

Controls the number of threads available for localization tasks.
Increasing the number of threads can improve localization
performance.

Set this variable to 0 to disable Hiero's 64-bit mov decoding and fall
back to 32-bit decoding.

When crash handling is enabled in GUI mode, this allows you to control
whether reports are automatically submitted or not:

When NUKE_NO_CRASH_PROMPT is set to 1, crash reports are
submitted automatically without displaying a crash reporter dialog.

When NUKE_NO_CRASH_PROMPT is set to 0, Hiero always displays a
crash reporter dialog before submitting a crash report.

The location where Hiero saves any temporary files that do not have a
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NUKE_
WINDOWMANAGER _
DEBUG

OcCIo

QT_COMPRESS_TABLET_
EVENTS

QT_PLUGIN_PATH

TIMELINE_DISABLE_PBO_
UPLOADS

Sharing Presets
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Description
particular place defined for them.

You can find the current location of Nuke's temporary directory from
within Nuke by pressing X on your keyboard, when the focus is on the
Node Graph, and then running the following TCL command:

getenv NUKE TEMP DIR

When enabled, data from Hiero's window manager is printed to the
command line or Terminal.

Set this variable to the location of your OCIO configuration file for color
conversion.

Note: If you plan to use the OCIO config file specified in the
Preferences, ensure that the Preferences > Project Defaults
> Color Management > Export > use OCIO nodes when
exportingto a Comp checkbox is enabled.

Due to recent updates to Qt, running Nuke on CentOS 7 Linux
distributions with a tablet can cause lag when moving Roto shapes
around the Viewer. Setting this environment variable compresses tablet
events, eliminating the lag.

The location where Nuke looks for custom Qt libraries if you don't want
to use those shipped with Nuke. Setting this environment variable adds
the custom path to Nuke's Qt library paths.

When enabled, the performance benefit from using pixel buffer objects
(PBO) for texture uploads from RAM to the GPU is disabled.

You can try disabling PBOs if you notice playback degradation.

Hiero and HieroPlayer support facility-wide preset sharing by pointing multiple seats to a single
network location using the HIERO_PLUGIN_PATH. As long as the folder hierarchy mirrors what the
application expects, you can place this repository anywhere on your network.
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To setup sharing:

1. Create the shared repository directory, for example:
/Volumes/myFacility/Shared/

2. Follow the instructions under Setting Environment Variables to point individual machines to the
shared location. For example, if you're using a bash shell, you could use:
export HIERO PLUGIN PATH=/Volumes/myFacility/Shared/

Any file that can be read locally can be placed in the shared path.

Startup Projects

Hiero and HieroPlayer search <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer
and <path>/Templates for preset projects saved as .hrox files. See Mac, Linux, and Windows for a
description of the <path> variable by platform.

Projects placed in these folders behave differently, depending on which folder they are read from:

* StartupProjects/Hiero or HieroPlayer - projects in these folders are displayed in the bin view at
startup and are read only. An example project, Tag Presets, is included in the Tags tab.

* Templates - projects in this folder appear in a dropdown menu when you open a new project. Select
the template to use for the new project.

Note: You may need to create the StartupProjects/Hiero, StartupProjects/HieroPlayer,
and Templates folders manually in the chosen path.

To remove a startup project, either:

* Remove it from <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer or
<path>/Templates, or

* Rename the file extension so the application doesn't recognize it on startup. For example,
myStartup.hrox_hidden.

To modify a startup project:

1. Load the project using File > Open.

2. Make any required edits and save over the original in the same location.
The edited project loads at startup.
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Using the Python API

Hiero and HieroPlayer ship with a comprehensive Python application programming interface (API)
enabling you to perform most user interface actions using Python scripting.

This section provides a basic overview and some simple examples to get you started, but more
information is available in the dedicated Python APl document included in the Hiero package. See
Help > Python Dev Guide for more information.

On startup, Hiero and HieroPlayer scan various directories for Python scripts that customize the
behavior of the application. These scripts can be downloaded from online resources and placed in
specific locations on disk, depending on the platform you're using.

If you're familiar with Python scripting, you can place custom startup scripts in the same locations,
though bear in mind that you should take care as mistakes can produce performance issues.

Some example scripts are included in the application package in the following directories:

On Mac:
* /Applications/Hiero16.0v5/Hiero16.0v5.app/Contents/Plugins/site-packages/hiero/examples/

On Linux:

* /usr/local/Hiero16.0v5/Plugins/site-packages/hiero/examples/

On Windows:
* drive letter:\Program Files\Hiero16.0v5\plugins\site-packages\hiero\examples

At startup, Hiero and HieroPlayer search <path>/Python/Startup and <path>/Python/StartupUl for

any Python .py modules or packages containing __init__.py. Scanning is done in two passes - all the
Startup folders are searched and then all the StartupUl folders.

You can also add your own Startup folders, which are scanned after the standard paths, by creating a

Python file pointing to the custom location. For example:
import hiero.core

hiero.core.addPluginPath ("/myCustomPlugins")
Searches /myCustomPlugins/Python/Startup after the standard paths.

Each package or module discovered is imported and added to the built-in package hiero.plugins.
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Note: Python startup scripts are imported in alphabetical order so you can force ordering if
necessary.

The <path> varies by platform as follows:

Mac

* /Applications/Hiero16.0v5/Hiero16.0v5.app/Contents/Plugins
+ /Library/Application Support/TheFoundry/Hiero
* ~/Library/Application Support/TheFoundry/Hiero

* ~/.nuke

Linux

* /usr/local/Hiero16.0v5/Plugins
* ~/.nuke

Windows

* drive letter:\Program Files\Hiero\plugins\hieroscripts
* drive letter:\Program Files (x86)\Hiero\plugins\hieroscripts

* ~\.nuke

Note: The .nuke folder can be found under the directory pointed to by the HOME
environment variable. If this variable is not set (which is common), the .nuke directory is
under the folder specified by the USERPROFILE environment variable - which is generally of
the form drive letter:\Documents and Settings\login name\ or drive letter:\Users\login name\

To find out if the HOME and USERPROFILE environment variables are set and where they are
pointing at, enter %HOME% or %USERPROFILE% into the address bar in Windows Explorer. If
the environment variable is set, the folder it's pointing at is opened. If it's not set, you get an
error.

You can specify any number of user-defined paths using the environment variable HIERO_PLUGIN_
PATH, separating them with : just like the standard unix PATH environment variable and Nuke's
NUKE_PATH. See Setting Environment Variables for more information.
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Using the Script Editor

Hiero and HieroPlayer include a Python Script Editor, accessible from the user interface, allowing you
to enter Python statements directly.

To access the Script Editor:

1.

Navigate to Window > Script Editor.

The Script Editor displays.

Enter scripts in the lower half of the editor and press Ctrl/Cmd + Enter to execute the script.
The results are displayed at the top of the editor. A simple example might be:

from hiero.core import *

bin = projects () [-1].clipsBin{()

bin.addItem(Bin ("Plates"))

bin["Plates"] .importFolder ("/Footage/Hiero/finalshots")

Which imports hiero.core, defines bin in the last project opened, creates a bin called Plates at
root level, and imports the specified folder into Plates.

Script Editor buttons and commands are described below:

a
BE B EEBRA B
=

Hotkeys Description

Ctrl/Cmd+[ Go to the previous script.
Ctrl/Cmd+] Go to the next script.

n/a Clear the script history.
n/a Load and execute a script.
n/a Load an existing script.
n/a Save a script as a .py file.

Ctrl/Cmd+ enter Run the current script.
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Icon Hotkeys Description
- n/a Show the input pane only.
n/a Show the output pane only.
- n/a Show both the input and output panes.
n Ctrl/Cmd+ Clear the output pane.
Backspace

The Script Editor also features auto-completion and help for commands. Classes, attributes and so on
are discoverable by:

* Entering the beginning of an object name and pressing the Tab key.

For example, typing Bin and pressing Tab displays a list of objects starting with Bin:

1Binl
Bin(

Binltem(

* Using the help command for a known object.

For example, help(Clip) returns a list of useful information on Clip:

Scroll down in the top pane to see more information relating to Clip.
* Using the dir command for a known object.

For example, dir(Project) returns a concise list of useful information on Project:
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Note: The last entry in the Script Editor is restored at startup by default, but you can disable
this behavior by navigating to Preferences > Script Editor and deselecting Save and
restore script editor history.

For more information on Python scripting, see Help > Python Dev Guide.
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The Available Preference Settings

The Preferences dialog is divided into the following sections:

General
Project Defaults
Performance

Behaviors

Panels

General

General
Autosave

force project autosave
after <300> seconds

Path Substitutions

path substitutions

Settings for auto-saving and path substitutions.
General project settings, and settings for color management.
Settings for caching, hardware, localization, and threads/processes.

Settings for start up, file handling, export options, scripting, node
behaviors, and more.

Settings for the interface appearance, file browser, control panels, nodes,
Viewers, script editors, and scopes.

Set the number of seconds after which to automatically save your project.
Disable this by setting it to zero.

Allows you to remap file paths in order to easily share projects across
different operating systems. When the application encounters a file path,
any text in the Mac/Linux column is replaced with the text in the Windows
column, or vice versa.

For example, if you enter /Volumes/networkmount in the Mac/Linux
column and Z: in the Windows column:

* On Mac and Linux, any file paths that start with Z: are converted to start
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General

with /Volumes/networkmount.

* On Windows, any file paths that start with /Volumes/networkmount are
converted to start with Z:.

To be able to enter text in either column, you need to click on the + button
below to add a row to the table.

Note: Path substitution is invaluable for Sync Review sessions if
you're using local source files rather than files from a central
server. See Sync Review for more information.

+ Adds a row under path substitutions.
- Deletes the selected row(s) under path substitutions.
Nuke

Open In > New Hiero When enabled, new Hiero sessions are launched as NukeX.
Session launches
NukeX

Project Defaults

Note: You must restart the application for changes to Project Defaults preferences to be
applied.

Channel Management

Channel Management

Channel Warning Sets the total number of channels required in a script to trigger the
Threshold Channel Warning. Hiero only supports 1023 uniquely named channels per
script.

The Channel Count is displayed in the bottom-right of the interface, next
to the Localization Mode indicator.
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Channel Management

Note: Hiero does not remove unused channels until you close
and reopen a script, so the Channel Count does not decrease
when you remove Read nodes from the Node Graph.

Color Management
Default Color Management

Default Color Sets the default color management system to use in new projects.
Management

OpencColorlO config

OpenColorlO config Sets the OpenColorlO configuration to use, if you don't intend to use the
file nuke-default settings.

If you select custom from the dropdown, enter the file path of the
configuration file or click Choose to use the browser.

Note: Hiero also includes an environment variable method for
setting a config file. See Nuke Environment Variables for more
information.

Default Color Transforms

working space Sets the colorspace files should be converted to, on import, and from,
during render - it's the colorspace used under the hood.

viewer Sets the default LUT applied to Viewers.
thumbnails Sets the default LUT applied to thumbnails when ever they are generated.
Monitor Out Sets the default LUT applied to external monitors.
8 bit files Sets the default LUT applied to the specified ingested file type.
16 bit files
USER GUIDE
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Color Management
log files

floating point files
OCIO Roles

Allow OCIO Roles in
Colorspace Knobs

Prioritize OCIO Roles

HDR (macOS only)

Enable macOS HDR
Color Profile (Display
P3) (Beta)
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When enabled, OCIO roles are available in all colorspace controls.

When enabled, OCIO roles are created in the main menu of cascading
dropdowns, with Colorspaces in a sub-menu. When disabled, roles are
demoted to a sub-menu called Roles.

You can also control this preference using an environment variable. See
Nuke Environment Variables for more information.

When enabled, running under macOS with a screen capable of displaying
values greater than 1 allows you to display HDR images in the Display P3
colorspace correctly.

Hiero Script Project Settings

color management

Sets whether Hiero uses the LUTs read from the configuration specified or
the Nuke native LUTs during export. Selecting OCIO makes the relevant
OCIO LUTs available to the Read and Write nodes in scripts on a per project
basis.

All configurations except nuke-default automatically switch this control to
ocio.

General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.

Project

project directory

USER GUIDE

Sets the project directory used by new projects. You can change the project
directory for the current project in the Project Settings.
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General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.

Hrox Directory

export directory

custom export
directory

Sequence

output resolution

frame rate

start timecode

time display

drop frame

USER GUIDE

Click to set the project directory to the location of the .hrox file using the
[python {nuke.script_directory()}] expression.

Sets the directory used by timeline exports:

*+ Use Project Directory - use the directory specified by the project
directory preference.

* Use Custom Directory - use the directory specified by the custom
export directory control.

Sets the export directory used by new projects when the export directory
control is set to Use Custom Directory.

Use this to set the output resolution in the Timeline environment for new
projects. By default, clips in the sequence are not reformatted to fit this
format, they retain the source clip resolution. You can adjust the
reformatting for new clips added to a sequence using the Clip settings
below or by selecting clips in the timeline and adjusting the settings in the
Properties tab.

Select the frame rate for new projects in the Timeline environment.

Use this to define the start timecode for new projects. For shots, this
overrides the timecode defined in the media.

You can use this to select the display format for times. You can select either
Timecode or Frames.

Use this to choose whether timecodes from this sequence are displayed in
drop frame times or not.

Drop Frame is a timecode display option that leaves out two frames from

the 30 fps timecode sequence every minute (except every 10th minute) so
that long running NTSC sequences are accurate to a real-time clock (NTSC
frame rate is 3000/1001, or approximately 0.01% slower than 30fps).

Note: Enabling Drop Frame is a Timecode display feature only -
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General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.

the source media remains a continuous stream of frames.

Clip

clip reformat Sets how new clips added to a sequence are formatted. The default, None,
displays shots at the source clip resolution, whereas To Sequence
Resolution reformats the shot to the output resolution using the resize
type control.

resize type When clip reformat is To Sequence Resolution, determines how the shot
is resized to fit the output resolution. This control is disabled when clip
reformat is set to None.

center When clip reformat is To Sequence Resolution, disabling center places

the clip at the bottom-left of the output resolution, rather than the center.

Link bin and track item When enabled, selecting a new version for a clip in a bin or a shot on the
versions timeline updates all instances of that media.

When disabled, you can version clips and shots independently, even if they
reference the same media.

Poster Frame

poster frame Sets a preset poster frame for all new source clips or select Custom to
select a relative frame offset as the poster frame:

* First - new source clips display the first frame of the file on disk as the
poster frame.

* Middle - new source clips display the middle frame of the file(s) on disk as
the poster frame.

* Last - new source clips display the last frame of the file(s) on disk as the
poster frame.

* Custom - the poster frame number is derived from the number of frames

in the clip starting at 0. Use the frame offset control to set the relative
offset.

For example, a .dpx sequence myClip.####.dpx 1001-1500 can have a
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General - these preferences only apply to new scripts and projects. To affect the current project,
use the Project Settings.

custom poster frame between 0 and 499.

frame offset When poster frame is set to Custom, enter the relative frame offset from
the first available frame in the file(s) on disk.

Sync Session
Default Appearance

name Sets the name and color you want to display on participant sessions. Click
the color swatch to open the color picker.

Default Behavior

open sync panel on When enabled, automatically open the Sync Session panel when a session
sync session startup is started.

Project Saving

save directory Sets the default directory where all Sync Session projects are saved.

Views - these preferences only apply to new scripts and projects. To affect the current project, use
the Project Settings.

Views

+/- Click to add and remove views from the views list.

Tl Click to move views up and down the views list. Moving a view changes the
position of the corresponding Viewer button.

View Lists the views in the script or project and the color associated with the
view when Use color in Ul is enabled.

hero Sets the principal view selected on script or project load.
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Views - these preferences only apply to new scripts and projects. To affect the current project, use
the Project Settings.

Set up views for stereo  Click to automatically add left and right views to scripts or projects.

Use colors in UI? When enabled, the colors specified in the views matrix are applied to the
interface. For example, if you click Set up views for stereo and enable this
control, any Ul items representing the left and right views are colored red

and green.
Performance
Caching
Timeline Disk Caching
directory path The directory where all .exr files from timeline disk caching are stored by

default. The caching directory should be on a local disk, preferably with the
fastest access time available. It's also important to leave enough space for
the maximum disk cache size (defined below).

limit to (GB) This allows you to set the maximum amount of space (in GB) to use for the
timeline disk cache. Set to zero for unlimited size. Values lower than zero,
leave that amount of space free. The currently in use and currently free
fields display how much free cache remains from the total specified.

If this limit is reached during caching, a dialog displays options to free up
disk space.

EXR compression Sets the type of compression applied when writing files to the disk cache:
* DWAB

* Zip (1 scanline)

Note: DWAB compression produces smaller cache files more
quickly, but can be lossy compared to Zip compression.

clear cache Clear All removes all cached files from the root directory specified in the
directory path control. A dialog displays a list of files for confirmation
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Caching
before the files are deleted.
default disk caching Sets the default dick caching mode for new sequences:
mode * Manual - the default mode, when a region is cached any changes made

after the initial cache operation are not automatically re-cached.

* Automatic - when a region is cached, any changes to soft effects made
after the initial cache operation automatically triggers a re-cache of the
affected region of your cached timeline. This means that your timeline is
always cached and up to date in the selected regions, regardless of
changes made.

Note: You can override this preference in the Sequence panel
using the Disk Caching Mode dropdown.

Comp Disk Caching

temp directory The comp disk cache saves all recent images displayed in the Viewer for
fast playback. Using this control, you can specify where you want Hiero to
save these images. Select a local disk (for example, C:/temp), preferably
with the fastest access time available. It's also important to leave enough
space for the maximum disk cache size (defined below).

Memory Caching

playback cache size (% Specifies the percentage of system RAM used for the timeline Viewer
of system RAM) playback cache. The entire amount is allocated, even if you've only got a
few frames in the Viewer.

Recently used frames are retained in the memory to avoid relying on the
disk buffering system. The cache is freed when you switch to the
compositing Viewer and reallocated when you switch back to the timeline
Viewer.

Tip: On low-end machines, minimizing this may improve
application responsiveness at the expense of smooth playback.

free timeline playback  When enabled, any frames cached to RAM (the white bar in the timeline
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Caching

RAM cache when Viewer) are discarded when you switch to the Node Graph within Nuke
switching to the node  Studio, freeing the RAM for use in Hiero.

graph

Note: When you switch back to the timeline, the cached files are
re-cached, which can be time consuming.

Audio Waveforms

waveform memory Sets the amount of memory available for storing timeline audio
(MB) waveforms.

Application in Background

pause timeline Viewer When enabled, pause timeline Viewer caching when the application is in
when the application  the background.

goes to the

background

clear timeline Viewer ~ When enabled, the timeline Viewer cache is cleared when the application
cache when the goes into the background.
application goes to the

background
Note: This preference is only available when pause timeline

Viewer when the application goes to the background is
enabled.

Undo Caching

undo history size Allows you to set the amount of RAM, in MB, to use for the undo history. If
this limit is exceeded, older items are discarded.

minimum undo events Use this to set the amount of undo events. This setting always applies, even
if it breaches the undo history size limit.
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Hardware
Audio

audio device

GPU

expand 3to 4
channels

enable vsync

Localization

System
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The audio device control allows you to select an existing audio device for
playout from a list of automatically detected devices. You can disable
playout on a device by selecting Disabled.

You can use this to expand images cached for playback from 3 to 4 color
channels per pixel. Some graphics hardware performs better at loading
images to video memory with 4 channels per pixel, than it does with 3.
Enabling this option improves playback performance on such hardware, at
the expense of reducing the number of frames that it's possible to cache.

If you are seeing poor playback performance, enabling this option may
help. However, if you are seeing acceptable playback performance with this
option disabled, then leaving it disabled increases the number of frames
that may be cached for smooth playback.

Note: You must restart Hiero for this option to take effect.

When enabled, synchronize new timeline Viewer's playback frame rate with
the refresh rate of the monitor. Enabling vsync limits the playback fps to
the monitor refresh rate and may reduce performance.

When disabled, timeline Viewer performance is unaffected but you may see
tearing in timeline Viewers.

Note: This preference is only shown in Nuke Studio and Hiero
sessions and only affects new timeline Viewers. Close and reopen
any existing Viewers after enabling this option.
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Localization

mode Sets the overall localization mode:

* on - checks for updates to source clips and Read nodes with localization
policy set to On or From auto-localize path and localizes those files
automatically.

* manual - checks for updates to source clips and Read nodes with
localization policy set to On Demand and prompts you to update them
manually.

+ off - no source clips or Read nodes are localized, regardless of the their
localization policy.

Note: The current localization mode is displayed in the status bar
at the bottom-right of the interface.

read source files when When enabled, source clips and Read nodes referencing out of date
localized files are out  localized files automatically revert to reading the entire sequence from the
of date original source files. Source files are read in the following circumstances:

* With Localization mode set to on:
* A localized source clip or Read node with localization policy set to on
demand is detected to be out of date.

* A localized source clip or Read node with localization policy set to on
or from auto-localize path is detected to be out of date and it is
queuing to be automatically localized.

* With Localization mode set to manual:

* A localized source clip or Read node with localization policy set to
on, on demand, or from auto-localize path is detected to be out of
date.

When disabled, the out of date localized files are read until you update
them manually.

hide out of date When read source files when localized files are out of date is enabled,
progress bar you can enable this control to hide the progress/status bar on Read nodes
that are reading from the original source files.

pause localizationon ~ When enabled, localization does not start automatically when you open a
script/project open script or project. Enabling this option can help to open scripts and projects
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Localization
more quickly.
Inputs

localization policy Sets the localization policy for all new source clips and Read nodes:

* on - always localize source clips and Read nodes with this policy
automatically.

+ from auto-localize path - localize these source clips and Read nodes
automatically if they reside in the auto-localize from directory.

+ on demand - only localize these source clips and Read nodes when you
manually update them.

+ off - never localize these source clips or Read nodes.
Paths

auto-localize from Enter the location of the files you need automatically localized, unless
otherwise specified in the Read node’s cache locally control or in the bin
right-click, Localization Policy menu. Commonly this would be your
remote working folder. If you leave this field blank, automatic local file
caching doesn't take place.

localize to Enter the file path where all the localized files are automatically stored.
Localizing files allows for faster reloading for files that are stored in a
location that is slow to access (such as a network drive).

On Windows, files saved to the localize to directory replace \\ (double back
slashes) and : (colon drive signifiers) with underscores so that the file path
works as expected between operating systems. For example:

\\windowspath\to\my\network\file.dpx is saved as __
windowspath\to\my\network\file.dpx
t:\my\network\path\file.dpx is saved as t_\my\network\path\file.dpx

Storage

limit to (GB) This allows you to set the maximum amount of space (in GB) to use for
localized files. Set to zero for unlimited size. Values lower than zero, leave
that amount of space free. The currently in use and currently free fields
display how much free storage remains from the total specified.
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If this limit is reached during localization, a dialog displays options to free
up storage space.

When files are localized, specifies the time interval (in minutes) before
Hiero checks for updated versions of the files.

Sets the colors used to represent the localization states of source clips and
Read nodes.

Sets the number of threads to use per reader. If your source files are
located on high performance local drives, increasing the number threads
can significantly improve read times.

CPU intensive operations, such as .jpg decoding, can also be improved by
increasing the number of threads per reader.

Allows you to override the default number of decode threads used,
dependent on file format.

Use the plus button to add an entry to the table and then select the file
format using the dropdown menu. Double click the Number of threads
column to set the required number of decode threads for that format.

Sets the number of helper threads to use for OpenEXR only. The default,
zero, automatically sets the number of helper threads used.

Allows you to increase the number of minutes a render process can stay
unresponsive before ending. If you're experiencing Render application
timed out messages with process-heavy scripts, you can try increasing this
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value.

When enabled, rendering using the Frame Server automatically opens the
Background Renders panel, or if it is already open, shifts focus to the
panel.

Set the number of worker Hiero processes to run for the frame server.

Note: You must restart Hiero for this setting to take effect.

You can select from several render options:

* limit renderer (more responsive ui) - Select this option to make the
user interface more responsive during transcodes. It tells Hiero to use 2
threads to transcode and to use 25% of RAM to cache. Using this option is
likely to result in slower transcodes.

* no renderer limits (fastest transcoding) - Select this option to ensure
that transcodes happen as quickly as possible. This option may result in a
less responsive user interface during transcodes.

+ customize render limits - Select this option to manually configure the
number of threads used and cache memory available when
transcoding files.

Note: You must restart Hiero for this setting to take effect.

Sets the number of threads that Hiero uses when transcoding. Lower
numbers allow the Timeline environment's interface to be more
responsive. Higher numbers allow faster transcodes. This setting is passed
to Hiero using the -m option.

Use this to set the number of gigabytes of RAM that Hiero uses for its cache
settings. Lower numbers may improve the Timeline environment's
interface responsiveness, while higher numbers may improve the speed of
the transcodes. This setting is passed to Hiero with the -c option.

Customizes the downsize filtering behavior by bit-depth. The default (1x)
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Threads/Processes

10-, 12- and 16-bit retains the original image size. You can select 2x to halve the image size, or

integer images 4x to quarter the image size.

16-bit float images The Viewer image quality dropdown affects the decode rate and resolution
o of clips displayed in the Viewer. Lower resolutions decode faster and vice

32-bit images e

Behaviors

Documentation

documentation source Sets the help source for the Properties ? button:

* local - use Hiero's built-in HTML help server. Hiero's local help server also
searches the NUKE_PATH, .nuke, and .nuke/Documentation directories
for HTML files with the same name as the requested node, such as
Blur.html.

* foundry - This uses Foundry's Online Help, the most up-to-date version
of the documentation.

* custom - Select this to point to your own help server.
auto port When enabled, assign a free port automatically.

local port Specify a local documentation server port manually. This is usually >= 1024.
You can also set this to 0 to automatically assign the port.

range Specify a range of ports to attempt with the local documentation server.

File Handling

scan for file sequence  When enabled, identify and import the file range of media that is dropped
range on drop into Bin into the bin. When disabled, no range is detected and only a single frame is
view ingested. (This does not affect container formats, such .mov and .r3d.)

automatically rescan When enabled, incrementing a source clip or shot's version past the end of
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the previously discovered versions list, forces a rescan to update the
versions list. See Using Versions for more information.

Sets the sequence display mode to be used in the file browser.

When enabled, assume frames have a fixed width number. With this
selected, frame numbers need to be padded with zeros to a fixed length,
otherwise frame numbers without preceding zeros are assumed to belong
to sequences with no padding. This is important as the sequence identifier
specifies a unique file name for each and every frame. For example:

Files With fixed frame With fixed frame
width width
assumed NOT assumed

sequence 1.18.exr,
sequence 1.19.exr,
and sequence 1.20.exr

sequence 1.##.exr/
sequence 1.%02d.exr

sequence 1.#.exr/
sequence 1.%d.exr

When enabled, opening contextual menus positions them with the most
recently used item under the pointer.

Sets which workspace to display on startup. You can choose from
Compositing, Conforming, Editing, Finishing, Reviewing, and Timeline.
You can also choose to save a customized workspace, which would also be
available from this list.

When enabled, display the splash screen on startup.
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Startup
startup
show startup dialog When enabled, display the dialog on startup.

restore workspace When enabled, restore the selected saved workspace when opening
when opening projects projects.

Analytics

submit usage statistics When enabled, certain usage statistics are collected from the machine on
which you license Hiero, NukeX, Nuke Studio, Hiero, and HieroPlayer.

When disabled, we don't collect any usage data from your machine.

Note: The port number used to communicate with Foundry is
443, the same one used for uploading crash reports.

Timecode

R3D file timecode Sets the source timecode for RED files. You can choose from Default From
File, Absolute Timecode, or Edge Timecode.

other media timecode Sets the timecode source for file-per-frame media (such as .dpx). You can
choose from File Header or Frame Number. If File Header is selected
and a timecode exists, then the timecode is used. Otherwise it defaults
back to using the frame number from the file name.

max valid timebase Sets the maximum image header timebase above which the value is
(fps) clamped.

Image files are often created with application specific timebase values in
the header description. This can lead to reading in spuriously high frame
rates and the clamp aims to prevent this from happening.

If your clips do have extremely high frame rates, increase this value as
necessary to avoid clamping.

EDL style spreadsheet When disabled, the srcOut and dstOut values in the spreadsheet use the
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Timecode

timecodes film convention, representing the last frame of the cut.
When enabled, the srcOut and dstOut values in the spreadsheet use the
video convention, representing the frame directly after the cut.

Ul Scaling

Note: You must restart the application to apply changes to Ul Scaling preferences.

Ul Scaling Mode Sets the scaling mode for the Ul on Windows and Linux. macOS handles Ul
scaling automatically.

+ off - no scaling is applied to the Ul, regardless of screen resolution.

+ auto - the Ul attempts to scale appropriately dependent on screen
resolution.

+ all - enables the Scale All dropdown, which allows you to scale all screens
by the selected factor.

* per display - enables the Per Display table, which allows you to set the
scaling applied per screen.

Scale All When Ul Scaling Mode is set to all, allows you to scale all screens by the
selected factor.

Per Display When Ul Scaling Mode is set to per display, allows you to set the scaling
applied per screen.

Panels

Appearance

Font Change the type, weight, angle, and size of the font used on Hiero's user
interface.

Ul Colors - right-click on any color button and select Set color to default to revert changes.
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Change the background color of most user interface elements (menus,
toolbars, panes, properties panels, Viewers, and pop-up dialogs).

Change the color of input fields, the input pane of the Script Editor, and the
left side of the Curve Editor.

Change the color of the highlighting that appears when you hover the
cursor over a control, select a file or folder in the File Browser, or scrub to a
new frame on the timeline.

Change the color of any highlighted text (for example, text you select in
node properties).

Change the color of labels and text on the application interface. Note that
this does not set the color of the labels on nodes in the Node Graph.

Change the color of buttons and dropdown menus.

Change the color that indicates a control has been animated.
Change the color that indicates a keyframe has been set.

Change the color of the disk cached frames on the Viewer timeline.
Change the color of the RAM cached frames on the Viewer timeline.
Change the color of the frame marker on the Viewer timeline.

Change the color of the in and out frame markers on the Viewer timeline.

Curve Editor / Dope Sheet - right-click on any color button and select Set color to default to

revert changes.

no. of curves visible
background
unselected key
part-selected key

selected key

USER GUIDE

Sets the maximum number of curves visible in the Curve Editor.
Change the background color of the Dope Sheet tab.

Change the color used for an unselected key on the Dope Sheet.
Change the color used for a part-selected key on the Dope Sheet.

Change the color used for a selected key on the Dope Sheet.
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Appearance
timeline

control text

control text shadow

time label

current frame

project frame range

Control Panels

max nodes in
properties bin

reopen acts like new
panel

expand / collapse
panels in Properties
bin to match selection

Color Panel

color picker button
opens

USER GUIDE
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Change the color used for the timeline on the Dope Sheet.

Change the color used for the control text on the Dope Sheet. These
indicate the frame number of a key when you select one.

Change the color used for the shadow of the control text on the Dope
Sheet.

Change the color used for the time labels on the Dope Sheet. These
indicate frame numbers.

Change the color used for the current frame on the Dope Sheet. This is a
vertical line that indicates the current frame on the timeline.

Change the color used for the project frame range on the Dope Sheet.
These are two vertical lines indicate your frame range.

Use this to set the maximum number of panels that can be open in the
Properties pane.

When this is enabled, double-clicking a node that has been open before,
places the panel in the same place as a new panel. If this is disabled, the
panel appears in its previous position.

If this is enabled, the node selection in the Node Graph determines which
control panels are expanded (all unselected nodes automatically have their
panels collapsed). This does not apply to floating control panels.

Sets the type of color picker displayed when you click a color picker button
in the properties panel:

* in-panel color picker - opens a color wheel and sliders in the properties
panel.

* floating color picker - opens a color wheel and sliders in a floating panel.
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Control Panels

Tip: Holding Ctrl/Cmd and clicking the color picker button opens
the alternate color picker to the one specified in the Preferences.

File Browser

start file browser from When enabled, new file browsers open at the last location used. When

most recently used disabled, new file browsers open at the current working directory.
directory

Node Colors

autocolor Deselect this checkbox to ignore individual soft effect color settings and,

instead always use the All Others color.

<node name or type>  The soft effects listed here have been given a default color. You can change
this by clicking the assigned color to open the color menu, and selecting a
new one.

All Others Use this to select the color to use as default for all soft effects not
otherwise specified above, or all soft effects if autocolor is disabled.



Project Items

shade project items

Item Labels
project bin
timeline

auto-adjust contrast

Item States
offline

error

freeze

comp not rendered
comp out of date
comp rendered
Item Colors

display in project
panel

display in sequence
panel

spreadsheet color
rows

USER GUIDE
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When enabled, additional shading is applied to source clips and shots in
the Project bin and timeline.

Click to change the color of labels in the Project and timeline panels. A
color wheel displays allowing you to select the required color.

When enabled, label colors are automatically adjusted if a potential color-
clash is detected.

Click the buttons to change the color of shots and comps in the timeline
panel. A color wheel displays allowing you to select the required color.

When enabled, the specified item colors, or defaults, are displayed in the
Project panel.

When enabled, the specified item colors, or defaults, are displayed in the
timeline panel.

When enabled, the specified item colors applied to rows in the
spreadsheet.
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Project Items

project Click the buttons to change the color of items in the Project and timeline
» panels. A color wheel displays allowing you to select the required color.
in

sequence

source

audio

comp

file types Allows you to add custom color-coding by file extension. Click the =
button and then select a file type from the extension dropdown. Double-
click the color swatch to display a color wheel allowing you to select the
required color.
Any source clip or shot with that extension is then colored accordingly in
the interface.

extension color

Scopes

black point Use the slider or the entry box to select the black point value.

white point Use the slider or the entry box to select the white point value.

luma/chroma Use this to select the video standard to use when converting from RGB to

encoding luma and chroma for scope display.

Include viewer color Select this checkbox to include applied Viewer color transforms (gain,

USER GUIDE
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Scopes
transforms gamma, and LUT) in scope data. If this checkbox is disabled, all Viewer
transforms are ignored.
Note: If disabled, rendering may become slow as image
calculation may be needed.
Force full frame Select this checkbox so that the Viewer always requests full frame data

when a scope is displaying data for that Viewer. If this checkbox is disabled,
the scopes only display data for the current area requested by the Viewer,
rather than the whole image.

Script Editor

font Use this to select the font to use in the Script Editor.

Note: This control also changes the font in the BlinkScript Kernel
Source field.

indent You can use this control to set the indent value to use when scripting.

save and restore script Disable this checkbox if you prefer that the contents of the Script Editor is
editor history not saved and restored between sessions of Hiero.

clear input window on  Disable this checkbox if you want the most recent script to remain in the

successful script input window after execution.
execution
Timeline
Highlight clones of When enabled, selecting a clone in the timeline highlights all clones
selected clone(s) associated with the selected clone.
USER GUIDE
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Timeline
Playhead

Show frame end
marker

Show buffer labels

Visible range follows
playhead

Audio Tracks

half waveforms

Viewer (Monitor Out)

use video legal range
for monitor out

always keep the
floating window on
top

Enable support for
HMD devices

Enable global monitor
out mode

Mouse Pointer Scale

Background

[background]

USER GUIDE
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When enabled, an extra line is drawn on the timeline to the right of the
playhead, indicating the end of the current frame.

When enabled, A/B labels are displayed on the buffer indicators at the
playhead if the buffers are enabled and have shots assigned.

When enabled, the timeline scrolls with the playhead, constantly updating
the view. When disabled, the playhead is allowed to move off screen.

When enabled, audio tracks on the timeline display only the rectified
waveform. When disabled, the full waveform is displayed.

When enabled, automatically limit monitor out to the legal range when
swapping between the Timeline environment and Compositing
environment.

When enabled, Hiero's internal floating monitor out window always
remains on top of other open application windows.

When enabled, VR headsets such as the Oculus Rift and HTC Vive are added
to the Monitor Out > Device dropdown. Choose the required headset from
the dropdown to pass the monitor out to the selected device.

Makes all viewers share the same monitor output, including node graph
and timeline viewers. Requires a restart to take effect.

Sets the size of the pointer displayed on the monitor when the Show
Pointer control is enabled for Nuke Studio monitor out.

Sets the background color used to fill Hiero's floating window when the
output is not full-frame:
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Viewer (Monitor Out)

* Black

* Gray - use the slider to the right to set the brightness of the plain
background.

* Checkerboard - use the slider to the right to set the brightness of the
checkerboard background.

NDI

Enable NDI When enabled, you can stream Viewer output over the local network from
the Monitor Out controls using NDI from NewTek.

Viewer

default flipbook Sets the default flipbook mode, Hiero's Flipbook Viewer or HeiroPlayer.

* Flipbook Viewer opens a new Viewer inside Hiero containing the
flipbooked content.

* HieroPlayer launches an instance of the application containing the
flipbooked content, but requires either a Nuke Studio or HieroPlayer
license.

playback mode Use this to set the Viewer playback mode:

* Play All Frames - the default setting, plays all frames in real-time
(dependent on hardware).

* Skip Frames - plays frames in real-time skipping where necessary to
maintain the frame rate.

* Play All Frames, Buffering - plays all frames by buffering and playing
frames back as they become available.

guides You can use this to choose to show overlays in the image area. You can
choose from:

* Title Safe - Indicates where text should be entered to be visible.

* Action Safe - Indicates the area in which to place actions so that they are
visible.

* Format - Displays the size of the format over the Viewer.

USER GUIDE
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Viewer

fullscreen display

see through missing

media

background

frame increment

filtering mode

Audio

default latency
adjustment (ms)

default volume

Viewer Handles
Controls

2D handle size

USER GUIDE
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Use this to select which display to use for fullscreen mode. This setting
takes effect the next time fullscreen mode is entered.

Select this checkbox to see through missing media in the timeline,
displaying the first displayable media in the underlying tracks.

Use this to select the Viewer background. You can select black, or gray
(using the slider to determine the grayscale), or checkerboard (using the
slider to determine the brightness).

Use this to set the default number of frames skipped by the Viewer skip
controls, and the timeline Nudge More commands.

Use this to determine the filtering used during rendering in the Timeline
environment. You can select Auto, Nearest neighbour, or Linear.

Auto uses ths same automatic selection as in the Compositing
environment. This does not affect exports or rendering in the Compositing
environment.

Use this to adjust the default timing offset (in milliseconds) between audio
and video to apply to new Viewers. Positive values make audio play earlier
relative to video; negative values make audio play later. To convert from
video frames to ms, divide 1000 ms by the video frame rate. For example:
* at 25fps, a video frame is 1000/25 = 40ms, or

*a 1.5 video frame delay = 1.5 * 40ms = 60ms.

Use the slider or numeric field to set the default volume.

Adjust the size of the square control handles that appear on the Viewer for
some operations, such as transformations, warps, and Bezier and B-spline
shapes.
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Viewer Handles

By default, this value is set to 5. You can also set the pickable area size of
the square control handles in the numeric field or slider to the right of the
2D handle size control.

USER GUIDE
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Appendix B: Keyboard Shortcuts

This page lists the keyboard shortcuts used by Hiero and HieroPlayer, along with their function. In
general, contiguous areas of the keyboard are assigned to related functionality. The left-hand keys on
a QWERTY keyboard are used for tool selection and actions, the right-hand side for playhead
manipulation including source/record and insert/overlay, the arrow keys for selection and nudging,
and the numeric pad for timecode entry.

Playhead
Editerial Tools Manipulation
and Marking

Selection, Nudging,
and Timecode Entry

Hotkeys Button Menubar Function

Timeline and Editing Controls

Q - n/a Cycles between the available move tools:
* Multi Tool
* Move/Trim
* Select
W - n/a Cycles between the available selection tools:

* Select Track to Right/Left
* Select All in Track
* Select All Tracks Right/Left

Note: Holding Alt toggles between
track and all tracks behavior.



Hotkeys

E

left-click

Alt + left-click

Shift + drag
shot

left-click then
Shift + left-click

drag then Alt
Alt then drag
Alt and drag

Alt and left-
click

Ctrl/Cmd + A

Ctrl/Cmd +
Shift + A

File Menu

Ctrl/Cmd +

USER GUIDE

Button

n/a

n/a
n/a
n/a

n/a
n/a
n/a

n/a

n/a

n/a

n/a

Menubar

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a
n/a
n/a

n/a

n/a

n/a

File > New Project

Appendix B: Keyboard Shortcuts |

Function

Cycles between the Slip Clip and Slide Clip
tools.

Cycles between the available edit tools:
* Roll Edit

* Ripple Edit

* Retime Clip

Cycles between the available razor tools:
* Razor
* Razor All

*Join
Select a clip including any linked tracks.

Select a clip, ignoring linked tracks (for
example, audio only).

Insert a new track

Select all clips between the left-clicks (use
Shift + Alt + left-click to ignore linked tracks).

Activate Ripple mode while dragging the shot.
Duplicate the dragged shot.
Ripple and duplicate the dragged shot.

Select a clip, ignoring linked tracks.
Select all shots.

Deselect all shots.

Open a new project.
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Hotkeys
Shift + N
Ctrl/Cmd + O

Alt + Shift +
<num>

Ctrl/Cmd + W
Ctrl/Cmd + S

Ctrl/Cmd +
Shift + S

Ctrl/Cmd + |

Ctrl/Cmd +
Shift + |

Ctrl/Cmd + Alt
+ Shift + |

Ctrl/Cmd +
Shift + E

Ctrl/Cmd +Q

Edit Menu
Ctrl/Cmd + Z

Ctrl/Cmd +
Shift +Z

Ctrl/Cmd + X

Ctrl/Cmd + C
Ctrl/Cmd +V

Backspace /

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

File > Open

File > Open Recent >
Project Name

File > Close
File > Save

File > Save As...

File > Import Clips
File > Import Folder
File > Import
EDL/XML

File > Export

File > Quit

Edit > Undo

Edit > Redo

Edit > Cut

Edit > Copy
Edit > Paste

Edit > Delete

Appendix B: Keyboard Shortcuts |

Function

Open an existing project.

Open a previously saved project from the list.

Close the current project.
Save the current project.

Save the current project with a different
name.

Import a clip or clips.

Import a folder or folders.

Import an EDL or XML sequence.

Export the selected sequence.

Close Hiero and display a prompt to save any
unsaved work.

Undo the last action.

Redo the last undo action.

Cut the selected item(s) and place in the
buffer.

Copy the selected item(s) to the buffer.
Paste item(s) from the buffer.

Delete selected item(s).
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Hotkeys
Delete
Ctrl/Cmd + A

Ctrl/Cmd +
Shift + A

Ctrl/Cmd + D
Shift + S
Viewer Menu

Ctrl/Cmd +
Shift + 1

Ctrl/Cmd +
Shift + 2

H

F
+

- (minus)
Ctrl/Cmd +F

Ctrl/Cmd +
Shift + F

Esc

E

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

Edit > Select All

Edit > Clear Selection

Edit > Duplicate

Edit > Preferences

View > Zoom to
Actual Size

View > Zoom to Half
Size

View > Zoom to Fill

View > Zoom to Fit
View > Zoom In
View > Zoom Out
View > Full Screen

View > Full Quality
1:1

n/a

View > Clipping
Warning

View > Mark In

View > Mark Out

Appendix B: Keyboard Shortcuts |

Function

Select all files in the current bin.

Deselect all files in the current bin.

Duplicate the selected object(s).

Open the Preferences dialog.

Zoom the contents of the Viewer to actual
size.

Zoom the contents of the Viewer to half size.

Fit the current clip to the height or width of
the Viewer, depending on the clip's format.

Zoom to fit the clip to the Viewer.
Zoom in to the Viewer.

Zoom out of the Viewer.

Toggle Full Screen mode.

Toggle Full Screen mode at Full Quality 1:1
zoom.

Exit full screen mode.

Toggle the Level Warning tool on and off.

Set the In Point at the current frame.

Set the Out Point as the current frame.
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Hotkeys

Alt + 1

Alt+ 0O

Alt+U

Home

End

Shift + |

Shift + O

&

(K+)J)
9

(K+1)

Shift + &

Shift + >

Alt + €&

Alt+->

Alt + Shift +<

Alt + Shift + >

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

View > Clear In Point

View > Clear Out
Point

View > Clear In and
Out Points

View > Go to Start

View > Go to End

View > Go to In Point

View > Go to Out
Point

View > Frame
Backwards

View > Frame
Forwards

View > Skip
Backwards

View > Skip Forwards

View > Previous Edit

View > Next Edit

View > Previous Tag

View > Next Tag

Appendix B: Keyboard Shortcuts |

Function

Clear the In point for the current clip or
timeline.

Clear the Out point for the current clip or
timeline.

Clear the In and Out points for the current clip
or timeline.

Go to the start of all clips.

Go to the end of all clips.

Go to the In Point in the current clip.

Go to the Out Point in the current clip.

Skip one frame backwards.

Skip one frame forwards.

Skip backwards by the frame increment value
specified in the Viewer tools.

Skip forwards by the frame increment value
specified in the Viewer tools.

Go to the previous clip in the Viewer.

Go to the next clip in the Viewer.

Go to previous frame tag.

Go to next frame tag.
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Hotkeys

Space

Enter (numeric
pad)

Ctrl/Cmd +

Shift + P

Ctrl/Cmd +/

Return
(main
keyboard)

R, G BAY

PgUp

PgDn

USER GUIDE

Button

n/a

n/a
n/a

n/a

RGB _

n/a

n/a

n/a

/A

Menubar

View > Play

View > Play Backward

View > Pause

View > Play Forward

View > Edit Playhead
Time

View > Ignore Pixel
Aspect

Show Timeline Editor

View > Swap Inputs

View > Channels

n/a

PgDn
View > Show Overlays

View > Toggle
SplitWipe

Appendix B: Keyboard Shortcuts |

Function

Play the clip or sequence currently in the
Viewer.

Play clip or sequence currently in the Viewer
backward (click multiple times to increase
playback speed).

Pause playback.

Play clip or sequence currently in the Viewer
forward (click multiple times to increase
playback speed).

Shift focus to the timecode field under the
Viewer, allowing you to manually edit the
playhead position.

Display the clip in the Viewer with a 1:1 aspect
ratio.

Display the timeline pane, if it is not already
visible.

Controls the AB inputs:

* Stack - swaps which input is visible.

* Horizontal - swaps the inputs horizontally.
* Vertical - swaps the inputs vertically.

Set the Viewer output channel.

Scroll up and down through available layers in
the Viewer.

n/a
Toggle the HUD overlays.

Toggle the SplitWipe compare mode on and
off.
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Hotkeys
Cache Menu

F12

Window Menu

Alt+S

Ctrl/Cmd + Alt
+ Shift +
(backtick)

Ctrl/Cmd + Alt
+ ' (backtick)

Ctrl/Cmd +
Shift + [

Ctrl/Cmd +
Shift + ]

Shift + F1

Shift + F2

Shift + F3

Shift + F4

Shift + F<knum>

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

Cache > Clear
Playback Cache

Window > Toggle
Fullscreen

n/a

n/a

n/a

n/a

Window > Workspace
>

Conforming/Editing

Window > Workspace
>

Editing/Flipbook

Window > Workspace
> Reviewing

Window > Workspace
> Timeline

Window > Workspace

Appendix B: Keyboard Shortcuts |

Function

Click to clear the frames stored in the
playback cash, represented by the green bar
under the Viewer playhead.

Expand the interface to fill the available
screen space.

Cycle backwards through all current panes.

Cycle forwards through all current panes.

Jump between tabs in the current pane.

Ctrl/Cmd + Shift + ]

Switch to Hiero's Conforming workspace or
HieroPlayer's Editing workspace.

Switch to Hiero's Editing workspace or
HieroPlayer’s Flipbook workspace.

Switch to the Reviewing workspace.

Switch to the Timeline workspace.

Switch to the custom workspace associated
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Hotkeys

Project Menu
Ctrl/Cmd + B

Ctrl/Cmd +Y

Ctrl/Cmd + N

Clip Menu

Ctrl/Cmd +
Return

(main
keyboard)

Ctrl/Cmd + Alt
+ Return

(main
keyboard)

A

Alt+D

Alt + N

Alt +

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

> Custom Workspace
Name

Project > New Bin

Project > New Tag

Project > New
Sequence

Clip > Open In >
Viewer

Clip > Open In > New
Viewer

Clip > Open In >
Viewer Input A

Clip>Open In>
Viewer Input B

Clip>Open In>
Metadata View

Clip > Hide Version

Clip > Version Up

Clip > Version Down

Appendix B: Keyboard Shortcuts |

Function

with the number selected.

Create a new bin in the current bin.

Create a new tag in the current bin (tags can
only be created in the Tags tab).

Create a new sequence in the current bin.

Open the selected clip in the Viewer.

Open the selected clip a new Viewer.

Open the selected clip in Viewer input A.
Open the selected clip in Viewer input B.
Open the metadata view for the selected clip.
Hide the currently selected version(s) of a clip
in the Versions Bin view.

Cycle up through the available clip versions.

Cycle down through the available clip
versions.
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Hotkeys

Alt + Shift +

Alt + Shift +

F8

Alt + F5

Timeline Menu

Shift + U

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar

Clip > Max Version

Clip > Min Version

Clip > Select Version

Clip > Refresh Clips

Clip > Rescan Clip
Range

Clip > Insert

Clip > Overwrite

Timeline > Mark
Selection

Timeline > Mark Clip

Timeline > Razor

Appendix B: Keyboard Shortcuts |

Function

Jump to the maximum known version or scan
for new versions if the max version is already
reached.

Jump to the minimum known version or scan
for new versions if the min version is already
reached.

Display the available versions of a source clip
or sequence.

Reload the source clip or shot when the
source file location has not changed, such as
when work has been done on the clip offline.
Selecting refresh only refreshes the source
clip’s current frame range.

Similar to Refresh Clips, above, but rescan
also checks for additional frames that may
have been added to the source clip and adds
them to the shot's frame range.

Insert the contents of a source Viewer into the
timeline at the current playhead position and
ripple existing shots downstream to
accommodate the change.

Insert the contents of a source Viewer into the
timeline at the current playhead position
overwriting existing shots.

Place the In and Out markers around the
selected shot or shots on the timeline.

Place the In and Out markers around the
upper-most timeline clip under the current
playhead position.

Apply the Razor tool to the currently selected
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Hotkeys

Shift + C
Shift +

Backspace

Ctrl/Cmd+T

Ctrl/Cmd + Alt
+A

, (comma)

. (period)

Shift +,
(comma)

Shift +.
(period)

Alt +, (comma)

Alt + . (period)

USER GUIDE

Button

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

n/a

Menubar
Selected

Timeline > Razor All

Timeline > Ripple
Delete

Timeline > Transition
> Dissolve

n/a

Timeline > Select All
in Track

Timeline > Nudge >
Nudge Left

Timeline > Nudge >
Nudge Right

Timeline > Nudge >
Nudge Left More

Timeline > Nudge >
Nudge Right More

Timeline > Nudge >
Nudge Up

Timeline > Nudge >
Nudge Down

Appendix B: Keyboard Shortcuts |

Function
track(s) within the selected clip(s).

Apply the Razor tool to all tracks within the
selected clip(s).

Remove the selected clip(s) and ripple clips
down stream to close gaps in the timeline.

Add a dissolve between two selected shots.

Enable or disable the selected clip(s) or track
(s).

Select all the shots on the current track.

Trim, roll, or nudge a selected transition or
shot to the left (within the available handles
for trim and roll).

Trim, roll, or nudge a selected transition or
shot to the right (within the available handles
for trim and roll).

Trim, roll, or nudge a selected transition or
shot to the left by the frame increment value
specified in the Viewer tools (within the
available handles for trim and roll).

Trim, roll, or nudge a selected transition or
shot to the right by the frame increment value
specified in the Viewer tools (within the
available handles for trim and roll).

Nudge the selected shot(s) up one track.

Nudge the selected shot(s) down one track,
where possible.
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Hotkeys Button

Ctrl/Cmd + Alt  n/a
+S

Alt + Shift +/ n/a

Viewer Controls

Alt + left-click + n/a
drag

(middle-click
and drag on
Linux)

Scroll wheel n/a

(over Viewer or
Viewer
timeline)

Scroll wheel n/a

middle-click +
drag

(over Viewer
timeline or
timeline)

Scroll wheel n/a

Alt + middle-
click + drag

(over Viewer or
timeline)

middle-click n/a

(over Viewer
timeline or

USER GUIDE

Menubar

Timeline > Audio
Scrubbing

Timeline > Rename
Shots

n/a

n/a

n/a

n/a

n/a
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Function

Enable or disable audio scrubbing.

Display the Rename Shots dialog for the
selected shots.

Pan the contents of the Viewer.

Zoom the Viewer or Viewer timeline.

Zoom the Viewer timeline to the indicated
frame range.

Zoom the contents of the Viewer or timeline.

Zoom to fit the Viewer timeline to Viewer
contents.
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Hotkeys Button Menubar

timeline)

Alt + close n/a

Viewer

Spreadsheet Controls

Alt + left-click n/a n/a
Alt + double n/a n/a
left-click

Alt + close n/a
Spreadsheet

Bin View Searchbox Controls
left-click n/a n/a
Ctrl/Cmd + n/a n/a
left-click

Shift + left-click n/a n/a

Script Editor Controls

Ctrl/Cmd + [ - n/a
Ctrl/Cmd +] - n/a
Ctrl/Cmd + n/a
Enter

USER GUIDE
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Function

Note: If your mouse preferences
are not set to Button 3 for the
middle mouse button, you may have
to use Ctrl/Cmd + middle-click.

Close only the selected tab. Clicking close
without holding Alt closes any linked tabs as
well.

Move the playhead to the selected clip’s In
point on the timeline.

Move the playhead to the selected clip’s In
point on the timeline and zoom to fit the clip
in the timeline view.

Close only the selected tab. Clicking close
without holding Alt closes any linked tabs as
well.

Select a tag search criteria.

Toggle select individual tag search criteria.

Select a range of tag search criteria.

Go to the previous script.

Go to the next script.

Execute current script.
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Hotkeys Button Menubar Function
Ctrl/Cmd + n n/a Clear the output pane.
Backspace

USER GUIDE
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Appendix C: Supported File and
Camera Formats

Supported File Formats

The following table lists the supported file formats. The extensions listed under Extension let you
specify the image format; use these as the actual file name extensions or the prefix to indicate output
format for the image sequences.

Format Bit Depths Read/Write Extension Notes
Apple ProRes 10,12 read and write mov Support for the
following:

* Apple ProRes
4444 XQ 12-bit

* Apple ProRes
4444 12-bit

* Apple ProRes
422 HQ 10-bit

* Apple ProRes
422 10-bit

* Apple ProRes
422 LT 10-bit

* Apple ProRes
422 Proxy 10-bit

ARRIRAW 12 read only ari Alexa Mini LF

Codex arx Codex HDE
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Format Bit Depths Read/Write Extension Notes
Camera/Sensor Nuke 13.2 Nuke 14.0 Nuke 14.1 Nuke
15.0

ARRIRAW SDK v6.2.3.0 v7.0.0 v6.2.3.0 v7.0.0 v6.2.3.0 v8.0.0 v8.0.0

(.ari, .arx, and

.mxf)

CodexHDE SDK 4.0.2 - 4.0.2 - 4.0.3 4.0.3 4.0.3

CUDA GPU [ ] o o o o o ]

Support

ALEXA 35 - [ ] - ] - o ]

ALEXA Mini LF ® - @ - ® - o

ALEXA LF o - ® ; ® - ®

ALEXA SXT(W) [ ] = o - ® - o

ALEXA Mini [ ] - ® - [ ] - ]

ALEXA 65 ® - @ - ® - o

ALEXA XT o - ® ; ® - ®

ALEXA Studio [ ] = ® - ® - o

ALEXA Classic [ ] - ] - [ ] - ]

AMIRA ® - @ - ® - o

Note: Nuke, Nuke Studio, and Hiero do not
support .mxf from the AMIRA camera.
AVI n/a read and write avi On Windows, the

AVI reader uses
DirectShow
multimedia

USER GUIDE
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Format

BRAW
CIN

DNG

DPX

GIF

Radiance

JPEG

USER GUIDE

Bit Depths

12
10 (log)

8,12

8,10,12,and 16

16

Appendix C: Supported File and Camera Formats |

Read/Write

read
read and write

read

read and write

read only

read and write

read and write

Extension

braw
cin

dng

dpx

gif
hdr, hdri

jpg. jpeg

Notes

architecture.
When decoding
.avi files,
DirectShow tries
to find the
appropriate codec
on the system. If
the codec is not
available, .avi files
cannot be
opened.

Includes RAW 2.5K
CinemaDNG

YCbCr encoded
DPX files are not
supported on the
timeline.

This format stores
an 8-bit mantissa
for each of r, g,
and b and an
additional 8-bit
exponent thatis
shared by all
three, which packs
the floating point
RGB triplet into 32
bits per pixel.

Adjust
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Format

MOV

USER GUIDE

Bit Depths

n/a

Appendix C: Supported File and Camera Formats |

Read/Write

read and write

Extension

mov

Notes

compression
levels using the
quality slider in
the Write node’s
properties panel.

The writer
supports the
following codecs:

* Animation

* Apple ProRes
4444 XQ 12-bit

* Apple ProRes
4444 12-bit

* Apple ProRes
422 HQ 10-bit

* Apple ProRes
422 10-bit

* Apple ProRes
422 LT 10-bit

* Apple ProRes
422 Proxy 10-bit

* Avid DNxHD 444
10-bit 440Mbit

* Avid DNxHD 422
10-bit 220Mbit

* Avid DNxHD 422
8-bit 220Mbit

* Avid DNxHD 422
8-bit 145Mbit

* Avid DNxHD 422
8-bit 36Mbit
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Format Bit Depths Read/Write Extension Notes

Note:
Interlace
d writing
is not
supporte
d. See
Avid
DNxHD
Notes for
more
informati
on.

e Avid DNxHR:
* 8-bit 4:2:2
DNxHR LB,

DNxHR SQ,
and DNxHR

HQ
. 12-bit
DNxHR HQX

422 and
DNxHR 444

* H.264 Main 4:2:0
8-bit

* H.264 High 4:2:0
8-bit

* Motion JPEG A

* Motion JPEG B

* MPEG-4

* Photo - JPEG

* PNG

* Uncompressed

USER GUIDE
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Format

MXF

USER GUIDE

Bit Depths

8,10,12

Read/Write

write only

read only
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Extension

mov

mxf

Notes

DNxHR Pattern:
OP-1A, OP-Atom

Profiles:

* 4:4:4 12-bit

*« HQX 4:2:2 12-bit
* HQ 4:2:2 8-bit
*SQ 4:2:2 8-bit
LB 4:2:2 8-bit

Supported codecs
include:

* Uncompressed
4:2:2 YCbCr 8-
/10-bit

* Uncompressed
4:4:4:4 RGBA 8-
/10-bit

* Uncompressed
Avid 4:2:2 YCbCr
8-/10-bit

* Uncompressed
Avid 4:4:4:4
RGBA 8-/10-bit

* JPEG2000

* Avid DNxHD
(1080p and 720p
1920x1080 and
1280x720,
4:4:4:4 and 4:2:2)
36, 115, 120,
145,175, 185,
220, 220x
See Avid DNxHD
Notes for more
information.
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Format

USER GUIDE

Bit Depths Read/Write

write only
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Extension

mxf

Notes

* Avid DNxHR:

* 8-bit 4:2:2
DNxHR LB,
DNxHR SQ,
and DNxHR
HQ

* 12-bit
DNxHR HQX
422 and
DNxHR 444

* Sony Raw from
the F65, F55, F5
and FS700
cameras. All
formats that
these cameras
provide: 4K, 2K,
1K, 0.5K and
0.25K

* Sony X-OCN
from the VENICE,
F55, and F5
cameras.

* ARRIRAW from
the Alexa Mini.

DNxHD Pattern:
OP-1A, OP-Atom

Profiles:

* HQX 4:4:4 10-bit
* HQX 4:2:2 10-bit
* HQ 4:2:2 8-bit
*SQ 4:2:2 8-bit

* LB 4:2:2 8-bit
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Format Bit Depths
Camera/Sensor Nuke 13.2
SONY SDK (.mxf) v3.3
SONY SMDK v4.19.0
GPU Support o
VENICE 2 -
VENICE ®
F55 @
F5 @
F65 [ _
FS700 ®

Avid DNxHD Notes

The bit rates listed in the Codec Profile dropdown are the bit rates for 1080p at 29.97 fps EXCEPT
for 36 fps (which is actually 45 Mbps @ 29.97fps). You should look at the codec format (422/444,

8/10-bit).

Read/Write

Nuke 14.0
v4.0.0
v4.21.0
o

® ¢ ¢ ¢ ¢ o

Appendix C: Supported File and Camera Formats |

Nuke 14.1  Nuke 15.0

v4.0.0 v4.0.0
v4.21.0 v4.21.0

® @

® ®

® ®

® o

® @

® ®

® ®

Extension

Notes

DNxHR Pattern:
OP-1A, OP-Atom

Profiles:

e 4:4:4 12-bit

*« HQX 4:2:2 12-bit

* HQ 4:2:2 8-bit
* SQ 4:2:2 8-bit
* LB 4:2:2 8-bit
Nuke 15.1
v5.0.0

v4.24.0

®

® ¢ ¢ & ¢ o

Note: Hiero only supports 1080p and 720p. Non-HD resolutions are scaled to 1080p

before writing.

USER GUIDE
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Format Bit Depths Read/Write Extension Notes

This leads to a set of 1080p bit rates:

+ 1080p/29.97 440x, 220x, 220, 145, 45

* 1080p/60 N/A, N/A, 440, 290, 90 (same at 59.94)

+ 1080p/50 N/A, N/A, 367, 242, 75

+ 1080p/25 365x, 185x, 185, 120, 36

+ 1080p/24 350x, 175x%, 175, 115, 36 (same at 23.976)

At 720p, the Codec Profile dropdown has a different interpretation. The bit rate is taken as the bit
rate at 720p at 59.94fps. This leads to another set of bit rates:

+ 720p/59.94 N/A, 220x, 220, 145, N/A
+ 720p/50 N/A, 175x%, 175, 115, N/A

* 720p/29.97 N/A, 110x, 110, 75, N/A
*+ 720p/25 N/A, 90x, 90, 60, N/A

*+ 720p/23.976 N/A, 90x, 90, 60, N/A

Note: Since the bit rates are for 1080p at 29.97 fps AND 720p at 59.94 fps (except for 36
Mbit which should read 45 Mbit). It is possible to calculate the bandwidth for all the other
frame rates by:

BandWidth@1080p = fps/29.97 * NominalBandWidth, or

BandWidth@720p = fps/59094 * NominalBandWidth

where NominalBandWidth is the bandwidth listed in the codec profile knob OR 45 if the
bandwidth listed is 36 Mbit. (Avid labels the codec profile names by the approximate
bandwidth.)

OpenEXR 16, 32 read and write exr OpenEXR handles
16- and 32-bit

and float. This 16 is

OpenEXR 3.2.1 also called "half
float" and is
different from the
16-bit integer that
all the other
formats that
support 16-bit

USER GUIDE
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Format Bit Depths Read/Write Extension Notes
use.

Hiero supports
multi-part
OpenEXR files. For
more information,
see the Hiero User
Guide.

EXR Compression

EXR file metadata contains a compression key/value pair detailing the compression type used to
write the .exr file. The value is expressed as the name of the compression type or an integer
referencing the compression used:

0 - no compression

1 - RLE compression, run length encoding

2 - Zip compression, one scan line at a time

3 - Zip compression, in blocks of 16 scan lines

4 - PIZ-based wavelet compression, in blocks of 32 scan lines

5 - PXR24 compression, lossy 24-bit float

6 - B44 compression, lossy 4-by-4 pixel block, fixed rate

7 - B44A compression, lossy 4-by-4 pixel block, flat fields are compressed more
8 - DWAA compression, lossy DCT based compression, in blocks of 32 scan lines

9 - DWAB compression, lossy DCT based compression, in blocks of 256 scan lines

PIC 8 read and write pic
Softimage®
PNG 8,16 read and write png (8-bit)

png16 (16-bit)

USER GUIDE
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Format

PSD

R3D

Camera/Sensor
R3D SDK (.r3d)

CUDA GPU
Support

V_RAPTOR XL
V-RAPTOR
KOMODO
MONSTRO 8K W
HELIUM 8K S35

SCARLET-W 5K

USER GUIDE

Bit Depths

8,16

16

Nuke 13.2

v8.0.4

o

® 6 0 ¢

Read/Write

read only

read only

Nuke 14.0
v8.3.0
[ _

® 6 ¢ 0 ¢ ¢
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Extension
psd
r3d
Nuke 14.1  Nuke 15.0
v8.3.0 v8.3.0
@ @
@ o
® ®
@ @
@ @
@ o
® ®

Notes

While Hiero reads
standard
Photoshop®
blend modes, it
doesn't read
Photoshop layer
comps or
recognize group
blend modes.
Photoshop layers
are read into
separate Hiero
layers and
anything that
doesn't map into
that is ignored.

Nuke 15.1
v8.4.0
®

® 6 ¢ 0 ¢ ¢
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Format Bit Depths
Camera/Sensor Nuke 13.2
RED RAVEN 4.5K L
WEAPON ®
DRAGON 6K
EPIC/SCARLET ®
DRAGON
RED ONE ®
MYSTERIUM 4K
MYSTERIUM-X ®
MYSTERIUM-X ®
MONOCHROME

RAW n/a

RLA 8

Wavefront®

USER GUIDE

Read/Write

Nuke 14.0

®
®

read only

read only

Appendix C: Supported File and Camera Formats |

Nuke 14.1

@
@

Extension

n/a

rla

Nuke 15.0

o
®

Notes

Nuke 15.1
@

®

®
®

DSLR raw data
files, such as
Canon .CR2 files.
These are only
supported via the
dcraw command
line program,
which you can
download from
the dcraw
website. Bit depth
and other
specifications
depend on the
device. Some
devices may not
be supported.
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Format Bit Depths Read/Write Extension Notes

SGI 8,16 read and write sgi, rgb, rgba (8-
bit sequences)

sgi16 (for 16-bit

sequences)
TIFF 8,16, and 32 read and write tif, tiff (8-bit If utilized, the
sequences) compression

schema on
imported TIFF
sequences must

®
feif, feiff 32-bit ~~ PELZWT.

tif16, tiff16 (16-bit
sequences)

sequences)

TARGA 8 read and write tga, targa

Truevision®

XPM 8 read and write Xpm This is the text-
based format in
which Hiero’s
interface elements
are stored.

YUV 8 read and write yuv This format does
not specify

resolution, so
Hiero assumes a
width of 720
pixels.

If the application can't find a suitable reader when reading source clips from disk, the following paths
are searched for fallback .dylib, .so, and .dll readers compiled against the comparable Hiero version:

Mac:

* /$HOME/.nuke

USER GUIDE
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* /Library/Application Support/Nuke/x.x/plugins/

Linux:

* /$HOME/.nuke
* /usr/local/Nuke/x.x/plugins/

Windows:

*\$HOME\.nuke
* C:\Program Files\Common Files\Nuke\x.x\plugins\

* C:\Program Files (x86)\Common Files\Nuke\x.x\plugins\

Note: You can also add your own search paths using the NUKE_PATH environment variable.
See Setting Environment Variables for more information.

USER GUIDE
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Supported Audio Formats

The following table lists supported audio formats.

Format Name

Audio only formats

All platforms

Wave

Audio interchange format
Audio Codec 3

MPEG 1 Audio Stream
Mac and Windows

MPEG 4 Audio
Integrated audio formats
RED Audio

QuickTime Audio

Extension

wav

aiff

ac3

m4a

r3d

mov

Supported Audio Formats |



Appendix D: Third-Party Software

Third-Party Contributions

The following table lists third-party contributions included in Hiero, along with their licenses.

Contributor

Pixar

Description

DTEX file
reader

License
Copyright © Pixar. All rights reserved.

This license governs use of the accompanying software. If you use
the software, you accept this license. If you do not accept the
license, do not use the software.

1. Definitions

mnn

The terms "reproduce,” "reproduction," "derivative works," and
"distribution" have the same meaning here as under U.S. copyright
law. A "contribution" is the original software, or any additions or
changes to the software.

A "contributor" is any person or entity that distributes its
contribution under this license. "Licensed patents" are a
contributor's patent claims that read directly on its contribution.

2. Grant of Rights

(A) Copyright Grant- Subject to the terms of this license, including
the license conditions and limitations in section 3, each contributor
grants you a non-exclusive, worldwide, royalty-free copyright
license to reproduce its contribution, prepare derivative works of
its contribution, and distribute its contribution or any derivative
works that you create.

(B) Patent Grant- Subject to the terms of this license, including the
license conditions and limitations in section 3, each contributor
grants you a non-exclusive, worldwide, royalty-free license under
its licensed patents to make, have made, use, sell, offer for sale,



Contributor

USER GUIDE

Description
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License

import, and/or otherwise dispose of its contribution in the
software or derivative works of the contribution in the software.

3. Conditions and Limitations

(A) No Trademark License- This license does not grant you rights to
use any contributor's name, logo, or trademarks.

(B) If you bring a patent claim against any contributor over patents
that you claim are infringed by the software, your patent license
from such contributor to the software ends automatically.

(C) If you distribute any portion of the software, you must retain all
copyright, patent, trademark, and attribution notices that are
present in the software.

(D) If you distribute any portion of the software in source code
form, you may do so only under this license by including a
complete copy of this license with your distribution. If you
distribute any portion of the software in compiled or object code
form, you may only do so under a license that complies with this
license.

(E) The software is licensed "as-is." You bear the risk of using it. The
contributors give no express warranties, guarantees or conditions.
You may have additional consumer rights under your local laws
which this license cannot change.

To the extent permitted under your local laws, the contributors
exclude the implied warranties of merchantability, fitness for a
particular purpose and non-infringement.
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Third-Party Libraries and Fonts

Note: If, for any reason, you think Foundry is not entitled to use these libraries and fonts,
please visit support.foundry.com.

Third-Party Library Versions

The following table lists third-party libraries included in the application and their current version. This
version of Nuke is compliant with VFX Reference Platform 2024.

Note: We use the ARRI IMAGE 8.0 SDK for ALL ARRI RAW files. The result of this is that there
will be changes in image for all legacy ARRI RAW files when a project from 14.0 or earlier is
opened using Nuke 15.0.

These changes will mean that in Nuke 15.0 all ARRI RAW files will match the output from the
ARRI Reference tool. However, it also means that any images included in scripts moved in
this way will be different. Notably the aspect ratio may change, the Format know entry may
change, and there may be color changes and precision changes due to changes to the
debayer settings.

Version
Library Linux Mac Windows
AAF 1.2.0 1.2.0 1.2.0
ACES 1.3 1.3 1.3
AJA 16.2.2 16.2.2 16.2.2
Alembic 1.8.6 1.8.6 1.8.6
ARRI RAW SDK N/A N/A N/A
ArriMXF 3.0.0.10 3.0.0.10 3.0.0.10

ARRI Image SDK 8.0.0 8.0.0 8.0.0


https://support.foundry.com/

Library

Blackmagic RAW SDK

Blosc

BMD Decklink SDK

Boost
Breakpad
bzip
cIFFT_AMD
Clang
CodexHDE SDK
cppunit
Ctypes
CUDA
cuDNN
Curl
DirectX

DNG SDK

DNxHD and DNxHR

EuCon
Expat
FBX
FFmpeg

FFTW

USER GUIDE

Linux

2.2

1.14.3

12.4.2

1.82

r1338

1.0.6

2.14.0

N/A

4.0.3

1.12.1

1.0.2

11.8.0

8.4.1

8.5.0

N/A

1.6

2.7.3

N/A

2.5.0

2020.3.1

6.1.1

3.1.3
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Version
Mac
2.2
1.14.3
12.4.2
1.82
r1338
1.0.6
2.14.0
10.2.1
4.0.3
1.12.1
1.0.2
N/A
N/A
8.5.0
N/A
1.6
2.7.3
255
2.5.0
2020.3.1
6.1.1

3.1.3

Windows
2.2
1.14.3
12.4.2
1.82
r1338
1.0.6
2.14.0
N/A
4.0.3
1.12.1
1.0.2
11.8.0
8.4.1
8.5.0
Jun10
1.6
2.7.3
N/A
2.5.0
2020.3.1
6.1.1

3.1.3
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Library
Flatbuffers
fmt
FreeType
FTGL

GCC
GLEW
googletest
gperftools
HDF
HIDAPI
imath
Intel Libraries
Intel MKL
Intel TBB
JPEG

JWT
Libexif
Libpng
libsndfile
Libtiff
Libusb

libuv

USER GUIDE
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Linux
23.5.26
8.1.1

2.13.2

11.2.1
1.13.0
1.12.1
2.10
5.1.8.7
0.13.1
3.1.6
N/A
2020.4
2020 Update 3
%e
0.4.0
0.6.24
1.4.8
1.0.31
4.6.0
1.0.26

1.47.0

Version
Mac
23.5.26
8.1.1

2.13.2

N/A
1.13.0
1.12.1
2.10
5.1.8.7
N/A
3.1.6
N/A
2020.4
2020 Update 3
%e
0.4.0
0.6.24
1.4.8
1.0.31
4.6.0
N/A

1.47.0

Windows
23.5.26
8.1.1

2.13.2

N/A
1.13.0
1.12.1
2.10
5.1.8.7
N/A
3.1.6
N/A
2020.4
2020 Update 3
%e
0.4.0
0.6.24
1.4.8
1.0.31
4.6.0
N/A

1.47.0
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Library

LLVM

Mesa

MoltenVK
Murmur3
Nablet

NDI SDK
nlohman
Oculus Rift SDK
OFX

OpenAssetlO

OpenAssetlO-MediaCreation

OpenCL

OpenColorlO

OpenColorlOConfigs

OpenEXR
OpenHMD
OpenimagelO
OpenJPEG
OpenSSL
OpenSubDiv
OpenTimelinelO

OpenVDB

USER GUIDE
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Linux

13.0.0

N/A

N/A

20150501

2.50.4

55.2

3.9.1

N/A

1.2

1.0.0-rc.1.0

1.0.0-alpha.10

2021.7.1

2.3.1

1.0.3

3.2.1

0.3.0

2.5.7.0

1.5.0

3.0.13

3.6.0

0.15.0

11.0.0

Version
Mac
13.0.0
24.0
1.2.8
20150501
2.50.4
5.5.2
3.9.1
N/A
1.2
1.0.0-rc.1.0
1.0.0-alpha.10
N/A
2.3.1
1.0.3
3.2.1
N/A
2.5.7.0
1.5.0
3.0.13
3.6.0
0.15.0

11.0.0

Windows
13.0.0
N/A

N/A
20150501
2.50.4
5.5.2
3.9.1
1.15.0

1.2

1.0.0-rc.1.0

1.0.0-alpha.10

2021.7.1

2.3.1

1.0.3

3.2.1

N/A

2.5.7.0

1.5.0

3.0.13

3.6.0

0.15.0

11.0.0
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Library
OpenVR
picojson

PNG
PoissonRecon
PortAudio
Primatte
ProResCodec
Protobuf
pybind11
psutil

Ptex

PyString
Python
PyTorch
PyZMQ

Qt

Qt for Python (PySide6)

Note: Shiboken is part
of PySide and uses the
same version.

QtSingleApplication

USER GUIDE
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Linux

1.2.10

1.3.0

1.6.40

V2

19.7.0

5.0.2023

2021.01.29

25.2

2.9.2

5.8.0

2.4.x

1.1.0

3.11.7

2.1.1

19.0.2

6.5.3

6.5.3

2.6.0

Version
Mac
N/A
1.3.0
1.6.40
V2
19.7.0
5.0.2023
N/A
25.2
2.9.2
5.8.0
2.4.x
1.1.0
3.11.7
2.1.1
19.0.2
6.5.3

6.5.3

2.6.0

Windows

1.2.10

1.3.0

1.6.40

V2

19.7.0

5.0.2023

2021.01.29

25.2

2.9.2

5.8.0

2.4.x

1.1.0

3.11.7

2.1.1

19.0.2

6.5.3

6.5.3

2.6.0
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Library
R3D SDK
Revulytics
RLM
sentry
SCons
Skein

SonyRAW

SonyRenderman

sony-smdk
SQLCipher
SQLite
sse2neon
symbolicator
Tcl

tinyxml2
TorchVision
Ultimatte
URIParser
usD

uuid
VideoToolbox

Visual Studio

USER GUIDE

Linux

8.4.0

6.2.0

16.0

0.7.6

1.1

5.0.0

15.1

4.24.0

4.5.6

3.45.0

1.6.0

v0.7.0

8.4.16

10.0.0

0.16.1

1.0

0.8.0

24.05

1.0

N/A

N/A
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Version
Mac
8.4.0
6.2.0
16.0

0.7.6

1.1
5.0.0
N/A
4.24.0
4.5.6
3.45.0
1.6.0
v0.7.0
8.4.16
10.0.0
0.16.1
1.0
0.8.0
24.05
N/A
HW/SW

N/A

Windows

8.4.0

6.2.0

16.0

0.7.6

1.1

5.0.0

15.1

4.24.0

4.5.6

3.45.0

1.6.0

v0.7.0

8.4.16

10.0.0

0.16.1

1.0

0.8.0

24.05

N/A

N/A

2019
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Library
VXL
xmlrpcpp
ZeroMQ
Zipstream

zlib

Linux

1.18.0

N/A

4.3.5

1.0

1.2.11

Third-Party Libraries and Fonts |

Version
Mac
1.18.0
N/A
4.3.5
1.0

1.2.11

Windows
1.18.0

0.7

4.3.5

1.0

1.2.11

For a full list of all third-party licenses and fonts used in the application, please see the Nuke Online
Help, Third-Party Libraries and Fonts, or click here.

Nuke's Machine Learning tools were trained using the image libraries referenced and licensed in this
AIR Image Licences PDF, available for download by clicking the link.
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End User License Agreement
(EULA)

PLEASE READ THIS EULA CAREFULLY BEFORE ORDERING OR DOWNLOADING OR USING ANY
SOFTWARE PRODUCTS OF FOUNDRY. YOUR ATTENTION IS PARTICULARLY DRAWN TO: (A) CLAUSE 8 IN
WHICH SUBSCRIPTION CUSTOMERS AGREE TO THE AUTO-RENEWAL OF THEIR LICENSE ON AN
ANNUAL BASIS; (B) CLAUSES 15 AND 16 WHERE WE LIMIT OUR LIABILITY TO USERS OF OUR SOFTWARE
PRODUCTS; (C) CLAUSE 19.2 REGARDING THE DATA WE MAY COLLECT AND HOW WE MAY USE IT; AND
(D) CLAUSE 19.3 WHERE YOU AUTHORISE FOUNDRY TO USE THE SOFTWARE TO ACCESS AND COLLECT
CERTAIN INFORMATION FROM YOUR COMPUTER NETWORKS AND TO TRANSMIT THIS INFORMATION
TO FOUNDRY.

IMPORTANT NOTICE TO ALL USERS: BY DOWNLOADING AND/OR USING THIS SOFTWARE YOU
ACKNOWLEDGE THAT YOU HAVE READ THIS EULA, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS
TERMS AND CONDITIONS. IF YOU DO NOT AGREE TO THE TERMS OF THIS EULA DO NOT DOWNLOAD,
INSTALL, COPY OR USE THE SOFTWARE.

IMPORTANT NOTICE TO CONSUMERS WHO PURCHASE SOFTWARE PRODUCTS DIRECT FROM
FOUNDRY: YOU HAVE THE RIGHT TO CANCEL YOUR CONTRACT AND OBTAIN A FULL REFUND IN
ACCORDANCE WITH CLAUSE 9. HOWEVER YOU WILL LOSE THIS RIGHT ONCE YOU INSTALL THE
SOFTWARE OR LOGIN TO AN INDIVIDUAL LOGIN OR TEAM LOGIN LICENSE. THIS DOES NOT AFFECT
YOUR CONSUMER RIGHTS IN RELATION TO DEFECTIVE PRODUCTS OR SERVICES.

This END USER LICENSE AGREEMENT (“EULA") is, in cases where you purchase our product(s) direct
from Foundry, incorporated into the agreement between The Foundry Visionmongers Ltd a company
registered in England and Wales with company number 4642027 and whose registered office is at
Squire Patton Boggs Secretarial Services Limited, Rutland House, 148 Edmund Street, Birmingham,
United Kingdom, B3 2JR and whose address for correspondence is 5 Golden Square, London W1F 9HT,
(“Foundry”), and you, as either an individual or a single company or other legal entity (“Licensee”) on
the terms of which you will purchase the products and services of Foundry (the “Agreement”). In
cases where you purchase our product(s) from one of our resellers, the use of the term “Agreement”
in this EULA refers to the arrangements between Foundry and Licensee on which Licensee is
permitted to use Foundry's product(s), including this EULA.

Foundry reserves the right to refuse to grant a License (as defined in clause 1.1) to any Licensee who
has failed to pay any sum due either to Foundry or to a reseller of Foundry, in connection with the
Agreement, in connection with any other software license, in connection with any other agreed terms
between Foundry and the Licensee, to use any Software product(s) of Foundry and/or in connection
with any Maintenance and Support Agreement as defined in clause 11.1.
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1. GRANT OF LICENSE

1.1 Subject to terms and the scope of the applicable licence model as set out in clause 2, the
limitations of clause 3 and all the other terms of the Agreement, Foundry grants to Licensee a limited,
non-transferable (subject to clause 2.1(b) below) and non-exclusive license to download, install and
use a machine readable, object code version (subject to clauses 3 and 4 below) of the software
program(s) purchased by Licensee (the “Software”) together with, and in accordance with, any
accompanying user guide and other documentation (the “Documentation”), solely for Licensee’s,
where the Licensee is a business, own internal purposes or, where the Licensee is a consumer,
domestic and private purposes (the “License”); provided, however, that Licensee’s right to download,
install and use the Software and the Documentation is limited to those rights expressly set out in this
EULA.

1.2 Some types of license models set out in clause 2.1 limit the installation and use of the Software to
the country in which Licensee is based at the date of purchase (the “Home Country”), unless
otherwise agreed by Foundry in writing. For the avoidance of doubt, ‘use’ in a Home Country requires
the server, network and user to be based in the Home Country. Notwithstanding such limits, Licensee
may still use the Software outside the Home Country if traveling or working outside the Home Country
on a temporary basis provided that: a) such use does not exceed 70 days in aggregate in any rolling
twelve month period or, in the case of any license which lasts for less than twelve months, does not
exceed the number of days representing 20% of the term of the license, and b) our Software may not
be accessed or used in countries which are subject to import/export controls or sanctions, as further
detailed in Clause 22.

1.3 Only to the extent that is proportionate to, and reasonably necessary to support, Licensee’s
licensed use of the Software in accordance with the Agreement, Licensee may (provided valid license
keys or license entitlements have been obtained) install the Software on more than one computer,
provided always that Licensee’s concurrent use of different installations of the Software does not
exceed the number of valid Licenses that Licensee has paid for or licensed (as applicable).

2. LICENSE MODELS

2.1 For each Software product that you purchase from Foundry, the product will be licensed (and not
sold) to you on either a rental or subscription basis in accordance with one or more of the license
models set out in this clause 2.1 and clause 2.2, as specified in Foundry's invoice or order confirmation
(as applicable), and subject to the other terms and conditions of this EULA. Please note that some
licensing models set out below do not apply to certain Software products of Foundry. Whichever
licensing model applies, Licensee shall not at any one time use more copies of the Software than the
total number of valid licenses purchased by Licensee.

(a) “Offline Node Locked License”
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If Licensee purchases an Offline Node Locked License, Licensee will install and use only a single copy
of the Software on only one computer at a time in the Home Country.

(b) “Modo Individual License”

If Licensee has a Modo Individual License then: (a) Licensee warrants and represents that Licensee is a
natural person and that only Licensee will use the Software; (b) Licensee may transfer or assign
(“transfer”) the Modo Individual License to another natural person (“Assignee”) subject to Licensee: (i)
notifying Foundry of such transfer and obtaining Foundry's express written consent, (ii) paying an
administrative fee with respect to such transfer as may be required by Foundry, and (iii) after
transferring a single copy of the Software to the Assignee, deleting any copies of the Software that
Licensee may have in Licensee’s possession, custody or power; (c) Licensee shall not share its login
details for the Software with any third party (d) Licensee shall be entitled to use the Software on
different computers which may be located anywhere and use is not limited to the Home Country; (e)
use of the Software shall be limited to no more than one concurrent use at all times.

(c) "Offline Floating License”

If Licensee purchases an Offline Floating License, then: (a) Licensee may use the Software on any
number of computers, provided that the number of concurrent users shall never exceed the total
number of valid Offline Floating Licenses purchased by Licensee; and (b) use of the Software shall be
limited to any site in the Home Country.

(d) “Individual Login License”

If Licensee purchases an Individual Login License, Licensee warrants and represents that Licensee is a
natural person and that only Licensee shall use the Software. Licensee will be issued with log in details
and may use the Software on any number of computers (but not simultaneously). Use of the Software
shall be limited to any site in the Home Country.

(e) “Team Login License”

If Licensee purchases a Team Login License, then: (a) Licensee may use the Software on any number
of computers, provided that the number of concurrent users shall never exceed the total number of
valid Team Login Licenses purchased by Licensee; (b) use of the Software shall be limited to any site in
the Home Country; and (c) use of the Software, and changes to the user authorizations within
Licensee’s team organization(s), shall be in accordance with any Team Login License guidance and
instructions, as published on Foundry's website and which may be amended from time to time.

(f) “Nuke Indie License”

If Licensee purchases a License for Nuke Indie, then: (a) Licensee warrants and represents that
Licensee (i) is a natural person and that only Licensee will use the Software; (ii) is working
independently and shall not use the Nuke Indie License in a pipeline with other Nuke commercial or
Nuke Indie licenses, whether those licenses are held by the Licensee, other individuals or other
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businesses or organisations; and (iii) earns less than $100,000 USD (or local equivalent) a year; and (iv)
that Licensee satisfies all criteria set out in Foundry's Nuke Indie Eligibility Requirements as published
on its website and which may be amended from time to time (the “Nuke Indie Eligibility
Requirements”); (b) Licensee shall not share its login details for the Software with any third party; (c)
Licensee shall not purchase or use more than one Nuke Indie License; (d) Licensee may use the
License on different computers, subject to (i) a maximum of two computer authorisations at any one
time and (ii) no more than one concurrent user at any one time; and (e) Licensee shall use the
Software in accordance with terms of the Nuke Indie Eligibility Requirements, including abiding by any
functional restrictions; and (f) the provisions of clause 8 shall apply.

(g) “"Modo Subscription License”

If Licensee has a Modo Subscription License, then: (a) Licensee warrants and represents that Licensee
is a natural person and that only Licensee will use the Software; (b) Licensee shall not share its login
details for the Software with any third party; (c) Licensee may use the Software on different computers
which may be located anywhere and use is not restricted to the Home Country; (d) Licensee may use
the License on different computers, subject to (i) a maximum of two computer authorisations at any
one time and (ii) no more than one concurrent user at any one time; (e) Licensee shall not purchase or
use more than one Modo Subscription License; and (f) the provisions of clause 8 shall apply.

(h) “Mari Individual Subscription License”

If Licensee purchases a Mari Individual Subscription License then: (a) Licensee warrants and
represents that Licensee is a natural person and that only Licensee will use the Software; (b) Licensee
shall not share its login details for the Software with any third party; (c) Licensee may use the Software
on different computers which may be located anywhere and use is not restricted to the Home
Country; (d) Licensee may use the License on different computers, subject to (i) a maximum of two
computer authorisations at any one time and (ii) no more than one concurrent user at any one time;
(e) Licensee shall not purchase or use more than one Mari Individual Subscription License; and (f) the
provisions of clause 8 shall apply.

(i) “Rental License”

If Licensee has purchased the Software on a rental basis, the License shall be limited to the term of
the rental as agreed in writing with Foundry after which it shall automatically expire.

(j) “Educational License”

If Licensee has purchased the Software on the discounted terms of Foundry's educational program
and eligibility criteria as published on its website and amended from time to time, Licensee warrants
and represents to Foundry as a condition of the Educational License that: (i) it is an educational
institution that will use the Software only for the purpose of training and instruction, and for no other
purpose, (ii) Licensee will at all times comply with any eligibility criteria and guidelines in respect of the
Educational License, as may be communicated to a Licensee and/or published on Foundry’'s website
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and amended from time to time, and (iii) use of the Software shall be limited to any site in the Home
Country. Unless the Educational License is a Floating License, Licensee shall use the Software on only
one computer at a time.

(k) “Graduate License”

If Licensee has purchased the Software on the discounted terms of Foundry’s Graduate Licence,
Licensee warrants and represents to Foundry as a condition of the Graduate Licence that the Licensee
has graduated from a university or tertiary education institute no more than six (6) months prior to
the grant of the Graduate Licence. The Licensee may use the Software in a personal capacity only
(namely, as a sole trader or freelancer). For the avoidance of doubt, Licensee may not use the
Graduate License in connection with any work or employment, whether paid or unpaid, or other such
collaborations with studios or similar organisations. Foundry reserves the right to require evidence of
graduation by the Licensee. Use of the Software shall be limited to any site in the Home Country.

() “Student License”

If Licensee has purchased the Software on the discounted terms of Foundry’s student program and
eligibility criteria as published on its website and amended from time to time, Licensee warrants and
represents to Foundry as a condition of the Student License that: (i) the Licensee is a part-time or full-
time student at the time of purchase and will not use the Software for any commercial, professional or
for-profit purposes; (ii) Licensee will at all times comply with any eligibility criteria and guidelines in
respect of the Student License, as may be communicated to a Licensee and/or published on Foundry's
website and amended from time to time, and (iii) use of the Software shall be limited to any site in the
Home Country. Unless the Student License is a Floating License, Licensee shall use the Software on
only one computer at a time.

(m) “Non-Commercial License”

If the License is a Non-Commercial License, Licensee warrants and represents that Licensee is a
natural person, that they will only access and/or use one copy of a Non-Commercial License for
personal, recreational and non-commercial purposes and that only Licensee will use the Software.
Under a Non-Commercial License, Licensee will not use the Software: (a) in conjunction with any other
copies or versions of the Software, under any type of License model; (b) for any commercial,
professional, for-profit and/or on-sale purpose or otherwise to provide any commercial service(s) to a
third party (whether or not for financial or other reward and including for education, instruction of or
demonstration to any third party for commercial purposes); (¢) in the course of any employment or
business undertaking of Licensee; (d) on any commercial premises during business hours (except
where use of the Software is solely for a personal, recreational, educational or other non-commercial
purpose); and/or (e) to create any commercial tools or plug ins.

(n) “Mari indie”
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Variants of Mari with limited functionality as described in the Documentation are available to
purchase. If Licensee has purchased such a variant, Licensee warrants and represents to Foundry as a
condition of the Agreement that: (i) Licensee is a natural person; or (ii) Licensee is an entity in the
direct ownership of a single natural person; (iii) Licensee will only access and/or use one copy of the
Software; and (iv) only Licensee will use the Software.

(o) “Trial License”

Licensee may register for a “Trial License” of the Software (not available for all products or in all
regions or markets). A Trial License is for product evaluation and learning purposes only and may only
be used by a natural person, A Trial License lasts a limited specified period on the expiry of which the
Software will automatically cease to function. Foundry may terminate any Trial License for
convenience immediately on notice to Licensee. Licensee will use the Software for product evaluation
and learning purposes only.

(p) “Subscription License”

If Licensee has purchased the Software on a subscription basis then: (a) the License shall be limited to
the Subscription Period (as defined in clause 8.1) after which it shall automatically expire and; (b) the
provisions of clause 8, including but not limited to auto-renewal, shall apply.

(q) “Nuke Stage License”

If Licensee purchases a Nuke Stage License, then: (a) Licensee may use the Software on any number of
computers, provided that the number of concurrent Nuke Stage Output Device(s) shall never exceed
the total number of valid Nuke Stage Floating Licenses purchased by Licensee; and (b) use of the
Software shall be limited to any site in the Home Country. “Nuke Stage Output Device(s)” shall mean
one region designated for rendered output, which may be mapped to one endpoint such as display
windows, SDI outputs, files, or other render targets.

2.2 If Licensee has purchased a License that permits “non-interactive” use of the Software (“Headless
Rendering”), Licensee is authorized to use a non-interactive version of the Software for rendering
purposes only (i.e. without a user, in a non-interactive capacity) and shall not use such Software on
workstations or otherwise in a user-interactive capacity. Headless Rendering is not available on all
products. In all cases, Headless Rendering licenses may be used on any number of computers,
provided that the number of concurrent computers shall never exceed the total number of valid
Headless Rendering licenses purchased by Licensee.

3. RESTRICTIONS ON USE

Please note that in order to guard against unlicensed use of the Software, a license key is
required to access and enable the Software. Licensee is authorised to use the Software in machine
readable, object code form only (subject to clause 4), and Licensee shall not: (a) assign, sublicense, sell,
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distribute, transfer, pledge, lease, rent, lend, share or export the Software, the Documentation or
Licensee's rights under this EULA; (b) alter or circumvent the license keys or other copy protection
mechanisms in the Software or reverse engineer, decompile, disassemble or otherwise attempt to
discover the source code of the Software in each case except as and to the extent that applicable law
requires such reverse engineering, decompilation, disassembly or discovery to be permitted and it is
not lawful to contract out of such requirement; (c) implement or use any method or mechanism
designed to enable product functionality not available in the Software but available in (i) other
Foundry products; or (ii) other Foundry releases of the same product; (d) (subject to clause 4) modify,
adapt, translate or create derivative works based on the Software or Documentation; (e) use, or allow
the use of, the Software or Documentation on any project other than a project produced by Licensee
(an “Authorized Project”) or to provide a service (whether or not any charge is made) to any third
party; (f) allow or permit anyone (other than Licensee and Licensee’s authorized employees to the
extent they are working on an Authorized Project) to use or have access to the Software or
Documentation; (g) copy or install the Software or Documentation other than as expressly provided
for in this EULA; or (h) take any action, or fail to take action, that could adversely affect the
trademarks, service marks, patents, trade secrets, copyrights or other intellectual property rights of
Foundry or any third party with intellectual property rights in the Software (each, a “Third Party
Licensor”); (i) use the Software, or permit any third party to use the Software, for any illegal purpose.
The Licensee shall maintain appropriate internal security, safeguards and controls which shall be at
least as great as the measures the Licensee uses to keep Licensee’s own information secure (but in
any case, using no less than a reasonable degree of care) to ensure that the Software is not used in
any way which is in violation of this clause 3 or of this Agreement. For the avoidance of doubt,
Licensee remains fully liable for any unauthorized use of the Software by its staff. For purposes of this
clause 3, the term “Software” shall include any derivatives of the Software.

Notwithstanding clause 3(b) above, where the reduction of the Software to human readable form is
necessary for the purposes of integrating the operation of the Software with the operation of other
software or systems used by the Licensee in accordance with section 50B of the Copyright Designs
and Patents Act 1988 (or any analogous legislation in other jurisdictions), prior to reducing the
Software to human readable form (whether by reverse engineering, decompilation or disassembly),
the Licensee shall notify Foundry in advance and allow Foundry a reasonable period to either carry
out such action as is required to fulfil the integration or provide the information necessary to achieve
such integration to the Licensee, and in either case the Licensee shall meet Foundry’s reasonable
costs in doing so.

Unless Licensee has purchased an Individual License, a Team Login License or an Individual Login
License, for other license types, if the Software is moved from one computer to another (or, in the
case of an Offline Floating License, from one license server to another), the issuing of replacement or
substituted license keys or approval of the new server location, is in Foundry’s sole discretion and is
subject to and strictly in accordance with Foundry's License Transfer Policy, which is available on
Foundry’'s website and which requires a fee to be paid in certain circumstances. Foundry may from
time to time and at its sole discretion vary the terms and conditions of the License Transfer Policy.
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The Software and/or any components thereof are not intended to be used for and Licensee shall not
use the Software for (or modify the Software such that is suitable for): (i) prohibited practices under
the European Union Artificial Intelligence Act (the “EU Al Act”) or similar legislation, (ii) any use that
would result in the Software being considered a high-risk Al system or that otherwise qualifies as
“high-risk” under the EU Al Act. Licensee may not remove, alter or obscure any metadata fields which
are automatically applied to content generated by the Software which indicate that such content has
been artificially generated or manipulated.

4. SOURCE CODE

Notwithstanding that clause 1 defines “Software” as an object code version and that clause 3 provides
that Licensee may use the Software in object code form only:

4.1 if Foundry has agreed to license to Licensee (including by way of providing SDKs, upgrades,
updates or enhancements/customization) source code or elements of the source code of the
Software, the intellectual property rights in which belong either to Foundry or to a Third Party Licensor
(“Source Code"), Licensee shall be licensed to use the Source Code as Software on the terms of this
EULA and: (a) notwithstanding clause 3 (c), Licensee may use the Source Code at its own risk in any
reasonable way for the limited purpose of enhancing its use of the Software solely for, where the
Licensee is a business, its own internal business purposes or, where the Licensee is a consumer,
domestic and private purposes and in all respects in accordance with this EULA; (b) Licensee shall in
respect of the Source Code comply strictly with all other restrictions applying to its use of the Software
under this EULA as well as any other restriction or instruction that is communicated to it by Foundry at
any time during the Agreement (whether imposed or requested by Foundry or by any Third Party
Licensor);

4.2 to the extent that the Software links to or itself incorporates any open source software and/or
software libraries (“OSS Components”) that are provided to Licensee with or as part of the Software,
then where such OSS Components are licensed on the terms of an open source software licence that
requires Foundry to make the OSS Components available to the Licensee on specific terms (the “OSS
Licence Terms"), those OSS Components are licensed to Licensee on, and subject to, the terms of the
relevant OSS Licence Terms;

4.3 where Foundry is required by any OSS Licence Terms to make the source code of the relevant OSS
Component available to the Licensee, Foundry will at any time during the three year period starting on
the date of the Agreement, at the request of Licensee and subject to Licensee paying to Foundry a
charge that does not exceed Foundry’s costs of doing so, provide Licensee with the source code of the
relevant OSS Component (the “OSS Source Code”) in order that Licensee may modify the OSS
Component in accordance with the relevant OSS Licence Terms, together (where appropriate) with
certain object code of the Software necessary to enable Licensee to re-link any modified OSS
Components to the Software (the “Object”); and
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4.4 notwithstanding any other term of the Agreement, Foundry gives no express or implied warranty,
undertaking or indemnity whatsoever in respect of the Source Code, the OSS Components, the OSS
Source Code or the Object, all of which are licensed on an “as is” basis, or in respect of any
modification of the Source Code, the OSS Components or the OSS Source Code made by Licensee
(“Modification”). Licensee may not use the Object for any purpose other than its use of the Software
in accordance with this EULA. Notwithstanding any other term of the Agreement, Foundry shall have
no obligation to provide support, maintenance, upgrades or updates of or in respect of any of the
Source Code, the OSS Components (save for any obligations Foundry may have in respect of any
elements that form part of the Software as a whole), the OSS Source Code, the Object or any
Modification. Licensee shall indemnify Foundry against all liabilities and expenses (including
reasonable legal costs) incurred by Foundry in relation to any claim asserting that any Modification
infringes the intellectual property rights of any third party.

5. BACK-UP COPY

Licensee may store one copy of the Software and Documentation off-line and off-site in a secured
location within the Home Country that is owned or leased by Licensee in order to provide a back-up in
the event of destruction by fire, flood, acts of war, acts of nature, vandalism or other incident. In no
event may Licensee use the back-up copy of the Software or Documentation to circumvent the usage
or other limitations set forth in this EULA.

6. OWNERSHIP

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that
is licensed to Licensee) and Documentation and all related intellectual property rights and other
proprietary rights are and shall remain the sole property of Foundry and the Third Party Licensors.
Licensee shall not remove, or allow the removal of, any copyright or other proprietary rights notice
included in and on the Software or Documentation or take any other action that could adversely affect
the property rights of Foundry or any Third Party Licensor. To the extent that Licensee is authorized to
make copies of the Software or Documentation under this EULA, Licensee shall reproduce in and on
all such copies any copyright and/or other proprietary rights notices provided in and on the materials
supplied by Foundry hereunder. Nothing in the Agreement shall be deemed to give Licensee any
rights in the trademarks, service marks, patents, trade secrets, confidential information, copyrights or
other intellectual property rights of Foundry or any Third Party Licensor, and Licensee shall be strictly
prohibited from using the name, trademarks or service marks of Foundry or any Third Party Licensor
in Licensee’s promotion or publicity without Foundry's prior express written approval.

Subject to clause 4.3, Foundry undertakes (the “Undertaking”) to defend Licensee or at Foundry's
option settle any claim brought against Licensee alleging that Licensee’s possession or use of the
Software or Documentation in accordance with the Agreement infringes the intellectual property
rights of a third party in the same country as Licensee (“Claim”) and shall reimburse all reasonable
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losses, damages, costs (including reasonable legal fees) and expenses incurred by or awarded against
Licensee in connection with any such Claim, provided that the Undertaking shall not apply where the
Claim in question is attributable to possession or use of the Software or Documentation other than in
accordance with the Agreement, or in combination with any hardware, software or service not
supplied or specified by Foundry. The Undertaking is conditional on Licensee giving written notice of
the Claim to Foundry as soon as reasonably possible, cooperating in the defence of the Claim and not
making any admission of liability or taking any step prejudicial to the defence of the Claim. If any
Claim is made, or in Foundry’s reasonable opinion is likely to be made, against Licensee, Foundry may
at its sole option and expense (a) procure for Licensee the right to continue using the Software, (b)
modify the Software so that it ceases to be infringing, (c) replace the Software with non-infringing
software, or (d) terminate the Agreement immediately by notice in writing to Licensee and refund the
License Fee (less a reasonable sum in respect of Licensee’s use of the Software to the date of
termination) on return of the Software and all copies by Licensee. The Undertaking constitutes
Licensee's exclusive remedy and Foundry's only liability in respect of any Claim.

7. LICENSE FEE

7.1 Licensee acknowledges that the rights granted to Licensee under this EULA are conditional on
Licensee’s timely payment of the license fee payable to Foundry in connection with the Agreement or,
as the case may be, payable to Foundry's reseller (the “License Fee"). Except where the applicable
invoice expressly sets out payment in instalments, the License Fee shall be payable in full as one
single payment.

7.2 Licensee will be charged and agrees to pay to Foundry or Foundry’s authorized reseller (as
applicable): (a) the License Fee as notified by Foundry (or its reseller) at the time of the initial purchase
of the License; and (b) in respect of any Subscription Auto-renewal Period for a Subscription License,
the License Fee as notified by Foundry (or its reseller) on or about the applicable Renewal Date.

7.3 Unless stated otherwise, any Licence Fee notified to the Licensee by Foundry (or its reseller) is
exclusive of sales tax, VAT and any other similar taxes, duties or levies, which shall be payable by the
Licensee (and the Licensee agrees to pay) in addition to the Licence Fee.

7.4 In the cases of Non-Commercial Licenses or Trial Licenses or specific End of Life Software, the fact
that no License Fee may be payable shall not be construed as a waiver by Foundry of any right or
remedy available to it in relation to any breach by the Licensee of this EULA or the Agreement, or of
any other right or remedy arising under applicable law, all of which are expressly reserved.

8. SUBSCRIPTION LICENSES AND AUTO-RENEWAL

8.1 If Licensee has purchased a Subscription Licence, the License shall be limited to the Initial
Subscription Period and any/all Auto-renewal Periods (each as defined below) (together the
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“Subscription Period”) after which it shall automatically expire.

8.2 The Subscription Licence shall begin as soon as Foundry accepts Licensee’s order by issuing
Licensee with a license key (the “Subscription Start Date”) and shall continue for an initial period of
twelve (12) months (the “Initial Subscription Period”) unless earlier terminated in accordance the
terms of this EULA, or unless otherwise communicated by Foundry.

8.3 Unless Licensee opts out of auto-renewal in accordance with clause 8.5 then upon the first
anniversary of the Subscription Start Date and each subsequent anniversary (each a “Subscription
Renewal Date”), Licensee's Subscription Licence shall renew automatically for a further twelve (12)
months (each an “Auto-renewal Period”). Licensee’s Subscription License will continue to auto-renew
in this manner until Licensee opts out of auto-renewal or unless earlier terminated in accordance with
the terms of this EULA.

8.4 Prior to each Subscription Renewal Date, Foundry shall send one (1) email to advise you that your
Subscription License is approaching auto-renewal to the contact email address as provided by
Licensee in accordance with clause 23. The reminder email will be sent not less than thirty (30) days
prior to the relevant Subscription Renewal Date.

8.5 Opting Out of Auto-renewal and License Expiry. If Licensee wishes to opt out of auto-renewal
then you must email licenses@foundry.com providing details of the Subscription Licence(s) which you
wish to opt out not less than seventy-two (72) hours prior to the relevant Subscription Renewal Date.
Provided that Licensee notifies Foundry in accordance with the provisions of this clause 8.5 then your
Subscription License(s) will not auto-renew and shall expire at the end of the then-current
Subscription Period.

8.6 Increases to the License Fee for Subscription Licenses. Foundry reserves the right to increase
the License Fee for Subscription Licenses from time to time provided that it shall provide Licensee
with not less than thirty (30) days’ notice of any increase prior to the relevant Subscription Renewal
Date.

9. CANCELLATIONS

9.1 Licensee may cancel a License within 14 days of the original purchase date to obtain a full refund
and Licensee will no longer be able to use the Software from the cancellation date. Licensee’s right to
obtain a refund will be lost once the Software has been installed.

9.2 Refunds are not payable for cancellations made after such date. This includes Subscription
licenses which are subject to the fixed twelve (12) month terms and for which the Licensee may opt
out of auto-renewal in accordance with Clause 8.

9.3 Cancellations and requests for refunds can be made by contacting Foundry’s Sales Support team
at licenses@foundry.com.
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10. END OF LIFE

10.1 From time to time, Foundry will retire Software product(s) (and any/ all versions) by withdrawing
them from the market. Such Software product(s) will be designated as end of life (“EoL") and a
corresponding announcement (the “Announcement”) will be published on Foundry's website from
time to time (the date of such announcement being the “EoL Notification Date"”). The announcement
will include an EoL date (“EoL Date”) and other relevant information.

10.2 No new License(s) (including renewals, if applicable) for the EoL Software product(s) will be sold
after the EoL Notification Date. Unless otherwise provided for in the Announcement, the EoL Date will
be the last day that the EoL Software product(s) is sold, improved, maintained, updated, or supported
(subject to the below).

10.3 Unless otherwise provided for in the Announcement, a Licensee with an active Subscription
License(s) at the time of the EoL Date will receive certain limited support until the relevant
Subscription Period expires. A Licensee with an active perpetual License(s) (purchased on or prior to
31 December 2023) for which it has renewed (or auto renewed) the associated Maintenance and
Support Agreement prior to the EoL Notification Date, will receive certain limited support until the EoL
Date, or for a period specified in the Announcement.

10.4 In the event of EoL, Foundry advises Licensee to install the latest product releases, security
updates, fixes and patches available until the EoL Date, to remain as secure as possible. Older
products may not meet security or performance requirements, and Foundry cannot confirm
compatibility with future operating system updates after the EoL Date. To the maximum extent
permitted by applicable law, Foundry shall not be liable for any form of loss, damage or disruption in
respect of the EoL Software product(s) beyond the EoL Date.

10.5 Foundry retains all rights, including intellectual property rights, associated with the EoL Software
product(s) beyond the EoL Date. Any use by Licensee of the EoL Software product(s) beyond the EoL
Date will continue to be governed by the terms of this Agreement.

11. MAINTENANCE AND SUPPORT

11.1 Subject to Licensee’s timely payment of the applicable License Fee, each Subscription Licence and
each Rental License shall include access to certain maintenance and support services in accordance
with the Maintenance and Support Agreement which is available on Foundry’'s website (the
“Maintenance and Support Agreement”).

11.2 If Licensee purchased a perpetual License on or prior to 31 December 2023 for which it has
renewed (or auto-renewed) the associated Maintenance and Support Agreement, then such License
shall include access to certain maintenance and support services for the relevant continuous Renewal
Support Period(s) (as defined in, and in accordance with, the Maintenance and Support Agreement),
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after which Licensee shall not be entitled to purchase further maintenance and support for such
License.

11.3 Foundry may vary the terms and conditions of the Maintenance and Support Agreement from
time to time and at its sole discretion.

12. TAXES AND DUTIES

Licensee agrees to pay, and indemnify Foundry from claims for, any local, state or national tax
(exclusive of taxes based on net income), duty, tariff or other impost related to or arising from the
transaction contemplated by the Agreement.

13. LIMITED WARRANTY

13.1 Subject to clause 13.3, Foundry warrants that, for a period of ninety (90) days after Licensee first
downloads the Software (“Warranty Period”): (a) the Software will, when properly used on an
operating system for which it was designed, perform substantially in accordance with the functions
described in the Documentation; and (b) that the Documentation correctly describes the operation of
the Software in all material respects. If, within the Warranty Period, Licensee notifies Foundry in
writing of any defect or fault in the Software as a result of which it fails to perform substantially in
accordance with the Documentation, Foundry will, at its sole option, either repair or replace the
Software, provided that Licensee makes available all the information that may be necessary to
identify, recreate and remedy the defect or fault. This warranty will not apply to, and Foundry shall
have no liability for, any defect or fault caused by: (a) unauthorised use of or any amendment made to
the Software by any person other than Foundry; and/or (b) use of the Software in conjunction with
third party technology. If Licensee is a consumer, the warranty given in this clause is in addition to
Licensee's legal rights in relation to any Software or Documentation that is faulty or not as described.

13.2 Foundry does not warrant that the Software or Documentation will meet Licensee’s requirements
or that Licensee’s use of the Software will be uninterrupted or error free.

13.3 If Licensee purchases a license of the Software that is of a fixed term duration, the Warranty
Period in clause 13.1 shall apply only to Licensee’s first purchase of such license and not to any
subsequent renewal(s) even if a renewal involves another download.

14. INDEMNIFICATION

14.1 Licensee agrees to indemnify, hold harmless and defend Foundry, the Third Party Licensors and
Foundry’'s and each Third Party Licensor’s respective affiliates, officers, directors, shareholders,
employees, authorized resellers, agents and other representatives from all claims, defence costs
(including, but not limited to, legal fees), judgments, settlements and other expenses arising from or
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connected with any claim that any authorised or unauthorised use including but not limited to
modification of the Software or Documentation by Licensee or any person connected with Licensee or
any person provided with the Software by Licensee, infringes the intellectual property rights or other
proprietary rights of any third party.

14.2 Licensee agrees to indemnify, hold harmless and defend Foundry, the Third Party Licensors and
Foundry’'s and each Third Party Licensor's respective affiliates, officers, directors, shareholders,
employees, authorized resellers, agents and other representatives from all claims, defence costs
(including, but not limited to, legal fees), judgments, settlements and other expenses arising from or
connected with any claim that any authorised or unauthorised use (including but not limited to
modification) of the Software or Documentation, by Licensee, any person connected with Licensee or
any person provided with the Software by Licensee, causes any of them or any third party (including
but not limited to those viewing a product of the Software) to suffer harm or loss of any kind.

15. LIMITATION OF LIABILITY TO BUSINESS USERS

This clause applies where Licensee is a business user (and for these purposes any Licensee that is not
a consumer shall be treated as a business user). Licensee acknowledges that the Software has not
been developed to meet its individual requirements, and that it is therefore Licensee’s responsibility
to ensure that the facilities and functions of the Software as described in the Documentation meet
such Licensee requirements. The Software and Documentation is supplied only for Licensee’s internal
use for its business, and not for any re-sale purposes or for the provision of the Software (whether
directly or indirectly) to third parties. Foundry shall not under any circumstances whatever be liable to
Licensee, its affiliates, officers, directors, shareholders, employees, agents or other representatives,
whether in contract, tort (including negligence), breach of statutory duty, or otherwise, arising under
or in connection with the Agreement for loss of profits, sales, business, or revenue, business
interruption, loss of anticipated savings, loss or corruption of data or information, loss of business
opportunity, goodwill or reputation (in each case whether the loss is direct or indirect) or any indirect
or consequential loss or damage. In respect of any other losses, Foundry's maximum aggregate
liability under or in connection with the Agreement whether in contract, tort (including negligence) or
otherwise, shall in all circumstances be limited to the greater of US$5,000 (five thousand USD) and a
sum equal to the License Fee. Nothing in the Agreement shall limit or exclude Foundry’s liability for
death or personal injury resulting from our negligence, for fraud or fraudulent misrepresentation or
for any other liability that cannot be excluded or limited by applicable law. This EULA sets out the full
extent of our obligations and liabilities in respect of the supply of the Software and Documentation.
Except as expressly stated in writing in this EULA, there are no conditions, warranties, representations
or other terms, express or implied, that are binding on Foundry. Any condition, warranty,
representation or other term concerning the supply of the Software and Documentation which might
otherwise be implied into, or incorporated in, the Agreement, whether by statute, common law or
otherwise, is excluded to the fullest extent permitted by law.
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16. LIMITATION OF LIABILITY TO CONSUMERS

This clause applies where Licensee is a consumer. Licensee acknowledges that the Software has not
been developed to meet Licensee’s individual requirements, and that it is therefore Licensee’s
responsibility to ensure that the facilities and functions of the Software as described in the
Documentation meet such Licensee requirements. The Software and Documentation are only
supplied for Licensee's domestic and private use. Licensee agrees not to use the Software and
Documentation for any commercial, business or re-sale purposes, and Foundry has no liability to
Licensee for any loss of profit, loss of business, business interruption, loss of business opportunity or
loss or harm caused to property or data used for professional purposes. Foundry is only responsible
for loss or damage suffered by Licensee that is a foreseeable result of Foundry’s breach of the
Agreement or its negligence but Foundry is not responsible for any loss or damage that is not
foreseeable. Our maximum aggregate liability under or in connection with the Agreement, whether in
contract, tort (including negligence) or otherwise, shall in all circumstances be limited to a sum equal
to the greater of US$5,000 (five thousand USD) and a sum equal to the latest annual License Fee.
Nothing in the Agreement shall limit or exclude Foundry's liability for death or personal injury
resulting from our negligence, for fraud or fraudulent misrepresentation or for any other liability that
cannot be excluded or limited by applicable law.

17. TERM; TERMINATION

17.1 The Agreement is effective upon Licensee’s download of the Software, and the Agreement will
remain in effect until termination or expiry. Licensee may terminate the Agreement on written notice
to Foundry if Foundry is in material breach of this Agreement and fails to cure the breach within 10
(ten) working days of receiving notice of such breach. If Licensee breaches the Agreement, Foundry
may terminate the License immediately by notice to Licensee.

17.2 If the Agreement expires or is terminated, the License will cease immediately and Licensee will
immediately cease use of any Software and Documentation and either return to Foundry all copies of
the Software and Documentation in Licensee’s possession, custody or power or, if Foundry directs in
writing, destroy all such copies. In the latter case, if requested by Foundry, Licensee shall provide
Foundry with a certificate confirming that such destruction has been completed within 10 days.

17.3 Foundry reserves the right to terminate and/or suspend the License as it deems reasonable in its
sole discretion by notice to Licensee if it becomes aware that Licensee has failed to pay any sum due
either to Foundry or to a reseller of Foundry either in connection with the Agreement or in connection
with any other Software license to use any product(s) of Foundry, in connection with any other agreed
terms between Foundry and the Licensee in connection with the Software, in connection with any
Maintenance and Support Agreement or if the Licensee is otherwise in breach of or fails to comply
with any term of the Agreement.
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17.4 Foundry may also terminate this Agreement if Licensee becomes subject to bankruptcy
proceedings, becomes insolvent, or makes an arrangement with Licensee’s creditors. This Agreement,
and for the avoidance of doubt the Licenses to which it relates, will terminate automatically without
further notice or action by Foundry if Licensee goes into liquidation.

18. CONFIDENTIALITY

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is
licensed to Licensee) and Documentation are proprietary to and the confidential information of
Foundry or, as the case may be, the Third Party Licensors, and that all such information and any
related communications (collectively, “Confidential Information”) are confidential and a
fundamental and important trade secret of Foundry and/or the Third Party Licensors. If Licensee is a
business user, Licensee shall disclose Confidential Information only to Licensee’s employees who are
working on an Authorized Project and have a “need-to-know” such Confidential Information for the
purposes of that Authorized Project, and shall advise any recipients of Confidential Information that it
is to be used only as expressly authorized in the Agreement. Licensee shall not disclose Confidential
Information or otherwise make any Confidential Information available to any other of Licensee’s
employees or to any third parties without the express written consent of Foundry. Licensee agrees to
segregate, to the extent it can be reasonably done, the Confidential Information from the confidential
information and materials of others in order to prevent commingling. Licensee shall take reasonable
security measures, which measures shall be at least as great as the measures Licensee uses to keep
Licensee’s own confidential information secure (but in any case using no less than a reasonable
degree of care), to hold the Software, Documentation and any other Confidential Information in strict
confidence and safe custody. Foundry may request, in which case Licensee agrees to comply with,
certain reasonable security measures as part of the use of the Software and Documentation. This
clause shall not apply to any information that is in or comes into the public domain (other than as a
result of the Licensee’s breach of its obligations under the Agreement), or was in Licensee’s lawful
possession before receipt or which Licensee develops independently and without breach of this
clause. Licensee acknowledges that monetary damages may not be a sufficient remedy for
unauthorized disclosure of Confidential Information, and that Foundry shall be entitled, without
waiving any other rights or remedies, to such injunctive or other equitable relief as may be deemed
proper by a court of competent jurisdiction.

19. INSPECTION AND INFORMATION

19.1 Unless Licensee is a consumer, Licensee shall advise Foundry on demand of all locations where
the Software or Documentation is used or stored. Licensee shall permit Foundry or its authorized
agents to audit all such locations during normal business hours and on reasonable advance notice.

19.2 The Software may include mechanisms to access and collect limited information from computer
(s) on which it is installed and from any IT systems to which those computer(s) may be connected
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(including any system registry files) and transmit it to Foundry and/or its resellers, including the ability
to locally cache such information on such computers. Such information (the “Information”) may
include details of relevant license(s) to Foundry products, details of computer and network
equipment, details of the operating system(s) in use on such computer equipment, email domain
relating to owners of such computer and network equipment, the location of the computer(s) on
which the Software is installed and the profile and extent of use of the different elements of the
Software and other Foundry software. Foundry may use the Information to (a) model the profiles of
usage, hardware and operating systems in use collectively across its customer base in order to focus
development and support, (b) to provide targeted support to individual customers, (c) to ensure that
the usage of the Software by Licensee is in accordance with the Agreement and does not exceed any
user number or other limits on its use, (d) to confirm the identity of Licensee, to identify unlicensed
use of the Software (including use of pirated or other unlicensed copies of the Software) and to assist
Foundry (and its resellers and any enforcement bodies) in contacting any unlicensed users of the
Software and seeking to terminate unlicensed use of the Software, and (e) to advise Licensee about
service issues such as available upgrades and maintenance expiry dates. To the extent that any
Information constitutes personal data for the purposes of the General Data Protection Regulation (EU)
2016/679 (“EU GDPR") and the version of the EU GDPR retained in UK domestic law as further defined
in the Data Protection Act 2018 (“UK GDPR”), in each case, as amended, superseded or replaced from
time to time (as applicable, “GDPR") it shall be processed in accordance with the GDPR and with
Foundry’s Privacy Notice (see https://www.foundry.com/privacy-notice), as may be updated by
Foundry from time to time. Licensee undertakes to make all of users of the Software aware of the
uses which Foundry will make of the Information and of the terms of Foundry's Privacy Policy.

19.3 By downloading or using the Software, you (i) warrant that you are entitled to control access to
the computer(s) on which the Software is downloaded and any IT systems to which they may be
connected, and (ii) irrevocably authorise Foundry (through the use of the Software) to access such
computer(s) and IT systems (including any system registry files) and collect the Information from them
and to transmit that Information to Foundry and its resellers (and any enforcement bodies) and use it
for the purposes identified at clause 19.2(a) to (e) above.

20. U.S. GOVERNMENT LICENSE RIGHTS

All Software, including all components thereof, and Documentation qualify as “commercial items,” as
that term is defined at Federal Acquisition Regulation (“FAR") (48 C.F.R.) 2.101, consisting of
“commercial computer software” and “commercial computer software documentation” as such terms
are used in FAR 12.212. Consistent with FAR 12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-
4, and notwithstanding any other FAR or other contractual clause to the contrary in any agreement
into which this Agreement may be incorporated, a government end user will acquire the Software and
Documentation with only those rights set forth in this Agreement. Use of either the Software or
Documentation or both constitutes agreement by the government that all Software and
Documentation are “commercial computer software” and “commercial computer software
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documentation,” and constitutes acceptance of the rights and restrictions herein. The Software is the
subject of the following notices:

* Copyright © 2001 - 2025 The Foundry Visionmongers Ltd. All Rights Reserved.

* Unpublished- rights reserved under the Copyright Laws of the United Kingdom.

21. SURVIVAL

Clause 6, clause 7 and clauses 12 to 25 inclusive shall survive any termination or expiration of the
Agreement.

22. IMPORT/EXPORT CONTROLS AND SANCTIONS

To the extent that any Software made available under the Agreement is subject to restrictions upon
export and/or re-export from any applicable jurisdiction (including the United States), Licensee agrees
to comply with, and not act or fail to act in any way that would violate, applicable international,
national, state, regional or local laws and regulations, including, without limitation, the U.S. Export
Administration Act and the Export Administration Regulations, the regulations of the U.S. Department
of Treasury Office of Foreign Assets Control, the International Traffic in Arms regulations, the United
States Foreign Corrupt Practices Act, the UK Export Control Act 2002 and the UK Export Control Order
2008 (collectively, “Export Laws”) as those laws may be amended or otherwise modified from time to
time, and neither Foundry nor Licensee shall be required under the Agreement to act or fail to act in
any way which it believes in good faith will violate any such laws or regulations. Without limiting the
foregoing, Licensee agrees that it will not sell, supply, transfer, export or re-export, directly or
indirectly, Foundry's Software or related products and services, or any commodity, technology,
technical data, software or service that incorporates, contains or is a direct product of Foundry's
Software, products and/or services, (i) in violation of the Export Laws; (ii) to any country for which an
export license or other governmental approval is required at the time of export, without first
obtaining all necessary export licenses or other approvals; (iii) to any country, or national or resident
of a country, to which trade is embargoed by the United States and/or sanctioned by the United
Kingdom or the European Union; (iv) to any person or firm on any government agency’s list of blocked,
denied or barred persons or entities, including but not limited to the U.S. Department of Commerce's
Denied Persons List and Entities List, and the U.S Treasury Department’s Specially Designated
Nationals List; or (v) to the Russian Federation and/or Belarus or for use in the Russian Federation
and/or Belarus, or (vi) for use in any nuclear, chemical or biological weapons, or missile technology
end-use. Licensee warrants and represents that it is not subject to any Export Law, sanction and/or
other form of trading compliance restriction or regulation which may limit or prohibit its right to
download, install and/or use the Software in accordance with this EULA.
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23. MISCELLANEOUS

Unless Licensee is a consumer, the Agreement is the exclusive agreement between the parties
concerning its subject matter and supersedes any and all prior oral or written agreements,
negotiations, or other dealings between the parties concerning such subject matter. Licensee
acknowledges that Licensee has not relied upon any representation or collateral warranty not
recorded in the Agreement inducing it to enter into the Agreement.

The Agreement may be modified only in writing, by Foundry, at any time.

The failure of either party to enforce any rights granted under the Agreement or to take action against
the other party in the event of any such breach shall not be deemed a waiver by that party as to
subsequent enforcement of rights or subsequent actions in the event of future breaches.

The Agreement and any dispute or claim arising out of or in connection with it or its subject matter or
formation (including, unless Licensee is a consumer, non-contractual disputes or claims) shall be
governed by, and construed in accordance with English Law and the parties irrevocably submit to the
non-exclusive jurisdiction of the English Courts, subject to any right that a consumer may have to
bring proceedings or to have proceedings brought against them in a different jurisdiction.

If Foundry fails to insist that Licensee performs any obligation under the Agreement, or delays in
doing so, that will not mean that Foundry has waived its rights.

If any provision or part-provision of this Agreement is or becomes invalid, illegal or unenforceable, it
shall be deemed deleted, but that shall not affect the validity and enforceability of the rest of this
Agreement.

Unless Licensee is a consumer, Licensee agrees that Foundry may refer to Licensee as a clientor a
user of the Software, may display its logo(s) for this purpose and may publish quotations and
testimonials from Licensee, its directors, partners, officers or employees. Foundry agrees to promptly
cease any such use on Licensee’s written request.

Foundry and Licensee intend that each Third Party Licensor may enforce against Licensee under the
Contracts (Rights of Third Parties) Act 1999 (the “Act”) any obligation owed by Licensee to Foundry
under this EULA that is capable of application to any proprietary or other right of that Third Party
Licensor in or in relation to the Software. Foundry and Licensee reserve the right under section 2(3)(a)
of the Act to rescind, terminate or vary this EULA without the consent of any Third Party Licensor.

Email Address for General Correspondence: Licensee shall notify Foundry of an email address for
the provision of any correspondence in connection with the Agreement and shall notify Foundry via
licenses@foundry.com of any change(s) to that email address. Please note, the email address you
provide is important for the provision of information and notices to you, including in relation to the
autorenewal of any Subscription License (if applicable). It is your responsibility to provide and
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maintain an up-to-date email address. Foundry shall store details of and may use the email address to
notify you in accordance with the terms of this Agreement.

24. NOTICES

Any legal notices from the Licensee to Foundry should be sent via postal mail or international delivery
to The Foundry Visionmongers Ltd, 5 Golden Square, London, W1F 9HT, addressed to The General
Counsel. These notices will be effective upon receipt by Foundry. Additionally, a copy of the notice
should be emailed to Foundry at legal@foundry.com. Unless otherwise agreed in writing, any notices
from Foundry to the Licensee will be provided either (a) by email to the registered email address
associated with the Licensee’s account, or (b) in any other reasonable manner that involves specific
notification to the Licensee. Notices from Foundry to the Licensee will be effective (i) one day after
being sent by email, and (ii) five days after being posted or sent by international delivery service. The
Licensee agrees that service of process may be effected on the Licensee by registered mail sent to the
last known address on record with Foundry, if permitted by applicable law.

25. COMPLAINTS & ONLINE DISPUTE RESOLUTION PLATFORM

We hope that you are satisfied with any Software purchase made or service received from Foundry,
but if you have a complaint, in the first instance, please contact us on licenses@foundry.com or
through our Support Portal: https://support.foundry.com/hc/en-us (for technical support and bug
reports), or you can request a call back from the Sales team here: https://www.foundry.com/contact-
us.

Last updated 27 March 2025.
Copyright © 27 March 2025 The Foundry Visionmongers Ltd.

All Rights Reserved. Do not duplicate.
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