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1  PREFACE

Storm is designed to assist digital media production workflow by combining 
several traditional process steps. Storm preserves the original captured 
media at its native resolution and colour depth throughout the workflow 
simplifying the production process.

Storm’s key features include:

• Ease of operation—designed for use on or near set by directors, 
cinematographers, or continuity assistants.

• Minimal data loss—preserve the original captured media at its native 
resolution and colour depth.

• Real-time playback—play media and productions in real-time.

Production 
Workflow and 
Storm

So where does Storm fit into the production process? Storm was initially 
designed to fill a niche between onset filming and post-production 
processes like colour correction, visual effects (VFX), and sound editing. 
From there, Storm evolved organically to blur the line between the set and 
more technical processes like advanced editing.

Figure 1.1 shows a typical Storm production workflow combining some 
traditional production steps.

Figure 1.1: Typical Storm workflow



PREFACE 7
About this Guide 
About this Guide Throughout this User Guide, we assume you have a basic knowledge of 
video and audio theory, as well as proficiency with the operating system on 
which Storm is installed.

There are a few style conventions that you should be aware of throughout 
this Guide:

Note This text provides important or useful information for the smooth operation 
of Storm.

Tip These are extra bits of information, not necessarily critical to the procedure 
you’re performing, but worth knowing.

Bold text denotes onscreen points of interest such as tabs, buttons, and 
menu items.

Underlined text highlights links to cross references or our website with 
automatic redirection to the relevant page.

For the most up-to-date information, please see the Storm product page 
and the latest Storm User Guide on our website at www.thefoundry.co.uk.

Getting Help If you can’t find what you need in this document, there are other sources of 
help available to you for all aspects of Storm and its operation.

Online Help Most controls offer concise instructions in the form of tool tips. To display 
the tool tips, hover your mouse pointer over an interface control or 
parameter.

Figure 1.2: Tooltips
Storm 1.0v4The Foundry

http://www.thefoundry.co.uk


2  INSTALLATION AND LICENSING

Installing and licensing new applications can be a boring task that you just 
want to be done with as soon as possible. To help you with that, this 
chapter guides you to the point where you have a default Storm workspace 
in front of you and are ready to start viewing and editing your media with 
the minimum of effort.

System 
Requirements

Before you do anything else, ensure that your system meets the following 
minimum requirements to run Storm effectively:

• Mac Pro, MacBook Pro, or iMac running a minimum of Mac OS X Snow 
Leopard 10.6.4

• 2 GB of disk space available for caching and temporary files

• 2 GB of RAM (minimum requirement)

• Display with at least 1280 x 1024 pixel resolution and 24-bit colour

Installing Storm Download Storm from www.thefoundry.co.uk/products/storm/get/ by 
clicking Buy Storm.

Follow the on screen instructions to download the correct installer.

Mac OS X

1. Double-click on the .dmg archive to extract the installation package.

2. Double-click on the .pkg file.

3. Follow the on-screen instructions to install Storm. By default, Storm is 
installed to /Applications/Storm 1.0.

Launching and 
Licensing Storm

Storm requires that you obtain a licence at first start up. You can purchase 
activation keys over the Internet by clicking Purchase Licence in the Storm 
licensing dialog that displays when you launch Storm without a licence, or 
by contacting The Foundry Sales Department at sales@thefoundry.co.uk.

Launch Storm using one of the following methods:

Mac OS X

• Click the Storm dock icon.

http://www.thefoundry.co.uk/products/storm/get/


INSTALLATION AND LICENSING 9
Launching and Licensing Storm 
• Using the Finder, open the Storm application directory (by default, 
/Applications/Storm 1.0/), and double-click the Storm 1.0.app icon (or 
list item).

• Open a terminal and enter the following command:
open /Applications/Storm1.0v4/Storm 1.0.app

A Licensing dialog box displays.

Select an activation option from the Storm Licensing dialog: 

• Purchase Licence—click to open a web browser directly to The Foundry 
website to purchase an activation key. 

• Activate Key or Use Server—click to enter a previously obtained 
activation key. When you enter the activation key, Storm automatically 
obtains a licence from the web and installs it on your machine. 

Note Storm does not currently support Licence Servers.

• Obtain Trial Licence—click to automatically install a trial licence valid for 
15 days. Whenever you then launch Storm, the Licensing dialog displays 
how many days remain before your trial licence expires. Note that you 
can only obtain a trial licence for a major Storm release once on each 
machine (for example, if you had a trial licence for Storm 1.0v1, you can’t 
get another one for Storm 1.0v2 on the same machine).

Note You can select Help > Licence in Storm to display the Licensing dialog at any 
time.

Manual Licensing If the automated licensing provided with Storm fails, for example if your site 
has a strict Internet usage policy, you’ll need to obtain a licence manually. 
You’ll need the Foundry Licence Installer (FLI), your machine’s System ID, 
and a licence key. If you encounter any problems with licensing, go to our 
website’s support page at: www.thefoundry.co.uk/products/storm/support/
Storm 1.0v4The Foundry
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INSTALLATION AND LICENSING 10
Launching and Licensing Storm 
To licence Storm manually, do the following:

1. Download and run the FLI software package from: 
www.thefoundry.co.uk/support/licensing/foundry-licence-installer/rlm/

Your System ID is displayed at the bottom of the window.

2. Using an Internet browser, navigate to 
www.thefoundry.co.uk/products/storm/try/manual-install/

3. Enter your System ID and details in the fields provided and click 
Continue.

The field at the top of the screen contains your licence key, which 
should look something like this:

LICENSE foundry storm_i 1.4 permanent uncounted   
hostid="d49a20e90cea" share=h start=29-nov-2010  
issuer=website issued=29-nov-2010 _ck=6f589821dd 
sig="60P0452V06MDS  
AP8MWWNYVF8YRP56U26SDH8H0022GD4MSFP940PHQ74M4V6T7514GEH4
Y18CV"

4. Drag-and-drop, or copy and paste, the licence key into the FLI window 
to install the licence.

5. Start Storm using one of the following methods:

Mac OS X

• Click the Storm dock icon.

• Using the Finder, open the Storm application directory (by default, 
/Applications/Storm 1.0/), and double-click the Storm 1.0.app icon (or 
list item).

• Open a terminal and enter the following command:

open /Applications/Storm1.0v4/Storm 1.0.app

The default Reviewing workspace displays.
Storm 1.0v4The Foundry
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INSTALLATION AND LICENSING 11
Troubleshooting Licensing 
Troubleshooting 
Licensing

If the following screen displays, there is a problem with the connection 
between Storm and our website. 

• Check your Internet connection and click OK to try again, or

• Install you licence manually using the steps described in 
Manual Licensing.

Using Proxy Servers If you use a proxy server to connect to the Internet:

1. Click Use Proxy and enter your proxy server information in the Server, 
Username, and Password fields.

2. Click OK to try again.

For other licensing problems, go to our website’s support page at: 
www.thefoundry.co.uk/products/storm/support/
Storm 1.0v4The Foundry
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3  IMPORTING MEDIA

The first step in any Storm Production is to import your media files to the In 
Tray within your Production. There are a number of ways to do this, and 
each method depends largely on the quantity of media you’re working with.

Note Before you begin, it’s always a good idea to back up your raw media to at 
least one other location.

Using Drag-and-
Drop

Storm allows you to quickly load media from the Finder directly using drag-
and-drop. Simply locate your media in the Finder and drag the clip, folder, 
or folders into Storm’s Production tab or Viewer.

Storm automatically sorts through the folders you drag-and-drop and only 
imports supported file types, ignoring any files that were imported 
previously—you cannot import duplicate files into Storm.

Note Storm 1.0v4 supports EPIC and HDRx in addition to regular R3D files.

All media loaded using drag-and-drop is placed in the In Tray in the 
Production tab.
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Using the File Menu 
Using the File Menu If you’re used to working with menus, you can also import clips using the 
file browser. You can import individual clip files or entire folders, depending 
on the amount of media you intend to use.

1. Navigate to File > Import Clips or Import Folders.

Tip You can also use the cmd/Ctrl + I and shift + cmd/Ctrl + I hotkeys.

A browser dialog box displays.

2. Select the file(s) or folder(s) that you require and click Open.

Storm automatically sorts through the folders you select and only 
imports supported file types.

Note Storm 1.0v4 supports EPIC and HDRx in addition to regular R3D files.

All media loaded using Import Clips or Import Folder is placed in the In 
Tray in the Production tab.
Storm 1.0v4The Foundry



4  RECONNECTING AND CONFORMING MEDIA

Storm automatically attempts to reconnect and conform imported Storm 
Productions or Final Cut Pro XML with the original source files during 
import. This process recovers all the grades you applied in Storm and 
applies them to the imported files.

Note You may need to reconnect your Production or XML manually if the location 
of your media has changed, for example if you originally read the source 
files from an external drive.

Loading Storm 
Productions

When you load a Production, Storm checks the file paths to the media used 
and attempts to reconnect and conform the files automatically.

To load a previously saved Production on Mac OSX:

1. Navigate to File > Open... or use the cmd + O hotkey.

The Choose a Storm project file dialog box displays.

2. Locate your Production and click Open.

Storm opens your Production and attempts to reconnect and conform 
the source files. 

Manual Reconnection If the file paths have changed, for example, when you load a Production 
created remotely, some or all of the media may appear Offline.
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Loading Storm Productions 
1. Right-click the offline media and select Reconnect Media...

The Choose directory to search for media dialog box displays.

2. Browse to the location of the source files and click Choose.

Storm reconnects and conforms the source files from the directory you 
selected.

A progress dialog reports the number of successful re-connections.

3. Repeat the Reconnect Media process for all the offline media.
Storm 1.0v4The Foundry



RECONNECTING AND CONFORMING MEDIA 16
Importing XML 
Importing XML Storm can read existing clip, Bin, or Timeline XML files created by Final Cut 
Pro and reconnect and conform the XML with the original files. Storm can 
process the XML if it was originally created in Storm and round-tripped to 
Final Cut Pro and back again, or if the XML was created in Final Cut Pro 
using QuickTime reference files and then imported.

Note QuickTime files that were not created by Storm do not carry effects over 
from Final Cut Pro.

Reconnecting XML When you load XML from Final Cut Pro, Storm checks the file paths to the 
media used and attempts to reconnect and conform the files automatically. 

Note If you know where all the source media used by the XML resides, you can 
pre-import the files manually and then import the XML to auto reconnect 
and conform the Production.

1. Import your XML file:

• Locate your XML in the Finder and drag the file to Storm’s Production 
tab,

OR
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Importing XML 
• Import your XML using the File > Import Final Cut Pro XML menu 
option, locate your XML and click Open.

Storm opens your XML and attempts to reconnect and conform the 
source files. 

Unless you pre-imported your source files, your media appears as 
offline.

2. Right-click the offline clip, Bin, or Timeline and select Reconnect Media...
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Importing XML 
The Choose directory to search for media dialog box displays.

3. Browse to the location of the source files and click Choose.

Storm reconnects and conforms the source files from the directory you 
selected.

A progress dialog reports the number of successful re-connections.

4. Repeat the Reconnect Media process for all the offline media.

Tip You can also import XML directly into Storm Timelines for concurrent 
editing, preserving your edits, but adding grades from third party 
applications. See Applying Grades to Timelines for more information.
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5  CUSTOMISING YOUR WORKSPACE

Workspace 
Overview

Storm’s interface is customisable using floating panes and show/hide 
functionality, but two default workspaces are supplied for your 
convenience; Reviewing and Editing.

• The default Reviewing workspace is used primarily to confirm your media 
intent is fully realised before proceeding to the editing stage of post-
production. You can add tags and notes, set clip In and Out markers, and 
organise your media into bins as required.

• The Editing workspace provides the tools you’ll need to fine-tune your 
media, add visual effects, synchronise audio, and export your finished 
product.

Launch Storm and take a moment to familiarise yourself with the default 
Reviewing workspace.

1. Production tab—manage all aspects of your projects and Bins.

2. Menu bar—access Storm’s drop down menus.

3. Viewer tab—display and review your media.

4. Effects tab—displays any effects applied to the clip in the Viewer.

5. Waveform and Histogram tab—displays Luma and RGB information for 
the currently selected Viewer.

Viewer Effects

Waveform

MenuProduction
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Creating Your Own Workspace 
Menu Bar Components The Menu Bar contains various Storm controls, many of which are available 
through context sensitive right-click menus, keyboard shortcuts, and 
toolbars. 

For a full list of hotkeys, buttons, and menu functions refer to Appendix A: 
Storm Hotkeys.

You can switch between workspaces by navigating to Window > Workspace 
and selecting Editing or Reviewing as shown. Alternatively, you can toggle 
between the default workspaces using cmd/Ctrl + 1 and cmd/Ctrl + 2.

Any custom workspaces you create are added to the end of the list. You can 
access the first custom workspace using cmd/Ctrl + 3, and so on.

Creating Your Own 
Workspace

Storm’s workspace consists of panes, which act like containers, and tabs 
which describe the individual areas you work with in Storm. During the 
customisation process, you can:

• Resize your entire workspace or panes independently.

• Split panes to create new work areas, for example two Viewers side-by-
side.

• Add and remove panes and tabs as required.

• Float and nest tabs to group similar functions together, for example 
Histogram, Vectorscope, and Waveform in the same pane.

• Maximise the pane under the mouse cursor by pressing ~ (tilde). Press ~ 
again to return to the regular interface.

Storm allows you to create as many workspaces as you require, one for each 
project you undertake if necessary. In practice though, you may find that 
two or three custom workspaces will cover your needs.

Tip You can return to the saved version of a workspace by navigating to 
Window > Workspace > Reset Workspace.
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Creating Your Own Workspace 
Resizing your workspace

Resizing the interface, panes, and tabs works in much the same way as 
other software applications:

• To resize the entire interface, drag the resize handle at the bottom right 
of the application to the required width and height.

• To resize individual panes, hover the mouse over the edges of the 
required area until the cursor changes to the resize icon. 
Click and drag the cursor to resize the pane or tab.

Splitting panes

Splitting panes allows you to organise your workspace into distinct areas 
delineated by well defined borders.

• To split panes, right-click the required pane and select Split Vertical or 
Split Horizontal.

Adding and removing panes and tabs

Adding and removing tabs gives you the freedom to personalise your 
workspace depending on your current production.

• Add new tabs by navigating to Window and selecting the required tab.

The tab is embedded in its default position or added to the interface as a 
floating window. 
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Creating Your Own Workspace 
• Close any pane or tab that is not required by:

• Clicking the x in its top right-hand corner,

OR

• Right-clicking the tab name and selecting Close Pane or Close Tab.

Floating and nesting

You can move existing panes and tabs to new locations in the interface (to 
help you organise your production).

• Float a pane or tab by:

• Clicking the  icon in its top right-hand corner,

OR
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Creating Your Own Workspace 
• Right-clicking the tab name and selecting Float Pane or Float Tab.

OR

• Dragging the required tab from its current location.

• Nest any floating pane or tab by dragging it to any existing pane.

Tip Use the orange highlight  around the destination pane to help you 
determine where the tab will be nested.
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Creating Your Own Workspace 
Saving Workspaces Once you’re happy with the changes you’ve made to the workspace, 
navigate to Window > Workspace > Save Workspace.

Enter a name for the workspace, then click OK to preserve your workspace 
as a Storm workspace file (extension .stws).

Tip If you save a workspace called Editing or Reviewing, you can override the 
default supplied with Storm by clicking Save in the dialog box.

Delete the workspace you created to restore the default layout.
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Creating Your Own Workspace 
Loading Workspaces To use a previously saved workspace, navigate to Window > Workspace and 
select the custom workspace name you require.

Tip Alternatively, you can use the workspace hotkey cmd/Ctrl + n (where n = the 
number of the custom workspace).

Your presaved workspace is loaded.

Deleting Workspaces You may find that after using Storm on a number of productions, some of 
the workspaces you created earlier have been superceded by more useful 
entries. Delete Workspace allows you clear up your saved files from within 
Storm, although you can remove the files manually from the save location.

Tip You can return to the saved version of a workspace by navigating to 
Window > Workspace > Reset Workspace.

To delete custom workspaces: 

1. Navigate to Window > Workspace > Delete Workspace.

2. Select the required workspace from the drop down menu.

3. Click OK to delete the selected entry.
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Workspace Preferences 
Workspace 
Preferences

The Preferences dialog allows you to make global changes to the way the 
interface behaves every time you start Storm. Changes you make in the 
Preferences override any local changes when you restart Storm.

To access the Preferences dialog, either:

• Navigate to Storm > Preferences, or

• Use the Preferences hotkey cmd/Ctrl + , (comma).

• General preferences take care of how Storm starts up and how often 
your work is automatically saved.

• Startup Workspace—select the default workspace Storm loads at 
startup.

• Show splash screen—enable or disable Storm’s product page during 
startup.

• Autosave period—set how often you want Storm to save your work in 
the background. Use the up and down arrows or type a new value in 
the field.

• Advanced Mode—enable or disable the bit depth dropdown in the 
Viewer and Export dialogs. Advanced Mode is disabled by default.

• Restore workspace—whether Storm restores the saved workspace lay-
out or uses the default Reviewing or Editing workspaces when you 
open an existing Production.

• Automatically save RMD files—enable this option to automatically 
save changes you make to clip RED Look effects as RMD files. See 
About RMD Files for more information.

• Show popup clip overlay—enable or disable the thumbnail mouse-over 
popup containing clip information and mini playback controls.

• Viewers preferences determine the default settings for the Viewer at 
startup as well as all new Viewers that you add to the workspace—you 
can still adjust the settings of individual Viewers.

• Guides—select the default Guides to apply to Viewers. Choose from No 
Guides (the default), Title Safe, Action Safe, and Both.
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Workspace Preferences 
• Avid Artist Color Panel preferences allow you to enable or disable the 
use of control surfaces. See About Control Surfaces for more 
information.

• Scopes preferences set the Black and White points for Histogram and 
Waveform Out of Range warnings individually, in the range 0-1. See 
Using Scopes for more information.

• RED Rocket Card preferences determine the default settings for RED 
Rocket output.

• Select Enable monitor output to use the RED Rocket’s monitor output 
function.

• Enable Progressive Segmented Frames to send progressive signal as if 
it were interlaced.

• Use the dropdown menus to set Storm’s output to match the monitor 
you intend to use:

• Resolution

• Colour Space

• Bit Depth

• Frames Rate (fps)

Once you’ve made your selections in the Preference dialog, click OK to save 
your changes. Bear in mind that changing some preferences, for example 
Use RED Rocket card and Scopes, require you to restart Storm before 
they’re applied.

You can also click Restore Defaults to return to the original Preference 
settings.
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About Control Surfaces 
About Control 
Surfaces

Storm supports the use of the Avid Artist Color Panel in conjunction with 
effects applied to clips in the Viewer. Any effect in the Effects Stack can be 
mapped to the panel, for example Lift Gamma Gain, and is adjustable using 
the wheels on the panel.

To help you get started using the panel to complement Storm’s Effects 
Stack, run through the following example setup and use instructions.

1. Plug the panel directly into the computer currently running Storm, using 
a standard Ethernet cable.

2. Ensure that the panel is enabled in Workspace Preferences (see above).

3. Drag a clip to the Viewer.

4. Go to Storm > Effect and drag the Lift Gamma Gain effect to the Viewer.

By default, the panel focuses on the RED Look effect in the Effects 
Stack.

5. To select the Lift Gamma Gain effect, either:

• Use the panel shift + Page  buttons to move down the Effects Stack 
to Lift Gamma Gain, or

• Select Lift Gamma Gain using the mouse.

6. Move the panel wheels to adjust the Lift Gamma Gain settings.

For more detailed setup and use instructions, see the Avid website at 
http://euphonix.avid.com/artist/ux/euphonix/artist-support.html
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6  REVIEWING AND ORGANISING YOUR MEDIA

In the film industry, reviewing your media at the beginning of the day is the 
norm. This media is often referred to as Dailies. One of Storm’s most 
powerful features is realtime playback—having the power to review your 
media onset—enabling you to view Hourlies, preventing wasted time earlier 
in the production workflow.

The default Reviewing workspace is designed for viewing Hourlies, 
providing a large Viewer, scopes, and Tags so you can evaluate your media 
onset.

About Clips Storm’s interface sorts your clips into three broad categories: Audio and 
Video, Audio Only, and Video Only. Clips are displayed differently depending 
on their content, location, and in the case of the Viewer, the current mode 
(see Viewer Tools):

Clips in Bins

Clips in the Viewer

Audio and Video Audio Only Video Only

Audio and Video Audio Only Video Only
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Viewing Media 
Clips on the Timeline

For more information on Timelines, see Using the Timeline.

Viewing Media The Viewer is where your media is displayed and manipulated as well as 
where you apply tags and effects. When using the Reviewing workspace, the 
Viewer is set by default to be the main focus of the interface.

To view your media in the Viewer, simply drag-and-drop the file or files 
from the Production tab in to the Viewer. Any duplicate clips discovered by 
Storm are ignored during the import process.

Note All your media resides in the Production tab In Tray by default.

Viewer Tools The Viewer, in both the Reviewing and Editing workspaces, has two sets of 
tools for manipulating your media: the view tools and the playback tools.

The view tools, located at the top of the Viewer, are used to affect the 
mouse pointer as you move over the Viewer, and to select Viewer 
preferences. 

Audio and Video Audio Only Video Only
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Viewing Media 
Icon Function Description

Pan Click and hold to pan around the Viewer if the image is larger than 
the window.

Colour 
Sample

Enable or disable the RGB colour information sampler in the Viewer.

Magnifier Enable or disable the spot magnifier. Drag the tool over the Viewer 
to enlarge areas of the media temporarily.

ROI Click and drag to define a Region of Interest (ROI) in the Viewer. The 
scopes only display information within the ROI, when active.

Show 
Overlays

Enable or disable overlay bounding boxes, for example Action Safe.

Show 
Masks

Enable or disable a range of Viewer masks, for example 16:9.

Clipping 
Warning

Enable or disable Storm’s clipping warning tool to alert you when the 
image is under or over exposed.

Transform Change the orientation of the clip(s) in the Viewer. Select from 
Rotate, Flip Horizontal, and Flip Vertical.

Note: Transforms in the Viewer do not affect your final exports.

Channels Select the channel(s) to output to the Viewer, for example RGB, sin-
gle channel, or Luma.

Playback 
Mode

Select the playback behaviour for Viewer output. Select from Con-
tinue, Repeat, Bounce, and Stop.

Viewer 
Mode

Select the Viewer display mode, for example Audio and Video or 
Video Only.

RED Rocket 
Indicator

Lights when a RED Rocket card is installed on the machine running 
Storm. See RED Rocket Options below for more information.

Toggle 
Effects

Enable or disable the Effects Stack applied to the current clip.

Set Thumb-
nail Image

Click to set the current Viewer frame as the clip’s thumbnail in Bins.

Bit Depth Set the bit depth displayed in the Viewer, for example 8-bit or Half 
Float.

Note: The Bit Depth dropdown menu is only displayed if you enable 
Advanced Mode in the Preferences dialog. See Workspace Prefer-
ences.

Image Quality Set the Viewer image quality for working with low powered 
machines, for example Full Quality, Quarter, or Sixteenth.

Scale Set the scale applied to the clip in the Viewer, for example 25%, 
75%, or Fit.
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Viewing Media 
RED Rocket Options Using a RED Rocket card with Storm increases the rendering speed and adds 
the option to pipe your output to a monitor as well as the Viewer.

The RED Rocket icon has five states:

To modify the RED Rocket options: 

1. Click the  icon in the Viewer.

Note You must have Use RED Rocket enabled in the Preferences dialog to access 
these options. See Workspace Preferences for more information.

The RED Rocket Settings dialog displays.

2. Temporarily disable the RED Rocket card by deselecting Use RED Rocket 
card. Unlike the option in the Preferences dialog, changing this setting 
does not affect Storm at startup.

3. Select Enable monitor output to use the RED Rocket’s monitor output 
function.

Inactive—the RED Rocket card is either not present or inactive.

Firmware error—there is a problem with the card firmware. Hover 
the mouse over the icon for more information.

Monitor active—the monitor is enabled and working correctly. 
Hover the mouse over the icon for more information.

Active—the RED Rocket card is present and active.
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Viewing Media 
4. Use the dropdown menus to set Storm’s output to match the monitor 
you intend to use:

• Resolution

• Colour Space

• Bit Depth

• Frame Rate (fps)

5. Enable Progressive Segmented Frames to send progressive signal as if it 
were interlaced.

6. Click OK to save your settings.

Playback Tools The playback tools manipulate the media itself, in much the same way as 
other editing or playback software.

The playback tools can be summarised as follows:

• In and Out markers—numerical representations of the clip In and Out 
markers. See Editing and Effects for more information on In and Out 
markers.

• Playhead position—numerical representation of the current position of 
the playhead.

• Display Mode—select the timing method to display during playback:

• Timecode (TC)—displays the playhead position within the current clip 
irrespective of the number of clips in the Viewer.

• Absolute Timecode (AC)—displays the Time of Day (ToD) inherited 
from the camera or timecode imposed on the media from an external 
source, for example a Jam sync source such as an Audio recorder. 

Timecodes imposed by external sources are suffixed with • (jam) as 
shown in Figure 6.1.

Figure 6.1: External Timecodes.

Playhead Position Out Marker 
Position

In Marker 
Position

Playback Controls
Display 
Mode
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About Anamorphic Media 
• Edge Code (EC)—displays the clip edge code read from the current 
clip’s metadata. 

• Clip Frames (CF)—displays the frame number in the current clip read 
from the clip’s metadata.

Note In dedicated Timeline Viewers, sometimes known as Record Viewers, the 
Clip Frames timecode is renamed Timeline Frames. 

• Drop Frame—is a timecode display option that leaves out two frames 
from the 30 fps timecode sequence every minute (except every 10th 
minute) so that long running NTSC timelines are accurate to a real-
time clock (NTSC framerate is 3000/1001, or approximately 0.01% 
slower than 30fps).

Drop Frames cannot be used when CF is selected as the Display Mode.

Note Enabling Drop Frame is a Timecode display feature only—the source media 
remains a continuous stream of frames.

• Playback controls—standard media playback controls including 
continuous or by frame forward and backward, skip to next or previous 
edit, and skip to start or end of all clips.

The following table describes playback behaviour depending on the Play-
back Mode selected. 

About Anamorphic 
Media

Storm automatically recognises anamorphic clips and displays them with a 
2:1 aspect ratio. When you’re ready to export an anamorphic clip, you can 
select whether or not to preserve the aspect ratio using a dropdown menu 
in the Export dialog. See Managing Storm Output.

If for any reason you want to display an anamorphic clip with a 1:1 aspect 
ratio, right-click in the Viewer displaying the clip and deselect the 

Mode Description In/Out Effect

Continue Play once through all clips in the Viewer sequentially. In-Out range has 
no effect.

Repeat Play through the current clip from start to finish in an infi-
nite loop.

Repeats within the 
In-Out Points.

Bounce Play through the current clip from start to finish then 
reverse to the start of the clip and stop.

Bounces within the 
In-Out Points.

Stop Play through the current clip from start to finish then stop. Play through to the 
Out Point.
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Anamorphic checkbox.

Using Scopes Storm provides three realtime scopes to help you evaluate your media. 
Realtime scopes provide data as the Viewer plays your clip, but you can also 
view the scopes frame by frame if you prefer.

Histogram The Histogram provides three colour channel and luma channel information 
that describes the distribution of red, green, blue, and luma pixels 
throughout the current frame. 

The Histogram graphs the number of pixels at each brightness level, and 
from left to right, the areas of the Histogram represent shadow, mid tones, 
and highlights.

There are also Viewer and Channel selection controls on the Histogram tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Histogram output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

Viewer 
Selection

Channel 
Selection
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• Channel selection—select the channel information to output. The default 
setting displays RGB and Luma, but you can break the view down to just 
RGB or single channels.

The scopes feature global customisable guides to help you grade your clips. 
Navigate to Storm > Preferences > Scopes and enter values between 0 and 
1 for the Black and White points.

The guides at the edges of the Histogram turn red to warn you when the 
distribution is out of range:

Waveform The Waveform scope provides information on clip luminance, or brightness, 
which you can use to decide whether the clip is over or under exposed. The 
white traces represent luminance values from 0 - 100% (black through the 
spectrum to white). The higher the waveform, the brighter the image in the 
Viewer.

Shadow 
Guide

Highlight 
Guide

Viewer 
Selection

Mode 
Selection
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The upper white marker is used to measure when over exposure could be a 
problem. If your waveform has a lot of traces over the white marker, you 
should consider reducing the brightness of the clip. The opposite is true of 
the lower black marker.

There are also Viewer and Mode selection controls on the Waveform tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Waveform output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

• Mode selection—select the mode to output. The default setting displays 
Luma only, but you can also view the RGB channels ganged together or 
separately.

The scopes feature global customisable guides to help you grade you clips. 
Navigate to Storm > Preferences > Scopes and enter values between 0 and 
1 for the Black and White points.

The guides at the top and bottom of the Waveform turn red to warn you 
when the distribution is out of range:

White Guide

Black Guide
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Vectorscopes Vectorscopes display colour, saturation, and hue information for the 
current frame. Similar to colour wheels, Vectorscopes display information 
radially, from the centre outward. The further from the centre the data 
spans, the more saturation is represented.

In Figure 6.2, you can see that the frame represented contains mostly 
yellows and reds, but the values are not oversaturated. Figure 6.3 
represents a badly saturated frame. Notice the spill of yellow traces 
distributed toward the edge of the scope pass the target (the highlighted 
square).

There is also a Viewer selection control on the Vectorscope tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Vectorscope output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

Using Tags During the review process, you can use Tags to mark shots of a particular 
type or content as you organise your production into Bins ready for editing. 
The default Tags supplied with Storm include good and bad shots, colour 
codes, and 1-5 star quality Tags. You can also create custom Tags by right-
clicking in the right hand side of the Production tab or by pressing cmd/Ctrl 
+ Y. You can apply Tags to frames, clips, or all clips currently in the Viewer.

Note There is no limit to the number of Tags you can apply, but the playback 
toolbar can become cluttered if you apply Tags to every frame.

Figure 6.2 Normal saturation. Figure 6.3: High Saturation.
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Using Tags 
To apply a tag to your media, use the playback tools to move to the 
required frame and drag-and-drop the tag from Production > Storm Presets 
> Tags to the Viewer.

Drop the tag on Tag this frame, Tag whole clip, or Tag all clips as required.

Tags applied to frames appear above the Viewer playback tools in the clip 
Timeline.

Tip Use Shift +  or  to skip to the next or previous Tag on the current clip or 
reposition Tags by dragging them along the Timeline.

Tags applied to entire clips appear above the Viewer, next to the Image 
Quality dropdown menu.

Adding Notes to Tags In some cases, a simple Tag on a frame or clip may not contain all the 
information that you wish to pass on to the next stage of production. 
Adding a note to a Tag can provide that extra detail.

Note To delete a note, don’t click Delete, because this refers to the Tag. Instead, 
delete the notes in the window and click OK.

Tags Playhead

Tags
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1. Add notes to Tags by clicking on the required Tag and entering text. The 
example shows a note added to a clip Tag, but you can also add notes to 
frame Tags in the same way.

2. Click OK to save the note.

Filtering and Flagging 
Media Using Tags

Once all your media is tagged as required, you can use Storm to search for 
clips containing certain tags, for example, if you wanted to find all clips that 
you tagged as 3 Star quality.

There are two types of Tag search you can perform: Filter and Flag. Select 
the desired search type by clicking the magnifier icon in the Production tab.

• Filter—displays all clips that contain the specified tag. This is the default 
search method.

• Flag—displays all clips and marks the items that don’t match the search 
tag.

Drag the required Tag from the Production tab into the search box and 
select the Bin or Bins you want to Filter or Flag.

Tip If you have more than one search criteria, click the icons in the search box 
to display a brief description of the icons.

Filters and flags persist until you change the search criteria or click the 
icon in the search box.
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You can select multiple search items and move left and right through the 
criteria, as well as remove individual criteria by pressing Backspace. See 
Appendix A: Storm Hotkeys for more information.

The examples below show Storm Filtering the In Tray to display only media 
with the 3 Star Tag applied and Flagging all media that doesn’t have the 3 
Star Tag applied to it.

Creating Custom Tags While using Storm you may find that you require a specific Tag or suite of 
Tags that are not provided by default. Creating Custom Tags allows you to 
really control the organisation of your media, and you can even create your 
own Tag icons.

Tip Move your Custom Tags to the User Presets > Tags Bin so that you can 
access them across all your Productions.

To create a Custom Tag, do the following:

1. Select the Bin to contain the Tag in the Production tab.

2. Navigate to File > New Tag, or press cmd/Ctrl + Y.

The new Tag is placed in the selected Bin.

Filtering... ...and Flagging
Storm 1.0v4The Foundry



REVIEWING AND ORGANISING YOUR MEDIA 42
Using Tags 
3. Double-click the Tag to open the Edit Tag dialog box.

4. Enter a name for the Tag in the description field.

5. Click the Tag dropdown menu to select an icon for the Custom Tag.

Tip You can import your own image for the Tag by selecting Assign to open the 
Finder.

6. Click OK to save your changes.
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Viewing Metadata 
Removing Tags To remove a Tag from a frame or clip, click the Tag and click Delete.

You can remove all Tags from a clip or selection of clips by right-clicking 
your selections in the Media Pool and choosing Clear Tags.

Viewing Metadata Metadata is information that describes media content, separate from the 
clip itself, in the form of a table on the Metadata tab. Types of metadata 
include Duration, File Size, the Camera used to record the clip, and RED Look 
data.

Some metadata cannot be edited using Storm, for example the items under 
the RED Clip section shown below. Other areas such as RED Look (User) and 
User data update as you make edits, change settings, or add Tags.
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Viewing Metadata 
To view Metadata for a clip, drag-and-drop the clip in to the Viewer and 
select the Metadata tab.

Tip If the Metadata tab is not populated automatically, click the clip in the 
Viewer to update the information.

Filtering and Flagging 
Media Using Metadata

If searching using Tags has not filtered your media effectively, you can use 
Storm to search for clips containing certain Metadata, for example, if you 
wanted to find all clips that had a particular Resolution or Frame rate.

To filter or flag using Metadata, you must create a Metadata Template to 
use in the search function:

1. Select the data to filter by clicking the required entry in the Metadata 
tab.

Tip You can select more than one entry by holding cmd/Ctrl and clicking to add 
items.

2. Click Create Template.
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A Templates folder is added to the Production tab, and the new tem-
plate is placed inside.

Note If a Templates folder is already present, the new template is placed in the 
existing folder.

3. Rename the Template by clicking the new entry and typing a new name.

4. Use the Template as a filter or flag by dragging the Template to the 
search box as described in Filtering and Flagging Media Using Tags.

About Bins The term Bins originates from when film clips were actually stored in 
physical containers during the editing process, and Storm continues this 
tradition by using this naming convention for the folders in which your 
media is stored and organised.

The Reviewing workspace contains several Bins by default to help you begin 
organising your clips, Tags, and Looks.

• Scale Slider—adjust the size of your thumbnails. This slider is not 
available in the text only Display Mode.

• Search Box—filter or flag your media using Tags, Metadata, or Looks. 
See Filtering and Flagging Media Using Tags for more information.

Search
Box

Default 
Bins

Display 
Mode

Scale Slider
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• Default Bins—basic Bins containing Tags, Effects, and the In Tray. See 
Default Bins for more information.

• Display Mode—select the display mode from thumbnails, small 
thumbnails and text, or text only.

Bins can contain all file types used by Storm including other Bins, effects, 
Tags, and Looks.

Default Bins The default Bins are always present when you open a new Storm Production. 
These basic Bins are used to differentiate between types of content as 
described below:

• Storm Presets—this Bin contains all the default Tags, Looks, and Effects 
that are available for new Productions.

• User Presets—this Bin contains any custom Tags or Looks that you save 
when using Storm. Files saved in the User Presets Bin are available 
across all future Productions.

• Untitled 01—you should rename this Bin using File > Save Untitled 01 as 
your current Production and store files that are only associated with the 
current Production.

Creating Bins To create new Bins, navigate to File > New Bin or press cmd/Ctrl + B. New 
Bins are added to the currently selected location, or to the default 
Production Bin if nothing is selected.

To rename a Bin, click the new Bin and type a name in the field provided.

You can move Bins, effects, Tags, and Looks around by dragging and 
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About Bins 
dropping them to a new location.
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Editing Your Media Once you’ve organised your media, you’re ready to start the editing 
process. You can remove audio or video tracks, add In and Out Points to 
create more accurate selections, cutting out parts of the media you don’t 
require, and add some colour, grade, and other effects before adding your 
clips to the Timeline.

Removing Tracks from 
Clips

Linked audio and video tracks in the same clip are not always required and 
Storm allows you remove either track from a clip and create a new clip in 
the In Tray.

1. Select the required clip or clips in the Production tab and right-click on 
a selection to display the context menu.

2. Select Remove Audio or Remove Video from the list.

New clips are added to the In Tray with the same name as the source. 
Notice that the Audio icon at the top-right of the clip or the video 
thumbnail is removed from the new clip.

Note You can relink video only clips with independent WAV files using Sync 
Media. See WAV Clip Tracks for more information.
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Using In and Out 
Markers

In and Out markers enable you to trim clips down to just the portions of the 
media that you require. These markers don’t alter the length of the source 
clip, but instead, tell Storm which part of the clip you want to use.

The source In and Out markers define the actual start point and duration of 
the clip. The remainder of the source clip not required is known as the clip 
’head and tail’ or ’handles’. When a source clip containing In and Out points 
is added to a Timeline, you can slip the clip around the markers to adjust the 
clip’s output. See Timeline Editing Tools for more information.

Figure 7.1: Clip Handles

To set In and Out markers:

1. Move the playhead to the location of the In Point and press I on your 
keyboard.

The In Point is marked by the In tab and the time is recorded on the 
playback controls pane.

Note See Playback Tools for a description of the various Time Codes you can use.

2. Move the playhead to the location of the Out Point and press O on your 
keyboard.

Source Clip

Timeline Clip

OutIn

Head Tail
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The Out Point is marked by the Out tab and the time is recorded on the 
playback controls pane.

Tip You can also set markers by navigating to View > Mark In or Mark Out.

Click and drag the markers to adjust their position or clear the markers from 
your clip by navigating to View > Clear In and Out Points. The markers are 
removed completely, but you can reapply them by repositioning the 
playhead and pressing I or O.

See Exporting Trimmed R3Ds for details on using In and Out points to trim 
R3D source files.

Using Time Code Fields Storm’s Viewer Time Code fields are used to place the playhead or In and 
Out markers with more accuracy than placing them manually. There are 
three fields corresponding to In Point, playhead, and Out Point respectively.

You can enter absolute, partial, and relative Time Code values for each 
individual field, and if you like, you can even exclude the separators.

•  Absolute—places the marker at the point selected in real time, providing 
that the value is not out of range in the selected clip. Absolute markers 
always contain eight digits.

Example Result

01:05:43:21 Places the selected marker at 1 hour, 05 minutes, 43 seconds, and 21 
frames

01054321
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• Partial—alters the current position of the marker depending on the 
current position. Partial markers can contain up to seven digits.

• Relative—uses + and - values to alter the position of the marker relative 
to its current position. Relative markers are valid from ± 1 to 99999999.

Note See Playback Tools for a description of the various Time Codes you can use.

Applying Effects Storm has a versatile Effects palette for use with your media, including 
transform, colour, and blur effects. Effects can be added by drag-and-drop 
from the Production tab to either the Viewer or the Effects Stack.

You can drop effects directly into the Effects Stack—either above or below 
existing effects—as long as the orange highlight is visible before you drop 
the effect.

Note You cannot drop effects above the RED Look effect.

Any number of effects can be added to clips and are stored in the order they 
were applied in the Effects Stack.

Current Position Example Result

01:05:43:21 01 01:05:43:01

02:01 01:05:02:01

0201

Current Position Example Result

01:05:43:21 +1 01:05:43:22

-110 01:05:42:11

+10000 01:06:43:21

-100000 00:05:43:21
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Applying Effects 
The RED Look Effect It’s worth noting here that all R3D clips include a RED Look effect with three 
modes that can be applied to the entire clip or individual settings and handy 
White Balance and curve tools.

• RED Look—this mode contains all the input decisions made by the on set 
cameraman. Click the red buttons to apply the RED Look.

• Default—this mode applies the RED camera factory settings, that is, 
none of the on set decisions are included. Click the green buttons to 
apply the camera default settings.

• User—this mode records any changes that you make to the RED Look 
effect. Click the yellow buttons to apply your changes.

• Clip Overrides—use the clip overrides to apply the above modes across 
the entire clip. As the name suggests, selecting overrides removes any 
modifications you may have made, but you can retrieve them using the 
User buttons on individual settings.

• White Balance—quickly adjusts the Kelvin and Tint RED Look settings. To 
use the tool, click the dropper icon and use the dropper tool to select a 
colour you recognise as white in the Viewer. If you use this tool 
repeatedly, you’ll notice that selecting the dropper tool temporarily turns 
off your previous White Balance effect so it’s easier for you to see the 
true colours of your footage and select the colour you want to mark 
white. 

Override Buttons

RED Look 
Buttons

Default 
Buttons

User 
Buttons

White 
Balance
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Tip You can use the colour picker window in the top left corner of the Viewer to 
help you select colour values closer to 1.0 for the white.

Click on the selected white in the Viewer to White Balance the clip. 
Notice the Kelvin and Tint values are adjusted and the User mode but-
tons are activated.

• Curves—used to adjust channels in the current clip. Select the required 
channel from Master (or RGB), Red, Green, or Blue.

Use the mouse to drag-and-drop a point anywhere along the curve to a 
new value. The example shows a high Red and low Green and Blue values. 
The Master curve is at its default value.

• Lift Gamma Gain—used to adjust the Lift, Gamma, and Gain values using 
colour wheels or sliders. The Lift Gamma Gain tools in the RED Look 
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effect work in a similar way to those supplied in the Storm effect, but 
with more emphasis on the Redcine-X math.

About HDRx Clips High Dynamic Range (HDR) clips shot on EPIC cameras simultaneously 
record two values for each frame, resulting in High and Low exposure 
information which Storm can read individually.

You can view HDRx clips in the same way as any other clip, but there are 
two unique identifiers for HDRx—the Metadata and REDLook effects.

HDRx Metadata

Drag-and-drop an HDRx clip to the Viewer and open up the Metadata tab. 
Expand the RED Look (User) and RED Clip fields to see the HDRx specific 
metadata:

Note The Metadata tab shown is truncated for ease of reference.

• Exposure—displays which exposure setting is currently displayed in the 
Viewer. A value of 0 refers to High exposure, and 1 refers to Low 
exposure.

• HDRx—displays whether or not the clip currently in the Viewer is HDRx.
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HDRx REDLook

All HDRx clips have an extra REDLook effect included, just above the Image 
dropdown in the Effects tab.

The Exposure type you select in the REDLook sets the exposure level carried 
over into the Timeline or export, so make sure you set the correct level 
before proceeding.

Using the Effects 
Stack

The Effects Stack displays all the effects applied to the current clip, 
including the RED Look settings. Effects are displayed in chronological 
order, with the most recent addition at the bottom of the stack.

Note Bear in mind that the order in which effects are applied alters the impact 
they have on the clip—Storm reads applied effects from the top of the 
Effects Stack down.

For example, adding a Curves effect followed by Lift Gamma Gain does not 
produce the same results as Lift Gamma Gain followed by Curves.

You can change the order in which effects appear by dragging and dropping 
the required effect to a new position in the stack.
Storm 1.0v4The Foundry



EDITING AND EFFECTS 56
Applying Effects 
All Effects in the stack also have the following controls:

• Reveal Controls—click the reveal button to open the control drop down 
menu for the selected effect.

• Show/Hide Effect—click show/hide to quickly toggle the selected effect 
on and off.

• Blending Mode—click and hold the icon to display the effects blending 
modes. See Blending Modes for more information.

• Opacity—enter the effect opacity or click and scrub the slider to dissolve 
between the full effect at 100% and the original footage at 0%.

• Return to Defaults—click to return all controls to the default setting for 
the selected effect.

Specialised Effect 
Controls

In addition to the universal stack controls, you can adjust effects using their 
specialised controls in the Effects Stack or by entering numerical values in 
the appropriate fields. 

The following control types enable you to fine-tune Storm’s effects:

• Sliders and Fields—the most basic controls in the Effects Stack. Scrub 
the sliders or enter values in the fields to adjust effect parameters.

Values that have not been altered remain greyed out until used, similar 
to Hue in the example.

Show/Hide 
Effect

Reveal 
Controls Opacity

Return to 
Defaults

Blending 
Mode
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• Range Graphs—enable you to affect or pick out only certain areas of the 
clip, for example, the highlights.

• Select View Ranges to dynamically update the Viewer as you alter 
Range values.

• Select how you would like the Ranges to be represented in the Viewer 
from the drop down menu. The default is Black and White.

• Enable and disable Hue, Saturation, and Luma controls individually 
using the checkboxes, for example Enable Luma as shown.

• Adjust the curves to highlight the areas of the clip where the selected 
effect is applied.

• Curves—used to adjust channels in the current clip. Select the required 
channel from Master (or RGB), Red, Green, or Blue.

Use the mouse to drag-and-drop a point anywhere along the curve to a 
new value. The example shows a high Red and low Green and Blue values. 
The Master curve is at its default value.

• Wheels—used to alter luma and HSV values for the current clip. The 
outer ring represents the luma value (from black, clockwise to white) and 
the inner ring the HSV value (stronger values are further away from the 
centre).
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Note Wheels in Storm are calibrated to need a lot of mouse movement to make 
significant changes to the colour values.

• Adjust the luma value by dragging the pointer to the new luma setting, 
for example anti clockwise to decrease the luminance as shown in 
Figure 7.3.

• Adjust the colour values by dragging the pointer from the centre to the 
required colour and hue, for example low luminance green shown in 
Figure 7.3.

Storm supports the use of third party control panels with colour wheels. 
See About Control Surfaces for more information.

Blending Modes Effect blending modes enable you to customise your output by blending the 
original footage with effects at different intensities, or Opacity. All Storm 
effects have blend and opacity controls, but the results depend on the 
effect and the effect hierarchy within the Effects Stack.

The blend mode button has three states:

Click and hold the blending modes button to display the available modes:

Figure 7.2: Default wheel values. Figure 7.3: Low luminance green.

Normal—no blending is applied. Click and hold to select a blend 
mode.

Active—the selected blending mode is currently enabled. Click to 
disable the current blend mode.

Inactive—the selected blending mode is currently disabled. Click to 
enable the current blend mode.
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The various blend modes behave in a similar way to other applications using 
blending modes for editing or layering, for example Adobe® PhotoShop®. 
After selecting your blending mode, click the Opacity field and adjust the 
slider as required.

Effect Groups Effects within Storm are stored in Production > Storm Presets > Effects. 
Simply drag-and-drop the required effect on to the Viewer to apply the 
effect and add it to the Effects Stack.

The Effects tab contains the following effects:

Effect Description Icon

Colour Effects

Adjust HSV Apply HSV changes and use the Range graphs to limit 
the effect to apply only to particular luma or hue/sat-
uration ranges.

Curves Adds an RGB curve graph to the clip to adjust colour 
and a Range graphs to highlight particular colours or 
features.

You can adjust all the curves at once using the Master 
button, or individual channels using the Red, Green, 
and Blue buttons.
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Colour Filter Enables or disables RGB and Luma channels.

You can export which ever channels you require using 
this effect, for example if you wanted to check for 
noise in a particular channel.

Invert Inverts the colour values of the current clip.

Levels Allows you to adjust the black and white points of the 
current clip. The histogram in the effect doesn’t 
update as you move the markers—it only represents 
the input from the Viewer.

You can also use the Range graphs to limit the effect 
to apply only to particular ranges.

Lift Gamma 
Gain

Adds individual colour wheels and sliders for Lift, 
Gamma, and Gain on the clip as well as a Range graphs 
to highlight particular colours or features.

Select which controls are displayed using the Wheel, 
Sliders, and Both buttons.

Tint Use the colour wheel, sliders, and colour picker to 
push the clip’s midtones toward a particular colour 
while not affecting the blacks and whites.

WhiteBalance Allows you to automatically balance colour tempera-
ture in the current clip by setting a ’standard white’ 
using the colour picker. You can adjust your results 
using the colour wheel and sliders.

Masking Effects

Blanking Apply manual or preset masks to each side of the clip, 
for example 4:3, 16:9, or 2.35:1.

Soft Edges Applies adjustable soft edges to the clip.

Effect Description Icon
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Vignette Applies an adjustable brightness reduction around the 
borders of the clip.

Generators

Checkerboard Generates an adjustable checkerboard over the entire 
clip. 

You can toggle between generators and clips using the 
show/hide icon and Opacity field described under 
Using the Effects Stack.

Colour Wheel Generates a colour wheel over the entire clip for com-
parison. 

Colour Bars Generates colour bars over the entire clip for colour 
comparison.

Constant Generates a colour constant over the entire clip. 

You can use the colour picker to select a constant 
from the current clip.

Ramp Applies an adjustable colour ramp to the clip.

Transform Effects

Flip Inverts the image on the Y axis.

Flop Inverts the image on the X axis.

Effect Description Icon
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Removing Effects The Effects Stack can contain any number of effects, but in order to keep 
the stack ’clean’ you should consider removing effects that are not in use.

Note The RED Look effect cannot be removed from the stack.

To remove an effect or effects:

1. Hold cmd/Ctrl or Shift and click the effect or effects you want to 
remove.

2. Either:

• Press Delete or Backspace on your keyboard, or

• Right-click on an effect banner and select Remove.

In the example, the Lift Gamma Gain effect is removed leaving only RED 
Look, Flop, and Curves in the Effects Stack.

You can remove all Storm effects from a clip or selection of clips by right-

Pan and Scan Zoom, scale, pan, and rotate the image in the Viewer.

Blur Effects

GaussianBlur Applies an adjustable soft-edged, circular blur to the 
current clip.

RadialBlur Applies adjustable blur to the clip from a specified 
centre.

Effect Description Icon
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About RMD Files 
clicking your selections in the Media Pool and choosing Clear Storm Effects.

About RMD Files RED metadata files, or RMDs, are designed to contain grade information for 
R3D clips. Storm can automatically create RMDs for all files, or you can 
create RMDs manually for specific clips.

RMDs created by Storm reside in the same folder as the clip, along with the 
QuickTime reference files, and can be applied to other clips further down 
the workflow pipeline.
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Automatic RMDs Storm’s Preferences dialog contains an option to automatically create RMDs 
for files as you make changes to the RED Look to achieve an overall grade.

Note When Automatically save RMD files is enabled, all changes you make to RED 
Look settings are added to the RMD file, overwriting any metadata that was 
present.

To enable Automatic RMDs:

1. Navigate to Storm > Preferences > General, or press cmd/Ctrl + , 
(comma).

The Preferences dialog box displays.

2. Select Automatically save RMD files and click OK.

3. Restart Storm to apply the change.

Creating Manual RMDs Sometimes in your workflow, it’s not practical to constantly save RMDs for 
all your clips. Storm allows you to create individual RMDs or make selections 
from your Production and create RMDs for just those files.

Once your RED Look changes are in place for the grade you require, you’re 
ready to create RMDs. There are two methods of RMD creation: from the 
Effects Stack and directly from Bins.
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RMDs from the Effects Stack

1. Modify the RED Look parameters as required to produce your grade.

2. Right-click in the RED Look effect and select Clip Options > Save RMD.

3. Storm creates an RMD file in the same folder as the source clip.

RMDs from Bins

1. Modify the RED Look parameters in all the required clips to produce your 
grades.

2. Select all the clips to receive RMDs from the Bin.

3. Right-click a highlighted clip and select Clip Options > Save RMD.

4. Storm creates an RMD file for each selection in the same folder as the 
source clip.

Pre-existing RMDs Working with clips that have changed hands a number of times within a 
pipeline can mean that clips already have associated RMDs supplied with 
them—clips with existing RMD files display an RMD icon in the media pool.
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Storm enables you to use or ignore existing RMDs on a single or multiple 
clip basis.

Select a clip or clips within a Bin, right-click and select either Ignore RMD or 
Use RMD as required.

Clip with RMD 
Disabled

Clip with RMD 
Enabled

Clips without 
RMDs
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Managing Looks Storm ships with a suite of preset Looks that you can apply to clips or use 
to get an idea of Storm’s Effects Stack capabilities—applying a preset Look 
might inspire you to produce your own Custom Looks.

Effects in the stack can be combined to create Custom Looks that are 
transferrable to other clips or Productions. If you create a specific Look on 
one clip that you think you might be useful elsewhere, save it as a Look in 
Storm.

Preset Looks You can drag-and-drop Looks from Storm Presets > Looks to the Viewer to 
add or replace a Look in the same way that Tags and effects are applied.

To apply a preset Look:

1. Navigate to Storm Presets > Looks and select the required look.

2. Drag the Look into the Viewer and drop it on the add or replace hotspot.

The effects contained in the Look are added to the Effects Stack.

3. Adjust the individual effects contained in the Look to create a Custom 
Look if required. See Creating Custom Looks.
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Creating Custom Looks Once you’re happy with the Effects Stack, you’re ready to create your Look:

1. Hold cmd/Ctrl or Shift and click the effects in the stack that you want to 
include in the Look.

2. Right-click on an effect banner and select Save as Look or press S.

3. Enter a name for the Look in the Save Look dialog, then click OK.

Looks are automatically placed in the Production > Untitled 01 > Looks 
folder by default.

If you want a Look to be available across all your Storm Productions, 
move the Look to the User Presets > Look folder—everytime you start 
Storm all the Looks you placed in the User Presets Bin are available for 
use.

Sharing Looks You can share your Looks by saving and distributing a Production 
containing only a Look, which typically creates a small, easy to manage file.

Note Storm Productions are saved with the .stormpackage file extension.

To save a Look you want to share:

1. Create your Look as described in Creating Custom Looks.

2. Navigate to File > Save Untitled01, or use the hotkey cmd/Ctrl + S.
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The Save Production screen displays.

3. Enter a file name in the Save As field and click Save.

4. Distribute the resulting .stormpackage file as required.

To import a shared Look:

1. Navigate to File > Open, or use the hotkey cmd/Ctrl + O.

The Choose a Storm project file screen displays.

2. Select your .stormpackage and click Open.

Storm loads your Production file. 

3. Move the imported Look to the local User Presets > Looks Bin to make it 
available across all future Productions.
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Timelines in Storm initially have two tracks, one video and one audio, and 
can be described as containers for your clips. Each track contains clips that 
reference the source clips in your Production—making changes to clips on 
the Timeline does not affect the original source clip.

• Video Toggle—quickly turn off and on video tracks during playback.

• Playhead Position—displays the playhead location synchronised with the 
contents of the Viewer.

• Time Code—displays the Timeline scale. You can adjust the scale using 
the Scale Slider or by using the mouse wheel.

• Video Track—contains all video clips for the current Timeline.

• Audio Track—contains all the audio clips for the current Timeline.

• Scale Slider—adjusts the scale of the Timeline. You can fit the contents 
of the Timeline to the screen space available by pressing the F hotkey.

• Audio Toggle—quickly turn off and on audio tracks during playback.

• Track Lock—secure the selected track to disable all editing tools.

• Editing Tools—the tools used to manipulate clips on the Timeline. See 
Timeline Editing Tools for more information.

Multi-track Timelines work in the same way as standard Timelines, but they 
can contain more than one audio and video track:

• Video tracks in multi-track Timelines are read from the highest number 
track downward, for example Video 3, Video 2, Video 1. As a result, if 
video is present on track 3, video on track 2 in the same time slice is 
obscured.

Video Track

Audio Track

Editing Tools

Track Lock

Audio Toggle

Time Code

Video Toggle Playhead Position

Scale Slider
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Adding Clips to the Timeline 
In Figure 9.1, although the playhead crosses clips on three video tracks, 
only the clip in Video 3 appears in the Viewer.

Figure 9.1: A typical multi-track Timeline

• Audio tracks, on the other hand, are layered and can be played back 
simultaneously—all three audio tracks crossed by the playhead in 
Figure 9.1 play back together, creating a complete audio backing for the 
video.

Adding Clips to the 
Timeline

Storm’s Timeline allows you to add clips by simple drag-and-drop from 
either the Viewer or Bins. Using the Viewer restricts you to a single clip, the 
current clip, but you can drag as many clips as you like from Bins.

Note If you’re using HDRx clips, make sure you select the correct Exposure 
setting in the Effects tab before adding the clips to the TImeline. See About 
HDRx Clips for more information.
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Note Storm does not support clips with different framerates on the same 
Timeline. If you attempt to drag clips with multiple framerates to the 
Timeline, a warning message displays and the action is cancelled.

You can also drag clips to Timelines that already contain clips, but take care 
not to overwrite existing clips—the most recent clip overlays any existing 
clip. To avoid this, do one of the following:

• Use the Move Clip Tool to make space for the new clip and then drag-
and-drop it in to the space (see Move Clips Tool for more information),

OR

• Drag-and-drop the new clip at the end of the sequence. Next, drag the 
new clip to an existing transition, hold down the alt hotkey, and drop the 
clip to Ripple all other clips down the Timeline.

Tip The cursor changes to  when you’re using Ripple mode.
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To add tracks to multi-track Timelines: 

• Drag-and-drop a clip above or below existing tracks as shown, 

OR

• Right-click an existing audio or video track and select New Track.

Audio and the 
Timeline

Storm handles audio tracks on the Timeline in much the same way as video 
tracks. By default, linked audio and video tracks are edited at the same time, 
but you can lock either track and move them independently or hold Alt to 
select a single track if required.

Storm can handle two types of audio:

• RED Audio—up to four channels of audio recorded by the RED camera at 
the time of shooting. RED audio and video is automatically synchronised 
by the camera.

• WAV Clips—separate audio files in the WAV format that may or may not 
have any relation to the RED video clip. Audio in this format can be 
synchronised with the video track automatically or manually.

RED Audio Tracks RED cameras can record audio at the same time as video, producing up to 
five tracks—four audio and one video. You can use the Timeline Editing 
Tools to edit tracks individually or all at once.
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To edit individual tracks:

1. Lock the track(s) you do not wish to edit using the  track icon.

2. Select the required Timeline tool and perform your edits. 

For example, a simple move edit of an audio track might produce the fol-
lowing result:

Notice locked video and audio tracks are greyed out and the red values 
on the linked tracks detail the amount of displacement.

3. You can unlock tracks using the  track icon.

WAV Clip Tracks Individual WAV clips can be recorded at the same time as shooting the video 
or they can be unrelated to the shoot, for example sound effects or music. 
You can add WAV clips to the Timeline in two ways:

• Drag-and-drop—drag your WAV clip to a Timeline audio track and drop 
it in to place. Use the Timeline Editing Tools to move the clip into place 
and set its output.

• Synchronise audio—the WAV clip is automatically added to the video 
clip, creating a new clip in the same Bin.

To synchronise audio and video clips:

1. Select the two clips you intend to link in the Bin.

2. Right-click either clip and select Sync Media.

A new clip is created containing both original clips. 
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The new clip is marked with the synchronised media icon.

3. Drag and drop the new clip to the Timeline.

4. If the audio clip you synchronised is longer than the video clip, you can 
lock the video track and use the Slip Tool to adjust which part of the 
audio file plays along with video. 

See using the Slip Clips Tool for more information.
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Timeline Editing 
Tools

Adding your clips to the Timeline is rarely, if ever, the end of the Production 
process. The Timeline Editing Tools allow you to manipulate your clips 
directly in the Timeline instead of the Viewer. Bear in mind that edits you 
make in the Timeline are not carried over to the associated source clips.

Move Clips Tool The default Move Clips Tool is used to make simple changes to the Timeline. 
Click and drag the selected clip to required position on the Timeline. A time 
count popup, in conjunction with the snap to clip function, helps you to 
reposition the clip accurately.

You can also move clips up and down the track hierarchy using drag-and-
drop.

Move tool modifiers

 Before moving...  ...and after.

Mode Method Indicator Description

Overwrite drag and drop The default move mode. The dragged clip 
overwrites any clips that are present in the 
move location.

Ripple drag then hold Alt 
and drop

Drag and drop clips on top of other clips 
without overwriting content—clips are 
pushed down the Timeline to accommodate 
the dragged clip.

Duplicate hold Alt and drag 
then release Alt and 
drop

 

Copy the clip, then drag and drop on top of 
other clips overwriting existing content—
clips are not pushed down the Timeline to 
accommodate the dragged clip.

Time 
Count
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Delete modifiers

Slip Clips Tool The Slip Clip Tool allows you to shift a clip’s In and Out Points by the same 
amount and in the same direction, retaining the original clip length but 
altering the Timeline output. 

Note The target clip must have In and Out markers on its source reference clip to 
use the Slip Clip Tool.

1. Click and hold the required clip to display the slip handles.

2. Drag the clip to the new position and release the mouse to complete the 
slip.

Using the Slip Clip Tool does not move the clip on the Timeline, only the clip 
output is changed.

Roll Tool The Roll Tool enables you to move the cut in a clip backward or forward in 
time. Rolling the edit point between two clips shortens one clip while 
lengthening the other to keep the overall duration the same.

Ripple and 
Duplicate

hold Alt then drag 
and drop while hold-
ing Alt

 

Copy the clip, then drag and drop clips on 
top of other clips without overwriting con-
tent—clips are pushed down the Timeline to 
accommodate the dragged clip.

Action Hotkeys Description

Delete Backspace Delete the selected Timeline clip(s) or gap(s)

Ripple 
Delete

Shift + Backspace Remove the selected clip(s) and ripple clips down stream 
to close gaps in the Timeline

Note: The ripple effect may not close gaps entirely, 
because Storm does not allow linked tracks to become 
desynchronised during rippling.

Mode Method Indicator Description

Slip 
Handle

Slip 
Amount
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You can use the Roll Tool in one of two ways:

• Single clip—you can only use the Roll Tool after you have made a cut 
using the Razor Tool.

• Dual clips—one of the target clips must have In and Out markers on its 
source reference clip to use the Roll Tool.

For example, if you roll five frames at the end of one clip, the next clip 
would start five frames later. Figure 9.2 shows a Timeline containing a 
razored clip, and Figure 9.3 shows the same clips with the cut point ’rolled’ 
to the right.

Figure 9.2: Original clips.

Figure 9.3: Rolled clips.

Razor Tool The Razor Tool allows you to cut a clip in to separate parts so you can 
remove sections of the clip or rearrange clips in the Timeline. 

Tip The cursor changes state between  and  when you’re using the 

Razor Tool to let you know where you can and can’t make cuts.

Figure 9.4 shows three clips on a Timeline before the Razor Tool is applied, 
and Figure 9.5 shows the same Timeline after two Razor edits and a move.

Figure 9.4: Original clips.
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Figure 9.5: The same Timeline after two 
Razor cuts and move.

Join Tool The Join Tool enables you to remove Razor cuts in a clip to restore it to its 
original state.

Joins can only occur when:

• The clips on either side of the join are from a single source clip, and

• The frame numbers are continuous. 

For example, if clip 1 ends at frame 15, clip 2 must start at frame 16.

Tip If a join operation is possible, the cursor changes when you hover over 
the transition.

Enabling and Disabling 
Clips

You can temporarily enable or disable a clip or clips on the Timeline to 
selectively view your footage without removing the clip(s), for example if 
you wanted to listen to certain audio layers within a Timeline.

To enable or disable a clip or clips:

1. Select the clip or clips you want to enable or disable using the mouse 
and selection hotkeys.

2. Right-click on the highlighted clip and deselect Enable Clip to disable the 
clip.
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Disabled clips appear black and are effectively removed from the Time-
line.

3. Right-click the clip and select Enable Clip to re-enable the clip.

Tagging Timelines Timelines accept Tags in a similar way to Viewers, and they are applied in 
the same way—by drag-and-drop. You can add Tags to frames, clips, or the 
entire Timeline as necessary.

• To tag frames—move the playhead to the required frame and drag-and-
drop the Tag into the Timeline Viewer hotspot.

Frame Tags are displayed under the Viewer, in the mini Timeline.

Tip Use Shift +  or  to skip to the next or previous Tag on the current clip or 
reposition Tags by dragging them along the Timeline.

Tags Playhead
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• To tag clips—select the clip or clips to tag and drag-and-drop the Tag 
onto the Timeline.

Clip Tags are displayed on the clip in the Timeline.

• To tag the entire Timeline—drag-and-drop the Tag into the Timeline 
Viewer hotspot (Figure 9.6), or select the entire Timeline and drag-and-
drop the Tag into the Timeline tracks (Figure 9.7).

Figure 9.6: The Tag Timeline hotspot
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Figure 9.7: Tagging a selected Timeline

Timeline Tags are displayed on top of the Timeline Viewer, next to the 
Image Quality dropdown menu.

Adding Effects to 
Timelines

Looks and Effects are also added using the familiar Storm drag-and-drop, 
but they can only be added to clips or the entire Timeline, not individual 
frames.

• To add Effects to a clip—either drag-and-drop the Effect into the 
required clip on the Timeline,

Tags
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OR

Move the playhead to the required clip then drag-and-drop the Effect 
into the Viewer.

• To add Effects to multiple clips—select multiple clips in the Timeline and 
drop the Effect within the orange highlight to add the Effect to all 
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selected clips. The following example adds the Effect to the 2nd, 4th, and 
5th clips in the Timeline.

Tip You can add an Effect to the entire Timeline by using the cmd/Ctrl + A 
hotkey in the Timeline pane.

Effects are displayed in the top-right corner of the clip on the Timeline.

Adding Looks to 
Timelines

Looks are essentially groups of Effects and they are applied in the same 
way, with an added option to Add to or Replace existing effects. You can 
use the Looks supplied with Storm or create and apply your own. See 
Managing Looks for more information.

• To apply a Look to a clip—either drag-and-drop the Effect into the 
required clip on the Timeline,

OR

Move the playhead to the required clip then drag-and-drop the Effect 
into the Timeline Viewer.

• To apply a Look to multiple clips—select clips in the Timeline and drop 
the Effect within the orange highlight to add the Effect to all selected 
clips.

Tip You can add an Effect to the entire Timeline by using the cmd/Ctrl + A 
hotkey in the Timeline pane.
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Applying Grades to 
Timelines

Productions rarely occur in a linear fashion, for example shooting, followed 
by editing, followed by grading, and so on. Storm allows for this by round-
tripping edits created in third party applications, such as Final Cut Pro, back 
into Storm and applying them to your Timeline—even if the Timeline was 
graded after it was exported to Final Cut Pro.

Providing that the same source files are present in the current Production, 
Storm can conform the edits from Final Cut Pro with the graded Timeline, or 
grade a Timeline from Bins or other Timelines within Storm.

As an example, let’s assume that you’ve exported three clips on a Timeline 
to Final Cut Pro:

• You send the XML and QuickTime movies on to the next stage in your 
pipeline for fine editing, while you create three test grades in Storm.

• Your editor provides a Final Cut Pro XML file containing the final edit.

To conform the edit with your grades:

1. Import your XML using the File > Import Final Cut Pro XML menu option, 
locate your XML and click Open.

2. Double-click the imported XML to open up the Timeline. 

Note If the source files are not present in the current Production, you may need 
to relink the XML and source files manually. See Reconnecting XML for more 
information.
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3. You can apply your grades to individual clips on the imported Timeline, 
or to the entire Timeline as required:

• Individual clips—select the required clip(s) on the Timeline and then 
right-click and navigate to Grades to apply the required look to the 
selection.

• Timeline—select the XML Timeline in the In Tray and then right-click and 
navigate to Grades to apply the required look to the entire Timeline.

Storm retains the edits you made in Final Cut Pro, but applies the grade 
from Storm, integrating the separate workflows.

You can swap easily between all available grades—Storm automatically 
removes the existing grade and replaces it with your new selection.

Note Warning icons let you know when your selection could produce unexpected 
results—for example if more than one grade could be applied from the 
selected location.
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You can also use grades as a ’soft backup’ for versions of your work, 
keeping track of your Timeline decisions. By saving your current Timeline 
often as your grade develops, you can quickly review previous edits if you 
think you’re heading in the wrong direction.

To create a Timeline version:

1. Select the current Timeline in the Bin view.

2. Copy and paste the Timeline by navigating to the Edit menu or by using 
the cmd/Ctrl + C and cmd/Ctrl + V hotkeys.

A copy of the selected Timeline is created.

3. Rename the new Timeline as required. 

Using this method, you can quickly build up a version history within a 
Bin:

4. Right-click the Current_Timeline and select the required version to 
quickly review your grade’s development.
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Whether you’re exporting to another post-production application like Final 
Cut Pro or Nuke, creating QuickTime files or still frames, or trimming 
existing R3D files, this chapter explains how to achieve the best results 
from production to production.

About the Export 
Queue

Storm renders output in the background using the Export Queue, allowing 
you to continue working while your output is created. New export 
operations are added to the foot of the queue and processed in order from 
the top-down.

The Export Queue components are described below:

• Column Name—export information broken down into columns:

• Exporting—the export operation queued.

• Clip—the clip currently rendering.

• Elapsed Time—the time spent rendering the current clip or the total 
time taken in the case of completed exports.

• Remaining—the estimated time remaining to complete the current 
export.

• Format—the format selected for the exports in the queue.

• Progress—a visual representation of the Remaining column shown as 
a percentage.

• Status—the status of all operations in the queue.

• Destination—the specified output destination.

• Cancel—click to cancel individual exports.

• Pause—click to pause the entire Export Queue. Click once more to 
resume.

• Clear—click to remove cancelled, failed, and finished exports.

Cancel Pause ClearColumn Name
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About Export 
Presets

As you use Storm from production to production, you’ll probably find that 
certain combinations of export settings are used regularly. Storm’s export 
dialog allows you to save commonly used combinations as Export Presets, 
so you can apply complex export decisions efficiently.

The Export dialog is shown in Figure 10.1, with the Export Presets 
highlighted on the left-hand side.

Figure 10.1: The Export Dialog

To create an Export Preset:

1. Click New to create an untitled preset.

2. Enter a meaningful name in the preset field, for example QT HDV 1080i.

3. Work through the export settings described in Exporting To Final Cut 
Pro, Exporting, and Exporting Trimmed R3Ds depending on your 
requirements.

4. Click Save to add the Export Preset to the preset list.

5. You can create as many presets as you need and overwrite or delete 
existing presets.

Exporting To Final 
Cut Pro

Unlike Storm, Final Cut Pro does not read R3D files directly. If your 
workflow uses Final Cut Pro for offline editing, Storm can generate 
QuickTime Movies for your media combined with an associated XML file that 
contains the Timeline and metadata.

Using Storm’s export function, you can create XML and QuickTime Movies 
concurrently for Timelines, Bins, or single clips.

• XML—generated during the export process, these files contain the 
information necessary for Final Cut Pro to display your media organised 
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into Bins or edited into Timelines from Storm. XML is also used to 
convert Storm Tags to Final Cut Pro markers. 

• QuickTime Movies—you can decide whether or not to generate reference 
files. Reference files are essentially copies of the selected media from 
your Storm project at a lower resolution, making them more manageable 
for offline editing. Any effects you applied in Storm are 'baked' in and 
contain enough information to enable Storm to conform with the original 
R3D media if you bring the edit back to Storm later. 

The following example delivers a Timeline, but the process is the same for 
Bins.
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1. In the Production tab, select the Timeline and navigate to File > Send to 
Final Cut Pro.

The Export dialog box displays.

2. Enter the file path of the folder to save your output, or click Choose... to 
browse to the location.

3. Enter an XML file name in the field provided.

4. If you want to export your XML straight to Final Cut Pro, select the 
Automatically open Final Cut Pro checkbox.

5. If you have previously created QuickTime Movie files for the XML, you 
can deselect Generate QuickTime Movies to save time.

Note If you elect to skip this step and you have not previously created QuickTime 
Movies from the same source R3D files, Final Cut Pro has no reference 
media, resulting in an empty Timeline.
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A warning displays if Storm cannot locate existing .mov files for any of the 
clips you intend to export.

6. Click the Video tab to display the video export options shown below.

7. Under Folder and Filename Options:

• Enter an Output Location in the field provided, or click Choose... to 
browse to the location. 

Note The default value saves your output to the same folder as the XML file.

• Select your folder structure from the Folder Options dropdown:

No Folder per Clip—All clips are placed in a single location.

Folder per Clip—A separate folder is created for each clip in a single 
location.

Bin Structure no Folder per Clip—The Storm Bin structure is preserved, 
but individual clips within a Bin are placed together.

Bin Structure and Folder per Clip—The Storm Bin structure is pre-
served and additional folders are created for individual clips within 
Bins.

8. Under Format Options:

• Click Setup to select the export Codec.
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There are too many types of codec to list here, but examples include 
Apple ProRes 422 (the default), H.264, and HDV 720p24.

• Select the required Resolution from the dropdown menu.

Again, there are too many display types to list here, but some exam-
ples are 1920x1080 HD (the default), 720x480 NTSC 4:3, and 
4096x1716 CinemaScope.

Alternatively, you can create a non-standard resolution by selecting 
Custom from the dropdown menu.

Note If the aspect ratio of the selected format doesn't match the R3D material, 
the media is resized to fit the frame, potentially leaving black bands at top 
and bottom or sides.

Enter a Name, Width, Height, and Pixel Aspect for the new format, and 
then click OK to save your settings.

Tip The ratio representation updates dynamically as you make changes to the 
Pixel Aspect field.

9. Under Advanced Options, select the required Scaling and Filtering 
options from the dropdown menus:

• Scaling—designed to give you some control over output width and 
height. For example, if your clips were shot in 16:9, you could limit the 
scale by Height so that the frame edges are clipped to the equivalent 
width.

• Filtering—the type of filter you select affects the quality of your out-
put. For example, selecting a high quality Lanczos3 filter improves 
quality over the standard Box filter.
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• Anamorphic—if the export contains anamorphic clips, this dropdown 
gives you the option to discard the 2:1 aspect ratio and export the clip 
as 1:1. The default value, Apply, retains the aspect ratio.

• Bit Depth—the bit depth to use during export, select from 8-bit, 16-
bit, and Half Float. The Bit Depth dropdown menu is only displayed if 
you enable Advanced Mode in the Preferences dialog. See Workspace 
Preferences.

Note Bear in mind that high quality filters and bit depth, for example Lanczos3 
and Half Float, require more rendering time.

10. If you’re exporting as a series of clips, you can add extra frames as 
’handles’ allowing you manipulate the output more easily, for example to 
slip the clip within the handles.

11.Click the Audio tab and check Export Audio to include any audio tracks 
present in the export.

Note Storm does not export audio tracks by default. You can toggle up to eight 
audio tracks on and off on the Audio tab.

12.Click the RED tab and check Use RED Rocket to export using the RED 
Rocket decoder.
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13.Select the Decoding quality using the dropdown menu.

Note Using the RED Rocket card is a high speed/low quality export option, 
passing your output though the hardware rather than the software. 

If time is not one of your main considerations, you should leave Use RED 
Rocket disabled.

14. Click Export to begin the conversion.

The Export Queue window displays an estimate of how long the export 
is expected to take.

Note The amount of time required to export your work to Final Cut Pro depends 
on the options you choose. Generating reference files, for example, can be a 
lengthy process.

If you checked Open Final Cut Pro, the application launches and your 
work is automatically imported.
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Tip When Final Cut Pro’s Import XML... dialog displays, ensure Reconnect to 
Media Files is checked or your media may appear offline.

If you’re using uncommon or custom codecs and resolutions, you may also 
need to adjust the Sequence Settings Default to reflect your settings within 
Storm.
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Exporting Storm can also export a clip, Bin, or Timeline as a single or multiple 
QuickTime file(s), or a series of still images (EXR or DPX).

Exporting to 
QuickTime

1. Select the clip, Bin, or Timeline you want to export from the Production 
tab and navigate to File > Export or use the shift + cmd/Ctrl + E hotkey.

The Export dialog box displays.

Note Storm displays a different Export dialog depending on what you intend to 
deliver. For example, the Handles field is not displayed if you select Timeline 
as single clip.

2. Enter the file path of the folder to save your output, or click Choose... to 
browse to the location.

3. Select your folder structure from the Folder Options dropdown:

• No Folder per Clip—All clips are placed in a single location.

• Folder per Clip—A separate folder is created for each clip in a single 
location.

• Bin Structure no Folder per Clip—The Storm Bin structure is preserved, 
but individual clips within a Bin are placed together.
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• Bin Structure and Folder per Clip—The Storm Bin structure is pre-
served and additional folders are created for individual clips within 
Bins.

4. By default, Storm automatically names your output files. You can 
manually select the naming structure by entering text in the following 
format:

• name—Use when creating .mov files. For example, entering 
Tokyo_Times names your files Tokyo_Times-cn.mov (where cn = clip 
number in the sequence).

5. Select File Type > QuickTime using the dropdown menu.

6. Click Setup to select the codec used during the export.

There are too many types of codec to list here, but some examples 
include Apple ProRes 422 (the default), H.264, and HDV 720p24.

7. Select the required Resolution from the dropdown menu.

Again, there are too many display types to list here, but some examples 
include 1920x1080 HD (the default), 720x480 NTSC 4:3, and 
4096x1716 CinemaScope.

Alternatively, you can create a non-standard resolution by selecting 
Custom from the dropdown menu.

Note If the aspect ratio of the selected format doesn't match the R3D material, 
the media is resized to fit the frame, potentially leaving black bands at top 
and bottom or sides.

Enter a Name, Width, Height, and Pixel Aspect for the new format, and 
then click OK to save your settings.

Tip The ratio representation updates dynamically as you make changes to the 
Pixel Aspect field.
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8. Under Advanced Options, select the required Scaling and Filtering 
options from the dropdown menus:

• Scaling—designed to give you some control over output width and 
height. For example, if your clips were shot in 16:9, you could limit the 
scale by Height so that the frame edges are clipped to the equivalent 
width.

• Filtering—the type of filter you select affects the quality of your out-
put. For example, selecting a high quality Lanczos3 filter improves 
quality over the standard Box filter.

• Anamorphic—if the export contains anamorphic clips, this dropdown 
gives you the option to discard the 2:1 aspect ratio and export the clip 
as 1:1. The default value, Apply, retains the aspect ratio.

• Bit Depth—the bit depth to use during export, select from 8-bit, 16-
bit, and Half Float. The Bit Depth dropdown menu is only displayed if 
you enable Advanced Mode in the Preferences dialog. See Workspace 
Preferences.

Note Bear in mind that high quality filters and bit depth, for example Lanczos3 
and Half Float, require more rendering time.

9. If you’re exporting as a series of clips, you can add extra frames as 
’handles’ allowing you manipulate the output more easily, for example to 
slip the clip within the handles.

10.Click the Audio tab and check Export Audio to include any audio tracks 
present in the export.
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Note Storm does not export audio tracks by default. You can toggle up to eight 
audio tracks on and off on the Audio tab.

11.Click the RED tab and check Use RED Rocket to export using the RED 
Rocket decoder.

Select the Decoding quality using the dropdown menu.

Note Using the RED Rocket card is a high speed/low quality export option, 
passing your output though the hardware rather than the software. 

If time is not one of your main considerations, you should leave Use RED 
Rocket disabled.

12.Take a moment to review your choices, then click Export.
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Storm sends the output to the Export Queue using the preferences you 
selected. A progress window displays an estimate of how long the 
export will take.

About Avid DNxHD If you intend to export from Storm to the Avid DNxHD ® format, you’ll need 
the correct codec supplied with Avid Media Composer™ to do the 
conversion. A codec converts one file format to another during the export 
process, and you can specify the DNxHD codec from the Export dialog box.

1. The process is identical to other QuickTime exports, so follow the initial 
steps described in Exporting to QuickTime.

2. Under Format Options, click Setup to select the Compression type, or 
codec, to use during the export.

3. Select Avid DNxHD Codec from the dropdown menu.

4. Under Compressor settings, select the required Resolution from the 
dropdown menu.
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5. Follow the remaining steps under Exporting to QuickTime and click 
Export.

Storm sends the output to the Export Queue using the DNxHD codec 
you selected. A progress window displays an estimate of how long the 
export will take.

Exporting to Individual 
Frames

1. Select the clip, Bin, or Timeline you want to export from the Production 
tab and navigate to File > Export.

The Export dialog box displays.
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Note Storm displays a different Export dialog depending on what you intend to 
deliver. For example, the Handles field is not displayed if you select Timeline 
as single clip.

2. Enter the file path of the folder to save your output, or click Choose... to 
browse to the location.

3. Select your folder structure from the Folder Options dropdown:

• No Folder per Clip—All clips are placed in a single location.

• Folder per Clip—A separate folder is created for each clip in a single 
location.

• Bin Structure no Folder per Clip—The Storm Bin structure is preserved, 
but individual clips within a Bin are placed together.

• Bin Structure and Folder per Clip—The Storm Bin structure is pre-
served and additional folders are created for individual clips within 
Bins.

4. By default, Storm automatically names your output files. You can 
manually select the naming structure by entering text in the following 
format:

• name-frame—Use when creating EXRs or DPXs. For example, entering 
Tokyo_Times-{frames} names your files Tokyo_Times-fn-cn.exr (where 
cn = clip number, and fn = frame number in the sequence).

5. Select File Format > EXR or DPX using the dropdown menu.

6. Click Setup to select the required compression type:

7. Select the required Resolution from the dropdown menu.

Again, there are too many display types to list here, but some examples 
include 1920x1080 HD (the default), 640x480 PC_Video, and 720x486 
(1.21) NTSC_16:9.

Alternatively, you can create a non-standard resolution by selecting 
Custom from the dropdown menu.

Note If the aspect ratio of the selected format doesn't match the R3D material, 
the media is resized to fit the frame, potentially leaving black bands at top 
and bottom or sides.
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Enter a Name, Width, Height, and Pixel Aspect for the new format, and 
then click OK to save your settings.

Tip The ratio representation updates dynamically as you make changes to the 
Pixel Aspect field.

8. Under Advanced Options, select the required Scaling and Filtering 
options from the dropdown menus:

• Scaling—designed to give you some control over output width and 
height. For example, if your clips were shot in 16:9, you could limit the 
scale by Height so that the frame edges are clipped to the equivalent 
width.

• Filtering—the type of filter you select affects the quality of your out-
put. For example, selecting a high quality Lanczos3 filter improves 
quality over the standard Box filter.

• Anamorphic—if the export contains anamorphic clips, this dropdown 
gives you the option to discard the 2:1 aspect ratio and export the clip 
as 1:1. The default value, Apply, retains the aspect ratio.

• Bit Depth—the bit depth to use during export, select from 8-bit, 16-
bit, and Half Float. The Bit Depth dropdown menu is only displayed if 
you enable Advanced Mode in the Preferences dialog. See Workspace 
Preferences.

Note Bear in mind that high quality filters and bit depth, for example Lanczos3 
and Half Float, require more rendering time.
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9. If you’re exporting as a series of clips, you can add extra frames as 
’handles’ allowing you manipulate the output more easily, for example to 
slip the clip within the handles.

10.Click the RED tab and check Use RED Rocket to export using the RED 
Rocket decoder.

Select the Decoding quality using the dropdown menu.

Note Using the RED Rocket card is a high speed/low quality export option, 
passing your output though the hardware rather than the software. 

If time is not one of your main considerations, you should leave Use RED 
Rocket disabled.

11.Take a moment to review your choices, then click Export.

Storm sends your output to the Export Queue using the preferences you 
selected. A progress window displays an estimate of how long the 
export will take.
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Exporting Trimmed 
R3Ds

Storm can trim R3D files, allowing you to cut out wasteful footage and 
create new R3D source files. The new R3Ds retain the same filename to 
enable you to conform existing XML using the trimmed files.

Before you begin, ensure you make selections by placing In and Out points 
on the source clips as required.

1. Select the clip, Bin, or Timeline you want to export from the Production 
tab and navigate to File > Export.

The Export dialog box displays.

2. Enter the file path of the folder to save your output, or click Choose... to 
browse to the location.

3. Select your folder structure from the Folder Options dropdown:

• No Folder per Clip—All clips are placed in a single location.

• Folder per Clip—A separate folder is created for each clip in a single 
location.

• Bin Structure no Folder per Clip—The Storm Bin structure is preserved, 
but individual clips within a Bin are placed together.
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• Bin Structure and Folder per Clip—The Storm Bin structure is pre-
served and additional folders are created for individual clips within 
Bins.

4. Select File Type > R3D Trim using the dropdown menu.

5. Click Setup to select whether or not to produce RMD files along side the 
trimmed R3D.

6. The other export options are not available when you’re trimming R3D 
files, so click Export to begin.

Storm sends your output to the Export Queue using the preferences you 
selected. A progress window displays an estimate of how long the 
export will take.
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Storm Hotkeys

This appendix lists the hotkeys used by Storm, along with their function. 

Note:  LMB, RMB, and MMB refer to the left, right, and middle mouse buttons respectively.

Hotkey Button Menubar Function

Viewer

Shift +  cmd + 1 - View > Zoom to Actual Size Zoom the contents of the Viewer to actual size

Shift +  cmd + 2 - View > Zoom to Half Size Zoom the contents of the Viewer to half size

F - Scale dropdown > Fit Zoom to fit the clip to the Viewer

H - Zoom to Fit (Height) Fit the current clip to the height of the Viewer

W - Zoom to Fit (Width) Fit the current clip to the width of the Viewer

cmd  + F - View > Full Screen Toggle Full Screen mode

cmd  + Shift + F - View > Full Quality 1:1 Toggle Full Screen mode at Full Quality 1:1 zoom

E View > Clipping Warning Toggle the Level Warning tool on and off

cmd  +  View > Transform > 
Rotate Left

Rotate the current clip 90° counter-clockwise

cmd  +  View > Transform > 
Rotate Right

Rotate the current clip 90° clockwise

I View > Mark In Set the In Point at the current frame

O View > Mark Out Set the Out Point as the current frame

Shift +  View > Go to Start Go to the start of all clips

Shift +  View > Go to End Go to the end of all clips

Shift + I - View > Go to In Point Go to the In Point in the current clip

Shift + O - View > Go to Out Point Go to the Out Point in the current clip
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 View > Frame Backward Skip one frame backward

 View > Frame Forward Skip one frame forward

 View > Previous Edit Go to the previous clip in the Viewer

 View > Next Edit Go to the next clip in the Viewer

Shift +  - View > Previous Tag Go to previous frame tag

Shift +  - View > Next Tag Go to next frame tag

Space View > Play Play clip

J View > Play Backward Play clip backward (click multiple times to increase playback 
speed)

L View > Play Forward Play clip forward (click multiple times to increase playback 
speed)

K View > Pause Pause playback

cmd  + drag - - Zoom the contents of the Viewer

Scroll MMB

(over Viewer)

- - Zoom the contents of the Viewer

Scroll MMB

(over mini Timeline)

- - Zoom the mini Timeline and Viewer waveform

Click MMB

(over mini Timeline)

- - Zoom to fit the mini Timeline and Viewer waveform. 

Note: If your mouse preferences are not set to Button 3 for 
the middle mouse button, you may have to use ctrl + MMB.

Bin

cmd  + B - File > New Bin Create a new Bin in the current Bin

cmd  + Y - File > New Tag Create a new Tag in the current Bin

Shift + cmd + T - File > New Timeline Create a new Timeline in the current Bin

cmd  + T - File > New Template Create a new Template in the current Bin

cmd  + A - Edit > Select All Select all files in the current Bin

cmd  + C - Edit > Copy Copy the selected item(s) to the buffer

Hotkey Button Menubar Function
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cmd  + X - Edit > Cut Cut the selected item(s) to the buffer

cmd  + V - Edit > Paste Paste item(s) from the buffer

Backspace - - Delete selected item(s)

Timeline

LMB - - Select a clip including any linked tracks

Alt + LMB - Select a clip, ignoring linked tracks (for example, audio only)

F - View > Zoom to Fit Zoom to fit the clips on the Timeline to the available space

Backspace - - Remove the selected clip(s) or gap(s) from the Timeline

Ripple Delete - Timeline > Ripple Delete Remove the selected clip(s) and ripple clips down stream to 
close gaps in the Timeline

cmd + A - - Select all clips in the Timeline

LMB then Shift + 
LMB

- - Select all clips between the LMB clicks (use Shift + Alt + LMB 
to ignore linked tracks)

Shift + C - Timeline > Razor Selected Apply the Razor tool to the currently selected track(s) within 
the selected clip(s)

C - Timeline > Razor All Apply the Razor tool to all tracks within the selected clip(s)

drag then alt - - Activate Ripple mode while dragging clips

alt then drag - - Duplicate the dragged clips

alt and drag - - Ripple and duplicate the dragged clips

Spacebar View > Play Play through the Timeline

alt + MMB - - Fit the Viewer to marked In and Out Points

Effects Stack

S - - Save selected effect(s) as a Look

Backspace - - Delete effect(s)

cmd  + A - - Select all effects in the Effects Stack

Shift + LMB - - Select a continuous range of effects from the currently 
selected effect to the next effect selected.

User Interface

cmd  + 1 - Window > Workspace > 
Editing

Switch to the default Editing workspace

cmd  + 2 - Window > Workspace > 
Reviewing

Switch to the default Reviewing workspace

Hotkey Button Menubar Function
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Note:  LMB, RMB, and MMB refer to the left, right, and middle mouse buttons respectively.

cmd  + n - Windows > Workspace > 
Custom Workspace Name

Switch to the custom workspace associated with the number 
selected.

~ (tilde) - - Toggle between full screen and preset pane size for the pane 
currently under the mouse pointer.

Media Pool Searchbox

LMB - - Select search criteria

cmd + LMB - - Toggle select individual search criteria

Shift + LMB - - Select a range of search criteria

 - - Cycle left or right through the search criteria

Backspace - - Remove the selected search criteria

Escape - - Return focus to the previously selected panel

Hotkey Button Menubar Function
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Third Party Licences

This appendix lists third party libraries used in Storm, along with their licences.

Library Description Licence

Boost/1.37.0 Source code function / 
template library

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organisation obtain-
ing a copy of the software and accompanying documentation covered by this license 
(the “Software”) to use, reproduce, display, distribute, execute, and transmit the 
Software, and to prepare derivative works of the Software, and to permit third-par-
ties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above 
license grant, this restriction and the following disclaimer, must be included in all 
copies of the Software, in whole or in part, and all derivative works of the Software, 
unless such copies or derivative works are solely in the form of machine-executable 
object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN 
NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFT-
WARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, 
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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Library Description Licence

Breakpad 1.0 Multi-platform crash 
reporting system

Copyright © 2010, Google Inc.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of the organization nor the names of its contributors may be 
used to endorse or promote products derived from this software without specific 
prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

EuCon SDK - 
EuCon/2.5.5

Software development 
kit

The EUCON specification and trademark are property of Avid Technology, Inc. Used 
under license.

Expat/2.0.1 XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark 
Cooper

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the “Software”), to deal in the Soft-
ware without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, sublicense, and/or sell copies of the Software, and to per-
mit persons to whom the Software is furnished to do so, subject to the following 
conditions:

The above copyright notice and this permission notice shall be included in all copies 
or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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GLEW/1.5.0 OpenGL support The OpenGL Extension Wrangler Library Copyright © 2002-2008, Milan Ikits <milan 
ikits@ieee.org>

Copyright © 2002-2008, Marcelo E. Magallon <mmagallo@debian.org>

Copyright © 2002, Lev Povalahev All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  The name of the author may be used to endorse or promote products derived 
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

JPEG/6b File format support This software is based in part on the work of the Independent JPEG Group.

Libexif/0.6.16 Metadata parser Author Lutz Mueller lutz@users.sourceforge.net date 2001-2005

This library is free software; you can redistribute it and/or modify it under the terms 
of the GNU Lesser General Public License as published by the Free Software Founda-
tion; either version 2 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

Library Description Licence
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Libtiff/3.8.2 File format support Copyright © 1988-1997 Sam Leffler Copyright © 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documen-
tation for any purpose is hereby granted without fee, provided that (i) the above 
copyright notices and this permission notice appear in all copies of the software and 
related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may 
not be used in any advertising or publicity relating to the software without the spe-
cific, prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, 
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPE-
CIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY 
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, 
WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THE-
ORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFOR-
MANCE OF THIS SOFTWARE.

Msinttypes File format support Copyright © 2006 Alexander Chemeris

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  The name of the author may not be used to endorse or promote products derived 
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR 
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRAN-
TIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DIS-
CLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, 
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, 
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS 
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR 
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Library Description Licence
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OpenEXR/cvs-03-
03-2008

File format support Copyright © 2002, Industrial Light & Magic, a division of Lucas Digital Ltd. LLC All 
rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of Industrial Light & Magic nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenImageIO 
r1719

File format support Copyright © 2008 Larry Gritz and the other authors and contributors. All Rights 
Reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of the software's owners nor the names of its contributors may 
be used to endorse or promote products derived from this software without spe-
cific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

Library Description Licence
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Qt/4.6.2 Application and UI 
framework

The Qt GUI Toolkit is Copyright © 2010 Nokia Corporation and/or its 
subsidiary(-ies).

Contact: Nokia Corporation (qt-info@nokia.com)

Qt is available under the GNU Lesser General Public License.

To see the GNU Lesser General Public License, go to www.gnu.org/licenses/.

QuaZip/0.3 Qt ZIP wrapper Copyright © 2005 Sergey A. Tachenov

This program is free software; you can redistribute it and/or modify it under the 
terms of the GNU General Public License as published by the Free Software Founda-
tion; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS 
FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

Original ZIP package is copyrighted by Gilles Vollant, see quazip/(un)zip.h files for 
details.

RED SDK 4.1 Software Development 
Kit

The R3D SDK and all included materials (including header files, libraries, sample code 
& documentation) are Copyright © 2008-2011 RED Digital Cinema. All rights 
reserved. All trademarks are the property of their respective owners.

This software was developed using KAKADU software.

Library Description Licence
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VXL/1.10.0 Computer vision Copyright © 2000-2003 TargetJr Consortium 

GE Corporate Research and Development (GE CRD)

1 Research Circle 

Niskayuna, NY 12309 

All Rights Reserved 

Reproduction rights limited as described below.

Permission to use, copy, modify, distribute, and sell this software and its documen-
tation for any purpose is hereby granted without fee, provided that (i) the above 
copyright notice and this permission notice appear in all copies of the software and 
related documentation, (ii) the name TargetJr Consortium (represented by GE CRD), 
may not be used in any advertising or publicity relating to the software without the 
specific, prior written permission of GE CRD, and (iii) any modifications are clearly 
marked and summarised in a change history log.

THE SOFTWARE IS PROVIDED “AS IS” AND WITHOUT WARRANTY OF ANY KIND, 
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO 
EVENT SHALL THE TARGETJR CONSORTIUM BE LIABLE FOR ANY SPECIAL, INCIDEN-
TAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND OR ANY DAMAGES 
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR 
NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR ON ANY THEORY OF 
LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE 
OF THIS SOFTWARE.

Zlib/1.2.3 Compression library Copyright © 1995-2010 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied warranty. In no 
event will the authors be held liable for any damages arising from the use of this 
software.

Permission is granted to anyone to use this software for any purpose, including 
commercial applications, and to alter it and redistribute it freely, subject to the fol-
lowing restrictions:

1. The origin of this software must not be misrepresented; you must not claim that 
you wrote the original software. If you use this software in a product, an 
acknowledgment in the product documentation would be appreciated but is not 
required.

2. Altered source versions must be plainly marked as such, and must not be misrep-
resented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Library Description Licence
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End User Licensing Agreement (EULA)

IMPORTANT: BY INSTALLING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ THIS 
AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. IF YOU DO 
NOT AGREE TO THE TERMS OF THIS AGREEMENT DO NOT INSTALL, COPY OR USE THE SOFTWARE.

This END USER LICENSE AGREEMENT (this "Agreement") is made by and between The Foundry 
Visionmongers Ltd., a company registered in England and Wales, ("The Foundry"), and you, as either an 
individual or a single entity ("Licensee").

In consideration of the mutual covenants contained herein and for other good and valuable consideration 
(the receipt and sufficiency of which is acknowledged by each party hereto) the parties agree as follows:

SECTION 1. GRANT OF LICENSE.

Subject to the limitations of Section 2, The Foundry hereby grants to Licensee a limited, non-transferable 
and non-exclusive license to install and use a machine readable, object code version of this software 
program (the "Software") and accompanying user guide and other documentation (collectively, the 
"Documentation") solely for Licensee's own internal business purposes (collectively, the "License"); 
provided, however, Licensee's right to install and use the Software and the Documentation is limited to 
those rights expressly set out in this Agreement.

SECTION 2. RESTRICTIONS ON USE.

Licensee is authorized to use the Software in machine readable, object code form only, and Licensee shall 
not: (a) assign, sublicense, sell, distribute, transfer, pledge, lease, rent, share or export the Software, the 
Documentation or Licensee's rights hereunder; (b) alter or circumvent the copy protection mechanisms in 
the Software or reverse engineer, decompile, disassemble or otherwise attempt to discover the source 
code of the Software; (c) modify, adapt, translate or create derivative works based on the Software or 
Documentation; (d) use, or allow the use of, the Software or Documentation on any project other than a 
project produced by Licensee (an "Authorized Project"); (e) allow or permit anyone (other than Licensee and 
Licensee's authorized employees to the extent they are working on an Authorized Project) to use or have 
access to the Software or Documentation; (f) copy or install the Software or Documentation other than as 
expressly provided for herein; or (g) take any action, or fail to take action, that could adversely affect the 
trademarks, service marks, patents, trade secrets, copyrights or other intellectual property rights of The 
Foundry or any third party with intellectual property rights in the Software (each, a "Third Party Licensor"). 
Furthermore, for purposes of this Section 2, the term "Software" shall include any derivatives of the 
Software.

Licensee shall install and use only a single copy of the Software on one computer, unless the Software is 
installed in a "floating license" environment, in which case Licensee may install the Software on more than 
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one computer; provided, however, Licensee shall not at any one time use more copies of the Software than 
the total number of valid Software licenses purchased by Licensee.

Please note that in order to guard against unlicensed use of the Software a licence key is required to 
access and enable the Software. The issuing of replacement or substituted licence keys if the Software is 
moved from one computer to another is subject to and strictly in accordance with The Foundry’s Licence 
Transfer Policy, which is available on The Foundry’s website and which requires a fee to be paid in certain 
circumstances. The Foundry may from time to time and at its sole discretion vary the terms and conditions 
of the Licence Transfer Policy.

Furthermore, if the Software can be licensed on an "interactive" or "non-interactive" basis, licensee shall be 
authorized to use a non-interactive version of the Software for rendering purposes only (i.e., on a CPU, 
without a user, in a non-interactive capacity) and shall not use such Software on workstations or 
otherwise in a user-interactive capacity. Licensee shall be authorized to use an interactive version of the 
Software for both interactive and non-interactive rendering purposes, if available.

If Licensee has purchased the Software on the discount terms offered by The Foundry’s Educational Policy 
published on its website (“the Educational Policy”), Licensee warrants and represents to The Foundry as a 
condition of this Agreement that: (a) (if Licensee is an individual) he or she is a part-time or full-time 
student at the time of purchase and will not use the Software for commercial, professional or for-profit 
purposes; (b) (if the Licensee is not an individual) it is an organisation that will use it only for the purpose 
of training and instruction, and for no other purpose (c) Licensee will at all times comply with the 
Educational Policy (as such policy may be amended from time to time).

Finally, if the Software is a "Personal Learning Edition," (“PLE”) Licensee may use it only for the purpose of 
personal or internal training and instruction, and for no other purpose. PLE versions of the Software may 
not be used for commercial, professional or for-profit purposes including, for the avoidance of doubt, the 
purpose of providing training or instruction to third parties.

SECTION 3. SOURCE CODE.

Notwithstanding that Section 1 defines “Software” as an object code version and that Section 2 provides 
that Licensee may use the Software in object code form only, The Foundry may also agree to license to 
Licensee (including by way of upgrades, updates or enhancements) source code or elements of the source 
code of the Software the intellectual property rights in which belong either to The Foundry or to a Third 
Party Licensor (“Source Code”). If The Foundry does so Licensee shall be licensed to use the Source Code as 
Software on the terms of this Agreement and: (a) notwithstanding Section 2 (c) Licensee may use the 
Source Code at its own risk in any reasonable way for the limited purpose of enhancing its use of the 
Software solely for its own internal business purposes and in all respects in accordance with this 
Agreement; (b) Licensee shall in respect of the Source Code comply strictly with all other restrictions 
applying to its use of the Software under this Agreement as well as any other restriction or instruction 
that is communicated to it by The Foundry at any time during this Agreement (whether imposed or 
requested by The Foundry or by any Third Party Licensor); (c) notwithstanding any other term of this 
Agreement The Foundry gives no warranty whatsoever in respect of the Source Code, which is licensed on 
an “as is” basis, or in respect of any modification of the Source Code made by Licensee (“Modification”); (d) 
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notwithstanding any other term of this Agreement The Foundry shall have no obligation to provide 
support, maintenance, upgrades or updates of or in respect of the Source Code or of any Modification; and 
(e) Licensee shall indemnify The Foundry against all liabilities and expenses (including reasonable legal 
costs) incurred by The Foundry in relation to any claim asserting that any Modification infringes the 
intellectual property rights of any third party.

SECTION 4. BACK-UP COPY.

Notwithstanding Section 2, Licensee may store one copy of the Software and Documentation off-line and 
off-site in a secured location owned or leased by Licensee in order to provide a back-up in the event of 
destruction by fire, flood, acts of war, acts of nature, vandalism or other incident. In no event may 
Licensee use the back-up copy of the Software or Documentation to circumvent the usage or other 
limitations set forth in this Agreement.

SECTION 5. OWNERSHIP.

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that is 
licensed to Licensee) and Documentation and all intellectual property rights and other proprietary rights 
relating thereto are and shall remain the sole property of The Foundry and the Third Party Licensors. 
Licensee shall not remove, or allow the removal of, any copyright or other proprietary rights notice 
included in and on the Software or Documentation or take any other action that could adversely affect the 
property rights of The Foundry or any Third Party Licensor. To the extent that Licensee is authorized to 
make copies of the Software or Documentation under this Agreement, Licensee shall reproduce in and on 
all such copies any copyright and/or other proprietary rights notices provided in and on the materials 
supplied by The Foundry hereunder. Nothing in this Agreement shall be deemed to give Licensee any rights 
in the trademarks, service marks, patents, trade secrets, confidential information, copyrights or other 
intellectual property rights of The Foundry or any Third Party Licensor, and Licensee shall be strictly 
prohibited from using the name, trademarks or service marks of The Foundry or any Third Party Licensor in 
Licensee's promotion or publicity without The Foundry's express written approval.

SECTION 6. LICENSE FEE.

Licensee understands that the benefits granted to Licensee hereunder are contingent upon Licensee's 
payment in full of the license fee payable in connection herewith (the "License Fee").

SECTION 7. UPGRADES/ENHANCEMENTS.

The Licensee's access to support, upgrades and updates is subject to the terms and conditions of the 
"Annual Upgrade and Support Programme” available on The Foundry's website. The Foundry may from time 
to time and at its sole discretion vary the terms and conditions of the Annual Upgrade and Support 
Programme.

SECTION 8. TAXES AND DUTIES. 

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax 
(exclusive of taxes based on net income), duty, tariff or other impost related to or arising from the 
transaction contemplated by this Agreement.
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SECTION 9. LIMITED WARRANTY.

The Foundry warrants that, for a period of ninety (90) days after delivery of the Software: (a) the machine 
readable electronic files constituting the Software and Documentation shall be free from errors that may 
arise from the electronic file transfer from The Foundry and/or its authorized reseller to Licensee; and (b) 
to the best of The Foundry's knowledge, Licensee's use of the Software in accordance with the 
Documentation will not, in and of itself, infringe any third party's copyright, patent or other intellectual 
property rights. Except as warranted, the Software and Documentation is being provided "as is." THE 
FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS, EXPRESS OR 
IMPLIED, AND The Foundry DISCLAIMS ANY AND ALL IMPLIED WARRANTIES OR CONDITIONS, INCLUDING, 
WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF TITLE, NON-INFRINGEMENT, MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE, REGARDLESS OF WHETHER The Foundry KNOWS OR HAS REASON 
TO KNOW OF LICENSEE'S PARTICULAR NEEDS. The Foundry does not warrant that the Software or 
Documentation will meet Licensee's requirements or that Licensee's use of the Software will be 
uninterrupted or error free. No employee or agent of The Foundry is authorized to modify this limited 
warranty, nor to make additional warranties. No action for any breach of the above limited warranty may 
be commenced more than one (1) year after Licensee's initial receipt of the Software. To the extent any 
implied warranties may not be disclaimed under applicable law, then ANY IMPLIED WARRANTIES ARE 
LIMITED IN DURATION TO NINETY (90) DAYS AFTER DELIVERY OF THE SOFTWARE TO LICENSEE. 

SECTION 10. LIMITED REMEDY.

The exclusive remedy available to the Licensee in the event of a breach of the foregoing limited warranty, 
TO THE EXCLUSION OF ALL OTHER REMEDIES, is for Licensee to destroy all copies of the Software, send 
The Foundry a written certification of such destruction and, upon The Foundry's receipt of such 
certification, The Foundry will make a replacement copy of the Software available to Licensee.

SECTION 11. INDEMNIFICATION.

Licensee agrees to indemnify, hold harmless and defend The Foundry, the Third Party Licensors and The 
Foundry's and each Third Party Licensor’s respective affiliates, officers, directors, shareholders, 
employees, authorized resellers, agents and other representatives (collectively, the "Released Parties") 
from all claims, defense costs (including, but not limited to, attorneys' fees), judgments, settlements and 
other expenses arising from or connected with the operation of Licensee's business or Licensee's 
possession or use of the Software or Documentation.

SECTION 12. LIMITED LIABILITY.

In no event shall the Released Parties' cumulative liability to Licensee or any other party for any loss or 
damages resulting from any claims, demands or actions arising out of or relating to this Agreement (or the 
Software or Documentation contemplated herein) exceed the License Fee paid to The Foundry or its 
authorized reseller for use of the Software. Furthermore, IN NO EVENT SHALL THE RELEASED PARTIES BE 
LIABLE TO LICENSEE UNDER ANY THEORY FOR ANY INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, 
EXEMPLARY OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS OR LOSS OF 
PROFITS) OR THE COST OF PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES, REGARDLESS OF 
WHETHER THE RELEASED PARTIES KNOW OR HAVE REASON TO KNOW OF THE POSSIBILITY OF SUCH 
DAMAGES AND REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL 
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PURPOSE. No action arising out of or related to this Agreement, regardless of form, may be brought by 
Licensee more than one (1) year after Licensee's initial receipt of the Software; provided, however, to the 
extent such one (1) year limit may not be valid under applicable law, then such period shall be limited to 
the shortest period allowed by law.

SECTION 13. TERM; TERMINATION.

This Agreement is effective upon Licensee's acceptance of the terms hereof and Licensee's payment of the 
License Fee, and the Agreement will remain in effect until termination. If Licensee breaches this Agreement, 
The Foundry may terminate the License granted hereunder by notice to Licensee. In the event the License 
is terminated, Licensee will either return to The Foundry all copies of the Software and Documentation in 
Licensee's possession or, if The Foundry directs in writing, destroy all such copies. In the later case, if 
requested by The Foundry, Licensee shall provide The Foundry with a certificate signed by an officer of 
Licensee confirming that the foregoing destruction has been completed.

SECTION 14. CONFIDENTIALITY.

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is licensed 
to Licensee) and Documentation are proprietary and confidential information of The Foundry or, as the 
case may be, the Third Party Licensors, and that all such information and any communications relating 
thereto (collectively, "Confidential Information") are confidential and a fundamental and important trade 
secret of The Foundry or the Third Party Licensors. Licensee shall disclose Confidential Information only to 
Licensee's employees who are working on an Authorized Project and have a "need-to-know" of such 
Confidential Information, and shall advise any recipients of Confidential Information that it is to be used 
only as authorized in this Agreement. Licensee shall not disclose Confidential Information or otherwise 
make any Confidential Information available to any other of the Licensee's employees or to any third 
parties without the express written consent of The Foundry. Licensee agrees to segregate, to the extent it 
can be reasonably done, the Confidential Information from the confidential information and materials of 
others in order to prevent commingling. Licensee shall take reasonable security measures, which such 
measures shall be at least as great as the measures Licensee uses to keep Licensee's own confidential 
information secure (but in any case using no less than a reasonable degree of care), to hold the Software, 
Documentation and any other Confidential Information in strict confidence and safe custody. The Foundry 
may request, in which case Licensee agrees to comply with, certain reasonable security measures as part 
of the use of the Software and Documentation. Licensee acknowledges that monetary damages may not be 
a sufficient remedy for unauthorized disclosure of Confidential Information, and that The Foundry shall be 
entitled, without waiving any other rights or remedies, to such injunctive or equitable relief as may be 
deemed proper by a court of competent jurisdiction. 

SECTION 15. INSPECTION.

Licensee shall advise The Foundry on demand of all locations where the Software or Documentation is used 
or stored. Licensee shall permit The Foundry or its authorized agents to inspect all such locations during 
normal business hours and on reasonable advance notice.
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SECTION 16. NONSOLICITATION.

Licensee agrees not to solicit for employment or retention any of The Foundry's current or future 
employees who were or are involved in the development and/or creation of the Software.

SECTION 17. U.S. GOVERNMENT LICENSE RIGHTS.

The Software, Documentation and/or data delivered hereunder are subject to the terms of this Agreement 
and in no event shall the U.S. Government acquire greater than RESTRICTED/LIMITED RIGHTS. At a 
minimum, use, duplication or disclosure by the U.S. Government is subject to the applicable restrictions of: 
(i) FAR §52.227-14 ALTS I, II and III (June 1987); (ii) FAR §52.227-19 (June 1987); (iii) FAR §12.211 and 
12.212; and/or (iv) DFARS §227.7202-1(a) and DFARS §227.7202-3.

The Software is the subject of the following notices:

• Copyright (c) 2011 The Foundry Visionmongers, Ltd.. All Rights Reserved.

• Unpublished-rights reserved under the Copyright Laws of the United Kingdom.

SECTION 18. SURVIVAL.

Sections 2, 3, 5, 6, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19 and 20 shall survive any termination or 
expiration of this Agreement.

SECTION 19. IMPORT/EXPORT CONTROLS.

To the extent that any Software made available hereunder is subject to restrictions upon export and/or 
reexport from the United States, Licensee agrees to comply with, and not act or fail to act in any way that 
would violate, the applicable international, national, state, regional and local laws and regulations, 
including, without limitation, the United States Foreign Corrupt Practices Act, the Export Administration 
Act and the Export Administration Regulations, as amended or otherwise modified from time to time, and 
neither The Foundry nor Licensee shall be required under this Agreement to act or fail to act in any way 
which it believes in good faith will violate any such laws or regulations.

SECTION 20. MISCELLANEOUS.

This Agreement is the exclusive agreement between the parties concerning the subject matter hereof and 
supersedes any and all prior oral or written agreements, negotiations, or other dealings between the 
parties concerning such subject. This Agreement may be modified only by a written instrument signed by 
both parties. If any action is brought by either party to this Agreement against the other party regarding 
the subject matter hereof, the prevailing party shall be entitled to recover, in addition to any other relief 
granted, reasonable attorneys' fees and expenses of litigation. Should any term of this Agreement be 
declared void or unenforceable by any court of competent jurisdiction, such declaration shall have no 
effect on the remaining terms of this Agreement. The failure of either party to enforce any rights granted 
hereunder or to take action against the other party in the event of any breach hereunder shall not be 
deemed a waiver by that party as to subsequent enforcement of rights or subsequent actions in the event 
of future breaches. This Agreement shall be governed by, and construed in accordance with English Law.

The Foundry and Licensee intend that each Third Party Licensor may enforce against Licensee under the 
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Contracts (Rights of Third Parties) Act 1999 ("the Act") any obligation owed by Licensee to The Foundry 
under this Agreement that is capable of application to any proprietary or other right of that Third Party 
Licensor in or in relation to the Software. The Foundry and Licensee reserve the right under section 2(3)(a) 
of the Act to rescind, terminate or vary this Agreement without the consent of any Third Party Licensor.

Copyright (c) 2011 The Foundry Visionmongers Ltd. All Rights Reserved. Do not duplicate.
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