
RELEASE NOTES

Release Notes for Modo 14.0v2

Release Date
26 May 2020

System Requirements

Officially Supported Operating Systems
• macOS 10.13.x, 10.14.x, and 10.15.x (64-bit only)

• Windows 10 (64-bit only)

• Linux 64-bit operating system (CentOS/RHEL 7+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher

• 1 GB available hard disk space (for Modo installation).

• 6 GB available hard disk space (for full content).

• At least 4 GB RAM

• Display with 1920 x 1080 pixel resolution

• Internet connection for product activation and online videos access

• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of
graphics memory and drivers that support OpenGL 3.2 or higher.

1

Copyright © 2020 The Foundry Visionmongers Ltd.



RELEASE NOTES
2

Recommended System Requirements

Note: This information is our best recommendation for the average user. Requirements
vary by usage, and individual users may have different requirements from those listed here.

• 2.5+ GHz quad-core processor

• 250+ GB disk space available for caching and temporary files, SSD is preferable

• 16 GB RAM with additional virtual memory*

• Display with 1920 x 1080 pixel resolution

• An NVIDIA or AMD graphics card with the latest drivers

• 2+ GB of graphics memory

• OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions
• NVIDIA: 435 or later*

• AMD: 8.982.8.1 or later*

*We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 13.0v1. Due to the
constantly changing nature and wide variety of computer hardware available in the market, Foundry
is unable to officially certify hardware. The list below can be used as a recommendation and does not
guarantee that it meets your particular needs.

If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

Tested Workstation Hardware

Apple • MacBook Pro (Retina, 15-inch, Mid-2015)

• iMac (Late 2012)

• Mac Pro (Late 2013)

Release Notes for Modo 14.0v2 |
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Tested Workstation Hardware

• MacBook Pro (Mid-2015)

Dell • XPS 15 9560

• Precision 3520

HP • HP Z800

• HP Z640

• HP Z600

CPU • AMD Ryzen Threadripper

• Intel i7-4770k

• Intel i7-7700k

• Intel i7-8700

• Xeon E3-1505M v6

• Xeon E5504

• Xeon 5620

Tested GPU Hardware

AMD Prosumer Graphics Cards • Radeon™ Vega RX

• Radeon™ R9 M370X

• Radeon™ Pro WX8200

• Radeon™ Pro WX7100

AMD Enterprise Graphics Cards • FirePro™ D700

NVIDIA Prosumer Graphics Cards • GeForce 675MX

• GeForce 970

• GeForce 1050 (laptop)

• GeForce GTX 1070 Ti (Linux)

• GeForce 1080

NVIDIA Enterprise Graphics Cards • Quadro® K620

• Quadro® M620

• Quadro® M4000

Release Notes for Modo 14.0v2 |
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New Features
There are no new features in this release.

Feature Enhancements
There are no feature enhancements in this release.

Bug Fixes

Note: Due to internal bug-logging and tracking process improvements, new bug
identification numbers are used, with the legacy IDs provided in parentheses, where
appropriate.

• BUG ID 417108 - Viewports: Images viewed in the Clips viewport appeared grainy.

• BUG ID 422974 (60231) - Rendering: mPath produced unexpected refraction in a customer scene.

• BUG ID 426549 - Scripting: The base material of a scene could not be copied to a different scene
using import.layer().

• BUG ID 426710 - Modeling: Snapping did not stick to snapped vertices using Instances.

• BUG ID 427060 - Rendering: Stereoscopic scenes caused mPath to crash.

• BUG ID 427274 - Rendering the same scene with Modo 13 and Modo 14 produced different results.

• BUG ID 427765 - Viewports: Switching between the Preview render window and the AVP/GL View
caused Modo to crash.

• BUG ID 427934 - Windows only: Certain scenes displayed black render artifacts/NaNs.

• BUG ID 427945 - Procedurals: Enabling Curve Sweep caps in polygon Strip mode caused Modo to
crash.

• BUG ID 428289 - Procedurals: Manually shrinking an edge selection on meshes with vertex merges
occasionally caused Modo to crash.

• BUG ID 429002 - Shader Tree: Hiding displacement layers stopped alpha Channel attributes working
as expected.

• BUG ID 429006 - Shader Tree: Setting .png alpha channels as Ignore did not work as expected in
Group Masks.

• BUG ID 429389 (60374) - Procedurals: Adjusting the radius of a circle in certain scenes caused Modo
to crash.

Release Notes for Modo 14.0v2 | New Features
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• BUG ID 429399 - Rendering: Updating images outside Modo did not update new Renders correctly.

• BUG ID 429598 - Windows only: Certain scenes displayed black and magenta NaNs with the default
renderer.

• BUG ID 429717 - UVing: SelectingMove and Sew after editing a mesh caused Modo to crash.

• BUG ID 429874 - Unity materials rendered incorrectly.

• BUG ID 429905 - Shader Tree: Certain image groups set to Alpha Only rendered incorrectly.

• BUG ID 430177 - Scripting: Removing the last environment item Pythonically caused Modo to crash.

• BUG ID 430276 (60395) - Replicators: Previewing certain Replicators caused Modo to crash.

• BUG ID 430288 (60396) - Replicators: Opening Preview occasionally caused Modo to crash during
Replicator drawing.

• BUG ID 430318 - Shader Tree: Channel Swizzle did not work as expected.

• BUG ID 430554 - Modeling: Lassoing B-Splines occasionally caused Modo to crash.

• BUG ID 430861 (60405) - Channel Swizzling did not work as expected with image maps containing
texture falloffs.

• BUG ID 431201 - Channel Swizzling on UDIM tiles rendered incorrectly.

• BUG ID 431274 (60417) - UV Stitch occasionally caused Modo to crash.

• BUG ID 432160 (60426) - Creating a clip (videostill) Pythonically did not render as expected.

Known Issues and Workarounds
This section covers known issues and gives workarounds for them, where appropriate.

Note: Due to internal bug-logging and tracking process improvements, new bug
identification numbers are used, with the legacy IDs provided in parentheses, where
appropriate.

Animation
• BUG ID 423909 - Markup: Setting image type to .jpg results in a black fill over the screen.

• BUG ID 395357 - Deformer Caching doesn’t work as expected.

• BUG ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by
copying actions.

As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab,
then save and reload the scene.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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Assemblies
• BUG ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual
layout of nodes on import.

As a workaround, you can save assemblies from the Schematic viewport.

Baking
• BUG ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the
baked displacement map to show quilting effects and other render artifacts.

• BUG ID 221481 (49437) - The Bake Channel Swizzling option can’t bake to texture alpha.

Bucket Render
• BUG ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when
the mesh has transform channels.

As a workaround, freeze the transforms in the mesh properties.

• BUG ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo
10.1 or earlier now show on the render item instead.

• BUG ID 279848 (55663) - Motion Blur applied on a curve in a mesh operation no longer works.

• BUG ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than
expected.

As a workaround, any machine that has more than 32 cores, performance will be better if you limit
rendering to half the number of cores you have.

• BUG ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies
(hot pixels) in some cases.

As a workaround, use aMaximum Radiance higher than 1 W/srm2 to reduce the bias.

Color Management
• BUG ID 221439 (49244) - (Windows only): With Perform Color Correction on, setting a default scene
to a scene with a mesh that has a position channel crashes Modo at launch.

As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default
scene.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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Command Line
• BUG ID 289290 (49514) - macOS only: Runningmodo_cl before running the UI Modo application
breaks code signing.

As a workaround, start the UI version of Modo once, before runningmodo_cl on any system where
you later intend to use the UI version.

File and Image I/O
• BUG ID 346842 - Alembic import: Drag-and-drop doesn't import animation correctly.

As a workaround, use File > Import.

• BUG ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same
SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct
imports (File > Import).

As a workaround: Before importing a SolidWorks file for the second time, exit and restart Modo.

• BUG ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes
and procedural shatter items.

• BUG ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't
export instances, unless the original mesh is also exported.

To resolve this, set the .fbx preference to Export Selection and use Export As….

• BUG ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-
effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color
correction was enabled.

• BUG ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer
masking can be very slow.

Fur
• BUG ID 288248 (35731) - Fur length textures can’t be edited with the Stretch tool.

As a workaround, use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices
• BUG ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause
undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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To avoid this, plug in the tablet before application start-up or restart.

• BUG ID 226536 (51741) - macOS only: Modo sometimes becomes unresponsive when using the
combination of a click-drag in a tree view (for example, when toggling the visibility of two successive
items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices,
including laptop trackpads and the Magic Mouse.

As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).

MeshFusion
• BUG ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and
dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion buttons (Tool palette - Set Mesh Role & Apply section) or
Pie Menu (Apply Subtraction or Apply Intersection) when initially adding Trims to each Fusion
Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those
methods, all subsequent Drag & Drop options are supported.

Modeling
• BUG ID 408278 (60027) - Linear Falloff snaps to the object size.

As a workaround, use the right mouse button for an interactive initial linear handle.

• BUG ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

Network Rendering
• BUG ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong
image sequence number on slave machines.

As a workaround, use File > Consolidate Scene, then render the scene using a shared network
folder (Preferences option under Rendering > Network Rendering).

• BUG ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the
scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden
state, however.

As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or
open System > Preferences > Rendering and disable Use Network Render Nodes.

• BUG ID 226336 (25636) - Frame passes are not supported.

• BUG ID 220955 (30318) - Network Rendering doesn’t support Realflow particles.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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• Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not
implemented to support baking. Changes to Modo in the 10-series apparently broke what was
working for some artists, so the functionality has been disabled.

As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an
external render controller. For more information, please see the SDK Wiki.

Nodal Shading
• BUG ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

• BUG ID 221393 (50642) - Nodal shading does not support UDIMs.

Painting/Sculpting
• BUG ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an
image map.

You can save and reload the image to force the update.

Particles
• BUG ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache
files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation
item in the Schematic viewport, and clicking Cache Simulation.

Preview
• If a high poly mesh is not visible, the Preview baking output will be incorrect.

As a workaround, reset Preview to fix the baking.

Procedurals
• BUG ID 388978 - Paving doesn't work when a Guide curve runs through a paving hole.

• BUG ID 305303 (56318) - Procedural duplication of mesh operations in a Deform folder creates
errantMesh Ops list.

• BUG ID 305302 (56317) - Duplicating procedurals does not work with the Select By Previous
Operation tool.

As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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• BUG ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in
GL. This is a limitation of the feature and will not be fixed.

You can use Preview or RayGL to visualize the variations from rigging.

• BUG ID 266469 (54738) - A duplication of any item that is a Merge Meshes source (for example, a
mesh item, procedural item, or Fusion Item), any duplicates (duplicate or instance) are added to the
Merge Meshes Ops List as a source.

As a workaround, remove the unwanted additional Merge Mesh sources (regardless of the type of
source) in theMesh Ops List using the X button next to each Merge Meshes source.

• BUG ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to
Normal option doesn't work when using a Bezier with zero-length tangents.

As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there
are no zero-length tangents.

References
• BUG ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after
attempting to revert a reference override.

As a workaround, first close and reopen the scene before attempting to revert the reference.

• BUG ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the
original references may not persist.

As a workaround, limit scenes with shading to one level of reference.

• BUG ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo
to crash.

Rigging
• BUG ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

• BUG ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original
joint chain.

Scripting
• BUG ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to
Modo.

As a workaround, click in the top window of the Script Editor, use the main menus, or change to
another application, then switch back to Modo.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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Shader Tree
• BUG ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the
Skin material), no longer smooth the mesh correctly.

• BUG ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use
clip browser) fails.

To work around this issue, in the Clip Browser, choose a single image instead of the group, and
then change to the image group using the Texture Layer's Properties tab.

• BUG ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the
masking layer onto the displacement layer.

Unreal and Unity Materials
• BUG ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• BUG ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• BUG ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the
Advanced viewport when used with bump maps and shadows.

UI
• BUG ID 395884 - macOS only: Double-clicking the bottom right corner or edge of a popover doesn't
resize the popover correctly.

• BUG ID 388937 - macOS only: UI form field highlights occasionally appear solid gray.

• BUG ID 333249 (57715) - Selecting items in the viewport does not always update the Properties
form.

As a workaround, press the Alt key.

• BUG ID 288714 (43162) - Windows only: Setting a custom text size affects Modo's text drawing.

As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable,
and turn off font-scaling for the application.

• BUG ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• BUG ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

• BUG ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on
some macOS/AMD configurations.

As a workaround: Upgrade macOS to 10.12 or 10.13.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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• BUG ID 226492 (44496) - macOS only: Disabling Affect System Color Dialog in Preferences >
Rendering > Color Management, and using the system color picker caused colors to darken with
each use of the color picker.

This is due to an OS X issue, which requires the color profile in both the monitor settings and color
picker to be set to sRGB IEC61966-2.1.

• BUG ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn’t work.

If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below
other images in the list.

Viewports
• Windows only: Using Raptr can cause GL driver crashes in Modo.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any
unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in
the Shader Tree.

• BUG ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

• BUG ID 408416 - The Gradient texture layer renders incorrectly in the Advanced viewport.

As a workaround, use Preview.

• BUG ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon
WX-series graphics card. This is due to a driver bug and should be fixed by a AMD in a future driver
release.

• BUG ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D
view (palette or separate window).

As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a
Layout).

• BUG ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded
into the Advanced viewport.

As a workaround, enable and then disable the visibility of the Shader Tree textures.

• BUG ID 296123 (46995) - Ambient Occlusion display in the Advanced viewport is affected by selected
item wireframes.

You can disable Show Selection in the Visibility options or disable wireframe drawing on the active
mesh layers.

• BUG ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit
mode and the width is less than the height.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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• BUG ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and
baking.

To avoid this, make sure that the projection camera has a film width-to-height ratio that matches
the main render camera.

• BUG ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced
viewport.

As a workaround, avoid transparency when modeling or doing work where wireframes are needed.
Alternatively, use the Default viewport.

VR
• BUG ID 218386 - VR is now supported on Linux, but has only been tested and verified working using
SteamVR on Ubuntu 18.04.

Release Notes for Modo 14.0v2 | Known Issues and Workarounds
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Release Notes for Modo 14.0v1

Release Date
19 March 2020

System Requirements

Officially Supported Operating Systems
• Mac OS 10.13.x, 10.14.x, and 10.15.x (64-bit only)

• Windows 10 (64-bit only)

• Linux 64-bit operating system (CentOS/RHEL 7+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher

• 1 GB available hard disk space (for Modo installation).

• 6 GB available hard disk space (for full content).

• At least 4 GB RAM

• Display with 1920 x 1080 pixel resolution

• Internet connection for product activation and online videos access

• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of
graphics memory and drivers that support OpenGL 3.2 or higher.

14
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Recommended System Requirements

Note: This information is our best recommendation for the average user. Requirements
vary by usage, and individual users may have different requirements from those listed here.

• 2.5+ GHz quad-core processor

• 250+ GB disk space available for caching and temporary files, SSD is preferable

• 16 GB RAM with additional virtual memory*

• Display with 1920 x 1080 pixel resolution

• An NVIDIA or AMD graphics card with the latest drivers

• 2+ GB of graphics memory

• OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions
• NVIDIA: 435 or later*

• AMD: 8.982.8.1 or later*

*We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 13.0v1. Due to the
constantly changing nature and wide variety of computer hardware available in the market, Foundry
is unable to officially certify hardware. The list below can be used as a recommendation and does not
guarantee that it meets your particular needs.

If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

Tested Workstation Hardware

Apple • MacBook Pro (Retina, 15-inch, Mid-2015)

• iMac (Late 2012)

• Mac Pro (Late 2013)

Release Notes for Modo 14.0v1 |
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Tested Workstation Hardware

• MacBook Pro (Mid-2015)

Dell • XPS 15 9560

• Precision 3520

HP • HP Z800

• HP Z640

• HP Z600

CPU • AMD Ryzen Threadripper

• Intel i7-4770k

• Intel i7-7700k

• Intel i7-8700

• Xeon E3-1505M v6

• Xeon E5504

• Xeon 5620

Tested GPU Hardware

AMD Prosumer Graphics Cards • Radeon™ Vega RX

• Radeon™ R9 M370X

• Radeon™ Pro WX8200

• Radeon™ Pro WX7100

AMD Enterprise Graphics Cards • FirePro™ D700

NVIDIA Prosumer Graphics Cards • GeForce 675MX

• GeForce 970

• GeForce 1050 (laptop)

• GeForce GTX 1070 Ti (Linux)

• GeForce 1080

NVIDIA Enterprise Graphics Cards • Quadro® K620

• Quadro® M620

• Quadro® M4000

Release Notes for Modo 14.0v1 |
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New Features

Animation and Rigging

Markup

The Markup tool allows you to draw directly onto selected camera views so you can add annotations,
notes, and comments to your animations or stills.

Direct Modeling

Bevel Enhancements

Unbevel

Unbevel collapses beveled faces between two selected edge loops.

Add Point Option for Edge Relax

This option allows you to insert new points or remove existing ones along selected edges. 

Edge Chamfer Enhancements

• Profile Preset Support - You can now select a 1D profile shape to determine the shape of the
chamfer.

• Reverse Direction - When using a profile preset, this option allows you to reverse the start and end
of the profile curve.

• Reverse Depth - When using a profile preset, this option allows you to reverse the depth direction
of the profile shape.

• Falloff Support - Edge Chamfer now supports falloffs.

Face Slide

The Slide tool has a new Face mode, which allows you to slide a vertex on a connected face.

Release Notes for Modo 14.0v1 | New Features
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MeshFusion

Surface Strip Embossing

A new workflow that allows you to create embossed surface strips on Fusion Items using simple,
Bezier, B-Spline curves, or text.

Procedural Modeling

Mesh Operations

You can now create vertex maps and set weight values, seams, and RGBA values procedurally. The
following tools are now available as mesh operations:

• Create Vertex Map

• Set Weight

• Set Edge Weight

• Set Seam

• Set RGB

• Select Vertex Map Value selection operation

Shading and Rendering

mPath Improvements

• Light Path Expression names have been simplified, making it easier to work with them in the Shader
Tree.

• mPath now supports the rendering of AxF materials.

Scale Groups in the Shader Tree

Manually scaling individual texture layers in the Shader Tree may be difficult. The separate layers
might not contain the same relative scale or tiling, which means you have to figure out what the
relative scaling is. These parameters allow you to scale all layers within a material relative to one
another in the Shader Tree.

Release Notes for Modo 14.0v1 | New Features
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Topology

Transparency Overrides

The X-Ray and Ghost 3D viewport transparency modes have been added to help you differentiate
between background and foreground wireframes, so you can easily understand the topology you're
working with. This option is especially useful for decluttering heavy wireframe models.

UV Enhancements

Unwrap & Relax

The Unwrap & Relax tool combines the Unwrap Tool and UV Relax into one tool, allowing you to
perform two operations on your UVs in one step to create a UV pelt.

UV Relax Enhancements

The Ignore Edge Selection option has been added to the UV Relax tool. UV Relax is frequently run
after Unwrap, which requires edges to be selected. You then need to drop the tool before running UV
Relax. When this option is enabled, the UV Relax operation ignores any currently selected edges.

Workflow and UI Improvements
• Select Partial for Lasso Selection - The Lasso Partial Selection Mode (keyboard shortcut: 8) allows
you to select entire edges or polygons by only selecting part of it.

• Always Raycast Option for Element Move - This option allows you to manipulate polygons in in
Wireframe viewport mode. When disabled, only vertices and edges can be edited in Wireframe
mode.

• Use World Transforms option for Falloffs - This option allows falloffs to affect all selected mesh
surfaces as one surface and deform them as one. This option has been added to the following
falloffs:

• Linear Falloff

• Cylinder Falloff

• Radial Falloff

• Noise Falloff

• Path Falloff

Release Notes for Modo 14.0v1 | New Features
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• Lasso Falloff

• Image Falloff

• Rename Vortex Deformer to Twist - Vortex Deformer has been renamed to Twist Deformer.

• No Trackball Rotation by Default - Trackball Rotation is now disabled by default for all viewports.

• Numeric Command Queries on Key Assignments - Support has been added to numeric
arguments in the input remapping system.

Feature Enhancements
• BUG ID 410657 - File I/O: Decimal frame support has been added to Alembic animation export, so
fractional frame ranges can now be exported correctly.

• BUG ID 417075 - Viewports: The Advanced viewport now supports color remapping, enabling non-
default high and low texture values to be displayed correctly.

Advanced Viewport Improvements
• Support has been added for the Shader Tree Texture Layer’s Brightness and Contrast controls.

• Support has been added for Widget and UI element-wide line rendering.

• Added support for OpenGL Storage Shader Buffer Objects (SSBO). Extends storage and texture
allocations for supported GPU drivers (not MacOS).

• Extra GPU information has been added to the viewport timeline when using the 'glmeter true true'
command.

• MacOS HDR capable rendering (Experimental) has been added.

Bug Fixes

Note: Due to internal bug-logging and tracking process improvements, new bug
identification numbers are used, with the legacy IDs provided in parentheses, where
appropriate.

• BUG ID 221462 (46650) - Viewports: In Material selection mode, the Advanced viewport displayed
meshes in white.

• BUG ID 239667 - Viewports: In the Advanced viewport, image maps with different remapping were
not remapped separately.

• BUG ID 288668 (42960) - Customization: Saving a form containing sub-forms created in the Form
Editor caused Modo to crash.
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• BUG ID 293964 (45397) - UVing: Running the UV sew command on adjacent edges with the
unselected edges belonging to non-connected polygons produced unexpected results.

• BUG ID 335271 - Modeling: Noise falloff was fixed on object space.

• BUG ID 337823 (57375) - File I/O: FBX: Exporting animation to .fbx did not work if the .lxo scene was
not imported into a new scene.

• BUG ID 344023 (58323) - Viewports: Moving the default scene's directional light forced the
environment image to redraw.

• BUG ID 345015 (57023) - Modeling: The Clone tool (in component mode) and the Clone mesh
operation with any generator sub-tool with scale used the wrong pivot position.

• BUG ID 345804 (58360) - File I/O: Exporting the Current Action to .fbx exported all animated frames,
rather than the timeline range.

• BUG ID 356552 (58738) - Viewports: Selection transparency through geometry was incorrect in the
Advanced viewport.

• BUG ID 363144 (58979) - Procedurals: The Merge Meshes mesh operation merged normals, but did
not apply item level transforms to the normals.

• BUG ID 364152 - Shader Tree: The Group Mask layer effect did not mask the Dissolve layer effect
correctly.

• BUG ID 373746 (59206) - Modeling: Geometry Snapping attributes did not update automatically.

• BUG ID 376773 - Shader Tree: Group Masks with alpha textures did not mask parts of a normal map
correctly when it was below the Group Mask in the hierarchy.

• BUG ID 382113 - Uving: UV Relax was incorrectly adding UV Constraints Vertex maps.

• BUG ID 384912 (59519) - Preview: Updating lighting textures significantly slowed down rendering.

• BUG ID 392196 - MeshFusion: The Use Inward property didn't update correctly in certain scenes.

• BUG ID 392485 - Preset Browser: Populating directories containing thousands of files was slow.

• BUG ID 393250 - Preset Browser: Adding a preset to Favorites caused Modo to become
unresponsive.

• BUG ID 395275 (59779) - Modeling: Mesh Paint did not create duplicates or instances for Procedural
meshes that contained ngons.

• BUG ID 396286 - Modeling: The Snapping cursor was not always visible.

• BUG ID 396497 - UI: Changing the Cut Map Seam Color changed the background of the floating UV
Edit window.

• BUG ID 397616 - UVing: Underlying UVs could be selected with Inactive UVs disabled.

• BUG ID 397876 - Modeling: Snapping caused performance issues in certain scenes.

• BUG ID 399070 - Viewports: GL Reflection didn't update correctly when switching GL Background
from Environment to Image.

• BUG ID 399088 - Viewports: The Topology viewport preset wasn't reset by changing to a different
viewport style.
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• BUG ID 399246 - UI: Dragging User Channels from an item's Properties into the Schematic Viewport
sometimes caused Modo to crash.

• BUG ID 399252 - Rigging: Item display in the 3D viewport displayed the internal name and not use
name for Morph Containers.

• BUG ID 401677 - Modeling: Activating the Lasso falloff in the UV viewport and then in the 3D
viewport, caused Modo to crash.

• BUG ID 402177 - Background lighting renders darker. Modifies mPath to allow indirect rays to pass
through area lights unless they are specified as opaque, matching the behavior of the legacy
renderer.

• BUG ID 403674 (59903) - Shader Tree: Moving a mesh from one scene into another resulted in
incorrect shaders.

• BUG ID 403839 (59904) - Shader Tree: Shader Tree child masks incorrectly affected the surface
normals of materials below them.

• BUG ID 404585 (59928) - Modeling: Loop Slice occasionally created holes in the mesh.

• BUG ID 404646 (59931) - Modeling: Jitter Rigid produced incorrect results.

• BUG ID 404663 (59933) - Modeling: Polygon Extrude created flipped geometry with symmetry active.

• BUG ID 405278 (59954) - mPath: Rendering a specific scene with RTX and mPath caused Modo to
become unresponsive.

• BUG ID 405551 - Modeling: Using Edge Chamfer in Square mode produced incorrect results.

• BUG ID 406202 - Schematic: The Gradient Math node didn't appear in the Insert Channel Modifier
context menu.

• BUG ID 406432 - Modeling: When extending edges imported from a .dxf file, Modo didn't create
face polygons.

• BUG ID 407694 - Rigging: The Gradient Layer Properties form was not initially visible.

• BUG ID 408766 - UVing - When using Shortest Path selection, hovering over the UV window if only
part of the mesh has UVs caused Modo to crash.

• BUG ID 409210 - Rigging: Opening a scene with loads of user gradients caused Modo to crash.

• BUG ID 409314 - Modeling: Edge Chamfer produced incorrect edge inset in certain scenes.

• BUG ID 409503 - UVing: UV Unwrap and Project From View didn't work on the first click.

• BUG ID 409548 - Performance: Certain custom camera rig workflows caused performance issues.

• BUG ID 409713 - File I/O: The Alembic export frame range was incorrect.

• BUG ID 410115 - File I/O: Select Polygons didn't work as expected when a mesh with material tags
was dragged into a new scene.

• BUG ID 410207 - Rigging: Loading a Gradient preset into a User Gradient caused Modo to crash.

• BUG ID 410643 - Modeling: Importing and then translating an Instance with Snapping enabled
caused Modo to crash.

• BUG ID 410647 - Shader Tree: Purging unused materials resulted in removing materials incorrectly.
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• BUG ID 410785 - MeshFusion: Airtight Final Item Parts didn't update instantly to the correct material
result in the 3D viewport.

• BUG ID 410795 - UI: Hovering over items in the Command History viewport sometimes caused
Modo to crash.

• BUG ID 410838 - Modeling: Edge Extend didn't create polylines when in Vertex selection mode.

• BUG ID 410973 - Modeling: Polygon Bevel, Edge Bevel, and Edge Extrude didn't carry over edge
weighting correctly.

• BUG ID 411335 - Rendering: Artifacts appeared in the mPath render for certain scenes.

• BUG ID 411336 - Modeling: Bridging geometry that touched on the symmetry line caused Modo to
crash.

• BUG ID 411360 - Modeling: Using Edge Chamfer with multiple segments didn't produce the same
result on symmetrical meshes.

• BUG ID 411531 - Modeling: Chamfering inner ring corners created ngons, which produced
unexpected results when chamfered.

• BUG ID 411644 - Procedurals: Opening certain scenes with multiple Transfer Vertex Normal Map
mesh operations caused Modo to crash.

• BUG ID 411857 - Schematic: There was a typo in the right-click context menu for Add Comment.

• BUG ID 411972 - File I/O: Replacing a missing image in a preset sometimes caused Modo to crash.

• BUG ID 412037 (60067) - Rigging: When an IK chain was reset from FK to a new rest pose, the Setup
angle bias was not recalculated.

• BUG ID 412183 - Schematic: Connecting a Texture Falloff output into a Weight Map Falloff
sometimes caused Modo to crash.

• BUG ID 412265 (60071) - Rigging: Resetting the solver from FK didn't apply the new transform to the
IK goal correctly.

• BUG ID 413757 - Schematic: Dragging a rotation channel into the Schematic viewport sometimes
caused Modo to crash.

• BUG ID 413799 (60072) - Modeling: Edge Chamfer produced incorrect results on certain meshes.

• BUG ID 413954 (60075) - Scripting: Right-clicking a command in Command History and clicking
Show Help contained an incorrect URL.

• BUG ID 414243 - File I/O: Importing .svg files sometimes caused Modo to crash.

• BUG ID 414342 - Preview Render: Preview render didn't always update to reflect material changes.

• BUG ID 414682 - macOS only: In the Advanced viewport, the Specular Roughness value of a
Principled Shader was set into the wrong GPU table value.

• BUG ID 414686 - Viewports: In the Advanced viewport, resizing the window resulted in incorrect
renders.

• BUG ID 414768 - Preset Browser: Generating thumbnails in the Preset Browser was slow.
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• BUG ID 414822 - Modeling: When using Addmode for Bezier curves, the curve point was using the
nearest curve point rather than the selected point.

• BUG ID 415032 - Viewports: Tool handle drawing in the Advanced viewport did not work correctly.

• BUG ID 415065 - Customization: &clip type user values in a form command list did not trigger
assigned actions when the value was changed.

• BUG ID 415074 (60100) - Procedurals: The Thicken mesh operation didn't propagate an Edge
SelectionSet Tag to the new edges created.

• BUG ID 415135 - Viewports: The Advanced viewport displayed textures with negative values
differently to the Render and Preview viewports.

• BUG ID 415516 - Viewports: Some meshes displayed black in the Default viewport until Material was
toggled.

• BUG ID 415554 - Viewports: Selecting items in Wireframe mode in a scene with a large number of
items caused performance issues.

• BUG ID 415724 (60104) - UVing: Convert UV to Mesh didn't retain selection sets in the resulting
mesh.

• BUG ID 415971 - File I/O: Importing and selecting a new material for certain .fbx files caused Modo
to crash.

• BUG ID 416128 - File I/O: Exporting certain files into Alembic caused Modo to crash.

• BUG ID 416131 - Schematic: Opening a file containing a Comment Node from Modo 13.1 and 13.2
on previous versions resulted in Modo becoming unresponsive.

• BUG ID 416255 - Viewports: Render Proxies were not displayed correctly in the 3D viewport.

• BUG ID 416333 - File I/O: The progress monitor for .fbx export was not working correctly.

• BUG ID 416369 (60105) - Viewports: Proxy preview items didn't display in the 3D viewport.

• BUG ID 417299 - UVing: The UV Relax error message contained a spelling mistake.

• BUG ID 418010 - Viewports: Enabling Material selection mode in the Advanced viewport with AMD
graphics cards produced thick grid lines.

• BUG ID 418194 (60135) - Edge Relax: consider making Add Point absolute instead of relative

• BUG ID 418356 - Viewports: Initiating a Playblast caused Modo to crash.

• BUG ID 419033 - UI: Moving a camera with locked channels corrupted the Properties panel.

• BUG ID 419151 - UI: Clicking the Visibility button on an image sequence in the Clips viewport.

• BUG ID 419172 - Modeling: The Bezier tool's Addmode was adding points after the nearest vertex
instead of the last selected one.

• BUG ID 419270 - Modeling: Reversing a Linear Falloff resulted in tool handles becoming
unresponsive in the 3D viewport.

• BUG ID 419342 (60168) - Rigging: 3-bar IKs incorrectly flipped the second joint orientation on a zig-
zag IK chain.

• BUG ID 419345 (60169) - Rigging: 3-bar IK had a posing limit on third joints.
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• BUG ID 419383 (60170) - Rigging: Posing IK chain with IK blending set to 0% produces unexpected
results above a certain limit.

• BUG ID 419437 - Rendering: Denoising options were incorrectly displayed as unavailable on some
devices.

• BUG ID 419491 (60175) - Modeling: Jitter incorrectly affected hidden UVs.

• BUG ID 419560 - Modeling: The Vertex Slide tool's Tool Handle Size property didn't work as
expected.

• BUG ID 419992: UVing: The Lock Stacked UVs command didn't work as expected.

• BUG ID 420021: Modeling - Using the Curve Rebuild mesh operation and setting Point Count to 2,
then freezing the curve caused Modo to crash.

• BUG ID 420411 - Procedural: The Quick Align and Ground Align buttons were incorrectly showing
active for Procedural Meshes.

• BUG ID 420526 - Viewports: Modifying components of a displaced mesh caused Performance issues.

• BUG ID 420850 (60197) - UVing: Snapping in the UV editor was incorrectly affected by hidden
background items.

• BUG ID 421145 - Preset Browser: DirCache scans were performed in headless mode, causing
deadlocks with Python file/preset plug-ins.

• BUG ID 421566 (60207) - Rigging: Unplugging 2D IK end position outputs caused Modo to crash.

• BUG ID 421567 (60208) - Rigging: Removing a Planar IK solver after unplugging the goal item input
first results in an incorrect scene evaluation.

• BUG ID 422039 - Customization: Having an incorrect command in a Form Command List caused
Modo to crash.

• BUG ID 422104 - Customization: Toggling Boolean checkboxes in a Form Command List sometimes
caused Modo to crash.

• BUG ID 422706 - Viewports: Bringing a viewport into focus required two clicks.

• BUG ID 422707 (60222) - UVing: Right-clicking in the UV viewport incorrectly opened a dialog even
when the tool was active.

• BUG ID 422774 - macOS only: Modo randomly crashed on macOS 10.15.x (Catalina).

• BUG ID 422986 - Viewports: Removing Draw Options with one of them selected in the Graph Editor
caused Modo to crash.

• BUG ID 423306 - Procedurals: Curve Sweep added extra edges when used with shape mesh
operations of different sizes.

• BUG ID 423545 - Bucket Render: Render Animation didn't clear memory after completion in certain
scenes.

• BUG ID 423704 - Presets: Loading specific presets sometimes caused Modo to crash.

• BUG ID 424020 - Customization: The Work Plane command couldn't be used as a command filter.

• BUG ID 424029 (60246) - UVing: Vertex Join sometimes produced incorrect UVs.
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• BUG ID 424397 (60265) - Render: Vertex Map Textures were rendered as black in the Preview and
Render viewports.

• BUG ID 425633 - Clicking the Fusion tab sometimes caused Modo to crash.

• BUG ID 426632 - File I/O: Dragging a group locator into another scene resulted in an error, or
caused Modo to crash.

• BUG ID 426751 - Customization: &clip type user values in a form command list did not trigger
assigned actions when using Choose (none).

• BUG ID 427482 - Using Stitch Mesh with Curve Source set to Selected Edges didn't work as
expected.

Known Issues and Workarounds
This section covers known issues and gives workarounds for them, where appropriate.

Note: Due to internal bug-logging and tracking process improvements, new bug
identification numbers are used, with the legacy IDs provided in parentheses, where
appropriate.

Animation
• BUG ID 423909 - Markup: Setting image type to .jpg results in a black fill over the screen.

• BUG ID 395357 - Deformer Caching doesn’t work as expected.

• BUG ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by
copying actions.

As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab,
then save and reload the scene.

Assemblies
• BUG ID 288164 (36452) - Assemblies exported from the Item List context menu result in poor visual
layout of nodes on import.

As a workaround, you can save assemblies from the Schematic viewport.
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Baking
• BUG ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the
baked displacement map to show quilting effects and other render artifacts.

• BUG ID 221481 (49437) - The Bake Channel Swizzling option can’t bake to texture alpha.

Bucket Render
• BUG ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when
the mesh has transform channels.

As a workaround, freeze the transforms in the mesh properties.

• BUG ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo
10.1 or earlier now show on the render item instead.

• BUG ID 279848 (55663) - Motion Blur applied on a curve in a mesh operation no longer works.

• BUG ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than
expected.

As a workaround, any machine that has more than 32 cores, performance will be better if you limit
rendering to half the number of cores you have.

• BUG ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies
(hot pixels) in some cases.

As a workaround, use aMaximum Radiance higher than 1 W/srm2 to reduce the bias.

Color Management
• BUG ID 221439 (49244) - (Windows only): With Perform Color Correction on, setting a default scene
to a scene with a mesh that has a position channel crashes Modo at launch.

As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default
scene.

Command Line
• BUG ID 289290 (49514) - macOS X only: Runningmodo_cl before running the UI Modo application
breaks code signing.

As a workaround, start the UI version of Modo once, before runningmodo_cl on any system where
you later intend to use the UI version.
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File and Image I/O
• BUG ID 346842 - Alembic import: Drag-and-drop doesn't import animation correctly.

As a workaround, use File > Import.

• BUG ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same
SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct
imports (File > Import).

As a workaround: Before importing a SolidWorks file for the second time, exit and restart Modo.

• BUG ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes
and procedural shatter items.

• BUG ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't
export instances, unless the original mesh is also exported.

To resolve this, set the .fbx preference to Export Selection and use Export As….

• BUG ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-
effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color
correction was enabled.

• BUG ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer
masking can be very slow.

Fur
• BUG ID 288248 (35731) - Fur length textures can’t be edited with the Stretch tool.

As a workaround, use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices
• BUG ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause
undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

To avoid this, plug in the tablet before application start-up or restart.

• BUG ID 226536 (51741) - Mac OS X only: Modo sometimes becomes unresponsive when using the
combination of a click-drag in a tree view (for example, when toggling the visibility of two successive
items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices,
including laptop trackpads and the Magic Mouse.

As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).
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MeshFusion
• BUG ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and
dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion buttons (Tool palette - Set Mesh Role & Apply section) or
Pie Menu (Apply Subtraction or Apply Intersection) when initially adding Trims to each Fusion
Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those
methods, all subsequent Drag & Drop options are supported.

Modeling
• BUG ID 408278 (60027) - Linear Falloff snaps to the object size.

As a workaround, use the right mouse button for an interactive initial linear handle.

• BUG ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

Network Rendering
• BUG ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong
image sequence number on slave machines.

As a workaround, use File > Consolidate Scene, then render the scene using a shared network
folder (Preferences option under Rendering > Network Rendering).

• BUG ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the
scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden
state, however.

As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or
open System > Preferences > Rendering and disable Use Network Render Nodes.

• BUG ID 226336 (25636) - Frame passes are not supported.

• BUG ID 220955 (30318) - Network Rendering doesn’t support Realflow particles.

• Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not
implemented to support baking. Changes to Modo in the 10-series apparently broke what was
working for some artists, so the functionality has been disabled.

As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an
external render controller. For more information, please see the SDK Wiki.
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Nodal Shading
• BUG ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.

• BUG ID 221393 (50642) - Nodal shading does not support UDIMs.

Painting/Sculpting
• BUG ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an
image map.

You can save and reload the image to force the update.

Particles
• BUG ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache
files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation
item in the Schematic viewport, and clicking Cache Simulation.

Preview
• If a high poly mesh is not visible, the Preview baking output will be incorrect.

As a workaround, reset Preview to fix the baking.

Procedurals
• BUG ID 388978 - Paving doesn't work when a Guide curve runs through a paving hole.

• BUG ID 305303 (56318) - Procedural duplication of mesh operations in a Deform folder creates
errantMesh Ops list.

• BUG ID 305302 (56317) - Duplicating procedurals does not work with the Select By Previous
Operation tool.

As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

• BUG ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in
GL. This is a limitation of the feature and will not be fixed.

You can use Preview or RayGL to visualize the variations from rigging.
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• BUG ID 266469 (54738) - A duplication of any item that is a Merge Meshes source (for example, a
mesh item, procedural item, or Fusion Item), any duplicates (duplicate or instance) are added to the
Merge Meshes Ops List as a source.

As a workaround, remove the unwanted additional Merge Mesh sources (regardless of the type of
source) in theMesh Ops List using the X button next to each Merge Meshes source.

• BUG ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to
Normal option doesn't work when using a Bezier with zero-length tangents.

As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there
are no zero-length tangents.

References
• BUG ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after
attempting to revert a reference override.

As a workaround, first close and reopen the scene before attempting to revert the reference.

• BUG ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the
original references may not persist.

As a workaround, limit scenes with shading to one level of reference.

• BUG ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo
to crash.

Rigging
• BUG ID 404238 - Bezier Curves don't work correctly with the Curve Falloff.

• BUG ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original
joint chain.

Scripting
• BUG ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to
Modo.

As a workaround, click in the top window of the Script Editor, use the main menus, or change to
another application, then switch back to Modo.
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Shader Tree
• BUG ID 372282 (57874) - Custom Materials that define their own smoothing properties (such as the
Skin material), no longer smooth the mesh correctly.

• BUG ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use
clip browser) fails.

To work around this issue, in the Clip Browser, choose a single image instead of the group, and
then change to the image group using the Texture Layer's Properties tab.

• BUG ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the
masking layer onto the displacement layer.

Unreal and Unity Materials
• BUG ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• BUG ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• BUG ID 221477 (50451) - On some graphics cards, Unity material may cause flickering in the
Advanced viewport when used with bump maps and shadows.

UI
• BUG ID 395884 - macOS only: Double-clicking the bottom right corner or edge of a popover doesn't
resize the popover correctly.

• BUG ID 388937 - macOS only: UI form field highlights occasionally appear solid gray.

• BUG ID 333249 (57715) - Selecting items in the viewport does not always update the Properties
form.

As a workaround, press the Alt key.

• BUG ID 288714 (43162) - Windows only: Setting a custom text size affects Modo's text drawing.

As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable,
and turn off font-scaling for the application.

• BUG ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• BUG ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

• BUG ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on
some macOS/AMD configurations.

As a workaround: Upgrade macOS to 10.12 or 10.13.
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• BUG ID 226492 (44496) - macOS X only: Disabling Affect System Color Dialog in Preferences >
Rendering > Color Management, and using the system color picker caused colors to darken with
each use of the color picker.

This is due to an OS X issue, which requires the color profile in both the monitor settings and color
picker to be set to sRGB IEC61966-2.1.

• BUG ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn’t work.

If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below
other images in the list.

Viewports
• Windows only: Using Raptr can cause GL driver crashes in Modo.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any
unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in
the Shader Tree.

• BUG ID 497416 - The Gradient texture layer renders incorrectly in the Advanced viewport.

As a workaround, use Preview.

• BUG ID 420733 - Ghost Mode Transparency set to 0% isn't fully transparent.

• BUG ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon
WX-series graphics card. This is due to a driver bug and should be fixed by a AMD in a future driver
release.

• BUG ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D
view (palette or separate window).

As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a
Layout).

• BUG ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded
into the Advanced viewport.

As a workaround, enable and then disable the visibility of the Shader Tree textures.

• BUG ID 296123 (46995) - Ambient Occlusion display in the Advanced viewport is affected by selected
item wireframes.

You can disable Show Selection in the Visibility options or disable wireframe drawing on the active
mesh layers.

• BUG ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit
mode and the width is less than the height.
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• BUG ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and
baking.

To avoid this, make sure that the projection camera has a film width-to-height ratio that matches
the main render camera.

• BUG ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced
viewport.

As a workaround, avoid transparency when modeling or doing work where wireframes are needed.
Alternatively, use the Default viewport.

VR
• BUG ID 218386 - VR is now supported on Linux, but has only been tested and verified working using
SteamVR on Ubuntu 18.04.

Developer Notes
Here are the changes relevant to developers.

Bug Fixes
• BUG ID 366901 - SDK: The envelope.keyframes.setSlopeType() function failed with TypeError.

• BUG ID 407913 - SDK: Multiple selection types in lx.symbol.sPMODEL_SELECTIONTYPES only
returned one.

• BUG ID 412257 - SDK: The Samples solution didn't match shipped samples. Math multi has been
replaced with sum, but the sln was not updated.

• BUG ID 412258 - SDK: sample item_type_influence_morph couldn't be built.

• BUG ID 427218 - SDK: The IsClosed() method on ILxCurve returned None instead of True or False.
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