Release Notes for Modo 13.1v1

Release Date
13 August 2019

System Requirements

Officially Supported Operating Systems

• Mac OS 10.12.x, 10.13.x, and 10.14.x (64-bit only)
• Windows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7+)

Minimum Hardware Requirements

• Intel processor(s), Core i3 or higher
• 1 GB available hard disk space (for Modo installation).
• 6 GB available hard disk space (for full content).
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of graphics memory and drivers that support OpenGL 3.2 or higher.
Recommended System Requirements

**Note:** This information is our best recommendation for the average user. Requirements vary by usage, and individual users may have different requirements from those listed here.

- 2.5+ GHz quad-core processor
- 250+ GB disk space available for caching and temporary files, SSD is preferable
- 16 GB RAM with additional virtual memory*
- Display with 1920 x 1080 pixel resolution
- An NVIDIA or AMD graphics card with the latest drivers
- 2+ GB of graphics memory
- OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

Recommended Graphics Driver Versions

- NVIDIA: 419 or later*
- AMD: 8.982.8.1 or later*

*We recommend downloading the latest driver version from the NVIDIA or AMD websites

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Modo 12.2v1. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

If you encounter any issues, please visit the Support Portal at [https://support.foundry.com](https://support.foundry.com).

<table>
<thead>
<tr>
<th>Tested Workstation Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple</td>
</tr>
<tr>
<td>MacBook Pro (Retina, 15-inch, Mid-2015)</td>
</tr>
<tr>
<td>MacBook Pro (Late 2013)</td>
</tr>
<tr>
<td>iMac (Late 2012)</td>
</tr>
<tr>
<td>Mac Pro (Late 2013)</td>
</tr>
</tbody>
</table>
## Tested Workstation Hardware

<table>
<thead>
<tr>
<th>Tested Workstation Hardware</th>
<th>MacBook Pro (Mid-2015)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dell</strong></td>
<td></td>
</tr>
<tr>
<td>XPS 15 9560</td>
<td></td>
</tr>
<tr>
<td>Precision 3520</td>
<td></td>
</tr>
<tr>
<td><strong>HP</strong></td>
<td></td>
</tr>
<tr>
<td>HP Z800</td>
<td></td>
</tr>
<tr>
<td>HP Z640</td>
<td></td>
</tr>
<tr>
<td>HP Z600</td>
<td></td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td>AMD Ryzen Threadripper</td>
</tr>
<tr>
<td></td>
<td>Intel i7-4770k</td>
</tr>
<tr>
<td></td>
<td>Intel i7-7700k</td>
</tr>
<tr>
<td></td>
<td>Intel i7-8700</td>
</tr>
<tr>
<td></td>
<td>Xeon E3-1505M v6</td>
</tr>
<tr>
<td></td>
<td>Xeon E5504</td>
</tr>
<tr>
<td></td>
<td>Xeon 5620</td>
</tr>
</tbody>
</table>

## Tested GPU Hardware

<table>
<thead>
<tr>
<th>Tested GPU Hardware</th>
<th>Radeon™ Vega RX</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AMD Prosumer Graphics Cards</strong></td>
<td></td>
</tr>
<tr>
<td>Radeon™ R9 M370X</td>
<td></td>
</tr>
<tr>
<td>Radeon™ Pro WX8200</td>
<td></td>
</tr>
<tr>
<td>Radeon™ Pro WX7100</td>
<td></td>
</tr>
<tr>
<td><strong>AMD Enterprise Graphics Cards</strong></td>
<td></td>
</tr>
<tr>
<td>FirePro™ D700</td>
<td></td>
</tr>
<tr>
<td><strong>NVIDIA Prosumer Graphics Cards</strong></td>
<td></td>
</tr>
<tr>
<td>GeForce 675MX</td>
<td></td>
</tr>
<tr>
<td>GeForce 970</td>
<td></td>
</tr>
<tr>
<td>GeForce 1050 (laptop)</td>
<td></td>
</tr>
<tr>
<td>GeForce GTX 1070 Ti (Linux)</td>
<td></td>
</tr>
<tr>
<td>GeForce 1080</td>
<td></td>
</tr>
<tr>
<td><strong>NVIDIA Enterprise Graphics Cards</strong></td>
<td></td>
</tr>
<tr>
<td>Quadro® K620</td>
<td></td>
</tr>
<tr>
<td>Quadro® M620</td>
<td></td>
</tr>
<tr>
<td>Quadro® M4000</td>
<td></td>
</tr>
</tbody>
</table>
New Features

Advanced Viewport

Improved Ambient Occlusion

Hybrid Ambient Occlusion mode has been introduced, providing a robust solution that works well for large scenes.

Improved Area Light Roughness

Area lights now respect the Material’s **Specular Roughness** parameter, and the rendered effect approximates offline renders.

Improved Point and Spot Light Shadows

Previously, the shadows produced for point and spot lights where hard-wired depth projections. These have been updated to use camera vs scene vs light source frustum and bounds culling. This produces better quality shadows on all scenes and camera positions.

Progressive Anti-aliasing

Another way of producing anti-aliased images. It specifies the maximum number of frames used to produce the final image in the **Advanced** viewport.

Animation and Rigging

Backdrop Improvements

• **Header-only Moving Backdrop** - Backdrops can now be moved by clicking and dragging on the node header instead of anywhere on the Backdrop node.

• **Autosize on Collapse** - When a Backdrop node is collapsed, it now shrinks to fit the width of the node title, rather than retaining the width of the expanded node.
Bounding Box Drawing in Animation Playback

A new option has been added to the Display Preferences, allowing you to display meshes as bounding boxes during animation playback, to eliminate lag.

Morph Containers

A Morph Container is an item that allows you to store morph information separate from a mesh. It works the same way as a Weight Container, but instead of storing Weight Map information, it stores Morph Map information. Morph containers can also handle more than one morph map a time.

Shortcut for Removing Links

Links in the Schematic can be removed by Shift+clicking on the link. All links at a connection can be removed by Shift+clicking the connection.

Direct Modeling

Bevel Boundary Toggle

The Open Boundary option has been added to the Polygon Bevel tool, allowing you to specify whether boundary edges are inset.

Select Symmetrical Command

The Select Symmetrical command allows you to select any geometry that is symmetric to the current selection.

Tool State Presets

You can now save the state of a tool as a Tool State Preset. This can be handy if you frequently use a tool for the same task, with the same settings.
General Workflow and UI

Renaming Workflow

You can now rename multiple items at once, based on defined rules, either in the Item List, or in the Rename Palette in the Setup Toolbar.

Revert Image Update Alerts to Dialog

When you edit and save images outside of Modo, the update notifications are now displayed in a dialog, rather than as repeated alerts. You can set the dialog to not be shown again, if preferred.

Script Editor Saves Scripts between Sessions

Code entered into the Script Editor is now saved between sessions.

Scrolling Forms

Vertical Properties and Toolbars now have a scrollbar on the right and you can scroll the panel by:
• Clicking and dragging on the bar
• Using the mouse wheel
• Shift+Alt+left-mouse dragging (Pan navigation)

You can also adjust how vertical tabs are displayed in the Form View Options.

Tool Properties Workflow

A third Split option has been added to the Modo Layout preference found under Preferences > Defaults > UI > Tool Properties. It adds an embedded Properties form into the left-hand toolbars when a tool is active. It is hidden when a tool is dropped or the tool's properties are opened in a popover.
MeshFusion

Curves as Input Meshes

Curves, Beziers, and B-Splines can serve as input meshes in MeshFusion modeling. They can be used the same way as regular polygonal meshes and produce primaries, trims, and surface strips.

Modeling Enhancements

Co-planar Polygon Selection

You can now select neighboring polygons located on the same plane as the original selection, using the Coplanar Polygons tool, or its procedural equivalent, the Select Coplanar Polygons operation.

Find Shortest Path Enhancement: Start New Path

When using Shortest Path selection, Ctrl+Shift+clicking allows you to start a new path without connecting to the previous path.

Primitives Default to Face Polygons

For consistency, all primitives use Face polygons by default.

Thicken from Both Sides of Source Position

The Thicken tool has a new Both Sides option. When this is enabled, the geometry is thickened in both directions instead of one.

Topological Morph Creation

The Topological Morph Creation tool allows you to create morph maps on multiple selected meshes or parts, based on the geometry of a source mesh or part. For example, if you generate your morph shapes as separate meshes instead of morph maps, you can merge them all into morph maps using this tool.
Topological Vertex Map Transfer

The Topological Transfer command can transfer UV, morph, color, vertex normal, and weight in selected vertex maps, and can be applied to multiple surfaces at the same time.

Vertex Bevel for Curves

All curve types except Bezier can now be used with Vertex Bevel.

Modo VR

Mac and Linux Support

In addition to Windows, Modo VR is now supported on Mac and Linux.

Performance Improvements

Improved Animation Playback

The surface calculation code has been rewritten for Modo 13.1, and face polygons have been migrated to use a new API that processes polygons in batches, improving performance significantly in some cases.

Reduced Event Storms

The way events are handled throughout the application has been significantly improved. This has major benefits for many aspects across Modo, but especially animation.

Threading Improvements

Low-level threading optimizations have been added, which improve all threaded workloads. The speed of mesh evaluation for interactive work has improved, for example during animation playback, and modeling.
Procedural Modeling

Array Value Saving

The values of array channels are now saved into the scene file (.lxo).

Curve Fill Update

The Curve Fill mesh operation can use open curves as guide curves for the topology. For example, if you need an edge in a certain place on your filled curve, you can specify a guide curve, and Modo will place an edge along the length of the guide curve.

Curve Rebuild Spans Mesh Operation

The Curve Rebuild Spans mesh operation allows you to procedurally rebuild sections of a curve without altering the existing points.

Curve Sweep Mesh Operation

The Curve Sweep mesh operation provides a streamlined workflow for procedurally extruding geometry along a curve.

Lace Item

The Lace Item is a collection of commands designed to streamline the process of building laces in Modo.

UV Flip Mesh Operation

The procedural UV Flip mesh operation allows you to horizontally or vertically flip UV orientations for an entire map or a selected area.
Rendering and Shading

AxF Import and Shader Support

Modo now supports the import and shading of a subset of AxF shaders, allowing you to get full quality materials on your surfaces when using the AxF material.

The importer supports the following:
• SVBRDF material type, including Base Color, Normal, Specular Color and Lobe, and Anisotropy rotation texture effects (AxF 1.0)
• Improved SVBRDF material specular calculations to use GGX normal distribution function (AxF 1.5)

ProRender Alpha Render Output Support

A dropdown has been added to the PView viewport that allows you to select between Final Color Output and Alpha Output.

In Options, you can now save a layered image of all render outputs by clicking Save Layered Image.

Feature Enhancements

• ID 335207 - Viewports: Immediate GL camera updates have been introduced for 3rd party render engines.
• ID 398806 - Preset Browser: You can now disable auto-rescan of directories on browser selection changes to improve performance.

Bug Fixes

• ID 221437 - Viewports: Ambient Occlusion didn't work.
• ID 221449 - Viewports: Screen Space Ambient Occlusion doesn't update in Advanced viewport correctly.
• ID 242593 - Performance: Using the UV relax tool in Adaptive mode caused performance issues.
• ID 243293 - Schematic: Adding nodes to the Schematic when the viewport was showing an HDR environment was slow.
• ID 273581 - Modeling: Snapping a mesh to a component of an instanced mesh did not work when the parent of the instance was hidden.
• ID 273748 - Performance: Marquee selecting items in larger scenes caused Modo to become unresponsive.
• ID 292146 - UI: When right-clicking on a node placed low in the Schematic viewport, the right click menu opened with empty space on top.

• ID 293369 - Performance: Timeline scrubbing was slow with a Backdrop item in the scene.

• ID 293902 - Performance: Moving, scaling, and rotating UVs with Distortion on caused Modo to become slow.

• ID 294010 - Performance: Selecting edge loops in UVs on heavy meshes was very slow.

• ID 295781 - Viewports: Ambient Occlusion did not work if the Advanced viewport was enabled in two tabs.

• ID 295796 - Viewports: Ambient Occlusion in the Advanced viewport did not work as expected.

• ID 296123 - Viewports: When selecting an item in the Advanced viewport with Ambient Occlusion enabled, the wireframes of the mesh caused occlusion on the mesh surface.

• ID 310920 - Viewports: Using deformed Instances produced visual 3D viewport glitches in certain camera perspectives, when the original Instance source was outside of the viewport frustrum.

• ID 318061 - Viewports: Using a Matcap shader in the Advanced viewport displayed the mesh as black.

• ID 333250 - Performance: Selecting a large amount of polygons using Lasso selection caused performance issues.

• ID 340220 - Performance: Rotating a UV Island that is part of a relatively dense mesh by Selected Edge to Horizontal / Vertical (in Align Tab) was very slow.

• ID 341174 - ProRender: The terminator for the self-shadow on objects didn't use smoothed normals.

• ID 351049 - Viewports: Advanced viewport Area light specular had no roughness.

• ID 352328 - UI: When hovering over a single line Gradient channel in a property form while dragging a Gradient preset, the channel's label text could get scrambled.

• ID 353054 - Viewports: Advanced viewport screen space reflections were overly reflective.

• ID 358312 - Performance: The Join vertices command was slow to process in mesh items containing large quantities of vertices.

• ID 359129 - Modeling: Beveling (shift) a single polygon didn't adhere to the Vertex Normal map.

• ID 359154 - Modeling: Beveling (shift) a group of polygons with non-uniform vertex normals produced non-planar results.

• ID 360028 - File I/O: A specific scene did not open in 12.1 and later versions of Modo.

• ID 361780 - ProRender: Prorender's camera did not match Modo's.

• ID 362710 - Procedurals: Merging a mesh with a Bevel mesh operation corrupted UVs.

• ID 362719 - Modeling: Snapping considered mesh instances to be active mesh layers.

• ID 363486 - Particles: The Particle Look At Modifier pointed particles in the -Y axis.

• ID 365352 - Preset Browser: Adding paths to the Color Picker preset browser didn't work correctly.

• ID 370757 - File I/O: Animations exported as glTF were not correct when viewed in glTF viewers.
• ID 371436 - Procedurals: Using the Freeze mesh operation on Curve and Curve Patch items caused Modo to crash.

• ID 372461 - File I/O: Exported glTF meshes that are rigged with modified translation values resulted in an incorrect position when loaded into glTF viewers.

• ID 375017 - Procedurals: Using the Merge mesh operation when a Material tag is applied on the Source produced incorrect UVs.

• ID 375575 - UI: The Modo UI was covered in gray when using the shortcut Ctrl + any key to open the Pie Menus while the Open Pies Immediately option was disabled.

• ID 375653 - Modeling: Rotation along the X axis was not working for the Jitter tool.

• ID 376774 - Procedurals: Using the Polygon Bevel mesh operation with the Thicken Polygons option enabled resulted in corrupted UVs.

• ID 376871 - Scripting: Setting a string value via the command system failed if the string contained more than one question mark.

• ID 378838 - Baking: In certain scenes, artifacts appeared in Displacement bake.

• ID 378854 - UI: When the Vertical Tabs option was set to Multiselect Tabbed, tool properties appeared in the middle of a panel.

• ID 380435 - Procedurals: Replicators didn't work as expected when changing the Prototype polygons during Array to Curve/Create Polygons workflow.

• ID 381474 - File I/O: Importing a specific V-Ray scene (.vrscene) caused Modo to crash.

• ID 381520 - Modeling: Symmetric Linear Falloffs didn't always auto-align correctly.

• ID 382633 - ProRender: Film Back Offset was not working as expected.

• ID 383054 - Simulation: Opening a specific simulation scene sometimes caused Modo to crash.

• ID 383068 - Rigging: Weight Flow did not update correctly.

• ID 383264 - Rigging: A specific rig caused the deformation system to stop evaluating.

• ID 383297 - UVing: UV Seam maps could not be copied and pasted.

• ID 384524 - Rigging: Weight Containers did not update when points were added to them.

• ID 384684 - Preset Browser: Clicking the Up button after searching and attempting to re-select the folder caused Modo to crash.

• ID 385684 - Replicators: Dragging the Poisson density level below 0 caused Modo to crash.

• ID 386009 - UI: Adding the Graph Editor to the UI sometimes caused Modo to crash.

• ID 386020 - UI: There was a typo in the Select Unmapped Polygons dialog.

• ID 386286 - Modeling: Rigid Jitter was broken by inserting a falloff.

• ID 386287 - Modeling: The Spike mesh operation produced unexpected strength results.

• ID 386296 - Procedurals: Using the Merge mesh operation with Replicators produced incorrect UVs from the Sources in a specific scene.

• ID 386485 - Procedurals: The Clone mesh operation cloned polygons when set to Vertex.
• ID 386756 - Procedurals: Disabling Faces in Polygon Types for the Merge Meshes operation caused Modo to crash.
• ID 386915 - Schematic: Backdrop size was sometimes incorrect after deleting contents.
• ID 386997 - Schematic: Expanding collapsed Backdrop nodes sometimes resulted in incorrect resizing.
• ID 387163 - Schematic: Hovering the cursor over the Input Channels in an Assembly and letting it zoom in caused Modo to crash.
• ID 387275 - Modeling: Resetting the Thicken tool's attributes to the default state produced incorrect results.
• ID 387785 - Schematic: Disabling a link from a Boolean mesh operation in a specific rig caused Modo to crash.
• ID 387844 - ProRender: Windows only: The installer didn't create the ProRender directory by default if the install location was changed.
• ID 387995 - Topology: Vertex transforms were inactive when selecting and moving the central vertices of a mesh using the Topology Pen with Symmetry enabled.
• ID 388001 - Modeling: Blending Falloffs did not work in world space
• ID 388671 - UI: Opening the Graph Editor through the side bar viewport caused Modo to crash.
• ID 389048 - Preset Browser: Switching between PBviews directed to folders containing thousands of images caused Modo to crash.
• ID 389056 - UI: Reordering a Divider Channel in an Assembly caused Modo to crash.
• ID 389516 - UI: Clicking the More button in the Graph Editor opened the whole toolbar, not just the missing buttons.
• ID 389702 - UI: in the Application > Form View > Choice list, multiple entries were the same.
• ID 389853 - Referencing: When using Import Reference with certain files, the rigged geometry wasn't placed correctly.
• ID 390297 - Modeling: After translating the view, the Snapping cursor started at the previous location, seeming to disappear.
• ID 390470 - Performance: Using Select More (Up arrow) with the Tools panel on the left open, caused performance issues.
• ID 391703 - Preview: Selecting a Channel Relationship node with Preview running caused Modo to crash.
• ID 392484 - UI: A dialog for locating an image appearing on startup caused Modo to crash.
• ID 392485 - Preset browser: Populating directories containing a large number of files was slow.
• ID 394040 - UVing: Texel Density didn't work in Vertex mode with all vertices are selected.
• ID 394403 - Customization: Adding clip type values to a Form Command List caused Modo to crash.
• ID 395018 - Modeling: When using Axis Drill, moving the cutter mesh caused Modo to crash.
• ID 395240 - Procedurals: Adding the Curve Rebuild mesh operation in certain scenes caused Modo to crash.
• ID 396252 - UI: Clicking on the Mesh channel in an item’s properties caused Modo to crash.
• ID 396779 - File I/O: Saving rendered images under the macOS Catalina Beta caused Modo to crash.
• ID 399808 (59861) - Schematic: Duplicating mesh item nodes in certain scenes caused Modo to crash.
• ID 401177 - Render: Adding a new scene with the Schematic open in the Render V-Ray layout caused Modo to crash.

**Known Issues and Workarounds Specific to this Release**

This section covers known issues and gives workarounds for them, where appropriate.

**Note:** Due to internal bug-logging and tracking process improvements, new bug identification numbers are used, with the legacy IDs provided in parentheses, where appropriate.

### Animation

• ID 395357 - Deformer Caching doesn't work as expected.
• ID 240321 (53661) - Selecting actions does not always select the correct one. This is caused by copying actions.

As a workaround, manually edit the tags on the broken actions by selecting them in the **Groups** tab, then save and reload the scene.

### Assemblies

• ID 288164 (36452) - Assemblies exported from the **Item List** context menu result in poor visual layout of nodes on import.

As a workaround, you can save assemblies from the **Schematic** viewport.
Baking

• ID 293020 (50671) - Baking displacement maps can cause UV seams to be visible, and the baked displacement map to show quilting effects and other render artifacts.

• ID 221481 (49437) - The Bake Channel Swizzling option can't bake to texture alpha.

Bucket Render

• ID 297021 (52730) - The Vertex Illumination Bake command doesn't work as expected, when the mesh has transform channels.

As a workaround, freeze the transforms in the mesh properties.

• ID 292947 (53184) - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier now show on the render item instead.

• ID 279848 (55663) - Motion Blur applied on a curve in a mesh operation no longer works.

• ID 243070 (53793) - Rendering using a Dual CPU with 72 threads was significantly slower than expected.

As a workaround, any machine that has more than 32 cores, performance will be better if you limit rendering to half the number of cores you have.

• ID 235368 (53411) - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some cases.

As a workaround, use a Maximum Radiance higher than 1 W/srm² to reduce the bias.

Color Management

• ID 221439 (49244) - (Windows only): With Perform Color Correction on, setting a default scene to a scene with a mesh that has a position channel crashes Modo at launch.

As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

Command Line

• ID 289290 (49514) - macOS X only: Running modo_cl before running the UI Modo application breaks code signing.

As a workaround, start the UI version of Modo once, before running modo_cl on any system where you later intend to use the UI version.
File and Image I/O

• ID 346842 - Alembic import: Drag-and-drop doesn't import animation correctly.

  As a workaround, use File > Import.

• ID 337523 (56862) - Modo for SolidWorks Kit: Modo crashes when importing the same SolidWorks file twice in one Modo session. This bug only affects import using the kit, not direct imports (File > Import).

  As a workaround: Before importing a SolidWorks file for the second time, exit and restart Modo.

• ID 221508 (50198) - Alembic scenes don't export some surface items, including static meshes and procedural shatter items.

• ID 226589 (49728) - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances, unless the original mesh is also exported.

To resolve this, set the .fbx preference to Export Selection and use Export As....

• ID 220991 (47036) - Color management in .svg images is not currently supported. This is a side-effect of a bug fix where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

• ID 220975 (46962) - Rendering .svg images used as stencil maps for displacement or for layer masking can be very slow.

Fur

• ID 288248 (35731) - Fur length textures can't be edited with the Stretch tool.

  As a workaround, use different fur length drivers, such as hair guides or vector vertex maps.

Input Devices

• ID 303287 (35856) - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired movement. This cannot be fixed, due to a limitation of the hardware driver.

  To avoid this, plug in the tablet before application start-up or restart.

• ID 226536 (51741) - Mac OS X only: Modo sometimes becomes unresponsive when using the combination of a click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and the Magic Mouse.

  As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).
MeshFusion

- ID 316276 (56973) - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a Primary, the drop menu does not contain the Trim boolean options.

As a workaround, use either the Fusion buttons (Tool palette - Set Mesh Role & Apply section) or Pie Menu (Apply Subtraction or Apply Intersection) when initially adding Trims to each Fusion Item (Trims can contribute to multiple Fusion Items). If initially applied with either of those methods, all subsequent Drag & Drop options are supported.

Modeling

- ID 401919 - Setting Smoothing on a Smoothing Group’s Base Material to 0%, then to 100% causes Modo to crash.
- ID 226970 (32728) - Zooming out with a Space Navigator alters the Work Plane position.

Network Rendering

- ID 226363 (48325) - Scenes with image sequences rendered with Full Frames use the wrong image sequence number on slave machines.

As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder (Preferences option under Rendering > Network Rendering).
- ID 226337 (36986) - Slaves render hidden meshes. Since mesh hide state is not stored in the scene, when that scene is transferred to the slaves, the state is lost. The master respects the hidden state, however.

As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System > Preferences > Rendering and disable Use Network Render Nodes.
- ID 226336 (25636) - Frame passes are not supported.
- ID 220955 (30318) - Network Rendering doesn’t support Realflow particles.
- Several Bugs - While it apparently worked in Modo 902, in some cases, Network Rendering was not implemented to support baking. Changes to Modo in the 10-series apparently broke what was working for some artists, so the functionality has been disabled.

As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render controller. For more information, please see the SDK Wiki.
Nodal Shading

- ID 385250 - Nodal Shading is slower in 13.0 with some modifiers.
- ID 221393 (50642) - Nodal shading does not support UDIMs.

Painting/Sculpting

- ID 288461 (41682) - Textures are not always updating in Preview/Render when painting on an image map.

  You can save and reload the image to force the update.

Particles

- ID 303192 (34925) - Re-opening scenes saved with large particle caches can cause problems.

  To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the Schematic viewport, and clicking Cache Simulation.

Preview

- ID 401372 - When using the Sphere, Plane, or Preset Sphere geometry options under Options, Preview renders an empty background.

  - If a high poly mesh is not visible, the Preview baking output will be incorrect.

    As a workaround, reset Preview to fix the baking.

Procedurals

- ID 305303 (56318) - Procedural duplication of mesh operations in a Deform folder creates errant Mesh Ops list.
- ID 305302 (56317) - Duplicating procedurals does not work with the Select By Previous Operation tool.

  As a workaround, manually edit the duplicate's Select By Previous Operation Mesh Ops.

- BUG ID 289810 (46512) - When rigged, Rock items and other procedurals do not display correctly in GL. This is a limitation of the feature and will not be fixed.

  You can use Preview or RayGL to visualize the variations from rigging.
• ID 266469 (54738) - A duplication of any item that is a Merge Meshes source (for example, a mesh item, procedural item, or Fusion Item), any duplicates (duplicate or instance) are added to the Merge Meshes Ops List as a source.

As a workaround, remove the unwanted additional Merge Mesh sources (regardless of the type of source) in the Mesh Ops List using the X button next to each Merge Meshes source.

• ID 221355 (52149) - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal option doesn't work when using a Bezier with zero-length tangents.

As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-length tangents.

References

• ID 309252 (56620) - Modo crashes when closing a scene containing a referenced scene after attempting to revert a reference override.

As a workaround, first close and reopen the scene before attempting to revert the reference.

• ID 294394 (44492) - If a scene that already contains references is referenced, the shading of the original references may not persist.

As a workaround, limit scenes with shading to one level of reference.

• ID 220957 (41119) - Reloading a reference after replacing it with the same file can cause Modo to crash.

Rigging

• ID 287584 (27244) - Duplicating joints in a bound mesh retains influences from the original joint chain.

Scripting

• ID 242545 (53458) - Right-clicking or running a script in the Script Editor can lock up input to Modo.

As a workaround, click in the top window of the Script Editor, use the main menus, or change to another application, then switch back to Modo.

Shader Tree

• ID 399434 - The Texture Replicator Particle Source doesn't render as expected.
• Unreported: Material Preset References: Material Preset References may not always show the correct preset as selected in the item properties. You should look at the filepath channel in the Channels list to find out which preset file a material preset item is referencing.

• ID 336112 (57874) - Custom Materials that define their own smoothing properties (such as the Skin material), no longer smooth the mesh correctly.

• ID 299187 (37858) - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip browser) fails.

To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change to the image group using the Texture Layer’s Properties tab.

• ID 288141 (30947) - Layer masking displacement does not work unless you drag and drop the masking layer onto the displacement layer.

Unreal and Unity Materials

• ID 295862 (50700) - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• ID 294747 (50701) - Unreal material Ambient Occlusion does not bake correctly in Modo.

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 277244 (55571) - Resizing the dopesheet in Zen crashes Modo 11.1, but not in Modo 11.0.

UI

• ID 395884 - macOS only: Double-clicking the bottom right corner or edge of a popover doesn’t resize the popover correctly.

• ID 388937 - macOS only: UI form field highlights occasionally appear solid gray.

• ID 333249 (57715) - Selecting items in the viewport does not always update the Properties form.

As a workaround, press the Alt key.

• ID 288714 (43162) - Windows only: Setting a custom text size affects Modo’s text drawing.

As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable, and turn off font-scaling for the application.

• ID 281374 (55759) - Transforming objects can cause the Items Properties panel to flicker.

• ID 273139 (55185) - Text in the viewport icon buttons is not visible in the Advanced viewport on some macOS/AMD configurations.

As a workaround: Upgrade macOS to 10.12 or 10.13.
• ID 226492 (44496) - macOS X only: Disabling Affect System Color Dialog in Preferences > Rendering > Color Management, and using the system color picker caused colors to darken with each use of the color picker.

This is due to an OS X issue, which requires the color profile in both the monitor settings and color picker to be set to sRGB IEC61966-2.1.

• ID 224169 (44896) - Dragging and dropping an image from disk into the Clips list doesn't work.

If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images in the list.

Viewports

• ID 397191 - Meshes transferred from GoZ with texture maps generated in zBrush appear dark in Modo.

• Windows only: Using Raptr can cause GL driver crashes in Modo.

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in the Shader Tree.

• ID 338599 (57955) - Clicking on the VR layout tab may crash when using a system with a Radeon WX-series graphics card. This is due to a driver bug and should be fixed by a AMD in a future driver release.

• ID 338374 (58003) - Game Navigation mode (camera rotation) does not work in a floating 3D view (palette or separate window).

As a workaround, use Game Navigation mode only in docked 3D views (views that are part of a Layout).

• ID 310930 (56706) - Unity and Unreal materials are not displayed correctly when first loaded into the Advanced viewport.

As a workaround, enable and then disable the visibility of the Shader Tree textures.

• ID 296123 (46995) - Ambient Occlusion display in the Advanced viewport is affected by selected item wireframes.

You can disable Show Selection in the Visibility options or disable wireframe drawing on the active mesh layers.

• ID 289738 (49473) - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is less than the height.

• ID 289020 (43771) - Camera projections from non-render cameras show distortion in GL and baking.
To avoid this, make sure that the projection camera has a film width-to-height ratio that matches the main render camera.

- ID 281365 (55816) - Wireframes are washed out on transparent surfaces in the Advanced viewport.

As a workaround, avoid transparency when modeling or doing work where wireframes are needed. Alternatively, use the Default viewport.

**VR**

- ID 218317 - VR is now supported on Linux, but has only been tested and verified working using SteamVR on Ubuntu 18.04.

**Developer Notes**

- ID 383843 - TD SDK: RenderPassGroup.passes failed if the group had items in it.
- ID 380748 - Python: Using Modo with ACS python commands was gradually slowing down file saving.
- ID 381024 - Python: Using commands from the ACS2 kit to adjust poses of characters resulted in longer saving times.