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1 Preface
Mari is a creative texture-painting tool that can handle extremely complex or texture heavy projects. It was
developed at Weta Digital and has been used on films such as The Adventures of Tintin: The Secret of the Unicorn,
District 9, TheDay the Earth Stood Still, The Lovely Bones and Avatar.

The nameMari comes from the Swahili 'Maridadi', meaning 'beautiful' and carrying connotations of 'usefulness'.

About this Guide
This guide provides a complete reference for all the functions and fields within Mari. It does not give you any
instructions on usingMari. For details on installingMari, read theMari Getting Started Guide. For full instructions on
usingMari, read theMari User Guide.

The first part of this document describes all the functions within Mari, broken up by functional area.

Contact customer support
Should questions arise that thismanual fails to address, you can contact Customer Support directly via e-mail at
support@thefoundry.co.uk or via telephone to our London office on +44 (0)20 7479 4350 or to our Los Angeles
office on (310) 399-4555 during office hours.

mailto:support@thefoundry.co.uk


2 Types of Controls
The types of controls that can be found inMari are listed in the table below. Each control is accompanied by an
example image of how t appears in Mari, as well as a description of what it does and how to use it.

Controls What it looks like What it does How to use it Notes

Add attribute Lets you add an attribute
to a property.

Click the icon
and fill in the
Add User
Attribute
dialog box.

Formore information,
see the Extending Mari
chapter in theMari
USer Guide.

Buttons , Lets you select a function. Click it. May show an icon or a
word.

Checkbox unselected,

selected

Lets you select an option. Click to select. An x displays when
selected.

Control
sphere

Lets youmove a light
around the scene.

Click and drag
to pull the light
around.

Curve editor Maps between input and
output values (45° = the
same). Bar along the
bottomdisplays the
effect at each point.

Drag to move
points on the
graph. Add
points by
clicking on the
curve or bar.
Edit a point by
right-clicking it.

You can also remove a
point by clicking on it
while holding
Ctrl/Cmd.
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Controls What it looks like What it does How to use it Notes

Dropdown
list

Lets you select from a list
of valid values.

Click the down
arrow on the
right, then click
to select an
option.

Entry box Lets you type an entry. Click inside the
box and type a
valid entry.

Often combined with a
slider and reset button.

When an entry box has
been combined with a
slider to change values,
click in the entry box
and press themiddle-
mouse button+drag up
or down to increase or
decrease the value.

Horizontal
slider

Slides along a range of
valid values.

Click and drag
left (more) or
right (less).

Often combined with
an entry box (that
shows the value) and
reset button.

Incrementers Lets you increase or
decrease a value.

Click the up or
down arrows.

If you press Ctrl (on
Windows and Linux) or
fn (Mac) while pressing
the up or down arrows,
the number is
increased or decreased
by whole numbers
rather than individual
decimal points.

List Lets you select from a list
of valid values.

Click to select
an option.

On/Off
Indicator

on, off Showswhether an option
is on or off

Look at it. Often combined with a
switch.

2 TYPES OF CONTROLS |
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Controls What it looks like What it does How to use it Notes

Option
buttons

Lets you select mutually
exclusive options.

Click to select
which option
you want.

Circle is filled when
selected. Sometimes
called “radio buttons”.

Remove
attribute

Lets you remove an
attribute from a property.

Click the icon,
then click
Remove to
confirm.

Reset button Reset to the default. Click the icon. Often combined with
an entry box and slider

Swatch Displays the currently
selected color, and lets
you select a different
color.

Click to select a
color from the
Colors Palette

Switch Turns an option on or off. Click and drag
right (on) or left
(off).

Often combined with
an On/Off indicator.

Tabs Displays several groups of
the same kind of
information, such as
different categories of
brush tips in the Brush
Editor Palette.

Click:

• a tab to view it

• to view
the previous
or next tab

• to add a
tab

• to delete
a tab

• to open
the current
tab in a
separate
window

2 TYPES OF CONTROLS |
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Controls What it looks like What it does How to use it Notes

Thumbnail Displays a thumbnail
preview of a selected
feature or function.

Look at it.

2 TYPES OF CONTROLS |



3 Project Functions
A list of the functions used on the project level, for instance, shortcuts andmenu items to open or close a project can
be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Newproject •Menubar | File > New

• Keyboard | Ctrl/Cmd+N

• Projects tab |New
button

• Projects tab | Right-click >
New

• Toolbar |

Creates a new project. New Project
Dialog

Name the project,
select options, and add
geometry.

Open a
project

• Projects tab | Right-click >
Open

• Projects tab | Double-click

Opens the selected
project (the project you
right-clicked on).

Open recent
project

•Menubar | File > Open >
<project name>

Opens a project, from a
list of the last 10
projects opened.

Save project •Menubar | File > Save

• Keyboard | Ctrl/Cmd+S

• Toolbar |

Saves the current
project.

Close project •Menubar | File > Close

• Keyboard | Ctrl/Cmd+W

• Toolbar |

Closes the current
project.

Save Changes
Before
Closing?
(if unsaved
changes)
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Function How to access it What it does Opens this
dialog box

Notes

Delete project • Projects tab |Delete
button

• Projects tab | Right-click >
Delete

Deletes the selected
project fromdisk.

Open Archive • Projects tab |Open
Archive button

• Projects tab | Right-click >
Open Archive

Opens a project from an
archive file.

Import Archive

Archive
Project

• Projects tab |Archive
button

• Projects tab | Right-click >
Archive

Saves the selected
project to disk as aMari
archive (.mra) file.

The archive includes all
the supporting files
required for the
project.

Copy
(Duplicate)
Project

• Projects tab | Copy
button

• Projects tab | Right-click >
Copy

Creates a copy of the
selected project.
The new copy appears
in the Projects tab.

3 PROJECT FUNCTIONS |



4 Preference Functions
The functions for how to access and edit preferences, toolbars, and shortcuts can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Set
preferences

•Menubar | Edit >
Preferences

Lets you set general
preferences forMari -
cache size, plug-ins,
autosave frequency, and
so on.

Mari
Preferences
Dialog

Edit toolbars •Menubar | Edit >
Toolbars

Lets you create and edit
custom toolbars.

Manage
Toolbar
Dialog

Edit shortcuts •Menubar | Edit >
Shortcuts

Lets you add or edit
keyboard shortcuts.

Manage
Keyboard
Shortcuts
Dialog

Configure
Heads-Up
Display

•Menubar | Edit > HUD
Manager

Lets you set what
informationMari shows
in theHeads-Up Display
(HUD) behind themodel
on the canvas.

HUD Manager
Dialog



5 Selection Functions
A list of functions for selecting items inMari can be found in the table below, this includes the selection of objects,
patches, and faces, as well as how to access selectionmodes.

Function How to access it What it does Opens this
dialog box

Notes

Object
selection
mode

• Selection toolbar |

•Menubar | Selection >
Object Mode

• Right-click | canvas >
Object Mode

SetsMari to select
whole objects.

Patch
selection
mode

• Selection toolbar |

•Menubar | Selection >
Patch Mode

• Right-click | canvas >
Patch Mode

SetsMari to select
patches on objects.

Faces
selection
mode

• Selection toolbar |

•Menubar | Selection >
Face Mode

• Right-click | canvas > Face
Mode

SetsMari to select
areas on the objects.

Create a smart selection
in Facemode by
double-clicking on the
face of themodel. This
creates a smart selection
(to select faces
connected in UV) based
on the settings in the
Smart Type dropdown
menu.
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Function How to access it What it does Opens this
dialog box

Notes

Hide
unselected
areas

•Menubar | Selection >
Hide Unselected

• Right-click | canvas >
Visibility > Hide
Unselected

• Right-click | Patches
Palette > Hide
Unselected

• Keyboard | Shift+H

•Mouse |

Hides the unselected
areas on the canvas.

For themouse gesture:
press and hold \, click
and drag in the direction
indicated. (A thin red line
traces gesture
onscreen.)

Hide selected
areas

•Menubar | Selection >
Hide Selected

• Right-click | canvas >
Visibility > Hide
Selected

• Right-click | Patches
Palette > Hide Selected
Patches

• Keyboard |H

•Mouse |

Hides the selected
areas on the canvas.

For themouse gesture:
press and hold \, click
and drag in the direction
indicated. (A thin red line
traces gestures
onscreen.)

Show selected
areas

•Menubar | Selection >
Show Selected

• Right-click | canvas >
Visibility > Show
Selected

• Right-click | Patches
Palette > Show Selected
Patches

Shows the selected
areas on the canvas.

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Show all areas •Menubar | Selection >
ShowAll

• Right-click | canvas >
Visibility > Show All

• Right-click | Patches
Palette > ShowAll
Patches

• Keyboard | Ctrl/Cmd+
Shift+H

•Mouse |

Displays all areas,
selected or not, on the
canvas.

For themouse gesture:
press and hold \, click
and drag in the direction
indicated. (A thin red line
traces gestures
onscreen.)

Showwhole
object

•Menubar | Selection >
Show Entire Object

• Right-click | canvas >
Visibility > Show Entire
Object

Shows all area, selected
or not, on only the
selected object.

Select all areas •Menubar | Selection >
Select All

• Right-click | canvas >
Selection > Select All

• Right-click | Patches
Palette > Select All
Patches

• Button | Patches Palette >

• Keyboard | Ctrl/Cmd+A

Selects all areas in the
model, depending on
your current selection
mode (objects, patches,
or faces).

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

De-select all
areas

•Menubar | Selection >
Select None

• Right-click | canvas >
Selection > Select None

• Right-click | Patches
Palette > Select None

• Keyboard | Ctrl/Cmd+E

De-selects all areas on
themodel.

Invert
selection of
areas

•Menubar | Selection >
Select Invert

• Right-click | canvas >
Selection > Select
Invert

• Right-click | Patches
Palette > Select Invert
Patches

• Keyboard | Ctrl/Cmd+I

De-selects the current
selection and selects
everything currently
unselected.

Depends on your
current selectionmode
(either objects, patches,
or faces) for the scope
of inversion. For
example, in facemode,
the unselected faces
become selected and
vice versa.

Select visible
areas

•Menubar | Selection >
Select Visible

• Right-click | canvas >
Selection > Select
Visible

• Right-click | Patches
Palette > Select Visible
Patches

Selects only areas that
aren't hidden.

Lock
unselected
areas

• Menubar | Selection >
Lock Unselected

• Right-click | canvas >
Locking > Lock
Unselected

• Right-click | Patches
Palette > Lock
Unselected Patches

Locks unselected
patches so they
cannot be edited.

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Lock selected
areas

•Menubar | Selection >
Lock Selected

• Right-click | canvas >
Locking > Lock
Selected

• Right-click | Patches
Palette > Lock Selected
Patches

• Button | Patches Palette >

Locks selected areas, so
they cannot be
painted.

Unlock
selected areas

•Menubar | Selection >
Unlock Selected

• Right-click | canvas >
Locking > Unlock
Selected

• Right-click | Patches
Palette > Unlock
Selected Patches

• Button | Patches Palette >

Unlocks selected
locked areas, so they
are again paintable.

Lock all areas •Menubar | Selection >
Lock All

• Right-click | canvas >
Locking > Lock All

• Right-click | Patches
Palette > Lock All
Patches

Locks all areas, so they
cannot be painted.

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Unlock all
areas

•Menubar | Selection >
Unlock All

• Right-click | canvas >
Locking > Unlock All

• Right-click | Patches
Palette > Unlock All
Patches

Unlocks all locked
areas, so they are again
paintable.

Unlock
everything

•Menubar | Selection >
Unlock Entire Object

• Right-click | canvas >
Locking > Unlock Entire
Object

Unlocks everything on
the current object,
regardless of whether
it’s a face, patch, or
channel.

Create
selection
group for
patches

• Right-click | canvas >
Create Patch Selection
Set

Creates a new selection
set consisting of
whichever patches you
currently have
selected.

Creates a new selection
set in the Patches
Palette

Create
selection
group

• Right-click | canvas >
Create Selection Group

• Button | Selection Groups

Palette >

Creates a new selection
group to save your
selectionmodes.

You can create selection
groups in any selection
mode (objects, patches,
or faces).

Reselect
selection
group

• Right-click | selection
group in Selection Groups
Palette > Select
Selection Group

• Button | Selection Groups

Palette >

Reselects the current
selection group.

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Lock the
selection
group

• Right-click | selection
group in Selection Groups
Palette > Lock Selection
Group

• Button | Selection Groups

Palette >

Locks the selection
group.

Unlock the
selection
group

• Right-click | selection
group in Selection Groups
Palette > Unlock
Selection Group

• Button | Selection Groups

Palette >

Unlocks the selection
group.

Hide the
selection
group

• Right-click | selection
group in Selection Groups
Palette > Hide Selection
Group

• Button | Selection Groups

Palette >

Hides the contents of
the selection group.

Assign a
shortcut

Right-click | selection group
in Selection Groups Palette
> Assign Shortcut

Opens theAssign
Keyboard Shotcut
dialog and allows you
to set a shortcut for
the selected object.

Show the
selection
group

• Right-click | selection
group in Selection Groups
Palette > Show Selection
Group

• Button | Selection Groups

Palette >

Shows the contents of
the selection group.

5 SELECTION FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Remove the
selection
group

• Right-click | selection
group in Selection Groups
Palette > Remove
Selection Group

• Button | Selection Groups

Palette >

Removes the contents
of the selection group.

Add selection
groups
together

• Shift+click a selection
group in Selection Groups
Palette when another
selection group is already
selected.

Adds the two selection
groups together on the
canvas to show the
visibility of both
selections at once.

This does not create a
new selection group
automatically; it only
adjusts the visible
selections on the
canvas.

Subtract
selection
groups from
one another

• Ctrl+click a selection
group in Selection Groups
Palette when another
selection group is already
selected.

Subtracts one selection
group from another on
the canvas to show the
visibility of a selection
without the faces or
patches of the other.

This does not create a
new selection group
automatically; it only
adjusts the visible
selections on the
canvas.

5 SELECTION FUNCTIONS |



6 Object Functions
A list of functions for adding, editing, moving, or removing objects can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Add object •Menubar |Objects > Add
Object

• Right-click | Objects
Palette > AddObject

• Button | Objects Palette >

Adds a new object to
the project.

Add Objects

Remove
object

•Menubar |Objects >
Remove Object

• Right-click | an object in
theObjects Palette >
Remove Object

• Button | Objects Palette >

Removes the selected
object from the
project.

Projectsmust always
have at least one
object.

Add object
version

• Right-click | an object in
theObjects Palette > Add
Object Version

Lets you select a file
containing the new
object version data.

Add Version

Rename
object version

• Right-click | an object in
theObjects Palette >
Rename Object Version

Renames the current
object version.

Remove
object version

• Right-click | an object in
theObjects Palette >
Remove Object Version

Deletes the current
object version.

Objectsmust always
have at least one
version.
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Function How to access it What it does Opens this
dialog box

Notes

Calculate
ambient
occlusion

•Menubar |Objects >
Ambient Occlusion

• Right-click | an object in
theObjects Palette >
Ambient Occlusion

Calculates the ambient
occlusion for the object.
This is required for any
operations that use the
ambient occlusion data
(such as using ambient
occlusionmasking).

This can take a long
time, depending on the
complexity of the
model.

Reset Move
Object - single
object

•Mouse | Shift-click on
the object

Shift-click on the object
resets that object to its
original position.

Reset Move
Object - all
objects

• Keyboard | ’ Pressing the '
(apostrophe) key resets
all objects back to their
original positions.

Assign a
shortcut

Right-click | an object in the
Objects Palette > Assign
Shortcut

Opens theAssign
Keyboard Shotcut
dialog and allows you to
set a shortcut for the
selected object.

6 OBJECT FUNCTIONS |



7 Channel Functions
A list of functions for adding, editing, and removing channels and channels presets can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Add channel •Menubar | Channels >
Add Channel

• Right-click | in Channels
Palette > Add Channel

• Button | Channels Palette

>

Adds a new channel to
the current project.

Add Channel
Dialog

Create
channel
presets

•Menubar | Channels >
Channel Presets

• Right-click | in Channels
Palette > Channel
Presets

Allows you to create a
new channel preset to use
as a template for new
channels.

Channel
Presets Dialog

Click the checkbox for
channels you want to
add, and click OK.
You can customize
available categories of
channel presets using
an XML file in a folder
specified in your
preferences.

Remove
channel

•Menubar | Channels >
Remove Channel

• Right-click | in Channels
Palette > Remove
Channel

• Button | Channels Palette

>

Removes the selected
channel, and any layers
associated with it, from
the channels list.
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Function How to access it What it does Opens this
dialog box

Notes

Convert
channel

•Menubar | Channels >
Convert Channel

• Right-click | in Channels
Palette > Convert
Channel

• Button | Channels Palette

>

Changes the color depth
of the channel to either
8bit (Byte), 16bit (Half),
or 32bit (Float).

Convert Type
Dialog

Determines number
of pixels per RGB
channel.

Duplicate
channel

• Keyboard |Alt+drag and
drop channel

Duplicates the channel
and all the layers
belonging to that
channel.

Flatten
channel

• Menubar | Channels >
Flatten

• Right-click | in Channels
Palette > Flatten

Flattens the channel data
and bakes down the
texture.

Channel
transfer

• Menubar | Channels >
Transfer

• Right-click | in Channels
Palette > Transfer

Transfers channels from
one object or version to
another.

Channel
Transfer
Dialog

Cut channel • Menubar | Channels >
Cut

• Right-click | in Channels
Palette > Cut

• Keyboard | Ctrl/Cmd+X

Cuts the channel and all
associated layers from
the channels list and
places it in the clipboard.

Copy channel • Menubar | Channels >
Copy

• Right-click | in Channels
Palette > Copy

• Keyboard | Ctrl/Cmd+C

Copies the channel, and
all associated layers from
the channels list and
places it in the clipboard.

7 CHANNEL FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Paste channel • Menubar | Channels >
Paste

• Right-click | in Channels
Palette > Paste

• Keyboard | Ctrl/Cmd+V

Pastes any cut or copied
channel and associated
layers from the clipboard
to the channels list.

Export
current
channel

•Menubar | Channels >
Export Current
Channel

• Right-click | canvas >
Export > Export Current
Channel

• Right-click | in Channels
Palette > Export Current
Channel

Exports the current
channel to a series of
files.

Export Dialog

Export all
channels

•Menubar | Channels >
Export > Export All
Channels

• Right-click | canvas >
Export > Export All
Channels

• Right-click | in Channels
Palette > Export >
Export All Channels

Exports all the channels in
the channels palette to a
series of files.

Export Dialog

Export
everything

•Menubar | Channels >
Export > Export
Everything

• Right-click | canvas >
Export > Export
Everything

• Right-click | in Channels
Palette > Export > Export
Everything

Exports the channels for
all the objects in your
project to a series of files.

Export Dialog

7 CHANNEL FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Flatten and
export the
current
channel

•Menubar | Channels >
Export Flattened >
Export Current
Channel Flattened

• Right-click | canvas >
Export Flattened >
Export Current
Channel Flattened

• Right-click | in Channels
Palette > Export
Flattened > Export
Current Channel
Flattened

Flattens the current
channel and exports it to
a series of files.

Export Dialog

Flatten and
export all
channels

•Menubar | Channels >
Export Flattened >
Export All Channels
Flattened

• Right-click | canvas >
Export Flattened >
Export All Channels
Flattened

• Right-click | Channels
Palette > Export
Flattened > Export All
Channels Flattened

Flattens all the channels
in the channels palette
and exports it to a series
of files.

Export Dialog

7 CHANNEL FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Flatten and
export
everything

•Menubar | Channels >
Export Flattened >
Export Everything
Flattened

• Right-click | canvas >
Export Flattened >
Export Everything
Flattened

• Right-click | Channels
Palette > Export
Flattened > Export
Everything Flattened

Flattens the channels for
all objects in your project
and exports them to a
series of files.

Export Dialog

Import into a
layer stack

•Menubar | Channels >
Import > Import into
Layer Stack

• Right-click | canvas >
Import > Import into
Layer Stack

• Right-click | in Channels
Palette > Import >
Import into Layer
Stack

Imports the file as layers
into the layer stack of
your current, selected
channel.

Import Dialog

Import into a
new channel

•Menubar | Channels >
Import > Import into
New Channel

• Right-click | canvas >
Import > Import into
New Channel

• Right-click | in Channels
Palette > Import >
Import into New
Channel

Import the file as a new
channel in the Channels
Palette.

Import Dialog
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Function How to access it What it does Opens this
dialog box

Notes

Resize
channel

• Menubar | Channels >
Resize

• Right-click | in Channels
Palette > Resize

Resize options are:

• 256x256

• 512x512

• 1024x1024

• 2048x2048

• 4096x4096

• 8192x8192

• 16384x16384

• 32768x32768

• Half Size

• Double Size

Lock channel • Menubar | Channels >
Lock Channel

• Right-click | channel in
Channels Palette > Lock
Channel

• Button | Channels Palette

>

Lock the selected channel
so that the channel nor
any of the layers in the
associated layer stack can
be edited or deleted.

Lock icons in the
Channels Palette
show the current
state of the
channel.

Unlock
channel

• Menubar | Channels >
Unlock Channel

• Right-click | channel in
Channels Palette >
Unlock Channel

• Button | Channels Palette

>

Unlocks the selected
channel so that the
channel or the layers
within the layer stack can
be edited.

Lock icons in the
Channels Palette
show the current
state of the
channel.

Lock all
channels

• Menubar | Channels >
Lock All Channels

• Right-click | Channels
Palette > Lock All
Channels

Locks all the channels in
the Channels Palette,
regardless of what is
selected.

7 CHANNEL FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Unlock all
channels

Menubar | Channels >
Unlock All Channels

Right-click | Channels
Palette > Unlock All
Channels

Unlock all the channels in
the Channels Palette,
regardless of what is
selected.

In addition to the
unlock options listed
here, you can also
unlock channels by
selectingUnlock
Entire Object.

View theNext
Channel

•Menubar | Channels >
Next Channel

• Right-click | in Channels
Palette > Next Channel

•Mouse |

Selects the next
channel in the list.

View the
Previous
Channel

• Menubar | Channels >
Previous Channel

• Right-click | in Channels
Palette > Previous
Channel

• Mouse |

Selects the previous
channel in the list.

Snapshot all
channels

•Menubar | Channels >
Snapshots > Snapshot
All Channels

• Right-click | in Channels
Palette > Snapshots >
Snapshot All Channels

Takes snapshots of all the
channels in the
Channels Palette.

Snapshot the
current
channel

•Menubar | Channels >
Snapshots > Snapshot
Current Channel

• Right-click | in Channels
Palette > Snapshots >
Snapshot Current
Channel

Takes snapshots of only
the current selected
channel.
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Function How to access it What it does Opens this
dialog box

Notes

Manage
snapshots

•Menubar | Channels >
Snapshots >Manage
Snapshots

• Right-click | in Channels
Palette > Snapshots >
Manage Snapshots

Opens the Snapshots
palette.

Delete all
snapshots

• Menubar | Channels >
Snapshots > Delete All
Snapshots

• Right-click | in Channels
Palette > Snapshots >
Delete All Snapshots

Deletes all the
snapshots taken for the
current project.

7 CHANNEL FUNCTIONS |



8 Layer Functions
A list of functions for adding, editing, removing, exporting, or importing layers and layer stacks can be found in the
table below.

Function How to access it What it does Opens this
dialog box

Notes

Add new layer • Menubar | Layers > Add
New Layer

• Right-click | in Layers
Palette > Add New Layer

• Button | Layers Palette >

Adds a new layer to the
layer stack.

Add
adjustment
layer

• Menubar | Layers > Add
Adjustment Layer

• Right-click | layer inLayers
Palette > Add Layer
Adjustment

• Button | Layers Palette >

• Keyboard | Tab

Adds the selected filter
as an Adjustment layer
to the layer stack.

Following the arrows in
the Add Adjustment
Layermenu leads to a
choice of 25 adjustment
layers.

If adding adjustments
by pressing Tab, type
in the name of the
adjustment you want
to add, for example,
Contrast.

Add
procedural
layer

• Menubar | Layers > Add
Procedural Layer

• Right-click | in Layers
Palette > Add
Procedural Layer

• Button | Layers Palette >

• Keyboard | Tab

Adds the selected Basic,
Environment,
Geometry, or
Procedural layer to the
layer stack.

Following the arrows in
the Add Procedural
Layermenu leads to a
choice of 27
procedurals.

If adding procedurals
by pressing Tab, type
in the name of the
procedural you want
to add, for example,
Cloud.
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Function How to access it What it does Opens this
dialog box

Notes

Cut layer or
layermask

• Menubar | Layers > Cut

• Right-click | layer in Layers
Palette > Cut

• Menubar | Layers >
Layer Mask > Cut

• Right-click | layermask in
Layers Palette > Layer
Mask > Cut

• Keyboard | Ctrl/Cmd+X

Cuts the layer from the
layers list to allow you to
paste it elsewhere in the
project or
temporarily remove it.

Using theCtrl/Cmd+X
shortcut cuts the
whole layer. You
cannot cut only the
layermask.

Copy layer or
layermask

• Menubar | Layers > Copy

• Right-click | layer in Layers
Palette > Copy

• Menubar | Layers >
Layer Mask > Copy

• Right-click | layermask in
Layers Palette > Layer
Mask > Copy

• Keyboard | Ctrl/Cmd+C
orAlt+drag

Copies the layer from
the layers list to allow
you to paste it
elsewhere in the
project.

Using theCtrl/Cmd+C
shortcut copies the
whole layer. You
cannot copy only the
layermask.

Paste layer or
layermask

• Menubar | Layers >
Paste

• Right-click | layer in Layers
Palette > Paste

• Menubar | Layers >
Layer Mask > Paste

• Right-click | layermask in
Layers Palette > Layer
Mask > Paste

• Keyboard | Ctrl/Cmd+V

Pastes a cut or copied
layer into the selected
location in the project’s
Layers Palette. Layers
can be paste as a copy in
the layer list, or as a new
layer in amask stack or
adjustment stack.

Duplicate
layer

• Button | Layers Palette > Creates an exact copy of
the selected layer.

’Copy’ is added to the
layer name to denote
which layer is the
duplicate.

8 LAYER FUNCTIONS |



41

Function How to access it What it does Opens this
dialog box

Notes

Remove
layers

• Right-click | layer in Layers
Palette > Remove
Layers

• Button | Layers Palette >

Removes the selected
layer from the current
project.

Merge layers • Right-click | layer in Layers
Palette >Merge Layers

Merges two ormore
layers together into a
single new layer.

Any masks or layer
groups contained in
the selection will also
bemerged into the
layer and are no longer
displayed asmasks or
groups.

Layer transfer • Menubar | Layers >
Transfer

• Right-click | layer in Layers
Palette > Transfer

Transfers layers from
one object or version to
another.

Layer Transfer
Dialog

Add empty
layer group

• Right-click | in Layers
Palette > Add Layer
Group

• Button | Layers Palette >

Adds an empty layer
group, which allows you
to add layers, masks,
adjustments or
procedurals within a
single layer group.

These layer groups can
be flattened to create a
single layer.

Group layers • Right-click | layer inLayers
Palette > Group Layers

Gathersmultiple
selected layers together
under a single group.

Selected layers are
located under a parent
layer, which is given a
‘group’ name.

Flatten layer
group

• Right-click | layer in Layers
Palette > Flatten Layer
Group

Reducesmultiple layers
into a single layer, where
all the textures are still
present.
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Function How to access it What it does Opens this
dialog box

Notes

Addmask • Menubar | Layers >
Layer Mask > Add Mask

• Right-click | layer in Layers
Palette > Layer Mask >
Add Layer Mask

• Button | Layers Palette >

Adds a layermask to the
selected layer. Select
Reveal All,Hide All, or
to create From Alpha.

Bakemask •Menubar | Layers >
Layer Mask > Bake
Mask

• Right-click | layer in Layers
Palette > Layer Mask >
Bake Mask

Bakes themask into the
layer, essentially
flattening it.

ResizeMask •Menubar | Layers >
Layer Mask > Resize
Mask

• Right-click | layer in Layers
Palette > Layer Mask >
Resize Mask

Resizes themask to a
size listed in theResize
Mask dropdownmenu.

Removemask •Menubar | Layers >
Layer Mask > Remove
Mask

• Right-click | layer in Layers
Palette > Layer Mask >
Bake Mask

Remove themask from
the layer.
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Function How to access it What it does Opens this
dialog box

Notes

Makemask
stack

• Menubar | Layers >
Layer Mask >Make
Mask Stack

• Right-click | layer in Layers
Palette > Layer Mask >
Make Mask Stack

• Button | Layers Palette >

Creates amask layer
stack from a singlemask
on a layer. Requires the
selected layer to have a
mask, unless you are
adding themask stack
using theAdd Mask
Stack button in the
Layers palette.

Clicking themask stack

icon opens an
undockedmask stack
palette.

Flattenmask
stack

• Menubar | Layers >
Layer Mask >Make
Mask Stack

• Right-click | layer in Layers
Palette > Flatten Mask
Stack

Reduces themasks in a
mask stack back into a
singlemask on the layer.

Enablemask • Menubar | Layers >
Layer Mask > Enable
Mask

• Right-click | in Layers
Palette > Layer Mask >
Enable Mask

Enables themask to be
viewed on themodel.

Disablemask • Menubar | Layers >
Layer Mask > Disable
Mask

• Right-click | in Layers
Palette > Layers Mask >
Disable Mask

Disables themask from
being viewed on the
model. Disabling the
mask only temporarily
removes it from view.

To remove themask
entirely, simply
Remove Mask in the
samemenu.

Convert Mask • Menubar | Layers >
Layer Mask > Convert
Mask

• Right-click | in Layers
Palette > Layers Mask >
Convert Mask

Converts themask's
texel format to either
8bit (Byte), 16bit
(Half), or 32bit (Float).
This worksmuch the
sameway as converting
a channel's texel format.
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Function How to access it What it does Opens this
dialog box

Notes

Add
secondary
adjustment

• Menubar | Layers >
Secondary Adjustment
> Add Secondary
Adjustment

• Right-click | adjustment
layer in Layers Palette >
Secondary Adjustment

Allows you to add
another type of
adjustment to the
selected adjustment
layer.

This only applies to
adjustment layers. The
option appears grayed
out if the selected layer
isn’t an adjustment.

Remove
secondary
adjustment

• Menubar | Layers >
Secondary Adjustment
> Remove Secondary
Adjustment

• Right-click | adjustment
layer in Layers Palette >
Remove Secondary
Adjustment

Removes any secondary
adjustment that has
been applied to the
selected adjustment
layer.

This only applies to
adjustment layers. The
option appears grayed
out if the selected layer
isn’t an adjustment.

Add
adjustment
stack

• Menubar | Layers >
Adjustment Stack > Add
Adjustment Stack

• Right-click | layer in Layers
Palette > Adjustment
Stack > Add
Adjustment Stack

• Button | Layers Palette >

Adds an adjustment
stack to the selected
layer. Add an
adjustment layer from
themenu of 21 Filter
adjustment layers.

This only applies to
layers other than
adjustment layers.

Bake
adjustment
stack

• Menubar | Layers >
Adjustment Stack >
Bake Adjustment Stack

• Right-click | layer in Layers
Palette > Adjustment
Stack > Bake
Adjustment Stack

Bakes an adjustment
stack down, essentially
flattening the stack into
a single adjustment
layer.
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Function How to access it What it does Opens this
dialog box

Notes

Remove
adjustment
stack

• Menubar | Layers >
Adjustment Stack >
Remove Adjustment
Stack

• Right-click | layer in Layers
Palette > Adjustment
Stack > Remove
Adjustment Stack

Removes any
adjustment stack that
has been applied to the
selected layer.

This only applies to
layers other than
adjustment layers.

Enable
adjustment
stack

• Menubar | Layers >
Adjustment Stack >
Enable Adjustment
Stack

• Right-click | layer in Layers
Palette > Adjustment
Stack > Enable
Adjustment Stack

If an adjustment stack
has been disabled, this
option re-enables the
adjustment stack.

This only applies to
adjustment stacks that
have been disabled. If
a layer does not have
an adjustment stack,
or if the stack is
already enabled, the
option appears grayed
out.

Disable
adjustment
stack

• Menubar | Layers >
Adjustment Stack >
Disable Adjustment
Stack

• Right-click | layer in Layers
Palette > Adjustment
Stack > Disable
Adjustment Stack

Disables an adjustment
stack to show the paint
layer result as it is
without the stack.
Useful for comparing
themodel with and
without the adjustment
stack.

This only applies to
adjustment stacks that
have been added to a
layer. If a layer does
not have an
adjustment stack, the
option appears grayed
out.

Convert to
paintable

• Menubar | Layers >
Convert to Paintable

• Right-click | layer in Layers
Palette > Convert to
Paintable

8 LAYER FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Share Layer • Menubar | Layers >
Sharing > Share Layer

• Right-click | layers in
Layers Palette > Sharing
> Share Layer

• Shift+drag layer

Creates a shared layer in
the layer stack.

Unshare layer • Menubar | Layers >
Sharing > Unshare
Layer

• Right-click | layer in Layers
Palette > Sharing >
Unshare Layer

Undoes the shared state
of the shared
(created) layer and the
original layer.

If sharing a layer as a
channel, unsharing the
layer to remove the
shared state doesn’t
remove the channel
from the Channels
Palette. This needs to
be donemanually.

Share Layers
As Channel

• Menubar | Layers >
Sharing > Share
Layers As Channel

• Right-click | layers in
Layers Palette > Sharing
> Share Layers As
Channel

Copies the selected
layers into the Channels
Palette as a new
Channel. Clicking on the
channel icon opens a
new palette with the
shared layer already
listed.

Make shared
channel
current

• Menubar | Layers >
Sharing >Make Shared
Channel Current

• Right-click | layer in Layers
Palette > Sharing >Make
Shared Channel
Current

Makes the shared
channel the current
channel in theView
Current Channel
option of theDefault
Shaders toolbar.

Cache layer(s) • Menubar | Layers >
Cache Layers

• Right-click | layer in Layers
Palette > Cache Layers

Bakes the layer to speed
up layer performance.
Caching a layer caches it
to the hard-disk.
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Function How to access it What it does Opens this
dialog box

Notes

Cache up to
here

• Menubar | Layers >
Cache Up To Here

• Right-click | layer in Layers
Palette > Cache Up To
Here

Caches up to the
current selected layer in
the layer stack.

Uncache
layer(s)

• Menubar | Layers >
Uncache Layers

• Right-click | layer in Layers
Palette > Uncache
Layers

Release the cached files
and unlocks the layer
stack, allowing it to be
edited again.

Uncache layer
up to here

• Menubar | Layers >
Uncache Up To Here

• Right-click | layer in Layers
Palette > Uncache Up To
Here

Releases the cached files
and unlocks the layer
stack up to the selected
layer, allowing those
layers to be edited
again.

Export
selected layers

• Menubar | Layers >
Export > Export
Selected Layers

• Right-click | layer in Layers
Palette > Export > Export
Selected
Layers

Exports the selected
layer to an external
source.

Export Dialog

Export all
layers

• Menubar | Layers >
Export > Export All
Layers

• Right-click | layer in Layers
Palette > Export > Export
All Layers

Exports all the layers in
the layer stack to an
external source.

Export Dialog
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Function How to access it What it does Opens this
dialog box

Notes

Export
selected
masks

• Menubar | Layers >
Export > Export
Selected Masks

• Right-click | layer in Layers
Palette or shader in
Shader Layers tab >
Export > Export
Selected Masks

Exports themask of the
selected layer(s) or
layered shader(s).

Export Dialog Themasks for layers
and layered shaders
behave in the same
way as they are in
effect the same entity.

Export all
masks

• Menubar | Layers >
Export > Export All
Masks

• Right-click | layer in Layers
Palette or shader in
Shader Layers tab >
Export > Export All
Masks

Exports all themasks in
a layer stack, in either
the Layers Palette or the
Shader Layers tab of
the Shaders Palette.

Export Dialog

Export
selected layers
flattened

• Menubar | Layers >
Export Flattened >
Export Selected
Layers Flattened

• Right-click | layer in Layers
Palette > Export > Export
Selected Layers
Flattened

Exports the selected
layer or layers flattened
into a single file to an
external source.

Export Dialog

Export all
layers
flattened

• Menubar | Layers >
Export Flattened >
Export All Layers
Flattened

• Right-click | layer in Layers
Palette > Export > Export
All Layers Flattened

Exports all the layers in
the layer stack flattened
into a single file to an
external source.

Export Dialog
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Function How to access it What it does Opens this
dialog box

Notes

Export
selected
masks
flattened

• Menubar | Layers >
Export Flattened >
Export Selected
Masks Flattened

• Right-click | layer in Layers
Palette or shader in
Shader Layers tab >
Export > Export
Selected Masks
Flattened

Exports themask of the
selected layer(s) or
layered shader(s)
flattened into a single
file to an external
source.

Export Dialog Themasks for layers
and layered shaders
behave in the same
way as they are in
effect the same entity.

Export all
masks
flattened

• Menubar | Layers >
Export Flattened >
Export All Masks
Flattened

• Right-click | layer in Layers
Palette or shader in
Shader Layers tab >
Export > Export All
Masks Flattened

Exports all themasks in
a layer stack, in either
the Layers Palette or the
Shader Layers tab of
the Shaders
Paletteflattened into a
single file to an external
source.

Export Dialog

Import into
layer

• Menubar | Layers >
Import > Import into
Layer

• Right-click | layer in Layers
Palette > Import >
Import into Layer

Selects a file with paint
ormask data to be
imported into the
selected layer.

Import Dialog

Import into
layer stack

• Menubar | Layers >
Import into Layer Stack

• Right-click | layer in Layers
Palette > Import >
Import into Layer Stack

Selects a file with paint
ormask data to be
imported into the
current layer stack.

Import Dialog

Inspect layer
properties

• Right-click | layer in Layers
Palette > Layer
Properties

Opens a separate
window to display the
properties of the
selected layer.
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Function How to access it What it does Opens this
dialog box

Notes

Refresh layer
view

• Right-click | in Layers
Palette > Refresh Layer
View

Refreshes the entire
layer stack.

8 LAYER FUNCTIONS |



9 Ptex Functions
A list of the functions for working with Ptex objects can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Double face
resolution

•Menubar | Ptex > Double
Face Resolution

• Button | Ptex Toolbar >

Double the selected face
resolution.

Halve face
resolution

•Menubar | Ptex > Halve
Face Resolution

• Button | Ptex Toolbar >

Halve the selected face
resolution.

Set theworld
space face
resolution for the
selected face

•Menubar | Ptex >World
Space Face Resolution

• Button | Ptex Toolbar >

Set theworld space face
resolution for the
selected face.

Set the face
resolution for the
selected face

•Menubar | Ptex > Set Face
Resolution

• Button | Ptex Toolbar >

Set the face resolution for
the selected face.

Fill selected faces
with foreground
color

•Menubar | Ptex > Fill
Faces Foreground

• Button | Ptex Toolbar >

Fill the selected faces with
the foreground color.

Fill selected faces
with background
color

•Menubar | Ptex > Fill
Faces Background

• Button | Ptex Toolbar >

Fill the selected faces with
the background color.



10 Patch Functions
A list of the functions for working with patches, including copying, filling, mirroring, and transforming patches, can be
found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Extract patch •Menubar | Patches >
Extract Selected

• Right-click | canvas >
Patches > Extract
Selected

Extracts the selected
patches as images, and
displays them in the
ImageManager Palette.

You can only extract
images up to 8K in
resolution.

Select patches by
number

•Menubar | Patches >
Select Range

• Right-click | canvas >
Patches > Select Range

Lets you enter a series
of patch numbers in
order to select those
patches.

Select
Patches

Copy selected
patches to
system
clipboard

•Menubar | Patches >
Copy Indexes to
Clipboard

• Right-click | canvas >
Patches > Copy Indexes
to Clipboard

• Right-click | Patches
Palette > Copy Indexes
to Clipboard

Copies selected patch
IDs to the system
clipboard.

Copies theUDIM of
the selected patch
(es) to the system
clipboard, for use in
other applications.

Paste selected
patch

•Menubar | Patches >
Quick Paste

• Right-click | canvas >
Patches > Quick Paste

• Keyboard | Ctrl/Cmd+V

Pastes a copied patch
(from the clipboard).
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Function How to access it What it does Opens this
dialog box

Notes

Copy selected
patch

Menubar | Patches >
Quick Copy

Right-click | canvas >
Patches > Quick Copy

Keyboard | Ctrl/Cmd+C

Copies the selected
patch.

Only copies the paint
baked onto the patch
(does not copy
unbaked paint).

Copy textures •Menubar | Patches >
Copy Textures

• Right-click | canvas >
Patches > Copy
Textures

Copiesmultiple
textures from
selected patches.

Copy Multiple
Textures
Dialog

Fill patches with
black

•Menubar | Patches > Fill
> Black

• Right-click | canvas >
Patches > Fill > Black

Fills the patch with black
paint.

Fill patches with
gray

•Menubar | Patches > Fill
> Gray

• Right-click | canvas >
Patches > Fill > Gray

Fills the patch with gray
paint.

Fill patches with
white

• Menubar | Patches > Fill
>White

• Right-click | canvas >
Patches > Fill >White

Fills the patch with
white paint.

Fill patches with
foreground color

•Menubar | Patches > Fill
> Foreground

• Right-click | canvas >
Patches > Fill >
Foreground

Paints the selected
patch(es) with the
current foreground
color.
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Function How to access it What it does Opens this
dialog box

Notes

Fill patches with
background
color

•Menubar | Patches > Fill
> Background

• Right-click | canvas >
Patches > Fill >
Background

Paints the selected
patch(es) with the
current background
color.

Fill patches with
transparency

•Menubar | Patches > Fill
> Transparent

• Right-click | canvas >
Patches > Fill >
Transparent

Makes the selected
patch(es) transparent.

Fill patches with
a UVmask

• Menubar | Patches > Fill
> UV Mask

• Right-click | canvas >
Patches > Fill > UV
Mask

Fills the selected
patches with a black
and white UV mask for
the current layer’s
current paint
component, if
paintable.

Fill patches with
wireframe

• Menubar | Patches > Fill
>Wireframe

• Right-click | canvas >
Patches > Fill >
Wireframe

Fills the selected
patches with a
wireframe for the
current layer’s current
component, if
paintable.

Copy the patch
mask

•Menubar | Patches > UV
Mask to Image
Manager

• Right-click | canvas >
Patches > UV Mask to
Image Manager

• Right-click | patch in
Patches Palette > UV
Mask to Image
Manager

Copies the outline
(mask) of the UVs on
the patch to the Image
Manager.
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Function How to access it What it does Opens this
dialog box

Notes

Copy the
patches
wireframe

•Menubar | Patches > UV
Wireframe to Image
Manager

• Right-click | canvas >
Patches > UV
Wireframe to Image
Manager

Copies thewireframe of
theUVs on the patch to
the ImageManager.

Extend the patch
bleed area

•Menubar | Patches >
Bleed Patch Edges

• Right-click | canvas >
Patches > Bleed Patch
Edges

• Right-click | in Patches
Palette > Bleed Patch
Edges

Extends the bleed area
at the edges of the UV
patches out to the edge
of the entire patch.

Flip patch
vertically

•Menubar | Patches >
Transform > Flip
Vertical

• Right-click | canvas >
Patches > Transform >
Flip Vertical

Flips the paint on the
selected patch(es)
vertically.

Flip patch
horizontally

•Menubar | Patches >
Transform > Flip
Horizontal

• Right-click | canvas >
Patches > Transform >
Flip Horizontal

Flips the paint on the
selected patch(es)
horizontally.

Rotate patch 90
degrees
counterclockwise

•Menubar | Patches >
Transform > Rotate 90
CCW

• Right-click | canvas >
Patches > Transform >
Rotate 90 CCW

Rotates the paint on the
selected patch(es) 90
degrees
counterclockwise.
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Function How to access it What it does Opens this
dialog box

Notes

Rotate patch 90
degrees
clockwise

•Menubar | Patches >
Transform > Rotate 90
CW

• Right-click | canvas >
Patches > Transform >
Rotate 90 CW

Rotates the paint on the
selected patch(es) 90
degrees clockwise.

Rotate patch
180 degrees

•Menubar | Patches >
Transform > Rotate
180

• Right-click | canvas >
Patches > Transform >
Rotate 180

Rotates the paint on the
selected patch(es) 180
degrees.

Mirror patch
from left to right

•Menubar | Patches >
Mirror >Mirror Left to
Right

• Right-click | canvas >
Patches >Mirror >
Mirror Left to Right

Mirrors the paint on the
selected patch(es) from
left to right.

Mirror patch
from right to left

•Menubar | Patches >
Mirror >Mirror Right
to Left

• Right-click | canvas >
Patches >Mirror >
Mirror Right to Left

Mirrors the paint on the
selected patch(es) from
right to left.

Mirror patch
from top to
bottom

•Menubar | Patches >
Mirror >Mirror Top to
Bottom

• Right-click | canvas >
Patches >Mirror >
Mirror Top to Bottom

Mirrors the paint on the
selected patch(es) from
top to bottom.
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Function How to access it What it does Opens this
dialog box

Notes

Mirror patch
frombottom to
top

•Menubar | Patches >
Mirror >Mirror
Bottom to Top

• Right-click | canvas >
Patches >Mirror >
Mirror Bottom to Top

Mirrors the paint on the
selected patch(es) from
bottom to top.

Link selected
patches

•Menubar | Patches >
Link > Link Selected
Patch Images

• Right-click | canvas > Link
> Link Selected Patch
Images

• Right-click | Patches
Palette > Link Selected
Patch Images

Links patches that have
been selected in the
Patches palette. This
allows you to quickly
replicate changes from
one patch across
multiple patches.

A colored box
highlights linked
patches in theUV
view.

Unlink
selected patches

•Menubar | Patches >
Link > Unlink Selected
Patch Images

• Right-click | canvas > Link
> Unlink Selected
Patch Images

• Right-click | Patches
Palette > Unlink
Selected Patch Images

Unlinks any linked
patches that have been
selected in the Patches
palette.

Removes the colored
box from the
unlinked patches in
theUV view.

Selects all
patches linked to
a specific patch

•Menubar | Patches >
Link > Select Linked
Patch Images

• Right-click | canvas > Link
> Select Linked Patch
Images

• Right-click | Patches
Palette > Select Linked
Patch Images

Selects all of the
patches that have been
linked to the specified
patch selection, and
highlights them in the
Patches palette.
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Function How to access it What it does Opens this
dialog box

Notes

Unlinks all linked
patches

•Menubar | Patches >
Link > Unlink All
Linked Patch Images

• Right-click | canvas > Link
> Unlink All Linked
Patch Images

• Right-click | Patches
Palette > Unlink All
Linked Patch Images

Unlinks all linked
patches for the entire
project.

Resize patches •Menubar | Patches >
Resize Selected > Size

• Right-click | canvas >
Resize Selected > Size

• Right-click | Patches
Palette > Resize
Selected > Size

Resizes the selected
patches to the selected
size, including options
to double or halve the
size.
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11 Shading Functions
A list of functions for adding, editing, removing, and toggling shaders, as well as how to change the lighting, can be
found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Add new
shader

•Menubar | Shading >
AddNew Shader

• Right-click | in Shaders
Palette > AddNew
Shader

• Button | Shaders Palette >

Adds a new shader from
the choices:

• Phong,

• Cook Torrance,

• Beckman,

• Blinn,

• Flat,

• sRGB Lighting,

• BRDF,

• Standard Lighting,

• Layered, and

• Choose Diffuse and
Specular.

Create Shader
Dialog when
selecting Choose
Diffuse and
Specular.

Masks Formats
Dialog when
selecting
Layered.

TheChoose
Diffuse and
Specular option
allows you to
create a custom
shader.

Refer to the Create
Shader Dialog for
more
information.
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Function How to access it What it does Opens this
dialog box

Notes

Add new
shader layer

• Button | Shaders Palette >
Shader Layers tab >

Adds a new shader to the
layer stack for the
selected layered shader:

• Phong,

• Cook Torrance,

• Beckman,

• Blinn,

• Flat,

• sRGB Lighting,

• BRDF,

• Standard Lighting,
and

• Choose Diffuse and
Specular.

Create Shader
Dialog when
selecting Choose
Diffuse and
Specular.

TheChoose
Diffuse and
Specularoption
allows you to
create a custom
shader.

Refer to the Create
Shader Dialogfor
more
information.

Duplicate
shader

•Menubar | Shading >
Duplicate Shader

• Right-click | in Shaders
Palette > Duplicate
Shader

• Button | Shaders Palette >

Makes a copy of the
selected shader.

Delete shader • Menubar | Shading >
Remove Shader

• Right-click | in Shaders
Palette> Remove Shader

• Button | Shaders Palette >

Deletes the selected
shader from the project.

Cut shader • Right-click | on shader in
Shaders Palette > Cut

• Ctrl/Cmd+X

Cuts the shader from the
Shaders palette list and
places it in the clipboard.

Default shaders
cannot be cut or
pasted.
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Function How to access it What it does Opens this
dialog box

Notes

Copy shader • Right-click | on shader in
Shaders Palette > Copy

• Ctrl/Cmd+C

Copies the shader from
the Shaders palette list
and places it in the
clipboard.

Default shaders
cannot be copied
or pasted.

Paste shader • Right-click | on shader in
Shaders Palette > Paste

• Ctrl/Cmd+V

Pastes the cut or copied
shader from the
clipboard into the
Shaders palette list.

add shader
mask

• Button | Shaders Palette >
Shader Layers tab >

Adds amask to the
selected shader layer in
the Shader Layers tab.

add shader
mask stack

• Button | Shaders Palette >
Shader Layers tab >

Adds amask stack to the
selected shader layer in
the Shader Layers tab.

remove
shader layer

• Button | Shaders Palette >
Shader Layers tab >

Removes the shader
layer from the layer stack
in the Shader Layers
tab.

assign a color
tag

• Button | Shaders Palette >
Shader Layers tab >

Assigns the selected
shader a color tag that
can be searched for with
the color tag filter.

Set lighting on
mainmesh to
flat

•Menubar | Shading >
Flat

• Toolbar |

Shades all pixels with the
same value.

Set lighting on
mainmesh to
basic

•Menubar | Shading >
Basic

• Toolbar |

Applies a basic lighting
model.
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Function How to access it What it does Opens this
dialog box

Notes

Set lighting on
mainmesh to
full

•Menubar | Shading >
Full

• Toolbar |

Applies a full,
configurable lighting
model.

Fromwithin the
Lighting palette,
you can also
adjust the four
basic lights or the
environment light.

Mari saves these
lighting values
with the project.

Toggle
shadows in
the display

•Menubar | Shading >
Shadows

• Toolbar |

Toggles whether to show
the shadows in the
display.

This does not
enable or disable
shadow
processing. To
enable shadow
processing, enable
Depth
Projections in the
Preferences. By
default this
preference is
disabled.

Toggle
wireframe
view

•Menubar | Shading >
Toggle Wireframe

• Keyboard | Shift+W

• Toolbar |

Toggles whether to show
thewireframes on the
model.

Toggle UV
image
rendering

•Menubar | Shading >
Toggle UvImage

• Toolbar |

Shows the patches in the
UV view as they appear
after export, including
the overspill areas.

Toggle whole
patch project

•Menubar | Shading >
Toggle Whole Patch
Project

• Toolbar |

Enables painting outside
geometry shell
boundaries in UV
patches.

This is only
available in UV
views.
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12 Painting Functions
A list of functions and shortcuts for painting and baking paint can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Undo all
unbaked
painting

•Menubar | Painting >
Clear Painting

• Toolbar |

•Mouse |

Undo all painting not
yet baked into the
model (still in the paint
buffer).

For themouse gesture:
press and hold \, click
and drag in the
direction indicated. (A
thin red line traces
gestures onscreen.)

Undo •Menubar | Edit > Undo

• Keyboard | Ctrl/Cmd+Z

• Toolbar |

•Mouse |

Undo the last action. For themouse gesture:
press and hold \, click
and drag in the
direction indicated. (A
thin red line traces
gestures onscreen.)

See also theHistory
View Palette.

Redo •Menubar | Edit > Redo

• Keyboard | Ctrl/Cmd+Y

• Toolbar |

•Mouse |

Redo the last (undone)
action.

For themouse gesture:
press and hold \, click
and drag in the
direction indicated. (A
thin red line traces
gestures onscreen.)

See also theHistory
View Palette.
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Function How to access it What it does Opens this
dialog box

Notes

Bake painting
into the
model

• Keyboard |B

•Menubar | Painting >
Bake

•Mouse |

• Statusbar |

Saves the painting as
part of the project.

For themouse gesture:
press and hold \, click
and drag in the
direction indicated. (A
thin red line traces
gestures onscreen.)

Show or hide
painting

• Keyboard | . Shows or hides the
contents of the paint
buffer (that is, the
unbaked paint).

Show or hide
paintable
areas
(not currently
masked out)

•Menubar | Painting >
Toggle Mask Preview

• Keyboard | ,

• Projection Palette |Mask
Preview |Mask
Preview Enabled

Shows or hides the
current masking
(including all masking
currently turned on - the
edgemask, channel
mask, ambient
occlusionmask, depth
mask, and backface
mask).

When this is on, this
shows paintable areas
normally, and
unpaintable areas are
colored.

Save current
painting as a
file

•Menubar | Painting >
Save Painting

Saves the current
unbaked paint (the
contents of the paint
buffer) as an .exr file.

SaveWindow
Painting

Saves the paint buffer
as an .exr file, and puts
it in the ImageManager
Palette.

Load
previously
saved
painting files

•Menubar | Painting >
Load Painting

Loads an .exr file and
projects it onto the
model as the current
painting.

Load
Window
Painting

Draw straight
line between
two points

•Mouse | Click, then
Shift+click

Draws a linewith the
current brush between
the two selected points.
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Function How to access it What it does Opens this
dialog box

Notes

Draw straight
line
horizontally or
vertically

•Mouse | Shift+click and
drag

Constrains painting to
straight horizontal or
vertical lines.

Toggle Last
Brush Tip •Mouse |

• Keyboard |N

Switches to the last
brush tip used.

12 PAINTING FUNCTIONS |



13 Filter Functions
A list of the filters available in Mari, where to find them, and how to apply them can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Apply Invert
filter

•Menubar | Filters >
Invert

Inverts the colors in the
selection’s alpha channel.
Replaces colors with their
“opposite” in the color
chart. For example,
replaces a color with a
float value of 0.3 with a
color with float value 0.7.

Apply Invert

Apply
Luminosity
filter

•Menubar | Filters >
Luminosity

Outputs just the
luminosity value of each
pixel in the selection. That
is, it outputs a grayscale
image based on the
brightness of every pixel
in the original image.

Apply
Luminosity
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Function How to access it What it does Opens this
dialog box

Notes

Apply In Blur
filter

•Menubar | Filters >
Blur > Blur

Applies a standard blur to
the selection.

Apply Blur You can select the blur
radius - the number of
pixelsMari uses when
calculating the blur value
for each pixel. The higher
the radius, themore
blurred the results. If you
use a larger blur radius,
youmay get slight lines
on the boundaries
between patches. This is
an artifact of theway
that Mari handles patch
edges.

This filter is not
supported with Ptex
channels.

Apply Soften
Blur filter

•Menubar | Filters >
Blur > Soften

Applies a subtle softening
blur. This is a quick,
predefined blur filter. If
you needmore control
over the degree or type of
blurring, use either the
standard Blur or
Gaussian Blur filters.

Apply Soften This filter is not
supported with Ptex
channels.
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Function How to access it What it does Opens this
dialog box

Notes

Apply
Gaussian Blur
filter

•Menubar | Filters >
Blur > Gaussian

Applies a Gaussian blur.
Compared to the
standard Blur filter, this
gives youmuch finer
control over the degree of
blurring, and the option
of usingmuch higher blur
values.

Apply
Gaussian

You can select the blur
radius. The higher the
radius, themore blurred
the results. If you use a
higher blur radius, you
may see artifacts along
the boundaries of
geometry shells and UV
patches.

This filter is not
supported with Ptex
channels.

Apply Gamma
filter

•Menubar | Filters >
Gamma

Changes the gamma
levels in the selection.

Apply
Gamma

Do Inverse reverses the
gamma conversion. That
is, a higher setting for
Gamma results in amore
washed-out looking
image.

Apply sRGB
To Linear
Filter

•Menubar | Filters >
sRGB To Linear

Applies an sRGB to linear
colorspace conversion.

Apply sRGB
To Linear

Checking Invert applies a
linear to sRGB colorspace
conversion.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Hue
filter

Menubar | Filters >
Hue

Changes the hue,
saturation, and value of
the colors on themodel.

Apply Hue To change the hue of the
colors, set the value for
Hue. Thismoves the
colors around the color
wheel. The rotation value
is the degree around the
color wheel that each
color shifts, between 0
and 360 (which both
correspond to the
original colors). The
options to change the
Saturation are:

• Saturation - howmuch
saturation is applied.
Select amultiplier from
0 to 2, where 1.00 is the
original saturation
value.

•Offset - an offset value
to add to the initial
saturation value, before
applying the scale.

You can also edit the
Saturation curve. This
controls how the filter
translates current
saturation values to new
values. For each input
value along the bottom
of the graph, the output
value is set from the
position of the line above
that point. Edit the curve
by:

13 FILTER FUNCTIONS |



70

Function How to access it What it does Opens this
dialog box

Notes

• pulling the anchor
points,

• clicking between anchor
points to add a new
point, and

• right-clicking to select
from a set of preset
values.

You can edit the Scale,
Offset and Value curve
for the value of the colors
in the sameway.

Apply
Brightness
filter

•Menubar | Filters >
Brightness

Changes the brightness of
the paint, either overall or
for specific color
channels. You can also
change the contrast.

Apply
Brightness

You can either change the
brightness of all color
channels at once, or one-
by-one. Changing the
main Brightness control
changes (overwrites) any
changes youmake to
brightness values for
individual color channels.

Apply
Contrast filter

•Menubar | Filters >
Contrast

Changes the contrast of
the paint.

Apply
Contrast

You can select the
amount of contrast using
the slider.

Apply Clamp
filter

•Menubar | Filters >
Clamp

Clamps color values to lie
within the specified upper
and lower values.

Apply Clamp Set theUpper Value and
Lower Value by
adjusting the sliders or
entering values in the
entry boxes.

Select the individual
Color Component to
clamp in the dropdown
menu.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Levels
filter

Menubar | Filters >
Levels

Changes the color levels in
the paint, by setting the
white point, midtone, and
black point.

Apply Levels You can change the levels
of all color components
or each color component
separately. You can set
the:

• Color Component -
whether this affects all
color components, or a
specific one (Red,
Green, orBlue).

•White Point - the
upper limit of displayed
color
intensity. Areas with a
value higher than this
aremapped to 1
(white).

•Midtone - themiddle
point between white
and black. Mari remaps
the values so that this is
themiddle of the range
between thewhite
point and black point.
Moving this pushes the
values towards that end
of the spectrum.

• Black Point - the lower
limit of displayed color
intensity. Areas with a
value lower than this
aremapped to 0
(black).
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Function How to access it What it does Opens this
dialog box

Notes

•White Output Level -
how strongly to output
thewhite in the filtered
image. Higher values
show the entire white
output, lower values
show decreasing
amounts.

• Black Output Level -
how strongly to output
the black in the filtered
image. Higher values
show the entire black
output, lower values
show decreasing
amounts.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Color
Curves filter

•Menubar | Filters >
Color Curves

Changes the color curve
for each color
component (RGB) in the
painting.

Apply Color
Curves

You can also edit each
color curve, controlling
how each color
component appears on-
screen. This controls how
the filter translates
current color values to
new values. For each
input value along the
bottomof the graph, the
output value is set from
the position of the line
above that point. Edit the
curve by:

• pulling the anchor
points,

• clicking between anchor
points to add a new
anchor point,

• right-clicking to select
from a set of preset
values.

Apply Color
Switches filter

•Menubar | Filters >
Color Switches

Turns individual color
components on or off.

Apply Color
Switches

Use the checkboxes to
select which color
components are
displayed. WhenMari
applies the filter, it
removes any unchecked
color components from
the painting.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Tone
Mapping filter

•Menubar | Filters >
Tone Mapping

Varies the “exposure” of
the painting.

Apply Tone
Mapping

You can set the:

•White Point - the
upper limit of color
intensity displayed; any
colors of greater
intensity map to white.

• Exposure - lower
exposures give darker
images; higher
exposures give lighter
ones.

Apply Copy
Channel filter

•Menubar | Filters >
Copy Channel

Copies the value fromone
RGB color
component to the other
two. The result is a
grayscale imagewith the
intensity values from the
selected component.

Apply Copy
Channel

Select the source
component from the list.
When you apply the filter,
Mari copies the selected
component over the
other two components.

Apply
Premultiply
Alpha filter

•Menubar | Filters >
Premultiply Alpha

Either pre- or post-
multiplies the alpha in the
selected image. If you are
painting using an image
without pre-multiplied
alpha onto onewith it,
use this filter to perform
the pre-multiplication, so
the imagesmatch and
you avoid lines around
the outside of the patch.
Post-multiply works the
same, but in reverse
(removes
pre-multiplication to
match images that do not
have pre-multiplied
alphas).

Apply
Premultiply
Alpha

If the Postmultiply box
is checked, the
pre-multiplied alpha is
removed.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Edge
Detect filter

•Menubar | Filters >
Edge Detect

Finds “edges”
(transitions between
colors) in the image and
heightens them.

Apply Edge
Detect

This filter is not
supported with Ptex
channels.

Apply Emboss
filter

•Menubar | Filters >
Emboss

Applies an “emboss”
effect, so that textures
look “raised” on the
surface.

Apply
Emboss

This filter is not
supported with Ptex
channels.

Apply Sharpen
filter

•Menubar | Filters >
Sharpen

Removes 'fuzziness' and
clarifies detail in the
image.

Apply
Sharpen

You can set the amount
of sharpening. Higher
valuesmeanmore
sharpening, while a value
of 0.00 is the picture
without the filter applied.

This filter is not
supported with Ptex
channels.

Apply High
Pass Filter

•Menubar | Filters >
High Pass

Removes low frequency
information from the
imagewhilemaintaining
higher frequency detail.

This can be useful for
quickly creating specular
maps where only the
higher frequency image
highlights are
maintained.

Apply High
Pass

You can set the kernel
size (the amount of
filtering) by adjusting the
Radius.

If you use a large radius,
youmay get slight lines
on the boundaries
between patches. This is
an artifact of theway
that Mari handles patch
edges.

This filter is not
supported with Ptex
channels.
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Function How to access it What it does Opens this
dialog box

Notes

Apply Color
Correction
filter

•Menubar | Filters >
Color Correction

Applies a colorspace
correction to the current
channel or painting.

Apply Color
Correction

You have the option to
useMari’s default
Configuration File or a
customone.

Set the colorspace of the
current channel or
painting in the Input
ColorSpace dropdown.

Set the colorspace
correction to apply to the
current channel or
painting in theOutput
ColorSpace dropdown.

Apply Add
Noise filter

•Menubar | Filters >
Add Noise

Applies noise to the
current channel or
painting.

Apply Add
Noise

Use theAmount slider
to adjust howmuch noise
is applied and select the
component you want to
affect from theColor
Component dropdown.

For additive grayscale
noise that modifies the
intensity while retaining
the original color, check
theGrayscale
checkbox.

You can regenerate the
noise using different
random samples by
dragging on the Seed
slider.

Adjust the size of the
noise applied by
dragging on the Size
slider.
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14 Camera Functions
A list of functions for using cameras, including how to project and unproject them, saving views and snapshots, and
commands formoving the camera, can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

View all
selected areas

•Menubar | Camera >
ViewAll

• Keyboard |A

•Mouse |

Fills the canvas with all
selected areas (or all
objects in the project if
nothing is selected).

For themouse gesture:
press and hold \, click
and drag in the direction
indicated. (A thin red line
traces gestures
onscreen.)

Load FBX
Camera

•Menubar | Camera >
Load Camera

Loads a 3rd party .fbx
camera view point of
the current model.

(The view point may
seem arbitrary,
depending on the
model)

Load
Camera

File format is .fbx

Project onto
the front
patches from
the current
view

•Menubar | Camera >
Quick Project Front

Loads the data from the
file set in theQuick
Projection dialog. The
result is projected onto
the patches of the
model visible from the
current view, and baked
on.

Quick
Projection (if
details have
not already
been set)
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Function How to access it What it does Opens this
dialog box

Notes

Project onto
all images
from the
current view

•Menubar | Camera >
Quick Project Through

Loads the data from the
file set in theQuick
Projection dialog. The
result is projected onto
all patches of themodel
(whether visible in the
current view or not) and
baked on.

Quick
Projection (if
details have
not already
been set)

Unproject
from the
current view

•Menubar | Camera >
Quick Unproject

Saves the current baked
painting, as visible in the
current view, to an
image file (as set in the
Quick Projection
properties dialog box).

Quick
Projection (if
details have
not already
been set)

Set up quick
projection

•Menubar | Camera >
Quick Projection
Settings

Lets you set the image
Resolution, Path and
Lighting setup for the
projected file.

Quick
Projection

Project from a
layered PSD
file.

•Menubar | Camera >
Layered Painting
Project

Manually loads the data
from the PSD file set in
the Painting
Projection settings
dialog. The result is
projected onto all
patches and relevant
channels of themodel
and baked down.

Painting
Projection (if
details have
not already
been set)

Unproject to a
layered PSD
file.

•Menubar | Camera >
Layered Painting
Unproject

Unprojects selected
channels to a layered
PSD file, set in the
Painting Projection
settings dialog, for
further editing in an
external image editor.

Painting
Projection (if
details have
not already
been set)
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Function How to access it What it does Opens this
dialog box

Notes

Set up layered
projection.

•Menubar | Camera >
Layered Painting
Projection Settings

Opens the Painting
Projection settings
dialog.

Painting
Projection

The Painting
Projection settings
dialog lets you set the
following:

• Channels - the
channels to unproject.

• Resolution - the
image resolution of
the unprojected
channels.

• Path - the filename
and path of the PSD
file.

• Image Editor - the
location of your image
editor application
binary.

•Watch Files - whether
external changes to
the PSD file are
automatically applied
in Mari.

• Reset Projection -
whether the original
position of themodel
is restored before the
painting is projected
onto it.

View left side
of model

•Menubar | Camera >
Camera Left

• Keyboard | 1

Changes the view to
show the “left” side of
themodel.

Model's “left” (may seem
arbitrary, depending on
themodel).

View right side
of model

•Menubar | Camera >
Camera Right

• Keyboard | 2

Changes the view to
show the “right” side of
themodel.

Model's “right” (may
seem arbitrary,
depending on the
model).

14 CAMERA FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

View top of
model

•Menubar | Camera >
Camera Top

• Keyboard | 3

Changes the view to
show the “top” of the
model.

Model's “top” (may
seem arbitrary,
depending on the
model).

View bottom
of model

•Menubar | Camera >
Camera Bottom

• Keyboard | 4

Changes the view to
show the “bottom” of
themodel.

Model's “bottom” (may
seem arbitrary,
depending on the
model).

View front of
model

•Menubar | Camera >
Camera Front

• Keyboard | 5

Changes the view to
show the “front” the
model.

Model's “front” (may
seem arbitrary,
depending on the
model).

View back of
model

•Menubar | Camera >
Camera Rear

• Keyboard | 6

Changes the view to
show the “rear” the
model.

Model's “back” (may
seem arbitrary,
depending on the
model).

Create a
projector

• Right-click | in Projectors
Palette > Create
Projector

• Button | Projectors

Palette >

Sets the current camera
and paintable region, to
frame a particular view
on themodel.

Use the view
saved in a
particular
projector

• Right-click | Projector in
Projectors Palette >
Make Projector
Current

Changes the current
view to the view set in
the selected projector.

Save the
current
camera view

• Right-click | Projector in
Projectors Palette > Save
Projector

• Button | Projectors

Palette >

Saves the current
projector (including all
details of the view) to
disk.

Save

14 CAMERA FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Save all
projectors
defined in the
project

• Right-click | in Projectors
Palette > Save All
Projectors

Saves all the projectors
currently defined in the
project. Mari saves all
the projectors as a
single file.

File format is .mpc (Mari
Projector Collection).

Load
projectors
fromdisk

• Right-click | in Projectors
Palette > Load
Projector

• Button | Projectors

Palette >

Loads one ormore
projectors from a file,
and changes the current
view to the first
projector in the file.

Load

Save a
snapshot
from a
projector to a
file

• Right-click | Projector in
Projectors Palette >
Unproject

Saves the current baked
painting from the
selected projector to an
image file.

Save
Unprojected
Image (if
Output Path
has not been
set yet)

Load image
data from the
current
projector

Right-click | Projector in
Projectors Palette >
Project

Loads the data from the
file specified for that
projector, projects it
onto themodel, and
bakes it on.

Pick Path (if
Input Path
has not been
set yet)

Unproject
multiple
channels at
once

• Right-click | Projector in
Projectors Palette >
Batch Unproject

Unprojectsmultiple
channels at once.

Batch
Unproject

Project
multiple
channels at
once

• Right-click | Projector in
Projectors Palette >
Batch Project

Projects onto multiple
channels at once.

Batch
Project
Dialog

14 CAMERA FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Load image
data into the
paint buffer
from the
current
projector

• Right-click | Projector in
Projectors Palette >
Import Image

Loads the data from the
file specified for that
projector, and puts it
into the paint buffer.

Pick Path (if
Input Path
has not been
set yet)

Load a
projector

• Right-click | Projector in
Projectors Palette >
Make Projector
Current

Displays the current
project with that
projector (camera and
paintable region).

Remove a
projector

• Right-click | Projector in
Projectors Palette >
Remove Projector

• Button | Projectors

Palette >

Deletes that projector.

Generate a
render
turntable
from a
projector

• Right-click | Projector in
Projectors Palette >
Render Turntable

Takes the scene as
viewed through the
selected projector, and
creates a series of
images showing the
scene rotating through
an axis. You can include
custom text or
thumbnails of reference
images in the turntable.

Render
Turntable
Dialog

Generate a
diagnostic
turntable
from a
projector

• Right-click | Projector in
Projectors Palette >
Diagnostic Turntable

Takes the scene as
viewed through the
selected projector, and
creates a turntable for a
set of channels. The
turntable has flat
lighting and uses the
default shader.

Diagnostic
Turntable
Dialog

14 CAMERA FUNCTIONS |
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Function How to access it What it does Opens this
dialog box

Notes

Rotate •Mouse |Alt and drag Drag to rotate the
model in different
directions.

Keys plusmouse
movement; uses last
mouse click as pivot
point.

Zoom •Mouse |Alt+Ctrl/Cmd
and drag left or right

Drag left to zoomout,
right to zoom in.

Keys plusmouse
movement.

Pan •Mouse |Alt+Shift and
drag

Drag themodel to a
different place on the
canvas.

Keys plusmouse
movement

Spin •Mouse | Ctrl/Cmd+R and
drag

Drag up to spin the
model clockwise, left to
spin counterclockwise

Keys plusmouse
movement.

Focus • Keyboard | F Re-centers view on
selected patch(es).

If no patches are
selected, focuses on the
center of themodel.

Switch to
Ortho Camera

• Keyboard | F10 Switches the canvas
view toOrthographic
mode.

Switch to
Perspective
Camera

• Keyboard | F11 Switches the canvas
view to Perspective
mode.

Enables theNear, Far,
and FoV fields. See
Projectors palette fields
formore information.

Switch to UV
Camera

• Keyboard | F12 Switches the canvas
view toUVmode.

Reset the
model
position

• Keyboard | 1 In the UV view, resets
themodel to its default
position.

14 CAMERA FUNCTIONS |



84

Function How to access it What it does Opens this
dialog box

Notes

Rotate the
model 90
degrees
counter-
clockwise

• Keyboard | 2 In the UV view, rotates
themodel 90 degrees
counter-clockwise from
the default position.

Rotate the
model 180
degrees
counter-
clockwise

• Keyboard | 3 In the UV view, rotates
themodel 180 degrees
counter-clockwise.

Rotate the
model 270
degrees
counter-
clockwise

• Keyboard | 4 In the UV view, rotates
themodel 270 degrees
counter-clockwise.

14 CAMERA FUNCTIONS |



15 View Functions
A list of functions for changing your view and saving layouts can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

Set the
display
properties

• Right-click |main canvas
> Display Properties

•Menubar | View >
Display Properties

Opens a dialog box
allowing you to control
how themain canvas
displays.

Display
Properties
Dialog

Save the
current layout

•Menubar | View > Save
Layout

Saves the current layout
of yourMari workspace
as a *.mws file.

SaveWindow
Layout

Saves the position of
palettes and other
elements of the GUI.

Open a saved
layout

•Menubar | View > Load
Layout

Opens a saved layout
(*.mws file).

LoadWindow
Layout

By default, Mari starts
with the last-used
layout.

Revert to the
default layout

•Menubar | View >
Default Layout

Resets the layout back
to theMari default.

Save image of
current
canvas

•Menubar | View > Take
Screenshot

Saves the current view
of the canvas as an
image file.

Various image formats
available.

Adjust the
screenshot
settings

•Menubar | View >
Screenshot Settings

Opens a dialog box that
allows you to set how
screenshots are saved.

Screenshot
Settings

Hide docked
palettes

•Menubar | View > Hide
Palettes

• Keyboard |Home

Hides all docked
palettes, so the canvas
takes up the entire
workspace.

TheHome key cycles
between showing all
palettes, hiding
undocked palettes, and
hiding all palettes.
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Function How to access it What it does Opens this
dialog box

Notes

HideGUI
components
on canvas

• Keyboard | / Hides displayed
information (such as the
histogram, heads-up
display, etc) from the
canvas.

View a
particular
palette

•Menubar | View >
Palettes ><palette
name>

• Right-click |Menubar or
Toolbar > <palette
name>

Displays the selected
palette.

The palette re-displays in
its last position.

Enter full
screenmode

•Menubar | View > Full
Screen

Enters full screenmode Click View > Full
Screen to exit full
screenmode.

15 VIEW FUNCTIONS |



16 Tool Functions
A list of functions formanaging plug-ins, imported custom content, and other tools can be found in the table below.

Function How to access it What it does Opens this
dialog box

Notes

View installed
plug-ins

•Menubar | Tools >
Plug-ins

Displays a list of
installed plug-ins.

Plug-ins Drag the edge of the
dialog box, and column
headings within, to
display full content.

Imports
Custom
Brushes

•Menubar | Tools >
Import Brushes

Allows you to select the
customPhotoshop
brush file that you want
to import into Mari

Import
Brushes

Photoshop custom
brush filesmust be in
the .abr file format.

Set theMari
cache location

•Menubar | Tools >
Cache Location Setup

Lets you set the area to
hold theMari cache.

Cache
Location

You can only add or
remove additional cache
locations when there are
no projects. Once
projects have been
created for a given set of
cache locations, that set
must not be changed or
project corruption will
occur.



88

Function How to access it What it does Opens this
dialog box

Notes

Make changes
to your
license

Menubar | Tools >
License

Lets you:

• purchase, activate, and
install licenses,

• tell Mari where to find
a license server,

• obtain 15-day trial
licenses,

• see howmany days
remain before your
license expires (if you
are using a temporary
license),

• see your System ID (if
you are using a node
locked license), and

• see your server name
(if you are using a
floating license).

Mari Licensing You can only obtain a
trial license for amajor
Mari release once on
eachmachine. For
example, if you had a
trial license forMari
1.1v1, you can’t get
another one forMari
1.1v2 on the same
machine.

16 TOOL FUNCTIONS |



17 Python Functions
A list of functions for working with Python and accessing the Python and API documentation can be found in the
table below.

Function How to access it What it does Notes

Execute example
scripts

•Menubar | Python >
Examples

Executes example scripts
and displays results in the
output pane of the Python
Console.

View Python API
documentation

•Menubar | Python >
Documentation

Displays the Python API
documentation in aweb
browser.

View Software API
Overview
documentation

•Menubar | Python >
Readme

Displays the Software API
Overview documentation.

An introduction to Python in
Mari and GLSL shaders

Display Python
Console

•Menubar | Python > Show
Console

Displays the Python Console



18 Help Functions
A list of the functions for accessing the documentation and training information in Mari can be found in the table
below.

Function How to access it What it does Notes

View information
about Mari

•Menubar |Help > About Displays theMari info screen. About this
release, credits,
and so on.

View theMari Getting
Started Guide

•Menubar |Help > Getting
Started

Displays the basic guide to working
with Mari.

View theMari User
Guide

•Menubar |Help > User
Guide

Displays the comprehensive, step-
by-step guide to all Mari's functions.

View theMari
Reference Guide

•Menubar |Help >
Reference Guide

Displays the overallMari Reference
Guide.

View theMari Release
Notes

•Menubar |Help > Release
Notes

Displays aweb page that links to the
release notes

View theMari Training
Resources web page.

•Menubar |Help > Training
and Tutorials

Displays aweb pagewith links to
user guide assets and video
tutorials.

View Software API
Overview
documentation

•Menubar |Help > SDK > API
Overview

Displays the Software API Overview
documentation.

An introduction
to Python inMari
and GLSL
shaders.

View the Python API
documentation and
examples.

•Menubar |Help > SDK >
Python

Displays the Python API
documentation and a list of
examples.

View the C API
documentation and
examples.

•Menubar |Help > SDK > C
API

Displays the C API documentation
and a list of examples.



19 Toolbars
The toolbars that are available in Mari are shown in the tables below, along with example images, the controls that
can be found on each toolbar, and a list of descriptions of both the toolbar and the controls on it.

Project Toolbar

What it looks like What it does

Lets you perform common project functions, such as creating, closing and
saving projects.

Project Toolbar Controls

Control Type What it does Opens this
dialog box

Notes

button Create a new project. New Project
Dialog

Name the project,
select options,
and add
geometry.

button Close the current project. Save Changes
Before Closing?
(if unsaved
changes)

button Save the current project.

button Undo the last action. See also History
View Palette.

button Redo the last action. See also History
View Palette.
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Lighting Toolbar

What it looks like What it does

Lets you change the lighting on the object. You can select one of the three
lighting presets: flat, basic, or full, and toggle the use of shadows in the display.

By default, lighting is relative to the scene, not the view. You can set individual
lights to movewith the view.

Mari saves custom lighting with the project. If you need the same lights in
another project, you need to set themup separately.

Lighting Toolbar Controls

Control Type What it does Notes

button Set the lighting on the object to "flat". In thismode, the position of the lights has no
effect.

button Set the lighting on the object to "basic". In thismode, you canmove lights around on
the canvas ormake fine adjustments to
lighting using the Lights Palette.

button Set the lighting on the object to "full". In thismode, you canmove lights around on
the canvas ormake fine adjustments to
lighting using the Lights Palette.

button Toggles shadows on or off. This does not enable or disable shadow
processing. It simply controls whether the
shadows are displayed or not. To enable
shadow processing, enableDepth
Projections in the Preferences. By default,
this preference is disabled.

19 TOOLBARS | LIGHTING TOOLBAR
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Painting Toolbar

What it looks like What it does

Clears all painting not yet baked into themodel (still in the paint buffer).

Tools Toolbar

What it looks like What it does

Lets you select a tool for
painting.

Tools Toolbar Controls

Control Type What it does Opens this
dialog box

Notes

button Activate the Select tool. This tool lets you
select areas on themodel(s) in your
project.

You can select whole objects,
patches, or areas on the
surface of the objects. Once
you havemade a selection,
you can choose to show or
hide the selected areas, or to
lock them for editing.

button Activate theMarquee Select tool. This
tool lets you select areas on the screen, to
control where you can apply paint.

When you'vemade a
selection, paint only bakes
downwithin the selected
areas.

19 TOOLBARS | PAINTING TOOLBAR
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Control Type What it does Opens this
dialog box

Notes

button Activate the Transform Paint Buffer
tool. This tool lets you resize, rotate, and
move the paint buffer (and any unbaked
paint in the buffer). It works on the entire
paint buffer at once.

You can also make these
transformations by manually
editing the values under
Transform in the Paint
Buffer section of the Painting
Palette.

button Activate the Zoom Paint Buffer tool.
This tool lets you zoom in and out of the
scenewith the paint buffer locked to the
object and without baking the paint.

You can also enable this tool
by pressing Z. Zooming is
reset when paint is baked.

button Activate the Pan Object tool. This tool
lets youmove objects and lights around
on the canvas.

button Activate theVector Inspector tool. This
tool lets you control the appearance of
the directionalmarkers for painted
vectors.

You can opt to enable or
disable the visibility of the
directionalmarkers in the
Vector Inspector toolbar. If
themarkers don’t appear
when you select the tool,
ensure that this option is set
to enabled.

button Activate theBlur tool. This tool lets you
blur paint already baked on amodel.

If you want to blur large areas
of the surface, youmay want
to use the blur Filter
Functions instead. These
apply a controlled blur to
entire patches or objects.
Mari includes several blur
filters, including a controllable
Gaussian blur.

button Activate theWarp tool. This tool lets you
warp a selected areawithin your paint
buffer. You create awarp box - a rectangle
with between 4 and 64 control points.

19 TOOLBARS | TOOLS TOOLBAR
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Control Type What it does Opens this
dialog box

Notes

button Activate the Slerp tool. This tool works
like the Liquify tool in Adobe®
Photoshop®. It lets you “pull” the
contents of the paint buffer around.

As well as pulling, Slerp lets
you grow, shrink, and rotate
the paint. You can also use it
to selectively erase distortions
you've already applied.

button Activate the Pinup tool. This tool lets you
works like theWarp tool, but lets you set
your own control points (pins) wherever
you want.

Shift-click to create a pin.

button Activate the Paint tool. This tool lets you
draw paint strokes in the paint buffer.

button Activate theVector Paint tool. This tool
lets you draw vector paint strokes in the
paint buffer.

button Activate the Eraser tool. This tool lets you
erase paint from the paint buffer. It does
not affect any underlying paint baked
onto themodel.

To clear the entire paint

buffer, click the button
in the Painting Toolbar.

button Activate the Paint Through tool. This
tool lets you position an image over an
object, and then as you paint, paints the
image "through" onto yourmodel.

button Activate the Paint Gradient tool. This
lets you create a color gradient floating
over yourmodel, which you can paint
through to stamp onto yourmodel (like
the Paint Through tool).

button Activate theClone Stamp tool. This tool
lets you clone from an existing image,
shown in a separatewindow. You set a
source point on the image. As you paint,
Mari copies the texture around that
source point onto yourmodel.

You can also clone stamp
frompainting already on an
object, in the paint buffer, or
in another channel.

19 TOOLBARS | TOOLS TOOLBAR
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Control Type What it does Opens this
dialog box

Notes

button Activate the Towbrush tool. This tool lets
you lets you select areas of paint and drag
them around the surface of yourmodel.
As you tow the paint around, it blends the
edges of your selection with the
surrounding paint. It works like the
CloneStamp tool, but blends in the edges
of the cloned selection.

button Activate the Color Picker/Pixel
Analyzer tool. This tool lets you pick a
color from the paint on themodel.

Color
swatch

button Select a foreground color. Select Color

button Swap the foreground and background
colors.

Color
swatch

button Select a background color. Select Color

button Set the foreground color to white and the
background color to black.

Selection Toolbar

What it looks
like

What it does

Lets you switch between three selectionmodes (objects, patches, and faces) when using the
Select tool.

19 TOOLBARS | SELECTION TOOLBAR
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Selection Toolbar Controls

Control Type What it does Notes

button Set Mari to select whole objects.

button Set Mari to select patches on objects. You can hold down Shift to add to the selection,

Ctrl/Cmd to remove from the selection, and
(Windows) to intersect the selection.

button Set Mari to select areas on objects. You can hold down Shift to add to the selection,

Ctrl/Cmd to remove from the selection, and
(Windows) to intersect the selection.

When using the Select tool, double-click on the
face of themodel to create a smart selection based
on the settings in the Smart Type dropdown
menu.

Canvas Toolbar

What it looks like What it does

Lets you set the view options for theUV and
3D views.

Canvas Toolbar Controls

Control Type What it does Notes

button Toggle whether to show thewireframes
on themodel.

You can also press Shift+W to do this.

19 TOOLBARS | CANVAS TOOLBAR
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Control Type What it does Notes

button Toggle between showing the patches in
theUV view:

• as they appear as part of themodel, and

• as they appear when exported (that is, as
square images, with overpaint areas
around the corners of the patches).

button Toggle whether paint can be projected
onto UV patches located outside the
shells of the original geometry.

This control is only available in UV view.

button Switch to the orthographic camera view.

button Switch to the perspective camera view. In this view, you can set the near and far
clipping planes and the field of view.

button Switch to theUV camera view (theUV
tab). This gives you a “flat” view of the
patches in themodel.

Near entry
box

Set the value for the near clipping plane.
Mari doesn’t display parts of the scene
that are closer than theNear plane.

This control is only available in the perspective
camera view.

Far entry
box

Set the value for the far clipping plane.
Mari doesn’t display parts of the scene
that are further than the Far plane.

This control is only available in the perspective
camera view.

FoV entry
box,
slider

Set the value for the field of vision. This
controls howmuchMari distorts the view
when applying perspective. At 0, the
perspective camera gives exactly the same
view as the ortho camera. As the value
increases, the distortion increases.

This control is only available in the perspective
camera view.

19 TOOLBARS | CANVAS TOOLBAR
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Tool Properties Toolbar

What it looks like What it does

Displays information about the
selected tool.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR
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Tool Properties Toolbar Control

Tool Control Type What it does Opens this
dialog box

Notes

Facing dropdown Set whether the selection only
applies to the Front of themodel
as you can see it, or if the selection
goes Through themodel and
includes the other side.

button ActivateRectangle Selection
mode. This lets you draw a
rectangular selection.

This control
only works in
Face selection
mode.

button Activate Lasso Selectionmode.
This lets you draw the outline of
your selected area. You can draw
any shape you want.

This control
only works in
Face selection
mode.

button Activate the Polygonal Lasso
Selectionmode. This lets you draw
the outline of your selected area by
setting points between polygon
sides until you close the selection.

You can close
the selection
by double-
clicking on the
canvas,
pressing
Enter, or
clicking on the
first point.

button Activate Smart Selectionmode.
This lets you create selections based
on the surface of themodel.

Smart
selection only
works in Face
selection
mode.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR
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Tool Control Type What it does Opens this
dialog box

Notes

Smart
Type

dropdown Choosewhether to base your smart
selection on:

• Connectedness - selects the
areas on themodel connected to
the selected face. When you look
at the area in theUV view, this
selects thewhole connected area
within the current UV patch. If the
UV patch holds several different
areas, only those areas you click
on are selected.

• Edge Angle - selects based on the
degree of change between
neighboring faces. The selection
goes until it hits an angle higher
than the Smart Angle.

•Orientation - selects the area
that faces in the same direction as
your initial selection.

This control
only works in
Smart
Selection
mode.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR
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Tool Control Type What it does Opens this
dialog box

Notes

Smart
Angle

entry box, slider Set themaximumangle for the
smart selection.

• For Edge Angles, this sets the
maximumangle between areas on
themodel surface. For example, if
the angle is set to 30, this selects
areas up to a 30 degree change of
facing.

• ForOrientation, this sets how far
from the facing of your original
selection the selection goes to.
For example, if the angle is set to
30, this selects areas up to 30
degrees away from the facing of
your original selection.

This control
only works in
Smart
Selection
mode.

All button Select all items.

None button Unselect all items.

Invert button Invert the current selection.
Unselected areas become selected,
and vice versa.

Grow button Grow the current selection. This control
only works in
Face selection
mode.

Shrink button Shrink the current selection. This control
only works in
Face selection
mode.

Grow/
Shrink by

dropdown Choosewhether to grow or shrink
the
current selection by Vertex or
Edge.

This control
only works in
Face selection
mode.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR



103

Tool Control Type What it does Opens this
dialog box

Notes

button ActivateRectangle Selection
mode. This lets you draw a
rectangular selection.

button Activate Lasso Selectionmode.
This lets you draw the outline of
your selected area. You can draw
any shape you want.

button Activate the Polygonal Lasso
Selectionmode. This lets you draw
the outline of your selected area by
setting points between polygon
sides until you close the selection.

You can close
the selection
by double-
clicking on the
canvas,
pressing
Enter, or
clicking on the
first point.

button Activate Ellipse Selectionmode.
This lets you draw an elliptical
selection.

button ActivateMagicWand Selection
mode. This lets you select by color.
When you click, Mari creates a
selection around the point you
clicked. The selection is based on
color – areas with a similar color to
the original point are selected. You
can change the color threshold for
the selection.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR
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Tool Control Type What it does Opens this
dialog box

Notes

Mode button How drawing a new selection
affects the current marquee
selection:

• Replace - the new selection
replaces the existing selection.

• Transform - this lets youmove
your selection area around (move,
rotate, or scale the selection).

In Replacemode (the default), you
can:

• hold down Shift, click and drag to
add to the current selection, or

• hold down Ctrl/Cmd, click and
drag to remove from the current
selection.

In Transformmode, you can:

• hold down Shift, click and drag to
move the current selection,

• hold down Ctrl/Cmd, click and
drag to rotate the current
selection, or

• hold down Shift+Ctrl/Cmd, click
and drag to scale the current
selection.

Invert button Invert the current selection.
Unselected areas become selected,
and vice versa.

Clear button Clear the current selection.

Feathering entry box Soften the edges of the selection.
Higher values give the selection a
softer, fuzzier edge. At 0, the
selection has a hard edge.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR



105

Tool Control Type What it does Opens this
dialog box

Notes

Reset
Buffer

button Reset any transformations (moves,
rotations, scales) applied to the
paint buffer (and any unbaked
paint in the buffer).

Reset button Reset the zoom level of the paint
buffer.

Zoom In button Zoom in on the paint buffer.

Zoom Out button Zoomout of the paint buffer.

No
properties.

Reset button Reset the settings of the vector
inspector.

Can also be done by using the ’
(apostrophe) shortcut when the
vector inspector is active.

Enabled checkbox Enable (or disable) the visible
directionalmarkers for the vector
paint tool.

Can also be done by using the
Shift+I shortcut.

Line
spacing

entry box, slider Adjust the spacing between the
directionalmarkers.

Can also be done by Shift+dragging
themousewhen the vector
inspector is active.

Line
length

entry box, slider Adjust the length of the directional
markers.

Start Color button Change the color at the base of the
directionalmarkers.
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Tool Control Type What it does Opens this
dialog box

Notes

End Color button Change the color at the tip of the
directionalmarkers.

Vector
Space

dropdown Set whether the vector inspector
operates in ScreenSpace,
TangentSpace, orWorldSpace.

Same as
Paint,
plus:

Blur entry box, slider Set the blur strength. The higher
the value, themore blur is
produced.

Clear button Remove the current warp.

+ button Increase the number of control
points (up to 64) in thewarp grid.

- button Decrease the number of control
points in thewarp grid.

Toggle
Grid

button Toggle between hiding and
displaying the grid lines connecting
the control points.
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Tool Control Type What it does Opens this
dialog box

Notes

Mode dropdown Select how to use the Slerp tool:

• Pull - pulls paint around.

• Grow - makes the paint in a
specific area larger.

• Shrink - makes the paint in a
specific area smaller.

• Rotate - rotates paint around.

• Erase - lets you undo the
distortion in a specific area of the
painting.

You can also:

• press ’ (apostrophe) to undo all
the distortions you've applied, or

• press ;(semicolon) to apply your
changes to the paint buffer (that
is, make them so you can't erase
the distortions).

Radius entry box, slider Set the slerp radius (that is, how big
the brush tip is).

Opacity entry box, slider Set the strength of the Slerp effect.

Reset Pins button Undo all the distortions you've
applied, moving the pins back to
their original positions.

Clear Pins button Remove all the current pins.

+ button Increase the strength of the
currently selected pin. Stronger pins
pull more of the surrounding
texture towards them.

- button Decrease the strength of the
currently selected pin.
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Tool Control Type What it does Opens this
dialog box

Notes

Apply button Apply your changes to the paint
buffer and remove all current pins.

Painting
Mode

dropdown The blendingmode used when the
paint bakes down onto the channel
surface. The default isNormal
(paint in the buffer overwrites the
surface), but Mari supports a
number of other blendingmodes.

Colors checkbox Whethermore pressure causes the
color to vary (from slightly darker to
the target color).

Alpha checkbox Whethermore pressure increases
the opacity.

Radius checkbox Whethermore pressure increases
the radius.

Flow checkbox Whethermore pressure increases
the flow.

Radius entry box Set how big the brush tip is (in
pixels).

Opacity entry box How opaque the paint is. This is a
multiplier on the paint buffer
contents. At 1.0, the paint bakes
down to the surfacewith the same
opacity as it is in the buffer. At 0.5,
the paint applied to the surface is
half as transparent as when it's in
the buffer.

Flow entry box Mimics how quickly paint is applied,
by setting themaximumopacity in
a splat.
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Tool Control Type What it does Opens this
dialog box

Notes

Same as
Paint

Same as
Paint.

Same as
Paint, plus:

Mode dropdown Select from twomodes:

• Paint through - you hover the
image preview over themodel
and stamp it down onto the
surface.

• Image clone - you hover the
image next to themodel, set a
source point, and clone from that
point.

Stamp button Stamp the image straight onto the
model.

Toggle
Repeat

button Toggle source image tiling on and
off. If this is on, when you paint off
the edge of the image, Mari repeats
the image (so you always have
source data).

Tint button Tint combines the foreground color
with the paint through texture.
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Tool Control Type What it does Opens this
dialog box

Notes

Stencil dropdown Stencil uses the Paint Through
texture’s alpha channel as amask
and paints the foreground color.
There are three options available:

•No Stencil - if this is selected,
Mari ignores the stencil color and
follows the alpha value.

• Stencil - if this is selected, paint is
applied to the foreground color.

• Inverted Stencil - if this is
selected, paint is applied in
everything that is transparent.
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Tool Control Type What it does Opens this
dialog box

Notes

Luminance dropdown Luminance uses the Paint Through
texture’s luminance instead of the
alpha, but works similarly to
Stencil. The following options exist
within the same dropdownmenu as
the Stencil options:

• Luminance - Works well for dirt,
noise, and other similar images by
using the luminance value of an
image instead of the alpha.

• Inverted Luminance - Similar to
the luminance option, but the
calculated luminance value is
inverted before use.

Reset
Image

button Reset any transformations (such as
moving, resizing, or rotating) you
havemade to the source image that
you're cloning.

Pan Lock checkbox Lock the image position relative to
themodel. If you pan themodel,
the image that you're painting
through pans too.

Scale Lock checkbox Lock the image size relative to the
model. If you zoom themodel in or
out, the image that you're painting
through zooms in or out too.
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Tool Control Type What it does Opens this
dialog box

Notes

Same as
Paint,
plus:

Color
swatch

Select the start color for the
gradient.

Select Color

Color
swatch

Select the end color for the
gradient.

Select Color

In Point entry box How far through the gradient the
start color lasts (before it starts
graduating into the end color).

Out Point entry box How far through the gradient the
end color reaches.

Type dropdown Select between Linear orRadial
gradient. A linear gradient has a
color at one end grading into the
other color. A radial gradient has a
color in themiddle, radiating out in
a circle to the other color on the
outside.
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Tool Control Type What it does Opens this
dialog box

Notes

Same as
Paint,
plus:

Source dropdown Clone from:

• Current Paint Target - the
model's surface (baked paint) in
the active channel.

• Painting - the current (unbaked)
paint in the paint buffer.

• Image - an external image
(selected from the Image
Manager, optionally zoomed in
or out).

• Any of the other channels in the
project.

button Clone from the selected region to
another part of the surface.

button Overwrite the selected region with
another part of the surface.

button Swap the contents of the selected
region with another area on the
surface.

Sample
Size

entry box, slider Radius in pixels that the eyedropper
uses when sampling colors off the
surface. The eyedropper takes the
average value of all the pixels in this
area, and sets this as the
foreground color.

19 TOOLBARS | TOOL PROPERTIES TOOLBAR



114

Ptex Toolbar

What it looks like What it does

Displays a number of options for
managing Ptex faces within your
project.

This toolbar is only available for Ptex
channels.

Ptex Toolbar Controls

Control Type What it does Notes

button Double the selected face resolution.

button Halve the selected face resolution.

button,
entry box

Set theworld space face resolution for
the selected face. Enter the Texel Density and then click .

button,
dropdown

Set the face resolution for the selected
face. Select the Size and then click .

dropdown Fill the selected faces with the
foreground color.

button Fill the selected faces with the
background color.
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ColorSpace Toolbar

What it looks like What it does

Displays a number of options
formanaging colorspaces in
Mari.

ColorSpace Controls

Control Type What it does Notes

button Enable colormanagement. Click to toggle.

button Select a custom colorspace
configuration file.

button Select a custom LUT to apply to the
scene.

button Clear the current LUT applied to the
scene.

Extrapolate checkbox Sets whether theGPU extrapolates
the grid values or clamps to the
maximum value of the LUT.

InputColor
Space

dropdown Set the colorspace of the scene.

Display
Device

dropdown Set the colorspace of the display
device used to view the scene.

View
Transform

dropdown Select a colorspace transform to apply
to the scene.

Component dropdown View the individual color channels for
the scene.
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Control Type What it does Notes

Gain incrementer,
entry box,
slider

Set the amount of exposure
adjustment applied before the display
transform.

You can boost or reduceGain by entering a
multiplier (exposure value), dragging on the
slider, or adjusting the F-Stop value.

Gamma entry box,
slider

Set the amount of gamma correction
applied after the display transform.

You can boost or reduceGammaby
entering a gamma level or dragging on the
slider.

Navigation Toolbar

What it looks like What it does

Displays a number of options formanaging navigation in
Mari.

Navigation Toolbar Controls

Control Type What it does Notes

button Resets all the options in theNavigation
toolbar to the default settings.

button,
dropdown

Provides the following options for
panning:

• Pan All - allows panning in any
direction.

• Pan X - allows panning on the x axis
only.

• Pan Y - allows panning on the y axis
only.

• Pan Disabled - disables all panning.

The button changes to reflect the selected
option.
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Control Type What it does Notes

button,
dropdown

Provides the options to either enable or
disable zooming.

The button changes to reflect the selected
option.

button,
dropdown

Provides the options to either enable or
disable rolling.

The button changes to reflect the selected
option.

button,
dropdown

Provides the following options for
orbiting:

•Orbit All - allows orbiting around the
model in any direction.

•Orbit X - allows orbiting around the
model on the x axis only.

•Orbit Y - allows orbiting around the
model on the y axis only.

•Orbit Disabled - disables all orbiting.

The button changes to reflect the selected
option.

button,
dropdown

Provides the following options:

• Snap 45 degrees - when rotating the
model it snaps at 45 degree angles.

• Snap 90 degrees - when rotating the
model it snaps at 90 degree angles.

• Snap angle disabled - when rotating
themodel it does not snap to any
angle.

The button changes to reflect the selected
option.

Paint Buffer Symmetry Toolbar

What it looks like What it does

Displays the four options for the Paint Buffer Symmetry
functionality.
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Paint Buffer Symmetry Toolbar Controls

Control Type What it does Notes

button This is the default setting. Whenmirroring
is disabled, the paint buffer acts as normal
and the paint strokes are not mirrored.

button Mirroring left and right splits the paint
buffer down the center vertically. Any
paint strokesmade on either the left or
right side of the divider aremirrored on
the opposite side.

This applies to paint strokes only.

button Mirroring top and bottom splits the paint
buffer down the center horizontally. Any
paint strokesmade on either the top or
bottomof the divider aremirrored on the
opposite side.

This applies to paint strokes only.

button Mirroring four ways splits the paint buffer
into quarters around the center of the
canvas. Any paint strokesmade in one of
the quadrants aremirrored in the other
three.

This applies to paint strokes only.

Vector Painting Toolbar

What it looks like What it does

Displays the option to toggle the vector inspector on or off
and to create default vector shaders. When the tool is active,
the vector inspectormarkers are shown, regardless of
whether you toggle the option on or off.
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Vector Painting Toolbar Controls

Control Type What it does Notes

button Quickly enables the vector inspector so
that the directionalmarkers are visible. To
quickly turn off the directionalmarkers,
click the button again.

Can also be done by using the Shift+I shortcut.

button Sets up two default vector shaders with
default channels and layers for painting
flow or normalmaps. Also changes the
tool to Vector Paint and switches the
Painting Mode to Paint Flow Vectors.

Can also be done by navigating to Python |
Examples > Setup Vector Brush.

Default Shaders Toolbar

What it looks like What it does

Displays one of the four default shader in the Shaders
palette: Current Channel, Current Layer and Below,
Current Layer, and Current Paint Target. Selecting a
custom created shader in the Shaders palette won’t highlight
any of the shaders in the toolbar, but selecting a default
shader from either the palette or the toolbar activates the
shader and highlights the icon in the toolbar.
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Default Shaders Toolbar Controls

Control Type What it does Notes

button Selects the default Current Channel
shader from the Shaders palette and
displays only the paint in the current
channel.

button Selects the default Current Layer and
Below shader from the Shaders palette
and displays only the paint in the current
layer stack.

button Selects the default Current Layer shader
from the Shaders palette and displays
only the paint in the current layer.

button Selects the default Current Paint Target
shader from the Shaders palette and
displays only the paint of the currently
selected target.
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20 Status Bar
The status bar and descriptions of all the controls on it can be found in the tables below.

What it looks like What it does

Displays status icons that indicatewhich features are active, whether an error
has been encountered, and information about the current project. This
includes progress bars on running processes.

Status Bar Icons

Icon What it does Notes

Displays theUDIM number of the patch you have selected. If
nothing is selected, then there is nothing listed afterUdim.

Notifies you that there is paint to bake. Click on the icon to bake.

Notifies you that background jobs are currently running. Clicking on this icon displays a
dialog for the progress bar.

Notifies you that the project has changed and allows you to
save.

Click on the icon to save changes.

Notifies you that your painting is hidden.

Notifies you that colormanagement is active.

Notifies you that you are currently projecting on the front of
objects.

Clicking on this icon toggles
between projecting through
objects and projecting on the front
of objects. The icon takes the
default icon’s placewhen switching
to project through.
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Icon What it does Notes

Notifies you that you currently have edgemasking enabled. Clicking on this icon disables edge
masking.

Notifies you that you currently have channelmasking enabled. Clicking on this icon disables
channelmasking.

Notifies you that you currently have ambient occlusionmasking
enabled.

Clicking on this icon disables
ambient occlusionmasking.

Notifies you that you currently have depthmasking enabled. Clicking on this icon disables depth
masking.

Notifies you that you currently have backfacemasking enabled. Clicking on this icon disables
backfacemasking.

Notifies you that you currently have fractal noisemasking
enabled.

Clicking on this icon disables fractal
noisemasking.

Notifies you that you currently have the globalmask preview
enabled.

Clicking on this icon disables the
globalmask preview.

Notifies you whether you are in LDR (LowDynamic Range) or
HDR (High Dynamic Range) mode.

Clicking on this icon toggles
between LDR and HDR. When in
HDRmode, the icon appears as

.

Warns you that a lowmemory status has been detected. Low
memory affectsMari’s performance andmay make it unstable.

Try freeingmemory or closing and
restartingMari to clear this issue.

Notifies you that there arewarningmessages present. Clicking on this icon displays these
warnings.

Warns you that the cache disk is critically full. If you don’t free disk space, data
lossmay occur. A simpleway to
free disk space is to close the
project and re-open it. Mari saves
your session history, but closing
your project clears this used disk
space up for use.

Warns you that there is no disk space left for the operation you
are trying to run.
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Icon What it does Notes

Warns you that channels are a higher bit-depth than what the
virtual texture is configured for.

Notifies you that Mari is currently loading data from the disk.

Notifies you that Mari is currently loading data from the RAM to
GPU memory.

Notifies you that Mari is listening for commands on [COMPUTER
NAME] port [PORTNUMBER].

Hovering over this icon displays
the computer name and port
number on whichMari is listening
for commands.

Notifies you that therewas an error whileMari was listening for
commands.

Notifies you that Nuke is connected to send commands to Mari
on [COMPUTER NAME] port [PORTNUMBER].

Hovering over this icon displays
the computer name and port
number fromwhich Nuke is
connected.
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21 Channels Palette
TheChannels palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
TheChannels palette displays:

• a list of channels in the project,

• buttons to add, duplicate, convert, or remove channels,

• options for creating quick channels, and

• channel attribute information.

Channels provide a foundation that layers and layered shaders are built on. These channels can be diffuse, bump, or
specular channels, to name only a few. Channels are assigned to lighting shaders, and sliders in that palette give you
fine control over aspects of each channel.

Channels Palette Fields

Control Type What it does Dialog Notes

button Adds a new channel to the channels list. Add Channel
Dialog

button Converts the channel into either 8bit (Byte),
16bit (Half), 32bit (Float).

Convert Type
Dialog

button Removes the channel.
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Control Type What it does Dialog Notes

Quick Channel

|

swatch Creates a channel filled in black.

The created channel is namedQuick Channel.
If there aremultiple Quick Channels, then the
name is followed with a number.

Quick Channel

|

swatch Creates a channel filled in white.

The created channel is namedQuick Channel.
If there aremultiple Quick Channels, then the
name is followed with a number.

Quick Channel

|

swatch Creates a channel filled inmid-gray.

The created channel is namedQuick Channel.
If there aremultiple Quick Channels, then the
name is followed with a number.

Quick Channel

|

swatch Creates a channel filled in transparent.

The created channel is namedQuick Channel.
If there aremultiple Quick Channels, then the
name is followed with a number.

Quick Channel
|

dropdown Sets the channel size used when creating a
Quick Channel, from the options:

• 256x256

• 512x512

• 1024x1024

• 2048x2048

• 4096x4096

• 8192x8192

• 16384x16384

• 32768x32768

Ensure this is
set to the size
you want
before
creating Quick
Channels.
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Control Type What it does Dialog Notes

Quick Channel
|

dropdown Sets the channel depth used when creating a
Quick Channel, from the options:

• 8bit (Byte)

• 32bit (Float)

• 16bit (Half)

Ensure this is
set to the
depth you
want before
creating Quick
Channels.

button Opens an individual palette that displays the
layers of that channel only.

button Indicates an unlocked state. Clicking the icon
changes the channel state to locked.

button Indicates a locked state. Clicking the icon
changes the channel state to unlocked.

button Adds user attributes for the channel.

<channel
name> >
General | File
Space

information Sets whether the channel isNormal, Vector,
Vector (flipped Y)

<channel
name> >
General | Color
Space

information Sets whether the channel is Color or Scalar.

<channel
name> >
General | Size

information Lists the size of the patches in the channel.

<channel
name> >
General |
Depth

information Lists the color depth of the channel.
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22 Layers Palette
The Layers palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Layers palette lets you view, create and edit layers. You can also add the following to individual layers, or layer
groups:

• masks

• adjustments

• procedurals

• shader layers

NOTE: For shader layers, the fields that are available to each shader are the same as those in the Shaders
Palette chapter.
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Layers Palette Fields

Control Type What it does Notes

dropdown,
switch

Filter bar function that gives the choices:
Name, Type,Attribute, and Color Tag.
Depending on which filter option you select,
the filter bar shows one of the
following:

• - filter for the type of layers by
clicking on the associated icons.

• - filter for the
attributes of layers by clicking on the
associated icons.

• - filter for the color
tags of the selected color icon.

Both Type and Attribute
provide icons that allow you
to set the parameters for
your filter.

Quickly clear the entry box

by pressing the icon.

dropdown Click to select from the blendmode options
available for individual layers. To adjust the
blend amount, enter the value into the entry
box, or adjust the slider located to the right of
the blendmodemenu.

• - adjusts the
blendmode amount.

This list does not include the
advanced blendmode
options.

button Opens theAdvanced Blendingmenu, which
gives options for blendmodes and
components, as well as blend amount.

icon Click to toggle the selected layers’ visibility on
the canvas.

icon Denotes whether the layer is a paint layer and,
when lit, whether it is selected as the current
paint target.
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Control Type What it does Notes

icon Denotes whether the layer is amask layer and,
when lit, whether themask is selected as the
current paint target.

Shift+click on themask to
disable it, or right-click on
the layer and select Layer
Mask > Disable Mask. The

disabledmask icon
indicates the disabled state.

To enable it, Shift+click on
themask again or select
Layer Mask > Enable
Mask from the right-click
menu.

icon Denotes whether the layer has amask stack
and, when lit, whether themask stack is
selected as the current layer.

Clicking on the icon opens
themask stack palette.

icon Denotes whether the layer is an adjustment
layer, or has an adjustment as part of the layer
and, when lit, whether the adjustment is
selected as the current layer.

To distinguish whether the
layer is an adjustment layer
or simply has an
adjustment on it, look for
the position of the icon. If
the icon is in the left-most

column, where the icon
is normally
located on paint layers, then
the layer is an
adjustment layer.

icon Denotes whether the layer is a procedural
layer and, when lit, whether the procedural is
selected as the current layer.

icon Denotes whether the layer is the parent layer
of a group.
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Control Type What it does Notes

icon Locks or unlocks the selected layer. If the layer
is the parent of a group of layers, all the layers
in the group are also locked or unlocked.
Clicking the padlock icon when a layer is
cached also unlocks it.

button Adds a new paint layer to the layer stack.

button Adds amask to the selected layer or, if none is
selected, the top layer in the layer stack.

If amask has already been
added to a layer, you
cannot add a secondmask
using thismethod. You
must create amask stack
using the right-click menu.

button Adds amask stack to the selected layer, or if
none is selected, the top layer in the layer
stack.

Clicking on themask stack
icon opens themask stack
palette.

button Adds an adjustment layer to the layer stack. Select adjustments from the
dropdownmenu when you
click the icon.

button Adds an adjustment stack to the selected
layer.

Select adjustments from the
dropdownmenu when you
click the icon. Clicking on the
adjustment stack icon
opens the adjustment stack
palette.

button Adds a procedural layer to the layer stack. Select procedurals from the
dropdownmenu when you
click the icon.

button Adds a parent layer for a group to the layer
stack. Additional layers can be added after the
parent layer is created.
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Control Type What it does Notes

button Duplicates the selected layer in the layer stack. The duplicate has "copy"
included in the name so that
it can be differentiated from
the original.

button Removes the selected layer from the layer
stack.

button Assigns a color to the selected layers. To clear
an already assigned color, click the icon and
select the gray color in the center of the
palette. This effectively removes the color and
returns it to the default color state.

Adjustment/Brightness

Brightness entry box,
slider

Controls the brightness of the paint on the
model.

Adjustment/Brightness Lookup

Map curve editor Adjusts the brightness to a specific lookup
value using a curvemap.

Adjustment/Clamp

Min entry box,
slider

Clamps theminimumRGB value for the
selected checkboxes below.

Max entry box,
slider

Clamps themaximumRGB value for the
selected checkboxes below.

Components | R checkbox If enabled, specifies that the red channel
should be affected by theMin andMax
sliders.

Components |G checkbox If enabled, specifies that the green channel
should be affected by theMin andMax
sliders.
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Control Type What it does Notes

Components |B checkbox If enabled, specifies that the blue channel
should be affected by theMin andMax
sliders.

Components |A checkbox If enabled, specifies that the alpha channel
should be affected by theMin andMax
sliders.

Adjustment/Color Balance

Preserve
Luminosity

checkbox Ensures that the luminosity value is
maintained when other values are adjusted.

Highlights |
Cyan/Red

entry box,
slider

Adjusts the scale of the Red color component.
Dragging the slider to the left pulls the scale
towards cyan, whereas dragging the slider to
the right pulls it towards red. Themodification
applies to the texture’s highlights.

Highlights |
Magenta/Green

entry box,
slider

Adjusts the Green color component. Dragging
the slider to the left pulls the scale towards
magenta, whereas dragging the slider to the
right pulls it towards green. Themodification
applies to the texture’s highlights.

Highlights |
Yellow/Blue

entry box,
slider

Adjusts the Blue color component. Dragging
the slider to the left pulls the scale towards
yellow, whereas dragging the slider to the right
pulls it towards blue. Themodification applies
to the texture’s highlights.

Shadows |
Cyan/Red

entry box,
slider

Adjusts the scale of the Red color component.
Dragging the slider to the left pulls the scale
towards cyan, whereas dragging the slider to
the right pulls it towards red. Themodification
applies to the texture’s shadows.
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Control Type What it does Notes

Shadows |
Magenta/Green

entry box,
slider

Adjusts the Green color component. Dragging
the slider to the left pulls the scale towards
magenta, whereas dragging the slider to the
right pulls it towards green. Themodification
applies to the texture’s shadows.

Shadows |
Yellow/Blue

entry box,
slider

Adjusts the Blue color component. Dragging
the slider to the left pulls the scale towards
yellow, whereas dragging the slider to the right
pulls it towards blue. Themodification applies
to the texture’s shadows.

Midtones |
Cyan/Red

entry box,
slider

Adjusts the scale of the Red color component.
Dragging the slider to the left pulls the scale
towards cyan, whereas dragging the slider to
the right pulls it towards red. Themodification
applies to the texture’smidtones

Midtones |
Magenta/Green

entry box,
slider

Adjusts the Green color component. Dragging
the slider to the left pulls the scale towards
magenta, whereas dragging the slider to the
right pulls it towards green. Themodification
applies to the texture’smidtones

Midtones |
Yellow/Blue

entry box,
slider

Adjusts the Blue color component. Dragging
the slider to the left pulls the scale towards
yellow, whereas dragging the slider to the right
pulls it towards blue. Themodification applies
to the texture’smidtones.

Adjustment/Color Lookup

Red curve editor Adjusts the value of the red channel for the
overall layer stack, using the curve editor.

Green curve editor Adjusts the value of the green channel for the
overall layer stack, using the curve editor.

Blue curve editor Adjusts the value of the blue channel for the
overall layer stack, using the curve editor.
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Control Type What it does Notes

Adjustment/Color Switch

Red checkbox Turns the red channel on or off. Disabling the
red channel removes it from the painting.

Green checkbox Turns the green channel on or off. Disabling
the green channel removes it from the
painting.

Blue checkbox Turns the blue channel on or off. Disabling the
blue channel removes it from the
painting.

Alpha checkbox Turns the alpha channel on or off. Disabling
the alpha channel removes it from the
painting.

Adjustment/Color to Mask

Color swatch Select a color from the color picker to convert
that color to amask. This allows amulti-
colored channel to be used formultiplemasks.

Error entry box,
slider

The tolerance level of themask to the selected
color. The lower the number, the closer the
RGB value has to be to the selected color in
order for it to be treated as amask; the higher
the number, themore variation that's allowed.

Adjustment/Contrast

Contrast entry box,
slider

Adjusts the contrast for the layer stack.

Contrast Pivot entry box,
slider

Sets the point around which Contrast is
adjusted.

Adjustment/Copy Channel
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Channel dropdown Copies the value fromone RGB color channel
to the other two. The result is a grayscale
imagewith the intensity values from the
selected channel.

Adjustment/Gamma

Gamma entry box,
slider

Adjusts the gamma levels in the layer stack.

Invert entry box,
slider

Reverses the gamma conversion. That is, a
higher setting forGamma results in amore
washed-out looking image.

Adjustment/Grade

Blackpoint entry box,
slider

Sets the blackpoint of the RGB values. Blackpoint is the color value
at which the input is
considered to be 100%
black.

Whitepoint entry box,
slider

Sets thewhitepoint of the RGB values. Whitepoint is the color value
at which the input is
considered to be 100%
white.

Lift entry box,
slider

Lifts the blackpoint, while keeping the
whitepoint the same.

Gain entry box,
slider

Adjusts thewhitepoint, while keeping the
blackpoint the same

Multiply entry box,
slider

Multiplies the value to lighten the texturewhile
preserving the blackpoint.

Offset entry box,
slider

Specifies a fixed value to add in order to
lighten the texture.

Adding negative values
essentially darkens the
texture.

Gamma entry box,
slider

Adjusts themidtones, while keeping the
whitepoint and blackpoint the same.
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Adjustment/HSL

Hue Shift entry box,
slider

Adjusts the hue, as tied to theHSL, for the
layer stack.

Saturation Scale entry box,
slider

Adjusts the saturation level, as tied to theHSL,
for the layer stack.

Lightness Scale entry box,
slider

Adjusts the lightness level, as tied to theHSL,
for the layer stack.

Adjustment/HSV

Hue Shift entry box,
slider

Adjusts the hue level, as tied to theHSV, for
the layer stack.

Saturation Scale entry box,
slider

Adjusts the saturation level, as tied to theHSV,
for the layer stack.

Value Scale entry box,
slider

Adjusts the value level, as tied to theHSV, for
the layer stack.

Adjustment/Height As Normal

Bump Weight entry box,
slider

Adjusts the sensitivity of the bumpweight
when calculating height as a normal value.

Adjustment/Hue Shift

Hue entry box,
slider

Changes the RGB hue value of the paint in the
layer stack.

Adjustment/Invert

Red checkbox Inverts the contents of the red color
component when checked. Uncheck the
parameter to leave the component
unchanged. If there is a significant amount of
red paint in your layer stack the inverse is a
significant absence of red.

It is uncommon that only
one component would be
selected, however if the
need arises, you can choose
to invert only one, or a
subset, of the four
components.
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Green checkbox Inverts the contents of the green color
component when checked. Uncheck the
parameter to leave the component
unchanged. If there is a significant amount of
green paint in your layer stack the inverse is a
significant absence of green.

It is uncommon that only
one component would be
selected, however if the
need arises, you can choose
to invert only one, or a
subset, of the four
components.

Blue checkbox Inverts the contents of the blue color
component when checked. Uncheck the
parameter to leave the component
unchanged. If there is a significant amount of
blue paint in your layer stack the inverse is a
significant absence of blue.

It is uncommon that only
one component would be
selected, however if the
need arises, you can choose
to invert only one, or a
subset, of the four
components.

Alpha checkbox Inverts the contents of the alpha color
component when checked. Uncheck the
parameter to leave the component
unchanged.

It is uncommon that only
one component would be
selected, however if the
need arises, you can choose
to invert only one, or a
subset, of the four
components.

Adjustment/Levels

Red checkbox Determines whether to apply the adjustment
to the red component.

Green checkbox Determines whether to apply the adjustment
to the green component.

Blue checkbox Determines whether to apply the adjustment
to the blue component.

Output Level |
WhiteOut

entry box,
slider

Adjusts thewhite level of the output in the
paint for the selected color components.

Output Level |
BlackOut

entry box,
slider

Adjusts the black level of the output in the
paint for the selected color component.
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Input Level |White entry box,
slider

Adjusts thewhite level of the input for the
selected color component.

Input Level |Mid entry box,
slider

Adjusts themidtone level of the input for the
selected color components.

Input Level |Black entry box,
slider

Adjusts the black level of the input for the
selected color component.

Adjustment/Luminosity

Adjustment/Premultiply Alpha

Unpremultiply checkbox Either pre- or post-multiplies the alpha in the
selected image. If you are painting using an
imagewithout pre-multiplied alpha onto one
with it, use this filter to perform the
pre-multiplication, so the imagesmatch and
you avoid lines around the outside of the
patch. Post-multiply works the same, but in
reverse: it removes pre-multiplication to match
images that do not have pre-multiplied alpha.

Adjustment/Saturation

Saturation entry box,
slider

Adjusts the color saturation of the paint in the
layer stack.

Adjustment/Scale

R entry box,
slider

Adjusts the scale of the Red color component.
Dragging the slider to the left pulls the scale
towards cyan, whereas dragging the slider to
the right pulls it towards red.

G entry box,
slider

Adjusts the Green color component. Dragging
the slider to the left pulls the scale towards
magenta, whereas dragging the slider to the
right pulls it towards green.
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B entry box,
slider

Adjusts the Blue color component. Dragging
the slider to the left pulls the scale towards
yellow, whereas dragging the slider to the right
pulls it towards blue.

A entry box,
slider

Adjusts the Alpha component.

Adjustment/Set Value

Channel dropdown The options available in the dropdownmenu
are Red, Green, Blue, Alpha.

Value entry box,
slider

Adjusting the slidermodifies the value of the
component selected from the dropdown
menu above.

Adjustment/Shuffle

R dropdown Select a color component from the options r,
g, b, and a in the dropdownmenu to replace
the Red component with another color.
Setting r in the dropdownmenu keeps the red
color in the Red component.

G dropdown Select a color component from the options r,
g, b, and a in the dropdownmenu to replace
theGreen component with another color.
Setting g in the dropdownmenu keeps the
green color in theGreen component.

B dropdown Select a color component from the options r,
g, b, and a in the dropdownmenu to replace
the Blue component with another color.
Setting b in the dropdownmenu keeps the
blue color in the Blue component.
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A dropdown Select a color component from the options r,
g, b, and a in the dropdownmenu to replace
the Alpha component with another color.
Setting a in the dropdownmenu keeps the
alpha color in the Alpha component.

Adjustment/Tangent To Screen

Suppress Blue checkbox Suppresses the blue value from the
color-encoded vectors in screen space.

Adjustment/Tangent To World

Suppress Blue checkbox Suppresses the blue value from the
color-encoded vectors in world space.

Adjustment/World To Tangent

Suppress Blue checkbox Suppresses the blue value from the
color-encoded vectors in world space.

Flip Y dropdown Choosewhether to Flip the Y axis normals or
leave them as they arewith normal.

Adjustment/sRGB2Linear

Invert checkbox Applies an sRGB to linear colorspace
conversion. Checking Invert applies a linear to
sRGB colorspace conversion.

Procedural/Basic/Color

Color swatch Applies the specified color from the color
swatch to the entiremodel.

Procedural/Basic/Constant

Constant entry box,
slider

Generates a constant number across theRGB
orRGBA components that may be relied upon
formathematical operations.

This number ranges from 0
to 10,000, and defaults to
1.000.

Components dropdown Choosewhether the contact applies to the
RGB orRGBA components.
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Procedural/Basic/Vector

X entry box,
slider

Adjusts the values of the X axis, which
correspond to the Red color component, to
modify the color-encoded vectors.

Y entry box,
slider

Adjusts the values of the Y axis, which
correspond to theGreen color component, to
modify the color-encoded vectors.

Z entry box,
slider

Adjusts the values of the Z axis, which
correspond to the Blue color component, to
modify the color-encoded vectors.

W entry box,
slider

Adjusts the values of theW axis, which
correspond to the Alpha component, to
modify the color-encoded vectors.

Procedural/ Environment/Cubemap

Cubic Image entry box,
file browser

The environment image you want to be
reflected.

This procedural cannot be
cached or baked and is for
display purposes only.

Falloff Start entry box,
slider

Specifies where the cubic image starts.

Falloff End entry box,
slider

Specifies where the cubic image ends.

Procedural/ Environment/Cubemap Projector

Cubic Image entry box,
file browser

Select or input the filepath to the .dds cubic
image to project as a texture.

This procedural cannot be
cached or baked and is for
display purposes only.

Cull Backfaces checkbox When the checkbox is ticked, this setting
ensures that projection does not affect areas
facing away from the camerawhen factoring
edge falloff.
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Offset | X entry box,
incrementer

The offset of the projected image along theX
axis. This affects the position of where the
camera sits in the scene.

Offset | Y entry box,
incrementer

The offset of the projected image along the Y
axis. This affects the position of where the
camera sits in the scene.

Offset | Z entry box,
incrementer

The offset of the projected image along the Z
axis. This affects the position of where the
camera sits in the scene.

Rotation | X entry box,
slider

The rotation of the projected image along the
X axis.

This rotates the camera for
the entire scene, not just
one part.

Rotation | Y entry box,
slider

The rotation of the projected image along the
Y axis.

This rotates the camera for
the entire scene, not just
one part.

Rotation | Z entry box,
slider

The rotation of the projected image along the
Z axis.

This rotates the camera for
the entire scene, not just
one part.

Edge Falloff | Start entry box,
slider

Modifies how far away the projection falloff
starts on themodel.

Edge Falloff | End entry box,
slider

Modifies how far away the projection falloff
ends on themodel.

Edge Falloff |
Curve

curve editor Modifies the otherwise linear shape of the
edge falloff to your desired shape.

Distance Falloff |
Start

entry box,
incrementer

Modifies the falloff start distance. From
0-100; 100 represents straight-on projection.

Distance Falloff |
End

entry box,
incrementer

Modifies the falloff end distance. From 0-100;
100 represents straight-on projection.

Distance Falloff |
Curve

curve editor Modifies the otherwise linear shape of the
distance falloff to your desired shape.
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Procedural/Environment/Sphere Map

SphereMap file browser The environment image you want to be
reflected.

This procedural cannot be
cached or baked and is for
display purposes only.

FalloffStart entry box,
slider

Specifies where the spherical image starts.

FalloffEnd entry box,
file browser

Specifies where the spherical image ends.

Procedural/Environment/Sphere Map Projector

Spherical Image file browser Uses a spherical image of any file type as a
texture to project onto themodel. Select the
filepath to the spherical image to project as a
texture.

Cull Backfaces checkbox When the checkbox is ticked, this setting
ensures that projection does not affect areas
facing away from the camerawhen factoring
edge falloff.

Offset | X entry box,
incrementer

The offset of the projected image along theX
axis. This affects the position of where the
camera sits in the scene.

Offset | Y entry box,
incrementer

The offset of the projected image along the Y
axis. This affects the position of where the
camera sits in the scene.

Offset | Z entry box,
incrementer

The offset of the projected image along the Z
axis. This affects the position of where the
camera sits in the scene.

Rotation | X entry box,
slider

The rotation of the projected image along the
X axis.

This rotates the camera for
the entire scene, not just
one part.
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Rotation | Y entry box,
slider

The rotation of the projected image along the
Y axis.

This rotates the camera for
the entire scene, not just
one part.

Rotation | Z entry box,
slider

The rotation of the projected image along the
Z axis.

This rotates the camera for
the entire scene, not just
one part.

Edge Falloff | Start entry box,
slider

Modifies how far away the projection falloff
starts on themodel.

Edge Falloff | End entry box,
slider

Modifies how far away the projection falloff
ends on themodel.

Edge Falloff |
Curve

curve editor Modifies the otherwise linear shape of the
edge falloff to your desired shape.

Distance Falloff |
Start

entry box,
incrementer

Modifies the falloff start distance. From
0-100; 100 represents straight-on projection.

Distance Falloff |
End

entry box,
incrementer

Modifies the falloff end distance. From 0-100;
100 represents straight-on projection.

Distance Falloff |
Curve

curve editor Modifies the otherwise linear shape of the
distance falloff to your desired shape.

Procedural/Environment/Triplanar Projection

World Scale entry box Gives overall scale control for the image
projection.

Top | Top Image file browser Specifies the location of the image you want to
project onto the top of yourmodel.

Top | Top Repeat entry box,
slider

Specifies the frequency at which the image is
repeated across the top of yourmodel.

Top | Top Angle entry box,
slider

Specifies the rotation angle of the image on
the top of yourmodel.

Top | Top U
Offset

entry box,
slider

Specifies howmuch the image on the top of
yourmodel is offset by on theU axis.
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Top | Top V Offset entry box,
slider

Specifies howmuch the image on the top of
yourmodel is offset by on the V axis.

Top | Top U Scale entry box,
slider

Specifies howmuch the image on the top of
yourmodel is stretched or contracted on theU
axis.

Top | Top V Scale entry box,
slider

Specifies howmuch the image on the top of
yourmodel is stretched or contracted on the V
axis.

Top | Top Falloff
Start

entry box,
slider

Controls where the image projection starts on
the top of themodel.

Top | Top Falloff
End

entry box,
slider

Controls where the image projection ends on
the top of themodel.

Top | Top Falloff curve editor Controls the falloff of the image projection
between the start and end values on the top
of themodel.

Front | Front
Image

file browser Specifies the location of the image you want to
project onto the front of yourmodel.

Front | Front
Repeat

entry box,
slider

Specifies the frequency at which the image is
repeated across the front of yourmodel.

Front | Front
Angle

entry box,
slider

Specifies the rotation angle of the image on
the front of yourmodel.

Front | Front U
Offset

entry box,
slider

Specifies howmuch the image on the front of
yourmodel is offset by on theU axis.

Front | Front V
Offset

entry box,
slider

Specifies howmuch the image on the front of
yourmodel is offset by on the V axis.

Front | Front U
Scale

entry box,
slider

Specifies howmuch the image on the front of
yourmodel is stretched or contracted on theU
axis.
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Front | Front V
Scale

entry box,
slider

Specifies howmuch the image on the front of
yourmodel is stretched or contracted on the V
axis.

Front | Front
Falloff
Start

entry box,
slider

Controls where the image projection starts on
the front of themodel.

Front | Front
Falloff
End

entry box,
slider

Controls where the image projection ends on
the front of themodel.

Front | Front
Falloff

curve editor Controls the falloff of the image projection
between the start and end values on the front
of themodel.

Right | Right
Image

file browser Specifies the location of the image you want to
project onto the side of yourmodel.

Right | Right
Repeat

entry box,
slider

Specifies the frequency at which the image is
repeated across the side of yourmodel.

Right | Right
Angle

entry box,
slider

Specifies the rotation angle of the image on
the side of yourmodel.

Right | Right U
Offset

entry box,
slider

Specifies howmuch the image on the side of
yourmodel is offset by on theU axis.

Right | Right V
Offset

entry box,
slider

Specifies howmuch the image on the side of
yourmodel is offset by on the V axis.

Right | Right U
Scale

entry box,
slider

Specifies howmuch the image on the side of
yourmodel is stretched or contracted on theU
axis.

Right | Right V
Scale

entry box,
slider

Specifies howmuch the image on the side of
yourmodel is stretched or contracted on the V
axis.

Right | Right
Falloff Start

entry box,
slider

Controls where the image projection starts on
the side of themodel.

22 LAYERS PALETTE | LAYERS PALETTE FIELDS



147

Control Type What it does Notes

Right | Right
Falloff End

entry box,
slider

Controls where the image projection ends on
the side of themodel.

Right | Right
Falloff

curve editor Controls the falloff of the image projection
between the start and end values on the side
of themodel.

Procedural/Geometry/Ambient Occlusion

Procedural/Geometry/Position

Procedural/Geometry/Surface Normal

Procedural/Geometry/UDIM Mask

UDIM entry box Enter theUDIM number of the UDIM you
want to unmask.

Procedural/Geometry/UV

Procedural/Procedural/Fractal/ Cloud

Size entry box,
slider

Adjusts the size of the cloud pattern.

Roughness entry box,
slider

Adjusts the roughness of the cloud pattern.
Dragging the slider to lower values smooths
out the transition from color A to color B.

Offsets | X Offset entry box,
slider

Moves the pattern across themodel on the x
axis.

Offsets | Y Offset entry box,
slider

Moves the pattern across themodel on the y
axis.

Offsets | Z Offset entry box,
slider

Moves the pattern across themodel on the z
axis.

Color | Color A swatch Sets the color to be used for the pattern’s A
input.

Color | Color B swatch Sets the color to be used for the pattern’s B
input.
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Procedural/Procedural/Fractal/Turbulence

Size entry box,
slider

Adjusts the size of the turbulence pattern.

Roughness entry box,
slider

Adjusts the roughness of the turbulence
pattern. Dragging the slider to lower values
smooths out the transition from color A to
color B.

Color | Color A swatch Sets the color to be used for the pattern’s A
input.

Color | Color B swatch Sets the color to be used for the pattern’s B
input.

Procedural/Procedural/Misc/Flow

Animation |
Animated

checkbox Enables or disables the animation.

Animation | Time
Offset

entry box,
slider

Adjusts the flow over time to view the effect of
vector paint.

Animation | Speed entry box,
slider

Adjusts the sensitivity of Time Offset to
affect the speed of flow.

Image | Tile
Image

file browser Selects the image to use on themodel for flow.

Image | Repeat entry box,
slider

Sets the repetition value of the tiled image.

Procedural/Procedural/Misc/Oil

Size entry box,
slider

Adjusts the size of the oil pattern.

Organicness entry box,
slider

Sets the overall organic quality of the oil
pattern.
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Roughness entry box,
slider

Adjusts the roughness of the oil pattern.
Dragging the slider to lower values smooths
out the transition from color A to color B.

Color | Color A swatch Sets the color to be used for the pattern’s A
input.

Color | Color B swatch Sets the color to be used for the pattern’s B
input.

Procedural/Procedural/Noise/Cellular

Size entry box,
slider

Adjusts the size of the cellular pattern.

Type dropdown Sets how color A and color B are used in the
pattern.

Distance Method dropdown Changes the shape of the cells to affect the
distance the cells are from each other.

Color | Color A swatch Sets the color to be used to the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.

Procedural/Procedural/Noise/Perlin

Size entry box,
slider

Adjusts the size of the noise pattern.

Color | Color A swatch Sets the color to be used for the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.

Procedural/Procedural/Noise/Squiggle

Size entry box,
slider

Adjusts the size of the squiggle pattern.
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Color | Color A swatch Sets the color to be used for the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.

Procedural/Procedural/ Pattern/Cube

Repeat entry box,
slider

Specifies the repetition frequency of the cube
pattern.

Gap entry box,
slider

Sets the spacing between the cubes in the
pattern.

Fall Off entry box,
slider

Adjusts the falloff amount between the cubes.

Roundness entry box,
slider

Adjusts howmuch the cubes are rounded off.

Color | Color A swatch Sets the color to be used for the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.

Procedural/Procedural/Pattern/Object Space Linear Gradient

Start entry box,
slider

Sets the start point on the object for Color B of
the gradient.

End entry box,
slider

Sets the end point of Color B, where Color A
begins, on the object of the gradient.

Map curve editor Set the color A and color B transitions for the
gradient using points on a curve.

Rotation | X entry box,
slider

Adjusts how the gradient appears on the
model by rotating the gradient on the X axis.

Rotation | Y entry box,
slider

Adjusts how the gradient appears on the
model by rotating the gradient on the Y axis.
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Rotation | Z entry box,
slider

Adjusts how the gradient appears on the
model by rotating the gradient on the Z axis.

Color | Color A swatch Sets the color to be used for the gradient’s A
input.

Color | Color B swatch Sets the color to be used for the gradient’s B
input.

Procedural/Procedural/Pattern/Sphere

Size entry box,
slider

Adjusts the size of the spherical pattern.

Falloff curve editor Adjusts the falloff amount between the
spheres.

Color | Color A swatch Sets the color to be used for the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.

Procedural/Procedural/Pattern/Tiled

Tile Image file browser The image you want to have tiled across the
model.

Rotation Angle
(Degrees)

entry box,
slider

Changes the angle of rotation for the tiled
image.

Offset |U Offset entry box,
slider

Specifies howmuch the image is offset by on
theU axis.

Offset | V Offset entry box,
slider

Specifies howmuch the image is offset by on
the V axis.

Repeat |U Repeat entry box,
slider

Specifies howmuch the image is repeated on
theU axis.

Repeat | V Repeat entry box,
slider

Specifies howmuch the image is repeated on
the V axis.
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Mirror |Mirror U entry box,
slider

Sets whether the tiled image ismirrored on the
U axis.

Mirror |Mirror V entry box,
slider

Sets whether the tiled image ismirrored on the
V axis.

Procedural/Procedural/Pattern/UV Grid

Color swatch Sets the color to be used for the grid lines.

Repeat entry box,
slider

Specifies the repeat rate for the grid on the
model’s surface.

Thickness entry box,
slider

Sets the thickness of the grid lines.

Procedural/Procedural/Pattern/UV Linear Gradient

Start entry box,
slider

Sets the start point on theUV patches for
Color B of the gradient.

End entry box,
slider

Sets the end point of Color B, where Color A
begins, on theUV patches of the gradient.

Map curve editor Set the color A and color B transitions for the
gradient in UV space using points on a curve.

Angle entry box,
slider

Specifies the angle of the linear gradient on the
UV patches.

Repeat entry box,
slider

Sets howmuch the linear gradient is repeated
across theUV patches.

Color | Color A swatch Sets the color to be used for the gradient’s A
input.

Color | Color B swatch Sets the color to be used for the gradient’s B
input.

Procedural/Procedural/Plant/Wood

Size entry box,
slider

Adjusts the size of thewood pattern across the
entiremodel.
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Bands entry box,
slider

Adjusts the size of the individual bands in the
wood pattern.

Noise | Size entry box,
slider

Adjusts the amount of the noise in the bands
of thewood pattern.

Noise |
Roughness

entry box,
slider

Adjusts the roughness of thewood pattern.
Dragging the slider to lower valuesmakes the
transition from color A to color B more
distinct.

Stretch | X entry box,
slider

Stretches thewood pattern across themodel
on the x axis.

Stretch | Y entry box,
slider

Stretches thewood pattern across themodel
on the y axis.

Stretch | Z entry box,
slider

Stretches thewood pattern across themodel
on the z axis.

Color | Color A swatch Sets the color to be used for the pattern’s color
A input.

Color | Color B swatch Sets the color to be used for the pattern’s color
B input.
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23 Patches Palette
The Patches palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Patches palette displays a selectable list of patches in the project, with icons and buttons to toggle whether they
are visible, or whether they are locked. You can group patches into sets.

Patches palette fields

Control Type What it does Opens this
dialog box

Notes

Sorted by dropdown Lets you specify whether to list patches
by: UDIM, or a custom sort (by dragging
patches up and down the list).

icon Click to toggle whether a patch is visible or
not.

icon Click to toggle whether a patch is locked or
not.

button Hide selected patches.

button Show selected patches.

button Select all patches.

button Lock selected patches.
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Control Type What it does Opens this
dialog box

Notes

button Unlock selected patches.

button Link selected patches.

This allows you to replicate changesmade
to one patch onto all linked patches
quickly and easily.

button Unlink selected patches.
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24 Objects Palette
TheObjects palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
TheObjects palette displays the current objects in the project, and allows you to:

• Show and hide the objects.

• Add and remove objects from the project.

• Lock and unlock the objects.

• Select the object to edit.

• Add versions to existing objects.

Objects palette fields

Control Type What it does Notes

Sorted by dropdown Lets you specify whether to list the objects
by name , version number, or none.

icon Click to toggle whether an object is visible
or not.

icon Click to toggle whether an object is locked
or not.

button Add another object to the project.

button Removes the selected object from the
project.
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Control Type What it does Notes

button Allows you to add user attributes to the
selected object.

<object name> > Geometry |
Version

dropdown List of versions of the object, listed by the
name of the source file. When you select a
version from this list, Mari updates to show
that version in the display.

<object name> > Info |Name text The name of the object file. You can edit this
if required.

<object name> > Rendering | Cast
Shadows

checkbox Specify whether or not the object is set to
cast shadowswhenDepth Projections
are enabled and toggle shadows is set to
show themon the canvas.

<object name> > State |Hidden checkbox Whether the object is hidden.

<object name> > State | Locked checkbox Whether the object is locked or editable.

<object name> > UserAttributes |
Created

info The creation date of themodel file.

<object name> > UserAttributes |
Modified

info The last modification date of themodel file.

<object name> > UserAttributes |
Owner

info The user whomade the last edit to the
model file.
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25 Shaders Palette
The Shaders palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Shaders palette displays the lighting shaders and allows you to toggle between the shader setup for the current
channel, layer stack, layer, and paint target, as well as custom-made shaders.

Shaders Palette Fields

Control Type What it does Dialog Notes

Current
Channel

shader Default shader that displays only the
paint in the selected channel.

This shader can
also be found on
theDefault
Shaders toolbar.

Current Layer
and Below

shader Default shader that displays only the
paint in your selected sub-stack (such
as amask or adjustment stack) up to
the selected layer. If you don’t have a
sub-stack selected, it shows the parent
stack up to the selected layer.

This shader can
also be found on
theDefault
Shaders toolbar.

Current Layer shader Default shader that displays only the
paintable paint andmasks in your
selected layer.

This shader can
also be found on
theDefault
Shaders toolbar.
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Control Type What it does Dialog Notes

Current Paint
Target

shader Default shader that displays only the
paint in your selected layer, including
any mask ormask stack, adjustment,
filter or groups associated with the
layer.

This shader can
also be found on
theDefault
Shaders toolbar.

button Adds a new shader or layered shader to
the shader list in the palette from a
dropdownmenu list of:

• Phong

• Cook Torrance

• Beckman

• Blinn

• Flat

• sRGB Lighting

• BRDF

• Standard Lighting

• Layered , and

• Choose Diffuse And Specular.

Create Shader
Dialog when
selecting
Choose
Diffuse and
Specular.

Masks
Formats
Dialog when
selecting
Layered.

TheChoose
Diffuse and
Specular option
allows you to
create a custom
shader. Refer to
the Create Shader
Dialog formore
information.

The Layered
option creates a
layered shader.
When selected, its
layers can be
accessed using the
Shader Layers Tab
Fields.

button Makes a copy of the selected shader.

button Removes the shader from the shader
list in the palette.

Default shaders
cannot be
removed from the
Shaders palette.

button Selects the default Current Channel
shader from the shader list and
displays only the paint in the current
channel.
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Control Type What it does Dialog Notes

button Selects the default Current Layer
and Below shader from the shader list
and displays only the paint in the
current layer stack.

button Selects the default Current Layer
shader from the shader list and
displays only the paint in the current
layer.

button Selects the default Current Paint
Target shader from the shader list and
displays only the paint of the
currently selected target.

Lambertian/Phong

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Shininess

dropdown The channel controlling the high shine
areas for highlights in the specular
shaded surface.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select either aBump or
Normal shader component in the
same shader. If you attempt to use
both,Normal overrides theBump
shader component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.
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Control Type What it does Dialog Notes

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel to be used for the
shader component.

Add Channel
Dialog

Diffuse entry box,
shader

Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Shininess

entry box, slider Howmuch shininess the specularity
appears to have on the shaded
surface.

From 0 to 100;
defaults to 30.

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.
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Control Type What it does Dialog Notes

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher
values equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore
obvious displacements.

From 0 to 10;
defaults to 0.100.

Bump | Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

By default, Bump
Mode is set to
Fast.

Lambertian/Cook Torrance
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Control Type What it does Dialog Notes

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Roughness

dropdown The channel controlling the rough
shaded surface for specularity.

button Inverts the channel values of the
selected channel.

Inputs |
Specular IOR

dropdown The channel controlling the specularity
for the index of refraction. This can be
adjusted to the IOR value of the
desiredmaterial.

button Inverts the channel values of the
selected channel.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select either aBump or
Normal shader component in the
same shader. If you attempt to use
both,Normal overrides theBump
shader component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.
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Control Type What it does Dialog Notes

Inputs |
Ambient
Occlusion

entry box, slider The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

entry box, slider The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Roughness

entry box, slider How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From 0 to 1;
defaults to 0.700.

Specular IOR
Weight

entry box, slider Adjust the IOR to the value of a
specific material, or adjust the slider
until you find the index of refraction
that suits your needs.

From 0 to 5;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.
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Control Type What it does Dialog Notes

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore
obvious displacements.

From 0 to 10;
defaults to 0.100.
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Control Type What it does Dialog Notes

Bump | Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

By default, Bump
Mode is set to
Fast.

Lambertian/Beckman

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Roughness

dropdown The channel controlling the rough
shaded surface for specularity.

button Inverts the channel values of the
selected channel.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select either aBump or
Normal shader component in the
same shader. If you attempt to use
both,Normal overrides theBump
shader component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.
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Control Type What it does Dialog Notes

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Roughness

entry box, slider How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From 0 to 1;
defaults to 0.700.

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.
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Control Type What it does Dialog Notes

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Displacement
Range

entry box Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore obvious
displacements.

From 0 to 10;
defaults to 0.100.

Bump | Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

By default, Bump
Mode is set to
Fast.
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Control Type What it does Dialog Notes

Lambertian/Blinn

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Shininess

dropdown The channel controlling the high shine
areas for highlights in the specular
shaded surface.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select either aBump or
Normal shader component in the
same shader. If you attempt to use
both,Normal overrides theBump
shader component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.
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Control Type What it does Dialog Notes

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Shininess

entry box, slider Howmuch shininess the specularity
appears to have on the shaded
surface.

From 0 to 100;
defaults to 30.

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement|
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore
obvious displacements.

From 0 to 10;
defaults to 0.100.

Bump | Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

By default, Bump
Mode is set to
Fast.

Flat

Inputs | Color dropdown The channel controlling the RGB values
of the shaded surface under flat
lighting.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.
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Control Type What it does Dialog Notes

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

sRGB Lighting

Inputs |
Diffuse Color

dropdown The channel controlling the sRGB
diffuse color effect of the shaded
surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.
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Control Type What it does Dialog Notes

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 1;
defaults to 0.600.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 1;
defaults to 0.200.

Specular
Roughness

entry box, sldier How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From .001 to .999;
defaults to .500.

sRGB checkbox When the checkbox is selected, Mari
changes the output colors from linear
color space to sRGB color space. This
can be used to set up a single shader
that is sRGB, rather than setting the
entire color profile in theColor
Manager palette to sRGB.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

BRDF

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Glossiness

dropdown The channel controlling the glossy
areas for highlights in the specular
shaded surface.

button Inverts the channel values of the
selected channel.

Inputs |
Reflectance

dropdown The channel controlling the reflective
effect of the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).
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Control Type What it does Dialog Notes

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select either aBump or
Normal shader component in the
same shader. If you attempt to use
both,Normal overrides theBump
shader component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 1;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 1;
defaults to 1.

Glossiness entry box, slider How glossy the highlights appear on
the shaded surface. The closer to 1 this
is set, themoremirror-like the shaded
surface appears.

From 0 to 1;
defaults to .200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.
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Reflectance entry box, slider Howmuch of the reflection appears on
the shaded surface. The closer to 1 this
is set, the higher the reflectiveness.

From 0 to 1;
defaults to .200.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 100;
defaults to 1.000.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump |Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore
obvious displacements.

From 0 to 10;
defaults to 1.000.

Bump |Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

Standard Lighting
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Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 1;
defaults to 0.600.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 1;
defaults to 0.200.

Specular
Roughness

entry box, slider How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Layered

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

Displacement|
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement|
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement|
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement|
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

ChooseDiffuse and Specular |Minnaert/Phong

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Shininess

dropdown The channel controlling the high shine
areas for highlights in the specular
shaded surface.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.
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Control Type What it does Dialog Notes

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Youmust select
either aBump or
Normal shader
component in the
same shader. If
you attempt to use
both,Normal
overrides the
Bump shader
component.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Shininess

dropdown Howmuch shininess the specularity
appears to have on the shaded
surface.

From 0 to 100;
defaults to 30.
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Control Type What it does Dialog Notes

Specular dropdown Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Environment dropdown Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Diffuse Falloff entry box, slider Howmuch falloff is given to the diffuse
input.

From 0 to 5;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Displacement
Range

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.
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Control Type What it does Dialog Notes

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore obvious
displacements.

From 0 to 10;
defaults to 0.100.

Bump|Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

ChooseDiffuse and Specular |Minnaert/Cook Torrance

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.

Inputs |
Specular
Roughness

dropdown The channel controlling the rough
shaded surface for specularity.

button Inverts the channel values of the
selected channel.

Inputs |
Specular IOR

dropdown The channel controlling the specularity
for the index of refraction. This can be
adjusted to the IOR value of the
desiredmaterial.

button Inverts the channel values of the
selected channel.
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Control Type What it does Dialog Notes

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select
either aBump or
Normal shader
component in the
same shader. If
you attempt to use
both,Normal
overrides the
Bump shader
component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog
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Control Type What it does Dialog Notes

Diffuse dropdown Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular dropdown Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Roughness

dropdown How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From 0 to 1;
defaults to 0.700.

Specular IOR
Weight

dropdown Adjust the IOR to the value of a
specific material, or adjust the slider
until you find the index of refraction
that suits your needs.

From 0 to 5;
defaults to 1.

Environment dropdown Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Diffuse Falloff entry box, slider Howmuch falloff is given to the
diffuse input.

From 0 to 5;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement |
Displacement
Scale

entry box, slider What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Displacement
Range

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore obvious
displacements.

From 0 to 10;
defaults to 0.100.

Bump|Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

ChooseDiffuse and Specular |Minnaert/Beckman

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.
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Control Type What it does Dialog Notes

Inputs |
Specular
Roughness

dropdown The channel controlling the rough
shaded surface for specularity.

button Inverts the channel values of the
selected channel.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select
either aBump or
Normal shader
component in the
same shader. If
you attempt to use
both,Normal
overrides the
Bump shader
component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.
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Control Type What it does Dialog Notes

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Roughness

entry box, slider How “rough” the surface is by default.
Rougher surfaces have the highlight
spreadmore across the surface. Lower
valuesmean the surface is smoother
(specular lights aremore
concentrated), higher valuesmean it is
rougher (specular lights are spread out
more).

From 0 to 1;
defaults to 0.700.

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Diffuse Falloff entry box, slider Howmuch falloff is given to the diffuse
input.

From 0 to 5;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.
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Control Type What it does Dialog Notes

Displacement |
Displacement
Scale

entry box, slider What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.

Displacement |
Displacement
Range

entry box Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore
obvious displacements.

From 0 to 10;
defaults to 0.100.

Bump|Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).

ChooseDiffuse/Specular |Minnaert/ Blinn

Inputs |
Diffuse Color

dropdown The channel controlling the RGB
diffuse color effect of the shaded
surface.

Inputs |
Specular
Color

dropdown The channel controlling the RGB
specular color effect of the shaded
surface.
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Control Type What it does Dialog Notes

Inputs |
Specular
Shininess

dropdown The channel controlling the high shine
areas for highlights in the specular
shaded surface.

Inputs |
Normal

dropdown The channel used for input as a
representation of the surface normals,
added to the shaded surface.

Youmust select
either aBump or
Normal shader
component in the
same shader. If
you attempt to use
both,Normal
overrides the
Bump shader
component.

Inputs | Bump dropdown The channel controlling the bumpmap
to show as a perturbed lighting.

Inputs |
Environment
Color

dropdown The channel controlling the reflective
surface, using an image in a channel as
the reflection, on the shaded surface.

Inputs |
Ambient
Occlusion

dropdown The channel controlling the ambient
occlusion effect of the shaded surface.
Using this input overrides the ambient
occlusion values stored on the object
(Objects > Ambient Occlusion).

Inputs |
Emissive
Color

dropdown The channel controlling the RGB color
of the emissive (glow) qualities on the
shaded surface.

Inputs |
Vector

dropdown The channel controlling the vector field
and resulting vector data frompaint on
the shaded surface.

This data is used
by the vector
inspector.

Inputs |
Displacement

dropdown The channel controlling the
displacement map and dynamic
tessellation to show amore advanced
preview of displacement.

This component is
disabled for Ptex
channels.

25 SHADERS PALETTE |



190

Control Type What it does Dialog Notes

button Adds a new channel for the shader
component.

Add Channel
Dialog

Diffuse entry box, slider Howmuch of the diffuse input appears
on the shaded surface.

From 0 to 2;
defaults to 1.

Specular
Shininess

entry box, slider Howmuch shininess the specularity
appears to have on the shaded
surface.

From 0 to 100;
defaults to 30.

Specular entry box, slider Howmuch of the specular light
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Environment entry box, slider Howmuch of the environment
appears on the shaded surface.

From 0 to 2;
defaults to 1.

Ambient entry box, slider Howmuch ambient light appears on
the shaded surface.

From 0 to 2;
defaults to 0.200.

Ambient
Occlusion

entry box, slider Howmuch ambient occlusion occurs
on the shaded surface.

From 0 to 2;
defaults to 1.

Emissive entry box, slider Howmuch glow the emissive channel
appears to have.

From 0 to 2;
defaults to 1.

Diffuse Falloff entry box, slider Howmuch falloff is given to the diffuse
input.

From 0 to 5;
defaults to 1.

Displacement |
Displacement
Bias

entry box, slider Howmuch thewhite or black values
are pushed or pulled from the surface.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Scale

entry box, slider Howmuch displacement is applied to
the shaded surface. Lower values equal
smaller displacement; higher values
equal larger andmore obvious
displacement.

From 0 to 1;
defaults to 0.500.

Displacement |
Displacement
Range

entry box What the range of displacement is. This
setting ismultiplied by the
Displacement Scale to give the
displacement.
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Control Type What it does Dialog Notes

Displacement |
Max
Tessellation

entry box, slider Howmany texels the surface is
tessellated to.

From 1 to 64;
defaults to 10.

Displacement |
Perturb
Normals

dropdown Selecting yes changes the
displacement so that displacement
moves the surface but leaves the
surface normals as they are.

Bump | Bump
Weight

entry box, slider Howmuch weight the bumpmap has.
Lower values are smaller bumps, higher
values are larger andmore obvious
displacements.

From 0 to 10;
defaults to 0.100.

Bump|Bump
Mode

dropdown Whether you want bump to be
displayed quickly (Fast) or accurately
(Accurate).
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Shader Layers Tab Fields

Control Type What it does Dialog Notes

dropdown,
switch

Filter bar function that gives the
choices: Name, Type,Attribute,
and Color Tag. Depending on
which filter option you select, the
filter bar shows one of the
following:

• - filter by the type
of layers by clicking on the
associated icons.

• - filter
by the attributes of layers by
clicking on the associated icons.

• - filter by
the color tags of the selected
color icon.

Both Type and
Attribute provide
icons that allow you
to set the parameters
for your filter.

Quickly clear the
entry box by pressing

the icon.

dropdown Click to select from the blendmode
options available for individual
layers. To adjust the blend amount,
enter the value into the entry box,
or adjust the slider located to the
right of the blendmodemenu.

• -
adjusts the blendmode amount.

This list does not
include the advanced
blendmode options.

button Opens theAdvanced Blending
menu, which gives options for
blendmodes and components, as
well as blend amount.
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Control Type What it does Dialog Notes

button Adds a new shader to the layer
stack from a dropdownmenu list
of:

• Phong

• Cook Torrance

• Beckman

• Blinn

• Flat

• sRGB Lighting

• BRDF

• Standard Lighting, and

• Choose Diffuse And Specular.

Create Shader
Dialog when
selecting
Choose
Diffuse and
Specular.

TheChoose
Diffuse and
Specular option
allows you to
create a custom
shader. Refer to the
Create Shader Dialog
formore information.

button Adds amask to the selected layer
or, if none is selected, the top layer
in the layer stack.

If amask has already
been added to a layer,
you cannot add a
secondmask using
thismethod. You
must create amask
stack using the right-
click menu.

button Adds amask stack to the selected
layer, or if none is selected, the top
layer in the layer stack.

Clicking on themask
stack icon opens the
mask stack palette.

button Removes the shader from the layer
stack.

Default shaders
cannot be removed
from the Shaders
palette.

button Assigns a color to the selected
layers. To clear an already assigned
color, click the icon and select the
gray color in the center of the
palette. This effectively removes
the color and returns it to the
default color state.
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26 Lights Palette
The Lights palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Lights palette displays the lights in your project, and allows you to:

• Customize the lights.

• Turn each light on or off.

• Move the lights around.

• Reposition a light to the current camera position.

• Render shadows for individual lights.

Lights palette fields

Control Type What it does Notes

Sorted by dropdown Lets you specify whether to list lights by their name or
in a customorder. To use a customorder, drag the
lights up and down the list.

button Lets you reposition the selected light to the current
camera position.

Environment > Color |
Intensity

entry box,
slider

Sets the intensity (brightness) of the selected light. 0.010 to
100.000;
defaults to
1.000.
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Control Type What it does Notes

Environment > General |
Fixed To

dropdown Sets what the light is fixed to:

• Scene (default) - the light is fixed to themodel, for
example if a light is set at themodel's back, it always
points at themodel's back, nomatter how youmove
the view.

• Camera - the light is fixed to a camera view, for
example you can have a light always shining from
above the camera, allowing you to move themodel
around and cast light on different areas.

Environment > General |
On

checkbox Whether the light is on or off.

Environment > Texture |
Up Axis

dropdown Sets the image being used for the environment light to
eitherAxis X,Axis Y (default), orAxis Z. This adjusts
both the background (canvas) image and the lighting
on themodel.

Environment > Texture |
Rotation

entry box,
slider

Rotates the background image and the lighting on the
Y axis.

0.000 to
360.000
degree
rotation;
defaults to
0.000.

Environment > Texture |
Background

dropdown Toggles the visibility of the background (canvas) image
by selecting Show orHide. This does not turning on or
off the lighting, only the image on the canvas.

Environment > Texture |
Resolution

dropdown Sets the resolution of the lighting to either 64, 128, or
256. This does not affect the resolution of the
background (canvas) image.

Environment > Texture |
Cubemap Type

dropdown Sets how the cubemap is handled: eitherNone,
LatLong, or Cross. If a 2D image is being used for the
environment light, this option specifies themethod
used for interpreting the image into a cubemap. When
a 2D image is brought into the Image field, Mari
attempts to set theCubemap Type automatically, but
this can be changed at any time.
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Control Type What it does Notes

Environment > Texture |
Image

arrows,
button,
file
browser

Click the blank image space to choose an environment
from theMari Environment library. Clicking either of
the arrow keys cycles backwards or forwards through
theMari Environment library, loading the image as it
does.

Clicking the file browser opens theOpen an Image
dialog. Select an image of any of the file formats listed
in the File of Type field. You can also drag-and-drop
an image from the Image Manager or a file browser
onto the blank image space to load the image as an
environment light.

Formore
about the
options in the
dialog, refer to
Open an
ImageDialog.

Environment > Texture |
Blur

entry box,
slider

Blurs the background (canvas) image. If the image is a
low resolution, it may not blur evenly.

0.000 to
1.000;
defaults to
0.000.

Environment > Texture
Animation |Animation

dropdown Sets the background (canvas) image animation to
either be Static, where it does not move, orRotate,
where it rotates around the object on the canvas at the
speed set in the Speed field. If the control is changed
fromRotate to Static, the background (canvas) image
is reset back to its default position.

Environment > Texture
Animation | Speed

entry box,
slider

Sets the rotation speed of the background (canvas)
image. If theAnimation field is set to Static, this
control has no affect.

0.000 to
1.000;
defaults to
0.050.

Light > Color | Specular swatch Sets the specular color of the light (the “shiny” color of
the light).

Defaults to
white.

Light > Color |Diffuse swatch Sets the diffuse color of the light (the “surface” color of
the light).

Defaults to
white.

Light > Color | Intensity entry box,
slider

Sets the intensity (brightness) of the selected light. 0.010 to 100;
defaults to
1.000.
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Control Type What it does Notes

Light > General | Fixed To dropdown Sets what the light is fixed to:

• Scene (default) - the light is fixed to themodel, for
example if a light is set at themodel's back, it always
points at themodel's back, nomatter how youmove
the view.

• Camera - the light is fixed to a camera view, for
example you can have a light always shining from
above the camera, allowing you to move themodel
around and cast light on different areas.

Light > General |On checkbox Whether the light is on or off.

Light > Position | Position control
sphere

Lets youmove the light around your project. Click and
drag to move the light.

Light > Rendering |
Render Shadows

checkbox Renders and displays the shadows cast on themodel
by the selected light in its current position.
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27 Projectors Palette
The Projectors palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Projectors palette displays the projectors in your project, and allows you to:

• Create, load, save, and delete projectors.

• Use a projector to take a snapshot of the current view.

• Use a projector to project an edited snapshot back onto themodel's surface.

Projectors palette fields

Control Type What it does Opens this
dialog box

Notes

button Creates a new projector.

button Saves the selected projector to
disk.

Save
Projector

button Loads a saved projector from
disk.

Load
Projector

button Deletes the selected projector.

<projector name> >
General |Name

entry box Enter the name of the projector. This identifies the
projector at the
top of the palette.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Action | Frame Offset

entry box,
slider

Set by howmany frames to
offset the loading of an animated
object. You can specify a frame
range, or simply a number of
frames.

<projector name> >
Action | Import

button Click to load the image from the
file set in the Input File Path and
project it as paint onto themodel
(without baking).

Pick Path (if
Input File
Path has not
been
specified)

<projector name> >
Action | Project

button Click to load the image from the
file set in the Input File Path
and project and bake it onto the
model.

Pick Path (if
Input File
Path has not
been
specified)

<projector name> >
Action | Input File
Path

entry box Enter the filename and path
where the projector loads
updated images from.

<projector name> >
Action |Unproject

button Click to save the current view
buffer out to the file set in the
Output File Path.

Pick Path (if
Output File
Path has not
been
specified)

<projector name> >
Action |Output File
Path

entry box Enter the filename and path
where the projector saves images
to disk.

<projector name> >
Unprojection | Clamp

checkbox If this is checked, Mari restricts
the range of the paint buffer to
values between 0 and 1.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Unprojection | Shader
Used

dropdown Select the shader you want the
projector to take a screen
snapshot of. By default, this is
set to Current Paint Target.

Current Shader,
Current
Channel, Current
Layer, Current
Paint Target, and
Current Layer
and Below.

<projector name> >
Unprojection |
Lighting Mode

dropdown The lightingmode to usewhen
taking a screen snapshot with
this projector.

Flat, Basic, Full.

<projector name> >
Unprojection | Color
Depth

dropdown The color depth of the screen
snapshots taken by this
projector.

8bit (Byte), 16bit
(Half), 32bit
(Float).

<projector name> >
Unprojection | Size

dropdown The size (in pixels) of the screen
snapshots taken by this
projector.

<projector name> >
Painting | Painting
Mode

dropdown Sets the paint blendingmode. The paint blending
modes available
are similar to
many other paint
packages. If you
aren't familiar with
the various
modes, see Paint
Blending Modes in
theMari User
Guide for
descriptions and
examples.

<projector name> >
Projection |
Projection

dropdown Sets whetherMari projects only
onto the Front of themodel (as
you're seeing it) or whether paint
goes straight Through themodel
(appearing on the back as well as
the front).
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Transformation |
Scale

entry boxes Sets the scale of the projector.

<projector name> >
Transformation |
Translation

entry boxes Sets the translated position of
the projector.

<projector name> >
Transformation |
Rotation

entry box Sets the rotation, in degrees, of
the projector.

<projector name> >
Update |Update
Global Settings
From Projector

button If you have adjusted any
projection properties, click this
button to see the effect of your
changes in the canvas. When you
do, the equivalent global
projection properties in the
Projection palette are also
updated.

Updates all global
projection
properties.

<projector name> >
Update |Update
Only Masks From
Projector

button If you have adjusted any
projectionmask properties, click
this button to see the effect of
your changes in the canvas.
When you do, the equivalent
global
projectionmask properties in the
Projection palette are also
updated.

Updates global
projectionmask
properties only.

<projector name> >
<projector name> >
General |Name

information Nameof the camera used for the
projector.

<projector name> >
<projector name> >
General |Animated

information Whether the camera used for the
projector is animated.

True, False.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
<projector name> >
Perspective | FoV

entry box,
slider

Enter the value for the field of
vision. This controls howmuch
Mari distorts the viewwhen
applying perspective. At 0, the
perspective camera gives exactly
the same view as the ortho
camera. As the value increases,
the distortion increases.

<projector name> >
<projector name> >
Perspective |Near
plane

entry box,
slider

Enter the value for the near
clipping plane. Mari doesn’t
display parts of the scene that
are closer than theNear plane.

<projector name> >
<projector name> >
Perspective | Far
plane

entry box,
slider

Enter the value for the far
clipping plane. Mari doesn’t
display parts of the scene that
are further than the Far plane.

<projector name> >
Edge Mask > General |
Enabled

checkbox Whether the edgemask is turned
on or not.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Edge Mask > General
| Falloff Start

entry box,
slider

Controls where the edgemask
starts on themodel. The higher
the value, themore forward
facing themasking starts. If this
is higher than the FalloffEnd,
areas facing the view are
paintable, and areas oblique to
the view aremasked. If this is
lower, facing areas aremasked
and oblique areas are paintable.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Edge Mask > General
| Falloff End

entry box,
slider

Controls where the edgemask
ends on themodel. The higher
the value, the closer, more
forward facing themask finishes.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Edge Mask > General
| Falloff Curve

curve editor Adjusts the falloff, using a curve
editor to modify the falloff start
and end point. To fine tun
control over the falloff, addmore
points to the curve.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Channel Mask >
General | Invert

checkbox If this is selected, themask data is
black on white rather than white
on black.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Channel Mask >
General |Mask
Curve

curve editor Adjusts the amount of masking
on the channel, wherewhite
pixels are totally masked, black
pixels are totally unmasked, and
50% gray is 50%masked.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Channel Mask >
General |Mask
Contrast

entry box,
slider

The contrast applied to the
original channel to derive the
mask. At 1.0, themask comes
directly from the original channel.
Lower valuesmake themask
fuzzier than the input channel,
higher valuesmake it sharper
than the input channel.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Channel Mask >
General |Mask
Amount

entry box,
slider

The strength of themask
effect.1.0 means that themask
absolutely controls where you
can paint; the effects of themask
decrease as the value gets lower.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Channel Mask >
General |Mask
Channel

dropdown Sets the channel holding the
mask from a list of available
channels in your project.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Channel Mask >
General | Enabled

checkbox Whether the channelmask is
turned on or not.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Ambient Occlusion
Mask > General |
Invert

checkbox If this is selected, themask data is
black on white rather than white
on black.

<projector name> >
Ambient Occlusion
Mask > General |
Mask Curve

curve editor Controls how the ambient
occlusion pixel values relate to
the degree of masking. The
horizontal axis is the darkness of
the occluded pixels (black to the
left, white to the right), the
vertical axis is the degree of
visibility. By default, this is a
direct line, wherewhite pixels are
totally masked, black pixels are
totally unmasked, and 50% gray
is 50%masked.

<projector name> >
Ambient Occlusion
Mask > General |
Mask Contrast

entry box,
slider

The contrast applied to the
ambient occlusion to derive the
mask. At 1.0, themask comes
directly from the calculated
ambient occlusion. Lower values
make themask fuzzier than the
ambient occlusion, higher values
make it sharper.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Ambient Occlusion
Mask > General |
Mask Amount

entry box,
slider

The amount of ambient occlusion
masking to apply.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Ambient Occlusion
Mask > General |
Enabled

checkbox Whether the ambient occlusion
mask is turned on or not.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Depth Mask > General
| Enabled

checkbox Whether the depthmask is
turned on or not.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Depth Mask > General
| Falloff

entry box,
slider

How fast the depthmasking
applies. Lower valuesmake the
mask apply slowly, higher values
make it apply more quickly.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Depth Mask > General
| End

entry box,
slider

The depth in the scene for the
depthmasking to finish.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Depth Mask > General
| Start

entry box,
slider

The depth in the scene for the
depthmasking to start.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Backface Mask >
General | Enabled

checkbox Whether the backfacemask is
turned on or not.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Fractal Noise Mask >
General | Invert

checkbox If this is selected, themask data is
black on white rather than white
on black.

<projector name> >
Fractal Noise Mask >
General |Mask
Curve

curve editor Adjusts the fractal noisemasking
wherewhite pixels are totally
masked, black pixels are totally
unmasked, and 50% gray is 50%
masked.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Fractal Noise Mask >
General | Enabled

checkbox Whether the fractal noisemask is
turned on or not.

When enabled, a

icon displays
in the status bar.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Fractal Noise Mask >
General |Mask
Amount

entry box,
slider

The amount that themask
affects the paint buffer. 1.0
means that themask absolutely
controls where you can paint; the
effects of themask decrease as
the value gets lower.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Fractal Noise Mask >
General | Size

entry box,
slider

Determines the size of the fractal
noise features.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Fractal Noise Mask >
General | Roughness

entry box,
slider

Determines the roughness of the
fractal noise features.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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Control Type What it does Opens this
dialog box

Notes

<projector name> >
Fractal Noise Mask >
General | Contrast

entry box,
slider

Controls the level of contrast
applied to the fractal noise
features to derive themask.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.

<projector name> >
Fractal Noise Mask >
General | Seed

entry box,
slider

Changes the pattern of the
fractal noise by moving the
pattern start point through 3D
space.

You need to click
either of the
update buttons
underUpdate to
see the effect of
your changes in
the canvas. When
you do, the
equivalent global
properties in the
Projection palette
are also updated.
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28 Selection Groups Palette
The Selection Groups palette and the controls that can be found on it are described in the table below. When
controls also bring up additional dialogs, these are referenced formore information.

What It Does
The Selection Groups palette lets you switch between saved selection groups. You can also create new selection
groups, lock and unlock groups, and show or hide groups.

Selection Groups palette fields

Control Type What it does Opens this
dialog box

Notes

Sorted by dropdown Sets how to sort the entries in the list.

At present, you can only sort by name.

button Adds a new selection group, based on
the current selection.

button Removes the highlighted selection
group.

button Reloads the highlighted selection group.

button Locks the selection group.

button Unlocks the selection group.

button Hides the selection group.

button Shows the selection group.



29 Color Manager Palette
TheColor Manager palette and the controls that can be found on it are described in the table below. When controls
also bring up additional dialogs, these are referenced formore information.

What It Does
TheColor Manager lets youmanage how colors are displayed on yourmonitor. It includesmany options for color
correction, including a host of preset filters. Managing colors using the preset filters in this palette does not affect
the paint on yourmodel. For information on the filters used to apply transformations to the paint on yourmodel,
refer to the Filter Functions chapter.

Color Manager Palette Fields

Control Type What it does Opens this
dialog box

Notes

Options | Enable Color
Management

switch, on/off
indicator

Turns color
correction on or off.

When on,
displays in the status
bar, and a histogram
displays a count of
frequencies of colors
in RGBA channels in
the current view.

Options |Active on/off indicator Displays green when
color correction is
on.

Not active for scalar
channel.
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Control Type What it does Opens this
dialog box

Notes

Options |Histogram switch, on/off
indicator

Turns histogram
view on or off. If it's
on, Mari displays a
color histogram in
the background of
the canvas.

Options | Split Point entry box, slider Lets you split the
display between
showing corrected
and uncorrected
color.

Enter a value or slide
to specify what
percentage of the
model (split
vertically) displays
with color correction.

Color Correction is
on.

Range: 0.00 to 1.00

Current Color Profile | <profile> dropdown Lets you select from
saved color profiles.

Default tries to make
onscreen colors
emulate film.

Current Color Profile |New button Prompts you to
name a new profile,
select available filters
to include in a
particular order, and
save.

Edit

Current Color Profile | Edit button Lets you rename and
change the current
profile, including
adding filter to or
deleting filters from
the profile.

Edit The default filters
Gain, LUT, and
Display cannot be
deleted from the
profile
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile |Delete button Deletes the current
profile (after
confirming).

Really Delete?

Current Color Profile | LUT switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Current Color Profile > LUT >
General | LUT File

entry box Enter the filename
and path of the LUT.

Current Color Profile > LUT >
General | Extrapolate

checkbox Sets whether the
GPU extrapolates
the grid values or
clamps to the
maximum value of
the LUT.

Current Color Profile |
Composite Filter

switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Add User
Attribute

Current Color Profile | Levels switch, on/off
indicator, add
attribute

Changes the color
levels in the paint, by
setting thewhite
point, midtone, and
black point.

Current Color Profile > Levels >
Channel | Color Component

dropdown Whether the filter
affects all
components, or a
specific one (Red,
Green, orBlue).
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Levels >
Input Levels |White Point

entry box, slider Specifies the upper
limit of displayed
color intensity. Areas
with a value higher
than this are
mapped to 1 (pure
white).

Current Color Profile > Levels >
Input Levels |Midtone

entry box, slider Sets themiddle point
between white and
black. Mari remaps
the values so that
this is themiddle of
the range between
thewhite point and
black point. Moving
this pushes the
values towards that
end of the spectrum.

Current Color Profile > Levels >
Input Levels |Black Point

entry box, slider Specifies the lower
limit of displayed
color intensity. Areas
with a value lower
than this are
mapped to 0 (pure
black).

Current Color Profile > Levels >
Output Levels |White Output
Levels

entry box, slider Sets howmuch white
is output in the
filtered image.
Higher values show
the entire white
output, lower values
show decreasing
amounts.
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Levels >
Output Levels |Black Output
Levels

entry box, slider Sets howmuch black
is output in the
filtered image.
Higher values show
the entire black
output, lower values
show decreasing
amounts.

Current Color Profile| sRGB To
Linear

switch, on/off
indicator, add
attribute

Applies an sRGB to
linear colorspace
conversion.

Current Color Profile > sRGB To
Linear > General | Invert

checkbox Applies a linear to
sRGB colorspace
conversion.

Current Color Profile| Color
Curves

switch, on/off
indicator, add
attribute

Changes the color
curve for each color
channel (RGB) in the
painting.

Add User
Attribute

Presets can be
loaded from .mgf
(Mari Gradient Files).

Current Color Profile > Color
Curves > Channels | Red

curve editor Controls how the
filter translates
current Red values to
new values.

Current Color Profile > Color
Curves > Channels |Green

curve editor Controls how the
filter translates
current Green values
to new values.

Current Color Profile > Color
Curves > Channels |Blue

curve editor Controls how the
filter translates
current Blue values
to new values.

29 COLORMANAGER PALETTE |



218

Control Type What it does Opens this
dialog box

Notes

Current Color Profile | Color
Switches

switch, on/off
indicator, add
attribute

Turns individual
color channels on or
off. (WhenMari
applies the filter, it
removes any
unchecked color
channels from the
painting.)

Add User
Attribute

Current Color Profile > Color
Switches > Channels |Blue

checkbox Click to turn the Blue
channel display on or
off.

Current Color Profile > Color
Switches > Channels |Green

checkbox Click to turn the
Green channel
display on or off.

Current Color Profile > Color
Switches > Channels | Red

checkbox Click to turn the Red
channel display on or
off.

Current Color Profile |
Brightness

switch, on/off
indicator, add
attribute

Changes the
brightness of the
paint on themodel,
either overall or for
specific channels.

Add User
Attribute

Current Color Profile >
Brightness > General |
Brightness

entry box,
slider, reset

Sets the brightness
value for all channels
(overwrites changes
to individual
channels).

Range: 0.00 to 2.00

Reset: 1.00

Current Color Profile >
Brightness > Channels |Blue

entry box,
slider, reset

Sets the brightness
value for the blue
channel.

Range: 0.00 to 2.00

Reset: 1.00

Current Color Profile >
Brightness > Channels |Green

entry box,
slider, reset

Sets the brightness
value for the green
channel.

Range: 0.00 to 2.00

Reset: 1.00
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile >
Brightness > Channels | Red

entry box,
slider, reset

Sets the brightness
value for the red
channel.

Range: 0.00 to 2.00

Reset: 1.00

Current Color Profile| Blur switch, on/off
indicator, add
attribute

Applies a standard
blur to the selection.

Add User
Attribute

Current Color Profile > Blur >
General|Blur Radius

entry box,
slider, reset

Sets the blur radius -
the number of pixels
Mari uses when
calculating the blur
value for each pixel.
The higher the
radius, themore
blurred the results.

Range: 0 to 10

Reset: 4

If you use a larger
blur radius, youmay
get slight lines on the
boundaries between
patches. This is an
artifact of theway
that Mari handles the
edges of patches.

Current Color Profile | Tone
Mapping

switch, on/off
indicator, add
attribute

Varies the
“exposure” of the
painting.

Add User
Attribute

Current Color Profile > Tone
Mapping > General |White
Point

entry box,
slider, reset

Sets the upper limit
of displayed color
intensity - any colors
of greater intensity
map to white.

Range: 0.00 to 1.00

Reset: 1.00

Current Color Profile > Tone
Mapping > General | Exposure

entry box,
slider, reset

Sets the exposure -
lower exposures give
darker images;
higher exposures
give lighter ones.

Range: 0.00 to 10.00

Reset: 1.00
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile |Gamma switch, on/off
indicator, add
attribute

Changes the gamma
levels in the
selection.

Add User
Attribute

A higher setting for
Gamma results in a
morewashed-out
looking image.

Current Color Profile > Gamma
> General |Do Inverse

checkbox Reverses the gamma
conversion.

Current Color Profile > Gamma
> General |Use default
gamma

checkbox Disables the other
controls and uses
your default setting
for gamma (as set in
the Painting tab of
theMari Preferences
Dialog).

Current Color Profile > Gamma
> General |Gamma

entry box,
slider, reset

Sets the gamma
level.

Range: 0.00 to 3.00

Reset: 2.20

Current Color Profile | Lin 2
Log

switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Add User
Attribute

Current Color Profile |Hue switch, on/off
indicator, add
attribute

Changes the hue,
saturation, and value
of the colors on the
model.

Add User
Attribute

Current Color Profile > Hue > Hue
| Rotate

entry box,
slider, reset

Moves the colors
around the color
wheel. The rotation
value is the degree
around the color
wheel that each color
shifts, between 0
and 360 (which both
correspond to the
original colors).

Range: 0.00 to
360.00

Reset: 0.00
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Hue >
Saturation | Scale

entry box,
slider, reset

Sets amultiplier for
the saturation.

Range: 0.00 to 2.00

Reset: 1.00 (the
original saturation)

Current Color Profile > Hue >
Saturation |Offset

entry box,
slider, reset

Adds an offset value
to the initial
saturation, before
applying the Scale.

Range: 0.00 to 1.00

Reset: 0.00

Current Color Profile > Hue >
Saturation | Saturation

curve editor Controls how the
filter translates
current saturation to
new saturation.

Current Color Profile > Hue >
Value | Scale

entry box,
slider, reset

Sets amultiplier for
the value.

Range: 0.00 to 2.00

Reset: 1.00 (the
original value)

Current Color Profile > Hue >
Value |Offset

entry box,
slider, icon

Adds an offset value
to the initial value,
before applying the
Scale.

Range: 0.00 to 1.00

Reset: 0.00

Current Color Profile > Hue >
Value | Value

curve editor Controls how the
filter translates
current values to
new values.

Current Color Profile | Invert switch, on/off
indicator, add
attribute

Inverts the colors in
the selection.
Replaces colors with
their “opposite” in
the color chart. For
example, replaces a
color with a float
value of 0.3 with a
color with float value
0.7.

Add User
Attribute
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Invert >
General | Invert Alpha

checkbox Inverts the alpha
channel.

Current Color Profile |
Premultiply Alpha

switch, on/off
indicator, add
attribute

Either pre- or post-
multiplies the alpha
in the selected
image. If you are
painting using an
imagewithout
pre-multiplied alpha
onto onewith it, use
this filter to perform
the
pre-multiplication, so
the imagesmatch
and you avoid lines
around the outside
of the patch.

Add User
Attribute

Current Color Profile >
Premultiply Alpha > General |
Postmultiply

checkbox Works the same as
pre-multiply, but in
reverse (removes
pre-multiplication to
match images that
do not have
pre-multiplied
alpha).

Current Color Profile | Log 2 Lin switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Add User
Attribute
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile |
Luminosity

switch, on/off
indicator, add
attribute

Outputs just the
luminosity value of
each pixel in the
selection. That is, it
outputs a grayscale
image based on the
brightness of each of
the pixels in the
original image.

Add User
Attribute

Current Color Profile | Contrast switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Add User
Attribute

Current Color Profile | Clamp switch, on/off
indicator, add
attribute

Clamps color values
to lie within the
specified upper and
lower values.

Set theUpper Value
and Lower Value by
adjusting the sliders
or entering values in
the entry boxes.

Select the individual
Color Component
to clamp in the
dropdownmenu.

Current Color Profile > Clamp >
General |Upper Value

entry box, slider Set the upper value
at which color values
are clamped. All
values higher than
this number are set
to this value.

Current Color Profile > Clamp >
General | Lower Value

entry box, slider Set the lower value
at which color values
are clamped. All
values lower than
this number are set
to this value.
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Clamp >
Channel | Color Component

dropdown Select the individual
color component to
clamp.

Current Color Profile > Contrast
> General |Amount

entry box,
slider, reset

Changes the contrast
of the paint.

Range: 0.00 to 2.00

Reset: 1.00

Current Color Profile| Copy
Channel

switch, on/off
indicator, add
attribute

Copies the value
fromone RGB color
channel to the other
two. The result is a
grayscale imagewith
the intensity values
from the selected
channel.

Add User
Attribute

Current Color Profile > Copy
Channel > General | Copy
Channel

dropdown Select the source
channel from the list
(Red,Green, or
Blue). When you
apply the filter, Mari
copies the selected
channel over the
other two channels.

Current Color Profile | Soften switch, on/off
indicator, add
attribute

Applies a subtle
softening blur.

Add User
Attribute

This is a quick,
predefined blur filter.
If you needmore
control over the
degree or type of
blurring, use either
the standard Blur or
GaussianBlur
filters.
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile | Edge
Detect

switch, on/off
indicator, add
attribute

Finds “edges”
(transitions between
colors) in the image
and heightens them.

Add User
Attribute

Current Color Profile | Emboss switch, on/off
indicator, add
attribute

Applies an “emboss”
effect, so that
textures look
“raised” on the
surface.

Add User
Attribute

Current Color Profile | Sharpen switch, on/off
indicator, add
attribute

Removes 'fuzziness'
and clarifies detail in
the image.

Add User
Attribute

Current Color Profile > Sharpen
> General |Amount

entry box,
slider, reset

Sets the amount of
sharpening. Higher
valuesmeanmore
sharpening, while a
value of 0.00 is the
picturewithout the
filter applied.

Range: 0.00 to 1.00

Current Color Profile |Dilate switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Add User
Attribute

Current Color Profile |Gaussian switch, on/off
indicator, add
attribute

Applies a Gaussian
blur. Compared to
the standard Blur
filter, this gives you
much finer control
over the degree of
blurring, and the
option of using
much higher blur
values.

Add User
Attribute
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Gaussian
> General | Radius

entry box, slider Sets the blur radius.
The higher the
radius, themore
blurred the results.

Range: 0.00 to 50.00

If you use a larger
blur radius, youmay
get slight lines on the
boundaries between
patches. This is an
artifact of theway
that Mari handles the
edges of patches.

Current Color Profile |High
Pass

switch, on/off
indicator, add
attribute

Removes low
frequency
information from
the imagewhile
maintaining higher
frequency detail.

Current Color Profile > High
Pass > General |Amount

entry box, slider Sets howmuch low
frequency
information is
removed by the
filter.

Current Color Profile > High
Pass > General | Radius

entry box, slider Controls the number
of pixels around the
image highlights that
are affected by the
filter.

Current Color Profile | Color
Correction

switch, on/off
indicator, add
attribute

Switches the filter on
or off, or lets you
add attributes to it.

Current Color Profile > Color
Correction > User Attributes |
Configuration File

entry box Specifies the
configuration file to
use.
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Control Type What it does Opens this
dialog box

Notes

Current Color Profile > Color
Correction > User Attributes |
Input ColorSpace

dropdown The colorspace of
the current painting.

Current Color Profile > Color
Correction > User Attributes |
Output ColorSpace

dropdown The colorspace
correction to apply
to the current
painting.

Current Color Profile |Add
Noise

switch, on/off
indicator, add
attribute

Applies noise to the
current painting.

Current Color Profile > Add
Noise > User Attributes |
Amount

entry box, slider Adjusts howmuch
noise is applied.

Current Color Profile > Add
Noise > User Attributes | Color
Component

dropdown Sets the channel you
want to affect.

Current Color Profile > Add
Noise > User Attributes |
Grayscale

checkbox Applies grayscale
noisewith only the
intensity values from
the selected channel.

Current Color Profile > Add
Noise > User Attributes | Seed

entry box, slider Adds variation to the
noise.

Current Color Profile > Add
Noise > User Attributes | Size

entry box, slider Adjusts the size of
the noise applied.
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30 Image Manager Palette
The Image Manager palette and the controls that can be found on it are described in the table below. When
controls also bring up additional dialogs, these are referenced formore information.

What It Does
The Image Manager lets you store and work with images in your project, including using them for brushes and
painting through themonto yourmodel.

ImageManager Palette Fields

Control Type What it does Opens this
dialog box

Notes

Image Info |MriImage add
attribute

Image Info > MriImage > Info |
Depth

information The color depth of the
currently selected image in
bytes.

Image Info > MriImage > Info |
Channels

information The color components of
the currently selected
image.

Image Info > MriImage > Info |
File Space

dropdown File space of the currently
selected image.

NORMAL or
VECTOR

Image Info > MriImage > Info |
ColorSpace

dropdown Colorspace of the currently
selected image.

COLOR or
SCALAR

Image Info > MriImage > Info |
Tiled Image

information Whether the image is tiled -
true or false.
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Control Type What it does Opens this
dialog box

Notes

Image Info > MriImage > Info |
Height

information The height of the currently
selected image in pixels.

Image Info > MriImage > Info |
Width

information Thewidth of the currently
selected image in pixels.

Image Info > MriImage > Info |
Path

information The file path to the original
image.

button Adds an image to the Image
Manager.

Open an
Image

button Removes the selected
image from the Image
Manager.

button Opens the selected image
in another window, where
you can crop it.

<image>

button Saves the selected image to
a file.

Save an image

30 IMAGEMANAGER PALETTE |
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Control Type What it does Opens this
dialog box

Notes

(<image> window) |
button Crops the current image.

Mari copies the cropped
area as a separate image in
the ImageManager. The
cropped image is part of
the project, but won't be
saved as a separate image
file unless you use the
SaveAs option (see above).

Select one of the following
cropmodes:

• Arbitrary - Click and drag
on an arbitrary area of
the image.

• Fixed - Enter a fixed size
for the crop box (in pixels)
and drag it to the area
you want to crop.

• Aspect - Enter a fixed
aspect ratio for the crop
box (in pixels) and drag it
over the area you want to
crop.

Once you have selected the
crop area, click themouse
button to crop.
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31 History View Palette
TheHistory View palette is described below.

What It Does
TheHistory View palette displays a list of actions performed in the current session. Click an action to step back to
that version of the project.



32 Brush Editor Palette
TheBrush Editor palette and the controls that can be found on it are described in the table below. When controls
also bring up additional dialogs, these are referenced formore information.

What It Does
TheBrush Editor palette shows the settings for the current brush tip. It includes the following tabs:

• Properties - properties of the selected brush.

• Shelves - customized shelves of brushes.

• Presets - pre-set shelves of brushes.

• (Shelves and Presets tabs are the same as the Shelf Palette).

Brush Editor Palette Fields

Control Type What it does Opens this
dialog box

Notes

Properties > General |Noise entry box,
slider, reset

The amount of noise to
add to the brush tip for
each splat. This is a little
bit of noise added to the
splat itself, to soften the
appearance and reduce
banding. Lower values
give a harder brush,
higher values a softer
brush.
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Control Type What it does Opens this
dialog box

Notes

Properties > General | Spacing entry box,
slider, reset

The space between
splats, as a proportion
of thewidth of a splat.
1.00 = side-by-side (so if
the tip is a circle, it
would look like a string
of beads.) .02 = .02 x
thewidth of a splat.

Range: 0.02 to
5.00

Reset: 0.02

Properties > Paint |
JitterOpacityMax

entry box,
slider, reset

Howmuch to randomly
vary the opacity (if
Jitter Opacity is
enabled).

1.00 = side by
side

Range: 0.00 to
1.00

Reset: 0.00

Properties > Paint |
JitterOpacity

checkbox If enabled, picks random
number to add to
opacity.

Properties > Paint |Opacity entry box,
slider, reset

How dark a stroke can
be (maximumalpha).

Range: 0.01 to
1.00

Reset: 1.00

Properties > Paint | Flow entry box,
slider, reset

Mimics how quickly
paint is applied, by
setting themaximum
opacity in a splat.

Range: 0.01 to
1.00

Reset: 1.00

Properties > Position |
JitterPositionMax

entry box,
slider, reset

Howmany pixels at
most to randomly vary
displacement from the
line of the brush stroke
(if Jitter Position is
enabled).

Range: 0 to 1000

Reset: 1000
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234

Control Type What it does Opens this
dialog box

Notes

Properties > Position |
JitterPosition

checkbox Whether to randomly
vary displacement from
the line of the brush
stroke (to the degree
specified in
Jitter Position Max).

Properties > Pressure | Colors checkbox Whethermore
pressure causes the
color to vary (from
slightly darker to the
target color).

Properties > Pressure | Radius checkbox Whethermore
pressure increases the
radius.

Properties > Pressure | Flow checkbox Whethermore
pressure increases the
flow.

Properties > Pressure |Alpha checkbox Whethermore
pressure increases the
opacity.

Properties > Radius | Squish entry box,
slider, reset

Howmuch to flatten the
radius. If the brush tip is
a circle, 1.0 is a circle, .5
is an oval half as tall as it
is wide.

Range: 0.05 to
1.00

Reset: 1.00

Properties > Radius |
JitterRadius

entry box,
slider, reset

Whether to randomly
vary the radius (to the
degree specified for the
Radius and
InnerRadius).
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Control Type What it does Opens this
dialog box

Notes

Properties > Radius |
InnerRadius

entry box,
slider, reset

How few pixels the
radius of a splat can be
(if JitterRadius and/or
RadiusPressure are
enabled).

Range: 1 to 1200

Reset: 1

Properties > Radius | Radius entry box,
slider, reset

Howmany pixels at
most the radius of splat
can be (if
JitterRadius and/or
RadiusPressure are
enabled).

Range: 1 to 1200

Reset: 100

Properties > Rotation |
AligntoStroke

checkbox Whether the brush tip
rotates along with the
direction you're
painting. (With
calligraphy, for example,
the tip does not align.)

Properties > Rotation |
JitterRotationMax

entry box,
slider, reset

Howmany degrees at
most to randomly vary
the rotation (if
JitterRotation is
enabled).

Range: 1 to 360

Reset: 360

Properties > Rotation |
JitterRotation

checkbox Whether to randomly
vary the rotation.

Properties > Rotation |
Rotation

entry box,
slider, reset

The degree to which the
brush rotates to match
the direction you're
painting (if
AligntoStroke is
enabled).

Range: 0.00 to
360.00

Reset: 0.00
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Control Type What it does Opens this
dialog box

Notes

Properties > General | Type dropdown Whether to use a
Bitmap image for the
brush tip, orRender
based on the qualities
specified in these
properties

Properties > General | Preview image An image of the brush
tip, based on the
selected properties.

Properties > Bitmap |
UsePainting

button Click to use the painting
in the paint buffer as a
brush tip. Mari prompts
you to save it either as
an .exr or a .tif file
(which file format is
used depends on the
support in your graphics
card). Note that .exr
files are 16-bit - most
other bitmaps are 8-bit.

Properties > Bitmap | Path entry box,
button

Type the path or click

to select an
existing bitmap to use
as the brush tip.

To use an image
as the brush tip,
you need to set
Type to Bitmap.

Properties > Geometry |
VerticalShear

entry box,
slider, reset

Howmuch to distort the
brush tip diagonally, top
to bottom (as if pulling
opposite corners up and
down).

Range: -1.00 to
1.00

Reset: 0.00
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Control Type What it does Opens this
dialog box

Notes

Properties > Geometry |
HorizontalShear

entry box,
slider, reset

Howmuch to distort the
brush tip diagonally,
right to left (as if pulling
opposite corners right
and left).

Range: -1.00 to
1.00

Reset: 0.00

Properties > Geometry |
VerticalScale

entry box,
slider, reset

Howmuch to distort the
brush tip vertically.

Range: 0.00 to
2.00

Reset: 50

Properties > Geometry |
HorizontalScale

entry box,
slider, reset

Howmuch to distort the
brush tip horizontally.

Range: 0.00 to
2.00

Reset: 50

Properties > Noise |Octaves entry box,
slider, reset

Number of applications
of noise.

Range: 1 to 8

Reset: 4

Properties > Noise |
Frequency

entry box,
slider, reset

Howmany spikes per
octave.

Range: 0.00 to
100.00

Reset: 1.00

Properties > Noise | Scale entry box,
slider, reset

How big the spikes are,
as a proportion of the
radius (1.00 = twice as
big as the radius).

Range: 0.00 to
1.00

Reset: 0.00

Properties > Noise | Segments entry box,
slider, reset

Linesmaking up the
brush outline, to which
noise is applied
(4=square, 360=circle).

Range: 4 to 360

Reset: 360

Properties > Profile | Profile curve editor How opaque or
transparent the brush is
at different points.

Properties > Profile |Bit Depth dropdown The color depth of the
brush tip.
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Control Type What it does Opens this
dialog box

Notes

Shelves tabs Select shelves, click to
display more to the left
or right.

Presets tabs Select shelves, click to
display more to the left
or right.

Scratch pad Provides a space to test
the brush.
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33 Play Controls Palette
The Play Controls palette and the controls that can be found on it are described in the table below. When controls
also bring up additional dialogs, these are referenced formore information.

What It Does
The Play Controls palette allows you to play animations. You can set keyframes, which allows you to paint different
textures in different parts of the animation sequence.

What It Looks Like

Play Controls Palette Fields

Control Type What it does Opens this
dialog box

Notes

Timeline timeline Showswhere in the animation
sequence you are currently
viewing.

Keyframes appear as solid boxes
in the timeline.

button Adds a keyframe at the current
frame.
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Control Type What it does Opens this
dialog box

Notes

button Removes the selected keyframe.

Frame range entry box The start and end frames of the
animation.

entry box,
dropdown

Sets the start and end frames of
the animation to play. Use this if
you want to play only a section of
the animation.

Select the play mode from the
dropdown. One of:

• Loop - play the selected frames
through, repeating again from
the start when it finishes.

• Bounce - play the selected
frames through from start to
finish, then backwards from the
finish to start, and then
repeating.

• Stop - play the animation once
and then stop.

button Move back a single frame.

button Move back to the beginning of the
animation.

button Play the animation.

button Stop playing.

button Move forward a single frame.
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34 Python Console Palette
The Python Console palette and the controls that can be found on it are described in the table below. When
controls also bring up additional dialogs, these are referenced formore information.

What It Does
The Python Console palette is divided into three sections:

• a Script Path entry box that loads Python scripts from a defined location

• an input pane that is used to enter and execute Python statements in the lower half of the palette

• an output pane that displays statements and their outputs in the upper half of the palette.

What It Looks Like
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Python Console Palette Fields

Control Type What it does Notes

Output Pane information Displays Python statements and their
outputs.

Input Pane entry box Click inside to enter Python statements.

Script Path entry box Enter the file path where the
console loads scripts from.

button Selects a Python file for evaluation in the
console. Selecting a file fills in the Script
Path but you need to click Evaluate to
continue.

Opens the
Python Script
Path dialog.

Evaluate button Executes Python script or statement.

Clear button Clears the input and output panes.

Help button Opens theMari Python API Help in a new
window. This window is visible until you click
Help again or close thewindow.

If you have the help open while typing in the
Input Panewith auto-complete on,
commands that appear in auto-complete
are automatically found in the help as well.
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35 Pixel Analyzer Palette
The Pixel Analyzer palette and the controls that can be found on it are described in the table below. When controls
also bring up additional dialogs, these are referenced formore information.

What It Does
The Pixel Analyzer displays information about pixels selected with theColor Picker/Pixel Analyzer tool.

Pixel Analyzer Palette Fields

Control Type What it does Opens this
dialog box

Notes

Colors | Current swatch Displays the color of the pixel selected
with theColor Picker/Pixel Analyzer
tool.

Colors |Minimum swatch Displays theminimum color of the pixels
that have been selected with theColor
Picker/Pixel Analyzer tool (when
Accumulate is enabled).

Colors |Average swatch Displays the average color of the pixels
that have been selected with theColor
Picker/Pixel Analyzer tool (when
Accumulate is enabled).

Colors |Maximum swatch Displays themaximum color of the pixels
that have been selected with theColor
Picker/Pixel Analyzer tool (when
Accumulate is enabled).
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Control Type What it does Opens this
dialog box

Notes

Accumulate | Enabled checkbox When selected, keeps data on all pixels
selected (until Reset), and calculates
Minimum,Average andMaximum
colors.

Accumulate | Reset button Clears all accumulated pixel selections, to
just the Current selection.

Values | Range dropdown Byte, Float, orHalf.

Values | R, G, B, A information Values for Red, Green, Blue, and Alpha.

Values |H, S, V, L information Values for Hue, Saturation, Value, and
Luminosity.

Values | X, Y E, I information Values for position of pixel on x and y
axis, and the pixel Exposure and
Intensity.

35 PIXEL ANALYZER PALETTE |



36 Colors Palette
TheColors palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
TheColors palette lets you view and change colors. The controls on this palette all work together - as you change the
color through one control, the other controls update to show your change.

Colors Palette Fields

Control Type What it does Notes

Foreground/Background |
Foreground

swatch Shows the current foreground color. This is the color that Mari
uses when you paint
using the Paint tool.
Clicking on this swatch
opens the Select Color
dialog box.

Foreground/Background |
Background

swatch Shows the current background color. Clicking on this swatch
opens the Select Color
dialog box.

Foreground/Background |
button Swap foreground and background.

Foreground/Background |
button Set colors to black (background) and

white (foreground).

entry box,
slider

Specify Red values. Range: 0.000 to 1.000

entry box,
slider

Specify Green values. Range: 0.000 to 1.000
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Control Type What it does Notes

entry box,
slider

Specify Blue values. Range: 0.000 to 1.000

entry box,
slider

Specify Alpha values. Range: 0.000 to 1.000

entry box,
slider

Specify Hue values. Range: 0.000 to 0.999

entry box,
slider

Specify Saturation values. Range: 0.000 to 1.000

entry box,
slider

Specify Value values. Range: 0.000 to 1.000

HSV tab: field,
sliders,
option
buttons

Use this to pick colors from a
Hue/Saturation/Value field.

To create custom color
spectrums. Adjust the
field values using the
controls on the right,
then click in the field to
set the foreground color.

Values tab: field Use this to set Byte (8 Bit),Half (16
Bit), or Float (32 Bit) color values.

Image tab: field Drag an image here from the Image
Manager Palette to pick colors from an
image.

Click the image to select a
foreground color.

You can also load an
image by right-clicking
and selecting Load
Image, then selecting a
file from the Load dialog
box.

To clear an image,
right-click it and select
Clear Image.

Grey tab:
sliders,
buttons

Use this to pick a gray value from the
gradient, or one of the presets.
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Control Type What it does Notes

Swatches tab:
swatches,
buttons

Use this to pick from theBackground
and Foreground swatches. Click the
buttons to swap foreground and
background, and switch to black and
white.

(same as swatches and
buttons next to tabs)

Sliders tab:
sliders

Use this to pick colors by specifying
RGB, alpha, and HSV values.

(same as sliders next to
tabs)

Blend tab:
swatches,
field

Use this to show a field with four colors
blending into each other.

Click on the box at each
corner of the field to set
the color for that corner.
You can set each color
individually, then click in
the field to pick from the
blend.

Intensity entry box,
slider

Adjusts the intensity of colors in the
Select Color dialog to select HDR
colors. HDR colors are considered to be
any color with an intensity that is
greater than 1.

From 0 to 4096; defaults
to 4096.

Themaximum range of
the Intensity slider can
be adjusted in theMari
Preferences Dialog under
Color > Color
Management Defaults |
Color Picker Maximum.
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37 Tool Properties Palette
The Tool Properties palette and the controls that can be found on it are described in the table below. When
controls also bring up additional dialogs, these are referenced formore information.

What It Does
The Tool Properties palette displays information about the selected tool.

Tool Properties Palette Fields

Tool Control Type What it does Opens this
dialog box

Notes

Select > MriSelect >
General | Facing

dropdown Sets whether the selection only
applies to the Front of themodel
as you can see it, or if the selection
goes Through themodel and
includes the other side.
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Tool Control Type What it does Opens this
dialog box

Notes

Marquee Select Tool >
MriMarqueeSelectTool >
General | Crawling
Ants

checkbox Controls whether the
selection edges are
animated. If on, the edges are
animated.

Marquee Select Tool >
MriMarqueeSelectTool >
General | Type

dropdown The shape of the
selection drawn:

• Lasso - lets you draw a “free”
selection of any shape.

• Rectangle - lets you draw a
rectangular selection.

• Polygonal - lets you draw a
polygonal selection of any shape
by settingmultiple points before
closing the selection.

• Ellipse - lets you draw an oval
selection.

•MagicWand - lets you select by
color. When you click, Mari
creates a selection around the
point you clicked. The selection is
based on color – areas with a
similar color to the original point
are selected. You can change the
color threshold for the selection.
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Tool Control Type What it does Opens this
dialog box

Notes

Marquee Select Tool >
MriMarqueeSelectTool >
General |Mode

dropdown Howdrawing a new selection
affects the current marquee
selection:

• Replace - the new selection
replaces the existing selection.

• Transform - this lets youmove
you selection area around (move,
rotate, or scale the selection).

• Add - the new selection adds onto
the existing selection.

• Subtract - the new selection
removes areas of the existing
selection.

• Intersect - inverts the existing
selection. That is, any areas that
were selected become
unselected, and any areas that
were
unselected become selected.
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Tool Control Type What it does Opens this
dialog box

Notes

Marquee Select Tool >
MriMarqueeSelectTool >
General | Invert
Marquee Selection

button Inverts the current selection.
Unselected areas become selected,
and vice versa.

Marquee Select Tool >
MriMarqueeSelectTool >
General | Clear
Marquee Selection

button Clears the current selection.

Marquee Select Tool >
MriMarqueeSelectTool >
General | Enabled

checkbox Turns themarquee selection on
and off.

Marquee Select Tool >
MriMarqueeSelectTool >
General | Color
Threshold

entry box,
slider

Sets the color threshold for the
marquee selection. Setting a lower
value here results in amore
accurate color selection. Higher
values catchmore of the
surrounding color.

Marquee Select Tool >
MriMarqueeSelectTool >
General |Amount

entry box,
slider, reset

Sets howmuch themarquee
selection prevents painting outside
the selected area. This works as a
multiplier to the alpha of paint
applied outside the selection:

• At 1, only the area inside the
selection is paintable.

• At 0.5, paint outside the selection
applies with an alpha of 0.5.
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Tool Control Type What it does Opens this
dialog box

Notes

Marquee Select Tool >
MriMarqueeSelectTool >
Selection Edge |
Feathering

entry box,
counter

Controls how sharp the edge of the
selection area is. At 0, the selection
has a completely sharp edge. As
the value rises, the edges become
softer.

Marquee Select Tool >
MriMarqueeSelectTool >
Transform | Reset
Marquee Transform

button Resets any transformations
(moves, rotations, scales) applied
to themarquee selection area.

Marquee Select Tool >
MriMarqueeSelectTool >
Transform | Center

entry box Sets the center of themarquee
selection.

Use the
break link
button to
break the
link
between
the two
fields.

Marquee Select Tool >
MriMarqueeSelectTool >
Transform | Rotation

entry box Sets the rotation, in degrees, of the
marquee selection.

Marquee Select Tool >
MriMarqueeSelectTool >
Transform | Scale

entry box Sets the scale of themarquee
selection.

1 is the
original
scale.

Marquee Select Tool >
MriMarqueeSelectTool >
Transform |
Translation

entry box Sets the translated position
onscreen of themarquee selection.

No properties.

No properties.

No properties.
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Tool Control Type What it does Opens this
dialog box

Notes

Vector Inspector |
MriVector
InspectorTool

add
attribute

Click to add attributes. Add User
Attribute

Vector Inspector >
MriVectorInspectorTool >
General | Line Spacing

entry box,
slider

Adjusts the spacing between the
directionalmarkers.

Shift+
drag the
mouse
when the
vector
inspector is
active.

Vector Inspector >
MriVectorInpsectorTool >
General | Line Length

entry box,
slider

Adjust the length of the
directionalmarkers.

Vector Inspector >
MriVectorInspectorTool >
General | Start color

swatch Change the color at the base of the
directionalmarkers.

Vector Inspector >
MriVectorInspectorTool
>
General | End color

swatch Change the color at the tip of the
directionalmarkers.

Vector Inspector >
MriVectorInspectorTool >
General | Vector Space

dropdown Set whether the vector inspector
operates in ScreenSpace,
TangentSpace, orWorldSpace.

Vector Inspector >
MriVectorInspectorTool >
General | Rotation

entry box,
slider

Adjusts the rotation of the
directionalmarkers. This can be
changed using the slider, or by
entering a specific value.

Vector Inspector >
MriVectorInspectorTool
>
General | Translation

entry boxes The exact location in XY space of
the vector inspector. Entering
values adjusts the position of the
inspector too.
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Tool Control Type What it does Opens this
dialog box

Notes

Blur > (Same as Paint.) add
attribute

Click to add attributes. Add User
Attribute

No properties. add
attribute

Click to add attributes Add User
Attribute

No properties. add
attribute

Click to add attributes. Add User
Attribute

No properties. add
attribute

Click to add attributes. Add User
Attribute

Paint | Paint add
attribute

Click to add attributes Add User
Attribute

Paint > Paint > General
|
Description

information

Paint > Paint > General
| Name

information

Paint > Paint | Tip add
attribute

Brush tip details. This is a duplicate
of the section from the Brush
Editor Palette.

Add User
Attribute

Paint > Paint | Texture Brush texture details. This is a
duplicate of the section from the
Brush Editor Palette.

Paint > Paint |
Geometry

Brush geometry details. This is a
duplicate of the section from the
Brush Editor Palette.
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Tool Control Type What it does Opens this
dialog box

Notes

Vector Paint | Vector
Paint

add
attribute

Click to add attributes. Add User
Attributes

Vector Paint > Vector
Paint > General |
Description

information

Vector Paint > Vector
Paint > General |
Name

information

Vector Paint > Vector
Paint | Tip

add
attribute

Brush tip details. This is a duplicate
of the section from the Brush
Editor Palette.

Add User
Attribute

Vector Paint > Vector
Paint | Texture

add
attribute

Brush texture details. This is a
duplicate of the section from the
Brush Editor Palette.

Add User
Attribute

Vector Paint > Vector
Paint |Geometry

add
attribute

Brush geometry details. This is a
duplicate of the section from the
Brush Editor Palette.

Add User
Attribute

Eraser > (Same as
Paint)

add
attribute

Click to add attributes. Add User
Attributes

37 TOOL PROPERTIES PALETTE |



256

Tool Control Type What it does Opens this
dialog box

Notes

Paint Through > Same
as Paint except:

Texture does not
include
Geometry. And it
includes the following:
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Tool Control Type What it does Opens this
dialog box

Notes

Texture > Image |

Filename

entry box,
button

Texture > Info |
Description

information

Texture > Info |Height information

Texture > Info |Width information

Texture > Preview |
PreviewAlpha

entry box,
slider

Range:
0.10 to
1.00

Texture > Preview |
Image

image

Texture > Transform |
Image Scale

two entry
boxes

Enter values to scale the image on
the x and y axes.

Texture > Transform |
ImageScale

button Locks the current ImageScale
values so that any changes to scale
are applied proportionately to
both axes.

Texture > Transform |
Pan Lock

checkbox Locks the image position relative to
themodel. If you pan themodel,
the image that you're painting
through pans too.

Texture > Transform |
Scale Lock

checkbox Locks the image size relative to the
model. If you zoom themodel in or
out, the image that you're painting
through zooms in or out too.

Texture > Transform |
Reset Size

dropdown ToOriginalSize,
RelativeToPaintBuffer.

Texture > Transform |
Auto Reset

dropdown Reset, DoNotReset.
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Tool Control Type What it does Opens this
dialog box

Notes

Texture > Gradient >
Info |Width

information

Texture > Gradient >
Preview | Preview
Alpha

swatch The alpha value to use for the
gradient “floating” over themain
canvas

Texture > Gradient >
Preview | Image

image Preview version of the gradient
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Tool Control Type What it does Opens this
dialog box

Notes

Gradient > Same as
Paint except:

Texture does not
includeGeometry. And
it includes:
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Tool Control Type What it does Opens this
dialog box

Notes

Texture > Gradient >
Gradient |Description

information

Texture > Gradient >
Gradient |Name

information

Texture > Gradient >
Gradient |Name

dropdown Selects between Linear or Radial
gradient.

Texture > Gradient >
Gradient |Out Point

entry box,
slider

How far through the gradient the
final color reaches.

0.00 to
1.00,
higher
values
imply the
end color is
reached
later.

Texture > Gradient >
Gradient | In Point

entry box,
slider

How far through the gradient the
start color lasts for (before it starts
graduating into the end color).

0.00 to
1.00,
higher
values
imply the
start color
finishes
later.

Texture > Gradient >
Gradient | End

swatch Final color for the gradient (color
that the gradient ends up as).

Texture > Gradient >
Gradient | Start

swatch First color for the gradient (color
the gradient starts out as).

Texture > Gradient >
Info |Height

information

37 TOOL PROPERTIES PALETTE |



261

Tool Control Type What it does Opens this
dialog box

Notes

Clone Stamp > Same as
Paint Through except
it includes:

Texture > Debug |
Relative

checkbox

Texture > Debug
|DebugView

checkbox

Texture > Debug |
Preview Alpha

entry box,
slider

Range:
0.10 to
1.00

Texture > Image | Clone
From

two entry
boxes

Texture > Preview |
Onscreen Preview

checkbox

Towbrush >
MriTowbrush > General
| Falloff

entry box,
slider

Sets how sharply the texture
blends in from the edges of the
selected patch. Higher values have
sharper transition to the
surrounding texture, lower values
blendmore smoothly.

Towbrush >
MriTowbrush > General
| Value

entry box,
slider

Controls howmuch of the color of
the original patch to preserve.
Higher values keepmore of the
original color, lower values blend
thewhole patch in with the
background as youmove it.
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Tool Control Type What it does Opens this
dialog box

Notes

Eye Dropper > General |
Sample Size

entry box,
slider

Radius in pixels that the
eyedropper uses when sampling
colors off the surface of themodel.

Range: 1 to
15

Eye Dropper > Graph |
Grid Size

entry box,
slider

The size of the grid overlay.

Eye Dropper > Graph |
Grid

checkbox Enable the grid overlay.

To see the grid overlay youmust
select a Type other thanNone.

Eye Dropper > Graph |
Color

swatch The color of the grid overlay.

Eye Dropper > Graph |
Type

dropdown The orientation of the Eye
Dropper guide. When Both is
selected, both axes of the guide are
displayed.
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38 Painting Palette
The Painting palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Painting palette displays information and controls formanaging painting features.

Painting Palette Fields

Control Type What it does Opens
this
dialog
box

Notes

Painter > Filtering | Image dropdown The image filtering to usewhen
copying textures using the clone
tools (CloneStamp and
PaintThrough). One of:

•Nearest - preserves edge detail,
but gives quite "blocky" textures.

• Bilinear - gives good results, but
can produce square artifacts at
extreme zoom.

• Bicubic - providesmore rounded
results, slightly blurrier but without
the square artifacts.
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Control Type What it does Opens
this
dialog
box

Notes

Painter > SourceGrade | Enabled checkbox Enables source image grading.

Used this to grade your source
imagewhen cloning fromor painting
through an image.

Painter > SourceGrade | Rgb entry box,
slider

Changes the overall color saturation
for all three color components of
the source image. Moving this also
moves the separateRed,Green,
and Blue sliders.

Painter > SourceGrade | Red entry box,
slider

Changes the color saturation in the
Red component of the source
image.

Painter > SourceGrade |Green entry box,
slider

Changes the color saturation in the
Green component of the source
image.

Painter > SourceGrade |Blue entry box,
slider

Changes the color saturation in the
Blue component of the source
image.

Painter > SourceGrade | Contrast entry box,
slider

Changes the contrast of the source
image.

Painter > SourceGrade |
Saturation

entry box,
slider,
reset

Changes the saturation of the
source image.

Painter > SourceGrade |
Saturation

entry box,
slider

Changes the color saturation of the
source image. Used in addition to
the RGB sliders.

Painter > SourceGrade | Value curve
editor

Allows you to edit the color value
curve for the source image.
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Control Type What it does Opens
this
dialog
box

Notes

PaintBuffer > PaintBuffer |
ColorDepth

dropdown Color depth of the paint buffer. 8,
16, or 32-bit color.

PaintBuffer > PaintBuffer |
BufferSize

dropdown Onscreen resolution of the paint
buffer. This controls the amount of
detail you can usewhen painting,
not the resolution of the patches in
your project.

PaintBuffer > PaintBuffer | Clamp checkbox If this is checked, Mari restricts the
range of the image to values
between 0 and 1.

PaintBuffer > Transform |
Translation

entry
boxes

The amount that the buffer has
been translated (moved onscreen)
from the default.

PaintBuffer > Transform | Scale entry
boxes

The amount that the buffer has
been scaled (resized) from the
default.

PaintBuffer > Transform |
Rotation

entry box,
slider

The amount that the buffer has
been rotated from the default.

PaintBuffer > Transform | Reset button Resets the paint buffer to the
default values, removing any
translations or distortions you have
applied.

PaintBuffer > Transform |
Resetonbake

dropdown Either:

• Enabled - the paint buffer
automatically resets to default
settings every time you bake the
paint.

• Disabled - any changes you have
made to the paint buffer stay until
youmanually click theReset
button.
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39 Projection Palette
The Projection palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Projection palette holds controls for howMari projects the paint onto themodel. This includes details of the
variousmasks available (edgemask, channelmask, depthmask, ambient occlusionmask, backfacemask and fractal
noisemask).

Projection Palette Fields

Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > Masking |
Masking Disabled

checkbox Disables all masking,
regardless of channel, and
overrides theMasking
Enabled setting.

When enabled, a

icon
displays in the
status bar.

Projection Settings > Masking |
Mask Preview Color

swatch What color to display the
masking on-screen.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > Masking |
MaskPreviewEnabled

checkbox Shows themasking. Areas that
are covered by the current
definedmask(s) are shown
colored. This includes all the
masking currently in use – for
example, if you have both the
edgemask and depthmask
turned on, Mari shows the
effects of both
simultaneously.

When enabled, a

icon
displays in the
status bar.

Projection Settings > Painting |
PaintingMode

dropdown The blendingmode used when
the paint bakes down onto the
channel surface. The default is
Normal (paint in the buffer
overwrites the surface), but
Mari supports a number of
other blendingmodes.

Projection Settings > Painting |
PaintingOpacity

entry box,
slider,
reset

How opaque the paint is. This
is amultiplier on the paint
buffer contents. At 1.0, the
paint bakes down to the
surfacewith the same opacity
as it is in the buffer. At 0.5, the
paint applied to the surface is
half as transparent as when
it's in the buffer.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > Projection |
ProjectionFilter

dropdown The image filtering to use
when calculating how to apply
the paint buffer onto the
surface. One of:

•Nearest - preserves edge
detail, but gives quite
"blocky" textures.

• Bilinear - gives good results,
but can produce square
artifacts at extreme zoom.

Projection Settings > Projection |
BakeBehavior

dropdown One of:

•Manual - you have to bake
manually. After a bake, the
paint stays in the paint
buffer until youmanually
clear it.

• ClearOnly - you have to
bakemanually. After a bake,
the paint buffer clears
automatically.

• AutoBakeAndClear - Mari
bakes, and then clears the
paint buffer, whenever you
move themodel.

Projection Settings > Projection |
Projection

dropdown One of:

• Front - paint only applies to
the front of themodel, as it
is visible in the current view.

• Through - paint applies to all
surfaces on themodel under
your brush, whether or not
there is something in front
of them.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > Projection |
ProjectOn

dropdown Either:

• All - you can paint on all
areas on yourmodel(s),
selected or not.

• SelectedOnly - you can only
paint on the currently
selected areas.

Projection Settings > EdgeMask toggle Whether the edgemask is
turned on or not. If this is on,
butMaskPreviewEnabled is
off, themodel ismasked but
you won't see themasking.
That is, you can see themask's
effects, but not themask
itself.

When enabled, a

icon
displays in the
status bar.

Projection Setttings > EdgeMask >
General | Falloff Curve

curve
editor,
reset

Sets how the edgemasking
falloff works.

The X axis is the transition
from the Falloff Start to
Falloff End. The Y axis is how
paintable the target pixel is. By
default, the curve runs from
the bottom at the left up to
the top at the right - so there’s
a smooth, constant falloff.

Projection Settings > EdgeMask >
General | FalloffEnd

entry box,
slider,
reset

Controls where the edgemask
ends on themodel. The higher
the value, the closer, more
forward facing themask
finishes.

Range: 0.00 to
1.00 Reset: 0.00
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > EdgeMask >
General | FalloffStart

entry box,
slider,
reset

Controls where the edgemask
starts on themodel. The
higher the value, themore
forward facing themasking
starts. If this is higher than the
FalloffEnd, areas facing the
view are paintable, and areas
oblique to the view are
masked. If this is lower, facing
areas aremasked and oblique
areas are paintable.

Range: 0.00 to
1.00 Reset: 0.00

Projection Settings > ChannelMask toggle Whether the channelmask is
turned on or not. If this is on,
butMaskPreviewEnabled is
off, themodel ismasked but
you won't see themasking.
That is, you can see themask's
effects, but not themask
itself.

When enabled, a

icon
displays in the
status bar.

Projection Settings > ChannelMask >
General |MaskChannel

dropdown Sets the channel holding the
mask for the paint buffer. This
mask sets the paintable area
within the buffer.

Projection Settings > ChannelMask >
General |MaskAmount

entry box,
slider,
reset

The amount that themask
affects the paint buffer. 1.0
means that themask
absolutely controls where you
can paint; the effects of the
mask decrease as the value
gets lower.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > ChannelMask >
General |MaskContrast

entry box,
slider,
reset

The contrast applied to the
original channel to derive the
mask. At 1.0, themask comes
directly from the original
channel. Lower valuesmake
themask fuzzier than the
input channel, higher values
make it sharper than the input
channel.

Projection Settings > ChannelMask >
General |Mask Curve

curve
editor,
reset

Sets how the channelmasking
works.

The x axis is the color of the
source pixel (black to the left,
white to the right). The y axis is
how paintable the target pixel
is. By default, the curve runs
from the bottom at the left up
to the top at the right - so
black pixels are totally masked,
white pixels are totally
paintable, and there's a
constant curve between the
two. Use this if you want to
changewhich pixel values are
masked.

Projection Settings > ChannelMask >
General | Invert

check box Whether to invert the input
from themask. If this is
selected, themask data is
black on white rather than
white on black.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > Ambient
Occlusion Mask

toggle Whether the ambient
occlusionmask is turned on or
not. If this is on, but
MaskPreviewEnabled is off,
themodel ismasked but you
won't see themasking. That is,
you can see themask's effects,
but not themask itself.

Before using this, you should
calculate the ambient
occlusion for each object in
the project (Objectsmenu,
select AmbientOcclusion).

When ambient
occlusion
masking is

enabled, a
icon displays in
the status bar.

Projection Settings >
AmbientOcclusionMask > General |
Mask Amount

entry box,
slider,
reset

The amount of ambient
occlusionmasking to apply.

Projection Settings >
AmbientOcclusionMask > General |
MaskContrast

entry box,
slider,
reset

The contrast applied to the
ambient occlusion to derive
themask. At 1.0, themask
comes directly from the
calculated ambient occlusion.
Lower valuesmake themask
fuzzier than the ambient
occlusion, higher valuesmake
it sharper.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings >
AmbientOcclusionMask > General |
MaskCurve

curve
editor,
reset

Controls how the ambient
occlusion pixel values relate to
the degree of masking. The
horizontal axis is the darkness
of the occluded pixels (black to
the left, white to the right), the
vertical axis is the degree of
visibility. By default, this is a
direct line, wherewhite pixels
are totally masked, black pixels
are totally unmasked, and
50% gray is 50%masked.

Projection Settings >
AmbientOcclusionMask > General |
Invert

checkbox If this is selected, themask
data is black on white rather
than white on black.

Projection Settings > DepthMask toggle Whether the depthmask is
turned on or not.

When enabled, a

icon
displays in the
status bar.

Projection Settings > DepthMask >
General | Start

entry box,
slider,
reset

The depth in the scene for the
depthmasking to start.

Projection Settings > DepthMask >
General | End

entry box,
slider,
reset

The depth in the scene for the
depthmasking to finish.

Projection Settings > DepthMask >
General | Falloff

entry box,
slider,
reset

How fast the depthmasking
applies. Lower valuesmake
themask apply slowly, higher
valuesmake it apply more
quickly.
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Control Type What it does Opens
this
dialog
box

Notes

Projection Settings > BackfaceMask toggle Whether the backfacemask is
turned on or not.

When enabled, a

icon
displays in the
status bar.

Projection Settings > Fractal Noise
Mask

toggle Whether the fractal noise
mask is turned on or not.

When enabled, a

icon
displays in the
status bar.

Projection Settings > Fractal Noise
Mask > General | Seed

entry box,
slider,
reset

Changes the pattern of the
noise by moving the pattern
through 3D space.

Projection Settings > Fractal Noise
Mask > General | Contrast

entry box,
slider,
reset

Controls the level of contrast
applied to the fractal noise
features to derive themask.

Projection Settings > Fractal Noise
Mask > General | Roughness

entry box,
slider,
reset

Determines the roughness of
the fractal noise features.

Projection Settings > Fractal Noise
Mask > General | Size

entry box,
slider,
reset

Determines the size of the
fractal noise features.

Projection Settings > Fractal Noise
Mask > General |Mask Amount

entry box,
slider,
reset

The amount that themask
affects the paint buffer. 1.0
means that themask
absolutely controls where you
can paint; the effects of the
mask decrease as the value
gets lower.
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Control Type What it does Opens
this
dialog
box

Notes

ProjectionSettings > Fractal Noise
Mask > General |Mask Curve

curve
editor,
reset

Controls how the fractal noise
relates to the degree of
masking, based on the above
fields. This allows you to fine
tune the contrast and pattern
appearance of the fractal
noisemask.

Projection Settings > Fractal Noise
Mask > General | Invert

checkbox If this is selected, themask
data is black on white rather
than white on black.

39 PROJECTION PALETTE |



40 Shelf Palette
The Shelf palette and the controls that can be found on it are described in the table below. When controls also bring
up additional dialogs, these are referenced formore information.

What It Does
The Shelf stores sets of brushes and colors. These include:

•Menu shelf - the content of the F9menu.

• Personal shelf (with customized items) - selected items you use regularly.

• Basic Brushes shelf - a set of predefined basic brushes.

•Hard Surface Brushes shelf - a set of predefined hard surface brushes.

•Organic Brushes shelf - a set of predefined organic brushes.

• Project - shelf items for just the current project.

Shelf palette fields

Control What it does Notes

Types of Controls Select from shelves, click icons to add
new shelf, spawn floating shelves, delete
custom shelves.

Mari saves shelves as .msh files, and itemswithin
shelves (which you can save through a right-click
option) as .msi files.

Right-click to toggle icon size (for example, to use
smaller icons to create color swatches).
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The Snapshots palette and the controls that can be found on it are described in the table below. When controls also
bring up additional dialogs, these are referenced formore information.

What It Does
The Snapshots palette displays:

• a list of snapshots for the entire project or currently selected channel

• buttons to take, revert, or delete channel snapshots

• information about snapshots, such as name, when they were created and by what user.

Snapshots Palette Fields

Control Type What it does Opens this
dialog box

Notes

Channels > All button Displays a list of all
snapshots in the
project.

Channels > Current button Displays a list of
snapshots for the
currently selected
channel.

Created info The date and timewhen
the snapshot was taken.

Preview thumbnail A thumbnail preview of
the snapshot.

Name info The name of the
snapshot.
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Control Type What it does Opens this
dialog box

Notes

User info The name of the user
that created the
snapshot.

button Takes a new snapshot.
Depending on whether
Channels > All, or
Channels > Current is
selected, this button
behaves differently. If
All is selected, a
snapshot is taken for all
channels in a project. If
Current is selected, a
snapshot is only taken
for the current channel.

Snapshot All
Channels.

Snapshot
Channel.

button Extracts the snapshot
into a new channel in
theChannels palette
and populates the
Layers palette with the
layers of the snapshot.

Extract
Snapshot

This option is
only
available
when the
Channels >
Current
button is
active.

button Loads the selected
snapshot.

button Deletes the selected
snapshot.

Delete
Snapshot
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42 New Project Dialog
TheNew Project dialog is described belowwith functions for how to access it. A list of the controls on the dialog
box can be found in the table below.

What It Does
TheNewProject dialog box lets you select geometries and various options for a newMari project. Use the Path
control to select an .obj, .ptx, or .abc file you want to use in the project.

Resize the dialog box to display long filenames or select multiple files to display more than one geometry, if they are
of the same file type. Mari checks themodel for any errors that might prevent it fromprocessing, for example
whether UVs overlap or touch border edges. AMesh Sanity Check dialog displays any warnings or errors. (Errors
cancel opening themodel, but you can continuewith warnings.)

Depending on the size and complexity of textures, it can take several minutes the first time you load them into a
Mari project. Once saved, however, the project should open quickly in future.

How to Access It
•Menubar | File > New

• Keyboard | Ctrl/Cmd+N

• Projects tab |New button

• Projects tab | Right-click > New

• Toolbar |
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New Project Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Name entry box Lets you specify the name of
the project.

This is for you to identify
the project only (this is not
a filename).

Geometry | Path entry box,
dropdown,
button

Opens .obj, .ptx, or .abc
files. Dropdown lists the last
10 opened.

Once you select a file, the
Mesh options appear under
theRoot Path.

Pick Mesh
dialog

Select by either typing the
Path, selecting from the
dropdown of the last 10
files selected, or
clicking the icon to browse
to a file.

Geometry > Mesh
options |Mapping
Scheme

dropdown If there is a UV map available,
and you would like to use it,
select UV if available, Ptex
otherwise. If you prefer to
use Ptex, select Force Ptex.
This option loads the selected
geometry and replaces the
existing UVmap with a Ptex
map.

Only available when
choosing .obj or .abc files
in the Path.

Geometry > Mesh
options | Selection
Sets

dropdown Selection sets have two
options, to either:

• Create From Face Groups
- this is the default behavior
and allows the use of
selection sets in Mari.

• Don’t Create - if you
choose not to create a
selection set, Mari does not
create any from the file.

Only available when
choosing .obj files in the
Path.
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Control Type What it does Opens this
dialog box

Notes

Geometry > Mesh
options |Multiple
Geometries Per
Object

dropdown If your .obj consists of
multiple geometries, you
have the option toMerge
Geometries Into One,
which is the default behavior,
or Create Separate
Geometries (Ptex Only). If
you selectMerge
Geometries Into One, Mari
combines the individual
geometries into a single
geometry, while selecting
Create Separate
Geometries (Ptex Only)
creates individual
geometries.

Only available when
choosing .obj files in the
Path.

Even if you select Create
Separate Geometries
(Ptex Only), Mari only
displays a single geometry
on the canvas. However,
when you export a
channel you have the
option to export individual
.ptx files for each
geometry.

Geometry > Mesh
options | Start
Frame and End
Frame

entry box Set the frame range from the
source file to import.

Only available when
choosing .obj and .abc file
sequences in the Path.

Geometry > Mesh
options | Single
Frame

button Sets the other fields to only
import the first frame from
the animation in the object
file.

Only available when
choosing .obj and .abc file
sequences in the Path.

Geometry > Mesh
options |All Frames

button Sets the other fields to
import the entire animation
from the object file.

Only available when
choosing .obj and .abc file
sequences in the Path.
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Control Type What it does Opens this
dialog box

Notes

Geometry > Mesh
options | Process
each geometry file
as a

dropdown For Ptex files, there are two
choices for the geometry
mesh options:

• Separate Object - creates
only one object with one
geometry.

• Separate Geometry In
One Object - creates only
one object, but hasmultiple
geometries within it.

Only available when
choosing .ptx files in the
Path.

The option to Separate
Geometry In One
Object is essentially the
inverse of the Ptex
channel export process,
and allows project
reconstruction.

Geometry > Mesh
options |Merge
Type

dropdown Choosewhether to merge
selected items from the
object hierarchy tree as:

• Single Mesh - merges
selected geometry into one
singlemesh in a GeoEntity.
Note that this implies that
the information about the
original geometries cannot
be accessed once themerge
is done.

• Just Merge Nodes -
merges selected geometry
into oneGeoEntity while
retaining themetadata and
mesh information about
the original individual
geometries. Note, this
information can only be
accessed by more technical
users using the C API.

Only available when
choosing .abc files in the
Path.
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Control Type What it does Opens this
dialog box

Notes

Geometry > Mesh
options | Scene

information In the object hierarchy,
shows all the geometries or
meshes, cameras, and groups
that are part of the selected
Alembic file. Note, expanding
the parent row, reveals the
child geometries beneath it.

Only available when
choosing .abc files in the
Path.

Geometry > Mesh
options |Merge

checkbox Select the checkbox to
determine if a geometry is to
bemerged with another on
project creation.

Only available when
choosing .abc files in the
Path.

Formore information on
merging Alembic
geometry, see Create New
Project under the Alembic
chapter in theMari User
Guide.

Geometry > Mesh
options | Frame
Offset

entry box Set by howmany frames to
offset the loading of an
animated object. You can
specify a frame range, or
simply a number of frames.

Only available when
choosing .abc files in the
Path.

Texture | Root Path dropdown,
button

Displays the root path for the
project. This is whereMari
looks for any existing
textures to import as it
creates the channels.

Choose Base
Path dialog

This is the value that Mari
substitutes for $PATH in
the import templates in
the bottom list.

Texture | Scan button Scans the Root Path for any
existing texture files.

After scanning the Root
Path, you should always
set the Size of the texture
filesmanually. The default
valuesMari setsmay not
be correct as channels can
containmany different
patch sizes.
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Control Type What it does Opens this
dialog box

Notes

Texture | Prefix entry box Filename prefix for existing
texture files, if applicable.

Texture | Create checkbox Select this to create the listed
channel.

Texture | Import checkbox Select this to import existing
textures into the channel
after creating it.

Texture |Name information Nameof the channel to
create. Mari sets a default
value, but you can change
this.

For example, color,
specRough, dispFine,
dispBroad, colorDetail,
colorDetailMask.

Texture | Size dropdown Patch size for the new
channel. Mari sets a default
value, but you can change
this.

256x256, 512x512,
1024x1024, 2048x2048,
4096x4096, 8192x8192,
16384x16384,
32768x32768

Texture | Type dropdown Channel type. Mari sets a
default value, but you can
change this.

Color or Scalar

texture | File Space dropdown The file space used when
generating vectors. Mari sets
a default but you can change
this.

Normal or Vector.

Texture | Fill swatch Color to fill the new channel.
Mari sets a default value, but
you can change this.

Click the swatch to change
the color.

Texture |Depth dropdown The color depth size. Mari
sets a default value, but you
can change this.

8bit (Byte), 16bit (Half),
or 32bit (Float).
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Control Type What it does Opens this
dialog box

Notes

Texture | Files entry The filename template used
to pick existing textures to
import into the channel. Mari
sets a default value, but you
can change this, or you can
use the button to open a
dialog allowing you to
manually pick the files.

Texture |
button Opens a dialog box allowing

you to pick the textures for
Mari to import into the new
channel.

Import Dialog

Texture |
image Indicates that Mari has not

found any textures to
import.

If there are textures to
import, Mari displays the
number of patches
available.
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43 Select Color Dialog
The Select Color dialog is described belowwith functions for how to access it. A list of the controls on the dialog box
can be found in the table below.

What It Does
The Select Color dialog box lets you view and change colors. The controls on this palette all work together - as you
change the color through one control, the other controls update to show your change.

How to Access It
• Tools toolbar | Foreground color swatch

• Tools toolbar |Background color swatch

• Colors palette | Foreground color swatch

• Colors palette |Background color swatch

• Add Channel dialog | Color color swatch

• HSV palette | Color swatch

Select Color dialog box fields

Control Type What it does Notes

swatch Displays currently selected color.

entry box,
slider

Specify Red values. Range: 0.000 to 1.000

entry box,
slider

Specify Green values. Range: 0.000 to 1.000
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Control Type What it does Notes

entry box,
slider

Specify Blue values. Range: 0.000 to 1.000

entry box,
slider

Specify Alpha values. Range: 0.000 to 1.000

entry box,
slider

Specify Hue values. Range: 0.000 to 0.999

entry box,
slider

Specify Saturation values. Range: 0.000 to 1.000

entry box,
slider

Specify Value values. Range: 0.000 to 1.000

History Swatches swatch These swatches store the 5 most
recently selected colors. When a new
color is selected, it is added to the top
of the list. Clicking on a swatch selects
it as the current color.

You can drag and drop
from the current swatch
to the history swatches
to manually arrange the
colors.

HSV tab: field,
sliders,
option
buttons

Use this to pick colors from a
Hue/Saturation/Value field.

To create custom color
spectrums. Adjust the
field values using the
controls on the right,
then click in the field to
set the foreground color.

Values tab: field Use the fields to manually enter RGBA
and HSV values for eitherByte (8 Bit),
Half (16 bit), or Float (32 Bit)
categories.

This sets the default
values for RGBA and HSV
colors when creating
either 8 bit, 16 bit, or 32
bit channels.

Grey tab:
sliders,
buttons

Use this to pick a gray value from the
gradient, or one of the presets.

43 SELECT COLORDIALOG |
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Control Type What it does Notes

Intensity entry box,
slider

Adjusts the intensity of colors in the
Select Color dialog to select HDR
colors. HDR colors are considered to
be any color with an intensity that is
greater than 1.

From 0 to 4096; defaults
to 0.

Themaximum range of
the Intensity slider can
be adjusted in theMari
Preferences Dialog under
Color > Color
Management Defaults |
Color Picker
Maximum.

button Pick a color fromwithin Mari, as well as
from your desktop or other windows

Canvas dropdown The type of pixels you want the color
picker to pick from. Either Pick screen
Pixels or Pick raw pixels.

43 SELECT COLORDIALOG |



44 Advanced Blending Mode
TheAdvanced Blendingmode pop-up fromwithin the Layers palette is described belowwith functions for how to
access it. A list of the controls in the pop-up can be found in the table below.

What It Does
TheAdvanced Blending mode pop-up lets you adjust the blended colors before the blendingmode is applied to
the selected layers and layered shaders. Thesemodes can be applied to each layer independently, regardless of
whether it already has other adjustments applied to it.

How to Access It
• Button | Layers Palette >

• Button | Shaders Palette > Shader Layers Tab Fields >

• Button |Mask Stack >

• Button | Adjustment Stack >

Advanced Blending Mode Fields

Control Type What it does Opens this
dialog

Notes

Mode dropdown Select the blendmode that you want to
modify with the advanced settings.

Amount entry box,
slider

Adjusts the blendmode amount.
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Control Type What it does Opens this
dialog

Notes

Amount
Enabled

dropdown Enable orDisable the ability to change
the blendmode amount.

If Amount has already
beenmodified and
Amount Enabled is set
to Disable, then the
amount is not reset to
the default. It is locked to
the amount entered
whenDisable was set.

Blending dropdown Choosewhether to modify the blending
modewith Basic orAdvanced
settings. If you select Basic, the
Component field and the curve editor
fields cannot bemodified.

Component dropdown Select either theGreyscale, Red,
Green, Blue, or Luminance
components to adjust whenmodifying
the curve editors and applying the
blendmode.

This Layer curve
editor

Maps between input and output values
for the selected layer.

Drag to move points on
the graph. Add points by
clicking on the curve. Edit
a point by right-clicking it.

Below layer curve
editor

Maps between input and output values
for the layer stack below the selected
layer.

Drag to move points on
the graph. Add points by
clicking on the curve. Edit
a point by right-clicking it.

Swizzle Red dropdown Select the component - R,G, B,A,One,
or Zero - that is output from the Red
color component. This allows you to re-
arrange the RGBA values.

By default, the Red
component is set to
output red color values.
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Control Type What it does Opens this
dialog

Notes

Swizzle
Green

dropdown Select the component - R,G, B,A,One,
or Zero - that is output from theGreen
color component. This allows you to re-
arrange the RGBA values.

By default, the Green
component is set to
output green color
values.

Swizzle Blue dropdown Select the component - R,G, B,A,One,
or Zero - that is output from the Blue
color component. This allows you to re-
arrange the RGBA values.

By default, the Blue
component is set to
output blue color values.

Swizzle Alpha dropdown Select the component - R,G, B,A,One,
or Zero - that is output from the Alpha
component. This allows you to re-
arrange the RGBA values.

By default, the Alpha
component is set to
output alpha values.
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45 Add Channel Dialog
TheAdd Channel dialog is described belowwith functions for how to access it. A list of the controls on the dialog
box can be found in the table below.

What It Does
This allows you to add a single channel to your project. The dropdown at the top of the dialog box lets you select
from recently created channels. If you select a channel from the dropdown, Mari updates the rest of the fields with
the details you used last time. You can change any of the values if required.

How to Access It
•Menubar | Channel > Add Channel

• Right-click | in Channels Palette > Add Channel

• Button | Channels Palette >

• Button | Shaders Palette >

Add Channel Dialog Box Fields

Control Type What it does Opens
this dialog
box

Notes

<Previous
channel
names>

dropdown This holds the names of recently created
channels. Select a channel from the list, and the
rest of the dialog box updates with the details
from the last time the channel was created.
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Control Type What it does Opens
this dialog
box

Notes

Name information,
dropdown

Nameof the channel to create.

Size dropdown Patch size for the new channel. Either 256x256,
512x512, 1024x1024, 2048x2048,
4096x4096, 8192x8192, 16384x16384, or
32768x32768.

Depth dropdown Color depth for the new channel.Either 8bit
(Byte), 16bit (Half), or 32-bit (Float).

ColorSpace dropdown The type of channel. Either Color or Scalar. Scalar channels
do not use color
correction.

File Space dropdown The type of file space used for vector painting.
EitherNormal orVector.

Color swatch Color to fill the new channel. Click the swatch to
change the color.

Select Color
Dialog

45 ADD CHANNELDIALOG |



46 Add Multiple Channels Dialog
TheAdd Multiple Channels dialog is described belowwith functions for how to access it. A list of the controls on
the dialog box can be found in the table below.

What It Does
Addsmultiple channels at once. Mari takes the channels available frompredefined sets of standard channels for
types of assets - for example, the channels required to paint a vehicle. You can select which channels from the set to
create.

Also, if there are existing textures for the channels, Mari can automatically load these in as it creates the channels.
Mari automatically detects existing textures that conform to the selected naming convention. You can write config
files that add new sets of channels to theCategory field. See the Extending Mari chapter in theMari User Guide for
details.

How to Access It
•Menubar | Channel > Channel Presets

• Right-click | channel in Channels Palette > Channel Presets

• Button | Channels Palette >
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Add Multiple Channels Dialog Box Fields

Control Type What it does Opens
this dialog
box

Notes

Root Path dropdown Displays the root path for the project.
This is whereMari looks for any
existing textures to import as it creates
the channels.

Choose
Base Path

This is the value that Mari
substitutes for $PATH in the
import templates in the
bottom list.

Scan button Scans the Root Path for any existing
texture files.

Import dropdown Whether to import all patches in the
project or only the selected ones. This
applies to every channel being
imported during the creation.

Resize dropdown HowMari handles patch/image size
mismatches (for example, attempting
to import a 1024x1024 image to a
2048x2048 patch). You can select
either to resize the images to match
the patches, or to resize the patches to
match the images.

Prefix entry box Filename prefix for existing texture
files, if applicable.

Create checkbox Select this to create the listed channel.

Import checkbox Select this to import existing textures
into the channel after creating it.

Name information Nameof the channel to create. For example, color, specRough,
dispFine, dispBroad,
colorDetail, colorDetailMask.
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Control Type What it does Opens
this dialog
box

Notes

Size dropdown Patch size for the new channel. Mari
sets a default value, but you can
change this.

Type dropdown Channel type. Either Color or Scalar.
Mari sets a default value, but you can
change this.

Fill swatch Color to fill the new channel. Mari sets
a default value, but you can change
this.

Click on the swatch to set the
color.

Files entry The filename template used to pick
existing textures to import into the
channel. Mari sets a default value, but
you can change this, or you can use the
button to open a dialog allowing you to
manually pick the files.

button Opens a dialog box allowing you to pick
the textures forMari to import into the
new channel.

Import
Channel

image Indicates that Mari has not found any
textures to import.

If there are textures to import,
Mari displays the number of
patches available.
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47 Masks Formats Dialog
TheMasks Formats dialog is described belowwith functions for how to access it. A list of the controls on the dialog
box can be found in the table below.

What It Does
This allows you to set up a designatedmaterial channel to usewhen you are creating a layered shader.

How to Access It
•Menubar | Shading > Add New Shader > Layered

• Right-click | in Shaders Palette > Add New Shader > Layered

• Button | Shaders Palette > > Layered
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Mask Formats Dialog Box fields

Control Type What it does Opens this
dialog box

Notes

Size dropdown Set the channel size when creating amask to
be:

• 256x256

• 512x512

• 1024x1024

• 2048x2048

• 4096x4096

• 8192x8192

• 16384x16384

• 32768x32768

Depth dropdown Sets the channel depth when creating amask
to be:

• 8bit (Byte)

• 32bit (Float)

• 16bit (Half)
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48 Channel Presets Dialog
TheChannel Presets dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Allows you to set up preferences for quickly creating channels through theChannels palette ormenu. These presets
include options such as the color depth size, patch size, file space, and color space. This gives you the opportunity to
quickly set up a channel template for channel types you know are going to be created numerous times.

How to Access It
•Menubar | Channels > Channel Presets

• Right-click | in Channels Palette > Channel Presets

Channel Preset Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Root Path entry box,
dropdown,
button

Specify the file path for the creation of new
channel templates.

The browse and
scan
buttons also
allow you to
search for the
file location.

Import dropdown Select which patches to import if a channel is
being imported for the creation of the template.
Options are: All Patches.
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Control Type What it does Opens this
dialog box

Notes

Resize dropdown Select which files should be resized when patches
are being imported for channel template
creation. Options are: Patches to fit images or
Images to fit patches.

Prefix entry box Specify a prefix for organizing created channels.

Create checkbox Select which channel templates you want to
create from the list in the dialog.

Import checkbox Select which channel templates you want to
create from imported channels. Import settings
were selected from the earlier option in the
dialog.

Name information Nameof the channel type; for instance, color,
displacement, or specular.

Size dropdown Select a patch size for the channels from the
options: 256x256, 512x512, 1024x1024,
2048x2048, 4096x4096, 8192x8192,
16384x16384, 32768x32768.

Channels can
be resized later
from the
Channels
menu or palette
if necessary.

Type dropdown Select a color space for the created channel
template. Options are: Color or Scalar.

File Space dropdown Select a file space for the created channel
template. Options are: Normal and Vector.

Fill swatch Select a color to use for the background of
channel template.

Select Color
Dialog

48 CHANNEL PRESETS DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Depth dropdown Select a color depth size for the created channel
template. Options are: 8bit (Byte), 16bit (Half),
32bit (Float).

The color depth
size for
channels can be
resized later
from the
Channels
menu or palette
if necessary.

Files entry box Specify a file location to be imported.

button Select a file to import for the channel template.
This corresponds to the File entry box above.

icon
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49 Convert Type Dialog
TheConvert Type dialog is described belowwith functions for how to access it. A list of the controls on the dialog
can be found in the table below.

What It Does
Converts the color depth of the selected channel into a different bit depth. The color depth determines the number
of pixels per RGB channel. Existing channels set to another color depth can be converted by simply selecting them
and opening theConvert Type dialog box.

How to Access It
•Menubar | Channels > Convert Channel

• Right-click | in Channels Palette > Convert Channel

• Button | in Channels Palette >

Convert Type Dialog Box Fields

Control Type What it does Opens
this dialog
box

Notes

Type dropdown The color depth options for converting the
selected channel. Depth sizes are: 8bit (Byte),
16bit (Half), and 32bit (Float).

Note that you
should only see
two options in
the dropdown
menu, as it does
not show the
current depth
size of your
channel.



50 Copy Multiple Textures
Dialog

TheCopy Multiple Textures dialog is described belowwith functions for how to access it. A list of the controls on
the dialog can be found in the table below.

What It Does
Lets you copy the textures fromone layer to another. If you havemultiple objects in your project, you can copy the
textures between objects.

How to Access It
Menubar | Patches > Copy Textures

Copy Multiple Textures Dialog Box Fields

Control Type What it does Opens
this dialog
box

Notes

Source
Object

dropdown Select the object holding the source layer.

Source Layer dropdown The layer to copy the patches from.

Select By dropdown Select how to identify the patches on the source
layer.
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Control Type What it does Opens
this dialog
box

Notes

Source
Range

entry box The patch numbers of the patches to copy textures
from. Enter the patch numbers. You can separate
patch numbers with commas, or enter ranges.

For example: 1001,1003,1005-1008

Target
Object

dropdown The object to copy the patches onto.

Target Layer dropdown The layer to copy the patches onto. If required, this
can be the same as the source layer.

Offset entry box A numeric offset for the patch numbers.

For example, if this is set to 100, the source patch
1001 is copied to 1101. Use this to copy textures
between sides of symmetrical models.

The default for
theOffset is
zero.
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51 Channel Transfer Dialog
TheChannel Transfer dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Lets you transfer channels fromone object or version to another.

How to Access It
•Menubar | Channels > Transfer

• Right-click | in Channels Palette > Transfer

Channel Transfer Dialog Fields

Control Type What it does Opens this
dialog box

Notes

Options >
Source |
Object

dropdown Select the object you want to transfer
channels from.

Options >
Source |
Version

dropdown Select the version of the object you want to
transfer channels from.

Options >
Destination |
Object

dropdown Select the object you want to transfer
channels to.
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Control Type What it does Opens this
dialog box

Notes

Options >
Destination |
Version

dropdown Select the version of the object you want to
transfer channels to.

button Moves all the channels that appear in the
source channel list to the destination channel
list.

button Moves only the selected channel in the source
channel list to the destination channel list.

Multiple
selections in
the source list
can bemoved
to the
destination
list.

button Moves only the selected channel in the
destination channel list back to the source
channel list.

Multiple
selections in
the destination
list can be
moved to the
source list.

button Moves all the channels that appear in the
destination channel list back to the source
channel list.

Ok button Accepts the channel transfer parameters and
starts the transfer.

Cancel button Cancels the channel transfer and closes the
Channel Transfer dialog.

Advanced >
Source |
Frame

entry box,
incrementer

For animated objects, select the frame
number you want to transfer channels from.

51 CHANNEL TRANSFER DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Source |
Patches

dropdown,
entry box,
incrementer

Select All, Selected, orRange to specify
which patches are transferred from.

You can only set Patches to Selected if you
have already selected patches on themodel
prior to opening theChannel Transfer
dialog.

Advanced >
Destination |
Frame

entry box,
incrementer

For animated objects, select the frame
number you want to transfer channels to.

Advanced >
Destination |
Patches

dropdown,
entry box,
incrementer

Select All, Selected, orRange to specify
which patches are transferred to.

You can only set Patches to Selected if you
have already selected patches on themodel
prior to opening theChannel Transfer
dialog.

Advanced >
Sampling |
Search

dropdown Defines the direction of the search:

• Bidirectional - both forwards and
backwards ray casting.

• Forward - forward ray casting only.

• Backward - backward ray casting only.

• Radial - in a sphere outwards from each
point.

By default, the
search type is
set to Radial.
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Sampling |
Interpolation

dropdown Interpolation is similar to Photoshop's
sampling functionality. You can select the
methodMari uses to average out pixels from
either:

• Nearest Neighbor - selects the nearest
pixel for sampling.

• Inverse Distance Weighted - weights the
average on the closest pixels.

• Inverse Distance Weighted (Smoother)
- weights the average on the closest pixels
with a priority to providing smoother
sampling.

• Inverse Distance Weighted (Sharper) -
weights the average on the closest pixels
with a priority to providing sharper
sampling.

Interpolation
in Mari is
distance-
based, not
size-based, as
sampling is
done in 3D
space.

Advanced >
Sampling |
Samples

entry box,
slider,
incrementer

Set the number of points the search is to find
and combinewhen sampling.

By default, the
sample size is
set to 16.

Advanced >
Sampling|
Object Has
Moved

dropdown Select Yes orNo to specify whether the object
hasmoved. This is to stipulate where the new
object is in relation to the old object or
version.

If the topology of the object has changed, or
the object has beenmoved across the canvas,
select Yes.

If the object
has a different
orientation, for
instance, it has
been rotated,
data won't be
transferred
correctly.

Advanced >
Sampling|
Flatten

dropdown Select whether or not to Flatten the layers in
the selected channels prior to transferring the
channels.

Advanced >
Sampling |
Bleed Edges

dropdown Choose Yes orNo to specify whether or not
to bleed patch edges when applying the
transfer.

51 CHANNEL TRANSFER DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Sampling |
Range

dropdown,
entry box,
incrementer

Sets how the range for the search distance,
when performing the transfer, is limited:

• Infinite - there is no limit; Mari attempts to
find a pixel in the source image data.

•Object Size Percentage - themaximum
search distance is expressed as a percentage
of the destination object's size. For example,
if the destination object is 10 world-space
units and you set the range value to 10,
then themaximumdistance becomes 1
world-space unit.

•World Units - themaximum search distance
expressed directly in world space. For
example, if you set the range value to 2,
then themaximumdistance becomes 2
world space units.

Advanced >
Sampling | Fill
Color

dropdown Sets the fill color for new patches to either
Transparent, Black,White,Mid-gray,
Magenta, Foreground, orBackground.

button Resets the dropdown fields in theAdvanced
> Sampling tab to the default options.

Ok button Accepts the channel transfer parameters and
starts the transfer.

Cancel button Cancels the channel transfer and closes the
Channel Transfer dialog.
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52 Layer Transfer Dialog
The Layer Transfer dialog is described belowwith functions for how to access it. A list of the controls on the dialog
can be found in the table below.

What It Does
Lets you transfer layers fromone object or version to another.

How to Access It
• Menubar | Layers > Transfer

• Right-click | layer in Layers Palette > Transfer

Layer Transfer Dialog Fields

Control Type What it does Opens this
dialog box

Notes

Options >
Source |
Object

dropdown Select the object you want to transfer layers
from.

Options >
Source |
Version

dropdown Select the version of the object you want to
transfer layers from.

Options >
Source |
Channel

dropdown Select the channel you want to transfer layers
from.
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Control Type What it does Opens this
dialog box

Notes

Options >
Destination |
Object

dropdown Select the object you want to transfer layers
to.

Options >
Destination |
Version

dropdown Select the version of the object you want to
transfer layers to.

Options >
Destination |
Channel

dropdown Select the channel you want to transfer layers
to.

button Moves all the layers that appear in the source
layer list to the destination layer list.

button Moves only the selected layer in the source
layer list to the destination layer list.

Multiple
selections in
the source list
can bemoved
to the
destination
list.

button Moves only the selected layer in the
destination layer list back to the source layer
list.

Multiple
selections in
the destination
list can be
moved to the
source list.

button Moves all the layers that appear in the
destination layer list back to the source layer
list.

Ok button Accepts the layer transfer parameters and
starts the transfer.

Cancel button Cancels the layer transfer and closes the
Layer Transfer dialog.

52 LAYER TRANSFER DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Source |
Frame

entry box,
incrementer

For animated objects, select the frame
number you want to transfer layers from.

Advanced >
Source |
Patches

dropdown,
entry box
incrementer

Select All, Selected, orRange to specify
which patches are transferred from.

You can only set Patches to Selected if you
have already selected patches on themodel
prior to opening the Layer Transfer dialog.

Advanced >
Destination |
Frame

entry box,
incrementer

For animated objects, select the frame
number you want to transfer layers to.

Advanced >
Destination |
Patches

dropdown,
entry box
incrementer

Select All, Selected, orRange to specify
which patches are transferred to.

You can only set Patches to Selected if you
have already selected patches on themodel
prior to opening the Layer Transfer dialog.

Advanced >
Sampling |
Search

dropdown Defines the direction of the search:

• Bidirectional - both forwards and
backwards ray casting.

• Forward - forward ray casting only.

• Backward - backward ray casting only.

• Radial - in a sphere outwards from each
point.

By default, the
search type is
set to Radial.

52 LAYER TRANSFER DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Sampling |
Interpolation

dropdown Interpolation is similar to Photoshop's
sampling functionality. You can select the
methodMari uses to average out pixels from
either:

• Nearest Neighbor - selects the nearest
pixel for sampling.

• Inverse Distance Weighted - weights the
average on the closest pixels.

• Inverse Distance Weighted (Smoother)
- weights the average on the closest pixels
with a priority to providing smoother
sampling.

• Inverse Distance Weighted (Sharper) -
weights the average on the closest pixels
with a priority to providing sharper
sampling.

Interpolation
in Mari is
distance-
based, not
size-based, as
sampling is
done in 3D
space.

Advanced >
Sampling |
Samples

entry box,
slider,
incrementer

Set the number of points the search is to find
and combinewhen sampling.

By default, the
sample size is
set to 16.

Advanced >
Sampling |
Object Has
Moved

dropdown Select Yes orNo to specify whether the
object hasmoved. This is to stipulate where
the new object is in relation to the old object
or version.

If the topology of the object has changed, or
the object has beenmoved across the canvas,
select Yes.

If the object
has a different
orientation, for
instance, it has
been rotated,
data won't be
transferred
correctly.

Advanced >
Sampling |
Flatten

dropdown Select whether or not to Flatten the selected
layers prior to transferring them.

Advanced >
Sampling |
Bleed Edges

dropdown Choose Yes orNo to specify whether or not
to bleed patch edges when applying the
texture transfer.

52 LAYER TRANSFER DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced >
Sampling |
Range

dropdown,
entry box,
incrementer

Sets how the range for the search distance,
when performing the transfer, is limited:

• Infinite - there is no limit; Mari attempts to
find a pixel in the source image data.

•Object Size Percentage - themaximum
search distance is expressed as a percentage
of the destination object's size. For example,
if the destination object is 10 world-space
units and you set the range value to 10,
then themaximumdistance becomes 1
world-space unit.

•World Units - themaximum search
distance expressed directly in world space.
For example, if you set the range value to 2,
then themaximumdistance becomes 2
world space units.

Advanced >
Sampling | Fill
Color

dropdown Sets the fill color for new patches to either
Transparent, Black,White,Mid-gray,
Magenta, Foreground, orBackground.

button Resets the dropdown fields in theAdvanced
> Sampling tab to the default options.

Ok button Accepts the layer transfer parameters and
starts the transfer.

Cancel button Cancels the layer transfer and closes the
Layer Transfer dialog.

52 LAYER TRANSFER DIALOG |



53 Export Dialog
The Export dialog is described belowwith functions for how to access it. A list of the controls on the dialog can be
found in the table below.

What It Does
Invoked by the export channel functions, export flattened channel functions, export layer functions, or export
flattened layers functions, the Export dialog box lets you specify options for exporting channels or layers from the
current Mari project, in either flattened or non-flattened states.

If you export with Small Textures set to Enabled then any patches that are entirely filled with one color (such as
gray, before anything else has been painted on the patch,) are exported as small 8x8 images to save space. Mari
supports loading these 8x8 images when importing. These images are scaled up to fill the entire patch.

How to Access It
•Menubar | Channels > Export > any of the dropdown options

•Menubar | Channels > Export Flattened > any of the dropdown options

•Menubar | Layers > Export > any of the dropdown options

•Menubar | Layers > Export Flattened > any of the dropdown options

• Right-click | in Channels Palette > Export > any of the dropdown options

• Right-click | in Channels Palette > Export Flattened > any of the dropdown options

• Right-click | in Layers Palette > Export > any of the dropdown options

• Right-click | in Layers Palette > Export Flattened > any of the dropdown options
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Export dialog box fields

Control Type What it does Opens this
dialog box

Notes

Named Files

U information Lists the U texture coordinate for the left
edge of the patch.

V information Lists the V texture coordinate for the
bottom edge of the patch.

UDIM information Lists the UDIM number for the patch.

File entry box Specify the file location to export to.

button Browse to the file location you want to
export the texture to.

Small Textures dropdown With this option enabled, Mari exports any
patches filled with a constant color as 8x8
pixel textures, nomatter what resolution
the patches are in Mari.

Enabling SmallTextures saves disk space
if you're exporting a channel that hasn't
been fully painted.

Disabling SmallTextures letsMari always
export patches at their full size (even if they
haven't been painted).

Enabling
SmallTextures
saves disk space if
you're exporting a
channel that hasn't
been fully painted.
Disable
SmallTextures if
you want Mari to
always export
patches at their full
size (even if they
haven't been
painted).

Alpha Channels dropdown Select Keep orRemove alpha channels
when exporting textures. This can help
decrease the resulting file size when
exporting images that don’t need alpha
channels.

53 EXPORT DIALOG | EXPORT DIALOG BOX FIELDS
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Control Type What it does Opens this
dialog box

Notes

Sequence

Layer information The name of the object, channel, and layer
being exported.

Path entry box,
dropdown

The directory to export the files to. Type
the directory, select a recent directory from
the dropdown, or use the navigation
controls below.

button Resets the path to the default location.

button Goes back to the previous directory.

button Goes forward to the next directory that
you have browsed.

Only available if
you have already
browsed back via
the back button.

button Goes up one level in the directory
hierarchy.

button Creates a new folder in the current
directory.

button Displays the contents of the directory as
icons and names only.

button Displays the contents of the directory as a
details view, with a sort option at the top of
the listing.

Filter entry box,
dropdown

Lets you filter the image sequences
displayed in the dialog box. As you enter
the filter text, Mari updates the display to
only show the image sequences that match
your text.

53 EXPORT DIALOG | EXPORT DIALOG BOX FIELDS
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Control Type What it does Opens this
dialog box

Notes

Full Image Indicates whether the selected image
sequence has a full set of images for the
current model. That is, for each patch on
themodel, there is a corresponding image
in the image sequence. Green if a full set of
images is present, otherwise the number
found vs number required (for example,
4/5) displays.

Images information Lists the image sequences found in the
selected Path.

Start information First UDIM number in the selected image
sequence.

End information Last UDIM number in the selected image
sequence.

Patch Count information Number of image patches in the image
sequence.

Frames Information Howmany frames in the image sequence.

Modified information Last modified date for the images in the
sequence.

53 EXPORT DIALOG | EXPORT DIALOG BOX FIELDS
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Control Type What it does Opens this
dialog box

Notes

Template entry box,
dropdown

Sets the Template forMari to usewhen
gathering the names of images in the
selected sequence. Variables available are:

• $ENTITY - the name of the object

• $CHANNEL - the name of the channel

• $LAYER - the name of the layer

• $UDIM - the UDIM patch value

• $FRAME - the animation frame number

• $NUMBER - number of the file within the
batch (for example, “$NUMBER of
$COUNT” gives strings like “22 of 28”)

• $COUNT - total number of files in the
channel

• $[METADATA VALUE] - any user-defined
variables (for example, if a patch has a
user attribute called “PROJECT”, with a
value of “Project1”, Mari replaces the
variable “$PROJECT” with “Project1”).

Don't use numbers
in your texture
name - if you do,
the Import and
Export dialog
boxes won't
recognize the
sequence.

File Example information Displays an example of the selected
template path and filename.

Formats Information Displays a list of supported export file
formats.

Use Template
For

dropdown Specifies whether the template should be
used forOnly this layer or Everything
that is being exported.
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Control Type What it does Opens this
dialog box

Notes

Small Textures dropdown With this option Enabled, Mari exports any
patches not yet painted on as 8x8 pixel
textures (in the background color), no
matter what resolution the patches are in
Mari.

Enabling
SmallTextures
saves disk space if
you're exporting a
channel that hasn't
been fully painted.
Disable
SmallTextures if
you want Mari to
always export
patches at their full
size (even if they
haven't been
painted).

Alpha Channels dropdown Select Keep orRemove alpha channels
when exporting textures. This can help
decrease the resulting file size when
exporting images that don’t need alpha
channels.

Export All
Patches

button Exports images from all patches in the
project.

Cancel button Cancels the export and closes the dialog
box.
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54 Import Dialog
The Import dialog is described belowwith functions for how to access it. A list of the controls on the dialog can be
found in the table below.

What It Does
Invoked by the import channel functions and import layer functions, the Import dialog box lets you specify options
for importing channels or layers. This can be done by importing textures into existing layer stacks, layers, or as new
channels, however, importing textures as a new channel only opens the Import dialog box after first selecting
options for the new channel from the Add Channel Dialog.

How to Access It
•Menubar | Channels > Import > any of the dropdown options

•Menubar | Layers > Import > any of the dropdown options

• Right-click | Channels Palette > Import > any of the dropdown options

• Right-click | Layers Palette > Import > any of the dropdown options

Import Channel Dialog Fields

Control Type What it does Opens this
dialog box

Notes

Named Files

U information Lists the U texture coordinate for the left
edge of the patch.

V information Lists the V texture coordinate for the
bottom edge of the patch.
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Control Type What it does Opens this
dialog box

Notes

UDIM information Lists the UDIM number for the patch.

File entry box Specify the file location to import from.

button Browse to the file location you want to
export the texture to.

Sequence

Channel/Layer information The name of the channel or layer that is
being imported.

This name is only
displayed if a name
has been assigned to
the selected layer.

Path entry box,
dropdown

The directory containing the files to
import. Type the directory, select a recent
directory from the dropdown, or use the
navigation controls below.

Make sure you check
the path and name
carefully, especially if
you have been
swapping between
assets - Mari defaults
to the last place you
imported from.
Don't risk overwriting
your
textures!

button Resets the path to the default location.

button Goes back to the previous directory.

button Goes forward to the next directory that
you have browsed.

Only available if you
have already
browsed back using
the back button.

button Goes up one level in the directory
hierarchy.

button Creates a new folder in the current
directory.

54 IMPORT DIALOG |
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Control Type What it does Opens this
dialog box

Notes

button Displays the contents of the directory as
icons and names only.

button Displays the contents of the directory as a
details view, with a sort option at the top
of the listing.

Filter entry box,
dropdown

Lets you filter the image sequences
displayed in the dialog box. As you enter
the filter text, Mari updates the display to
only show the image sequences that
match your text.

Full Image Indicates whether the selected image
sequence has a full set of images for the
current model. That is, for each patch on
themodel, there is a corresponding image
in the image sequence. Green if the
selected image sequence has a full set of
images for the current model, yellow if the
selected image sequence has a partial set
of images for the current model, or red if
the selected image sequence has no
images for the current model.

Images information Lists the image sequences found in the
selected Path.

Start information First UDIM number in the selected image
sequence.

End information Last UDIM number in the selected image
sequence.

Patch Count information Number of image patches in the image
sequence.

Frames information Howmany frames in the image sequence.

54 IMPORT DIALOG |
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Control Type What it does Opens this
dialog box

Notes

Modified information Last modified date for the images in the
sequence.

Template entry box,
dropdown

Specify or select a preset format for
automatically naming and numbering files
on import. Variables available are:

• $ENTITY - the name of the object

• $LAYER - the name of the layer

• $CHANNEL - the name of the channel

• $UDIM - the UDIM patch value

• $FRAME - the animation frame number

• $NUMBER - number of the file within the
batch (for example, “$NUMBER of
$COUNT” gives strings like “22 of 28”)

• $COUNT - total number of files in the
channel

• $[METADATA VALUE] - any user-defined
variables (for example, if a patch has a
user attribute called “PROJECT”, with a
value of “Project1”, Mari replaces the
variable “$PROJECT” with “Project1”).

Don't use numbers in
your texture name -
if you do, the Import
and Export dialog
boxes won't
recognize the
sequence.

File Example information Displays an example of the selected
template path and filename.

Formats Information Displays a list of supported import file
formats.

Import All
Patches

button Imports textures onto all patches in the
project.

Import
Selected
Patches

button Appears instead of Import All Patches
when at least one patch is selected.

Cancel button Closes the dialog box without importing.
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55 Open an Image Dialog
TheOpen Image dialog is described belowwith functions for how to access it. A list of the controls on the dialog can
be found in the table below.

What It Does
Allows you to choose an image from somewhere on yourmachine or network for use in environment lighting and
the Image Manager. Image files can be opened inMari using this dialog, so long as they are of a valid file format,
shown in the File of type field in the table below.

How to Access It
• Right-click | ImageManager Palette > Open

• ImageManager Palette >

• Right-click | Lights Palette > Environment > Image >

Open Image Dialog Fields

Control Type What it does Opens this
dialog box

Notes

Look in dropdown The directory containing the files to
import. Select a recent directory from the
dropdown, or use the navigation controls
described below.

Make sure you check
the path and name
carefully. Mari
defaults to the last
place you imported
from. Don't risk
overwriting your
textures!
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Control Type What it does Opens this
dialog box

Notes

button Goes back to the previous directory.

button Goes forward to the next directory that
you have browsed.

Only available if you
have already
browsed back using
the back button.

button Goes up one level in the directory
hierarchy.

button Creates a new folder in the current
directory.

button Displays the contents of the directory as
icons and names only.

button Displays the contents of the directory as a
details view, with a sort option at the top
of the listing.

Name information Lists the name of the files or folder in the
selected directory.

The files that are
shown are only those
that are of a valid file
format.

Size information Lists the file or folder size.

Kind information Displays what kind of file the item is, for
example, a folder, a .tiff file, or a .jpg file.

DateModified information Lists the date that the file was last opened
ormodified.

File name entry box Type a file name into the field to open the
imagewith a specific name in the Image
Manager.

File of type dropdown Lists the file formats that are able to be
opened inMari or brought into the Image
Manager.

55 OPEN AN IMAGEDIALOG |
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Control Type What it does Opens this
dialog box

Notes

Advanced
Options > Color
Space
Conversion

dropdown Convert the image before opening it by
setting the field to Linear to sRGB or, if
you don't want any image conversion, set
it toNone.

Open button Open the image in the Image Manager or
the environment lighting with the settings
listed in the dialog.

Cancel button Closes the dialog without opening any
image.
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56 Mari to Maya Export Dialog
TheMari to Maya Export dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
TheMari To Maya Export dialog box lets you specify the file type and destination for exporting a channel from the
current Mari project to aMaya .ma file. Exported textures are saved to a user-selected directory and the created .ma
file is set up to reference those texture files. The .ma file is created with the correct UDIM offsets for the textures so
that Maya can import and apply them to themodel correctly.

How to Access It
•Menubar | Python > Examples > Export for Maya.

Mari to Maya Export Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Output
Folder

entry box Displays the selected filepath for the
exported files. You can also manually type
in the file location.

Browse button Allows you to select the file location for the
exported files from the Select Directory
for Export dialog.

Select
Directory
for Export
dialog box.

Channels list Displays the channel(s) for the currently
selected object.

Multiple channels can
be selected at once.
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Control Type What it does Opens this
dialog box

Notes

+ button Adds the selected channel(s) and
destination directory to the For Export
pane.

- button Removes the selected channel(s) and
destination directory from the For Export
pane.

For Export information Displays the channel(s) to be exported.

8-bit Files dropdown Selects the bit depth of the exported
images.

Available formats: bmp,
jpg, jpeg, png, ppm,
psd, tga, tif, tiff,
xbm, and xpm.

16/32-bit
Files

dropdown Selects the bit depth of the exported
images.

Available formats: exr,
psd, tif, and tiff.

Force
Overwrite

checkbox ForcesMari to overwrite previously
exported files to the same location,
effectively replacing them.

OK button Accepts the current channel export
selections and exports them to the
designated file location.

Mari >
Maya
Progress
dialog box.

Cancel button Cancels the current channel export
selections and closes theMari To Maya
Export dialog box.

56 MARI TO MAYA EXPORT DIALOG |



57 New Shader Dialog
TheNew Shader dialog is described belowwith functions for how to access it. A list of the controls on the dialog can
be found in the table below.

What It Does
Specify what lighting shader you want to set up for your project. This does not affect your Flat, Basic, or Full lighting
options, but instead impacts how the texture on yourmodel looks under the lighting and shader components you’ve
selected.

How to Access It
• Menubar | Shading > Add SurfaceShader

• Button | in Shaders Palette > > Choose Diffuse/Specular

New Shader Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Diffuse

Diffuse | Lighting/
Diffuse/Lambertian

dropdown Sets theDiffuse component of the
shader to Lambertian.

Diffuse | Lighting/
Diffuse/Minnaert

dropdown Sets theDiffuse component of the
shader to Minnaert.

Specular
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Control Type What it does Opens this
dialog box

Notes

Specular | Lighting/
Specular/Phong

dropdown Sets the Specular component of
the shader to Phong.

By default, the
Phong shader in
theAdd New
Shader
dropdownmenu
is Lambertian/
Phong.

Specular | Lighting/
Specular/Cook
Torrance

dropdown Sets the Specular component of
the shader to Cook Torrance.

By default, the
Cook Torrance
shader in theAdd
New Shader
dropdownmenu
is Lambertian/
Cook Torrance.

Specular | Lighting/
Specular/Beckman

dropdown Sets the Specular component of
the shader to Beckman.

By default, the
Beckman shader
in theAdd New
Shader
dropdownmenu
is Lambertian/
Beckman.

Specular | Lighting/
Specular/Blinn

dropdown Sets the Specular component of
the shader to Blinn.

By default, the
Blinn shader in
theAdd New
Shader
dropdownmenu
is Lambertian/
Blinn.
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58 Create Shader Dialog
TheCreate Shader dialog is described belowwith functions for how to access it. A list of the controls on the dialog
can be found in the table below.

What It Does
TheCreate Shader dialog box allows you to create shaders that are not listed in the Shadingmenu or Shaders
palette. These shaders are primarily those that do not use Lambertian diffuse shading. However, options for
Lambertian diffuse shading are still included in theCreate Shader dialog, so you can customize your shaders
however you want.

How to Access It
•Menubar | Shading > Add New Shader > Choose Diffuse and Specular

• Right-click | Shaders Palette > Choose Diffuse and Specular

• Shaders Palette | > Choose Diffuse and Specular

Create Shader dialog box fields

Control Type What it does Opens
this
dialog
box

Notes

Diffuse dropdown Select either Lambertian orMinnaert for
Lighting/Diffuse options. Selecting either
option does not limit the options you can
select from the Specular dropdownmenu.

Selecting Lambertian and
a Specular options gives
you the same result as the
named options forAdd
New Shader on the
menubar.
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Control Type What it does Opens
this
dialog
box

Notes

Specular dropdown Select Phong, Cook-Torrance, Beckman, or
Blinn for the Lighting/Specular options.
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59 Mask Channel To Alpha
Dialog

TheMask Channel to Alpha dialog is described belowwith functions for how to access it. A list of the controls on
the dialog can be found in the table below.

What It Does
Creates a new channel based on the selectedmask channel and source texture, with the alpha values on the new
channel set by the original mask.

How to Access It
•Menubar | Channel >Mask to Alpha

• Right-click | Channel in Channels Palette > Mask to Alpha

Mask Channel to Alpha Dialog Box Fields

Control Type What it does Opens
this dialog
box

Notes

NewChannel Name entry / dropdown Enter the name for the new
channel to create.

RGB Channel dropdown Selects the existing channel that
provides the diffuse color data
for the new channel.
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Control Type What it does Opens
this dialog
box

Notes

Mask Channel dropdown Selects the existing channel to use
as themask when creating the
new channel. A second dropdown
allows you to select the specific
color channel to use as themask
(red, green, or blue).
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60 Select Patches By Range
Dialog

The Select Patches By Range dialog is described belowwith functions for how to access it. A list of the controls on
the dialog can be found in the table below.

What It Does
Selects a range of patches according to their index or UDIM value number. Objects or scenes withmany patchesmay
benefit frombeing able to quickly select patches by their range value as opposed to selecting themmanually from
the Patches palette.

How to Access It
•Menubar | Patches > Select Range

Select Patches By Range dialog box fields

Control Type What it does Opens this
dialog box

Notes

Select By dropdown Gives you the choice of selecting a range of
patches by either theUDIM value or the
index value.

This is set to UDIM by
default.

Value entry box Allows you to specify the UDIM or index
values that you wish to select. You can select
a range of consecutive values by listing them
with a hyphen (for example, 1-5) and include
non-consecutive values by separating them
with a comma (for example, 1-5, 8).



61 Add Object Settings Dialog
TheAdd Object Settings dialog is described belowwith functions for how to access it. A list of the controls on the
dialog box can be found in the table below.

What It Does
Specifies the settings of the imported object that is being added to theMari project. This relates primarily to whether
selected objects aremerged, and how, and how the object mapping is handled.

How to Access It
•Menubar |Objects > Add Object > select object andOpen

• Right-click | in Objects Palette > Add Object > select object and Open

• Button | Objects Palette > >select object andOpen

Add Object Settings Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Mapping
Scheme

dropdown If there is a UV map available, and
you would like to use it, select UV if
available, Ptex otherwise. If you
prefer to use Ptex, select Force Ptex.
This option loads the selected
geometry and replaces the existing
UVmap with a Ptex map.

Only available when choosing
.obj or .abc files in the file
browser.
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Control Type What it does Opens this
dialog box

Notes

Selection
Sets

dropdown Selection sets have two options, to
either:

• Create From Face Groups - this is
the default behavior and allows the
use of selection sets in Mari.

• Don’t Create - if you choose not to
create a selection set, Mari does not
create any from the file.

Only available when choosing
.obj files in the file browser.

Multiple
Geometries
Per Object

dropdown If your .obj consists of multiple
geometries, you have the option to
Merge Geometries Into One,
which is the default behavior, or
Create Separate Geometries
(Ptex Only). If you selectMerge
Geometries Into One, Mari
combines the individual geometries
into a single geometry, while selecting
Create Separate Geometries
(Ptex Only) creates individual
geometries.

Only available when choosing
.obj files in the file browser.

Even if you select Create
Separate Geometries
(Ptex Only), Mari only
displays a single geometry on
the canvas. However, when
you export a channel you
have the option to export
individual .ptx files for each
geometry.

Process
each
geometry
file as a

dropdown For Ptex files, there are two choices
for the geometry mesh options:

• Separate Object - creates only one
object with one geometry.

• Separate Geometry In One
Object - creates only one object,
but hasmultiple geometries within
it.

Only available when choosing
.ptx files in the file browser.

The option to Separate
Geometry In One Object is
essentially the inverse of the
Ptex channel export process,
and allows project
reconstruction.

61 ADD OBJECT SETTINGS DIALOG |



339

Control Type What it does Opens this
dialog box

Notes

Merge
Type

dropdown Choosewhether to merge selected
items from the object hierarchy tree
as:

• Single Mesh - merges selected
geometry into one singlemesh in a
GeoEntity. Note that this implies
that the information about the
original geometries cannot be
accessed once themerge is done.

• Just Merge Nodes - merges
selected geometry into one
GeoEntity while retaining the
metadata andmesh information
about the original individual
geometries. Note, this information
can only be accessed by more
technical users using the C API.

Only available when choosing
.abc files in the file browser.

Scene information In the object hierarchy, shows all the
objects, cameras, and lights that are
part of the Alembic file.

Only available when choosing
.abc files in the file browser.

Merge checkbox Select the checkbox to determine if a
geometry is to bemerged with
another on project creation.

Only available when choosing
.abc files in the file browser.

Formore information on
merging Alembic geometry,
see Create New Project under
the Alembic chapter in the
Mari User Guide.

Start
Frame and
End Frame

entry box Set the frame range from the source
file to import.

Only available when choosing
.obj and .abc file sequences
in the file browser.

Single
Frame

button Sets the start and end frame fields to
only import the first frame from the
animation in the object file.

Only available when choosing
.obj and .abc file sequences
in the file browser.
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Control Type What it does Opens this
dialog box

Notes

All Frames button Sets the start and end frame fields to
import the entire animation from the
object file.

Only available when choosing
.obj and .abc file sequences
in the file browser.

Frame
Offset

entry box Set by howmany frames to offset the
loading of an animated object. You
can specify a frame range, or simply a
number of frames.

Only available when choosing
.abc files in the file browser.

Ok button Accepts the object settings and
imports the selected objects.

Cancel button Cancels the object import and closes
theAdd Object Settings dialog.
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62 Add Version Settings Dialog
TheAdd Version Settings dialog is described belowwith functions for how to access it. A list of the controls on the
dialog box can be found in the table below.

What It Does
Specifies the settings of the imported object version that is being added to theMari project.

How to Access It
• Right-click | on object in Objects Palette > Add Version > select object and Open

Add Version Settings Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Mapping
Scheme

dropdown If there is a UV map available, and you
would like to use it, select UV if
available, Ptex otherwise. If you prefer
to use Ptex, select Force Ptex. This
option loads the selected geometry and
replaces the existing UVmap with a Ptex
map.
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Control Type What it does Opens this
dialog box

Notes

Merge
Type

dropdown Choosewhether to merge selected items
from the object hierarchy tree as:

• Single Mesh - merges selected
geometry into one singlemesh in a
GeoEntity. Note that this implies that
the information about the original
geometries cannot be accessed once the
merge is done.

• Just Merge Nodes - merges selected
geometry into oneGeoEntity while
retaining themetadata andmesh
information about the original individual
geometries. Note, this information can
only be accessed by more technical
users using the C API.

Scene information In the object hierarchy, shows all the
objects, cameras, and lights that are part
of the Alembic file.

Merge checkbox Select the checkbox to determine if a
geometry is to bemerged with another on
project creation.

Formore information on
merging Alembic
geometry, see Create
New Project under the
Alembic chapter in the
Mari User Guide.

Start
Frame
and End
Frame

entry box Set the frame range from the source file
to import.

Single
Frame

button Sets the start and end frame fields to only
import the first frame from the animation
in the object file.

All
Frames

button Sets the start and end frame fields to
import the entire animation from the
object file.
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Control Type What it does Opens this
dialog box

Notes

Frame
Offset

entry box Set by howmany frames to offset the
loading of an animated object. You can
specify a frame range, or simply a number
of frames.

Ok button Accepts the object settings and imports
the selected object versions.

Cancel button Cancels the object import and closes the
Add Version Settings dialog.
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63 Load Camera Dialog
The Load Camera dialog is described belowwith functions for how to access it. A list of the controls on the dialog
can be found in the table below.

What It Does
The Load Camera dialog box comes up whenever you attempt to load or import a camera fromoutside the current
Mari project. The camera file types are .fbx only.

How to Access It
•Menubar | Camera > Load Camera

Load Camera dialog box fields

Control Type What it does Opens this
dialog box

Notes

Look in entry box,
dropdown

The directory of the camera file that is to be
loaded into the current project.

button Goes back to the previous directory.

button Goes forward to the next directory that you
have browsed.

Only available if you
have already
browsed back via
the back button.

button Goes up one level in the directory
hierarchy.
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Control Type What it does Opens this
dialog box

Notes

button Creates a new folder in the current
directory.

button Displays the contents of the directory as
icons and names only.

button Displays the contents of the directory as a
details view, with a sort option at the top of
the listing.

File Name entry box Displays the name of the selected file to be
imported into the project.

This field is
automatically filled
in when a file is
selected from the
above directory
location.

File Type entry box,
dropdown

Displays the file formats available to import
the selected file.

By default this
should display .fbx
or .FBX.
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64 Manage Toolbar Dialog
TheManage Toolbar dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Lets you add, edit and remove toolbars for quick access to Mari functions.

Click Add to add a new toolbar, Remove to remove the selected toolbar. Drag icons for actions listed to and from
existing toolbars.

How to Access It
Menubar | Edit > Toolbars

Manage Toolbars Dialog Box Fields

Control Type What it does Opens this
dialog box

Notes

Search Actions entry box,
dropdown

Search for actions in the list
below to quickly find a
particular action shortcut or
information.

button Clear the search bar for the
Search Actions field.

button Go back to the previous search
result.
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Control Type What it does Opens this
dialog box

Notes

button If on a previous result, go
forward to the next search
result.

button Reset all shortcuts to their
default entries.

button Import custom shortcuts from
outsideMari.

button Export custom shortcuts to an
external source.

Lookup Shortcut entry box Enter the shortcut to look up
what action the shortcut is set
to.

(actions) | Name information The name of the action.

(actions) |
Description

information A brief description of the
action.

(actions) | Shortcut information,
entry

Displays assigned keyboard
shortcuts.

(toolbars)| Visible checkbox Whether the action is currently
displayed.

Grouped by Default
(the standard toolbars
that comewithMari)
and Custom (user-
added toolbars).

(toolbars)|Add button Add a new toolbar. MakeNew
Toolbar

Opens a dialog box to
name the new toolbar.

(toolbars)| Remove button Remove selected custom
toolbar.
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65 Manage Keyboard Shortcuts
Dialog

TheManage Keyboard Shortcuts dialog is described belowwith functions for how to access it. A list of the
controls on the dialog can be found in the table below.

What It Does
Lets you add, edit and remove keyboard shortcuts for quick access to Mari functions.

Click in the Shortcut column and type the keyboard shortcut for a function. A 'collision' icon displays if that
shortcut has already been assigned to another function.

How to Access It
Menubar | Edit > Shortcuts

Edit Shortcuts dialog box fields

Column Type What it does Notes

Search Actions entry box, dropdown Search for actions in the list below
to quickly find a particular action
shortcut or information.

button Clear the search bar for the Search
Actions field.

button Go back to the previous search
result.
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Column Type What it does Notes

button If on a previous result, go forward
to the next search result.

button Reset all shortcuts to their default
entries.

button Import custom shortcuts from
outsideMari.

button Export custom shortcuts to an
external source.

Lookup Shortcut entry box Enter the shortcut to look up what
action the shortcut is set to.

(actions) |Name information The name of the action.

(actions) |
Description

information A brief description of the action.

(actions) | Shortcut information Displays assigned keyboard
shortcuts. Click and type over new
shortcuts.
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66 HUDManager Dialog
TheHUD Manager dialog is described belowwith functions for how to access it. A list of the controls on the dialog
can be found in the table below.

What It Does
Lets you select what appears on the “Head Up Display” (HUD) that shows information about Mari and the current
project in the top left-hand corner of the canvas. For each piece of information, theHUD Manager shows its:

•Name - displayed hierarchically.

• Type - QString, int, bool, qint64, float, PaintSelectedMarkFlag, MriColor, PaintOnFlag, DisplayQuality, MriGradient,
LightingMode, Qdate, MriFileList, Background, MriPaintMode.

•HUD - a checkbox for whether to include in theHUD.

• Control - this is debug information, and can be ignored.

How to Access It
Menubar | Edit > HUD Manager

HUDManager Dialog Box Fields

Control Type What it does Notes

Shader Network GLSL Code
Generator Manager > General |
GLSL Generator

QString Shows theGLSL for the shader network.

Project > Data | Texture Image
Count

int Shows the number of texture images (patches)
present.

Project > Data | Total Image Count int Shows the total number of images present.
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Control Type What it does Notes

Project > Data | Image Tile Count int Shows the total number of image tiles present.

Project > Data | DDI Hash Count int Debug info.

Project > Project | Current
Modular Shader

QString Shows the name of the current shader network.

Project > Project | Current Object QString Shows the name of the object currently selected.

Project >Project | Current
ImageSet

QString Shows the name of the image set currently
selected.

Canvas > Rendering |Deferred
Texture Array

bool Debug info.

Canvas > Rendering |Deferred
Shading

bool Debug info.

Canvas > Rendering | Selected
Patches

int Shows the number of patches currently selected.

Canvas > Rendering | Triangles int Shows the number of triangles on themodel.

Canvas >Rendering | Current
Uniforms

int Shows the number of GLSL uniforms for the
currently selected shader.

Canvas >Rendering |Uniforms int Shows themaximumnumber of GLSL uniforms
used to draw the canvas.

Canvas > Rendering | FPS float Shows the current Frames Per Second of the
display. This shows how fast the display is
rendering, and how smoothly movement displays.

Canvas > Rendering | FPAnim int Shows the number of frames per animation.

Tool Manager > General | Tool Help QString Shows basic tool help for the current tool.

Tool Manager > General | Current
Tool

QString Shows the name of the current tool.

GPU 0 > Capabilities |Global
Cubemap Seams Allowed

bool Debug info.
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Control Type What it does Notes

GPU 0 > Capabilities | Threaded
OpenGL Operations Allowed

bool Debug info.

GPU 0 > Capabilities | Tessellation
Allowed

bool Debug info.

GPU 0 > Capabilities |Geometry
Shaders Supported

bool Debug info.

GPU 0 > Capabilities |Offscreen
AA

bool Debug info.

GPU 0 > Capabilities | Float Data bool Debug info.

GPU 0 > Capabilities |Offscreen bool Debug info.

GPU 0 > Capabilities | Shaders bool Debug info.

GPU 0 > Capabilities |Max Texture
Size

int Debug info.

GPU 0 > Capabilities | Texture
Units

int Debug info.

GPU 0 > Driver | Renderer QString Debug info.

GPU 0 > Driver |Glew QString Debug info.

GPU 0 > Driver | Version QString Debug info.

GPU 0 > Driver | Vendor QString Debug info.

GPU 0 >Resources |Max Uniforms QString Debug info.

GPU 0 > Resources |Memory Info QString Shows thememory usage and freememory
information for the project.

GPU 0 > Resources|Used Texture
Units

int The number of texture units used in the project.

GPU 0 > Resources | Free Offsceen int Debug info.

GPU 0 > Resources |Offscreen
Buffers

int Debug info.
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Control Type What it does Notes

GPU 0 > Resources |GPU Ram qint64 Debug info.

GPU 0 > Resources |Max Image
Memory

qint64 Debug info.

GPU 0 > Resources |Buffer
Memory

qint64 Debug info.

GPU 0 > Resources | Tile Memory qint64 Debug info.

GPU 0 > Resources | Image Tiles int Debug info.

Channels | Current Channel
Path

QString Show the path of the currently selected channel.

Channels | Current Channel QString Shows the name of the current channel on the
current object.

Clock |Animation Frame int The number of the frame currently being
displayed.

Clock |Animation Frame int The frame number currently displayed, if
applicable.

Clock |Animation Loop int The number of frames currently being looped.

Clock |Animation FPS int Frames Per Second of the animation.

Clock |Animation Time QString Time length of the animation in the scene.

Layers | Current Layer Path QString Shows the path of the currently selected layer.

Layers | Current Layer QString Shows the name of the current layer in the current
channel and object.

Shaders | Current Shader QString Shows the name of the shader currently selected.

<Project> > General |Description QString Shows description of current project.

<Project> > Creation | Created By QString Displays the login name of the user who originally
created the project.

<Project> > Creation | Creation
Date

QDate Displays the initial creation date of the project.
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Control Type What it does Notes

<Project> > Debug |Unique ID QString Debug info.

<Project> > Editing | Last Edited QDate Displays date that the project was last edited.

<Project> > Editing | Last Editor QString Displays user who last edited the project.

<Project> > Geometry |Mesh
Creator

QString Displays the user who created the geometry file
upon which the project is based.

<Project> > Geometry |Mesh
Created

QString Displays the date and time that the geometry file
was created.

<Project> > Geometry |Mesh Path QString Displays the path for themesh file.
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67 Mari Preferences Dialog
TheMari Preferences dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Lets you set preferences for howMari works.

How to Access It
Menubar | Edit > Preferences

Mari Preferences Dialog Box Fields

Setting Type What it does Notes

Color

Color Management Defaults |
Color Picker Maximum

entry box,
slider

Themaximum color intensity that
can be chosen in the color picker.

From 1 to 65,365;
defaults to 4,096.

Color Management Defaults |
Enabled

checkbox Sets whether colormanagement is
enabled by default.

Color Management Defaults |
Color Profile

dropdown Sets the default color profile for
displaying colors on yourmonitor.

Display Defaults |
Configuration File

entry box,
button

Specifies the default colorspace
configuration file that is loaded by
the colorspace toolbar.
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Setting Type What it does Notes

Display Defaults | Input
ColorSpace

dropdown Sets the default colorspace of the
scene.

Display Defaults |Display dropdown Sets the default colorspace for the
display device used to view the
scene.

Display Defaults | View dropdown Sets the default display transform
applied to the scene.

Display Defaults | Component dropdown Sets the default color component
displayed for the scene.

Display Defaults |Gain entry box,
slider

Sets the default amount of exposure
adjustment that is applied before
the
display transform.

Display Defaults |Gamma entry box,
slider

Sets the default amount of gamma
correction that is applied after the
display transform.

Display Defaults | LUT Size dropdown Sets the size of the display LUT
loaded by the colorspace toolbar.

Youmay sometimes
notice artifacts on the
canvas when your LUT
size is too small. Increase
the size of the LUT here.

Display General | Center
F-Stop

entry box,
slider

Sets the center F-Stop value for
when theGain reset button is
clicked.

LUT Defaults | File entry box,
button

Sets the location of the default LUT
file that is loaded by the colorspace
toolbar.

LUT Defaults | Extrapolate checkbox Sets whether extrapolation is
enabled by default. If enabled, the
GPU extrapolates the grid values or
clamps to themaximum value of the
LUT.
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Setting Type What it does Notes

Data

Autosave |Autosave
Frequency (Mins)

entry box,
incrementers

Sets how frequently (in minutes)
Mari
automatically saves your work.

Cache | Thread Count entry box,
slider

Sets the number of free threads that
are available for background tasks.

These are in
addition to the
dedicated data
management threads (of
which there are three per
cache directory).

Cache |Max Memory entry box,
incrementers

Sets themaximumamount of
memory Mari uses for theDDI cache
blocks. You can't set this to a value
higher than 80% of thememory you
have available (rounded to the
nearest half-GB). For example, if you
have 6GB of memory available, you
can't set Max Memory to a value
higher than 4.5GB. This is to avoid
using all the physical memory
available.

DDI is the data caching
systemused inMari.

TheReset (R) icon resets
themaximummemory
value to 2 GB.

Cache | Check Drive Space entry box,
slider

Sets the interval, in seconds, that the
cache drives are checked for
sufficient disk space.

Channel Cache | Resolution
Mode

dropdown Determines if Mari caches at the
given channel’s resolution or a lower
proxy level. Setting this to Fixed
uses theDefault resolution and
Type
listed below.

This can speed up the
caching process if you
don’t require the full
resolution of the
channel to be cached.

Channel Cache |Default
Resolution

dropdown If theResolution Mode is set to
Fixed, Mari caches at the selected
resolution.

This can save timewhen
caching large patches if
you don’t require the full
resolution while working.
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Setting Type What it does Notes

Channel Cache |Default
Type

dropdown If theResolution Mode is set to
Fixed, Mari caches at the selected bit
depth.

This can save timewhen
caching large patches if
you don’t require the full
resolution while working.

Channels | Importer dropdown Sets themode for the import
function. One of:

• Fast Importer - takes over your
Mari session while it imports the
textures, but works quicker.

• Background Importer - works in
the background, letting you paint
and work on your project, but
takes longer.

Channels | Exporter dropdown Sets themode for the export
function. One of:

• Fast Exporter - takes over your
Mari session while it exports the
textures, but works quicker.

• Background Exporter - works in
the background, letting you paint
and work on your project, but
takes longer.

Channels | Export Mask
Stacks

dropdown Determines howmask stacks are
exported. Either:

• Export Baked Mask Stack and
an Invisible Group - exports a
group along with themask stack in
order to group the exported
masks.

• Export Baked Mask Stack Only -
exports on themask stack with
nothing else as part of the export.

67MARI PREFERENCES DIALOG |



359

Setting Type What it does Notes

Channels |Autosnapshot dropdown Sets whether automatic snapshots
are enabled or disabled. The options
available are:

• Disabled - Disables the
Autosnapshot feature.

• Enabled with Limit - Enables the
Autosnapshot feature but limits
the number of autosnapshots that
can be stored in the Snapshots
palette.

• Enabled - Unlimited - Enables the
Autosnapshot featurewithout a
limit on the number of
autosnapshots that can be stored
in the Snapshots palette.

Channels |Autosnapshot
Limit

entry box,
slider

When Enabled with Limit is
selected, Mari limits the number of
automatic snapshots that are stored
in the Snapshots palette to the
number specified by the
Autosnapshot Limit. The
maximum value is 20.

General | Fix Edge UVs dropdown Sets whetherMari should “fix” any
UVs that sit on the edge of the
patch. With this on, you can paint
models that haveUVs at the edge of
the patch.

General | Channel Input dropdown When creating a new project, sets
whether theNew Channel dialog
box adds either:

• Single Channel - a single channel.

• Channel Presets - a set of
channels that you select from a list
of presets.

GPU
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Setting Type What it does Notes

Baking and Projection |Max
Tile Size for Tiled
Renderers

dropdown Sets themaximum tile size for tiled
render operations (for example,
unprojections). Setting this to a
lower value improves accuracy but
may
result in slower render operations.

Baking and Projection |Max
Render Size for Baking

dropdown If baking calculation has to be
divided into sections in order to
continue
efficiently, this specifies the
maximum square size of these
sections.

Increasing the number
of squares per section
can increase baking time,
but may impact stability.

Canvas |Deferred Shading checkbox Specifies whether to use deferred
shading. This is on by default and
should increase painting and
navigation speed.

Canvas |Deferred Texture
Array

checkbox TurnsDeferred Texture Array
on/off. When this is active, Mari
makesmore efficient use of
OpenGL.

Depth Projection |Allow
Depth Projections

checkbox Allows the use of shadow rendering
in Mari. If the box is ticked, shadow-
related features are available in the
Lights andObjects palettes. By
default, this preference is disabled.

Depending on your
hardware and project
requirements, shadow
processingmay cause a
noticeable drop in UI
responsiveness.
Disabling this option
disables shadow
processing entirely and
improves rendering
throughput.
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Setting Type What it does Notes

Depth Projection |Use
Variance Maths

checkbox Sets whether variancemapmaths
are used for shadows. If this box is
ticked, the boundary of the shadows
are softer and less prone to aliasing.
For a sharper edge to shadows,
unselect this box.

If Allow Depth
Projections is
unselected, shadows do
not display. TheUse
Variance Maths
checkbox should be
unselected as it depends
on shadows being used.

Depth Projection | Depth
Projection Resolution

dropdown Sets the texture resolution of each
of the array of depth textures used
for shadow rendering. TheDepth
Projection Texture Array Size is
linked to this resolution and impacts
other resolution sizes set in Mari.

Depth Projection | Depth
Projection Texture Array
Size

dropdown Sets the number of depth projection
textures to use for shadow
rendering. Increasing the array size
increases the graphics cardmemory
made available for shadow
rendering. The total graphics
memory used for these textures is 8
multiplied by the depth projection
resolution, multiplied by the depth
projection texture array size. The
array size controls howmany angles
each light of the 4 lights uses. The
maximumarray size is 24, which
allows for 6 angles per light.

Options are available for
25-32, but at this time
Mari does not use these
additional angles.
Selecting options over
24 causes wasted cache
space.

General |Max Image
Memory

entry box,
incrementers

Sets themaximumamount of
additional GPU memory Mari uses
for tasks other than painting, for
example, filter operations.
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Setting Type What it does Notes

General |Deferred Quad
Split Count

entry box,
slider

Sets the quad split count. Increasing
this value splits the canvas into
smaller parts.

Used in conjunction with
Draw Batch Size,
adjusting this value can
improve stability and
prevent Windows driver
resets.

General | Threaded OpenGL
Operations Allowed

checkbox If this is enabled then operations
requiring threaded OpenGL can be
executed.

General | Tessellation
Allowed

Enables the use of tessellation
shaders for hardware able to
support them.

General | VSync dropdown Sets the VSync option toOff,On, or
System.

If the VSync option is On, then this
forces themain canvas to only
update at themonitor’s refresh rate.
If it isOff, then themain
canvas can update at any time. This
could result in tearing, if the canvas
is running faster than themonitor’s
refresh rate.

If the option for System is set, Mari
uses the system and driver settings
for VSync. mari needs to be
restarted for this to fully take effect.

This setting is
dependent on driver and
operating system
settings. Hence, this
option doesn't appear if
you do not have the
correct OS or drivers.

Virtual Texture | Virtual
Texture Type

dropdown Sets the pixel type of the virtual
texture that Mari uses. Setting this
toHalf or Float givesmore precision
when painting or previewing
displacement but requires
significantly moreGPU memory.
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Setting Type What it does Notes

Virtual Texture | Virtual
Texture Size

dropdown Sets the size of the virtual textures
Mari uses. Larger sizesmay give
better results but require
significantly moreGPU memory.

Virtual Texture | Virtual
Texture Size for Paint Bake

dropdown Controls the size of the virtual
texture being used for the display.
Increasing this settingmay resolve
issues, such as flickering, but takes
upmorememory.

This is a graphics card-
dependant setting.

Virtual Texture |Gather Scale entry box,
slider

Sets the buffer sizeMari uses when
gathering information on which
image tiles are required for rendering
a scene. The default value of 1.000
halves the canvas resolution and
works well in most situations, saving
processing time. However, if glitches
are appearing in the canvas, youmay
need to increase this value to fix the
problem (at the cost of reduced
painting and navigation speed).

Virtual Texture | Thin
Triangle Preview Quality

entry box,
slider

Controls the texture preview quality
of thin triangles. The default value is
0. In cases where the geometry has
long thin triangles, increasing this
value results in the use of higher
resolution textures.

Misc

Appearance |Use Custom
Font Size

checkbox Enabling this allows you to change
the font used in Mari from the
default setting.

Appearance | Custom Font
Size

entry box,
slider

Adjusts point size of the custom
font.

Use Custom Fontmust
be enabled in order for
this to have an affect.
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Setting Type What it does Notes

Image Import/Export | Show
Summary Dialog on Import

checkbox Sets whetherMari displays an import
summary dialog after importing an
image.

The import summary
dialog displays
information such as how
many images were
imported, how long the
operation took, and if
patches were resized -
then howmany.

Image Import/Export |
Remember Import and
Export Paths

checkbox If enabled, Mari automatically
remembers paths previously set for
importing and exporting, and offers
them again next time you attempt to
import or export.

Input |Use HiRes Positions checkbox If this option is enabled, Mari uses
high resolution position values from
tablets and other devices.

Most often this is only noticeable
using Paint and Vector Paint on
large patch sizes.

In some cases, having
this option enabled can
hinder painting entirely.
Disabling it resolves the
issue.

NamedFiles | Patch Cutoff entry box,
slider

Sets themaximumnumber of
patches objects are allowed to have
for theNamed Files tab to appear
on the Import and Export Channel
dialogs. You can override this setting
using theMARI_
NAMEDFILEIMPORT_
SEQUENCELIMIT environment
variable.

You can use theNamed Files tab to
import or export individual files
rather than a sequence of patches
with theUDIM number (1001, 1002,
etc.) in the file names.
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Setting Type What it does Notes

Scene |Default Lights Fixed
To

dropdown Sets whether the lights are fixed to a
camera or scene by default.

Shelf | Show Overlay checkbox Specifies whether to show object
information over the itemswithin
shelves (for example, color values for
color swatches).

Shelf | Show Overlay checkbox Specifies whether to show item
labels in shelves (for example, names
for color swatches).

Shelf | Shelves Include
Presets

checkbox Specifies whether to showMari's
preset brushes in the Shelf tab. If
off, only your personal and custom
shelves are displayed.

Shelf | Remake Icons button RegeneratesMari's icons for shelf
items. If these have become corrupt
(for example, if your brush icons are
all blank), clicking this forcesMari to
re-create all the icons.

Slider Precision | Slider
Precision

slider Adjusts howmany decimal places are
represented by Mari’s sliders.
Increasing this gives you finer
control over slider values.
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Setting Type What it does Notes

ToggleTools | Tool on Key
Held

checkbox Sets how the shortcut keys for the
Zoom Paint Buffer (Z), Color
Picker (C), and Select (S) tools work.

If On, these shortcut keys only apply
while you're holding themdown.
Mari switches back to your previous
tool when you let go of the shortcut
key.

If this isOff, tapping the shortcut
key quickly switches permanently to
the tool, and holding it down for
more than a second or two switches
to the tool while you're holding the
shortcut key (and switches back as
soon as you let it go).

Usage Statistics | Send
Statistics

checkbox AllowsMari to send usage data to
The Foundry.

All information is sent
anonymously.

Navigation

General |Momentum
Enabled

checkbox If this is enabled, themodel has
momentum, so when you let go of
themouse button, it slowly coasts to
a stop. If this is disabled, themodel
only moves when you are holding
themouse button down.

General |Minimum Flick
Speed

entry box,
slider

Sets theminimum speed at which
you canmove yourmodel around.
The higher this is set, themore
sensitive themovement controls
are.
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Setting Type What it does Notes

General | Friction entry box,
slider

Affects themomentumof your
model as youmove it around the
canvas.

Decreasing this value
allowsmovement to
retain itsmomentum for
longer. Increasing the
value arrests
momentum faster.

General | Control Type dropdown Sets up theMari controls on the
canvas to match the controls of
another application, specified in the
dropdown list. Applications include:
Nuke, Maya, LightWave, and
Houdini.

Orbit | Lock To World Up checkbox If this is on, it locks the y axis to
world up view.

Orbit | Center Mode dropdown Specify the center point to orbit
around from the choice of:

• Look At - what is currently being
viewed in the display.

•Objects - the objects in a scene.

•Origin - the scene origin point.

• Selection - the current selection.

Roll | Circular Motion
Enabled

checkbox If enabled, rolling is achieved by
making a circularmotion in the
center of the canvas. If this option is
disabled, rolling is only donewith a
horizontal motion across the canvas.

Nuke

General |Use flat lighting checkbox,
reset

Modifies theNukeworkflow to use
flat lighting.

The reset icon resets the
flat lighting option back
to default.

Server |Nuke host entry box,
reset

Allows you to specify the host name
for the location of Nuke.
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Setting Type What it does Notes

Server | Port entry box,
slider, reset

Allows you to specify the port
number, ormodify it with the slider.

Server |Nuke launch path entry box Allows you to browse and load a
launch path for accessing Nuke files.

The path can bewritten
manually or inserted
using the browse and
load icon.

OpenCL

Graphics Card |Use Device dropdown Select whether toUse the graphics
card listed to performOpenCL-
accelerated operations, or set it to
Disabled, so that Mari does not use
the device.

If you haveOpenCL issues while
runningMari, try disabling this
device.

This preference is
available onMac only.

Graphics Card |Device
Vendor

information Displays the vendor (company)
name of the graphics card listed
above.

This preference is
available onMac only.

Graphics Card |Driver
Version

information Displays the driver version of the
graphics card listed above.

This preference is
available onMac only.

CPU |Use Device dropdown Select whether toUse the CPU listed
to performOpenCL-accelerated
operations, or set it toDisabled, so
that Mari does not use the device.

If you haveOpenCL issues while
runningMari, try disabling this
device.

This preference is
available onMac only.

CPU |Device Vendor information Displays the vendor (company)
name of the CPU listed above.

This preference is
available onMac only.

CPU |Driver Version information Displays the driver version of the
CPU listed above.

This preference is
available onMac only.

Painting
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Setting Type What it does Notes

Cursor | Shape dropdown Allows you to set whether the brush
cursor in Mari is displayed as an
outline of the selected brush tip or
as a standard round paint cursor.

Cursor |Opacity entry box,
slider

Allows you to set the opacity of the
brush cursor. This only affects how
opaque the cursor design is, not the
opacity of the paint.

Projection |Default Color
Depth

dropdown Sets the default color depthMari
uses: 8, 16, or 32-bit.

Paths

Channel Presets | Search Paths list, button Adds or removes directories that
Mari checks for channel preset
configuration files.

See theMari User Guide
for details on writing
your own channel
preset files.

Environments |HDR Paths list, button Adds or removes directories that
Mari checks for environment light
images.

For each directory provided, a
Thumbnails sub-directory within it is
looked for that should contain
smaller versions of the images, with
matching filenames, for use by the
UI.

WhenMari scans the
path, it also searches for
image thumbnails to use
from the Thumbnails
directory.

Shaders | Search Paths list, button Adds or removes directories that
Mari checks for compositing
shaders.

Ptex
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Setting Type What it does Notes

Face Textures |Minimum
Size

dropdown Sets theminimum face texture size.
The options provide increments in
powers of two, and allow you to
clamp face texture sizes during
project creation and face resizing.

The default state is 1 for
quadrangular textures,
and 2 for triangular
textures.

Scripts

Console | Font Size entry box,
slider

The point size of the default Mari
font in the Python console.

Mari Command Port | Port entry box,
slider

Sets the port number that Mari
receives commands fromNuke
through. The default value is 6100.

Mari Command Port | Enabled checkbox If checked, Mari can receive
commands through the specified
port.

The default state is
disabled.

Mari Command Port | Local
Host Only

checkbox If unchecked, Mari can listen for
connections to its command port
from any machine.

If this is checked, thenMari only
listens for connections from the local
machine.

Only allowing connections from the
local host ismore secure but
prevents you fromusing features,
such as theNuke<>Mari Bridge.

The default state is
enabled.
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68 Display Properties Dialog
TheDisplay Properties dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Allows you to set howMari displays the project - the background behind themodel, the overlay used on locked
patches, whether to showwireframes on themodel, and so on.

How to Access It
Right-click |main canvas > Display Properties

Display Properties Dialog Box Fields

Control Type What it does Notes

Canvas > HUD |HUD checkbox Shows theHeads Up Display information
in the background of the canvas (tool tips,
etc).

Canvas > Background | Image entry box,
button

Select the file to display as the project
background in the canvas. If not set, the
colors in theBottom and Top fields are
used for the background.

Canvas > Background |Bottom swatch Sets the color to display at the bottomof
the screen. To use a single color in the
background, set both theBottom and
Top to the same value.



372

Control Type What it does Notes

Canvas > Background | Top swatch Sets the color to display at the top of the
screen.

Canvas > Environment | Show
Environment

checkbox If an Environment light image is set to
display as a background on the canvas,
this control applies as a global setting for
the canvas so that it can be turned on or
off separately.

Canvas > Grid | Color swatch Sets the color for the onscreen reference
grid.

Canvas > Grid | Size entry box How large (in squares) the onscreen
reference grid is.

Canvas > Grid | Visible checkbox Shows the reference grid in the
background of the onscreen display.

This does not
affect the UV view.

Canvas > Wireframe | Color swatch The color of thewires displayed in the
wireframe overlay.

Canvas > Wireframe | Visible checkbox If this is selected, themodel in the 3D
views are displayed with thewireframe
visible on top of the paint.

Canvas > CameraMask |Opacity entry box,
slider

The opacity of the black bars that indicate
the aspect ratio of the perspective camera
in the Canvas.

By default, this is
set to 0, which
means the bars
are disabled.

Canvas > Linked Patches | Color swatch The color of the patches that are linked
together.

Canvas > Rendering | Checker
Color A

swatch Sets color A of the transparency
checkerboard. This can be selected using
the color picker.

Canvas > Rendering | Checker
Color B

swatch Sets color B of the transparency
checkerboard. This can be selected using
the color picker.

68 DISPLAY PROPERTIES DIALOG |



373

Control Type What it does Notes

Canvas > Rendering | Checker
Size

entry box,
slider

The size of the individual checkerboard
squares. This can be adjusted using either
the slider or the entry box.

By default this is
set to 10.

Canvas > Rendering | Render
Camera

checkbox Show the cameras on the canvas.

Canvas > Rendering | Render
Light

checkbox Show the lights on the canvas.

Canvas > Rendering | Render UV
Image

checkbox Show the patches in theUV view as they
appear after export, including the overspill
areas.

Canvas > UV Label | Text Color swatch The color for the onscreen text on theUV
view, used to show theUV patch
information.

Only visible if you
have opened the
dialog box from
within theUV
view.

Canvas > UV Label | Visible checkbox Whether to show the onscreen UV patch
information text over each patch in theUV
view.

Only visible if you
have opened the
dialog box from
within theUV
view.

Canvas > Selection | Fill Render dropdown When to show the selection fill color. This
appears in themiddle of selected areas.
Options are:

• Select - show the selection fill while the
area is being selected. Once you've
finishedmaking the selection, the fill
disappears.

• Always - show the selection fill thewhole
time the area is selected.

•Never - do not show the selection fill.

Canvas > Selection | Fill Color swatch The color to use to fill selected areas. Click
on the swatch to set the color.
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Control Type What it does Notes

Canvas > Selection |Outline
Render

dropdown When to show the selection outline.
This appears around the outside of
selected areas. The options are the same
as for Fill Render, above.

Canvas > Selection |Outline
Color

swatch The color to use to outline the selected
areas. Click on the swatch to set the color.
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69 Screenshot Settings Dialog
The Screenshot Settings dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Allows you to specify the settings for any screenshots that you take of theMari canvas. If these settings have never
been adjusted before, the dialog appears the first time you attempt to take a screenshot from theViewmenu.
However, you can change these settings at any time.

How to Access It
Menubar | View > Screenshot Settings

Screenshot Settings dialog box fields

Control Type What it does Opens
this dialog
box

Notes

Output entry box,
dropdown

The directory where the screenshots are to be
saved. Type the directory or click the file browser
button to navigate to it directly.

button Browse to the directory where you want the
screenshots to be saved.

Incremental dropdown If Enabled, multiple screenshots are saved with
incremental numbers appended to the filename.
If Disabled, every screenshot overwrites the
previous one.
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Control Type What it does Opens
this dialog
box

Notes

Background dropdown Sets whether the background of the screenshot
isGray or Transparent.
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70 Render Turntable Dialog
TheRender Turntable dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Takes the scene as you can see it through the selected shader, and creates a series of images showing themodel
rotating through an axis. The axis of rotation is a vertical line through the current camera view, centered in the
middle of the visible portion of themodel. You can include custom text or thumbnails of reference images in the
turntable.

How to Access It

Right-click | Projector in Projectors Palette > Render Turntable

Render Turntable Dialog Box Fields

Control Type What it does Notes

Settings | Size dropdown Selects the size of the generated images.

Settings | Antialias dropdown Howmuch anti-aliasing to use in the
generated images.

Settings |
Background

dropdown Selects the background for the images
(Gray, Transparent, or FromCanvas).

FromCanvas uses the current
background inMari.

Settings | Frames entry box,
slider

Sets the number of frames to generate -
howmany images should be in the
sequence.

Range: 1 to 1000

Default: 360
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Control Type What it does Notes

Settings | Play
Animation

checkbox If you are using animatedmodels or
textures, lets you render the turntable
with the animation.

When you check this, the
Frames control above
becomes disabled. This is
because the frame range is
taken from the Play Controls
Palette.

Settings |Offset entry box If you are combiningmultiple turntables,
lets you chain together sequences by
offsetting the image numbers.

For example, with an offset of
0, the first image is
MariTurntable_1.jpg. With an
offset of 360, the first image is
MariTurntable_361.jpg. You can
use this to generate one
sequence of frames for the x
axis, then another for the y
axis.

Settings | Filters dropdown If this is checked, the turntable images
are produced with the LUT and any
other applicable view filters applied. If
this is not checked, no filters are applied
to the images produced.

Settings | Lighting dropdown Specify whether you want to render a
turntable with Flat, Basic, or Full
lighting.

Info | Comment entry box,
dropdown

Sets a comment to include this at the
bottomof the turntable.

Info | Text Size entry box,
slider

Sets the text size for the comment. Range: 0.10 to 10.00

Default: 1.00

Info | Reference entry box,
dropdown,
button

Selects a reference image to include at
the top right of yourmodel.

Second dropdown specifies
whether the colorspace is sRGB
or Linear.

Output | Path entry box,
dropdown,
button

Specifies whereMari should create the
images.

Default: /local1
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Control Type What it does Notes

Output | Template entry box,
dropdown

Sets a template for the filenames. Thismust include the $FRAME
variable, so Mari assigns the
frame numbers correctly to the
files. Mari can export turntables
as either .tif, .png, .jpg, or .tga
files - change the file extension
in the template to set the file
type. Default:
MariTurntable_$FRAME.jpg

Output | Command entry box,
dropdown

Specifies any commands to run on files
after creating them.

Preview button Generates the first frame of the
turntable, enabling you to check the
placement of reference images and text.
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71 Diagnostic Turntable Dialog
TheDiagnostic Turntable dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Creates a series of images showing the scene rotating through an axis. The axis of rotation is a vertical line through
the current camera view, centered in themiddle of the visible portion of the scene. You can export multiple channels
at once. Mari creates all the images using the default shader and flat lighting.

How to Access It
• Right-click | Projector in Projectors Palette > Diagnostic Turntable

•Menubar | Camera > QuickTurntable

Diagnostic Turntable Dialog Box Fields

Control Type What it does Notes

Channel list Selects which channels to export
turntables for.

Settings | Size dropdown Selects the size of the generated
images.

Settings | Antialias dropdown Howmuch anti-aliasing to use in the
generated images.

Settings |Background dropdown Selects the background for the
images (Gray, Transparent, or From
Canvas).

FromCanvas uses the current
background inMari.
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Control Type What it does Notes

Settings | Frames entry box,
slider

Sets the number of frames to
generate - howmany images should
be in the sequence.

Range: 1 to 1000

Default: 360

Settings | Play
Animation

checkbox If you are using animatedmodels or
textures, lets you render the
turntable with the animation.

When you check this, the Frames
control above becomes disabled.
This is because the frame range is
taken from the Play Controls
Palette.

Settings | Filters dropdown If this is checked, the turntable
images are produced with the LUT
and any other applicable view filters
applied. If this is not checked, no
filters are applied to the images
produced.

Info | Comment entry box,
dropdown

Sets a comment to include this at the
bottomof the turntable.

Info | Text Size entry box,
slider

Sets the text size for the comment. Range: 0.10 to 10.00

Default: 1.00

Info | Reference entry box,
dropdown,
button

Selects a reference image to include at
the top left of yourmodel.

Second dropdown specifies
whether the colorspace is sRGB or
Linear.

Output | Path entry box,
dropdown,
button

Specifies whereMari should create
the images.

Default: /local1
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Control Type What it does Notes

Output | Template entry box,
dropdown

Sets a template for the filenames. Thismust include the $FRAME
variable, so Mari assigns the
frame numbers correctly to the
files.

If you're generating turntables for
multiple channels, this should
include the $CHANNEL variable,
as otherwise the later channels
overwrite the earlier ones.

Mari can export turntables as
either .tif, .png, .jpg, or .tga files
- change the file extension in the
template to set the file type.

Output | Command entry box,
dropdown

Specifies any commands to run on
files after creating them.

Preview button Generates the first frame of the
turntable, enabling you to check the
placement of reference images and
text.
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72 Quick Projection Dialog
TheQuick Projection dialog is described belowwith functions for how to access it. A list of the controls on the
dialog can be found in the table below.

What It Does
Sets the details that the quick projection tools use - the filename, file size, and lightingmodel for the quick project
files.

How to Access It
• Toolbars |Quick Projection

•Menubar | Camera >Quick Projection Settings

Quick Projection Dialog Box Fields

Control Type What it does Notes

Resolution dropdown Sets the resolution for the projected file.

Color Depth dropdown Sets the color depth for the projected
file.

Clamp checkbox If enabled, Mari clamps the RGB values
for the projected file.

Path entry box,
button

Specifies the location and filename for
the projected file.
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Control Type What it does Notes

Lighting dropdown Sets whether the projected file contains
lighting information:

•None - no lighting information.

• Separate File - lighting information is
stored in a separate file. For example:
diffuse.lighting.tif or
diffuse.lighting.psd.

• Layer - lighting information is stored in
a separate layer (PSD files only).
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