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RELEASE NOTES FOR MARI 1.4Vv2

Release Date 12 December 2011
System Officially Supported Operating Systems
Requirements « Windows 7 64-bit, or a Linux 64-bit operating system (Fedora 12 or Red

Hat Enterprise Linux 5.4)

Minimum Hardware Requirements

Quad-core processor

250GB disk space available for caching and temporary files (or a
minimum of 50GB if you're working on a small project)

At least 4GB RAM
Display with 1680 x 1050 pixel resolution

An NVIDIA graphics card with at least 1GB of RAM and OpenGL 3.0
support (see Supported Graphics Cards below)

Supported Graphics Cards

NVIDIA GeForce GTX 480*

NVIDIA GeForce GTX 580*

NVIDIA Quadro FX 3800***

NVIDIA Quadro FX 3800M***
NVIDIA Quadro FX 4800***

NVIDIA Quadro FX 5800***

NVIDIA Quadro (Fermi Series) 600*
NVIDIA Quadro (Fermi Series) 4000*
NVIDIA Quadro (Fermi Series) 5000*
NVIDIA Quadro (Fermi Series) 6000*

Please download and install the latest graphics driver for your card from
the NVIDIA website.

Note ‘"Displacement preview is currently only supported by these cards.

***Please note that as of Mari 2.0v1 we will cease to officially support
these cards.
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RELEASE NOTES FOR MARI 1.4V2
New Features

New Features

Feature
Enhancements

Bug Fixes

Known Issues &
Workarounds

There are no new features in this release.

There are no feature enhancements in this release.

e BUGID 23381 - The Watch feature of layered painting projections
sometimes stopped watching files after the first reprojection.

e BUG ID 23418 - Ptex: Mari crashed while creating projects from meshes
with triangular faces.

e BUGID 23583 - Custom post process filters, including the ones under
Python > Examples, did not compile against the GLSL 1.3 specifications
in Mari 1.4v1. Shader code that compiled for post process filters in Mari
1.3 may require some modification to comply with the new GLSL
specification.

e BUG ID 23626 - Clicking Objects > Ambient Occlusion sometimes caused
a crash.

e BUGID 23706 - Clicking in the LUT File box in the Color Manager palette
and then clicking elsewhere on the palette causes a crash.

To work around this, select a LUT via the Color Space toolbar instead.

e BUGID 11874 - Mari doesn’t recognize 3-digit padded OBJ sequences
as animation.

e BUGID 12102 - Current brush settings do not get saved as part of the
project. Instead, Mari reverts to the default settings when you close and
relaunch it.

e BUGID 12567 - Enabling Sync to VBlank in NVIDIA settings can
drastically reduce Mari’s performance.

If you experience very slow interaction, even with low-polygon models
and one of the Supported Graphics Cards, navigate to:

NVIDIA X Server Settings > X Screen 0 > OpenGL Settings and turn off
Sync to VBlank. Then, restart Mari.

e BUG ID 13394 - Using the Select Items tool with the Facing set to Front
to select and hide a portion of faces causes some of the faces within the
selection to remain visible when zoomed in.

To catch all selected faces, either:

« select Facing > Through instead of Front,
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Known Issues & Workarounds

OR
e zoom in closer to the object.
BUG ID 13481 - Making a selection using the Marquee Select Tool with
the selection mode set to Magic Wand sometimes ignores regions that
are completely surrounded by other selected regions, despite differences
in color.
BUG ID 13571 - Launching a new version of Mari for the first time, when
a config file exists from a previous version, sometimes results in an
object not appearing in the Ortho view.
To solve this, close Mari, delete the following config file and relaunch
Mari:
e Linux: ~/.config/TheFoundry/Mari.conf
» Windows: C:/Users/<login>/.mari/TheFoundry/Mari.ini
BUG ID 13640 - The Blur tool can be slow to use on the initial stroke.
Wait for Mari to process the blur before applying a second stroke.
BUG ID 13700 - Adjusting the Camera > Perspective settings for a
Projector is not reflected on the canvas until the Projector is made
Current.
BUG ID 14201 - Linux only: Mari becomes unresponsive after the system
is woken from sleep.
BUG ID 14208 - Windows only: Sometimes the canvas will only partially
refresh after a menu, palette or dialog box has been closed. To refresh
the canvas:

* Double-click on Mari’s title bar, or click the maximize button,

OR
¢ Click on another application’s window, and then back to Mari,

OR
e Switch to another canvas using the tabs, and then back again.
BUG ID 15491 - Python: PythonQt bindings are missing for some
enumerations and types such as QFileSystemModel. For enumerations,
you can usually work around the problem by passing in the integer value
instead.
BUG ID 15810 - The black borders at the edge of the canvas in
Perspective view are selected, if an object overlaps the borders when a
selection is made using the Marquee Select tool, with the selection mode
set to Magic Wand.
BUG ID 16324 - Windows only: You cannot currently import an image
into a channel using a relative file path. To work around this, use an
absolute path when importing images.
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Known Issues & Workarounds

BUG ID 16616 - Python: PythonQt sometimes crashes when adding
temporary objects to layouts, or compound widgets such as
QTreeWidget. This is because of incorrect reference counting. To work
around the problem, always store a reference to every GUI item until you
are sure it is no longer needed.

BUG ID 17018 - Required channels are not created when a shader is
copied.

BUG ID 17618 - Ptex will not bake properly if the resolution of the face
is too small.

The work around is to increase the resolution of the selected faces you
are having problems with.

BUG ID 17623 - Using the Wacom stylus pen nib to simulate a mouse
button press on dialogs appears to intermittently get stuck so that
further presses on the nib temporarily fail to be acknowledged.

Waiting for a few seconds may free the problem. Moving the stylus off of
the pad also may work.

Using a button on the stylus pen, registered to a mouse click, does not
appear to have this issue

BUG ID 17626 - It can take a long time to import very large or very high
polygon count Ptex models.

The work-around is to assign a small uniform face size (1x1 or 2x2) on
import, and then increase the resolution of the relevant bits of the model
as necessary after loading.

BUG ID 17690 - The Tiled shader module and the Masked Tiled shader
module do not render correctly on Ptex channels. They are only intended
for use with a UV mapped object.

BUG ID 18292 - Loading Mari on a Fedora Linux distribution may cause
the application to crash upon startup. If you encounter this problem, try
the following:

¢ Launch Mari with the --nobrowser command line option. This disables
any web-browser related functionality in Mari, and should resolve the
issue.

¢ Update the java-1.6.0.0 package to a version newer than version 41.

¢ Update or uninstall Open]DK.

* Update or uninstall Flash Player.

BUG ID 18457 - Using "Fermi Series” NVIDIA graphics cards with drivers

older than version 270 results in various rendering issues when the

Virtual Texture Type is set to Half or Float.

To resolve this, please download and install the latest graphics driver for

your card from the NVIDIA website.

The Foundry
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Known Issues & Workarounds

BUG ID 18610 - Ptex: Loading an OBJ with multiple geometries can be
slow.

BUG ID 19780 - Nuke<>Mari Bridge: A projector created in Ortho view
in Mari does not re-project correctly in Nuke.

BUG ID 19829 - Nuke<>Mari Bridge: Unprojecting a displaced piece of
geometry does not project correctly in Nuke.

BUG ID 20021 - Textures in the canvas intermittently switch between
lower and higher resolutions.

This issue is more likely to occur if your virtual texture atlas resolution is
low, and you're working on a complex model with displacement. Possible
work-arounds include increasing your virtual texture atlas size, reducing
the number of channels Mari has to access at once (for example, by
reducing the number of channels required for the current shader), or to
disable displacement temporarily.

BUG ID 20510 - If you find that the startup time for Mari is longer than
usual, please check that the LIC files in your RLM licensing data folder do
not refer to obsolete server ports. If they do, move them out of the way
and restart Mari.

BUG ID 21800 - The images used as inputs for shader modules (for
example, those for Triplanar Projection) are linked via the Image
Manager. When you load an image for a shader, its location on disk is
remembered, and a copy is loaded into the Image Manager. The copy of
the image in the Image Manager is used across all shaders that use it.
This results in the following two oddities:

1. When you attempt to reload an image modified on disk from the Shad-
ers palette, it will look up the image with corresponding (previously used)
file name in the Image Manager, and use that instead. The image will not
be reloaded.

2. When you reload an image modified on disk from the Image Manager
palette, it will be loaded as a new image. This will cause the thumbnails
for shaders parameter list to be updated, but internally the shader will
still use the old image - so there is a mismatch in the image shown in the
parameters and the image actually used by the shader. The shaders will
only use the new image once all the similarly named old copies have been
removed from the Image Manager.

If you need to work around the above behavior, then:

1) use different file names for images you want to change separately for
different shaders, and

2) if you need to reload a modified image, clear out old copies in the
Image Manager and then load the updated image.

BUG ID 22099 - The way that Mari converts quad faces to triangular
faces is different to other applications. As a result, normal map renders
from other applications may not always match.

The Foundry
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e BUG ID 23010 - Nuke<>Mari Bridge: If Mari crashes when receiving
incoming components from Nuke when the Virtual Texture Type is set to
Float, lower the Virtual Texture Size to a value below 8192x8192.

VISUAL EFFECTS SOFTWARE
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Release Date

RELEASE NOTES FOR MARI 1.4V1

Release Date

System
Requirements

Note

30 November 2011

Officially Supported Operating Systems

« Windows 7 64-bit, or a Linux 64-bit operating system (Fedora 12 or Red
Hat Enterprise Linux 5.4)

Minimum Hardware Requirements
¢ Quad-core processor

» 250GB disk space available for caching and temporary files (or a
minimum of 50GB if you're working on a small project)

¢ At least 4GB RAM
¢ Display with 1680 x 1050 pixel resolution

¢ An NVIDIA graphics card with at least 1GB of RAM and OpenGL 3.0
support (see Supported Graphics Cards below)

Supported Graphics Cards
¢ NVIDIA GeForce GTX 480*
* NVIDIA GeForce GTX 580*
¢ NVIDIA Quadro FX 3800***
« NVIDIA Quadro FX 3800M***
¢ NVIDIA Quadro FX 4800***
¢ NVIDIA Quadro FX 5800***
e NVIDIA Quadro (Fermi Series
e NVIDIA Quadro (Fermi Series
e NVIDIA Quadro (Fermi Series
e NVIDIA Quadro (Fermi Series

600"

4000*
5000*
6000*

[ i )

Please download and install the latest graphics driver for your card from the
NVIDIA website.

*Displacement preview is currently only supported by these cards.

***Please note that as of Mari 2.0v1 we will cease to officially support these
cards.
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New Features

New Features * A color space toolbar based on the OpenColorlO library has been added
to Mari with controls for the following:

* Input color space

¢ Display color space

* Viewing of individual color channels
¢ Gain and gamma levels

¢ Loading custom LUTs.

In addition, a Color tab has been added to the Mari Preferences dialog,
allowing you to set the default values for the controls in the toolbar.

¢ Basic PSD file support has been added for UV based projects. You can

now:

e Export a selection of channels as layers to a .psd file.

e Import a .psd file, where image data layers are imported onto channels
of the same name, or if no channels exist, new ones are created.

 Load/Save .psd files via the Image Manager.

¢ You can also unproject a painting to a layered PSD file by clicking Camera
> Painting Unproject. The resulting PSD file includes a wireframe and
pseudo-lighting layeres. Once unprojected, Mari automatically launches
your image editor where you can paint on the individual layers. Once
finished, you can reproject these layers back into Mari. The Painting
Projection Settings dialog has fields for specifying your Image Editor and
whether file watching is enabled.

e There is a new button in the Shaders palette called Create Layered
Shader. Clicking this creates a new shader from channels loaded from a
layered PSD file.

* You can now apply a mask to control areas on a model affected by
filters. The following can be used as masks:

¢ Channels
* Images in the Image Manager
» Marquee Selections (for paint that has not been baked)
e Seven new shader modules have been added to the Shaders palette:

« Diffuse Brightness/Contrast - Adjusts the brightness and contrast of
the base diffuse channel.

« Diffuse HSV - Applies an HSV adjustment to the base diffuse channel.

¢ Masked Brightness Contrast - Adjusts the brightness and contrast of
the base diffuse channel using another channel as a mask.

¢ Masked Diffuse HSV - Applies an HSV adjustment to the base diffuse
channel using another channel as a mask.

The Foundry Mari 1.4v2
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Feature Enhancements

Feature
Enhancements

* Masked Blend Constant Color - Adds a selected color to the surface,
using a channel as a mask. The result is blended with the underlying
diffuse channel according to the Blend Amount and Blend Mode.

e Triplanar - Provides more efficient control of tiled textures in 3D
space. You can set three separate images (Front, Top, and Side) for til-
ing. The repetition and rotation angle can be adjusted for each individ-
ual image.

* Masked Triplanar - A Triplanar shader module using a channel as a
mask.

Two new filters have been added to the Filters menu:
¢ A Color Correction filter based on the OpenColorlO library.
* An Add Noise filter to apply noise to the current channel or painting.

A new tool called Zoom Paint Buffer has been added. This lets you zoom
the scene and the paint buffer together. You can enable this via the
Tools toolbar or by pressing Z. Zooming is reset when paint is baked.

Mari now includes a C API for importing custom geometry formats and
importing/exporting custom image formats. Documentation can be found
under Help > SDK > C APl > Documentation. Headers and examples are
in the installation directory under SDK/include and SDK/examples,
respectively.

To see a list of the plug-ins loaded, select Tools > Plugins. Any user
plug-ins are displayed in the box underneath the list.

To build the examples, Makefiles are provided on Linux, and a Visual Stu-
dio solution with build batch files are provided on Windows. The build
process for these examples should be simple as there are no libraries to
link to, and no special options should be required other than using the
single include directory.

Mari Preferences

A new preference has been added to Preferences > Data to improve
stability and prevent Windows driver resets. Increasing Deferred Quad
Split Count splits the canvas into smaller parts, which can help to avoid
Windows graphics driver resets.

Preferences > Data > Gpu 0 has been renamed to Graphics Card, and the
tooltips for it have been improved.

An option has been added to the Mari Preferences dialog under Data >
Graphics Card to turn Deferred Texture Array on/off. When this is active,
Mari makes more efficient use of OpenGL.

A Max Tile Size for Tiled Renders preference has been added to
Preferences > Data > Graphics Card. This preference lets you set the

The Foundry

Mari 1.4v2



RELEASE NOTES FOR MARI 1.4V1
Feature Enhancements

maximum tile size for tiled render operations like unprojections. Setting
this to a lower value improves accuracy but may result in a slower render
operation.

Preferences > Data > Channels > Autosnapshot is now disabled by
default.

The Virtual Texture Size in the Mari Preferences dialog is now expressed
in pixels.

The texture size options under Preferences > Data > Graphics Card >
Virtual Texture Size are now defined by numerical values.

Ptex

The scaling of constant color faces now makes better use of available
CPU resources.

Mari now uses a CPU based algorithm for generating proxy textures
during the last step of face resizing.

While efficiency has been improved, the interface may appear unrespon-
sive when the CPU is updating the proxy textures.

Ptex project creation and face resizing operations have been optimized.
Hashing has been added for Ptex channels, taking into account pixel data
and face sizing. Hashes uniquely identify Ptex content and can be
compared to determine if a Ptex channel has changed.

Worldspace Texels are now expressed as floating point values.
Choosing a clear color for an empty Ptex project now uses a standard
Mari color swatch that also displays transparency.

Nuke<>Mari Bridge

When the Send Sequence Projections option finds multiple temporary
files that already exist, it now shows a single dialog asking which to
overwrite, instead of one dialog for each file.

There is now an option for switching the lighting mode to flat when
sending LUTs from Nuke.

Image Manager

There is now an option for Color Space Conversion when importing an
image via the Image Manager.

You can now change the Color Space of an image in the Image Manager
by selecting either COLOR or SCALAR from the dropdown menu under
Image Info.

The Image Manager > View Image dialog now has marquee selection
width and height fields when set to Fixed and Aspect modes.

The Foundry

Mari 1.4v2

10



RELEASE NOTES FOR MARI 1.4V1
Feature Enhancements

Palettes

e The Update Masks button in the Projectors palette has been renamed to
Update Only Masks From Projector.

¢ Clicking Update Global Settings From Projector in the Projectors palette
updates the global projection settings in the Projection palette. Clicking
Update Only Masks From Projector in the Projectors palette updates only
the global mask settings in the Projection palette.

¢ The Color Manager and the Color Picker tool have been improved.

Brushes

* Added a set of new brushes. You can find them in the Brad's New
Brushes tab of the brush presets in the Brush Editor palette.

» Mari's default brush has been replaced with a much smoother, softer
edge brush.

Command Line

e Three new command line options have been added. They are alternative
versions of three existing options:

« —-execute (This is the equivalent of -x)
« —terminal (This is the equivalent of -t)
« v (This is the equivalent of --verbose)

e Launching Mari via the command line with the option --nobrowser
disables any web browser related functionality in the application.

Projectors

¢ You can now export an approximation of the effect of the lighting in
Mari as a layer or separate image in the Quick Projection dialog.

e UV scale has been added for all projections to allow for negative values
which allows flipping.

¢ In the Projectors palette, projector file path fields have been moved next
to their corresponding Project and Unproject buttons.

¢ Projectors > Image has been renamed to Unproject.

Miscellaneous

¢ The Environment Sphere shader module now has controls for both Falloff
Start and Falloff End.

¢ A Ctrl+Shift+C hotkey has been added to clear the paint buffer.

e Pressing Ctrl+Tab and Ctrl+Shift+Tab now cycles forwards and
backwards through the tabs above the canvas.

The Foundry
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Feature Enhancements

There is now an option in the Canvas toolbar called Whole Patch Project.
When turned on, this allows the projection of paint onto UV patches
located outside of the shells of the original geometry. This function is
only available in UV views.

There are new icons for the status of the virtual texture atlas in Mari:
@ - Loading data from disk.
@ - Loading data from RAM to GPU memory.

@ - No space left for this operation. Please see BUG ID 20021 in the
23249 - The Snapshots palette kept re-appearing even if you closed it.

section for more information.

A warning is now displayed if you attempt to change the Virtual Texture
Size or the size of your Paint Buffer to a value that is not supported by
your graphics card.

A Values tab has been added to the Color Picker that allows color values
to be edited as Byte, Half, or Float.

A checkbox has been added to the Import Image Summary dialog to
disable the dialog for subsequent imports.

A Lookup Shortcut search field has been added to the Manage Toolbars
and Manage Keyboard Shortcuts dialogs. Enter a keyboard shortcut here
and Mari searches for the associated action.

The virtual texture system has been optimized.

The Space key can no longer be used for custom shortcuts.

The Export dialog now supports additional options for some layered file
formats.

You can now rename a project by right-clicking on it in the Projects tab.
Memory management has been improved, so that Mari is less likely to
use system swap space when working with large projects or complex
operations.

You can now adjust the strength of the Blur tool using the Blur slider in
the Blur toolbar.

A dropdown menu called Mask Component has been added to the Masked
Diffuse shader module. Use this to select the color component from the
channel in the Mask Texture that you want to use as a mask.

You can now import OBJ files that define faces with negative vertex
attribute indices.

You can now remove images from shader modules by clicking on the
reset button next to the image.

You can now edit and delete curve editor points via the right-click menu.
You can now rename the currently open project by clicking File >
Rename.

The Foundry
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Bug Fixes

Bug Fixes

Color Manager > Use Color Correction has been renamed to Enable Color
Management.

The default Ul layout has been updated.

The Snapshot function has been updated to manage Snapshots more
efficiently. As a result, the interface is more responsive with a large
number of Snapshots.

Some of the icons in the GUI have been improved.

When Baking a shader, there is now an Auto option that bakes according
to the highest/lowest patch sizes present in the shader.

Additionally, Mari now remembers the previous setting used to bake a
particular shader.

Graph editor boxes now have spline point right-click menu items to edit
and delete points.

Camera > Painting options have been renamed to Layered Painting
options and have new tooltips.

Paint through Lock Object has been split into Pan Lock and Scale Lock.

The filter for the Sequence import tab has been modified so that, when
the search Template is empty, images without the $UDIM naming
convention are also listed.

The font size in the Python Console is now retained.

The Community tab has been renamed to Forums.

Shader modules with image inputs now display thumbnails.
Mari now uses slightly less CPU resources when idle.
Slider behavior has been improved.

The layout of the Mari documentation set has changed.
The Mari EULA has been updated.

The select tool stopped working when Quick Copy, Quick Paste or Ctrl+
shortcuts were selected.

Tessellation shaders are no longer automatically created for projects
that use tessellation, when they are opened on cards that do not support
it.

The Add Version dialog now remembers its size.

Mari now properly displays errors when unable to rename projects.

BUG ID 11902 - In the Projection palette, under Channel Mask > Mask
Channel, the available channels list displayed the channels for all objects.
This has been changed to show only the channels for the current object
for clarity.

BUG ID 12020 - Submenus did not appear as soon as the pointer moved
over them, making navigation difficult for tablet input.

The Foundry
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Bug Fixes

BUG ID 15603 - Windows only: USER Objects in the Task Manager
increased indefinitely when switching between tools.

BUG ID 15693 - Undoing the addition of a new shader module was not
possible.

BUG ID 16571 - Undoing a Remove SurfaceShader didn’t always work as
expected.

BUG ID 17017 - Mari crashed if you closed a project immediately after
creating it.

BUG ID 17359 - Windows only: Upgrading a project from an older
version resulted in a black thumbnail for that project in the Projects tab.
BUGID 17765 - Pressing Ctrl+B to bake paint into a new channel did not
work correctly for channels without an alpha.

BUG ID 18101 - Some specific user shortcut keys were overwritten by
Mari's default shortcuts.

BUG ID 18319 - The Towbrush tool showed two cursors at once.

BUG ID 18364 - Images imported by the Tiled shader module came in
upside down.

BUG ID 18655 - Ptex: The default export path ended with .ptx.ptx
instead of .ptx.

BUG ID 18969 - The Help menu has moved to the end of the menubar.
BUG ID 19039 - All filter options now have reset buttons to return
values to their default state.

BUG ID 19549 - Switching between tools using keyboard shortcuts did
not work correctly.

BUG ID 19700 - Resizing images on import now works as expected.
BUG ID 19739 - Applying blur to an alpha channel with paint on it and
then painting over was leaving an outline where the previous paint was.
BUG ID 20115 - Warping paint with the Pinup tool did not work as
expected.

BUG ID 20118 - Filling selected faces on a Ptex channel with the format
set to half did not work.

BUG ID 20148 - Baking through a shader setup with Channel Mask active
failed.

BUG ID 20155 - The Snapshot function was updating once per channel
per Snapshot add or delete and Python registered palettes were not set
up correctly.

BUG ID 20169 - Python: Channellnfo file templates and paths were not
applied correctly.

BUG ID 20173 - Dragging a shader module onto itself removed it from
the Shaders palette.

BUG ID 20251 - OBJ files with empty group names did not load properly.

The Foundry
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Bug Fixes

BUG ID 20264 - Front face selection did not work as expected in
Perspective view.

BUG ID 20327 - When creating a new project, selecting a single texture
for import using the file browser did not work.

BUG ID 20376 - Mari crashed when importing some 16-bit floating point
TIFF files.

BUG ID 20415 - Python: $GEO and $ALLGEO patch attributes are now
updated when new geometry is added.

BUG ID 20433 - Filter Preview did not work for multiple objects.

BUG ID 20634 - Python: Importing images smaller than 512x512 caused
a crash.

BUG ID 20648 - Smart selections did not work with all geometries.

BUG ID 20666 - Python: Changing a shader parameter was not reflected
in the GUI.

BUG ID 20699 - Smart selections did not always work with multiple
geometries.

BUG ID 20765 - Mari did not allow snapshots to be created for projects
with mixed UV and Ptex objects/channels.

You can now create snapshots for the UV channels in such projects.
Snapshots for Ptex channels may be supported at some point in the
future.

BUG ID 20904 - The Clone Stamp and Towbrush tools were clamped.
BUG ID 20922 - A project did not load because of a missing thumbnail in
the Image Manager.

BUG ID 20952 - The Mari command socket allows the execution of
arbitrary Python code with the same access rights as the Mari
application. For improved security when the socket will only be used by
other applications on the same machine (for example, the Nuke<>Mari
Bridge where Nuke and Mari are on the same machine), there is now the
option to make the Mari command socket allow connections from
localhost only.

BUG ID 20964 - Image Import and Export dialogs contained multiple
copies of the same file extension and didn’t appear in alphabetical order.
BUG ID 20972 - Nuke<>Mari: Nuke's default listening port conflicted
with Maya’s. This has now been changed to 50107.

BUG ID 20997 - Navigating a model with a Projector active and Edge
Mask enabled resulted in unexpected behavior.

BUG ID 21018 - Using the Paint tool on a transparent channel with the
Painting Mode set to Clear did not work as expected.

BUG ID 21130 - You can no longer remove all geometry from a project.

The Foundry
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Bug Fixes

BUG ID 21146 - Some keyboard shortcuts for the Slerp tool did not
work.

BUG ID 21149 - Paint Through image previews were clamped.
BUG ID 21154 - Selecting Camera > Quick Project Front did not work.

BUG ID 21184 - Gaussian, Soften and High-Pass filters sometimes
caused a display driver reset.

BUG ID 21191 - Integer sliders in Preferences > Data did not behave as
expected.

BUG ID 21193 - Image export failures were unclear.
BUG ID 21262 - Some filter dialog boxes were too small.

BUG ID 21269 - The Mask to Alpha function did not work correctly when
the bit depths of the two channels did not match.

BUG ID 21294 - Increasing the exposure in the Color Manager resulted
in a slightly red hue.

BUG ID 21410 - Quickly switching to the Clone Stamp tool or the Blur
tool caused the application to hang.

BUG ID 21458 - Ptex: Face flood filling was slow and used too much
memory for models with large face counts.

BUG ID 21480 - Previewing images in the Image Manager caused
problems with image previews in shader modules.

BUG ID 21508 - Ptex: Exporting certain Ptex files took a long time.
BUG ID 21525 - Unprojecting an image greater than 2K corrupted it.
BUG ID 21552 - Ptex: Exporting Ptex files for triangle only meshes
caused a crash.

BUG ID 21591 - Using smart face selection on certain Ptex projects
caused a crash.

BUG ID 21603 - Face selection did not work correctly in Perspective
view,

BUG ID 21612 - Baking a shader with an image preview swatch crashed
Mari.

BUG ID 21628 - Mari was unable to import OBJ files with negative face
indices.

BUG ID 21664 - Renaming patches, through Python or the GUI, now
correctly updates the UV view and persists with a save.

BUG ID 21678 - The Brush Editor palette failed to load correctly if the
Select tool was in use.

BUG ID 21719 - Nuke<>Mari: Send Current View only worked for the
first frame of an animated projector.

BUG ID 21948 - The result of applying a filter did not match the preview
for 32-bit RGBA channels.

The Foundry
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Bug Fixes

BUG ID 21963 - The Color Picker was sometimes unresponsive when
adjusting the color slider.

BUG ID 22042 - Renaming a channel referenced by a shader before it
was made current caused problems.

BUG ID 22057 - Ptex: Resizing faces a number of times caused a crash.
BUG ID 22099 - Normal maps did not always render correctly.

BUG ID 22173 - Importing an invalid image onto a channel caused Mari
to hang.

BUG ID 22206 - Mari Preferences > Painting > Projection >
Supersampling has been removed.

BUG ID 22207 - The vascularVeinage brush did not work.

BUG ID 22219 - Projects created from the command line had trashcan
icons in place of their thumbnail images.

BUG ID 22266 - Renamed projects continued to display old project
names until they were saved again.

BUG ID 22270 - A number of unnecessary windows appeared on start-
up.

BUG ID 22273 - Warning messages were repeated many times when
filter dialogs were active.

BUG ID 22332 - Resizing the Luminosity filter dialog corrupted the
Preview enabled icon.

BUG ID 22394 - Brushes could be accidentally renamed when using the k
shortcut pop-up menu.

BUG ID 22513 - Unnecessary property changes were logged in the
history.

BUG ID 22520 - Adding a new shader module and then closing the
project caused a crash.

BUG ID 22540 - Undoing the addition of a shader removed it from the
history.

BUG ID 22546 - Undo and redo did not take into account a shader
module’s enabled/disabled status.

BUG ID 22555 - Channel Export did not respect Selected only patches
for named files.

BUG ID 22560 - Mari Preferences > Data > Thread Count always
defaulted to 2.

BUG ID 22599 - Disabling clamping on a projector did not allow HDR
projections.

BUG ID 22600 / 20558 - NVIDIA 270.* drivers on Linux caused crashes.
Mari now warns you if you are using these drivers. If you are, we
recommend upgrading to 280.%,
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BUG ID 22613 - Nuke<>Mari Bridge: Sending a camera from Nuke to
Mari sometimes failed.

BUG ID 22656 - The Painting Projection dialog was using too much
screen real estate.

BUG ID 22667 - The Preview Alpha control for the Paint Through tool
was not working.

BUG ID 22711 - Switching Paint Buffer sizes from 16k caused a crash.
BUG ID 22806 - Corrected the Mask Tiled shader so that masked out
areas do not affect the underlying color.

BUG ID 22808 - Some soft brush opacities were accumulating in a single
stroke.

BUG ID 22844 - Exporting and re-importing 16-bit RGB channels did not
work as expected.

BUG ID 22858 - The Environment Sphere shader module is no longer
clamped when using images with a high dynamic range.

BUG ID 22871 - Renaming a large number of patches at once took a very
long time.

Projects with a very large number of items in a collection (such as
patches) are now processed much more quickly, both when renaming
items and when loading.

BUG ID 22878 - Some toolbars could not be seen clearly upon a first
launch of Mari.

BUG ID 22912 - Added a dialog that allows you to select a layer from a
layered image. Added a dialog to projection if there is more than one
layer in the loaded layer.

BUG ID 22925 - Mari could not handle objects that contained faces with
no UV coordinates.

BUG ID 22950 - Nuke<>Mari Bridge: Sending projection components to
Mari failed if there were any Dot or NoOp nodes between the Project3D
node and the Camera.

BUG ID 23022 - The UV view was very slow when using projects with a
lot of patches.

BUG ID 23041 - Fixed some issues loading older Ptex projects.

BUG ID 23054 - Fixed shader rendering issues when using preset
gradients in shader module parameters.

BUG ID 23061 - Mari didn't release its handles to various files when
sending things across the Nuke<>Mari Bridge causing a number of Nuke
errors.

BUG ID 23118 - Progress bars didn’t always update correctly.

BUG ID 23129 - OBJ files with many groups were slow to load.
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Developer Notes

New Features

Feature Enhancements

e BUG ID 23194 - Mari crashed when importing an OBJ file containing
degenerate quads for Ptex.

e BUGID 23210 - The Ptex project creation dialog now uses the last clear
color used if a new one is not selected.

e BUGID 23222 - Tiled shaders clamped the output to SDR ranges.

e BUGID 23247 - The file browser icon in the Python Console was too
bright.

e BUGID 23249 - The Snapshots palette kept re-appearing even if you
closed it.

Here are the changes relevant to developers.

Mari now includes a C API. Documentation can be found by clicking on Help
> SDK > C API > Documentation. Headers and examples are in the
installation directory under SDK/include and SDK/examples, respectively.

To see a list of the plug-ins loaded, select Tools > Plugins. Any user plug-
ins are displayed in the box underneath the list.

To build the examples, Makefiles are provided on Linux, and a Visual Studio
solution with build batch files are provided on Windows. The build process
for these examples should be simple as there are no libraries to link to, and
no special options should be required other than using the single include
directory.

e A signal has been added for when GLSL filters are enabled or disabled.
* You can now get and set the lighting mode on a project.

¢ Signals have been added for when objects, channels, shaders, and
projectors are renamed.

¢ You can now retrieve optional sub-properties of metadata items, such as
range or display name.

¢ Unproject size validation has been changed to allow arbitrary sizes to be
used through Python.

e Python bindings have been added for:
¢ Setting and getting foreground and background colors
¢ Signals when foreground and background colors are modified
* Displaying the color picker dialog and returning the value picked
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* Renaming a channel.
A convenient static function has been added to create icons.
You can now insert a widget before an action on a toolbar.

Shader declarations and body parameters are now optional when
creating a GLSL shader via the Python API.

Python: The Metadata class has been refactored and extended:

¢ The missing metadataChanged and metadataRemoved signals have
been implemented.

¢ A metadataCreated signal has been implemented.

* You can now set sub-properties on a metadata item.

Python: Creating channels of invalid sizes now shows an error message.

A Python example of how to use Mari’'s Command Port has been added.

A Python method has been added to release the physical memory used

for DDI caching.

Python: The PostFilter APl has been extended to include methods for

disabling a filter and querying whether it's been enabled.

Python: Error checking has been improved when importing Python

modules.

Python: mari.images.savelmages() has been added to allow you to save a

list of images as a layered file.

Python: mari.projects.rename() has been added to enable project

renaming.

Python: A new ImageManager function that opens an image file and

returns a list of images has been added.

Python: Added the new function mari.gl_render.flushError(). This

performs the same function as calling glError() in C++.

Python: Creating mari.Channelinfo instances no longer compares the

requested dimensions against OpenGL maximum texture dimensions.

Channels can now be larger than the size supported by your graphics

card.

Python: You can now set persistent metadata on Projectinfo objects.
This allows project data to be stored without opening the project.

Python: The method bIockSignaIsO has been added to the LineEdit and
Slider Ul classes.

Python: The following functions have been added:
* Projectinfo.modelPathList()

* mari.projects.get()

* mari.projects.current().info()

Python: Error checking has been improved when importing Mari Python
modules.
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Bug Fixes

Python APl documentation:

¢ Improved the documentation on how UV indices and Channel Image
indices relate to each other.

* Added a better example for Channel.importimages().

BUG ID 16769 - Python: Projectinfo.modelPath() was not working
correctly. The correct data is now returned from projects once they have
been saved at least once after this update.

BUG ID 20666 - Python: Changing a shader’s parameters via Python did
not update the GUI.

BUG ID 22033 - Command outputs in the Python Console were not
always displayed correctly.

BUG ID 22040 - Canvas.repaint() did not work while processing was
active, for example, between calls to mari.app.startProcessing() and
mari.app.stopProcessing().

BUG ID 22268 - Python: Various errors have been fixed when passing
arguments to scripts run via the command line.
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