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Version 1.1v3

Release Date 22 December 2010

System 
Requirements

Recommended System Requirements

• Quad-core processor

• Windows 7 64-bit, or a Linux 64-bit operating system (Fedora 12 or Red 
Hat Enterprise Linux 5.4)

• 250GB disk space available for caching and temporary files (or a 
minimum of 50GB if you're working on a small project)

• At least 4GB RAM

• Display with 1680 x 1050 pixel resolution

• An NVIDIA graphics card with at least 1GB of RAM and OpenGL 3.0 
support (see Recommended Graphics Cards below).

Recommended Graphics Cards

• NVIDIA GeForce GTX 480

• NVIDIA Quadro FX 3800

• NVIDIA Quadro FX 3800M

• NVIDIA Quadro FX 4800

• NVIDIA Quadro FX 5800

• NVIDIA Quadro (Fermi Series) 600

• NVIDIA Quadro (Fermi Series) 5000

• NVIDIA Quadro (Fermi Series) 6000

Please download and install the latest graphics driver for your card from the 
NVIDIA website.
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New Features There are no new features in this release.

Feature 
Enhancements

• When baking a shader, you can now set the name of the channel in the 
Bake Shaders dialog.

• Texture derived normal and height maps now match other applications 
and render engines better.

Bug Fixes • Mari no longer selects hidden faces when the Select Tool is set to Facing 
> Through.

• Adjusting the value of the paint tool’s Opacity slider caused the paint in 
the buffer to change color.

• BUG ID 10448 - Saving a project was not possible if a new Shader was 
created immediately after opening an existing project, without first 
making another change.

• BUG ID 13336 - Renaming Projects or Menu shelf items activated 
shortcuts when certain keys were pressed.

• BUG ID 13484 - Right-clicking on the canvas with a Wacom Pen Tablet, 
when using the Marquee Selection tool, did not launch the contextual 
menu.

• BUG ID 13569 - Undoing strokes in the paint buffer sometimes behaved 
unexpectedly.

• BUG ID 13797 - There were some performance issues with animated FBX 
camera imports including frame inconsistencies and geometry clipping.

• BUG ID 13908 - Windows Only: Making a selection using a Wacom Pen 
Tablet did not always work first time.

• BUG ID 14266 - Windows Only: There was an issue with pressure 
sensitivity when using Wacom Pen Tablets, resulting in alpha and flow 
painting at full opacity irrespective of your brush’s properties.

• BUG ID 14984 - Paintings saved to the Image Manager were not saved 
with a project on closing.

• BUG ID 14994 - Making a selection using the Select Tool with the Facing 
set to Through, would not always select all front faces.

• BUG ID 15107 - Rendering certain turntables caused Mari to crash.

• BUG ID 15254 - Changing the Input or Output file paths in the 
Projectors palette did not work as expected.

• BUG ID 15264 - Right-clicking on the canvas with some tools using a 
Wacom Pen Tablet, did not display the contextual menu.
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• BUG ID 15320 - Right-clicking on the canvas with a Wacom Pen Tablet, 
when using the Pan Selected Object tool prevented you selecting 
anything else in Mari.

• BUG ID 15333 - Rotating the Paint Buffer using the Rotation Slider in 
the Painting palette caused some of the paint in the buffer to 
temporarily disappear.

• BUG ID 15351 - Closing Mari immediately after creating a shader caused 
Mari to crash.

• BUG ID 15352 - Rendering a turntable with Deferred Shading active and 
Shaders set to Current caused Mari to crash.

• BUG ID 15539 - Windows Only: Switching between tools in the toolbar 
caused Mari’s USER object count to increase indefinitely, causing a 
crash.

• BUG ID 15596 - In Windows 7, the value for Max Image Memory under 
Edit > Preferences > Data > Gpu 0 was capped at 1.0GB for some 
graphics cards.

• BUG ID 15597 - The default value for Max Image Memory under Edit > 
Preferences > Data > Gpu 0 is now set to 50% of the maximum memory 
available.

• BUG ID 15677 - Using the Marquee Select Tool with the selection mode 
set to Magic Wand, only allowed up to 3 selections to be made before 
resetting the selection.

• BUG ID 15688 - Undoing multiple marquee selections made with the 
Marquee Select Tool set to Ellipse Selection Mode sometimes caused a 
crash.

• BUG ID 15876 - Clicking on the canvas with a Wacom Pen Tablet, when 
using the Color Picker tool resulted in unexpected behaviour.

• BUG ID 15905 - In Windows 7, applying a filter to a selected patch 
sometimes caused a crash.

• BUG ID 15937 - The help text displayed when selecting or deselecting 
faces was incorrect.

Known Issues and 
Workarounds

• Mari sometimes doesn't paint on first launch. This is because the 
Ambient Occlusion mask can be stuck on by default even when it is not 
available. To solve this, close Mari, delete the config file found in:

• Linux: ~/.config/TheFoundry/Mari.conf 

• Windows: C:/Users/<username>/.mari/TheFoundry/Mari.ini

and relaunch Mari.
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• On page 202 of the Mari User Guide, in the Settings column for the 
Normal shader module, there is a reference to a Normal Weight setting 
that is no longer available.

• BUG ID 10825 - The file browser doesn't always recall directories.

• BUG ID 10991 - The heads-up display (HUD) elements remain in UV View 
when switched off.

• BUG ID 11539 - Color Manager: Using Blur with other filters causes 
artifacts/corruption in the canvas. For this reason, we don't recommend 
using Blur together with other filters at this time.

• BUG ID 11874 - Mari doesn't recognize 3-digit padded OBJ sequences as 
animations.

• BUG ID 11902 - In the Projection palette, under Channel Mask > Mask 
Channel, there is currently no way to distinguish between the same 
channel in different objects.

• BUG ID 12023 - When changing the view, graphical glitches may appear 
in the canvas. To fix this, you can try increasing Gather Scale in the Mari 
preferences. This increases the buffer size Mari uses when gathering 
information on which image tiles are required for rendering the scene. A 
larger value may get rid of the glitches but also reduces painting and 
navigation speed.

• BUG ID 12102 - Current brush settings do not get saved as part of the 
project. Instead, Mari reverts to the default settings when you close and 
relaunch it.

• BUG ID 12244 - Selecting Channels > Import and Selected Only only 
works with sequences and not individually named files. 

• BUG ID 12480 - There are issues with some show/hide channel 
operations.

• BUG ID 12567 - Enabling Sync to VBlank in NVIDIA settings drastically 
hits Mari performance. If you experience very slow interaction, even with 
low-polygon models and one of the Recommended Graphics Cards, go to 
NVIDIA X Server Settings > X Screen 0 > OpenGL Settings and turn off 
Sync to VBlank. Then, restart Mari.

• BUG ID 13294 - In Windows 7, Mari sometimes exhausts its allowance 
of handles for Windows Manager objects, causing a crash. This can 
sometimes happen when switching back and forth between tools. If this 
happens, please contact The Foundry Support.

• BUG ID 13322 - Windows Only: Using a GeForce GTX graphics card in 
Deferred mode can cause Windows to crash. You can disable Deferred 
mode in Preferences to avoid this issue.

• BUG ID 13394 - Using the Select Items tool with the Facing set to Front 
to select and hide a portion of faces causes some of the faces within the 
selection to remain visible when zoomed in. 
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The workaround is to select Facing > Through instead of Front - this will 
catch all selected faces.

• BUG ID 13481 - Making a selection using the Marquee Select Tool with 
the selection mode set to Magic Wand sometimes ignores regions that 
are completely surrounded by other selected regions, despite differences 
in color.

• BUG ID 13571 - Launching a new version of Mari for the first time, when 
a config file exists from a previous version, will sometimes result in an 
object not appearing in the Ortho view.

To solve this, close Mari, delete the config file found in:

• Linux: ~/.config/TheFoundry/Mari.conf 

• Windows: C:/Users/<username>/.mari/TheFoundry/Mari.ini

and relaunch Mari.

• BUG ID 13640 - The Blur tool can be slow to use. Painting a stroke then 
waiting for Mari to process the blur can reduce slow down.

• BUG ID 13700 - Adjusting the Camera > Perspective settings for a 
Projector is not reflected on the canvas until the Projector is made 
Current.

• BUG ID 14128 - FBX IMPORT: CAMERAS from Nuke import the wrong 
field of vision (FoV) into Mari. There is a bug in Nuke where it always 
exports a half width anamorphic camera. The workaround is to take the 
camera into Maya (if possible), correct the squeeze value to 1.0, and re-
export the camera.

• BUG ID 14130 - FBX Camera Projection: Projections display incorrectly if 
the image being projected has been re-oriented.

• BUG ID 14201 - Linux Only: There is an issue where Mari becomes 
unresponsive after the system is woken from sleep.

• BUG ID 14210 - Windows Only: Using the Clone Stamp tool with a 
Wacom Pen Tablet can be slow.

• BUG ID 15712 - You cannot use the remove user attribute shortcut (-) in 
the Objects palette.
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1.1V2

Version 1.1v2

Release Date 11 November 2010

System 
Requirements

Recommended System Requirements

• Quad-core processor

• Windows 7 64-bit, or a Linux 64-bit operating system (Fedora 12 or Red 
Hat Enterprise Linux 5.4)

• 250GB disk space available for caching and temporary files (or a 
minimum of 50GB if you're working on a small project)

• At least 4GB RAM

• Display with 1680 x 1050 pixel resolution

• An NVIDIA graphics card with at least 1GB of RAM and OpenGL 3.0 
support (see Recommended Graphics Cards below).

Recommended Graphics Cards

• NVIDIA GeForce GTX 480

• NVIDIA Quadro FX 3800

• NVIDIA Quadro FX 3800M

• NVIDIA Quadro FX 4800

• NVIDIA Quadro FX 5800

• NVIDIA Quadro (Fermi Series) 600

• NVIDIA Quadro (Fermi Series) 5000

• NVIDIA Quadro (Fermi Series) 6000

Please download and install the latest graphics driver for your card from the 
NVIDIA website.
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New Features • Mari now displays a warning on launch if an unsupported graphics card 
configuration is detected. Depending on the configuration detected, you 
have the option to Quit, Ignore or Ignore Permanently. Note that if you 
ignore the warning and run Mari anyway, you may experience instability 
or performance issues. If a supported graphics card configuration is 
detected, Mari will run as normal.

Feature 
Enhancements

• BUG ID 12616 - The Projection icon on the status bar is now a button 
and can be toggled between Front and Through.

• BUG ID 13776 - The Channels > Export dialog box now indicates a list of 
supported export file formats.

Bug Fixes • BUG ID 12331 - The width of the Channels > Export > Small Textures 
dropdown menu has been adjusted to correctly display the menu’s label.

• BUG ID 12492 - The Channels > Import dialog box now remembers the 
window size if this was previously adjusted.

• BUG ID 12563 - Creating a new channel and closing a project with the 
Clone Stamp tool active, caused the Clone Stamp tool to paint garbage in 
a new project.

• BUG ID 12898 - Selecting Patches > Bleed Patch Edges on 32K patches 
caused Mari to crash.

• BUG ID 15090 - Pressing B to bake with the projects tab open caused 
Mari to crash.

• There was a rare issue where Mari crashed when trying to activate a 
license. This has now been fixed.

Known Issues and 
Workarounds

• Mari sometimes doesn't paint on first launch. This is because the 
Ambient Occlusion mask can be stuck on by default even when it is not 
available. To solve this, close Mari, delete the config file found in: 
~/.config/TheFoundry/Mari.conf, and relaunch Mari.

• BUG ID 10448 - If you open a saved project and create a new shader, 
you cannot save your changes until you make another change. This is 
because new shaders are not getting registered in the undo stack.

• BUG ID 10825 - The file browser doesn't always recall directories.

• BUG ID 10991 - The heads-up display (HUD) elements remain in UV View 
when switched off.
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• BUG ID 11539 - Color Manager: Using Blur with other filters causes 
artifacts/corruption in the canvas. For this reason, we don't recommend 
using Blur together with other filters at this time.

• BUG ID 11874 - Mari doesn't recognize 3-digit padded OBJ sequences as 
animation.

• BUG ID 11902 - In the Projection palette, under Channel Mask > Mask 
Channel, there is currently no way to distinguish between the same 
channel in different objects.

• BUG ID 12023 - When changing the view, graphical glitches may appear 
in the canvas. To fix this, you can try increasing Gather Scale in the Mari 
preferences. This increases the buffer size Mari uses when gathering 
information on which image tiles are required for rendering the scene. A 
larger value may get rid of the glitches but also reduces painting and 
navigation speed.

• BUG ID 12102 - Current brush settings do not get saved as part of the 
project. Instead, Mari reverts to the default settings when you close and 
relaunch it.

• BUG ID 12244 - Selecting Channels > Import and Selected Only only 
works with sequences and not individually named files. 

• BUG ID 12480 - There are issues with some show/hide channel 
operations.

• BUG ID 12567 - Enabling Sync to VBlank in NVIDIA settings drastically 
hits Mari performance. If you experience very slow interaction, even with 
low-polygon models and one of the Recommended Graphics Cards, go to 
NVIDIA X Server Settings > X Screen 0 > OpenGL Settings and turn off 
Sync to VBlank. Then, restart Mari.

• BUG ID 13322 - Windows Only: Using a GeForce GTX graphics card in 
Deferred mode can cause Windows to crash.

You can disable Deferred mode in Preferences to avoid this issue.

Alternatively, to be able to use the Deferred mode, you can install the 
Quadro drivers for your GeForce card (at your own risk, of course). Do 
the following:

1. Download the NVIDIA drivers for both the GeForce & Quadro range of 
cards for Windows.

2. Run the installers so they get unpacked, but don't install anything yet. 
This should create a directory under C:/NVIDIA/DisplayDriver/ with the 
two different versions.

3. Uninstall any driver you currently have installed for the GeForce and 
reboot.

4. Go back to C:/NVIDIA/DisplayDriver/ and copy NV_DISP.inf from the 
GeForce driver folder into the Quadro driver folder. Then, run the 
setup.exe file in the Quadro driver folder and install the drivers.
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5. After reboot, reboot once more.

Now when you come back you should have a GeForce card installed but 
with the newer Quadro drivers, and Mari will no longer cause Windows to 
crash.

• BUG ID 13394 - Using the Select Items tool with the Facing set to Front 
to select and hide a portion of faces causes some of the faces within the 
selection to remain visible when zoomed in. 

The workaround is to select Facing > Through instead of Front - this will 
catch all selected faces.

• BUG ID 13571 - Launching a new version of Mari for the first time, when 
a config file exists from a previous version, will sometimes result in an 
object not appearing in the Ortho view.

To solve this, close Mari, delete the config file found in:

• Linux: ~/.config/TheFoundry/Mari.conf 

• Windows: C:/Users/<login>/.mari/TheFoundry/Mari.ini

and relaunch Mari.

• BUG ID 13640 - The Blur tool can be slow to use. Painting a stroke then 
waiting for Mari to process the blur can reduce slow down.

• BUG ID 13700 - Adjusting the Camera > Perspective settings for a 
Projector is not reflected on the canvas until the Projector is made 
Current.

• BUG ID 13797 - There are a few performance issues with animated FBX 
camera imports including frame inconsistencies and geometry clipping.

• BUG ID 14128 - FBX IMPORT: CAMERAS from Nuke import the wrong 
field of vision (FoV) into Mari. There is a bug in Nuke where it always 
exports a half width anamorphic camera. The workaround is to take the 
camera into Maya (if possible), correct the squeeze value to 1.0, and re-
export the camera.

• BUG ID 14130 - FBX Camera Projection: Projections display incorrectly if 
the image being projected has been re-oriented.

• BUG ID 14201 - On Linux, there is an issue where Mari becomes 
unresponsive after the system is woken from sleep.
Mari 1.1v3The Foundry



1.1V1

Version 1.1v1

Release Date 2 November 2010

System 
Requirements

Recommended System Requirements

• Quad-core processor

• Windows 7 64-bit, or a Linux 64-bit operating system (Fedora 12 or Red 
Hat Enterprise Linux 5.4)

• 250GB disk space available for caching and temporary files (or a 
minimum of 50GB if you're working on a small project)

• At least 4GB RAM

• Display with 1680 x 1050 pixel resolution

• An NVIDIA graphics card with at least 1GB of RAM and OpenGL 3.0 
support (see Recommended Graphics Cards below).

Recommended Graphics Cards

• NVIDIA GeForce GTX 480

• NVIDIA Quadro FX 3800

• NVIDIA Quadro FX 3800M

• NVIDIA Quadro FX 4800

• NVIDIA Quadro FX 5800

• NVIDIA Quadro (Fermi Series) 5000

• NVIDIA Quadro (Fermi Series) 6000

Please download and install the latest graphics driver for your card from the 
NVIDIA website.

New Features • Mari now supports Windows 7 64-bit.

• The licensing system used by Mari has changed. Mari now uses RLM 
licensing instead of FLEXlm. For more information, see the Installation 
and Licensing chapter in the Mari Getting Started Guide.
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• On Linux, Mari is now distributed via self-extracting archives with a .run 
file extension (replacing the existing .tgz files). To install Mari you need 
to run the installer using a terminal command. Typically, this should be 
done with ’sudo’ for elevated permissions:

sudo ./Mari1.1v1-linux-x86-release-64.run

The installer prompts you to accept the End User Licensing Agreement 
(EULA) before continuing. If you would like to automate the installation 
and do not want to be prompted for the EULA, you can also pass in the 
option --accept-eula to automatically accept the EULA:

sudo ./Mari1.1v1-linux-x86-release-64.run --accept-eula

For more information on the Linux installer, see the Installation and 
Licensing chapter in the Mari Getting Started Guide.

• There is now a Deferred Shading Preference option, enabled by default, 
that should significantly increase Mari performance (you can disable this 
in the event that Mari is actually slower with it enabled).

• You can now load FBX cameras into Mari for use with projectors. To do 
this, open up the Projectors palette, right-click in empty space, and click 
Load Projector. Note that FBX support currently only loads cameras. 
Geometry should be loaded into Mari either at project creation or in the 
Objects palette using another supported format like an OBJ file.

• A Perspective camera view has been added. You can access this by 

clicking the Perspective button  on the canvas toolbar, or clicking on 

the Perspective tab.

In addition, the three existing camera views have changed:

• 3D View is now known as Ortho. You can access this by clicking the 

Ortho button  on the canvas toolbar, or clicking on the Ortho tab.

• UV View has been shortened to Uv. You can access this by clicking the 

Uv button  on the canvas toolbar, or clicking on the Uv tab.

• The Split View tab now displays the names of the camera views that 
are split across the canvas. By default, this is Ortho/Uv.

Shortcuts have been assigned to each of the new camera views:

• Switch to Ortho camera - F10

• Switch to Perspective camera - F11

• Switch to UV camera - F12.

• A new canvas toolbar has been added which lets you set the view options 
for the Uv and 3D views:
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•  Toggles whether to show the wireframes on the model. This 

option can also be set using the shortcut Shift+W.

•  Toggles between showing the patches in the Uv view as they 

appear as part of the model, and as they will appear when exported.

• Near - Sets the value for the near clipping plane in the Perspective 
view.

• Far - Sets the value for the far clipping plane in the Perspective view.

• FoV - Sets the value for the field of vision in the Perspective view.

• Mari now lets you import and export TGA files. Note that if you want to 
export to TGA, you need to type .tga in place of .tif in the Export Channel 
dialog.

• Four new shader modules have been added, these are:

• Ambient Occlusion: This takes a channel as an input mask to define the 
amount of ambient occlusion to add to the shaded surface. It can be 
used instead of Mari’s own Ambient Occlusion generator, if required.

• Masked Constant Color: This adds a constant color input to the shaded 
surface, using a channel as a mask.

• Masked Diffuse Blend: This blends the texture over the current diffuse 
color through a mask using the specified Blend Mode.

• Normal: This shows the input texture as a normal map. Mari assumes 
that the map is normalized around 0.5.

• The Specular Shader module has been split into 3 separate shaders:

• Gain

• Color

• Roughness

• A Smart Selection mode  has been added to the Select tool. This 

mode lets you create selections based on the surface of the model. Smart 
selections can be based on:

• Connectedness

• Edge Angles

• Orientation

• A Magic Wand Selection  mode has been added to the Marquee 

Select tool. This allows you to make selections based on color.
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• The Marquee Select tool’s Lasso , Rectangle  and Ellipse  

 modes now have buttons in the Tool Properties toolbar.

• A new function has been added that allows you to save the image of the 
outline of a UV mask to the Image Manager. This image can then be 
saved and used as a mask in another application. You can access this 
function by selecting Patches > UV Mask to Image Manager.

• A Lighting checkbox has been added to Camera > Quick Projection 
Settings. Check this to output the following two files when you 
unproject:

• The view with paint but no lighting.

• The view with the current lighting but no paint.

These two images could then be multiplied in another package to pro-
duce the model with paint and lighting.

• A new option has been added to Lights Palette > General called Fixed To. 
This sets what the light is fixed to:

• Scene (Default) - the light is fixed to the model, for example if a light is 
set at the model’s back, it will always point at the model’s back, no 
matter how you move the view.

• Camera - the light is fixed to a camera view, for example you can have 
a light always shining from above the camera, allowing you to move 
the model around and cast light on different areas.

• A function called Bleed Patch Edges has been added to the Patches 
menu. If you are experiencing seaming artefacts at the edges of your 
patches, this function performs a full bleed across affected patches.

Feature 
Enhancements

• Texture loading in saved projects should now be faster.

• BUG ID 11153 - The Max Memory cap was too restrictive and has been 
increased to 80% of the total machines memory (to the nearest half GB).

• BUG ID 13454 - There is a new option called Camera Mask Opacity in the 
Display Properties. This lets you set the opacity of the black bars that 
indicate the aspect ratio of the camera in the canvas.

By default, Camera Mask Opacity is set to 0.50. If you want to disable 
the aspect ratio bars, you can set the slider to 0. Note that Camera Mask 
Opacity only affects newly created (rather than existing) projects.

• BUG ID 13469 - Added projection mask properties to the Projectors 
palette. Note that if you adjust these properties, you need to click the 
Update Masks button to see the effect of your changes in the canvas. 
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When you do, the equivalent global properties in the Projection palette 
are also updated.

• BUG ID 13512 - The Invert Marquee Selection option is now clearly 
displayed in the Marquee Selection tool properties.

• BUG ID 13757 - Mari’s TIFF transparency handling has been modified to 
compensate for different 3rd party applications. Imported TIFFs are now 
interpreted and displayed based on the application that created them.

Bug Fixes • BUG ID 11500 - Some mask icons in the status bar were missing or 
broken. These are now displayed correctly when a mask is enabled.

• BUG ID 12591 - The current version of object geometry wasn’t getting 
saved in projects.

• BUG ID 12658 - Switching between painting modes took a long time.

• BUG ID 12704 - The lighting control sphere changed position when it 
shouldn't have, and didn’t reset when you clicked the Reset button.

• BUG ID 12764 - The Global Gamma setting has been removed from Edit 
> Preferences > Painting.

• BUG ID 12807 - Importing textures using the New Project dialog wasn’t 
working.

• BUG ID 12986 - Marquee selection of multiple patches was very slow.

• BUG ID 13005 - On Windows, the Windows shortcut key is reserved for 
Mari whenever Mari has focus. This allows you to use all of the Mari 
shortcuts but prevents you from pressing the Windows key to open the 
Windows Start menu. If you need to access the Start  menu, you can 
either click it manually or move focus to another application and then 
press the Windows key.

• BUG ID 13030 - When applying the Hue filter to Current Painting, 
adjusting the second curve editor had no effect in the preview.

• BUG ID 13081 - Navigating to New Project > Import Existing had no 
effect. 

• BUG ID 13133 - User interface tools were selectable when no project 
was open.

• BUG ID 13326 - Mari crashed when saving 32-bit painting.

• BUG ID 13335 - Renaming a project caused a crash.

• BUG ID 13409 - Mari crashed on close if you clicked  to see a 

progress box for a background job.

• BUG ID 13509 - Mari crashed when saving a project with invalid 
selection group data references.

• BUG ID 13627 - There were unexpected viewport jumps and lighting 
changes in a customer project.
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• BUG ID 13714 - Some palettes were not displayed in View > Palettes if 
Mari was launched with no CacheLocation set.

• BUG ID 14039 - Exporting an EXR file from Nuke and loading it into the 
Image Manager froze Mari.

• BUG ID 14069 - Per-face selection crashed Mari in the Through mode if 
heavy meshes were used.

• BUG ID 14101 - The Falloff/Value settings of the Towbrush tool reset 
every time a new Towbrush selection was made.

• BUG ID 14135 - Resetting curves in the Hue filter didn’t work properly.

• BUG ID 14146 - In Linux, Mari would not launch without write 
permissions. This was due to Mari’s log file being written to the launch 
folder. The file is now written to /var/tmp/mari by default.

• BUG ID 14382 - Mari sometimes crashed after bake when using the 
Paint Through tool.

• BUG ID 14384 - There were problems with opening archive files larger 
than 4GB.

Known Issues and 
Workarounds

• The Mari Getting Started Guide lists the NVIDIA Quadro FX 1800 in it’s 
list of Recommended graphics cards. This is incorrect as Mari no longer 
supports this card. Please refer to the System Requirements for an up to 
date list of supported cards.

• Mari sometimes doesn't paint on first launch. This is because the 
Ambient Occlusion mask can be stuck on by default even when it is not 
available. To solve this, close Mari, delete the config file found in: 
~/.config/TheFoundry/Mari.conf, and relaunch Mari.

• BUG ID 10448 - If you open a saved project and create a new shader, 
you cannot save your changes until you make another change. This is 
because new shaders are not getting registered in the undo stack.

• BUG ID 10825 - The file browser doesn't always recall directories.

• BUG ID 10991 - The heads-up display (HUD) elements remain in UV View 
when switched off.

• BUG ID 11539 - Color Manager: Using Blur with other filters causes 
artifacts/corruption in the canvas. For this reason, we don't recommend 
using Blur together with other filters at this time.

• BUG ID 11874 - Mari doesn't recognize 3-digit padded OBJ sequences as 
animation.

• BUG ID 11902 - In the Projection palette, under Channel Mask > Mask 
Channel, there is currently no way to distinguish between the same 
channel in different objects.
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• BUG ID 12023 - When changing the view, graphical glitches may appear 
in the canvas. To fix this, you can try increasing Gather Scale in the Mari 
preferences. This increases the buffer size Mari uses when gathering 
information on which image tiles are required for rendering the scene. A 
larger value may get rid of the glitches but also reduces painting and 
navigation speed.

• BUG ID 12102 - Current brush settings do not get saved as part of the 
project. Instead, Mari reverts to the default settings when you close and 
relaunch it.

• BUG ID 12244 - Selecting Channels > Import and Selected Only only 
works with sequences and not individual named files. 

• BUG ID 12480 - There are issues with some show/hide channel 
operations.

• BUG ID 12563 - If you create a new channel, select the Clone Stamp 
tool, close the project, and create a new project, the Clone Stamp tool 
paints garbage.

• BUG ID 12567 - Enabling Sync to VBlank in NVIDIA settings drastically 
hits Mari performance. If you experience very slow interaction, even with 
low-polygon models and one of the Recommended Graphics Cards, go to 
NVIDIA X Server Settings > X Screen 0 > OpenGL Settings and turn off 
Sync to VBlank. Then, restart Mari.

• BUG ID 13322 - Windows Only: Using a GeForce GTX graphics card in 
Deferred mode can cause Windows to crash.

You can disable Deferred mode in Preferences to avoid this issue.

Alternatively, to be able to use the Deferred mode, you can install the 
Quadro drivers for your GeForce card (at your own risk, of course). Do 
the following:

1. Download the NVIDIA drivers for both the GeForce & Quadro range of 
cards for Windows.

2. Run the installers so they get unpacked, but don't install anything yet. 
This should create a directory under C:/NVIDIA/DisplayDriver/ with the 
two different versions.

3. Uninstall any driver you currently have installed for the GeForce and 
reboot.

4. Go back to C:/NVIDIA/DisplayDriver/ and copy NV_DISP.inf from the 
GeForce driver folder into the Quadro driver folder. Then, run the 
setup.exe file in the Quadro driver folder and install the drivers.

5. After reboot, reboot once more.

Now when you come back you should have a GeForce card installed but 
with the newer Quadro drivers, and Mari will no longer cause Windows to 
crash.
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• BUG ID 13394 - Using the Select Items tool with the Facing set to Front 
to select and hide a portion of faces causes some of the faces within the 
selection to remain visible when zoomed in. 

The workaround is to select Facing > Through instead of Front - this will 
catch all selected faces.

• BUG ID 13571 - Launching a new version of Mari for the first time, when 
a config file exists from a previous version, will sometimes result in an 
object not appearing in the Ortho view.

To solve this, close Mari, delete the config file found in:

• Linux: ~/.config/TheFoundry/Mari.conf 

• Windows: C:/Users/<login>/.mari/TheFoundry/Mari.ini

and relaunch Mari.

• BUG ID 13640 - Windows only: The Blur tool is slow to use. Painting a 
stroke then waiting for Mari to process the blur can reduce slow down.

• BUG ID 13700 - Adjusting the Camera > Perspective settings for a 
Projector is not reflected on the canvas until the Projector is made 
Current.

• BUG ID 13797 - There are a few performance issues with animated FBX 
camera imports including frame inconsistencies and geometry clipping.

• BUG ID 14128 - FBX Import: cameras from Nuke import the wrong field 
of vision (FoV) into Mari. There is a bug in Nuke where it always exports 
a half width anamorphic camera. The workaround is to take the camera 
into Maya (if possible), correct the squeeze value to 1.0, and re-export 
the camera.

• BUG ID 14130 - FBX Camera Projection: Projections display incorrectly if 
the image being projected has been re-oriented.
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