Katana 3.1v1 Release Notes

Release Date

20 November 2018

Previous Releases

System Requirements

Officially Supported Operating Systems

Hardware Requirements

Minimum Recommended
CPUDual-core processor
Storage1+ GB available for installation
System RAM1+ GB available
Graphics RAM1+ GB available2+ GB available
Display800 x 6001920 x 1080
OpenGLOpenGL 4.3+

'Recommended' does not guarantee that it meets your particular needs

Tested Workstation Hardware

The configurations listed below are those that Foundry have tested with Katana. Due to the constantly changing nature and wide variety of computer hardware available in the market, Foundry is unable to officially certify hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular needs.

Please download and install the latest graphics driver from the NVIDIA website.

If you encounter any issues, please contact Customer Support directly through the Support Portal at the following address: https://support.foundry.com.

What's New in Katana 3.1

These release notes describe changes from Katana 3.0v6 to 3.1v1.

For a high-level overview of all changes in the Katana 3.1 line, please see the accompanying What's New in Katana 3.1 document.

Table of Contents

Feature Enhancements

Qt

As part of Katana 3.1, we have updated the version of Qt used by Katana from 4.8.5 to 5.6.1, as specified in the VFX Reference Platform CY2017. This means that any UI plugins that utilize Qt should be updated. These changes are detailed below:

Performance

Hydra Viewer

Other Feature Enhancements

Bug Fixes

Hydra Viewer

UI

Performance

Multisampled Parameters

Other Bug Fixes

3Delight

3Delight has been upgraded to version 1.1.16. For more information, refer to the 3Delight Cloud Changelog.

Documentation

Example Projects

Third-Party Libraries

The table below summarizes changes to shipped versions of third-party software. Katana 3.1v1 aims for compatibility with VFX Reference Platform CY2017.

Katana 3.1 Katana 3.0
Qt 5.6.1 4.8.5
PyQt 5.6 4.11.4
SIP 4.18.1 4.17
OpenSubdiv 3.1.1 3.0.5
Ptex 2.1.28 2.1.10
fmt 4.1.0 Not shipped
Fontconfig Not shipped 2.8.0 (Linux only)

Known Issues

Live Groups

Materials

Parameter Expressions

Qt 5

Rendering

Widgets

Miscellaneous