
RELEASE NOTES FOR KATANA 1.6V2

Release Date 11 July 2014

System 
Requirements

• Katana 1.6v2 is tested and qualified on Linux 64-bit CentOS/RHEL 5.4

• A graphics card which supports OpenGL shader model 4.0

• A supported renderer (see below)

Supported 
Renderers

Katana 1.6v2 supports PRMan 17.0, Arnold 4.1.3.3 and 4.0.11.0. The 
supplied renderer plug-ins are compiled and tested against these versions, 
using GCC 4.1.2. Minor version increments of PRMan and Arnold may work, 
as long as they are API compliant with the supported versions.

Support for PRMan 18.0 and above are provided directly by Pixar using 
their RenderMan Studio for Katana plug-in. To get access to RenderMan 
Studio for Katana please contact Pixar directly. 

To use a version of PRMan or Arnold other than those listed above, you may 
need to recompile the renderer plug-in.

To expose new features and portions, you may need to modify the renderer 
plug-in.

Using a version of PRMan or Arnold other than those listed above may 
produce unexpected behavior. Using a compiler other than GCC 4.1.2 may 
produce unexpected behavior. Please note that we can only guarantee to 
respond to Katana bug reports when they are reproducible with the 
supplied versions of the renderer plug-in, compiled with the supported 
version of GCC.

Third Party 
Dependencies

Katana 1.6v2 has dependencies on the following third party libraries:

• OpenEXR 2.0.1

• OpenSSL 1.0.0.a
These libraries are provided in the Katana distribution, in separate
directories under ${KATANA_HOME}/bin
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Feature Enhancements and Important Changes for 1.6v2

An ABI-compatible copy of these libraries needs to reside on your 
LD_LIBRARY_PATH in order for many of Katana's plug-ins to run. The Katana 
application itself uses RPATHs to locate the required libraries.

Feature 
Enhancements 
and Important 
Changes for 
1.6v2

• Katana now ships with the Arnold 4.1 plug-in, which supports the Arnold 
4.1.3.3 renderer version.

• As part of the technical collaboration between The Foundry and Pixar’s 
RenderMan, in addition to the standard Katana render licenses (katana_r) 
there are also separate RenderMan for Katana (katana_rfk_r) render 
licenses designed for only rendering with RenderMan.  These can only be 
used with Katana 1.6v2 onwards. An environment variable, 
KATANA_WITH_RFK, must be set to 1 in order to use the RenderMan for 
Katana render licenses. This will use katana_rfk_r licenses when running a 
batch/script process, if one is available. If no katana_rfk_r licenses are 
available, a standard Katana render license (katana_r) will be used 
instead. Please note that rendering using renderers other than 
RenderMan while the KATANA_WITH_RFK environment variable is set, 
may consume both a RenderMan for Katana render license and a 
standard Katana render license. Please unset the environment variable if 
you are not using RenderMan as the renderer.

• BUG ID 40448 - The NetworkMaterialSplice node was reporting a 
misleading error message due to incorrect connection type checking.

• BUG ID 40538 - When scene graph locations are constrained to other 
scene graph locations, geometry drawn for them by Viewer Modifier Plug-
ins (VMPs), for example bounding boxes or guide geometry for lights, was 
incorrectly shown in the Viewer tab even when the locations were not 
expanded in the Scene Graph tab.

• BUG ID 40946 - When loading an autosave project after a crash, the 
LiveGroup nodes were made non-editable again, and their parameters and 
contents were reloaded from their respective sources. This meant that 
any changes that were not previously published to LiveGroup sources 
were lost. Now all LiveGroup nodes in an autosave project are loaded in 

NOTE: Katana's wrapper script ${KATANA_HOME}/katana appends 
${LD_LIBRARY_PATH} to ensure these libraries are visible to Katana plug-
ins.

If you manage your own LD_LIBRARY_PATH or wish to expose these 
libraries to plug-ins by some other means, you can call the Katana binary 
directly using:

${KATANA_ROOT}/bin/katanaBin
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Bug Fixes

editable mode, which means that the user can either reload or publish 
potential changes on them.

• BUG ID 41784 - The AttributeFile_In node (and the example AttributeFile 
AMP) now correctly respond to the Flush Caches button.

• BUG ID 42653 - There was no C++ access to flush plug-in caches. 
RenderOutputUtils::flushProceduralDsoCaches() now also flushes plug-in 
caches.

• BUG ID 43147 - Execution of a disk render or render debug output 
caused geometry producers to be leaked (never cleaned up, even via the 
Flush Caches mechanism). In order for this fix to be applied, custom 
Render plug-ins must be recompiled.

Bug Fixes • BUG ID 27742 - The hide state for locations in the Viewer was leaking 
into other locations, causing more locations to be hidden than expected.

• BUG ID 40462 - Flushing the caches or the Util > Reload shaders and 
args file erased all new shader array parameters added on Shading 
Nodes.

• BUG ID 40544 - A constraint resolve error was being issued when 
resolving a constraint with no target. Now a constraint is not added to 
the global constraints list if it has no target.

• BUG ID 40658 - Collapsing and re-expanding locations whose children 
had viewer surface shaders assigned could cause the shader assignments 
to be lost.

• BUG ID 40774 - When reloading a LiveGroup node's parameter interface 
and contents from its source, the viewed, edited, and selected states of 
nodes within the LiveGroup node were reset. This caused the parameters 
of edited child nodes to disappear from the Parameters tab.

• BUG ID 40833 - When choosing the Edit > Explode Selected Groups 
command or pressing the U key in the Node Graph tab while LiveGroup 
nodes were selected, an exception was raised.

• BUG ID 40924 - Scene edits could trigger excessive computation and UI 
lag for scenes with large LiveGroup nodes that were in an editable state.

• BUG ID 41046 - Custom LookFile name spaces only worked with one 
override when multiple LookfileOverrideEnable nodes were applied.

• BUG ID 41076 - In ViewerModifier plug-ins the 
getLocalSpaceBoundingBox() method wasn't called when attributes on 
matching locations changed.

• BUG ID 41285 - Changing the viewed node could cause locations with 
assigned Viewer shaders to lose their assignments.
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Known Issues

• BUG ID 41475, 41477 - When switching display transforms in the 
Monitor, a Python stack trace appeared in the console and the change 
wasn't applied.

• BUG ID 41796 - ProducerObservers performed work on 
nodegraph_changed events, even when scenegraph updates had been 
disabled.

• BUG ID 41798 - Performance improvements have been made for changing 
render settings in a scene with lots of render outputs defined. 

• BUG ID 42723 - Reverting an editable LiveGroup with the source 
parameter set to an invalid source file resulted in an error, making it 
impossible to exit the editable state.

• BUG ID 42963 - When rendering in batch mode, an initial cook of /root 
was taking place at frame 0, rather than at the frame at which the Katana 
file had been saved.

• BUG ID 43341 - The RenderNodeInfo cache was not flushed when the 
Flush Caches button was pressed.

• BUG ID 43439 - Updates to Arnold light filters that were applied with a 
ShadingNodeArrayConnector did not work correctly while live rendering.

• BUG ID 43455 - Katana would occasionally crash during Preview Renders 
for node graphs containing 2D Nodes due to unreliable socket 
connections. Stability and error reporting for this issue has been 
improved.

Known Issues • BUG ID 41152 - When editing parameters of a node that is part of a 
LiveGroup node and reloading the parent LiveGroup node, the UI state of 
the Parameters tab is reset. This includes scroll bar positions, selections 
of items, and selections of nested tabs (for example Object, Material and 
Linking tabs for a Gaffer node).

• BUG ID 41092 - When reloading a LiveGroup node's parameter interface 
and contents from its source, parameters of child nodes that are edited in 
floating panes disappear from those panes.

• BUG ID 40709 - The Alembic library does not support multiple process or 
thread access to an Alembic file. This means that a crash occurs when 
modifying an Alembic file outside Katana, while it's loaded in an open 
Katana scene. To avoid this, you must Flush Caches before attempting to 
update any modified Alembic files.

• BUG ID 40600 - Undoing a revert of an unpublished LiveGroup does not 
restore the LiveGroup's editable and modified state.

• BUG ID 40599 - User parameters of non-editable LiveGroup nodes can 
incorrectly be edited.
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Known Issues

• BUG ID 40598 - Reverting a LiveGroup node does not revert its user 
parameters.

• BUG ID 40237 - Nodes can be dragged into the Group bubble of a non-
editable LiveGroup node. 

• BUG ID 39261 - Operations that lock and unlock nodes do not currently 
create entries in the Undo History, which can lead to an incorrect node 
graph state when undoing and redoing operations.

• BUG ID 37477 - Adding an invalid path to the ImageRead node causes 
Katana to crash.

• BUG ID 37256 - When using the RGBA widget type, RGB values in the 
color picker are reset to 0 when the alpha is 0, which is the alpha’s 
default value.

• BUG ID 36926 - The rendererSettings > displayOptions parameter of a 
RenderOutputDefine node for the PRMan renderer, shown when its type 
parameter is set to raw, cannot be set using the Parameters tab.

For a workaround, 

1.Make sure that the PRMan 17.0 plug-in is loaded. See the Installation 
and Licensing chapter in the User Guide for more on this.

2.Click on the Shelf Actions button.

3.Select the shelf named (other) PRMan17.

4.Click on CreateUpdateDisplayOptionsNode.

5.Place the newly created node after the RenderOutputDefine node defin-
ing the display options.

• BUG ID 36691 - State badges are currently shown for attribute values of 
dynamic array child parameters, even though only their parent array 
parameter should appear with a state badge.

• BUG ID 36663 - It is not currently possible to sort notifications in the 
Notifications popup window.

• BUG ID 36225 - The UpdatePrmanSettingsNode shelf script does not 
currently deal with expression parameters. Locally set Parameter 
Expressions on PRMan nodes will need re-adjusting after running the 
shelf script.

• BUG ID 36176 - The 2D node Disk Render Upstream Render Outputs 
option does not use the batch render method, batchRender, for upstream 
render nodes, instead it is using diskRender.

• BUG ID 36170 - Control keys (notably arrow keys) do not function as 
expected in shell mode.

• BUG ID 34870 - Katana doesn't support render output directory creation 
for shadow, merge and script output types.

• BUG ID 34274 - When using Reyes mode in PRMan Live Rendering, lights 
are duplicated when sending live render updates. 
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• BUG ID 34256 - Preview Rendering 2D nodes fails when Disk Render 
Upstream Render Outputs is set to Unless Already Cached. In addition, a 
crash sometimes occurs when attempting to repeat the Preview Render.
You can work around this issue by setting the right-click context menu 
option on a 2D node to Always instead of Disk Render Upstream Render 
Outputs will work around this problem, however, this will mean that each 
time a change is done in the 2D node and Preview Render started, a Disk 
Render will be triggered for the image dependency upstream, even if this 
had no changes.Alternatively another workaround  for the 2D nodes 
Preview Render work flow is using an ImageRead node that is expression 
linked to your RenderOutputDefine node render location parameter. You 
will need to disk render beforehand to have your image output available 
as 2D nodes input, and set the Monitor's 2D Render Mode to Pen-Up 
instead of Continuous to preview the changes as expected.

• BUG ID 33242 - Live Rendering is not designed to work with rapid 
updates to region of interest (ROI), and may cause unexpected behavior.

• BUG ID 32125 - Live Rendering complex scenes using anything other 
than Selected Scenegraph Locations can result in Katana crashing.

• BUG ID 31790 - In the Parameters tab, setting an expression for an array 
or a group parameter currently breaks the parameter's UI.

• BUG ID 31257 - The keyboard shortcut for Edit > Toggle Ignore State of 
Selected Nodes command in the Node Graph tab is Alt+D, not D. This 
overrides the Alt+D keyboard shortcut of the Unconnected to Viewed 
Node menu item. The D key toggles the ignore state of a single node 
under the mouse pointer.

• BUG ID 30170 - The --crop-rect and setDisplayWindowToCropRect 
command-line options do not currently work, so nothing is cropped. You 
can work around this issue by adding a RenderSettings node to your 
Katana scene with the cropWindow parameter set. This allows you to 
render using a cropped display window in batch mode.

• BUG ID 28549 - Main menu commands that create nodes, notably 

File > Import..., File > Import LiveGroup..., and Help > I want a pony, do 
not create the nodes in a Group or LiveGroup node that has been entered 
in a Node Graph tab. Instead they create the nodes in the root level of the 
node graph document.

• BUG ID 27147 - Due to an internal bug in Qt 4.7.2 an error message 
similar to the following may occasionally be displayed in the console: 
"Application asked to unregister timer 0x13000076 which is not 
registered in this thread. Fix application." (https://bugreports.qt-
project.org/browse/QTBUG-16175.)

• BUG ID 22296 - Due to a known issue with PRMan, Katana does not 
currently support PRMan Live Rendering with AOVs. 
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For a workaround, to allow Live Rendering, disable AOVs in interactive 
renders by applying an interactive render filter, using a RenderSettings 
node with the interactiveOutputs parameter set to just primary.


