
USER GUIDE
VERSION 1.9v1



Hiero™ and HieroPlayer™ User Guide. Copyright © 2014 The Foundry Visionmongers Ltd. All Rights Reserved. Use of this User Guide and
the Hiero software is subject to an End User Licensing Agreement (the “EULA”), the terms of which are incorporated herein by reference.
This User Guide and the Hiero software may be used or copied only in accordance with the terms of the EULA. This User Guide, the Hiero
software and all intellectual property rights relating thereto are and shall remain the sole property of The Foundry Visionmongers Ltd.
(“The Foundry”) and/or The Foundry's licencors. The EULA is available in the appendices.

The Foundry assumes no responsibility or liability for any errors or inaccuracies that may appear in this User Guide and this User Guide
is subject to change without notice. The content of this User Guide is furnished for informational use only.

Except as permitted by the EULA, no part of this User Guide may be reproduced, stored in a retrieval system or transmitted, in any form
or by any means, electronic, mechanical, recording or otherwise, without the prior written permission of The Foundry. To the extent that
the EULA authorizes the making of copies of this User Guide, such copies shall be reproduced with all copyright, trademark and other
proprietary rights notices included herein. The EULA expressly prohibits any action that could adversely affect the property rights of The
Foundry and/or The Foundry's licencors, including, but not limited to, the removal of the following (or any other copyright, trademark or
other proprietary rights notice included herein):

Hiero™ and HieroPlayer™ shot management and conform software © 2014 The Foundry Visionmongers Ltd. All Rights Reserved.

Hiero™ and HieroPlayer™ are trademarks of The Foundry Visionmongers Ltd.

Mac, Mac OS, Final Cut Pro and QuickTime are trademarks of Apple, Inc., registered in the U.S. and other countries.

Linux ® is a registered trademark of Linus Torvalds.

Windows ® is the registered trademark of Microsoft Corporation.

RED, RED-ONE, R3D, EPIC, HDRx, and RMD are trademarks of Red.com, Inc.

Adobe ® and After Effects ® are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or
other countries.

Avid ®, Avid DNxHD ®, and Media Composer™ are either registered trademarks or trademarks of Avid Technology, Inc. or its subsidiaries
in the United States and/or other countries.

In addition to those names set forth on this page, the names of other actual companies and products mentioned in this User Guide
(including, but not limited to, those set forth below) may be the trademarks or service marks, or registered trademarks or service marks,
of their respective owners in the United States and/or other countries. No association with any company or product is intended or
inferred by the mention of its name in this User Guide.

Software design and engineering: Matt Brealey, Jack Binks, Adam Cherbetji, Rick Coles, Jon Creighton, Vincent Delannoy, Paul Dunnill,
Martiño Figueroa, Michael Hughes, Jerry Huxtable, David Jennings, Michael Jones, Juan Leni, Zulfiqar Malik, Matthew Mauger, Dan
Milburn, John Mercer, Antón Morant Fernández, Ant Nascè, Bruno Nicoletti, Matt Plec, Przemek Stys, and Dylan Yudaken.

Product testing: Dan Allum, Nikolas Almpanis, Konrad Korzel, Natasha Sandars, Andrea Smith, and Zachary Quinn Scheuren.

Writing and proofreading: Joel Byrne, Eija Närvänen, Jack Binks, and Tim Baier.

Layout design: Annabel Landau and Ash Joseph.

The Foundry
5 Golden Square
London
W1F 9HT
UK

Rev: 30 September 2014



Contents
1 Preface
Key Features 9

About this Guide 9

Getting Help 9
Customer Support 10
Online Help 10

2 Installation and Licensing
System Requirements 11

Operating System 11
Hardware 11

Installing Hiero or HieroPlayer 12

Launching Hiero or HieroPlayer 13
Startup Options 14

Licensing Hiero and HieroPlayer 16
Obtaining Licenses 16
Installing Licenses 17

3 Hiero Workflow Case Studies
Hiero 20

HieroPlayer 20

Feature Comparison 20

Collaborative Project Case Study 22
Preparing a Project in Hiero 23
Loading a Hiero Project in HieroPlayer 23

Hero Seat Case Study 26

Element Library Case Study 26

4 Customizing Your Workspace
Workspace Overview 28

Menu Bar Components 30

Creating Your Own Workspace 30
Saving Workspaces 34



Loading Workspaces 34
Deleting Workspaces 35

Workspace Preferences 35
General Preferences 36
Viewer Preferences 38
Audio Preferences 40
Timecode Preferences 40
Scopes Preferences 41
RED Rocket Preferences 42
Sequence Preferences 42
Color Management Preferences 43
Nuke/Export Preferences 43
Performance Preferences 45
Script Editor Preferences 47

Optimizing Read and Decode Performance 48
Using Helper Threads 49
Using Pixel Buffer Objects 49
Using Downsize Sampling 50

5 Ingesting Media
About Clips 51

Ingesting Media 53
Using Drag-and-Drop 55
Using the File Browser 55
Reconnecting and Refreshing Clips 56

Caching Media Locally 57

6 Using the Viewer
Introduction 60

Viewer Tools 62

Playback Tools 65
Caching Frames in the Playback Cache 68
Using In and Out Markers 69
Using the Media Tab 70

Working with Colorspaces 72

Previewing on a Broadcast Monitor 73

Using Scopes 75
Histogram 75
Waveform 76
Vectorscopes 77



About Anamorphic Media 77

About QuickTimeMedia 78

About REDMedia 79
Using RMD Look Files 80

Synching to VBlank on Linux 81

7 Using Tags
Introduction 82

Using Quick Tags 82

Tagging Using the Viewer 83

Tagging Track Items 84
Adding Notes to Tags 85

Filtering and Flagging Media Using Tags 86
Creating Custom Tags 87
Removing Tags 87

8 Viewing Metadata
Clip and Track ItemMetadata 89

Filtering and Flagging Media Using Metadata 90

9 Conforming Using Hiero
Introduction 91

Project Settings 91

Importing Sequences 92

Conforming Sequences 95
Conforming Using a Browser 95
Conforming with Pre-ingested Media 98
About the Media Spreadsheet 99
Adjusting Timecodes 101

Renaming Shots on the Timeline 102

Saving and Loading Projects 104
Autosaved Projects 105

10 Managing Timelines
Introduction 107



Adding Tracks to the Timeline 108

Adding Clips to the Timeline 110

Audio and the Timeline 112
WAV Track Items 114
Synchronizing Audio and Video 114

Using ReferenceMedia 115
Comparing Media 116

Viewing Multi-Format Timelines 118

Refreshing and Replacing Track Items 119
Setting Soft Trims 120
Enabling and Disabling Track Items 121

Adding Transitions 121
Invalid Transitions 122

Retiming Clips 123
Using Freeze Frames 127

11 Timeline Editing Tools
Introduction 128

Using theMulti Tool 130

Using theMove/Trim Tool 131
Moving Track Items 131
Trimming Track Items 133

Using the Selection Tools 136

Using the Slip Clip Tool 137
Slipping Using the Spreadsheet View 139

Using the Slide Clip Tool 140

Using the Roll Edit Tool 141

Using the Retime Clip Tool 143

Using the Razor and Join Tools 144
Copying Cuts Between Tracks 144

Insert, Overwrite, and 3-Point Editing 145
Inserting Clips 145
Overwrite Edits 147
3-Point Editing 148



12 Versions and Snapshots
Introduction 151

Using Versions 151
Versions in Bins 153
Versions in Sequences 154

Using Snapshots 155
Creating Snapshots 155
Restoring Snapshots 156

13 Export Management
Introduction 158

Round-Tripping Using the Export Dialog 158
Introduction to the Export Dialog 159
Using the Shot Template 160
Adding Burn-in Text to Exports 165
Adding Additional Nuke Nodes During Export 166
Exporting to Nuke 168
Building VFX Tracks 172

Round-Tripping Using Hiero<>Nuke 176
Connecting Hiero<>Nuke 176
Using Hiero<>Nuke in HieroPlayer 179

Advanced Send to Nuke 181
About 3:2 Pulldown 182

Transcoding 183
Transcoding a Sequence or Shots 183
Transcoding from the Bin View 186
Transcoding Timeline Selections 187

Ad Hoc Exports 187
Exporting EDLs and XMLs 187
Using the Copy Exporter 189

14 Customizing Hiero
Environment Variables 191

Setting Environment Variables 191

Sharing Presets 194

Startup Projects 194

Using the Python API 195
Running Python During Startup 195



Using the Script Editor 196

Appendix A
Hiero and HieroPlayer Hotkeys 199

Appendix B
Supported Image Formats 211

Optimized Formats and Limitations 212
Reader Fallback Paths 213

Supported Audio Formats 214

Appendix C
Third-Party Library Versions 215

Third-Party Library Licenses 216

Appendix D
End User License Agreement (EULA) 246



1 Preface
Hiero, in conjunction with HieroPlayer, is designed to provide shot management, conform, and
playback capabilities for people creating visual effects, especially those using The Foundry’s Nuke
Compositor. Hiero combines well with Nuke to deliver visual effects sequences without resorting to
other third party applications.

Key Features
The following are key features supported by Hiero and HieroPlayer:

• Conform multi-track timelines from CMX 3600 Edit Decision Lists (EDLs) and Final Cut Pro XML, including cuts,
transitions and retimes.

• Soft import any image sequence type supported by Nuke, meaning the media is not copied multiple times saving
disk space. In addition, Hiero and HieroPlayer can also ingest audio and multi-channel images.

• Playback clips and sequences in realtime (dependent on hardware) on 2-up source/record Viewers.

• Version and snapshot clips and sequences to record progress and manage your creative options.

• Round-trip through Nuke or export general purpose shots using soft exports in most cases - no bakes are required.

• Use Hiero<>Nuke to set up a connection between the two applications, updating clips on-the-fly.

• Accomplish most tasks through Python scripting that you can with the Hiero and HieroPlayer user interfaces.

About this Guide
Throughout this User Guide, we assume you have a basic knowledge of video and audio theory, as well as proficiency
with the operating system on which Hiero is installed.

For the most up-to-date information, please see the Hiero product page and the latest User Guide on our web site at
www.thefoundry.co.uk.

Getting Help
If you can’t find what you need in this document, there are other sources of help available to you for all aspects of
Hiero and its operation.

http://www.thefoundry.co.uk/
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Customer Support

Should questions arise that this manual or the online help system fails to address, you can contact Customer
Support directly by email at support@thefoundry.co.uk or telephone to our London office on +44 (0)20 7479 4350
or to our Los Angeles office on (310) 399 4555 during office hours.

Online Help

Most controls offer concise instructions in the form of tooltips. To display the tooltips, hover your mouse pointer
over an interface control or parameter.

Hiero’s Help menu includes links to the latest Release Notes and www.nukepedia.com, the online knowledge base
maintained by experienced Nuke users, containing downloads, tutorials, interviews and more.

There is also a Hiero user forum at forums.thefoundry.co.uk, set up as a hub for users to ask questions and share
information about Hiero.

1 PREFACE |
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2 Installation and Licensing
Installing and licensing new applications can be a boring task that you just want to be done with as
soon as possible. To help you with that, this chapter guides you to the point where you have a default
workspace in front of you and are ready to start viewing and editing your media with the minimum of
effort.

System Requirements
Before you do anything else, ensure that whichever platform you intend to run Hiero or HieroPlayer on meets the
following minimum requirements.

Operating System

The following operating systems are supported:

Mac OS X
• Mac OS X Snow Leopard 10.6.8, or above

Linux
• Linux RHEL 5.4 64-bit, or above

Windows
• Windows 7 64-bit, or above, with the latest version of QuickTime installed

Hardware

The following hardware is recommended:

• 4 GB of disk space available for caching and temporary files

• 8 GB of RAM (minimum requirement)

• Intel i3 CPU (or equivalent)

• Workstation-class graphics card with OpenGL 2.1 driver support, such as NVIDIA Quadro series or ATI FireGL series
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NOTE: Hiero and HieroPlayer do not support the NVIDIA Quadro 4500 FX and GeForce 7300 GT graphics
cards.

• RED Rocket cards with at least Rocket Driver 1.4.19.0 and Firmware 1.1.16.5 or later

NOTE: RED Rocket cards may not work as expected without the latest drivers and firmware.

• Our monitor out architecture interfaces directly with the AJA and BlackMagic device drivers, which are unified across
their respective hardware lines, meaning all current supported cards for the following versions should work:

• BlackMagic: 9.1

• AJA: 3.2 on Mac OS X, 10.5.1 on Windows

• We test using a selection of the following hardware :

• BlackMagic: Current BlackMagic Decklink PCI hardware, including Decklink SDK, DeckLink 4K Extreme, and
Ultrastudio SDI Thunderbolt devices (Mac only).

• AJA: Current AJA Kona PCI Family, including Kona 3G, LHi, LHe Plus, and ioXT Thunderbolt device (Mac only).

NOTE: AJA monitor out cards are not currently supported on Linux.

NOTE: On Mac, the AJA Kona 3G is only supported on OS X 10.7 (Lion).

NOTE: Monitor out on Windows machines with AMD graphics cards is not currently supported.

Installing Hiero or HieroPlayer
Download the required application from www.thefoundry.co.uk/products/ by choosing the required platform from
the list. For example, if you intend to install Hiero on Mac OS X, download the Hiero .dmg file.

Follow the on-screen instructions to download the correct installer.

Mac OS X
1. Double-click on the .dmg archive to extract the installation package.

2. Double-click on the .pkg file.

3. Follow the on-screen instructions to install the application. By default, Hiero is installed to
/Applications/Hiero1.9v1 and HieroPlayer to
/Applications/HieroPlayer1.9v1

2 INSTALLATION AND LICENSING | INSTALLING HIERO OR HIEROPLAYER
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Linux
1. Extract the application from the .run archive with the following terminal command:

sudo ./Hiero1.9v1-linux-x86-release-64.run

OR
sudo ./HieroPlayer1.9v1-linux-x86-release-64.run

The installer displays the End User Licensing Agreement (EULA) and prompts you to accept it.

2. If you agree with the EULA, enter y and press Enter to accept the EULA. (If you don’t agree with the EULA and
press n instead, the installation is cancelled.)

The selected application is installed in an appropriately named folder in the current working directory.

If you leave out sudo from the terminal command, you need to ensure that you have sufficient permissions to
install the application under your current working directory.

NOTE: After the application files have been installed, the installer also runs a post-installation script that
creates the following directory:
/usr/local/foundry/RLM

If you don’t have sufficient permissions on the /usr/local folder for this directory to be created, the post-
installation script prompts you for your sudo password as necessary.

Windows

WARNING: Ensure that the latest version of QuickTime is installed before installing the application.
See http://www.apple.com/quicktime/download/ for more information.

1. Double-click on the Hiero .exe file.

2. Follow the on-screen instructions to install the required application. By default, Hiero is installed to <drive
letter>:/Program Files/Hiero1.9v1 and HieroPlayer to <drive letter>:/Program Files/HieroPlayer1.9v1

Launching Hiero or HieroPlayer
Launch Hiero using one of the following methods, depending on which platform you’re using.

NOTE: If you intend to use an external Nuke application, Hiero<>Nuke requires Nuke 6.3v5 or later to run
correctly.

2 INSTALLATION AND LICENSING | LAUNCHING HIERO OR HIEROPLAYER
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Mac OS X
• Click the dock icon.

• Using the Finder, open the application directory (by default,
/Applications/Hiero1.9v1/ or /Applications/HieroPlayer1.9v1/) and double-click the .app icon (or list item).

• Open a terminal and enter the following command:
/Applications/Hiero1.9v1/Hiero1.9v1.app/Hiero1.9v1

OR
/Applications/HieroPlayer1.9v1/HieroPlayer1.9v1.app/HieroPlayer1.9v1

Linux
• Open the ~/Hiero1.9v1/bin or ~/HieroPlayer1.9v1/bin directory and double-click the icon (or list item).

• Open a terminal, navigate to the ~/Hiero1.9v1/bin or ~/HieroPlayer1.9v1/bin directory and enter:

./Hiero1.9v1 or ~/HieroPlayer1.9v1/

NOTE: The ~/ in the filepath indicates the directory from which the installer was executed.

Windows
• Double-click the icon on the Desktop.

• Navigate to Start > All Programs > The Foundry > Hiero1.9v1 orHieroPlayer 1.9v1.

• Using a command prompt, navigate to the application directory (by default, \Program Files\Hiero1.9v1 or
\Program Files (x86)\Hiero1.9v1 for Hiero and \Program Files\HieroPlayer1.9v1 or \Program Files (x86)
\HieroPlayer1.9v1 for HieroPlayer), and enterHiero1.9v1 orHieroPlayer1.9v1.

Startup Options

If you choose to launch the application from a command line, you can append arguments to the command as
follows:

Argument Result

--help (-h) Displays the available arguments with examples.

--version Displays version and copyright information.

2 INSTALLATION AND LICENSING | LAUNCHING HIERO OR HIEROPLAYER
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Argument Result

--script Opens the specified script. For example:
./Hiero1.9v1 --script myscript.py

If the script resides in a different directory to the application, specify the
filepath as well.

--player (Hiero only) Launches Hiero in HieroPlayer mode.

--log-file Sets the location of any logfiles created. For example:
./Hiero1.9v1 --log-file /Desktop/log.txt

See Setting Environment Variables to specify the logfile using an environment
variable.

--log-level Sets the level of logging produced during operation. For example:
./Hiero1.9v1 --log-level warning

Log messages are output to screen unless you specify a
--log-file. There are four levels of detail, on a sliding scale from minimal to
verbose:

• error

• warning (default)

• message

• verbose

NOTE: Setting the logging level to verbose can produce large log
files when --log-file is specified.

See Setting Environment Variables to set the log level using an environment
variable.

--quiet (-q) Launch the application without displaying the splash screen or startup dialog.

--safe (-s) Launch the application without loading any plug-ins, Export presets, and so
on.

--single-threaded-playback Launch the application in single-thread mode. This option can solve playback
issues on various Linux Fedora flavors.

See Setting Environment Variables to set the playback mode using an
environment variable.

2 INSTALLATION AND LICENSING | LAUNCHING HIERO OR HIEROPLAYER
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On Windows, you can also use the same arguments on executables (or their shortcuts) by adding them to the
program’s Properties. To use a startup argument:

1. Right-click theC:\Program Files\Hiero1.9v1 orHieroPlayer1.9v1 icon or the equivalent icon on the Desktop.

2. Click Properties.

3. Append the required argument to the Target or .exe field.

Licensing Hiero and HieroPlayer
The following licensing methods are available:

• Activation Keys and Node Locked Licenses - these are used to license applications on a single machine. They
do not work on different machines and if you need them to, you’ll have to transfer your license.

Node locked licenses, sometimes called uncounted licenses, do not require additional licensing software to be
installed.

• Floating Licenses - these are used to license applications on any networked client machine. The floating license is
put on the server and is locked to a unique number on that server.

Floating licenses, sometimes called counted licenses, require additional software to be installed on a server to
manage the licenses and give them out to the client stations that want them. This software is called the Foundry
Licensing Tools (FLT) and can be downloaded at no extra cost from our website.

These instructions run through the basic options for both licensing methods, but you can find a more detailed
description in the Foundry Licensing Tools (FLT) User Guide available on our website
www.thefoundry.co.uk/support/licensing/tools/

Obtaining Licenses

To obtain a license, you'll need your machine's System ID (sometimes called Host ID or rlmhostid). Just so you know
what a System ID number looks like, here’s an example: 000ea641d7a1.

NOTE: Bear in mind that, for floating licenses, you'll need the System ID of the license server, not the
machines on which you intend to run Hiero.

There are a number of ways you can find out your machine's System ID:

• Launch Hiero without a license, click Status, and then scroll down the error report until you see your System ID.

• On Mac and Windows, you can download the Foundry License Utility (FLU) from
www.thefoundry.co.uk/support/licensing/ and run it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from www.thefoundry.co.uk/support/licensing/ and
then:

• On Mac, run /Applications/TheFoundry/LicensingTools7.0/Foundry License Utility.app

• On Linux, run the following command in a terminal shell:

2 INSTALLATION AND LICENSING | LICENSING HIERO AND HIEROPLAYER
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/usr/local/foundry/LicensingTools7.0/bin/systemid

• On Windows, run C:\Program Files\TheFoundry\LicensingTools7.0\ Foundry License Utility.exe

When you know your System ID, you can request a license for The Foundry products:

• from The Foundry's Sales Department at sales@thefoundry.co.uk

• from the product pages on our web site, such as www.thefoundry.co.uk/products/hiero-product-family

• by launching Hiero without a license and selecting:

• Buy Hiero - opens a web browser directly to The Foundry website to purchase a license.

• Try Hiero - displays the 15-day trial license download screen. Enter your The Foundry account details or create
a new account and follow the on-screen instructions to receive a trial license.

NOTE: By default, if you have installed a temporary license, Hiero displays a dialog at start-up alerting you
to the number of days remaining. If you want to disable this behavior, you can set the FN_DISABLE_
LICENSE_DIALOG environment variable to 1 to suppress the warning message about imminent license
expiration. See Environment Variables for more information.

Installing Licenses

When you start the application before installing a license, a Licensing dialog displays an error, informing you that no
license was available. The installation process is dependent on what type of license you requested:

• License file - if you requested a license file, typically foundry.lic, this option allows you to browse to the file
location and install it automatically. See To install a license from disk for more information.

• Activation Key or license text - if you requested an Activation Key or license by email, this option allows you to
paste the key or license text into the Licensing dialog, which then installs the license in the correct directory. See
To install an Activation Key or license text for more information.

• A floating license - if you requested a floating license to supply licenses to multiple client machines, this option
allows you enter the server address that supplies the client licenses.

NOTE: You must install a floating license and additional software on the license server to use this option.

See To install a floating license for more information.

To install a license fromdisk
1. Save the license file to a known location on disk.

2. Launch Hiero.

The Licensing dialog displays.

3. Click Install License to display the available license installation options.

4. Click Install from Disk.

5. Browse to the location of the license file.

2 INSTALLATION AND LICENSING | LICENSING HIERO AND HIEROPLAYER
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6. Click Open to install the license automatically in the correct directory.

To install an Activation Key or license text
1. Launch Hiero.

The Licensing dialog displays.

2. Click Install License to display the available license installation options.

3. Click Activation Key / License Text and then either:

• Enter theActivation Key string in place of Insert Activation Key Here. A license key typically looks
something like this:
hiero-0101-77d3-99bd-a977-93e9-8035

OR

• Copy the license text and paste it over theCopy/Paste license text here string. License text typically looks
something like this:
LICENSE foundry hiero_i 2014.1223 permanent 2 share=h min_timeout=30

start=23-jan-2014 issuer=sf issued=23-jan-2014 replace

_ck=6dd78e4c69 sig="60PG452MPDMMM6MJAMRGKNQAN3PEAK8JYTHN45022M0C98H

XFA9N7SAASMRABT8TUJ6FAMX8TWU0"

4. Click Install.

The license is automatically installed on your machine in the correct directory.

NOTE: Activation Keys require an internet connection. If you access the internet through a proxy server
and cannot connect to the activation server, you may get an error dialog prompting you to either:

Click Use Proxy to enter the proxy server name, port number, username, and password. This enables the
application to connect to the activation server and obtain a license. The license is then installed
automatically, or

Click on the web link in the dialog and use the System ID (also known as hostid) provided to manually
activate and install a license.

To install a floating license

If you requested a floating license from The Foundry, you will receive your license key (foundry.lic) in an email or
internet download. You should also receive the Foundry License Utility (FLU) application to help you install the
license key on the license server machine. The server manages licenses for the clientmachines on your network.

NOTE: The FLU is also available to download from www.thefoundry.co.uk/support/licensing/

1. Make sure you have saved both the license key (foundry.lic) and the FLU application in the same directory.

2 INSTALLATION AND LICENSING | LICENSING HIERO AND HIEROPLAYER
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2. Run the FLU application.

The license key automatically appears in the FLU window if the FLU and foundry.lic are in the same directory.

TIP: If they are not in the same directory, you can either copy and paste the contents of the license key or
drag-and-drop the file into the FLU window.

3. Click Install.

This checks the license file and, provided that the license is valid, installs it into the correct directory.

4. In order for the floating license to work, you will need to install the Foundry Licensing Tools (FLT) on the license
server machine.

For more information on how to install floating licenses, refer to the FLT User Guide, which you can download
from our website www.thefoundry.co.uk/support/licensing/

5. Once your license server is up and running, launch Hiero on the client machine.

The Licensing dialog displays

6. Click Install License to display the available install methods.

7. Click Use Server and enter the server address in the field provided. The format for the server name is:
<port>@<servername>, for example, 30001@red.

NOTE: You must perform steps 5 through 7 on each client machine that requires a Hiero license from the
server.

TIP: If you later need to display the Licensing dialog again, you can select Help > License.

For more information on how to install licenses, see the Foundry Licensing Tools (FLT) User Guide available on our
website at www.thefoundry.co.uk/support/licensing/

2 INSTALLATION AND LICENSING | LICENSING HIERO AND HIEROPLAYER
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3 Hiero Workflow Case Studies
This chapter describes a number of possible collaborative workflows supported by Hiero,
HieroPlayer, and Nuke.

Hiero
In a typical collaborative project environment, Hiero sits in between edit and grading, and finishing and delivery,
acting as a hub for visual effects. It is used to locate, preview, and then farm media out to shot-based effects
applications (such as Nuke), and take their results and re-integrate them into the sequences for review and
comment. See Collaborative Project Case Study for more information.

Hiero can also be used as a “Hero” seat, passing content between timeline and shot creation using Hiero<>Nuke,
without leaving the local machine. See Hero Seat Case Study for more information.

HieroPlayer
HieroPlayer sits next to your compositing and other shot creation software, allowing artists to view their work in the
context of a timeline. This collaborative workflow allows multiple artists to work on the same timeline, viewing
colleague’s work as well as their own. See Collaborative Project Case Study for more information.

HieroPlayer can also be used to maintain an element library. You can filter content using the bin structure, tags, and
metadata and view elements on scratch sequences, passing clips between applications using Hiero<>Nuke. See
Element Library Case Study for more information.

Feature Comparison
Designed to work hand-in-hand in different scenarios, Hiero and HieroPlayer share a number of features, but as the
hub, Hiero has a richer feature set than HieroPlayer.
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Feature Hiero HieroPlayer

Review and Playback - Robust playback & review engine for post production

Multi-track timeline viewing and editorial workspace, including industry
standard tools

Nuke equivalent format support including OpenColorIO management

Multi-channel audio import and playback

Extensive review toolset including A/B compare, masks, and color picker

Realtime image scopes including histogram, waveform, and vectorscope

Media localization and caching

Standard jog and shuttle controls

Broadcast Monitor support

Editing - Standard tools and layouts for editorial.

Modal editorial tools including equivalent keyboard hotkey interface

Source/record 2-up Viewer workspace and 3-point editing

Conform - Simple and flexible ingest of cuts from editorial.

Conform multi-track timelines from CMX 3600 Edit Decision Lists (EDLs)
and Final Cut Pro XML, including cuts, transitions and retimes

Session-wide spreadsheet containing all sequence events

Shot Management and Export - Manage, distribute and ingest media with ease

Export sequences, timeline shot structures, clip hierarchies, and EDL/XMLs

3 HIEROWORKFLOW CASE STUDIES |
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Feature Hiero HieroPlayer

Transcode, copy, and soft link media

Create template Nuke scripts for easy distribution of work

Hiero<>Nuke integration - a live link between applications updating on-the-
fly as VFX work is completed

Automatically update VFX shots in context

Version shots and snapshot timelines for review and editing

Hierarchical project and element library management

Tag shots, frames, and sequences for easy filtering of content including
custom metadata

Open and Scriptable Playback Framework - Flexible enough to fit any pipeline

Extensive Python API to accomplish most tasks through Python scripting
that you can with the Hiero and HieroPlayer user interfaces

Integrated Pyside enabling fine-grained customization of interface tasks

Collaborative Project Case Study
As mentioned, Hiero can sit comfortably in a post pipeline as the hub for managing content. The diagram below
shows a typical workgroup scenario.
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Hiero, HieroPlayer, and Nuke in a collaborative project.

Preparing a Project in Hiero

The first step in Hiero is to conform the EDL or XML from the editor. The conform process pulls together the
required source clips and matches them to events in the EDL or XML. Hiero displays these events in a spreadsheet
which is linked to a timeline showing the corresponding track items. See Conforming Using Hiero for more
information.

Once the conform is complete, you can view your timeline to confirm that the correct clips are present, check the
content using Hiero’s scopes, add reference tracks, and pass on any pertinent information to the next step in
production using tags and notes. See Ingesting Media for more information.

The next step is to make any minor edits to the timeline, including transitions and retimes, swap or rename track
items, or examine different versions of clips on the timeline. See Managing Timelines and Versions and Snapshots for
more information.

The final step before HieroPlayer steps in is to export and save your project. Exporting from Hiero and saving the
project creates placemarker track items for VFX work in a read-only Hiero project (.hrox file), preserving the conform
work from Hiero. Multiple artists can then work on track items, creating versions which are then automatically
updated in HieroPlayer. See Round-Tripping Using the Export Dialog for more information.

Loading a Hiero Project in HieroPlayer

HieroPlayer is most commonly used to open Hiero projects as read-only copies to preserve conform work from
Hiero. This way, multiple artists can work on a project without worrying about overwriting a colleagues work.

To open a Hiero project in read-only form:
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1. Launch HieroPlayer and navigate to File > Open.

TIP: You may find that the project you require is displayed in the startup dialog underRecent Projects.
Select the project and click Open to quickly access the project.

2. Locate the required Hiero project using the browser and click Open.

A warning displays informing you that the project is read-only, as it was created in Hiero.

3. Click OK to dismiss the prompt.

4. Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to indicate that the
project is read-only.

You can’t delete bins, clips, or track items, or make edits on the timeline when the highlight is light blue.

See Using Hiero<>Nuke in HieroPlayer for information on how to update work between HieroPlayer and Nuke.

Opening a Writable Hiero Project

If you want to open a writable version of a Hiero project, you can open the project and save it as a HieroPlayer
project. HieroPlayer projects are always readable in Hiero, so don’t worry about backward compatibility.

To open a Hiero project in writable form:

1. Launch HieroPlayer and navigate to File > Open.

TIP: You may find that the project you require is displayed in the startup dialog underRecent Projects.
Select the project and click Open to quickly access the project.
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2. Locate the required Hiero project using the browser and click Open.

A warning displays informing you that the project is read-only, as it was created in Hiero.

3. Click OK to dismiss the prompt.

4. Opening a Hiero project in HieroPlayer changes the interface highlight color to light blue to indicate that the
project is read-only.

You can’t delete bins, clips, or track items, or make edits on the timeline when the highlight is light blue.

5. Navigate to File > Save as Player Project and select a save location.

6. The highlight color changes to orange to indicate that the project is now writable.
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Hero Seat Case Study
Running Hiero and Nuke on the same machine can really take advantage of the Hiero<>Nuke connection, an open
port between the two applications, that doesn’t require using Hiero’s Export dialog.

Round-tripping using Hiero<>Nuke.

After connecting Hiero<>Nuke, changes made to clips in one application are automatically updated in the other. For
example, VFX work in Nuke is added automatically to the scanned versions dialog in Hiero’s timeline as it is
completed.

See Round-Tripping Using Hiero<>Nuke for more information.

Element Library Case Study
As well as acting as a timeline context review tool in collaborative workflows, HieroPlayer is well suited to passing
elements from a library to Nuke over the Hiero<>Nuke connection.

Pass elements easily from
HieroPlayer to Nuke.
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Ingest and tag your elements in HieroPlayer, then use the tag filtering and flagging field to quickly locate elements
with the required tags. See Ingesting Media and Using Tags for more information.

HieroPlayer also features all Hiero’s editing capabilities, allowing you to create scratch timelines to view elements in
context. See Timeline Editing Tools for more information.

3 HIEROWORKFLOW CASE STUDIES | ELEMENT LIBRARYCASE STUDY



4 Customizing Your Workspace
The Hiero and HieroPlayer interfaces are customizable using floating panes and show/hide
functionality, but several default workspaces are supplied for your convenience.

Workspace Overview
Hiero and HieroPlayer ship with a number of different workspaces. These are specific layouts that can be loaded as
the current tasks change.

Hiero ships with the following workspaces:

• Hiero’s Conforming workspace is where the bulk of the work you undertake with Hiero is done. The linked
spreadsheet and timeline panes are where you’ll really see the power of Hiero.

• The Editing workspace provides the tools you’ll need to fine-tune your media in Hiero, including 2-up
source/record Viewers.

• TheReviewing workspace is shared by both applications and is used to confirm your media intent is fully realized.
You can add tags and notes, mark In and Out points on clips and timelines, and organize your ingested media into
bins as required.

HieroPlayer ships with the following workspaces:

• The Flipbooking workspace consists of a Viewer and Project tab and is used primarily as a review tool in
HieroPlayer.

• The Timeline workspace is similar to Hiero’s Editing space, but exclusive to HieroPlayer.

• TheReviewing workspace is shared by both applications and is used to confirm your media intent is fully realized.
You can add tags and notes, mark In and Out points on clips and timelines, and organize your ingested media into
bins as required.

NOTE: HieroPlayer doesn’t include any Conform functionality and projects loaded from Hiero can’t be
edited unless they’re resaved using File > Save as Player Project.

When you launch either application, you’re presented with a startup dialog.
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The startup dialog allows you to create a new project, open an existing project, or view the User Guide and website
dedicated to Hiero.

TIP: You can disable this dialog by checkingDon’t show this dialog again or by toggling it off in the
Workspace Preferences dialog.

Select the required option or click Close to access the application. Take a moment to familiarize yourself with the
default workspaces.

Hiero’s default Conforming workspace: HieroPlayer’s default Timeline workspace:

Feature Description Hiero HieroPlayer

Project Tab You can manage all aspects of your projects and bins in
the Project tab.
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Feature Description Hiero HieroPlayer

Menu Bar Use the Menu bar to access Hiero’s dropdown menus.

Bin View The Bin displays the contents of any selected Project tab.

Viewer You can display and review your media in the Viewer.

Timeline Info The timeline info displays the current timeline’s sequence,
media, and metadata information.

Editing Tools There is a comprehensive set of editing tools provided in
Hiero and HieroPlayer. Timeline Editing Tools for more
information.

Spreadsheet
Tab

Use the Spreadsheet tab to display the contents of the
timeline in spreadsheet form. Note that the spreadsheet
and timeline are linked, mirroring any selections made.

Timeline The timeline displays the current track including all track
items and any effects that have been added.

Menu Bar Components

The Menu Bar contains various controls, many of which are available through right-click menus, hotkeys, and
toolbars.

For a full list of hotkeys, buttons, and menu functions, see Appendix A.

You can switch between workspaces by navigating to Window > Workspace and selecting Conforming, Editing,
Reviewing, Flipbooking, or Timeline. Alternatively, you can toggle between the default workspaces using
Shift+F1, Shift+F2, Shift+F3, and so on.

Any custom workspaces you create are added to the end of the list. You can access the first custom workspace using
Shift+F5, and so on.

Creating Your Own Workspace
Hiero's interface is comprised of any number of panels. Panels act like containers with different tabs; you can
configure panels to contain specific tools, such as the timeline or a Viewer, depending on the task you are presently
performing. The default panel configurations are saved as Workspaces (referred to as Layouts in Nuke) and include:
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Conforming, Editing, Reviewing, Flipbooking, and Timeline. You can easily create your own custom workspace that
suits your needs, and then save it as a custom Workspace for easy recall.

During the customization process, you can:

• Resize your entire workspace or panes independently.

• Split panes to create new work areas, for example two Viewers side-by-side.

• Add and remove panes and tabs as required.

• Float and nest tabs to group similar functions together, for example Histogram, Vectorscope, and Waveform in the
same pane.

• Maximize the pane under the mouse cursor by pressing ` (back tick). Press ` again to return to the regular
interface.

You can create as many workspaces as you require, one for each project you undertake if necessary. In practice
though, you may find that two or three custom workspaces are sufficient.

TIP: You can return to the saved version of a workspace by navigating to Window > Workspace > Reset
Workspace.

Resizing YourWorkspace

Resizing the interface, panes, and tabs works in much the same way as other software applications:

• To resize the entire interface, drag the resize handle at the bottom right of the application to the required width and
height.

• To resize individual panes, hover the mouse over the edges of the required area until the cursor changes to the
resize icon. Click and drag the cursor to resize the pane or tab.

Splitting Panes

Splitting panes allows you to organize your workspace into distinct areas delineated by well-defined borders.

• To split panes, right-click the required pane and select Split Vertical or Split Horizontal.
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Adding and Removing Panes and Tabs

Adding and removing tabs gives you the freedom to personalize your workspace depending on your current project.

• Add new tabs by:

• Navigating to Window and selecting the required tab. The tab is embedded in its default position or added to
the interface as a floating window,

OR

• Right-clicking the pane in which you want the tab to appear and selecting it from theWindows dropdown.

• Close any tab that is not required by:

• Clicking the x on the tab’s right-hand side,

OR

• Right-clicking the tab name and selecting Close Pane or Close Tab.
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Floating and Nesting

You can move existing panes and tabs to new locations in the interface (to help you organize your project).

• Float a pane or tab by:

• Right-clicking the tab name and selecting Float Pane or Float Tab.

OR

• Dragging the required tab from its current location.

• Nest any floating pane or tab by dragging it to any existing pane.
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TIP: Use the orange highlight around the destination pane to help you determine where the tab
nests.

Saving Workspaces

Once you’re happy with the changes you’ve made to the workspace, navigate to Window > Workspace > Save
Workspace.

Enter a name for the workspace, then click OK to preserve your workspace as a workspace file (extension .hws).

TIP: If you save a workspace called Conforming, Editing, Reviewing, Flipbooking, or Timeline you can
override the defaults supplied with either application by clicking Save in the dialog box.

Delete the workspace you created to restore the default layout.

Loading Workspaces

To use a previously saved workspace, navigate to Window > Workspace and select the custom workspace name
you require.

TIP: Alternatively, you can use the workspace hotkeys Ctrl/Cmd+n (wheren is equal to the number of the
custom workspace).

Your pre-saved workspace is loaded.

4 CUSTOMIZING YOURWORKSPACE | CREATING YOUROWNWORKSPACE



35

Deleting Workspaces

You may find that after using Hiero or HieroPlayer on a number of projects, some of the workspaces you created
earlier have been superceded by more useful entries. Delete Workspace allows you to clear up your saved files,
although you can remove the files manually from the save location.

To delete custom workspaces:

1. Navigate to Window > Workspace > Delete Workspace.

2. Select the required workspace from the dropdown menu.

3. Click OK to delete the selected entry.

Workspace Preferences
The Preferences dialog allows you to make global changes to the way the interface behaves every time you start
Hiero or HieroPlayer. Changes you make in the Preferences override any local changes when you restart the
application.

NOTE: Workspace Preferences are saved in the ~/.hiero/uistate.ini file.

To access the Preferences dialog, either:

• Navigate to Hiero (HieroPlayer) > Preferences (OS X) or Edit > Preferences (Linux and Windows), or

• Use the Preferences hotkeys Shift+S.
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Once you’ve made your selections in the Preference dialog, click OK to save your changes. Bear in mind that
changing some preferences, for exampleQuickTime decoders, Scopes, and Use RED Rocket card, require you to
restart Hiero before they’re applied.

NOTE: Click RestoreDefaults to return to the default Preference settings.

General Preferences

These preferences take care of how the applications start up, how often your work is automatically saved,
localization, and cross-platform compatibility.

Preference Default Value Description

Startup Workspace Conforming (Timeline
for HieroPlayer)

Sets the default startup workspace.

Show splash screen at
startup

enabled Enables or disables the product page during startup.

Reconstruct directories
on ingest

enabled When enabled, preserve the original folder/file hierarchy
during ingest.

Show startup dialog enabled Enables or disables the Settings dialog during startup.
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Preference Default Value Description

Scan for file sequence
range on drop into bin
view

enabled When enabled, dragging a single file or file range, that is part of
an image sequence, creates a clip in the bin view containing all
available frames.

When disabled, only the dragged frame or range is imported
into the bin.

See Using Drag-and-Drop for more information.

Automatically rescan
versions when moving
off end of the version
list

enabled When enabled, incrementing a clip or track item’s version past
the end of the previously discovered versions list, forces a
rescan to update the versions list. See Using Versions for more
information.

Warn when opening a
locked Hiero project

(HieroPlayer only)

When enabled, opening a Hiero project in HieroPlayer displays
a read only warning.

If you disable this option, you won’t be warned but the clips
and sequences in the project will still be colored light blue to
remind you of the read only state of the project.

Autosave period 5 minutes Sets how often you want to save your work in the
background. Use the up and down arrows or type a new value
in the field.

Restore workspace
when opening projects

enabled When enabled, restore the saved workspace layout at project
load.

When disabled, use the Startup Workspace when you open
an existing project.

Automatically save
RMD files

disabled When enabled, automatically save changes to a RED clip’s Look
effects in an RMD file.

Temp Directory Dependent on OS Defines the directory used to cache thumbnail information.

You can disable caching using an environment variable, as
described in Environment Variables.
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Preference Default Value Description

Auto Localize From none Sets the working directory that is automatically cached on
ingest to the Localize To directory.

For example, setting the filepath to
/project/myclips/footage would locally cache media from
that directory on ingest, up to theMax localized files limit.

Localize To none Sets the local directory where cached files are stored. See
Caching Media Locally for more information.

NOTE: If this filepath is not specified, cached files
are saved in a subdirectory of the folder specified in
Temp Directory.

Max localized files (MB) 10000 MB Sets the maximum space available for localized caching.
Negative values in this field reserve the specified amount of
space at all times. For example, -2000 stops 2 GB of memory
being used for caching.

Path substitution none Sets the mapping rules for cross-platform project sharing.

The mapping rules allow the application to read platform
specific file paths by explicitly mapping them to
Mac/Linux/Windows friendly names.

Click the + icon to add an entry to the table and then enter the
paths as necessary. For example:

Viewer Preferences

These preferences determine the default settings for the Viewer at startup as well as all new Viewers that you add to
the workspace - you can still adjust the settings of individual Viewers.
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Preference Default Value Description

Playback Mode Play All Frames Sets the default playback mode for new Viewers. See Viewer
Tools for more information.

OpenColorIO config file none Sets the OpenColorIO configuration to use if you don’t intend
to use the default settings.

Enter the filepath of the configuration file or click Choose to
use the browser.

NOTE: Hiero and HieroPlayer also include an
environment variable method for setting a config
file. See Environment Variables for more
information.

Guides disabled Selects the default Guides to apply to Viewers. Choose from
Title Safe,Action Safe, and Format. See Viewer Tools for
more information.

Fullscreen Display Primary Monitor (1) Controls where the Viewer expands to when in Fullscreen
mode.

See through missing
media

enabled When enabled, any offline media on a timeline is treated as
transparent, allowing the Viewer to display the track
underneath.

Crop to format disabled When enabled, clips or track items that extend outside the
format guide are cropped.

Background Black Sets the Viewer background color, including sliders to control
brightness. Choose fromBlack,Gray, or Checkerboard.

NOTE: Hiero and HieroPlayer currently treat all
alpha channels as premultiplied, which can result in
the Viewer background being “added” to the image.
If you’re working with un-premultiplied images, set
the Viewer background to Black.

Frame Increment 12 Sets the frame increment amount for Skip and Nudge More
operations. This control only affects new Viewers.
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Preference Default Value Description

Filtering mode Auto This allows you to specify the Viewer behavior when filtering
your sequences for display.

• Nearest neighbor and Linear - standard OpenGL filtering
options.

• Auto - mimics the previous Viewer filtering, which was based
on Nuke’s behavior.

Audio Preferences

These preferences control how audio behaves in Hiero and HieroPlayer. See Audio and the Timeline for more
information.

Preference Default Value Description

Disable audio disabled When enabled, audio output is muted throughout the
application.

NOTE: You must restart Hiero or HieroPlayer for
this option to take effect.

Audio device Speakers Sets the audio output device or driver.

Default latency
adjustment (ms)

0 ms Sets the default audio latency for all new Viewers in
milliseconds. Audio latency allows you to correct audio and
video sychronization by changing the point at which audio
playback starts.

Positive values cause the audio track to start earlier in relation
to the video track, and vice versa.

Default volume 50% Sets the default audio volume for all new Viewers.

Timecode Preferences

These preferences determine where selected file types derive their timecode.
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Preference Default Value Description

RED File Timecode Default From File Sets the start timecode to use for conformed or ingested R3D
files. Select Default From File,Absolute Timecode, or Edge
Timecode.

Other Media Timecode File Header Sets where the start timecode for all other media is derived.
Select File Header or Frame Number. See Ingesting Media
for more information.

Max Valid Timebase 10000 fps Sets the maximum image header timebase above which the
value is clamped.

Image files are often created with application specific timebase
values in the header description. This can lead to reading in
spuriously high frame rates and the clamp aims to prevent this
from happening.

If your clips do have extremely high frame rates, increase this
value as necessary to avoid clamping.

EDL-Style Spreadsheet
Timecodes

disabled When disabled, the srcOut and dstOut values use the film
convention, representing the last frame of the cut.

When enabled, the srcOut and dstOut values use the video
convention, representing the frame directly after the cut.

Scopes Preferences

These preferences set the Black and White points for Histogram and Waveform Out of Range warnings individually,
in the range 0-1.

Preference Default Value Description

Black point 0.00 Sets the black out of range warning level.

White point 1.00 Sets the white out of range warning level.

Luma/chroma
encoding

REC 709 Sets how the scopes display luma and chroma information by
selecting the rec601 or rec709 standard.
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RED Rocket Preferences

This preference enables and disables your RED Rocket.

Preference Default Value Description

Use RED Rocket card enabled When enabled, any RED Rocket card present can increase the
rendering speed for R3D files significantly, especially at higher
resolutions.

Sequence Preferences

Sequence preferences set the defaults applied to new timelines.

Preference Default Value Description

Output Resolution 1920x1080 HD 1080 Sets the default resolution for new timelines. Video tracks on
new timelines are cropped to the this format.

Frame Rate 25 Sets the default frame rate to use when a new timeline is
created.

Start Timecode 01:00:00:00 Sets the timecode starting point for new timelines.

Time Display Timecode Sets whether new timelines are measured using Timecode or
Frames for display purposes.

Drop Frame disabled Sets whether drop frames are accounted for or not when new
timelines are created.

Drop Frame is a timecode display option that leaves out two
frames from the 30 fps timecode sequence every minute
(except every 10th minute) so that long running NTSC
sequences are accurate to a real-time clock (NTSC frame rate is
3000/1001, or approximately 0.01% slower than 30fps).

NOTE: EnablingDrop Frame is a Timecode display
feature only - the source media remains a
continuous stream of frames.
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Color Management Preferences

These preferences set the default colorspace applied to various display and file types. For example, setting Viewer
to None displays all media in new Viewers with no colorspace applied to them.

Preference Default Value Description

Viewer sRGB Sets the default LUT applied to new Viewers.

Thumbnails sRGB Sets the default LUT applied to thumbnails when ever they are
generated in Hiero and HieroPlayer.

8-bit Files sRGB Sets the default LUT applied to the specified ingested file type.

16-bit Files sRGB

Log Files Cineon

Floating Point Files linear

Use OCIO nodes when
exporting in Nuke

disabled When enabled, Nuke uses the LUTs read from the OCIO config
file specified in Hiero or HieroPlayer, rather than the Nuke
native LUTs, and adds the relevant OCIO nodes to the script.

Nuke/Export Preferences

These preferences define whether Hiero transcodes internally or uses an external Nuke, and how transcoding is
handled.
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Preference Default Value Description

Nuke Path Dependent on OS When Use Specified Path For Hiero Renders is enabled,
sets the filepath to the external Nuke application you intend
to use during round-tripping and Send to Nuke exports.

NOTE: If you intend to use an external Nuke
application, Hiero<>Nuke requires Nuke 6.3v5 or
later to run correctly.

Use Specified Path For
Hiero Renders

disabled When enabled, the Nuke application specified in Nuke Path is
used to render your output.

When disabled, the internal, command line only HieroNuke is
used for rendering.

Always Use Interactive
Nuke license

disabled When enabled, renders on external Nukes use an interactive
license (if available).

Launch as NukeX enabled When enabled, the Nuke application specified in Nuke Path is
launched as NukeX, if a license is available.

NOTE: On Mac, this option is grayed-out. If you
need to Launch NukeX, specify the NukeX bundle in
theNuke Path field. For example:
/Applications/Nuke8.0v1/NukeX8.0v1.app

Nuke Limits

Limit Nuke to improve
Hiero UI
responsiveness

enabled When enabled, the user interface is still responsive during
transcodes.

This option causes Nuke to use only 2 threads and 25% of
available RAM during transcodes. As a result, transcoding may
slow down considerably.

Do Not Limit Nuke disabled When enabled, transcoding uses as much processing power as
possible, which may cause the user interface to become
unresponsive.
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Preference Default Value Description

Customize Nuke Limits disabled When enabled, use the Threads and Cache Memory fields to
manually configure transcode handling:

• Threads - limits the number of threads available to Nuke.

• Cache Memory - limits the amount of total cache memory
available to Nuke.

NOTE: Hiero supports render farm implementation using Python scripting. Scripts must be located in
specific directories, dependent on platform, as listed in Running Python During Startup. If no scripts exist,
theRender background tasks dropdown in the Export dialog box is disabled.

Some example scripts are included in the Hiero package in the following directories:

• On Mac: /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

• On Linux: /usr/local/Hiero1.9v1/Plugins/site-packages/hiero/examples/

• On Windows: drive letter:\Program Files\Hiero1.9v1\plugins\site-packages\hiero\examples

Performance Preferences

These preferences allow you to customize Hiero’s performance according to your machine’s capabilities. See
Optimizing Read and Decode Performance for more information.

Preference Default Value Description

Default number of
threads per reader

2 Sets the number of threads to use per reader. If your source files are
located on high performance local drives, increasing the number
threads can significantly improve read times.

CPU intensive operations, such as .jpg decoding, can also be improved
by increasing the number of threads per reader.

Overridden number
of decode threads
per reader

none Allows you to override the default number of decode threads used,
dependent on file format.

Use theplus button to add an entry to the table and then select the
file format using the dropdown menu. Double click theNumber of
threads column to set the required number of decode threads for that
format.
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Preference Default Value Description

OpenEXR helper
threads to use

0 Sets the number of helper threads to use for OpenEXR only. The
default, zero, automatically sets the number of helper threads used.

ARRI helper threads
to use

0 Sets the number of helper threads to use for ARRI only. The default,
zero, automatically sets the number of helper threads used.

NOTE: The OpenEXR and ARRI helper thread preferences are independent of the threads per reader and
override table per format settings.

QuickTime
decoders

8 Total Sets the number of background processes available to handle
QuickTime file I/O. You must restart the application for this preference
change to take effect.

NOTE: Using too many decoders can affect performance,
depending on the available hardware.

Enable PBO texture
uploads

Disabled Enabling Pixel Buffer Objects (PBOs) can improve playback
performance for certain combinations of hardware, software, and file
formats.

NOTE: You must restart Hiero for this option to take effect.

Expand images
from 3 to 4
channels per pixels

Dependent on OS Enabling this option can improve playback performance for certain
combinations of hardware at the expense of the number of frames
cached.

NOTE: Expansion is enabled by default on Mac and
Windows.

Playback cache size 33% Sets the percentage of total memory available for use as cache.

You can't set this to a value higher than 80% of the memory available
(rounded down to the nearest half-GB). For example, if you have 6 GB
of memory available, the maximum cache size available 4.5 GB.
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Preference Default Value Description

Lock cache into
memory

(Mac only)

enabled When enabled, lock the playback cache in memory so that the
operating system doesn’t swap out the memory allocated for the
playback cache.

This settings can improve playback performance, but reduces the
amount of memory available to run other applications.

NOTE: Cache locking is only available on Mac OS X.

Unlock cache when
application is in
background

(Mac only)

enabled When Lock cache into memory is active, enabling this control can
improve system performance by allowing other applications to use the
reserved system RAM when the application is running in the
background.

Bear in mind that when the application becomes active again, there
may be playback delays while the cache memory is swapped back in.

NOTE: Cache release is only available on Mac OS X.

Pause caching when
the application goes
to the background

enabled When enabled, pause RAM caching when the application loses focus.
When you click back into Hiero or HieroPlayer, caching picks up from
where it stopped.

Clear cache when
the application goes
to the background

disabled When enabled, the RAM cache is flushed when the application loses
focus. When you click back into Hiero or HieroPlayer, caching starts
again from the position of the playhead.

Downsize filtering 1x Set the number of samples averaged to achieve proxy resolutions for
the listed bit-depths. See Using Downsize Sampling for more
information.

Script Editor Preferences
• Script Editor preferences control the appearance of Hiero’s Script Editor.

Preference Default Value Description

Font Courier New Sets the font to use for display purposes in the Script Editor.
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Preference Default Value Description

Font Size 12 Sets the font size to use for display purposes in the Script
Editor.

Indent 4 Sets the indent amount, in spaces, to insert when Tab is
pressed.

Save and restore script
editor history

enabled When enabled, the last entry in the Script Editor is restored at
startup.

Optimizing Read and Decode Performance
The Performance preferences enable you to get the best the results from the hardware you’re using by specifying
the number of “threads” used for reading and decoding media.

A thread is, at its most basic level, a series of operations (in this case reading and decoding frames) that operates
concurrently with other sets of operations. Most media is read intensive, but highly compressed formats like .jpg are
decode intensive. Increasing the number of threads can decrease the time it takes to perform an instruction. For
example, decoding a .dpx file using 2 threads, instead of 1, decodes 2 frames in parallel.

Hiero and HieroPlayer default to 2 threads per reader to accommodate lower specification hardware, but the
following guidelines may improve performance.

Operation Recommended number of threads

Read or I/O

Local HDD 2

Local SSD 3

Network HDD 2

NOTE: As a general rule of thumb, you shouldn’t increase the number of threads above the number of
cores in your machine.

You can override theDefault number of threads per reader on a format-by-format basis using the override table
in the Preferences.

1. Click the icon to add an entry to the table.

2. In the Extension column, click the dropdown to select the file extension to override.
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3. Enter theNumber of threads to use for the selected format.

For example, .jpg files rely heavily on decoding so an override setting between 6 and 8 is recommended. Setting
the default threads per helper to 6 is not advisable, except on high specification hardware.

4. Click OK to close the Preferences and apply the setting immediately, there is no need to restart the application,
so feel free to experiment to achieve the best combination for your setup.

Using Helper Threads

Hiero and HieroPlayer also include two additional helper thread settings dedicated to OpenEXR and ARRI files. These
helper threads assist the reader threads to improve performance for .exr and .ari files.

You can change the number of available helpers using the up and down arrows, or by simply entering the number of
required helpers in the fields provided.

In general, the default setting 0 should automatically assign helper threads correctly. If, however, your project is
.exr/.ari heavy you might consider increasing the number of helper threads.

NOTE: The application must be restarted to apply changes to the ARRI helper setting.

Using Pixel Buffer Objects

Hiero also includes the option to upload textures to the GPU using Pixel Buffer Objects (PBOs), which can decrease
upload times from the RAM cache to the graphics card on Windows and Linux, depending on your hardware and
driver combination. This option is disabled by default, but you can enable PBOs in the Preferences > Performance
submenu by checking Enable PBO texture uploads.

NOTE: Hiero must be restarted for this option to take effect.

The benefit of enabling PBOs may, depending on your hardware and driver combination, be increased further by
enabling or disabling Expand images from 3 to 4 channels per pixel, also on the Preferences > Performance
submenu.
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NOTE: Results may vary depending on your platform, graphics card, drivers, and source image format.

Using Downsize Sampling

The Viewer Image Quality dropdown affects the decode rate and resolution of clips displayed in the Viewer. Lower
resolutions decode faster and vice versa.

You can customize this behavior by bit-depth using the Preferences > Performance > Downsize filtering
controls.
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5 Ingesting Media
Hiero and HieroPlayer are able to handle the same file formats as Nuke (on the same operating
system), including the associated embedded audio and .wav files.

For a full list of supported file formats and playback optimization, see Appendix B.

About Clips
The interface sorts your bin clips into three broad categories: Audio and Video, Audio Only, and Video Only. Clips are
displayed differently depending on their content, location, and in the case of the Viewer, the current mode (see
Viewer Tools).

NOTE: Hiero and HieroPlayer currently treat all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image. If you’re working with un-premultiplied images, set the
Viewer background to Black.

See Workspace Preferences for more information.

NOTE: Hiero and HieroPlayer don’t currently support any QuickTime audio on Linux. Support for audio is
scheduled for a later release.

Clips in Bins
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NOTE: The colored bars under the thumbnail represent the layers available in the clip, in this case color.
Other layers include alpha, depth, and motion, similar to Nuke. See Viewer Tools for more information on
displaying layers.

Clips in the Viewer

Clips, or Track Items, on a Timeline

See Managing Timelines for more information.

5 INGESTING MEDIA |



53

A Clip Opened in a Timeline

See Using In and Out Markers for more information.

Clips and track items are highlighted differently in Hiero and HieroPlayer read-only projects:

Clips selected in Hiero... ...and in HieroPlayer.

The blue highlight denotes that the project is read-only. Once you’ve saved the project in HieroPlayer using File >
Save as Player Project, the highlight changes to orange.

Ingesting Media
Adding media to Hiero, and writable HieroPlayer projects, is as simple as drag-and-drop from a file browser or
selecting File > Import Clips or Import Folder. Hiero imports your media into the bin view providing you with a
thumbnail of all of your clips and preserving the original folder and file hierarchy.

Both applications soft import the media used in projects, creating symbolic links to locations on disk. See Using the
Copy Exporter for information on how to quickly consolidate your media and projects, or Caching Media Locally to
help stabilize playback.
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NOTE: Projects containing large amounts of movie files (for example .r3d and .mov) may exceed the
number of available file handles per process, causing problems opening new files or projects and
exporting.

You can increase the default limit of 1024 by entering the following command from the terminal, then
running Hiero from the same session:
ulimit -Sn 2048

Clips with no inherent frame rate information are assigned a frame rate at ingest as specified in the Preferences.

1. Open the Preferences dialog by pressing Shift+S.

2. Select Timecode from the sub-menu on the left.

3. Use theRED File Timecode dropdown to determine R3D clip behavior:

• Default from File - use the default set by the R3D file in question.

• Absolute Timecode - force the use of the Absolute Timecode as specified in the clip metadata.

• Edge Timecode - force the use of the Edge Timecode as specified in the clip metadata.

4. Use theOther Media Timecode dropdown to determine clip behavior for all other clips:

• File Header - the file metadata header is used to derive the timecode, if it exists. This option defaults to
Frame Number if the header is missing.

• Frame Number - ignores the metadata header, even when present, and derives the timecode from the frames
in the clip.

5. Set theMax valid timebase allowed from the image header, above which the value is clamped.

Image files are often created with application specific timebase values in the header description. This can lead to
reading in spuriously high frame rates, and the clamp aims to prevent this from happening.

If your clips do have extremely high frame rates, increase this value as necessary to avoid clamping.

6. Enable or disable EDL-Style Spreadsheet Timecodes:

• When disabled, the srcOut and dstOut values use the film convention, representing the last frame of the cut.

• When enabled, the srcOut and dstOut values use the video convention, representing the frame directly after
the cut.

7. Click OK to save your settings.
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Using Drag-and-Drop

Simply locate your media in a file browser and drag the frame range, clip, folder, or folders into the Project tab.

Ingest behavior depends on the target:

• Dragging a folder into the Project tab automatically ingests all the contents of the folder, including other folders
and their contents.

• Dragging a movie file, such as a .mov or .r3d, automatically ingests the entire clip.

• Dragging a single file or file range, that is part of an image sequence, is controlled by the Preferences > General >
Scan for file sequence range checkbox:

• Enabled - the default setting, dragging a single file or file range, that is part of an image sequence, creates a clip
in the bin view containing all available frames.

For example, dragging frames 1-5 and 11-20 ingests the entire frame range.

• Disabled - only the dragged frame or range is imported into the bin.

For example, dragging frames 1-5 and 11-20 ingests two distinct clips, one containing 5 frames and one
containing 10 frames.

Using the File Browser

If you prefer to work with menus, you can also import clips using the file browser. You can import individual clip files,
ranges, or entire folders, depending on the amount of media you intend to use.

1. Navigate to File > Import Clips or Import Folders.
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TIP: You can also use theCtrl/Cmd+I and Ctrl/Cmd+Shift+I hotkeys.

A browser dialog box displays.

2. Select the type of sequence to display:

• Auto Sequences - displays only sequences containing appropriate file types, such as .dpx and .jpg. For
example,myclip.##.dpx.

• No Sequences - displays individual file names with out collapsing them into sequences. For example,
myClip.01.dpx,myClip.02.dpx,myClip.03.dpx, and so on.

• All Sequences - displays all possible sequences regardless of file type, including .mov and .r3d.

3. Check split seq to split incomplete sequences into separate clips.

4. Enter text in the Filter field and use the dropdown to show or hide files:

• Select * to display all files except hidden files.

• Select .* * to display all files, including hidden files.

• Select */ to display directory names, but not their contents.

5. Select the file(s) or folder(s) that you require and click Open.

If you import folders, use the Import Options dialog to filter your ingest using inclusion and exclusion
parameters, separated by spaces. The dialog's Include patterns field defaults to {supportedfiles}, which
resolves to a list of all known supported file extensions. To add your own custom extensions to this, you can use
{supportedfiles} *.ext (replacing .ext with your custom file extension).

Hiero automatically sorts through your selection and only imports supported file types.

Reconnecting and Refreshing Clips

During the post process, media inevitably changes location or form. You can reload or replace your media using the
reconnect, refresh, and rescan functions.

Though all three options deal with reloading bin clips, each has a particular use dependent on context:
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• Reconnect Media - allows you to redirect the filepath when the source file location changes.

• Refresh Clips (F5) - allows you to reload the clip when the source file location has not changed, such as when work
has been done on the clip offline. Selecting refresh only refreshes the clip’s current frame range.

• Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional frames that
may have been added to the source file and adds them to the bin clip’s frame range.

Caching Media Locally
Hiero and HieroPlayer have the facility to cache files locally, either individually or by setting an automatically localized
folder, to help guarantee playback stability. Local caching is controlled initially in the Preferences dialog, then on a
clip-by-clip basis.

NOTE: During export, Hiero references the original source files, not the localized playback copy. This is
primarily to avoid issues with the localization state of the media when Nuke attempts to locate the files.
As a workaround, you can point Nuke at the same localization directory as Hiero using Nuke's
Preferences > Localize To field.

By default, files are cached to the same location as thumbnail data, though the path varies by platform:

• Mac and Linux - /var/tmp/hiero

• Windows - the system temporary directory, usually C:\temp

To setup your initial caching preferences:

1. Open the Preferences dialog by pressing Shift + , (comma).

2. Enter a filepath forAuto Localize From, if required.

Any files that reside in this directory are automatically cached when conformed or ingested in Hiero.

3. Enter a filepath for Localize To, if required.

Leaving this field blank creates a subdirectory in the Temp Directory as the local cache.

4. Enter a value forMax localized files, in mega bytes, to control how much disk space is available in the cache
directory.

NOTE: Negative values in this field reserve the specified amount of space at all times. For example, -2000
stops 2 GB of memory being used for caching.

To cache individual clips and control localization:

1. Select the clip(s) in the bin view.

2. Right-click and select Localization Policy to display the available options:
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• Always - the selection is cached, regardless of its location, as long as theMax localized files limit is not
breached.

• Never - the selection is never cached, regardless of its location.

• Auto - the selection is cached if it resides in theAuto Localize From directory, as long as theMax localized
files limit is not breached.

As clips cache, a progress bar displays in the thumbnail. Fully cached clips are marked with an orange bar at the
top of the thumbnail.

3. Navigate to Cache > Localization > Edit Settings to display Localization Options.

NOTE: This dialog also displays when you reach theMax localized files limit.
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4. The localization cache defaults to 10000 MB, but you can change its size using the Store size field, if required.

NOTE: Negative values in this field reserve the specified amount of space at all times. For example, -2000
stops 2 GB of memory being used for caching.

5. You can enable or disable local caching by clicking Enable localization.

You can also toggle local caching on or off using theCache > Localization menu.

6. Click Clear all unused files to purge the localization cache of all clips not in use in the current session.

You can also purge the cache using theCache > Localization menu.

7. Check Don't notify me when the localiser runs out of space to stop this dialog displaying if you run out of
localization cache space.

8. Click Apply to confirm changes without closing the dialog or click OK to close the dialog and accept changes.

Hiero and HieroPlayer also feature a playback cache, allowing frames to be cached in RAM memory instead of on
local disk. See Caching Frames in the Playback Cache for more information.
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6 Using the Viewer
Hiero and HieroPlayer support two distinct Viewer types: clip and sequence. This chapter describes
the difference between the two and how to use them.

Introduction

Clip Viewers, sometimes referred to as source Viewers, are marked with the icon and deal exclusively with bin
clips. You can set In and Out points and apply tags to the Viewer, but the source clips are unaffected.

Sequence Viewers, also known as record Viewers, are marked with the icon and deal with sequences and track
items on the timeline. You can set In and Out points and apply tags here too, but you can also edit the track items on
the timeline by trimming, retiming, and so on. See Timeline Editing Tools for more information.

The Editing workspace combines both clip and sequence Viewers by default, enabling you to add bin clips to the
timeline using insert and overwrite functions. See Insert, Overwrite, and 3-Point Editing for more information.

To view your media in a Viewer, simply drag-and-drop a clip or sequence from the Project tab on to a Viewer input,
or double-click the item to send it to the appropriate Viewer.
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NOTE: Hiero and HieroPlayer currently treat all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image. If you’re working with un-premultiplied images, set the
Viewer background to Black.

See Workspace Preferences for more information.

NOTE: On Linux builds with dual monitors, you may need to set which screen is synchronized for NVIDIA
graphics cards. See Synching to VBlank on Linux for more information.

Deleting Media

To remove media from the bin view, select the clip(s) or bin and pressBackspace orDelete.

If any of the media is in use in a sequence, the following warning displays:

Click Yes to delete the media from the bin view, but bear in mind that all instances of the deleted media are removed
from your current sequences.
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NOTE: You cannot delete clips from HieroPlayer read-only projects.

Viewer Tools
The Viewer has two sets of tools for manipulating your media: the Viewer tools and the playback tools. The Viewer
tools, located at the top of the Viewer, are used to affect the mouse pointer as you move over the Viewer, and to
select Viewer preferences:

Icon Function Description

Layers Select the layer to output to the Viewer, for example forwardmotion vectors or
disparityL. Only layers available in the clip are displayed - check the clip’s
thumbnail to see at a glance which layers are present:

- red color layer.

- green color layer.

- blue color layer.

- alpha layer.

- depth layer.

- forward motion vector layers.

- backward motion vector layers.

- all other custom layers, such as disparity.

NOTE: You can scroll through available layers using PgUp or PgDn.

Gain Adjusts the gain applied to the linear input image before viewing, but doesn’t
affect your exported image.
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Icon Function Description

Viewer color
transform

Set the colorspace used to display images in the Viewer, for example sRGB and
rec709.

NOTE: If you have specified an OpenColorIO configuration file in the
Preferences, you may have more colorspace choices available.

Gamma Adjusts the gamma applied to the image after the viewing transform, but doesn’t
affect your exported image.

Channels Select the channel(s) to output to the Viewer, for exampleRGB, single channel,
Alpha, or Luma.

Viewer
Output

Click theViewer Output button and then select what you want to view. This can
be selected tracks or tracks with selected tags.

Viewer
Layout

Select the Viewer configuration, Stack,Horizontal, orVertical.

SplitWipe When both Viewer inputs contain an image, enable SplitWipe to compare the two
images.

Blend Mode Set the type of interaction between images in the Viewer, for exampleOnion
Skin orDifference.

Image Quality Set the Viewer image quality, for example 1:1, 1:4, or 1:16. The default setting,
Auto, resizes the image dependent on the Viewer zoom level, which may re-cache
the image at a higher resolution.

NOTE: Image quality, or proxy, for RED clips is dependent on the clip’s
Decode Resolution in the Effect tab.
For example, if you're viewing a 4K file and theDecode Resolution is
set to Half Premium, a 1:1 proxy value is equal to 2K, 1:2 is equal to
1K, and so on.

Scale Set the scale applied to the clip in the Viewer, for example 25%, 75%, or Fit.
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Icon Function Description

Color
Sample

Enable or disable the RGBA color information sampler in the Viewer.

NOTE: TheColor Sample tool displays color information from the
source file, not the colorspace selected in the Viewer color transform
dropdown.

See Working with Colorspaces for more information.

ROI Click and drag to define a Region of Interest (ROI) in the Viewer. The scopes only
display information within the ROI, when active.

Pause
playback
caching

Pause or release Viewer playback caching, indicated by the green bar under the
Viewer. See Caching Frames in the Playback Cache for more information.

Guides Enable or disable Viewer overlays:

• Title Safe - any text intended for the audience should reside within this zone.

• Action Safe - any visual elements intended for the audience should reside
within this zone.

• Format - adds a red, format-dependent box for the clip or sequence in the
Viewer. Sequences support multi-format clips, see Viewing Multi-Format
Timelines for more information.

Mask Enable or disable a range of Viewer masks, for example 16:9 or 1.85:1.

Non RT
Playback

Sets the Viewer playback mode:

• Play All Frames - the default setting, plays all frames in realtime (dependent
on hardware).

• Skip Frames - plays frames in realtime skipping where necessary to maintain
the frame rate.

• Play All Frames, Buffering - plays all frames by buffering and playing frames
back as they become available.
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Icon Function Description

See through
missing media

When disabled, any offline media on a timeline is treated as a blank clip so the
Viewer cannot display the track underneath. This setting also applies to missing
frames within a clip.

NOTE: This control only affects the current Viewer.

Crop to
Format

Enable or disable cropping when viewing sequences. When enabled, areas
outside the Format guide are cropped automatically.

Clipping Enable or disable Hiero’s clipping warning tools:

• No Warnings - all clipping warnings are disabled.

• Exposure - alerts you when the image is under (blue) or over (red) exposed.

• Hot PAL Colors - alerts you when the image chroma is too low (blue) or high
(red) for PAL formats.

• Hot NTSC Colors - alerts you when the image chroma is too low (blue) or high
(red) for NTSC formats.

View Select the Viewer display mode, for exampleAudio and Video orVideo Only.

Obey Alpha Allows you to control the alpha channel independent of the ViewerBlend Mode.

• Enabled - any alpha channel present in the image is treated as premultiplied
transparency.

• Disabled - the alpha channel is ignored.

Audio latency Sets the audio latency, in milliseconds, for the current Viewer only. Audio latency
allows you to correct audio and video synchronization by changing the point at
which audio playback starts.

Positive values cause the audio track to start earlier in relation to the video track,
and vice versa.

n/a Pan On Mac and Windows, hold Alt and drag the image to pan. On Linux, use
middle-click and drag to pan.

Playback Tools
The playback tools manipulate the media itself, in much the same way as other editing or playback software.
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The playback tools can be summarized as follows:

• In and Out markers - numerical representations of the clip In and Out markers, if they’re set.

• Playhead position - numerical representation of the current position of the playhead.

• Frame rate - allows you to force the Viewer to play at a certain speed, within your hardware’s limitations, by
entering the required frame rate in the field provided.

• Display Mode - select the timing method to display during playback:

• Timecode (TC) - displays the timecode read from the clip’s metadata or from the timeline.

• Timeline Frames (TF) - displays the frame number read from the clip’s metadata or from the timeline.

• Drop Frame - is a timecode display option that leaves out two frames from the 30 fps timecode sequence
every minute (except every 10th minute) so that long running NTSC sequences are accurate to a real-time clock
(NTSC frame rate is 3000/1001, or approximately 0.01% slower than 30 fps).

NOTE: EnablingDrop Frame is a Timecode display feature only - the source media remains a continuous
stream of frames.

• Playback Controls - standard media playback controls including continuous or by frame forward and backward,
skip to next or previous edit, skip to start/end of the timeline, and Frame Increment.

The J, K, and L hotkeys also control playback. TheK hotkey is mapped to Pause/Play and JL to backward and
forward. Combinations are also supported:

• K+J - frame backward.

• K+L - frame forward.

• K+drag in the top third of the Viewer - standard jog controls. Dragging the cursor left and right moves the
playhead backward and forward, frame-by-frame.

The jog controls also detect rotary motion to jog through frames. Clockwise motion in the top third of the
Viewer, while holding K, advances the playhead and vice versa.

• K+drag in the middle third of the Viewer - standard shuttle controls. Dragging the cursor left and right plays
backward and forward, with increased frame rate toward the edges of the Viewer.

• K+drag in the bottom third of the Viewer - skips the playhead to absolute timeline position.
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The following table describes playback behavior depending on the Playback Mode selected.

Mode Description In/Out Effect

Repeat Play through from start to finish in an infinite loop. Repeats within the In-
Out Points.

Bounce Play through from start to finish then reverse to the start and repeat. Bounces within the In-
Out Points.

Stop Play through from start to finish then stop. Play through to the
Out Point.

Continue Play once through all media in the Viewer sequentially. In-Out range has no
effect.

• Volume - controls the playback volume for the current Viewer.

NOTE: If the video frame rate is unavailable, no audio is output. The speaker icon under the Viewer
changes to the no audio playback icon if this is the case.

TIP: You can also control volume on a per track and per track item basis. See Audio and the Timeline for
more information.
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Caching Frames in the Playback Cache

Hiero and HieroPlayer’s playback cache places frames in RAM for rapid retrieval during playback, rather than copying
the source files locally as with Caching Media Locally.

The green bar under the Viewer represents the contents of the playback cache, a full bar indicating that the entire clip
or timeline is currently accessible from RAM, optimizing playback. You can:

• Temporarily disable caching using the pause button above the Viewer, or use the P hotkey.

Clicking pause again, resumes caching from the playhead position.

• Flush the cache completely by navigating to Cache > Clear Playback Cache. Caching is automatically paused after
flushing, but clicking the pause button resumes caching from the playhead position.

There are also a number of Preferences that affect how much RAM is available and when caching should occur. To
set the caching behavior:

1. Navigate to Hiero (HieroPlayer) > Preferences (OS X) or Edit > Preferences (Linux and Windows),

OR

Use the Preferences hotkeys Shift+, (comma).

2. Click the Performance sub-menu.

3. Set the total RAM cache available using the Playback cache size field.

NOTE: You can't set this to a value higher than 80% of the memory available (rounded down to the
nearest half-GB). For example, if you have 6 GB of memory available, the maximum cache size available
4.5 GB.

4. Enable Pause decoding when the application goes to the background to pause playback caching when
the application loses focus.

When you click back into Hiero or HieroPlayer, caching picks up from where it stopped.

5. EnableClear cache when the application goes to the background to flush the playback cache when the
application loses focus.

When you click back into Hiero or HieroPlayer, caching starts again from the position of the playhead.

Mac OS X Specific Controls

Mac OS X handles memory differently to Linux or Windows and, as a result, these controls can improve
performance:

1. Enable Lock cache into memory so that the operating system doesn’t swap out the memory allocated for the
playback cache.

This settings can improve playback performance, but reduces the amount of memory available to run other
applications.
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NOTE: Cache locking is enabled by default.

2. EnablingUnlock cache when application is in background can improve system performance by allowing
other applications to use the reserved system RAM when the application is running in the background.

Bear in mind that when the application becomes active again, there may be playback delays while the cache
memory is swapped back in.

NOTE: Cache release is enabled by default.

Using In and Out Markers

In and Out markers enable you to alter the duration of a clip to just the portions of the source that you require.

When a clip containing In and Out points is added to a timeline, you can slip the clip around the markers to adjust the
clip’s output. See Timeline Editing Tools for more information.

You can also use In and Out points to export certain portions of a clip or sequence. See Transcoding for more
information.

To set In and Out markers:

1. Right-click on the required clip or sequence and select Open In > Timeline View.

Clips opened in a timeline have a purple background in the timeline.

2. Move the playhead to the location of the In point and press I on your keyboard.

The In point is marked by the In tab and the time is recorded in the playback controls.

3. Move the playhead to the location of the Out point and pressO on your keyboard.

The Out point is marked by the Out tab and the time is recorded in the playback controls.

NOTE: You can also set markers by navigating to View > Mark In orMark Out, by using the Timeline
menu to Mark Selection orMark Clip dependent on clip selections on the timeline, or by right-clicking a
track items and selectingOpen In > Viewer.

Click and drag the markers to adjust their position, or hold Ctrl/Cmd to move both markers at once, retaining their
relative positions. A Viewer preview shows the current frame for the selected marker(s) and a timecode/frame popup
helps to set the new position.
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Clear the markers from your clip by navigating to View > Clear In Point (Alt+I) and Clear Out Point (Alt+O). The
markers are removed completely, but you can reapply them by repositioning the playhead and pressing I orO.

When the playhead is positioned near In and Out markers, the top half of the timecode scale controls the playhead
and bottom half controls the markers.

Using the Media Tab

TheMedia tab contains format specific controls dependent on the media currently in the Viewer. If theMedia tab is
not displayed in your workspace, navigate to Window > Media to open it in a floating window.

As an example, .mov files allow you to control theColor Space, YCbCr Encoding, Codec, Pixel Format, and Source
Media for clips:
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See About QuickTime Media for more information on QuickTimes.

R3D and ARRIRAW media, however, use their own software development kits (SDKs) to control the extensive settings
usually seen on RED and ARRIRAW Cameras, as well as the Source Media.

The RED Decode Resolution and ARRIRAW Resolution and Proxy dropdowns control the maximum allowed
Viewer resolution, overriding the Image Quality setting.

When a clip’s resolution is altered using these controls, the resolution displayed in the Viewer is italicized to indicate
that the clip is not displayed at full resolution.

Notes for R3D clips

The following R3D controls have no effect in Hiero’s default 16-bit half-float decoding mode:

• Version (always set to ColorVersion2)

• Shadow

• Contrast

• CustomPDLogBlackPoint, CustomPDLogWhitePoint and CustomPDLogGamma

• RestrictedRange

This list is subject to change depending on the R3D software version in use.

6 USING THE VIEWER | PLAYBACK TOOLS



72

Notes for ARRIRAW clips
• ARRIRAW specific controls do not currently work in LogC colorspaces.

• Generally, theUnsqueeze Anamorphic control should not be enabled because the Hiero, HieroPlayer, and Nuke
Viewers expand the image automatically.

Working with Colorspaces
Colorspace changes are applicable to clips in bins and track items, as well as in the Viewer using theMedia tab.

To apply colorspace changes to clips in bins:

1. Select the clip or clips in the bin view.

2. Right-click a selected clip and navigate to Set Media Color Transform.

The current colorspace is highlighted with a tick mark.

3. Select the colorspace to apply to the clip selection.

NOTE: Only colorspaces applicable to the selection are displayed. For example, REDspace and LogC -
CameraNative are only available for R3D and ARRIRAW clips, respectively.

4. Selecting multiple formats supporting different colorspaces, for example R3Ds and ARRIRAW, breaks the
available LUTs into sub-menus:
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To apply colorspace changes to track items:

1. Select the item(s) on the timeline.

2. Right-click a selected item and navigate to Set Media Color Transform.

3. Select the colorspace to apply to the selection.

Previewing on a Broadcast Monitor
Hiero’s monitor out feature allows you to preview Viewer images on an external broadcast video monitor to check
the final result, including the correct colorspace and aspect ratio. This option requires additional hardware, such as a
monitor output card or a FireWire port.

NOTE: HieroPlayer does not support Monitor Out cards.

Our monitor out architecture interfaces directly with the AJA and BlackMagic device drivers, which are unified across
their respective hardware lines, meaning all current supported cards for the following versions should work:

• BlackMagic: 9.1

• AJA: 3.2 on Mac OS X, 10.5.2 on Windows

We test using a selection of the following hardware :

• BlackMagic: Current BlackMagic Decklink PCI hardware, including Decklink SDK, DeckLink 4K Extreme, and
Ultrastudio SDI Thunderbolt devices (Mac only).

• AJA: Current AJA Kona PCI Family, including Kona 3G, LHi, LHe Plus, and ioXT Thunderbolt device (Mac only).

NOTE: AJA monitor out cards are not currently supported on Linux.

NOTE: On Mac, the AJA Kona 3G is only supported on OS X 10.7 (Lion), or above.
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NOTE: Monitor out on Windows machines with AMD graphics cards is not currently supported.

Some monitor out cards allow you to extend or mirror your desktop so that Hiero’s user interface is visible on the
monitor. Please refer to your card’s documentation for more information.

To preview output on an external broadcast video monitor:

1. Navigate to Window > Monitor Output.

TheMonitor Output toolbar displays in a floating pane.

2. Select the external device you want to use from the output device dropdown. All available devices are
automatically detected and listed in this menu, along with the following default options:

• None - disables the monitor out feed.

• Floating Window - opens up a pseudo output monitor window, without the need for a monitor device and
card. This is intended for full-screen use without displaying any of Hiero’s interface.

3. Select the display format for the device selected in the previous step. The available options depend on the device
you are using.

4. Select the Viewer to feed to the output monitor using the source viewer dropdown. SelectingActive Viewer
always display the current Viewer.

5. Select the view mode using the A/B selection dropdown. All the usual Hiero A/B controls, such as SplitWipe, are
available on the output monitor.

6. Click the filter button to apply the active Viewer’s filtering, gamma, and gain to the monitor output.

7. Click the flip button to flip the output vertically.

8. Click the range button to switch between full-range 0-255 (default) and 16-236 (ITU-R BT.610-4). This
button can correct the image output for certain monitor out cards.

9. Click the bit-depth button to toggle between 8- and 10-bit monitor output.

10. Select the colorspace to apply to the image, rec709 in the example shown previously. If you’ve specified an
OCIO configuration file in Preferences > Viewers, these custom LUTs are also applicable.

NOTE: If you plan to use the OCIO config file specified in Hiero or HieroPlayer, ensure that the
Preferences > Color Management > Use OCIO nodes when exporting in Nuke checkbox is
enabled.
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Using Scopes
Hiero and HieroPlayer provide realtime scopes to help you evaluate your media. Realtime scopes provide data as the
Viewer plays your clip, but you can also view the scopes frame by frame if you prefer.

Histogram

TheHistogram provides three color channel and luma channel information that describes the distribution of red,
green, blue, and luma pixels throughout the current frame.

The Histogram graphs the number of pixels at each brightness level, and from left to right, the areas of the
Histogram represent shadow, mid tones, and highlights.

There are also Viewer and Channel selection controls on theHistogram tab:

• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Histogram output to
the required clip.

The default value,Active Viewer, automatically displays details on the last Viewer you selected.

• Channel selection - select the channels to output. The default setting displays RGB, but you can also view
channels separately.

• Mode selection - select the mode to output. The default setting displays ganged RGB, but you can also view the
channels separately.

The scopes feature global customizable guides to help you view your clips. Navigate to Hiero (HieroPlayer) >
Preferences > Scopes (OS X) or Edit > Preferences > Scopes (Linux and Windows) and enter values between 0
and 1 for theBlack and White points. Note that this also sets the values for the Waveform display.

The guides at the edges of the Histogram turn red to warn you when the distribution is out of range:
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Waveform

TheWaveform scope provides information on clip luminance, or brightness, which you can use to decide whether
the clip is over or under exposed. The white traces represent luminance values from 0 - 100% (black through the
spectrum to white). The higher the waveform, the brighter the image in the Viewer.

The upper white marker is used to measure when over exposure could be a problem. If your waveform has a lot of
traces over the white marker, you should consider reducing the brightness of the clip. The opposite is true of the
lower black marker.

There are also Viewer and Mode selection controls on theWaveform tab:

• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Waveform output to
the required clip.

The default value,Active Viewer, automatically displays details on the last Viewer you selected.

• Channel selection - select the channels to output. The default setting displays RGB, but you can also view
channels separately.

• Mode selection - select the mode to output. The default setting displays ganged RGB, but you can also view the
channels separately.

The scopes feature global customizable guides to help you view your clips. Navigate to Hiero (HieroPlayer) >
Preferences > Scopes (OS X) or Edit > Preferences > Scopes (Linux and Windows) and enter values between 0
and 1 for theBlack and White points. Note that this also sets the values for the Histogram display.

The guides at the top and bottom of the Waveform turn red to warn you when the distribution is out of range:
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Vectorscopes

Vectorscopes display color, saturation, and hue information for the current frame. Similar to color wheels,
Vectorscopes display information radially, from the center outward. The farther from the center the data spans, the
more saturation is represented.

In the image on the left, you can see that the frame represented contains mostly blues and cyans, but the values are
not oversaturated. The image on the right represents a badly saturated frame. Notice the spill of cyan traces
distributed toward the edge of the scope pass the target (the highlighted square).

Normal saturation. High Saturation.

There is also aViewer selection control on theVectorscope tab:

• Viewer selection - if you have multiple Viewers open, use the dropdown menu to associate Vectorscope output to
the required clip.

The default value,Active Viewer, automatically displays details on the last Viewer you selected.

About Anamorphic Media
The Viewer automatically recognizes anamorphic clips and displays them with the correct aspect ratio.
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If for any reason you want to display an anamorphic clip with a 1:1 aspect ratio, right-click in the Viewer displaying
the clip and enable the Ignore Pixel Aspect checkbox, or use theCtrl/Cmd+Shift+P hotkeys.

About QuickTimeMedia
Working with .mov files can be unpredictable when compared to other formats, so Hiero and HieroPlayer give you a
few QuickTime options when reading and writing .mov files.

Hiero attempts to select the ’best fit’ combination by reading an extended list of metadata key/value pairs from the
QuickTime header, including nclc atom, gama atom, and ProRes codec headers.

If you place a clip in the Viewer or select a track item on the timeline and open theMedia tab, you'll see that Hiero
has a number of controls that you can manually override if the 'best fit' is not what you're looking for:

• YCbCr Matrix - sets the way Y’CbCr is converted to RGB. You can choose to use the new Rec 601 and Rec 709 or
the Legacy encoding methods, which are the methods used previously in Nuke and Hiero.

• Codec - sets the codec used to read (write already had a similar control) the QuickTime file.

6 USING THE VIEWER | ABOUT QUICKTIMEMEDIA



79

The codec dropdown defaults to a codec appropriate for the QuickTime in question, where available, and only lists
those that declare themselves able to read the file.

• Pixel Format - sets the read and write pixel format, which includes bit depth, colorspace, pixel packing, and ranges.

This setting defaults to the best format accepted by the codec, allowing Nuke to perform the conversion to RGB
without the use of an unknown QuickTime transform, where possible. RGB pixel types rely on QuickTime to do the
conversion from Y’CbCr when dealing with a non-RGB codec.

In addition to thenclc, gama, and ProRes data Hiero, and by extension Nuke, also write additional metadata into
the file headers during export, retaining your QuickTime preferences. This combined metadata represents myriad
potential QuickTimes preferences, so Hiero and Nuke read the available metadata in the following order, reverting
down each level as the level above is unavailable or set to a reserved or unknown value:

• The Foundry specific metadata

• ProRes header data

• nclc atom data

• gama atom data

• The defaults associated with the chosen codec

In this way, the worst case scenario is that you end up with the chosen codec class' default values. See Export
Management for more information on writing files.

About REDMedia
When working with RED clips, using a RED Rocket card can increase the rendering speed significantly, especially at
higher resolutions.

NOTE: The RED Rocket icon is only visible if you have a RED Rocket installed.

The RED Rocket icon has three states:

Inactive - the RED Rocket card is inactive.

Firmware error - there is a problem with the card firmware. Hover the mouse over the icon for more
information.

Active - the RED Rocket card is present and active.

To modify the RED Rocket options:

1. Click the icon in theViewer.
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NOTE: You must haveUse RED Rocket enabled in the Preferences dialog to access these options. See
Workspace Preferences for more information.

TheRED Rocket Settings dialog displays.

2. Temporarily disable the RED Rocket card by deselectingUse RED Rocket card. Unlike the option in the
Preferences dialog, changing this setting does not affect the application at startup.

3. Click OK to save your settings.

NOTE: Projects containing large amounts of movie files (for example .r3d and .mov) may exceed the
number of available file handles per process, causing problems opening new files or projects and
exporting.
You can increase the default limit of 1024 by entering the following command from the terminal, then
running Hiero from the same session:
ulimit -Sn 2048

Using RMD Look Files

RED metadata files, or RMDs, are designed to contain grade information for R3D clips. You can automatically create
RMDs for all files, or create RMDs manually for specific clips. RMDs reside in the same folder as the source R3D clip.

Automatic RMDs

The Preferences dialog contains an option to automatically create RMDs for files as you make changes to the RED
Look.

NOTE: When Automatically save RMD files is enabled, all changes you make to RED Look settings are
added to the RMD file, overriding any metadata that was present.

To enable Automatic RMDs:

1. Navigate to Hiero (HieroPlayer) > Preferences > General (OS X) or Edit > Preferences > General (Linux and
Windows),

OR

Use the Preferences hotkeys Shift+, (comma).

The Preferences dialog box displays.
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2. Select Automatically save RMD files and click OK.

Manual RMDs

Sometimes in your workflow, it’s not practical or necessary to constantly save RMDs for all your clips. You can create
individual RMDs using theMedia tab.

1. Modify the RED Look parameters as required.

2. Right-click in theMedia tab Effect panel and select Clip Options > Save RMD.

An RMD file is created in the same folder as the source clip.

Synching to VBlank on Linux
Hiero and HieroPlayer automatically account for tearing that can occur due to NVIDIA and OpenGL issues on Linux,
but with dual screen setups, you need to specify which screen to synchronize. The __GL_SYNC_DISPLAY_DEVICE
environment variable enables you to specify the synch device by appending the screen device name to the variable.

To determine your screen names:

1. From the console, enter:
nvidia-settings

TheNVIDIA X Server Settings dialog box displays.

2. Open up theGPU dropdown to display the screen device names.

3. Make a note of the device names, for example,DFP-0 or CRT-1.

Set the __GL_SYNC_DISPLAY_DEVICE environment variable value to the device name as described in Setting
Environment Variables.
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7 Using Tags
Tags are used by Hiero and HieroPlayer to quickly sort or filter clips and track items for better
visibility, organization, and export.

Introduction
Tags are used to mark shots of a particular type or content as you organize your project. The default tags supplied
includeApproved,Notes, Reference, and other general purpose tags. You can also create custom tags by right-
clicking in the Tags tab or by pressing Ctrl/Cmd + Y. You can apply tags to clips, track items, individual frames,
sequences, and tracks.

Clip and track item tags and notes can be added to exports using Hiero’s burn-in feature. See Adding Burn-in Text to
Exports for more information.

Using Quick Tags
Quick tags allow you to add tags, depending on context, by right-clicking a selection and then choosing the type of
tag to apply. If you’re tagging a large amount of media, you might find it more convenient to use the drag-and-drop
methods described later on.

Quick tags are accessible from bins, spreadsheets, Viewers, and timelines for single or multiple selections.

1. Select the target clips or sequences.

2. Right-click a highlighted selection, go to Tags, and choose the required action, dependent on context.

For example, bin items only allow you to Tag Selection, whereas track items allow you to Tag Shot Selection,
Tag Tracks, or Tag this Sequence

Once you’ve selected the tag type, theAdd Tag dialog displays.
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3. Select the icon to represent the tag using the Icon dropdown.

4. Enter aName and Note as required.

5. Click Add to mark your selections with the chosen tag.

See Creating Custom Tags and Removing Tags for more information.

Tagging Using the Viewer
To apply a tag using the Viewer:

1. Click the Tags tab, or navigate to Window > Tags.

The Tags tab displays.

2. Drag-and-drop the required tag from the Tags tab to the Viewer.

Depending on whether you’re looking at a clip or sequence, drop the tag on Tag this frame, Tag whole clip, or Tag
whole sequence as required.

Tags applied to frames appear above the playback tools in the Viewer timeline.
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TIP: You can useAlt+Shift+ , (comma) or . (period) to skip to the previous or next tag on the current clip.
You can also reposition tags by dragging them along the Viewer timeline.

Tags applied to entire clips or sequences appear above the Viewer, next to theA/B layout dropdown.

Tagging Track Items
To apply a tag to a track item on the timeline:

1. Click the Tags tab, or navigate to Window > Tags.

The Tags tab displays.

2. Drag-and-drop the required tag from the Tags tab to the timeline.

Depending on where the tag is dropped, you’ll mark a track item (or items if you make multiple selections) or a
track.
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Tags applied to track items appear on the right of the selected item(s) on the timeline.

Tags applied to tracks appear in the track header on the left of the timeline.

Adding Notes to Tags

In some cases, a simple tag on a frame or clip may not contain all the information that you wish to pass on to the
next stage of production. Adding notes to a tag can provide that extra detail.

WARNING: To delete a note, don’t click the - button because this refers to the tag. Instead, simply delete
the notes in the window and click outside the note dialog.

1. Add notes to tags by clicking on the required tag and entering text or editing the metadata keys and values.
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The example shows a note and metadata key “Artist” added to a clip tag, but you can add notes to frame and
timeline tags in the same way.

2. Click outside the dialog to save the note.

Hiero and HieroPlayer allow you to “hide” tags using the Python API. Hidden tags are not displayed in the interface,
unless you enable Show Hidden in the Tags popup, but the notes and metadata are still accessible.

Navigate to Help > Python Dev Guide for more information on creating hidden tags.

Filtering and Flagging Media Using Tags
You can search for clips containing certain tags, for example, if you wanted to find all clips that you tagged as
Approved.

There are two types of tag search you can perform: Filter and Flag. Select the desired search type by clicking the
magnifier icon in the Project tab.

• Filter - displays all objects that contain the specified tag. This is the default search method.

• Flag - displays all objects and marks the items that don’t match the search tag.

Drag the required tag from the Tags tab into the search box and select the bin or bins you want to Filter or Flag.

TIP: If you have more than one search criteria, click the icons in the search box to display a brief
description of the icons.
Filters and flags persist until you change the search criteria or click the x icon in the search box.
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The following examples show Filtering a bin to display only clips with theNotes tag applied and Flagging all clips
that don’t have theNotes tag applied.

Filtering... ...Flagging.

Creating Custom Tags

You may find that you require a specific tag or suite of tags that are not provided by default. Creating custom tags
allows you to really control the organization of your media, and you can even create your own tag icons.

NOTE: Custom tags can only be created in the Tags tab.

To create a custom tag:

1. Click the Tags tab, or navigate to Window > Tags.

2. Select your project and navigate to Project > New Tag, or press Ctrl/Cmd + Y.

The new tag is placed in the selected project.

3. Double-click the tag to open the Edit Tag dialog box.

4. Click the Icon dropdown menu to select an icon for the custom tag.

TIP: You can import your own image for the tag by selecting Custom to open the browser.

5. Enter a description for the tag in theName field.

6. Click OK to save your changes.

Removing Tags

To remove a tag from a frame or clip, click the tag and then click .
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You can remove all tags from a clip or selection of clips by right-clicking your selections in the bin and choosing Tags
> Clear Tags.

To remove a tag from a track or track item, click on a tag icon and select the required tag to remove.

Click to remove your selection.
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8 Viewing Metadata
Metadata is information that describes media content, separate from the clip itself, in the form of a
table on the Metadata tab. Types of metadata include Duration, File Size, and the Path to the
location of the source media.

Clip and Track ItemMetadata
To view metadata for a bin clip, right-click the clip and select Open In > Metadata View, or pressAlt+D.

To view metadata for a track item, select theMetadata tab in the timeline pane and click on the item to examine.
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Filtering and Flagging Media Using Metadata
If searching your project using tags has not filtered your media effectively, you can search for clips containing certain
metadata. For example, if you wanted to find all clips that had a particular resolution or frame rate.

To filter or flag using metadata:

1. Right-click the clip that contains the required metadata key and select Open In > Metadata View, or press
Alt+D.

2. Drag-and-drop the required key from theMetadata pane to the bin view search box.

3. Use the metadata key as a filter or flag as described in Filtering and Flagging Media Using Tags.
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9 Conforming Using Hiero
Conforming describes the process of matching up the footage from a shoot with the required edit
decisions to create a meaningful timeline.

Introduction
Hiero accepts sequences either from edit decision lists (EDLs) or Final Cut Pro XML files from a specified directory
structure containing the source media files. Hiero attempts to conform the media, warning you if there are missing
media.

Hiero conforms EDLs into single tracks, and XMLs into multi-track timelines. You can either conform into a brand
new timeline, or into an existing timeline by adding new tracks. For example, when conforming multiple EDLs into
the same timeline, you would add new tracks for each EDL sequence conformed.

NOTE: HieroPlayer does not support any Conforming functionality. If you need to work on conformed
sequences in HieroPlayer, import a Hiero project and select File > Save as Player Project to make it
editable in HieroPlayer.

Project Settings
A good place to start work is by defining default Project Settings before importing sequences, particularly in the
case of EDLs as they may not contain frame rate information. Project Settings only apply to the current project
and override Preferences settings.

NOTE: You can modify Project Settings later on, for example, when you’re ingesting media.

To define Project Settings in Hiero or HieroPlayer:

1. Navigate to Project > Edit Settings.

The Project Settings dialog displays.

2. Click theGeneral sub-menu to set the project Name.

3. Click the Sequence sub-menu to set the default timelineOutput Resolution, Frame Rate, and Start
Timecode.

4. Click theColor Management sub-menu to manage the display and file colorspaces for the project.
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5. Use the dropdown menus to define how clips in the Viewer, thumbnails, and so on are displayed.

6. Check Use OCIO nodes when exporting in Nuke to force Nuke to use the LUTs read from the OCIO config
file specified in Hiero or HieroPlayer, rather than the Nuke native LUTs. This adds the relevant OCIO nodes to the
script on a per project basis.

Enable this option in the Preferences to apply it to all new projects.

7. Click theRED Settings sub-menu to define theDefault Video Decode Mode for R3D files.

The dropdown contains a sliding resolution scale from FullPremium to SixteenthGood, but bear in mind that
higher resolutions are slower to decode.

8. Lastly, click the Export/Roundtrip sub-menu to create the locked Project Shot Template in the Export dialog.

Hiero and HieroPlayer rely on this locked template when you select Open in Nuke. For more information on
shot templates and tokens, see Using the Shot Template.

NOTE: HieroPlayer is limited to editing the External Media Track Name as there is no support for
creating shot templates in HieroPlayer. You cannot useOpen in Nuke if the project was created in
HieroPlayer.

You might also consider setting performance, caching, and localization behavior at this point, though the defaults
may suit your purposes:

• Performance - sets the number of threads used for disk reads and decoding, either globally or on a per format
basis. See Optimizing Read and Decode Performance for more information.

• Playback cache size - sets the percentage of total memory available for use as cache. See Workspace Preferences
for more information.

• Max localized files - sets the maximum space available for localized caching. See Caching Media Locally for more
information.

• Localize from and to - sets the working directory that is automatically cached on ingest and the local directory
where cached files are stored. See Caching Media Locally for more information.

Importing Sequences
Hiero allows you to import your EDL or XML sequences in one of two ways, depending on your preferences.
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NOTE: HieroPlayer does not support importing sequences.

If you’re a menu-orientated user:

1. Navigate to File > Import EDL/XML and use the browser to locate the EDL or XML.

2. Select the file and click Open to import the sequence.

If you’re a more hands-on user:

Drag-and-drop the EDL or XML files directly from a file browser into Hiero.

3. If you’re importing an EDL, bear in mind that there is no guaranteed frame rate information included in the file.

When you import EDLs, an Import Options dialog displays.

4. Select the correct frame rate and use the following check boxes, if required:

• Drop Frame - when enabled, the EDL is assumed to contain drop file information. See Playback Tools for more
information.

• Assume differences in source/destination durations indicate a retime - when enabled, any disparity
between the source clip (Src) and track item (Dst) duration is treated as a retime.

5. Click OK to import.
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After importing the EDL or XML, theConforming workspace displays and the spreadsheet and timeline are
populated with offline clips - media with an unknown location.

NOTE: The Event column represents the clip’s position on the timeline, not its event number from the
EDL.

Notice that clicking entries in the spreadsheet highlights the corresponding track items on the timeline?

The spreadsheet, timeline, and Viewer are linked together when viewing sequences. If suitable screen real estate
exists within the current workspace, double-clicking a sequence forces the associated panes to open automatically.
You can also close all three panes by holding theAlt modifier while closing one of the linked panes.

NOTE: If you imported an XML sequence, you may find that Hiero has automatically matched media for
you.
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Conforming Sequences
Once your EDLs or XML sequence are imported, it’s time to begin the conform process to match the offline track
items in your spreadsheet with the source clips on disk. You can conform sequences by searching on disk or by pre-
ingesting the required clips into Hiero.

NOTE: Projects containing large amounts of movie files (for example .r3d and .mov) may exceed the
number of available file handles per process, causing problems opening new files or projects and
exporting.
You can increase the default limit of 1024 by entering the following command from the terminal, then
running Hiero from the same session:
ulimit -Sn 2048

NOTE: HieroPlayer does not support conforming sequences.

Conforming Using a Browser

To conform a sequence using a browser:

1. After importing a sequence, click Match Media on the spreadsheet and use the browser to locate the source
folder containing the correct media.

NOTE: Match Media can also be used on selected events in the Spreadsheet view.

2. Click Open to display theConform Options dialog box.
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Hiero uses a set of conformRules and file name Patterns to match candidate media files on disk to the events, or
track items, in a sequence:

• Rules - sets the offline media properties to match to the corresponding spreadsheet entry during conform.

Rules that rely on information that doesn't exist in the event or candidate clip are ignored, and some rules
compound others to identify a better match.

Rule Description

Umid Match a file’s unique material ID (UMID) – that is written into the file's metadata on
creation – to the candidate media’s UMID. If either, or both, lack a UMID this rule is
ignored.

RedTapeName Match a RED-style camera reel name from the event to the candidate media name.

RedName Look for a RED-style camera file name in the event that matches the candidate media
name.

ReelName Look for the event's reel name in the candidate's media name.

FullPath Match the event's entire filepath to the candidate media’s entire filepath.

FileName Match only the event's file name (no path) to the candidate media’s file name.

FileHead Match the event's file name head (no path, file extension, or padding) to the candidate
media’s file name.

PartialName Look for the event's name in the candidate media’s name and vice versa.

FolderName Look for the event's name in the filepath of the candidate media.

All rules are enabled by default, but you may occasionally need to disable rules if they cause incorrect matches
between a particular edit and set of source clips.

TIP: Use the Select/Deselect All buttons to quickly enable or disable rules.
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• Patterns - sets the inclusion and exclusion parameters during the conform, separated by spaces. For example,
*mov *dpx would only include or exclude MOV and DPX files.

You could also conform by name, such asBR_Shot*, which would only include or exclude source clip names
starting with that string.

TIP: It’s always a good idea to be as specific as possible with search locations during conforms, but if the
need arises, conformRules and Patterns can save time.

3. EnableAccept best timecode match... to use the nearest source timecode match to conform the event, if no
rules are matched.

4. When Ignore clips with non-overlapping timecodes is enabled, any potentially matching source clip whose
timecode doesn't overlap the track item in question at all is ignored.

5. Check Conform shots that already have media if you want to update all timeline track items. By default,
Hiero doesn’t try to conform events that are not offline.

6. Click OK to begin the conform process.

Hiero attempts to conform the EDL or XML with the selected media.

A dialog box informs you of the success rate once the conform is complete.

Successfully matched media is placed in a new Conform bin in the project.

NOTE: You can display the conform Rules matched for each spreadsheet object by hovering the cursor
over the required entry.
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Conforming with Pre-ingested Media

To conform with pre-ingested media:

1. If your source media has been ingested into Hiero, you can drag-and-drop media from the bin view onto the
Match Media button.

See Ingesting Media for information on getting media into Hiero.

2. Follow theConform Options instructions described previously to complete the conform process.

If you want to conform a single entry in the spreadsheet, drag-and-drop the media from the bin view onto the
required entry in the spreadsheet.

Conforming individual, pre-ingested media doesn’t requireConformOptions because Hiero already knows the
exact location of the media and trusts the decision to replace a track item.
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About the Media Spreadsheet

All events in a sequence are displayed in an easy to read format in the spreadsheet including status, the track it
resides on, length, and the source file location.

After conforming, you can use the spreadsheet to locate bin clips or replace track items in the timeline, as well as
massage timecodes if they are invalid.

The media spreadsheet displays each entry’s current media state:

• - the media was successfully conformed and its timecode is correct.

• - the media was successfully conformed, but the timecode is currently incorrect.

• - the media could not be conformed.

NOTE: Any source or destination field highlighted in yellow indicates that the entry has been rounded
down for display purposes.

See Managing Timelines for more information on importing tracks and reference media.

Sorting and CustomColumns

Hiero’s spreadsheet can be organized in much the same way as accounting spreadsheets:

• Right-click the column headers to display the list of default columns available. Enable or disable each column using
the checkboxes.

• Click the required column to sort the spreadsheet in ascending or descending order, as indicated by the arrow in the
column header.

• Drag-and-drop column headers to reorder the spreadsheet as required.

• Add custom columns, such as Tags, using the Python API. See Hiero’sHelp > Python Dev Guide for more
information.

Spreadsheet Controls

There are also a number of controls, accessed by clicking the cog icon, that determine the spreadsheet’s appearance
and behavior
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• Select Matching Name - when enabled, selecting an item in the spreadsheet highlights all items with the same
name.

• Select Linked - when enabled, selecting an item in the spreadsheet highlights other items linked to it, such as
audio tracks ingested with video tracks.

• Display Speed As - sets the unit used in the Speed column of the spreadsheet. Select either fps (frames per
second) or% (the percentage of the media frame rate).

• Retime method - sets the type of Speed retime applied on the timeline.

• Time Edit Behaviors - sets how source and destination In,Out, and Duration are calculated.

See Retiming Clips for more information on retime methods and Timeline Editing Tools for source/destination
calculations.

You can locate, display, reconnect, or rename track items directly from the spreadsheet.

• Hold Alt and click an entry to move the playhead to the track item’s In point on the timeline.

• Hold Alt and double-click an entry to move the playhead to the track item’s In point on the timeline and zoom to fit
the timeline view.

• Right-click a spreadsheet entry and select the required option:

• Open In - the associated bin clip opens in the selected location, such as a Viewer.

• Project View - the associated clip is highlighted in the bin view.

• Reconnect Media - Hiero attempts to reconnect the media from a specified location on disk, such as when
the source was originally on a drive that is no longer connected.
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• Replace Clip - replaces the selected entry with a specified source clip. Hiero assumes that any source clip you
choose is acceptable, regardless of timecode.

• Delete - deletes the selected entries from the spreadsheet and timeline.

• Tags - allows you to add tags to your selection directly from the spreadsheet view. See Using Quick Tags for
more information.

• Nuke - provides access to the Hiero<>Nuke functionality directly from the spreadsheet. See Round-Tripping
Using Hiero<>Nuke for more information.

Adjusting Timecodes

You can easily adjust single or multiple event timecodes:

1. Select the invalid entry or entries in the spreadsheet.

2. Double-click in the Src In column.

3. Adjust the timecode as required. You can enter absolute or relative timecode values:

• Absolute - absolute timecodes contain eight digits and specify the new timecode for the event, regardless of
the current timecode.

Example Result

01:05:43:21 Sets the timecode at 1 hour, 05 minutes, 43 seconds, and 21 frames

01054321

• Relative - uses + and - values to alter the timecode relative to its current value. You can also useh,m, and s to
denote hours, minutes, and seconds.

Current Position Example Result

01:05:43:21 +1h 02:05:43:21

-110 01:05:42:11

+10000 01:06:43:21

-6m 00:59:43:21

The media changes state to .

NOTE: Timelines start at 01:00:00:00 by default, but you can change this to any value using the
Sequence tab.
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If you’re not sure what the timecode should be, you can:

• Hover the mouse over the target entry in the spreadsheet to view a timecode tooltip.

OR

• Examine the bin clip’s metadata and calculate the correct Src In:

1. Right-click the required entry and select Reveal in Project.

2. Right-click the clip in the bin and select Show Metadata.

The selected clip metadata is displayed in a floating pane.

Renaming Shots on the Timeline
Once you’ve conformed your EDL or XML, you may want to rename track items on the timeline sequentially for
clarity.
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NOTE: If you need to work on conformed sequences in HieroPlayer, import a Hiero project and select File
> Save as Player Project to make it editable in HieroPlayer.

To rename track items:

1. Select the track items to rename using the timeline or spreadsheet view.

2. Right-click on the timeline or spreadsheet and select Rename Shots.

TIP: You can also navigate to Timeline > Rename Shots or use theAlt+Shift+/ customizable hotkey.
Navigate to Help > Python Dev Guide for more information on custom hotkeys.

TheRename Shots dialog displays.

3. Select the rename type from the dropdown:

• Sequential Rename - rename shots sequentially using the Pattern, Start #, and Increment fields.

• Find and Replace - a simple find and replace shot name. All selected shots containing the specified Find
pattern are substituted with theReplace pattern.

• Simple Rename - all shots are replaced by theNew Name specified.

• Match Sequence - allows you to select a sequence to copy shot names from, providing that they use the
same track items. For example, renaming track items on a 30 second timeline to mirror the shot names from a
60 second timeline.

NOTE: You can only use sequences that reside in the same project and track items that have overlapping
frame ranges.

• Clip Name - all shot names are replaced by the name of the source clip they reference. This option can be used
to revert previous rename operation.

4. Rename operations also accept token substitutions. The following tokens are recognized:

Token Resolves to

{clip} The name of the source clip referenced by the target track item.

{event} The EDL event number associated with the target track item.
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Token Resolves to

{fps} The frame rate of the sequence containing the rename target.

{sequence} The name of the sequence containing the rename target.

{shot} The name of the track item.

{track} The name of the track containing the rename target.

5. Enable Include Clips From Audio Tracks to rename audio track items as well as video track items.

6. Click Rename.

The selected track items are renamed as specified.

Saving and Loading Projects
You can save your work as a Hiero or HieroPlayer project using the .hrox file extension.

If you quit the application without saving, you’ll be prompted to save or discard your changes:

Click the required button or pressD forDon’t Save or S to Save.

To save a project:

1. Navigate to File > Save Untitled 1 or Save Untitled 1 As...

OR

Use theCtrl/Cmd+S or Shift+Ctrl/Cmd+S hotkeys respectively.
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The Save Project dialog box displays.

2. Browse to the save location and enter a name for the project.

3. Click Save.

Hiero saves your project to the location specified and appends the .hrox file extension automatically.

NOTE: Projects saved in Hiero are read only when loaded into HieroPlayer. If you want to edit Hiero .hrox
files in HieroPlayer, use the File > Save As Player Project function to create a copy.

To load a project:

1. Navigate to File > Open.

TIP: If you need to open a project that you worked on recently, you can select Open Recent to quickly
locate your work.

OR

Use theCtrl/Cmd+O hotkeys.

TheOpen Project dialog box displays.

2. Browse to the file location and click Open.

Hiero opens your project and populates the necessary panes automatically.

Autosaved Projects

The autosave function creates a temporary save file at 5 minute intervals, but you can adjust theAutosave period
in the Preferences dialog. See Workspace Preferences for more information.

At startup, the application scans for autosaved projects and displays a prompt if autosaves exist.
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Click Yes to load the autosave orNo to ignore and delete it.

Opening a project also uses the autosave functionality. If the autosave is more recent than the saved project file, a
prompt displays:

Click Yes to load the autosave file orNo to load the original project file.

NOTE: ClickingNo does not delete the autosaved project in this case.
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10 Managing Timelines
Timelines contain video and audio track items that reference the source clips in your project. Once
the conform process is complete, the timeline displays your clips in context and enables you make
finer edits.

Introduction
Timelines can contain any number of video sequences and audio tracks with each track containing track items that
reference the source clips in your project - making changes to track items in the timeline does not affect the original
source clip.

NOTE: HieroPlayer does not allow you to edit read-only projects. If you need to edit an imported Hiero
project, select File > Save as Player Project to make it editable in HieroPlayer.

NOTE: Conformed EDLs only support one video sequence. If you’ve created multiple EDLs from the same
edit, you can add each one into the timeline using the right-click Import New Tracks menu or the Import
Track button under the spreadsheet. See Adding Tracks to the Timeline.

• Video Toggle - quickly turn off and on video tracks during playback. Hold Alt and click to solo the selected track.
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• Editable Timecode - manually enter the required playhead position or use the up and down arrow keys or mouse
scroll wheel to increment the playhead position.

• Playhead Position - displays the playhead location synchronized with the contents of the Viewer.

• Timecode - displays the timecode or frame number depending on the Time Display mode selected. You can
adjust the scale using the Scale Slider or by using the mouse wheel.

• Video Tracks - contain all video sequences for the current timeline.

• Audio Tracks - contain all the audio clips for the current timeline.

• Scale Slider - adjusts the scale of the timeline. You can fit the contents of the timeline to the screen space available
by pressing the F hotkey.

• Audio Toggles - quickly mute audio or set the track output during playback to left, right, or mono.

• Track Lock - secure the selected track to disable all editing tools.

TIP: Selecting tracks while holding Ctrl/Cmd allows tools to affect multiple tracks at once, such as locking,
disabling, and resizing tracks.

Video tracks in multi-track timelines are read from the highest number track downward, for example Video 3, Video
2, Video 1. As a result, if video is present on track 3, video on track 2 in the same time slice is obscured.

In this example, although the playhead crosses clips on two video tracks, only the clip in Video 3 is displayed in the
Viewer.

Audio tracks, on the other hand, can be played back simultaneously - all three audio tracks crossed by the playhead
in the example play back together, creating a complete audio backing for the video.

Adding Tracks to the Timeline
You can add empty tracks to existing timelines or import other EDLs or XML edits - effectively another sequence
within the timeline.
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NOTE: HieroPlayer cannot import EDLs or XMLs, but you can add scratch tracks to HieroPlayer projects or
imported, read-only Hiero projects if you resave them using File > Save as Player Project.

To import EDL or XML edits:

1. Select the required sequence in the project bin, right-click, and select Import > New Track(s) from EDL/XML,

OR

2. Click Import Track.

3. Use the browser to locate the EDL or XML files, select the file(s) and click Open to import the sequence.

NOTE: If you’re importing EDLs, bear in mind that there is no guaranteed frame rate information included
in the file. Select the correct frame rate then click OK in the dialog supplied.

4. Conform the new track as described in Conforming Sequences.

To add new tracks:

• Drag-and-drop a clip above or below existing tracks as shown,
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OR

• Right-click in the timeline and select New > New Video Track orNew Audio Track.

NOTE: You can also collapse and expand existing tracks using the right-click menu, and resize the track
header to accommodate longer track names.

Adding Clips to the Timeline
Hiero’s timeline allows you to add clips by simple drag-and-drop from either the Viewer or bins. Using the Viewer
restricts you to a single clip, the current clip, but you can drag as many clips as you like from bins.

NOTE: HieroPlayer does not allow you to edit read-only projects. If you need to edit an imported Hiero
project, select File > Save as Player Project to make it editable in HieroPlayer.

TIP: You can create a new sequence by dragging a clip to an empty timeline pane.
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New timelines pick up their frame rate from the Preferences > Sequence dialog by default. Dropping a clip with a
different frame rate to the sequence preferences on a new timeline displays a warning:

The timeline default frame rate is set by the first clip added to it.

However, if the timeline is already populated and the clip you’re adding doesn’t have the same frame rate as the
timeline, you’re prompted to choose whether the clip’s duration or frame rate is retained.

Take care not to overwrite existing track items - the most recent clip overlays any existing track item. To avoid this,
do one of the following:

• Move the playhead to the target area of the timeline in the record Viewer , load the required clip in a source

Viewer , and then use Insert (N) orOverwrite (M) to place the clip into the timeline at the playhead position
on the lowest, unlocked track available.

NOTE: You can only Insert orOverwrite using clips from the current project.

See Insert, Overwrite, and 3-Point Editing for more information on source/record editing.

• Use theMulti or Move/Trim tools to make space for the new clip and then drag-and-drop it in to the space (see
Using the Move/Trim Tool for more information).
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• Drag-and-drop the new clip at the end of the sequence, then using theMulti or Move/Trim tools,drag the new
clip to an existing transition, hold down theAlt modifier, and drop the clip to Ripple all other track items down the
timeline.

Audio and the Timeline
Audio tracks on the timeline are handled in much the same way as video tracks. By default, linked audio and video
tracks are edited at the same time, but you can lock either track and move them independently or hold Alt to select a
single track, if required.

NOTE: Although you can import and edit multi-channel audio, during playback audio is mixed to 48 KHz
stereo output.

NOTE: Hiero and HieroPlayer do not currently support any QuickTime audio on Linux. Support for audio
on Linux is scheduled for a later release.

When both Viewer inputs contain clips, the audio output is set by the input marker on the overlays. In the following
example, input A is providing the audio output:

The volume slider in the lower right corner of the Viewer controls the output level for that Viewer only.
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Audio output for track items can be toggled between left, right, and mono using the audio toggles in the track
header. Click on the icon to cycle between outputs:

You can also control audio on a per track and per track item basis. Audio track headers and track items have
independent volume controls in the timeline and Properties tab.

• Track headers - click and hold the mute icon on the header to display the volume slider.

• Track items - select an audio track item and click on the Properties tab to display the Volume control.

TIP: You can control the volume on multiple track items simultaneously by holding Ctrl/Cmd and selecting
the required items before adjusting the volume slider.
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The Preferences contain a toggle for audio, allowing you to enable and disable audio playback across the entire
interface as well as control the volume level for all new Viewers. See Workspace Preferences for more information.

NOTE: If the frame rate drops too low, audio is automatically muted and the speaker changes to the no
audio playback icon.

WAV Track Items

Audio can be recorded at the same time as shooting the video or it can be unrelated to the shoot, for example sound
effects or music. You can add .wav clips to the timeline in two ways:

• Drag-and-drop - drag your .wav clip to a timeline audio track and drop it in to place.

• Navigate to File > Import Clips or Import Folders.

TIP: You can also use theCtrl/Cmd+I and Ctrl/Cmd+Shift+I hotkeys.

Use the Timeline Editing Tools to move the clip into place and set its output.

Synchronizing Audio and Video

Hiero and HieroPlayer allow you to massage the synchronization between audio and video tracks using audio latency
adjustment during playback in the Viewer, or by a default amount in the Preferences > Audio dialog.

NOTE: Latency adjustments can take a few seconds to affect the audio track.

1. Mark a portion of the timeline containing the target audio and video track items using In and Out markers.

2. Press or use the L hotkey to begin playback.
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3. Click the Viewer settings icon and increment the latency using the controls in the popup.

4. Adjust the latency until the tracks are in synch.

Using ReferenceMedia
Importing a lower resolution version of your timeline enables you to compare your current timeline against the
reference media to avoid issues with continuity, missed frames, and so on.

To import reference media, click Set Reference Media and use the browser to locate the required file.

NOTE: HieroPlayer does not support Set Reference Media, but you can import reference files manually
and use A/B compare in the Viewer.
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The reference media is automatically imported into Reference tracks, pushing existing tracks outward, and marked
with theReference Media tag.

After importing the reference media, use the show/hide icon to compare the current timeline against the reference
clip. Hold Alt and click to solo the selected track.

Comparing Media

You can drag media from the bin view to the second Viewer input, and use the SplitWipe tool to compare media.

NOTE: Hiero and HieroPlayer currently treat all alpha channels as premultiplied, which can result in the
Viewer background being “added” to the image. If you’re working with un-premultiplied images, set the
Viewer background to Black. See Workspace Preferences for more information.

Alternatively, switch the Viewer to Horizontal mode and click theA/B button to determine the Viewer output using
tracks flags and/or tags.
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The following controls affect the A/B output:

Icon Description

Clear the associated Viewer input.

Set the associated clip’s thumbnail to the current frame.

Swap the A and B inputs.

Automatically places any tagged Reference media on the timeline in Viewer input B.

Click to toggle A/B time synchronization.

The Viewer overlay displays a description of the contents of the A and B inputs, orNo Clipwhen there is no clip at
the playhead, for instance, when there is a gap in a timeline.

The orange triangle in the A/B overlay denotes the clip currently supplying audio and timecode information in the
Viewer.
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Viewing Multi-Format Timelines
Initially, sequences have an Output Resolution applied across all video tracks on a timeline. You can apply this
resolution project-wide through Project > Edit Settings > Sequence or to individual sequences using the timeline
Sequence tab.

In the real world, however, clips are often of different formats so Hiero and HieroPlayer provide clip-by-clip
formatting options to help you standardize sequences more easily.

Reformatting applied to track items on a timeline carries over into any export from Hiero. The reformat options in
the Export dialog are applied after the transforms applied here. See Export Management for more information.

NOTE: Track items default to Resize Type > Width when you change the format of the sequence.

To apply format changes:

1. Select the track item(s) to reformat on the timeline.

2. Click the Properties tab on the timeline pane to display the reformat options.

3. Select the reformat Type from the dropdown:

• Disabled - no reformatting is applied.

• To Format - enables theResize Type and orientation controls.

• Scale - enables the Scale controls.

TIP: You can enable the Format guide in the Viewer controls to overlay the current format as a red box.

4. To Format controls how a clip is resized and its orientation. The following Resize Types are supported:

• None - no resize is applied.

• Width - scale the original until its width matches the format’s width. Height is then scaled to preserve the
original aspect ratio.

• Height - scale the original until its height matches the format’s height. Width is then scaled to preserve the
original aspect ratio.
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• Fit - scale the original until its smallest side matches the format’s smallest side. The original’s longer side is then
scaled to preserve original aspect ratio.

• Fill - scale the original until its longest side matches the format’s longest side. The input’s shorter side is then
scaled to preserve original aspect ratio.

• Distort - to scale the original until all its sides match the lengths specified by the format. This option does not
preserve the original aspect ratio, so distortions may occur.

You can also change the clip orientation:

• Center - centers the clip within the format dimensions.

• Flip - flips the clip the X axis.

• Flop - flops the clip on the Y axis.

• Turn - rotates the clip 90 degrees clockwise.

5. Scale allows you to directly control the size of the clip without changing its aspect ratio.

Use the slider or enter a value in the field provided to scale the clip.

6. You can crop the clip outside the format by enabling Crop to Format in the Viewer controls.

Refreshing and Replacing Track Items
During the post process, media inevitably changes location or form. Hiero can reload or replace your media using the
refresh, rescan, reconnect, and replace functions.

NOTE: HieroPlayer cannot perform theReplace Clip(s) function on read-only projects.

Though all four options deal with reloading track items, each has a particular use dependent on context:

• Reconnect Media - allows you to redirect the filepath when the source file location changes.

• Replace Clip - replaces the selected track item with a specified source clip. Hiero assumes that any source clip you
choose is acceptable, regardless of timecode.

• Refresh Clips (F5) - allows you to reload the track item when the source file location has not changed, such as
when work has been done on the clip offline. Selecting refresh only refreshes the clip’s current frame range.
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• Rescan Clip Range (Alt+F5) - similar to Refresh Clips, above, but rescan also checks for additional frames that
may have been added to the source file and adds them to the track item’s frame range.

• Set Soft Trims - sets the files handles on the selected clip(s). See Setting Soft Trims for more information.

Setting Soft Trims

Soft Trims limit the handles on track items to a pre-defined amount, simulating In and Out points on the source clips,
allowing you to use other timeline tools on the track items such as Slip Clip and Slide Clip.

NOTE: HieroPlayer does not support Soft Trimming.

To set Soft Trims on a track item(s):

1. Select the track item(s) on the timeline.

2. Right-click and select Clip > Set Soft Trims.

The Set Soft Trims dialog displays.

3. Set the number of frames to add to the head and tail of each track item:

• Use full available range - sets the handles to the full extent of the source clip frame range.

• Use Frames - adds the specified number of frames to the head and tail of the track item(s).

4. Click OK to add the specified number of handles.

If the handles requested are not within the available frame range, Hiero displays a warning dialog with a suitable
correction for each selected track item.
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Click Yes to accept, orNo to abort the operation.

NOTE: With track items used in multiple sequences, click Yes to All to accept the correction in all
instances.

Enabling and Disabling Track Items

You can temporarily enable or disable tracks and track items on the timeline to selectively view your media without
removing track item(s), for example if you wanted to view to lower level video tracks within a timeline.

To enable or disable a track or track item(s):

1. Select the item(s) you want to enable or disable.

2. Right-click on a highlighted item and select Editorial > Disable Track orDisable Items to disable the selection.

TIP: You can also use theD hotkey to disable or enable your selection.

Disabled items appear black, and are effectively removed from the timeline.

3. Right-click the item and select Enable Clip to re-enable the clip.

Adding Transitions
Hiero supports basic fade transitions as well as dissolves between track items. Transitions come in three flavors:
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• Fade in - fades in from black on a single track item.

• Fade out - fades out to black on a single track item.

• Dissolve - fades out from one track item and into the next, by merging frames.

NOTE: HieroPlayer does not support adding transitions, though you can edit existing transitions in
HieroPlayer projects.

TIP: Once a transition is in place, it can be nudged in the same way as an edit using theCtrl/Cmd+ßà
hotkeys, providing the required handles exist.

To add a fade transition:

1. Right-click the target track item and select Editorial > Transition > Fade In or Fade Out to add the fade icon.

2. Adjust the fade by dragging the fade icon using theMulti Tool orMove/Trim tool.

To add a dissolve transition:

NOTE: Dissolves must be between track items on the same track.

1. Select theMulti Tool orRoll Edit tool and hover the mouse pointer over an edit between two track items.

The cursor changes to .

TIP: Clicking the edit point displays available handles as a red overlay.

2. Right-click and select Editorial > Transition > Dissolve, or use theCtrl/Cmd+T hotkeys, to add the dissolve
icon to the edit.

3. Adjust either side of the dissolve by dragging the icon, in a similar way to using theMulti Tool orMove/Trim
tool.

Invalid Transitions

Transitions are controlled in a similar way to track items, in that you can drag-and-drop them, but with the following
restrictions:
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• A fade can not be dragged past the ends of the track item it's attached to, and if the item is deleted, the fade is
deleted with it.

• Dissolve ends can not be dragged past the ends of the track items they are attached to, and if both items are
deleted, then the dissolve is also deleted.

If only one of the track items linked by the dissolve is deleted, the transition remains so that another item can be
placed on the other side.

Invalid transitions are colored red on the timeline. In most cases, adjusting the length of the transition should be
enough to correct the error.

Retiming Clips
In addition to transitions, Hiero (and HieroPlayer in writable projects) supports constant retimes on track items.
Decreasing the speed of a track item causes frames to play more than once, whereas increasing the speed skips
frames.

NOTE: Audio is not currently supported for retimes and is automatically muted to avoid playback
problems.

To retime track items using the Speed column in the spreadsheet:

1. Select the required event(s) in the spreadsheet view.

2. Click the cog icon and select the required Retime method:

• Keep source duration - the track item length is altered on the timeline depending on the retime applied.

For example, retiming a track item to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer, and as a
result, the item’s length is doubled on the timeline.

Retiming a track item to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length is halved
on the timeline.

• Keep timeline duration - the track item length on the timeline is maintained regardless of the retime applied.

For example, retiming a track item to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 4, and so on in the Viewer, but the
item’s length on the timeline remains the same, effectively removing the second half of the item.

Retiming a track item to 200% renders frames 1, 3, 5, 7, and so on in the Viewer, but the item’s length on the
timeline remains the same. If no extra frames are available from the source, the item is filled with black frames.

3. Double-click the Speed column and enter the retime value.
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The following example shows a track item and the results of 50% and 200% retimes with theKeep source
duration and Keep timeline duration methods selected.

Notice that theKeep timeline duration method doesn’t change the length of the track item on the timeline and
inserts blank filler frames on the 200% retime?

Original clip

50% Source retime 200% Source retime

50% Destination retime 200% Destination retime

You can also retime track items using the Src,Dst, and Duration columns of the spreadsheet, though the
calculation method depends on the Time Edit Behaviors applied.

1. Select the event(s) in the spreadsheet view.

2. Click the cog icon and select the required Time Edit Behaviors:
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Modify Using Result

Src In Retime Adjusts the event’s Src In and retimes the remaining frames to maintain Dst
Duration.

Before and after a 2 second Src In increase:

Src Out Retime Adjusts the event’s Src Out and applies a retime to maintain Dst Duration.

Before and after a 2 second Src Out increase:

Src Dur Retime Adjusts the event’s Src Dur and Src Out, and applies a retime to maintain Dst
Duration.

Before and after a 50 frame Src Dur increase:

Dst In Retime Adjusts the event’sDst In and retimes the remaining frames to maintain the
relationship between Dst In and Out.

Before and after a 2 second Dst In increase:

10 MANAGING TIMELINES | RETIMING CLIPS



126

Modify Using Result

Dst Out Retime Adjusts the event’sDst Out and retimes the remaining frames to maintain the
relationship between Dst Out and In.

Before and after a 2 second Dst Out increase:

Dst Dur Retime Adjusts the event’sDst Dur and Dst Out, and applies a retime to accommodate the
newDst Duration.

Before and after a 50 frameDst Dur increase:

3. Adjust the values as required to retime the track item(s) by the specified amount.

NOTE: Any source or destination field highlighted in yellow indicates that the entry has been rounded
down for display purposes.

To retime a track item using the Timeline menu:

1. Select the required track item(s) on the timeline.

2. Navigate to Timeline > Retime.

TheClip Speed dialog displays.

3. Enter the required retime value as a percentage.

4. Select the required retime method using the dropdown:

• Keep timeline duration - the track item length on the timeline is maintained regardless of the retime applied.
When increasing speed, if no extra frames are available from the source, the track item is filled with black
frames.

• Keep source duration - the track item length is altered on the timeline depending on the retime applied. For
example, a 200% retime halves the length of the item.

• Anchor current frame - the track item length on the timeline and the current frame’s position are maintained
after the retime. When increasing speed, if no extra frames are available from the source, the track item is filled
with black frames.
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5. Click OK to retime the track item(s).

Using Freeze Frames

The freeze frame feature enables you to create track items of any length using a single frame. To achieve this, the
application takes the first frame of the track item and applies a 0% retime, which is reversible by applying a 100%
retime.

To freeze frame track items:

1. Select the target item(s) on the timeline.

2. Right-click the item and select Make Freeze Frame,

OR

Navigate to Timeline > Make Freeze Frame.

NOTE: Freeze Frames can also be created using the spreadsheet retime modes to modify Src Dur to 0, or
make Src In and Src Out equal.

3. The selection is retimed to 0% and colored blue on the timeline for easy identification.

4. Use theMulti Tool or Slip Clip to set the freeze frame from the available range.

5. Drag the item’s edit points, using theMulti Tool orMove/Trim as required, to set the length of the track item.
There’s no upper limit for the length of a freeze frame track item.
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11 Timeline Editing Tools
The timeline editing tools allow you to manipulate your track items directly in the timeline using a
series of modal editorial tools that complement the Multi Tool. You select the tool you need for the
job and then select a new tool and continue editing.

Introduction
The editing tools in Hiero are grouped for convenience - each tool group contains several tools and you can cycle
between them by clicking the tool or using hotkeys.

NOTE: HieroPlayer does not allow you to edit read-only projects. If you need to edit an imported Hiero
project, select File > Save as Player Project to make it editable in HieroPlayer.

Icon Tools Description

Multi Tool TheMulti Tool’s functionality is equivalent to most of the other tools combined,
but doesn’t require modal tool selection.

Move/Trim TheMove/Trim tool allows you to manipulate the position of a track item or its
output by adding or removing handles.

Select The marquee Select tool allows you to make multiple selections quickly by lassoing
track items. Hold Shift to add to the selection and Alt to subtract from the
selection.

Selection by
Track

The track selection tools allow you to quickly select multiple items depending on the
initial selection. For example, the Select Track to Right tool selects all track items
to the right of the target track item, within a single track.

Slip Clip The Slip Clip tool allows you to shift a track item’s In and Out points by the same
amount and in the same direction, retaining the original duration but altering the
timeline output.

Slide Clip The Slide Clip tool allows you to move a track item in relation to the item before
and/or after the target item, without changing its length or timeline output.
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Icon Tools Description

Roll Edit TheRoll Edit tool enables you to roll a single edit within the available handles,
shortening one track item while lengthening the other, but keeping the overall
duration the same.

Ripple Edit TheRipple Edit tool operates similarly to the trim function of theMove/Trim tool,
except that downstream track items are rippled to automatically close any resulting
gaps in the timeline.

Retime Clip TheRetime Clip tool allows you to trim a track item’s In or Out point and
automatically retime the clip to fill the new track item duration.

Razor TheRazor and Razor All tools allow you to cut track items in to separate parts so
you can remove sections or rearrange items on the timeline.

Join The Join tool can only be used on edit points between two razored track items,
denoted by the yellow arrows at the edit.

The modal editorial tools are mapped to theQ,W, E, R, and T hotkeys when the timeline is the active tab.

NOTE: For a full list of hotkeys, please see Appendix A.

Pressing a hotkey multiple times selects the tools within each mode. For example, pressing E twice, rapidly in
succession activates Slide Clip. Pressing them slowly in succession does not achieve the same result, but instead,
remains on the first item in the menu. This allows you to activate a tool without knowing the current state of tool
selection.

• mapped to Q, cycles through Multi Tool,Move/Trim, and Select.
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• mapped to W, cycles through Track Selection tools.

• mapped to E, cycles through Slip Clip and Slide Clip.

• mapped to R, cycles through Roll Edit, Ripple Edit, and Retime Clip.

• mapped to T, cycles through Razor, Razor All, and Join.

Using theMulti Tool
Unlike the other editing tools available in Hiero and HieroPlayer, theMulti Tool changes function depending on the
position of your mouse in relation to the track item(s) selected.

TheMulti Tool’s functionality is equivalent to most of the other tools combined, but doesn’t require modal tool
selection:

• Move - placing the mouse in the center of a track item activates the tool. Drag the selected track item to the
required position on the timeline.

• Trim - placing the mouse at the left or right of the track item activates the tool. Drag the edit point to the new
position and release the mouse to complete the trim.

See Using the Move/Trim Tool for more information.

• Select - click-and-drag to marquee select clips. Hold Shift to add to your selection orAlt to subtract.

See Using the Selection Tools for more information.

• Slip - placing the mouse at the bottom of the track item activates the tool and displays the slip handles. Drag the
track item to the new position and release the mouse to complete the slip.

See Using the Slip Clip Tool for more information.

• Slide - placing the mouse at the top of the track item activates the tool and displays the slide handles. Drag the
track item to the new position and release the mouse to complete the slide.

See Using the Slide Clip Tool for more information.

• Roll - placing the mouse on the edit between track items activates the tool and displays the handles. Drag the edit
to the new position and release the mouse to complete the roll.

See Using the Roll Edit Tool for more information.
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• Razor - when using the Multi Tool, Razor cuts are menu driven. Navigate to Timeline > Razor Selected orRazor
All to make cuts at the current playhead position.

See Using the Razor and Join Tools for more information.

Using theMove/Trim Tool
TheMove/Trim tool allows you to manipulate the position of a track item or its output by adding or removing
handles. Activate theMove/Trim tool by clicking the tool or pressingQ twice.

Moving Track Items

Click and drag the selected track item(s) to the required position on the timeline. A time count popup, in conjunction
with the snap to edit function, helps you to reposition the track item(s) accurately.

You can also move track items up and down the track hierarchy using drag-and-drop or theCtrl/Cmd+áâ hotkeys.

The following table describes theMove/Trim tool’s modifiers and actions:
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Mode Method Indicator Description

Overwrite drag-and-drop The default move mode. The dragged track item
overwrites any items that are present in the move
location.

Ripple drag then hold Alt and
drop

Drag-and-drop track items on top of other items
without overwriting content - items are pushed down
the timeline to accommodate the move.

Duplicate hold Alt and drag then
releaseAlt and drop

Copy the track item, then drag-and-drop on top of
other items overwriting existing content - items are
not pushed down the timeline to accommodate the
move.

Ripple and
Duplicate

hold Alt then drag and
drop while holdingAlt

Copy the track item, then drag-and-drop items on top
of others without overwriting content - items are
pushed down the timeline to accommodate the
move.

NOTE: On Linux, hold Ctrl+Alt forDuplicate and Ripple Duplicate modifiers.

Action Hotkeys Description

Delete Backspace Delete the selected track item(s) or gap(s).

Ripple
Delete

Shift + Backspace Remove the selected track item(s) and ripple items down stream to
close gaps in the timeline.

NOTE: The ripple effect may not close gaps entirely, because
Hiero does not allow linked tracks to become desynchronized
during rippling.

If you need to nudge track items by just a frame or two, you can select the items on the timeline and press
Ctrl/Cmd+ßà to nudge by one frame in the chosen direction. Press Ctrl/Cmd+Shift+ßà to nudge by the Frame
Increment set under the Viewer.

NOTE: You cannot overwrite other track items on the timeline using the nudge keys.

To Move Track Items Using the Spreadsheet View:
1. Select the required events in the spreadsheet view.
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2. Click the cog icon and select the required Time Edit Behaviors:

Modify Using Result

Dst In Move
Destination

Adjusts the event’sDst In and Out by the same amount, moving the track item’s
position on the timeline by the specified amount, while maintaining Speed.

Before and after a 2 second Dst In increase:

Dst Out Move
Destination

Adjusts the event’sDst Out and In by the same amount, moving the track item’s
position on the timeline by the specified amount, while maintaining Speed.

Before and after a 2 second Dst Out increase:

3. Adjust theDst In orDst Out to move the track item(s) by the specified amount.

Trimming Track Items

Click-and-drag the edit point to the new position and release the mouse to complete the trim.
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TIP: Use theRipple Edit tool, activated by pressing R twice, to ripple downstream track items
automatically.

The Viewer displays the new In or Out point (depending on whether you’re adjusting the beginning or end of the
track item), allowing you to accurately gauge the new output.

NOTE: Trimming multiple track items simultaneously trims each item by the same amount and in the same
direction.

Alternatively, click an edit point and nudge the edit using theCtrl/Cmd+ßà keys or hold Shift to nudge by the
Frame Increment set under the Viewer.

By holding Ctrl/Cmd and dragging an edit, you can add blank frames past the end of the track item’s handles. Blank
frames are coloredred on the timeline for clarity:

To Trim Track Items Using the Spreadsheet View:
1. Select the required events in the spreadsheet view.

2. Click the cog icon and select the required Time Edit Behaviors depending on whether you’re using the In or
Out points or duration:
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Modify Using Result

Src In Trim In Trims the event’s Src In,Dst In, and durations while maintaining speed.

Before and after a 2 second Src In increase:

Src Out Trim Out Trims the event’s Src Out,Dst Out, and durations while maintaining speed.

Before and after a 2 second Src Out increase:

Src Dur Trim Out Trims the event’s Src Dur,Dst Dur, and Src/Dst Out while maintaining speed.

Before and after a 50 frame Src Dur increase:

Dst In Trim In Trims the event’sDst In, Src In, and durations while maintaining speed.

Before and after a 2 second Dst In increase:
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Modify Using Result

Dst Out Trim Out Trims the event’sDst Out, Src Out, and durations while maintaining speed.

Before and after a 2 second Dst Out increase:

Dst Dur Trim Out Trims the event’sDst Dur, Src Dur, and Dst/Src Out while maintaining speed.

Before and after a 50 frameDst Dur increase:

3. Adjust the values as required to trim the track item(s) by the specified amount.

Using the Selection Tools
The timeline editing tools include a marquee selection tool and several context dependent track selection tools.

The marquee Select tool, activated by clicking the tool or pressingQ three times, allows you to make multiple
selections quickly by lassoing track items.

Hold Shift to add to the selection and Alt to subtract from the selection.
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The track selection tools, activated by clicking the tool or by pressingW, selects multiple items depending on the
initial selection:

• Select Track to Right or Left - all track items right or left of the target track item are selected, within a single
track.

• Select All in Track - all track items on the target track are selected, regardless of the item selected.

• Select All Tracks Right or Left - all track items right or left of the target item are selected, regardless of which
track they occupy.

Using the Slip Clip Tool
The Slip Clip tool allows you to shift a track item’s In and Out points by the same amount and in the same direction,
retaining the original duration but altering the timeline output. Activate the Slip Clip tool by clicking the tool or
pressing E.

NOTE: The target track item must have handles to use the Slip tool.
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The Slip Clip tool displays different Viewer previews depending on whether the playhead is on the target track item
or not, but the basic principals are the same.

Click the target clip to display the available handles and then drag the track item to the new position. Release the
mouse to complete the slip.

NOTE: Using the Slip Clip tool does not move the track item on the timeline, only the output is changed.

Alternatively, nudge the slip using theCtrl/Cmd+ßà keys or hold Shift to nudge by the Frame Increment set
under the Viewer.

TIP: If you’re using theMulti Tool, you can nudge using the “slip bar” by clicking at the bottom the track
item.

The following Viewer previews are displayed, depending on the playhead position:

NOTE: The Viewer background always displays the playhead’s current position.

• When the playhead is not currently on the target track item, the Viewer displays the In frame (1) and Out frame (2),
allowing you to accurately gauge the new output.

• When the playhead is on the target track item, the Viewer displays the In frame (1), the current frame (2), and Out
frame (3), allowing you to accurately gauge the output of the track item against the current frame.
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• When the playhead is on the target track item and A/B compare is active, the Viewer displays the target track item
(1) and the reference track item (2), allowing you to synchronize your working track against the reference track.

Slipping Using the Spreadsheet View

You can slip track items using the Src In and Src Out columns of the spreadsheet:

1. Select the required event in the spreadsheet view.

2. Click the cog icon and select the required Time Edit Behaviors depending on whether you’re using the In or
Out point:

11 TIMELINE EDITING TOOLS | USING THE SLIP CLIP TOOL



140

Modify Using Result

Src In Slip Source Adjusts the Src In and Src Out by the same amount, slipping the event while
maintaining speed.

Before and after a 2 second Src In increase:

Src Out Slip Source Adjusts the Src Out and Src In by the same amount, slipping the event while
maintaining speed.

Before and after a 2 second Src Out increase:

3. Adjust the Src In or Src Out to slip the track item(s) by the specified amount.

Using the Slide Clip Tool
The Slide Clip tool allows you to move a track item in relation to the item before and/or after the target item,
without changing its length or timeline output. Activate the Slide Clip tool by clicking the tool or pressing E twice.

The track item either side of the target are shortened or lengthened within the limits of their handles to
accommodate the slide.

NOTE: The surrounding track items must have handles to use the Slide tool.

Click the target track item and then drag it to the new position and release the mouse to complete the slide.

For example, if you slide the target track item (2) five frames to the right, the preceding item (1) ends five frames
later and the next item (3) starts five frames later.

The first image shows a timeline containing three track item, and the second shows the same track items with the
target (2) sliding to the right.
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The Viewer displays the new end point of the previous track item on the left and the new start point of the next track
item on the right, allowing you to accurately gauge the slide.

The two center images (2) represent the start and end frames of the target track item, which don’t change.

Using the Roll Edit Tool
TheRoll Edit tool enables you to roll a single edit within the available handles, shortening one track item while
lengthening the other, but keeping the overall duration the same. Activate theRoll Edit tool by clicking the tool or
pressing R.

NOTE: At least one of the target items must have handles to use theRoll tool.

1. Click an edit point between two track items to display the available handles as a red overlay.

2. Drag the edit to the new position and release the mouse to complete the roll.
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For example, if you roll five frames at the end of one track item (1), the next item (2) starts five frames later. The
first image shows a timeline containing two track items, and the second shows the same items with the edit
point “rolled” to the right.

The Viewer displays the pre-edit track item on the left and the post-edit item on the right, allowing you to accurately
gauge the new position of the edit.

Alternatively, click the edit point between the track item and nudge the edit using theCtrl/Cmd+ßà keys or hold
Shift to nudge by the Frame Increment set under the Viewer.
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Using the Retime Clip Tool
TheRetime Clip tool allows you to trim a track item’s In or Out point and automatically retime the clip to fill the new
track item duration. Activate theRetime Clip tool by clicking the tool or pressing R three times.

Click-and-drag the edit point to the new position and release to complete the trim and retime. For example, trimming
a 50 frame track item to 25 frames retimes the clip to 200%.

Alternatively, click an edit point and nudge the edit using theCtrl/Cmd+ßà keys or hold Shift to nudge by the
Frame Increment set under the Viewer.
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TIP: By holding Ctrl/Cmd and dragging an edit, you can retime past the end of the track item’s handles.

Using the Razor and Join Tools
TheRazor tools allow you to cut track items in to separate parts so you can remove sections or rearrange items on
the timeline. ActivateRazor and Razor All by clicking the tool or pressing R.

Place the cursor on the target track item, and if the cut is permissible, click to razor the track item or all track items
depending on which tool you have selected.

TIP: The Razor cursor indicates whether a cut is permissible or not, such as on existing edits.

You can also apply cuts at the playhead position from the menu bar using Timeline > Razor Selected, or all tracks
using Timeline > Razor All.

TIP: Use theC and Shift+C hotkeys, or the right-click context menu, to perform the respective cuts.

The Join tool can only be used on edit points between razored track items, denoted by the yellow arrows at the edit.

Copying Cuts Between Tracks

TheCopy Cuts function allows you to quickly apply cuts from one track to other tracks on the timeline. For example,
in the timeline shown, you could copy the cuts from the second video track to the Reference audio tracks.

To copy cuts:
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1. Select the track items containing the cuts to copy, or if you intend to copy all the cuts from a track you don’t
need to make a selection.

2. Right-click in the timeline and select Editorial > Copy Cuts.

TheCopy Cuts dialog displays.

3. If you made a selection on the timeline, use the dropdown to select Copy All Cuts or Copy Selected Cuts as
required.

This dropdown is not displayed if no track items were selected.

4. Click the From dropdown to select the source track.

5. Check all the destination tracks in the To field to which you want to copy the cuts.

6. Choose whether or not the resulting track items are named identically to the source track.

SelectingNone retains the destination clip name.

7. Click OK to copy the cuts to the destination track(s).

Insert, Overwrite, and 3-Point Editing
Insert and Overwrite edits are applied at the current playhead position by default, but the use of In and Out points
in the clip Viewer and/or sequence Viewer can give you greater control over the result. 3-point editing, makes use of
In and Out points in the clip Viewer and an In or Out in the sequence Viewer to control where the clip is placed on the
timeline.

Inserting Clips

By default, Insert places the entire contents of the clip Viewer into the timeline at the current playhead position, on
the lowest available track. All track items downstream of the playhead are rippled to make room for the clip. No
items are overwritten or removed.
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Pre-insert timeline Post-insert timeline

NOTE: If the playhead is not positioned at an edit point, or there are track items on other tracks, the
Insert action cuts the track item(s) at the playhead and ripples the cut downstream.
For example, the Post-insert image shows the audio track item being cut and rippled, even though it
doesn’t reside on the same track.

You can select a track before inserting if you don’t want to target the lowest available track. Even if the target track is
empty, track items on all other unlocked tracks are rippled by the same amount.

You can also use In and Out points to control where the clip is inserted and how many frames are included. See 3-
Point Editing for more information.

To insert a clip at the playhead:

1. Navigate to Window > Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .

4. Place the playhead at the required edit point or timecode and select the target track, if necessary.

5. Navigate to Clip > Insert, or pressN, to insert the clip into the timeline.

All track items downstream of the clip are rippled to make room for the duration of the edit.

To insert a clip at an In or Out point:

1. Navigate to Window > Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .

4. Place an In or Out point on the timeline to determine the clip’s position:

• In point - the source clip is inserted so that the first frame is at the In point specified.

• Out point - the source clip is inserted so that the last frame is at the Out point specified.

5. Navigate to Clip > Insert, or pressN, to insert the clip into the timeline.

All track items downstream of the In or Out point are rippled to make room for the duration of the edit.
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Overwrite Edits

Unlike inserting,Overwrite does not incorporate downstream ripple and doesn’t alter the length of your sequence.
Any track items you overwrite are destroyed, though they can easily be recovered from the source clips in the bin
view.

Pre-overwrite timeline Post-overwrite timeline

You can select a track before overwriting if you don’t want to target the lowest available track.

You can also use In and Out points to control what the clip overwrites and how many frames are included. See 3-
Point Editing for more information.

To overwrite at the playhead:

1. Navigate to Window > Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .

4. Place the playhead at the required edit point or timecode and select the target track, if necessary.

5. Navigate to Clip > Overwrite, or pressM, to overwrite from the playhead for the duration of the source clip.

All track items under the source clip are overwritten.

To overwrite from an In or Out point:

1. Navigate to Window > Workspace > Editing to display the 2-up Viewer layout.

2. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

3. Double-click the source clip to load it into the left-hand clip Viewer .

4. Place an In or Out point on the timeline to determine the clip’s behavior:

• In point - the source clip begins overwriting from its first frame at the In point specified downstream for the
duration of the clip.

• Out point - the source clip begins overwriting from its last frame at the Out point specified upstream for the
duration of the clip.

5. Navigate to Clip > Overwrite, or pressM, to overwrite from the In or Out point for the duration of the source
clip.

All track items under the source clip are overwritten.
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3-Point Editing

Setting the output of a source clip and then editing the clip into a timeline at a specific point is sometimes referred to
as 3-point editing. Using this method, you can insert and overwrite edits in an existing timeline or quickly construct
scratch timelines from your bin clips.

Firstly, set the output of your source clip using In and Out points in a clip Viewer, then set the reference In or Out
point on your timeline to determine the clip’s position. Finally, add the clip to the timeline using Insert or
Overwrite.

TIP: You can set both In and Out points on the timeline, but bear in mind that there may be insufficient
source frames for the range specified. If this is the case, blank frames are added and highlighted in red.

You can select a track before editing if you don’t want to target the lowest available track. When inserting, even if the
target track is empty, track items on all other unlocked tracks are rippled by the same amount.

1. Navigate to Window > Workspace > Editing to display the 2-up Viewer layout.

2. Double-click the required source clip to load it into the left-hand clip Viewer .

3. Set the required frame range using In and Out points. See Using In and Out Markers for more information.

4. Double-click your sequence in the bin view to load it into the right-hand sequence Viewer .

5. Set In and/or Out points on the timeline to specify where the clip should be added and use Insert (N) or
Overwrite (M) as required.

As an example, assuming your clip Viewer and timeline are represented by the following image, and the
Overwrite function is used:
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• No In or Out points - insert or overwrite at the current playhead position, for the range currently set in the
clip Viewer.

• In point but no Out point - insert or overwrite from the In point position downstream, for the range
currently set in the clip Viewer.

• Out point but no In point - insert or overwrite from the Out point position upstream, for the range currently
set in the clip Viewer.

• In and Out points - insert or overwrite at the current In point position, for the duration set by the timeline's
In and Out points. If there are insufficient source frames for the range specified, blank frames are added
highlighted in red.
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12 Versions and Snapshots
In addition to the regular project save and restore options, Hiero and HieroPlayer can record the
different states of your workflow as you progress using versions and snapshots.

Introduction
Versions are children of clips. You can have any number of versions per clip as long as they follow the correct
naming conventions, as shown in Using Versions. Versions can only be applied to bin clips and track items and can be
swapped in and out without overwriting existing work.

Snapshots are time-stamped copies of a sequence, allowing you to save its current state without the inconvenience
of saving the entire project. When you restore a snapshot, a warning displays prior to the restore reminding you that
edits since the snapshot was taken are lost. See Using Snapshots for more information.

Using Versions
Versions can be added to clips and track items to allow greater flexibility in your workflow. You can have as many
versions as required and cycle through them quickly using hotkeys.

NOTE: You cannot use versions when a clip is opened as a timeline, that is, by using the right-click Open In
> Timeline View option.

The application relies on specific file naming or folder structure conventions to discover versions:

Convention Description Example

File name constants

Clip name The file name base must remain the same. myClip_v1.0001.dpx

myClip_v2.0001.dpx

myClip_v3.0001.dpx
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Convention Description Example

Version prefix The delineation between the file name and
version information must be either _ (underscore)
or . (period) and remain the same for all versions.

myClip_v1.0001.dpx

myClip_v2.0001.dpx

myClip_v3.0001.dpx

File name variables

Version
padding

The version number padding in the clip name can
be increased or decreased.

myClip_v1.0001.dpx

myClip_v002.0001.dpx

myClip_v03.0001.dpx

Frame padding The frame padding in the clip name can be
increased or decreased.

myClip_v1.01.dpx

myClip_v1.1.dpx

myClip_v1.0001.dpx

Extension The file format is interchangeable. See Supported
Image Formats for more information.

myClip_v1.01.png

myClip_v1.0001.dpx

myClip_v1.mov

NOTE: If the file extension is a movie format, such as .r3d or .mov, the Frame padding can be omitted.

Folder name constants

Root folder The root folder name must remain the same for
all folders containing versions.

~/version/v1/myClip_v1.0001.dpx

~/version/v2/myClip_v2.0001.dpx

~/version/v3/myClip_v3.0001.dpx

Folder name variables

Version
padding

The version number padding in the folder name
can be increased or decreased.

09_WF_Shot004_v1

09_WF_Shot004_v002

09_WF_Shot004_v03
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Versions in Bins

Versions behave similarly in both bins and sequences, and in both cases, you first have to ingest an existing version.

Ingest and locate the versioned clip, then:

1. Right-click and select Scan for Versions to search for available versions.

A dialog box lets you know how many versions were discovered.

2. Use the right-click Version menu to:

• Go to the next Version Up orVersion Down.

• Go to theMinimum orMaximum Versions.

TIP: You can also use theAlt +áâ hotkeys to increment versions or Ctrl/Cmd+Alt+áâ to go to the
maximum or minimum.

When you reach the end of the discovered versions, incrementing the version automatically scans for new
versions that may have become available.

NOTE: You can turn off the auto scan function by navigating to Preferences > General and disabling
Automatically rescan versions...

3. For bin clips only, you can right-click the clip and select Open in > Versions Bin to display all discovered
versions of the target clip.

The versioning conventions may allows clips into the Version Bin that you weren’t expecting. You can disable
versions by selecting them and pressingD or set theActive Version of a clip using the right-click Version
menu.

TheActive Version is the version displayed when you drag the source clip to the timeline, denoted by the
orangeV in the top left-hand corner of the thumbnail.
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4. Once you’ve sorted all the available versions, select a clip in the bin view and press V to display all versions for
that clip in a convenient window.

5. Select the required clip to set theActive Version and apply it to the clip.

Versions in Sequences

As mentioned previously, versions behave similarly in both bins and sequences, but swapping versions in sequences
allows you to compare results more easily.

NOTE: You cannot use versions when a clip is opened as a sequence, that is, using the right-click Open In
> Timeline View option.

Locate the ingested version clip and drag it to the timeline.

• Version Up orVersion Down to increment the version by one.

• Go to theMinimum orMaximum Version.

TIP: You can also use theAlt +áâ hotkeys to increment versions or Ctrl/Cmd+Alt+áâ to go to the
maximum or minimum.

Once you’ve scanned for versions in the bin view, select a track item on the timeline and press V to display all
available versions for that item in a convenient window.

Select the required track item version to set theActive Version.
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Using Snapshots
Within a project you can save the current state of a sequence as a snapshot, including a comment or tag to describe
that snapshot. You can see what snapshots exist for a sequence in the bin view and flip it back to any previously
saved state.

NOTE: HieroPlayer does not support creating snapshots, but you can restore snapshots created in Hiero.

An example workflow might appear as follows:

1. Two snapshots of the sequence (SQ) are recorded after edits. See Creating Snapshots.

2. Snapshot 1 is then restored. See Restoring Snapshots.

3. Further edits are made, then the sequence is recorded as snapshot 3.

Creating Snapshots

To create a snapshot for a sequence:

1. Locate the sequence in the bin view.

2. Right-click the sequence and select Snapshot > Add Snapshot.
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TheAdd new snapshot dialog box displays.

3. Enter a comment, or use the default date and time supplied.

4. Click Add to create the snapshot.

Snapshots are indicated in the bin view with a camera icon containing the number of snapshots available.

Restoring Snapshots

To restore a snapshot:

1. Locate the sequence in the bin view.
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2. Right-click the sequence and select Snapshot > Restore Snapshot.

3. Select the required snapshot from the list.

A warning displays reminding you that edits since the snapshot was taken are lost.

4. Click OK to restore the sequence to the point at which the snap was recorded.
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13 Export Management
This chapter deals with Hiero's shot management and export functionality, though HieroPlayer only
supports round-tripping using Hiero<>Nuke.

Introduction
Hiero’s export suite can automate round-trips through Nuke, send clips back and forth between Hiero and Nuke
using Hiero<>Nuke, transcode, export clip selections from a timeline or bin, write out EDLs and XMLs, or bake out an
entire timeline as a single clip in your required delivery format.

NOTE: HieroPlayer only supports round-tripping using Hiero<>Nuke.

With the addition of Python bindings to perform the same functions, this infrastructure provides a massive amount
of flexibility, whether your pipeline is GUI or command line orientated.

NOTE: Hiero is non-destructive and can slot into your pipeline if you setup your shot template to mirror
the existing file structure.

Hiero ships with several context-sensitive and ad hoc export options:

• Round-Tripping Using the Export Dialog - the process of preparing a project for export and paving the way for VFX
work to come back into Hiero.

• Round-Tripping Using Hiero<>Nuke - enables you to open selections in Nuke scripts, from either bin clips or track
items, add clips and track items to existing scripts, and send rendered Write nodes from Nuke back to Hiero.

• Advanced Send to Nuke - a single clip or bin export option that doesn’t require the Export dialog or Hiero<>Nuke.

• Ad Hoc Exports - an umbrella covering exports that you might not perform on a per project basis, such as EDL or
XML exports.

Round-Tripping Using the Export Dialog
A round-trip describes the process of exporting clips to another application, in this case Nuke, and then paving the
way back into Hiero to conform the new VFX clips.
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Introduction to the Export Dialog

Hiero uses shot templates and processors to perform some export operations, including round-tripping and
EDL/XML creation. The Export dialog controls what is exported and where, and whether or not to expect versioned
clips as part of a round-trip from Nuke.

Two types of Presets are available to construct commonly used export tasks:

• Local Presets - saved in a Task Presets folder using the XML file format. See Running Python During Startup for
more information on save locations and the differences between platforms.

• Project Presets - you can drag-and-drop Local Presets into this panel to save the preset within a project .hrox
file. This option is designed for collaborative work, allowing you to quickly share your export presets.

NOTE: If you select Process as Shots, you’ll notice there is a locked Project Shot Template included in
the Project Presets. This preset can only be edited from the main Project > Edit Settings menu. See
Using the Shot Template for more information.

Hiero also uses Content Presets in all shot templates, enabling you to create commonly used export conditions,
which are then available across all projects. Some presets are only available with certain processors, for example, the
EDL Exporter preset cannot be used with Process as Shots.

You can filter your exports using the Tracks for Export and Tag Filter lists, exporting only certain tracks or track
items marked with a particular tag. See Using Tags for more information.

For your convenience, Hiero ships with a number of ready-made presets, but you can edit these as required:

• Transcode Images - defines transcode parameters allowing you to save your most-used file type conversions.

• Nuke Project File - defines the paths used by Nuke Read and Write nodes during a round-trip.
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• Nuke Write Node - defines the render format for Nuke Write nodes. Add multiple Nuke Write Node presets to
create multiple Write nodes in Nuke.

• External Render - defines the export paths used by third party applications, such as Adobe® After Effects®,
during a round-trip.

The External Render preset functions as a marker in the template so that other tasks can find the location of
external renders and so that you can write your own custom exporters. You can find an example of the marker
function in the examples directory, called FnExternalRender.py, and example custom exporters on Nukepedia
(www.nukepedia.com).

See Running Python During Startup for more information on where to find the examples directory.

• EDL Exporter - used to export a sequence to the EDL format.

• SymLink Exporter - creates symlinks to the location of the source files, rather than making copies.

• XML Exporter - used to export a sequence to XML format.

• Copy Exporter - creates copies of the source files to a specified location, rather than symlinking.

• Audio Export - copies any audio tracks to .wav files in a specified location.

Using the Shot Template

The shot template sets up the folder hierarchy and naming conventions for export processors such as Transcode
Images. Any folders added to the template are created during export unless they already exist, in which case the
export writes to the existing structure.

Hiero ships with default templates for your convenience, but you can quickly create custom templates using folders
and “tokens”, which are replaced with the relevant information during export.

TIP: A useful auto-expansion feature can save time when creating folder structures in the shot template.
Simply type the required folder structure in the first field of the shot template, then press enter to create
the specified hierarchy.

Hiero can resolve the following tokens during export:

Token Resolves to

{ampm} The local equivalent of either AM or PM.

{binpath} The bin structure to preserve. Including this token recreates your bin structure
upto the nearest parent bin.

{clip} The name of the clip used in the shot processed.

{day} The local weekday name, abbreviated to Mon, Tue, and so on.
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Token Resolves to

{DD} The day of the month as a decimal, 01, 02, and so on.

{event} The timeline event number associated with the track item to process.

{ext} The extension of the file to output, such as .dpx or .mov

{filebase} The base of the clip name to process. For example, the filebase of Shot01_
####.dpx is Shot01_####.

{fileext} The format of the clip to process, such as .dpx or .mov

{filehead} The source clip filename not including frame padding or extension. For example,
the filehead of Shot01_####.dpx is Shot01.

{filename} The source clip name of the media to process.

{filepadding} The source filename padding, which you might use for formatting frame indices.

{fullbinpath} The full bin structure to preserve. Including this token recreates the bin structure
upto the project level.

{fullday} The local full weekday name.

{fullmonth} The local full month name.

{hierotemp} The Hiero temp directory as specified in the Preferences.

{hour12} The export start time hour component (12-hour clock).

{hour24} The export start time hour component (24-hour clock).

{MM} The month of the year as a decimal, 01, 02, and so on.

{minute} The export start time minute component.

{month} The local month name, abbreviated to Jan, Feb, and so on.

{project} The name of the parent project of the export item.

{projectroot} The root export filepath as specified in the Project Settings.

{second} The export start time second component.

{sequence} The sequence name to process.

{shot} The name of the track item to process.
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Token Resolves to

{timestamp} The export start time in the 24-hour clock format (HHMM).

{track} The name of the track to process. Exporting EDLs using this token generates a
separate EDL for each track.

{user} The current username.

{version} The string v#, defined by the number (#) set in the Version section of the export
dialog

{YY} The year of the century as a decimal, 01, 02, and so on.

{YYYY} The year, including century.

TIP: After double-clicking the path column, right-click and choose Select Keyword to display a list of
available export tokens, though only valid tokens for the current selection are listed.

Token substrings are valid if you need to extract a certain part of an evaluated string. For example, if {shot} resolves
to JB100, then:

• {shot [0:2] } - resolves to JB

• {shot [-3:] } - resolves to 100

Similarly, anything within the outer brackets is evaluated as a Python string. For example, if {shot} resolves to JB_10_
20, then:

• {shot.split(’_’) [0] } - resolves to JB

• {shot.split(’_’) [2] } - resolves to 20

Example Shot Templates

Hiero’s shot template enables you to create as many Nuke Read and Write nodes as required for a project. A typical
use case might be creating .jpg clips for review and .dpx resolution clips for finishing.
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TIP: A useful auto-expansion feature can save time when creating folder structures in a template. Simply
type the required folder structure in the first field of the template, then press enter to create the specified
hierarchy.

Multi-format Exports

The following example describes how to build a shot template to export a sequence of .mov clips, create .dpx and
.jpg Write nodes in Nuke, and bring the .dpx clips back into Hiero.

1. Set up an export as described in Round-Tripping Using the Export Dialog.

2. In the Export dialog, select Basic Nuke Shot in the Local Presets pane to auto-complete the shot template
with the preset values.

3. Click Duplicate selected preset and give the new preset a name.

4. Rename the renders folder renders_dpx.

5. Select thenuke folder and click the folder icon to add a new folder. Name the new folder renders_jpg.

6. Select the renders_jpg folder and click to add a new entry.

7. Replace the {filename} token with {shot}_comp_{version}.####.{ext}, the same as the existing entry under
renders_dpx.

NOTE: The#### marks represent frame numbers for image sequences. If you were creating .mov clips,
they’d be omitted.

The shot template should look something like this:

8. Click theContent column and select NukeWrite Node.
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NOTE: When using a third party application to produce the VFX work, select ExternalRender instead of
Nuke Write Node.

9. In theNukeWrite Node settings, use the File Type dropdown to select jpeg.

Notice that the settings available change depending on the File Type selected?

10. Click Nuke Project File in the shot template and check that both Write nodes are enabled.

11. Set up the rest of the export as described in Exporting to Nuke and click Export.

12. When complete, locate aNuke Shot Exporter entry in the Export Queue and click the magnifying glass icon to
reveal the Nuke scripts in a browser.

13. Drag the script into Nuke’s Node Graph to display the script.

13 EXPORT MANAGEMENT |



165

Once the VFX work is complete, bring the .dpx clips back into Hiero:

1. Select the original clips on the Hiero timeline.

2. Right-click and select Build Track > From Export Structure.

TheBuild Track From Export Structure dialog displays.

3. Enter a Track Name or use the default VFX.

4. Select the Export Preset used from the dropdown menu. In this case,Dual Render.

5. Enter the filepath of the Export Root directory or click Choose and browse to the location.

6. Select theNuke Write Node (dpx - 10 bit) entry.

7. Click Build to create the VFX track.

Hiero automatically creates the new track containing the .dpx clips.

Adding Burn-in Text to Exports

Hiero can burn-in text during the export process using a simple Nuke gizmo. The gizmo contains controls for the font
style and fields denoting the position of the text.

NOTE: The Font field only accepts the full filepath and name of the font file to use. For example, on Mac
OS X ~/Library/Fonts/Verdana.ttf
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You can mix-and-match the following methods to create burn-in text:

• Enter text manually, what you see is what you get in the burn-in.

• Use any of the tokens valid in the shot template as burn-in tokens. For example:
{shot}_comp

Extracts the shot name from the timeline and appends _comp.

See Using the Shot Template for more information.

• Use metadata from tags applied to clips and track items. For example:
[metadata hiero/tags/Approved]

Extracts the Approved tag from the clip or track item. You can also append note to include any notes associated
with the tag:
[metadata hiero/tags/Approved/note]

NOTE: You must precede spaces and slashes in the tag name with \ \ ( backslashes) to enable Hiero to
process it correctly. For example:
[metadata hiero/tags/Blue\\ Screen/note]

Adding Additional Nuke Nodes During Export

Hiero can include additional Nuke nodes, in any Nuke Project File or Transcode export in the Shot Template, by
simply copying and pasting scripts from Nuke.

You can add nodes to shots, tracks, or sequences, or include them as unconnected ad hoc nodes in the script, filtered
by tags if necessary.

1. In the Export Controls panel, scroll down to theAdditional Nodes control and click Edit.

TheAdditional Nodes Setup dialog displays.

2. Click to add an entry.
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3. Click theApply To field and select what the current entry applies to:

• Shot - the additional nodes are added to the script for each shot in the export.

• Track - the additional nodes are added to the script for each track in the export.

• Sequence - the additional nodes are added to the script for the entire sequence.

• Unconnected - the additional nodes are added to the script, but are not connected to the export node tree.

• None - temporarily disables the current entry.

4. Select the Tags that you intend to use to filter which items receive the additional nodes.

If you want to affect only the Reference track, for example, select the Reference tag. All items without that tag
are ignored.

5. Copy and paste a node from Nuke into the Script panel.

NOTE: If you need more than one node, you might consider creating a Group in Nuke and pasting that
into the Script panel.

6. Click OK to accept the additional nodes.

7. Select theAdditional Nodes checkbox and complete the export process as described later in this chapter.
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Exporting to Nuke

To export to Nuke:

1. Select a sequence in the bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Shots from the Processors list.

3. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot hierarchy.

4. Select theBasic Nuke Shot preset under Local Presets to auto-complete the shot template or select Project
Shot Template to use the Project Settings template.

NOTE: You can build a custom shot template using Path tokens, theContents field, and the folder and
+/- buttons. Simply copy an existing template and edit as required.

Basic Nuke Shot creates a folder for each clip, or shot, containing a plates folder and anuke folder containing
script and renders folders.

The tokens in theBasic Nuke Shot template break down as follows:

• {filename} simply extracts the source filenames as they appear in the file browser.

• {shot}_comp_{version}.nk extracts the track item name for each clip and the version selected in the Export
Controls. For example, Shot01_comp_v03.nk

• {shot}_comp_{version}.####.{ext} appends padding and the specified file extension. For example, Shot01_
comp_v03.0001.dpx

NOTE: See the Example Shot Templates for information on how to use the shot template to create
multiple format Write nodes in Nuke.

5. Click theNuke Project File preset to display theRead Node and Write Node settings.
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6. Check which path from the shot template should be used for the Nuke Read and Write nodes. In this case:

• {shot}/plates/{filename} to resolve to the symlinks during export.

• {shot}/nuke/renders/{shot}_comp_{version}.####.{ext} to resolve the render path where Hiero expects
to find the Nuke files.

7. EnableCollate Shot Timings or Collate Shot Names to create additional Nuke Read nodes in the same script
for clips that would normally be hidden by clips higher up the track hierarchy or clips on the same track with the
same track item name.

NOTE: If you have a Read node selected, you can’t enable theCollate functions.

For example:

• Items on track 1 that would otherwise be hidden by track 2.

Exporting these track items
from Hiero...

...creates a Nuke script for
each track item containing

both clips.

• Two items on the same track with the same shot name.
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Exporting these track items
from Hiero...

...creates this Nuke script.

8. Click theNuke Write Node preset to display the file type settings.

9. Select the file type to render using the dropdown and complete the relevant fields, dependent on the file type
selected.

NOTE: Selectingmov from the dropdown provides additional QuickTime specific controls, allowing you to
choose a codec and YCbCrMatrix. The matrix control enables you to use the new Rec 601 and Rec 709
or the Legacy encoding methods, which are the methods used previously in Nuke and Hiero.

Similarly, selecting exr provides an additional metadata dropdown allowing you to export or roundtrip
selected metadata along with your .exr output.

10. Set the following controls common to all file types:

• Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.

• Reformat - select the required reformatting option to enable the Format dropdown.

• Format - sets the format to render out in Nuke, such as 1920x1080 HD 1080.

Select Custom... to create formats that don’t appear in the list of presets.

• Resize - sets the method by which you want to preserve or override the original aspect ratio:

• width - scales the original until its width matches the format’s width. Height is then scaled in such a manner as
to preserve the original aspect ratio.

• height - scales the original until its height matches the format’s height. Width is then scaled in such a manner
as to preserve the original aspect ratio.
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• fit - scales the original until its smallest side matches the format’s smallest side. The original’s longer side is then
scaled in such a manner as to preserve original aspect ratio.

• fill - scales the original until its longest side matches the format’s longest side. The input’s shorter side is then
scaled in such a manner as to preserve original aspect ratio.

• distort - scales the original until all its sides match the lengths specified by the format. This option does not
preserve the original aspect ratio, so distortions may occur.

• Channels - set the channels to export using the dropdown.

NOTE: The default, all, exports all channels in the image, so any Nuke Read nodes created have auto
alpha enabled by default.

If you want to export a non-standard channel, type the name of the channel into the field manually.

• Write Node Name - if you intend to create more than one Nuke Write node, define the name here. The default,
Write_{ext}, appends the individual Write nodes with the file extension being written. You can, however, use any
of the tokens Hiero recognizes.

• Burn-in Gizmo - when enabled, text burn-in is applied to the media using a Nuke gizmo. Click Edit to define the
information applied during burn-in.

See Adding Burn-in Text to Exports for more information.

11. Set theHandles, if required:

• Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.

• Cut Length - exports only the cuts included on the timeline.

NOTE: Selecting Cut Length allows you to add handles to each clip, up to the maximum available source
clip length.

12. Check Apply Retimes to export any retimes present on the timeline.

13. Set how clip Start Frames are derived using the dropdown menu:

• Source - use the source clip’s start frame.

• Custom - specify a start frame for all clips using the field to the right.

14. Set theVersion number, Tracks For Export, and Tag Filter, if applicable.

NOTE: See Using Versions for more information on how versioning works in Hiero.

15. If you’re using a render farm, select the renderer from theRender background task dropdown.

Hiero requires a Python script to pass exports to your render farm of choice. Scripts must be located in specific
directories, dependent on platform, as listed in Running Python During Startup. If no scripts exist, the dropdown
is disabled.

Some example scripts are included in the Hiero package in the following directories:

• On Mac: /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

• On Linux: /usr/local/Hiero1.9v1/Plugins/site-packages/hiero/examples/
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• On Windows: drive letter:\Program Files\Hiero1.9v1\plugins\site-packages\hiero\examples

16. Click Export.

The Export Queue window displays an estimate of how long each component of the export is expected to take.

Once the export is complete, the file structure specified in the shot template is created. You can then import the
Nuke clips on a separate track when they’re ready.

TIP: Click the magnifying glass icon to reveal the exported file in a browser window.

When clips are exported from Hiero, they are marked with a Nuke tag flagging which clips have an export
history. Clips tagged in this way can be used to build VFX tracks quickly as described in building Tracks From
Export Tags.

Building VFX Tracks

When the compositing work is complete, the clips are ready to re-ingest. The shot template defines where the Nuke
files reside, so all you need to do is instruct Hiero to build Tracks From Export Structure.

Alternatively, if you have a history of rendered VFX clips, different versions and so on, you can also build Tracks From
Export Tags to select from a list of available clips.

Tracks From Export Structure
1. Select the required clips on the timeline and right-click to display the context sensitive menu.

TIP: You may find it easier to select clips in the spreadsheet and then right-click on the timeline.
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2. Click Build Track > From Export Structure.

TheBuild Track From Export Structure dialog displays.

3. Enter a Track Name or use the default VFX.

4. Select an Export Preset using the dropdown menu. In this case, select the same preset used during the export.

5. Enter the filepath of the Export Root directory or click Choose and browse to the location.

NOTE: The root directory is the location entered in Export Towhen exporting the project.

6. Select the content you intend to ingest from the shot template. In this case, theNuke Write Node.

7. Click Build to create the VFX track.

NOTE: Hiero warns you if no selection is made in theContents column.

8. If a clip already exists in any of the target tracks, a dialog displays containing options on how Hiero should
behave.
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9. Select the required option and click OK to proceed.

Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place holders if the clips
are a work in progress.

The clips are automatically updated when work is complete as long as they are saved with the expected name
and location, as specified in the shot template.

Tracks From Export Tags
1. Select the required clips on the timeline and right-click to display the context sensitive menu.

TIP: You may find it easier to select clips in the spreadsheet and then right-click on the timeline.

2. Click Build Track > From Export Tag.

TheBuild Track From Export Tag dialog displays.
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3. Enter a Track Name or use the default VFX.

4. Select the required export tag in the left-hand panel to display tag information in the right-hand panel.

5. Click Build to create the VFX track.

6. If a clip already exists in any of the target tracks, a dialog displays containing options on how Hiero should
behave.

7. Select the required option and click OK to proceed.

Hiero automatically creates a new track containing the VFX clips, if they exist, or offline place holders if the clips
are a work in progress.
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Round-Tripping Using Hiero<>Nuke
Selections in Hiero and HieroPlayer can be opened in Nuke using Hiero<>Nuke, which is an open port between the
two applications. When the connection is established, Hiero<>Nuke “listens” for changes applied to clips, in either
application, and updates them automatically with the latest version.

NOTE: Hiero and HieroPlayer rely on the locked Project Shot Template when you select Open in Nuke.
Navigate to Project > EditSettings > Export / Roundtrip to define the template using the Local Nuke
Roundtrip settings.
HieroPlayer is limited to editing the External Media Track Name as there is no support for creating shot
templates in HieroPlayer. You cannot useOpen in Nuke if the project was created in HieroPlayer.

Once established, the link operates in three distinct ways:

• Open in Nuke - allows you to open your selections in single or multiple new Nuke scripts, depending on context.

• Send to Nuke - sends your selections to an existing Nuke script. This option is only available when a connection to
an open Nuke script has been established.

• Send to Hiero - allows you to send a rendered Write node from Nuke to Hiero, creating a new bin.

Connecting Hiero<>Nuke

To connect Hiero<>Nuke:

1. Navigate to Window > Hiero<>Nuke and then click Start Server to begin “listening” for new Nuke output.

2. Click Install Nuke Scripts and follow the on-screen instructions to edit your init.py file.

The application then installs hiero_tools.py in your .nuke directory.

3. Click OK to dismiss the install dialog and then click Launch Nuke to start the application.

Once the connection has been verified, enable Start server on startup in Hiero or HieroPlayer and Start
connection on startup in Nuke to establish the link automatically in future.

NOTE: Hiero<>Nuke is configured to run between applications on the same machine, but if you know the
address and port number of a remote machine, click Edit Server Address and enter the appropriate
details to connect the applications.

Open in Nuke

Open in Nuke operates differently depending on whether you’re opening clips or track items. Clips are opened
independently, whereas track items are opened with additional nodes to produce a timeline position relative to a
specified master track item.
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To Open Bin Clips in Nuke
1. Select the clip(s) in the bin view.

2. Right-click a highlighted clip and select Open in Nuke.

The selected clips are opened in the Nuke application specified in the Preferences > Nuke / Export > Nuke
Path field.

These selections from Hiero... ...Opened in Nuke

To Open Track Items in Nuke
1. Select the track items in the timeline view.

2. Right-click a highlighted item and select Open in Nuke.

TheOpen in Nuke dialog displays.

3. Select the track item to use as the master, that is, the item to use to create the relative timeline positions of the
other track items.

4. Select the frame range to use from the dropdown menu:

• Timeline - use the frame range occupied by the track item on the timeline.

• Source - use the frame range from the source file.

• Custom - use a custom frame range by entering the required start frame in the field provided.

5. Click OK.
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NOTE: If you haven’t set a valid Project Root, a dialog prompts you for a file path.

The selected track items are opened in the Nuke application specified in the Preferences > Nuke / Export >
Nuke Path field.

These selections from Hiero... ...Opened in Nuke

Hiero also adds a single offline track item to receive the incoming VFX work.

NOTE: If you selected Open each item in its own Nuke instance, in the example above you’d get
three clips, each in a separate Nuke.

Send to Nuke

Send to Nuke enables you to add clips and track items to existing Nuke scripts that are connected to Hiero using
Hiero<>Nuke. Send to Nuke operates similarly to Open in Nuke, in that clips are opened independently and track
items are opened with additional nodes, but they are added to an existing script.

1. Select the required clip(s) or track item(s).

2. Right-click a highlighted item and select Send to Nuke.

A list of available scripts is displayed in the sub-menu.

3. Select the required script to receive the additional items.

Hiero adds the items to the selected script.

Send to Hiero

Send to Hiero enables you to send rendered Write nodes from Nuke back into Hiero using Hiero<>Nuke.

1. Select the required Write node(s) in Nuke’s Node Graph.

2. Right-click a highlighted node and select Send to Hiero.
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The selected files are added to Hiero in a new Nuke bin.

Using Hiero<>Nuke in HieroPlayer

Hiero projects loaded in HieroPlayer are read-only, but Hiero<>Nuke creates a link between the two applications in
the same way.

Because the project was exported from Hiero, important information is stored in tags on the individual track items.
The tags contain the filepath to the Nuke script for each shot as well as the location of the source files and the path
to the VFX clips that don’t exist yet.

Open in Nuke

Open in Nuke enables you to open track items using an existing Nuke script stored in a track item tag using
Hiero<>Nuke.

To Open a Track Item in Nuke
1. Select the track item(s) in the timeline view.

2. Right-click a highlighted item and select Open in Nuke.

The selected track items are opened in the Nuke application specified in the Preferences > Nuke / Export >
Nuke Path field. Each track item is opened in a separate Nuke.

13 EXPORT MANAGEMENT | ROUND-TRIPPING USING HIERO<>NUKE



180

This selection from
HieroPlayer...

...Opened in Nuke

3. Once you’ve completed the VFX work in Nuke, render the clip using the Write node supplied in the script. The
new clip is automatically picked up by HieroPlayer, superseding the placeholder clip.

4. You can create multiple versions of the same clip by incrementing the filepath in the Write node’s Properties
panel:

• Use theAlt+áâ hotkeys to increment the version up and down as required.

OR

• Manually edit the file name. For example:
/renders/BR_SHOT001_FINAL_comp_v02.mov

5. You can create as many versions of a clip as required and cycle through the available files in HieroPlayer to select
the latest version. See Using Versions for more information.

Send to Nuke

Send to Nuke enables you to add a track item to an existing Nuke script that is connected to HieroPlayer using
Hiero<>Nuke. Send to Nuke operates similarly to Open in Nuke, in that track items are opened with additional
nodes, but they are added to an existing script.

1. Select the required track item.

2. Right-click the highlighted item and select Send to Nuke.

A list of available scripts is displayed in the sub-menu.

3. Select the required script to receive the additional track item.

HieroPlayer adds the item to the selected script.

This selection from
HieroPlayer...

...Sent to Nuke

You can create as many versions of a clip as required and cycle through the available files in HieroPlayer to select
the latest version. See Using Versions for more information.
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Advanced Send to Nuke
Hiero provides a single clip or bin Advanced Send to Nuke option along with its other export functionality.

To send a clip or bin to Nuke using Advanced send:

1. Locate the required source clip or bin in the bin view.

2. Right-click the clip or bin and select Nuke > Advanced Send to Nuke.

TheAdvanced Send to Nuke dialog displays.

3. Enter the output script name and location in NukeScriptPath field.

4. If the clips you’re exporting have Soft Trims enabled, check Use Soft Trims to adjust the frame range
accordingly.

5. Enter the Nuke output location in theNuke Write Path field.

6. Select the File Type to transcode to within Nuke. The available transcode options depend on the File Type
selected.

NOTE: Selectingmov from the dropdown provides QuickTime specific controls, allowing you to choose a
codec and YCbCr Matrix. The matrix control enables you to use the new Rec 601 and Rec 709 or the
Legacy encoding methods, which are the methods used previously in Nuke and Hiero.

Similarly, selecting exr provides an additional metadata dropdown allowing you to export or roundtrip
selected metadata along with your .exr output.

7. Set the controls common to all file types as described in Round-Tripping Using the Export Dialog.

8. If you intend to bring the transcoded clips back into Hiero, check Ingest Nuke Output.

9. If your selection requires retiming, choose the retime to apply:

• None - no retimes are applied.

• Add 3:2 Pulldown - converts 24 fps clips to 30 fps clips.

• Remove 3:2 Pulldown - converts 30 fps clips to 24 fps clips.
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• To Timebase - enter the retime to apply as frames per second.

• Speed - enter the retime to apply as a percentage.

NOTE: The 3:2 Pulldown options are only displayed when applicable. See About 3:2 Pulldown for more
information.

10. Click Launch Nuke to send the clip to the Nuke specified in Preferences > Nuke / Export > Nuke Path.

Nuke starts up with Read and Write nodes for each clip incorporating the selected File Type settings and Write
Path.

NOTE: The Nuke script is saved in the directory specified as theWrite Path.

When Ingest Nuke Output is enabled, offline placeholders are added to the bin view. Once the VFX work is
complete, right-click a placeholder and select Refresh Clips, or press F5, to ingest the VFX clips.

About 3:2 Pulldown

3:2 pulldown is the process of converting 24 fps film to 29.97 fps interlaced video and vice versa. Hiero uses Nuke’s
Add and Remove 3:2 Pulldown nodes to achieve this, but only offers the option to do so when the selected clip is 24
or 30 fps.

When adding 3:2 pulldown, the film is first slowed down 0.1% to match the speed difference between 29.97 fps and
30 fps. Then, film frames are distributed across video fields in a repeating 3:2 pattern in order to make 24 film
frames fill the space of 30 video frames per second:

• The first frame of film is copied to 3 fields of video,

• the second frame of film is copied to 2 fields of video,

• the third frame of film is again copied to 3 fields,

• the fourth frame of film is copied to 2 fields, and so on.
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The opposite process is used to remove 3:2 pulldown. Hiero allows you to employ 3:2 pulldown from inside the
Advanced Send to Nuke dialog using theRetime dropdown, or directly from a bin clip by right-clicking and
selectingNuke > Add 3:2 or Remove 3:2.

Transcoding
Transcoding in Hiero can use a specified external Nuke application, HieroNuke, or a specified background render
process to convert one file format to another.

TIP: If you don’t want to use HieroNuke, select the required Nuke application using the Preferences >
General tab as described in Workspace Preferences.

Transcoding a Sequence or Shots

To transcode a sequence:

1. Select a sequence in the bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Sequence and click theContent column to select a format to transcode to using the File
Type dropdown.
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The controls exposed depend on the transcode you’re applying.

3. Complete the File Type specific controls. For example, selecting .dpx exposes thedatatype, timecode, and
edge_code settings.

4. Complete the general controls common to all file types:

• Include Audio - when enabled, any audio tracks are exported alongside the video.

• Colorspace - use the dropdown to set the colorspace to render, such as linear, REDLog, or raw.

• Reformat - select the required reformatting option to enable the Format dropdown.

• Format - sets the format to render out in Nuke, such as 1920x1080 HD 1080.

Select Custom... to create formats that don’t appear in the list of presets.

• Resize - sets the method by which you want to preserve or override the original aspect ratio:

• width - scales the original until its width matches the format’s width. Height is then scaled in such a manner as
to preserve the original aspect ratio.

• height - scales the original until its height matches the format’s height. Width is then scaled in such a manner
as to preserve the original aspect ratio.

• fit - scales the original until its smallest side matches the format’s smallest side. The original’s longer side is then
scaled in such a manner as to preserve original aspect ratio.

• fill - scales the original until its longest side matches the format’s longest side. The input’s shorter side is then
scaled in such a manner as to preserve original aspect ratio.

• distort - scales the original until all its sides match the lengths specified by the format. This option does not
preserve the original aspect ratio, so distortions may occur.

5. Select theChannels to export from the dropdown. The default, all, exports all channels in the image.

If you want to export a non-standard channel, type the name of the channel into the field manually.

6. Select theRetime Method to apply, if applicable.

7. Check Keep Temporary Nuke Script if you require the .nk files after the transcode operation.

8. Enable theBurn-in Gizmo to burn-in text using a Nuke gizmo. Click Edit to define the information applied
during burn-in.

See Adding Burn-in Text to Exports for more information.

9. Specify any Additional Nodes required during export by clicking Edit.

See Adding Additional Nuke Nodes During Export for more information.

10. If you set In and Out points on the sequence, select Range > In/Out Points to export only the specified range.

11. Set theVersion number, Tracks For Export, and Tag Filter, if applicable.

NOTE: See Using Versions for more information on how versioning works in Hiero.

12. If you’re transcoding using a render farm, select the renderer from theRender background task dropdown.

Hiero requires a Python script to pass exports to your render farm of choice. Scripts must be located in specific
directories, dependent on platform, as listed in Running Python During Startup. If no scripts exist, the dropdown
is disabled.

Some example scripts are included in the Hiero package in the following directories:
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• On Mac: /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

• On Linux: /usr/local/Hiero1.9v1/Plugins/site-packages/hiero/examples/

• On Windows: drive letter:\Program Files\Hiero1.9v1\plugins\site-packages\hiero\examples

13. Click Export.

The Export Queue window displays an estimate of how long each component of the export is expected to take.

Once the export is complete, the file structure specified in the shot template is created containing the
transcoded files.

TIP: Click the magnifying glass icon to reveal the exported file in a browser window.

To transcode shots:

1. Select Process as Shots and use the defaults or build a shot template using the Path and Contents fields and
the folder and +/- buttons.

For example:

Creates a folder for each timeline item {shot}, containing a clip {filename} with the required file extension {ext}.

2. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot hierarchy.

3. Complete the File Type specific and general controls common to all file types as described previously.

4. Set the clip Handles:

• Clip Length - exports the full clip length available, as if the clip was opened as a Viewer.

• Cut Length - exports only the cuts included on the timeline.

NOTE: Selecting Cut Length allows you to add handles to each clip, up to the maximum available source
clip length.

5. Check Apply Retimes to export any retimes present on the timeline.

6. Set how clip Start Frames are derived using the dropdown menu:

• Source - use the source clip’s start frame.

• Custom - specify a start frame for all clips using the field to the right.

7. Set theVersion number, Tracks For Export, and Tag Filter, if applicable.

NOTE: See Using Versions for more information on how versioning works in Hiero.

8. If you’re transcoding using a render farm, select the renderer from theRender background task dropdown.
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Hiero requires a Python script to pass exports to your render farm of choice. Scripts must be located in specific
directories, dependent on platform, as listed in Running Python During Startup. If no scripts exist, the dropdown
is disabled.

Some example scripts are included in the Hiero package in the following directories:

• On Mac: /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

• On Linux: /usr/local/Hiero1.9v1/Plugins/site-packages/hiero/examples/

• On Windows: drive letter:\Program Files\Hiero1.9v1\plugins\site-packages\hiero\examples

9. Click Export.

The Export Queue window displays an estimate of how long each component of the export is expected to take.

Once the export is complete, the file structure specified in the shot template is created containing the
transcoded files.

TIP: Click the magnifying glass icon to reveal the exported file in a browser window.

Transcoding from the Bin View

To transcode directly from the bin view:

1. Select the bin(s) to export from the bin view.

2. Right-click a highlighted bin and select Export.

The Export dialog displays.

3. Select Process as Clips and modify the shot template, if required.

4. Follow the steps under Transcoding a Sequence or Shots to complete the export.

13 EXPORT MANAGEMENT | TRANSCODING



187

Transcoding Timeline Selections

Transcoding an entire timeline can be time consuming, or even unnecessary, if all you’re looking for is a new version
of a selection of track items.

To transcode a selection of clips from a timeline:

1. Select the required track items on the timeline.

2. Right-click a highlighted item and select Export.

The Export dialog displays.

3. Refer to Transcoding a Sequence or Shots to complete the export.

Ad Hoc Exports
This section covers exports that you might not perform on a per project basis, such as EDL or XML exports.

Exporting EDLs and XMLs

Hiero supports export to EDL and XML using very similar methods, the main difference being that EDL doesn’t
support multiple video tracks in a single file whereas XML does.

To export to EDL or XML:

1. Select a sequence in the bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Sequence from the Processors list.

3. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot hierarchy.

4. Click theContents column to display a list of available presets and the associated Export Controls.
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NOTE: You can build a custom shot template using Path tokens, theContents field, and the

buttons.

5. Select the EDL Exporter orXML Exporter as required.

NOTE: EDLs only support one video track per file. If you have more than one track, include the {track}
token in the shot template to write out an EDL for each track preset.
For example, {filename}_{track}.{ext} might produce a separate EDL for each track on your timeline
called myTimeline_Video1.edl,myTimeline_Video2.edl, and so on.

6. When exporting EDLs, check the additional EDL Exporter controls if required:

• Reel Name - define the reel name written into the EDL, independent of the clip's reel name.

Enter text or standard shot-level tokens in this field. See Using the Shot Template for more information.

If the field is left blank, the reel name from the clip is used or the name of the track item, if no reel name exists.

• Include Absolute Path - adds the full filepath for each clip to the EDL comments field.

• Truncate Reel Name - restricts theReel name to eight characters.

• From Clip Name - define the text appended to “from” comment fields in EDLs, such as *FROM CLIP NAME.
Text and/or standard shot-level tokens are valid in this field: {shot}, {clip}, {track}, {sequence}, {event}, {fps},
and the default {filename}.

7. If you set In and Out points on the sequence, select Range > In/Out Points to export only the specified range.

8. Set Start Frame to Custom if you want to specify a particular frame.

9. Set theVersion number and Tracks For Export.

10. Click Export.

The Export Queue window displays an estimate of how long the export is expected to take.

Once the export is complete, the file structure specified in the shot template is created. You can then import the
EDL or XML into other applications.

TIP: Click the magnifying glass icon to reveal the exported file in a browser window.
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Using the Copy Exporter

Copying media from various locations is very time consuming and can waste disk space. Hiero’s Copy Exporter allows
you to consolidate sequences containing only your project media in a named file structure using the shot template.

To copy media to a named location:

1. Select a sequence in the bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Shots from the Processors list.

3. Enter the Export To directory or click Choose... and browse to the location.

The Export To directory is the starting point from which the shot template builds your shot hierarchy.

4. Create a new preset by clicking or copy an existing preset.

5. Build a custom shot template using Path tokens, theContents field, and the folder and +/- buttons.

An example shot template is shown below:

6. Set theHandles, if required:

• Clip Length - exports the full clip length available, as if the clip was opened from the bin.

• Cut Length - exports only the cuts included on the timeline.

NOTE: Selecting Cut Length allows you process retimes and add handles to each clip, up to the maximum
available source clip length.

7. Check Apply Retimes, if Cut Length is enabled, to export any retimes present on the timeline.

8. Set how clip Start Frames are derived using the dropdown menu:

• Source - use the source clip’s start frame.

• Custom - specify a start frame for all clips using the field to the right.

9. Set theVersion number, Tracks for Export, and Tag Filter, if applicable.

NOTE: See Using Versions for more information on how versioning works in Hiero.

10. Click Export.

The Export Queue window displays an estimate of how long the export is expected to take.

Once the export is complete, the file structure specified in the shot template is created.
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TIP: Click the magnifying glass icon to reveal the exported file in a browser window.
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14 Customizing Hiero
This chapter provides a basic overview and some simple examples to get you started, but more
information is available in the dedicated Python API document included in the Hiero package. See
Help > Python Dev Guide for more information.

Environment Variables
Environment variables are used to store values that influence the behavior of Hiero and HieroPlayer, such as adding
additional file paths to check at startup for plug-in scripts.

Setting Environment Variables

The process of setting environment variables differs depending on the operating system you're using:

OnMac OS X and Linux
1. The first step is to determine the type of the shell you’re using. Launch a terminal and enter:

echo $SHELL

Your shell type is printed to the screen. For example, /bin/bash indicates that your shell is “bash”.

2. Depending on the output of the $SHELL command, do one of the following:

• csh or tcsh - add the following command to the .cshrc or .tcshrc file in your home directory:
setenv VARIABLE value

Replace VARIABLE with the name of the environment variable and value with the value you want to give it, for
example:
setenv HIERO_PLUGIN_PATH /SharedDisk/Hiero

• bash or ksh - add the following command to the .bashrc or .kshrc file in your home directory:
export VARIABLE=value

Replace VARIABLE with the name of the environment variable and value with the value you want to give it, for
example:
export HIERO_PLUGIN_PATH=/SharedDisk/Hiero

NOTE: These steps set the environment variable until you manually remove it from the file in your home
directory. If you want to set a variable for a single session, you can simply type the variable in the terminal
then run Hiero from the same session.
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OnWindows
1. Right-click on My Computer and select Properties.

2. Click theAdvanced tab.

3. Click the Environment Variables button.

The Environment Variables dialog opens.

4. Click theNew button under eitherUser variables or System variables, depending on whether you want to
set the variable for the current user or all users.

NOTE: You must have administrator privileges to set system-wide variables.

5. In theVariable name field, enter the name of the environment variable you want to set.

6. In theValue field, enter the value for the variable. The value can be a directory path, for example.

7. Click OK to save the variable.

The following table lists the environment variables that Hiero recognizes:

Environment Variable Description

__GL_SYNC_DISPLAY_DEVICE On Linux, set this variable to the name of screen device to
synchronize in dual screen setups. See Synching to VBlank on
Linux for more information.

FN_DISABLE_LICENSE_DIALOG By default, if you have installed a temporary license, Hiero
displays a dialog at start-up alerting you to the number of days
remaining. If you want to disable this behavior, you can set this
environment variable to 1 to suppress the warning message
about imminent license expiration.

NOTE: When this environment variable is set, a warning
message is still displayed if no license is found.

HIERO_DISABLE_THUMBNAIL_CACHE Set this variable to TRUE to stop Hiero caching thumbnails.

NOTE: This variable does not clear the cache, you must
remove cached files manually.
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Environment Variable Description

HIERO_PLUGIN_PATH Set this variable to the location of additional scripts to run at
startup. You can use .<folder> to point to hidden folders, for
example .myPlugins.

For example, you could create a facility-wide location to share
presets and use this variable to point multiple Hiero’s to it. See
Sharing Presets for more information.

Use the following method to display set paths:
print hiero.core.pluginPath()

HIERO_SINGLE_THREADED_PLAYBACK This variable launches Hiero in single-thread mode, which can
solve playback issues on various Linux Fedora flavors.

FOUNDRY_LOG_FILE This variable specifies the location of Hiero’s logfile. If you don’t
specify a logfile, all output is to screen.

FOUNDRY_LOG_LEVEL This variable sets the level of logging Hiero produces during
operation. There are four levels of detail, on a sliding scale from
minimal to verbose:

• error

• warning

• message

• verbose

NOTE: Setting the logging level to verbose can produce
large log files when FOUNDRY_LOG_FILE is specified.

OCIO Set this variable to the location of your OCIO configuration file for
color conversion.

NOTE: If you plan to use the OCIO config file specified
in Hiero or HieroPlayer, ensure that the Preferences >
Color Management > Use OCIO nodes when
exporting in Nuke checkbox is enabled.
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Sharing Presets
Hiero and HieroPlayer support facility-wide preset sharing by pointing multiple seats to a single network location
using the HIERO_PLUGIN_PATH. As long as the folder hierarchy mirrors what the application expects, you can place
this repository anywhere on your network.

To setup sharing:

1. Create the shared repository directory, for example:
/Volumes/myFacility/Shared/

2. Follow the instructions under Setting Environment Variables to point individual machines to the shared location.
For example, if you’re using a bash shell, you could use:
export HIERO_PLUGIN_PATH=/Volumes/myFacility/Shared/

Any file that can be read locally can be placed in the shared path.

Startup Projects
Hiero and HieroPlayer search <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer and
<path>/Templates for preset projects saved as .hrox files. See Mac OS X, Linux, and Windows for a description of
the <path> variable by platform.

Projects placed in these folders behave differently, depending on which folder they are read from:

• StartupProjects/Hiero or HieroPlayer - projects in these folders are displayed in the bin view at startup and are
read only. An example project, Tag Presets, is included in the Tags tab.

• Templates - projects in this folder appear in a dropdown menu when you open a new project. Select the template
to use for the new project.

NOTE: You may need to create the StartupProjects/Hiero, StartupProjects/HieroPlayer, and
Templates folders manually in the chosen path.

To remove a startup project, either:

• Remove it from <path>/StartupProjects/Hiero, <path>/StartupProjects/HieroPlayer or <path>/Templates,
or

• Rename the file extension so the application doesn’t recognize it on startup. For example,myStartup.hrox_
hidden.

To modify a startup project:

1. Load the project using File > Open.

2. Make any required edits and save over the original in the same location.
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The edited project loads at startup.

Using the Python API
Hiero and HieroPlayer ship with a comprehensive Python application programming interface (API) enabling you to
perform most user interface actions using Python scripting.

This section provides a basic overview and some simple examples to get you started, but more information is
available in the dedicated Python API document included in the Hiero package. SeeHelp > Python Dev Guide for
more information.

Running Python During Startup

On startup, Hiero and HieroPlayer scan various directories for Python scripts that customize the behavior of the
application. These scripts can be downloaded from online resources and placed in specific locations on disk,
depending on the platform you’re using.

If you’re familiar with Python scripting, you can place custom startup scripts in the same locations, though bear in
mind that you should take care as mistakes can produce performance issues.

Some example scripts are included in the application package in the following directories:

On Mac:

• /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

• /Applications/HieroPlayer1.9v1/HieroPlayer1.9v1.app/Contents/Plugins/site-packages/hiero/examples/

On Linux:

• /usr/local/Hiero1.9v1/Plugins/site-packages/hiero/examples/

• /usr/local/HieroPlayer1.9v1/Plugins/site-packages/hiero/examples/

On Windows:

• drive letter:\Program Files\Hiero1.9v1\plugins\site-packages\hiero\examples

• drive letter:\Program Files\HieroPlayer1.9v1\plugins\site-packages\hiero\examples

At startup, Hiero and HieroPlayer search <path>/Python/Startup and <path>/Python/StartupUI for any Python
.py modules or packages containing __init__.py. Scanning is done in two passes - all the Startup folders are searched
and then all the StartupUI folders.

You can also add your own Startup folders, which are scanned after the standard paths, by creating a Python file
pointing to the custom location. For example:
import hiero.core

hiero.core.addPluginPath("/myCustomPlugins")
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Searches /myCustomPlugins/Python/Startup after the standard paths.

Each package or module discovered is imported and added to the built-in packagehiero.plugins.

NOTE: Python startup scripts are imported in alphabetical order so you can force ordering if necessary.

The <path> varies by platform as follows:

Mac OS X
• /Applications/Hiero1.9v1/Hiero1.9v1.app/Contents/Plugins

• /Applications/HieroPlayer1.9v1/HieroPlayer1.9v1.app/Contents/Plugins

• /Library/Application Support/TheFoundry/Hiero

• ~/Library/Application Support/TheFoundry/Hiero

• ~/.hiero

Linux
• /usr/local/Hiero1.9v1/Plugins

• /usr/local/HieroPlayer1.9v1/Plugins

• ~/.hiero

Windows
• drive letter:\Program Files\Hiero\plugins\hieroscripts

• drive letter:\Program Files\HieroPlayer\plugins\hieroscripts

• drive letter:\Program Files (x86)\Hiero\plugins\hieroscripts

• drive letter:\Program Files (x86)\HieroPlayer\plugins\hieroscripts

You can specify any number of user-defined paths using the environment variable HIERO_PLUGIN_PATH, separating
them with : just like the standard unix PATH environment variable and Nuke's NUKE_PATH. See Setting Environment
Variables for more information.

Using the Script Editor
Hiero and HieroPlayer include a Python Script Editor, accessible from the user interface, allowing you to enter
Python statements directly.

To access the Script Editor:

1. Navigate to Window > Script Editor.

The Script Editor displays.

2. Enter scripts in the lower half of the editor and press Ctrl/Cmd + Enter to execute the script.
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The results are displayed at the top of the editor. A simple example might be:
from hiero.core import *

bin = projects()[-1].clipsBin()

bin.addItem(Bin("Plates"))

bin["Plates"].importFolder("/Footage/Hiero/finalshots")

Which imports hiero.core, defines bin in the last project opened, creates a bin called Plates at root level, and
imports the specified folder into Plates.

Script Editor buttons and commands are described below:

Icon Hotkeys Description

Ctrl/Cmd+[ Go to the previous script.

Ctrl/Cmd+] Go to the next script.

n/a Clear the script history.

n/a Load and execute a script.

n/a Load an existing script.

n/a Save a script as a .py file.

Ctrl/Cmd+ enter Run the current script.

n/a Show the input pane only.

n/a Show the output pane only.

n/a Show both the input and output panes.

Ctrl/Cmd+ Backspace Clear the output pane.

The Script Editor also features auto-completion and help for commands. Classes, attributes and so on are
discoverable by:

• Entering the beginning of an object name and pressing the Tab key.
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For example, typing Bin and pressing Tab displays a list of objects starting with Bin:

• Using thehelp command for a known object.

For example, help(Clip) returns a list of useful information on Clip:

Scroll down in the top pane to see more information relating to Clip.

• Using thedir command for a known object.

For example, dir(Project) returns a concise list of useful information on Project:

NOTE: The last entry in the Script Editor is restored at startup by default, but you can disable this behavior
by navigating to Preferences > Script Editor and deselecting Save and restore script editor history.

For more information on Python scripting, seeHelp > Python Dev Guide.
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Hiero and HieroPlayer Hotkeys
This appendix lists the hotkeys used by both applications, along with their function. In general, contiguous areas of
the keyboard are assigned to related functionality. The left-hand keys on a QWERTY keyboard are used for tool
selection and actions, the right-hand side for playhead manipulation including source/record and insert/overlay, the
arrow keys for selection and nudging, and the numeric pad for timecode entry.

Hotkeys Button Menubar Function

Timeline and Editing Controls

Q n/a Cycles between the available move tools:

• Multi Tool

• Move/Trim

• Select
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Hotkeys Button Menubar Function

W n/a Cycles between the available selection tools:

• Select Track to Right/Left

• Select All in Track

• Select All Tracks Right/Left

NOTE: HoldingAlt toggles between track
and all tracks behavior.

E n/a Cycles between the Slip Clip and Slide Clip tools.

R n/a Cycles between the available edit tools:

• Roll Edit

• Ripple Edit

• Retime Clip

T n/a Cycles between the available razor tools:

• Razor

• Razor All

• Join

left-click n/a n/a Select a clip including any linked tracks.

Alt + left-click n/a n/a Select a clip, ignoring linked tracks (for example,
audio only).

Shift + drag clip n/a n/a Disable snap to transition when dragging clips.

left-click then
Shift + left-click

n/a n/a Select all clips between the left-clicks (use Shift + Alt
+ left-click to ignore linked tracks).

drag then Alt n/a n/a Activate Ripple mode while dragging track item.

Alt then drag n/a n/a Duplicate the dragged track item.

Alt and drag n/a n/a Ripple and duplicate the dragged track item.

Alt and left-click n/a n/a Select a clip, ignoring linked tracks.

Ctrl/Cmd + A n/a n/a Select all track items.
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Hotkeys Button Menubar Function

Ctrl/Cmd + Shift
+ A

n/a n/a Deselect all track items.

File Menu

Ctrl/Cmd + Shift
+ N

n/a File > New Project Open a new project.

Ctrl/Cmd + O n/a File > Open Open an existing project.

Alt + Shift +
<num>

n/a File > Open Recent >
Project Name

Open a previously saved project from the list.

Ctrl/Cmd + W n/a File > Close Close the current project.

Ctrl/Cmd + S n/a File > Save Save the current project.

Ctrl/Cmd + Shift
+ S

n/a File > Save As... Save the current project with a different name.

Ctrl/Cmd + I n/a File > Import Clips Import a clip or clips.

Ctrl/Cmd + Shift
+ I

n/a File > Import Folder Import a folder or folders.

Ctrl/Cmd + Alt +
Shift + I

n/a File > Import EDL/XML Import an EDL or XML sequence.

Ctrl/Cmd + Shift
+ E

n/a File > Export Export the selected sequence.

Ctrl/Cmd + Q n/a File > Quit Close Hiero and display a prompt to save any
unsaved work.

Edit Menu

Ctrl/Cmd + Z n/a Edit > Undo Undo the last action.

Ctrl/Cmd + Shift
+ Z

n/a Edit > Redo Redo the last undo action.

Ctrl/Cmd + X n/a Edit > Cut Cut the selected item(s) and place in the buffer.

Ctrl/Cmd + C n/a Edit > Copy Copy the selected item(s) to the buffer.
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Hotkeys Button Menubar Function

Ctrl/Cmd + V n/a Edit > Paste Paste item(s) from the buffer.

Backspace /
Delete

n/a Edit > Delete Delete selected item(s).

Ctrl/Cmd + A n/a Edit > Select All Select all files in the current bin.

Ctrl/Cmd + Shift
+ A

n/a Edit > Clear Selection Deselect all files in the current bin.

Ctrl/Cmd + D n/a Edit > Duplicate Duplicate the selected object(s).

Shift + S n/a Edit > Preferences Open the Preferences dialog.

View Menu

Ctrl/Cmd + Shift
+ 1

n/a View > Zoom to Actual
Size

Zoom the contents of the Viewer to actual size.

Ctrl/Cmd + Shift
+ 2

n/a View > Zoom to Half
Size

Zoom the contents of the Viewer to half size.

H n/a View > Zoom to Fill Fit the current clip to the height or width of the
Viewer, depending on the clip's format.

F n/a View > Zoom to Fit Zoom to fit the clip to the Viewer.

+ n/a View > Zoom In Zoom in to the Viewer.

- (minus) n/a View > Zoom Out Zoom out of the Viewer.

Ctrl/Cmd + F n/a View > Full Screen Toggle Full Screen mode.

Ctrl/Cmd + Shift
+ F

n/a View > Full Quality 1:1 Toggle Full Screen mode at Full Quality 1:1 zoom.

Esc n/a n/a Exit full screen mode.

E n/a View > Clipping
Warning

Toggle the Level Warning tool on and off.

I View > Mark In Set the In Point at the current frame.
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Hotkeys Button Menubar Function

O View > Mark Out Set the Out Point as the current frame.

Alt + I n/a View > Clear In Point Clear the In point for the current clip or timeline.

Alt + O n/a View > Clear Out Point Clear the Out point for the current clip or timeline.

Alt + U n/a View > Clear In and Out
Points

Clear the In and Out points for the current clip or
timeline.

Home View > Go to Start Go to the start of all clips.

End View > Go to End Go to the end of all clips.

Shift + I n/a View > Go to In Point Go to the In Point in the current clip.

Shift + O n/a View > Go to Out Point Go to the Out Point in the current clip.

, (comma)

(K + J)

View > Frame
Backwards

Skip one frame backwards.

. (period)

(K + L)

View > Frame Forwards Skip one frame forwards.

Shift + , (comma) View > Skip Backwards Skip backwards by the frame increment value
specified in the Viewer tools.

Shift + . (period) View > Skip Forwards Skip forwards by the frame increment value specified
in the Viewer tools.

Alt + , (comma) View > Previous Edit Go to the previous clip in the Viewer.

Alt + . (period) View > Next Edit Go to the next clip in the Viewer.

Alt + Shift + ,
(comma)

n/a View > Previous Tag Go to previous frame tag.
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Hotkeys Button Menubar Function

Alt + Shift + .
(period)

n/a View > Next Tag Go to next frame tag.

Space View > Play Play the clip or sequence currently in the Viewer.

P n/a Pause RAM caching in the Viewer.

J View > Play Backward Play clip or sequence currently in the Viewer
backward (click multiple times to increase playback
speed).

K View > Pause Pause playback.

L View > Play Forward Play clip or sequence currently in the Viewer forward
(click multiple times to increase playback speed).

Enter (numeric
pad)

n/a View > Edit Playhead
Time

Shift focus to the timecode field under the Viewer,
allowing you to manually edit the playhead position.

Ctrl/Cmd + Shift
+ P

n/a View > Ignore Pixel
Aspect

Display the clip in the Viewer with a 1:1 aspect ratio.

Ctrl/Cmd + / n/a Show Timeline Editor Display the timeline pane, if it is not already visible.

Return
(main keyboard)

n/a View > Swap Inputs Controls the AB inputs:

• Stack - swaps which input is visible.

• Horizontal - swaps the inputs horizontally.

• Vertical - swaps the inputs vertically.

R, G, B, A, Y View > Channels Set the Viewer output channel.

PgUp n/a Scroll up and down through available layers in the
Viewer.

PgDn n/a PgDn n/a

\ (back slash) n/a View > Show Overlays Toggle the HUD overlays.
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Hotkeys Button Menubar Function

W View > Toggle SplitWipe Toggle the SplitWipe compare mode on and off.

Project Menu

Ctrl/Cmd + B n/a Project > New Bin Create a new bin in the current bin.

Ctrl/Cmd + Y n/a Project > New Tag Create a new tag in the current bin (tags can only be
created in the Tags tab).

Ctrl/Cmd + N n/a Project > New
Sequence

Create a new sequence in the current bin.

Clip Menu

Ctrl/Cmd +
Return

(main keyboard)

n/a Clip > Open In > Viewer Open the selected clip in the Viewer.

Ctrl/Cmd + Alt +
Return

(main keyboard)

n/a Clip > Open In > New
Viewer

Open the selected clip a new Viewer.

1 n/a Clip > Open In > Viewer
Input A

Open the selected clip in Viewer input A.

2 n/a Clip > Open In > Viewer
Input B

Open the selected clip in Viewer input B.

Alt + D n/a Clip > Open In >
Metadata View

Open the metadata view for the selected clip.

D n/a Clip > Hide Version Hide the currently selected version(s) of a clip in the
Versions Bin view.

Alt +á n/a Clip > Version Up Cycle up through the available clip versions.

Alt +â n/a Clip > Version Down Cycle down through the available clip versions.

Ctrl/Cmd + Alt +
á

n/a Clip > Max Version Jump to the maximum known version or scan for
new versions if the max version is already reached.
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Hotkeys Button Menubar Function

Ctrl/Cmd + Alt +
â

n/a Clip > Min Version Jump to the minimum known version or scan for new
versions if the min version is already reached.

V n/a Clip > Select Version Display the available versions of a clip or sequence.

F5 n/a Clip > Refresh Clips Reload the clip or track item when the source file
location has not changed, such as when work has
been done on the clip offline. Selecting refresh only
refreshes the clip’s current frame range.

Alt + F5 n/a Clip > Rescan Clip
Range

Similar to Refresh Clips, above, but rescan also
checks for additional frames that may have been
added to the source file and adds them to the track
item’s frame range.

N n/a Clip > Insert Insert the contents of a source Viewer into the
timeline at the current playhead position and ripple
existing track items downstream to accommodate
the change.

M n/a Clip > Overwrite Insert the contents of a source Viewer into the
timeline at the current playhead position overwriting
existing track items.

Timeline Menu

Shift + U n/a Timeline > Mark
Selection

Place the In and Out markers around the selected
track item or track items on the timeline.

U n/a Timeline > Mark Clip Place the In and Out markers around the upper-most
timeline clip under the current playhead position.

C n/a Timeline > Razor
Selected

Apply the Razor tool to the currently selected track(s)
within the selected clip(s).

Shift + C n/a Timeline > Razor All Apply the Razor tool to all tracks within the selected
clip(s).

Shift + Backspace n/a Timeline > Ripple
Delete

Remove the selected clip(s) and ripple clips down
stream to close gaps in the timeline.
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Hotkeys Button Menubar Function

Ctrl/Cmd + T n/a Timeline > Transition >
Dissolve

Add a dissolve between two selected track items.

D n/a n/a Enable or disable the selected clip(s) or track(s).

Ctrl/Cmd + Alt +
A

n/a Timeline > Select All in
Track

Select all the track items on the current track.

Ctrl/Cmd +ß n/a Timeline > Nudge >
Nudge Left

Trim, roll, or nudge a selected transition or track item
to the left (within the available handles for trim and
roll).

Ctrl/Cmd +à n/a Timeline > Nudge >
Nudge Right

Trim, roll, or nudge a selected transition or track item
to the right (within the available handles for trim and
roll).

Ctrl/Cmd + Shift
+ß

n/a Timeline > Nudge >
Nudge Left More

Trim, roll, or nudge a selected transition or track item
to the left by the frame increment value specified in
the Viewer tools (within the available handles for trim
and roll).

Ctrl/Cmd + Shift
+à

n/a Timeline > Nudge >
Nudge Right More

Trim, roll, or nudge a selected transition or track item
to the right by the frame increment value specified in
the Viewer tools (within the available handles for trim
and roll).

Ctrl/Cmd +á n/a Timeline > Nudge >
Nudge Up

Nudge the selected track item(s) up one track.

Ctrl/Cmd +â n/a Timeline > Nudge >
Nudge Down

Nudge the selected track item(s) down one track,
where possible.

Alt + Shfit + / n/a Timeline > Rename
Shots

Display theRename Shots dialog for the selected
track items.

Cache Menu

F12 n/a Cache > Clear Playback
Cache

Click to clear the frames stored in the playback cash,
represented by the green bar under the Viewer
playhead.

Window Menu
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Hotkeys Button Menubar Function

Alt + S n/a Window > Toggle
Fullscreen

Expand the interface to fill the available screen space.

Ctrl/Cmd + Alt +
Shift + ‘ (backtick)

n/a n/a Cycle backwards through all current panes.

Ctrl/Cmd + Alt + ‘ 
(backtick)

n/a n/a Cycle forwards through all current panes.

Ctrl/Cmd + Shift
+ [

n/a n/a Jump between tabs in the current pane.

Ctrl/Cmd + Shift
+ ]

n/a n/a

Shift + F1 n/a Window > Workspace >
Conforming/Editing

Switch to Hiero’s Conforming workspace or
HieroPlayer’s Editing workspace.

Shift + F2 n/a Window > Workspace >
Editing/Flipbook

Switch to Hiero’s Editing workspace or HieroPlayer’s
Flipbook workspace.

Shift + F3 n/a Window > Workspace >
Reviewing

Switch to the Reviewing workspace.

Shift + F4 n/a Window > Workspace >
Timeline

Switch to the Timeline workspace.

Shift + F<num> n/a Window > Workspace >
Custom Workspace
Name

Switch to the custom workspace associated with the
number selected.

Viewer Controls

Alt + left-click +
drag

(middle-click and
drag on Linux)

n/a n/a Pan the contents of the Viewer.

Scroll wheel

(over Viewer or
Viewer timeline)

n/a n/a Zoom the Viewer or Viewer timeline.
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Hotkeys Button Menubar Function

Scroll wheel

middle-click +
drag

(over Viewer
timeline or
timeline)

n/a n/a Zoom the Viewer timeline to the indicated frame
range.

Scroll wheel

Alt + middle-click
+ drag

(over Viewer or
timeline)

n/a n/a Zoom the contents of the Viewer or timeline.

middle-click

(over Viewer
timeline or
timeline)

n/a n/a Zoom to fit the Viewer timeline to Viewer contents.

NOTE: If your mouse preferences are not
set to Button 3 for the middle mouse
button, you may have to useCtrl/Cmd +
middle-click.

Alt + close Viewer n/a Close only the selected tab. Clicking close without
holdingAlt closes any linked tabs as well.

Spreadsheet Controls

Alt + left-click n/a n/a Move the playhead to the selected clip’s In point on
the timeline.

Alt + double left-
click

n/a n/a Move the playhead to the selected clip’s In point on
the timeline and zoom to fit the clip in the timeline
view.

Alt + close
Spreadsheet

n/a Close only the selected tab. Clicking close without
holdingAlt closes any linked tabs as well.

Bin View Searchbox Controls

left-click n/a n/a Select a tag search criteria.
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Hotkeys Button Menubar Function

Ctrl/Cmd + left-
click

n/a n/a Toggle select individual tag search criteria.

Shift + left-click n/a n/a Select a range of tag search criteria.

Script Editor Controls

Ctrl/Cmd + [ n/a Go to the previous script.

Ctrl/Cmd + ] n/a Go to the next script.

Ctrl/Cmd + Enter n/a Execute current script.

Ctrl/Cmd +
Backspace

n/a Clear the output pane.
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Supported Image Formats
The following table lists supported image formats.

Format Name Bit Depths Read/Write Extension

ARRIRAW 12 read only ari

AVI n/a read only avi

CIN 10 (log) read and write cin

DPX (see the notes below) 8, 10, 12, and 16 read and write dpx

Radiance 16 read only hdr, hdri

JPEG 8 read and write jpg, jpeg

Maya IFF 8 and 16 read only iff

OpenEXR (see the notes
below)

16 and 32 read and write exr

PNG 8 and 16 read and write png (8-bit)

png16 (16-bit)

PSD 8 read only psd

QuickTime n/a read and write mov

RAW n/a read only n/a
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Format Name Bit Depths Read/Write Extension

REDCODE (see the notes
below)

16 read only r3d

SGI 8 and 16 read and write sgi, rgb, rgba (8-bit
sequences)

sgi16 (for 16-bit
sequences)

SoftImage® PIC 8 read and write pic

TIFF 8, 16, and 32 read and write tif, tiff (8-bit sequences)

tif16, tiff16 (16-bit
sequences)

ftif, ftiff (32-bit sequences)

Truevision® TARGA 8 read and write tga, targa

Wavefront® RLA 8 read only rla

XPM 8 read only xpm

YUV 8 read only yuv

Optimized Formats and Limitations

Hiero and HieroPlayer play most formats as fast as they can be read from the file system. The frames are cached in
RAM up to the cache limit specified in the Preferences dialog. When the cache is full, frames are ejected and must
be re-read from disk if needed again.

The playback system supports automatic resolution switching, which enables realtime playback of source clips on
typical desktop and graphics card combinations.

Most file formats are read through the same image I/O library used by The Foundry’s Nuke. Formats are optimized
for realtime playback based on user feedback about what is most frequently used. The following formats have been
optimized, so that the only limiting factor in achieving realtime playback is the rate at which files can be read from
the file system:

DPX

8-, 10-, 12-, and 16-bit RGB and RGBA reads are optimized, if the channels are all stored in the same element.
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EXR

EXR reads have been partially optimized. They currently still load more slowly if any part of the data window lies
outside the display window, or if the data window is smaller than the display window and aligned to one of the edges
of the display window. This reduction in speed is most noticeable for large data windows.

R3D

In conjunction with a RED Rocket, Hiero and HieroPlayer can take advantage of the lower scale/quality available from
the RED SDK based on the current Viewer zoom level.

Other Format Optimsation

The .jpg, .cin, and .sgi formats are also optimized. Reads of other formats may be optimized depending on the
number, bit depth and layout (within elements) of the channels. Future releases will handle more formats.

Reader Fallback Paths

If Hiero can't find a suitable reader when reading source clips from disk, the following paths are searched for fallback
.dylib, .so, and .dll readers compiled against the comparable Nuke version:

Mac OS X:
• /$HOME/.nuke

• /Library/Application Support/Nuke/x.x/plugins/

Linux:
• /$HOME/.nuke

• /usr/local/Nuke/x.x/plugins/

Windows:
• \$HOME\.nuke

• C:\Program Files\Common Files\Nuke\x.x\plugins\

• C:\Program Files (x86)\Common Files\Nuke\x.x\plugins\

NOTE: You can also add your own search paths using the NUKE_PATH environment variable. See Setting
Environment Variables on page 191 or the Configuring Nuke chapter in the NukeUser Guide for more
information.
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Supported Audio Formats
The following table lists supported audio formats.

NOTE: Although Hiero and HieroPlayer support the import and editing of multi-channel audio, during
playback audio is currently mixed to 48 KHz stereo output.

Format Name Extension

All platforms

RED Audio n/a

Wave wav

Audio interchange format aiff

Mac and Windows

QuickTime Audio .m4a
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Appendix C
This appendix lists third party libraries and versions used in Hiero and HieroPlayer, along with their licenses.

Third-Party Library Versions

Library Version Library Version

ARRIRAW SDK 4.4 OpenALSoft 1.13

Boost 1.46.0 OpenColorIO 1.0.7

Breakpad 1.0 OpenEXR 2.0.0

bzip2 1.0.6 OpenImageIO r1719

Curl 7.21.1 OpenSSL 1.0.0a

EuCon 2.5.5 PortAudio v19

Expat 2.0.1 PySide 1.0.9

FBX 2012.2 PyString 1.1.0

FFmpeg 1.0 Python 2.6.5

FreeType 2.4.4 Qt 4.7.2

GLEW 1.5.8 QuaZip 0.3

Google BSD 1.5.0 QuickTime 7.3

JPEG 6b R3D SDK 4.5

Libexif 0.6.20 Skein 1.1

Libpng 1.2.25 TBB N/A

libresample 0.1.3 VXL 1.10.0
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Library Version Library Version

libsndfile 1.0.25 xmlrpcpp 0.7

Libtiff 3.9.4 Zlib 1.2.5

Msinttypes r20

Third-Party Library Licenses

Library Description License

Boost Source code
function /
template library

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or
organisation obtaining a copy of the software and accompanying
documentation covered by this license (the “Software”) to use,
reproduce, display, distribute, execute, and transmit the Software, and
to prepare derivative works of the Software, and to permit third-parties
to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement,
including the above license grant, this restriction and the following
disclaimer, must be included in all copies of the Software, in whole or in
part, and all derivative works of the Software, unless such copies or
derivative works are solely in the form of machine-executable object
code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE
LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
IN THE SOFTWARE.
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Library Description License

Breakpad Multi-platform
crash reporting
system

Copyright © 2010, Google Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Google Inc nor the names of its contributors may
be used to endorse or promote products derived from this software
without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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Library Description License

bzip2 Data compressor Copyright © 1996-2000 Julian R Seward. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

2. The origin of this software must not be misrepresented; you must
not claim that you wrote the original software. If you use this
software in a product, an acknowledgment in the product
documentation would be appreciated but is not required.

3. Altered source versions must be plainly marked as such, and must
not be misrepresented as being the original software.

4. The name of the author may not be used to endorse or promote
products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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Curl URL transfer
library

Copyright © 1996 - 2010, Daniel Stenberg, <daniel@haxx.se>. All rights
reserved.

Permission to use, copy, modify, and distribute this software for any
purpose with or without fee is hereby granted, provided that the above
copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall
not be used in advertising or otherwise to promote the sale, use or
other dealings in this Software without prior written authorization of
the copyright holder.

EuCon Software
development kit

The EUCON specification and trademark are property of Avid
Technology, Inc. Used under license.
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Expat XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd
and Clark Cooper

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
“Software”), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
IN THE SOFTWARE.

FBX File format
support

This software contains Autodesk® FBX® code developed by Autodesk,
Inc. Copyright 2008 Autodesk, Inc. All rights, reserved. Such code is
provided “as is” and Autodesk, Inc. disclaims any and all warranties,
whether express or implied, including without limitation the implied
warranties of merchantability, fitness for a particular purpose or non-
infringement of third party rights. In no event shall Autodesk, Inc. be
liable for any direct, indirect, incidental, special, exemplary, or
consequential damages (including, but not limited to, procurement of
substitute goods or services; loss of use, data, or profits; or business
interruption) however caused and on any theory of liability, whether in
contract, strict liability, or tort (including negligence or otherwise)
arising in any way out of such code.
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FFmpeg File format
support

Copyright © 2001 Fabrice Bellard

This file is part of FFmpeg.

FFmpeg is free software; you can redistribute it and/or modify it under
the terms of the GNU Lesser General Public License as published by the
Free Software Foundation; either version 2.1 of the License, or (at your
option) any later version.

FFmpeg is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with FFmpeg; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-
1301 USA

FreeType Font support Portions of this software are copyright © 2008 The FreeType Project
(www.freetype.org). All rights reserved.
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GLEW OpenGL support The OpenGL Extension Wrangler Library Copyright © 2002-2008, Milan
Ikits <milan ikits@ieee.org>

Copyright © 2002-2008, Marcelo E. Magallon <mmagallo@debian.org>

Copyright © 2002, Lev Povalahev All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• The name of the author may be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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Google BSD Testing
Framework

Copyright © 2009, Google Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Google Inc. nor the names of its contributors
may be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

JPEG File format
support

This software is based in part on the work of the Independent JPEG
Group.
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Libexif Metadata parser Author Lutz Mueller lutz@users.sourceforge.net date 2001-2005

This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published
by the Free Software Foundation; either version 2 of the License, or (at
your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.
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Libpng File format
support

This copy of the libpng notices is provided for your convenience. In
case of any discrepancy between this copy and the notices in the file
png.h that is included in the libpng distribution, the latter shall prevail.

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

If you modify libpng you may insert additional notices immediately
following this sentence.

libpng versions 1.2.6, August 15, 2004, through 1.2.25, February 18,
2008, are Copyright © 2004, 2006-2008 Glenn Randers-Pehrson, and
are distributed according to the same disclaimer and license as libpng-
1.2.5 with the following individual added to the list of Contributing
Authors: Cosmin Truta.

libpng versions 1.0.7, July 1, 2000, through 1.2.5 - October 3, 2002, are
Copyright © 2000-2002 Glenn Randers-Pehrson, and are distributed
according to the same disclaimer and license as libpng-1.0.6 with the
following individuals added to the list of Contributing Authors: Simon-
Pierre Cadieux, Eric S. Raymond, Gilles Vollant.

Including the following additions to the disclaimer:

There is no warranty against interference with your enjoyment of the
library or against infringement. There is no warranty that our efforts or
the library will fulfill any of your particular purposes or needs. This
library is provided with all faults, and the entire risk of satisfactory
quality, performance, accuracy, and effort is with the user.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are
Copyright © 1998, 1999 Glenn Randers-Pehrson, and are distributed
according to the same disclaimer and license as libpng-0.96, with the
following individuals added to the list of Contributing Authors: Tom
Lane, Glenn Randers-Pehrson, Willem van Schaik.

libpng versions 0.89, June 1996, through 0.96, May 1997, are
Copyright © 1996, 1997 Andreas Dilger Distributed according to the
same disclaimer and license as libpng-0.88, with the following
individuals added to the list of Contributing Authors: John Bowler,
Kevin Bracey, Sam Bushell, Magnus Holmgren, Greg Roelofs, Tom
Tanner
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libpng versions 0.5, May 1995, through 0.88, January 1996, are
Copyright © 1995, 1996 Guy Eric Schalnat, Group 42, Inc. For the
purposes of this copyright and license, "Contributing Authors" is
defined as the following set of individuals: Andreas Dilger, Dave
Martindale, Guy Eric Schalnat, Paul Schmidt, Tim Wegner

The PNG Reference Library is supplied "AS IS". The Contributing
Authors and Group 42, Inc. disclaim all warranties, expressed or
implied, including, without limitation, the warranties of merchantability
and of fitness for any purpose. The Contributing Authors and Group
42, Inc. assume no liability for direct, indirect, incidental, special,
exemplary, or consequential damages, which may result from the use
of the PNG Reference Library, even if advised of the possibility of such
damage.

Permission is hereby granted to use, copy, modify, and distribute this
source code, or portions hereof, for any purpose, without fee, subject
to the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be
misrepresented as being the original source.

3. This Copyright notice may not be removed or altered from any
source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit,
without fee, and encourage the use of this source code as a component
to supporting the PNG file format in commercial products. If you use
this source code in a product, acknowledgment is not required but
would be appreciated.
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A "png_get_copyright" function is available, for convenient use in
"about" boxes and the like:

printf("%s",png_get_copyright(NULL));

Also, the PNG logo (in PNG format, of course) is supplied in the files
"pngbar.png" and "pngbar.jpg (88x31) and "pngnow.png" (98x31).

Libpng is OSI Certified Open Source Software. OSI Certified Open
Source is a certification mark of the Open Source Initiative.

Glenn Randers-Pehrson (glennrp at users.sourceforge.net)

February 18, 2008

libresample Realtime
resampler

All of the files in this package are Copyright 2003 by Dominic Mazzoni
<dominic@minorninth.com>. This library was based heavily on
Resample-1.7, Copyright 1994-2002 by Julius O. Smith III
<jos@ccrma.stanford.edu>, all rights reserved.

Permission to use and copy is granted subject to the terms of the "GNU
Lesser General Public License" (LGPL) as published by the Free
Software Foundation; either version 2.1 of the License, or any later
version. In addition, Julius O. Smith III requests that a copy of any
modified files be sent by email to jos@ccrma.stanford.edu so that he
may incorporate them into the CCRMA version.

This library is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.
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libsndfile Audio read/write Copyright © 1999-2011 Erik de Castro Lopo <erikd@mega-nerd.com>

Copyright © 2005 David Viens <davidv@plogue.com>

This program is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published
by the Free Software Foundation; either version 2.1 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
USA.
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Libtiff File format
support

Copyright © 1988-1997 Sam Leffler Copyright © 1991-1997 Silicon
Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and
its documentation for any purpose is hereby granted without fee,
provided that (i) the above copyright notices and this permission notice
appear in all copies of the software and related documentation, and (ii)
the names of Sam Leffler and Silicon Graphics may not be used in any
advertising or publicity relating to the software without the specific,
prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF
ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT
LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE
FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL
DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING
FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED
OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY,
ARISING OUT OF OR IN CONNECTION WITH THE USE OR
PERFORMANCE OF THIS SOFTWARE.
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Msinttypes File format
support

Copyright © 2006 Alexander Chemeris

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• The name of the author may not be used to endorse or promote
products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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OpenALSoft Cross platform
audio library

Copyright © 1999-2007 by authors.

This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Library General Public License as
published by the Free Software Foundation; either version 2 of the
License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Library General Public License for more details.

You should have received a copy of the GNU Library General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
USA.

Or go to www.gnu.org/copyleft/lgpl.html
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OpenColorIO Color
management
library

Copyright © 2003-2010 Sony Pictures Imageworks Inc., et al. All Rights
Reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Sony Pictures Imageworks nor the names of its
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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OpenEXR File format
support

Copyright © 2002, Industrial Light & Magic, a division of Lucas Digital
Ltd. LLC All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of Industrial Light & Magic nor the names of its
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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OpenImageIO File format
support

Copyright © 2008 Larry Gritz and the other authors and contributors.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of the software's owners nor the names of its
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.
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OpenSSL A toolkit
implementing
the Secure
Sockets Layer
(SSL v2/v3) and
Transport Layer
Security (TLS v1)
protocols as well
as a full-strength
general purpose
cryptography
library

The OpenSSL toolkit stays under a dual license, i.e. both the conditions
of the OpenSSL License and the original SSLeay license apply to the
toolkit. See below for the actual license texts. Actually both licenses are
BSD-style Open Source licenses. In case of any license issues related to
OpenSSL please contact:

openssl-core@openssl.org

OpenSSL License

Copyright © 1998-2008 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materialso provided with the
distribution.

3. All advertising materials mentioning features or use of this
software must display the following acknowledgment: "This
product includes software developed by the OpenSSL Project for
use in the OpenSSL Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be
used to endorse or promote products derived from this software
without prior written permission. For written permission, please
contact openssl-core@openssl.org

5. Products derived from this software may not be called "OpenSSL"
nor may "OpenSSL" appear in their names without prior written
permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following
acknowledgment:

"This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/)"
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THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND
ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young
(eay@cryptsoft.com). This product includes software written by Tim
Hudson (tjh@cryptsoft.com).

Original SSLeay License

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com)

All rights reserved.

This package is an SSL implementation written by Eric Young
(eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as
the following conditions are aheared to. The following conditions apply
to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc.,
code; not just the SSL code. The SSL documentation included with this
distribution is covered by the same copyright terms except that the
holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in
the code are not to be removed. If this package is used in a product,
Eric Young should be given attribution as the author of the parts of the
library used. This can be in the form of a textual message at program
startup or in documentation (online or textual) provided with the
package.
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Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

1. Redistributions of source code must retain the copyright notice,
this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

3. All advertising materials mentioning features or use of this
software must display the following acknowledgement:

"This product includes cryptographic software written by Eric
Young (eay@cryptsoft.com)"

The word 'cryptographic' can be left out if the routines from the
library being used are not cryptographic related.

4. If you include any Windows specific code (or a derivative thereof)
from the apps directory (application code) you must include an
acknowledgement:

"This product includes software written by Tim Hudson
(tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or
derivative of this code cannot be changed. i.e. this code cannot simply
be copied and put under another distribution license [including the
GNU Public License.]

APPENDIX C | THIRD-PARTY LIBRARY LICENSES



238

Library Description License

PortAudio Portable Real-
Time Audio
Library

Copyright © 1999-2011 Ross Bencina and Phil Burk.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT.

IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT
OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

The text above constitutes the entire PortAudio license; however, the
PortAudio community also makes the following non-binding requests:

Any person wishing to distribute modifications to the Software is
requested to send the modifications to the original developer so that
they can be incorporated into the canonical version. It is also requested
that these non-binding requests be included along with the license
above.
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PySide Python bindings
for the Qt cross-
platform
application and
UI framework

Copyright © 2009-2010 Nokia Corporation and/or its subsidiary(-ies).

Contact: PySide team <contact@pyside.org>

This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published
by the Free Software Foundation; either version 2.1 of the License, or
(at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-
1301 USA
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Library Description License

PyString C++ functions
matching the
interface and
behavior of
Python's string
class methods

Copyright © 2008-2010, Sony Pictures Imageworks Inc All rights
reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

• Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the
distribution.

• Neither the name of the organization Sony Pictures Imageworks nor
the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
OF SUCH DAMAGE.

Python Source code
language

Copyright © 2001, 2002, 2003, 2004 Python Software Foundation; All
Rights Reserved.
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Library Description License

Qt Application and
UI framework

The Qt GUI Toolkit is Copyright © 2010 Nokia Corporation and/or its
subsidiary(-ies).

Contact: Nokia Corporation (qt-info@nokia.com)

Qt is available under the GNU Lesser General Public License. To see the
GNU Lesser General Public License, go to www.gnu.org/licenses/.

QuaZip Qt ZIP wrapper Copyright © 2005 Sergey A. Tachenov

This program is free software; you can redistribute it and/or modify it
under the terms of the GNU General Public License as published by the
Free Software Foundation; either version 2 of the License, or (at your
option) any later version.

This program is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

Original ZIP package is copyrighted by Gilles Vollant, see quazip/(un)
zip.h files for details.

QuickTime QuickTime player Copyright © 1990-2006 by Apple Inc., all rights reserved.

R3D Software
Development Kit

The R3D SDK and all included materials (including header files, libraries,
sample code & documentation) are Copyright © 2008-2011 RED Digital
Cinema. All rights reserved. All trademarks are the property of their
respective owners.

This software was developed using KAKADU software.
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Library Description License

Skein Hashing library Source code author: Doug Whiting, 2008.

This algorithm and source code is released to the public domain.

Copyright © 2003, Dr Brian Gladman, Worcester, UK. All rights
reserved.

LICENSE TERMS

The free distribution and use of this software in both source and binary
form is allowed (with or without changes) provided that:

1. distributions of this source code include the above copyright
notice, this list of conditions and the following disclaimer;

2. distributions in binary form include the above copyright notice, this
list of conditions and the following disclaimer in the
documentation and/or other associated materials;

3. the copyright holder's name is not used to endorse products built
using this software without specific written permission.

ALTERNATIVELY, provided that this notice is retained in full, this
product may be distributed under the terms of the GNU General Public
License (GPL), in which case the provisions of the GPL apply INSTEAD
OF those given above.

DISCLAIMER

This software is provided 'as is' with no explicit or implied warranties in
respect of its properties, including, but not limited to, correctness
and/or fitness for purpose.
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Library Description License

TBB Thread Building
Blocks

Copyright 2005-2010 Intel Corporation. All Rights Reserved.

This file is part of Threading Building Blocks.

Threading Building Blocks is free software; you can redistribute it
and/or modify it under the terms of the GNU General Public License
version 2 as published by the Free Software Foundation.

Threading Building Blocks is distributed in the hope that it will be
useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with Threading Building Blocks; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
USA.

As a special exception, you may use this file as part of a free software
library without restriction. Specifically, if other files instantiate
templates or use macros or inline functions from this file, or you
compile this file and link it with other files to produce an executable,
this file does not by itself cause the resulting executable to be covered
by the GNU General Public License. This exception does not however
invalidate any other reasons why the executable file might be covered
by the GNU General Public License.
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Library Description License

VXL Computer vision Copyright © 2000-2003 TargetJr Consortium

GE Corporate Research and Development (GE CRD)

1 Research Circle

Niskayuna, NY 12309

All Rights Reserved

Reproduction rights limited as described below.

Permission to use, copy, modify, distribute, and sell this software and
its documentation for any purpose is hereby granted without fee,
provided that (i) the above copyright notice and this permission notice
appear in all copies of the software and related documentation, (ii) the
name TargetJr Consortium (represented by GE CRD), may not be used
in any advertising or publicity relating to the software without the
specific, prior written permission of GE CRD, and (iii) any modifications
are clearly marked and summarised in a change history log.

THE SOFTWARE IS PROVIDED “AS IS” AND WITHOUT WARRANTY OF
ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT
LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. IN NO EVENT SHALL THE TARGETJR
CONSORTIUM BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR
CONSEQUENTIAL DAMAGES OF ANY KIND OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
WHETHER OR NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGES,
OR ON ANY THEORY OF LIABILITY ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
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Library Description License

xmlrpcpp C++
implementation
of the XML-RPC
protocol

A full copy of the LGPL license is included in the file COPYING. The
source code is Copyright © 2002-2003 by Chris Morley.

This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published
by the Free Software Foundation; either version 2.1 of the License, or
(at your option) any later version. This library is distributed in the hope
that it will be useful, but WITHOUT ANY WARRANTY; without even the
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU Lesser General Public License for more details.
You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
USA.

Zlib Compression
library

Copyright © 1995-2010 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
arising from the use of this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must
not claim that you wrote the original software. If you use this
software in a product, an acknowledgment in the product
documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must
not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source
distribution.
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Appendix D

End User License Agreement (EULA)
PLEASE READ THIS EULA CAREFULLY BEFORE ORDERING OR DOWNLOADING ANY SOFTWARE FROM THIS WEBSITE.
YOUR ATTENTION IS PARTICULARLY DRAWN TO CLAUSES 12 AND 13 WHERE WE LIMIT OUR LIABILITY TO USERS OF
OUR SOFTWARE PRODUCTS.

IMPORTANT NOTICE TO ALL USERS: BY DOWNLOADING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE
READ THIS EULA, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. IF YOU DO NOT
AGREE TO THE TERMS OF THIS EULA DO NOT DOWNLOAD, INSTALL, COPY OR USE THE SOFTWARE.

IMPORTANT NOTICE TO CONSUMERS: YOU HAVE THE RIGHT TO WITHDRAW FROM YOUR TRANSACTION WITHOUT
CHARGE AND WITHOUT REASON AT ANY TIME BEFORE DOWNLOADING OUR PRODUCT(S). HOWEVER YOU WILL
LOSE THIS RIGHT ONCE YOU BEGIN TO DOWNLOAD OUR PRODUCT(S). THIS DOES NOT AFFECT YOUR CONSUMER
RIGHTS IN RELATION TO DEFECTIVE PRODUCTS OR SERVICES.

This END USER LICENSE AGREEMENT (this "EULA") is incorporated into the agreement between The Foundry
Visionmongers Limited, a company registered in England and Wales, ("The Foundry"), and you, as either an individual
or a single company or other legal entity ("Licensee") on the terms of which you will purchase the products and
services of The Foundry (the “Agreement”).

1. GRANT OF LICENSE

1.1 Subject to the limitations of clause 3 and all the other terms of the Agreement, The Foundry grants to Licensee a
limited, non-transferable (subject to clause 2.1 (b) below) and non-exclusive license to download, install and use a
machine readable, object code version (subject to clause 4 below) of the software program identified in the
Agreement (the "Software") and accompanying user guide and other documentation (the "Documentation"), solely
for Licensee's own internal purposes (the "License"); provided, however, Licensee's right to download, install and use
the Software and the Documentation is limited to those rights expressly set out in this EULA.

1.2 Some types of license in clause 2.1 limit the installation and use of the Software to the country in which Licensee
is based at the date of purchase (the “Home Country”), unless otherwise agreed in writing. Notwithstanding such
limits, Licensee may still use the Software outside the Home Country if traveling or working outside the Home
Country on a temporary basis provided that such use does not exceed 70 days in aggregate in any rolling twelve
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month period or, in the case of a Licensee who has purchased a fixed term license for less than twelve months, does
not exceed the number of days representing 20% of the term of the license.

1.3 Only to the extent that is proportionate to, and reasonably necessary to support, Licensee’s licensed use of the
Software in accordance with the Agreement, Licensee may (provided valid license keys have been obtained) install
the Software on more than one computer, provided always that Licensee’s concurrent use of different installations
of the Software does not exceed the number of valid Licenses that Licensee has paid for.

2. LICENSE MODELS

2.1 For each product purchased, the License shall be one of the following types of license, and is subject to the
following. Please note that some licensing models do not apply to certain products. Whichever licensing model
applies, Licensee shall not at any one time use more copies of the Software than the total number of valid licenses
purchased by Licensee.

(a) “Node Locked License”

If Licensee purchases a Node Locked License, Licensee shall install and use only a single copy of the Software on only
one computer at a time, which may be located anywhere in the Home Country.

(b) “Individual License”

If Licensee purchases an Individual License, Licensee warrants and represents that Licensee is a natural person and
that only Licensee shall use the Software. Licensee may assign the Individual License to another natural person
(“Assignee”); subject to Licensee (i) notifying The Foundry and obtaining its express written consent, (ii) paying an
administrative fee with respect to such transfer, and (iii) after transferring a single copy of the Software to the
Assignee, deleting any copies of the Software that Licensee may have in Licensee’s possession, custody or power. An
Individual License entitles Licensee to use the Software on only one computer at a time, which may be located
anywhere and is not restricted to the Home Country.

(c) “Floating License”

If Licensee purchases a Floating License, use of the Software may be at any site in the Home Country.

2.2 Some of the Software may be made available at concessionary rates as follows:

(a) “Educational License”

If Licensee has purchased the Software on the discount terms offered by The Foundry’s Educational Policy published
on its website (the “Educational Policy”), Licensee warrants and represents to The Foundry as a condition of the
Agreement that: (i) (if Licensee is a natural person) he or she is a part-time or full-time student at the time of
purchase and will not use the Software for any commercial, professional or for-profit purposes; (ii) (if the Licensee is
not a natural person) it is an organization that will use the Software only for the purpose of training and instruction,
and for no other purpose, and (iii) Licensee will at all times comply with the Educational Policy (as such policy may be
amended from time to time). Unless the Educational License is a Floating License, Licensee shall use the Software on
only one computer at a time.
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(b) “Personal Learning Edition License”

If the Software is a Personal Learning Edition (“PLE”), it will not require a license key to be issued to Licensee and will
have limited functionality as described in the Documentation. Licensee may use it only for the purpose of personal
or internal training and instruction, and for no other purpose. PLE versions of the Software may not be used for
commercial, professional or for-profit purposes including, for the avoidance of doubt, the purpose of providing
training or instruction to third parties. Licensee shall use the Software on only one computer at a time.

(c) “MODO Steam Edition”

A version of MODO with limited functionality as described in the Documentation is available to purchase on discount
terms through Valve Corporation’s Steam store. If Licensee has purchased such version, Licensee warrants and
represents to The Foundry as a condition of the Agreement that: (i) Licensee is a natural person; and (ii) Licensee will
use the Software strictly through Steam and only for personal, recreational and non-commercial use, except only
that if Licensee uses the Software to create assets and content Licensee may sell such assets and content through
Valve’s Steam Workshop.

(d) “Trial License”

Licensee may register for a “Trial License” of the Software (not available for all products or in all regions or markets).
A Trial License lasts a limited specified period on the expiry of which the Software will automatically cease to
function. Licensee shall use the Software on only one computer at a time.

(e) “Free License”

Licensee may register for a “Free License” of selected Software from The Foundry (not available for all products or in
all regions or markets). A Free License lasts a limited specified period on the expiry of which the Software will cease to
function; in normal circumstances a replacement to cover a new, time limited, period will be issued. Licensee shall use
the Software on only one computer at a time.

2.3 If Licensee has purchased a License that permits “non-interactive” use of the Software (“Headless Rendering”),
Licensee is authorized to use a non-interactive version of the Software for rendering purposes only (i.e. without a
user, in a non-interactive capacity) and shall not use such Software on workstations or otherwise in a user-interactive
capacity. Headless Rendering is not available on all products. In all cases except MODO (in respect of which there is
no limit on the amount of Headless Rendering allowed), Headless Rendering licenses are limited to one computer
such that the number of computers on which Headless Rendering can be carried out is limited to the number of valid
Licenses that have been purchased.

3. RESTRICTIONS ON USE

Please note that in order to guard against unlicensed use of the Software a license key is required to
access and enable the Software (other than Software which is licensed under the Personal Learning Edition
model – see clause 2.2 (b) above). Licensee is authorized to use the Software in machine readable, object code form
only (subject to clause 4), and Licensee shall not: (a) assign, sublicense, sell, distribute, transfer, pledge, lease, rent,
lend, share or export the Software, the Documentation or Licensee's rights under this EULA; (b) alter or circumvent
the license keys or other copy protection mechanisms in the Software or reverse engineer, decompile, disassemble or
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otherwise attempt to discover the source code of the Software; (c) (subject to clause 4) modify, adapt, translate or
create derivative works based on the Software or Documentation; (d) use, or allow the use of, the Software or
Documentation on any project other than a project produced by Licensee (an "Authorized Project") or to provide a
service (whether or not any charge is made) to any third party; (e) allow or permit anyone (other than Licensee and
Licensee's authorized employees to the extent they are working on an Authorized Project) to use or have access to
the Software or Documentation; (f) copy or install the Software or Documentation other than as expressly provided
for in this EULA; or (g) take any action, or fail to take action, that could adversely affect the trademarks, service
marks, patents, trade secrets, copyrights or other intellectual property rights of The Foundry or any third party with
intellectual property rights in the Software (each, a "Third Party Licensor"). For purposes of this clause 3, the term
"Software" shall include any derivatives of the Software.

Unless Licensee has purchased an Individual License, if the Software is moved from one computer to another, the
issuing of replacement or substituted license keys is subject to and strictly in accordance with The Foundry’s License
Transfer Policy, which is available on The Foundry’s website and which requires a fee to be paid in certain
circumstances. The Foundry may from time to time and at its sole discretion vary the terms and conditions of the
License Transfer Policy.

4. SOURCE CODE

Notwithstanding that clause 1 defines “Software” as an object code version and that clause 3 provides that Licensee
may use the Software in object code form only:

4.1 if The Foundry has agreed to license to Licensee (including by way of providing SDKs, upgrades, updates or
enhancements/customization) source code or elements of the source code of the Software, the intellectual property
rights in which belong either to The Foundry or to a Third Party Licensor (“Source Code”), Licensee shall be licensed to
use the Source Code as Software on the terms of this EULA and: (a) notwithstanding clause 3 (c) Licensee may use
the Source Code at its own risk in any reasonable way for the limited purpose of enhancing its use of the Software
solely for its own internal business purposes and in all respects in accordance with this EULA; (b) Licensee shall in
respect of the Source Code comply strictly with all other restrictions applying to its use of the Software under this
EULA as well as any other restriction or instruction that is communicated to it by The Foundry at any time during the
Agreement (whether imposed or requested by The Foundry or by any Third Party Licensor);

4.2 to the extent that the Software links to any open source software libraries (“OSS Libraries”) that are provided to
Licensee with the Software, nothing in the Agreement shall affect Licensee’s rights under the licenses on which the
relevant Third Party Licensor has licensed the OSS Libraries, as stated in the Documentation. To the extent that Third
Party Licensors have licensed OSS Libraries on the terms of v2.1 of the Lesser General Public License issued by the
Free Software Foundation (see http://www.gnu.org/licenses/lgpl-2.1.html) (the “LGPL”), those OSS Libraries are
licensed to Licensee on the terms of the LGPL and are referred to in this clause 4.2 as the LGPL Libraries. The
Foundry will at any time during the three year period starting on the date of the Agreement, at the request of
Licensee and subject to Licensee paying to The Foundry a charge that does not exceed The Foundry’s costs of doing
so, provide Licensee with the source code of the LGPL Libraries (the “LGPL Source”) in order that Licensee may
modify the LGPL Libraries in accordance with the LGPL, together with certain object code of the Software necessary
to enable Licensee to re-link any modified LGPL Library to the Software (he “Object”); and
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4.3 notwithstanding any other term of the Agreement The Foundry gives no express or implied warranty,
undertaking or indemnity whatsoever in respect of the Source Code, the OSS Libraries (including the LGPL Libraries),
the LGPL Source or the Object, all of which are licensed on an “as is” basis, or in respect of any modification of the
Source Code, the OSS Libraries (including the LGPL Libraries) or the LGPL Source made by Licensee (“Modification”).
Licensee may not use the Object for any purpose other than its use of the Software in accordance with this EULA.
Notwithstanding any other term of the Agreement, The Foundry shall have no obligation to provide support,
maintenance, upgrades or updates of or in respect of any of the Source Code, the OSS Libraries (including the LGPL
Libraries), the LGPL Source, the Object or any Modification. Licensee shall indemnify The Foundry against all liabilities
and expenses (including reasonable legal costs) incurred by The Foundry in relation to any claim asserting that any
Modification infringes the intellectual property rights of any third party.

5. BACK-UP COPY

Licensee may store one copy of the Software and Documentation off-line and off-site in a secured location within
the Home Country that is owned or leased by Licensee in order to provide a back-up in the event of destruction by
fire, flood, acts of war, acts of nature, vandalism or other incident. In no event may Licensee use the back-up copy of
the Software or Documentation to circumvent the usage or other limitations set forth in this EULA.

6. OWNERSHIP

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that is licensed to
Licensee) and Documentation and all related intellectual property rights and other proprietary rights are and shall
remain the sole property of The Foundry and the Third Party Licensors. Licensee shall not remove, or allow the
removal of, any copyright or other proprietary rights notice included in and on the Software or Documentation or
take any other action that could adversely affect the property rights of The Foundry or any Third Party Licensor. To
the extent that Licensee is authorized to make copies of the Software or Documentation under this EULA, Licensee
shall reproduce in and on all such copies any copyright and/or other proprietary rights notices provided in and on
the materials supplied by The Foundry hereunder. Nothing in the Agreement shall be deemed to give Licensee any
rights in the trademarks, service marks, patents, trade secrets, confidential information, copyrights or other
intellectual property rights of The Foundry or any Third Party Licensor, and Licensee shall be strictly prohibited from
using the name, trademarks or service marks of The Foundry or any Third Party Licensor in Licensee's promotion or
publicity without The Foundry's express written approval.

Subject to clause 4.3, The Foundry undertakes (the “Undertaking”) to defend Licensee or at The Foundry’s option
settle any claim brought against Licensee alleging that Licensee’s possession or use of the Software or
Documentation in accordance with the Agreement infringes the intellectual property rights of a third party in the
same country as Licensee (“Claim”) and shall reimburse all reasonable losses, damages, costs (including reasonable
legal fees) and expenses incurred by or awarded against Licensee in connection with any such Claim, provided that
the undertaking shall not apply where the Claim in question is attributable to possession or use of the Software or
Documentation other than in accordance with the Agreement, or in combination with any hardware, software or
service not supplied or specified by The Foundry. The Undertaking is conditional on Licensee giving written notice of
the Claim to The Foundry as soon as reasonably possible, cooperating in the defence of the Claim and not making
any admission of liability or taking any step prejudicial to the defence of the Claim. If any Claim is made, or in The
Foundry's reasonable opinion is likely to be made, against Licensee, The Foundry may at its sole option and expense
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(a) procure for Licensee the right to continue using the Software, (b) modify the Software so that it ceases to be
infringing, (c) replace the Software with non-infringing software, or (d) terminate the Agreement immediately by
notice in writing to Licensee and refund the License Fee (less a reasonable sum in respect of Licensee's use of the
Software to the date of termination) on return of the Software and all copies. The Undertaking constitutes Licensee's
exclusive remedy and The Foundry's only liability in respect of Claims.

7. LICENSE FEE

Licensee acknowledges that the rights granted to Licensee under this EULA are conditional on Licensee's payment in
full of the license fee payable in connection with the Agreement (the "License Fee").

8. UPGRADES/ENHANCEMENTS

If the Licensee has paid an annually renewable fee for access to support, upgrades and updates for the Software
("Annual Upgrade and Support Programme"), this is subject to the terms and conditions for the Annual Upgrade and
Support Programme available on The Foundry's website. The Foundry may from time to time and at its sole
discretion vary the terms and conditions of the Annual Upgrade and Support Programme.

9. TAXES AND DUTIES

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax (exclusive of taxes
based on net income), duty, tariff or other impost related to or arising from the transaction contemplated by the
Agreement.

10. LIMITED WARRANTY

10.1 Subject to clause 10.3, The Foundry warrants that, for a period of ninety (90) days after Licensee first
downloads the Software (“Warranty Period”): (a) that the Software will, when properly used on an operating system
for which it was designed, perform substantially in accordance with the functions described in the Documentation;
and (b) that the Documentation correctly describe the operation of the Software in all material respects. If, within
the Warranty Period, Licensee notifies The Foundry in writing of any defect or fault in the Software as a result of
which it fails to perform substantially in accordance with the Documentation, The Foundry will, at its sole option,
either repair or replace the Software, provided that Licensee makes available all the information that may be
necessary to identify, recreate and remedy the defect or fault. This warranty will not apply to any defect or fault
caused by unauthorised use of or any amendment made to the Software by any person other than The Foundry. If
Licensee is a consumer, the warranty given in this clause is in addition to Licensee’s legal rights in relation to any
Software or Documentation that is faulty or not as described.

10.2 The Foundry does not warrant that the Software or Documentation will meet Licensee's requirements or that
Licensee's use of the Software will be uninterrupted or error free.

10.3 If Licensee purchases a license of the Software that is of a fixed term duration, the Warranty Period in clause
10.1 shall apply only to Licensee’s first purchase of such license and not to any subsequent renewal(s) even if a
renewal involves another download.
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11. INDEMNIFICATION

Licensee agrees to indemnify, hold harmless and defend The Foundry, the Third Party Licensors and The Foundry's
and each Third Party Licensor’s respective affiliates, officers, directors, shareholders, employees, authorized resellers,
agents and other representatives from all claims, defence costs (including, but not limited to, legal fees), judgments,
settlements and other expenses arising from or connected with any claim that any authorised or unauthorised
modification of the Software or Documentation by Licensee or any person connected with Licensee infringes the
intellectual property rights or other proprietary rights of any third party.

12. LIMITATION OF LIABILITY TO BUSINESS USERS

This clause applies where Licensee is a business user. Licensee acknowledges that the Software has not been
developed to meet its individual requirements, and that it is therefore Licensee’s responsibility to ensure that the
facilities and functions of the Software as described in the Documentation meet such requirements. The Software
and Documentation is supplied only for Licensee’s internal use for its business, and not for any re-sale purposes or
for the provision of services to third parties. The Foundry shall not under any circumstances whatever be liable to
Licensee, whether in contract, tort (including negligence), breach of statutory duty, or otherwise, arising under or in
connection with the Agreement for loss of profits, sales, business, or revenue, business interruption, loss of
anticipated savings, loss or corruption of data or information, loss of business opportunity, goodwill or reputation or
any indirect or consequential loss or damage. In respect of any other losses, The Foundry’s maximum aggregate
liability under or in connection with the Agreement whether in contract, tort (including negligence) or otherwise, shall
in all circumstances be limited to the greater of US$5000 and a sum equal to the License Fee. Nothing in the
Agreement shall limit or exclude our liability for death or personal injury resulting from our negligence, fraud or
fraudulent misrepresentation or for any other liability that cannot be excluded or limited by applicable law. This
EULA sets out the full extent of our obligations and liabilities in respect of the supply of the Software and
Documents. Except as expressly stated in this EULA, there are no conditions, warranties, representations or other
terms, express or implied, that are binding on The Foundry. Any condition, warranty, representation or other term
concerning the supply of the Software and Documentation which might otherwise be implied into, or incorporated
in, the Agreement, whether by statute, common law or otherwise, is excluded to the fullest extent permitted by law.

13. LIMITATION OF LIABILITY TO CONSUMERS

This clause applies where Licensee is a consumer. Licensee acknowledges that the Software has not been developed
to meet Licensee’s individual requirements, and that it is therefore Licensee’s responsibility to ensure that the
facilities and functions of the Software as described in the Documentation meet such requirements. The Software
and Documentation are only supplied for Licensee’s domestic and private use. Licensee agrees not to use the
Software and Documentation for any commercial, business or re-sale purposes, and The Foundry has no liability to
Licensee for any loss of profit, loss of business, business interruption, or loss of business opportunity. The Foundry
is only responsible for loss or damage suffered by Licensee that is a foreseeable result of The Foundry’s breach of the
Agreement or its negligence but The Foundry is not responsible for any loss or damage that is not foreseeable. Loss
or damage is foreseeable if they were an obvious consequence of a breach or if they were contemplated by Licensee
and The Foundry at the time of forming the Agreement. Our maximum aggregate liability under or in connection
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with the Agreement, whether in contract, tort (including negligence) or otherwise, shall in all circumstances be limited
to a sum equal to the greater of US$5000 and a sum equal to the License Fee. Nothing in the Agreement shall limit
or exclude our liability for death or personal injury resulting from our negligence, fraud or fraudulent
misrepresentation or for any other liability that cannot be excluded or limited by applicable law.

14. TERM; TERMINATION

The Agreement is effective upon Licensee's download of the Software, and the Agreement will remain in effect until
termination. Licensee may terminate the Agreement at any time on written notice to The Foundry. If Licensee
breaches the Agreement, The Foundry may terminate the License by notice to Licensee. If the Agreement is
terminated, the License will cease immediately and Licensee will either return to The Foundry all copies of the
Software and Documentation in Licensee's possession, custody or power or, if The Foundry directs in writing,
destroy all such copies. In the latter case, if requested by The Foundry, Licensee shall provide The Foundry with a
certificate confirming that such destruction has been completed.

15. CONFIDENTIALITY

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is licensed to
Licensee) and Documentation are proprietary to and the confidential information of The Foundry or, as the case
may be, the Third Party Licensors, and that all such information and any related communications (collectively,
"Confidential Information") are confidential and a fundamental and important trade secret of The Foundry and/or
the Third Party Licensors. If Licensee is a business user, Licensee shall disclose Confidential Information only to
Licensee's employees who are working on an Authorized Project and have a "need-to-know" such Confidential
Information, and shall advise any recipients of Confidential Information that it is to be used only as expressly
authorized in the Agreement. Licensee shall not disclose Confidential Information or otherwise make any
Confidential Information available to any other of Licensee's employees or to any third parties without the express
written consent of The Foundry. Licensee agrees to segregate, to the extent it can be reasonably done, the
Confidential Information from the confidential information and materials of others in order to prevent commingling.
Licensee shall take reasonable security measures, which measures shall be at least as great as the measures Licensee
uses to keep Licensee's own confidential information secure (but in any case using no less than a reasonable degree
of care), to hold the Software, Documentation and any other Confidential Information in strict confidence and safe
custody. The Foundry may request, in which case Licensee agrees to comply with, certain reasonable security
measures as part of the use of the Software and Documentation. This clause shall not apply to any information that
is in or comes into the public domain, or was in Licensee’s lawful possession before receipt or which Licensee
develops independently and without breach of this clause. Licensee acknowledges that monetary damages may not
be a sufficient remedy for unauthorized disclosure of Confidential Information, and that The Foundry shall be
entitled, without waiving any other rights or remedies, to such injunctive or other equitable relief as may be deemed
proper by a court of competent jurisdiction.

16. INSPECTION AND INFORMATION

16.1 Unless Licensee is a consumer, Licensee shall advise The Foundry on demand of all locations where the
Software or Documentation is used or stored. Licensee shall permit The Foundry or its authorized agents to audit all
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such locations during normal business hours and on reasonable advance notice.

16.2 The Software may include mechanisms to collect limited information from Licensee’s computer(s) and transmit
it to The Foundry. Such information (the “Information”) may include details of Licensee’s hardware, details of the
operating system(s) in use on such hardware and the profile and extent of Licensee’s use of the different elements of
the Software. The Foundry may use the Information to (a) model the profiles of usage, hardware and operating
systems in use collectively across its customer base in order to focus development and support, (b) to provide
targeted support to individual customers, (c) to ensure that the usage of the Software by Licensee is in accordance
with the Agreement and does not exceed any user number or other limits on its use, and (d) to advise Licensee about
service issues such as available upgrades and maintenance expiry dates. To the extent that any Information is
confidential to Licensee it shall be treated as such by The Foundry. To the extent that any Information constitutes
personal data for the purposes of the Data Protection Act 1998 it shall be processed by The Foundry in accordance
with that Act and with The Foundry’s privacy policy (see http://www.thefoundry.co.uk/privacy/). Licensee
undertakes to make all of users of the Software aware of the uses which The Foundry will make of the Information
and of the terms of The Foundry’s privacy policy.

17. U.S. GOVERNMENT LICENSE RIGHTS

All Software, including all components thereof, and Documentation qualify as “commercial items,” as that term is
defined at Federal Acquisition Regulation (“FAR”) (48 C.F.R.) 2.101, consisting of “commercial computer software”
and “commercial computer software documentation” as such terms are used in FAR 12.212. Consistent with FAR
12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-4, and notwithstanding any other FAR or other
contractual clause to the contrary in any agreement into which this Agreement may be incorporated, a government
end user will acquire the Software and Documentation with only those rights set forth in this Agreement. Use of
either the Software or Documentation or both constitutes agreement by the government that all Software and
Documentation are “commercial computer software” and “commercial computer software documentation,” and
constitutes acceptance of the rights and restrictions herein. The Software is the subject of the following notices:

* Copyright © 2001 - 2014 The Foundry Visionmongers Limited. All Rights Reserved.

* Unpublished-rights reserved under the Copyright Laws of the United Kingdom.

18. SURVIVAL.

Clause 6 and clauses 9 to 20 inclusive shall survive any termination or expiration of the Agreement.

19. IMPORT/EXPORT CONTROLS

To the extent that any Software made available under the Agreement is subject to restrictions upon export and/or
re-export from the United States, Licensee agrees to comply with, and not act or fail to act in any way that would
violate, the applicable international, national, state, regional and local laws and regulations, including, without
limitation, the United States Foreign Corrupt Practices Act, the Export Administration Act and the Export
Administration Regulations, as amended or otherwise modified from time to time, and neither The Foundry nor
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Licensee shall be required under the Agreement to act or fail to act in any way which it believes in good faith will
violate any such laws or regulations.

20. MISCELLANEOUS

Unless Licensee is a consumer, the Agreement is the exclusive agreement between the parties concerning its subject
matter and supersedes any and all prior oral or written agreements, negotiations, or other dealings between the
parties concerning such subject matter. Licensee acknowledges that Licensee has not relied upon any representation
or collateral warranty not recorded in the Agreement inducing it to enter into the Agreement. The Agreement may be
modified only in writing. The failure of either party to enforce any rights granted under the Agreement or to take
action against the other party in the event of any such breach shall not be deemed a waiver by that party as to
subsequent enforcement of rights or subsequent actions in the event of future breaches. The Agreement and any
dispute or claim arising out of or in connection with it or its subject matter or formation (including, unless Licensee is
a consumer, non-contractual disputes or claims) shall be governed by, and construed in accordance with English Law
and the parties irrevocably submit to the non-exclusive jurisdiction of the English Courts, subject to any right that a
consumer may have to bring proceedings or to have proceedings brought against them in a different jurisdiction.

If The Foundry fails to insist that Licensee performs any obligation under the Agreement, or delays in doing so, that
will not mean that The Foundry has waived its rights.

Unless Licensee is a consumer, Licensee agrees that The Foundry may refer to Licensee as a client or a user of the
Software, may display its logo(s) for this purpose and may publish quotations and testimonials from Licensee, its
directors, partners, officers or employees. The Foundry agrees to promptly cease any such use on Licensee’s written
request.

The Foundry and Licensee intend that each Third Party Licensor may enforce against Licensee under the Contracts
(Rights of Third Parties) Act 1999 (the “Act") any obligation owed by Licensee to The Foundry under this EULA that is
capable of application to any proprietary or other right of that Third Party Licensor in or in relation to the Software.
The Foundry and Licensee reserve the right under section 2(3)(a) of the Act to rescind, terminate or vary this EULA
without the consent of any Third Party Licensor.

Copyright © 2014 The Foundry Visionmongers Limited. All Rights Reserved. Do not duplicate.
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