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1  PREFACE

Hiero is designed to provide shot management, conform, and playback 
capabilities for people creating visual effects, especially those using The 
Foundry’s Nuke Compositor. Hiero interoperates well with Nuke to deliver 
visual effects sequences without resorting to other third party applications.

For post-production houses creating visual effects in a collaborative 
manner, Hiero’s easy round tripping of clips to Nuke frees expensive “hero” 
seats that are currently being used as conform, review, and project 
management stations, allowing for more efficient use of staff and resources 
in those facilities.

Key Features • Hiero can “soft import” any image sequence type supported by Nuke, 
meaning the media is not copied multiple times saving disk space. In 
addition, Hiero can also ingest audio and multi-channel images.

• Multi-track Timelines capable of conforming Final Cut Pro XML and CMX 
3600 Edit Decision Lists (EDLs), including cuts, transitions and retimes.

• Realtime playback of sequences and clips (dependent on hardware).

• Round-tripping through Nuke and general purpose shot export for other 
uses using “soft exports” in most cases—no bakes are required.

• Versions and Snapshots of clips and sequences allow you to record 
progress and manage your creative options.

• Everything you can do with Hiero’s user interface you can also do using 
Python scripting.



PREFACE 7
Project Workflow and Hiero 
Project Workflow 
and Hiero

For short-form post projects, Hiero sits after edit and grading, but before 
finishing and delivery, acting as the conform Timeline for visual effects. It is 
used to locate, preview, and then farm footage out to shot based effects 
applications (such as Nuke), and take their results and re-integrate them 
onto the sequences for review and comment.

Figure 1.1: Where Hiero fits in short-form post workflows.

About this Guide Throughout this User Guide, we assume you have a basic knowledge of 
video and audio theory, as well as proficiency with the operating system on 
which Hiero is installed.

There are a few style conventions that you should be aware of throughout 
this Guide:

Note This text provides important or useful information for the smooth operation 
of Hiero.

Tip These are extra bits of information, not necessarily critical to the procedure 
you’re performing, but worth knowing.

Bold text denotes onscreen points of interest such as tabs, buttons, and 
menu items.

Underlined text highlights links to our website with automatic redirection to 
the relevant page.

For the most up-to-date information, please see the Hiero product page 
and the latest Hiero User Guide on our web site at www.thefoundry.co.uk.

Getting Help If you can’t find what you need in this document, there are other sources of 
help available to you for all aspects of Hiero and its operation.
Hiero 1.0v1The Foundry
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PREFACE 8
Getting Help 
Online Help Most controls offer concise instructions in the form of tooltips. To display 
the tooltips, hover your mouse pointer over an interface control or 
parameter.

Figure 1.2: Tooltips

Customer Support Should questions arise that this manual or the online help system fails to 
address, you can contact Customer Support directly by email at 
support@thefoundry.co.uk or telephone to our London office on +44 (0)20 
7968 6828 or to our Los Angeles office on (310) 399 4555 during office 
hours.
Hiero 1.0v1The Foundry



2  INSTALLATION AND LICENSING

Installing and licensing new applications can be a boring task that you just 
want to be done with as soon as possible. To help you with that, this 
chapter guides you to the point where you have a default Hiero workspace 
in front of you and are ready to start viewing and editing your media with 
the minimum of effort.

System 
Requirements

Before you do anything else, ensure that whichever platform you intend to 
run Hiero on meets the following minimum requirements.

Operating System Mac OS X

• Mac OS X Snow Leopard 10.6.8 or newer

Linux

• Linux RHEL 5.4 64-bit

• Graphics driver support for OpenGL 2.0

Hardware • 4 GB of disk space available for caching and temporary files

• 4 GB of RAM (minimum requirement)

• Intel i3 CPU (or equivalent)

• Workstation-class graphics card with OpenGL 2.0 driver support, such 
as NVIDIA Quadro series or ATI FireGL series

Installing Hiero Download Hiero from www.thefoundry.co.uk/products/hiero/get/ by clicking 
Buy Hiero and choosing the required platform from the list. For example, if 
you intend to install Hiero on Mac OS X, download the .dmg file.

Follow the on screen instructions to download the correct installer.

Mac OS X

1. Double-click on the .dmg archive to extract the installation package.

2. Double-click on the .pkg file.

http://www.thefoundry.co.uk/products/hiero/get/
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Launching Hiero 
3. Follow the on-screen instructions to install Hiero. By default, Hiero is 
installed to /Applications/Hiero1.0v1.

Linux

1. Extract the installer from the archive using the following terminal com-
mand:
tar xvzf Hiero1.0v1-linux-x86-release-64.tgz

2. Run the installer. 
sudo ./Hiero1.0v1-linux-x86-release-64.run

3. Follow the on-screen instructions. By default, Hiero is installed to 
/usr/local/Hiero1.0v1.

Launching Hiero Launch Hiero using one of the following methods, depending on which 
platform you’re using.

Mac OS X

• Click the Hiero dock icon.

• Using the Finder, open the Hiero application directory (by default, 
/Applications/Hiero1.0v1/), and double-click the Hiero1.0v1.app icon (or 
list item).

• Open a terminal and enter the following command:
open /Applications/Hiero1.0v1/Hiero1.0v1.app

Linux

• Double-click the Hiero icon on the Desktop.

• Open the Hiero application directory (by default, /usr/local/Hiero1.0v1/) 
and double-click the Hiero icon (or list item).

• Open a terminal, navigate to the Hiero application directory (by default, /
usr/local/Hiero1.0v1), and enter ./Hiero1.0v1.

Licensing Hiero About licences

• Activation Keys—these can be used to easily install and activate node 
locked (also known as uncounted) licences. Node locked licences allow 
you to use Hiero on a single machine. This licence does not work on 
different machines and if you need it to, you’ll have to transfer your 
licence. Node locked licences do not require additional licensing software 
to be installed. See Licensing Hiero on a Single Machine for more 
information.
Hiero 1.0v1The Foundry
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Licensing Hiero 
• Floating Licences—also known as counted licences, enable one of our 
products to work on any networked client machine. The floating licence is 
put on the server and is locked to a unique number on that server. 
Floating licences on a server require additional software to be installed. 
This software manages those licences on the server, giving licences out 
to client stations that want them. The software you need to manage 
these licences is called the Foundry Licensing Tools (FLT) which can be 
freely downloaded from our website. Floating licences often declare a 
port number on the server line and a port number on the vendor line. See 
Licensing Hiero Over a Network for more information.

The instructions below run through both licensing methods and you can find 
a more detailed description in the Foundry Licensing Tools User Guide 
available on our website www.thefoundry.co.uk/support/licensing/tools/

Licensing Hiero on a 
Single Machine

You can purchase activation keys over the Internet by clicking Purchase 
Licence in the Hiero licensing dialog that displays when you launch Hiero 
without a licence, or by contacting The Foundry Sales Department at 
sales@thefoundry.co.uk.

Installing the licence

You are prompted to enter your activation key when you start Hiero without 
a licence. Hiero skips this step if you’ve already activated the application.

Select an activation option from the Hiero Licensing dialog:

• Purchase Licence—click to open a web browser directly to The Foundry 
website to purchase an activation key.

• Activate Licence or Use Server—click to enter a previously obtained 
activation key. When you enter the activation key, Hiero automatically 
obtains a licence from the web and installs it on your machine. You’re 
good to go.

Tip If you later want to change your licence (for example, from a node locked 
licence to a floating licence), you can select Help > Licence in Hiero to 
display the Hiero Licensing dialog.

Note If you access the Internet through a proxy server and Hiero cannot connect 
to the activation server, you may get an error dialog prompting you to 
either:

• Click Use Proxy to enter the proxy server name, port number, username, 
and password. This enables Hiero to connect to the activation server and 
obtain a licence. Hiero then installs the licence automatically. 
Hiero 1.0v1The Foundry
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Licensing Hiero 
• Click on the web link in the dialog and use the System ID (also known as 
hostid) provided to manually activate and install a licence. For more 
information on how to install a licence manually, see the Foundry 
Licensing Tools (FLT) User Guide available on our website at
www.thefoundry.co.uk/support/licensing/

Licensing Hiero Over a 
Network

Alternatively, you can purchase a floating licence key from our website. To 
generate you a licence key, we need to know your System ID. The System ID 
(sometimes called Host ID or rlmhostid) returns a unique number for your 
computer. We lock our licence keys to the System ID. See Installing floating 
licences.

To display your System ID, do any of the following:

• Download the Foundry Licence Installer for Hiero (FLI) utility from 
www.thefoundry.co.uk/licensing and run it. Your System ID is displayed.

• Download the Foundry Licensing Tools (FLT) free of charge from our web 
site and then:

• On Mac, run /Applications/TheFoundry/LicensingTools6.0/Foundry 
Licence Installer.app

• On Linux, run the following command in a terminal shell: 
/usr/local/foundry/LicensingTools6.0/bin/systemid

Just so you know what a System ID number looks like, here’s an example: 
000ea641d7a1.

Once you have provided us with your System ID number and a licence key 
has been generated for you, you will receive the licence key in an email or 
Internet download. The licence key is contained in a text file called 
foundry.lic. For information on what to do with the foundry.lic file, see 
Installing floating licences below.

Installing floating licences

If you requested a floating licence from The Foundry, you will receive your 
licence key (foundry.lic) in an email or Internet download. You should also 
receive the Foundry Licence Installer (FLI) application to help you install the 
licence key. The instructions below tell you what to do with these.

Note The FLI is also available to download from www.thefoundry.co.uk/licensing. 

1. Make sure you have saved both the licence key (foundry.lic) and the 
Foundry Licence Installer application in the same directory.

2. Run the Foundry Licence Installer application. 
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Licensing Hiero 
The licence key automatically appears in the FLI window if the FLI and 
foundry.lic are in the same directory. If they are not, you can either copy 
and paste the contents of the licence key or drag-and-drop the file into 
the FLI window.

3. Click Install.

This checks the licence file and, provided that the licence is valid, 
installs it into the correct directory.

In order for the floating licence to work, you will need to install the 
Foundry Licensing Tools (FLT) on the licence server machine. For more 
information on how to install floating licences, refer to the FLT User 
Guide, which you can download from our website: 
www.thefoundry.co.uk/support/licensing/tools/

4. Once your licence server is up and running, launch Hiero (if it isn’t 
already running).

5. Click Activate Licence or Use Server and enter the server address in the 
field provided. The format for the server name is: 
<port>@<servername>, for example, 30001@red.

Note You must perform steps 4 and 5 on each client machine that requires a 
Hiero licence from the server.

Tip If you later need to display the Hiero Licensing dialog again, you can select 
Help > Licence in Hiero.

Further Reading For more information on licensing Hiero, displaying the System ID number, 
setting up a floating licence server, adding new licence keys, and managing 
licence usage across a network, you should read the Foundry Licensing 
Tools User Guide available on our website:
www.thefoundry.co.uk/support/licensing/tools/
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3  CUSTOMISING YOUR WORKSPACE

Workspace 
Overview

Hiero’s interface is customisable using floating panes and show/hide 
functionality, but three default workspaces are supplied for your 
convenience; Conforming, Editing, and Reviewing.

• The Conforming workspace is where the bulk of the work you undertake 
with Hiero is done. The linked Spreadsheet and Timeline panes are where 
you’ll really see the power of Hiero.

• The Editing workspace provides the tools you’ll need to fine-tune your 
media.

• The default Reviewing workspace is used primarily to confirm your 
media intent is fully realised. You can add tags and notes, mark In and 
Out points on clips, and organise your ingested media into bins as 
required.

When you launch Hiero for the first time, you’re presented with a Settings 
dialog.

Note You can disable this popup by checking Don’t show this dialog again or by 
toggling it off in the Hiero Workspace Preferences dialog.

The Settings dialog allows you to create a new project, open an existing 
project, or view the User Guide and website dedicated to Hiero.

Select the required option or click Close to launch Hiero.
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Workspace Overview 
Take a moment to familiarise yourself with the default Reviewing 
workspace.

1. Project tab—manage all aspects of your projects and Bins.

2. Menu bar—access Hiero’s drop down menus.

3. Viewer tab—display and review your media.

4. Media tab—displays any clip options and metadata relating to the clip in 
the Viewer.

5. Scopes tab—displays Luma and RGB information for the currently 
selected Viewer.

6. Bin View—displays the contents of the Bin selected in the Project 
browser.

Menu Bar Components The Menu Bar contains various Hiero controls, many of which are available 
through context sensitive right-click menus, keyboard shortcuts, and 
toolbars. 

For a full list of hotkeys, buttons, and menu functions refer to Appendix A: 
Hiero Hotkeys.

You can switch between workspaces by navigating to Window > 
Workspace and selecting Conform, Editing, or Reviewing as shown. 
Alternatively, you can toggle between the default workspaces using cmd/
ctrl + 1, cmd/ctrl + 2, and cmd/ctrl + 3.

Any custom workspaces you create are added to the end of the list. You can 

Viewer

Bin View Scopes

MenuProject Media
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Creating Your Own Workspace 
access the first custom workspace using cmd/ctrl + 4, and so on.

Creating Your Own 
Workspace

Hiero’s workspace consists of panes, which act like containers, and tabs 
which describe the individual areas you work with in Hiero. During the 
customisation process, you can:

• Resize your entire workspace or panes independently.

• Split panes to create new work areas, for example two Viewers side-by-
side.

• Add and remove panes and tabs as required.

• Float and nest tabs to group similar functions together, for example 
Histogram, Vectorscope, and Waveform in the same pane.

• Maximise the pane under the mouse cursor by pressing ~ (tilde). Press ~ 
again to return to the regular interface.

Hiero allows you to create as many workspaces as you require, one for each 
project you undertake if necessary. In practice though, you may find that 
two or three custom workspaces will cover your needs.

Tip You can return to the saved version of a workspace by navigating to 
Window > Workspace > Reset Workspace.

Resizing your workspace

Resizing the interface, panes, and tabs works in much the same way as 
other software applications:

• To resize the entire interface, drag the resize handle at the bottom right 
of the application to the required width and height.

• To resize individual panes, hover the mouse over the edges of the 
required area until the cursor changes to the resize icon. 
Click and drag the cursor to resize the pane or tab.
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Creating Your Own Workspace 
Splitting panes

Splitting panes allows you to organise your workspace into distinct areas 
delineated by well defined borders.

• To split panes, right-click the required pane and select Split Vertical or 
Split Horizontal.

Adding and removing panes and tabs

Adding and removing tabs gives you the freedom to personalise your 
workspace depending on your current project.

• Add new tabs by navigating to Window and selecting the required tab.

The tab is embedded in its default position or added to the interface as a 
floating window. 

• Close any tab that is not required by:

• Clicking the x on the tab’s right-hand side,
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Creating Your Own Workspace 
OR

• Right-clicking the tab name and selecting Close Pane or Close Tab.

Floating and nesting

You can move existing panes and tabs to new locations in the interface (to 
help you organise your project).

• Float a pane or tab by:

• Right-clicking the tab name and selecting Float Pane or Float Tab.

OR

• Dragging the required tab from its current location.
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Creating Your Own Workspace 
• Nest any floating pane or tab by dragging it to any existing pane.

Tip Use the orange highlight  around the destination pane to help you 
determine where the tab nests.

Saving Workspaces Once you’re happy with the changes you’ve made to the workspace, 
navigate to Window > Workspace > Save Workspace.

Enter a name for the workspace, then click OK to preserve your workspace 
as a Hiero workspace file (extension .hws).
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Creating Your Own Workspace 
Tip If you save a workspace called Conforming, Editing, or Reviewing, you can 
override the defaults supplied with Hiero by clicking Save in the dialog box.

Delete the workspace you created to restore the default layout.

Loading Workspaces To use a previously saved workspace, navigate to Window > Workspace 
and select the custom workspace name you require.

Tip Alternatively, you can use the workspace hotkey cmd/ctrl + n (where n = 
the number of the custom workspace).

Your presaved workspace is loaded.

Deleting Workspaces You may find that after using Hiero on a number of projects, some of the 
workspaces you created earlier have been superceded by more useful 
entries. Delete Workspace allows you clear up your saved files from within 
Hiero, although you can remove the files manually from the save location.

Tip You can return to the saved version of a workspace by navigating to 
Window > Workspace > Reset Workspace.
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Workspace Preferences 
To delete custom workspaces: 

1. Navigate to Window > Workspace > Delete Workspace.

2. Select the required workspace from the drop down menu.

3. Click OK to delete the selected entry.

Workspace 
Preferences

The Preferences dialog allows you to make global changes to the way the 
interface behaves every time you start Hiero. Changes you make in the 
Preferences override any local changes when you restart Hiero.

To access the Preferences dialog, either:

• Navigate to Hiero > Preferences, or

• Use the Preferences hotkey cmd/ctrl + , (comma).

• General preferences take care of how Hiero starts up and how often 
your work is automatically saved.

• Startup Workspace—select the default workspace Hiero loads at 
startup.

• Show splash screen—enable or disable Hiero’s product page during 
startup.
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Workspace Preferences 
• Reconstruct directories—set whether or not Hiero preserves the orig-
inal folder/file hierarchy during ingest.

• Show startup dialog—enable or disable Hiero’s Settings dialog during 
startup.

• Autosave period—set how often you want Hiero to save your work in 
the background. Use the up and down arrows or type a new value in 
the field.

• Restore workspace—whether Hiero restores the saved workspace 
layout or uses the default Conforming, Reviewing, or Editing work-
spaces when you open an existing project.

• Automatically save RMD files—enable this option to automatically 
save changes you make to clip RED Look effects as RMD files.

• Nuke Path—sets the filepath to the Nuke application you intend to use 
during round-tripping and Send to Nuke exports.

• Use For Hiero Renders—when enabled, the Nuke application specified 
in Nuke Path is used to render your output. When disabled, the inter-
nal command line only Nuke is used for rendering.

• Use interactive Nuke licence—when enabled, renders on external 
Nukes use an interactive licence (if available).

• Temp Directory—defines the directory used to cache data, including 
thumbnail information.

Note You can disable caching using an environment variable as described in Hiero 
Environment Variables.

• Viewers preferences determine the default settings for the Viewer at 
startup as well as all new Viewers that you add to the workspace—you 
can still adjust the settings of individual Viewers.

• Playback Mode—sets the default playback mode for new Viewers.

• OpenColorIO config file—sets the OpenColorIO configuration to use if 
you don’t intend to use the default settings.

Enter the file path of the config file or click Choose to use the browser.

• Guides—select the default Guides to apply to Viewers. Choose from 
No Guides (the default), Title Safe, Action Safe, and Both.

• Playback cache size—sets the percentage of total memory available 
for use as Hiero’s cache.

• Fullscreen Display—controls where the Viewer expands to when in 
Fullscreen mode.

• Timecode preferences determine where selected file types derive their 
timecode.

• Image Sequence—sets where the start timecode for sequences is 
derived.
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Workspace Preferences 
• RED Files—sets the start timecode to use for conformed or ingested 
R3D files.

• Scopes preferences set the Black and White points for Histogram and 
Waveform Out of Range warnings individually, in the range 0-1.

• RED Rocket preferences enable and disable your RED Rocket.

• Sequence preferences set the default frame and sample rate for new 
Timeline panes.

• Colour Management preferences set the default LUT applied for various 
display and file types. For example, setting Viewer to None displays all 
media in new Viewers with no LUT applied to them.

Once you’ve made your selections in the Preference dialog, click OK to 
save your changes. Bear in mind that changing some preferences, for 
example Use RED Rocket card and Scopes, require you to restart Hiero 
before they’re applied.

You can also click Restore Defaults to return to the default Preference 
settings.
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Hiero accepts sequences either from edit decision lists (EDLs) or Final Cut 
Pro XML files from a specified directory structure containing the source 
media files. Hiero attempts to conform the media, warning you if there are 
missing media or multiple “Versions” created from the same source.

See Versions and Snapshots for more information on multiple Versions and 
Snapshot saves.

Hiero conforms EDLs into single tracks, and XMLs into a multi-track 
Timelines. You can either conform into a brand new Timeline, or into an 
existing Timeline by adding new tracks. For example, when conforming 
multiple EDLs into the same Timeline, you would add new tracks for each 
EDL sequence conformed.

Project Settings A good place to start a conform is by defining default Project Settings 
before importing sequences, particularly in the case of EDLs as they may 
not contain framerate information.

Note You can override Project Settings later on when conforming or ingesting 
media.

To define Project Settings:

1. Navigate to Project > Edit Settings.

The Project Settings dialog displays.

2. Click the General submenu to set the Project Name and default Format.

3. Click the Sequence submenu to set the default Timeline Framerate and 
audio Samplerate.
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Importing Sequences 
4. Click the Colour Management submenu to manage the Display and File 
lookup tables.

5. Use the dropdown menus to define how clips in the Viewer, thumbnails, 
and so on are displayed.

6. Click the RED Settings submenu to define the Default Video Decode 
Mode for R3D files.

Importing 
Sequences

Hiero allows you to import your EDL or XML sequences in one of two ways, 
depending on your preferences.

If you’re a menu orientated user:

1. Navigate to File > Import EDL/XML and use the browser to locate the 
EDL or XML.
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Importing Sequences 
2. Select the file and click Open to import the sequence.

Or, if you prefer, you can drag-and-drop the EDL or XML directly from a file 
browser into Hiero:

Note If you’re importing an EDL, bear in mind that there is no guaranteed 
framerate information included in the file.

When you import EDLs, an Import Options dialog displays.

Select the correct frame rate and audio sample rate using the dropdown 
menus, then click OK to import.

After importing the EDL or XML, the Conforming workspace displays and the 
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Importing Sequences 
Media Spreadsheet and Timeline are populated.

Notice that clicking clips in the spreadsheet highlights the same clips on the 
Timeline?

Synchronised video and audio clips are also ganged in the same way.
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Conforming Sequences 
Conforming 
Sequences

Once your sequence is imported, it’s time to begin the conform process.

You can conform sequences using one of three methods, depending on your 
project:

• With no relevant media in the media view, click Match Media in the 
spreadsheet tab and use the browser to locate the folder containing the 
correct media.

Click Open to display the Conform Options dialog box.

Hiero uses a set of conform Rules and Patterns to determine the correct 
media to apply to the sequence:

• Rules—sets the media properties to match during conform. The more 
Rules you have enabled, the greater the accuracy of the conform.

Note You can display the conform Rules matched for each spreadsheet object by 
hovering the cursor over the required entry.

• Patterns—sets the inclusion and exclusion parameters during the con-
form, separated by spaces. For example, *mov *dpx would only include 
or exclude MOV and DPX files.
Hiero 1.0v1The Foundry



CONFORMING 29
Conforming Sequences 
It’s always a good idea to be as specific as possible when searching for 
conform media, but if the need arises conform Rules and Patterns can 
save time.

• When your source media is already known to Hiero, you can drag-and-
drop the root folder from the Bin view onto the Match Media button.

See Ingesting Media for information on getting media into Hiero.

Follow the Conform Options instructions on page 28 to complete the 
conform process.

3. If you want to conform a single entry in the Media Spreadsheet, drag-
and-drop the media from the Bin view onto the required entry in the 
spreadsheet.

Conforming individual pre-ingested media doesn’t require Conform 
Options because Hiero already knows the exact location of the media.

Whichever conform method you choose, Hiero attempts to conform the EDL 
or XML with the selected media.
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Conforming Sequences 
A dialog box informs you of the success rate once the conform is complete.

Successfully conformed media is also displayed in a new Bin under the 
Conform Bin.

About the Media 
Spreadsheet

All clips in a sequence are displayed in an easy to read format in the Media 
Spreadsheet including clip status, the track it resides on, length, and the 
source file location.

After the initial conform, you can use the spreadsheet to locate or replace 
media in the Timeline pane, as well as massage a clip’s timecode if it is 
invalid.

The Media Spreadsheet displays each entry’s current media state:

• —the media was successfully conformed and its timecode is correct. 

• —the media was successfully conformed, but the timecode is 
currently incorrect.

• —the media could not be conformed.

See Managing Timelines for more information on importing tracks and 
reference media.

There are also a number of controls, accessed by clicking the cog icon, that 
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Conforming Sequences 
determine the spreadsheet’s appearance and behaviour:

• Select Matching Name—when enabled, selecting an item in the 
spreadsheet highlights all items with the same name.

• Select Linked—when enabled, selecting an item in the spreadsheet 
highlights other items linked to it, such as audio tracks ingested with 
video tracks.

• Display Speed As—sets the unit used in the Speed column of the 
spreadsheet. Select either fps (frames per second) or% (the percentage 
of the media frame rate).

• Clamp for Speed Edit—sets whether the Source or Destination duration 
is preserved when a retime is applied to an item.

You can also locate or display clips in the Viewer directly from the 
spreadsheet.

Right-click a spreadsheet entry and select the required option:

• Open in Viewer—the selected clip opens in a new Viewer.

• Open in Bin—the selected clip is highlighted in the Bin view.

Adjusting Timecodes You can easily adjust single or multiple clip timecodes:

1. Select all the invalid media in the spreadsheet.

2. Double-click in the Src In column. 
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Conforming Sequences 
3. Adjust the timecode as required. The media changes state to .

Note Timelines start at 01:00:00:00 by default, but you can change this to any 
value using the Sequence tab.

If you’re not sure what the timecode should be, you can:

• Hover the mouse over the target clip in the Spreadsheet to view a 
timecode tooltip.

OR

• Examine the clip’s metadata and calculate the correct Src In:

1. Select the clip or clips in the Conform Bin.

2. Right click and select Show Metadata.

The selected clip metadata is displayed in a floating pane.
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Renaming Shots on 
the Timeline

Once you’ve conformed your EDL or XML, you may want to rename clips on 
the Timeline sequentially for clarity.

To rename clips:

1. Select the clips to rename using the Timeline or spreadsheet view.

2. Right-click on the Timeline to display the context sensitive menu and 
select Rename Shot.

The Rename Shots dialog displays.

3. Enter a name and suitable numeric padding, for example Shot####.

4. Enter the Start# number of the sequence.

5. Enter the required increment, bearing in mind the numeric padding used 
in the Pattern field.

6. Click Apply.

The selected clips are renamed as specified. If you use the defaults, your 
Timeline might appear as follows:
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Saving and Loading 
Projects

Once you have a fully conformed Timeline, you can save your work as Hiero 
project using the .hrox file extension.

To save a project:

1. Navigate to File > Save Untitled 1 or Save Untitled 1 As...

OR

Use the cmd/ctrl + S or Shift + cmd/ctrl + S hotkeys respectively.

The Save Project dialog box displays.

2. Browse to the save location and enter a name for the project.

3. Click Save.

Hiero saves your project to the location specified and appends the .hrox 
file extension automatically.

To load a project:

1. Navigate to File > Open.

Note If you need to open a project that you worked on recently, you can select 
Open Recent to quickly locate your work.
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Saving and Loading Projects 
OR

Use the cmd/ctrl + O hotkey.

The Open Project dialog box displays.

2. Browse to the file location and click Open.

Hiero opens your project and populates the necessary panes automati-
cally.
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5  INGESTING MEDIA

Hiero is able to handle the same file formats as Nuke (on the same 
operating system), including the associated embedded audio and WAV files.

For a full list of supported file formats and playback optimisation, see 
Appendix B: Supported File Formats.

About Clips Hiero’s interface sorts your clips into three broad categories: Audio and 
Video, Audio Only, and Video Only. Clips are displayed differently depending 
on their content, location, and in the case of the Viewer, the current mode 
(see Viewer Tools):

Clips in Bins

Clips in the Viewer

Audio and Video Audio Only Video Only

Audio Only Video Only
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About Clips 
Clips on a Timeline

Clip Opened as Timeline

For more information on Timelines, see Managing Timelines.

Audio and Video Audio Only Video Only

(grey background)

(purple background)
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Ingesting Media 
Ingesting Media Adding media to Hiero is as simple as drag-and-drop from a file browser or 
selecting File > Import Clips or Import Folder. Hiero imports your media into 
the Bin view providing you with a thumbnail of all of your clips and 
preserving the original folder and file hierarchy.

Using Drag-and-Drop Simply locate your media in a file browser and drag the clip, folder, or 
folders into Hiero’s Project tab.

Using the File Menu If you’re used to working with menus, you can also import clips using the 
file browser. You can import individual clip files or entire folders, depending 
on the amount of media you intend to use.

1. Navigate to File > Import Clips or Import Folders. 

Tip You can also use the cmd/ctrl + I and shift + cmd/ctrl + I hotkeys.
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Viewing Media 
A browser dialog box displays.

2. Select the file(s) or folder(s) that you require and click Open. 

Hiero automatically sorts through the folders you select and only 
imports supported file types.

Viewing Media To view your media in the Viewer, simply drag-and-drop the clip or 
sequence from the Project tab on to a Viewer input. 

Viewer Tools The Viewer has two sets of tools for manipulating your media: the Viewer 
tools and the playback tools. The Viewer tools, located at the top of the 
Viewer, are used to affect the mouse pointer as you move over the Viewer, 
and to select Viewer preferences.

Icon Function Description

Colour 
Sample

Enable or disable the RGB colour information sampler in the Viewer.

ROI Click and drag to define a Region of Interest (ROI) in the Viewer. The 
scopes only display information within the ROI, when active.
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Viewing Media 
Linux Playback Running Hiero on Linux machines with NVIDIA graphics cards can suffer 
from tearing in the Viewer due to issues with OpenGL.

To avoid tearing:

1. From the console, enter:

nvidia-settings

The NVIDIA X Server Settings dialog box displays.

2. Navigate to X Screen 0 > OpenGL Settings.

SplitWipe When both Viewer inputs contain an image, enable SplitWipe to 
compare the two images.

Gain Adjusts the gain applied to the linear input image before viewing, 
but doesn’t affect your exported image.

Gamma Adjusts the gamma applied to the image after the viewing transform, 
but doesn’t affect your exported image.

Channels Select the channel(s) to output to the Viewer, for example RGB, sin-
gle channel, or Luma.

Viewer LUT Set the LUT used to display images in the Viewer, for example sRGB, 
rec709, and REDLog.

Guides Enable or disable overlay bounding boxes, for example Action Safe.

Blanking Enable or disable a range of Viewer masks, for example 16:9.

Non RT Play-
back

Sets the Viewer playback mode if realtime cannot be achieved, for 
example Skip Frames. The default is Play All Frames.

Clipping Enable or disable Hiero’s clipping warning tool to alert you when the 
image is under or over exposed.

View Select the Viewer display mode, for example Audio and Video or 
Video Only.

Viewer
Layout

Select the Viewer configuration, Stack, Horizontal, or Vertical.

Blending Mode Set the type of interaction between images in the Viewer, for exam-
ple Onion Skin or Difference.

Image Quality Set the Viewer image quality for working with low powered 
machines, for example Full Quality, Quarter, or Sixteenth.

Scale Set the scale applied to the clip in the Viewer, for example 25%, 
75%, or Fit.

Viewer 
Output

Sets the output for the current input and enables or disables Tags.

Icon Function Description
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Viewing Media 
3. Check Sync to VBlank.

4. Launch Hiero as normal and check playback.

Playback Tools The playback tools manipulate the media itself, in much the same way as 
other editing or playback software.

The playback tools can be summarised as follows:

• In and Out markers—numerical representations of the clip In and Out 
markers, if they’re set.

• Playhead position—numerical representation of the current position of 
the playhead.

• Display Mode—select the timing method to display during playback:

• Timecode (TC)—displays the playhead position within the current clip 
irrespective of the number of clips in the Viewer.

• Clip Frames (CF)—displays the frame number read from the clip’s 
metadata.

• Drop Frame—is a timecode display option that leaves out two frames 
from the 30 fps timecode sequence every minute (except every 10th 
minute) so that long running NTSC sequences are accurate to a real-
time clock (NTSC framerate is 3000/1001, or approximately 0.01% 
slower than 30fps).

Note Enabling Drop Frame is a Timecode display feature only—the source media 
remains a continuous stream of frames.

Playhead Position Out Marker 
Position

In Marker 
Position

Playback Controls
Display 
Mode

Playback 
Mode
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About Anamorphic Media 
• Playback Controls—standard media playback controls including 
continuous or by frame forward and backward, skip to next or previous 
edit, and skip to start or end of all clips.

The following table describes playback behaviour depending on the Play-
back Mode selected. 

Mode Description In/Out Effect

Repeat Play through from start to finish in an infinite loop. Repeats within the 
In-Out Points.

Bounce Play through from start to finish then reverse to the start 
and repeat.

Bounces within the 
In-Out Points.

Stop Play through from start to finish then stop. Play through to the 
Out Point.

About Anamorphic 
Media

Hiero automatically recognises anamorphic clips and displays them with the 
correct aspect ratio. 

If for any reason you want to display an anamorphic clip with a 1:1 aspect 
ratio, right-click in the Viewer displaying the clip and enable the Ignore 
Pixel Aspect checkbox.

About RED Media When working with RED footage, using a RED Rocket card with Hiero can 
increase the rendering speed significantly.

Note The RED Rocket icon is only visible if you have a RED Rocket installed.

The RED Rocket icon has four states:

Inactive—the RED Rocket card is inactive.

Firmware error—there is a problem with the card firmware. Hover 
the mouse over the icon for more information.
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To modify the RED Rocket options: 

1. Click the  icon in the Viewer.

Note You must have Use RED Rocket enabled in the Preferences dialog to access 
these options. See Workspace Preferences for more information.

The RED Rocket Settings dialog displays.

2. Temporarily disable the RED Rocket card by deselecting Use RED Rocket 
card. Unlike the option in the Preferences dialog, changing this setting 
does not affect Hiero at startup.

3. Click OK to save your settings.

Using Scopes Hiero provides three realtime scopes to help you evaluate your media. 
Realtime scopes provide data as the Viewer plays your clip, but you can also 
view the scopes frame by frame if you prefer.

Histogram The Histogram provides three colour channel and luma channel information 
that describes the distribution of red, green, blue, and luma pixels 
throughout the current frame. 

The Histogram graphs the number of pixels at each brightness level, and 
from left to right, the areas of the Histogram represent shadow, mid tones, 
and highlights.

Active—the RED Rocket card is present and active.

Viewer 
Selection

Channel 
Selection
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There are also Viewer and Channel selection controls on the Histogram tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Histogram output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

• Channel selection—select the channel information to output. The default 
setting displays RGB and Luma, but you can break the view down to just 
RGB or single channels.

The scopes feature global customisable guides to help you grade your clips. 
Navigate to Hiero > Preferences > Scopes and enter values between 0 and 
1 for the Black and White points.

The guides at the edges of the Histogram turn red to warn you when the 
distribution is out of range:

Waveform The Waveform scope provides information on clip luminance, or brightness, 
which you can use to decide whether the clip is over or under exposed. The 
white traces represent luminance values from 0 - 100% (black through the 
spectrum to white). The higher the waveform, the brighter the image in the 
Viewer.

Shadow 
Guide

Highlight 
Guide
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The upper white marker is used to measure when over exposure could be a 
problem. If your waveform has a lot of traces over the white marker, you 
should consider reducing the brightness of the clip. The opposite is true of 
the lower black marker.

There are also Viewer and Mode selection controls on the Waveform tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Waveform output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

• Mode selection—select the mode to output. The default setting displays 
Luma only, but you can also view the RGB channels ganged together or 
separately.

The scopes feature global customisable guides to help you grade you clips. 
Navigate to Hiero > Preferences > Scopes and enter values between 0 and 
1 for the Black and White points.

The guides at the top and bottom of the Waveform turn red to warn you 

Viewer 
Selection

Mode 
Selection
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when the distribution is out of range:

Vectorscopes Vectorscopes display colour, saturation, and hue information for the 
current frame. Similar to colour wheels, Vectorscopes display information 
radially, from the centre outward. The farther from the centre the data 
spans, the more saturation is represented.

Figure 5.1: Normal saturation. Figure 5.2: High Saturation.

In Figure 5.1, you can see that the frame represented contains mostly 
yellows and reds, but the values are not oversaturated. Figure 5.2 
represents a badly saturated frame. Notice the spill of yellow traces 
distributed toward the edge of the scope pass the target (the highlighted 
square).

There is also a Viewer selection control on the Vectorscope tab:

• Viewer selection—if you have multiple Viewers open, use the drop down 
menu to associate Vectorscope output to the required clip. 

The default value, Active Viewer, automatically displays details on the 
last Viewer you selected.

Using Tags Tags are used to mark shots of a particular type or content as you organise 
your project. The default Tags supplied with Hiero include Approved and 
Reference Tags. You can also create custom Tags by right-clicking in the 

White Guide

Black Guide
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Tags tab or by pressing cmd/ctrl + Y. You can apply Tags to clips, individual 
frames, sequences, and tracks.

Tags can also be used to define what Hiero exports. For example, exporting 
selected tracks from a multi-track Timeline. See Round-Tripping and Export 
Management for more information.

Tagging Using the 
Viewer

To apply a Tag using the Viewer:

1. Navigate to Window > Tags.

The Tags tab displays.

2. Drag-and-drop the required Tag from the Tags tab to the Viewer.

Depending on whether you’re looking at a clip or Timeline, drop the Tag on 
Tag this frame, Tag whole clip, or Tag whole timeline as required.

Tags applied to frames appear above the playback tools in the Viewer 
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Timeline.

Tip Use Shift +  or  to skip to the next or previous Tag on the current clip or 
reposition Tags by dragging them along the Viewer Timeline.

Tags applied to entire clips or Timelines appear above the Viewer, next to 
the A/B layout dropdown menu.

Tagging Using the 
Timeline Pane

To apply a Tag using the Timeline pane:

1. Navigate to Window > Tags.

The Tags tab displays.

Tags Playhead

Tags
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2. Drag-and-drop the required Tag from the Tags tab to the Timeline pane.

Depending on where the Tag is dropped, you mark a clip (or clips if you 
make multiple selections) or a track.

Tags applied to clips appear on the right of the selected clip(s) on the 
Timeline.

Tags applied to tracks appear in the track label on the left of the Time-
line pane.
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Adding Notes to Tags In some cases, a simple Tag on a frame or clip may not contain all the 
information that you wish to pass on to the next stage of production. 
Adding a note to a Tag can provide that extra detail.

Note To delete a note, don’t click Delete, because this refers to the Tag. Instead, 
delete the notes in the window and click OK.

1. Add notes to Tags by clicking on the required Tag and entering text. The 
example shows a note added to a clip Tag, but you can also add notes to 
frame and Timeline Tags in the same way.

2. Click OK to save the note.

Filtering and Flagging 
Media Using Tags

You can use Hiero to search for clips containing certain Tags, for example, 
if you wanted to find all clips that you tagged as Approved.

There are two types of Tag search you can perform: Filter and Flag. Select 
the desired search type by clicking the magnifier icon in the Project tab.

• Filter—displays all objects that contain the specified Tag. This is the 
default search method.

• Flag—displays all objects and marks the items that don’t match the 
search Tag.

Drag the required Tag from the Tags tab into the search box and select the 
Bin or Bins you want to Filter or Flag.

Tip If you have more than one search criteria, click the icons in the search box 
to display a brief description of the icons.
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Filters and flags persist until you change the search criteria or click the 
icon in the search box.

The examples below show Hiero Filtering a Bin to display only media with 
the Approved Tag applied and Flagging all media that doesn’t have the 
Approved Tag applied to it.

Creating Custom Tags While using Hiero you may find that you require a specific Tag or suite of 
Tags that are not provided by default. Creating Custom Tags allows you to 
really control the organisation of your media, and you can even create your 
own Tag icons.

To create a Custom Tag, do the following:

1. Select the Bin to contain the Tag in the Project tab.

2. Navigate to Project > New Tag, or press cmd/ctrl + Y.

The new Tag is placed in the selected Bin.

Filtering... ...and Flagging
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3. Double-click the Tag to open the Edit Tag dialog box.

4. Enter a description for the Tag in the Name field.

5. Click the Tag dropdown menu to select an icon for the Custom Tag.

Tip You can import your own image for the Tag by selecting Assign to open the 
Finder.

6. Click OK to save your changes.

Removing Tags To remove a Tag from a frame or clip, click the Tag and click Delete.

You can remove all Tags from a clip or selection of clips by right-clicking 
Hiero 1.0v1The Foundry



INGESTING MEDIA 53
Using Tags 
your selections in the Bin and choosing Clear Tags.

To remove a Tag from a track, click on a Tag icon and select the required 
Tag.

Press  to remove your selection.
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Viewing Metadata Metadata is information that describes media content, separate from the 
clip itself, in the form of a table on the Metadata tab. Types of metadata 
include Duration, File Size, and the Path to the location of the source media.

To view Metadata for a Bin clip, right-click the clip and select Show 
Metadata.

To view Metadata for a clip in a sequence, select the Metadata tab and click 
on the clip to examine.

Filtering and Flagging 
Media Using Metadata

If searching your Project using Tags has not filtered your media effectively, 
you can use Hiero to search for clips containing certain Metadata. For 
example, if you wanted to find all clips that had a particular Resolution or 
Framerate.

To filter or flag using Metadata:

1. Right-click the clip that contains the required metadata key and select 
Show Metadata.
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2. Drag-and-drop the required key from the Metadata pane to the Bin view 
search box.

3. Use the metadata key as a filter or flag as described in Filtering and 
Flagging Media Using Tags.
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Timelines in Hiero can contain any number of video sequences and audio 
tracks with each track containing clips that reference the source clips in 
your project—making changes to clips in the Timeline does not affect the 
original source clip.

Note Conformed EDLs only support one video sequence. If you’ve created multiple 
EDLs from the same edit, you can add each one into the Timeline pane using 
the Import Track button in the Spreadsheet pane. See Adding Tracks to the 
Timeline.

• Video Toggle—quickly turn off and on video tracks during playback.

• Playhead Position—displays the playhead location synchronised with the 
contents of the Viewer.

• Time Code—displays the Timeline scale. You can adjust the scale using 
the Scale Slider or by using the mouse wheel.

• Video Tracks—contain all video sequences for the current Timeline.

• Audio Tracks—contain all the audio clips for the current Timeline.

• Scale Slider—adjusts the scale of the Timeline. You can fit the contents 
of the Timeline to the screen space available by pressing the F hotkey.

• Audio Toggle—quickly turn off and on audio tracks during playback.

• Track Lock—secure the selected track to disable all editing tools.

Video tracks in multi-track Timelines are read from the highest number 
track downward, for example Video 3, Video 2, Video 1. As a result, if video 
is present on track 3, video on track 2 in the same time slice is obscured.

Video Tracks

Audio Tracks
Track
Lock

Audio Toggle

Time CodeVideo Toggle Playhead Position

Scale Slider
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In Figure 6.1, although the playhead crosses clips on three video tracks, 
only the clip in Video 3 appears in the Viewer.

Figure 6.1: A typical multi-track Timeline

Audio tracks, on the other hand, are layered and can be played back 
simultaneously—all three audio tracks crossed by the playhead in 
Figure 6.1 play back together, creating a complete audio backing for the 
video.

Adding Tracks to 
the Timeline

Hiero allows you to add empty tracks to existing Timelines or import 
another EDL or XML edit—effectively a sequence within the Timeline.

To import another EDL or XML edit:

1. Click Import Track and use the browser to locate the EDL or XML.
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2. Select the file and click Open to import the sequence.

Note If you’re importing an EDL, bear in mind that there is no guaranteed 
framerate information included in the file.

When you import EDLs, an Import Options dialog displays.

Select the correct frame rate and audio sample rate using the dropdown 
menus, then click OK to import.

3. Before conforming the new track, be sure to lock down any existing 
tracks to stop them re-conforming at the same time.

Click the  icon on any tracks that you don’t want to conform.

To add new tracks:

• Drag-and-drop a clip above or below existing tracks as shown, 
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OR

• Right-click an existing audio or video track and select New Track.

Using Reference Media Importing a lower resolution version of your Timeline enables you to 
compare your current Timeline against the reference media to avoid issues 
with continuity, missed frames, and so on.

To import reference media, click Set Reference Media and use the browser 
to locate the required file.

The reference media is automatically imported into the Video 1 track, 
pushing all other tracks upward, and is marked with the Reference Media 
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tag.

After importing the reference media, use the show/hide icon  to 

compare the current Timeline against the reference clip.

Alternatively, you can drag the reference media from the Conform Bin to the 
second Viewer input, and use the SplitWipe tool to compare media,

OR
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Switch the Viewer to Horizontal mode and click the  button to 

determine the Viewer output using track flags.

Adding Clips to the 
Timeline

Hiero’s Timeline allows you to add clips by simple drag-and-drop from 
either the Viewer or Bins. Using the Viewer restricts you to a single clip, the 
current clip, but you can drag as many clips as you like from Bins.

If the Timeline already contains clips, take care not to overwrite existing 
clips—the most recent clip overlays any existing clip. To avoid this, do one 
of the following:

• Use the Move Clip Tool to make space for the new clip and then drag-
and-drop it in to the space (see Move Tool for more information),

OR
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• Drag-and-drop the new clip at the end of the sequence. Next, drag the 
new clip to an existing transition, hold down the alt hotkey, and drop the 
clip to Ripple all other clips down the Timeline.

Tip The cursor changes to  when you’re using Ripple mode.

Note If the clip you’re adding doesn’t have the same framerate as the Timeline, 
you’re prompted to choose whether the clip’s duration or framerate is 
retained.
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Timeline Editing 
Tools

Hiero’s Timeline Editing Tools allow you to manipulate your clips directly in 
the Timeline instead of the Viewer. Bear in mind that edits you make in the 
Timeline are not carried over to the associated source clips.

Unlike some applications, the Timeline tools are automatically enabled 
depending on the position of your mouse in relation to the clip.

Move Tool Placing the mouse in the centre of a clip activates the Move tool. Click and 
drag the selected clip to required position on the Timeline. A time count 
popup, in conjunction with the snap to clip function, helps you to reposition 
the clip accurately.

You can also move clips up and down the track hierarchy using drag-and-
drop.

Slip Tool

Slide Tool Move Tool

Trim Tool Roll Tool

Time 
Count
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Move tool modifiers

Mode Method Indicator Description

Overwrite drag and drop The default move mode. The dragged clip 
overwrites any clips that are present in the 
move location.

Ripple drag then hold Alt 
and drop

Drag and drop clips on top of other clips 
without overwriting content—clips are 
pushed down the Timeline to accommodate 
the dragged clip.

Duplicate hold Alt and drag 
then release Alt and 
drop

Copy the clip, then drag and drop on top of 
other clips overwriting existing content—
clips are not pushed down the Timeline to 
accommodate the dragged clip.

Ripple and 
Duplicate

hold Alt then drag 
and drop while hold-
ing Alt

Copy the clip, then drag and drop clips on 
top of other clips without overwriting con-
tent—clips are pushed down the Timeline to 
accommodate the dragged clip.

Delete modifiers

Action Hotkeys Description

Delete Backspace Delete the selected Timeline clip(s) or gap(s)

Ripple 
Delete

Shift + Backspace Remove the selected clip(s) and ripple clips down stream 
to close gaps in the Timeline

Note: The ripple effect may not close gaps entirely, 
because Hiero does not allow linked tracks to become 
desynchronised during rippling.

If you need to nudge a clip or clips by just a frame or two, you can select the 
clips on the Timeline and press < or > to nudge by one frame in the chosen 
direction.

Note You cannot overwrite other clips on the Timeline using the nudge keys.

 

 

Hiero 1.0v1The Foundry



MANAGING TIMELINES 65
Timeline Editing Tools 
Trim Tool The Trim tool allows you to alter the output of a clip, within its total length, 
by adding or removing handles.

Note You can only increase clip output if the clip already has handles.

1. Place the mouse at the left or right of the clip to activate the Trim tool.

2. Drag the edit point to the new position and release the mouse to 
complete the Trim.

The Viewer displays the new In or Out point (depending on whether you’re 
adjusting the beginning or end of the clip), allowing you to accurately gauge 
the new output of the clip.

Alternatively, select the cut point by clicking at the beginning or end of the 

Trim 
Handles

Trim 
Amount
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clip and nudge the cut using the < and > keys.

Slip Tool The Slip tool allows you to shift a clip’s In and Out Points by the same 
amount and in the same direction, retaining the original clip length but 
altering the Timeline output. 

Note The target clip must have handles to use the Slip tool.

1. Place the mouse at the bottom of the clip to activate the Slip tool and 
display the slip handles.

2. Drag the clip to the new position and release the mouse to complete the 
slip.

Note Using the Slip tool does not move the clip on the Timeline, only the clip 
output is changed.

The Viewer displays the slipped start frame (A) and end frame (B), allowing 
you to accurately gauge the new output of the clip.

Slip 
Handle

Slip 
Amount
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Slide Tool The Slide tool allows you to move a clip in relation to the clip before and 
after the target clip, without changing its length or Timeline output.

The clips either side of the target are shortened or lengthened within the 
limits of their handles to accommodate the slide.

Note The surrounding clips must have handles to use the Slide tool.

1. Place the mouse at the top of the clip to activate the Slide tool and dis-
play the slide handles.

2. Drag the clip to the new position and release the mouse to complete the 
slide.

For example, if you slide the target clip (B) five frames to the right, the 
preceding clip (A) ends five frames later and the next clip © starts five 
frames later.

Figure 6.4 shows a Timeline containing three clips, and Figure 6.5 shows 
the same clips with the clip (B) sliding to the right.

Figure 6.2: Original clips.

A B

A B C
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Figure 6.3: Rolled clips.

The Viewer displays the new end point of the previous clip on the left and 
the new start point of the next clip on the right, allowing you to accurately 
gauge the slide.

The two centre images (B) represent the start and end frames of the target 
clip, which don’t change.

Roll Tool The Roll tool enables you to roll a single edit within the available handles, 
shortening one clip while lengthening the other, but keeping the overall 
duration the same.

Note At least one of the target clips must have handles to use the Roll tool.

1. Place the mouse on the cut between clips to activate the Roll tool and 
display the handles.

2. Drag the clip to the new position and release the mouse to complete the 
roll.

For example, if you roll five frames at the end of one clip (A), the next clip 
(B) would start five frames later. Figure 6.4 shows a Timeline containing 
two clips, and Figure 6.5 shows the same clips with the cut point “rolled” 
to the right.

A B C

A B C
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Figure 6.4: Original clips.

Figure 6.5: Rolled clips.

The Viewer displays the pre-edit clip on the left and the post-edit clip on 
the right, allowing you to accurately gauge the new position of the edit.

Alternatively, select the cut point by clicking between the clips and nudge 
the cut using the < and > keys.

A B

A B

A B
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Razor Tool The Razor tool allows you to cut a clip or clips in to separate parts so you 
can remove sections or rearrange clips on the Timeline. Unlike the other 
Timeline tools described in this section, Razor is menu driven not mouse 
position sensitive.

The Razor is applied at the playhead position and can cut through selected 
tracks using Window > Razor Selected, or all tracks using Window > Razor 
All.

Note You can also use the shift + C and C hotkeys, or the right-click context 
menu to perform the respective cuts.

Adding Soft Trims Soft Trims limit the handles on clips to a pre-defined amount, simulating In 
and Out points on the source media, allowing you to use other Timeline 
tools on the clip such as Slip and Slide.

Note Soft Trims are limited to the source clip’s frame range—a clip’s output plus 
trims cannot exceed the total frames available.

To add Soft Trims to a clip:

1. Locate the clip on the Timeline.

2. Right-click and select Set Soft Trims.
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The Set Soft Trims dialog displays.

3. Set the number of frames to add to the head and tail of the clip:

• Use full available range—sets the handles to the full extent of the 
clips frame range.

• Use Frames—adds the specified number of frames to the head and tail 
of the clip.

4. Click OK to add the specified number of handles.

If the handles requested are not within the available frame range, Hiero 
displays a warning dialog with a suitable correction.

Click Yes to accept, or No to abort the Soft Trim operation.

Source Clip

Timeline Clip

OutIn

Head Tail
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Enabling and Disabling 
Clips

You can temporarily enable or disable a clip or clips on the Timeline to 
selectively view your footage without removing the clip(s), for example if 
you wanted to listen to certain audio layers within a Timeline.

To enable or disable a clip or clips:

1. Select the clip or clips you want to enable or disable using the mouse 
and selection hotkeys.

2. Right-click on the highlighted clip and deselect Enable Clip to disable the 
clip.

Disabled clips appear black and are effectively removed from the Time-
line.

3. Right-click the clip and select Enable Clip to re-enable the clip.

Adding Transitions Hiero supports basic fade in and fade out transitions as well as dissolves 
between clips. Transitions come in three flavours:

• Fade in—fades in from black on a single clip.

• Fade out—fades out to black on a single clip.

• Dissolve—fades out from one clip and into the next, by merging frames.

Note Dissolves must be between clips on the same track.

To add a fade transition:
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1. Right-click the target clip and select Fade In or Fade Out to add the fade 
icon to the clip.

2. Adjust the fade by dragging the fade icon, in a similar way to using the 
Roll tool.

To add a dissolve transition:

1. Hover the mouse pointer over a cut point between two clips.

The cursor changes to .

2. Right-click and select Dissolve to add the dissolve icon to the clip.
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3. Adjust either side of the dissolve by dragging the icon, in a similar way 
to using the Roll tool.

Invalid Transitions Transitions are controlled in a similar way to clips, in that you can drag-
and-drop them, but with the following restrictions:

• A fade can not be dragged past the ends of the clip it's attached to and if 
the clip is deleted, the fade is deleted with it.

• Dissolve ends can not be dragged past the ends of the clips they are 
attached to and if both clips are deleted, then the dissolve is also 
deleted.

If only one of the clips linked by the dissolve is deleted, the transition 
remains so that another clip can be placed on the other side.

Invalid transitions are marked with red squares. In most cases, adjusting the 
length of the transition should be enough to correct the error.

Retiming or 
Reversing Clips

In addition to transitions, Hiero supports constant retimes on ingested 
clips. Decreasing the speed of a clip causes frames to play more than once, 
whereas increasing the speed of a clip skips frames.

To retime a clip using the spreadsheet:

1. Select the clip in the spreadsheet view.
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2. Click the cog icon and select the required retime clamp:

• Source—the clip length is altered on the Timeline depending on the 
retime applied.

For example, retiming a clip to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 
4, etc. in the Viewer, and as a result, the clip’s length is doubled on the 
Timeline.

Retiming a clip to 200% renders frames 1, 3, 5, 7, etc. in the Viewer, 
but the clip’s length is halved on the Timeline.

• Destination—the clip length on the Timeline is maintained regardless 
of the retime applied.

For example, retiming a clip to 50% renders frames 1, 1, 2, 2, 3, 3, 4, 
4, etc. in the Viewer, but the clip’s length on the Timeline remains the 
same, effectively removing the second half of the clip.

Retiming a clip to 200% renders frames 1, 3, 5, 7, etc. in the Viewer, 
but the clip’s length on the Timeline remains the same and the second 
half of the clip is filled with black frames.

The following example shows a clip and the results of 50% and 200% 
retimes with the Source and Destination clamp selected.

Notice that the Destination clamp doesn’t change the length of the clip 
on the Timeline?

Original clip

50% Source retime 200% Source retime
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3. Double-click the Speed column and enter the retime value.

To retime or reverse a clip using the Sequence menu:

Note Retimes using the Sequence menu are always clamped to the Destination 
duration.

1. Select the required clip on the Timeline.

2. Navigate to Sequence > Retime.

The Clip Speed dialog displays.

3. Enter the required retime value as a percentage.

4. Select Reverse to cause the clip play in the opposite direction.

5. Click OK to retime the clip.

50% Destination retime 200% Destination retime
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In addition to the regular project save and restore options, Hiero can record 
the different states of your workflow as you progress using Versions and 
Snapshots.

Hiero objects need a little explanation before getting into their uses:

• Versions are children of clips. You can have any number of Versions per 
clip as long as they reside in the same folder and follow the correct 
naming conventions.

Versions can only be applied to clips and can be swapped in and out 
without overwriting existing work.

• Snapshots are time-stamped copies of a either a clip or a sequence, 
allowing you to save their current state without the inconvenience of 
saving the entire project.

If you restore a Snapshot, any unsaved edits are lost.

Using Versions Versions can be added to clips to allow greater flexibility in your workflow. 
You can have as many Versions of a clip as required and cycle through them 
quickly using hotkeys.

Hiero relies on specific file naming or folder structure conventions to apply 
Versions:

• Versions of a clip must be named identically and be suffixed v1, v2, v3, 
etc., or

• Versions must reside in specifically named folders in the same root 
directory and be suffixed v1, v2, v3, etc.

You must use _ or . before the suffix (in the example _v1) in order for Hiero 
to discover the available Versions. For example:

Figure 7.1: Versioning using filename.
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Figure 7.2: Versioning using folder structure.

When you have named your Versions correctly, ingest one of the Versions 
into a Bin or sequence to let Hiero know where to start looking for Versions.

Versions in Bins Versions behave similarly in both Bins and sequences, but in the Bin view 
you can see all available Versions by using the Takes Bin.

1. Locate the ingested Version clip, right-click, and select Version Up or 
Version Down to cycle through the available Versions.

Note You can also use the alt +   hotkeys to cycle through Versions.

2. Right-click again and select Open Takes Bin.

The Takes Bin displays.

3. Select the Take in the left-hand pane to see all the available Versions.

Note Versions in Bins are easily identified by the “V” mark on the thumbnail.
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4. You can also set the Active Version in the same way as Active Takes. 
Right-click the ingested clip and select Set Version...

The Set Version dialog displays.

5. Enter the required Version, or use the arrows to increment the Version 
number, and click OK.

All new instances of this clip now use the Active Version though existing 
clips remain the same.

Versions in Sequences As mentioned previously, Versions behave similarly in both Bins and 
sequences, but swapping Versions in sequences allows you to compare 
results more easily.

1. Locate the ingested Version clip and drag it to the Timeline pane.

2. Right-click, and select Version Up or Version Down to cycle through the 
available Versions.

Note You can also use the alt +   hotkeys to cycle through Versions.

Tip You might want to rename the video track to something more meaningful, 
such as VFX.

The clip is labelled with the Version number currently in use.
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3. You can also set the Active Version in the same way as Active Takes. 
Right-click the ingested clip and select Set Version...

The Set Version dialog displays.

4. Enter the required Version, or use the arrows to increment the Version 
number, and click OK.

All new instances of this clip now use the Active Version though existing 
clips remain the same.

5. You can also select the Version in the Timeline pane, Viewer, or Bin view 
and press V to display the available Versions of the clip.

6. Select the required Version from the popup to use it in the sequence.
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Using Snapshots Within a Hiero project you can save the current state of a clip or sequence 
as a Snapshot, including a comment or tag to describe that Snapshot. You 
can see what Snapshots exist for a clip or sequence in the Take’s sub-
directory, and flip it back to any previously saved state.

As an example workflow, take a look at Figure 7.3.

Figure 7.3: A typical workflow using Snapshots.

1. Two Snapshots of the sequence (SQ) are recorded after edits. See Creat-
ing Snapshots.

2. Snapshot 1 is then restored. See Restoring Snapshots.

3. Further edits are made, then the sequence is recorded as Snapshot 3.

Creating Snapshots To create a Snapshot for a clip or sequence:

1. Locate the clip or sequence in the Bin view.

2. Right-click the clip or sequence and select Add Snapshot.

SQ 1 2 3

Time

SQ SQ
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The Add new snapshot dialog box displays.

3. Enter a name and comment, or use the default date and time supplied.

4. Click Add to create the Snapshot.

A new tab is created containing the Snapshot in the Take sub-directory 
if no others exist, or the Snapshot is added to an existing list as shown.

Note Snapshots in Bins are easily identified by the “S” mark on the thumbnail.

5. You can edit the name and comment associated with a Snapshot by 
clicking the cog icon on the thumbnail.

To create a Snapshot for a named Version:

1. Locate the clip or sequence in the Bin view.
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2. Right-click the clip or sequence and select Open Takes Bin.

The Takes Bin displays, including the current Active Version which is 
bolded on the left-hand side of the tab.

3. Right-click the required Version and select Add Snapshot.
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The Add new snapshot dialog box displays.

4. Enter a name and comment, or use the default date and time supplied.

5. Click Add to create the Snapshot.

The Snapshot is added to the Version sub-directory list.

Restoring Snapshots To restore a Snapshot:

1. Locate the clip or sequence in the Bin view.

2. Right-click the clip or sequence and select Open Takes Bin, if it’s not 
open already.

3. Locate the Version associated with the Snapshot, in this case there is 
only one version, right-click and select Restore Snapshot.
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4. Select the required Snapshot from the list to restore the Version to the 
point at which the snap was recorded.
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8  ROUND-TRIPPING AND EXPORT MANAGEMENT

Hiero uses Shot Templates and processors to perform all export operations, 
including round-tripping and EDL/XML creation. With the addition of Python 
bindings to perform the same functions, this infrastructure provides a 
massive amount of flexibility, whether your pipeline is GUI or command line 
orientated.

Note Hiero is non-destructive and can slot into your existing pipeline if you 
setup your Shot Template to mirror the existing file structure. 

The Shot Template sets up the folder hierarchy and naming conventions for 
export processors such as Transcode Images. Any folders added to the 
template are created during export unless they already exist, in which case 
the export writes to the existing structure.

Hiero ships with default templates for you convenience, but you can quickly 
create custom templates using folders and “tokens” which are replaced with 
the relevant information during export:

• {filebase}—the base of the clip name to process. For example, the 
filebase of Shot01_####.dpx is Shot01.

• {fileext}—the format of the clip to process, such as .dpx or .mov.

Processors

Presets

Export Root Shot Template

Export Controls
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• {filename}—the source clip name of the media to process.

• {sequence}—the sequence name to process.

• {shot}—the name of the track item to process.

• {track}—the name of the track to process.

• {version}—the version of the clip to process denoted by the v01 suffix.

Note After selecting the path column, right-click and choose Select Keyword to 
display a list of available export tokens.

Content Presets are used in all Shot Templates, enabling you to create 
commonly used export conditions, which are then available across all 
projects. For your convenience, Hiero ships with a number of ready-made 
presets, but you can edit these as required:

• Transcode Images—defines transcode processors allowing you to save 
your most used file type conversions.

• Nuke Project File—defines the paths used by Nuke Read and Write nodes 
during a round-trip.

• Nuke Render—defines the render format for Nuke Write nodes.

• External Render—defines the export paths used by third party 

applications, such as Adobe® After Effects®, during a round-trip.

• EDL Exporter—used to export a sequence to the EDL format.

• SymLink Exporter—creates symlinks to the location of the source files, 
rather than making copies.

• XML Exporter—used to export a sequence to a Final Cut Pro-friendly 
XML format.

• Copy Exporter—creates copies of the source files to a specified location, 
rather than symlinking.
Hiero 1.0v1The Foundry



ROUND-TRIPPING AND EXPORT MANAGEMENT 88
Round-Tripping 
Round-Tripping A round-trip describes the process of exporting clips to another 
application, in this case Nuke, and then paving the way back into Hiero to 
conform the new VFX clips.

Exporting to Nuke 1. Select a sequence in the Bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Shots from the Processors list.

3. Enter the Export To directory or click Choose... and browse to the 
location.

The Export To directory is the starting point from which the shot 
exporter builds your shot hierarchy.

4. Select the Basic Nuke Shot preset in the bottom-left pane to auto-
complete the Shot Template with the preset values.

Note You can build a custom Shot Template using Path tokens, the Contents field, 

and the  buttons.

Basic Nuke Shot creates a folder for each clip, or shot, containing a 
plates folder and a nuke folder containing script and renders folders.

The tokens in the Basic Nuke Shot template break down as follows:
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• {filename} simply extracts the source filenames as they appear in the 
file browser.

• {shot}_comp_{version}.nk extracts the sequence name for each clip and 
the version selected in the Export Controls. For example, 
Shot01_comp_v03.nk

• {shot}_comp_{version}.####.{ext} appends padding and the specified 
file extension. For example, Shot01_comp_v03.0001.dpx

5. Click the Contents column to display a list of available presets and the 
associated Export Controls.

6. Click the Nuke Project File preset to display the Read Node and Write 
Export Settings.

7. Using the Read Node dropdown, set the Nuke read path to 
{shot}/plates/{filename} which resolves to the symlinks during export.

8. Using the Write dropdown, set the Nuke write path to
{shot}/nuke/renders/{shot}_comp_{version}.####.{ext} which resolves to 
the render path where Hiero expects to find the Nuke files.

9. Set the Handles, if required:

• Clip Length—exports the full clip length available, as if the clip was 
opened as a Viewer.

• Cut Length—exports only the cuts included on the Timeline.

Note Selecting Cut Length allows you to add handles to each clip, up to the 
maximum available source clip length.

10.Set the Version number and Master Track, if applicable.

Note See Using Versions for more information on how versioning works in Hiero.

11.Click Export.
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The Export Queue window displays an estimate of how long each com-
ponent of the export is expected to take.

Once the export is complete, the file structure specified in the Shot 
Template is created. You can then import the Nuke clips on a separate 
track when they’re ready.

Tip Hover the cursor over Status Warnings to display a popup containing more 
detailed information.

Re-ingesting VFX 
Media

When the compositing work is complete, the clips are ready to re-ingest. 
The Shot Template defines where the Nuke files reside, so all you need to do 
is instruct Hiero to build a track from a known folder structure.

1. Select the required clips on the Timeline and right-click to display the 
context sensitive menu.

Tip You may find it easier to select clips in the spreadsheet and then right-click 
on the Timeline.

2. Click Build External Media Track.
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The Build External Media Track dialog displays.

3. Enter a Track Name or use the default VFX.

4. Select an Export Preset using the dropdown menu. In this case, select 
the same preset used during the export.

5. Enter the filepath of the Export Root directory or click Choose and 
browse to the location.

Note The root directory is the location entered in Export To when exporting the 
project.

6. Select the content you intend to ingest from the Shot Template. In this 
case, the Nuke Render.

7. Click Build to create the VFX track.

Note Build is greyed out until a Shot Template entry is selected.

Hiero automatically creates the new track containing the VFX clips.

Sending Clips and 
Bins to Nuke

Hiero provides a single clip or Bin Send to Nuke along with other export 
functionality.

To send a clip or Bin to Nuke:

1. Locate the required source clip or Bin in the Bin view.
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2. Right-click the clip or Bin and select Send to Nuke.

The Send to Nuke dialog displays.

3. The Nuke Script and Write paths are already filled in from the default 
Transcode Shot Template, but you can edit these as required.

4. If the clips you’re exporting have Soft Trims enabled, check Use Soft 
Trims to adjust the frame range accordingly.

5. Select the File Type to transcode to within Nuke. See Supported Image 
Formats for more information.

The available transcode options depend on the File Type selected.

6. If you intend to bring the transcoded clips back into Hiero, check Ingest 
Nuke Output.

7. Click Launch Nuke to send the clip to the Nuke specified in Preferences 
> Nuke Path.

Nuke starts up with Read and Write nodes for each clip incorporating 
the selected File Type settings and Write Path.
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Note The Nuke script is saved in the directory specified as the Write Path.

Sending Timeline 
Selections to Nuke

Sending an entire Timeline to Nuke can be time consuming, or even 
unnecessary, if all you’re looking for is a new version of a selection of clips.

To send a selection of clips to Nuke from a Timeline:

1. Select the required clips on the Timeline.

2. Right-click a highlighted clip and select Export.

The Export dialog displays.

3. Follow the steps shown in Exporting to Nuke to complete the export.
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Transcoding Transcoding in Hiero uses a specified external Nuke application or a 
command line only version of Nuke, included in the Hiero package, to 
convert one file format to another.

Note Before you transcode using Hiero, select the required Nuke application 
using the Preferences > General tab as described in Workspace Preferences.

1. Select a sequence in the Bin view and navigate to File > Export.

The Export dialog displays.

2. Select the Transcode Shot Template in the bottom left pane.

3. Enter the Export To directory or click Choose... and browse to the 
location.

The Export To directory is the starting point from which the shot 
exporter builds your shot hierarchy.

4. Build a Shot Template using the Path and Contents fields and the 

 buttons, or use the defaults supplied.

The default Shot Template creates a folder for each Timeline clip to con-
tain the transcoded files.

5. Select the Version number to add to the export, if applicable. 

Note See Using Versions for more information on how versioning works in Hiero.

6. Set the Master Track using the dropdown menu.

7. Click Export.
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The Export Queue window displays an estimate of how long each com-
ponent of the export is expected to take.

Once the export is complete, the file structure specified in the Shot 
Template is created containing the transcoded files.

Exporting EDLs and 
XMLs

Hiero supports export to EDL and XML using very similar methods, the main 
difference being that EDL doesn’t support multiple video tracks in a single 
file whereas XML does.

To export to EDL or XML:

1. Select a sequence in the Bin view and navigate to File > Export.

The Export dialog displays.

2. Select Process as Timeline from the Processors list.

3. Enter the Export To directory or click Choose... and browse to the 
location.

The Export To directory is the starting point from which the shot 
exporter builds your shot hierarchy.

4. Select the DefaultTimelinePreset in the bottom-left pane to auto-
complete the Shot Template with the preset values.

Note You can build a custom Shot Template using Path tokens, the Contents field, 

and the  buttons.
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5. Click the Contents column to display a list of available presets and the 
associated Export Controls.

6. Select the EDL Exporter or XML Exporter as required.

Note When exporting EDLs, check the additional EDL Exporter controls if 
required:

• Include Absolute Path

• Truncate Reel Name

7. Set the Version number and track or tracks to export.

Note EDLs only support one video track per file.

8. Click Export.

The Export Queue window displays an estimate of how long the export 
is expected to take.

Once the export is complete, the file structure specified in the Shot 
Template is created. You can then import the EDL into other applica-
tions.
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Hiero ships with a comprehensive Python application programming interface 
(API) enabling you to perform all user interface actions using Python 
scripting.

This chapter provides a basic overview and some simple examples to get 
you started, but more information is available in the dedicated Python API 
documents included in the Hiero package.

Note If you copy and paste example scripts from this user guide into the Script 
Editor, line indentations may not be preserved. If this is the case, correct 
the indentations manually.

Using the Script 
Editor

Hiero includes a Python Script Editor, accessible from the user interface, 
allowing you to enter Python statements directly.

To access the Script Editor:

1. Navigate to Window > Script Editor.

The Script Editor displays.

2. Enter scripts in the lower half of the editor and press cmd/ctrl + enter 
to execute the script.

The results are displayed at the top of the editor. A simple example 
might be:
from hiero.core import *
bin = project().clipsBin()
bin.addItem(Bin("Plates"))
bin["Plates"].importFolder("/Footage/Hiero/finalshots")
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Which imports hiero.core, defines bin, creates a Bin called Plates at root 
level, and imports the specified folder into Plates.

Script Editor buttons and commands are described below:

Hiero’s Script Editor also features auto-completion and help for commands. 
Classes, attributes and so on are discoverable by:

• Entering the beginning of an object name and pressing the Tab key. 

For example, typing Bin and pressing Tab displays a list of objects start-
ing with Bin:

Icon Hotkey Description

cmd/ctrl + [ Go to the previous script.

cmd/ctrl + ] Go to the next script.

- Clear the script history.

- Load and execute a script.

- Load an existing script.

- Save a script as a .py file.

- Run the current script.

- Show the input pane only.

- Show the output pane only.

- Show both the input and output panes.

cmd/ctrl + 
backspace

Clear the output pane.
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• Using the help command for a known object.

For example, help(Clip) returns a list of useful information on Clip:

Scroll down in the top pane to see more information relating to Clip.

• Using the dir command for a known object.

For example, dir(VersionedClip) returns a concise list of useful informa-
tion on VersionedClip:

For more information on Python scripting within Hiero, see the dedicated 
Python API documents included in the Hiero package.
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Adding Panes 
Using Window 
Manager

You can also add custom interface panes to Hiero using Python. You can 
create hybrid panes consisting of existing functionality or create your own 
from scratch. You can add panes on a per session basis or, if you save the 
script to the startup locations defined in Running Python During Startup, 
load them at startup.

The following script example creates a Web Browser entry in the Windows 
menu. Select Web Browser to display a Hiero pane containing a simple 
browser.

The script ships with Hiero and can be found in the following locations:

Mac OS X

• /Applications/Hiero1.0/Hiero.app/Contents/Plugins/site-packages/hiero/
examples

Linux

• /usr/local/Hiero1.0/Plugins/site-packages/hiero/examples

There are a few thing to note in this script:

• WA_DeleteOnClose is commented out in the script. If you uncomment this 
line the widget is destroyed when closed. Otherwise, the browser 
remains in the Window menu and can be displayed again.

• It’s not compulsory to have The Foundry’s website as your home page!

Adding Menu Items Two main types of menu items exist in Hiero’s interface, regular dropdown 
and context sensitive items. You can use Python to add these on a per 
session basis or, if you save the script to the startup locations defined in 
Running Python During Startup, load them at startup.

Tip It’s a good idea to use Hiero internal names, like foundry.menu.view, instead 
of interface names like View. Problems with interface language differences 
are avoided if you script using the internal names.

Dropdown Menus The simplest menu items to add are in dropdowns, so we’ll start with those. 
The following example script adds a menu item, Foo Report, to Hiero’s View 
menu.

Note Make sure you reapply line indentations if they are not preserved when 
pasted into the Script Editor.

import hiero.ui
import PySide.QtGui
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class StuffAction(PySide.QtGui.QAction):
  def __init__(self):
    PySide.QtGui.QAction.__init__(self, "Foo Report", None)
    self.triggered.connect( self.doit )

  def doit( self ):
    print "Report Results."

stuffAction = StuffAction()
hiero.ui.addMenuAction( "foundry.menu.view", stuffAction, 
"foundry.viewer.nextEdit" )

The result from this script is the string "Report Results" in the Script Editor.

Context Sensitive 
Menus

These are slightly trickier as they rely on an event from the interface. When 
the following example receives a registered event (kShowContextMenu) 
from the Timeline editor, a menu item is inserted into the right-click 
Timeline menu if the context is satisfied.

Note Make sure you reapply line indentations if they are not preserved when 
pasted into the Script Editor.

import hiero.core
import hiero.ui
import PySide.QtGui

class PrintSelectionAction(PySide.QtGui.QAction):
  def __init__(self):
    PySide.QtGui.QAction.__init__(self, "Print the 
Selection", None)
    self.triggered.connect( self.doit )
    hiero.core.events.registerInterest( "kShowContextMenu/
kTimeline", self.eventHandler )

  def doit( self ):
    print "This is what is selected in the timeline view:"
    for i in hiero.ui.getActiveView().getSelection():
      print " -", i

  def eventHandler( self, event ):
    print "Menu event, sender", event.sender
    print " - type", event.type, event.subtype
    print " - selection", event.sender.getSelection()
    if hasattr(event.sender, 'getSelection') and 
event.sender.getSelection() is not None and len( 
event.sender.getSelection() ) != 0:
      event.menu.addAction( self );
Hiero 1.0v1The Foundry



HIERO AND PYTHON APIS 102
Running Python During Startup 
printSelectionAction = PrintSelectionAction()

The script checks for a valid selection of clips on the Timeline, and if valid, 
the Print the Selection item is added to the right-click menu. If the selection 
is invalid, the context is incorrect and the menu item is not created.

Select one or more clips on the Timeline, right-click and select Print the 
Selection to print the selected clips in the Script Editor.

Running Python 
During Startup

On startup, Hiero scans various directories for Python scripts that 
customise the behavior of Hiero. These scripts can be downloaded from 
online resources such as www.nukepedia.com, and placed in a specific 
location on disk depending on the platform running Hiero.

If you’re familiar with Python scripting, you can place custom startup 
scripts in the same locations, though bear in mind that you should take care 
as mistakes can produce performance issues.

Hiero looks in specific subdirectories of the application directory path as 
follows:

Mac OS X

• /Applications/Hiero1.0/Hiero.app/Contents/Plugins/

• /Library/Application Support/TheFoundry/Hiero

• ~/Library/Application Support/TheFoundry/Hiero

• ~/.hiero

Linux

• /usr/local/Hiero1.0/Plugins

• ~/.hiero

Hiero then searches <path>/Python/Startup and <path>/Python/StartupUI 
for any Python .py files or folders containing _init_.py. Scanning is done in 
two passes—all the Startup folders are searched and then all the StartupUI 
folders.

Each package or module discovered is imported and added to the built-in 
package hiero.plugins. 

Note Python startup scripts are imported in alphabetical order so you can force 
ordering if necessary.
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Hiero Environment 
Variables

Running Hiero from the command line allows you to set additional paths 
that are checked on startup using environment variables. 

For example, you can guide Hiero to folders containing scripts at startup 
using the HIERO_PLUGIN_PATH variable.

To set the plug-in environment variable:

1. From a command line, enter:

export HIERO_PLUGIN_PATH=$HOME/<script folder>

Note You can use .<script folder> to point to hidden folders, for example 
.myPlugins.

2. Launch Hiero from the same command line:

open /Applications/Hiero1.0v1/Hiero1.0v1.app

3. In Hiero, navigate to Window > Script Editor.

The Script Editor displays.

4. In the bottom pane, enter:

import hiero.core
print hiero.core.pluginPath()

5. Press cmd/ctrl + enter to execute the script.

The results are displayed at the top of the editor.

6. Check that your scripts folder is included in the result. For example:

# Result: ('/Applications/Hiero1.0v1a8/Hiero1.0v1a8.app/
Contents/Plugins', '/Users/byrne/.myPlugins', '/Users/
byrne/Library/Application Support/TheFoundry/Hiero')

Another useful variable is HIERO_DISABLE_THUMBNAIL_CACHE, which as the 
name suggests, stops Hiero caching thumbnails.

To set the thumbnail environment variable:

1. From a command line, enter:

export HIERO_DISABLE_THUMBNAIL_CACHE=true

2. Launch Hiero from the same command line.
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Hiero Hotkeys

This appendix lists the hotkeys used by Hiero, along with their function.

Hotkey Button Menubar Function

Viewer

shift + cmd/ctrl + 1 - View > Zoom to Actual Size Zoom the contents of the Viewer to actual size.

shift + cmd/ctrl + 2 - View > Zoom to Half Size Zoom the contents of the Viewer to half size.

H - View > Zoom to Fill Fit the current clip to the height of the Viewer.

F - View > Zoom to Fit Zoom to fit the clip to the Viewer.

cmd/ctrl + F - View > Full Screen Toggle Full Screen mode.

cmd/ctrl + Shift + F - View > Full Quality 1:1 Toggle Full Screen mode at Full Quality 1:1 zoom.

Esc - - Exit full screen mode.

E View > Clipping Warning Toggle the Level Warning tool on and off.

I View > Mark In Set the In Point at the current frame.

O View > Mark Out Set the Out Point as the current frame.

shift +  View > Go to Start Go to the start of all clips.

shift +  View > Go to End Go to the end of all clips.

shift + I - View > Go to In Point Go to the In Point in the current clip.

shift + O - View > Go to Out Point Go to the Out Point in the current clip.

 View > Frame Backward Skip one frame backward.

 View > Frame Forward Skip one frame forward.

 View > Previous Edit Go to the previous clip in the Viewer.
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 View > Next Edit Go to the next clip in the Viewer.

shift +  - View > Previous Tag Go to previous frame tag.

shift +  - View > Next Tag Go to next frame tag.

space View > Play Play the clip or Timeline currently in the Viewer.

J View > Play Backward Play clip or Timeline currently in the Viewer backward (click 
multiple times to increase playback speed).

L View > Play Forward Play clip or Timeline currently in the Viewer forward (click 
multiple times to increase playback speed).

K View > Pause Pause playback.

Enter 
(numeric keypad)

- View > Swap Inputs Controls the AB inputs:

•  Stack - swaps which input is visible.

•  Horizontal - swaps the inputs horizontally.

•  Vertical - swaps the inputs vertically.

alt + left-click + 
drag

- - Pan the contents of the Viewer.

Scroll wheel

alt + middle-click + 
drag

(over Viewer)

- - Zoom the contents of the Viewer.

Scroll wheel

(over mini Timeline)

- - Zoom the mini Timeline and Viewer waveform.

middle-click

(over mini Timeline)

- - Zoom to fit the mini Timeline and Viewer waveform. 

Note: If your mouse preferences are not set to Button 3 for 
the middle mouse button, you may have to use ctrl + middle-
click.

alt + O - View > Show Overlays Toggle the HUD overlays.

Bin

cmd/ctrl + B - File > New Bin Create a new Bin in the current Bin.

cmd/ctrl + Y - File > New Tag Create a new Tag in the current Bin.

cmd/ctrl + T - File > New Timeline Create a new Timeline in the current Bin.

cmd/ctrl + X - Edit > Cut Cut the selected item(s) to the buffer.

cmd/ctrl + C - Edit > Copy Copy the selected item(s) to the buffer.

Hotkey Button Menubar Function
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cmd/ctrl + V - Edit > Paste Paste item(s) from the buffer.

cmd/ctrl + A - Edit > Select All Select all files in the current Bin.

cmd/ctrl + D - Edit > Duplicate Duplicate the selected object(s). 

backspace - - Delete selected item(s).

Timeline

left-click - - Select a clip including any linked tracks.

alt + left-click - - Select a clip, ignoring linked tracks (for example, audio only).

F - View > Zoom to Fit Zoom to fit the clips on the Timeline to the available space.

backspace - - Remove the selected clip(s) or gap(s) from the Timeline.

Ripple Delete - Timeline > Ripple Delete Remove the selected clip(s) and ripple clips down stream to 
close gaps in the Timeline.

cmd/ctrl + A - - Select all clips in the Timeline.

left-click then shift 
+ left-click

- - Select all clips between the left-clicks (use shift + alt + left-
click to ignore linked tracks).

alt +  - - Cycle up through the available clip Versions.

alt +  - Cycle down through the available clip Versions.

Shift + C - Timeline > Razor Selected Apply the Razor tool to the currently selected track(s) within 
the selected clip(s).

C - Timeline > Razor All Apply the Razor tool to all tracks within the selected clip(s).

drag then alt - - Activate Ripple mode while dragging clips.

alt then drag - - Duplicate the dragged clips.

alt and drag - - Ripple and duplicate the dragged clips.

spacebar View > Play Play through the Timeline currently in the Viewer.

alt + middle-click - - Fit the Viewer to marked In and Out Points.

< - - Trim, roll, or shift a selected transition or clip to the left 
(within the available handles for trim and roll).

> - - Trim, roll, or shift a selected transition or clip to the right 
(within the available handles for trim and roll).

User Interface

cmd/ctrl + 1 - Window > Workspace > 
Conforming

Switch to the default Conforming workspace.

cmd/ctrl + 2 - Window > Workspace > Edit-
ing

Switch to the default Editing workspace.

Hotkey Button Menubar Function
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cmd/ctrl + 3 - Window > Workspace > 
Reviewing

Switch to the default Reviewing workspace.

cmd/ctrl + n - Windows > Workspace > 
Custom Workspace Name

Switch to the custom workspace associated with the number 
selected.

~ (tilde) - - Toggle between full screen and preset pane size for the pane 
currently under the mouse pointer.

cmd/ctrl + N - File > New Project Open a new project.

cmd/ctrl + O - File > Open Open an existing project.

cmd/ctrl + W - File > Close Close the current project.

cmd/ctrl + S - File > Save Save the current project.

shift + cmd/ctrl + S - File > Save As... Save the current project with a different name.

cmd/ctrl + I - File > Import Clips Import a clip or clips.

shift + cmd/ctrl + I - File > Import Folder Import a folder or folders.

V - - Display the available Versions of a clip or sequence.

Media View Searchbox

left-click - - Select search criteria.

cmd/ctrl + left-click - - Toggle select individual search criteria.

Shift + left-click - - Select a range of search criteria.

Script Editor

cmd/ctrl + [ - Go to the previous script.

cmd/ctrl + ] - Go to the next script.

cmd/ctrl + 
backspace

- Clear the output pane.

Hotkey Button Menubar Function
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Supported Image Formats

The following table lists supported image formats.

Format Name Bit Depths Read/Write Extension

AVI n/a read only avi

CIN 10 (log) read and write cin

DPX (see the notes below) 8, 10, 12, and 16 read and write dpx

EXR (see the notes below) 16 and 32 read and write exr

GIF 8 read only gif

Radiance 16 read only hdr, hdri

JPEG 8 read and write jpg, jpeg

Maya IFF 8 and 16 read only iff

PNG 8 and 16 read and write png (8-bit)

png16 (16-bit)

PSD 8 read only psd

QuickTime n/a read and write mov

RAW n/a read only n/a

REDCODE (see the notes below) 16 read only r3d

SGI 8 and 16 read and write sgi, rgb, rgba (8-bit sequences)

sgi16 (for 16-bit sequences)

SoftImage®

PIC

8 read and write pic

TIFF 8, 16, and 32 read and write tif, tiff (8-bit sequences)

tif16, tiff16 (16-bit 
sequences)

ftif, ftiff (32-bit sequences)

Truevision® TARGA 8 read and write tga, targa

Wavefront®

RLA

8 read only rla

XPM 8 read only xpm

YUV 8 read only yuv
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Optimised Formats and Limitations

Hiero plays frames as fast as they can be read from the file system. The frames are cached in RAM up to 
the cache limit specified in the Preferences dialog. When the cache is full, frames are ejected and must be 
re-read from disk if needed again. 

Most file formats are read through the same image I/O library used by The Foundry’s Nuke. Formats are 
optimised for real-time playback based on user feedback about what is most frequently used. The 
following formats have been optimised, so that the only limiting factor in achieving realtime playback is 
the rate at which files can be read from the file system:

R3D
In conjunction with a RED Rocket, Hiero can take advantage of the lower scale/quality available from the 
RED SDK based on the current viewer zoom level.

EXR
EXR reads have been partly optimised. They currently still load more slowly if any part of the data window 
lies outside the display window, or if the data window is smaller then the display window and aligned to 
one of the edges of the display window. This reduction in speed is most noticeable for large data windows.

DPX
8, 10, 12 and 16 bit RGB and RGBA reads are optimised, if the channels are all stored in the same element. 
Reads of other formats may be optimised depending on the number, bit depth and layout (within elements) 
of the channels. Future releases will handle more formats.
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Supported Audio Formats 
Supported Audio Formats

The following table lists supported audio formats. 

Format Name Extension

All platforms

Broadcast wave format bwf

Wave wav

Mac

Audio interchange format aif

aiff

MPEG Layer III Audio mp3

Linux

Audio interchange format aif

aiff
Hiero 1.0v1The Foundry



APPENDIX C: THIRD PARTY LICENCES

Third Party Licences

This appendix lists third party libraries used in Hiero, along with their licences.

Library Description Licence

Boost/1.46.0 Source code function / 
template library

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organisation obtain-
ing a copy of the software and accompanying documentation covered by this license 
(the “Software”) to use, reproduce, display, distribute, execute, and transmit the 
Software, and to prepare derivative works of the Software, and to permit third-par-
ties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above 
license grant, this restriction and the following disclaimer, must be included in all 
copies of the Software, in whole or in part, and all derivative works of the Software, 
unless such copies or derivative works are solely in the form of machine-executable 
object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN 
NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFT-
WARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, 
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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Breakpad/1.0 Multi-platform crash 
reporting system

Copyright © 2010, Google Inc.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of the organization nor the names of its contributors may be 
used to endorse or promote products derived from this software without specific 
prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Curl/7.21.1 URL transfer library Copyright © 1996 - 2010, Daniel Stenberg, <daniel@haxx.se>.

All rights reserved.

Permission to use, copy, modify, and distribute this software for any purpose with or 
without fee is hereby granted, provided that the above copyright notice and this 
permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD 
PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE 
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION 
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION 
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used 
in advertising or otherwise to promote the sale, use or other dealings in this Soft-
ware without prior written authorization of the copyright holder.

EuCon/2.5.5 Software development 
kit

The EUCON specification and trademark are property of Avid Technology, Inc. Used 
under license.

Library Description Licence
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Expat/2.0.1 XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark 
Cooper

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the “Software”), to deal in the Soft-
ware without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, sublicense, and/or sell copies of the Software, and to per-
mit persons to whom the Software is furnished to do so, subject to the following 
conditions:

The above copyright notice and this permission notice shall be included in all copies 
or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
THE USE OR OTHER DEALINGS IN THE SOFTWARE.

FBX/2010.2 File format support This software contains Autodesk® FBX® code developed by Autodesk, Inc. Copy-
right 2008 Autodesk, Inc. All rights, reserved. Such code is provided “as is” and 
Autodesk, Inc. disclaims any and all warranties, whether express or implied, including 
without limitation the implied warranties of merchantability, fitness for a particular 
purpose or non-infringement of third party rights. In no event shall Autodesk, Inc. be 
liable for any direct, indirect, incidental, special, exemplary, or consequential dam-
ages (including, but not limited to, procurement of substitute goods or services; loss 
of use, data, or profits; or business interruption) however caused and on any theory 
of liability, whether in contract, strict liability, or tort (including negligence or other-
wise) arising in any way out of such code.

FFmpeg/r15261 File format support Copyright © 2001 Fabrice Bellard

This file is part of FFmpeg.

FFmpeg is free software; you can redistribute it and/or modify it under the terms of 
the GNU Lesser General Public License as published by the Free Software Foundation; 
either version 2.1 of the License, or (at your option) any later version.

FFmpeg is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with 
FFmpeg; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth 
Floor, Boston, MA 02110-1301 USA 

Library Description Licence
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GLEW/1.5.8 OpenGL support The OpenGL Extension Wrangler Library Copyright © 2002-2008, Milan Ikits <milan 
ikits@ieee.org>

Copyright © 2002-2008, Marcelo E. Magallon <mmagallo@debian.org>

Copyright © 2002, Lev Povalahev All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  The name of the author may be used to endorse or promote products derived 
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

JPEG/6b File format support This software is based in part on the work of the Independent JPEG Group.

Libexif/0.6.20 Metadata parser Author Lutz Mueller lutz@users.sourceforge.net date 2001-2005

This library is free software; you can redistribute it and/or modify it under the terms 
of the GNU Lesser General Public License as published by the Free Software Founda-
tion; either version 2 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

Library Description Licence
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Libpng/1.2.25 File format support This copy of the libpng notices is provided for your convenience. In case of any dis-
crepancy between this copy and the notices in the file png.h that is included in the 
libpng distribution, the latter shall prevail.

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

If you modify libpng you may insert additional notices immediately following this 
sentence.

libpng versions 1.2.6, August 15, 2004, through 1.2.25, February 18, 2008, are 
Copyright © 2004, 2006-2008 Glenn Randers-Pehrson, and are distributed accord-
ing to the same disclaimer and license as libpng-1.2.5 with the following individual 
added to the list of Contributing Authors: Cosmin Truta.

libpng versions 1.0.7, July 1, 2000, through 1.2.5 - October 3, 2002, are Copyright 
© 2000-2002 Glenn Randers-Pehrson, and are distributed according to the same 
disclaimer and license as libpng-1.0.6 with the following individuals added to the list 
of Contributing Authors: Simon-Pierre Cadieux, Eric S. Raymond, Gilles Vollant.

Including the following additions to the disclaimer:

There is no warranty against interference with your enjoyment of the library or 
against infringement.  There is no warranty that our efforts or the library will fulfill 
any of your particular purposes or needs.  This library is provided with all faults, and 
the entire risk of satisfactory quality, performance, accuracy, and effort is with the 
user.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are Copyright 
© 1998, 1999 Glenn Randers-Pehrson, and are distributed according to the same 
disclaimer and license as libpng-0.96, with the following individuals added to the list 
of Contributing Authors: Tom Lane, Glenn Randers-Pehrson, Willem van Schaik.

libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright © 1996, 
1997 Andreas Dilger Distributed according to the same disclaimer and license as lib-
png-0.88, with the following individuals added to the list of Contributing Authors: 
John Bowler, Kevin Bracey, Sam Bushell, Magnus Holmgren, Greg Roelofs, Tom Tan-
ner

libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright © 1995, 
1996 Guy Eric Schalnat, Group 42, Inc. For the purposes of this copyright and 
license, "Contributing Authors" is defined as the following set of individuals: Andreas 
Dilger, Dave Martindale, Guy Eric Schalnat, Paul Schmidt, Tim Wegner

The PNG Reference Library is supplied "AS IS".  The Contributing Authors and Group 
42, Inc. disclaim all warranties, expressed or implied, including, without limitation, 
the warranties of merchantability and of fitness for any purpose.  The Contributing 
Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, 
exemplary, or consequential damages, which may result from the use of the PNG 
Reference Library, even if advised of the possibility of such damage.

Library Description Licence
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Permission is hereby granted to use, copy, modify, and distribute this source code, 
or portions hereof, for any purpose, without fee, subject to the following restric-
tions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be misrepresented 
as being the original source.

3. This Copyright notice may not be removed or altered from any source or altered 
source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without fee, and 
encourage the use of this source code as a component to supporting the PNG file 
format in commercial products. If you use this source code in a product, acknowledg-
ment is not required but would be appreciated.

A "png_get_copyright" function is available, for convenient use in "about" boxes and 
the like:

printf("%s",png_get_copyright(NULL));

Also, the PNG logo (in PNG format, of course) is supplied in the files "pngbar.png" 
and "pngbar.jpg (88x31) and "pngnow.png" (98x31).

Libpng is OSI Certified Open Source Software. OSI Certified Open Source is a certifi-
cation mark of the Open Source Initiative.

Glenn Randers-Pehrson

glennrp at users.sourceforge.net

February 18, 2008

libresample/0.1.3 Realtime resampler All of the files in this package are Copyright 2003 by Dominic Mazzoni <domi-
nic@minorninth.com>. This library was based heavily on Resample-1.7, Copyright 
1994-2002 by Julius O. Smith III <jos@ccrma.stanford.edu>, all rights reserved.

Permission to use and copy is granted subject to the terms of the "GNU Lesser Gen-
eral Public License" (LGPL) as published by the Free Software Foundation; either ver-
sion 2.1 of the License, or any later version. In addition, Julius O. Smith III requests 
that a copy of any modified files be sent by email to jos@ccrma.stanford.edu so that 
he may incorporate them into the CCRMA version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. 

Library Description Licence
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libsndfile/1.0.25 Audio read/write Copyright © 1999-2011 Erik de Castro Lopo <erikd@mega-nerd.com>

Copyright © 2005 David Viens <davidv@plogue.com>

This program is free software; you can redistribute it and/or modify it under the 
terms of the GNU Lesser General Public License as published by the Free Software 
Foundation; either version 2.1 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS 
FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more 
details.

You should have received a copy of the GNU Lesser General Public License along with 
this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place - 
Suite 330, Boston, MA 02111-1307, USA.

Libtiff/3.9.4 File format support Copyright © 1988-1997 Sam Leffler Copyright © 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documen-
tation for any purpose is hereby granted without fee, provided that (i) the above 
copyright notices and this permission notice appear in all copies of the software and 
related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may 
not be used in any advertising or publicity relating to the software without the spe-
cific, prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, 
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPE-
CIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY 
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, 
WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THE-
ORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFOR-
MANCE OF THIS SOFTWARE.

Library Description Licence
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Msinttypes/r20 File format support Copyright © 2006 Alexander Chemeris

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution. 

•  The name of the author may not be used to endorse or promote products derived 
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR 
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRAN-
TIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DIS-
CLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, 
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, 
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS 
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR 
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenALSoft/1.13 Cross platform audio 
library 

Copyright © 1999-2007 by authors.

This library is free software; you can redistribute it and/or modify it under the terms 
of the GNU Library General Public License as published by the Free Software Founda-
tion; either version 2 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Library General Public License for more details.

You should have received a copy of the GNU Library General Public License along 
with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place 
- Suite 330, Boston, MA 02111-1307, USA.

Or go to www.gnu.org/copyleft/lgpl.html

Library Description Licence
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OpenColorIO/
1.0.0

Color management 
library

Copyright © 2003-2010 Sony Pictures Imageworks Inc., et al. All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of Sony Pictures Imageworks nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenEXR/cvs-03-
03-2008

File format support Copyright © 2002, Industrial Light & Magic, a division of Lucas Digital Ltd. LLC All 
rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of Industrial Light & Magic nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Library Description Licence
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OpenImageIO/
r1719

File format support Copyright © 2008 Larry Gritz and the other authors and contributors. All Rights 
Reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of the software's owners nor the names of its contributors may 
be used to endorse or promote products derived from this software without spe-
cific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Library Description Licence
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OpenSSL/1.0.0a A toolkit implementing 
the Secure Sockets 
Layer (SSL v2/v3) and 
Transport Layer Secu-
rity (TLS v1) protocols 
as well as a full-
strength general pur-
pose cryptography 
library

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the 
OpenSSL License and the original SSLeay license apply to the toolkit. See below for 
the actual license texts. Actually both licenses are BSD-style Open Source licenses. 
In case of any license issues related to OpenSSL please contact

openssl-core@openssl.org.

OpenSSL License

Copyright © 1998-2008 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list 
of conditions and the following disclaimer in the documentation and/or other materi-
also provided with the distribution.

3. All advertising materials mentioning features or use of this software must display 
the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse 
or promote products derived from this software without prior written permission. 
For written permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor may 
"OpenSSL" appear in their names without prior written permission of the OpenSSL 
Project.

6. Redistributions of any form whatsoever must retain the following acknowledg-
ment:

"This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY 
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@crypt-
soft.com). This product includes software written by Tim Hudson

(tjh@cryptsoft.com).

Library Description Licence
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Original SSLeay License

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com)

All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following 
conditions are aheared to. The following conditions apply to all code found in this 
distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL 
documentation included with this distribution is covered by the same copyright 
terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are 
not to be removed.

If this package is used in a product, Eric Young should be given attribution as the 
author of the parts of the library used.

This can be in the form of a textual message at program startup or in documentation 
(online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of condi-
tions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list 
of conditions and the following disclaimer in the documentation and/or other materi-
als provided with the distribution.

3. All advertising materials mentioning features or use of this software must display 
the following acknowledgement:

"This product includes cryptographic software written by Eric Young (eay@crypt-
soft.com)"

The word 'cryptographic' can be left out if the rouines from the library being used are 
not cryptographic related :-).

4. If you include any Windows specific code (or a derivative thereof) from the apps 
directory (application code) you must include an acknowledgement:

"This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR 
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRAN-
TIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DIS-
CLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAM-
AGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS 
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) 
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN 
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSI-
BILITY OF SUCH DAMAGE.

Library Description Licence
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The licence and distribution terms for any publically available version or derivative of 
this code cannot be changed. i.e. this code cannot simply be copied and put under 
another distribution licence [including the GNU Public Licence.]

PySide 1.0.9 Python bindings for the 
Qt cross-platform 
application and UI 
framework

Copyright © 2009-2010 Nokia Corporation and/or its subsidiary(-ies).

Contact: PySide team <contact@pyside.org>

This library is free software; you can redistribute it and/or modify it under the terms 
of the GNU Lesser General Public License as published by the Free Software Founda-
tion; either version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with 
this library; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, 
Fifth Floor, Boston, MA 02110-1301 USA

PyString C++ functions match-
ing the interface and 
behavior of Python's 
string class methods

Copyright © 2008-2010, Sony Pictures Imageworks Inc

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

•  Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

•  Redistributions in binary form must reproduce the above copyright notice, this 
list of conditions and the following disclaimer in the documentation and/or other 
materials provided with the distribution.

•  Neither the name of the organization Sony Pictures Imageworks nor the names of 
its contributors may be used to endorse or promote products derived from this 
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTIC-
ULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY 
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFT-
WARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Python/2.6.5 Source code language Copyright © 2001, 2002, 2003, 2004 Python Software Foundation; All Rights 
Reserved.

Library Description Licence
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Qt/4.7.2 Application and UI 
framework

The Qt GUI Toolkit is Copyright © 2010 Nokia Corporation and/or its

subsidiary(-ies).

Contact: Nokia Corporation (qt-info@nokia.com)

Qt is available under the GNU Lesser General Public License.

To see the GNU Lesser General Public License, go to www.gnu.org/licenses/.

QuaZip/0.3 Qt ZIP wrapper Copyright © 2005 Sergey A. Tachenov

This program is free software; you can redistribute it and/or modify it under the 
terms of the GNU General Public License as published by the Free Software Founda-
tion; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS 
FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

Original ZIP package is copyrighted by Gilles Vollant, see quazip/(un)zip.h files for 
details.

QuickTime/7.3 QuickTime player Copyright © 1990-2006 by Apple Inc., all rights reserved.

R3D/4.1 Software Development 
Kit

The R3D SDK and all included materials (including header files, libraries, sample code 
& documentation) are Copyright © 2008-2011 RED Digital Cinema. All rights 
reserved. All trademarks are the property of their respective owners.

This software was developed using KAKADU software.

Skein/1.1 Hashing library Source code author: Doug Whiting, 2008.

This algorithm and source code is released to the public domain.

Copyright © 2003, Dr Brian Gladman, Worcester, UK. All rights reserved.

LICENSE TERMS

The free distribution and use of this software in both source and binary form is 
allowed (with or without changes) provided that:

1. distributions of this source code include the above copyright notice, this list of 
conditions and the following disclaimer;

2. distributions in binary form include the above copyright notice, this list of condi-
tions and the following disclaimer in the documentation and/or other associated 
materials;

3. the copyright holder's name is not used to endorse products built using this soft-
ware without specific written permission.

ALTERNATIVELY, provided that this notice is retained in full, this product may be 
distributed under the terms of the GNU General Public License (GPL), in which case 
the provisions of the GPL apply INSTEAD OF those given above.

DISCLAIMER

This software is provided 'as is' with no explicit or implied warranties in respect of 
its properties, including, but not limited to, correctness and/or fitness for purpose.

Library Description Licence
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TTB Thread Building Blocks Copyright 2005-2010 Intel Corporation. All Rights Reserved.

This file is part of Threading Building Blocks.

Threading Building Blocks is free software; you can redistribute it and/or modify it 
under the terms of the GNU General Public License version 2 as published by the Free 
Software Foundation.

Threading Building Blocks is distributed in the hope that it will be useful, but WITH-
OUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more 
details.

You should have received a copy of the GNU General Public License along with 
Threading Building Blocks; if not, write to the Free Software Foundation, Inc., 51 
Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

As a special exception, you may use this file as part of a free software library with-
out restriction. Specifically, if other files instantiate templates or use macros or 
inline functions from this file, or you compile this file and link it with other files to 
produce an executable, this file does not by itself cause the resulting executable to 
be covered by the GNU General Public License. This exception does not however 
invalidate any other reasons why the executable file might be covered by the GNU 
General Public License. 

VXL/1.10.0 Computer vision Copyright © 2000-2003 TargetJr Consortium

GE Corporate Research and Development (GE CRD)

1 Research Circle

Niskayuna, NY 12309

All Rights Reserved

Reproduction rights limited as described below.

Permission to use, copy, modify, distribute, and sell this software and its documen-
tation for any purpose is hereby granted without fee, provided that (i) the above 
copyright notice and this permission notice appear in all copies of the software and 
related documentation, (ii) the name TargetJr Consortium (represented by GE CRD), 
may not be used in any advertising or publicity relating to the software without the 
specific, prior written permission of GE CRD, and (iii) any modifications are clearly 
marked and summarised in a change history log.

THE SOFTWARE IS PROVIDED “AS IS” AND WITHOUT WARRANTY OF ANY KIND, 
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO 
EVENT SHALL THE TARGETJR CONSORTIUM BE LIABLE FOR ANY SPECIAL, INCIDEN-
TAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND OR ANY DAMAGES 
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR 
NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR ON ANY THEORY OF 
LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE 
OF THIS SOFTWARE.
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xmlrpcpp/0.7 C++ implementation of 
the XML-RPC protocol

A full copy of the LGPL license is included in the file COPYING. The source code is 
Copyright © 2002-2003 by Chris Morley. 

This library is free software; you can redistribute it and/or modify it under the terms 
of the GNU Lesser General Public License as published by the Free Software Founda-
tion; either version 2.1 of the License, or (at your option) any later version. This 
library is distributed in the hope that it will be useful, but WITHOUT ANY WAR-
RANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. 
You should have received a copy of the GNU Lesser General Public License along with 
this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, 
Suite 330, Boston, MA 02111-1307 USA 

Zlib/1.2.5 Compression library Copyright © 1995-2010 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied warranty. In no 
event will the authors be held liable for any damages arising from the use of this 
software.

Permission is granted to anyone to use this software for any purpose, including 
commercial applications, and to alter it and redistribute it freely, subject to the fol-
lowing restrictions:

1. The origin of this software must not be misrepresented; you must not claim that 
you wrote the original software. If you use this software in a product, an acknowl-
edgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrep-
resented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Library Description Licence
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End User Licensing Agreement (EULA)

IMPORTANT: BY INSTALLING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ THIS 
AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. IF YOU DO 
NOT AGREE TO THE TERMS OF THIS AGREEMENT DO NOT INSTALL, COPY OR USE THE SOFTWARE.

This END USER LICENSE AGREEMENT (this "Agreement") is made by and between The Foundry 
Visionmongers Ltd., a company registered in England and Wales, ("The Foundry"), and you, as either an 
individual or a single entity ("Licensee").

In consideration of the mutual covenants contained herein and for other good and valuable consideration 
(the receipt and sufficiency of which is acknowledged by each party hereto) the parties agree as follows:

SECTION 1. GRANT OF LICENSE.

Subject to the limitations of Section 2, The Foundry hereby grants to Licensee a limited, non-transferable 
and non-exclusive license to install and use a machine readable, object code version of this software 
program (the "Software") and accompanying user guide and other documentation (collectively, the 
"Documentation") solely for Licensee's own internal business purposes (collectively, the "License"); 
provided, however, Licensee's right to install and use the Software and the Documentation is limited to 
those rights expressly set out in this Agreement.

SECTION 2. RESTRICTIONS ON USE.

Licensee is authorized to use the Software in machine readable, object code form only, and Licensee shall 
not: (a) assign, sublicense, sell, distribute, transfer, pledge, lease, rent, share or export the Software, the 
Documentation or Licensee's rights hereunder; (b) alter or circumvent the copy protection mechanisms in 
the Software or reverse engineer, decompile, disassemble or otherwise attempt to discover the source 
code of the Software; (c) modify, adapt, translate or create derivative works based on the Software or 
Documentation; (d) use, or allow the use of, the Software or Documentation on any project other than a 
project produced by Licensee (an "Authorized Project"); (e) allow or permit anyone (other than Licensee and 
Licensee's authorized employees to the extent they are working on an Authorized Project) to use or have 
access to the Software or Documentation; (f) copy or install the Software or Documentation other than as 
expressly provided for herein; or (g) take any action, or fail to take action, that could adversely affect the 
trademarks, service marks, patents, trade secrets, copyrights or other intellectual property rights of The 
Foundry or any third party with intellectual property rights in the Software (each, a "Third Party Licensor"). 
Furthermore, for purposes of this Section 2, the term "Software" shall include any derivatives of the 
Software.

Licensee shall install and use only a single copy of the Software on one computer, unless the Software is 
installed in a "floating license" environment, in which case Licensee may install the Software on more than 
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one computer; provided, however, Licensee shall not at any one time use more copies of the Software than 
the total number of valid Software licenses purchased by Licensee.

Please note that in order to guard against unlicensed use of the Software a licence key is required to 
access and enable the Software. The issuing of replacement or substituted licence keys if the Software is 
moved from one computer to another is subject to and strictly in accordance with The Foundry’s Licence 
Transfer Policy, which is available on The Foundry’s website and which requires a fee to be paid in certain 
circumstances. The Foundry may from time to time and at its sole discretion vary the terms and conditions 
of the Licence Transfer Policy.

Furthermore, if the Software can be licensed on an "interactive" or "non-interactive" basis, licensee shall be 
authorized to use a non-interactive version of the Software for rendering purposes only (i.e., on a CPU, 
without a user, in a non-interactive capacity) and shall not use such Software on workstations or 
otherwise in a user-interactive capacity. Licensee shall be authorized to use an interactive version of the 
Software for both interactive and non-interactive rendering purposes, if available.

If Licensee has purchased the Software on the discount terms offered by The Foundry’s Educational Policy 
published on its website (“the Educational Policy”), Licensee warrants and represents to The Foundry as a 
condition of this Agreement that: (a) (if Licensee is an individual) he or she is a part-time or full-time 
student at the time of purchase and will not use the Software for commercial, professional or for-profit 
purposes; (b) (if the Licensee is not an individual) it is an organisation that will use it only for the purpose 
of training and instruction, and for no other purpose (c) Licensee will at all times comply with the 
Educational Policy (as such policy may be amended from time to time).

Finally, if the Software is a "Personal Learning Edition," (“PLE”) Licensee may use it only for the purpose of 
personal or internal training and instruction, and for no other purpose. PLE versions of the Software may 
not be used for commercial, professional or for-profit purposes including, for the avoidance of doubt, the 
purpose of providing training or instruction to third parties.

SECTION 3. SOURCE CODE.

Notwithstanding that Section 1 defines “Software” as an object code version and that Section 2 provides 
that Licensee may use the Software in object code form only, The Foundry may also agree to license to 
Licensee (including by way of upgrades, updates or enhancements) source code or elements of the source 
code of the Software the intellectual property rights in which belong either to The Foundry or to a Third 
Party Licensor (“Source Code”). If The Foundry does so Licensee shall be licensed to use the Source Code as 
Software on the terms of this Agreement and: (a) notwithstanding Section 2 (c) Licensee may use the 
Source Code at its own risk in any reasonable way for the limited purpose of enhancing its use of the 
Software solely for its own internal business purposes and in all respects in accordance with this 
Agreement; (b) Licensee shall in respect of the Source Code comply strictly with all other restrictions 
applying to its use of the Software under this Agreement as well as any other restriction or instruction 
that is communicated to it by The Foundry at any time during this Agreement (whether imposed or 
requested by The Foundry or by any Third Party Licensor); (c) notwithstanding any other term of this 
Agreement The Foundry gives no warranty whatsoever in respect of the Source Code, which is licensed on 
an “as is” basis, or in respect of any modification of the Source Code made by Licensee (“Modification”); (d) 
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notwithstanding any other term of this Agreement The Foundry shall have no obligation to provide 
support, maintenance, upgrades or updates of or in respect of the Source Code or of any Modification; and 
(e) Licensee shall indemnify The Foundry against all liabilities and expenses (including reasonable legal 
costs) incurred by The Foundry in relation to any claim asserting that any Modification infringes the 
intellectual property rights of any third party.

SECTION 4. BACK-UP COPY.

Notwithstanding Section 2, Licensee may store one copy of the Software and Documentation off-line and 
off-site in a secured location owned or leased by Licensee in order to provide a back-up in the event of 
destruction by fire, flood, acts of war, acts of nature, vandalism or other incident. In no event may 
Licensee use the back-up copy of the Software or Documentation to circumvent the usage or other 
limitations set forth in this Agreement.

SECTION 5. OWNERSHIP.

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that is 
licensed to Licensee) and Documentation and all intellectual property rights and other proprietary rights 
relating thereto are and shall remain the sole property of The Foundry and the Third Party Licensors. 
Licensee shall not remove, or allow the removal of, any copyright or other proprietary rights notice 
included in and on the Software or Documentation or take any other action that could adversely affect the 
property rights of The Foundry or any Third Party Licensor. To the extent that Licensee is authorized to 
make copies of the Software or Documentation under this Agreement, Licensee shall reproduce in and on 
all such copies any copyright and/or other proprietary rights notices provided in and on the materials 
supplied by The Foundry hereunder. Nothing in this Agreement shall be deemed to give Licensee any rights 
in the trademarks, service marks, patents, trade secrets, confidential information, copyrights or other 
intellectual property rights of The Foundry or any Third Party Licensor, and Licensee shall be strictly 
prohibited from using the name, trademarks or service marks of The Foundry or any Third Party Licensor in 
Licensee's promotion or publicity without The Foundry's express written approval.

SECTION 6. LICENSE FEE.

Licensee understands that the benefits granted to Licensee hereunder are contingent upon Licensee's 
payment in full of the license fee payable in connection herewith (the "License Fee").

SECTION 7. UPGRADES/ENHANCEMENTS.

The Licensee's access to support, upgrades and updates is subject to the terms and conditions of the 
"Annual Upgrade and Support Programme” available on The Foundry's website. The Foundry may from time 
to time and at its sole discretion vary the terms and conditions of the Annual Upgrade and Support 
Programme.

SECTION 8. TAXES AND DUTIES. 

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax 
(exclusive of taxes based on net income), duty, tariff or other impost related to or arising from the 
transaction contemplated by this Agreement.
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SECTION 9. LIMITED WARRANTY.

The Foundry warrants that, for a period of ninety (90) days after delivery of the Software: (a) the machine 
readable electronic files constituting the Software and Documentation shall be free from errors that may 
arise from the electronic file transfer from The Foundry and/or its authorized reseller to Licensee; and (b) 
to the best of The Foundry's knowledge, Licensee's use of the Software in accordance with the 
Documentation will not, in and of itself, infringe any third party's copyright, patent or other intellectual 
property rights. Except as warranted, the Software and Documentation is being provided "as is." THE 
FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS, EXPRESS OR 
IMPLIED, AND The Foundry DISCLAIMS ANY AND ALL IMPLIED WARRANTIES OR CONDITIONS, INCLUDING, 
WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF TITLE, NON-INFRINGEMENT, MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE, REGARDLESS OF WHETHER The Foundry KNOWS OR HAS REASON 
TO KNOW OF LICENSEE'S PARTICULAR NEEDS. The Foundry does not warrant that the Software or 
Documentation will meet Licensee's requirements or that Licensee's use of the Software will be 
uninterrupted or error free. No employee or agent of The Foundry is authorized to modify this limited 
warranty, nor to make additional warranties. No action for any breach of the above limited warranty may 
be commenced more than one (1) year after Licensee's initial receipt of the Software. To the extent any 
implied warranties may not be disclaimed under applicable law, then ANY IMPLIED WARRANTIES ARE 
LIMITED IN DURATION TO NINETY (90) DAYS AFTER DELIVERY OF THE SOFTWARE TO LICENSEE. 

SECTION 10. LIMITED REMEDY.

The exclusive remedy available to the Licensee in the event of a breach of the foregoing limited warranty, 
TO THE EXCLUSION OF ALL OTHER REMEDIES, is for Licensee to destroy all copies of the Software, send 
The Foundry a written certification of such destruction and, upon The Foundry's receipt of such 
certification, The Foundry will make a replacement copy of the Software available to Licensee.

SECTION 11. INDEMNIFICATION.

Licensee agrees to indemnify, hold harmless and defend The Foundry, the Third Party Licensors and The 
Foundry's and each Third Party Licensor’s respective affiliates, officers, directors, shareholders, 
employees, authorized resellers, agents and other representatives (collectively, the "Released Parties") 
from all claims, defense costs (including, but not limited to, attorneys' fees), judgments, settlements and 
other expenses arising from or connected with the operation of Licensee's business or Licensee's 
possession or use of the Software or Documentation.

SECTION 12. LIMITED LIABILITY.

In no event shall the Released Parties' cumulative liability to Licensee or any other party for any loss or 
damages resulting from any claims, demands or actions arising out of or relating to this Agreement (or the 
Software or Documentation contemplated herein) exceed the License Fee paid to The Foundry or its 
authorized reseller for use of the Software. Furthermore, IN NO EVENT SHALL THE RELEASED PARTIES BE 
LIABLE TO LICENSEE UNDER ANY THEORY FOR ANY INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, 
EXEMPLARY OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS OR LOSS OF 
PROFITS) OR THE COST OF PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES, REGARDLESS OF 
WHETHER THE RELEASED PARTIES KNOW OR HAVE REASON TO KNOW OF THE POSSIBILITY OF SUCH 
DAMAGES AND REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL 
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PURPOSE. No action arising out of or related to this Agreement, regardless of form, may be brought by 
Licensee more than one (1) year after Licensee's initial receipt of the Software; provided, however, to the 
extent such one (1) year limit may not be valid under applicable law, then such period shall be limited to 
the shortest period allowed by law.

SECTION 13. TERM; TERMINATION.

This Agreement is effective upon Licensee's acceptance of the terms hereof and Licensee's payment of the 
License Fee, and the Agreement will remain in effect until termination. If Licensee breaches this Agreement, 
The Foundry may terminate the License granted hereunder by notice to Licensee. In the event the License 
is terminated, Licensee will either return to The Foundry all copies of the Software and Documentation in 
Licensee's possession or, if The Foundry directs in writing, destroy all such copies. In the later case, if 
requested by The Foundry, Licensee shall provide The Foundry with a certificate signed by an officer of 
Licensee confirming that the foregoing destruction has been completed.

SECTION 14. CONFIDENTIALITY.

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is licensed 
to Licensee) and Documentation are proprietary and confidential information of The Foundry or, as the 
case may be, the Third Party Licensors, and that all such information and any communications relating 
thereto (collectively, "Confidential Information") are confidential and a fundamental and important trade 
secret of The Foundry or the Third Party Licensors. Licensee shall disclose Confidential Information only to 
Licensee's employees who are working on an Authorized Project and have a "need-to-know" of such 
Confidential Information, and shall advise any recipients of Confidential Information that it is to be used 
only as authorized in this Agreement. Licensee shall not disclose Confidential Information or otherwise 
make any Confidential Information available to any other of the Licensee's employees or to any third 
parties without the express written consent of The Foundry. Licensee agrees to segregate, to the extent it 
can be reasonably done, the Confidential Information from the confidential information and materials of 
others in order to prevent commingling. Licensee shall take reasonable security measures, which such 
measures shall be at least as great as the measures Licensee uses to keep Licensee's own confidential 
information secure (but in any case using no less than a reasonable degree of care), to hold the Software, 
Documentation and any other Confidential Information in strict confidence and safe custody. The Foundry 
may request, in which case Licensee agrees to comply with, certain reasonable security measures as part 
of the use of the Software and Documentation. Licensee acknowledges that monetary damages may not be 
a sufficient remedy for unauthorized disclosure of Confidential Information, and that The Foundry shall be 
entitled, without waiving any other rights or remedies, to such injunctive or equitable relief as may be 
deemed proper by a court of competent jurisdiction. 

SECTION 15. INSPECTION.

Licensee shall advise The Foundry on demand of all locations where the Software or Documentation is used 
or stored. Licensee shall permit The Foundry or its authorized agents to inspect all such locations during 
normal business hours and on reasonable advance notice.
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SECTION 16. NONSOLICITATION.

Licensee agrees not to solicit for employment or retention any of The Foundry's current or future 
employees who were or are involved in the development and/or creation of the Software.

SECTION 17. U.S. GOVERNMENT LICENSE RIGHTS.

The Software, Documentation and/or data delivered hereunder are subject to the terms of this Agreement 
and in no event shall the U.S. Government acquire greater than RESTRICTED/LIMITED RIGHTS. At a 
minimum, use, duplication or disclosure by the U.S. Government is subject to the applicable restrictions of: 
(i) FAR §52.227-14 ALTS I, II and III (June 1987); (ii) FAR §52.227-19 (June 1987); (iii) FAR §12.211 and 
12.212; and/or (iv) DFARS §227.7202-1(a) and DFARS §227.7202-3.

The Software is the subject of the following notices:

• Copyright © 2012 The Foundry Visionmongers, Ltd.. All Rights Reserved.

• Unpublished-rights reserved under the Copyright Laws of the United Kingdom.

SECTION 18. SURVIVAL.

Sections 2, 3, 5, 6, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19 and 20 shall survive any termination or 
expiration of this Agreement.

SECTION 19. IMPORT/EXPORT CONTROLS.

To the extent that any Software made available hereunder is subject to restrictions upon export and/or 
reexport from the United States, Licensee agrees to comply with, and not act or fail to act in any way that 
would violate, the applicable international, national, state, regional and local laws and regulations, 
including, without limitation, the United States Foreign Corrupt Practices Act, the Export Administration 
Act and the Export Administration Regulations, as amended or otherwise modified from time to time, and 
neither The Foundry nor Licensee shall be required under this Agreement to act or fail to act in any way 
which it believes in good faith will violate any such laws or regulations.

SECTION 20. MISCELLANEOUS.

This Agreement is the exclusive agreement between the parties concerning the subject matter hereof and 
supersedes any and all prior oral or written agreements, negotiations, or other dealings between the 
parties concerning such subject. This Agreement may be modified only by a written instrument signed by 
both parties. If any action is brought by either party to this Agreement against the other party regarding 
the subject matter hereof, the prevailing party shall be entitled to recover, in addition to any other relief 
granted, reasonable attorneys' fees and expenses of litigation. Should any term of this Agreement be 
declared void or unenforceable by any court of competent jurisdiction, such declaration shall have no 
effect on the remaining terms of this Agreement. The failure of either party to enforce any rights granted 
hereunder or to take action against the other party in the event of any breach hereunder shall not be 
deemed a waiver by that party as to subsequent enforcement of rights or subsequent actions in the event 
of future breaches. This Agreement shall be governed by, and construed in accordance with English Law.

The Foundry and Licensee intend that each Third Party Licensor may enforce against Licensee under the 
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Contracts (Rights of Third Parties) Act 1999 ("the Act") any obligation owed by Licensee to The Foundry 
under this Agreement that is capable of application to any proprietary or other right of that Third Party 
Licensor in or in relation to the Software. The Foundry and Licensee reserve the right under section 2(3)(a) 
of the Act to rescind, terminate or vary this Agreement without the consent of any Third Party Licensor.

Copyright © 2012 The Foundry Visionmongers Ltd. All Rights Reserved. Do not duplicate.
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