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1  INTRODUCTION

Welcome to this User Guide for CameraTracker 1.0 on After Effects.

We hope you enjoy using CameraTracker.

About this User 
Guide

This User Guide will tell you how to install and use CameraTracker 1.0 on 
After Effects. This guide assumes you are familiar with After Effects and the 
machine it is running on.
For the most up to date information, please see the CameraTracker product 
page and the latest user guide on our web site at 
http://www.thefoundry.co.uk.

Release Notes For information on system requirements, new features, improvements, fixed 
bugs, known bugs and workarounds, see “Appendix A” on page 88.

Example Images Example images for use with CameraTracker can be downloaded from our 
web site http://www.thefoundry.co.uk.

Installing 
CameraTracker 1.0 
on After Effects

Please note that installing CameraTracker will effectively overwrite any 
other versions of CameraTracker that have been installed to the default 
location.

On Windows CameraTracker is distributed as a software download from our web site at 
http://www.thefoundry.co.uk. To install CameraTracker on a computer 
running Windows follow these instructions:

1. Download the correct installation file from our web site at 
www.thefoundry.co.uk.

2. Unzip the file and double-click on the EXE file to launch the installer. 
Follow the on-screen instructions to install CameraTracker.
CameraTrackerThe Foundry
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On Mac CameraTracker is distributed as a software download from our web site at 
http://www.thefoundry.co.uk. To install CameraTracker on a Mac, follow 
these instructions:

1. Download the correct installation file from our web site at 
www.thefoundry.co.uk.

2. Double-click on the downloaded DMG file.

3. Double-click on the PKG file that is created.

4. Follow the on-screen instructions to install CameraTracker.

Licensing 
CameraTracker

You can license, or activate, CameraTracker in one of two ways:

• Licence Key—a sequence of numbers and letters stored in a plain text 
file that unlocks CameraTracker. 

Using FLEXlm encryption, licence keys can be created for a particular 
computer enabling the software to run only on that computer. These are 
called node locked licences. We also supply floating licences that will 
unlock CameraTracker on any computer networked to a Foundry FLEXlm 
Tools (FFT) server.

Here is an example node-locked (uncounted) licence that expires on 31 
July 2010 for a computer running CameraTracker with a System ID of 
00123fdb9e9f. Node-locked licences allow you to run CameraTracker on 
one machine only.

INCREMENT cameratracker_ae_i foundry 1.0 31-jul-2010 uncounted 
\ HOSTID=00123fdb9e9f ISSUED=30-jun-2010 TS_OK SIGN="030A 5EB4 
\ FC11 3D9C B47F 3C03 6AEE 88A5 3338 ADB9 6E00 BE55 FC97 6021 \ 
7AAF 82CD D2F3 3833 E5D8 4CED A3CD"

INCREMENT cameratracker_ae_r foundry 1.0 31-jul-2010 uncounted 
\ HOSTID=00123fdb9e9f ISSUED=30-jun-2010 TS_OK SIGN="00C2 EE6A 
\ 9BBF EE0C FA43 45EB 282C 10B7 47FA 4FE3 8C01 FF47 7A39 F35E \ 
8E65 8D65 7C52 3B07 E1A3 F39F 70D5" 

FFT tools and a user guide to install licence keys, manage floating 
licences, and diagnose licence problems can be downloaded from our web 
site, http://www.thefoundry.co.uk/licensing.

• Serial Number—a series of 32 numbers and letters emailed to you that 
activates CameraTracker. 

Here is an example serial number:

6D4A-453B-FE3A-4A2F-35C2-ED29-A1D3-7DC2

To authenticate CameraTracker from the After Effects user interface:

1. Click the Activation button. See “Basic Controls” on page 13.

2. You are automatically directed to The Foundry web site log in page.

Note If you’re logged in already, skip ahead to step 4.
CameraTrackerThe Foundry
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3. Log in as normal, or sign up if you do not have a log in ID and password.

The Activate a Plug-in Serial Number page displays.

4. Enter the Serial Number that was emailed to you in the fields provided.

Your System ID is displayed on screen for verification.

It is very important to check the System ID shown on the web site 
matches your machine before continuing, as CameraTracker will only be 
licensed to the computer identified with this unique number. 

Note You can display your System ID by clicking on the About button of Foundry 
plug-ins running on After Effects.

5. Click Activate.

The Licence Key Created screen displays, and you will receive an email 
containing the on screen information.

6. Follow the on screen instruction to install the Licence Key.

Other Foundry 
Products

The Foundry is a leading developer of visual effects and image processing 
technologies for film and video post production. Its products include Nuke, 
Mari, Storm, Furnace, FurnaceCore, Ocula, Keylight, RollingShutter, and 
Kronos and run on a variety of compositing platforms including Adobe After 
Effects, Discreet Flame from Autodesk, Avid DS and Apple’s Final Cut Pro. 
For the full list of products and supported platforms see http://
www.thefoundry.co.uk.

Nuke is an Academy Award® winning compositor. It has been used to 
create extraordinary images on scores of feature films including Avatar, 
District 9, The Dark Knight, Iron Man, Quantum of Solace, The Curious Case 
of Benjamin Button, Transformers, and Pirates of the Caribbean: At World’s 
End.

Mari is a creative texture-painting tool that can handle extremely complex 
or texture heavy projects. It was developed at Weta Digital and has been 
used on films such as District 9, The Day the Earth Stood Still, The Lovely 
Bones, and Avatar.

Storm is a product developed in-house at The Foundry to assist RED Digital 
Cinema camera production workflows from on-set to delivery. It acts as a 
hub, providing access to both metadata and original RAW image files 
throughout the production process.

Furnace and FurnaceCore are collections of film tools. Many of the 
algorithms utilise motion estimation technology to speed up common 
compositing tasks. Plug-ins include wire removal, rig removal, steadiness, 
CameraTrackerThe Foundry
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deflicker, degrain and regrain, retiming, and texture tools.

Keylight is an industry-proven blue/green screen keyer, giving results that 
look photographed, not composited. The Keylight algorithm was developed 
by the Computer Film Company who were honoured with a technical 
achievement award for digital compositing from the Academy of Motion 
Picture Arts and Sciences.

Ocula is a collection of tools that solve common problems with stereoscopic 
imagery, improve productivity in post production, and ultimately help to 
deliver a more rewarding 3D-stereo viewing experience.

Kronos is a plug-in that retimes footage using motion vectors to generate 
additional images between frames. Utilising NVIDIA’s CUDA technology, 
Kronos optimises your workflow by using both the CPU and GPU.

RollingShutter is a plug-in that tackles image-distortion problems often 
experienced by users of CMOS cameras. The plug-in will often vastly 
improve the look of distorted footage, by either minimising or eradicating 
image distortions. Unlike solutions tied to camera stabilisation, that stretch 
the image as a whole, the RollingShutter plug-in compensates for local 
skewing and distortion in the scene, by correcting each object individually.

Visit The Foundry’s web site at http://www.thefoundry.co.uk for further 
details.
CameraTrackerThe Foundry
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2  GETTING STARTED

Overview CameraTracker is designed to provide an integrated camera tracking or 
matchmoving tool which allows you to create a virtual camera whose 
movement matches that of your original camera, all without leaving the 
After Effects environment. This camera can be used for a multitude of tasks 
including integrating 2.5D objects in to the scene to reduce masking and 
roto work, projection mapping, and more.

You can automatically track features, solve the position of cameras, and 
create a scene linked to the solve containing a 3D camera. CameraTracker 
also enables you to mask out areas of the scene that you don’t want 
tracked, like moving objects for example.

Bear in mind that CameraTracker requires footage from a moving camera 
with sufficient parallax between features from frame to frame in order to 
extract enough data to solve the 3D camera—static camera footage does 
not provide enough information to solve the data correctly.

Launching 
CameraTracker

CameraTracker on After Effects acts like any other effect available on the 
user interface, and as such, you can access the controls from the Effect 
drop down menu or Effects & Presets panel.

To access CameraTracker from the Effect menu, select Effect > The Foundry 
> CameraTracker.

Note In order to access CameraTracker from the Effect menu, a layer must be 
selected in the Viewer or Timeline.
CameraTrackerThe Foundry
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To access CameraTracker from the Effects & Presets panel, select The 
Foundry and double-click CameraTracker, or drag and drop the effect on to 
the required layer in your composition.

Quick Start 
CameraTracker

On the CameraTracker panel you can see the default settings shown below.

CameraTracker can automatically calculate your feature tracks, solve the 
CameraTrackerThe Foundry
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camera, and create a scene with three button clicks, but the results may not 
be very useful unless the layer you’re tracking is extremely simple.

To use CameraTracker on a simple layer, follow the steps below. Otherwise 
proceed to “Using CameraTracker” on page 12.

1. In the CameraTracker Effect Control Window (ECW), click Track Features, 
or navigate to CameraTracker Menu > Actions > Track Features in the 
Viewer.

Note This step can take a long time depending on the length of your composition.

2. When the track phase completes, click Solve Camera, or navigate to 
CameraTracker Menu > Actions > Solve Camera in the Viewer. A dialog 
box displays the solve progress.

3. Click Create Scene, or navigate to CameraTracker Menu > Actions > 
Create Scene in the Viewer.

CameraTracker creates a camera (and a parent null object) within your 
composition, then you can select feature points in the viewer to create 
solids or nulls at specific locations.

For very simple tracking problems, these three steps may allow you to 
create a tracked camera and place 3D objects so that they ’stick’ to the 
required plane in the composition when viewed through the tracked camera.
CameraTrackerThe Foundry
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3  USING CAMERATRACKER

Getting the best results from CameraTracker usually involves more than 
simply using the automatic tracking, solving, and scene creation tools. The 
CameraTracker interface incorporates many settings that can improve your 
final output, and this chapter aims to instruct you on using the tools 
included in the package.

CameraTracker 
Workflow

Camera tracking, or matchmoving as it is sometimes known, generally 
occurs early on in the post-production workflow. A typical workflow using 
CameraTracker can be broken down in to the following steps:

1. Tracking Features—record a layer’s feature data using the automatic 
tracking function. See “Tracking Features” on page 14.

• Mask out any areas in your sequence that you don’t want to track. See 
“Using Mattes” on page 14.

• Enter the tracking range and configuration. See “Setting Tracking 
Parameters” on page 16.

• Troubleshoot the feature tracks if necessary. See “Fine Tuning Your 
Feature Tracks” on page 58.

2. Solving—analyse the 2D tracking data and create an internal 
representation of the scene’s feature points and camera. See “Solving 
Your Camera Position” on page 23.

• Set the solve and lens parameters including focal length and lens dis-
tortion. See “Setting Camera Parameters” on page 23 and “Setting 
Lens Distortion Parameters” on page 47.

• Troubleshoot the solve if necessary. See “Troubleshooting Solves” on 
page 62.

3. Creating a Scene—create a 3D scene incorporating the 3D camera 
position and related solid and null objects associated with the scene. 
See “Creating a Scene” on page 28.

Successfully completing the CameraTracker workflow above creates a 
camera, identical to other cameras within After Effects, that can be used in 
a range of techniques from simple floating text within a 3D environment to 
extensive projection mapping and high-end 2D/3D integration.
CameraTrackerThe Foundry



USING CAMERATRACKER 13
Basic Controls 
Basic Controls CameraTracker’s basic controls show effect information, provide an 
activation function for licensing purposes, and allow you to reset or turn 
effects on or off without removing them from layers.

Menu Bar The menu bar at the top of the CameraTracker panel displays the current 
effect and file names as well as the following buttons.

Icon Name Description

Reveal Show or hide the current effect panel.

Effect Toggle Enable or disable the current effect to quickly view the results.

3D Though not strictly a button, this icon tells you that the current 
effect is a 3D feature.

Reset Return all CameraTracker settings to their default values.

Activation Click to open a web page for activation of CameraTracker serial 
numbers. See “Licensing CameraTracker” on page 6.

About... Displays the About window containing information on 
CameraTracker.
CameraTrackerThe Foundry
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Tracking Features Tracking is the first stage of the camera tracking process and obtaining 
accurate results is crucial as subsequent stages rely on the integrity of the 
initial tracking data. CameraTracker handles feature track selection for you, 
including reseeding tracks if they become unusable.

CameraTracker sometimes encounters problems with the automatic tracking 
of features, for example when objects go off screen or are occluded by 
moving foreground objects. You can assist CameraTracker by masking 
moving objects or by removing problem tracks using the delete track 
functions. See “Using Mattes” below and “Removing Feature Tracks” on 
page 57.

Using Mattes Mattes can help to reduce processing time and eliminate unusable tracks by 
covering areas of the layer, allowing CameraTracker to ignore features in 
certain parts of the scene. These mattes should generally be keyframed to 
allow them to follow features as they move around the screen.

There are a couple of things to be aware of before you get started with 
mattes that will hopefully stop you becoming frustrated.

1. The first thing to understand is that After Effects has a number of 
Channel and Colour Management filters that you can apply to the 
viewer.

The RGB and RGB Straight modes display mattes in different ways. While 
not disastrous, the differences between the two can be extremely con-
fusing.

Figure 3.1: A matte around the 
background building in RGB mode.

Figure 3.2: The same matte when 
viewed in RGB Straight.
CameraTrackerThe Foundry
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The reason for this is that RGB Straight uses the bounding box alpha 
instead of the matte alpha.

2. You MUST pre-compose your matte layer before you use it or 
CameraTracker uses the source layer without any effects that you apply.

To use a matte on a layer:

1. Create a suitable matte and add it as a layer in the project. See your 
After Effects User Guide for more information on creating and using 
mattes.

Note Matte layers must be pre-composed using Layer > Pre-Compose before 
they can be used by CameraTracker.

2. Select an appropriate Matte Source from the drop down menu, 
depending on the matte you are using.

The Matte Source parameter controls how the pixel values in the matte 
are used to do the masking.

• None—no matte is applied.

• Src Alpha—use the alpha of the source layer.

• Src Inverted Alpha—use the inverted alpha of the source layer.

• Matte Layer Luminance—use the luminance of the matte layer.

• Matte Layer Inverted Luminance—use the inverted luminance of the 
matte layer.

• Matte Layer Alpha—use the alpha of the matte layer.

• Matte Layer Inverted Alpha—use the inverted alpha of the matte layer.

3. Select the matte you created from the Matte Layer drop down menu.

Note You cannot select a Matte Layer without first specifying a Matte Source.

4. Select the Tracking > Preview Features checkbox to preview where 
features will track with the matte in place.

Setting the Analysis 
Range

The Analysis Range is set to Source Clip Range by default, which causes 
CameraTracker to analyse the entire layer from start to finish. In some 
cases, however, you may only require tracking data for specific frames.

Tip Analysis Range is particularly useful for testing your settings on a small 
frame sample before committing yourself to the potentially lengthy full 
feature tracking process.

To select a range for tracking:

1. Select Analysis Range > Specified Range from the drop down menu.
CameraTrackerThe Foundry
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2. Use the slider or enter an Analysis Start value to set which frame is the 
starting point.

3. Use the slider or enter an Analysis Stop value to set which frame is the 
ending point.

In the below example, Analysis Range is set to start at frame 5 and end 
at frame 15. The range is inclusive, so both frame 5 and frame 15 will be 
included in the analysis.

Note The Analysis Range refers to the CameraTracker effect layer, not your entire 
composition, so you can move layers within your composition without 
invalidating your track data.

Setting Tracking 
Parameters

Tracking parameters are used to tailor the properties of the data you’ll 
capture when you track features on a layer.

In most cases, the default settings supplied with CameraTracker should do a 
good job of tracking features, but you may want to fine tune your settings 
using the following guidelines.

Number of Features

As the name suggests, setting this value alters how many features are 
tracked within the current layer. For extremely simple scenes, a lower 
number of features may be required for the solve and vice-versa. As a 
general guideline, you should track no fewer than 100 features for most 
layers.

Note Bear in mind that although tracking more features can improve your results, 
the process will take longer.
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Figure 3.3 and Figure 3.4 show examples of low and high value feature 
tracks.

Figure 3.3: Tracking 50 features.

Figure 3.4: Tracking 300 features.

Detection Threshold

Detection Threshold sets the distribution of tracked features over the layer. 
A low value selects prominent points throughout the layer, whereas a high 
value selects more localised points in distinct regions.

Tip Using a low Detection Threshold (Figure 3.5) can produce a more accurate 
solve when large areas of the layer are relatively featureless.

Figure 3.5: A low Detection Threshold value 
produces a more even feature spread.
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Figure 3.6: A high Detection Threshold value 
produces more localised grouping.

Tip You can select the Preview Features checkbox to preview your features 
before tracking. 

Feature Separation

Separation determines the distribution of features in relation to each other. 
To force feature separation and spread features evenly over the image at 
even distances, enter a high feature separation value. 

Tip You may consider reducing Feature Separation when you increase the 
number of tracked features.

Figure 3.7: Low separation value of 1.

Figure 3.8: High separation value of 100.
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Previewing Features Select the Preview Features checkbox to preview the features that will be 
tracked. Preview comes in handy when you want to tweak the tracking 
parameters further before tracking.

Tracking Your 
Features

After testing feature tracks on a small number of frames and previewing, 
you’re ready to track features on your layer.

Note Tracking can take a long time, but you can speed up the process by 
disabling Render During Analysis. Bear in mind, however, that the dynamic 
tracks in the Viewer are also switched off if rendering is disabled.

In some cases, tracking may be interrupted if the After Effects Auto Save 
feature is turned on. To work around this, you can either:

Turn off Auto Save or increase the time between saves in After Effects > 
Preferences > Auto Save,

OR

Turn off Render During Analysis in the CameraTracker Effect Controls 
Window (ECW) before tracking features.

To start tracking, click the Track Features button on the CameraTracker 
panel shown in Figure 3.9, or navigate to CameraTracker Menu > Actions > 
Track Features in the Viewer.

Figure 3.9: Automatically track features within a layer.

CameraTracker begins reading the frames in the layer sequentially and 
CameraTrackerThe Foundry
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tracking the features present. Tracks that encounter persistent errors are 
automatically reseeded—CameraTracker keeps the number of tracks 
constant as specified in Tracking > Number of Features.

When the playhead reaches the end of the layer, it begins a verifying pass 
by reading the frames sequentially backwards. Any tracks that were 
reseeded due to error are tracked back past the point where they were 
created, if they remain viable. 

Note Unlike the initial track, the verifying pass can increase the number of tracks 
past the Number of Tracks you specified.

Once the verification pass is complete, you can view track and point 
information using the Display drop down menu, or point tooltips, as 
described below. 

Viewing Tracks and 
Track Information

Viewing your track information can help you to decide whether to retrack 
the features in the layer or just delete the problem tracks before solving the 
scene. See “Fine Tuning Your Feature Tracks” on page 58 for more 
information on retracking layers and deleting tracks.

You can view your track quality or point quality using the Display drop down 
menu. You can navigate through the layer using the Preview panel to 
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examine the information associated with each frame.

• Tracks—the default setting used to view tracks without colour coded 
quality information. After solving the camera, tracks are colour coded red 
(for a rejected track), orange (for an unsolved track), and green (for a 
solved track).

Note All tracks are coloured orange before solving.

• Track Quality—view the reliability of your tracks. The tracks are colour 
coded red (for an unreliable track), yellow (for a potentially unreliable 
track), and green (for a reliable track).

• Point Quality—view the quality of your 3D points. The tracks are colour 
coded according to their reprojection error figures, red being the worst 
and green the best.

Note Reprojection error values are not available until you solve the camera.
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• View Keyframe Points Only—select this checkbox to only view the 
keyframe points used during tracking. CameraTracker creates these 
keyframe points as it tracks the layer, using the keyframes as reference 
points to fill in the other tracks.

Viewing keyframe points can assist you when troubleshooting your track 
data because all the tracks within a layer reference these points—if you 
define the keyframe points more accurately, you’ll output a more refined 
feature track.

You can also display the track lifetime for individual tracks by hovering the 
mouse pointer over the track to display the tooltip. Track lifetime refers to 
how persistent the track is within a layer—the higher the track lifetime, the 
better the track. In the example, the highlighted track was good for 21 
frames within the tracked layer.

If you’re happy with the tracking results you can proceed to “Solving Your 
Camera Position” on page 23, otherwise you can adjust your tracking data 
by using the fine-tuning parameters described in “Troubleshooting Tracks 
and Solves” on page 49.
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Solving Your 
Camera Position

When you’re happy with the features that you’ve tracked, you can proceed 
to solving the camera. CameraTracker uses the tracking information to 
internally calculate the camera position and add positional information to 
the feature points in the Viewer. The first step is to adjust the parameters 
for your camera solve.

Note The camera solve doesn’t place the camera in your composition—the Create 
Scene step takes care of the camera’s location within the layer.

Setting Camera 
Parameters

Camera settings relate to the physical aspects of the camera used on set. 
Accurate physical camera data produces a better camera solution.

Figure 3.10: Physical camera properties in After Effects.

Focal Length Type

Select the focal length type for the camera from the drop down menu:

• Known—select this option if the focal length is available and enter a 
value in the Focal Length panel.

• Approximate Varying—select this option if an approximate focal length 
is available and enter keyframed focal length values in the Focal Length 
panel.

• Approximate Constant—select this option if an approximate focal 
length is available and there is no zoom, and enter a focal length value 
in the Focal Length panel.

Note If you select either of the Approximate options, CameraTracker tries to 
refine the focal length during the solve.

• Unknown Varying—select this option if the focal length is unknown and 
changing. 

• Unknown Constant—this is the default option. Use this option if the 
focal length is unknown and there is no zoom.

Focal Length

The Focal Length, or distance between the film back and the lens, assists 
CameraTracker to emulate the on set camera. If you don’t know the Focal 
Length, select Unknown Constant or Unknown Varying from the Focal 
Length Type drop down menu.
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Note Digital cameras often record the Focal Length for you as metadata 
contained within the output.

Film Back Size

Film Back Size is the physical size of the film used or the size of the imaging 
sensor used in digital cameras. If you entered a Focal Length, the film 
dimensions are critical for achieving accurate data.

Note You can usually find these values in the Specification pages of the camera 
used on set, or online at sites such as http://www.dpreview.com/

Select the required units from the Units drop down menu and enter the 
horizontal and vertical film or sensor size in the Film Back Size X and Y 
fields.

Camera Motion

You can assist CameraTracker with the solve by selecting the motion type of 
the on set camera from the Camera Motion drop down menu.

• Rotation Only—select this option if the camera is static and rotating, 
for example, if you’re using a tripod mounted camera for nodal pans.

The following images show the difference in solve quality you can 
achieve by selecting Free Camera and Rotation Only on the same piece 
of footage.

Notice the large amount of rejected tracks if Free Camera is selected?

Note If you select Rotation Only, make sure that Tracking > Track Validation is 
also set to Rotating Camera. See “Track Validation” on page 60 for more 
information.

• Free Camera—select this option if the camera is both translating and 
rotating.

Figure 3.11: Free Camera. Figure 3.12: Rotation Only.
CameraTrackerThe Foundry
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Creating a Solve Once you’re happy with the physical camera and lens parameters, you’re 
ready to create a solve using your tracks and camera properties.

To create the solve, click Solve Camera in the CameraTracker ECW, or 
navigate to CameraTracker Menu > Actions > Solve Camera in the Viewer.

The solving process does not take as long as tracking features within a 
layer, but it is dependent on the number of frames and complexity of the 
tracks. Once the solve completes successfully, a solve report displays.

In Figure 3.13, CameraTracker reports that reference frame 7 was used, 5 
keyframes were used, and the total root mean square (RMS) reprojection 
error rate was 0.849 pixels. 

Note The Reference Frame is the point at which the camera was located at the 
origin 0, 0 in 2D. This value is significant later on—see “Using Null Object 
Transforms in Compositions” on page 43.

Tip If your solve reports an RMS projection rate higher than 1.0 pixel, you may 
want to consider fine-tuning your solve or tracking data. See 
“Troubleshooting Tracks and Solves” on page 49.
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Figure 3.13: Solve camera report.

Note If your tracking phase was relatively lengthy, CameraTracker may need some 
extra time to create the Refine menu statistics.

If this is the case, a second progress bar displays the amount of time 
remaining:

CameraTracker solves take less time than tracking features and should 
produce data similar to that shown in Figure 3.14.

Figure 3.14: Typical After Effects solve data.

Tip Notice the red solve data in the lower half of the solve in Figure 3.14. The 
data could be unreliable due to the movement of the figure during tracking. 
This is a good example of when CameraTracker could benefit from masking 
features as described in “Using Mattes” on page 14.

You can also display track and solve data for individual tracks by hovering 
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the mouse pointer over the track to display the tooltip, as shown in 
Figure 3.15 on page 27.

Figure 3.15: Reprojection Error report.

If you’re happy with the solve results you can proceed to “Creating a Scene” 
on page 28, otherwise you can adjust your solve by using the fine-tuning 
parameters described in “Troubleshooting Tracks and Solves” on page 49.
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Creating a Scene After solving the camera, you're ready to create your scene. Create Scene 
produces an After Effects camera, that you can use in conjunction with the 
integrated 3D object creation functions, to place various solids relative to 
the camera in 3D space.

In a similar way to the previous steps, you can use CameraTracker to create 
the scene automatically by clicking Create Scene, or navigate to 
CameraTracker Menu > Actions > Create Scene in the Viewer.

Creating a scene takes very little time—all the hard work was completed in 
previous steps. There is very little to see in the After Effects Viewer when 
the camera is ready, but you may notice that new camera and null layers 
have been added to the Timeline.

So where is your camera and where is it in the layer?

In order to ’see’ the camera within the layer, you’ll have to view things 
slightly differently.
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You could create a new camera to view your composition, but the simplest 
way to view your scene is using Custom Views. 

1. In the Viewer, navigate to Select viewer layout > 2 Views - Horizontal 
to add a second panel to the Viewer.

The default settings display the Active Camera on the right and Top view 
on the left.

Note The Active Camera is always located in the highest layer of your 
composition. If you have more than one camera in your composition, select 
CameraTracker-Camera(1) to view your solved camera.

2. Click the left view to highlight it, then navigate to 3D View Popup > 
Custom View 1 to change the camera view from Top to a customisable 
view.

Custom View 1 represents the solved camera CameraTracker camera (1), 
but it is not fixed in place. You can move the camera around to view 
your scene from any angle you choose.

The red square at the same XY coordinates as the camera in Figure 3.16 
represents the Null Object associated with the camera, and the yellow 
highlight shows a Point of Interest (POI) marker.

Note If you click Solve Camera and Create Scene again, CameraTracker will 
attempt to update the existing scene. If, however, you have renamed the 
existing camera, CameraTracker creates a new camera and pairs it with the 
existing null.
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Figure 3.16: The Null Object associated with the solved 
camera and a Point of Interest marker.

Note CameraTracker creates a one-node camera, so the POI is set to the default 
location and provides no real benefit.

See your After Effects User Guide for more information on POI.

3. Click the Unified Camera Tool icon or press C on your keyboard to 
activate the camera tool.

4. Select the CameraTracker-Camera(1) layer in the composition and try 
moving the camera around the scene to view different angles.

Switch between 2D and 3D by clicking Toggle 2D/3D or pressing Tab on 
your keyboard.

Note The layer itself does not move and this can be confusing at first. No matter 
where you move the camera view, as with any 2D layer in After Effects, the 
layer will always remain front and centre.

If for any reason your camera doesn’t work, you may have to make some 
parameter changes and re-solve the camera or in some cases go back to the 
tracking stage to iron out tracking errors. See “Troubleshooting Tracks and 
Solves” on page 49.

That takes care of tracking, solving, and creating a scene. From here you 
can set the ground plane, axes, or origin, add your geometry (that is shapes 
or text), or use other After Effects features to add layers to your 
composition.

Alternatively, there are some third party scripts (snippets of code which 
extend After Effects functionality, but are not supplied by After Effects or 
CameraTracker) that allow you to export your camera tracks to other 
software suites like Maya or Cinema 4D, but these are not covered in the 
scope of this User Guide.
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Using the Point 
Cloud

The Point Cloud is a very powerful tool that enables you to view the 2D 
scene by examining the tracked points in 3D. All the features that were 
tracked and solved during the CameraTracker workflow can be viewed, each 
colour coded with the original layer colour.

Tip You can reduce the Point Cloud size to view more accurate keypoints from 
the solve by checking View Keyframe Points Only on the CameraTracker 
panel.

In this demonstration we’ll use a nice colourful scene as shown below.

Select the image layer in your composition and the CameraTracker effect in 
the Effect Controls window to access the CameraTracker Menu displayed in 
the bottom left of the Viewer.

Note The CameraTracker menu is only available when the CameraTracker effect is 
highlighted in the Effect Controls window.

Note You may notice that CameraTracker Menu selections can be slow, especially 
on Windows platforms. To avoid this, try holding down the left mouse 
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button in the menu, locating the option you require and releasing to 
complete the selection.

To start using the Point Cloud, follow these simple steps:

1. Navigate to CameraTracker Menu > Actions > Toggle 2D/3D,

OR

Press Tab on your keyboard to toggle between 2D and 3D.

The Point Cloud displays in the Viewer.

From the camera’s point of view, the cloud is not very useful. Point 
Clouds really come in to play when viewed using After Effects custom 
cameras, so you can really get ’into’ the 3D scene.

2. Navigate to 3D View Popup > Custom View 1 and select the 
CameraTracker-Camera(1) layer in your composition.
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The Point Cloud and custom camera perspective are now displayed on 
screen.

3. Click the Unified Camera Tool on the After Effects interface,

OR

Press C on your keyboard to activate the camera tool.

4. Click and drag the camera tool around to view the scene.

You may notice that the tracked points lose resolution as you drag 
around the scene. This is due to the Fast Previews default setting within 
After Effects.

No. Item Description

1 View Shows the camera’s current view.

2 Track The track that the camera follows through the scene. Each square 
represents one frame in the layer.

3 POI The scene’s Point of Interest.

4 Camera and Null The camera and associated null.

5 Control Unified Camera Tool used to control camera movement.

1

5

3

2

4
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If you want to retain resolution during movement, navigate to 
Fast Previews > Off.

5. You can select points in 2D by dragging a marquee or holding down Shift 
and clicking individual points then view them in 3D.

Figure 3.17 shows the same points selected in 2D and 3D. By moving 
the custom camera around the scene, it’s quite easy to see that the 
points selected are on the same plane.

     
Figure 3.17: 2D and 3D point comparison.

Once you master using the Point Cloud, you’ll find the other topics in this 
chapter, such as “Setting the Ground Plane” on page 35 and “Adding Solids 
to Your Composition” on page 39, relatively simple to achieve.
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Setting the Ground 
Plane

A tracked camera has no notion of where the ground plane is in the layer, 
and so it, and any associated 3D objects, can be at an unexpected offset 
and angle relative to where we expect the ground to be in 3D space. 
Essentially the camera has a different frame of reference to us, which can 
make working in the 3D environment confusing at first.

Setting the ground plane, origin, or set of axes is designed to provide 
CameraTracker with a sensible frame of reference. While doing so is not 
strictly necessary, it can simplify working in the 3D environment.

Before placing the ground plane, scan through your layer to find a frame 
with good track and solve data in an area that you know to be at ground 
level. Hover over likely points to display the track and solve data, and use 
the Point Cloud to guide you when selecting suitable points.

Tip Bear in mind that setting a ground plane over a number of points in the 
scene creates a ’best fit’ plane and, crucially, translates the camera to make 
use of the new plane. 

If you don’t want the camera to move or placing a ground plane is proving 
tricky, you might consider using an origin and setting individual axes as 
described later on in this chapter.

1. Drag a marquee over the required points or hold down the Shift key and 
click individual points.

Figure 3.18 shows a scene with five good ground level points selected.

Figure 3.18: Ground plane points within a layer.

2. Once you’ve selected your points, navigate to CameraTracker Menu > 
Ground Plane > Set to Selected.

Note The CameraTracker menu is only available when the CameraTracker effect is 
highlighted in the Effect Controls window.

You may notice that CameraTracker Menu selections can be slow, especially 
on Windows platforms. To avoid this, try holding down the left mouse 
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button in the menu, locating the option you require and releasing to 
complete the selection.

CameraTracker uses the points you selected as the ’ground’ when adding 
layers to your composition.

You can also add points to the ground plane calculation from other frames 
in the layer to help refine the results:

1. Set a ground plane as described previously.

2. Play through the layer to locate points to add to the ground plane.

3. Select the features and navigate to CameraTracker Menu > Ground 
Plane > Set to Selected.

The points are added to the ground plane.

Setting the Origin Defining the origin within a layer can assist you when placing objects in 
your composition—if you know where 0, 0, 0 is located, you can easily place 
objects precisely where you want them on any axis.

Tip Unlike setting a ground plane over a set of points, defining an origin does 
not translate the camera position.

1. Select a single track as an origin point from your feature and solve data 
and navigate to CameraTracker Menu > Ground Plane > Set Origin.
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Figure 3.19 shows a track selected for CameraTracker to use as the X, 
Y, Z origin.

Figure 3.19: Setting the origin.

2. Switch to the Point Cloud and use custom view on the scene. Notice that 
the CameraTracker Null has moved to the point you selected.

     

Setting Independent 
Axes

In some compositions, you may not have a clearly defined ground plane to 
reference. Using CameraTracker, you can set the X, Y, and Z axes separately 
instead of grouping them on the ground plane.

Tip Unlike setting a ground plane over a set of points, defining an origin and 
independent axes does not translate the camera position.

1. Set an Origin within the scene as described in “Setting the Origin” above.

2. Select the Origin and a point that you know to be on the required axis, 
or use the Point Cloud to assist you.

3. Navigate to CameraTracker Menu > Ground Plane > Set X, Y, or Z 
depending on the points selected.
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Figure 3.20 shows the Origin and one vertically aligned track selected as 
reference points for CameraTracker to use for the Y axis.

Figure 3.20: The Origin and Y axis reference points.

Resetting Planes, 
Axes, and Origins

Adding planes, axes, or an origin can greatly improve your 2D/3D 
integration but, in some cases, you might end up with too many points 
selected within your composition. You can reset all point and plane data by 
navigating to CameraTracker Menu > Ground Plane > Reset.
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Adding Solids to 
Your Composition

At this point, you can use the camera you’ve created, as you would any 
other After Effects camera, for all manner of applications. However, the 
CameraTracker Menu can still help you to add solids and nulls to your 
composition.

You can add solids manually by right-clicking in the left Timeline panel and 
selecting New > Solid... but positioning them inside the camera’s field of 
vision at the desired position can be time consuming. CameraTracker 
provides an automatic solid creation function to help you achieve the 
results you need.

1. Select points on the plane that will hold the solid by hovering over likely 
features to locate suitable points.

Tip Using the Point Cloud can really help you locate the best points available on 
any plane. See “Using the Point Cloud” on page 31.

2. Drag a marquee over the required points or hold down the Shift key and 
click individual points. 

Note The following example uses three points, but you may need to select more 
depending on the track and solve data.

3. Navigate to CameraTracker Menu > Create > Solid (or press S) to add a 
default solid to the composition.

4. CameraTracker default solids are red, have an opacity of 50%, and 
depending on the points you selected, may be quite large as shown in 
the example.
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5. Select the solid in the timeline and use the solid handles in the viewer to 
adjust the size of the solid so that it fits on the plane of the building.

6. You may notice that the solid is slightly skewed on the Z axis in the 
example. Use the solid’s Transform > Z Rotation to align the solid with 
the edge of the building.

7. Next, use the solid handles in conjunction with the Z Rotation and axis 
handles to adjust the solid so that it fills the side of the building.

8. Using the dual views described in “Creating a Scene” on page 28 you can 
view the solid from any angle using the Custom View 1 camera. See 
Figure 3.21 on page 41.
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Figure 3.21: The same solid viewed from 2 angles.

As mentioned previously, although the camera moves around the scene, 
the 2D layer is fixed in place and doesn’t relate to the camera move-
ment. In Figure 3.21, the custom camera is ’looking’ down on the scene 
and as a consequence, the solid appears lower in the scene and further 
away from the camera.

9. Switching to 3D and viewing the solid and Point Cloud together is more 
informative.

The 3D view can help you determine where your solid really is—hovering 
in space, or 'stuck' to the wall as desired. You can also select the 
tracked camera so as to see its field of view and positions in subsequent 
frames, and play through the sequence and see things change in 3D.

10.The final step is to check that there is no ’slipping’ between the scene 
and the solid. The best way to do this is to play the composition using 
the Play button in the Preview panel.

The only real way to verify your results is to view the solid with the 
naked eye and make a judgement based on your experience.
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Unparenting Solids: 
Absolute vs. Relative 
Transforms

Solids and nulls created using the CameraTracker Menu > Create menu are 
parented to the CameraTracker Null object by default and any translation, 
rotation, and scale changes applied are relative to this null. These objects 
can be described as residing in a relative coordinate space. This is so that 
the overall scene scale, orientation, and origin can be set both before and 
after creating objects, using the CameraTracker Null.

If you wanted to copy position transforms from a created object to another 
object, for example a text layer, solid, or null, you must ensure the source 
object’s position, rotation, and scale parameters are in absolute space. To 
do this, unparent the solid before copying its parameters:

1. Using the solid and null twirlies, reveal both Position parameters. If you 
compare the xyz values, you’ll notice a considerable difference.

The null’s positional coordinates are absolute, rather than relative like 
the solid.

2. Using the solid’s Parent dropdown menu, select None.

Notice the solid’s position values have changed?

Moving the solid around the scene when it is unparented produces an 
absolute move, rather than a move relative to the null object.

Once the data copy is complete you can reparent the solid and, if neces-
sary, the new object to the CameraTracker Null to return them to rela-
tive coordinate space. You can then control the overall scene position, 
rotation and scale changes.
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Using Null Object 
Transforms in 
Compositions

CameraTracker 3D objects are created relative to the tracked camera, and 
as a result, any offset, scale, or rotation transform applied to both the 
camera and objects will have no effect when viewing the composition 
through the tracked camera—everything will still be in the right place.

When you use the Create Scene button, CameraTracker creates a tracked 
camera and automatically parents it to a null object. Once you've completed 
the CameraTracker workflow and are happy with your scene, you can use 
the automatically generated null associated with the camera to control the 
offset, scale, and rotation of elements added to your composition.

Applying an additional transform using the null can be useful in many 
contexts. For example:

• You can adjust the scale of the 3D scene to approximately match that of 
the real world.

• If automatic ground plane setting is problematic, the null can be used 
tweak the position of the tracked camera relative to the ground plane.

• Sometimes, you may have already created a 3D environment. The null 
can then be used to reconcile that environment and the camera tracker 
environment.

• If a CameraTracker scene is added to a pre-existing 3D environment, 
nulls can be used to reconcile the offset, scale, and rotation of elements 
between the two scenes.

Creating Multiple Nulls Creating compositions can be a very time consuming process, and using 
shortcuts during your workflow can be the difference between success and 
failure. If you’re going to be placing and translating a large number of 
objects in your scene, you may consider using Multiple Null Objects. The 
only limit on the number of nulls you can create is the number of tracked 
features in your scene.

Bear in mind that there is a significant difference between creating multiple 
and single nulls across points:

• Creating multiple nulls across multiple points attaches a null to each 
point ’facing’ the camera.

• Creating a single null across multiple points averages the coordinates 
from the points you selected and places the null at ’best fit’ coordinates.
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To create multiple nulls on selected tracked features:

1. Select the tracks in your scene that will anchor the nulls and navigate to 
CameraTracker Menu > Create > Multiple Null Objects (or press F).

2. CameraTracker places nulls at each selected track.

Note If you place a single null across the same points, the result would be quite 
different.
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Accounting for 
Lens Distortion

You can use CameraTracker’s lens distortion features to account for lens 
distortion in your footage. Often, what you want to do is add CG images to 
your footage and distort those images so that they match the lens 
distortion in the footage.

The best practice for doing this is to apply CameraTracker to your footage, 
add the CG images, and apply lens distortion to the CG images. Do the 
following:

1. Use Track Features to track the features in your footage. See “Tracking 
Features” on page 14.

2. Set Lens Distortion parameters to automatically estimate or manually 
adjust the lens distortion of the camera used to shoot your footage. See 
“Setting Lens Distortion Parameters” on page 47.

This allows you to calculate the camera for the undistorted footage.

3. Use Solve Camera to create a solve. See “Creating a Solve” on page 25.

4. Use Create Scene to produce an After Effects camera that you can use 
in conjunction with the integrated 3D object creation functions to place 
a solid relative to the camera in 3D space. See “Creating a Scene” on 
page 28.

5. Create the solids, text, or CG elements you want to add to your original 
footage.

6. Select the objects you created in the previous step and the 
CameraTracker-NullObject(1) and CameraTracker-Camera(1) layers in 
the composition.

7. Then, navigate to Layer > Pre-compose. In the Pre-compose dialog, 
select Move all attributes into the new composition and click OK.

In the composition, you should now only see the Pre-comp 1 layer and 
the original footage you applied CameraTracker to. The Pre-Comp 1 
layer allows you to process both the original footage and the created 
objects together.

8. Next, you need to copy the CameraTracker effect. You’re going to use 
this copy to apply lens distortion to the objects in your Pre-Comp. To 
copy the effect, first select the original footage in the composition and 
the CameraTracker effect in the ECW. 
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Navigate to Edit > Copy. Then, select the Pre-Comp (1) layer and navi-
gate to Edit > Paste.

9. In the ECW, expand the Lens Distortion group and check Redistort.

That’s it! You have now added objects to your tracked footage and dis-
torted them to match the lens distortion in the original footage.

Note If your footage has a very large amount of lens distortion, CameraTracker 
may not be able to track or solve the footage. If this is the case, set the 
Lens Distortion drop down to Known Lens in the ECW and check Undistort 
to flatten the footage. Tweak the Lens Distortion parameters by eye to get 
the correction close. Then, apply another CameraTracker effect and use that 
to track and solve the flattened footage. You should create your 3D scene, 
camera and elements using the second, solving CameraTracker. When you're 
done, precompose your 3D elements, and then copy and paste the first 
CameraTracker effect onto the precomposed layer, and check Redistort to 
distort it. If your eyeballed correction is close but not quite there, you can 
also set the second CameraTracker to Unknown Lens to get it to estimate 
the final part of the correction.

Note If CameraTracker is able to track and solve your footage but the lens 
distortion estimate that it comes up with is poor, set Lens Distortion to 
Refine Known Lens in the ECW. Then, adjust the other Lens Distortion 
parameters until your footage looks about right when Undistort is checked, 
and hit Solve again.
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Setting Lens 
Distortion Parameters

Lens Distortion

Lens Distortion is used to select the type of lens used on set. Select the lens 
type from the drop down menu.

• No Lens Distortion—disables all lens distortion controls and treats the 
footage as having no distortion.

• Known Lens—allows you to specify the lens distortion manually for the 
camera solve.

• Refine Known Lens—gives you a chance to give an approximate 
distortion to use but attempts to refine it in the camera solve.

• Unknown Lens—calculates the lens distortion automatically from the 
sequence and then refines the distortion in the camera solve.

If you chose either Known Lens or Refine Known Lens, enter values for the 
Lens Type, Radial Distortion, Distortion Centre controls and, if necessary, 
the Anamorphic Squeeze and Asymmetric Distortion controls.

Lens Type

You can select the type of lens used on set from the drop down menu 
allowing CameraTracker to compensate for the selected type. The equations 
used to account for lens distortion are quite complex, but using these 
guidelines you should be able to output undistorted layers from distorted 
layers.

• Spherical—compensates for different spherical lenses. This is the 
simpler of the two lens corrections and uses the following equation:

Xu and Xd are equal to the same point in an undistorted plate and a dis-
torted plate respectively.

d1 is equal to Radial Distortion 1

d2 is equal to Radial Distortion 2

r2 is equal to the distance of the point from the distortion centre

r4 is equal to the square of r2

• Anamorphic—compensates for anamorphic lenses. Anamorphic 
correction uses three additional parameters (Ax, Ay, and Asq) and requires 
two equations because, unlike with spherical lenses, the amount of 
distortion parallel to the x-axis is not the same as that parallel to the y-
axis.

Xu
Xd

1 d1r
2 d2r

4+ +
------------------------------------=

xu
xd

1
d1
Asq
------- 
  r2

d2
Asq
------- 
  r4 Axyd

2+ + +

------------------------------------------------------------------------=
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(xu, yu) and (xd, yd) are equal to the same point in an undistorted plate and 
a distorted plate respectively.

d1 is equal to Radial Distortion 1

d2 is equal to Radial Distortion 2

r2 is equal to the distance of the point from the distortion centre

r4 is equal to the square of r2

Ax is equal to Asymmetric Distortion X

Ay is equal to Asymmetric Distortion Y

Asq is equal to Anamorphic Squeeze

Lens Parameters

You can manually enter physical lens characteristics depending on which 
Lens Type you selected.

• Radial Distortion 1 (d1)—defines the first radial distortion term. This is 
proportional to r2, where r is the distance from the distortion centre.

• Radial Distortion 2 (d2)—defines the second radial distortion term. This 
is proportional to r4, where r is the distance from the distortion centre.

• Distortion Centre (r2, r4)—defines the values for the centre of the radial 
distortion on the X and Y axes.

• Anamorphic Squeeze (Asq)—defines the anamorphic squeeze value. If you 
select an anamorphic lens, the Distortion Centre on the X axis is scaled 
by this amount.

• Asymmetric Distortion (Ax, Ay)—defines distortion for anamorphic 
lenses. Enter values to define asymmetric distortion to correct for slight 
misalignments between multiple elements in the lens.

• Undistort—check this to view your footage undistorted.

Redistort—check this to view your footage distorted.

yu
yd

1 d1r
2 d2r

4 Ayxd
2+ + +

--------------------------------------------------------=
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4  TROUBLESHOOTING TRACKS AND SOLVES

Unless the composition you’re working on is extremely simple or ideal for 
tracking, troubleshooting your tracks and solves is a necessary part of the 
CameraTracker workflow. Effective troubleshooting can improve your end 
result immeasurably and can be the difference between a good 3D result 
and a composition with slipping elements.

Knowing when to refine tracking or solving is also an important concept. If 
your scene doesn’t create successfully, the solve may be faulty and some 
fine-tuning may be necessary. Bear in mind, though, bad solves are often 
the result of bad feature tracks—if it seems that no amount of solve fine-
tuning is improving your results, try going back to square one and refining 
and retracking the layer.

Overview So, you’ve gone through the camera tracking workflow, but you want to 
improve the quality of the result you’re getting. The first thing to do is to 
figure out where the problem lies: the tracking, the solving, or the scene 
creation. 

Bear in mind that a problem in one stage of the process can be caused by 
any of the earlier stages. If you create a solid and get unexpected results, 
this may be caused by a bad solve or bad feature tracks. If you have a bad 
solve, this may be caused by bad feature tracks.

The table on the next page attempts to illustrate the troubleshooting 
process. The recommended workflow is to go to the step where you have a 
problem and work your way up from there.
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Workflow Step Result Troubleshooting Methods Potential Solutions

1. Track Features 2D tracks • Play through the sequence in the 2D View 
and look at the tracks in the Viewer. See if 
any tracks slip, jump, or seem too short.

• Have a look at the Track statistics under the 
Refine group. See “Using the Refine Group” 
on page 51.

• Use the Track Finder to locate poor tracks. 
See “Using the Track Finder” on page 56.

• If only a few of the tracks seem poor, you can 
delete those tracks, give precedence to 
tracks that you know are good, set thresh-
olds for the tracks, and click Solve Camera 
again. See “Removing Feature Tracks” on 
page 57, “Giving Precedence to Good Feature 
Tracks” on page 58, and “Track and Solve 
Thresholds” on page 55.

• If you have a lot of poor tracks, adjust the 
Tracking parameters or add a matte, and 
start again by clicking Track Features. See 
“Setting Tracking Parameters” on page 16, 
“Using Mattes” on page 14, and “Retracking 
Features” on page 61.

2. Solve Camera 
and Create Scene

Camera, 
null, and 
point cloud

• Have a look at the Solve statistics under the 
Refine group. “Using the Refine Group” on 
page 51.

• Use the Track Finder to evaluate the quality 
of the solve. See “Using the Track Finder” on 
page 56.

• Play through the sequence while looking at 
the Point Cloud in the 3D View. See if any 
points slip. See “Playing through the 
Sequence” on page 64.

• Look at the 3D scene from a Custom View, 
move around the scene, and see if any fea-
ture points are offset from the rest.

• Create a grid on the ground plane. See “Cre-
ating a Grid on the Ground Plane” on 
page 62.

• Remove bad tracks, give precedence to tracks 
that you know are good, adjust the Solve 
parameters (Keyframe Separation in particu-
lar), and/or set thresholds for the solve, and 
click Solve Camera again. See “Removing Fea-
ture Tracks” on page 57, “Giving Precedence 
to Good Feature Tracks” on page 58, “Setting 
Camera Parameters” on page 23, “Key-
frames” on page 63, and “Track and Solve 
Thresholds” on page 55.

• Of course, the problem could also be in the 
tracking stage of the process. Proceed to 
troubleshooting tracks.

3. Create Objects Solids, nulls, 
text, etc.

• Select some points, create a solid, and see if 
the solid looks as you’d expect. “Creating a 
Solid” on page 65.

• If the solid looks wrong but isn’t moving 
around over the course of time, try trouble-
shooting the solve. 

• If the solid is moving around over the course 
of time, you’ve probably got a bad track 
rather than just a bad solve. Try trouble-
shooting the track.
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Examining Your 
Feature Tracks

In addition to looking for bad tracks in the 2D View, the following tools can 
assist you when you’re troubleshooting tracks:

• The Refine group, in conjunction with the Graph Editor, provides detailed 
statistics on track and solve data across the entire composition, helping 
you to locate problematic frames within the scene. 

The Refine group also lets you set minimum and maximum thresholds for 
the tracks and the solve. Any tracks that fall outside these thresholds 
are automatically rejected.

• The Track Finder examines individual frames that you have identified 
using the Refine group and Graph Editor. After locating the problem 
features, you can remove them and begin reprocessing your data.

Using the Refine 
Group

The Refine group in the ECW contains animated parameters calculated after 
tracking and after solving. These parameters allow you to view various 
quality measures from the tracking and the solving phase, enabling you to 
troubleshoot and refine the resultant camera. You can also view the 
animated parameters using the Graph Editor in After Effects. 

The parameters are divided in to two groups: Track statistics and Solve 
statistics. As the names suggest, each group is used during a particular 
phase.

Bear in mind that the Track and Solve statistics are only meant for viewing 
information on track and solve data in the composition. The values here are 
not meant to be edited - indeed, doing so has no effect on the final result 
and will just confuse matters.

If you want to affect the values, you can use the Threshold controls under 
Refine to set minimum and maximum thresholds for the tracks. Any tracks 
that fall outside these thresholds are rejected and displayed in red. You can 
then click the Delete Rejected button at the bottom of the Refine group to 
delete all such tracks in one go.

If you want to delete all unsolved feature tracks (that is, tracks that don’t 
have a valid 3D point after solving), you can also click the Delete Unsolved 
button in the bottom of the Refine group.

If necessary, you can refresh the statistics by navigating to CameraTracker 
Menu > Tracks > Refresh Stats (or by pressing R). This updates everything 
under Refine (including the thresholds, which by default are set to the 
minimum and maximum values that exist in your track and solve data).
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Track Statistics

Track statistics can only be used after you have tracked your initial 
composition. To access statistics in the Graph Editor: 

1. Click the Graph Editor toggle in After Effects.

2. Select your composition and press the After Effects hotkey U to display 
the currently animated parameters associated with that layer. Often this 
just displays the animated statistics, as there may not be any other 
animated parameters.

• Track-Points displays the total count of feature points over the track 
phase. Large variations from the number set in the tracking parameters 
allows you to see possible tracking issues.

• Track-Lifetime-Min displays the shortest lifetime, in frames, of any track 
point on the current frame. Very short tracks are likely to be poor quality 
and are good candidates for removal.

• Track-Lifetime-Avg displays the lifetime of all track points, in frames, 
present on the current frame, averaged together. Look out for significant 
drops in this value which can indicate a significant number of track 
points being reseeded. You could try matting on the frame to remove 
potentially troublesome regions, and then retracking.
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• Track-Distance-Avg displays the total distance the track points have 
moved from the previous frame to the current frame, averaged together. 
Large variations in the average distance could indicate tracking 
problems.

• Track-Distance-Max displays the maximum distance a track point has 
moved from the previous frame to the current frame. Used in conjunction 
with Track Distance-Avg, this graph can be used to look out for track 
points being influenced by nearby features. Look out for a spike in the 
maximum distance measurement, while the average stays fairly constant.

Solve Statistics

Solve statistics can only be used after you have solved your camera, but 
they can be accessed in the same way as Track statistics.

• Solve-Keyframe displays frames used as a keyframe by the solve 
process: 1 for keyframes, 0 for those not used as a keyframe.
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Note The Keyframe statistics only show you whether or not a frame is a 
Keyframe. The number of Keyframes can increase or decrease depending on 
the Keyframe Separation setting.

• Solve-Overall Error displays the total solve error, as reported in the post 
solve dialog box. The value is recorded here for reference.

• Solve-Margin of Error indicates frames where outlying points may have 
caused possible solve errors. Higher values represent a greater margin of 
error.

• Solve-Per Frame Error-Avg represents the general quality measure of the 
solve over time. It’s calculated as the average of all the solve errors for 
the points present on the current frame (the error measure on the tracks 
is a snapshot, rather than constant average over the lifetime of the track 
point).

• Solve-Per Frame Error-Max displays the maximum value of all the solve 
errors for the points present on the current frame (again, a snapshot not 
an average). Look out for a spike in the maximum distance measurement, 
while the average per frame stays fairly constant. This could indicate 
possible outliers which need cleaning up.

• Solve-Per Track Error-Max displays the maximum value of all the solve 
errors for the points present on the current frame, averaged over the 
course of the track lifetimes. High values could indicate feature points 
which are generally bad over their lifetime (as opposed to those which 
spike in the Per Frame Error-Max graph).
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Once you’ve located the possible problem areas, you can use the Track 
Finder to locate the offending tracks in individual frames, or set minimum 
and maximum thresholds for the tracks and delete any tracks that fall 
outside these thresholds.

Note If you track and solve your footage, then re-track the footage, and refresh 
the statistics by selecting CameraTracker Menu > Tracks > Refresh 
Statistics, the solve statistics get reset to 0. This is to avoid displaying 
outdated solve statistics.

Track and Solve Thresholds

In addition to viewing the statistics as described above, you can use the 
following controls to set minimum and maximum thresholds for the tracks 
and the solve. Any tracks that fall outside these thresholds are 
automatically rejected and displayed in red. You can easily delete them by 
clicking Delete Rejected.

• Threshold-Track-Lifetime-Min sets the shortest acceptable lifetime of 
track points. This is measured in frames. For example, if you set the 
threshold to 3, any tracks that only exist for one or two frames are 
automatically rejected. This allows you to easily reject any very short 
tracks, which are likely to be of poor quality.

• Threshold-Track-Distance-Max sets the maximum distance a track point 
can move from one frame to the next without being rejected. This is 
measured in pixels. For example, if you set this to 80, CameraTracker 
rejects any tracks where the track point moves 81 pixels or more 
between two adjacent frames.

• Threshold-Solve-Frame Error-Max sets the maximum acceptable value of 
all the solve errors for the points present on any one frame (the error 
measure on the tracks is a snapshot, rather than constant average over 
the lifetime of the track point). This allows you to reject tracks that may 
not be generally bad over their lifetime but do go wrong at some point in 
time.

• Threshold-Solve-Track Error-Max sets the maximum acceptable value of 
all the solve errors for the points present on any one frame, averaged 
over the course of the track lifetimes. This allows you to reject tracks 
that are generally bad over their lifetime.
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Note By default, the thresholds are set to the minimum and maximum values in 
your track and solve data. If you use CameraTracker Menu > Tracks > 
Refresh Stats (or press R) to refresh the statistics, the thresholds are also 
refreshed.

Using the Track Finder CameraTracker is supplied with track finding tools to help you locate good 
and bad feature tracks after tracking and after solving. Features which don't 
have a valid 3D point after solving (the tracks highlighted in red) are 
automatically deselected by the track finder.

Note All Track Finders can be accessed from CameraTracker Menu > Track, or by 
using their hotkeys.

Pre-Solve Finder:

• Cycle Track Distance Selection—navigate to CameraTracker Menu > 
Track, or press E on your keyboard to select the feature point on the 
current frame with the greatest difference in track distance between this 
frame and the last. Subsequent presses cycle down through the track 
distances on points in the current frame. 

This allows you to easily select the points which have mistracked (judged 
using the statistics report and Graph Editor) and delete them. This is only 
available once you've tracked.

Note On the first frame, all the tracks have a distance of 0. This is because there 
is no previous frame to compare to.

Post Solve Finder:

• Cycle Per Track Error Selection—navigate to CameraTracker Menu > 
Track, or press Q on your keyboard to select the feature point on the 
current frame with the greatest per track error. Subsequent presses 
cycle down through the per track errors on points on the current frame. 

This allows you to easily select the points with the greatest solve error 
over their track lifetime (on frames judged using the statistics report and 
Graph Editor) and delete them.

• Cycle Per Frame Error Selection—navigate to CameraTracker Menu > 
Track, or press W on your keyboard to select the feature point on the 
current frame with the greatest per frame error. 

Subsequent presses cycle down through the per frame errors on points 
on the current frame. This allows you to easily select the points with the 
greatest snapshot solve error (on frames judged using the statistics 
report and Graph Editor) and delete them.
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Tip You can deselect all the tracks you have currently selected by pressing esc 
on your keyboard.

Removing Feature 
Tracks

CameraTracker allows you remove tracks completely if they’re causing 
problems for the solve. You can: 

• Select and remove tracks manually. See “Removing Tracks Manually” on 
page 57.

• Delete all unsolved tracks in one go. See “Removing All Unsolved Tracks” 
on page 58.

• Set thresholds for acceptable tracks and delete any tracks that fall 
outside these thresholds. See “Removing Tracks that Fall outside Set 
Thresholds” on page 58.

• Create a matte to prevent entire areas from being tracked. See “Using 
Mattes” on page 14.

Removing Tracks Manually

To remove feature tracks manually: 

1. Drag a marquee over the required points in the Viewer or hold down the 
Shift key and click individual points. If you find it difficult to select indi-
vidual tracks by clicking on the track point x, you can enable Allow Line 
Selection in the ECW.

2. Press Delete on your keyboard to remove your selections,

OR

Navigate to CameraTracker Menu > Tracks > Delete Selected to remove 
your selections.

Tip You can also change the Display mode so that the Viewer displays Track 
Quality to locate the worst per track error points before deciding which 
tracks to delete. See “Viewing Tracks and Track Information” on page 20.

Note The CameraTracker menu is only available when the CameraTracker effect is 
highlighted in the Effect Controls window.

You may notice that CameraTracker Menu selections can be slow, especially 
on Windows platforms. To avoid this, try holding down the left mouse 
button in the menu, locating the option you require, and releasing to 
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complete the selection (rather than clicking to bring the menu up and then 
clicking to select).

Note Instead of deleting selected tracks from the Viewer, consider using a 
keyframed matte to prevent entire regions from being tracked. This is often 
better than deleting tracks from the Viewer because a poor track in one 
area can cause CameraTracker to incorrectly estimate the motion in the 
footage and produce more poor tracks in the neighbouring areas. For more 
information on creating and using mattes, see “Using Mattes” on page 14.

Removing All Unsolved Tracks

To remove all unsolved feature tracks, click the Delete Unsolved button in 
the CameraTracker controls. This removes all tracks that don’t have a valid 
3D point after solving.

Removing Tracks that Fall outside Set Thresholds

You can use the Refine group in the CameraTracker controls to set 
thresholds for acceptable tracks and then click the Delete Rejected button 
to remove all tracks that fall outside these thresholds. This is described in 
more detail under “Track and Solve Thresholds” on page 55.

Giving Precedence to 
Good Feature Tracks

In addition to removing poor feature tracks, you can select a track and 
navigate to CameraTracker Menu > Tracks > Toggle Verified Track (or press 
T) to toggle whether it is a verified track. A verified track is marked with a 
yellow circle. It is treated differently in the solve phase, and given 
precedence over non-verified tracks when building the camera model and 
path. This allows you to clean up tracks by selecting a number of points you 
can actively see are good and not slipping, and toggling on their verified 
state.

Fine Tuning Your 
Feature Tracks

Inevitably some layers that you track will produce results that contain too 
many errors to be used for a solve. The following parameters are designed 
to fine tune your tracks if the automatic track data is inadequate.

You can use these settings to fine tune your tracks then re-examine them 
using the Refine group and Track Finder to really get the best results from 
CameraTracker.

Track Threshold

CameraTracker’s tolerance to change along the track is determined by the 
Track Threshold parameter. Reducing this threshold makes tracking more 
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tolerant to image changes, potentially producing longer tracks. When used 
in conjunction with Preview Features you can adjust this value to test 
whether a track is reliable over time.

Tracks marked in red suggest that the current settings may need some fine 
tuning.

Track Smoothness

Track Smoothness can be useful in preventing poor tracks in complex 
sequences. Increase the smoothness value to remove tracks that error over 
time. In Figure 4.1 and Figure 4.2, you can see that the higher value 
removes some tracks in the lower left of the layer and a number of tracks 
are shorter as a result of smoothing.

Figure 4.1: A low smoothness value.

Figure 4.2: A high smoothness value.
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Tip You can select the Preview Features checkbox to preview your features 
before tracking. 

Track Consistency

The consistency value defines how inconsistent a feature track can be 
before CameraTracker discards it and reseeds in a different location. Higher 
values allow for less inconsistency.

Figure 4.3 and Figure 4.4 show examples of low and high consistency 
values. Notice that the higher value loses some tracks in the highlighted 
area. 

Figure 4.3: Low consistency value of 0.1.

Figure 4.4: High consistency value of 1.

Track Validation

Validation determines what type of camera movement CameraTracker 
should compensate for while tracking features. Use the Free Camera and 
Rotating Camera options to test tracks against the expected motion of the 
camera.

• Free Camera—compensates for a freely moving camera that is rotating 
and translating. This is the default validation setting.

• Rotating Camera—compensates for a static camera that is rotating 
only, for example nodal pan shots.

If your tracking results appear as shown in Figure 4.5, with no Y axis 
translation, you may want to select Rotating Camera and retrack.
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Figure 4.5: A scene shot with no camera motion on the Y axis.

Note If you select Rotating Camera, make sure that Solve > Camera Motion is 
also set to Rotation Only. See “Camera Motion” on page 24 for more 
information.

• None—do not validate tracks based on any particular camera movement.

Tip You might want to use the None validation option if you need a larger 
number of tracks and want to keep all tracks in the image.

Retracking Features Once you’ve fine tuned your feature tracks and removed any problem tracks, 
click Track Features to retrack your layer.

When you attempt to retrack a layer, After Effects displays a warning to 
stop you overwriting your previous data.

Click Yes to replace your existing tracks or No to retain your previous 
tracking data and cancel retracking.
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Troubleshooting 
Solves

To troubleshoot and improve the solve, you can:

• Use the Solve Statistics and Track Finders to identify problems. See 
“Using the Refine Group” on page 51.

• Create a grid on the ground plane, play through the clip, and see if the 
ground plane slips. See “Creating a Grid on the Ground Plane” on 
page 62.

• Change the keyframe parameters and re-solve. See “Keyframes” on 
page 63.

Creating a Grid on the 
Ground Plane

Provided you are able to set a ground plane in your scene, creating a grid on 
the ground plane can help you judge the quality of the solve. Do the 
following:

1. Set a ground plane if you haven’t already. See “Setting the Ground 
Plane” on page 35.

2. Navigate to Layer > New > Solid to create a large solid.

The solid comes in as a 2D layer.

3. To make the solid a 3D layer, click on the 3D Layer column in the 
composition.

4. Under Transform, set the solid’s X Rotation to -90.0 degrees. This 
should put the solid on the ground plane.

5. Select the solid in your composition and navigate to Effect > Generate > 
Grid. This applies a grid effect to the solid.

6. Adjust the Grid controls as necessary. For example, it may be helpful to 
set Size From to Width Slider.

7. Move through the sequence and compare the grid against the plane it’s 
set on (rather than anything above that plane).
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Keyframes During a solve, CameraTracker automatically selects a subset of frames, 
called keyframes, that describe the camera motion within the layer. 
Keyframes are usually positioned relatively far apart so that there is 
sufficient parallax in the images to define 3D points for the tracks. This 
enables a better definition of the 3D points and makes the solve more 
accurate.

If you find that the automatic solve isn’t acceptable, you can use the Solve 
Statistics and Track Finders to troubleshoot and try changing the keyframe 
parameters and re-solving the camera.

Keyframe Separation

The separation value between keyframes can be tailored to specific layers if 
the default value of 0.30 is not satisfactory. 

• High separation values generate fewer keyframes with a greater spread 
and are typically used for slower camera motion.

• Low values generate more keyframes with a tighter spread and are 
typically used for rapid camera motion.

To solve using keyframes:

1. Enter the required Keyframe Separation.

2. Enter a Reference Frame to use as the first keyframe in the solve.

Tip You should choose a Reference Frame with a large number of tracks and 
variations in depth distributed throughout the frame.

3. Select the Set Reference Frame checkbox to confirm your selections.
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4. Select a Keyframe Accuracy from the drop down menu.

Note A higher accuracy takes longer to solve but it can improve the result when 
you’re working with a long sequence.

5. Enable Three Frame Initialization to force CameraTracker to use 3 initial 
frames to begin the solve, rather than 2, to help correct distorted 
solves. Trying different reference frames with this option can be 
particularly effective to correct complex solves.

6. Click Solve Camera to re-solve with the new Keyframe Separation value, 
or navigate to CameraTracker Menu > Actions > Solve Camera in the 
Viewer.

Bear in mind that a poor solve can also be a result of poor tracking data. If 
you’ve fine-tuned your solve and the results are still unsatisfactory, go back 
and refine your feature tracks to try and improve the results.

Troubleshooting 
Using the Point 
Cloud

The CameraTracker Point Cloud displays your track points in 3D space from 
the point of view of the solved camera and is a very useful tool for 
troubleshooting. You can use it in at least two ways:

• You can play through the sequence and view the feature points as they 
would be seen by the solved camera. If any feature points seem to slip 
between frames, they’re most likely producing bad results. For more 
information, see “Playing through the Sequence” on page 64.

• You can also select some points, create a solid, and use the Unified 
Camera Tool to move around the scene on one frame. If the solid does 
not look like you’d expect and you can see that one of the points is way 
off in the distance relative to other points, it’s safe to assume that 
you’ve found a bad feature point. For more information, see “Creating a 
Solid” on page 65.

Tip You can reduce the Point Cloud size to view more accurate keypoints from 
the solve by checking View Keyframe Points Only on the CameraTracker 
panel.

Playing through the 
Sequence

If your footage has elements that are easy to identify in the Point Cloud, 
simply looking at the tracked points in the 3D view whist playing through 
the clip can help you locate bad points.

To try this out, once you’ve created your scene, click Toggle 2D/3D in the 
CameraTracker controls to switch to the 3D View. Make sure that the active 
camera is the camera created in the scene: CameraTracker-Camera(1). You 
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should now see the Point Cloud from the point of view of the solved camera.

Next, select Window > Preview to bring up the After Effects play controls. 
Go to the first frame in your clip and hit the play button. As the Point Cloud 
moves through the sequence, try to identify the different elements in your 
footage and keep an eye out for any points that slip. If you see a point that 
moves to where it shouldn’t be, you’ve located a bad track point.

Note If your footage doesn’t have elements that are easy to identify in the Point 
Cloud (for example, if all the elements in the footage are pretty much the 
same colour), it may be difficult to see where the points should be and 
whether they slip. If this is the case, you can try troubleshooting the Point 
Cloud by creating a solid and using the Unified Camera Tool to move around 
the scene, as described below.

Tip You may also be able to spot poor feature points by looking at individual 
frames and pressing Tab repeatedly to switch between the 2D and 3D 
Views.

Creating a Solid Using CameraTracker Menu > Create > Solid sometimes produces 
unpredictable results and the Point Cloud is extremely useful to 
troubleshoot which features are causing the error.

To demonstrate this, let’s create an inaccurate solid and use the Point Cloud 
to fine-tune the result. Bear in mind that the points selected in this example 
are purposefully inadequate—in reality you wouldn’t select these points to 
create a solid.

Figure 4.6 shows the points selected from the scene created by 
CameraTracker.

Figure 4.6: Five points selected to produce a bad solid.
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The points in Figure 4.6 produce the following solid in After Effects.

As you can see, the solid is enormous and not what you would expect from 
good point selection. To troubleshoot the solid using the Point Cloud, do 
the following:

1. Switch the viewer to 2 Views - Horizontal and select Custom View 1 in 
the left panel (see “Creating a Solve” on page 25 for more information).

2. Navigate to CameraTracker Menu > Switch Mode 2D/3D or press Tab to 
toggle between 2D and 3D.

In Custom View 1, you can see immediately that one of the points 
selected is way off in the distance relative to the other 4 points.

3. Use the Unified Camera Tool to move around the scene in order to 
locate the spurious point. The most informative view of the Point Cloud 
in this example is directly in front and slightly above the scene. See 
Figure 4.7 on page 67.
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Figure 4.7: Selected points viewed from the solved camera.

In this example, the bad point is clearly the track that follows the mov-
ing figure in the centre of the selected points.

4. Deselect the bad point in the 3D View and recreate the solid without 
that point to improve the solid.

Admittedly, the new solid is still pretty bad—repeat the Point Cloud 
troubleshooting steps as many times as required to produce a good 
solid.

Note In the above example, the solid looked wrong but wasn’t moving around 
over the course of time. If you create a solid and see that it’s moving around 
in a way it shouldn’t be, you’ve probably got a bad track rather than just a 
bad solve or scene. Try troubleshooting the track. If only a few tracks slip, 
you can delete those tracks and/or use Toggle Verified Track to give 
precedence to tracks that you know are good. Then, solve your footage 
again. If a lot of tracks slip, you may want to go right back to the beginning, 
adjust the tracking parameters and/or add a matte, and retrack the footage.

Tip In addition to creating solids, you can also create null objects to 
troubleshoot your tracks and solves.
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5  TUTORIALS

Introduction Welcome to CameraTracker Tutorials! If you’ve reviewed the previous 
chapters in this guide—which we highly recommend—you already know 
something about CameraTracker’s capabilities. These tutorials show how to 
pull everything together through a series of practical examples.

Note These tutorials assume that you are reasonably familiar with the After 
Effects interface and basic compositing theory.

The Projects • Tutorial 1: Setting a Ground Plane—an example of setting a ground 
plane badly, then using the Point Cloud to correct the problem.

• Tutorial 2: Adding an Object to a Layer—a basic run through of creating 
a text banner in the 3D scene.

• Tutorial 3: Correcting a Troublesome Solve—some simple 
troubleshooting steps designed to help you correct difficult solves.

Example Images Before you continue, download the tutorial files from The Foundry web site 
http://www.thefoundry.co.uk and move them to a directory you’ll create, 
called “CameraTracker_Tutorials”. 

Note You may need to unzip the files before you can use them.

It’s up to you where you put the tutorial files, but bear in mind that you’ll 
need them during these tutorials.
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Tutorial 1: Setting 
a Ground Plane

In this tutorial, we’ll select some points in our layer to create a Ground 
Plane, examine the points using the Point Cloud, and refine the selection to 
improve the final results.

Preparing the 
Workspace

First, you’ll set up the workspace and apply CameraTracker as an effect on a 
layer:

1. Launch After Effects as normal and navigate to File > Import > File.

2. Navigate to the folder containing the tutorial files and open the 
Tutorial1_01.jpg file (After Effects imports the entire contents of the 
folder automatically).

3. Drag and drop the content from the Project tab to the Viewer and click 
the image to select the layer.

4. Navigate to Effect > The Foundry > CameraTracker.
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5. The CameraTracker panel displays in the Effect Controls window.

The next step is to track features within the layer, create a solve, and 
place the solved camera within the layer. For the purpose of these tuto-
rials, we’ll use the default settings for tracking, solving, and creating a 
scene, simply because they work well with the sample images provided.

6. On the CameraTracker panel, click Track Features, or navigate to 
CameraTracker Menu > Actions > Track Features in the Viewer.

Note The layer used in this tutorial should track quickly due to its simplicity.

7. When the track phase completes, click Solve Camera, or navigate to 
CameraTracker Menu > Actions > Solve Camera in the Viewer.

8. Click Create Scene, or navigate to CameraTracker Menu > Actions > 
Create Scene in the Viewer.

Once you’ve created a virtual 3D camera in your layer, you’re ready to select 
some track points and create a Ground Plane.

The first step when preparing to select Ground Plane points is to get a good 
feel for the layer that you intend to use. Play through the layer in 2D and 
3D using the Point Cloud and try to locate points that:

• appear to be on the correct plane or ’ground’ in the layer.

• are as consistent as possible throughout the layer.

• have minimal solve reprojection errors per frame.
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For the purposes of this tutorial, we’ll marquee a broad selection to start 
with, then refine the selection using the Point Cloud.

1. Drag a marquee over some points around the lawn area shown in 
Figure 5.1. Don’t worry if your points are not exactly the same as the 
ones illustrated—some of these points are purposefully poor.

Figure 5.1: Sample tracking points.

2. Navigate to CameraTracker Menu > Ground Plane > Set to Selected.

Note You may notice that CameraTracker Menu selections can be slow, especially 
on Windows platforms. To avoid this, try holding down the left mouse 
button in the menu, locating the option you require and releasing to 
complete the selection.
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3. CameraTracker highlights the points that you selected to represent the 
Ground Plane and shows the new position of the Null associated with 
the solved camera.

4. Switch to the 3D Point Cloud using Custom View 1 and activate the 
Unified Camera Tool by pressing C on your keyboard. 

5. Select the CameraTracker-Camera(1) layer in your composition and 
move around the scene to view the new Ground Plane. If you align the 
Null vertically and the grid horizontally, you should see a camera view 
similar to that shown below.

You can tell immediately that the camera view point is severely skewed 
and the yellow and blue points that represent the Wendy House are 
positioned at an unnatural angle.

The points producing the skew are most likely those located in the right 
of the shot, so let’s remove those and see if the results improve.

6. Navigate to CameraTracker Menu > Ground Plane > Reset.

7. Reselect your points, excluding those positioned in the bushes, and on 
the slide, and set the Ground Plane. 
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8. Switch to the Point Cloud and move around the scene to check your 
points.

Again, align the Null vertically and the grid horizontally, you should see 
a camera view similar to that shown below.

A great improvement on the original Ground Plane. From here you can 
experiment by adding and removing points to produce the best results.

Of course, you don’t have to use Ground Planes to represent ’the ground’ in 
your scene. If your composition calls for a lot of vertical positioning, why 
not set your Ground Plane on the side of a building or even the ceiling of a 
room? 
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Tutorial 2: Adding 
an Object to a 
Layer

In this tutorial, we’ll be adding an object to the 3D scene along the path of 
the camera. The result won’t be pretty, that’s up to you to refine, but it 
should give you a feel for working within a 3D scene.

First, you’ll set up the workspace as described in “Preparing the Workspace” 
on page 69, but in step 2 import the Tutorial2_01.jpg files instead.

Once you’ve created a virtual 3D camera in your layer, you’re ready to add 
objects to the scene. 

Creating a Reference 
Solid

Creating a solid as a reference point in CameraTracker is an excellent 
starting point before placing other objects within a composition. Solids 
created in this way are automatically aligned with the tracked features you 
select.

The first task is to locate likely features to fix the object to in 3D space. The 
Point Cloud is very useful for checking tracked points within the 
composition.

1. Play through the composition in 2D and 3D mode a couple of times to 
get a feel for the tracked features. Try to select points that are consis-
tent throughout the layer.

2. The two points we’re going to use to position our solid are shown below 
in both 2D and 3D space. Select the points by holding Shift and clicking 
each point.

Note The red rectangle in the images represents the Null associated with the 
solved camera.

Figure 5.2: Tracked points in 
2D space

Figure 5.3: The same 2 points in 3D 
space using the Point Cloud.
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3. Navigate to CameraTracker Menu > Create > Solid to produce a default 
solid using the two points we selected.

Note You may notice that CameraTracker Menu selections can be slow, especially 
on Windows platforms. To avoid this, try holding down the left mouse 
button in the menu, locating the option you require, and releasing to 
complete the selection.

4. Adjust the solid so that the edges are aligned with the pillar in the 
scene.

You can use the X, Y, and Z handles (the coloured arrows) to determine 
the correct positioning of the solid.

Note Use Transform > Y Rotation in this case, though in other circumstances 
you’ll probably need the other Transform tools as well.

5. Play through the composition and check that the solid doesn’t slip 
between frames. In this example, the solid is pretty good so you won’t 
need to make any adjustments.
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Importing and Placing 
an Object

Now that you have a solid reference point, we can import and place an 
object using the solid as a guide.

1. Right-click in the Project tab and select Import > File.

2. You can import any file in to your composition, but for the purposes of 
this tutorial, import the Poster.png image supplied with the Tutorial2 
files.

Next, we’ll use a handy After Effects hotkey to swap the imported object 
for the reference solid.

3. Select the Poster.png object and the CameraTracker-Solid(2) layer in the 
composition.
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4. Press cmd (or ctrl on Windows) + alt / to swap the object and the solid, 

OR

Hold alt then click and drag Poster.png over the CameraTracker-Solid(2) 
layer in the composition.

The object is placed on the plane that the solid occupied, but as you can 
see, the rotation and scale need some work.

5. Open up the Poster.png layer Transform controls in the composition.

6. Use the Scale and Rotation controls to position the object so that it 
appears on the pillar.

You should find that settings similar to those shown will position the 
poster nicely.

7. Finally, click the ’eye’ icon to turn off the Null layer to clean up the final 
result.
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Play through the composition to check that your final result produces no 
slippage, and we’re done!
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Tutorial 3: 
Correcting a 
Troublesome Solve

Tracking and solving a camera isn’t always as simple as clicking three 
CameraTracker buttons. At some stage in your career using CameraTracker, 
you’ll come across a scene that requires some fine-tuning to produce a 
usable result. In this tutorial, we’ll track a layer that won’t solve and then 
run through some steps to correct it.

First, you’ll set up the workspace as described in “Preparing the Workspace” 
on page 69, but in step 2 import the Tutorial3_01.jpg tutorial files instead.

1. The CameraTracker panel displays in the Effect Controls Window (ECW).

2. We’ll start off with the default Tracking and Solve parameters—on the 
CameraTracker panel, click Track Features, or navigate to 
CameraTracker Menu > Actions > Track Features in the Viewer.

You can tell immediately that there is something strange going on in the 
scene just by looking at the lengthy diagonal tracks across the Viewer.
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3. When the track completes, click Solve Camera, or navigate to 
CameraTracker Menu > Actions > Solve Camera in the Viewer.

The solve cannot complete on this sample footage, probably because 
there are one or two tracks that are throwing out the other features 
during the solve.

There are a number of ways we can fix the solve and improve the results, 
the most common being locating and covering the area where the tracks 
originate with a matte or finding and removing bad tracks. The method you 
choose will largely depend on the time you have available—searching 
through track data to locate bad feature points can be time consuming.

Using a Matte to Hide 
Bad Tracks

Using a matte to cover areas where you know the track data is bad is a 
quick fix, but can reduce the accuracy of solve data. You could use this 
method if you’re short of time or patience!

The first thing to do is view the track statistics for the composition:

1. Click the Graph Editor toggle in After Effects.
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2. Select your composition and press the After Effects hotkey U to display 
all the statistics associated with that layer.

If you examine the results, you should see at frame 11 a large spike in 
the Track Distance - Max.

3. Advance the playhead to frame 11 to view the tracked features.

Looking at the top of the composition, in the centre of the frame, you 
can see a group of three extremely long tracks. These are most likely to 
blame!

Next, we’ll create an animated matte and add it to the composition to 
cover the area during the tracking phase.

4. Right-click in your composition and select New > Solid to add a basic 
shape that we can mould into our matte.
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The Solid Settings dialog displays.

5. Set the colour to white and click Make Comp Size so that the solid fills 
the screen.

6. Click OK to add the solid to the composition.

7. By default, the solid is placed at the top layer of the composition, so 
drag and drop it under the Tutorial3_01.jpg layer.

8. Next, select the Pen Tool or press G on your keyboard.

9. Move the playhead to frame 14 and draw a rough matte shape where 
you think the faulty tracks are seeded. Something like this should be OK:

Note We’ve chosen a red outline for ease of illustration—the default After 
Effects colour is yellow.

In reality, you would probably not want to matte such a large area 
throughout the scene because you would lose a lot of good data along with 
the bad.
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10.Drill down through the White Solid 1 layer to Mask Path and click the 
stopwatch to place a keyframe.

11.Scrub the playhead to frame 10 and adjust the matte so that it still 
covers the area shown.

12.Select the White Solid 1 layer and navigate to Layer > Pre-compose. 

The Pre-Compose dialog displays.

13.Select Move all attributes into the new composition and click OK.

Next, we’ll tell CameraTracker how to use our matte. 

14. Open up the CameraTracker ECW and select Matte Source > Matte 
Alpha.

Note We chose Matte Alpha because the matte we created is white. If the matte 
was black, we would choose Matte Inverted Alpha.
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15.Select Matte Layer > White Solid 1 Comp 1.

16.Click Track Features to retrack the layer with the matte in place. Click 
Yes in the warning box.

If you pay close attention, you may be able to see where the matte is 
stopping tracks from seeding.

17.When the retrack has completed, check the track statistics again and 
scrub the playhead to the frame with the highest errors.

Notice that there are still some long diagonal tracks on frame 11? We 
should be able to do something about those in the next section.
CameraTrackerThe Foundry



TUTORIALS 85
Tutorial 3: Correcting a Troublesome Solve 
Locating and 
Removing Bad Tracks

Eliminating bad tracking data is an excellent way to fix a failing solve, if you 
have the time available. Unlike using mattes, deleting specific tracks doesn’t 
remove good tracks along with the bad.

1. The track statistics did a good job of highlighting frame 11, so we’ll 
start there. Use the Preview panel in After Effects to play through the 
layer frame-by-frame.

2. Scrub to frame 11 and select the two diagonal tracks as shown. 
Navigate to CameraTracker Menu > Tracks > Delete Selected or press 
delete on your keyboard.

Note You may find selecting the points easier if you enable Allow Line Selection 
on the ECW.

Scrub through the layer and make sure there are no more obviously bad 
tracks.

3. Refresh the track statistics by navigating to CameraTracker Menu > 
Tracks > Refresh Stats. Notice that the error peak at frame 11 has been 
smoothed out?
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4. As a final precaution, we’ll reduce the Keyframe Separation to 0.10 as 
shown.

5. Click Solve Camera to attempt the solve again. 

The solve should complete with a similar reprojection error to that 
shown below.

6. Click OK to view the solved tracks. You can use the track finder to 
examine the reprojection errors of individual tracks. See “Examining 
Your Feature Tracks” on page 51 for more information.

Note You may notice that CameraTracker has rejected a couple of tracks. When 
this occurs, you cannot view reprojection errors for these tracks.
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A total RMS reprojection error of 0.296 is pretty respectable, but feel 
free to play around with the track and solve settings as much as you 
like!

The real test of accuracy for any solve and scene is to add objects to your 
composition and verify that they don’t slip from frame to frame. Try adding 
the poster from Tutorial 2 to this scene to really show how the refined solve 
works.
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APPENDIX A

Release Notes for 
CameraTracker

This appendix describes the requirements, new features, improvements over 
previous versions, fixed bugs, and known bugs and workarounds in 
CameraTracker.

1.0v3 Requirements

1. Either:

• After Effects CS5 or CS5.5 on Mac OS X 10.5.8 (or later) 64-bit, or

• After Effects CS5 or CS5.5 on Windows 7 64-bit, or

• After Effects CS4 on Mac OS X 10.5.8 (or later) 32-bit, or

• After Effects CS4 on Windows XP 32-bit.

2. Foundry FLEXlm Tools (FFT 5.0v1 or later) for floating licences.

Release Date

May 2011

New Features

There are no new features in this release.

Feature Enhancements

Added support for After Effects CS5.5.

Fixed Bugs

There are no bug fixes in this release.

Known Issues and Workarounds

• Tracking with Render During Analysis enabled may be interrupted by 
After Effects events such as Autosave, and when switching away to 
another application and back again. If you are tracking a long layer, or 
are planning on switching away during the track, disable Render During 
Analysis.

• Differences between the frame rate of the composition and imported 
footage can produce unreliable feature track data.

To avoid this issue, ensure that the overall frame rate of your composi-
tion is identical to the layer containing the footage you intend to track.

• BUG ID 11088 - Menus can’t be tied to right click events in the Viewer.
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Use the CameraTracker Menu in the viewer or cmd/ctrl click to access the 
menu.

• BUG ID 12298 - Pressing the Cancel button during the Solve Camera or 
Create Scene phases does not halt the process.

• BUG ID 12975 - Transforming the Null Object parent associated with the 
CameraTracker camera doesn't automatically update the Point Cloud if 
you’re using an After Effects Custom View. 

To force the Null to update, manipulate the camera in the Viewer using 
the Unified Camera Tool.

• BUG ID 12302 - Overlay handles are drawn offset from subset masks. 

To avoid this, precomp your mask in a composition of the same resolu-
tion as the current one.

• BUG ID 13979 - Viewing the Point Cloud using the After Effects preset 
views (Top, Left, Right, etc.) does not produce the correct interpretation 
of points.

To avoid this, use the Custom View options and pan the camera around 
the scene using the Unified Camera Tool.
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1.0v2 Requirements

1. Either:

• After Effects CS5 on Mac OS X 10.5.8 (or later) 64-bit, or

• After Effects CS5 on Windows 7 64-bit, or

• After Effects CS4 on Mac OS X 10.5.8 (or later) 32-bit, or

• After Effects CS4 on Windows XP 32-bit.

2. Foundry FLEXlm Tools (FFT 5.0v1 or later) for floating licences.

Release Date

October 2010

New Features

CameraTracker is now available on After Effects CS4 for Mac OS X 10.5 32-
bit.

Feature Enhancements

• BUG ID 13270 - The generation of post solving statistics now has a 
progress bar because the creation of Refine statistics after long tracking 
functions seemed to cause After Effects to hang.

Fixed Bugs

• BUG ID 13008 - Creating a Ground Plane using the Set to Selected 
shortcut (A) caused After Effects to crash intermittently due to an 
underlying issue with setting After Effects cameras during certain 
events.

Unfortunately, we have had to remove this hotkey to prevent crashes. 

• BUG ID 13045 - Copy/Pasting layers between compositions was causing 
an After Effects error message to display, even though the function was 
completed.

• BUG ID 13137 - Tracking statistics in the Refine menu were not being 
reset when a new work area was created.

• BUG ID 13138 - Using Delete unsolved in the Refine settings deleted all 
points if you hadn't solved the camera.

• BUG ID 13202 - It was not possible to select/deselect points in the 3D 
Point Cloud on footage with non-square pixel aspect ratios.

• BUG ID 13203 - Solid and null creation on 3D points was being offset on 
footage with non-square pixel aspect ratios.

• BUG ID 13212 - Saving a project between the Solve Camera and Create 
Scene phases caused any input Lens Distortion values to reset to 
default.
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• BUG ID 13213 - Transferring projects between OS X and Windows, and 
vice-versa, was occasionally causing parameters to reset or read 
incorrectly.

• BUG ID 13304 - Selecting Known Lens in the Lens Distortion settings 
caused failing solves to produce a blank error message.

• BUG ID 13964 - When the frame rate of a clip was set to a non-integer 
value (for example 29.97), features occasionally tracked on the wrong 
frame range.

Known Issues and Workarounds

• Tracking with Render During Analysis enabled may be interrupted by 
After Effects events such as Autosave, and when switching away to 
another application and back again. If you are tracking a long layer, or 
are planning on switching away during the track, disable Render During 
Analysis.

• Differences between the frame rate of the composition and imported 
footage can produce unreliable feature track data.

To avoid this issue, ensure that the overall frame rate of your composi-
tion is identical to the layer containing the footage you intend to track.

• BUG ID 11088 - Menus can’t be tied to right click events in the Viewer.

Use the CameraTracker Menu in the viewer or cmd/ctrl click to access the 
menu.

• BUG ID 12298 - Pressing the Cancel button during the Solve Camera or 
Create Scene phases does not halt the process.

• BUG ID 12975 - Transforming the Null Object parent associated with the 
CameraTracker camera doesn't automatically update the Point Cloud if 
you’re using an After Effects Custom View. 

To force the Null to update, manipulate the camera in the Viewer using 
the Unified Camera Tool.

• BUG ID 12302 - Overlay handles are drawn offset from subset masks. 

To avoid this, precomp your mask in a composition of the same resolu-
tion as the current one.

• BUG ID 13979 - Viewing the Point Cloud using the After Effects preset 
views (Top, Left, Right, etc.) does not produce the correct interpretation 
of points.

To avoid this, use the Custom View options and pan the camera around 
the scene using the Unified Camera Tool.
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1.0v1 This is the first release for CameraTracker on After Effects.

Requirements

1. Either:

• After Effects CS5 on Windows 7 64-bit or,

• After Effects CS5 on Mac OS X 10.5.8 (or later) 64-bit.

2. Foundry FLEXlm Tools (FFT 5.0v1 or later) for floating licences.

Release Date

10 August 2010

New Features

This section will describe new features in later releases.

Feature Improvements

This section will describe feature improvements in later releases.

Fixed Bugs

This section will describe fixed bugs in later releases.
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Third Party Licences

This appendix lists third party libraries used in CameraTracker, along with their licences.

Library Description Licence

Boost Source code function / 
template library

Boost Software Licence - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organisation obtaining 
a copy of the software and accompanying documentation covered by this licence (the 
“Software”) to use, reproduce, display, distribute, execute, and transmit the Soft-
ware, and to prepare derivative works of the Software, and to permit third-parties to 
whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above 
licence grant, this restriction and the following disclaimer, must be included in all 
copies of the Software, in whole or in part, and all derivative works of the Software, 
unless such copies or derivative works are solely in the form of machine-executable 
object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN 
NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFT-
WARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, 
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFT-
WARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Expat XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark 
Cooper 

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers. 

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the “Software”), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, sublicence, and/or sell copies of the Software, and to per-
mit persons to whom the Software is furnished to do so, subject to the following 
conditions: 

The above copyright notice and this permission notice shall be included in all copies 
or substantial portions of the Software. 

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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FreeType Font support Portions of this software are copyright © 2008 The FreeType Project 

(www.freetype.org). All rights reserved.

FTGL OpenGL support FTGL - OpenGL font library

Copyright © 2001-2004 Henry Maddocks ftgl@opengl.geek.nz 

Copyright © 2008 Sam Hocevar sam@zoy.org 

Copyright © 2008 Sean Morrison learner@brlcad.org 

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the “Software”), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, sublicence, and/or sell copies of the Software, and to per-
mit persons to whom the Software is furnished to do so, subject to the following 
conditions 

The above copyright notice and this permission notice shall be included in all copies 
or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT-
ABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
THE USE OR OTHER DEALINGS IN THE SOFTWARE.

VXL Computer vision Copyright © 2000-2003 TargetJr Consortium GE Corporate Research and Develop-
ment (GE CRD) 1 Research Circle Niskayuna, NY 12309 All Rights Reserved Repro-
duction rights limited as described below.

Permission to use, copy, modify, distribute, and sell this software and its documenta-
tion for any purpose is hereby granted without fee, provided that (i) the above copy-
right notice and this permission notice appear in all copies of the software and 
related documentation, (ii) the name TargetJr Consortium (represented by GE CRD), 
may not be used in any advertising or publicity relating to the software without the 
specific, prior written permission of GE CRD, and (iii) any modifications are clearly 
marked and summarized in a change history log.

THE SOFTWARE IS PROVIDED “AS IS” AND WITHOUT WARRANTY OF ANY KIND, 
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MER- CHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO 
EVENT SHALL THE TAR- GETJR CONSORTIUM BE LIABLE FOR ANY SPECIAL, INCIDEN-
TAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND OR ANY DAMAGES 
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR 
NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR ON ANY THEORY OF LIA-
BILITY ARISING OUT OF OR IN CONNEC- TION WITH THE USE OR PERFORMANCE OF 
THIS SOFTWARE.

Library Description Licence
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End User Licensing Agreement

IMPORTANT: BY INSTALLING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, 
UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. IF YOU DO NOT AGREE TO THE TERMS 
OF THIS AGREEMENT DO NOT INSTALL, COPY OR USE THE SOFTWARE.

This END USER SOFTWARE LICENCE AGREEMENT (this "Agreement") is made by and between The Foundry 
Visionmongers Ltd., a company registered in England and Wales, ("The Foundry"), and you, as either an individual or a 
single entity ("Licencee"). 

In consideration of the mutual covenants contained herein and for other good and valuable consideration (the receipt 
and sufficiency of which is acknowledged by each party hereto) the parties agree as follows:

SECTION 1. GRANT OF LICENCE. 
Subject to the limitations of Section 2, The Foundry hereby grants to Licencee a limited, non-transferable and non-
exclusive licence to install and use a machine readable, object code version of this software program (the "Software") 
and the accompanying user guide and other documentation (collectively, the "Documentation") solely for Licencee's 
own internal business purposes (collectively, the "Licence"); provided, however, Licencee's right to install and use the 
Software and the Documentation is limited to those rights expressly set out in this Agreement.

SECTION 2. RESTRICTIONS ON USE. 
Licencee is authorised to use the Software in machine readable, object code form only, and Licencee shall not: (a) 
assign, sublicence, transfer, pledge, lease, rent, share or export the Software, the Documentation or Licencee's rights 
hereunder; (b) alter or circumvent the copy protection mechanisms in the Software or reverse engineer, decompile, 
disassemble or otherwise attempt to discover the source code of the Software; (c) modify, adapt, translate or create 
derivative works based on the Software or Documentation; (d) use, or allow the use of, the Software or 
Documentation on any project other than a project produced by Licencee (an "Authorised Project"); (e) allow or permit 
anyone (other than Licencee and Licencee's authorised employees to the extent they are working on an Authorised 
Project) to use or have access to the Software or Documentation; (f) copy or install the Software or Documentation 
other than as expressly provided for herein; or (g) take any action, or fail to take action, that could adversely affect 
the trademarks, service marks, patents, trade secrets, copyrights or other intellectual property rights of The Foundry 
or any third party with intellectual property rights in the Software (each, a "Third Party Licencor"). Furthermore, for 
purposes of this Section 2, the term "Software" shall include any derivatives of the Software. 

Licencee shall install and use only a single copy of the Software on one computer, unless the Software is installed in 
a "floating licence" environment, in which case Licencee may install the Software on more than one computer; 
provided, however, Licencee shall not at any one time use more copies of the Software than the total number of valid 
Software licences purchased by Licencee. 

Furthermore, the Software can be licensed on an "interactive" or "non-interactive" basis. Licencee shall be authorised 
to use a non-interactive version of the Software for rendering purposes only (i.e., on a CPU, without a user, in a non-
interactive capacity) and shall not use such Software on workstations or otherwise in a user-interactive capacity. 
Licencee shall be authorised to use an interactive version of the Software for both interactive and non-interactive 
rendering purposes, if available. 
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Finally, if the Software is an "Educational Version," Licencee may use it only for the purpose of training and 
instruction, and for no other purpose. Educational Versions of the Software may not be used for commercial, 
professional or for-profit purposes. 

SECTION 3. BACK-UP COPY. 
Notwithstanding Section 2, Licencee may store one copy of the Software and Documentation off-line and off-site in 
a secured location owned or leased by Licencee in order to provide a back-up in the event of destruction by fire, 
flood, acts of war, acts of nature, vandalism or other incident. In no event may Licencee use the back-up copy of the 
Software or Documentation to circumvent the usage or other limitations set forth in this Agreement.

SECTION 4. OWNERSHIP. 
Licencee acknowledges that the Software and Documentation and all intellectual property rights relating thereto are 
and shall remain the sole property of The Foundry and the Third Party Licencors. Licencee shall not remove, or allow 
the removal of, any copyright or other proprietary rights notice included in and on the Software or Documentation or 
take any other action that could adversely affect the property rights of The Foundry or any Third Party Licencor. To 
the extent that Licencee is authorised to make copies of the Software or Documentation under this Agreement, 
Licencee shall reproduce in and on all such copies any copyright and/or other proprietary rights notices provided in 
and on the materials supplied by The Foundry hereunder. Nothing in this Agreement shall be deemed to give Licencee 
any rights in the trademarks, service marks, patents, trade secrets, copyrights or other intellectual property rights of 
The Foundry or any Third Party Licencor, and Licencee shall be strictly prohibited from using the name, trademarks or 
service marks of The Foundry or any Third Party Licencor in Licencee's promotion or publicity without The Foundry's 
express written approval. 

SECTION 5. LICENCE FEE. 
Licencee understands that the benefits granted to Licencee hereunder are contingent upon Licencee's payment in full 
of the licence fee payable in connection herewith (the "Licence Fee"). 

SECTION 6. TAXES AND DUTIES. 
Licencee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax (exclusive of taxes 
based on net income), duty, tariff or other impost related to or arising from the transaction contemplated by this 
Agreement. 

SECTION 7. LIMITED WARRANTY. 
The Foundry warrants that, for a period of ninety (90) days after delivery of the Software: (a) the machine readable 
electronic files constituting the Software and Documentation shall be free from errors that may arise from the 
electronic file transfer from The Foundry and/or its authorised reseller to Licencee; and (b) to the best of The 
Foundry's knowledge, Licencee's use of the Software in accordance with the Documentation will not, in and of itself, 
infringe any third party's copyright, patent or other intellectual property rights. Except as warranted, the Software 
and Documentation is being provided "as is." THE FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER 
WARRANTIES OR CONDITIONS, EXPRESS OR IMPLIED, AND The Foundry DISCLAIMS ANY AND ALL IMPLIED 
WARRANTIES OR CONDITIONS, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF TITLE, NON-
INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, REGARDLESS OF WHETHER The 
Foundry KNOWS OR HAS REASON TO KNOW OF LICENCEE'S PARTICULAR NEEDS. The Foundry does not warrant that 
the Software or Documentation will meet Licencee's requirements or that Licencee's use of the Software will be 
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uninterrupted or error free. No employee or agent of The Foundry is authorised to modify this limited warranty, nor 
to make additional warranties. No action for any breach of the above limited warranty may be commenced more than 
one (1) year after Licencee's initial receipt of the Software. To the extent any implied warranties may not be 
disclaimed under applicable law, then ANY IMPLIED WARRANTIES ARE LIMITED IN DURATION TO NINETY (90) DAYS 
AFTER DELIVERY OF THE SOFTWARE TO LICENCEE. 

SECTION 8. LIMITED REMEDY. 
The exclusive remedy available to the Licencee in the event of a breach of the foregoing limited warranty, TO THE 
EXCLUSION OF ALL OTHER REMEDIES, is for Licencee to destroy all copies of the Software, send The Foundry a 
written certification of such destruction and, upon The Foundry's receipt of such certification, The Foundry will make 
a replacement copy of the Software available to Licencee. 

SECTION 9. INDEMNIFICATION. 
Licencee agrees to indemnify, hold harmless and defend The Foundry and The Foundry's affiliates, officers, directors, 
shareholders, employees, authorised resellers, agents and other representatives (collectively, the "Released Parties") 
from all claims, defense costs (including, but not limited to, attorneys' fees), judgments, settlements and other 
expenses arising from or connected with the operation of Licencee's business or Licencee's possession or use of the 
Software or Documentation. 

SECTION 10. LIMITED LIABILITY. 
In no event shall the Released Parties' cumulative liability to Licencee or any other party for any loss or damages 
resulting from any claims, demands or actions arising out of or relating to this Agreement (or the Software or 
Documentation contemplated herein) exceed the Licence Fee paid to The Foundry or its authorised reseller for use of 
the Software. Furthermore, IN NO EVENT SHALL THE RELEASED PARTIES BE LIABLE TO LICENCEE UNDER ANY 
THEORY FOR ANY INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY OR CONSEQUENTIAL DAMAGES 
(INCLUDING DAMAGES FOR LOSS OF BUSINESS OR LOSS OF PROFITS) OR THE COST OF PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES, REGARDLESS OF WHETHER THE RELEASED PARTIES KNOW OR HAVE REASON TO 
KNOW OF THE POSSIBILITY OF SUCH DAMAGES AND REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN 
FAILS OF ITS ESSENTIAL PURPOSE. No action arising out of or related to this Agreement, regardless of form, may be 
brought by Licencee more than one (1) year after Licencee's initial receipt of the Software; provided, however, to the 
extent such one (1) year limit may not be valid under applicable law, then such period shall limited to the shortest 
period allowed by law. 

SECTION 11. TERM; TERMINATION. 
This Agreement is effective upon Licencee's acceptance of the terms hereof (by clicking on the "Accept" button) and 
Licencee's payment of the Licence Fee, and the Agreement will remain in effect until termination. If Licencee breaches 
this Agreement, The Foundry may terminate the Licence granted hereunder by notice to Licencee. In the event the 
Licence is terminated, Licencee will either return to The Foundry all copies of the Software and Documentation in 
Licencee's possession or, if The Foundry directs in writing, destroy all such copies. In the later case, if requested by 
The Foundry, Licencee shall provide The Foundry with a certificate signed by an officer of Licencee confirming that 
the foregoing destruction has been completed. 
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SECTION 12. CONFIDENTIALITY. 
Licencee agrees that the Software and Documentation are proprietary and confidential information of The Foundry 
and that all such information and any communications relating thereto (collectively, "Confidential Information") are 
confidential and a fundamental and important trade secret of The Foundry. Licencee shall disclose Confidential 
Information only to Licencee's employees who are working on an Authorised Project and have a "need-to-know" such 
Confidential Information, and shall advise any recipients of Confidential Information that it is to be used only as 
authorised in this Agreement. Licencee shall not disclose Confidential Information or otherwise make any Confidential 
Information available to any other of Licencee's employees or to any third parties without the express written 
consent of The Foundry. Licencee agrees to segregate, to the extent it can be reasonably done, the Confidential 
Information from the confidential information and materials of others in order to prevent commingling. Licencee shall 
take reasonable security measures, which such measures shall be at least as great as the measures Licencee uses to 
keep Licencee's own confidential information secure (but in any case using no less than a reasonable degree of care), 
to hold the Software, Documentation and any other Confidential Information in strict confidence and safe custody. 
The Foundry may request, in which case Licencee agrees to comply with, certain reasonable security measures as part 
of the use of the Software and Documentation. Licencee acknowledges that monetary damages may not be a 
sufficient remedy for unauthorised disclosure of Confidential Information, and that The Foundry shall be entitled, 
without waiving any other rights or remedies, to such injunctive or equitable relief as may be deemed proper by a 
court of competent jurisdiction. 

SECTION 13. INSPECTION. 
Licencee shall advise The Foundry on demand of all locations where the Software or Documentation is used or stored. 
Licencee shall permit The Foundry or its authorised agents to inspect all such locations during normal business hours 
and on reasonable advance notice. 

SECTION 14. NONSOLICITATION. 
Licencee agrees not to solicit for employment or retention, and not to employ or retain, any of The Foundry's current 
or future employees who were or are involved in the development and/or creation of the Software. 

SECTION 15. U.S. GOVERNMENT LICENCE RIGHTS. 
The Software, Documentation and/or data delivered hereunder are subject to the terms of this Agreement and in no 
event shall the U.S. Government acquire greater than RESTRICTED/LIMITED RIGHTS. At a minimum, use, duplication or 
disclosure by the U.S. Government is subject to the applicable restrictions of: (i) FAR §52.227-14 ALTS I, II and III 
(June 1987); (ii) FAR §52.227-19 (June 1987); (iii) FAR §12.211 and 12.212; and/or (iv) DFARS §227.7202-1(a) and 
DFARS §227.7202-3. 

 The Software is the subject of the following notices: 

 * Copyright (c) 2011 The Foundry Visionmongers, Ltd.. All Rights Reserved. 

 * Unpublished-rights reserved under the Copyright Laws of the United Kingdom. 

SECTION 16. SURVIVAL. 
Sections 2, 4, 5, 6, 7, 8, 9, 10, 12, 13, 14, 15, 16, 17 and 18 shall survive any termination or expiration of this 
Agreement. 
CameraTrackerThe Foundry



APPENDIX C 99
End User Licensing Agreement 
SECTION 17. IMPORT/EXPORT CONTROLS. 
To the extent that any Software made available hereunder is subject to restrictions upon export and/or reexport 
from the United States, Licencee agrees to comply with, and not act or fail to act in any way that would violate, the 
applicable international, national, state, regional and local laws and regulations, including, without limitation, the 
United States Foreign Corrupt Practices Act, the Export Administration Act and the Export Administration 
Regulations, as amended or otherwise modified from time to time, and neither The Foundry nor Licencee shall be 
required under this Agreement to act or fail to act in any way which it believes in good faith will violate any such laws 
or regulations.

SECTION 18. MISCELLANEOUS. 
This Agreement is the exclusive agreement between the parties concerning the subject matter hereof and supersedes 
any and all prior oral or written agreements, negotiations, or other dealings between the parties concerning such 
subject. This Agreement may be modified only by a written instrument signed by both parties. If any action is brought 
by either party to this Agreement against the other party regarding the subject matter hereof, the prevailing party 
shall be entitled to recover, in addition to any other relief granted, reasonable attorneys' fees and expenses of 
litigation. Should any term of this Agreement be declared void or unenforceable by any court of competent 
jurisdiction, such declaration shall have no effect on the remaining terms of this Agreement. The failure of either 
party to enforce any rights granted hereunder or to take action against the other party in the event of any breach 
hereunder shall not be deemed a waiver by that party as to subsequent enforcement of rights or subsequent actions 
in the event of future breaches. This Agreement shall be governed by, and construed in accordance with English Law. 

Copyright (c) 2011 The Foundry Visionmongers Ltd. All Rights Reserved. Do not duplicate.
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