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Introduction

About this User Guide
This User Guide tells you how to install and use CameraTracker 1.0 on After Effects. This guide assumes you are
familiar with After Effects and themachine it is running on.

Release Notes
For information on new features, improvements, fixed bugs, known bugs and workarounds, see the ReleaseNotes
on our website: www.foundry.com/products/cameratracker-ae/

Installing CameraTracker 1.0 on After Effects
Please note that installing CameraTracker will effectively overwrite any other versions of CameraTracker that have
been installed to the default location.

On Windows

CameraTracker is distributed as a software download fromourweb site. To install CameraTracker on a computer
runningWindows follow these instructions:

1. Download the correct installation file fromourweb site at www.foundry.com/products/cameratracker-
ae/download.

2. Unzip the file and double-click on the .exe file to launch the installer. Follow the on-screen instructions to install
CameraTracker.
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On Mac

CameraTracker is distributed as a software download fromourweb site. To install CameraTracker on aMac, follow
these instructions:

1. Download the correct installation file fromourweb site at www.foundry.com/products/cameratracker-
ae/download.

2. Double-click on the downloaded .dmg file.

3. Double-click on the .pkg file that is created.

4. Follow the on-screen instructions to install CameraTracker.

Licensing
You can license, or activate, CameraTracker in one of two ways:

• Licence Key—a sequence of numbers and letters stored in a plain text file that unlocks CameraTracker.

Using FLEXlm encryption, licence keys can be created for a particular computer enabling the software to run only
on that computer. These are called node locked licences. We also supply floating licences that will unlock
CameraTracker on any computer networked to a Foundry Licensing Tools (FLT) server.

Here is an example node-locked (uncounted) licence that expires on 31 July 2010 for a computer running
CameraTracker with a System ID of 00123fdb9e9f. Node-locked licences allow you to run CameraTracker on one
machine only.
INCREMENT cameratracker_ae_i foundry 1.0 31-jul-2010 uncounted \ HOSTID=00123fdb9e9f
ISSUED=30-jun-2010 TS_OK SIGN="030A 5EB4 \ FC11 3D9C B47F 3C03 6AEE 88A5 3338 ADB9
6E00 BE55 FC97 6021 \ 7AAF 82CD D2F3 3833 E5D8 4CED A3CD"

INCREMENT cameratracker_ae_r foundry 1.0 31-jul-2010 uncounted \ HOSTID=00123fdb9e9f
ISSUED=30-jun-2010 TS_OK SIGN="00C2 EE6A \ 9BBF EE0C FA43 45EB 282C 10B7 47FA 4FE3
8C01 FF47 7A39 F35E \ 8E65 8D65 7C52 3B07 E1A3 F39F 70D5"

FLT tools and a user guide to install licence keys, manage floating licences, and diagnose licence problems can be
downloaded fromour support portal at support.foundry.com.

• Activation Key—a series of numbers and letters emailed to you that activates CameraTracker.

Here is an example activation key:
ctae-0101-3733-eeda-8376-df83-7235

To authenticate CameraTracker from the After Effects user interface:

1. Click theActivation button. See Basic Controls formore information.

2. You are automatically directed to The Foundry web site log in page.

NOTE: If you’re logged in already, skip ahead to step 4.

3. Log in as normal, or sign up if you do not have a log in ID and password.

The Product Activation page displays.

INTRODUCTION | LICENSING
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4. Enter the activation key that was emailed to you in the first field provided.

5. Enter your System ID in the second field.

It is very important to check the System ID matches yourmachine before continuing, as CameraTracker will only
be licensed to the computer identified with this unique number.

NOTE: You can display your System ID by clicking on theAbout button of Foundry plug-ins running on
After Effects.

6. Click Create Licence Key.

You will receive an email containing the on-screen information.

7. Follow the on-screen instruction to install the Licence Key.

Other Foundry Products
The Foundry is a leading developer of visual effects and image processing technologies for film and video post
production. Its stand-alone products includeNuke, Modo, Mari, Hiero, Katana, and Flix. The Foundry also supplies a
suite of plug-ins, including Ocula, CameraTracker, Keylight, Kronos, and Furnace and FurnaceCore for a variety of
compositing platforms, including Adobe® After Effects®, Autodesk® Flame®, Avid® DS™, and Apple’s Final Cut
Pro®. For the full list of products and supported platforms, visit our website at www.foundry.com.

Nuke is an Academy Award®winning compositor. It has been used to create extraordinary images on scores of
feature films, including Avatar, District 9, TheDark Knight, IronMan, Quantumof Solace, The Curious Case of
Benjamin Button, Transformers, and Pirates of the Caribbean: At World’s End.

Modo brings you the next generation of 3D modeling, animation, sculpting, effects and rendering in a powerful
integrated package.

Mari is a creative texture-painting tool that can handle extremely complex or texture-heavy projects. It was
developed at Weta Digital and has been used on films, such as District 9, TheDay the Earth Stood Still, The Lovely
Bones, and Avatar.

Hiero is a collaborative, scriptable timeline tool that conforms edit decision lists and parcels out VFX shots to artists,
allowing progress to be viewed in context, and liberating your finishing systems and artists formore creative tasks.

Katana is a look development and lighting tool, replacing the conventional CG pipelinewith a flexible recipe-based
asset workflow. Its node-based approach allows rapid turnaround of high-complexity shots, while keeping artists in
control and reducing in-house development overheads. Extensive APIsmean it integrates with a variety of renderers
and your pre-existing shader libraries and workflow tools.

Flix is a collaborative, visual story-development tool. It allows directors, editors, cinematographers, storyboard
artists, and pre-visualization artists to explore ideas quickly, saving valuable time, and to easily collaborate on the
visual story development of a film.

INTRODUCTION | OTHER FOUNDRY PRODUCTS
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Ocula is a collection of tools that solve common problemswith stereoscopic imagery, improve productivity in post
production, and ultimately help to deliver amore rewarding 3D-stereo viewing experience.

CameraTracker is an After Effects plug-in allowing you to pull 3D motion tracks andmatchmoves without having to
leave After Effects. It analyses the source sequence and extracts the original camera's lens andmotion parameters,
allowing you to composite 2D or 3D elements correctly with reference to the camera used to film the shot.

Keylight is an industry-proven blue/green screen keyer, giving results that look photographed, not composited. The
Keylight algorithmwas developed by the Computer Film Company who were honoured with a technical achievement
award for digital compositing from the Academy of Motion Picture Arts and Sciences.

Kronos is a plug-in that retimes footage usingmotion vectors to generate additional images between frames.
Utilising NVIDIA’s CUDA technology, Kronos optimises your workflow by using both the CPU and GPU.

Furnace and FurnaceCore are collections of film tools. Many of the algorithms utilisemotion estimation technology
to speed up common compositing tasks. Plug-ins includewire removal, rig removal, steadiness, deflicker, degrain and
regrain, retiming, and texture tools.

INTRODUCTION | OTHER FOUNDRY PRODUCTS



Getting Started

Overview
CameraTracker is designed to provide an integrated camera tracking ormatchmoving tool which allows you to create
a virtual camerawhosemovement matches that of your original camera, all without leaving the After Effects
environment. This camera can be used for amultitude of tasks including integrating 2.5D objects in to the scene to
reducemasking and roto work, projectionmapping, andmore.

You can automatically track features, solve the position of cameras, and create a scene linked to the solve containing
a 3D camera. CameraTracker also enables you to mask out areas of the scene that you don’t want tracked, like
moving objects for example.

Bear inmind that CameraTracker requires footage from amoving camerawith sufficient parallax between features
from frame to frame in order to extract enough data to solve the 3D camera—static camera footage does not
provide enough information to solve the data correctly.

Launching
CameraTracker on After Effects acts like any other effect available on the user interface, and as such, you can access
the controls from the Effect drop downmenu or Effects & Presets panel.

NOTE: In order to get the best results, we recommend that you apply CameraTracker to your original
footage rather than footage that has been composited or processed in a fashion not designed to assist in
tracking. You should also avoid using CameraTracker on precomposited footage, as doing somay cause
the track to fail or result in other problems.

To access CameraTracker from the Effectmenu, select Effect > The Foundry > CameraTracker.

NOTE: In order to access CameraTracker from the Effectmenu, a layermust be selected in theViewer or
Timeline.

10
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To access CameraTracker from the Effects & Presets panel, select The Foundry and double-click CameraTracker,
or drag and drop the effect on to the required layer in your composition.

Quick Start
On the CameraTracker panel you can see the default settings shown below.

GETTINGSTARTED | QUICK START
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CameraTracker can automatically calculate your feature tracks, solve the camera, and create a scenewith three
button clicks, but the resultsmay not be very useful unless the layer you’re tracking is extremely simple.

To use CameraTracker on a simple layer, follow the steps below. Otherwise proceed to Using CameraTracker on page
14.

1. In the CameraTracker Effect Control Window (ECW), click Track Features, or navigate to CameraTracker
Menu > Actions > Track Features in the Viewer.

NOTE: This step can take a long time depending on the length of your composition.

2. When the track phase completes, click Solve Camera, or navigate to CameraTracker Menu > Actions > Solve
Camera in the Viewer. A dialog box displays the solve progress.

3. Click Create Scene, or navigate to CameraTracker Menu > Actions > Create Scene in the Viewer.

CameraTracker creates a camera (and a parent null object) within your composition, then you can select feature
points in the viewer to create solids or nulls at specific locations.

GETTINGSTARTED | QUICK START
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For very simple tracking problems, these three stepsmay allow you to create a tracked camera and place 3D objects
so that they ’stick’ to the required plane in the composition when viewed through the tracked camera.

Getting Help

Contacting Customer Support

Should questions arise that the documentation fails to address, you can refer to The Foundry Support Portal for
more information.

GETTINGSTARTED | GETTINGHELP

https://supportportal.thefoundry.co.uk/


Using CameraTracker

Getting the best results fromCameraTracker usually involvesmore than simply using the automatic tracking, solving,
and scene creation tools. The CameraTracker interface incorporatesmany settings that can improve your final
output, and this chapter aims to instruct you on using the tools included in the package.

CameraTracker Workflow
Camera tracking, ormatchmoving as it is sometimes known, generally occurs early on in the post-production
workflow. A typical workflow using CameraTracker can be broken down in to the following steps:

1. Tracking Features—record a layer’s feature data using the automatic tracking function. See Tracking Features
formore information.

• Mask out any areas in your sequence that you don’t want to track. SeeUsingMattes.

• Enter the tracking range and configuration. See Setting Tracking Parameters.

• Troubleshoot the feature tracks if necessary. See Fine Tuning Your Feature Tracks.

2. Solving—analyse the 2D tracking data and create an internal representation of the scene’s feature points and
camera. See Solving Your Camera Position.

• Set the solve and lens parameters including focal length and lens distortion. See Setting Camera Parameters
and Setting Lens Distortion Parameters.

• Troubleshoot the solve if necessary. See Troubleshooting Solves.

3. Creating a Scene—create a 3D scene incorporating the 3D camera position and related solid and null objects
associated with the scene. See Creating a Scene.

Successfully completing the CameraTracker workflow above creates a camera, identical to other cameras within After
Effects, that can be used in a range of techniques from simple floating text within a 3D environment to extensive
projectionmapping and high-end 2D/3D integration.

NOTE: In order to get the best results, we recommend that you apply CameraTracker to your original
footage rather than footage that has been composited or processed in a fashion not designed to assist in
tracking. You should also avoid using CameraTracker on precomposited footage, as doing somay cause
the track to fail or result in other problems.

14
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Basic Controls
CameraTracker’s basic controls show effect information, provide an activation function for licensing purposes, and
allow you to reset or turn effects on or off without removing them from layers.

Menu Bar

Themenu bar at the top of the CameraTracker panel displays the current effect and file names as well as the
following buttons.

Icon Name Description

Reveal Show or hide the current effect panel.

Effect Toggle Enable or disable the current effect to quickly view the results.

3D Though not strictly a button, this icon tells you that the current effect is a 3D feature.

Reset Return all CameraTracker settings to their default values.

Activation Click to open aweb page for activation of CameraTracker serial numbers. See Licensing for
more information.

About... Displays the About window containing information on CameraTracker.

Tracking Features
Tracking is the first stage of the camera tracking process and obtaining accurate results is crucial as subsequent
stages rely on the integrity of the initial tracking data. CameraTracker handles feature track selection for you,

USINGCAMERATRACKER | BASIC CONTROLS
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including reseeding tracks if they become unusable.

CameraTracker sometimes encounters problemswith the automatic tracking of features, for examplewhen objects
go off screen or are occluded by moving foreground objects. You can assist CameraTracker by maskingmoving
objects or by removing problem tracks using the delete track functions. SeeUsingMattes and Removing Feature
Tracks.

Using Mattes

Mattes can help to reduce processing time and eliminate unusable tracks by covering areas of the layer, allowing
CameraTracker to ignore features in certain parts of the scene. Thesemattes should generally be keyframed to allow
them to follow features as they move around the screen.

There are a couple of things to be aware of before you get started withmattes that will hopefully stop you becoming
frustrated.

1. The first thing to understand is that After Effects has a number of Channel and ColourManagement filters that
you can apply to the viewer.

TheRGB and RGB Straightmodes display mattes in different ways. While not disastrous, the differences
between the two can be extremely confusing.

Amatte around the
background building in RGB

mode.

The samemattewhen viewed
in RGB Straight.

The reason for this is that RGB Straight uses the bounding box alpha instead of thematte alpha.

2. YouMUST pre-compose yourmatte layer before you use it or CameraTracker uses the source layer without any
effects that you apply.

To use amatte on a layer:

1. Create a suitablematte and add it as a layer in the project. See your After Effects User Guide formore
information on creating and usingmattes.

USINGCAMERATRACKER | TRACKING FEATURES
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NOTE: Matte layersmust be pre-composed using Layer > Pre-Compose before they can be used by
CameraTracker.

2. Select an appropriateMatte Source from the drop downmenu, depending on thematte you are using.

TheMatte Source parameter controls how the pixel values in thematte are used to do themasking.

•None—nomatte is applied.

• Src Alpha—use the alpha of the source layer.

• Src Inverted Alpha—use the inverted alpha of the source layer.

•Matte Layer Luminance—use the luminance of thematte layer.

•Matte Layer Inverted Luminance—use the inverted luminance of thematte layer.

•Matte Layer Alpha—use the alpha of thematte layer.

•Matte Layer Inverted Alpha—use the inverted alpha of thematte layer.

3. Select thematte you created from theMatte Layer drop downmenu.

NOTE: You cannot select aMatte Layerwithout first specifying aMatte Source.

4. Select the Tracking > Preview Features checkbox to previewwhere features will track with thematte in place.

Setting the Analysis Range

TheAnalysis Range is set to Source Clip Range by default, which causes CameraTracker to analyse the entire layer
from start to finish. In some cases, however, youmay only require tracking data for specific frames.

TIP: Analysis Range is particularly useful for testing your settings on a small frame sample before
committing yourself to the potentially lengthy full feature tracking process.

To select a range for tracking:

1. Select Analysis Range > Specified Range from the drop downmenu.

2. Use the slider or enter an Analysis Start value to set which frame is the starting point.

3. Use the slider or enter an Analysis Stop value to set which frame is the ending point.

In the below example, Analysis Range is set to start at frame 5 and end at frame 15. The range is inclusive, so
both frame 5 and frame 15 will be included in the analysis.

USINGCAMERATRACKER | TRACKING FEATURES
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NOTE: TheAnalysis Range refers to the CameraTracker effect layer, not your entire composition, so you
canmove layers within your composition without invalidating your track data.

Setting Tracking Parameters

Tracking parameters are used to tailor the properties of the data you’ll capturewhen you track features on a layer.

In most cases, the default settings supplied with CameraTracker should do a good job of tracking features, but you
may want to fine tune your settings using the following guidelines.

Number of Features

As the name suggests, setting this value alters howmany features are tracked within the current layer. For extremely
simple scenes, a lower number of featuresmay be required for the solve and vice versa. As a general guideline, you
should track no fewer than 100 features formost layers.

NOTE: Bear inmind that although trackingmore features can improve your results, the process will take
longer.

The images below show examples of low and high value feature tracks.

Tracking 50 features. Tracking 300 features.

USINGCAMERATRACKER | TRACKING FEATURES
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Detection Threshold

Detection Threshold sets the distribution of tracked features over the layer. A low value selects prominent points
throughout the layer, whereas a high value selectsmore localised points in distinct regions.

TIP: Using a lowDetection Threshold can produce amore accurate solvewhen large areas of the layer are
relatively featureless.

A lowDetection Threshold value produces a
more even feature spread.

A high Detection Threshold value produces
more localised grouping.

TIP: You can select the Preview Features checkbox to preview your features before tracking.

Feature Separation

Separation determines the distribution of features in relation to each other. To force feature separation and spread
features evenly over the image at even distances, enter a high feature separation value.

TIP: Youmay consider reducing Feature Separation when you increase the number of tracked features.

A low separation value of 1. A high separation value of 100.

USINGCAMERATRACKER | TRACKING FEATURES
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Previewing Features

Select the Preview Features checkbox to preview the features that will be tracked. Preview comes in handy when
you want to tweak the tracking parameters further before tracking.

Tracking Your Features

After testing feature tracks on a small number of frames and previewing, you’re ready to track features on your
layer.

To start tracking, click the Track Features button on the CameraTracker panel, or navigate to CameraTracker
Menu > Actions > Track Features in the Viewer.

CameraTracker begins reading the frames in the layer sequentially and tracking the features present. Tracks that
encounter persistent errors are automatically reseeded—CameraTracker keeps the number of tracks constant as
specified in Tracking > Number of Features.

USINGCAMERATRACKER | TRACKING FEATURES
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When the playhead reaches the end of the layer, it begins a verifying pass by reading the frames sequentially
backwards. Any tracks that were reseeded due to error are tracked back past the point where they were created, if
they remain viable.

NOTE: Unlike the initial track, the verifying pass can increase the number of tracks past theNumber of
Tracks you specified.

Once the verification pass is complete, you can view track and point information using theDisplay drop down
menu, or point tooltips, as described below.

Viewing Tracks and Track Information

Viewing your track information can help you to decidewhether to retrack the features in the layer or just delete the
problem tracks before solving the scene. See Fine Tuning Your Feature Tracks formore information on retracking
layers and deleting tracks.

You can view your track quality or point quality using theDisplay drop downmenu. You can navigate through the
layer using the Preview panel to examine the information associated with each frame.

• Tracks—the default setting used to view tracks without colour coded quality information. After solving the
camera, tracks are colour coded red (for a rejected track), orange (for an unsolved track), and green (for a solved
track).

NOTE: All tracks are coloured orange before solving.

USINGCAMERATRACKER | TRACKING FEATURES
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• Track Quality—view the reliability of your tracks. The tracks are colour coded red (for an unreliable track), yellow
(for a potentially unreliable track), and green (for a reliable track).

• Point Quality—view the quality of your 3D points. The tracks are colour coded according to their reprojection
error figures, red being theworst and green the best.

NOTE: Reprojection error values are not available until you solve the camera.

• View Keyframe Points Only—select this checkbox to only view the keyframe points used during tracking.
CameraTracker creates these keyframe points as it tracks the layer, using the keyframes as reference points to fill in
the other tracks.

Viewing keyframe points can assist you when troubleshooting your track data because all the tracks within a layer
reference these points—if you define the keyframe pointsmore accurately, you’ll output amore refined feature
track.

You can also display the track lifetime for individual tracks by hovering themouse pointer over the track to display
the tooltip. Track lifetime refers to how persistent the track is within a layer—the higher the track lifetime, the better
the track. In the example, the highlighted track was good for 21 frameswithin the tracked layer.

USINGCAMERATRACKER | TRACKING FEATURES
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If you’re happy with the tracking results you can proceed to Solving Your Camera Position, otherwise you can adjust
your tracking data by using the fine-tuning parameters described in Troubleshooting.

Solving Your Camera Position
When you’re happy with the features that you’ve tracked, you can proceed to solving the camera. CameraTracker
uses the tracking information to internally calculate the camera position and add positional information to the
feature points in the Viewer. The first step is to adjust the parameters for your camera solve.

NOTE: The camera solve doesn’t place the camera in your composition—theCreate Scene step takes care
of the camera’s location within the layer.

Setting Camera Parameters

Camera settings relate to the physical aspects of the camera used on set. Accurate physical camera data produces a
better camera solution.

Physical camera properties in After Effects.

Focal Length Type

Select the focal length type for the camera from the drop downmenu:

• Known—select this option if the focal length is available and enter a value in the Focal Length panel.

• Approximate Varying—select this option if an approximate focal length is available and enter keyframed focal
length values in the Focal Length panel.

• Approximate Constant—select this option if an approximate focal length is available and there is no zoom, and
enter a focal length value in the Focal Length panel.

USINGCAMERATRACKER | SOLVINGYOUR CAMERA POSITION
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NOTE: If you select either of theApproximate options, CameraTracker tries to refine the focal length
during the solve.

•Unknown Varying—select this option if the focal length is unknown and changing.

•Unknown Constant—this is the default option. Use this option if the focal length is unknown and there is no
zoom.

Focal Length

The Focal Length, or distance between the film back and the lens, assists CameraTracker to emulate the on set
camera. If you don’t know the Focal Length, select Unknown Constant orUnknown Varying from the Focal
Length Type drop downmenu.

NOTE: Digital cameras often record the Focal Length for you asmetadata contained within the output.

Film Back Size

Film Back Size is the physical size of the film used or the size of the imaging sensor used in digital cameras. If you
entered a Focal Length, the film dimensions are critical for achieving accurate data.

NOTE: You can usually find these values in the Specification pages of the camera used on set, or online at
sites such as www.dpreview.com/

Select the required units from theUnits drop downmenu and enter the horizontal and vertical film or sensor size in
the Film Back Size X and Y fields.

Camera Motion

You can assist CameraTracker with the solve by selecting themotion type of the on set camera from theCamera
Motion drop downmenu.

• Rotation Only—select this option if the camera is static and rotating, for example, if you’re using a tripod
mounted camera for nodal pans.

The following images show the difference in solve quality you can achieve by selecting Free Camera and Rotation
Only on the same piece of footage. Notice the large amount of rejected tracks if Free Camera is selected?

Free Camera. Rotation Only.

USINGCAMERATRACKER | SOLVINGYOUR CAMERA POSITION
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NOTE: If you select Rotation Only, make sure that Tracking > Track Validation is also set to Rotating
Camera. See Track Validation formore information.

• Free Camera—select this option if the camera is both translating and rotating.

Creating a Solve

Once you’re happy with the physical camera and lens parameters, you’re ready to create a solve using your tracks
and camera properties.

To create the solve, click Solve Camera in the CameraTracker ECW, or navigate to CameraTracker Menu >
Actions > Solve Camera in the Viewer.

The solving process does not take as long as tracking features within a layer, but it is dependent on the number of
frames and complexity of the tracks. Once the solve completes successfully, a solve report displays.

In the image shown, CameraTracker reports that reference frame 7 was used, 5 keyframeswere used, and the total
root mean square (RMS) reprojection error ratewas 0.849 pixels.

NOTE: The Reference Frame is the point at which the camerawas located at the origin 0, 0 in 2D. This
value is significant later on—seeUsing Null Object Transforms in Compositions.

USINGCAMERATRACKER | SOLVINGYOUR CAMERA POSITION
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TIP: If your solve reports an RMS projection rate higher than 1.0 pixel, youmay want to consider fine-
tuning your solve or tracking data. See Troubleshooting formore information.

Solve camera report.

NOTE: If your tracking phasewas relatively lengthy, CameraTrackermay need some extra time to create
theRefinemenu statistics. If this is the case, a second progress bar displays the amount of time
remaining.

CameraTracker solves take less time than tracking features and should produce data similar to that shown.

Typical After Effects solve data.

TIP: Notice the red track in the lower half of the solve data shown. The data could be unreliable due to the
movement of the figure during tracking. This is a good example of when CameraTracker could benefit
frommasking features as described in UsingMattes.

You can also display track and solve data for individual tracks by hovering themouse pointer over the track to
display the tooltip.

Reprojection error report.

USINGCAMERATRACKER | SOLVINGYOUR CAMERA POSITION
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If you’re happy with the solve results you can proceed to Creating a Scene, otherwise you can adjust your solve by
using the fine-tuning parameters described in Troubleshooting.

Creating a Scene
After solving the camera, you're ready to create your scene. Create Scene produces an After Effects camera, that
you can use in conjunction with the integrated 3D object creation functions, to place various solids relative to the
camera in 3D space.

In a similar way to the previous steps, you can use CameraTracker to create the scene automatically by clicking
Create Scene, or navigate to CameraTracker Menu > Actions > Create Scene in the Viewer.

Creating a scene takes very little time—all the hard work was completed in previous steps. There is very little to see in
the After Effects Viewer when the camera is ready, but youmay notice that new camera and null layers have been
added to the Timeline.

USINGCAMERATRACKER | CREATINGA SCENE
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So where is your camera and where is it in the layer? In order to ’see’ the camerawithin the layer, you’ll have to view
things slightly differently.

You could create a new camera to view your composition, but the simplest way to view your scene is using Custom
Views.

1. In the Viewer, navigate to Select viewer layout > 2 Views - Horizontal to add a second panel to the Viewer.

The default settings display theActive Camera on the right and Top view on the left.

NOTE: TheActive Camera is always located in the highest layer of your composition. If you havemore
than one camera in your composition, select CameraTracker-Camera(1) to view your solved camera.

2. Click the left view to highlight it, then navigate to 3D View Popup > Custom View 1 to change the camera view
from Top to a customisable view.

Custom View 1 represents the solved camera CameraTracker Camera (1), but it is not fixed in place. You can
move the camera around to view your scene from any angle you choose.

The red square at the same XY coordinates as the camera represents theNull Object associated with the camera,
and the yellow highlight shows a Point of Interest (POI) marker.

NOTE: If you click Solve Camera and Create Scene again, CameraTracker attempts to update the
existing scene. If, however, you have renamed the existing camera, CameraTracker creates a new camera
and pairs it with the existing null.
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TheNull Object associated with the solved
camera and a Point of Interestmarker.

NOTE: CameraTracker creates a one-node camera, so the POI is set to the default location and provides no
real benefit. See your After Effects User Guide formore information on POI.

3. Click theUnified Camera Tool icon or press C on your keyboard to activate the camera tool.

4. Select theCameraTracker-Camera(1) layer in the composition and try moving the camera around the scene to
view different angles.

NOTE: The layer itself does not move and this can be confusing at first. Nomatter where youmove the
camera view, as with any 2D layer in After Effects, the layer will always remain front and centre.

If for any reason your camera doesn’t work, youmay have to make someparameter changes and re-solve the
camera or, in some cases, go back to the tracking stage to iron out tracking errors. See Troubleshooting formore
information.

That takes care of tracking, solving, and creating a scene. Fromhere you can set the ground plane, axes, or origin, add
your geometry (that is shapes or text), or use other After Effects features to add layers to your composition.

Alternatively, there are some third party scripts (snippets of codewhich extend After Effects functionality, but are
not supplied by After Effects or CameraTracker) that allow you to export your camera tracks to other software suites
likeMaya or Cinema 4D, but these are not covered in the scope of this User Guide.

Using the Point Cloud
The Point Cloud is a very powerful tool that enables you to view the 2D scene by examining the tracked points in 3D.
All the features that were tracked and solved during the CameraTracker workflow can be viewed, each colour coded
with the original layer colour.

TIP: You can reduce the Point Cloud size to viewmore accurate keypoints from the solve by checking View
Keyframe Points Only on the CameraTracker panel.

In this demonstration we’ll use a nice colourful scene as shown below.
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Select the image layer in your composition and the CameraTracker effect in the Effect Controls window to access
theCameraTracker Menu displayed in the bottom left of the Viewer.

NOTE: TheCameraTracker Menu is only available when the CameraTracker effect is highlighted in the
Effect Controls window.

NOTE: Youmay notice that CameraTrackerMenu selections can be slow, especially onWindows
platforms. To avoid this, try holding down the left mouse button in themenu, locating the option you
require and releasing to complete the selection.

To start using the Point Cloud, follow these simple steps:

1. Navigate to CameraTracker Menu > Actions > Toggle 2D/3D,

OR

Press Tab on your keyboard to toggle between 2D and 3D.
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The Point Cloud displays in the Viewer.

From the camera’s point of view, the cloud is not very useful. Point Clouds really come in to play when viewed
using After Effects custom cameras, so you can really get ’into’ the 3D scene.

2. Navigate to 3D View Popup > Custom View 1 and select theCameraTracker-Camera(1) layer in your
composition.

The Point Cloud and custom camera perspective are now displayed on screen.

3. Click theUnified Camera Tool on the After Effects interface,

OR

Press C on your keyboard to activate the camera tool.

4. Click and drag the camera tool around to view the scene.
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No. Item Description

1 View Shows the camera’s current view.

2 Track The track that the camera follows through the scene. Each square represents one
frame in the layer.

3 POI The scene’s Point of Interest.

4 Camera and
Null

The camera and associated null.

5 Control Unified Camera Tool used to control cameramovement.

Youmay notice that the tracked points lose resolution as you drag around the scene. This is due to the Fast
Previews default setting within After Effects.

If you want to retain resolution duringmovement, navigate to Fast Previews > Off.

5. You can select points in 2D by dragging amarquee or holding down Shift and clicking individual points then view
them in 3D.

The following images show the same points selected in 2D and 3D. By moving the custom camera around the
scene, it’s quite easy to see that the points selected are on the same plane.
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Once youmaster using the Point Cloud, you’ll find the other topics in this chapter, such as Setting theGround Plane
and Adding Solids to Your Composition, relatively simple to achieve.

Setting the Ground Plane
A tracked camera has no notion of where the ground plane is in the layer, and so it, and any associated 3D objects,
can be at an unexpected offset and angle relative to wherewe expect the ground to be in 3D space. Essentially the
camera has a different frame of reference to us, which canmakeworking in the 3D environment confusing at first.

Setting the ground plane, origin, or set of axes is designed to provide CameraTracker with a sensible frame of
reference. While doing so is not strictly necessary, it can simplify working in the 3D environment.

Before placing the ground plane, scan through your layer to find a framewith good track and solve data in an area
that you know to be at ground level. Hover over likely points to display the track and solve data, and use the Point
Cloud to guide you when selecting suitable points.

TIP: Bear inmind that setting a ground plane over a number of points in the scene creates a ’best fit’ plane
and, crucially, translates the camera to make use of the new plane.
If you don’t want the camera to move or placing a ground plane is proving tricky, youmight consider using
an origin and setting individual axes as described later on in this chapter.

1. Drag amarquee over the required points or hold down the Shift key and click individual points. The example
shows a scenewith five good ground level points selected.

2. Once you’ve selected your points, navigate to CameraTracker Menu > Ground Plane > Set to Selected.

USINGCAMERATRACKER | SETTING THE GROUND PLANE



34

NOTE: TheCameraTracker Menu is only available when the CameraTracker effect is highlighted in the
Effect Controls window.
Youmay notice that CameraTracker Menu selections can be slow, especially onWindows platforms. To
avoid this, try holding down the left mouse button in themenu, locating the option you require and
releasing to complete the selection.

CameraTracker uses the points you selected as the ’ground’ when adding layers to your composition.

You can also add points to the ground plane calculation fromother frames in the layer to help refine the results:

1. Set a ground plane as described previously.

2. Play through the layer to locate points to add to the ground plane.

3. Select the features and navigate to CameraTracker Menu > Ground Plane > Set to Selected.

The points are added to the ground plane.

Setting the Origin

Defining the origin within a layer can assist you when placing objects in your composition—if you knowwhere 0, 0, 0
is located, you can easily place objects precisely where you want themon any axis.

NOTE: Unlike setting a ground plane over a set of points, defining an origin does not translate the camera
position.

1. Select a single track as an origin point from your feature and solve data and navigate to CameraTracker Menu
> Ground Plane > Set Origin.

The image shows a track selected for CameraTracker to use as the X, Y, Z origin.
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2. Switch to the Point Cloud and use custom view on the scene. Notice that the CameraTracker Null hasmoved to
the point you selected.

Setting Independent Axes

In some compositions, youmay not have a clearly defined ground plane to reference. Using CameraTracker, you can
set the X, Y, and Z axes separately instead of grouping themon the ground plane.

NOTE: Unlike setting a ground plane over a set of points, defining an origin and independent axes does
not translate the camera position.

1. Set an Origin within the scene as described in Setting theOrigin.

2. Select theOrigin and a point that you know to be on the required axis, or use the Point Cloud to assist you.

3. Navigate to CameraTracker Menu > Ground Plane > Set X, Y, or Z depending on the points selected.

The example shows theOrigin and one vertically aligned track selected as reference points for CameraTracker to
use for the Y axis.

Resetting Planes, Axes, and Origins

Adding planes, axes, or an origin can greatly improve your 2D/3D integration but, in some cases, youmight end up
with toomany points selected within your composition. You can reset all point and plane data by navigating to
CameraTracker Menu > Ground Plane > Reset.
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Adding Solids to Your Composition
At this point, you can use the camera you’ve created, as you would any other After Effects camera, for all manner of
applications. However, the CameraTrackerMenu can still help you to add solids and nulls to your composition.

You can add solidsmanually by right-clicking in the left Timeline panel and selectingNew > Solid... but positioning
them inside the camera’s field of vision at the desired position can be time consuming. CameraTracker provides an
automatic solid creation function to help you achieve the results you need.

1. Select points on the plane that will hold the solid by hovering over likely features to locate suitable points.

TIP: Using the Point Cloud can really help you locate the best points available on any plane. SeeUsing the
Point Cloud formore information.

2. Drag amarquee over the required points or hold down the Shift key and click individual points.

NOTE: The following example uses three points, but youmay need to select more depending on the track
and solve data.

3. Navigate to CameraTracker Menu > Create > Solid (or press S) to add a default solid to the composition.

4. CameraTracker default solids are red, have an opacity of 50%, and depending on the points you selected, may be
quite large as shown in the example.

5. Select the solid in the timeline and use the solid handles in the viewer to adjust the size of the solid so that it fits
on the plane of the building.
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6. Youmay notice that the solid is slightly skewed on the Z axis in the example. Use the solid’s Transform > Z
Rotation to align the solid with the edge of the building.

7. Next, use the solid handles in conjunction with the Z Rotation and axis handles to adjust the solid so that it fills
the side of the building.

8. Using the dual views described in Creating a Scene you can view the solid from any angle using theCustom
View 1 camera.

The same solid viewed from 2 angles.
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Asmentioned previously, although the cameramoves around the scene, the 2D layer is fixed in place and
doesn’t relate to the cameramovement. In the exmaple, the custom camera is ’looking’ down on the scene and
as a consequence, the solid appears lower in the scene and further away from the camera.

9. Switching to 3D and viewing the solid and Point Cloud together ismore informative.

The 3D view can help you determinewhere your solid really is—hovering in space, or 'stuck' to thewall as
desired. You can also select the tracked camera so as to see its field of view and positions in subsequent frames,
and play through the sequence and see things change in 3D.

10. The final step is to check that there is no ’slipping’ between the scene and the solid. The best way to do this is to
play the composition using the Play button in the Preview panel.

The only real way to verify your results is to view the solid with the naked eye andmake a judgement based on
your experience.

Unparenting Solids: Absolute vs. Relative Transforms

Solids and nulls created using theCameraTracker Menu > Createmenu are parented to theCameraTracker
Null object by default and any translation, rotation, and scale changes applied are relative to this null. These objects
can be described as residing in a relative coordinate space. This is so that the overall scene scale, orientation, and
origin can be set both before and after creating objects, using theCameraTracker Null.

If you wanted to copy position transforms from a created object to another object, for example a text layer, solid, or
null, youmust ensure the source object’s position, rotation, and scale parameters are in absolute space. To do this,
unparent the solid before copying its parameters:

1. Using the solid and null twirlies, reveal both Position parameters. If you compare the xyz values, you’ll notice a
considerable difference.
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The null’s positional coordinates are absolute, rather than relative like the solid.

2. Using the solid’s Parent dropdownmenu, select None.

Notice the solid’s position values have changed?

Moving the solid around the scenewhen it is un-parented produces an absolutemove, rather than amove
relative to the null object.

Once the data copy is complete you can re-parent the solid and, if necessary, the new object to the
CameraTracker Null to return them to relative coordinate space. You can then control the overall scene
position, rotation and scale changes.

Using Null Object Transforms in Compositions
CameraTracker 3D objects are created relative to the tracked camera, and as a result, any offset, scale, or rotation
transform applied to both the camera and objects will have no effect when viewing the composition through the
tracked camera—everything will still be in the right place.

When you use theCreate Scene button, CameraTracker creates a tracked camera and automatically parents it to a
null object. Once you've completed the CameraTracker workflow and are happy with your scene, you can use the
automatically generated null associated with the camera to control the offset, scale, and rotation of elements added
to your composition.

Applying an additional transformusing the null can be useful in many contexts. For example:

• You can adjust the scale of the 3D scene to approximately match that of the real world.

• If automatic ground plane setting is problematic, the null can be used tweak the position of the tracked camera
relative to the ground plane.
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• Sometimes, youmay have already created a 3D environment. The null can then be used to reconcile that
environment and the camera tracker environment.

• If a CameraTracker scene is added to a pre-existing 3D environment, nulls can be used to reconcile the offset, scale,
and rotation of elements between the two scenes.

Creating Multiple Nulls

Creating compositions can be a very time consuming process, and using shortcuts during your workflow can be the
difference between success and failure. If you’re going to be placing and translating a large number of objects in your
scene, youmay consider usingMultiple Null Objects. The only limit on the number of nulls you can create is the
number of tracked features in your scene.

Bear inmind that there is a significant difference between creatingmultiple and single nulls across points:

• Creatingmultiple nulls acrossmultiple points attaches a null to each point ’facing’ the camera.

• Creating a single null acrossmultiple points averages the coordinates from the points you selected and places the
null at ’best fit’ coordinates.

To createmultiple nulls on selected tracked features:

1. Select the tracks in your scene that will anchor the nulls and navigate to CameraTracker Menu > Create >
Multiple Null Objects (or press F).

2. CameraTracker places nulls at each selected track.

NOTE: If you place a single null across the same points, the result would be quite different.
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Accounting for Lens Distortion
You can use CameraTracker’s lens distortion features to account for lens distortion in your footage. Often, what you
want to do is add CG images to your footage and distort those images so that they match the lens distortion in the
footage.

The best practice for doing this is to apply CameraTracker to your footage, add the CG images, and apply lens
distortion to the CG images. Do the following:

1. Use Track Features to track the features in your footage. See Tracking Features.

2. Set Lens Distortion parameters to automatically estimate ormanually adjust the lens distortion of the camera
used to shoot your footage. See Setting Lens Distortion Parameters.

This allows you to calculate the camera for the undistorted footage.

3. Use Solve Camera to create a solve. See Creating a Solve.

4. UseCreate Scene to produce an After Effects camera that you can use in conjunction with the integrated 3D
object creation functions to place a solid relative to the camera in 3D space. See Creating a Scene.

5. Create the solids, text, or CG elements you want to add to your original footage.

6. Select the objects you created in the previous step and theCameraTracker-NullObject(1) and
CameraTracker-Camera(1) layers in the composition.

7. Then, navigate to Layer > Pre-compose. In the Pre-compose dialog, selectMove all attributes into the
new composition and clickOK.

In the composition, you should now only see the Pre-comp 1 layer and the original footage you applied
CameraTracker to. The Pre-Comp 1 layer allows you to process both the original footage and the created
objects together.
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8. Next, you need to copy the CameraTracker effect. You’re going to use this copy to apply lens distortion to the
objects in your Pre-Comp. To copy the effect, first select the original footage in the composition and the
CameraTracker effect in the ECW.

Navigate to Edit > Copy. Then, select the Pre-Comp (1) layer and navigate to Edit > Paste.

9. In the ECW, expand the Lens Distortion group and check Redistort.

That’s it! You have now added objects to your tracked footage and distorted them tomatch the lens distortion in
the original footage.

NOTE: If your footage has a very large amount of lens distortion, CameraTrackermay not be able to track
or solve the footage. If this is the case, set the Lens Distortion drop down to Known Lens in the ECW
and check Undistort to flatten the footage. Tweak the Lens Distortion parameters by eye to get the
correction close. Then, apply another CameraTracker effect and use that to track and solve the flattened
footage. You should create your 3D scene, camera and elements using the second, solving CameraTracker.
When you're done, precompose your 3D elements, and then copy and paste the first CameraTracker effect
onto the precomposed layer, and check Redistort to distort it. If your eyeballed correction is close but not
quite there, you can also set the second CameraTracker toUnknown Lens to get it to estimate the final
part of the correction.

NOTE: If CameraTracker is able to track and solve your footage but the lens distortion estimate that it
comes up with is poor, set Lens Distortion to Refine Known Lens in the ECW. Then, adjust the other
Lens Distortion parameters until your footage looks about right whenUndistort is checked, and hit
Solve again.

Setting Lens Distortion Parameters

Lens Distortion

Lens Distortion is used to select the type of lens used on set. Select the lens type from the drop downmenu.

•No Lens Distortion—disables all lens distortion controls and treats the footage as having no distortion.

• Known Lens—allows you to specify the lens distortionmanually for the camera solve.
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• Refine Known Lens—gives you a chance to give an approximate distortion to use but attempts to refine it in the
camera solve.

•Unknown Lens—calculates the lens distortion automatically from the sequence and then refines the distortion in
the camera solve.

If you chose eitherKnown Lens orRefine Known Lens, enter values for the Lens Type, Radial Distortion,
Distortion Centre controls and, if necessary, theAnamorphic Squeeze and Asymmetric Distortion controls.

Lens Type

You can select the type of lens used on set from the drop downmenu allowing CameraTracker to compensate for
the selected type. The equations used to account for lens distortion are quite complex, but using these guidelines
you should be able to output undistorted layers fromdistorted layers.

• Spherical—compensates for different spherical lenses. This is the simpler of the two lens corrections and uses the
following equation:

Xu and Xd are equal to the same point in an undistorted plate and a distorted plate respectively.

d1 is equal to Radial Distortion 1

d2 is equal to Radial Distortion 2

r2 is equal to the distance of the point from the distortion centre

r4 is equal to the square of r2

• Anamorphic—compensates for anamorphic lenses. Anamorphic correction uses three additional parameters (Ax,
Ay, and Asq) and requires two equations because, unlikewith spherical lenses, the amount of distortion parallel to
the x-axis is not the same as that parallel to the y-axis.

(xu, yu) and (xd, yd) are equal to the same point in an undistorted plate and a distorted plate respectively.

d1 is equal to Radial Distortion 1

d2 is equal to Radial Distortion 2

r2 is equal to the distance of the point from the distortion centre

r4 is equal to the square of r2

Ax is equal to Asymmetric Distortion X

Ay is equal to Asymmetric Distortion Y

Asq is equal to Anamorphic Squeeze
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Lens Parameters

You canmanually enter physical lens characteristics depending on which Lens Type you selected.

• Radial Distortion 1 (d1)—defines the first radial distortion term. This is proportional to r2, where r is the distance
from the distortion centre.

• Radial Distortion 2 (d2)—defines the second radial distortion term. This is proportional to r4, where r is the
distance from the distortion centre.

• Distortion Centre (r2, r4)—defines the values for the centre of the radial distortion on the X and Y axes.

• Anamorphic Squeeze (Asq)—defines the anamorphic squeeze value. If you select an anamorphic lens, the
Distortion Centre on the X axis is scaled by this amount.

• Asymmetric Distortion (Ax, Ay)—defines distortion for anamorphic lenses. Enter values to define asymmetric
distortion to correct for slight misalignments betweenmultiple elements in the lens.

•Undistort—check this to view your footage undistorted.

• Redistort—check this to view your footage distorted.
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Troubleshooting

Unless the composition you’re working on is extremely simple or ideal for tracking, troubleshooting your tracks and
solves is a necessary part of the CameraTracker workflow. Effective troubleshooting can improve your end result
immeasurably and can be the difference between a good 3D result and a composition with slipping elements.

Knowing when to refine tracking or solving is also an important concept. If your scene doesn’t create successfully,
the solvemay be faulty and some fine-tuningmay be necessary. Bear inmind, though, bad solves are often the
result of bad feature tracks—if it seems that no amount of solve fine-tuning is improving your results, try going back
to square one and refining and retracking the layer.

Overview
So, you’ve gone through the camera tracking workflow, but you want to improve the quality of the result you’re
getting. The first thing to do is to figure out where the problem lies: the tracking, the solving, or the scene creation.

Bear inmind that a problem in one stage of the process can be caused by any of the earlier stages. If you create a
solid and get unexpected results, thismay be caused by a bad solve or bad feature tracks. If you have a bad solve,
thismay be caused by bad feature tracks.

The following table attempts to illustrate the troubleshooting process. The recommended workflow is to go to the
step where you have a problem and work your way up from there.
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Workflow
Step

Result Troubleshooting Method Potential Solutions

1. Track
Features

2D tracks Play through the sequence in the 2D
View and look at the tracks in the
Viewer. See if any tracks slip, jump, or
seem too short.

Have a look at the Track statistics
under theRefine group. SeeUsing the
Refine Group.

Use the Track Finder to locate poor
tracks. SeeUsing the Track Finder.

If only a few of the tracks seempoor, you
can delete those tracks, give precedence to
tracks that you know are good, set
thresholds for the tracks, and click Solve
Camera again. See Removing Feature
Tracks, Giving Precedence to Good Feature
Tracks, and Track and Solve Thresholds.

If you have a lot of poor tracks, adjust the
Tracking parameters or add amatte, and
start again by clicking Track Features. See
Setting Tracking Parameters, UsingMattes,
and Retracking Features.

2. Solve
Camera
and Create
Scene

Camera,
null, and
point
cloud

Have a look at the Solve statistics under
theRefine group. Using the Refine
Group.

Use the Track Finder to evaluate the
quality of the solve. SeeUsing the Track
Finder.

Play through the sequencewhile looking
at the Point Cloud in the 3D View. See if
any points slip. See Playing through the
Sequence.

Look at the 3D scene from a Custom
View,move around the scene, and see if
any feature points are offset from the
rest.

Create a grid on the ground plane. See
Creating a Grid on theGround Plane.

Remove bad tracks, give precedence to
tracks that you know are good, adjust the
Solve parameters (Keyframe Separation
in particular), and/or set thresholds for the
solve, and click Solve Camera again. See
Removing Feature Tracks, Giving Precedence
to Good Feature Tracks, Setting Camera
Parameters, Keyframes, and Track and Solve
Thresholds.

Of course, the problem could also be in the
tracking stage of the process. Proceed to
troubleshooting tracks.
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Workflow
Step

Result Troubleshooting Method Potential Solutions

3. Create
Objects

Solids,
nulls, text,
etc.

Select some points, create a solid, and
see if the solid looks as you’d expect.
Creating a Solid.

If the solid looks wrong but isn’t moving
around over the course of time, try
troubleshooting the solve.

If the solid ismoving around over the course
of time, you’ve probably got a bad track
rather than just a bad solve. Try
troubleshooting the track.

Examining Your Feature Tracks
In addition to looking for bad tracks in the 2D View, the following tools can assist you when you’re troubleshooting
tracks:

• TheRefine group, in conjunction with theGraph Editor, provides detailed statistics on track and solve data across
the entire composition, helping you to locate problematic frameswithin the scene.

TheRefine group also lets you set minimumandmaximum thresholds for the tracks and the solve. Any tracks that
fall outside these thresholds are automatically rejected.

• The Track Finder examines individual frames that you have identified using theRefine group and Graph Editor.
After locating the problem features, you can remove them and begin reprocessing your data.

Using the Refine Group

TheRefine group in the ECW contains animated parameters calculated after tracking and after solving. These
parameters allow you to view various quality measures from the tracking and the solving phase, enabling you to
troubleshoot and refine the resultant camera. You can also view the animated parameters using theGraph Editor in
After Effects.

The parameters are divided in to two groups: Track statistics and Solve statistics. As the names suggest, each group
is used during a particular phase.

Bear inmind that the Track and Solve statistics are only meant for viewing information on track and solve data in the
composition. The values here are not meant to be edited - indeed, doing so has no effect on the final result and will
just confusematters.

If you want to affect the values, you can use the Threshold controls underRefine to set minimumandmaximum
thresholds for the tracks. Any tracks that fall outside these thresholds are rejected and displayed in red. You can
then click theDelete Rejected button at the bottomof theRefine group to delete all such tracks in one go.

TROUBLESHOOTING | EXAMININGYOUR FEATURE TRACKS



48

If you want to delete all unsolved feature tracks (that is, tracks that don’t have a valid 3D point after solving), you can
also click theDelete Unsolved button in the bottomof theRefine group.

If necessary, you can refresh the statistics by navigating to CameraTracker Menu > Tracks > Refresh Stats (or by
pressing R). This updates everything underRefine (including the thresholds, which by default are set to the
minimumandmaximum values that exist in your track and solve data).

Track Statistics

Track statistics can only be used after you have tracked your initial composition. To access statistics in theGraph
Editor:

1. Click theGraph Editor toggle in After Effects.

2. Select your composition and press the After Effects hotkey U to display the currently animated parameters
associated with that layer. Often this just displays the animated statistics, as theremay not be any other
animated parameters.

• Track-Points displays the total count of feature points over the track phase. Large variations from the number set
in the tracking parameters allows you to see possible tracking issues.

• Track-Lifetime-Min displays the shortest lifetime, in frames, of any track point on the current frame. Very short
tracks are likely to be poor quality and are good candidates for removal.

• Track-Lifetime-Avg displays the lifetime of all track points, in frames, present on the current frame, averaged
together. Look out for significant drops in this valuewhich can indicate a significant number of track points being
reseeded. You could try matting on the frame to remove potentially troublesome regions, and then retracking.
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• Track-Distance-Avg displays the total distance the track points havemoved from the previous frame to the
current frame, averaged together. Large variations in the average distance could indicate tracking problems.

• Track-Distance-Max displays themaximumdistance a track point hasmoved from the previous frame to the
current frame. Used in conjunction with Track Distance-Avg, this graph can be used to look out for track points
being influenced by nearby features. Look out for a spike in themaximumdistancemeasurement, while the
average stays fairly constant.

Solve Statistics

Solve statistics can only be used after you have solved your camera, but they can be accessed in the sameway as
Track statistics.

• Solve-Keyframe displays frames used as a keyframe by the solve process: 1 for keyframes, 0 for those not used
as a keyframe.

NOTE: The Keyframe statistics only show you whether or not a frame is a Keyframe. The number of
Keyframes can increase or decrease depending on theKeyframe Separation setting.

• Solve-Overall Error displays the total solve error, as reported in the post solve dialog box. The value is recorded
here for reference.

• Solve-Margin of Error indicates frameswhere outlying pointsmay have caused possible solve errors. Higher
values represent a greatermargin of error.
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• Solve-Per Frame Error-Avg represents the general quality measure of the solve over time. It’s calculated as the
average of all the solve errors for the points present on the current frame (the errormeasure on the tracks is a
snapshot, rather than constant average over the lifetime of the track point).

• Solve-Per Frame Error-Max displays themaximum value of all the solve errors for the points present on the
current frame (again, a snapshot not an average). Look out for a spike in themaximumdistancemeasurement,
while the average per frame stays fairly constant. This could indicate possible outliers which need cleaning up.

• Solve-Per Track Error-Max displays themaximum value of all the solve errors for the points present on the
current frame, averaged over the course of the track lifetimes. High values could indicate feature points which are
generally bad over their lifetime (as opposed to thosewhich spike in the Per Frame Error-Max graph).

Once you’ve located the possible problem areas, you can use the Track Finder to locate the offending tracks in
individual frames, or set minimumandmaximum thresholds for the tracks and delete any tracks that fall outside
these thresholds.

NOTE: If you track and solve your footage, then re-track the footage, and refresh the statistics by selecting
CameraTracker Menu > Tracks > Refresh Statistics, the solve statistics get reset to 0. This is to avoid
displaying outdated solve statistics.
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Track and Solve Thresholds

In addition to viewing the statistics as described above, you can use the following controls to set minimumand
maximum thresholds for the tracks and the solve. Any tracks that fall outside these thresholds are automatically
rejected and displayed in red. You can easily delete themby clickingDelete Rejected.

• Threshold-Track-Lifetime-Min sets the shortest acceptable lifetime of track points. This ismeasured in frames.
For example, if you set the threshold to 3, any tracks that only exist for one or two frames are automatically
rejected. This allows you to easily reject any very short tracks, which are likely to be of poor quality.

• Threshold-Track-Distance-Max sets themaximumdistance a track point canmove fromone frame to the next
without being rejected. This ismeasured in pixels. For example, if you set this to 80, CameraTracker rejects any
tracks where the track point moves 81 pixels ormore between two adjacent frames.

• Threshold-Solve-Frame Error-Max sets themaximumacceptable value of all the solve errors for the points
present on any one frame (the errormeasure on the tracks is a snapshot, rather than constant average over the
lifetime of the track point). This allows you to reject tracks that may not be generally bad over their lifetime but do
go wrong at some point in time.

• Threshold-Solve-Track Error-Max sets themaximumacceptable value of all the solve errors for the points
present on any one frame, averaged over the course of the track lifetimes. This allows you to reject tracks that are
generally bad over their lifetime.

NOTE: By default, the thresholds are set to theminimumandmaximum values in your track and solve
data. If you useCameraTracker Menu > Tracks > Refresh Stats (or press R) to refresh the statistics,
the thresholds are also refreshed.

Using the Track Finder

CameraTracker is supplied with track finding tools to help you locate good and bad feature tracks after tracking and
after solving. Features which don't have a valid 3D point after solving (the tracks highlighted in red) are automatically
deselected by the track finder.

NOTE: All Track Finders can be accessed from CameraTracker Menu > Track, or by using their
hotkeys.

Pre-Solve Finder:
• Cycle Track Distance Selection—navigate to CameraTracker Menu > Track, or press E on your keyboard to
select the feature point on the current framewith the greatest difference in track distance between this frame and
the last. Subsequent presses cycle down through the track distances on points in the current frame.

This allows you to easily select the points which havemistracked (judged using the statistics report and Graph
Editor) and delete them. This is only available once you've tracked.
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NOTE: On the first frame, all the tracks have a distance of 0. This is because there is no previous frame to
compare to.

Post Solve Finder:
• Cycle Per Track Error Selection—navigate to CameraTracker Menu > Track, or pressQ on your keyboard to
select the feature point on the current framewith the greatest per track error. Subsequent presses cycle down
through the per track errors on points on the current frame.

This allows you to easily select the points with the greatest solve error over their track lifetime (on frames judged
using the statistics report and Graph Editor) and delete them.

• Cycle Per Frame Error Selection—navigate to CameraTracker Menu > Track, or pressW on your keyboard to
select the feature point on the current framewith the greatest per frame error.

Subsequent presses cycle down through the per frame errors on points on the current frame. This allows you to
easily select the points with the greatest snapshot solve error (on frames judged using the statistics report and
Graph Editor) and delete them.

TIP: You can deselect all the tracks you have currently selected by pressing Esc on your keyboard.

Removing Feature Tracks

CameraTracker allows you remove tracks completely if they’re causing problems for the solve. You can:

• Select and remove tracksmanually. See Removing TracksManually.

• Delete all unsolved tracks in one go. See Removing All Unsolved Tracks.

• Set thresholds for acceptable tracks and delete any tracks that fall outside these thresholds. See Removing Tracks
that Fall outside Set Thresholds.

• Create amatte to prevent entire areas frombeing tracked. SeeUsingMattes.

Removing Tracks Manually

To remove feature tracksmanually:

1. Drag amarquee over the required points in the Viewer or hold down the Shift key and click individual points. If
you find it difficult to select individual tracks by clicking on the track point x, you can enableAllow Line
Selection in the ECW.

2. PressDelete on your keyboard to remove your selections,

OR

Navigate to CameraTracker Menu > Tracks > Delete Selected to remove your selections.
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NOTE: The CameraTrackermenu is only available when the CameraTracker effect is highlighted in the
Effect Controls window.
Youmay notice that CameraTrackerMenu selections can be slow, especially onWindows platforms. To
avoid this, try holding down the left mouse button in themenu, locating the option you require, and
releasing to complete the selection (rather than clicking to bring themenu up and then clicking to select).

TIP: You can also change theDisplaymode so that the Viewer displays Track Quality to locate theworst
per track error points before deciding which tracks to delete. See Viewing Tracks and Track Information.

Instead of deleting selected tracks from the Viewer, consider using a keyframedmatte to prevent entire regions from
being tracked. This is often better than deleting tracks from the Viewer because a poor track in one area can cause
CameraTracker to incorrectly estimate themotion in the footage and producemore poor tracks in the neighbouring
areas. Formore information on creating and usingmattes, see UsingMattes.

Removing All Unsolved Tracks

To remove all unsolved feature tracks, click theDelete Unsolved button in the CameraTracker controls. This
removes all tracks that don’t have a valid 3D point after solving.

Removing Tracks that Fall outside Set Thresholds

You can use theRefine group in the CameraTracker controls to set thresholds for acceptable tracks and then click
theDelete Rejected button to remove all tracks that fall outside these thresholds. This is described inmore detail
under Track and Solve Thresholds.

Giving Precedence to Good Feature Tracks

In addition to removing poor feature tracks, you can select a track and navigate to CameraTracker Menu > Tracks
> Toggle Verified Track (or press T) to toggle whether it is a verified track. A verified track ismarked with a yellow
circle. It is treated differently in the solve phase, and given precedence over non-verified tracks when building the
cameramodel and path. This allows you to clean up tracks by selecting a number of points you can actively see are
good and not slipping, and toggling on their verified state.
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Fine Tuning Your Feature Tracks
Inevitably some layers that you track will produce results that contain toomany errors to be used for a solve. The
following parameters are designed to fine tune your tracks if the automatic track data is inadequate.

You can use these settings to fine tune your tracks then re-examine themusing theRefine group and Track Finder
to really get the best results fromCameraTracker.

Track Threshold

CameraTracker’s tolerance to change along the track is determined by the Track Threshold parameter. Reducing
this thresholdmakes trackingmore tolerant to image changes, potentially producing longer tracks. When used in
conjunction with Preview Features you can adjust this value to test whether a track is reliable over time.

Tracksmarked in red suggest that the current settingsmay need some fine tuning.

Track Smoothness

Track Smoothness can be useful in preventing poor tracks in complex sequences. Increase the smoothness value to
remove tracks that error over time. In the examples, you can see that the higher value removes some tracks in the
lower left of the layer and a number of tracks are shorter as a result of smoothing.

A low smoothness value. A high smoothness value.

TIP: You can select the PreviewFeatures checkbox to preview your features before tracking.
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Track Consistency

The consistency value defines how inconsistent a feature track can be before CameraTracker discards it and reseeds
in a different location. Higher values allow for less inconsistency.

The examples show low and high consistency values. Notice that the higher value loses some tracks in the
highlighted area.

Low consistency value of 0.1. High consistency value of 1.

Track Validation

Validation determines what type of cameramovement CameraTracker should compensate for while tracking
features. Use the Free Camera and Rotating Camera options to test tracks against the expectedmotion of the
camera.

• Free Camera—compensates for a freely moving camera that is rotating and translating. This is the default
validation setting.

• Rotating Camera—compensates for a static camera that is rotating only, for example nodal pan shots.

If your tracking results appear as shown in the example, with no Y axis translation, youmay want to select
Rotating Camera and retrack.
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NOTE: If you select Rotating Camera, make sure that Solve > Camera Motion is also set to Rotation
Only. See CameraMotion formore information.

•None—do not validate tracks based on any particular cameramovement.

TIP: Youmight want to use theNone validation option if you need a larger number of tracks and want to
keep all tracks in the image.

Retracking Features

Once you’ve fine tuned your feature tracks and removed any problem tracks, click Track Features to retrack your
layer.

When you attempt to retrack a layer, After Effects displays awarning to stop you overwriting your previous data.

Click Yes to replace your existing tracks orNo to retain your previous tracking data and cancel retracking.

Troubleshooting Solves
To troubleshoot and improve the solve, you can:

• Use the Solve Statistics and Track Finders to identify problems. SeeUsing the Refine Group formore
information.

• Create a grid on the ground plane, play through the clip, and see if the ground plane slips. See Creating a Grid on
theGround Plane formore information.

• Change the keyframe parameters and re-solve. See Keyframes formore information.

Creating a Grid on the Ground Plane

Provided you are able to set a ground plane in your scene, creating a grid on the ground plane can help you judge the
quality of the solve. Do the following:

1. Set a ground plane if you haven’t already. See Setting theGround Plane.

2. Navigate to Layer > New > Solid to create a large solid.

The solid comes in as a 2D layer.
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3. To make the solid a 3D layer, click on the 3D Layer column in the composition.

4. Under Transform, set the solid’sX Rotation to -90.0 degrees. This should put the solid on the ground plane.

5. Select the solid in your composition and navigate to Effect > Generate > Grid. This applies a grid effect to the
solid.

6. Adjust the Grid controls as necessary. For example, it may be helpful to set Size From toWidth Slider.

7. Move through the sequence and compare the grid against the plane it’s set on (rather than anything above that
plane).

Keyframes

During a solve, CameraTracker automatically selects a subset of frames, called keyframes, that describe the camera
motion within the layer. Keyframes are usually positioned relatively far apart so that there is sufficient parallax in the
images to define 3D points for the tracks. This enables a better definition of the 3D points andmakes the solvemore
accurate.

If you find that the automatic solve isn’t acceptable, you can use the Solve Statistics and Track Finders to
troubleshoot and try changing the keyframe parameters and re-solving the camera.
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Keyframe Separation

The separation value between keyframes can be tailored to specific layers if the default value of 0.30 is not
satisfactory.

• High separation values generate fewer keyframeswith a greater spread and are typically used for slower camera
motion.

• Low values generatemore keyframeswith a tighter spread and are typically used for rapid cameramotion.

To solve using keyframes:

1. Enter the required Keyframe Separation.

2. Enter aReference Frame to use as the first keyframe in the solve.

TIP: You should choose aReference Frame with a large number of tracks and variations in depth
distributed throughout the frame.

3. Select the Set Reference Frame checkbox to confirm your selections.

4. Select aKeyframe Accuracy from the drop downmenu.

NOTE: A higher accuracy takes longer to solve but it can improve the result when you’re working with a
long sequence.

5. Enable Three Frame Initialization to force CameraTracker to use 3 initial frames to begin the solve, rather
than 2, to help correct distorted solves. Trying different reference frameswith this option can be particularly
effective to correct complex solves.

6. Click Solve Camera to re-solvewith the newKeyframe Separation value, or navigate to CameraTracker
Menu > Actions > Solve Camera in the Viewer.

Bear inmind that a poor solve can also be a result of poor tracking data. If you’ve fine-tuned your solve and the
results are still unsatisfactory, go back and refine your feature tracks to try and improve the results.

Troubleshooting Using the Point Cloud
The CameraTracker Point Cloud displays your track points in 3D space from the point of view of the solved camera
and is a very useful tool for troubleshooting. You can use it in at least two ways:

• You can play through the sequence and view the feature points as they would be seen by the solved camera. If any
feature points seem to slip between frames, they’remost likely producing bad results. Formore information, see
Playing through the Sequence.

• You can also select some points, create a solid, and use theUnified Camera Tool to move around the scene on
one frame. If the solid does not look like you’d expect and you can see that one of the points is way off in the
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distance relative to other points, it’s safe to assume that you’ve found a bad feature point. Formore information,
see Creating a Solid.

TIP: You can reduce the Point Cloud size to viewmore accurate keypoints from the solve by checking View
Keyframe Points Only on the CameraTracker panel.

Playing through the Sequence

If your footage has elements that are easy to identify in the Point Cloud, simply looking at the tracked points in the
3D viewwhist playing through the clip can help you locate bad points.

To try this out, once you’ve created your scene, click Toggle 2D/3D in the CameraTracker controls to switch to the
3D View. Make sure that the active camera is the camera created in the scene: CameraTracker-Camera(1). You
should now see the Point Cloud from the point of view of the solved camera.

Next, selectWindow > Preview to bring up the After Effects play controls. Go to the first frame in your clip and hit
the play button. As the Point Cloudmoves through the sequence, try to identify the different elements in your
footage and keep an eye out for any points that slip. If you see a point that moves to where it shouldn’t be, you’ve
located a bad track point.

NOTE: If your footage doesn’t have elements that are easy to identify in the Point Cloud (for example, if all
the elements in the footage are pretty much the same colour), it may be difficult to seewhere the points
should be and whether they slip. If this is the case, you can try troubleshooting the Point Cloud by creating
a solid and using theUnified Camera Tool to move around the scene, as described in Creating a Solid.

TIP: Youmay also be able to spot poor feature points by looking at individual frames and pressing Tab
repeatedly to switch between the 2D and 3D Views.

Creating a Solid
Using CameraTracker Menu > Create > Solid sometimes produces unpredictable results and the Point Cloud is
extremely useful to troubleshoot which features are causing the error.

To demonstrate this, let’s create an inaccurate solid and use the Point Cloud to fine-tune the result. Bear inmind that
the points selected in this example are purposefully inadequate—in reality you wouldn’t select these points to create
a solid.

The example shows the points selected from the scene created by CameraTracker.
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The points selected previously produce the following solid in After Effects.

As you can see, the solid is enormous and not what you would expect from good point selection. To troubleshoot
the solid using the Point Cloud, do the following:

1. Switch the viewer to 2 Views - Horizontal and select Custom View 1 in the left panel (Creating a Solve for
more information).

2. Navigate to CameraTracker Menu > Switch Mode 2D/3D or press Tab to toggle between 2D and 3D.

In Custom View 1, you can see immediately that one of the points selected is way off in the distance relative to
the other 4 points.

3. Use theUnified Camera Tool to move around the scene in order to locate the spurious point. Themost
informative view of the Point Cloud in this example is directly in front and slightly above the scene, as shown.
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In this example, the bad point is clearly the track that follows themoving figure in the centre of the selected
points.

4. Deselect the bad point in the 3D View and recreate the solid without that point to improve the solid.

Admittedly, the new solid is still pretty bad—repeat the Point Cloud troubleshooting steps asmany times as
required to produce a good solid.

NOTE: In the above example, the solid looked wrong but wasn’t moving around over the course of time. If
you create a solid and see that it’s moving around in away it shouldn’t be, you’ve probably got a bad track
rather than just a bad solve or scene. Try troubleshooting the track. If only a few tracks slip, you can delete
those tracks and/or use Toggle Verified Track to give precedence to tracks that you know are good.
Then, solve your footage again. If a lot of tracks slip, youmay want to go right back to the beginning,
adjust the tracking parameters and/or add amatte, and retrack the footage.

TIP: In addition to creating solids, you can also create null objects to troubleshoot your tracks and solves.
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Tutorials

Introduction
Welcome to CameraTracker Tutorials! If you’ve reviewed the previous chapters in this guide—which we highly
recommend—you already know something about CameraTracker’s capabilities. These tutorials show how to pull
everything together through a series of practical examples.

NOTE: These tutorials assume that you are reasonably familiar with the After Effects interface and basic
compositing theory.

The Projects
• Tutorial 1: Setting a Ground Plane—an example of setting a ground plane badly, then using the Point Cloud to
correct the problem.

• Tutorial 2: Adding an Object to a Layer—a basic run through of creating a text banner in the 3D scene.

• Tutorial 3: Correcting a Troublesome Solve—some simple troubleshooting steps designed to help you correct
difficult solves.

Example Images

Before you continue, download the tutorial files from The Foundry web site www.foundry.com andmove them to a
directory you’ll create, called “CameraTracker_Tutorials”.

NOTE: Youmay need to unzip the files before you can use them.

It’s up to you where you put the tutorial files, but bear inmind that you’ll need themduring these tutorials.
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Tutorial 1: Setting a Ground Plane
In this tutorial, we’ll select some points in our layer to create a Ground Plane, examine the points using the Point
Cloud, and refine the selection to improve the final results.

Preparing the Workspace

First, you’ll set up theworkspace and apply CameraTracker as an effect on a layer:

1. Launch After Effects as normal and navigate to File > Import > File.

2. Navigate to the folder containing the tutorial files and open the Tutorial1_01.jpg file (After Effects imports the
entire contents of the folder automatically).

3. Drag and drop the content from the Project tab to theViewer and click the image to select the layer.

4. Navigate to Effect > The Foundry > CameraTracker.

5. The CameraTracker panel displays in the Effect Controls Window (ECW).
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The next step is to track features within the layer, create a solve, and place the solved camerawithin the layer.
For the purpose of these tutorials, we’ll use the default settings for tracking, solving, and creating a scene, simply
because they work well with the sample images provided.

6. On the CameraTracker panel, click Track Features, or navigate to CameraTracker Menu > Actions > Track
Features in the Viewer.

NOTE: The layer used in this tutorial should track quickly due to its simplicity.

7. When the track phase completes, click Solve Camera, or navigate to CameraTracker Menu > Actions > Solve
Camera in the Viewer.

8. Click Create Scene, or navigate to CameraTracker Menu > Actions > Create Scene in the Viewer.

Once you’ve created a virtual 3D camera in your layer, you’re ready to select some track points and create a Ground
Plane.

The first step when preparing to select Ground Plane points is to get a good feel for the layer that you intend to use.
Play through the layer in 2D and 3D using the Point Cloud and try to locate points that:

• appear to be on the correct plane or ’ground’ in the layer,

• are as consistent as possible throughout the layer,

• haveminimal solve reprojection errors per frame.

For the purposes of this tutorial, we’ll marquee a broad selection to start with, then refine the selection using the
Point Cloud.

1. Drag amarquee over some points around the lawn area shown in the image. Don’t worry if your points are not
exactly the same as the ones illustrated—someof these points are purposefully poor.
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2. Navigate to CameraTracker Menu > Ground Plane > Set to Selected.

NOTE: Youmay notice that CameraTrackerMenu selections can be slow, especially onWindows
platforms. To avoid this, try holding down the left mouse button in themenu, locating the option you
require and releasing to complete the selection.

3. CameraTracker highlights the points that you selected to represent theGround Plane and shows the new
position of theNull associated with the solved camera.

4. Switch to the 3D Point Cloud using Custom View 1 and activate theUnified Camera Tool by pressing C on your
keyboard.
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5. Select theCameraTracker-Camera(1) layer in your composition andmove around the scene to view the new
Ground Plane. If you align theNull vertically and the grid horizontally, you should see a camera view similar to
that shown below.

You can tell immediately that the camera view point is severely skewed and the yellow and blue points that
represent theWendy House are positioned at an unnatural angle.

The points producing the skew aremost likely those located in the right of the shot, so let’s remove those and
see if the results improve.

6. Navigate to CameraTracker Menu > Ground Plane > Reset.

7. Reselect your points, excluding those positioned in the bushes, and on the slide, and set the Ground Plane.

8. Switch to the Point Cloud andmove around the scene to check your points.

Again, align theNull vertically and the grid horizontally, you should see a camera view similar to that shown
below.

A great improvement on the original Ground Plane. Fromhere you can experiment by adding and removing
points to produce the best results.
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Of course, you don’t have to useGround Planes to represent ’the ground’ in your scene. If your composition calls for
a lot of vertical positioning, why not set your Ground Plane on the side of a building or even the ceiling of a room?

Tutorial 2: Adding an Object to a Layer
In this tutorial, we’ll be adding an object to the 3D scene along the path of the camera. The result won’t be pretty,
that’s up to you to refine, but it should give you a feel for working within a 3D scene.

First, you’ll set up theworkspace as described in Preparing theWorkspace, but in step 2 import the Tutorial2_01.jpg
files instead.

Once you’ve created a virtual 3D camera in your layer, you’re ready to add objects to the scene.

Creating a Reference Solid

Creating a solid as a reference point in CameraTracker is an excellent starting point before placing other objects
within a composition. Solids created in this way are automatically aligned with the tracked features you select.

The first task is to locate likely features to fix the object to in 3D space. The Point Cloud is very useful for checking
tracked points within the composition.

1. Play through the composition in 2D and 3D mode a couple of times to get a feel for the tracked features. Try to
select points that are consistent throughout the layer.

2. The two points we’re going to use to position our solid are shown below in both 2D and 3D space. Select the
points by holding Shift and clicking each point.

Tracked points in 2D space. The same 2 points in 3D space
using the Point Cloud.

NOTE: The red rectangle in the images represents theNull associated with the solved camera.

3. Navigate to CameraTracker Menu > Create > Solid to produce a default solid using the two points we
selected.

NOTE: Youmay notice that CameraTrackerMenu selections can be slow, especially onWindows
platforms. To avoid this, try holding down the left mouse button in themenu, locating the option you
require, and releasing to complete the selection.
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4. Adjust the solid so that the edges are aligned with the pillar in the scene.

You can use the X, Y, and Z handles (the coloured arrows) to determine the correct positioning of the solid.

NOTE: Use Transform > Y Rotation in this case, though in other circumstances you’ll probably need the
other Transform tools as well.

5. Play through the composition and check that the solid doesn’t slip between frames. In this example, the solid is
pretty good so you won’t need to make any adjustments.

Importing and Placing an Object

Now that you have a solid reference point, we can import and place an object using the solid as a guide.

1. Right-click in the Project tab and select Import > File.
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2. You can import any file in to your composition, but for the purposes of this tutorial, import the Poster.png
image supplied with the Tutorial2 files.

Next, we’ll use a handy After Effects hotkey to swap the imported object for the reference solid.

3. Select the Poster.png object and theCameraTracker-Solid(2) layer in the composition.

4. Press cmd (or ctrl onWindows) + alt / to swap the object and the solid,

OR

Hold alt then click and drag Poster.png over theCameraTracker-Solid(2) layer in the composition.

The object is placed on the plane that the solid occupied, but as you can see, the rotation and scale need some
work.

5. Open up the Poster.png layer Transform controls in the composition.

6. Use the Scale and Rotation controls to position the object so that it appears on the pillar.

You should find that settings similar to those shownwill position the poster nicely.
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7. Finally, click the ’eye’ icon to turn off theNull layer to clean up the final result.

Play through the composition to check that your final result produces no slippage, and we’re done!

Tutorial 3: Correcting a Troublesome Solve
Tracking and solving a camera isn’t always as simple as clicking three CameraTracker buttons. At some stage in your
career using CameraTracker, you’ll come across a scene that requires some fine-tuning to produce a usable result. In
this tutorial, we’ll track a layer that won’t solve and then run through some steps to correct it.

First, you’ll set up theworkspace as described in Preparing theWorkspace, but in step 2 import the Tutorial3_01.jpg
tutorial files instead.

1. The CameraTracker panel displays in the Effect Controls Window (ECW).
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2. We’ll start off with the default Tracking and Solve parameters—on the CameraTracker panel, click Track
Features, or navigate to CameraTracker Menu > Actions > Track Features in the Viewer.

You can tell immediately that there is something strange going on in the scene just by looking at the lengthy
diagonal tracks across the Viewer.

3. When the track completes, click Solve Camera, or navigate to CameraTracker Menu > Actions > Solve
Camera in the Viewer.
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The solve cannot complete on this sample footage, probably because there are one or two tracks that are
throwing out the other features during the solve.

There are a number of ways we can fix the solve and improve the results, themost common being locating and
covering the areawhere the tracks originatewith amatte or finding and removing bad tracks. Themethod you
choosewill largely depend on the time you have available—searching through track data to locate bad feature points
can be time consuming.

Using a Matte to Hide Bad Tracks

Using amatte to cover areas where you know the track data is bad is a quick fix, but can reduce the accuracy of solve
data. You could use thismethod if you’re short of time or patience!

The first thing to do is view the track statistics for the composition:

1. Click theGraph Editor toggle in After Effects.

2. Select your composition and press the After Effects hotkey U to display all the statistics associated with that
layer.

If you examine the results, you should see at frame 11 a large spike in the Track Distance - Max.

3. Advance the playhead to frame 11 to view the tracked features.
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Looking at the top of the composition, in the centre of the frame, you can see a group of three extremely long
tracks. These aremost likely to blame!

Next, we’ll create an animatedmatte and add it to the composition to cover the area during the tracking phase.

4. Right-click in your composition and select New > Solid to add a basic shape that we canmould into ourmatte.

The Solid Settings dialog displays.

5. Set the colour to white and clickMake Comp Size so that the solid fills the screen.

6. ClickOK to add the solid to the composition.

7. By default, the solid is placed at the top layer of the composition, so drag and drop it under the Tutorial3_
01.jpg layer.

8. Next, select the Pen Tool or pressG on your keyboard.

9. Move the playhead to frame 14 and draw a roughmatte shapewhere you think the faulty tracks are seeded.
Something like this should beOK:
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NOTE: We’ve chosen a red outline for ease of illustration—the default After Effects colour is yellow.
In reality, you would probably not want to matte such a large area throughout the scene because you
would lose a lot of good data along with the bad.

10. Drill down through theWhite Solid 1 layer toMask Path and click the stopwatch to place a keyframe.

11. Scrub the playhead to frame 10 and adjust thematte so that it still covers the area shown.

12. Select theWhite Solid 1 layer and navigate to Layer > Pre-compose.

The Pre-Compose dialog displays.
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13. SelectMove all attributes into the new composition and clickOK.

Next, we’ll tell CameraTracker how to use ourmatte.

14. Open up the CameraTracker ECW and selectMatte Source >Matte Alpha.

NOTE: We choseMatte Alpha because themattewe created is white. If themattewas black, wewould
chooseMatte Inverted Alpha.

15. SelectMatte Layer >White Solid 1 Comp 1.

16. Click Track Features to retrack the layer with thematte in place. Click Yes in thewarning box.

If you pay close attention, youmay be able to seewhere thematte is stopping tracks from seeding.

17. When the retrack has completed, check the track statistics again and scrub the playhead to the framewith the
highest errors.

Notice that there are still some long diagonal tracks on frame 11? We should be able to do something about
those in the next section.
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Locating and Removing Bad Tracks

Eliminating bad tracking data is an excellent way to fix a failing solve, if you have the time available. Unlike using
mattes, deleting specific tracks doesn’t remove good tracks along with the bad.

1. The track statistics did a good job of highlighting frame 11, so we’ll start there. Use the Preview panel in After
Effects to play through the layer frame-by-frame.

2. Scrub to frame 11 and select the two diagonal tracks as shown. Navigate to CameraTracker Menu > Tracks >
Delete Selected or press delete on your keyboard.

NOTE: Youmay find selecting the points easier if you enableAllow Line Selection on the ECW.

Scrub through the layer andmake sure there are nomore obviously bad tracks.

3. Refresh the track statistics by navigating to CameraTracker Menu > Tracks > Refresh Stats. Notice that the
error peak at frame 11 has been smoothed out?

4. As a final precaution, we’ll reduce theKeyframe Separation to 0.10 as shown.
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5. Click Solve Camera to attempt the solve again.

The solve should completewith a similar reprojection error to that shown below.

6. ClickOK to view the solved tracks. You can use the track finder to examine the re-projection errors of individual
tracks. See Examining Your Feature Tracks formore information.

NOTE: Youmay notice that CameraTracker has rejected a couple of tracks. When this occurs, you cannot
view reprojection errors for these tracks.
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A total RMS reprojection error of 0.296 is pretty respectable, but feel free to play around with the track and
solve settings asmuch as you like!

The real test of accuracy for any solve and scene is to add objects to your composition and verify that they don’t slip
from frame to frame. Try adding the poster from Tutorial 2: Adding an Object to a Layer to this scene to really show
how the refined solveworks.

TUTORIALS | TUTORIAL 3: CORRECTINGA TROUBLESOME SOLVE



Appendix A: Third Party
Licences

Third-Party Licences
This appendix lists third party libraries used in CameraTracker, along with their licences.

Library Description Licence

Boost Source code
function / template
library

Boost Software Licence - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or
organisation obtaining a copy of the software and accompanying
documentation covered by this licence (the “Software”) to use,
reproduce, display, distribute, execute, and transmit the Software, and
to prepare derivative works of the Software, and to permit third-parties
to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement,
including the above licence grant, this restriction and the following
disclaimer, must be included in all copies of the Software, in whole or in
part, and all derivative works of the Software, unless such copies or
derivative works are solely in the form of machine-executable object
code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUTWARRANTYOF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUTNOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE
COPYRIGHTHOLDERSOR ANYONEDISTRIBUTING THE SOFTWARE BE
LIABLE FOR ANYDAMAGESOROTHER LIABILITY, WHETHER IN
CONTRACT, TORTOROTHERWISE, ARISING FROM, OUTOF OR IN
CONNECTIONWITH THE SOFTWAREOR THEUSEOROTHER DEALINGS
IN THE SOFTWARE.
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Library Description Licence

Expat XML parser Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd
and Clark Cooper

Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
“Software”), to deal in the Softwarewithout restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicence, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUTWARRANTYOF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUTNOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORSOR COPYRIGHTHOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGESOROTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORTOROTHERWISE, ARISING FROM, OUTOF OR IN
CONNECTIONWITH THE SOFTWAREOR THEUSEOROTHER DEALINGS
IN THE SOFTWARE.

FreeType Font support Portions of this software are copyright © 2008 The FreeType Project

(www.freetype.org). All rights reserved.
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Library Description Licence

FTGL OpenGL support FTGL - OpenGL font library

Copyright © 2001-2004 Henry Maddocks ftgl@opengl.geek.nz

Copyright © 2008 SamHocevar sam@zoy.org

Copyright © 2008 SeanMorrison learner@brlcad.org

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
“Software”), to deal in the Softwarewithout restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicence, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, subject to the
following conditions

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUTWARRANTYOF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUTNOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORSOR COPYRIGHTHOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGESOROTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORTOROTHERWISE, ARISING FROM, OUTOF OR IN
CONNECTIONWITH THE SOFTWAREOR THEUSEOROTHER DEALINGS
IN THE SOFTWARE.
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Library Description Licence

VXL Computer vision Copyright © 2000-2003 TargetJr ConsortiumGE Corporate Research
and Development (GE CRD) 1 Research Circle Niskayuna, NY 12309 All
Rights Reserved Reproduction rights limited as described below.

Permission to use, copy, modify, distribute, and sell this software and
its documentation for any purpose is hereby granted without fee,
provided that (i) the above copyright notice and this permission notice
appear in all copies of the software and related documentation, (ii) the
name TargetJr Consortium (represented by GE CRD), may not be used
in any advertising or publicity relating to the softwarewithout the
specific, prior written permission of GE CRD, and (iii) any modifications
are clearly marked and summarized in a change history log.

THE SOFTWARE IS PROVIDED “AS IS” AND WITHOUTWARRANTYOF
ANY KIND, EXPRESS, IMPLIED OROTHERWISE, INCLUDING WITHOUT
LIMITATION, ANYWARRANTYOF MER- CHANTABILITYOR FITNESS FOR
A PARTICULAR PURPOSE. IN NO EVENT SHALL THE TAR- GETJR
CONSORTIUM BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECTOR
CONSEQUENTIAL DAMAGESOF ANY KIND OR ANYDAMAGES
WHATSOEVER RESULTING FROM LOSSOF USE, DATAOR PROFITS,
WHETHERORNOT ADVISED OF THE POSSIBILITYOF SUCH DAMAGES,
ORON ANY THEORYOF LIABILITY ARISING OUTOF OR IN CONNEC-
TIONWITH THEUSEOR PERFORMANCEOF THIS SOFTWARE.
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Appendix B: End User License
Agreement (EULA)

END USER LICENSE AGREEMENT (EULA)
PLEASE READ THIS EULA CAREFULLY BEFOREORDERING ORDOWNLOADING ORUSING ANY SOFTWARE
PRODUCTSOF FOUNDRY. YOUR ATTENTION IS PARTICULARLYDRAWN TO: (A) CLAUSE 8 INWHICH SUBSCRIPTION
CUSTOMERS AGREE TO THE AUTO-RENEWAL OF THEIR LICENSEON AN ANNUAL BASIS; (B) CLAUSES 14 AND 15
WHEREWE LIMIT OUR LIABILITY TOUSERSOF OUR SOFTWARE PRODUCTS; AND (C) CLAUSE 18.2 REGARDING THE
DATAWEMAY COLLECT AND HOWWEMAYUSE IT.

IMPORTANTNOTICE TO ALL USERS: BYDOWNLOADING AND/OR USING THIS SOFTWARE YOU ACKNOWLEDGE
THAT YOU HAVE READ THIS EULA, UNDERSTAND IT AND AGREE TOBE BOUND BY ITS TERMS AND CONDITIONS. IF
YOU DONOT AGREE TO THE TERMSOF THIS EULADONOTDOWNLOAD, INSTALL, COPYOR USE THE SOFTWARE.

IMPORTANTNOTICE TO CONSUMERSWHOPURCHASE SOFTWARE PRODUCTS DIRECT FROM FOUNDRY: YOU HAVE
THE RIGHT TO CANCEL YOUR CONTRACT AND OBTAIN A FULL REFUND IN ACCORDANCEWITH CLAUSE 9.
HOWEVER YOU WILL LOSE THIS RIGHTONCE YOU INSTALL THE SOFTWAREOR LOGIN TO A LOGIN-BASED LICENSE.
THIS DOES NOT AFFECT YOUR CONSUMER RIGHTS IN RELATION TODEFECTIVE PRODUCTSOR SERVICES.

This END USER LICENSE AGREEMENT ("EULA") is, in cases where you purchase our product(s) direct from Foundry,
incorporated into the agreement between The Foundry Visionmongers Ltd a company registered in England and
Wales with company number 4642027 and whose registered office is at 5 Golden Square, LondonW1F 9HT,
("Foundry"), and you, as either an individual or a single company or other legal entity ("Licensee") on the terms of
which you will purchase the products and services of Foundry (the “Agreement”). In cases where you purchase our
product(s) fromone of our resellers, the use of the term “Agreement” in this EULA refers to the arrangements
between Foundry and Licensee on which Licensee is permitted to use Foundry’s product(s), including this EULA.

Foundry reserves the right to refuse to grant a License (as defined in clause 1.1) to any Licenseewho has failed to
pay any sumdue either to Foundry or to a reseller of Foundry, in connection with the Agreement, in connection with
any other software license to use any Software product(s) of Foundry and/or in connection with any Maintenance
and Support Agreement as defined in clause 8.5.
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1. GRANT OF LICENSE

1.1 Subject to terms and the scope of the applicable licencemodel as set out in clause 2, the limitations of clause 3
and all the other terms of the Agreement, Foundry grants to Licensee a limited, non-transferable (subject to clause
2.1(b) below) and non-exclusive license to download, install and use amachine readable, object code version (subject
to clauses 3 and 4 below) of the software program(s) purchased by Licensee (the "Software") and any accompanying
user guide and other documentation (the "Documentation"), solely for Licensee's own internal purposes (the
"License"); provided, however, that Licensee's right to download, install and use the Software and the
Documentation is limited to those rights expressly set out in this EULA.

1.2 Some types of licensemodels set out in clause 2.1 limit the installation and use of the Software to the country in
which Licensee is based at the date of purchase (the “Home Country”), unless otherwise agreed in writing.
Notwithstanding such limits, Licenseemay still use the Software outside theHomeCountry if traveling or working
outside theHomeCountry on a temporary basis provided that such use does not exceed 70 days in aggregate in any
rolling twelvemonth period or, in the case of any licensewhich lasts for less than twelvemonths, does not exceed
the number of days representing 20% of the term of the license.

1.3 Only to the extent that is proportionate to, and reasonably necessary to support, Licensee’s licensed use of the
Software in accordancewith the Agreement, Licenseemay (provided valid license keys or license entitlements have
been obtained) install the Software onmore than one computer, provided always that Licensee’s concurrent use of
different installations of the Software does not exceed the number of valid Licenses that Licensee has paid for or
licensed (as applicable).

2. LICENSE MODELS

2.1 For each Software product that you purchase from Foundry, the product will be licensed (and not sold) to you on
the terms of one ormore of the licensemodels set out in this clause 2.1 and clause 2.2 as specified in Foundry’s
invoice or order confirmation (as applicable), and subject to the other terms and conditions of this EULA. Please note
that some licensingmodels set out below do not apply to certain Software products of Foundry. Whichever licensing
model applies, Licensee shall not at any one time usemore copies of the Software than the total number of valid
licenses purchased by Licensee.

(a) “Node Locked License”

If Licensee purchases a Node Locked License, Licenseewill install and use only a single copy of the Software on only
one computer at a time, whichmay be located anywhere in theHomeCountry.

(b) “Modo Individual License”

If Licensee purchases aModo Individual License then: (a) Licenseewarrants and represents that Licensee is a natural
person and that only Licenseewill use the Software; (b) Licenseemay transfer or assign (“transfer”) theModo
Individual License to another natural person (“Assignee”) subject to Licensee: (i) notifying Foundry of such transfer
and obtaining Foundry’s express written consent, (ii) paying an administrative feewith respect to such transfer as
may be required by Foundry, and (iii) after transferring a single copy of the Software to the Assignee, deleting any

APPENDIX B: END USER LICENSE AGREEMENT (EULA) |



85

copies of the Software that Licenseemay have in Licensee’s possession, custody or power; (c) Licensee shall not
share its login details for the Softwarewith any third party (d) Licensee shall be entitled to use the Software on
different computers whichmay be located anywhere and use is not restricted to theHomeCountry; (e) use of the
Software shall be limited to nomore than one concurrent use at all times.

(c) “Floating License”

If Licensee purchases a Floating License, use of the Softwaremay be at any site in theHomeCountry.

(d) “Login-Based License”

If Licensee purchases a Login-Based License, Licenseewarrants and represents that Licensee is a natural person and
that only Licensee shall use the Software. Licenseewill be issued with log in details andmay use the Software on any
number of computers (but not simultaneously).

(e) “Modo Subscription License”

If Licensee purchases a License forModo on a subscription basis then the provisions of clause 8 shall apply.

(f) “Mari Individual Subscription License”

If Licensee purchases an Individual License forMari on a subscription basis then: (a) Licenseewarrants and
represents that Licensee is a natural person and that only Licenseewill use the Software; (b) Licensee shall not share
its login details for the Softwarewith any third party; (c) Licenseemay use the Software on different computers
whichmay be located anywhere and use is not restricted to theHomeCountry; (d) Licensee’s use of the Software
shall be limited to nomore than one concurrent use at all times; (e) Licensee shall not purchase or usemore than one
Mari Individual Subscription License; and (f) the provisions of clause 8 shall apply.

(g) “Rental Licence”

If Licensee has purchased a Licence on a rental basis, the License shall be limited to the term of the rental as agreed
in writing with Foundry after which it shall automatically expire.

(h) “Educational License”

If Licensee has purchased the Software on the discounted terms of Foundry’s Educational Policy published on its
website (the “Educational Policy”), Licenseewarrants and represents to Foundry as a condition of the Educational
License that: (i) (if Licensee is a natural person) he or she is a part-time or full-time student at the time of purchase
and will not use the Software for any commercial, professional or for-profit purposes; (ii) (if the Licensee is not a
natural person) it is an organization that will use the Software only for the purpose of training and instruction, and
for no other purpose, and (iii) Licenseewill at all times comply with the Educational Policy (as such policy may be
amended from time to time). Unless the Educational License is a Floating License, Licensee shall use the Software on
only one computer at a time.

(i) “Non-Commercial License”

If the License is a Non-Commercial License, Licenseewarrants and represents that Licensee is a natural person, that
they will only access and/or use one copy of a Non-Commercial License for personal, recreational and non-
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commercial purposes and that only Licenseewill use the Software. Under a Non-Commercial License, Licenseewill
not use the Software: (a) in conjunction with any other copies or versions of the Software, under any type of License
model; (b) for any commercial, professional, for-profit and/or on-sale purpose or otherwise to provide any
commercial service(s) to a third party (whether or not for financial or other reward and including for education,
instruction of or demonstration to any third party for commercial purposes); (c) in the course of any employment or
business undertaking of Licensee; (d) on any commercial premises during business hours (except where use of the
Software is solely for a personal, recreational, educational or other non-commercial purpose); and/or (e) to create
any commercial tools or plug ins.

(j) “Modo Steam Edition”

A version of Modo with limited functionality as described in theDocumentation is available to purchase on discount
terms through Valve Corporation’s Steam store. If Licensee has purchased such version, Licenseewarrants and
represents to Foundry as a condition of the Agreement that: (i) Licensee is a natural person; and (ii) Licenseewill use
the Software strictly through Steam and only for personal, recreational and non-commercial use, except only that if
Licensee uses the Software to create assets and content Licenseemay sell such assets and content through Valve’s
SteamWorkshop.

(k) “Modo indie” and “Mari indie”

Variants of Modo andMari with limited functionality as described in theDocumentation are available to purchase on
discount terms through Valve Corporation’s Steam store. If Licensee has purchased such a variant, Licenseewarrants
and represents to Foundry as a condition of the Agreement that: (i) Licensee is a natural person; or (ii) Licensee is an
entity in the direct ownership of a single natural person; (iii) Licenseewill only access and/or use one copy of either
variant; and (iv) only Licenseewill use the Software.

(l) “Trial License”

Licenseemay register for a “Trial License” of the Software (not available for all products or in all regions ormarkets).
A Trial License lasts a limited specified period on the expiry of which the Softwarewill automatically cease to
function. Licenseewill use the Software on only one computer at a time.

(m) “Subscription License”

Any reference to a Subscription License shall mean aModo Subscription License or aMari Individual Subscription
License, as the casemay be.

2.2 If Licensee has purchased a License that permits “non-interactive” use of the Software (“Headless Rendering”),
Licensee is authorized to use a non-interactive version of the Software for rendering purposes only (i.e. without a
user, in a non-interactive capacity) and shall not use such Software on workstations or otherwise in a user-interactive
capacity. Headless Rendering is not available on all products. In all cases except Modo (in respect of which there is no
limit on the amount of Headless Rendering allowed), Headless Rendering licenses are limited to one computer such
that the number of computers on which Headless Rendering can be carried out is limited to the number of valid
Licenses that have been purchased.
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3. RESTRICTIONS ON USE

Please note that in order to guard against unlicensed use of the Software, a license key is required to
access and enable the Software. Licensee is authorized to use the Software inmachine readable, object code
form only (subject to clause 4), and Licensee shall not: (a) assign, sublicense, sell, distribute, transfer, pledge, lease,
rent, lend, share or export the Software, the Documentation or Licensee's rights under this EULA; (b) alter or
circumvent the license keys or other copy protectionmechanisms in the Software or reverse engineer, decompile,
disassemble or otherwise attempt to discover the source code of the Software; (c) (subject to clause 4) modify,
adapt, translate or create derivative works based on the Software or Documentation; (d) use, or allow the use of, the
Software or Documentation on any project other than a project produced by Licensee (an "Authorized Project") or
to provide a service (whether or not any charge ismade) to any third party; (e) allow or permit anyone (other than
Licensee and Licensee's authorized employees to the extent they areworking on an Authorized Project) to use or
have access to the Software or Documentation; (f) copy or install the Software or Documentation other than as
expressly provided for in this EULA; or (g) take any action, or fail to take action, that could adversely affect the
trademarks, servicemarks, patents, trade secrets, copyrights or other intellectual property rights of Foundry or any
third party with intellectual property rights in the Software (each, a "Third Party Licensor"). For purposes of this
clause 3, the term "Software" shall include any derivatives of the Software.

Unless Licensee has purchased an Individual License or a Login-Based License, if the Software ismoved fromone
computer to another, the issuing of replacement or substituted license keys is subject to and strictly in accordance
with Foundry’s License Transfer Policy, which is available on Foundry’s website and which requires a fee to be paid in
certain circumstances. Foundry may from time to time and at its sole discretion vary the terms and conditions of the
License Transfer Policy.

4. SOURCE CODE

Notwithstanding that clause 1 defines “Software” as an object code version and that clause 3 provides that Licensee
may use the Software in object code form only:

4.1 if Foundry has agreed to license to Licensee (including by way of providing SDKs, upgrades, updates or
enhancements/customization) source code or elements of the source code of the Software, the intellectual property
rights in which belong either to Foundry or to a Third Party Licensor (“Source Code”), Licensee shall be licensed to
use the Source Code as Software on the terms of this EULA and: (a) notwithstanding clause 3 (c), Licenseemay use
the Source Code at its own risk in any reasonable way for the limited purpose of enhancing its use of the Software
solely for its own internal business purposes and in all respects in accordancewith this EULA; (b) Licensee shall in
respect of the Source Code comply strictly with all other restrictions applying to its use of the Software under this
EULA as well as any other restriction or instruction that is communicated to it by Foundry at any time during the
Agreement (whether imposed or requested by Foundry or by any Third Party Licensor);

4.2 to the extent that the Software links to any open source software libraries (“OSS Libraries”) that are provided to
Licenseewith the Software, nothing in the Agreement shall affect Licensee’s rights under the licenses on which the
relevant Third Party Licensor has licensed theOSS Libraries, as stated in theDocumentation. To the extent that Third
Party Licensors have licensed OSS Libraries on the terms of v2.1 of the Lesser General Public License issued by the
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Free Software Foundation (see http://www.gnu.org/licenses/lgpl-2.1.html) (the “LGPL”), thoseOSS Libraries are
licensed to Licensee on the terms of the LGPL and are referred to in this clause 4.2 as the LGPL Libraries. Foundry
will at any time during the three year period starting on the date of the Agreement, at the request of Licensee and
subject to Licensee paying to Foundry a charge that does not exceed Foundry’s costs of doing so, provide Licensee
with the source code of the LGPL Libraries (the “LGPL Source”) in order that Licenseemay modify the LGPL
Libraries in accordancewith the LGPL, together with certain object code of the Software necessary to enable
Licensee to re-link any modified LGPL Library to the Software (the “Object”); and

4.3 notwithstanding any other term of the Agreement, Foundry gives no express or implied warranty, undertaking or
indemnity whatsoever in respect of the Source Code, theOSS Libraries (including the LGPL Libraries), the LGPL
Source or theObject, all of which are licensed on an “as is” basis, or in respect of any modification of the Source Code,
theOSS Libraries (including the LGPL Libraries) or the LGPL Sourcemade by Licensee (“Modification”). Licensee
may not use theObject for any purpose other than its use of the Software in accordancewith this EULA.
Notwithstanding any other term of the Agreement, Foundry shall have no obligation to provide support,
maintenance, upgrades or updates of or in respect of any of the Source Code, theOSS Libraries (including the LGPL
Libraries), the LGPL Source, theObject or any Modification. Licensee shall indemnify Foundry against all liabilities and
expenses (including reasonable legal costs) incurred by Foundry in relation to any claim asserting that any
Modification infringes the intellectual property rights of any third party.

5. BACK-UP COPY

Licenseemay store one copy of the Software and Documentation off-line and off-site in a secured location within
theHomeCountry that is owned or leased by Licensee in order to provide a back-up in the event of destruction by
fire, flood, acts of war, acts of nature, vandalism or other incident. In no event may Licensee use the back-up copy of
the Software or Documentation to circumvent the usage or other limitations set forth in this EULA.

6. OWNERSHIP

Licensee acknowledges that the Software (including, for the avoidance of doubt, any Source Code that is licensed to
Licensee) and Documentation and all related intellectual property rights and other proprietary rights are and shall
remain the sole property of Foundry and the Third Party Licensors. Licensee shall not remove, or allow the removal
of, any copyright or other proprietary rights notice included in and on the Software or Documentation or take any
other action that could adversely affect the property rights of Foundry or any Third Party Licensor. To the extent
that Licensee is authorized to make copies of the Software or Documentation under this EULA, Licensee shall
reproduce in and on all such copies any copyright and/or other proprietary rights notices provided in and on the
materials supplied by Foundry hereunder. Nothing in the Agreement shall be deemed to give Licensee any rights in
the trademarks, servicemarks, patents, trade secrets, confidential information, copyrights or other intellectual
property rights of Foundry or any Third Party Licensor, and Licensee shall be strictly prohibited fromusing the name,
trademarks or servicemarks of Foundry or any Third Party Licensor in Licensee's promotion or publicity without
Foundry's prior express written approval.

Subject to clause 4.3, Foundry undertakes (the “Undertaking”) to defend Licensee or at Foundry’s option settle any
claim brought against Licensee alleging that Licensee’s possession or use of the Software or Documentation in
accordancewith the Agreement infringes the intellectual property rights of a third party in the same country as
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Licensee (“Claim”) and shall reimburse all reasonable losses, damages, costs (including reasonable legal fees) and
expenses incurred by or awarded against Licensee in connection with any such Claim, provided that the Undertaking
shall not apply where the Claim in question is attributable to possession or use of the Software or Documentation
other than in accordancewith the Agreement, or in combination with any hardware, software or service not supplied
or specified by Foundry. TheUndertaking is conditional on Licensee giving written notice of the Claim to Foundry as
soon as reasonably possible, cooperating in the defence of the Claim and not making any admission of liability or
taking any step prejudicial to the defence of the Claim. If any Claim ismade, or in Foundry's reasonable opinion is
likely to bemade, against Licensee, Foundry may at its sole option and expense (a) procure for Licensee the right to
continue using the Software, (b) modify the Software so that it ceases to be infringing, (c) replace the Softwarewith
non-infringing software, or (d) terminate the Agreement immediately by notice in writing to Licensee and refund the
License Fee (less a reasonable sum in respect of Licensee's use of the Software to the date of termination) on return
of the Software and all copies by Licensee. TheUndertaking constitutes Licensee's exclusive remedy and Foundry's
only liability in respect of any Claim.

7. LICENSE FEE

7.1 Licensee acknowledges that the rights granted to Licensee under this EULA are conditional on Licensee's timely
payment of the license fee payable to Foundry in connection with the Agreement or, as the casemay be, payable to
Foundry’s reseller (the "License Fee"). Except as expressly set out in clause 8.8, License Fee shall be payable in full as
one single payment.

7.2 Licenseewill be charged and agrees to pay to Foundry: (a) the License Fee as notified by Foundry (or its reseller)
at the time of the initial purchase of the License; and (b) in respect of any Subscription Autorenewal Period for a
Subscription License, the License Fee as notified by Foundry (or its reseller) on or about the applicable Renewal Date;
in each case together with any/all applicable taxes or other duties or levies.

7.3 In the cases of Non-Commercial NUKE or Trial Licenses for the avoidance of doubt, the fact that no License Fee
may be payable shall not be construed as awaiver by Foundry of any right or remedy available to it in relation to any
breach by Licensee of this EULA or the Agreement, or of any other right or remedy arising under applicable law, all of
which are expressly reserved.

8. SUBSCRIPTION LICENSES AND AUTO-RENEWAL

8.1 If Licensee has purchased a Subscription Licence, the License shall be limited to the Initial Subscription Period
and any/all Auto-renewal Periods (each as defined below) (together the “Subscription Period”) after which it shall
automatically expire.

8.2 The Subscription Licence shall begin as soon as Foundry accepts Licensee’s order by issuing Licenseewith a
license key (the “Subscription Start Date”) and shall continue for an initial period of twelve (12) months (the
“Initial Subscription Period”) unless earlier terminated in accordance the terms of this EULA.

8.3 Unless Licensee opts out of auto-renewal in accordancewith clause 8.6 then upon the first anniversary of the
Subscription Start Date and each subsequent anniversary (each a “Subscription Renewal Date”), Licensee’s
Subscription Licence shall renew automatically for a further twelve (12) months (each an “Auto-renewal Period”).
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Licensee’s Subscription Licensewill continue to auto-renew in thismanner until Licensee opts out of auto-renewal or
unless earlier terminated in accordancewith the terms of this EULA.

8.4 Prior to each Subscription Renewal Date, Foundry shall send you not less than two reminder emails to advise you
that your Subscription License is approaching auto-renewal to the contact email address as provided by Licensee in
accordancewith clause 22. The first reminder email will be sent not less than sixty (60) days prior to the relevant
Subscription Renewal Date. The second reminder email will be sent not less than thirty (30) days prior to the relevant
Subscription Renewal Date.

8.5 Subject to Licensee’s timely payment of the applicable License Fee, a Subscription Licence shall include access to
certainmaintenance and support services for the Subscription Licence in accordancewith the terms of the
Maintenance and Support Agreement which is available on FOUNDRY’s website (the “Maintenance and Support
Agreement”).

8.6 Opting Out of Auto-renewal. If Licenseewishes to opt out of auto-renewal then youmust email
licenses@foundry.comproviding details of the Subscription Licences which you wish to opt out not less than
seventy-two (72) hours prior to the relevant Subscription Renewal Date. Provided that Licensee notifies Foundry in
accordancewith the provisions of this clause 8.6 then your Subscription Licensewill not auto-renew and shall expire
at the end of the then-current Subscription Period. If you require furtherMaintenance and Support then please refer
to Foundry’s Maintenance and Support Policy as published on its website from time to time.

8.7 Increases to the License Fee for Subscription Licenses. Foundry reserves the right to increase the License
Fee for Subscription Licenses from time to time provided that it shall provide Licenseewith not less than thirty (30)
days’ notice of any increase prior to the relevant Subscription Renewal Date.

8.8 Payment in Instalments. If Licensee is paying the License Fee for the Subscription License in instalments (as
shall be noted in the applicable invoice), then the License Fee shall be owing on the Subscription Start Date and
any/all Subscription Renewal Dates and shall be payable in twelve (12) equalmonthly instalments thereafter, or on
termination of this agreement if earlier. By placing an order for a Subscription License payable in instalments,
Licensee requests and authorizes Foundry (or its agents) to take one twelfth of the applicable annual License Fee
from themeans of payment provided by Licensee every month during the Subscription Period. The Subscription
Licensewill terminate automatically if payment cannot be taken from themeans of payment provided by Licensee
for any onemonth. In the event of termination, Licensee shall remain liable for the balance of the License Feewhich
shall become payable immediately and in full.

9. CANCELLATIONS

9.1 Licenseemay cancel a Licensewithin 14 days of the original purchase date to obtain a full refund and Licensee
will no longer be able to use the Software from the cancellation date. Licensee’s right to obtain a refund will be lost
once the Software has been installed.

9.2 Refunds are not payable for cancellationsmade after such date. This includes Subscription licenses which are
subject to the fixed twelve (12) month terms and for which the Licenseemay opt out of auto-renewal in accordance
with Clause 8.
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9.3 Cancellations and requests for refunds can bemade by contacting Foundry’s Sales Support team at
licenses@foundry.com.

10. MAINTENANCE AND SUPPORT

If the Licensee has purchasedmaintenance and support services from Foundry for any Product licensed under this
EULA, or if the Licensee is entitled to receivemaintenance and support services for a Subscription Licence in
accordancewith clause 8.5, then Foundry shall provide those services subject to the terms of its Maintenance and
Support Agreement available on its website. Foundry may from time to time and at its sole discretion vary the terms
and conditions of theMaintenance and Support Agreement.

11. TAXES AND DUTIES

Licensee agrees to pay, and indemnify Foundry from claims for, any local, state or national tax (exclusive of taxes
based on net income), duty, tariff or other impost related to or arising from the transaction contemplated by the
Agreement.

12. LIMITED WARRANTY

12.1 Subject to clause 12.3, Foundry warrants that, for a period of ninety (90) days after Licensee first downloads
the Software (“Warranty Period”): (a) the Softwarewill, when properly used on an operating system for which it
was designed, perform substantially in accordancewith the functions described in theDocumentation; and (b) that
the Documentation correctly describes the operation of the Software in all material respects. If, within theWarranty
Period, Licensee notifies Foundry in writing of any defect or fault in the Software as a result of which it fails to
perform substantially in accordancewith theDocumentation, Foundry will, at its sole option, either repair or replace
the Software, provided that Licenseemakes available all the information that may be necessary to identify, recreate
and remedy the defect or fault. This warranty will not apply to any defect or fault caused by unauthorised use of or
any amendment made to the Software by any person other than Foundry. If Licensee is a consumer, thewarranty
given in this clause is in addition to Licensee’s legal rights in relation to any Software or Documentation that is faulty
or not as described.

12.2 Foundry does not warrant that the Software or Documentation will meet Licensee's requirements or that
Licensee's use of the Softwarewill be uninterrupted or error free.

12.3 If Licensee purchases a license of the Software that is of a fixed termduration, theWarranty Period in clause
12.1 shall apply only to Licensee’s first purchase of such license and not to any subsequent renewal(s) even if a
renewal involves another download.

13. INDEMNIFICATION

Licensee agrees to indemnify, hold harmless and defend Foundry, the Third Party Licensors and Foundry's and each
Third Party Licensor’s respective affiliates, officers, directors, shareholders, employees, authorized resellers, agents
and other representatives from all claims, defence costs (including, but not limited to, legal fees), judgments,
settlements and other expenses arising fromor connected with any claim that any authorised or unauthorised
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modification of the Software or Documentation by Licensee or any person connected with Licensee infringes the
intellectual property rights or other proprietary rights of any third party.

14. LIMITATION OF LIABILITY TO BUSINESS USERS

This clause applies where Licensee is a business user. Licensee acknowledges that the Software has not been
developed to meet its individual requirements, and that it is therefore Licensee’s responsibility to ensure that the
facilities and functions of the Software as described in theDocumentationmeet such requirements. The Software
and Documentation is supplied only for Licensee’s internal use for its business, and not for any re-sale purposes or
for the provision of the Software (whether directly or indirectly) to third parties. Foundry shall not under any
circumstances whatever be liable to Licensee, its affiliates, officers, directors, shareholders, employees, agents or
other representatives, whether in contract, tort (including negligence), breach of statutory duty, or otherwise, arising
under or in connection with the Agreement for loss of profits, sales, business, or revenue, business interruption, loss
of anticipated savings, loss or corruption of data or information, loss of business opportunity, goodwill or reputation
or any indirect or consequential loss or damage. In respect of any other losses, Foundry’smaximumaggregate
liability under or in connection with the Agreement whether in contract, tort (including negligence) or otherwise, shall
in all circumstances be limited to the greater of US$5,000 (five thousand USD) and a sumequal to the License Fee.
Nothing in the Agreement shall limit or exclude Foundry’s liability for death or personal injury resulting fromour
negligence, fraud or fraudulent misrepresentation or for any other liability that cannot be excluded or limited by
applicable law. This EULA sets out the full extent of our obligations and liabilities in respect of the supply of the
Software and Documentation. Except as expressly stated in this EULA, there are no conditions, warranties,
representations or other terms, express or implied, that are binding on Foundry. Any condition, warranty,
representation or other term concerning the supply of the Software and Documentation whichmight otherwise be
implied into, or incorporated in, the Agreement, whether by statute, common law or otherwise, is excluded to the
fullest extent permitted by law.

15. LIMITATION OF LIABILITY TO CONSUMERS

This clause applies where Licensee is a consumer. Licensee acknowledges that the Software has not been developed
to meet Licensee’s individual requirements, and that it is therefore Licensee’s responsibility to ensure that the
facilities and functions of the Software as described in theDocumentationmeet such requirements. The Software
and Documentation are only supplied for Licensee’s domestic and private use. Licensee agrees not to use the
Software and Documentation for any commercial, business or re-sale purposes, and Foundry has no liability to
Licensee for any loss of profit, loss of business, business interruption, or loss of business opportunity. Foundry is
only responsible for loss or damage suffered by Licensee that is a foreseeable result of Foundry’s breach of the
Agreement or its negligence but Foundry is not responsible for any loss or damage that is not foreseeable. Loss or
damage is foreseeable if they were an obvious consequence of a breach or if they were contemplated by Licensee
and Foundry at the time of forming the Agreement. Ourmaximumaggregate liability under or in connection with the
Agreement, whether in contract, tort (including negligence) or otherwise, shall in all circumstances be limited to a sum
equal to the greater of US$5,000 (five thousand USD) and a sumequal to the License Fee. Nothing in the Agreement
shall limit or exclude Foundry’s liability for death or personal injury resulting fromour negligence, fraud or fraudulent
misrepresentation or for any other liability that cannot be excluded or limited by applicable law.
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16. TERM; TERMINATION

16.1 The Agreement is effective upon Licensee's download of the Software, and the Agreement will remain in effect
until termination or expiry. Licenseemay terminate the Agreement on written notice to Foundry if Foundry is in
breach of this Agreement and fails to cure the breach within 10 (ten) working days of receiving notice of such breach.
If Licensee breaches the Agreement, Foundry may terminate the License immediately by notice to Licensee.

16.2 If the Agreement expires or is terminated, the Licensewill cease immediately and Licenseewill immediately
cease use of any Software and Documentation and either return to Foundry all copies of the Software and
Documentation in Licensee's possession, custody or power or, if Foundry directs in writing, destroy all such copies. In
the latter case, if requested by Foundry, Licensee shall provide Foundry with a certificate confirming that such
destruction has been completed.

16.3 Foundry reserves the right to terminate and/or suspend the License as it deems reasonable in its sole discretion
by notice to Licensee if it becomes aware that Licensee has failed to pay any sumdue either to Foundry or to a
reseller of Foundry either in connection with the Agreement or in connection with any other Software license to use
any product(s) of Foundry, in connection with any Maintenance and Support Agreement or if the Licensee is
otherwise in breach of or fails to comply with any term of the Agreement.

16.4 Foundry may also terminate this EULA if Licensee becomes subject to bankruptcy proceedings, becomes
insolvent, ormakes an arrangement with Licensee’s creditors. This EULAwill terminate automatically without further
notice or action by Foundry if Licensee goes into liquidation.

17. CONFIDENTIALITY

Licensee agrees that the Software (including, for the avoidance of doubt, any Source Code that is licensed to
Licensee) and Documentation are proprietary to and the confidential information of Foundry or, as the casemay be,
the Third Party Licensors, and that all such information and any related communications (collectively, "Confidential
Information") are confidential and a fundamental and important trade secret of Foundry and/or the Third Party
Licensors. If Licensee is a business user, Licensee shall disclose Confidential Information only to Licensee's
employees who areworking on an Authorized Project and have a "need-to-know" such Confidential Information, and
shall advise any recipients of Confidential Information that it is to be used only as expressly authorized in the
Agreement. Licensee shall not disclose Confidential Information or otherwisemake any Confidential Information
available to any other of Licensee's employees or to any third parties without the express written consent of
Foundry. Licensee agrees to segregate, to the extent it can be reasonably done, the Confidential Information from
the confidential information andmaterials of others in order to prevent commingling. Licensee shall take reasonable
security measures, whichmeasures shall be at least as great as themeasures Licensee uses to keep Licensee's own
confidential information secure (but in any case using no less than a reasonable degree of care), to hold the
Software, Documentation and any other Confidential Information in strict confidence and safe custody. Foundry
may request, in which case Licensee agrees to comply with, certain reasonable security measures as part of the use
of the Software and Documentation. This clause shall not apply to any information that is in or comes into the public
domain, or was in Licensee’s lawful possession before receipt or which Licensee develops independently and without
breach of this clause. Licensee acknowledges that monetary damagesmay not be a sufficient remedy for
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unauthorized disclosure of Confidential Information, and that Foundry shall be entitled, without waiving any other
rights or remedies, to such injunctive or other equitable relief asmay be deemed proper by a court of competent
jurisdiction.

18. INSPECTION AND INFORMATION

18.1 Unless Licensee is a consumer, Licensee shall advise Foundry on demand of all locations where the Software or
Documentation is used or stored. Licensee shall permit Foundry or its authorized agents to audit all such locations
during normal business hours and on reasonable advance notice.

18.2 The Softwaremay includemechanisms to collect limited information from Licensee’s computer(s) and transmit
it to Foundry, including the ability to locally cache such information on Licensee’s computer. Such information (the
“Information”) may include details of Licensee’s hardware, details of the operating system(s) in use on such
hardware, the location of the Licensee’s computer(s) and the profile and extent of Licensee’s use of the different
elements of the Software and other Foundry software. Foundry may use the Information to (a) model the profiles of
usage, hardware and operating systems in use collectively across its customer base in order to focus development
and support, (b) to provide targeted support to individual customers, (c) to ensure that the usage of the Software by
Licensee is in accordancewith the Agreement and does not exceed any user number or other limits on its use, and (d)
to advise Licensee about service issues such as available upgrades andmaintenance expiry dates. To the extent that
any Information is confidential to Licensee it shall be treated as such by Foundry when so notified or identified by
Licenseewhen the Information is first provided to Foundry (whether verbally or in written form). To the extent that
any Information constitutes personal data for the purposes of the Data Protection Act 1998 it shall be processed by
Foundry in accordancewith that Act and with Foundry’s Privacy Policy as updated from time to time (see
https://www.thefoundry.co.uk/EULA/TFPrivacyCookiesPolicy.pdf). Licensee undertakes to make all of users of the
Software aware of the uses which Foundry will make of the Information and of the terms of Foundry’s Privacy Policy.

19. U.S. GOVERNMENT LICENSE RIGHTS

All Software, including all components thereof, and Documentation qualify as “commercial items,” as that term is
defined at Federal Acquisition Regulation (“FAR”) (48 C.F.R.) 2.101, consisting of “commercial computer software”
and “commercial computer software documentation” as such terms are used in FAR 12.212. Consistent with FAR
12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-4, and notwithstanding any other FAR or other
contractual clause to the contrary in any agreement into which this Agreement may be incorporated, a government
end user will acquire the Software and Documentation with only those rights set forth in this Agreement. Use of
either the Software or Documentation or both constitutes agreement by the government that all Software and
Documentation are “commercial computer software” and “commercial computer software documentation,” and
constitutes acceptance of the rights and restrictions herein. The Software is the subject of the following notices:

* Copyright © 2001 - 2017 The Foundry Visionmongers Ltd. All Rights Reserved.

* Unpublished-rights reserved under the Copyright Laws of theUnited Kingdom.
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20. SURVIVAL

Clause 6, clause 7 and clauses 11 to 23 inclusive shall survive any termination or expiration of the Agreement.

21. IMPORT/EXPORT CONTROLS

To the extent that any Softwaremade available under the Agreement is subject to restrictions upon export and/or
re-export from theUnited States, Licensee agrees to comply with, and not act or fail to act in any way that would
violate, applicable international, national, state, regional or local laws and regulations, including, without limitation,
the U.S. Export Administration Act and the Export Administration Regulations, the regulations of the U.S.
Department of Treasury Office of Foreign Assets Control, and the International Traffic in Arms regulations
(collectively, “U.S. Export Laws”), and theUnited States Foreign Corrupt Practices Act, as those lawsmay be
amended or otherwisemodified from time to time, and neither Foundry nor Licensee shall be required under the
Agreement to act or fail to act in any way which it believes in good faith will violate any such laws or regulations.
Without limiting the foregoing, Licensee agrees that it will not export or re-export, directly or indirectly, Foundry’s
Software or related products and services, or any commodity, technology, technical data, software or service that
incorporates, contains or is a direct product of Foundry’s Software, products and/or services, (i) in violation of the
U.S. Export Laws; (ii) to any country for which an export license or other governmental approval is required at the
time of export, without first obtaining all necessary export licenses or other approvals; (iii) to any country, or national
or resident of a country, to which trade is embargoed by theUnited States; (iv) to any person or firm on any
government agency’s list of blocked, denied or barred persons or entities, including but not limited to theU.S.
Department of Commerce’s Denied Persons List and Entities List, and theU.S Treasury Department’s Specially
Designated Nationals List; or (v) for use in any nuclear, chemical or biological weapons, ormissile technology end-use
unless authorized by theU.S. Government by regulation or specific license.

22. MISCELLANEOUS

Unless Licensee is a consumer, the Agreement is the exclusive agreement between the parties concerning its subject
matter and supersedes any and all prior oral or written agreements, negotiations, or other dealings between the
parties concerning such subject matter. Licensee acknowledges that Licensee has not relied upon any representation
or collateral warranty not recorded in the Agreement inducing it to enter into the Agreement.

The Agreement may bemodified only in writing, by Foundry, at any time.

The failure of either party to enforce any rights granted under the Agreement or to take action against the other
party in the event of any such breach shall not be deemed awaiver by that party as to subsequent enforcement of
rights or subsequent actions in the event of future breaches.

The Agreement and any dispute or claim arising out of or in connection with it or its subject matter or formation
(including, unless Licensee is a consumer, non-contractual disputes or claims) shall be governed by, and construed in
accordancewith English Law and the parties irrevocably submit to the non-exclusive jurisdiction of the English
Courts, subject to any right that a consumermay have to bring proceedings or to have proceedings brought against
them in a different jurisdiction.
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If Foundry fails to insist that Licensee performs any obligation under the Agreement, or delays in doing so, that will
not mean that Foundry has waived its rights.

Unless Licensee is a consumer, Licensee agrees that Foundry may refer to Licensee as a client or a user of the
Software, may display its logo(s) for this purpose andmay publish quotations and testimonials from Licensee, its
directors, partners, officers or employees. Foundry agrees to promptly cease any such use on Licensee’s written
request.

Foundry and Licensee intend that each Third Party Licensormay enforce against Licensee under the Contracts
(Rights of Third Parties) Act 1999 (the “Act") any obligation owed by Licensee to Foundry under this EULA that is
capable of application to any proprietary or other right of that Third Party Licensor in or in relation to the Software.
Foundry and Licensee reserve the right under section 2(3)(a) of the Act to rescind, terminate or vary this EULA
without the consent of any Third Party Licensor.

Email Address for Notices. Licensee shall notify Foundry of an email address for the provision of any notices and
correspondence in connection with this Agreement and shall notify Foundry via licenses@foundry.comof any
change(s) to that email address. Please note, the email address you provide is important for the provision of notices
to you, including in relation to the autorenewal of any Subscription License (if applicable). It is your responsibility to
provide andmaintain an up to date email address. Foundry shall store details of andmay use the email address to
notify you in accordancewith the terms of this Agreement.

23. COMPLAINTS & ONLINE DISPUTE RESOLUTION PLATFORM

Wehope that you are satisfied with any Software purchasemade or service received from Foundry, but if you have a
complaint, in the first instance, please contact us on licenses@foundry.comor through our Support Portal:
https://support.foundry.com/hc/en-us (for technical support and bug reports), or you can request a call back from
the Sales teamhere: https://www.foundry.com/contact-us. Wewill do our best to resolve the issue but if you are still
not happy with our response, youmay seek to resolve it using theOnline Dispute Resolution Platform at
www.ec.europa.eu/consumers/odr/.

Last updated 11 May, 2017.

Copyright © May 2017 The Foundry Visionmongers Ltd.

All Rights Reserved. Do not duplicate.
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