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INTRODUCTION

Welcome to this User Guide for Keylight on Final Cut Pro.

Keylight is an industry-proven blue and green screen keyer. 
The core algorithm was developed by the Computer Film 
Company and has been further developed and ported to Final 
Cut Pro by The Foundry.

We hope you enjoy using Keylight.

About this Manual Use the Quick Key chapter to see how a simple key is pulled 
using Keylight. The Basic Keying Chapter goes over the most 
common parameters you’ll need to pull a variety of keys. The 
Advanced Keying Chapter explains how to tackle difficult 
keys.

Release Notes For information on system requirements, new features, 
improvements, fixed bugs and known bugs & workarounds, 
see “Appendix A” on page 67.

Example Images Example blue and green screen images for use with Keylight 
can be downloaded from our web site http://
www.thefoundry.co.uk.
The Foundry Keylight
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Installation on Mac OS X
Installation on Mac 
OS X

To install Keylight on a Mac OS X machine, follow these 
instructions:

1. Download Keylight_2.0v3_FCP-mac-universal-release-32.dmg 
from www.thefoundry.co.uk and extract the package by double 
clicking on it.

2. Double click on Keylight_2.0v3_FCP-mac-universal-release-
32.pkg

3. Follow the on-screen instructions to install Keylight.

4. Proceed to “Activating Keylight” on page 6.

Keylight can be found in the Effects > Video Filters > 
Keylight menu. Its parameters appear on the Filters tab of 
the Viewer.

If you at some point need to uninstall the plug-in, see 
“Uninstalling Keylight” below.

Uninstalling 
Keylight

The following directories are copied during the default 
installation process to the following paths. Removing these 
directories will uninstall Keylight: 

/Library/Plug-ins/FxPlug/Keylight_2.0_FCP 
/Applications/TheFoundry/Keylight_2.0_FCP

Activating Keylight Once you have installed Keylight, you will need to activate 
the product. Successful activation gives you a license key 
that unlocks the software.

If you have a serial number for Keylight, you can activate the 
plug-in via the Internet or by telephone. 
Keylight The Foundry
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If you don’t have a serial number for Keylight, you can 
activate the plug-in by telephone.

Activation via Internet 1. Start Final Cut Pro.

2. Select Effects > Video Filters > Keylight > Keylight (2.0) to 
apply the Keylight plug-in to an image sequence.

3. In the plug-in controls, press the Help button and make a note 
of your System ID (sometimes called host ID or lmhostid). This 
number is unique to your machine and your license key will be 
locked to it.

4. Press the Enter Serial Number button in the bottom left corner 
of the dialog.

5. This launches a web browser. Check that the System ID shown 
on the web page is correct. If it is not, or you wish to activate 
for a different computer, follow the on-screen instructions.

6. Type your serial number into the box provided. Make sure you 

type it in exactly as shown. Click continue.

7. If successful, you will be taken to a page that lets you download 
your license file and the Foundry License Installer (FLI). Click 
download license. 

8. Double-click on the downloaded file to extract the license key  
and the Foundry License Installer (your computer may do this  
automatically). The license will be in a plain text file called 
foundry.lic. The license will look a bit like this: 
INCREMENT keylight_fxplug_i foundry 1.0 permanent 
uncounted \
HOSTID=0022411f0759 ISSUED=7-aug-2009 SIGN="0118 0259 
3106 \
D626 F32A 54BC EA70 EFC6 AC23 0575 BD01 67F6 0D9B 9176 
36A7 \
128A C706 C495 C017 34B8 8125" 

Once you have downloaded the license file, proceed to “Install-
ing a License” on page 8.
The Foundry Keylight
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Installing a License
Activation by Phone Call our London office on 020 7434 0449 (country code 44) 
or phone our Los Angeles office on 310 399 4555. You will 
need your System ID (“System ID (lmhostid)” on page 8), an 
e-mail address for us to send the license key, and, if you 
have one, a serial number.

Installing a License Once you have received your license file, you need to install 
the license. The Foundry License Installer (FLI) application 
helps you with this. You may have received this application 
in an e-mail or downloaded it from 
http://www.thefoundry.co.uk/licensing. 

To install a license: 
1. Open the directory where you have saved the license file and 

the Foundry License Installer.

2. Double-click on the Foundry License Installer application.

3. In the window that opens, click Install..

This checks the license file and installs it into the correct direc-
tory. 

You’re good to go. Start Final Cut Pro and check whether 
Keylight is licensed. If it is not, check that you have a 
foundry.lic license file in the correct directory. See “Where 
Does the License File Go?” on page 9.

System ID 
(lmhostid) 

The System ID (sometimes called host ID or lmhostid) is a 
unique number that identifies your computer. We use this 
number to generate a license key for that, and only that, 
computer.

The System ID is shown at the bottom of the help dialog. To 
Keylight The Foundry
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display this number, select Effects > Video Filters > Keylight 
> Keylight (2.0) to apply the Keylight plug-in and click on the 
Help button in its controls.

Where Does the 
License File Go?

The license file should be called foundry.lic and saved in the 
following directory as a plain text file: 
/Library/Application Support/TheFoundry/FLEXlm/foundry.lic 

There are also other places where you can place the license 
file. See “Alternative License Directories” on page 9.

Alternative License 
Directories 

If you like, you can also put the license file in an arbitrary 
directory and point to it with the environment variable: 
FOUNDRY_LICENSE_FILE 

This can be useful for large post houses that have centrally 
managed license servers, but will not be necessary for most 
customers.

See “Further Reading” on page 10.

Watermark If you don’t have a valid license key, a warning will be 
displayed and the finished render will have coloured dots 
scattered over it.

License Problems If you can't get your licenses to work, you can download the 
Foundry License Diagnostics (FLD) utility from http:// 
www.thefoundry.co.uk/licensing. Run the FLD and e-mail the 
The Foundry Keylight
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Further Reading
resulting text file to support@thefoundry.co.uk with a clear 
description of the problem.

Error Log Files If the plug-in fails to get a license, the incident is recorded in 
an error log file. The time, date and nature of the problem 
are appended to the end of the file. The error log file can 
then be found in the following location: 
/Library/Application Support/TheFoundry/FLEXlm/log/
license.log

Further Reading System Administrators may wish to find out more about 
licensing Keylight with FLEXlm. We recommend reading the 
Foundry FLEXlm Tools (FFT) User Guide available to 
download from our web site (http://www.thefoundry.co.uk/ 
licensing). In addition, there are general FLEXlm licensing 
guides on Macrovision’s web site (http:// 
www.macrovision.com).

About The Foundry The Foundry is a leading developer of visual effects software 
for film and video post production. Its products include 
Nuke, a high-end compositing application, and plug-ins, such 
as Furnace, Tinder, Tinderbox, Keylight, Ocula, and 
RollingShutter. The plug-ins run on a variety of compositing 
platforms, including After Effects, Autodesk® Media and 
Entertainment Systems, Avid DS, Nuke, Shake, and Final Cut 
Pro. For the full list of products and supported platforms, 
see our web site http://www.thefoundry.co.uk.

Nuke is an Academy Award® winning compositor. It has 
been used to create extraordinary images on scores of 
Keylight The Foundry
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feature films including The Dark Knight, The Golden 
Compass, Iron Man, Transformers, King Kong, and Pirates of 
the Caribbean: At World’s End.

Furnace is a collection of film tools. Many of the algorithms 
utilise motion estimation technology to speed up common 
compositing tasks. Plug-ins include wire removal, rig 
removal, steadiness, deflicker, degrain and regrain, retiming, 
and texture tools.

Tinder and Tinderbox are collections of image processing 
effects including blurs, distortion effects, background 
generators, colour tools, wipes, matte tools, painterly 
effects, lens flares, and much more.

Ocula is a collection of tools that solve common problems 
with stereoscopic imagery, improve productivity in post 
production, and ultimately help to deliver a more rewarding 
3D-stereo viewing experience.

RollingShutter is a plug-in that tackles image-distortion 
problems often experienced by users of CMOS cameras. The 
plug-in will often vastly improve the look of distorted 
footage, by either minimising or eradicating image 
distortions. Unlike solutions tied to camera stabilisation, 
that stretch the image as a whole, the RollingShutter plug-in 
compensates for local skewing and distortion in the scene, 
by correcting each object individually.

Visit The Foundry’s web site at www.thefoundry.co.uk for 
further details.
The Foundry Keylight
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About CFC and Framestore
About CFC and 
Framestore

The Computer Film Company (CFC) pioneered the field of 
digital film compositing and today operates a state of the 
art film effects facility in London under the name 
Framestore. The company has always invested in research, 
and maintains the kind of edge that has twice been honoured 
with Technical Achievement Awards from the Academy of 
Motion Picture Arts and Sciences.

Visit Framestore’s web site at http://www.framestore.com 
for further details.
Keylight The Foundry
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GETTING STARTED

Introduction Keylight has been refined over a number of years to make 
keying quicker and easier while providing a depth to the 
tools that will tackle even the most challenging shots.

Keylight was first developed by The Computer Film Company 
to help with difficult keys in feature films. Over the years 
Keylight has been refined in production on hundreds of films.

Notation When we refer to blue screens throughout the text we mean, 
of course, blue or green screens

Quick Key Keylight is available from the Effects > Video Filters > 
Keylight in Final Cut Pro.

Consider this shot from The Saint, pictures courtesy of CFC 
and Paramount British Pictures Ltd. 

Figure 1 is the blue screen foreground that should be 

Figure 1. Blue Screen.
The Foundry Keylight
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Quick Key
composited over the background shown in Figure 2. 

If you want to have a go of this shot, you can! The images 
can be downloaded from our web site and this quick key is 
also covered in the Tutorial Chapter. See “Tutorial 1: Simple 
Key” on page 51.

Throughout this user guide we assume a good understanding 
of Final Cut Pro. To perform this quick key, do the following:

1. Create a new composition using SaintFG.mov and SaintBG.mov. 
Layer the clips with the blue screen over the background as 
shown in Figure 3.

Figure 2. Background.

Figure 3. Screen Shot showing Saint blue screen.
Keylight The Foundry
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2. Open the blue screen clip (SaintFG.mov) in the Viewer and apply 
Keylight from Effects > Video Filters > Keylight > Keylight 
(2.0). See Figure 4.

3. The Keylight parameters appear on the Filters tab of the 
Viewer, as shown in Figure 5.

4. To view the Keylight parameters and the foreground clip in 
separate Viewers, right-click on SaintFG.mov in the Browser 

Figure 4. Apply Keylight from the Effects > Video Filters 
menu.

Figure 5. Keylight Parameters.
The Foundry Keylight
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Quick Key
and select Open in New Viewer. This opens the foreground clip 

in a new Viewer, as shown in Figure 6.

5. In the Keylight controls, select the Screen Colour eye dropper 
and click on the blue screen in the new Viewer. A good place to 
pick is the blue from the back windscreen as this has no 
reflections. Picking this blue will key the back windscreen 
perfectly leaving reflections in the side window.

6. That’s it. In many cases this is all you will need to do to perform 
a key, since selecting the screen colour creates a matte and 

Figure 6. Opening a new Viewer.

Figure 7. Pick the blue from the back windscreen.
Keylight The Foundry
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despills the foreground. The final composite is shown in 
Figure 8.

There are a couple of extra steps that can be taken to fine 
tune this key and these are discussed in “Tutorial 2: Fine 
Tuning a Key” on page 56.

Picking the screen colour may be enough for a lot of keys, 
but there are many more tools within Keylight that can be 
used to tackle more complicated shots. These are described 
in later chapters.

Figure 8. Final composite.
The Foundry Keylight
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Quick Key
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BASIC KEYING

The following section describes the parameters you need to 
do basic keying. This will give you enough to tackle most 
simple keys. A discussion of advanced parameters to fine 
tune and tackle complex keys can be found in the next 
chapter.

Basic Workflow The first step is always to pick the Screen Colour. Then view 
the composite and the screen matte. 

If there is blue spill on the composite, pick skin tones for the 
Despill Bias from the foreground actor. 

If the background is showing through the foreground or the 
foreground is showing on the background, you need to 
improve your matte using the Clip Black and Clip White 
parameters. In the next chapter, we’ll look at ways of doing 
this with inside and outside masks.

Screen Colour The Screen Colour is probably the most important parameter, 
and you should always pick the screen colour before doing 
anything else. It should be set to the colour of the green or 
blue curtain behind the foreground object. 

When picking the screen colour, it is often useful to open the 
foreground image in a new Viewer. This way, you can adjust 
the Keylight controls in the original Viewer, pick the screen 
colour from the new Viewer, and view the output in the 
Canvas. To do so, right-click on the foreground clip in the 
The Foundry Keylight



BASIC KEYING20
Screen Colour
Browser and select Open in New Viewer, as shown in 
Figure 9. 

To set the Screen Colour, select the eye dropper in the 
Keylight controls, and pick the colour from the new Viewer. 
Setting the Screen Colour will create a matte (the Screen 
Matte), set the Screen Balance, and despill the foreground. In 
some cases, this is enough to get a decent key. For more 
information on Screen Colour see page 25.

Figure 10 shows a well lit blue screen behind an actor.  

Figure 9. Opening the foreground image in a new Viewer.

Figure 10. Blue Screen.
Keylight The Foundry
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You should note that repeatedly picking the Screen Colour 
will override any previous selections. It will not add to 
previous selections and key more of the image with each 
click.

Note You should always pick screen colours from the Source image and 
not the Final Result.

Tip

It’s worth picking several different blues, and for each one 
viewing the matte and status to judge the key. 

View After picking the Screen Colour, it’s useful to be able to 
check the quality of the key by viewing the composite and 
the screen matte. You can do this using the View Menu, 
shown here in Figure 11. 

The options you’ll use the most are:

• Screen Matte - this renders the matte created by picking 
the screen colour.

Figure 11. View Menu.
The Foundry Keylight
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Status
• Status - this renders an exaggeratted view of the mattes 
so that minor problems are shown clearly.

• Final Result - this renders the foreground composited 
over the background using all mattes, spill and colour 
corrections.

Status The Status is one of the options in the View menu and shows 
an exaggerated view of the key so that you can make a more 
informed decision when refining the composite. 

Figure 13 shows the Status display after the screen colour 
has been picked from the image shown in Figure 12. Three 
colours are displayed. Black pixels show areas that will be 
pure background in the final composite. White pixels show 
areas that will be pure foreground. Mid-grey pixels will be a 
blend of foreground and background pixels in the final 
composite. You need grey pixels around the edge of the 
foreground to get a good key at the foreground edge. 
However, if there are grey pixels where there should be pure 
background, you should try to remove these with the Screen 
Gain, Clip Black or Outside mask. If you have grey pixels 
where there should be pure foreground, this tells you that 
parts of the background will show through here and you will 

Figure 12. Green Screen. Figure 13. Status.
Keylight The Foundry
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need to firm up the foreground with Clip White or an Inside 
mask.

Pixels that are a blend between the foreground and 
background are shown in just one shade of grey. This is done 
to highlight potential problems with the key. These grey 
pixels may represent a foreground/background blend of 50/
50 or 99/1. No distinction is made as to this ratio.

You may occasionally see other colours in the Status View 
and these are covered on page 37 in the Advanced Keying 
Chapter.

Despill Bias Although the foreground is despilled automatically, you may 
find the need to pull out a little more of the screen colour 
after picking from the image. You can do this with the Bias 
controls. 

By default, the Alpha Bias colour is used for Despill Bias, 
which in the vast majority of cases, is the best way to use 
these controls. See “Why are there two Bias Colours?” on 
page 30 in the Advanced keying section for a look at a case 

Figure 14. Exaggeratted blue 
spill.

Figure 15. Despill Bias used to 
remove the blue spill.
The Foundry Keylight
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Despill Bias
where unlinking the bias controls is a good tactic.

Thus, using the Alpha Bias control colour dropper, pick the 
predominant foreground colour. In the majority of cases, it’s 
best to pick skin tones from the foreground actor, as viewers 
tend to be most tuned to colour shifts in these areas.
Keylight The Foundry
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ADVANCED KEYING

The following section describes the parameters you need to 
fine tune keys and get the most out of Keylight. Basic 
parameters covered in the previous chapter may also be 
covered here in more detail.

Screen Colour The Screen Colour represents the colour of the pure blue (or 
green) screen. The first thing you should do when pulling a 
key is pick the Screen Colour. This single colour has a 
primary component, blue or green, and that has a saturation. 
Once the screen colour has been picked, Keylight analyses all 
the pixels in the image and compares the saturation of the 
primary component in each of these pixels with the 
corresponding saturation of the screen colour, setting the 
alpha and modifying the colour accordingly.

Tip

Picking different shades of blue or green from the 
background can give quite different results. It’s worth 
experimenting with different screen colours if your initial 
pick didn’t give a good key.
The Foundry Keylight
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Screen Colour
Background Pixel

If the saturation of the pixel in the image is as strong or 

greater than the screen colour, then it’ll be a pixel from the 
blue screen background, and that pixel will be set to 
completely transparent and black. See Figure 16.

Edge Pixel

If the saturation of the pixel is less than the screen colour, 
then it’ll be the edge of the foreground object, and we 

Figure 16. Blue screen pixel set alpha to zero.
Keylight The Foundry
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subtract some of the screen colour from the pixel (de- 
spilling) and set the image to semi-opaque. See Figure 17.

Foreground Pixel

If the primary component in the pixel is not the same as the 
primary component of the screen colour, we have a 
foreground pixel, and the alpha is set to completely opaque. 
The pixel colour is not modified. See Figure 18.

Note You should note that the Screen Colour is a single colour. You are 
not picking lots of colours that are keyed out.

Figure 17. Edge pixel gives partial alpha.

Figure 18. Foreground pixel gives full alpha.
The Foundry Keylight
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Biasing
Biasing What’s biasing all about? Biasing in Keylight was originally 
developed for a shot in the motion picture "Executive 
Decision". The foreground consisted of reddish browns, but a 
combination of factors led to the 'green screen' being lit so 
that its primary component was actually slightly red.

So what happens when we pick the screen colour? Well 
because the screen was 'red', as is the foreground, our pilot 
ends up being keyed out as shown in Figure 20.

Not a great result, I’m sure you’ll agree, and much pressure 

Figure 19. Is this the worst green screen you’ve ever seen?

Figure 20. Default key showing the transparency in the foreground 
as a result of picking the "red" screen colour.
Keylight The Foundry
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was applied to the lowly programmers to get around the 
problem.

A work around to this is to manually colour correct the 
image so that the background is properly green, pull the key 
from this corrected image, then 'un-correct' the result of 
that so that the foreground colours match the original. A 
corrected image would look something like the one shown in 
Figure 21. The green screen is now strongly green and 
distinct from the foreground colours. Notice also the red 
cast on the pilots mask has been removed and turned into a 
neutral grey.

This is effectively how the Keylight developers got around 
the problem. They introduced the concept of a 'bias' colour, 
which is a colour cast that is removed from the source image 
and screen colour, then a key is pulled from this modified 
image, then the colour cast is put back. In essence this 
automates the 'work around' described above, however it is 
done in a way that does not slow Keylight down at all. For 
our Executive Decision shot, an appropriate colour is the red 
cast on the pilot's mask in the source footage. Setting our 
bias to this now gives us the far better result as shown in 

Figure 21. Colour corrected image that would give a better key.
The Foundry Keylight
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Figure 22.

The Bias Colours in 
everyday use

It also turns out that the bias colour is actually useful for 
situations without strong casts, typically where there is 
some colour spill around the edge of keys. By setting the 
biases to the main colour that occurs near the edge of the 
foreground (typically flesh tones or hair tones), you allow 
Keylight to better discriminate between foreground and 
background.

Picking a Bias Colour To pick a bias colour, activate the colour picker under Alpha 
Bias and click on the image foreground to select a colour. 

Why are there two 
Bias Colours?

Remember that Keylight does two things, calculates a 
transparency and removes the screen colour from the 
foreground. By default, one bias colour, the 'Alpha Bias', is 
used for both operations. This works fine in most situations, 
for example, the Executive Decision shot above.

Figure 22. Final Key, with the Bias Colour Set to the Value of the 
Pilot's Mask.
Keylight The Foundry
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However, sometimes you can pick a bias that gives a great 
alpha, but performs a poor despill, and another bias that 
gives a great despill, but a poor alpha. Consider the blue 
screen from the TV series Merlin, courtesy of CFC 
Framestore shown below in Figure 23.

We pick the strong blue of the background without choosing 
an alpha bias, and end up with the lovely alpha shown in 
Figure 24, but the despill resulting from this key is poor as 
shown in Figure 25 on page 32.

We can pick an alpha bias to get a better despill, but this 
destroys our nice alpha. The way around this is to turn off 
the 'Use Alpha Bias for Despill', which gives you a separate 
bias factor to use solely for despill calculations. If you then 
pick the 'Despill Bias' to be something from Miranda 
Richardson's hair or skin tone, you will keep the nice alpha, 

Figure 23. Merlin blue screen. Figure 24. Nice Alpha.
The Foundry Keylight
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and get a good despill as well (Figure 26).

Screen Gain The screen gain controls how much of the screen colour is 
removed to make the screen matte. Increasing this value will 

key more. For the most part, a better way of improving the 
matte is using the Clip Black and Clip White controls. 
Figure 27 shows the Status after picking the screen colour. 
You can clearly see that parts of the background are grey 
where they should be black. When composited you may see 
faint pixels from the foreground where you should be seeing 
pure background. Increasing the screen gain will fix this, as 

Figure 25. Poor despill. Figure 26. Final Key, Using Separate 
Despill and Alpha Biases.

Figure 27. Status after picking 
the Screen Colour.

Figure 28. Status showing the 
increase in Screen Gain.
Keylight The Foundry



Screen Balance

ADVANCED KEYING 33
shown in Figure 28, but increasing it too much will destroy 
your good work. Like many keying parameters it’s a balance - 
not too much, not too little. Increasing the screen gain too 
much will lead to the background showing through the 
foreground and edge detail will be destroyed. Figure 30 
shows this quite well.  

Note the steering wheel is black when it should be white. If 
you look at the composite you will see the background 
showing through here. Also, some of the fine hair detail on 
the actor, visible in Figure 29, has been eroded in Figure 30.

Screen Balance Saturation is measured by comparing the intensity of the 
primary component against a weighted average of the two 
other components. This is where the Screen Balance control 
comes in. A balance of 1 means that the saturation will be 
measured against the smallest of the other two components 
in the screen colour. 

A balance of 0 means that the saturation will be measured 
against the larger of the other two components. A balance of 

Figure 29. Screen Gain = 1 giving 
a good screen matte.

Figure 30. Screen Gain = 1.5 
giving background show through 

and over eroded edges.
The Foundry Keylight



ADVANCED KEYING34
Clip Levels
0.5 will measure the saturation from the average of the 
other two components. 

The appropriate balance point for each image sequence you 
key will be different depending on the colours in that image. 
Generally speaking, blue screens tend to work best with a 
balance of around 0.95 and green screens with a balance of 
around 0.5. These values are selected automatically the first 
time you pick the screen colour. If the key is not working too 
well with these settings, try setting the balance to about 
0.05, 0.5, and 0.95 and see what works best.

Clip Levels The clip levels are adjusted using two parameters - Clip 
Black and Clip White. Any alpha value at or below Clip Black 
will be set to zero and any alpha value at or above Clip White 
will be set to 1. Figure 31 shows the original alpha of an 
image and Figure 32 shows the result of clipping it. 

Notice how the grey areas in the black background have 
been reduced and that the grey edges have hardened up 
considerably. When compositing, the Clip Black control can 
be used to improve the background image if parts of the 
foreground are showing through. The Clip White control on 

Figure 31. Clip Black = 0. Figure 32. Clip Black = 0.5.
Keylight The Foundry
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the other hand can be used to firm up the centre of the 
matte, making it less transparent to the background. 

Note You need to be really careful if you chose to use Clip Black and Clip 
White that you don't destroy the edges on your foreground. It is 
possible to use Clip Rollback to compensate for this. 

View After picking the Screen Colour, it’s useful to be able to view 
the key in different ways. You can do this using the View 
Menu, shown here in Figure 33.

Here’s the complete list of options and what they do.

• Source - displays the blue or green screen.

• Source Alpha - displays the alpha channel embedded in 
the blue or green screen.

• Corrected Source - displays the uncomposited source 
image with any colour corrections applied.

Figure 33. View Menu.
The Foundry Keylight
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• Colour Correction Edges - displays the foreground edges 
as a matte that will be colour corrected using the controls 
in the Edge Colour Correction folder.

• Screen Matte - displays the matte created as a result of 
picking the screen colour.

• Inside Mask - displays the mask that firms up the 
foreground.

• Outside Mask - displays the mask that cleans up the 
background.

• Combined Matte - displays all the screen matte, inside 
and outside masks and any source alpha added together. 
The combined matte is used to composite the foreground 
over the background layer.

• Status - displays an exaggerated view of the key so you 
can make a more informed decision on how to improve 
the result. See “Status” on page 36.

• Intermediate Result - is used for multipass keying. The 
alpha is set as per normal, but the RGB values are not 
modified from the original source image.

• Final Result - renders the foreground composited over 
the image on the background track. This image is 
premultiplied. In other words, the RGB values of pixels 
have been multiplied by their corresponding alpha channel 
values. 

Status The Status view is one of the options in the View menu and 
shows an exaggerated view of the key so that you can make 
Keylight The Foundry
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a more informed decision when fine tuning the composite. 

Figure 35 shows the Status after the screen colour has been 
picked from the image shown in Figure 34. Three colours are 
displayed. Black pixels represent pure background in the 
final composite. White pixels are pure foreground and grey 
pixels are a blend of the foreground and background pixels. 
The grey is just one colour to highlight any areas that are 
not pure foreground or background. Grey pixels do not mean 
the key is poor - the final composite may be fine.

You may occasionally see other colours in the Status view. 

Figure 36 shows black, white, grey and green pixels. The 

Figure 34. Green Screen. Figure 35. Status.

Figure 36. Status showing 
processing of the Screen Matte.

Figure 37. Result showing Screen 
Replace Colour.
The Foundry Keylight
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green pixels are a warning. They show you the parts of the 
Screen Matte that have changed through processing the 
matte (clipped, softened or eroded). These areas have had 
the correct amount of spill removed, but the alpha has 
subsequently changed and the composite may no longer look 
right. This can be corrected using the Screen Replace Colour 
to put back colour in these areas. Figure 37 on page 37 is an 
extreme example to illustrate the point. The Replace Colour 
has been set to pure red and you can see that this mirrors 
the green pixels in the Status View.

Similarly, you may see blue pixels in the Status. 

These represent processed pixels in the Inside Mask that 
affect the despill of the foreground. The Inside Replace 
Colour will be used to modify these pixels. Another extreme 
example is shown in Figure 39. The Inside Replace Colour is 
set to pure yellow and Inside Replace to Hard Colour.

You may also see dark red pixels which indicate areas where 
an outside mask has been used to reduce the transparency 
of the image.

Figure 38. Status showing how 
the Inside Mask will affect the 

foreground.

Figure 39. Final Result showing 
the Inside Replace Colour.
Keylight The Foundry
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Unpremultiply 
Result

Use this switch to set the premultiplication of the RGB 
channels in the output image. If turned off, the RGB values 
will be multiplied by the alpha channel, thus transparent 
areas are always black, and semi-transparent areas are dark. 
If turned on, the RGB values of the output image will be not 
multiplied by the alpha, thus semi-transparent pixels will 
have full brightness in the RGB channels.

If colour correcting the image after applying Keylight you 
should switch on Unpremultiply Result.

Screen Matte The Screen Matte (Figure 41) is the result of pulling the blue 
or the green from the image (Figure 40) and making those 
regions transparent. 

Once you have done this, you will want to firm up the 
foreground (make it more white) and clean up the 
background (make it more black). This can be done by 
processing the Screen Matte.

Figure 40. Green screen. Figure 41. Screen Matte.
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Clip Rollback Pulling a Screen Matte (Figure 42) will typically produce lots 
of transparency (grey) in the matte at the edges. This is good 
since this is what you need to key hair well. You may also get 
transparency in the foreground as shown in Figure 43. This 
is bad as your subject will appear slightly see-through, and 
this should be corrected. You can do this with an inside mask 

shape, or you can use the Clip White parameter to turn these 
grey pixels white. This cleans up the foreground (Figure 44) 
but it will also destroy the edge detail you want to keep. This 
is where Clip Rollback comes in. This is used to put back the 
edges to restore the detail that was lost. A rather 

Figure 42. Screen matte 
highlighting the close up view as 

shown in Figure 43.

Figure 43. Close up screen matte 
showing unwanted (grey) 

transparency in the (white) 
foreground.
Keylight The Foundry



Screen Matte

ADVANCED KEYING 41
exaggerated clip rollback is shown in Figure 45 to illustrate 
the point.

Screen Dilate This control should not normally be used as eroding the 
edges can produce a very poor key. However, the Screen 
Dilate parameter allows you to grow (if greater than zero) or 
shrink (if less than zero) the alpha in the Screen Matte. 
These controls are sub-pixel accurate.

Figure 44. Clip White has been 
used to remove the unwanted 
grey pixels in the white matte.

Figure 45. Clip Rollback has been 
used to reduce the unwanted 

erosion of the edge.

Figure 46. Screen Matte. Figure 47. Eroded Matte.
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Screen Softness Occasionally, it is useful to be able to blur the matte. Use 
Screen Softness for this. The most common example would 
be to pull a very harsh matte that you would use as an inside 
matte further down the tree. For this you’d soften and erode 
the screen matte.

Screen Despot This controls how much to simplify the matte. It coagulates 
similar regions so that, for example, black specks in the 
white matte can be absorbed by the surrounding white areas. 
Increasing the Screen Despot Black will remove isolated 
spots of black in the white matte. Increasing Screen Despot 
White will remove isolated spots of white in the background 
up to that size. 

Screen PreBlur Some shots can be improved by softening the foreground 
image that is used to generate the key. The original image is 
then used in the composite and colour corrections. The 
Screen PreBlur parameter is used to do this. DV footage or 
grainy shots may benefit from subtle use of this control.

Figure 48. Eroded matte. Figure 49. Despot.
Keylight The Foundry
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Tuning Keylight creates the screen matte after the screen colour 
has been picked. You can make fine adjustments to this 
matte using the gain controls. Increasing the gain controls 
makes the screen matte more transparent by increasing the 
amount of screen colour showing through the matte. This 
tends to tint the edges the opposite of the screen colour (for 
blue screens, edges become yellow). Decreasing the gain 
makes the main matte more opaque by reducing the amount 
of screen colour showing through the matte.

The matte can be adjusted independently in the shadows, 
midtones, and highlights giving more control than the 
clipping levels.

The level of the midtones can be adjusted too. For example, 
if you are working on a dark shot you may want to set the 
midtone level to a dark grey to make the gain controls 
differentiate between tones that would otherwise all be 
considered shadows.

Colour 
Replacement

Remember that Keylight does two things - it removes the 
screen colour to despill the image and generates an alpha 
(Screen Matte) to composite the foreground over the 
background layer. 

If you then process the Screen Matte, for example, by 
eroding the matte or changing the clip levels, Keylight will be 
removing the wrong amount of screen colour from the pixels 
whose transparency have now changed. The Replace controls 
instruct Keylight how to deal with such pixels. The Status 
will display which pixels use a replace method. Those pixels 
who use a replace method because the Screen Matte 
processing tools modified the transparency will be green, 
The Foundry Keylight
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Inside & Outside Masks
whilst those pixels whose transparency was modified by the 
inside mask will be blue. See the Status View on page 37.

There are four options to the replace method, these are:

1. None - the despilled image is left untouched if the alpha is 
modified. 

2. Source - the image will have a corresponding amount of the 
original pixel (screen colour and all) reintroduced/removed if 
the alpha is changed. 

3. Hard Colour - the despilled image has a corresponding amount 
of the replace colour added for any increase in alpha. 

4. Soft Colour - the despilled image has a corresponding amount 
of the replace colour added for any increase in alpha, however, 
it attempts to modulate the luminance of the resulting pixel so 
that it matches the original pixel. This will give a more subtle 
result than the Hard Colour option.

Inside & Outside 
Masks

If you can’t adequately improve the Screen Matte using the 
Clip Levels, you can input a mask that defines the foreground 
or background. The Inside mask makes the foreground less 
transparent and the Outside mask is used to clean up the 
background that might have bits of the foreground showing 
through. The Outside mask is often used to clean up screens 
Keylight The Foundry



Inside & Outside Masks

ADVANCED KEYING 45
that are not a constant colour or have lighting rigs in shot 
(Figure 50) by forcing the alpha transparent. 

The Inside mask can be used to keep elements in the 
foreground that you don't want to lose (an actor’s blue eyes 
in front of a blue screen). These masks should normally be 
softened to blend into the Screen Matte.

Figure 51 shows a mask drawn around the lighting rig on the 
left side of the screen. When this is used as the Outside 
mask clip and the View control set to render the Outside 
Mask, you will see the image displayed in Figure 52. 

Figure 50. Green Screen with 
lighting rig visible.

Figure 51. Mask drawn round the 
lighting rig.

Figure 52. Mask used as an 
Outside Mask and Viewed.
The Foundry Keylight



ADVANCED KEYING46
Source Alpha
The Outside mask forces that part of the image to be in the 
background thus keying out the rig. The Screen Matte shown 
in Figure 53 shows the matte pulled when the green screen 
is picked. When the Outside mask is subtracted from the 
Screen Matte we get the Combined Matte, shown in 
Figure 54. 

Here, you can see the change in the matte that will result in 
the lighting rig being keyed out in the final composite. If 
more than one mask is required to remove garbage, then use 
the masks to create an embedded alpha channel in the image 
and set the Source Alpha to Normal. See “Source Alpha” 
below.

Source Alpha This parameter determines how to deal with any embedded 
alpha in the original image.

• Ignore - this will not use any embedded alpha in the key.

• Add To Inside Mask - the embedded alpha is added to the 
inside mask.

• Normal - the embedded alpha is used to key the layer as 
normal. It is added to Keylight’s screen matte and can be 
useful if requiring complicated multi-shaped masks to 
rotoscope out garbage.

Figure 53. Screen Matte. Figure 54. Combined Matte.
Keylight The Foundry
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Foreground Colour 
Correction

The Foreground Colour Correction parameters allow you to 
modify the foreground colours in your composite. In 
particular, reflected blues and greens from the screen can be 
suppressed.

Enable Colour Correction - enables foreground colour 
correction and all the tools that control this feature.

Saturation - this control will increase or decrease the 
colour saturation of the image, making colours more or less 
intense.

Contrast - the contrast is the ratio of brightest tones to the 
darkest. Increase this value for a contrasty image and 
decrease it to wash it out.

Brightness - the brightness equates to the overall 
luminance of the image. Increase this value to make the 
image lighter and decrease this value to make it darker.

Suppress - this controls colour suppression in the image. 
You can choose to remove a specific primary, either Red, 
Green, Blue or their complements, Cyan, Magenta or Yellow. 
For green screens you may find it helpful to suppress green.

Suppression Balance - determines what to reduce the 
suppressed component to. If set to 0%, it will be the smallest 
of the other two components, if set to 100% it will be the 
largest of the other two components. Otherwise, it will be to 
a balanced average.

Suppression Amount - determines how strongly you want 
to reduce the indicated component.

Balance - these controls are used to alter the colour balance 
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of the image. Choose a hue and saturation  (via the colour 
sampler, the sliders or the colour balance wheel) to shift the 
entire colour balance of the image.

Edge Colour 
Correction

The Edge Colour Correction parameters allow you to colour 
correct edges to seat the composite into the background. To 
see the areas considered an edge that you will be affecting, 
select the Colour Correction Edges from the View menu.

Enable Edge Colour Correction - use this option to 
separately colour correct edges of the image independently 
from the overall colour correction.

Edge Hardness - this determines how strongly to blend 
between the edge correction and the main correction.

Edge Softness - this will soften the region considered to be 
the edge by this amount (in pixels).

Edge Grow - this will grow the region considered to be the 
edge by this amount (in pixels). 

Edge Saturation - these controls determine how much to 
scale the saturation of the image.

Edge Contrast - this control increases/decreases the 
contrast on the region considered to be the edge. 

Edge Brightness - this control brightens the region 
considered to be the edge.

Edge Suppress - Choose to completely remove a specific 
primary, either Red, Yellow, Green, Blue or their components, 
Keylight The Foundry
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Cyan, Magenta, or Yellow. 

Edge Suppression Balance - determines what to reduce 
the suppressed component to. If set to 0, it will be the 
smallest of the other two components, if set to 1 it will be 
the largest of the other two components. Otherwise, it will 
be to a balanced average.

Edge Suppression Amount - determines how strongly you 
want to reduce the indicated component. 

Edge Balance - these controls are used to alter the colour 
balance of the image edges. Choose a hue and saturation  
(via the colour sampler, the sliders or the colour balance 
wheel) to shift the colour balance of the edges.

Source Crops The Source Crops enable you to quickly cut out lighting rigs 
or other unwanted elements using vertical and horizontal 
lines.

Keylight requires access to source pixels that lie off the edge 
of the source image. The cropping controls provide access to 
all the controls required for specifying how pixels are 
treated at these edges and where they appear. The built-in 
crop controls are also useful for removing unwanted black 
pixels at the edge of video footage. 

X  Y Method - determines the behaviour of the image at the 
left and right crop boundaries. Four edge methods are 
supplied:

• Colour - fills the area between the crop line and the edge 
with the Edge Colour. 
The Foundry Keylight
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• Reflect - reflects pixels about the current crop line. In 
other words, it copies pixels from the other side of the 
current crop line into the area between the current crop 
line and the screen edge. 

• Repeat - copies pixels on the crop boundary to the screen 
edge. 

• Wrap - copies pixels from the area between the opposite 
crop line and its screen edge to the area between the 
current crop line and its screen edge. 

Note Horizontal and vertical crop boundaries can have different edge 
methods. Cropping is often used to remove unwanted pixels at the 
edge of an image. If a video clip is digitized badly, you may get 
black edges left and right. These can be easily removed by moving 
the vertical crops and setting the edge method to Reflect. 

Edge Colour - sets the fill colour used when the edge method 
is set to Colour.

Left, Right, Top, Bottom - use these controls to set the crop 
positions. Lines will be overlaid in the display enabling you to 
set the various positions by eye. 

Note The position of the crop lines can be changed by clicking and 
dragging them directly on the screen.

Inside and Outside 
Crops

The crops controls described above also exist for Inside and 
Outside masks.
Keylight The Foundry
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Introduction We have included several tutorials with example images that 
you can use to practice Keylight. 

• Tutorial 1: Simple Key

• Tutorial 2: Fine Tuning a Key

• Tutorial 3: Extreme Blue Spill

• Tutorial 4: A Red Green Screen

Example Images The tutorial images referred to in this chapter can be 
downloaded from our web site http://www.thefoundry.co.uk.

Tutorial 1: Simple 
Key

Using the blue screen clip from The Saint, you will composite 
the actor over the background. You will learn how to:

• Apply Keylight to a clip.

• Pick the Screen Colour.

• View the Final Result.

The clips you will need for this task are called SaintFG.mov 
and SaintBG.mov, pictures courtesy of CFC and Paramount 
British Pictures Ltd. for the film The Saint. You should import 
them into Final Cut Pro and create a new sequence 
The Foundry Keylight
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containing the blue screen of Elizabeth Shue layered over the 
road.

Figure 55 is the blue screen foreground that should be 
composited over the background shown in Figure 56. 

Figure 55. Blue Screen - SaintFG.mov

Figure 56. Background - SaintBG.mov
Keylight The Foundry
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1. Create a new sequence using SaintFG.mov and 
SaintBG.mov, layer the clips with the blue screen over the 
background as shown in Figure 57.

2. Open the blue screen clip (SaintFG.mov) in the Viewer and 
apply Keylight from the Effects > Video Filters > Keylight 
menu. See Figure 58.

Figure 57. Screen Shot showing Saint blue screen.

Figure 58. Apply Keylight from the Effects > Video Filters > 
Keylight menu.
The Foundry Keylight
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3. The Keylight parameters appear on the Filters tab of the 
Viewer. They are shown in Figure 59.

4. To view the Keylight parameters and the foreground clip in 
separate Viewers, right-click on SaintFG.mov in the Browser 
and select Open in New Viewer. This opens the foreground clip 

in a new Viewer, as shown in Figure 60.

5. In the Keylight controls, select the Screen Colour eye 
dropper and click on the blue screen in the new Viewer 

Figure 59. Keylight Parameters.

Figure 60. Opening a new Viewer.
Keylight The Foundry
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window. A good place to pick is the blue from the back 
windscreen as this has no reflections. See Figure 61.

6. That’s it. In many cases this is all you will need to do to 
perform a key, since selecting the screen colour creates a 
matte and despills the foreground. The final composite is 
shown in Figure 62.

There are a couple of extra steps that can be taken to fine 
tune this key and these are discussed in the next tutorial on 
page 56.

Figure 61. Pick the blue from the back windscreen.

Figure 62. Final composite.
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Tutorial 2: Fine 
Tuning a Key

Using the images from the film The Saint, you will learn how 
to fine tune the key pulled in Tutorial 1. You will learn how 
to:

• Use Status to judge the quality of the key.

• Use the Screen Gain to improve the background.

• Use the Despill Bias to remove more blue spill.

1. Create a new composition using SaintFG.mov and 
SaintBG.mov. Apply Keylight. 

2. Open a the SaintFG.mov clip in a new Viewer. Select the 
Screen Colour eye dropper and click on the blue screen in 
the new Viewer.

Note These steps were covered in greater detail in the previous tutorial.

3. Before we do anything else, we need to look at the quality 
of the key so far. On first inspection, the composite looks 
pretty good, but it’s hard to judge. To see any potential 
problems more clearly, switch to the Status view as 
shown in Figure 63. 

Here, we can see that the windscreens are a mixture of 
black and grey pixels. The black pixels tell us that pure 
background will be seen here in the final composite. The 
grey pixels tell us that there will be a mix of foreground 

Figure 63. Status showing grey pixels in the background.
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and background pixels. What we want is a clean back-
ground showing through the windows, but with some 
reflections in the side window preserved. In other words 
we need mostly black pixels with a few grey ones.

4. Figure 64 shows the Status view that we’re aiming for. 
The background has been cleaned up and we still have 
some reflections in the side window. To get this you 
should increase the Screen Gain from 1 to 1.12.

5. Finally, if you look closely at the composite you will see a 
tiny amount of blue spill on the woman’s hand and in her 
hair. This was from reflected light from the blue screen. 
Pick skin tones for the Despill Bias to remove it.

Figure 64. Improved background with Screen Gain.

Figure 65. Final Composite.
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Tutorial 3: Extreme 
Blue Spill

This is a really interesting clip from the film Merlin. The 
results with Keylight are certainly not perfect, indeed it is 
unlikely that you will ever end up with a truly realistic 
looking shot. However, there are some interesting things to 
observe. You will learn how to:

• Reduce the blue spill using Screen Balance and Despill 
Bias.

• Improve the foreground opacity using Alpha Bias.

1. Load the MerlinBlueFG.mov (Figure 66) and Merlin-
BlueBG.mov clips and apply Keylight.

2. Open the MerlinFG.mov clip in a new Viewer and pick the 
Screen Colour using the eye dropper. 

Figure 66. A tricky blue screen.

Figure 67. Serious blue spill.
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Pick a pure blue pixel away from the hair.

3. Increase the Screen Gain from 1 to 1.05. This will clean 
up a little of the background.

4. Alter the Screen Balance from 0.95 to 0 as shown in 
Figure 68. This step is a bit subjective, but improves the 
blue spill.

5. Now let’s try and get rid of that blue spill. Switch off Use 
Alpha Bias for Despill. From the second Viewer, pick skin 
tones for the Despill Bias. When you do this, the image 
and the screen colour will have the blue component scaled 
up before the key is pulled so that more blue is removed.

Figure 68. Adjust the Screen 
Balance

Figure 69. Despill Bias.
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6. Look at the Final Result in the Canvas. You will notice that 
Miranda Richardson’s face still has a number of blue 
highlights that we should fix. The best way to do this is 
using an Inside mask. We have provided one for you, so 
import the Mask.mov clip shown in Figure 70 and drag it 
to the Inside clip well. 

7. To remove the blue highlights on the cheeks (Figure 71), 
make sure the Inside Replace is set to Soft Colour rather 
than Source.

Figure 70. Inside mask.

Figure 71. Replace - Source. Figure 72. Replace - Soft Colour.
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8. View Final Result as shown in Figure 73.

Figure 73. Final Key.
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Tutorial 4: A Red 
Green Screen

Using the images from the film Executive Decision, you will 
learn how to pull a key from a poor green screen using the 
Despill Bias control. You will learn how to:

• Pick the Screen Colour.

• Use Despill Bias and Alpha Bias.

• Produce a final composite. 

The images you will need for this tutorial are called ExecFG.

1. Load the pictures ExecFG.mov (Figure 74) and 
ExecBG.mov. Apply Keylight. 

The foreground image is actually a green screen shot 
although it doesn’t look it. If you analyse the pixels it’s 
slightly more red than green. To key this, we’ll have to 
fool Keylight.

2. Open the ExecFG.mov clip in a new Viewer and pick the 
Screen Colour. You should go for the slightly darker green 
patch to the left of the pilot. Although feel free to 

Figure 74. Poor Green Screen.
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experiment picking different parts of the green screen. 
The initial selection gives the result shown in Figure 75.

3. To fix this, we need to tell Keylight to scale down the red 
component to make the green the most dominant so that 
it keys correctly. To do this, pick colours from the pilot’s 
mask for both the Despill Bias and Alpha Bias. Then, look 
at the Final Result in the Canvas. The result is shown in 
Figure 76.

Figure 75. Default key.

Figure 76. Despill Bias and Alpha Bias.
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4. If you look closely, the background and foreground need 
cleaning up. Figure 77 shows the Status View. 

We will use the Screen Matte tools to make the cockpit 
windows black and the pilot white. 

5. Increase Clip Black to 0.2 to remove some of the 
foreground showing through the background. Decrease 
Clip White to 0.7 to improve the opacity of the 
foreground. Increase Screen Softness to 0.1, Screen 
Despot Black to 0.2 and Screen Despot White to 0.2.

6. Use the Screen Replace to pull some of the original image 
through the composite. This improves the apparent 

Figure 77. Status View.

Figure 78. Composite.
Keylight The Foundry



Tutorial 4: A Red Green Screen

TUTORIAL 65
graininess in the foreground. Figure 79 shows the 
differences.

Figure 79. Close up view. The left image has Screen Replace 
set to Source. The right image has Screen Replace set to 

None.
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Tutorial 4: A Red Green Screen
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Release Notes This appendix describes the requirements, new features, 
improvements over previous versions, fixed bugs and known 
issues and workarounds in Keylight.

Keylight 2.0v3 This is a maintenance release of Keylight on Final Cut Pro.

Requirements

Final Cut Pro 6.0.4 or above on Mac OS X.

New Features

There are no new features in this release.

Improvements

• The plug-in now appears in the Effects > Video Filters > 
Keylight menu with the version number after its name, for 
example Keylight (2.0). This allows you to have several 
different versions of Keylight available on one machine.

• The Help dialog now includes an Enter Serial Number 
button. This opens a web browser and takes you to a 
page where you can activate the plug-in. For more 
information, see “Activating Keylight” on page 6.

• The artwork for splash screens and dialogs has been 
updated.

• The demo license that is automatically installed for this 
beta is valid until October 31st of this year.

• Change to installation. Keylight is now installed to the 
following directories:
The Foundry Keylight
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/Library/Plug-ins/FxPlug/Keylight_2.0_FCP/

/Applications/TheFoundry/Keylight_2.0_FCP/Docs/
Keylight2.0<build version>_FCP.pdf

Fixed Bugs

• BUG ID 7075 - The Foundry plug-ins for Final Cut Pro 
were not designed to work with other applications 
supporting the FxPlug framework, such as Motion. When 
these plug-ins were used in Motion, crashes would result. 
This has been fixed by explicitly preventing the 
inadvertent use of the plug-ins in Motion. The user is 
notified by a splash screen that the plug-in will only 
function in Final Cut Pro.

• BUG ID 7093 - If the Inside Mask's Inside Replace Colour 
was zero, invalid ("inf") rgb values could occur. This is now 
fixed.

• BUG ID 7108 - After applying Keylight, the Intermediate 
Result would contain a binary alpha channel. This would 
make it less useful for using as an additional matte for 
further keying operations. It should have contained a 
continuous alpha channel. This has been fixed.

• BUG ID 8864 - Keylight would cause FCP to crash when 
working with larger projects containing hundreds of 
Keylight instances. FCP would crash when a sequence 
containing numerous Keylight plug-ins was copied and 
pasted, because the computer would run out of memory. 
This has been fixed.

• BUG ID 8902 - The Source Crops horizontal and vertical 
cropping controls were non-functional. This would have 
prevented simple removal of, e.g. wiring from the edges of 
the image. This has been fixed.
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• BUG ID 8903 - The Edge Colour parameter for Inside and 
Outside masks did not change the effect depending on 
the colour. It should. This has been fixed.

Known Bugs and Workarounds

• Final Cut Pro can set video processing to render in RGB, 
8-bit YUV, or high-precision YUV. In the 8-bit YUV and 
high-precision YUV rendering modes, frames that are 
rendered offline (by pressing Cmd+R, or by selecting one 
of the Render options in the Sequence menu) will appear 
slightly smoothed when compared with frames that are 
rendered online (by clicking on a position in the timeline). 
This is not a defect in Keylight, but rather applies to all 
plug-ins in Final Cut Pro.

• BUG ID 8895 - In some contexts, Final Cut Pro does not 
seem to support the use of alpha images which have not 
been premultiplied. We are investigating the issue. As 
such, the Unpremultiply Result option will therefore not 
yield useful images in Final Cut Pro, as Final Cut Pro will 
interpret the resulting images as premultiplied.

• BUG ID 8899 - Use of the Screen Matte operations 
Screen Dilate, Screen Softness, Screen Despot Black, and 
Screen Despot white can introduce faint interlacing 
(fielding) artefacts when the output sequence is fielded. 
The extent of the artefacts are best inspected in the 
Status view.
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Keylight 2.0v2 This is a maintenance release of Keylight on Final Cut Pro.

Requirements
Final Cut Pro 6.0.4 or above on Mac OS X.

New Features
There are no new features in this release.

Improvements
There are no improvements in this release.

Fixed Bugs
Fixed instability in plug-ins caused by OS incompatibility 
with FLEXlm 10.8 licensing module. Upgraded FLEXlm to 
10.8.6 for improved Leopard compatibility.

Known Bugs and Workarounds
There are no known bugs.
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Keylight 2.0v1 This is the first release of Keylight on Final Cut Pro.

Requirements
Final Cut Pro 6.0 on Mac OS X.

New Features
This section will describe new features in later versions.

Improvements
This section will describe improvements to existing features 
in later versions.

Fixed Bugs
This section will describe fixed bugs in later versions.

Known Bugs and Workarounds
There are no known bugs.
The Foundry Keylight
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End User License Agreement

IMPORTANT: BY INSTALLING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ THIS 
AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. IF YOU 
DO NOT AGREE TO THE TERMS OF THIS AGREEMENT DO NOT INSTALL, COPY OR USE THE SOFT-
WARE.

This END USER SOFTWARE LICENSE AGREEMENT (this "Agreement") is made by and between The 
Foundry Visionmongers Ltd., a company registered in England and Wales, ("The Foundry"), and you, 
as either an individual or a single entity ("Licensee"). 

In consideration of the mutual covenants contained herein and for other good and valuable consid-
eration (the receipt and sufficiency of which is acknowledged by each party hereto) the parties agree 
as follows:

SECTION 1. GRANT OF LICENSE. 

Subject to the limitations of Section 2, The Foundry hereby grants to Licensee a limited, non-trans-
ferable and non-exclusive license to install and use a machine readable, object code version of this 
software program (the "Software") and the accompanying user guide and other documentation (col-
lectively, the "Documentation") solely for Licensee's own internal business purposes (collectively, the 
"License"); provided, however, Licensee's right to install and use the Software and the Documenta-
tion is limited to those rights expressly set out in this Agreement.

SECTION 2. RESTRICTIONS ON USE. 

Licensee is authorized to use the Software in machine readable, object code form only, and Licensee 
shall not: (a) assign, sublicense, transfer, pledge, lease, rent, share or export the Software, the Doc-
umentation or Licensee's rights hereunder; (b) alter or circumvent the copy protection mechanisms in 
the Software or reverse engineer, decompile, disassemble or otherwise attempt to discover the 
source code of the Software; (c) modify, adapt, translate or create derivative works based on the 
Software or Documentation; (d) use, or allow the use of, the Software or Documentation on any proj-
ect other than a project produced by Licensee (an "Authorized Project"); (e) allow or permit anyone 
(other than Licensee and Licensee's authorized employees to the extent they are working on an 
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Authorized Project) to use or have access to the Software or Documentation; (f) copy or install the 
Software or Documentation other than as expressly provided for herein; or (g) take any action, or 
fail to take action, that could adversely affect the trademarks, service marks, patents, trade secrets, 
copyrights or other intellectual property rights of The Foundry or any third party with intellectual 
property rights in the Software (each, a "Third Party Licensor"). Furthermore, for purposes of this 
Section 2, the term "Software" shall include any derivatives of the Software. 

Licensee shall install and use only a single copy of the Software on one computer, unless the Soft-
ware is installed in a "floating license" environment, in which case Licensee may install the Software 
on more than one computer; provided, however, Licensee shall not at any one time use more copies 
of the Software than the total number of valid Software licenses purchased by Licensee. 

Furthermore, the Software can be licensed on an "interactive" or "non-interactive" basis. Licensee 
shall be authorized to use a non-interactive version of the Software for rendering purposes only 
(i.e., on a CPU, without a user, in a non-interactive capacity) and shall not use such Software on 
workstations or otherwise in a user-interactive capacity. Licensee shall be authorized to use an 
interactive version of the Software for both interactive and non-interactive rendering purposes, if 
available. 

Finally, if the Software is an "Educational Version," Licensee may use it only for the purpose of train-
ing and instruction, and for no other purpose. Educational Versions of the Software may not be used 
for commercial, professional or for-profit purposes. 

SECTION 3. BACK-UP COPY. 

Notwithstanding Section 2, Licensee may store one copy of the Software and Documentation off-
line and off-site in a secured location owned or leased by Licensee in order to provide a back-up in 
the event of destruction by fire, flood, acts of war, acts of nature, vandalism or other incident. In no 
event may Licensee use the back-up copy of the Software or Documentation to circumvent the usage 
or other limitations set forth in this Agreement.

SECTION 4. OWNERSHIP. 

Licensee acknowledges that the Software and Documentation and all intellectual property rights 
relating thereto are and shall remain the sole property of The Foundry and the Third Party Licensors. 
Licensee shall not remove, or allow the removal of, any copyright or other proprietary rights notice 
included in and on the Software or Documentation or take any other action that could adversely 
affect the property rights of The Foundry or any Third Party Licensor. To the extent that Licensee is 
authorized to make copies of the Software or Documentation under this Agreement, Licensee shall 
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reproduce in and on all such copies any copyright and/or other proprietary rights notices provided in 
and on the materials supplied by The Foundry hereunder. Nothing in this Agreement shall be deemed 
to give Licensee any rights in the trademarks, service marks, patents, trade secrets, copyrights or 
other intellectual property rights of The Foundry or any Third Party Licensor, and Licensee shall be 
strictly prohibited from using the name, trademarks or service marks of The Foundry or any Third 
Party Licensor in Licensee's promotion or publicity without The Foundry's express written approval. 

SECTION 5. LICENSE FEE. 

Licensee understands that the benefits granted to Licensee hereunder are contingent upon 
Licensee's payment in full of the license fee payable in connection herewith (the "License Fee"). 

SECTION 6. TAXES AND DUTIES. 

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or national tax 
(exclusive of taxes based on net income), duty, tariff or other impost related to or arising from the 
transaction contemplated by this Agreement. 

SECTION 7. LIMITED WARRANTY. 

The Foundry warrants that, for a period of ninety (90) days after delivery of the Software: (a) the 
machine readable electronic files constituting the Software and Documentation shall be free from 
errors that may arise from the electronic file transfer from The Foundry and/or its authorized 
reseller to Licensee; and (b) to the best of The Foundry's knowledge, Licensee's use of the Software 
in accordance with the Documentation will not, in and of itself, infringe any third party's copyright, 
patent or other intellectual property rights. Except as warranted, the Software and Documentation 
is being provided "as is." THE FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRAN-
TIES OR CONDITIONS, EXPRESS OR IMPLIED, AND The Foundry DISCLAIMS ANY AND ALL IMPLIED 
WARRANTIES OR CONDITIONS, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF 
TITLE, NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, 
REGARDLESS OF WHETHER The Foundry KNOWS OR HAS REASON TO KNOW OF LICENSEE'S PARTIC-
ULAR NEEDS. The Foundry does not warrant that the Software or Documentation will meet 
Licensee's requirements or that Licensee's use of the Software will be uninterrupted or error free. No 
employee or agent of The Foundry is authorized to modify this limited warranty, nor to make addi-
tional warranties. No action for any breach of the above limited warranty may be commenced more 
than one (1) year after Licensee's initial receipt of the Software. To the extent any implied warran-
The Foundry Keylight



APPENDIX B76
End User License Agreement
ties may not be disclaimed under applicable law, then ANY IMPLIED WARRANTIES ARE LIMITED IN 
DURATION TO NINETY (90) DAYS AFTER DELIVERY OF THE SOFTWARE TO LICENSEE. 

SECTION 8. LIMITED REMEDY. 

The exclusive remedy available to the Licensee in the event of a breach of the foregoing limited war-
ranty, TO THE EXCLUSION OF ALL OTHER REMEDIES, is for Licensee to destroy all copies of the 
Software, send The Foundry a written certification of such destruction and, upon The Foundry's 
receipt of such certification, The Foundry will make a replacement copy of the Software available to 
Licensee. 

SECTION 9. INDEMNIFICATION. 

Licensee agrees to indemnify, hold harmless and defend The Foundry and The Foundry's affiliates, 
officers, directors, shareholders, employees, authorized resellers, agents and other representatives 
(collectively, the "Released Parties") from all claims, defense costs (including, but not limited to, 
attorneys' fees), judgments, settlements and other expenses arising from or connected with the 
operation of Licensee's business or Licensee's possession or use of the Software or Documentation. 

SECTION 10. LIMITED LIABILITY. 

In no event shall the Released Parties' cumulative liability to Licensee or any other party for any loss 
or damages resulting from any claims, demands or actions arising out of or relating to this Agree-
ment (or the Software or Documentation contemplated herein) exceed the License Fee paid to The 
Foundry or its authorized reseller for use of the Software. Furthermore, IN NO EVENT SHALL THE 
RELEASED PARTIES BE LIABLE TO LICENSEE UNDER ANY THEORY FOR ANY INDIRECT, SPECIAL, INCI-
DENTAL, PUNITIVE, EXEMPLARY OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS 
OF BUSINESS OR LOSS OF PROFITS) OR THE COST OF PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES, REGARDLESS OF WHETHER THE RELEASED PARTIES KNOW OR HAVE REASON TO KNOW 
OF THE POSSIBILITY OF SUCH DAMAGES AND REGARDLESS OF WHETHER ANY REMEDY SET FORTH 
HEREIN FAILS OF ITS ESSENTIAL PURPOSE. No action arising out of or related to this Agreement, 
regardless of form, may be brought by Licensee more than one (1) year after Licensee's initial receipt 
of the Software; provided, however, to the extent such one (1) year limit may not be valid under 
applicable law, then such period shall limited to the shortest period allowed by law. 
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SECTION 11. TERM; TERMINATION. 

This Agreement is effective upon Licensee's acceptance of the terms hereof (by clicking on the 
"Accept" button) and Licensee's payment of the License Fee, and the Agreement will remain in effect 
until termination. If Licensee breaches this Agreement, The Foundry may terminate the License 
granted hereunder by notice to Licensee. In the event the License is terminated, Licensee will either 
return to The Foundry all copies of the Software and Documentation in Licensee's possession or, if 
The Foundry directs in writing, destroy all such copies. In the later case, if requested by The 
Foundry, Licensee shall provide The Foundry with a certificate signed by an officer of Licensee con-
firming that the foregoing destruction has been completed. 

SECTION 12. CONFIDENTIALITY. 

Licensee agrees that the Software and Documentation are proprietary and confidential information 
of The Foundry and that all such information and any communications relating thereto (collectively, 
"Confidential Information") are confidential and a fundamental and important trade secret of The 
Foundry. Licensee shall disclose Confidential Information only to Licensee's employees who are 
working on an Authorized Project and have a "need-to-know" such Confidential Information, and 
shall advise any recipients of Confidential Information that it is to be used only as authorized in this 
Agreement. Licensee shall not disclose Confidential Information or otherwise make any Confidential 
Information available to any other of Licensee's employees or to any third parties without the 
express written consent of The Foundry. Licensee agrees to segregate, to the extent it can be rea-
sonably done, the Confidential Information from the confidential information and materials of others 
in order to prevent commingling. Licensee shall take reasonable security measures, which such mea-
sures shall be at least as great as the measures Licensee uses to keep Licensee's own confidential 
information secure (but in any case using no less than a reasonable degree of care), to hold the 
Software, Documentation and any other Confidential Information in strict confidence and safe cus-
tody. The Foundry may request, in which case Licensee agrees to comply with, certain reasonable 
security measures as part of the use of the Software and Documentation. Licensee acknowledges 
that monetary damages may not be a sufficient remedy for unauthorized disclosure of Confidential 
Information, and that The Foundry shall be entitled, without waiving any other rights or remedies, to 
such injunctive or equitable relief as may be deemed proper by a court of competent jurisdiction. 

SECTION 13. INSPECTION. 

Licensee shall advise The Foundry on demand of all locations where the Software or Documentation 
is used or stored. Licensee shall permit The Foundry or its authorized agents to inspect all such 
locations during normal business hours and on reasonable advance notice. 
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SECTION 14. NONSOLICITATION. 

Licensee agrees not to solicit for employment or retention, and not to employ or retain, any of The 
Foundry's current or future employees who were or are involved in the development and/or creation 
of the Software. 

SECTION 15. U.S. GOVERNMENT LICENSE RIGHTS. 

The Software, Documentation and/or data delivered hereunder are subject to the terms of this 
Agreement and in no event shall the U.S. Government acquire greater than RESTRICTED/LIMITED 
RIGHTS. At a minimum, use, duplication or disclosure by the U.S. Government is subject to the appli-
cable restrictions of: (i) FAR §52.227-14 ALTS I, II and III (June 1987); (ii) FAR §52.227-19 (June 
1987); (iii) FAR §12.211 and 12.212; and/or (iv) DFARS §227.7202-1(a) and DFARS §227.7202-3. 

The Software is the subject of the following notices: 

 * Copyright (c) 2009 The Foundry Visionmongers, Ltd.. All Rights Reserved. 

 * Unpublished-rights reserved under the Copyright Laws of the United Kingdom. 

SECTION 16. SURVIVAL. 

Sections 2, 4, 5, 6, 7, 8, 9, 10, 12, 13, 14, 15, 16, 17 and 18 shall survive any termination or expi-
ration of this Agreement. 

SECTION 17. IMPORT/EXPORT CONTROLS. 

To the extent that any Software made available hereunder is subject to restrictions upon export 
and/or reexport from the United States, Licensee agrees to comply with, and not act or fail to act in 
any way that would violate, the applicable international, national, state, regional and local laws and 
regulations, including, without limitation, the United States Foreign Corrupt Practices Act, the 
Export Administration Act and the Export Administration Regulations, as amended or otherwise 
modified from time to time, and neither The Foundry nor Licensee shall be required under this Agree-
ment to act or fail to act in any way which it believes in good faith will violate any such laws or reg-
ulations.
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SECTION 18. MISCELLANEOUS. 

This Agreement is the exclusive agreement between the parties concerning the subject matter 
hereof and supersedes any and all prior oral or written agreements, negotiations, or other dealings 
between the parties concerning such subject. This Agreement may be modified only by a written 
instrument signed by both parties. If any action is brought by either party to this Agreement against 
the other party regarding the subject matter hereof, the prevailing party shall be entitled to recover, 
in addition to any other relief granted, reasonable attorneys' fees and expenses of litigation. Should 
any term of this Agreement be declared void or unenforceable by any court of competent jurisdic-
tion, such declaration shall have no effect on the remaining terms of this Agreement. The failure of 
either party to enforce any rights granted hereunder or to take action against the other party in the 
event of any breach hereunder shall not be deemed a waiver by that party as to subsequent enforce-
ment of rights or subsequent actions in the event of future breaches. This Agreement shall be gov-
erned by, and construed in accordance with English Law. 

Copyright (c) 2009 The Foundry Visionmongers Ltd. All Rights Reserved. Do not duplicate.
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