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INTRODUCTION

Welcome to this User Guide for Furnace on Final Cut Pro.

Furnace is a rich collection of image processing tools to help 
compositors tackle common problems when working on films. 
We have spent many years working closely with post 
production houses in London developing tools that will save 
you time.

About this User 
Guide

This User Guide will tell you how to install, license and use 
the Furnace plug-ins. Each plug-in is described in detail in 
later chapters. 

This guide assumes you are familiar with Final Cut Pro and 
the machine it is running on.

What’s New? Have a look at the new features and improvements in 
Appendix A.

Example Images Example images are provided for use with most of the plug-
ins. You can download these images from our web site http:/
/www.thefoundry.co.uk and try Furnace out on them. (From 
the Furnace product page, click on the Tutorials & Example 
Images link.)
The Foundry Furnace
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Notation
Notation In this User Guide we will refer to machines running Furnace 
and Final Cut Pro as clients and machines that are running 
the Foundry FLEXlm Tools software as servers.

Before Installing 
Furnace

Please note that installing Furnace 4.0 will effectively 
overwrite any previous versions of Furnace 4.0 that have 
been installed to the default Final Cut Pro location. Scripts 
will, however, be compatible between Furnace 4.0 versions, 
and all other Furnace builds with different major and minor 
version numbers will remain intact.

Installing Furnace Furnace is available as a download from our web site http://
www.thefoundry.co.uk. The downloads are in dmg format. 
Furnace should be installed on the client machines.

To install Furnace on a Mac OS X machine running Final Cut 
Pro, follow these instructions:

1. Download the file from our web site (www.thefoundry.co.uk).

2. Double click on the downloaded dmg file.

Furnace_4.0v2_FCP-mac-universal-release-32.dmg

3. Double click on the pkg file that is created.

Furnace_4.0v2_FCP-mac-universal-release-32.pkg

4. Follow the on-screen instructions to install Furnace directly 
into the /Library/Plug-ins/FxPlug directory. 

5. Proceed to “Licensing Furnace” on page 3.

Directory Structure

The following directories are copied during the default 
installation process to the following path. Removing these 
directories will uninstall Furnace.
Furnace The Foundry
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/Library/Plug-ins/FxPlug/Furnace_4.0_FxPlug1.2.1

/Applications/TheFoundry/Furnace_4.0_FxPlug1.2.1

Licensing Furnace Without a license key, the Furnace plug-ins will fail to run.

The license key is a sequence of numbers and letters, stored 
in a plain text file, that unlocks Furnace. License keys can be 
created for a particular computer enabling those plug-ins to 
run only on that computer. These are called node locked 
licenses. We also supply floating licenses that will unlock 
Furnace on any networked computer connected to a machine 
running the Foundry license server.

Tools to install license keys, manage floating licenses and 
diagnose license problems can be downloaded from our web 
site, http://www.thefoundry.co.uk/licensing.

About Furnace 
Plug-ins

All Furnace plug-ins integrate seamlessly into Final Cut Pro. 
They are applied to your clips as you would any other plug-in 
and they can all be animated using the standard animation 
tools.

You can load Furnace plug-ins from Effects > Video Filters > 
Furnace. Their parameters appear on the Filters tab of the 
Viewer.

All Furnace parameters include two important buttons: 

• the Help button. When clicked, this displays instructions 
related to the plug-in. 
The Foundry Furnace
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Other Foundry Products
• The user message button. By default, this is grayed 
out. The button only activates when Furnace has a 
message for the user. When this happens, you should 
click the button to see the message.

Other Foundry 
Products

The Foundry is a leading developer of plug-in visual effects 
for film and video post production. Its products include 
Nuke, Furnace, Tinder, Tinderbox, and Keylight and run on a 
variety of compositing platforms including Flame, Flint, Fire, 
Inferno and Smoke from Discreet, Shake, Avid DS and After 
Effects. For the full list of products and supported platforms 
see our web site http://www.thefoundry.co.uk.

Nuke is an Academy Award® winning compositor. It has 
been used to create extraordinary images on scores of 
feature films including The Dark Knight, The Golden 
Compass, Iron Man, Transformers, King Kong, and Pirates of 
the Caribbean: At World’s End.

Tinder and Tinderbox are collections of image processing 
effects including blurs, distortion effects, background 
generators, colour tools, wipes, matte tools, paint effects, 
lens flares and much more.

Keylight is an award winning blue/green screen keyer giving 
results that look photographed not composited. The Keylight 
algorithm was developed by the Computer Film Company who 
were honoured with a technical achievement award for 
digital compositing from the Academy of Motion Picture Arts 
and Sciences.

Visit The Foundry’s web site at http://www.thefoundry.co.uk 
for further details.
Furnace The Foundry
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DEFLICKER

When working in film you sometimes have to deal with shots 
that have a luminance flicker.

Introduction F_DeFlicker is used to remove flicker that is localised and
dependent on the geometry of the scene, such as that 
caused by an unsynchronised fluorescent light in a shot. It 
works by calculating the gain between the current frame and 
each frame in a small window surrounding it. It then tries to 
adjust the gain so that it varies smoothly over this temporal 
window. This means it is better at reducing fast flicker than 
flicker which varies slowly over the image sequence, as the 
latter will already appear smooth over the window and 
F_DeFlicker will leave it largely untouched.

The algorithm used by F_DeFlicker can introduce blurring in
areas where there is rapid motion. If this happens, using 
local motion estimation to align the frames before 
deflickering them can help. However, this process is 
complicated by the fact that the presence of flicker can 
adversely affect the results of the motion estimation. 
F_DeFlicker therefore adopts a two stage approach to this 
problem. First, the normal deflickering process is performed. 
The motion vectors for the sequence are calculated on the 
resulting deflickered frames, then applied to the original 
frames in order to align them. The deflicker calculation is 
then performed on the aligned frames to give the final result. 
To use this approach, turn on Use Motion in F_DeFlicker.

Note that F_DeFlicker can be a computationally expensive
plug-in that requires input frames from outside the current
The Foundry Furnace
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Quick Start
time, as such, using more than two instances of F_DeFlicker
in an effect stack will dramatically increase render times. It 
is strongly advised therefore, that you render each instance 
out separately.

Quick Start Import a sequence to deflicker. Choose Effects > Video 
Filters > Furnace > F_DeFlicker. Render.

Parameters The parameters for this plug-in are described below. 

Scale Down - use this to scale down the image for 
deflickering. This can speed up the calculation.

Clamp Flicker - use this to reduce flicker without removing it 
entirely; smaller values mean more will be left behind.

Use Motion - turn this on to do a second deflicker pass 
using motion-compensated frames. This can improve results 
in areas where there is fast motion, where the initial 
deflicker pass can introduce blurring.

Vector Detail - determines the accuracy of the motion 
vectors used when Use Motion is turned on. The maximum 
value of 1 will generate one vector per pixel. This will 
produce the most accurate vectors but will take longer to 
render.

Window Size - the size of the temporal window to use to 
remove flicker.
Furnace The Foundry
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Example In this example, we’ll look at removing flicker from a clip 
using F_DeFlicker. The clip used here can be downloaded 
from our web site. For more information, please see 
“Example Images” on page 1.

Step by Step

1. Import ToDeflicker.mov into Final Cut Pro.

2. Render the sequence loaded in the previous step. Notice the 
flickering fluorescent light in the window, which we’re going to 
try to remove.

3. Select Effects > Video Filters > Furnace > F_DeFlicker.

4. Render the output.

5. Compare the original and deflickered sequences by viewing 
them one after the other. Notice that the flickering from the 
light in the window has been substantially reduced.
The Foundry Furnace
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DENOISE

This chapter looks at removing noise or grain from an image
sequence using Furnace’s plug-in F_DeNoise. For hints, tips,
tricks, and feedback please visit http://
support.thefoundry.co.uk.

Introduction F_DeNoise is designed to remove noise or grain from a clip. 
Assuming there is no motion in a sequence, the best way to 
reduce the noise is to take an average across a number of 
frames (temporal averaging). The noise which is different on 
each frame will be reduced and the picture which is the same 
will be reinforced. Temporal averaging is far superior to 
averaging pixels from within the same frame (spatial 
averaging) as it doesn’t soften the image. Unfortunately, if 
there is motion in the sequence, the averaged image will be 
blurred as the image appears at different locations in each 
frame. However, by estimating the motion in the sequence 
using The Foundry’s advanced motion estimation technology, 
it is possible to compensate for any motion and so average 
frames temporally without introducing any blurring 
artefacts.

Quick Start Import and select the footage to be noise reduced. In the 
Canvas, set the zoom level to 100% or higher. Choose 
Effects > Video Filters > Furnace > F_DeNoise. By default, 
the analysis method of F_DeNoise is set to Auto-analysis. 
This means F_DeNoise automatically tries to pick a suitable 
sample region defining an area of noise and uses that region 
when calculating the noise reduction.
The Foundry Furnace
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Parameters
If you’re not happy with the results of Auto-analysis, you 
can set Analysis Method to Sample Region. This way, 
F_DeNoise works by analysing the grain structure in the 
region around the on-screen sample crosshair. Click on the 
crosshair button under Analysis Centre and move the 
crosshair over a plain area of the image in the Canvas. To 
get a good result, it is important that this area is free from 
image detail, so no textures or edges. The output should 
now show the denoised frame. 

If you are still not satisfied with the results, try moving the 
sample crosshair to a different, flat area of a frame. 
F_DeNoise will reanalyse the grain structure every time this 
crosshair is repositioned.

To remove more noise simply increase the Tune parameter. 
You can also remove different amounts of noise from the 
red, green and blue channels by altering the Tune Red, Tune 
Green and Tune Blue parameters.

Parameters The parameters for this plug-in are described below. 

Tune - This adjusts the overall amount of noise or grain that 
is removed. Increase this value to remove more noise.

The Fine Tuning parameters allow you to remove different 
amounts of noise in each of the colour channels.

• Tune Red - increases or decreases the amount of noise 
removed in the red channel.

• Tune Green - increases or decreases the amount of noise 
removed in the green channel.
Furnace The Foundry
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DENOISE 7
• Tune Blue - increases or decreases the amount of noise 
removed in the blue channel.

Analysis Method - Choose how you want to find the flat 
sample area that is used to analyse the grain structure in the 
image.

• Auto-analysis - let F_DeNoise automatically pick a sample 
area from the image.

• Sample Region - manually pick a sample area from the 
image.

Auto-analyse button - If Analysis Method is set to Auto-
analysis but you are not happy with the results of the 
analysis, you can change the frame to analyse on the 
timeline and then click this button to perform a new 
automatic analysis.

Analysis Centre - change the position of the centre of the 
analysis region. Click the button to move the crosshair into a 
new position on the Canvas, or enter new coordinates for 
the centre point in the coordinates fields.

Sample Region - shows what is included in the analysis 
region when you are picking the sample region manually. This 
area should be free of image detail.

Analysis Frame - shows the frame to analyse on. You cannot 
adjust this parameter.

Example The footage used in the following example can be 
downloaded from our web site. For more information, please 
see “Example Images” on page 1.
The Foundry Furnace
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Example
Mike In this example, we’ll use F_DeNoise to remove noise from a 
sequence.

Step by Step

1. Import MikeWire.mov.

2. In the Canvas, set the Zoom pop-up menu to 100% or higher.

3. Select Effects > Video Filters > Furnace > F_DeNoise. 

4. Render out the sequence to see the results.

Figure 1. Original image.
Furnace The Foundry
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5. Compare the original and denoised sequences by viewing them 
one after the other. Notice that the noise has been reduced.

Figure 2. Zoomed original image.

Figure 3. Zoomed output image.
The Foundry Furnace
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DIRTREMOVAL

This chapter looks at the removal of dust and dirt from 
images using Furnace’s plug-in F_DirtRemoval. For hints, 
tips, tricks, and feedback please visit http://
support.thefoundry.co.uk.

Introduction F_DirtRemoval will automatically detect and remove specs of 
dust and dirt from a frame. 

The plug-in works by looking for objects that appear for only 
one frame, after taking account of the motion in the 
sequence. For example:

• A spec of dirt that appears for only one frame will be 
classified as dirt.

• A football being kicked across the image will not be 
classified as dirt because, after taking account of motion, 
it appears in each frame of the sequence.

• A vertical scratch in a sequence will not be classified as 
dirt as it appears in the same place in each frame.

Figure 4. Before. Figure 5. After.
The Foundry Furnace
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Introduction
• Dirt on the camera lens or in the telecine gate will not be 
classified as dirt as it appears in the same place on each 
frame.

Having detected the location of the dirt, the algorithm 
produces a seamless repair by taking motion compensated 
pixels from the surrounding frames and interpolating them 
into the dirt region. In order to see which regions have been 
repaired, you can select Dirt under Output and render the 
result, which shows the pixels detected as dirt.

The main control provided by the plug-in is the set of 
Presets. These control the trade off between falsely 
identifying dirt and failing to spot the dirt. Often, even if a 
region of image has been falsely detected as dirt, it will be 
repaired perfectly as the dirt will not have corrupted the 
motion in the region, allowing a high quality motion 
compensated repair.

In order to understand how to tune the parameters it is first 
necessary to understand a bit more about the algorithms 
involved. F_DirtRemoval relies heavily on motion estimation 
to both detect the dirt and repair the image. Where the 
motion is complex, e.g. multiple objects moving fast in 
multiple directions, we are unable to correctly calculate the 
motion. This means both the dirt detection and repair will 
fail. In order to improve results in these regions we have a 
complex motion detector. This detector is designed to flag 
regions where we are unlikely to calculate the correct 
motion. In these regions, we detune the motion based dirt 
detector and add a spatial dirt detector. Only if both 
detectors flag dirt do we actually believe there to be dirt.
Furnace The Foundry



Quick Start

DIRTREMOVAL 13
Quick Start Import the sequence to be cleaned and select Effects > 
Video Filters > Furnace > F_DirtRemoval. Render and view 
the result. To see where the dirt has been detected and 
removed, set Output to Dirt and render again. 

If you think the results could be better, vary the preset 
applied as required. If regions of motion have been 
incorrectly classified as dirt, choose a lower preset. If dirt 
has been missed, try choosing a higher preset.

Parameters The parameters for this plug-in are described below. 

Presets - this is the main control for the plug-in which 
trades off the amount of dirt detected and repaired verses 
the number of false detections and incorrect repairs. For 
archive footage, you should typically choose Very 
Aggressive, whereas for a modern scan with isolated patches 
of dust you should choose Cautious or Neutral.

Output - as well as the repaired image it is possible to 
output diagnostic images which are useful for tuning the 
parameters.

• Source - the original frame containing dirt.

• Dirt - a black and white image showing where dirt has 
been detected.

• Repair - the repaired output image.

• Repair Dirt In Alpha - the repaired output image with the 
final dirt shown in the alpha channel. Any alpha in the 
source image will be removed.
The Foundry Furnace
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Examples
Examples The images for the following example can be downloaded 
from our web site.

Roller blades This clip of a roller blader suffers from a lot of dust.

Step-by-Step

1. Import Rollerblade.mov. Play it and look at the dirt.

2. Select Effects > Video Filters > Furnace > F_DirtRemoval.

3. Make sure Output is set to Repair and render. Notice how the 

dust has been reduced in the result. 

Figure 6. Roller blader.

Figure 7. Repaired image.
Furnace The Foundry
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4. To see where dirt was detected and removed, set Output to Dirt 

and render again.

Figure 8. The detected dirt.
The Foundry Furnace
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KRONOS

Introduction Kronos is Furnace’s re-timer and is designed to slow down or 
speed up footage. It works by calculating the motion in the 
sequence in order to generate motion vectors. These motion 
vectors describe how each pixel moves from frame to frame. 
With accurate motion vectors it is possible to generate an 
output image at any point in time throughout the sequence 
by interpolating along the direction of the motion.

Kronos contains a number of controls to allow you to trade 
off render time verses accuracy of vectors. The time controls 
can be used to generate arbitrary shaped speed curves.

Quick Start Import the sequence you wish to retime and select Effects > 
Video Filters > Furnace > F_Kronos. By default, the speed 
control will be set to perform a half speed slow down. This is 
achieved by generating a new frame at position 0.25 and 
0.75 between the original frames at 0 and 1. Frames are 

Figure 9. Simple mix of two 
frames to achieve an inbetween 

frame.

Figure 10. Kronos vector 
interpolation of the same two 

frames.
The Foundry Furnace
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Quick Start
created at a quarter and three quarters instead of zero (an 
original frame) and a half so as not to include any original 
frames in the re-timed sequence. This avoids the pulsing 
that would otherwise be seen every other frame on a half 
speed slowdown.

Time Curves To vary the speed, choose Source Frame as the Timing 
method and animate the Frame parameter. Make sure Frame 
is keyframed. Then, select an output frame from the Timeline 
and set Frame to the input frame you want to appear at that 
output position. Repeat this for at least one more output 
position to get a linear time curve. For example, if we wish to 
do a 4 times slow down, move to frame 1 and set Frame to 1, 
then move to frame 19 and set Frame to 5. You can use all 
the normal time curve tools provided by Final Cut Pro to 
create any time curve you might need. If the motion is 
speeded up, motion blur will be seen.

Alternatively, you can switch the Timing pulldown menu to 
Speed and use the Speed control to create an arbitrarily 
changing speed for the sequence.

Tuning Parameters At this point, you can render a re-timed sequence using the 
default parameter settings. Better results may be achieved 
by tuning Kronos using the following parameters.

Adjust Vector Detail to get a higher resolution vector field. 
The larger Vector Detail is, the greater the processing time 
but the more accurate the vectors should be. A value of 1 
will generate a vector at each pixel. A value of 0.5 will 
generate a vector at every other pixel. 
Furnace The Foundry
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Note In some circumstances, you may find that a lower Vector Detail 
may give smoother more natural looking results, even though they 
are less accurate.

Use Smoothness to adjust the smoothness of the vectors 
generated. A high smoothness will miss lots of local detail, 
but is less likely to provide you with the odd spurious vector. 
A low smoothness will concentrate on detail matching, even 
if the resulting field is jagged.

Using Placeholder 
Frames in Slow Downs

When slowing down footage, you may notice that you cannot 
access the entire clip after applying F_Kronos to it. For 
example, if your clip is 50 frames long and you slow it down 
to half a speed, 25 frames of the original clip are left outside 
the accessible frame range. To be able to access the entire 
original clip, you can make the clip longer by adding black 
placeholder frames to it and embedding them and the 
original clip in a sequence before using F_Kronos. Do the 
following:

1. In the Browser, go to the Effects tab.

2. Double-click on Video Generators.

3. Select Slug and drag it to the timeline either before or after 
your footage, depending on where you need the black 
placeholder frames.

4. On the timeline, resize the slug as necessary by dragging its 
edges to a new position. The slug and the clip together should 
cover the frame range you want to use for the retimed 
sequence.

5. In the Browser, go to the project tab.

6. Right-click on an empty spot and select New Sequence.

7. Right-click on the newly created sequence and select Open 
Timeline. A new tab appears on the timeline.
The Foundry Furnace
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Quick Start
8. Drag the earlier sequence that contains the original footage 
and slug on the new timeline tab. 

9. Right-click on this sequence on the timeline and select Open in 
Viewer. 

10. Apply F_Kronos.

Motion Blur without 
Retiming

You can add motion blur without retiming. To do this, set the 
Speed to 1. Then set Shutter Time (the output shutter time) 
to be a value greater than 1 (Figure 14 on page 25). Increase 
Shutter Samples until you don't see multiple images (say 10). 
This will add motion blur along the direction of motion 
without retiming (Figure 17 on page 26). Alternatively, you 
can use the simpler F_MotionBlur plug-in, described on 
page 35.

Frames and Fields For various historical reasons, video frames are usually 
divided into two fields. Each field contains only half of the 
image information, drawn as horizontal scan lines. The first 
field of a frame contains every other scan line. These scan 
lines are displayed first from top to bottom. Immediately 
after, the remaining scan lines are displayed, similarly from 
top to bottom. They make up the second field of the frame. 
When both fields are displayed in rapid sequence, they 
appear to produce a normal, complete frame. This technique 
of dividing frames into fields and then displaying them 
Furnace The Foundry
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immediately after each other is called interlacing. It is 
illustrated in Figure 11.

When a moving object is captured using an interlaced video 
format, the object appears in a slightly different place in 
each field of the same frame. This is because the second 
field is recorded after the first field. For example, let’s 
imagine a clip that shows a ball moving from left to right 
across the screen. Figure 12 shows what two frames from 
this clip might look like and how these frames could be 
represented as two fields. As you can see, the ball moves 
slightly to the right between fields, and the fields appear 
squashed, because they only contain half of the image 
information. You should also notice that because the fields 
are recorded and displayed immediately after each other and 
two fields make up one frame, the ball does not move quite 

Figure 11. Video frames consist of two interlaced fields.
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as far between two fields as it does between two frames.

Kronos is able to retime between frames and between fields. 
This is illustrated in Figure 13.

Figure 12. Two frames (on the left) divided into fields (on 
the right).

Figure 13. Retiming between frames and between fields.

Retiming between frames

Retiming between fields

Retiming between fields
Furnace The Foundry
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By default, the retime operation is applied to frames. 
Because any moving objects will be further apart between 
frames than between fields, this can produce a slightly 
riskier retime. To get better results for the retime, you can 
perform the retime on fields instead of frames. This way, the 
moving objects will be closer to each other, which improves 
the results of the motion estimation. However, because the 
retime is done between fields, and the scan lines that 
produce the image are slightly apart vertically, the results 
are vertically shifted by one pixel. This can introduce vertical 
jitter in the retimed clip. 

You can choose whether to retime between frames or fields 
using the Retime Fields parameter.

Parameters The parameters for this plug-in are described below.

Method - sets the interpolation algorithm.

• Frame - the nearest original frame is displayed.

• Blend - a mix between two frames is used for the in-
between frame. This is quick to render and useful when 
tweaking the timing on the curve before setting the 
method to motion.

• Motion - vector interpolation is used to calculate the in-
between frame.

Timing - sets how to control the new timing of the clip.

• Speed - select this if you wish to describe the retiming in 
terms of overall duration, i.e., double speed will halve the 
duration of the clip or half speed will double the duration 
of the clip.
The Foundry Furnace
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• Source Frame - select this if you wish to describe the 
retiming in terms of "at frame 100 in the output clip I 
want to see frame 50 of the source clip". You’ll need to 
set at least 2 keyframes for this to retime the clip.

Speed - this parameter is only active if Timing is set to 
Speed. Values below 1 slow down the clip. Values above 1 
speed up movement. For example, to slow down the clip by a 
factor of two (half speed) set this value to 0.5. Quarter 
speed would be 0.25.

Frame - this parameter is active only if Timing is set to 
Source Frame. Use this to specify the source frame at the 
current frame in the timeline. For example, to slow down a 
50 frame clip by half set the Frame to 1 at frame 1 and the 
Frame to 25 at frame 50. The default expression will result 
in a half-speed retime.

Vector Detail - Adjust this to vary the resolution of the 
vector field. The larger vector detail is, the greater the 
processing time, but the more detailed the vectors should be. 
A value of 1.0 will generate a vector at each pixel. A value of 
0.5 will generate a vector at every other pixel. For some 
sequences, a high vector detail near 1.0 generates too much 
unwanted local motion detail; often a low value is more 
appropriate.

Smoothness - Vector fields usually have two important 
qualities: they should accurately match similar pixels in one 
image to another and they should be smooth rather than 
noisy. Often, it is necessary to trade one of these qualities 
off against the other. A high smoothness will miss lots of 
local detail, but is less likely to provide you with the odd 
spurious vector. A low smoothness will concentrate on detail 
matching, even if the resulting field is jagged. The default 
Furnace The Foundry
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value of 0.5 should work well for most sequences.

Warp Mode - sets how to control the new timing of the clip.

• Simple - this is the quickest option, but may produce less 
than optimal results around moving objects and image 
edges.

• Normal - this is the standard option, with more optimal 
treatment of moving objects and image edges.

• Occlusions - this is an advanced option that can improve 
the results when not doing a separated picture build with 
multiple vector layers and mattes. It attempts to reduce 
the level of background dragging that occurs between 
foreground and background objects.

Shutter Time – sets the equivalent shutter time of the re-
timed sequence. A shutter time of 1 is equivalent to 
averaging over plus and minus half an input frame which is 
equivalent to a shutter angle of 360 degrees. A shutter time 
of 0.5 is equivalent to a shutter angle of 180 degrees. 
Imagine a grey rectangle moving left to right horizontally 
across the screen. Figure 14 and Figure 15 show how 
Shutter Time affects the retimed rectangle. 

 

Figure 14. Shutter Time 1 Figure 15. Shutter Time 0.5
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Shutter Samples – sets the number of in-between images 
used to create an output image during the shutter time. 
Increase this value for smoother motion blur.

Auto ShutterTime - automatically varies the Shutter Time 
throughout the sequence.

Retime Fields - sets whether the retime operation is 
performed between frames or fields.

• From Frame to Frame - retimes between complete frames. 
This can produce a slightly riskier retime, but the results 
will be on the correct scan line.

• From Field to Field - retimes between the fields that are 
used to make up frames. This produces a better retime, 
but the results are shifted vertically by one pixel, which 
may introduce vertical jitter in the retimed clip.

Examples All the images for the following example can be downloaded 
from our web site.

Figure 16. Shutter Samples 2 Figure 17. Shutter Samples 20
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Taxi This example, Figure 18 on page 27, shows a taxi driving 
past our offices in Soho. We’ll retime this sequence to speed 
up the taxi at the start and slow down at the end.

Step by Step

1. Start Final Cut Pro and import Taxi.mov.

2. Render the taxi clip to get a sense of the motion.

3. Select Effects > Video Filters > Furnace > F_Kronos.

4. By default, the clip will be slowed down to half speed. However, 
we wish to have a fast start and slow end. So, set Timing to 
Source Frame. At frame 1, set a Frame key to be 1, and at 
frame 50 set a Frame key to 25. Now to get that fast start, try 
setting the Frame key to be 12 at frame 15. Use the keyframe 
graph area to modify the animation graph.

5. To get a sense of the motion you can set Method to Blend, 
render and adjust your timing curve from there.

Figure 18. London taxi.
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6. When you’re happy, set Method to Motion. With Vector Detail 
set to 0.2, you may see part of the road under the taxi being 
dragged by the taxi. To improve this, increase this value to 1.
Furnace The Foundry
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MATCHGRADE

This chapter looks at automatic colour matching using 
Furnace’s plug-in F_MatchGrade. For hints, tips, tricks, and 
feedback please visit http://support.thefoundry.co.uk.

Introduction It is often necessary to match the colours of one clip with 
those of another. When filming outside at different times of 
the day you will inevitably get colour and luminance 
differences that will have to be corrected if the sequences 
are to be composited or edited together.

You can, of course, use colour correction tools and trial and
error to try and match the clips. But this tends to be time 
consuming and requires some considerable skill. 
F_MatchGrade does it all for you by automatically modifying 
the colour histogram of an image to match a target image.

This plug-in can also be used to add colour to black and 
white images.

Figure 19. Source image Figure 20. Target image
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Quick Start Import the clips you want to use as the source and target 
clips. The source clip is the sequence to which the colour 
transform will be applied. The target clip is the sequence you 
want the source clip to match. Select the source clip and 
choose Effects > Video Filters > Furnace > F_MatchGrade. 
Drag the target clip to the clip well of the Target parameter. 
View the output which should now match the look of the 
target clip. Try increasing Iterations if the match isn’t close 
enough.

By default, F_MatchGrade calculates the transform needed to 
match the source image frame to the target image frame, 
and applies this transform to every frame of the source 
sequence. This way, the transformation is temporally 
uniform. However, if you want the colour transfer to update 
according to the current frame of the source and target 
clips, you can set the Source Colour From and Target Colour 
From parameters to Current Frame.

Parameters The parameters for this plug-in are described below. 

Figure 21. Output image
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Target - drag the target clip (the clip whose colours you 
want the source clip to match) here.

Iterations - the number of refinement passes. More 
iterations should produce a better match but will take 
longer. This is an integer parameter, so animating it will not 
produce a smooth grade change but one with obvious steps. 
To achieve a smooth grade change, mix the output from 
F_MatchGrade with the original input sequence and animate 
the mix amount.

Source Colour From - sets how the source clip is used to 
calculate the colour transformation.

• Specified Frame - the colour transformation is calculated 
using a single frame from the source clip. You can specify 
this frame using the Source Frame parameter below.

• Current Frame - the colour transformation is calculated 
so that it updates according to the frames in the source 
clip.

Source Frame - sets the source clip frame that is used to 
calculate the colour transformation.

Target Colour From - sets how the target clip is used to 
calculate the colour transformation.

• Specified Frame - the colour transformation is calculated 
using a single frame from the target clip. You can specify 
this frame using the Target Frame parameter below.

• Current Frame- the colour transformation is calculated so 
that it updates according to the frames in the target clip.

Target Frame - sets the target clip frame that is used to 
calculate the colour transformation.
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Mike In this example, we will use F_MatchGrade to match the look
of two images, MikeWalking and MikeLightWand. The images 
used here can be downloaded from our website. For more 
information, please see “Example Images” on page 1.

Step by Step

1. Import MikeWalking.tif and MikeLightWand.tif - our goal is to 
make the image with the light stick lighter and more like the 
other. They are shown in Figure 22 and Figure 23.

2. Select the light stick image and choose Effects > Video Filters 
> Furnace > F_MatchGrade.

Figure 22. Source image Figure 23. Target image
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3. Drag the walking image into the clip well of the Target 
parameter. You should get the result in Figure 24.

4. The result is slightly garish, so decrease the Iterations 
parameter to 3, the result of which is shown in Figure 25.

Figure 24. Output image

Figure 25. Output image
The Foundry Furnace
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MOTIONBLUR

This chapter looks at adding motion blur using Furnace’s 
plug-in F_MotionBlur. For hints, tips, tricks, and feedback
please visit http://support.thefoundry.co.uk.

Introduction F_MotionBlur uses the Foundry’s advanced motion 
estimation technology to add realistic motion blur to a 
sequence. F_MotionBlur uses the same techniques and 
technology as the motion blur found in F_Kronos, but 
presents the controls in a less complex, more user friendly 
way. However, if you need precise control over the motion 
vectors used for adding blur, or a large temporal range (i.e. a 
very high shutter time), you should use F_Kronos.

Quick Start Import a clip and select Effects > Video Filters > Furnace > 
F_MotionBlur. Select a suitable Shutter Time, depending on 
the amount of blur you wish to add. Process the sequence to 
see the motion blurred result. Increasing Shutter Samples 
will result in more in-between images being used to generate 
the motion blur and a smoother blur. If you can see that the 
motion blur has been created from a few discreet images, try 
increasing Shutter Samples.

If your sequence is composed of a foreground object moving
over a background, the motion estimation is likely to get 
confused at the edge between the two.
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Frames and Fields For various historical reasons, video frames are usually 
divided into two fields. Each field contains only half of the 
image information, drawn as horizontal scan lines. The first 
field of a frame contains every other scan line. These scan 
lines are displayed first from top to bottom. Immediately 
after, the remaining scan lines are displayed, similarly from 
top to bottom. They make up the second field of the frame. 
When both fields are displayed in rapid sequence, they 
appear to produce a normal, complete frame. This technique 
of dividing frames into fields and then displaying them 
immediately after each other is called interlacing. It is 
illustrated in Figure 26.

When a moving object is captured using an interlaced video 
format, the object appears in a slightly different place in 
each field of the same frame. This is because the second 

Figure 26. Video frames consist of two interlaced fields.
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field is recorded after the first field. For example, let’s 
imagine a clip that shows a ball moving from left to right 
across the screen. Figure 27 shows what two frames from 
this clip might look like and how these frames could be 
represented as two fields. As you can see, the ball moves 
slightly to the right between fields, and the fields appear 
squashed, because they only contain half of the image 
information. You should also notice that because the fields 
are recorded and displayed immediately after each other and 
two fields make up one frame, the ball does not move as far 
between two fields as it does between two frames.

MotionBlur is able to retime between frames and between 

Figure 27. Two frames (on the left) divided into fields (on 
the right).
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fields. This is illustrated in Figure 28. 

By default, the retime operation is applied to frames. 
Because any moving objects will be further apart between 
frames than between fields, this can produce a slightly 
riskier retime. To get better results for the retime, you can 
perform the retime on fields instead of frames. This way, the 
moving objects will be closer to each other, which improves 
the results of the motion estimation. However, because the 
retime is done between fields, and the scan lines that 
produce the image are slightly apart vertically, the results 
are vertically shifted by one pixel. This can introduce vertical 
jitter in the retimed clip. 

You can choose whether to retime between frames or fields 
using the Retime Fields parameter.

Parameters The parameters for this plug-in are described below. 

Figure 28. Retiming between frames and between fields.

Retiming between frames

Retiming between fields

Retiming between fields
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Shutter Time - sets the equivalent shutter time of the 
retimed sequence. A shutter time of 1 is equivalent to 
averaging over plus and minus half an input frame which is 
equivalent to a shutter angle of 360 degrees. A shutter time 
of 0.5 is equivalent to a shutter angle of 180 degrees. 
Imagine a grey rectangle moving left to right horizontally 
across the screen. Figure 29 and Figure 30 show how 
Shutter Time affects the retimed rectangle.

Shutter Samples - sets the number of in-between images 
used to create an output image during the shutter time. 
Increase this value for smoother motion blur.

Vector Detail - the amount of detail used for the motion 

Figure 29. shutterTime 1 Figure 30. shutterTime 0.5

Figure 31. shutterSamples 2 Figure 32. shutterSamples 20
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estimation. The maximum value of 1 will produce the most 
accurate motion vectors, but will take longer to render.

Retime Fields - sets whether the retime operation is 
performed between frames or fields.

• From Frame to Frame - retimes between complete frames. 
This can produce a slightly riskier retime, but the results 
will be on the correct scan line.

• From Field to Field - retimes between the fields that are 
used to make up frames. This produces a better retime, 
but the results are shifted vertically by one pixel, which 
may introduce vertical jitter in the retimed clip.

Example All the images for the following example can be downloaded
from our web site. For more information, please see 
“Example Images” on page 1.

BelleWalking In this example, we’ll use F_MotionBlur to add motion blur to 
the sequence.

Step by Step

1. Start Final Cut Pro and import the BelleWalking.mov clip.

2. Render the clip to get a sense of the motion. Go to frame 16 on 
the time line (this merely gives a better example than the initial 
frames).

3. Select Effects > Video Filters > Furnace > F_MotionBlur.
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4. Set Shutter Time to 10, and Shutter Samples to 10. You should 
get an image as in Figure 33.

5. We can see the individual samples still, for example at the back 
of the dress and the right-hand foot. Increase Shutter Samples 
to 20 to sample more frames, and you should get a result as in 
Figure 34.

Figure 33. Output image

Figure 34. Output image
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Introduction Furnace’s ReGrain plug-in is used to add grain to a sequence. 
It has been designed to sample grain from one image and 
then to generate unlimited amounts of this grain with 
exactly the same statistics as the original. This new grain 
can then be applied to another image.

Figure 35 shows an enlarged and exaggerated sample of 
grain from Kodak 320 film stock. Furnace’s ReGrain was 
used to sample the original Kodak 320 stock and synthesize 
a plate of grain. The result is shown in Figure 36. Note that 
the grain characteristics closely match the original.

Similarly, Figure 37 on page 44 is a sample from Kodak 500 
film stock and Figure 38 on page 44 shows this replicated 

Figure 35. Kodak 320. Figure 36. ReGrain.
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using Furnace’s ReGrain.

Quick Start Import the clip to which you want to add grain and select 
Effects > Video Filters > Furnace > F_ReGrain. There are a 
variety of presampled grain types to choose from. Try the 
different grain types using the Stock Type pulldown menu.

If you don’t want to use one of the presampled grain types, 
you can also sample grain from a clip. To do so, set Stock 
Type to Sample Grain. Import a clip you want to sample and 
drag it into the clip well of the Grain parameter. Check View 
Grain Clip to display this clip in the Canvas. Click on the 
button under Analysis Centre and move the selection area 
over a plain area of the image in the Canvas. Your selection 
is important to get right. You should avoid any image detail 
or even a plain area that has luminance variations 
underneath the grain. The better this initial selection the 
better the result will be. See Figure 39. If you can’t find a 
decent sample area on the frame, then try other frames from 

Figure 37. Kodak 500. Figure 38. ReGrain.
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the same film stock.

Note The red selection box on the Canvas is not an overlay but actual 
pixels on the image displayed. If you render the grain clip, the 
selection box will be included in the output.

Once you have positioned the sample area, view the output 
of the F_ReGrain node to judge the results. The output will 
now contain the source image with grain from the sample 
image applied. Both the size and the luminance of the new 
grain can be manually tweaked using Grain Scale and Grain 
Gain respectively. 

The grain is sampled on a single frame which you set using 
the timeline. Although the grain is sampled on only one 
frame, the algorithmically created grain will change from 
frame to frame but mirror the characteristics of the sample 

Figure 39. This shows two possible selection regions that 
contain no edge detail and little luminance variation.
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grain.

There is a minimum size of the sample clip below which the 
statistical analysis of the grain will be unreliable. The 
minimum size is about 128x128.

Grain Stock To add grain from a standard film stock, select from the 
Stock Type list. 2K, 4K, aperture corrected and non aperture
corrected stocks are included. Individual colour channels can
be selected and adjusted using the Gain and Scale 
parameters.

Response In its default setting, F_ReGrain adds the same amount of 
grain over the whole image. However, the amount of grain on 
an image is normally a function of luminance. You can adjust 
how the amount of grain added varies with luminance. The 
Low Gain, Mid Gain and High Gain parameters allow you to 
adjust the amount of grain added to the lowlights, midtones 
and highlights of the image.

Checking the Result To test that the new grain is the same as the old grain you 
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can select Show - Grain Plate.

This generates a sheet of grain with the same luminance 
level as the mean of the sample region. The sample region 
with the original grain is also displayed. It should be 
impossible to differentiate between the two regions. 
Figure 40 shows a good selection area giving a good test 
plate of grain in Figure 41. Figure 42 shows a poor selection 
area since it contains image detail. Figure 43 shows the 
resulting test plate, which clearly highlights the problem.

Figure 40. Good selection area... Figure 41. ...producing a good 
test plate of grain, free of 

artifacts.

Figure 42. Bad selection area... Figure 43. ...producing a poor 
result.
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Parameters The parameters for this plug-in are described below.

Grain - drag a clip you want to sample grain from into the 
clip well here. For this to work, Stock Type needs to be set to 
Sample Grain.

Stock Type - selects whether the grain is sampled from the 
grain image (Sample Grain) or from a set of standard stocks. 
2K, 4K, aperture corrected and non aperture corrected 
stocks are supplied.

• Sample Grain - samples and reconstructs the grain 
characteristics from the Grain image.

• <Stock><Exposure><Size> - grain characteristics 
sampled from a supplied film stock. Common Fuji and 
Kodak stocks are supplied. The exposure can be under, 
over or, if left blank, non aperture corrected. The size is 
either 2K or 4K pixels. For example, FUJIF500 2K refers 
to the grain characteristics sampled from a 2K plate of 
Fuji Film 500 film stock non aperture corrected.

Show - sets whether to render the result or a test image.

• Result - shows the image with the grain applied.

• Grain Plate - shows a test image with the grain applied. 
This test image is composed from a section of the input 
image surrounded by a uniform solid colour sampled from 
the image with the grain applied (Figure 43). If the inner 
area is indistinguishable from the outer area, then you 
have a good grain sample (Figure 41). 

Grain Scale - adjusts the size of the grain granules.

Grain Gain - adjusts the brightness of the grain.

Red Gain - sets the brightness of the grain in the red 
Furnace The Foundry



Parameters

REGRAIN 49
channel.

Green Gain - sets the brightness of the grain in the green 
channel.

Blue Gain - sets the brightness of the grain in the blue 
channel.

Red Scale - adjusts the size of the grain granules in the red 
channel.

Green Scale - adjusts the size of the grain granules in the 
green channel.

Blue Scale - adjusts the size of the grain granules in the blue 
channel.

Low Gain - adjusts the gain of the grain in the lowlights.

Mid Gain - adjusts the gain of the grain in the midtones.

High Gain - adjusts the gain of the grain in the highlights.

View Grain Clip - check this to view the clip in the image well 
of the Grain parameter.

Analysis Center - change the position of the centre of the 
sample region. Click the button to move the selection area 
into a new position on the Canvas, or enter new coordinates 
for the centre point in the coordinates fields.

Sample Size - change the size of the sample area.

Analysis Frame - shows the frame to sample the grain from. 
You cannot adjust this parameter.
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Example The image used in the following example can be downloaded
from our website. For more information, please see “Example 
Images” on page 1.

Rachael In this example, we will degrain the image using F_DeNoise 
and then, using F_ReGrain, sample the grain from the original 
image and reapply it to the degrained image. Switching 
between the resulting outputs of F_DeNoise and F_ReGrain 
will show different grain but with the same characteristics.

Apply F_DeNoise to Rachael.tif. Set Analysis Method to 
Sample Region and position the sample region over a plain 
area.

Now load F_ReGrain using the processed output of 
F_DeNoise as the clip to add grain to and the original 
unprocessed image as the Grain sample clip. Make sure you 
have set Stock Type to Sample Grain. Compare the original to 
the regrained output of F_ReGrain. Note that although the 
actual grain differs on both images, the grain characteristics 
are the same.
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Release Notes This section describes the requirements, new features, 
improvements, fixed bugs and known bugs & workarounds 
for each release of Furnace.

Furnace 4.0v2 This is a maintenance release of Furnace for Final Cut Pro.

Release Date

November 2008

Requirements

1. Final Cut Pro 6.0.4 or above on Mac OS X.

2. Foundry FLEXlm Tools (FFT 4.0v1 or later) for floating licenses.

New Features

There are no new features in this release.

Improvements

There are no improvements in this release.

Bug Fixes

Fixed instability in plug-ins caused by OS incompatibility 
with FLEXlm 10.8 licensing module. Upgraded FLEXlm to 
10.8.6 for improved Leopard compatibility.

Known Bugs and Workarounds

There are no known bugs.
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Furnace 4.0v1 This is the first release of Furnace for Final Cut Pro. 

Release Date

September 2008

Requirements

1. Final Cut Pro 6.0 on Mac OS X.

2. Foundry FLEXlm Tools (FFT 4.0v1 or later) for floating licenses.

New Features

There are seven plug-ins in this release.

Improvements

This section will describe improvements to existing features 
in later versions.

Bug Fixes

This section will describe fixed bugs in later versions.

Known Bugs and Workarounds

There are no known bugs.
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End User License Agreement

IMPORTANT: BY INSTALLING THIS SOFTWARE YOU ACKNOWLEDGE THAT YOU HAVE READ 
THIS AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND 
CONDITIONS. IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT DO NOT 
INSTALL, COPY OR USE THE SOFTWARE.

This END USER SOFTWARE LICENSE AGREEMENT (this "Agreement") is made by and 
between The Foundry Visionmongers Ltd., a company registered in England and Wales, 
("The Foundry"), and you, as either an individual or a single entity ("Licensee"). 

In consideration of the mutual covenants contained herein and for other good and valuable 
consideration (the receipt and sufficiency of which is acknowledged by each party hereto) 
the parties agree as follows:

Section 1. Grant of License.

Subject to the limitations of Section 2, The Foundry hereby grants to Licensee a limited, 
non-transferable and non-exclusive license to install and use a machine readable, object 
code version of this software program (the "Software") and the accompanying user guide 
and other documentation (collectively, the "Documentation") solely for Licensee's own 
internal business purposes (collectively, the "License"); provided, however, Licensee's right 
to install and use the Software and the Documentation is limited to those rights expressly 
set out in this Agreement.
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Section 2. Restrictions on Use. 

Licensee is authorized to use the Software in machine readable, object code form only, and 
Licensee shall not: (a) assign, sublicense, transfer, pledge, lease, rent, share or export the 
Software, the Documentation or Licensee's rights hereunder; (b) alter or circumvent the 
copy protection mechanisms in the Software or reverse engineer, decompile, disassemble or 
otherwise attempt to discover the source code of the Software; (c) modify, adapt, translate 
or create derivative works based on the Software or Documentation; (d) use, or allow the 
use of, the Software or Documentation on any project other than a project produced by 
Licensee (an "Authorized Project"); (e) allow or permit anyone (other than Licensee and 
Licensee's authorized employees to the extent they are working on an Authorized Project) 
to use or have access to the Software or Documentation; (f) copy or install the Software or 
Documentation other than as expressly provided for herein; or (g) take any action, or fail to 
take action, that could adversely affect the trademarks, service marks, patents, trade 
secrets, copyrights or other intellectual property rights of The Foundry or any third party 
with intellectual property rights in the Software (each, a "Third Party Licensor"). 
Furthermore, for purposes of this Section 2, the term "Software" shall include any 
derivatives of the Software. 

Licensee shall install and use only a single copy of the Software on one computer, unless 
the Software is installed in a "floating license" environment, in which case Licensee may 
install the Software on more than one computer; provided, however, Licensee shall not at 
any one time use more copies of the Software than the total number of valid Software 
licenses purchased by Licensee. 

Furthermore, the Software can be licensed on an "interactive" or "non-interactive" basis. 
Licensee shall be authorized to use a non-interactive version of the Software for rendering 
purposes only (i.e., on a CPU, without a user, in a non-interactive capacity) and shall not 
use such Software on workstations or otherwise in a user-interactive capacity. Licensee 
shall be authorized to use an interactive version of the Software for both interactive and 
non-interactive rendering purposes, if available. 

Finally, if the Software is an "Educational Version," Licensee may use it only for the purpose 
of training and instruction, and for no other purpose. Educational Versions of the Software 
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may not be used for commercial, professional or for-profit purposes. 

Section 3. Back-Up Copy. 

Notwithstanding Section 2, Licensee may store one copy of the Software and 
Documentation off-line and off-site in a secured location owned or leased by Licensee in 
order to provide a back-up in the event of destruction by fire, flood, acts of war, acts of 
nature, vandalism or other incident. In no event may Licensee use the back-up copy of the 
Software or Documentation to circumvent the usage or other limitations set forth in this 
Agreement.

Section 4. Ownership. 

Licensee acknowledges that the Software and Documentation and all intellectual property 
rights relating thereto are and shall remain the sole property of The Foundry and the Third 
Party Licensors. Licensee shall not remove, or allow the removal of, any copyright or other 
proprietary rights notice included in and on the Software or Documentation or take any 
other action that could adversely affect the property rights of The Foundry or any Third 
Party Licensor. To the extent that Licensee is authorized to make copies of the Software or 
Documentation under this Agreement, Licensee shall reproduce in and on all such copies 
any copyright and/or other proprietary rights notices provided in and on the materials 
supplied by The Foundry hereunder. Nothing in this Agreement shall be deemed to give 
Licensee any rights in the trademarks, service marks, patents, trade secrets, copyrights or 
other intellectual property rights of The Foundry or any Third Party Licensor, and Licensee 
shall be strictly prohibited from using the name, trademarks or service marks of The 
Foundry or any Third Party Licensor in Licensee's promotion or publicity without The 
Foundry's express written approval. 
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Section 5. License Fee. 

Licensee understands that the benefits granted to Licensee hereunder are contingent upon 
Licensee's payment in full of the license fee payable in connection herewith (the "License 
Fee"). 

Section 6. Taxes and Duties. 

Licensee agrees to pay, and indemnify The Foundry from claims for, any local, state or 
national tax (exclusive of taxes based on net income), duty, tariff or other impost related to 
or arising from the transaction contemplated by this Agreement. 

Section 7. Limited Warranty. 

The Foundry warrants that, for a period of ninety (90) days after delivery of the Software: 
(a) the machine readable electronic files constituting the Software and Documentation shall 
be free from errors that may arise from the electronic file transfer from The Foundry and/or 
its authorized reseller to Licensee; and (b) to the best of The Foundry's knowledge, 
Licensee's use of the Software in accordance with the Documentation will not, in and of 
itself, infringe any third party's copyright, patent or other intellectual property rights. 
Except as warranted, the Software and Documentation is being provided "as is." THE 
FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS, 
EXPRESS OR IMPLIED, AND The Foundry DISCLAIMS ANY AND ALL IMPLIED WARRANTIES 
OR CONDITIONS, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF TITLE, 
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, 
REGARDLESS OF WHETHER The Foundry KNOWS OR HAS REASON TO KNOW OF LICENSEE'S 
PARTICULAR NEEDS. The Foundry does not warrant that the Software or Documentation 
will meet Licensee's requirements or that Licensee's use of the Software will be 
uninterrupted or error free. No employee or agent of The Foundry is authorized to modify 
this limited warranty, nor to make additional warranties. No action for any breach of the 
above limited warranty may be commenced more than one (1) year after Licensee's initial 
receipt of the Software. To the extent any implied warranties may not be disclaimed under 
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applicable law, then ANY IMPLIED WARRANTIES ARE LIMITED IN DURATION TO NINETY 
(90) DAYS AFTER DELIVERY OF THE SOFTWARE TO LICENSEE. 

Section 8. Limited Remedy. 

The exclusive remedy available to the Licensee in the event of a breach of the foregoing 
limited warranty, TO THE EXCLUSION OF ALL OTHER REMEDIES, is for Licensee to destroy 
all copies of the Software, send The Foundry a written certification of such destruction 
and, upon The Foundry's receipt of such certification, The Foundry will make a replacement 
copy of the Software available to Licensee. 

Section 9. Indemnification. 

Licensee agrees to indemnify, hold harmless and defend The Foundry and The Foundry's 
affiliates, officers, directors, shareholders, employees, authorized resellers, agents and 
other representatives (collectively, the "Released Parties") from all claims, defense costs 
(including, but not limited to, attorneys' fees), judgments, settlements and other expenses 
arising from or connected with the operation of Licensee's business or Licensee's 
possession or use of the Software or Documentation. 

Section 10. Limited Liability. 

In no event shall the Released Parties' cumulative liability to Licensee or any other party for 
any loss or damages resulting from any claims, demands or actions arising out of or 
relating to this Agreement (or the Software or Documentation contemplated herein) exceed 
the License Fee paid to The Foundry or its authorized reseller for use of the Software. 
Furthermore, IN NO EVENT SHALL THE RELEASED PARTIES BE LIABLE TO LICENSEE UNDER 
ANY THEORY FOR ANY INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY OR 
CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS OR LOSS OF 
PROFITS) OR THE COST OF PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES, 
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REGARDLESS OF WHETHER THE RELEASED PARTIES KNOW OR HAVE REASON TO KNOW OF 
THE POSSIBILITY OF SUCH DAMAGES AND REGARDLESS OF WHETHER ANY REMEDY SET 
FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE. No action arising out of or related to 
this Agreement, regardless of form, may be brought by Licensee more than one (1) year 
after Licensee's initial receipt of the Software; provided, however, to the extent such one 
(1) year limit may not be valid under applicable law, then such period shall limited to the 
shortest period allowed by law. 

Section 11. Term; Termination. 

This Agreement is effective upon Licensee's acceptance of the terms hereof (by clicking on 
the "Accept" button) and Licensee's payment of the License Fee, and the Agreement will 
remain in effect until termination. If Licensee breaches this Agreement, The Foundry may 
terminate the License granted hereunder by notice to Licensee. In the event the License is 
terminated, Licensee will either return to The Foundry all copies of the Software and 
Documentation in Licensee's possession or, if The Foundry directs in writing, destroy all 
such copies. In the later case, if requested by The Foundry, Licensee shall provide The 
Foundry with a certificate signed by an officer of Licensee confirming that the foregoing 
destruction has been completed. 

Section 12. Confidentiality. 

Licensee agrees that the Software and Documentation are proprietary and confidential 
information of The Foundry and that all such information and any communications relating 
thereto (collectively, "Confidential Information") are confidential and a fundamental and 
important trade secret of The Foundry. Licensee shall disclose Confidential Information only 
to Licensee's employees who are working on an Authorized Project and have a "need-to-
know" such Confidential Information, and shall advise any recipients of Confidential 
Information that it is to be used only as authorized in this Agreement. Licensee shall not 
disclose Confidential Information or otherwise make any Confidential Information available 
to any other of Licensee's employees or to any third parties without the express written 
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consent of The Foundry. Licensee agrees to segregate, to the extent it can be reasonably 
done, the Confidential Information from the confidential information and materials of 
others in order to prevent commingling. Licensee shall take reasonable security measures, 
which such measures shall be at least as great as the measures Licensee uses to keep 
Licensee's own confidential information secure (but in any case using no less than a 
reasonable degree of care), to hold the Software, Documentation and any other 
Confidential Information in strict confidence and safe custody. The Foundry may request, in 
which case Licensee agrees to comply with, certain reasonable security measures as part of 
the use of the Software and Documentation. Licensee acknowledges that monetary 
damages may not be a sufficient remedy for unauthorized disclosure of Confidential 
Information, and that The Foundry shall be entitled, without waiving any other rights or 
remedies, to such injunctive or equitable relief as may be deemed proper by a court of 
competent jurisdiction. 

Section 13. Inspection. 

Licensee shall advise The Foundry on demand of all locations where the Software or 
Documentation is used or stored. Licensee shall permit The Foundry or its authorized 
agents to inspect all such locations during normal business hours and on reasonable 
advance notice. 

Section 14. Nonsolicitation. 

Licensee agrees not to solicit for employment or retention, and not to employ or retain, any 
of The Foundry's current or future employees who were or are involved in the development 
and/or creation of the Software. 

Section 15. U.S. Government License Rights. 

The Software, Documentation and/or data delivered hereunder are subject to the terms of 
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this Agreement and in no event shall the U.S. Government acquire greater than 
RESTRICTED/LIMITED RIGHTS. At a minimum, use, duplication or disclosure by the U.S. 
Government is subject to the applicable restrictions of: (i) FAR §52.227-14 ALTS I, II and III 
(June 1987); (ii) FAR §52.227-19 (June 1987); (iii) FAR §12.211 and 12.212; and/or (iv) 
DFARS §227.7202-1(a) and DFARS §227.7202-3. 

The Software is the subject of the following notices: 

 * Copyright (c) 2007 The Foundry Visionmongers, Ltd.. All Rights Reserved. 

 * Unpublished-rights reserved under the Copyright Laws of the United Kingdom. 

Section 16. Survival. 

Sections 2, 4, 5, 6, 7, 8, 9, 10, 12, 13, 14, 15, 16, 17 and 18 shall survive any termination 
or expiration of this Agreement. 

Section 17. Import/Export Controls. 

To the extent that any Software made available hereunder is subject to restrictions upon 
export and/or reexport from the United States, Licensee agrees to comply with, and not act 
or fail to act in any way that would violate, the applicable international, national, state, 
regional and local laws and regulations, including, without limitation, the United States 
Foreign Corrupt Practices Act, the Export Administration Act and the Export Administration 
Regulations, as amended or otherwise modified from time to time, and neither The Foundry 
nor Licensee shall be required under this Agreement to act or fail to act in any way which it 
believes in good faith will violate any such laws or regulations.
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SECTION 18. MISCELLANEOUS. 

This Agreement is the exclusive agreement between the parties concerning the subject 
matter hereof and supersedes any and all prior oral or written agreements, negotiations, or 
other dealings between the parties concerning such subject. This Agreement may be 
modified only by a written instrument signed by both parties. If any action is brought by 
either party to this Agreement against the other party regarding the subject matter hereof, 
the prevailing party shall be entitled to recover, in addition to any other relief granted, 
reasonable attorneys' fees and expenses of litigation. Should any term of this Agreement 
be declared void or unenforceable by any court of competent jurisdiction, such declaration 
shall have no effect on the remaining terms of this Agreement. The failure of either party to 
enforce any rights granted hereunder or to take action against the other party in the event 
of any breach hereunder shall not be deemed a waiver by that party as to subsequent 
enforcement of rights or subsequent actions in the event of future breaches. This 
Agreement shall be governed by, and construed in accordance with English Law. 

Copyright (c) 2008 The Foundry Visionmongers Ltd. All Rights Reserved. Do not duplicate.
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